看雪技术论坛

www.pediy.com

致力于加密与解密研究 版权所有© 2000-2005 看雪学院


关于看雪学院

` 关于看雪学院 看雪学院
  • 看雪学院发展历史

        首先祝贺看雪学院成立5周年！5年前的今天，在无意中建立了看雪学院。为什么取看雪这个名称？由于当时申请QICQ（当然现在称为QQ了）时取昵称时，外面正在下雪，故随意取了个名字"看雪"，主页名称来源就这样的。

    那时国内的加解密资料极其缺乏，各处转载的主要是台湾的一些早期教学，如Error Free、yhq、HEIBOW等。遇到点问题，找人交流都很困难。于是就有个想法，建立一个主页，收集整理与加解密相关的资料。因为定位十分准确，主页一开张就获得成功，得到大家认可。

    当时网上有一些站点对加密领域发展功不可没。如TiANWEi，完整翻译的SoftICE指令手册并在主页公布；吴朝相的EXE世界，让我们对壳有了一个认识等等站点。看雪学院初期主要工作是整理网上一些零星资料、翻译相关的英文资料，再加上自己与网友们的学习心得整理成一套系统教学，即主页提供的Crack Tutorial。现在大家对这份教学可能不屑一顾，在那个时代它可是最棒的解密教学！后来，一份杂志没经过我们允许下，擅自将这份教学去头截尾，做了本专辑《黑客防线4》发表了。当时，大家都十分气愤，写信谴责也没结果。这件事后，就有自己出书的计划，并得到网友们的大力支持！大家分工合作，花了有一年时间，推出了《加密与解密--软件保护技术及完全解决方案》，这是自Windows 95 面世以来的6年内，市面上第一本全面介绍Windows平台下软件加密与解密技术的书籍。看雪也成了第一个吃螃蟹的人了，这本书过后，国内的加解密相关书籍，如雨后春笋般的出现了，当然质量都参差不齐，里面相当多的书籍还是直接抄袭了Crack Tutorial等主页提供的教学。

    论坛也是在那个时候发展起来的，在当时，是国内惟一一个讨论加解密技术的论坛，论坛学习气氛十分好，我相信许多过来人，都十分怀念那个时期的。最初用的拓创论坛系统，树形结构。先是在天极网呆了有一年左右，后来由于其改版，论坛搬到了鹰潭信息港提供的拓创论坛系统，呆了有半年有余。最后，搬到了001提供的拓创论坛系统，呆的时间最长。如果不是DDOS攻击的话，现在可能还会在那。

    看雪论坛是一个以技术讨论为主的论坛，主要研究加解密、逆向工程等技术，但我们只是讨论技术，并不将这些技术应用于商业目的，不违反现今法律的。我们公开讨论这些技术，可以让研究加解密、软件作者、开发人员从这里了解国内外的加解密技术发展动向，并能从中吸取营养。其实看雪论坛现在己成为了密界与外界的一个沟通窗口了。看雪技术论坛作为国内知名的加解密技术论坛，吸引了密界众多高手，大家以知识共享的精神，无私地将自己所知的技术奉献出来了，至今为止原创了数千余篇文章，极大地推动了国内加解密技术发展。

        加密与解密技术在相辅相成中不断发展，既没有无坚不摧的矛，也不会有坚不可摧的盾。一个不熟悉敌手的战士不会有太多的胜利机会，不熟悉解密技术的软件开发者，也很难开发出更加先进的保护技术。希望读者看过本精华集后，能够对当今流行的各种软件保护技术及破解技术有所了解，避免在软件保护上犯一些常识性的错误。

    为了赶上晚上发布这份《看雪学院五周年珍藏版》，不多聊了。论坛发展5年来，汇聚了许多兴趣相投的朋友，欢迎你也加入我们行列中来。

    看雪学院大事记：

    2000.1    　    看雪学院建站
    2001.9 《加密与解密--软件保护技术及完全解决方案》出版
    2002.9 《加密与解密--软件保护技术及完全解决方案》繁体版出版
    2003.6 《加密与解密》（第二版）出版
    2003.9 《程序员》 第2003.9期主持的技术专题—加密解密
    2004.6 《加密与解密（第二版）》繁体版出版
    2004.8 《软件加密技术内幕》出版

    kanxue

    二〇〇五年一月十二日 于京口
  • 联系我们

    • 　　看雪学院: http://www.pediy.com

    ©2000-2005 PE diy.com All rights reserved.
    By KanXue Studio


关于本精华手册

` 关于本手册 看雪学院
  • 制作说明
    1. 本论坛精华手册收集了看雪技术论坛 2000.1 - 2005.1 期间的精华内容，共3336余篇原创文章。
    2. 本手册中的所有内容，个人用户可以免费的收藏、参考，但是谢绝任何商业网站及传统媒体（如出版物）摘编转载！！！
    3. 未经看雪学院的授权许可，任何人不得擅自进行篡改、反编译，及将其全部或部分用于商业用途或把本精华手册收录到出版物内。
    4. 本精华手册内收录的帖子及图片的相关版权归各版权所有人所有。
    5. 欢迎在保持论坛精华手册的完整下散发该教学包。
    6. 本精华手册所有文章仅为学习研究软件内含的设计思想和原理。    任何人皆不可将其用于非法之目的，否则一切后果自负。
    7. 特别感谢看雪技术论坛各位版主在论坛辛勤的工作及所有网友对论坛的支持，没有你们的帮助，论坛是无法得到发展及壮大的，也感谢所有将自己的经验无私奉献的朋友们。
    8. 其他各类事宜，所有解释权归看雪学院及其论坛或相关的论坛注册用户所有。

    • ©2000-2005 PE diy.com All rights reserved.


加密与解密

` 书之专题 看雪学院
  • 书之专题 (汇集国内顶尖看雪技术论坛众多密界一流好手，展示软件调试最核心！)

    • 简体版 | 繁体版 | 《加密与解密--软件保护技术及完全解决方案》 Windows 95面世以来的6年内，市面上第一本全面介绍Windows平台下软件加密与解密技术的书籍。 （注：本书己停止印刷，读者只需要直接参考《加密与解密》（第二版）） 出版日期 >>> 2001年9月 电子工业出版社出版 获奖荣誉 >>> 获2004年全国优秀畅销书奖、2004年输出版优秀图书奖
简体版 | 繁体版 | 《加密与解密（第二版）》 本书全面揭示Windows平台的加密与解密技术！采用循序渐进方式，从基本的跟踪调试到深层的拆解脱壳，从浅显的注册码分析到加密算法及商用软件保护，这520页的一部书，几乎囊括了Windows软件保护的绝大多数内容。不论是解密爱好者还是软件编程者都应该好好去看看。 出版日期 >>> 2003年6月 电子工业出版社出版 网上定购 >>> 华储网、互动出版网、第二书店 页 数 >>> 520页 （含光盘一张）
 |  | 《软件加密技术内幕》 由看雪技术论坛数位好手共同打造，历时两年，是国内第一本专业探讨软件保护技术的书籍！ 本书首度公开如何编写加壳工具、各种加密技巧的实现等极具商业价值的保护技术！ 出版日期 >>> 2004年8月 电子工业出版社出版 网上定购 >>> 华储网定、第二书店、互动出版网 页 数 >>> 403页 （含光盘一张）
    ©2000-2005 PE diy.com All rights reserved.


论坛发帖必读

` 论坛规则 看雪学院
  • 论坛发帖必读

    本论坛是一个纯技术论坛，我们的目标是让来这里的每一个人，成为计算机高手！我们欢迎你从技术角度阐述问题，不要在本论申请破解或找注册码，也不欢迎你来此散发注册机程序。不是嬉戏灌水的地方！！
    在您发帖之前，请先做以下事情：
    1、如是您第一次发帖，请看     提问的智慧 和 论坛常见问题 ——这会提高你的帖字的回复率。
    2、先在本站提供资料里找答案，如本站论坛精华全集——或许就可以把问题解决，不必苦苦等待了。
    3、用     Google (http://www.google.com/)搜索引擎找找答案——通过他，你会得到许多意想不到的收获。

    其它事项：如果是研究笔记，但不要提供注册机，否则要删贴的。还有严禁抄袭他人作品，如果是转帖，请注明。

    我们欢迎这样的帖子：

    当你遇到问题，并难以解答时，把遇到的详细情况写出来，我们大家集体解答。
    当你小有成绩，并对自己的成果深有感触时，把你的心情写出来，我们大家一起分享快乐
    当你完成一篇学习笔记（特别是第一篇）时，请你公布出来，我们大家共同进步
    当你已经成为大虾，回顾菜鸟时代，酸甜苦辣，请你写一写，鼓舞一下还不能展翅翱翔的菜鸟的士气。
    其中好的帖子我们还会列入精品。

    我们不欢迎这样的帖子：

    一上来就问**请帮我看看**？**外挂的注册码是多少?这种人好*懒*，只会享用他人果实。
    一上来就问怎么盗password，怎么盗QQ,怎么用Trojan。这种人品德不好，说严重点是道*败*。
    一上来就用攻击他人的言语，这里严禁漫骂！！严禁相互攻击！！
    这类帖子的命运将是——删。


看雪论坛常见问题

` 看雪论坛常见问题 看雪学院
  • 常见问题-----2005.1.

      本论坛是一个纯技术论坛，我们欢迎你从技术角度阐述问题，不要在本论申请破解或找注册码，也不欢迎你来此散发破解补丁或注册机程序。
    一般提问前：

    1、提问前先用Google(http://www.google.com/)搜索引擎找找答案
    2、谨慎选择相关主题的论坛
    3、使用含义丰富，描述准确的标题
    4、别要求私下答复
    5、问题解决后，加个简短说明

    --------------------------------------------------------------------------------

    论坛精华集

    Q:如何调整本精华集字体的大小？
    A:本论坛精华集是使用用CSS（层叠样式表）来控制字符大小的，大小是9 points，通过IE的改变“文字大小”是没效果的。如果你想调整字体大小，可以试试下面的方法：　 启动IE，单击“工具→Internet选项”，出现“Internet选项”对话框，在“常规”标签中单击右下方的“辅助功能”按钮，在出现的“辅助功能”对话框中把“不使用网页中指定的字体大小”选项选上，按“确定”退出就可以了！现在，你再试试 点击本精华集CHM上面的字体按钮 或“查看→文字大小”命令，字体的大小又可以随意控制了。

    --------------------------------------------------------------------------------

    工具

    Q：从哪儿得到 IDA, SoftIce, Wdasm 等工具?
    A:本站的资源栏目列出了相关工具站点,还有本站首页链接站点转转，一般你也能发现这些工具。

    Q:哪种调试工具支持USB键盘与鼠标？
    A:目前只有DriverStudio V2.6以上版本内置的SoftICE支持。因此如你想用TRW2000调试工具请再接一个串口或PS/2接口的鼠标。

    Q:哪种Softice支持WindowsXP？
    A:只有DriverStudio V2.7以上版本支持。

    Q:哪个版本的SoftIce能运行在WinME系统？
    A:SoftIce 4.05以上版本就可，然后再安装Winice Loader工具就可，安装说明。

    Q:哪个版本的W32Dasm支持中文字串？
    A:W32Dasm最高版本是8.93（己停止开发），其不串式参考不支持中文字符，但后来有人在这个版本基础上，推出了几个修改版本，都支持中文字串。

    Q:我的Windows 2000用SoftICE 4.05老有问题
    A:强烈建议Windows 2000用户不要用SoftICE 4.05，因为或多或少会出现许多不能解释的问题，建议直接用更新更强大的DriverStudio系列。

    --------------------------------------------------------------------------------

    一般技术问题
    Q:ZIP和RAR之类密码（Word、execel等都属于这一类）能否用SOFTICE或TRW动态跟踪破解？
    A:不能，WinZip和WinRAR是通过与CRC结合的方式进行加密，它们在解压的时候会不管3721先把带上用户输入的密码的CRC放进解压流程中，先解出来再说，最后才进行原始的CRC判定，如果最后得到的CRC与原来的不一样，那就是解压失败。因为CRC是不可逆推的，所以也没办法得到原始的密码，同时也因为把对比的过程放在了最后，所以才没办法用SoftICE等工具进行破解，只能穷举（目前来说）。（感谢老罗详细的解释）

    Q:为什么在WinNT/2000/XP系统，bpx hmemcpy断点无效？
    A:hmemcpy是16 bits windows里的一个函数,全名Huge MEMory CoPY，俗称万能断点，但在一般的编程书籍上很少提到，原因它是底层的东西，没有特殊需要，一般不直接调用。它的操作很简单，只是将内存中的一块数据拷贝到另一个地方，Win9x系统里很频繁地调用它处理数据。在Win NT/2K系统上相关的函数是memcpy，但在Win NT/2K上不同于Windows 9x上，很少再调用memcpy来处理数据了，用此函数设断基本上什么也拦不住。

    Q:为何同一函数有几种形式，如MessageBoxA(W)？
    A:MessageBoxA(W)是MessageBoxA，MessageBoxW两种形式缩写，Windows函数是区分字符集的：A表示ANSI，W表示Wide，即Unicode (Wide character-set)，前者就是通常使用的单字节方式，而后者是双字节方式，方便处理双字节字符。Win98基本是使用ANSI字符串来进行内部操作的，但它仍可处理少数Unicode字串符函数，如MessageBoxW、MessageBoxExW等。而Win2000/XP所有核心函数都是Unicode字串符。

    Q:为什么SoftICE或TRW再运行一些软件时会中断跳出？
    A:用命令FAULTS off关闭错误跟踪功能。

    Q:F11与F12区别?
    A:F11对应的命令是：G@ss:sp，假如你目前正中断在程序中，下这个指令会在堆栈的返回地址设个暂时断点并执行到此断点。
    F12对应的命令是：P RET 。SoftICE或TRW将一直单步执行直到它找到一条返回语句(RET、RETF)，也就是说让SoftICE一直执行代码，直到出现 RET (XXXX) 命令，再跳出来拦截，这时，当前 IP(EIP) 会是停在 RET (XXXX) 后的某一条语句上，通常是在某一个CALL XXXXXXXX 后面。
    说明：F11功能键在SoftICE中有效，在TRW中可以用pmodule命令代替F11或F12，可瞬间回到到前程序领空。

    Q:SoftICE与TRW2000的断点有什么不同？
    A:在这里以G命令来解释，如对G 401000命令，大家都知道是执行到401000停下，但SoftICE认为是到当前段的401000停下（也就是说在当前应用程序领空），而TRW200却不管段址如何，只要EIP是401000便停下。 这样一般跟踪一软件只要G 401000便解决。这个功能看起来简单，却极为有用。有了这条命令，只要把当前跟踪到的EIP记下，下一次一G便到。而在SoftICE下，一般先用其Symbol Loader装载程序，先来到当前应用程序的领空，然后再G 401000才能到达指定地址处。其它断点命令，如bpx原理与此类似。

    Q:Icedump装不成功
    A:首先要确定IceDump版本要与SOFTICE的一至，如相同还不成功则把winice.dat中：
    ;EXP=c:windowssystemkernel32.dll
    ;EXP=c:windowssystemuser32.dll
    2句前的‘；’去掉重起即可。
    在Windows NT/2000/XP系统上类似的工具是NticeDump，具体安装参考此文。

    Q:有一汇编指令：cmp dword [ebp-10],byte +01, 请问dword在这里的作用是什么呢？在这里dword [ebp-10]和[ebp-10]有什么不一样吗？ 请问byte +01是一种怎么样的寻址呢？
    A:在16位指令中，缺省的类型是字Word，在32位指令中，缺省的类型是双字Dword。byte +01表示方法是TRW2000中特有的，就是数字1，一个字节长。

    Q:请问ASCII扩展字符（即ASCII值在080-0ff）如何输入?
    A:输入时按住Alt键，然后输入ASCII的十进制码（001~255）。

    Q:某一软件，用FI看到有 Win GUI *CRYPTED* 的字样
    A:Win GUI只是指Windows图形应用程序，有*CRYPTED* 的字样，是FI认为该软件己加密，但不能识别出加密的类型。

    Q:trw怎么抓图？
    A:下命令ver keep，然后按Print Screen即将图抓取到剪帖板内，剩下的事就是找下图像处理软件粘贴上去即可。

    Q:如何抓取SOFTICE中的汇编代码？
    A:第一步运行SOFTICE的symbol loader快捷方式，打开菜单的“SoftICE initialisation settings”选项。将历史缓冲区（history buffer）调大些（默认为256,不能放足够多的缓冲数据）。然后切换到SOFTICE调试画面下，来到你要抓取的地方，反汇编这些代码，如：U CS:EIP L 1000 ，立即按CTRL+D返回到windows环境，再次来到symbol loader程序，选择File/Save SoftICE History As ... 。
    或在SOFTICE基础下，装载icedump,用命令 ScreenDump更加方便灵活。

    Q:如何抓取TRW2000中的汇编代码？
    A:在TRW2000下：u 401000,402000 >myfile或 u 401000 L 100 >myfile

    Q:Delphi、C++ Builder编译的软件用getwindowtext等断点拦不住？
    A:这是因为Delphi通过向Edit发送WM_GETTEXT（直接调用WNDProc，而没有使用消息函数）消息来获得Text的内容的，整个过程没有调用过任何Win32 API函数。所以常用的Hmemcpy、GetDlgItemTextA、GetWindowTextA等断点失效是当然的。
    那么如何才能将用户输入的字符串拷贝到软件的缓冲区中时使SoftICE中断呢？办法有多种，例如用DeDe反编译得到该事件的地址，对此地址设断拦截。

    Q:今后采用密码学方面的软件会越来越多,对于一个CRACKER是否有必要因此学习大量的数论知识?
    A:首先我们要明确，加密算法在软件保护中的作用是什么？
    加密算法在软件保护中的作用，是防写注册机。而对其他pj方式防护能力较差。
    加密算法，在很多情况下是可知的，网络安全中，可以通过阅读通信协议，来了解算法；而软件中，算法往往嵌入在程序代码中。所以基于算法保密上的安全永远是不可靠的。于是人们通过密钥 来解决这个问题。目前所有流行的算法的安全性，都是基于密钥的保密。
    而对于软件来说，对称密钥算法，没有什么意义。因为密钥必须嵌入软件中。所以公开密钥（不对称密钥）算法，成为软件加密的理想选择。

    对于一个普通的CRACKER包括普通的程序员，是没有必要学习大量的数论知识。因为现在现成算法函数接口很多，随便拿来用就可以，不必自己去一行一行的去写代码，只要搞清算法的加密流程就可以了。一个普通的CRACKER只要跟某段代码时，能够感觉到他大概是什么算法，然后用算法验证软件（我常用cryptool)，检查一下，就可以了;而且pj软件的方法很多，比如做补丁，并不是写注册机这一种方法。理论上，软件可以在机器上正常运行所有功能一次，就是可以pj的。

    当然，对于想往更高层次发展的Cracker学一些数论知识是必要的，当然我们不太可能发现某的算法的弱点，但至少可以在，某个高人，发现算法的弱点，并公开时，能看懂人家是如何实现的（这需要涉及很多理论性的东西，会涉及数论的），并能写成代码。
    (zmworm 回答）

    Q:REPZ MOVSD是什么意思?
    A: REPZ：→相同的指令有REPE
    当ZF=0，退出重复，否则(CX或ECX)←(CX或ECX)-1,并执行其后的串指令,如MOVSD
    MOVSD：→同类指令MOVSB字节传送,MOVSW字传送
    以双字为单位的串操作指令，由源字符串向目标字符串移动数据
    REPZ MOVSD这条指令是在做数据传送，源字符串DS:SI 目标字符串ES:DI
    ( aboil回答)

    Q:DriverStudio3.0Beta2系统启动时蓝屏.我的系统为Windows2000 Professional + SP4．
    A:得打个补丁：http://www.pediy.com/tools/Debuggers/DS-SP4-patch/numega.htm

    Q:RSA 算法中的MOD运算疑问？
    A:mod是求余运算符。
    如果x与y的积除以z所得的余数为1，即xy = 1 (mod z)，则称x和y对于模数z来说互为逆元，这种互为逆元的关系用符号表示为：
    x = y的-1次方 (mod z)
    x的-1次方 = y (mod z)
    其中，-1次方只是个逆元的表示记号而已，是仿照以前的“倒数”的表示法，并非真的就是-1次方。
    17 * 593 mod (37-1)(41-1) = 1
    17 * 593 mod 1440 = 1
    求逆元用扩展欧基里德算法，初等数论书都有讲。
    ( blowfish 回答）

    Q: _lopen("\\\\.\\NTICE",...) 这一句代码,“\\.\NTICE”是驱动模块吗？“\\.”在这里是什么意思？
    A: \\.\表示本地计算机，\\servername\表示远程计算机。
    NTICE是softice的驱动程序向Win32应用程序所显露出来的设备的符号名称。每个驱动会创建/管理一个或者多个虚拟的或者物理的设备，每个设备有个设备名，但这个设备名只能在驱动之间引用。需要显露给Win32应用程序的设备除了设备名之外，还要有一个符号名，便于Win32应用程序通过CreateFile/_lopen来引用。在驱动里面是用IoCreateSymbolicLink( )来显露设备符号名的。
    ( blowfish 回答）

    Q:bmsg与bpmsg有什么不同？
    A：bmsg与bpmsg皆为中断消息用的,不同之处是bpmsg可预设条件.设法见说明书.
    硬件中断为利用CPU自身的标志寄存器设断.软件中断是软件模拟硬件产生中断.
    I/O中断与硬件中断是完全不同的两个概念.I/O中断用于系统与端口通讯时.一般在硬狗时用

    Q：CDQ是什么指令？
    A：CDQ是符号扩展指令
    D是dword(4字节），Q是qword（8字节）
    CDQ把EAX寄存器中的数视为有符号的数，将其符号位（即EAX的最高位）扩展到EDX寄存器，即若EAX的最高位是1，则执行后EDX的每个位都是1，结果EDX = FFFFFFFF；若EAX的最高位是0，则执行后EDX的每个位都是0，结果EDX = 00000000。这样就把EAX中的32位带符号的数变成了EDX:EAX中的64位带符号的数，以满足64位运算指令的需要，但转换后的值没变。
    ( blowfish 回答）

    Q:我使用XP SP1或2000SP3，安装了DriverStudio或DriverSuite 2.7 ，我设置的断点不起作用。我该怎么办？
    A: 首先，下载下面链接的OSINFO.DAT文件，替换系统目录原有的。
    ftp://ftp.compuware.com/pub/driverstudio/outgoing/OsInfo/OSINFO.DAT
    如果问题是由于安装HOTFIX后出现的，这样操作可以减少HOTFIX的影响。
    步骤如下：
    1. 建立正确的针对NTOSKRNL的NMS文件，参照 "Translating system files" 中的内容（略）
    2. 在Winice.dat中加入独立的一行内容：NTSYMBOLS=ON
    3. 将开始时，就将Symbols加入到symbol列表中
    这样就能解决你的问题了。

    Q:softice如何在Windows 退出 ？
    A:不能退出SOFTICE，他钩住了大量的内核函数！
    内核调试器可以实现不关闭计算机停止调试器。
    嚣张事情是SOFTICE根本没有为退出调试器做任何处理。。也就是说。他们的调试器不打算被大家所退出！
    ( kkkkk 回答）

    Q:W32Dasm中的“Ord:0109h”是什么？
    A:是Hint,本函数在其所驻留DLL的导出表中的索引号
    ( firstrose 回答）


提问的智慧

` 提问的智慧 看雪学院
  • 提问的智慧

    How To Ask Questions The Smart Way
    提问的智慧

    Copyright (C) 2001 by Eric S. Raymond
    中文版Copyleft 2001 by D.H.Grand(nOBODY/Ginux)

    英文版：http://www.tuxedo.org/~esr/faqs/smart-questions.html
    感谢Eric的耐心指点和同意，本文才得以完成并发布，本指南
    英文版版权为Eric Steven Raymond所有，
    中文版版权由D.H.Grand[nOBODY/Ginux]所有。

    目录

    简介
    提问之前
    怎样提问
    谨慎选择论坛
    尽量使用邮件列表
    用辞贴切，语法正确，拼写无误
    用易读格式发送问题
    使用含义丰富，描述准确的标题
    精确描述，信息量大
    话不在多
    只说症状，不说猜想
    按时间顺序列出症状
    别要求私下答复
    明白你想问什么
    别问应该自己解决的问题
    去除无意义的疑问
    谦逊绝没有害处，而且常帮大忙
    问题解决后，加个简短说明
    如何理解答案
    RTFM和STFW：别烦我啦
    还是不懂
    面对无礼
    决不要象个失败者
    三思而后问
    好问题，坏问题
    找不到答案怎么办

    ====
    简介
    ====

    在黑客世界里，当提出一个技术问题时，你能得到怎样的回答？这取决于挖出
    答案的难度，同样取决于你提问的方法。本指南旨在帮助你提高发问技巧，以
    获取你最想要的答案。

    首先你必须明白，黑客们只偏爱艰巨的任务，或者能激发他们思维的好问题。
    如若不然，我们还来干吗？如果你有值得我们反复咀嚼玩味的好问题，我们自
    会对你感激不尽。好问题是激励，是厚礼，可以提高我们的理解力，而且通常
    会暴露我们以前从没意识到或者思考过的问题。对黑客而
    言，“问得好！”是发自内心的大力称赞。

    尽管黑客们有蔑视简单问题和不友善的坏名声，有时看起来似乎我们对新手，
    对知识贫乏者怀有敌意，但其实不是那样的。

    我们不想掩饰对这样一些人的蔑视--他们不愿思考，或者在发问前不去完成他
    们应该做的事。这种人只会谋杀时间--他们只愿索取，从不付出，无端消耗我
    们的时间，而我们本可以把时间用在更有趣的问题或者更值得回答的人身上。
    我们称这样的人为“失败者”（由于历史原因，我们有时
    把它拼作“lusers”）。

    我们也知道，很多人只想使用我们编写的软件，对技术细节没什么兴趣。对多
    数人们而言，计算机不过是一个工具，一种达到目的的手段；他们有更重要的
    事情要做，有更重要的生活要过。我们明白这点，也并不奢望每个人都对另我
    们痴狂的技术问题有兴致。然而，我们回答问题的风格是
    针对这样一群人--他们有兴趣，并且愿意积极参与问题的解决。这点不会改变，
    也不应该改变；如果变了，我们将失去我们引以为傲的效率。

    我们在很大程度上属于志愿者，从繁忙的生活中抽出时间来解惑答疑，而且时常
    被提问淹没。所以我们无情的滤掉一些话题，特别是抛弃那些看起来象失败者的
    家伙，以便更高效的利用时间来回答胜利者的问题。

    如果你觉得我们过于傲慢的态度让你不爽，让你委屈，不妨设身处地想想。我
    们并没有要求你向我们屈服--事实上，我们中的大多数人最喜欢公平交易不过
    了，只要你付出小小努力来满足最起码的要求，我们就会欢迎你加入到我们的
    文化中来。但让我们帮助那些不愿意帮助自己的人是没有
    意义的。如果你不能接受这种“歧视”，我们建议你花点钱找家商业公司签个
    技术支持协议得了，别向黑客乞求帮助。

    如果你决定向我们求助，当然不希望被视为失败者，更不愿成为失败者中的一
    员。立刻得到有效答案的最好方法，就是象胜利者那样提问--聪明、自信、有
    解决问题的思路，只是偶尔在特定的问题上需要获得一点帮助。

    （欢迎对本指南提出改进意见。任何建议请E-mail至esr@thyrsus.com，然而
    请注意，本文并非网络礼节的通用指南，我通常会拒绝无助于在技术论坛得到
    有用答案的建议。）
    （当然，如果你写中文，最好还是寄到DHGrand@hotmail.com;-）

    ========
    提问之前
    ========

    在通过电邮、新闻组或者聊天室提出技术问题前，检查你有没有做到：
    1. 通读手册，试着自己找答案。
    2. 在FAQ里找答案（一份维护得好的FAQ可以包罗万象:）。
    3. 在网上搜索（个人推荐google~~~）。
    4. 向你身边精于此道的朋友打听。

    当你提出问题的时候，首先要说明在此之前你干了些什么；这将有助于树立你
    的形象：你不是一个妄图不劳而获的乞讨者，不愿浪费别人的时间。能说明你
    从这些操作中学到了什么就更好了。如果提问者能从答案中学到东西，我们更
    乐于回答他的问题。

    周全的思考，准备好你的问题，草率的发问只能得到草率的回答，或者根本得
    不到任何答案。越表现出在寻求帮助前为解决问题付出的努力，你越能得到实
    质性的帮助。

    小心别问错了问题。如果你的问题基于错误的假设，普通黑客（J. Random
    Hacker）通常会用无意义的字面解释来答复你，心里想着“蠢问题...”，希
    望着你会从问题的回答（而非你想得到的答案）中汲取教训。

    决不要自以为够资格得到答案，你没这种资格。毕竟你没有为这种服务支付任
    何报酬。你要自己去“挣”回一个答案，靠提出一个有内涵的，有趣的，有思
    维激励作用的问题--一个对社区的经验有潜在贡献的问题，而不仅仅是被动的
    从他人处索要知识--去挣到这个答案。

    另一方面，表明你愿意在找答案的过程中做点什么，是一个非常好的开端。
    “谁能给点提示？”、“我这个例子里缺了什么？”以及“我应该检查什么
    地方？”比“请把确切的过程贴出来”更容易得到答复。因为你显得只要有
    人指点正确的方向，你就有完成它的能力和决心。

    ========
    怎样提问
    ========

    ------------
    谨慎选择论坛
    ------------

    小心选择提问的场合。如果象下面描述的那样，你很可能被忽略掉或者被看作失败者：
    1. 在风马牛不相及的论坛贴出你的问题
    2. 在探讨高级技巧的论坛张贴非常初级的问题；反之亦然
    3. 在太多的不同新闻组交叉张贴

    黑客们通常砍掉问错地方的问题，以保护自己的社区不被大量无关帖子淹没。
    你不会希望自己的帖子被这样砍掉吧。

    总的说来，问题发到精心挑选的公众论坛，比发到封闭的小圈子更容易得到有
    用的答案。这一现象有多种原因，其中之一是公众论坛有更多潜在的问题回答
    者；另一个原因是公众论坛有更多的听众。黑客们更愿意让尽量多的人--而非
    有限的一两个--从回答中受益。

    ----------------
    尽量使用邮件列表
    ----------------

    如果某项目有自己的开发邮件列表，要把问题发到这个邮件列表而不是某个开
    发者，即使你很清楚谁最能回答你的问题。仔细查看项目文档和项目主页，找
    到这个项目的邮件列表地址，这样做的理由有四：
    1. 任何值得问某位开发者的好问题，都值得向整个开发团体提出。反之，若
    你认为这个问题不值得在邮件列表中提起，就没有理由用它来骚扰任何一位开发者。
    2. 在邮件列表提问可以分担开发者的工作量。某位开发者（尤其当他是项目
    负责人的情况下），可能忙得没时间回答你的问题。
    3. 大多数邮件列表都有历史存档，而且都能在搜索引擎中检索到。人们可以
    从中找到你的问题和答案，不用一遍又一遍在列表中发问。
    4. 如果某个问题经常被提出，开发者可以据此改进文档或改进软件，以减少
    用户的困惑。而如果问题总在私下提出，就不会有人对此有整体上的把握了。

    如果你找不到项目的邮件列表地址，只能看到项目维护者的，那就写给维护
    者吧。在这种情况下，也别以为邮件列表并不存在。在你的信中写明你已尽
    力寻找，仍无法找到邮件列表。另外表明你不介意将此消息转给他人。（大
    多数人认为私信就应该是私下的，即使并没有什么可保密的内容
    。允许你的消息被转寄给他人，给了收信者一种处理你邮件的选择。）

    ----------------------------
    用辞贴切，语法正确，拼写无误
    ----------------------------

    我们从经验中发现，粗心的写作者通常也是马虎的思考者（我敢打包票）。
    回答粗心大意者的问题很不值得，我们宁愿把时间耗在别处。

    因此，明确充分表述你的问题非常重要。如果你嫌这样做麻烦，我们也会懒
    得搭理你。注意推敲你的用辞，不一定要用呆板正式的语言--事实上，黑客
    文化的价值观是不拘小节。准确的运用俚语和富有幽默感的语言，但别乱用；
    一定要能表明你在思考，在关注。

    正确的拼写，标点符号和大小写很重要。别把“its”和“it's”或者
    “loose”和“lose”搞混淆了。别用全部大写的形式，这被视为粗鲁的大
    声叫嚷（全都用小写也好不到哪儿去，因为这会给阅读带来困难。Alan Cox
    可以用全部小写，但你不行）。

    更一般的说，如果你的提问写得象个半文盲，你很有可能被忽视。如果写得象
    一个窥客（pj爱好者）或者灰客（只会用现成工具的捣乱者）绝对是自己找
    死，保证你除了无情的抵制什么也得不到（或者，最好的结局是得到一大堆挖
    苦嘲笑的“帮助”）。

    如果你在使用非母语的论坛提问，你可以犯点拼写和语法上的小错--但决不能
    在思考上马虎（没错，我们能弄清两者的分别）。另外，除非你确切知道你的
    回答者会使用什么语言，否则请用英文。匆匆忙忙的黑客往往简单的跳过他们
    看不懂的问题，而英文是网络上的工作语言。用英文可以
    降低你的问题未被阅读即遭抛弃的风险。

    ------------------
    用易读格式发送问题
    ------------------

    如果人为造成你的提问难以阅读和理解，将会更容易被人忽略。因此你要：
    1. 使用纯文本邮件，不要使用HTML（关掉HTML并不难）。
    2. 通常可以附加MIME附件，但一定要有真正的内容（例如附加的源文件或者
    补丁），而不仅仅是你的邮件客户端产生的文件模板（例如你邮件的一份拷贝）。
    3. 不要把所有问题放在不停换行的一整段中。（这将让答复的人难于回答其中
    一部分问题，即使能回答所有问题，我也更希望条理清楚的一个一个来:）。很
    可能收件人只能在80个字符宽度的文本显示器上读信，因此要相应的把行环绕
    模式设在80字符以内。
    4. 不要在英文论坛使用MIME Quoted-Printable编码发送；这种编码格式对
    ASCII码不能表达的语言来说是非常必要的，但很多邮件代理不支持它，这
    时，满篇的“=20”符号把文字分割开，既难看，又分散注意力。
    5. 永远不要指望黑客会乐于阅读封闭所有权的文件格式，例如萎软的Word
    格式。多数黑客对此的反应就象你在门口的阶梯上堆满热烘烘的猪粪（意即
    谁也不会踏进你的门--译者注）。
    6. 如果你通过一台安装Windows的电脑发送邮件，关闭萎软愚蠢的“智能引
    用”功能。这能使你免于在邮件中夹带垃圾字符。

    ----------------------------
    使用含义丰富，描述准确的标题
    ----------------------------

    在邮件列表或者新闻组中，大约50字以内的主题标题是抓住资深专家注意力
    的黄金时机。别用喋喋不休的“帮帮忙”（更别说“救命啊！！！！！”这
    样让人反感的话）来浪费这个机会。不要妄想用你的痛苦程度来打动我们，
    别用空格代替问题的描述，哪怕是极其简短的描述。

    蠢问题：
    救命啊！我的膝上机不能正常显示了！

    聪明问题：
    XFree86 4.1下鼠标光标变形，Fooware MV1005的显示芯片。

    如果你在回复中提出问题，记得要修改内容标题，表明里面有一个问题。一个
    看起来象“Re：测试”或者“Re：新bug”的问题很难引起足够重视。另外，引
    用并删减前文的内容，给新来的读者留下线索。

    ------------------
    精确描述，信息量大
    ------------------

    1. 谨慎明确的描述症状。
    2. 提供问题发生的环境（机器配置、操作系统、应用程序以及别的什么）。
    3. 说明你在提问前是怎样去研究和理解这个问题的。
    4. 说明你在提问前采取了什么步骤去解决它。
    5. 罗列最近做过什么可能有影响的硬件、软件变更。

    尽量想象一个黑客会怎样反问你，在提问的时候预先给他答案。

    Simon Tatham写过一篇名为《如何有效的报告Bug》的出色短文。强力推荐你也读一读。

    --------
    话不在多
    --------

    你需要提供精确有效的信息。这并不是要求你简单的把成吨的出错代码或者数据完
    全转储摘录到你的提问中。如果你有庞大而复杂的测试条件，尽量把它剪裁得越小
    越好。

    这样做的用处至少有三点。第一，表现出你为简化问题付出了努力，这可以使你得
    到回答的机会增加；第二，简化问题使你得到有用答案的机会增加；第三，在提炼
    你的bug报告的过程中，也许你自己就能找出问题所在或作出更正。

    ------------------
    只说症状，不说猜想
    ------------------

    告诉黑客们你认为问题是怎样引起的没什么帮助。（如果你的推断如此有效，还用
    向别人求助吗？），因此要确信你原原本本告诉了他们问题的症状，不要加进你自
    己的理解和推论。让黑客们来诊断吧。

    蠢问题：
    我在内核编译中一次又一次遇到SIG11错误，我怀疑某条飞线搭在主板的走线上了，
    这种情况应该怎样检查最好？

    聪明问题：
    我自制的一套K6/233系统，主板是FIC-PA2007 （VIA Apollo VP2芯片组），256MB
    Corsair PC133
    SDRAM，在内核编译中频频产生SIG11错误，从开机20分钟以后就有这种情况，开机
    前20分钟内从没发生过。重启也没有用，但是关机一晚上就又能工作20分钟。所有
    内存都换过了，没有效果。相关部分的典型编译记录如下...。

    ------------------
    按时间顺序列出症状
    ------------------

    对找出问题最有帮助的线索，往往就是问题发生前的一系列操作，因此，你的说明
    应该包含操作步骤，以及电脑的反应，直到问题产生。在命令行操作的情况下，保
    存一个操作记录（例如使用脚本工具），并且引用相关的大约20条命令会大有帮助。

    如果崩溃的程序有诊断选项（例如用-v转到详尽模式），试着仔细考虑选择选项以
    在操作记录中增加有用的调试信息。

    如果你的说明很长（超过四个段落），在开头简述问题会有所帮助，接下来按时间
    顺序详述。这样黑客们就知道该在你的说明中找什么。

    --------------
    别要求私下答复
    --------------

    黑客们认为解决问题应该有公开、透明的流程。只要任何更有见地的人注意到答
    案的不完善或者不正确，这个最初的答案就可以和应该得到纠正。同时，通过能
    力和知识被大家注意，被大家接受，回答问题者得到了应有的奖励。

    如果你要求对方私下回答你，这既破坏了整个流程，也破坏了奖励制度。别提这
    要求，这是回答者的权利，由他来选择是否私下答复--如果他选择这样做，通常
    是因为他认为这个答案过于显而易见或者有不良的公开影响，别人不会感兴趣。

    只有一种有限的例外：如果你预计将收到大量雷同的答复，你可以说：“把答案
    寄给我，由我来汇总吧。”将邮件列表或者新闻组从大量重复的帖子中打救出来
    是很有君子之风的--但请记住，履行自己关于汇总的承诺。

    --------------
    明白你想问什么
    --------------

    漫无边际的提问近乎无休无止的时间黑洞。最能给你有用答案的人也正是最忙的
    人（他们忙是因为要亲自完成大部分工作）。这样的人对无节制的时间黑洞不太
    感冒，因此也可以说他们对漫无边际的提问不大感冒。

    如果你明确表述需要回答者做什么（提供建议，发送一段代码，检查你的补丁
    或是别的），就最有可能得到有用的答案。这会定出一个时间和精力的上限，
    便于回答者集中精力来帮你，这很凑效。

    要理解专家们生活的世界，要把专业技能想象为充裕的资源，而回复的时间则
    是贫乏的资源。解决你的问题需要的时间越少，越能从忙碌的专家口中掏出答案。

    因此，优化问题的结构，尽量减少专家们解决它所需要的时间，会有很
    大的帮助--这通常和简化问题有所区别。因此，问“我想更好的理解X，
    能给点提示吗？”通常比问“你能解释一下X吗？”更好。如果你的代码
    不能工作，问问它有什么地方不对，比要求别人替你修改要明智得多。

    ------------------------
    别问应该自己解决的问题
    ------------------------

    黑客们总是善于分辨哪些问题应该由你自己解决；因为我们中的大多数都
    曾自己解决这类问题。同样，这些问题得由你来搞定，你会从中学到东西。
    你可以要求给点提示，但别要求得到完整的解决方案。

    ----------------
    去除无意义的疑问
    ----------------

    别用无意义的话结束提问，例如“有人能帮我吗？”或者“有答案吗？”。
    首先：如果你对问题的描述不很合适，这样问更是画蛇添足。其次：由于这
    样问是画蛇添足，黑客们会很厌烦你--而且通常会用逻辑上正确的回答来表
    示他们的蔑视，例如：“没错，有人能帮你”或者“不，没答案
    ”。

    ----------------------------
    谦逊绝没有害处，而且常帮大忙
    ----------------------------

    彬彬有礼，多用“请”和“先道个谢了”。让大家都知道你对他们花费时间
    义务提供帮助心存感激。

    实话实说，虽然这不象合乎语法、清楚准确的描述，避免私有格式等等那么
    重要（也不能用来替代它们）；黑客一般更喜欢直接了当然而技术上敏锐的
    bug报告，而不是彬彬有礼的废话（如果这让你迷惑不解，请记住，我们衡
    量一个问题价值的标准是：它能让我们学会多少）。

    然而，如果你有很多问题无法解决，礼貌将会增加你得到有用答案的机会。

    （我们注意到，自从本指南发布后，从资深黑客处得到的唯一严重缺陷反
    馈，就是对预先道谢这一条。一些黑客觉得“先谢了”的言外之意是过后
    就不会再感谢任何人了。我们的建议是：都道谢。）

    ------------------------
    问题解决后，加个简短说明
    ------------------------

    问题解决后，向所有帮助过你的人发个说明，让他们知道问题是怎样解决
    的，并再一次向他们表示感谢。如果问题在新闻组或者邮件列表中引起了
    广泛关注，应该在那里贴一个补充说明。

    补充说明不必很长或是很深入；简单的一句“你好，原来是网线出了问
    题！谢谢大家--Bill”比什么也不说要强。事实上，除非结论真的很有
    技术含量，否则简短可爱的小结比长篇学术论文更好。说明问题是怎样
    解决的，但大可不必将解决问题的过程复述一遍。

    除了表示礼貌和反馈信息以外，这种补充有助于他人在邮件列表/新闻
    组/论坛中搜索对你有过帮助的完整解决方案，这可能对他们也很有用。

    最后（至少？），这种补充有助于所有提供过帮助的人从中得到满足感。
    如果你自己不是老手或者黑客，那就相信我们，这种感觉对于那些你向
    他们求助的导师或者专家而言，是非常重要的。问题久拖未决会让人灰
    心；黑客们渴望看到问题被解决。好人有好报，满足他们的渴望，你会在下
    次贴出新问题时尝到甜头。

    ============
    如何理解答案
    ============

    --------------------
    RTFM和STFW：别烦我啦
    --------------------

    有一个古老而神圣的传统：如果你收到“RTFM （Read The f\*\*king Manual）”
    的回复，回答者认为你应该去读TMD手册。当然，基本上他是对的，你应该读一读。

    RTFM有一个年轻的亲戚。如果答案是“STFW （Search The f\*\*king Web）”，
    回答者认为你应该到TMD的网上去搜索。基本上，他也是对的，你就去找吧。

    通常，用这两句之一回答你的人会给你一份包含你需要内容的手册或者一个网
    址，而且他们打这些字的时候正在阅读着。这些答复意味着回答者认为(1). 你
    需要的信息非常容易获得；(2). 你自己去搜索这些信息比灌给你能让你学到更多。

    别为这个而不爽；依照黑客的标准，他没有对你的要求视而不见，已经
    能大致能表示对你的关注。你应该对他祖母般的慈祥表示感谢。

    ----------
    还是不懂
    ----------

    如果你不是很理解答案，别立刻要求对方解释。象你以前试着自己解决
    问题时那样（利用手册，FAQ，网络，身边的高手），去理解它。如果
    你真的需要对方解释，记得表现出你已经学到了点什么。

    比方说，如果我回答你：“看来似乎是zEntry被阻塞了；你应该先清
    除它。”，然后：

    一个很糟的后续问题：“zEntry是什么？”

    聪明的问法应该是这样：“哦~~~我看过帮助了但是只有-z和-p两个
    参数中提到了zEntry而且还都没有清楚的解释:<你是指这两个中的
    哪一个吗？还是我看漏了什么？”

    --------
    面对无礼
    --------

    黑客圈子里很多貌 拼致车难 行并非有意冒犯。更恰当的说，这是
    直率、不说废话的沟通方式的产物，这种沟通方式源于人们关注问
    题的解决--多过让人感受温暖亲情然而却依旧糊里糊涂--的天性。

    如果你觉得受到粗鲁的对待，请保持冷静。如果真有人表现粗野，
    通常会有列表/新闻组/论坛的长辈找他谈心，如果没有这样，而你
    又大发脾气，则很可能对方的言行是黑客社区行为规范许可内，而
    你被认为是有过错的。这会不利于你得到信息或者帮助。

    另一方面，你偶尔也会无缘无故有粗野的言行和心态。上述现象的
    另一面是，人们允许狠狠打击真正的冒犯者，用尖刻的言语剖析他
    们的不当言行。如果你真决定这样做，先仔细又仔细的掂量一下你
    自己的分量。合理的粗鲁与发动一场无意义的论战之间只隔了一条
    细细的线，冒冒失失撞上
    去的黑客不在少数；如果你是新手或者门外汉，不犯这种错的机会
    是很渺茫的。如果你想得到信息而不是来胡闹，别冒险回复，最好
    把手从键盘上拿开。

    （有些人声称多数黑客有孤僻症或者社交障碍综合征的轻度症状，
    而且确实缺少部分有助“常人”进行社交行为的脑组织结构。这也
    许是真的，也许不是。如果你自己不是黑客，那么，把我们想象成
    脑部有缺陷的人有助你面对我们的古怪。有话直说，我们无所谓；
    我们乐于按自己的想法生
    活，而且总是对医学概念持相当怀疑的态度。）

    在下一节里，我们将谈论另一个话题；当你行差踏错时可能遇到的“无礼”。

    ================
    决不要象个失败者
    ================

    很有可能，你在黑客社区的论坛会受到很多公开的攻击--用本文提
    到的各种方式或类似的方法，而且很可能会有各式各样的旁敲侧击
    来告诉你你有多讨厌。

    如果噩梦成真，你能做的最糟的事就是为此发牢骚，抱怨受到人身
    攻击，要求对方道歉，尖叫，屏住呼吸，威胁要控诉对方，向他老
    板告状，不掀起马桶座圈，等等等等。然而，你应该这样：

    由它去吧，这没什么大不了的。实际上这么做是恰当的和有益的（
    主要是有利身心健康:）。

    社区的规范不靠社区，而是靠积极推行它们的人们来维护，这种维
    护是公开的，显而易见的。别抱怨说一切批评都应该通过私信传送，
    它本来就不该那样。当别人指出你的话有错误，或者他有不同观点的
    时候，坚持认为他在羞辱你是没有用的。这些都是失败者的态度。

    有那么一些黑客论坛，出于对高度自谦的误解，禁止参与者张贴专给
    人找茬的帖子，而且被告知“如果不愿帮助用户，那就闭嘴。”，他
    们认为，引开参与者的话题，只会使得他们陶醉在毫无意义的喋喋不
    休中，从而失去了技术论坛的意义。

    夸张的“友善”（以那种方式）还是有用的帮助：你自己选择吧。

    记住：当黑客说你很烦人，（无论用多么粗暴的语言）警告你别再那
    样做了，他的本意并非是针对(1)你，以及(2)他的社区。他本来可以
    轻易的忽略你，把你从他的视线中抹去。如果你无法接受要向他表示
    感激，至少应该表现出你的气度，别抱怨，别期望只因为你是新人，
    你有戏剧般的敏
    感脆弱的神经和自封的权利，而受到易碎玩偶般的特别对待。

    ==========
    三思而后问
    ==========

    以下是几个经典蠢问题，以及黑客在拒绝回答时的心中所想：

    问题：我能在哪找到X程序？
    问题：我的程序/配置/SQL申明没有用
    问题：我的Windows有问题，你能帮我吗？
    问题：我在安装Linux（或者X）时有问题，你能帮我吗？
    问题：我怎么才能pjroot帐号/窃取OP特权/读别人的邮件呢？

    提问：我能在哪找到X程序？
    回答：就在我找到它的地方啊蠢货--搜索引擎的那一头。天呐！
    还有人不会用Google吗？

    提问：我的程序（配置、SQL申明）没有用
    回答：这不算是问题吧，我对找出你的真正问题没兴趣--如果要
    我问你二十个问题才找得出来的话--我有更有意思的事要做呢。
    在看到这类问题的时候，我的反应通常不外如下三种：
    1. 你还有什么要补充的吗？
    2. 真糟糕，希望你能搞定。
    3. 这跟我有什么鸟相关？

    提问：我的Windows有问题，你能帮我吗？
    回答：能啊，扔掉萎软的垃圾，换Linux吧。

    提问：我在安装Linux（或者X）时有问题，你能帮我吗？
    回答：不能，我只有亲自在你的电脑上动手才能找到毛病。
    还是去找你当地的Linux用户组寻求手把手的指导吧（你能
    在这儿找到用户组的清单）。

    提问：我怎么才能pjroot帐号/窃取OP特权/读别人的邮件呢？
    回答：想要这样做，说明你是个卑鄙小人；想找个黑客帮你，说明你是个白痴！

    ==============
    好问题，坏问题
    ==============

    最后，我举一些例子来说明，怎样聪明的提问；同一个问题的两种问
    法被放在一起，一种是愚蠢的，另一种才是明智的。

    蠢问题：我可以在哪儿找到关于Foonly Flurbamatic的资料？
    这种问法无非想得到“STFW”这样的回答。

    聪明问题：我用Google搜索过“Foonly Flurbamatic 2600”，但是
    没找到有用的结果。谁知道上哪儿去找对这种设备编程的资料？
    这个问题已经STFW过了，看起来他真的遇到了麻烦。

    蠢问题：我从FOO项目找来的源码没法编译。它怎么这么烂？
    他觉得都是别人的错，这个傲慢自大的家伙

    聪明问题：FOO项目代码在Nulix 6.2版下无法编译通过。我读过了FAQ，
    但里面没有提到跟Nulix有关的问题。这是我编译过程的记录，我有什么
    做得不对的地方吗？
    他讲明了环境，也读过了FAQ，还指明了错误，并且他没有把问题的责任
    推到别人头上，这个家伙值得留意。

    蠢问题：我的主板有问题了，谁来帮我？
    普通黑客对这类问题的回答通常是：“好的，还要帮你拍拍背和换尿布
    吗？” ，然后按下删除键。

    聪明问题：我在S2464主板上试过了X、Y和Z，但没什么作用，我又试了
    A、B和C。请注意当我尝试C时的奇怪现象。显然边带传输中出现了收缩，
    但结果出人意料。在多处理器主板上引起边带泄漏的通常原因是什么？
    谁有好主意接下来我该做些什么测试才能找出问题？
    这个家伙，从另一个角度来看，值得去回答他。他表现出了解决问题的
    能力，而不是坐等天上掉答案。

    在最后一个问题中，注意“告诉我答案”和“给我启示，指出我还应该
    做什么诊断工作”之间微妙而又重要的区别。

    事实上，后一个问题源自于2001年8月在Linux内核邮件列表上的一个真
    实的提问。我（Eric）就是那个提出问题的人。我在Tyan S2464主板上
    观察到了这种无法解释的锁定现象，列表成员们提供了解决那一问题的重要信息。

    通过我的提问方法，我给了大家值得玩味的东西；我让人们很容易参与并
    且被吸引进来。我显示了自己具备和他们同等的能力，邀请他们与我共同
    探讨。我告诉他们我所走过的弯路，以避免他们再浪费时间，这是一种对
    他人时间价值的尊重。

    后来，当我向每个人表示感谢，并且赞赏这套程序（指邮件列表中的讨论
    --译者注）运作得非常出色的时候，一个Linux内核邮件列表（lkml）成
    员表示，问题得到解决并非由于我是这个列表中的“名人”，而是因为
    我用了正确的方式来提问。

    我们黑客从某种角度来说是拥有丰富知识但缺乏人情味的家伙；我相信
    他是对的，如果我象个乞讨者那样提问，不论我是谁，一定会惹恼某些
    人或者被他们忽视。他建议我记下这件事，给编写这个指南的人一些指导。

    ================
    找不到答案怎么办
    ================

    如果仍得不到答案，请不要以为我们觉得无法帮助你。有时只是看到你
    问题的人不知道答案罢了。没有回应不代表你被忽视，虽然不可否认这
    种差别很难区分。

    总的说来，简单的重复张贴问题是个很糟的想法。这将被视为无意义的
    喧闹。
    喧闹。

    你可以通过其它渠道获得帮助，这些渠道通常更适合初学者的需要。

    有许多网上的以及本地的用户组，由狂热的软件爱好者（即使他们可能
    从没亲自写过任何软件）组成。通常人们组建这样的团体来互相帮助并
    帮助新手。

    另外，你可以向很多商业公司寻求帮助，不论公司大还是小（Red
    Hat和LinuxCare就是两个最常见的例子）。别为要付费才能获得帮助而
    感到沮丧！毕竟，假使你的汽车发动机汽缸密封圈爆掉了--完全可能如
    此--你还得把它送到修车铺，并且为维修付费。就算软件没花费你一分
    钱，你也不能强求技术支持总是免费的。

    对大众化的软件，就象Linux之类而言，每个开发者至少会有上万名用户。
    根本不可能由一个人来处理来自上万名用户的求助电话。要知道，即使你
    要为帮助付费，同你必须购买同类软件相比，你所付出的也是微不足道

    的（通常封闭源代码软件的技术支持费用比开放源代码软件要高得多，
    且内容也不那么丰富）。


相关资源

` 相关资源 看雪学院
  • 相关资源
    1
    RCE Messageboard's Regroupment (http://www.woodmann.net/)
    2
    Reverse-Engineering-Forums (AntiCrack) (http://board.anticrack.de/)
    3
    Win32ASM Community messageboard (http://board.win32asmcommunity.net/index.php)
    4
    Olldbg论坛 (http://ollydbg.win32asmcommunity.net/index.php)