search is not available in 3.0 browsers

The search function requires a 4.0 browser.


Help Contents

Extending Fireworks Overview


Generator Overview

Extending Fireworks Overview

Every command or setting in Fireworks can be controlled using special JavaScript commands that Fireworks can interpret. The Extending Fireworks manual includes information about writing JavaScript to automate Fireworks tasks.

A PDF version of Extending Fireworks is available for download from the Macromedia Web site.


Visit the Support Center
Contents Index Search


Welcome to Fireworks 4 Help!

For updates and downloads, visit the Fireworks Support Center.


简介概述（侠客岛版权所有）

简介 > 简介概述

简介概述

Fireworks 4是专业网络图形设计和生产解决方案。

使用Fireworks® 来创建、编辑、制作网络动画、增加先进的互动性，在专业环境中优化图象。Fireworks 是编辑矢量和位图的综合工具。在Fireworks 中任何物体在任何时候都是可编辑的。而且，你可以设置自动处理以满足更新和变化的要求。

Fireworks 和其它Macromedia产品例如 FreeHand, Director, Dreamweaver™, Macromedia Flash™以及其它常用的图形程序和HTML编辑器综合使用，提供一整套网络解决方案。你可以轻松地输出带有HTML 和 JavaScript™并适应你使用的HTML编辑器。

（侠客岛版权所有）


系统需求 （侠客岛版权所有）

简介 > 系统需求

系统需求

要运行Fireworks，至少要拥有以下配置

对于Microsoft Windows™: Intel Pentium® 处理器 (Pentium II 更好) 系统为 Windows 95, 98, ME, 2000, or NT 4 (with Service Pack 5) 或更新版本; 64 MB 内存加 100 MB 以上硬盘; 800 x 600 分辨率, 256色 (1024 x 768 分辨率, 百万色更好); 鼠标或压杆笔再加一个 CD-ROM
对于 Macintosh®: A Power Macintosh (G3 或更高), 系统为 8.6 or 9.x; 64 MB 内存加 100 MB 以上硬盘;Adobe 字体管理® 4 或更新版本用于打一号字体 ； 彩色显示器 (1024 x 768 分辨率, 百万色更好); 鼠标或压杆笔再加一个 CD-ROM。


安装Fireworks （侠客岛版权所有）

简介 >安装Fireworks

安装Fireworks

在安装Fireworks之前,确定你的电脑符合下列所述要求系统需求. 阅读Fireworks CD-ROM上的说明文件

在Windows系统安装 Fireworks :

1 | 把 the Fireworks 4 CD插入你的光驱 .
2 | 开始安装:
 | 在 Windows中, Fireworks 安装程序会自动开始. 如果没有的话，选择开始 > 在Fireworks 4 CD中运行.点击浏览 并选择 Setup.exe 在对话框中点击OK.
 | 在Macintosh中,双击 Fireworks 4 安装图标.
3 | 遵照屏幕指导，安装程序会提醒你填入必要的信息，
4 | 如果系统提醒你重启电脑，选重启


学习 Fireworks （侠客岛版权所有）

简介 > 学习 Fireworks

学习 Fireworks

有许多资源可以用来学习Fireworks ，包括手册，附带的帮助系统、互动交互课程。以及一些网络信息资源。

Fireworks 中文帮助 在系统启动后随时可以使用。他包含了和指导相同的信息加上其他附加信息。

Fireworks 教程 是一个关于Fireworks主要特性的交互介绍，课时约一分钟。包括普通的Fireworks的任务，例如：优化GIFs和JPEGs图象、创建rollover图象变换和动画。如果你是新手，请先从帮助菜单里选择lessons基础课程，然后进入教程。

Fireworks 基础课程 是一系列关于Fireworks特性的短小的课程，内容包括从动画基础到创建rollovers图象变换和弹出式菜单。每一课中课时越10分钟，如果你是新手，请从 基础课程开始，然后进入教程。

Fireworks 应用包含许多对话框和工具说明以帮助你使用本程序，工具说明在你的指针在某个用户界面单元停滞时出现。

使用Fireworks 包括Fireworks的基础和高级特性的信息。

拓展Fireworks 包括用JavaScript来自动操作 Fireworks任务的信息。每一个命令或设置都可以通过Fireworks可以执行的特殊JavaScript命令来进行控制。拓展Fireworks的PDF版电子书可以从这里下载 http://www.macromedia.com/support/fireworks/extend.html.

Fireworks支持中心网站及时更新Fireworks的最新信息，以及专家建议、高级主题、范例、技巧、以及升级。查看关于Fireworks的新闻和如何获知更多关于Fireworkshttp://www.macromedia.com/support/fireworks/.

Fireworks 讨论组 向Fireworks用户、技术支持代表、Fireworks开发者提供经验交流的地方。要使用这个新闻组。news://forums.macromedia.com/macromedia.fireworks.


Fireworks 4新特性（侠客岛版权所有）

介绍 > Fireworks 4新特性

Fireworks 4新特性

Fireworks 4提供了许多新特征来加强你的网络设计。

Macromedia用户界面

稳定熟悉的用户界面帮助设计者顺利地在Macromedia Flash, Dreamweaver, Dreamweaver UltraDe和Fireworks中切换自如。不论你使用哪种 Macromedia网络设计产品，你将会发现尽可能同样的图标、工具、工具栏以及术语。

Macromedia用户界面可以自定义快捷键。你可以建立你使用的Macromedia或者非Macromedia图形编辑程序的快捷方式，也可以建立你自己的方案。

一个小的在底部的启动工具栏使你快速打开常用Fireworks面板。

Dreamweaver 兼容性

Fireworks 和 Dreamweaver 合作更为天衣无缝。

双程表格编辑使你可以在Dreamweaver编辑、更新HTML 和 JavaScript 代码以及图形，而又保持对表格的编辑。它可以更新放置于Dreamweaver页面HTML表格中的图案，在Fireworks外保存对 HTML的变化。如果你改变了行为、输入文字、修改链接或者进行其它编辑，你可以更新图象变化而不用在Dreamweaver中 重写HTML。

加强的启动和编辑窗口可以让你直接从主程序例如Dreamweaver 或 Macromedia Flash进入Fireworks 。你可以在Fireworks 中进行编辑，然后按完成，并回到主程序。

当你在启动并且编辑放在Dreamweaver中的Fireworks图象，Dreamweaver属性检查器可以告诉你你是在编辑一个图象还是一个表格。点击属性检查器上的编辑按钮，就可以找到PNG源文件。

拖放行为

建立替代图象和图象变化变得很容易，只要从触发区域拖到目标就可以了。每个切片和热区拥有一个行为控制点，使你能轻易地拖动分配行为。当你拖动控制点后，一个对话框自动打开，这样你就可以分配一个任务到某一桢。

当你在web层中查看时，拖放行为显示从哪里链接到哪里。点击一个行为控制点并从右键菜单向一个切片或热区添加行为。拖放行为和传统的分配行为是一样的，但它们更容易应用和管理。你仍然可以要行为面板中查看、编辑和分配行为。要看更多的信息，按 向热区应用拖放行为.

弹出式菜单

在许多有新意的站点看到需要长时间下载的漂亮菜单，但你可能既不知道怎么做，也没时间去做这样的菜单，Fireworks 在它日益增大的命令库中增加了弹出式菜单，令你节省大量时间。

你可以使用样式化的文字创建一个弹出式茶单，或者使用图片作为弹出式菜单的项目以增加创造性。另一方面，弹出式菜单命令把非常困难的任务变得轻松。你还可以象在Dreamweaver中一样使用font families。

蒙版，层面板，影格面板的加强

新的层面板显示了每个层对象的缩略图，包括web层的切片和热区。你可以在层面板使用缩略图和添加蒙版图标来创建一个矢量或者位图蒙板，或者使用传统的在剪贴板内形成遮照。

你可以从层面板轻易地选择，命名，移动以及删除单个对象。你可以通过拖曳显示/隐藏和锁定/解锁栏来隐藏、显示、锁定、或截锁多个层。不透明度和漂白状态设置直接可以在层面板上进行。

你也可以在影格面板里命名影格，来方便在图象替换或动画中管理影格，以及将层作为影格输入。

升级的输入输出选项。

输出对话框使用更为简单，布局更为合理，当前输出模式不可用的选项显示为灰暗或者隐藏。

改进了它对不同文件格式的输出能力：

Photoshop PSD 输出 让你选择是否保持可编辑状态或者Fireworks格式，或压平层成为完全渲染的图像。

Photoshop PSD 输入 Fireworks新的层和影格功能加强了这个方面的能力。例如，当你将层作为影格输入时，Photoshop层的名字变成Fireworks影格的名字。每一个Photoshop层转化为Fireworks层上的一个对象，Photoshop层蒙版完整的被导入作为Fireworks图像对象。

FreeHand 9 输入 允许对抗锯齿文字和对象的独立控制。这也适用于对其它矢量输入模式，例如 Illustrator、 CorelDRAW。

Director 输出允许你输出层或切片以及HTML到Director，如果你安装了用于Director的Import Xtra > Fireworks > Fireworks HTML, 你的图像既可以输入到stage也可以输入到score，并保持registration points完整。要下载这个外挂程序到 www.macromedia.com/support/director/xtras.html.

EPS 输入现在在Fireworks中也可以了。文件被作为位图渲染。

WBMP 输入输出 现在在Fireworks中也可以了。WBMP文件格式用于无线通讯设备。

要得到更多Fireworks输出的信息，参见用输出向导输出。.

用户效率加强

Fireworks 改进了许多特征以使用户效率提高。

当你创建一个按钮，它像其它矢量对象一样置于层上。
如果切片发生重叠，最顶层的切片在重叠区是激活的。Fireworks切片输出文件基于最顶层切片的百分比，不会在重叠区域输出多余切片。
如果你在系统参数中选择了笔刷大小绘制指针，你绘图时指针会显示笔刷和橡皮檫的大小和形状。
你可以轻易地在2-up和4-up视图中使用快捷菜单选择原始和预览视图。
你可以在变形对象时通过消息面板查看变化消息。
你可以在位图模式下通过取消选择显示条纹框选项来隐藏条纹框。
当你拖曳指针经过文件窗口时，窗口中的文件会在该方向滚动。你也可以卷过画布这样你就可以对工作区域聚焦以及对其边缘进行操作。
不规则选择更为流畅和精确。
填色手柄自动出现，这样你就可以对矢量对象快速进行图案和渐变填色。同样填色面板上的一个新的编辑按钮使你更容易编辑渐变。
当你拖曳路径的节点接近相同笔触路径的节点时，两个路径会自动吸附到一起。

可选JPEG压缩

使用不规则选取工具并设置Selective JPEG属性，你可以确定JPEG图像中重要的部分，并以高质量显示。然后你可以制作较小文件体积的替换图片来显示图像的次要部分。

钢笔工具的改进

钢笔工具加强了在绘制和编辑矢量图形时的控制性。新的smart指针表明你的操作目的。按住Control (Windows)或Command (Macintosh)可以从钢笔工具切换到细部选取工具以获得更好的指针控制。

带有圆角的矩形

使用新的圆角矩形工具，你可以在绘制矩形前设置圆角半径。同样，你也可以用它选择一个矩形并改变它的圆角半径。

工作区的实时动画控制

Fireworks现在提供了实时动画用户界面，可以让你像Director和Macromedia Flash一样，直接在屏幕上设置起始和结束位置。Fireworks使用动画本体和动画起点、终点和中间点的线框来代表每个影格。

当你选择一个动画本体，对象面板显示动画属性，例如影格数、大小、不透明度、旋转角度。你可以通过在对象面板中改变数值来编辑所选动画。

GIFs动画可以作为一个动画本体输入

批处理

Fireworks新设计的批处理用户界面合理地显示了批处理过程的选项。你可以在建立批处理任务时决定输出文件夹的名字和位置。

选项位于面板的普通视图上而不是隐藏在弹出式菜单中。首先，你在批处理对话框中选择目标文件，然后你在面板上键入引导程序进行的命令。

第一个面板让你选择批处理的动作和顺序，第二个面板让你选择处理过的文件如何保存或备份。

要知道更多这个主题的内容，参见 批处理.

更新的HTML设置对话框

HTML 选项通过HTML设置对话框可以轻松地寻找和选择。这些选择放置在四个面板表格中：普通(设置通用参数)；文件(设置命名规则、关联、(Macintosh)以及后缀名)；表格(设置如何输出HTML表格)；特定文件(设置当前文件的选项，例如手动或自动命名切片)。

HTML设置对话框让你精确控制HTML、JavaScript以及图像输出的许多参数。

通过自定义创建和输出变量，你可以输出适合特定工作方法、样式需求以及服务器应用要求的Fireworks文件。你可以指定HTML风格(普通、Dreamweaver、 GoLive™, FrontPage®或自定义)以及后缀名(.htm, .html, .HTML, .asp, .jsp, .php, .shtml, 或自定义)。

你可以包括HTML评论，设置小写文件名以及设置边框样式(无边框、单像素透明图像、或指定图像)。你可以设置空单元颜色和内容。Macintosh用户可以指定文件并指定文件的编辑器设置。

Fireworks 4 简化了建立切片命名规则的任务，你可以通过HTML设置对话框的文件特别标签上的一系列弹出式菜单，选择你命名规则的每个部分。

文字改进

Fireworks 4 保留了单个文字的颜色和字体。如果你选择了一个文字颜色，那么Fireworks会对你打的下一个字继续使用这个颜色。

同样，如果你选择另一个绘图工具并改变了笔触或填色然后回到文字工具，你上次使用的文字颜色会回复为当前文字颜色。

当文字编辑器打开时，你可以改变文字的位置。


教程概述（侠客岛版权所有）

教程 >教程概述

教程概述

本教程让你直接领略 Fireworks 4 的多才多艺。通过本教程，你将会发现 Fireworks如何以简单易用的方式将多种不同功能统一起来，而且，Fireworks提供更提供了一些特性以自动完成例如创建网络对象，整个网页以及文字和特效图象的高难任务。

学什么

通过本教程，在不到两小时里你将会完成设计网页的一个典型Fireworks开发工作流程。该流程将包括以下任务：

创建矢量图形和文字
输入及编辑位图图象
在文件中排列对象
创建JavaScript按钮
向按钮添加链接
使用历史面板
创建简单的和分离的 rollovers 图象变换
输出 HTML

你应该掌握的基础

整个教程专为Fireworks新手设计，你至少应掌握Fireworks 基础课程中的基础技巧，这个交互课程提供的以下主题的动手操作：

简介 Fireworks
创建动画
建立切片
用拖放行为建立rollovers 图象变换
创建弹出式菜单
重复任务自动化操作

要参加基础课程，选择help> Lessons, 并从列表里选择。请放心你将会在轻松掌握课程中的概念，然后进入教程。


下一步（侠客岛版权所有）

教程 > 下一步

下一步

现在你已经完成工作流程的主要任务（用Fireworks创建网页）了，这些任务包括：
创建矢量图形和文字
导入和修改位图图形
排列文件中的对象
创建JavaScript按钮
给按钮添加链接
使用历史面板
创建简单的和分隔的图象轮换
输出HTML文件

要获知教程里提到的任何特性的详细信息，以及Fireworks附加特性，请使用目录或者使用本帮助的搜索。同样可以访问 Macromedia's有奖支持中心 http://www.macromedia.com/support/fireworks.


观察完成的页面（侠客岛版权所有）

教程 > 观察完成的页面

观察完成的页面

注意，在开始教程前，仔细观察这个完成的页面，这应是你完成项目后输出的html页面应该达到的效果。

1 | 在你安装 Fireworks 4 程序的文件夹, 打开 Tutorial\Complete文件夹
2 | 选择Final.htm 在浏览器中打开
 | 在本教程，你将会为一家叫指南针的冒险旅行社完成一个半成品网页，你将会向按钮栏添加链接，并指向到构成指南针网站的另两个网页。
3 | 移动你的指针掠过网页顶部的按钮栏，你将会发现有rollover图象变换效果—指针掠过按钮时，按钮如何变化
 | 同样请注意分离的图象变换效果—指针掠过按钮时，一个大的图形如何变化。
4 | 点击旅行日志按钮来测试链接，然后使用浏览器的后退按钮回到Final.htm页面。
5 | 当你观察完毕之后，你可以关闭页面，也可以让它开着在使用教程时作为参考。

注意： 你的 Tutorial 也包含着生成这些页面的Fireworks文件。要看该文件，请打开 Fireworks 4\Tutorial \Complete\Final.png.


打开Start文件（侠客岛版权所有）

教程 > 打开Start文件

打打开Start文件

你已经参加了基础课程并浏览了Final.htm，并做好了开始本项目的准备。

1 | 在Fireworks中,选择File > Open. 找到 Fireworks 4 程序文件夹，并打开Tutorial\Start\Start.png.
 | Fireworks 文件是以png为后缀名，当你完成一个Fireworks 文件，你可以以不同格式输出。
2 | 选择File > 保存为 MyFile.png. 在start文件夹保存 MyFile.png
 | 通过制作文件的备份，你保存了你的工作的结果同时也方便了别人以后使用这个教程。

注意：完成教程时，你有可能觉得undo（还原一个操作）会很有用，Fireworks根据你在系统参数里设置的undo水平值可以还原很多步操作。要使用 undo, 选择 Edit > Undo.

当你进行操作时，请记得经常存盘。


加入矢量图形（侠客岛版权所有）

教程 > 加入矢量图形

加入矢量图形

矢量图形是几何形状的数学名称，而位图用一格格不同颜色的像素来定义图形。两种图形各有长处，比如：矢量图形更容易编辑，位图则有更多复杂的颜色变化更适合艺术作品，比如照片。

许多程序要么提供编辑矢量图形的工具，要么提供位图编辑工具。Fireworks让你可以同时编辑两种图形，Fireworks默认以矢量方式打开文件，你可以使用矢量模式来快速转化为按钮。

创建矢量图形

你可以用工具面板来创建矢量图形，工具面板同时提供了矢量工具和位图工具，以及一些功能随图形模式改变的工具，

1 | 选择 View > Guides（辅助线） 请确认选中Show Guides（显示辅助线） 以及 Snap to Guides （辅助线吸附）如果没有请选中。
 | 注意：默认为绿色的辅助线，可以帮助你在画布上排列对象。
2 | 如果层面板不可见，选择 Window > 层, 或者按文件窗口底部的层按钮
 | 你将会在后面的教程里学到层的优势和更多知识。现在，你只需要层面板提供组织一系列对象的方法。选择按钮层，会在文件中你放置 将你创建的按钮都放在同一个层里，也就是按钮层。
3 | 如果工具面板没有显示，选择 Window > Tools. 在工具面板里，选则矩形工具。把十子字指针放在下面说明的单元的左上角，然后拖到单元的对角，这样矩形自动吸附到排列导线上。

增加渐变填色

有些创新的格调让你的矢量图形看上去更象更象按钮，首先，你可以加入渐变颜色，再加上效果。渐变颜色显示了两种颜色间细致的变化。你可以给你的矢量图形加入线形渐变。

1 | 如果填色面板不显示，选择 Window > Fill, 并确认选中了你创建的矢量图形。在填色面板中，选择填色类型下拉菜单来选择线形渐变。
 | 注意： 在矢量状态下，即你现在使用的状态，你可以用指针选择一个对象，选择路径（默认浅蓝色）框出所选对象的轮廓，表示该对象被选中。
2 | 在填色预设渐变设置下拉菜单中选择 Black, White.
3 | 点击Edit ，向右拖动左边色样，使渐变更暗一些。
 | 当你在按钮上加入亮的文字时，稍暗的底色最易于辨认。

应用特效

使用Fireworks特效，你可以文字和图象添加各种特殊效果，例如斜角和浮雕。

1 | 如果特效面板不显示，选择 Window > Effect, 并且确认你的矢量图形被选中。
2 | 在特效面板的添加特效弹出菜单里选择斜角和浮雕 > 内部斜角。
 | 特效面板显示附加的区域。
3 | 在斜角边缘形状弹出菜单里，选斜坡。
4 | 要减少斜角的宽度，移动宽度滑钮到4，或者键入4 在宽度文本框里，并回车，

注意： 当你添加一个特效后，如果你打算修改他，点击特效面板上的该特效的信息按钮。


创建按钮（侠客岛版权所有）

教程 > 创建按钮

创建按钮

你可以通过把矢量图形转变为按钮本体来将之变为按钮。 ( 本体是储藏在文件的库中的可重复使用的媒体元素）然后你可以在按钮编辑器里为rollover图象变换添加附加的按钮状态。在 Fireworks里，你可以为rollover图象变换的对象设计多达四种不同的按钮状态。在这里，你将创建一个在在指针掠过时替换形状的按钮。

把图形转为按钮本体

要创建一个按钮，先创建一个本题

1 | 选中形状，选择 Insert > Convert to Symbol.
2 | 在本体属性对话框，命名这个本体为MyButton.
3 | 选择按钮性质，点击OK.
 | 在画布上，注意矢量图形变化了。按钮上有一个覆盖图，表明这是一个不会出现在输出文件中的切片。一个左下角的小箭头表明该物体是库中MyButton本体的一个分身。然后你可以用圆形的行为控制点来创建一个分离的图象替换效果。
4 | 要查看库中的按钮本体，选择 Window > Library.

向按钮添加文字

你可以通过用按钮编辑器打开按钮，然后用文字编辑器添加文字。

1 | 用指针双击画布中的MyButton分身
 | 按钮编辑器出现
2 | 在工具面板中选择文字工具，然后点击按钮编辑器中的按钮的左侧。
3 | 在文字编辑器中选择Impact 字体，16-point大小和居中排列。
4 | 确认没有选中粗体和斜体等样式参数。
5 | 用字体颜色框选择橘黄色，或者你可以在编辑区域打入十六进制数值。
 | Final.png file使用的橘黄色的十六进制数值是#FF9900.
6 | 确认抗锯齿域中平滑抗锯齿和自动紧排被选中。
 | 抗锯齿平滑了文字的边缘，而自动紧排改变某些字母组合的间距，使字母看上去一个紧挨者另一个。
7 | 同样确认选中自动应用复选框（不是应用按钮）这样你可以在打字的时候在按钮上直接查看。
8 | 在文字输入框里，键入 Adventure Planner （冒险计划）点击 OK.

排列文字

要在按纽中排列文字，请使用菜单命令。

1 | 用指针选择按钮并，按住shift+点击来选择文字。
2 | 选 Modify > Align > Center Vertical.（中心对齐）
3 | 选 Modify > Align > Center Horizontal.（水平对齐）

注意： 如果渐变对于文字太亮，将按钮左边的色样向右移动，使渐变暗一些。

创建图象替换rollaover

你已经创建了按钮的up状态，即用户的指针没有触及按钮时。现在你可以使用按钮编辑器来设计按钮的 Over 状态—即指针在按钮上方时按钮的状态。

1 | 在按钮编辑器中点击 Over标签, 并点击窗口右下角的CopyUp Graphic按钮
 | Copy Up Graphic通过自行创建相近的按钮，使你不用另行创建。
2 | 用指针选中建立的按钮。在填色面板中的预设渐变中选 White, Black.
 | 注意现在的渐变颜色从白到黑。
3 | 用指针工具，点击按钮上的文字，在填色面板里在颜色框选择红色#FF3300.
4 | 选择按钮并将按钮右边的色样向左移直到渐变足够深，使文字易于辨认。
5 | 点关闭来关闭按钮编辑器。
6 | 用指针移动按钮，使对齐辅助线

记得经常存盘

通过使用按钮编辑器，你可以不用写JavaScript就能创建一个图象替换按钮。当你输出html文件时，实现替换的JavaScript也包含在html文件中。

查看按钮行为

行为面板让你能附加JavaScript行为到按钮、切片和热区，并查看他们。如果你现在查看行为面板，你会看到里面包含着图象替换行为。

选 Window > Behaviors来查看行为面板。

预览按钮

预览视窗排在你的文件窗口的左上角，显示你的文件在浏览器里的样子。原始视窗不能展示图象替换效果，但你可以在预览里看到这些动作。

1 | 在工具面板里，点击面板底部的隐藏切片按钮来隐藏绿色的覆盖物。
2 | 点击预览视窗
3 | 移动指针掠过Adventure Travel（冒险旅行）按钮来查看图象替换效果。

注意：使用预览的另一个方法是，选择 File > Preview in Browser, 然后选择一种浏览器，浏览器会显示一个你的文件的临时版本。

创建单个本体的多个分身

你将会看到将可重复使用本体储藏在库中的好处：你不用再重复创建更多按钮。相反，你可以从库中将按钮主体拖到画布里成为两个分身。然后你可以修改两个分身的文字而不影响原始的本体。

1 | 点击 Original标签，离开预览视窗
2 | 在库面板中，选择 MyButton将它拖到画布中成为一个新的分身，放在原有的Adventure Planner（冒险计划）按钮，这样他吸附在辅助线上。
3 | 拖相同按钮的另一个分身，并放在第二个按钮的边上。（小心不要拖行为控制点）利用辅导线排齐这些按钮。
4 | 选中第二个 MyButton分身, 查看对象面板(如果对象面板没有显示，选择Window > Object ). 选择文本框中的文本，并替换为 Check Conditions. 按回车
5 | 一个对话框会问你编辑该按钮的所有分身还是当前分身。选（当前）Current.
6 | 对最后一个按钮重复第4步和第5步, 这次文字改为 Travel Log（旅行日志）.
7 | 使用预览视窗来查看你的按钮，完毕后返回原始视窗。

向按钮分配URLs

按钮通常提供导航功能，要定制每个按钮的链接，你可以使用链接向导。

1 | 在画布上, 选择 Adventure Planner按钮, 点对象面板上的链接向导
2 | 在链接向导对话框的链接域弹出菜单的最上行键入 compasssite/adventureplanner/index.html 点击OK.
3 | 选择 Check Conditions按钮，并用链接向导分配到URL compasssite/checkconditions/index.html.
4 | 选择 travellog 按钮，并用链接向导分配到URLcompasssite/travelog/index.html.

你可以在稍后输出文件后测试这些链接。


导入和修改位图图形（侠客岛版权所有）

教程 > 导入和修改位图图形

导入和修改位图图形

到现在为止，你已经在矢量模式下操作过了。Fireworks还提供了用于创建、导入和修改位图图象的特性。你可以象对矢量图形一样，对位图图形加特效。另外，你修改和删除位图中的颜色。

在本教程，你可以使用导入的位图来建立或修改分离的图象替换rollovers—即鼠标掠过一处区域时，在另一个区域图象对应变换。

增加层

层提供了象重叠透明薄片一样在文件中管理对象的的方法

注意：如果你很熟悉 Photoshop 请注意 Photoshop的层和Fireworks里的意思不同, 在Fireworks中，对象是任何你导入或创建的东西，比如矢量图形，你可以把对象放在层上。

通过使用层，你可以轻松修改层上的对象而不影响其他对象。层也提供了管理媒介单元的方式，比如把所有按钮放在同一层里，而位图放在另一个层里。

现在你可以添加一个新层，并命名它，然后导入两个位图在层上以作好创建分隔的图象替换.

1 | 如果层面板不可见，选择 Window > Layers, 或点击你文件窗口右下角启动栏的显示层按钮。
 | 注意本教程的例子有5个层，包括一个默认的网络层，用来放置网络对象。你可以使用打开/关闭按钮来显示或隐藏层上的对象列表。你还可以点击显示/隐藏按钮来隐藏一个层。
2 | 选择 Insert > Layer, 或在层面板上点击新建/复制层按钮。
3 | 要命名一个层，双击面板中一个已有的名字。
4 | 在出现弹出菜单的层的名字域里，键入 Disjoint Rollover Art. 注意影格间共享没有选中，然后点击画面任何部位来关闭该菜单。
5 | 在层面板中，确认网络层隐藏，绿色的切片不可见，你可以用网络层的显示/隐藏按钮来隐藏该层。

注意：当你完成对层上所有对象的设置并满意后，可以通过点击层的锁定和解锁来防止不小心的改变。

增加影格

在浏览器中，rollover 图片替换会用一个图片快速代替另一个。Fireworks用影格来实现这样的功能。

当分隔的轮换图象效果，将一个图片替换同一位置另一个图片时，你必须为这些图片都单独设一个影格，稍后，你可以用拖放行为来确定你所加的影格对应的行为。

要创建一个分隔的轮换图象效果，你可以添加两个新影格，然后将位图图象输入对应的影格。

1 | 选中所有分隔的轮换图象效果的层，打开影格面板 (选 Window > Frames, ).
 | 注意： 你可能觉得奇怪，影格面板显示只有一个影格，而你按钮的效果需要两个影格：一个对应up状态，一个对应over状态。只有当按钮是激活状态下，才会在影格面板中显示。
2 | 选 Insert > Frame,或在影格面板里弹出菜单里选新建/复制影格
3 | 在影格面板里，双击 Frame 2（你新加的影格） 并命名为Check Conditions.
4 | 选Insert > Frame 命名为 Travel Log.

导入第一个位图图形

Fireworks 提供了多种不同方法来向文件添加原有的位图图形, 包括剪切和粘贴, 拖放, 导入—你现在用的方法.

1 | 选中层面板里的分隔的图象轮换，并且Check Conditions影格在影格面板中被选中，选择 File > Import.
 | 画布只显示第二个影格（Check Conditions）的对象。
2 | 在导入对话框中，找到Fireworks文件夹下 Tutorial\Start\Assets双击 Check_Cond.png.
3 | 移动导入指针到从上数下来第3根辅助线和画布左边边缘交界处，如下图所示，点击导入新图象。

导入第二幅图

现在，在第3影格，你可以导入和 Travel Log按钮相关联的位图图形。

，以及
1 | 选中你的分隔图象轮换 Travel Log 影格,选File > Import.
2 | 在导入对话框中，找到Fireworks文件夹下 Tutorial\Start\Assets双击 Trav_Log.png.
3 | 把指针移到你导入上一幅图的地方，点击导入新图。

删除相似颜色并修正颜色

当你导入关联Check Conditions按钮的图形后, 你可能会注意到它的颜色有点过于亮了。因为暗一些的颜色会和周围的环境更匹配，你可以删除白色，然后用色彩修正来换成暗色。魔术棒工具可以让你删除一片相近的色块。

1 | 在影格面板里，选Check Conditions影格.
 | 分隔图象轮换层应该在层面板中被选中。
2 | 双击魔术棒打开工具选项面板。
3 | 用容差滑钮调到15，并在边缘弹出菜单里选中抗锯齿。
 | 较低的容差设置使魔术棒选择更接近所选颜色的邻近颜色。抗矩尺使锯齿状的线条平滑。
4 | 使用魔术棒，点击画布中图象右边的白色区域。
 | 画布周围的条纹框表示你是在位图模式。图中白色区域被选中。
5 | 按Backspace (Windows) or Delete (Macintosh), 选 Edit > Cut 来删除白色
6 | 选 Modify > 离开位图模式。
7 | 用指针，点选位图图形。
 | 不要双击，不然你会回到位图模式。
8 | 在特效面板里，选从弹出菜单里 Adjust Color > Color Fill
9 | 在特效面板里的色彩框，选择棕色 ( Final.png 的棕色16进制值为 #CC6600).
10 | 移动染色滑钮到 35% 回车。
 | 注意位图有了较深的色调。

添加阴影

1 | 选中位图，在特效面板里，在特效弹出菜单里选Shadow and Glow > Drop Shadow
2 | 移动距离滑钮到10，在面板外点一下。
 | 距离滑钮确定阴影的位置和宽度。

用历史面板自动操作任务

对和Travel Log按钮对应的位图，你也需要做颜色修正和加阴影，但与其重复操作，你不如使用历史面板来自动操作重复的任务。

1 | 在影格面板里，选旅行日志影格。
2 | 用指针选择Travel Log image (笔和地图那张) 。
3 | 选Window > History.
4 | 在历史面板的命令列表里，点击最后的设置特效，再按 Shift-click点倒数第二个设置特效。
5 | 点击历史面板的Replay注意Fireworks如何执行命令来修改你的图形。

记得常存盘哦。


创建一个分隔的图象轮换（侠客岛版权所有）

教程 > 创建一个分隔的图象轮换

创建一个分隔的图象轮换

要创建一个分隔的图象轮换，每个组成部分必须和一个切片对象关联，切片对象显示在你文件的网络层上。你可以为位图文件建立一个切片，然后用拖放行为来建立一个分隔的图象轮换。

插入一个切片

因为图象轮换的每个对象都必须是一个切片对象，所以你要向图象加切片。

1 | 在影格面板里选择Check Conditions影格.
2 | 在画布上，用指针选中手持望远镜的图象，并选 Insert > Slice.
 | 在画布上，位图图象上出现绿色的覆盖物，代表一个切片。层面板在网络层包括一个切片。

拖放来创建一个分隔的图象轮换

要将一个图象和按钮关联，你只要简单的将指针从按钮的行为控制点拖到将在效果中出现的图象的切片上即可。

1 | 用指针选择Check Conditions按钮。
2 | 点击Check Conditions 按钮中心的行为控制点，拖到你导入的图象上的切片。
 | 一根蓝线，行为线吸附到切片上，表示两个切片是关联的，图象翻转对话框出现。
3 | 在对话框中，确认你要翻转显示的是 Check Conditions影格的图象, 点击OK.
 | 就这样你创建了一个分隔的图象轮换。

记得常存盘。

增加最后的分隔图象轮换

你要对Travel Log按钮完成相似的步骤。

1 | 在画布上，选 Travel Log按钮, 将按钮中心的行为控制点，拖到你导入的图象上的切片。
2 | 在对话框中，选 Travel Log (影格 3)作为翻转图象, 点击OK.
3 | 点击预览视窗，并将指针掠过按钮查看效果。然后返回原始视窗。
 | 编译： Flashcat


输出Fireworks文件为HTML（侠客岛版权所有）

教程 > 输出Fireworks文件为HTML

输出Fireworks文件为HTML

祝贺你完成了Fireworks文件的制作。下一步，你要将文件输出为可以将文件输出以在浏览器中显示。 Fireworks 支持输出多种不同网络或印刷格式；你应该输出为 HTML。注意输出过程不会修改你的 PNG 文件—只要你愿意，你仍可以用你的 PNG 再次修改和输出

输出文件

要输出文件，你可以使用输出对话框。

1 | 保存文件，并选File > Export.
2 | 在输出对话框，找到Fireworks文件夹下的 Tutorial\Start\Export子目录
 | 在文件名框内，请注意你的HTML文件名默认是和你的PNG文件同名。
3 | 在切片弹出菜单里，选中Export Slices
 | 只有选中 Export Slices 才能保证你的按钮在HTML文件中有效。
4 | 选择将图片放在子目录里。
 | Fireworks将创建一个子目录来放置你所有的图片文件。
5 | 点击选项，并确认HTML 样式菜单里选中了 Dreamweaver，点击 OK.
6 | 在输出对话框中，点Save.

在浏览器里查看你的输出文件

输出的新文件在你的Export子目录里。

1 | 浏览到 Tutorial\Start\Export目录并打开。
2 | 注意 Fireworks 创建了HTM文件，如果你打开Images子目录，你可以看到Fireworks也创建了你作品的图象文件。每个切片都输出了一个独立的图象文件。
3 | 在输出文件夹里，打开MyFile.htm 浏览
4 | 在浏览器里，点击按钮来测试链接，并用浏览器的后退按钮退回 MyFile.htm。
5 | 测试你作品的其他性能。
6 | 大多数浏览器让你用View > Source查看原文件。找到这个命令并试一下。
7 | 查看原代码，如果你懂得 JavaScript，你能辨认出Fireworks替你写的JavaScript. 如果你不懂 JavaScript，你也一定很高兴，有了Fireworks使你没必要非得学 JavaScript了。
 | 编译： Flashcat


结合使用Fireworks和Dreamweaver（侠客岛版权所有）

教程 > 结合使用Fireworks和Dreamweaver

结合使用Fireworks和Dreamweaver

如果你有兴趣学习如何结合使用，一定要学习 Fireworks和 Dreamweaver 教程。它指导你结合使用 Dreamweaver 和Fireworks 来编辑, 优化和将图形放在 HTML页里的基础。你将可以学习到如何在 Dreamweaver文件里导入 Fireworks图象和表格，同时你可以利用 Dreamweaver的编辑工具来修改文件。你还可以学到如何使用独特的启动-编辑特性，让你在Dreamweaver中直接使用Fireworks来编辑或优化放在页面中的Fireworks图片或切片，并将更新完整地带回Dreamweaver。要学习 Fireworks 和 Dreamweaver 教程, 到 http://www.macromedia.com/support/dreamweaver/programs.html.


Fireworks概述--蓝骑士（侠客岛版权所有）

Fireworks基础 > Fireworks概述

Fireworks概述

Fireworks是一款用于网络图像设计和艺术处理的优秀应用软件.它最大的优点在于解决了图像设计和网络应用的关键问题.

Fireworks又是一个多才多艺的图像和网页设计工具.它强大的工具套餐使您在这一个软件里,可以获得其他矢量图像处理软件和位图图像处理软件所拥有的一些最好功能.您可以自由的在Fireworks中编辑对象,对它们进行位图效果的处理,例如添加斜角,光晕,阴影等,或者应用Photoshop的滤镜效果----当您在编辑的时候,这些效果会自动的实时添加,你可以随时看到添加后的图像效果.

Fireworks的出现使得网页设计师处理网络图像时,能从费力的在一大堆图像处理软件间切换来切换去中解放出来.在图像的编辑过程中,设计师可以随时观察图像的效果,随时返回以前的操作,非常的便捷.它的图像优化功能使得创作的图像既能获得满意的品质又能进行适当的压缩,从而适合网络的传输和显示.

蓝骑士编译


设置属性--蓝骑士（侠客岛版权所有）

Fireworks基础 > 设置属性

设置属性

Fireworks的属性设置用于设置用户界面的一般显示状态,包括一般属性,编辑属性,文件夹属性等的设置.

设置属性:

1 | 选择菜单 Edit > Preferences(编辑 > 属性).
2 | 选择您需要定义或修改的属性. (参看下面的属性设置细节.)
3 | 修改后点击确定.

设置一般属性

一般属性设置包括恢复步数,默认色彩和放缩插值.

恢复步数

在0-1009间设置您的恢复步数. 这一设置对文件的可返回次数有影响.

恢复步数设置的越多,Fireworks需要的临时文件缓存空间就越大.

默认色彩

为笔刷,笔触,填充和高亮路径显示设置默认色彩值.

放缩插值

通过设置下列四种方式中的某一种,决定图像在放缩过程中选用哪种插值方式:

Bicubic(双三次)插值绝大部分时候可以给出最好的显示品质,这也是默认的插值方式.
Bilinear(双线性)插值给出一个比柔和插值好的效果,但不及双三次插值.
Soft(柔和)插值,这种方式最早在Fireworks 1中使用,在放缩过程中通过soft插值使图像看上去比较柔和,不至于出现很多锯齿现象.这种方法在一些不需要艺术加工的基本图形放缩时比较实用,例如实色块.
Nearest Neighbor(临近)插值消除图像放缩过程出现的锯齿化现象,但不对图像进行柔化,这种方式的效果和使用工具面板中的放缩工具来放大显示图像编辑区域的效果类似.

蓝骑士编译


设置编辑属性--蓝骑士（侠客岛版权所有）

Fireworks基础 > 设置属性 > 设置编辑属性

设置编辑属性

编辑属性用于设置鼠标的显示效果和位图编辑模式的视觉提示.

精确十字鼠标

选择某项工具时,使用十字鼠标符号替换原来的工具符号,常用于精确定位.

剪切文件时删除对象

彻底的删除所选择对象或区域外的对象和图像.选择菜单 Edit > Crop Document(编辑 > 剪切文件) 或 Modify > Canvas Size(修改 > 画布尺寸).

笔刷鼠标形状设置

设置笔刷或橡皮擦的鼠标形状尺寸和形状,使得与工具的属性相一致,例如圆形的橡皮擦以空心圆形鼠标形状来表示,帮助您更精确的使用工具.

扩展位图编辑区域

选中该项,切换到位图编辑模式时,整个文件窗口都是可编辑的.不选该项,只有选中的对象在位图编辑模式可以修改,其他未选中的对象不会被修改.

文件打开为位图模式

选中该项,任何图片在Fireworks中打开时,首先进入位图编辑模式.不选该项,所有图片打开时进入矢量图编辑模式.

关闭"隐藏边界"

在进入或离开位图编辑模式自动关闭"隐藏边界".

(隐藏边界:当对象选中时,对象边缘有选中提示,也就是边界,当"隐藏边界"有效时,选中对象,对象边缘没有选中提示)

显示斑纹边界

进入位图编辑模式自动打开斑纹边界提示.

选中距离

让您决定当鼠标离一个对象多近的时候您可以选中该对象.选中距离的调节范围为1-10个像素距离.

吸附距离

让您决定一个对象在拖动过程中,距离网格或轨迹线多近的时候可以被吸附,吸附距离只有在 网格吸附(Snap to Grid) 和 辅助线吸附(Snap to Guides) 打开时才有效.吸附距离的调节范围为1-10个像素距离.

蓝骑士编译


设置启动和编辑属性--蓝骑士（侠客岛版权所有）

Fireworks基础 > 设置属性 > 设置启动和编辑属性

设置启动和编辑属性

您能够设置,当在Dreamweaver中对图像进行编辑和优化时是否打开Fireworks的图像原始格式PNG.

当使用外部应用程序编辑图像时

当您使用Dreamweaver或其他的HTML编辑器编辑图像时,是否打开Fireworks来处理原始的PNG格式图像.

当使用外部应用程序优化图像时

当您使用Dreamweaver调用Fireworks的优化图像命令时,是否打开原始的PNG格式图像.

更多详细请参看在Dreamweaver中对Fireworks对象进行处理. 在Dreamweaver中编辑Fireworks文件.

蓝骑士编译


管理扩展文件夹和缓存磁盘--蓝骑士（侠客岛版权所有）

Fireworks基础 > 设置属性 > 管理扩展文件夹和缓存磁盘

管理扩展文件夹和缓存磁盘

扩展文件夹属性可以让您建立Fireworks调用外部文件夹的路径,这些文件夹中可以包含Photoshop的插件,或者是需要使用的更多纹理文件,图案文件.缓存磁盘属性让您定义在哪一个磁盘存放Fireworks的临时文件.

扩展资源(Photoshop插件,纹理,图案)

目标文件夹包含有Fireworks可以调用的扩展资源:插件,纹理和图案(plug-ins, textures, patterns).扩展资源可以存放在硬盘,光盘,外部存储磁盘或网络存储介质.

Photoshop插件出现在Fireworks菜单 扩展(Xtras) 和效果面板(Effect).
以PNG文件格式保存的纹理和图案使用时出现在填充面板(Fill)的图案和纹理旁的下拉菜单选项里,和笔触面板(Stroke)的纹理旁的下拉菜单选项里.

更多信息请参看 使用Fireworks扩展功能创作效果 和 使用Photoshop插件创作效果.

缓存磁盘(主缓存磁盘和从缓存磁盘)

用于定义Fireworks的临时文件缓存在哪个磁盘,有时候这样的临时文件是比较大的.如果您有两个以上磁盘分区,您可以决定其中有较大空余空间的磁盘为主缓存磁盘.当主缓存磁盘没有空间,Fireworks会将临时文件放置在从缓存磁盘.

蓝骑士编译


设置导入Photoshop文件属性--蓝骑士（侠客岛版权所有）

Fireworks基础 > 设置属性 > 设置导入Photoshop文件属性

设置导入Photoshop文件属性

该属性用于解决Photoshop文件导入时的一些转换问题.(详细请参看有关章节)

蓝骑士编译


改变键盘快捷键设置--蓝骑士（侠客岛版权所有）

Fireworks基础 > 设置属性 > 改变键盘快捷键设置

改变键盘快捷键设置

Fireworks允许您使用键盘快捷键来调用某些命令,在工具面板选择工具,帮助完成一些简单的动作,从而大大提高您创作的效率.如果您已经使用过FreeHand, Illustrator, Photoshop, 或其他使用Macromedia标准的应用程序,您可以通过快捷键设置定义自己习惯的快捷键方式.

改变当前快捷键设置:

1 | 选择菜单 Edit > Keyboard Shortcuts(编辑 > 快捷键设置).
2 | 选择您希望改变的快捷键.
 | (快捷键对话框)

蓝骑士编译


创建自定义快捷键--蓝骑士（侠客岛版权所有）

Fireworks基础 > 设置属性 > 创建自定义快捷键

创建自定义快捷键

您能够创建自定义的快捷键.自定义前,请先复制一个已经存在的方案,然后在复制的方案上进行修改.快捷键的定义遵循以下的原则:

菜单命令必须包括Control键(Windows操作系统)或Command键(Macintosh操作系统)的组合键.
注: 例外的是您可以使用F2-F12键直接定义菜单命令.
在Fireworks中, 工具的快捷键不能包括修饰键Control, Shift, Alt(Windows操作系统),Command, Shift, Option, 和 Control(Macintosh操作系统). 工具快捷键由单个字母或数字组成.

为菜单,工具或其他命令创建快捷键:

1 | 选择菜单 Edit > Keyboard Shortcuts(编辑 > 快捷键设置),打开快捷键对话框.
2 | 点击方案旁的复制小按钮.
3 | 在复制弹出对话框键入新的自定义快捷键方案的名字,点击确定.
 | 此时新的快捷键方案名字出现在方案选项框.
4 | 从命令列表框中选择需要改变的类.
 | 选择 菜单命令(Menu Commands) 为总菜单里的命令创建自定义快捷键.
 | 选择 工具(Tools ) 为工具面板的工具创建自定义快捷键.
 | 选择 其他命令(Miscellaneous) 为其他命令创建自定义快捷键.
 | 一旦选中某一个类,该类可以设置快捷键的命令在下面的命令列表中显示.
5 | 从这个命令列表中选择您需要改变的某个快捷键.
 | 如果此时快捷键已经存在,快捷键键值在快捷键键值列表中显示.
6 | 在键值输入框用键盘键入您需要的新的快捷键.(可以是组合键)
7 | 点击 更改(Change) 按钮.完成设置.

蓝骑士编译


创建候选快捷键--蓝骑士（侠客岛版权所有）

Fireworks基础 > 设置属性 > 创建候选快捷键

创建候选快捷键

如果您希望能用几种方式不同方式调用需要的命令,您可以创建候选快捷键.候选快捷键出现在快捷键列表中已经存在快捷键键值下方.同时你也可以在这个快捷键键值列表中为一个没有快捷键的命令创建新的快捷键.

创建候选快捷键或新的快捷键:

1 | 重复上一页的1-6的步骤.
2 | 点击添加快捷键(+)按钮.
3 | 键入您需要的快捷键.

蓝骑士编译


删除自定义快捷键或自定义快捷键方案--蓝骑士（侠客岛版权所有）

Fireworks基础 > 设置属性 > 删除自定义快捷键或自定义快捷键方案

删除自定义快捷键或自定义快捷键方案

您可以方便的删除自定义快捷键或自定义快捷键方案.

删除自定义快捷键方案:

1 | 打开键盘快捷键对话框.
2 | 点击删除方案按钮.
3 | 在删除快捷键方案对话框的列表中选择您希望删除的快捷键方案.
4 | 点击删除按钮.

删除自定义快捷键:

1 | 在快捷键键值列表中选择希望删除的快捷键.
2 | 点击删除按钮(-).

蓝骑士编译


为当前的快捷键方案创建参考表--蓝骑士（侠客岛版权所有）

Fireworks基础 > 设置属性 > 为当前的快捷键方案创建参考表

为当前的快捷键方案创建参考表

快捷键方案的参考表以HTML的表格格式保存.您可以在网页中查看该参考表或打印输出.

创建参考表:

1 | 打开快捷键对话框.
2 | 点击方案列表旁的以HTMl格式输出参考表按钮.
 | 此时弹出保存文件对话框.
3 | 为参考表取个名字并保存在合适的位置.
4 | 点击 保存(Save) 按钮.

蓝骑士编译


关于矢量图和位图--蓝骑士（侠客岛版权所有）

Fireworks基础 > 关于矢量图和位图

关于矢量图和位图

计算机能以矢量图(vector)或位图(bitmap)格式显示图像.理解两者的区别能帮助您更好的提高工作效率.Fireworks可以让您在一个软件中使用矢量图或位图工具创作图像,或者导入和处理其他应用软件生成的矢量图和位图文件.Fireworks提供了位图编辑模式和矢量图编辑模式.

矢量图

矢量图使用线段和曲线描述图像,所以称为矢量,同时图形也包含了色彩和位置信息.下面例子中的树叶,就是利用大量的点连接成曲线来描述树叶的轮廓线.然后根据轮廓线,在图像内部填充一定的色彩.

当您进行矢量图形的编辑时,您定义的是描述图形形状的线和曲线的属性,这些属性将被记录下来.对矢量图形的操作,例如移动,重新定义尺寸,重新定义形状,或者改变矢量图形的色彩,都不会改变矢量图形的显示品质.您也可以通过矢量对象的交叠,使得图形的某一部分被隐藏,或者改变对象的透明度.矢量图形是"分辨率独立"的,这就是说,当您显示或输出图像时,图像的品质不受设备的分辨率的影响.在例子中,右图是放大后的矢量图形,我们看见图像的品质没有受到影响.

位图

位图使用我们称为像素的一格一格的小点来描述图像.您的计算机屏幕其实就是一张包含大量像素点的网格.在位图中,上面我们看到的树叶图像将会由每一个网格中的像素点的位置和色彩值来决定.每一点的色彩是固定的,当我们在更高分辨率下观看图像时,每一个小点看上去就像是一个个马赛克色块,如下面例子中的右图.

当您在进行位图编辑时,其实您是在一点一点的定义图像中的所有像素点的信息,而不是类似矢量图只需要定义图形的轮廓线段和曲线.因为一定尺寸的位图图像是在一定分辨率下被一点一点记录下来,所以这些位图图像的品质是和图像生成时采用的分辨率相关的.当图像放大后,会在图像边缘出现锯齿现象.当在低于图像创作分辨率的设备上进行图像输出时,图像的品质会相应降低.

蓝骑士编译


恢复和重复动作--蓝骑士（侠客岛版权所有）

Fireworks基础 > 恢复和重复动作

恢复和重复动作

使用历史面板(History),您可以显示,修改和重复创作过程中进行的操作.在历史面板列表中罗列了您在Fireworks最近完成的一些操作,最大总数等于您在恢复属性中设置的恢复步数.利用历史面板,您可以:

使用标记块快速的恢复或重复到您最近的动作.
从列表中选择一些您最近的动作然后点击 重复(Replay) 按钮重复选中的动作.
保存列表中一系列动作为自定义的一个命令,然后在命令菜单中选择该命令进行重现.更多信息参看 利用历史面板创建命令和脚本.

恢复和重复动作:

1 | 选择菜单 Window > History(窗口> 历史),打开历史面板.
2 | 鼠标上下拖动标记块.

重复动作:

1 | 如果命令是针对对象的,请先选中对象.
2 | 在历史面板中,高亮显示的动作和命令可以被重复. 鼠标+shift键复选可以高亮选中一系列动作.
3 | 点击历史面板底部的 重复(Replay)按钮.

保存自定义动作:

1 | 在历史面板高亮选中以后需要使用的动作.
2 | 点击面板底部的 保存(Save) 按钮.
3 | 键入一个的名字,为动作命名.点击确定,Fireworks将自定义动作自动加入菜单 Command(命令) 的子菜单中.

使用已经保存的自定义动作:

从菜单 Command(命令)的字菜单中选择自定义的动作名.

蓝骑士编译


关于Fireworks的工作流程--蓝骑士（侠客岛版权所有）

Fireworks基础 > 关于Fireworks的工作流程

关于Fireworks的工作流程

Fireworks可以完成矢量图像和位图图像的创建,在文件中添加网页特效,例如图像翻转,弹出菜单,对图像进行优化处理,或者使用批处理自动生成图像等工作.

当图像制作完成,如果您希望在网页中直接应用,您可以输出Fireworks生成的HTML文件.如果您还需要对图像使用其它工具再处理,您也可以单独输出图像文件,作为Photoshop和Illustator等图像处理软件的素材文件使用.

创建图像

Fireworks可以让您在矢量图模式和位图模式进行图像编辑.在矢量图模式,您绘制和编辑的是路径(线段和曲线);在位图模式,您编辑的是像素点.

您可以选择工具面板(Obeject)上的相应工具在画布上创建新的矢量图对象或位图图形.在每一个编辑模式,都有自己对应的一套工具.有些工具仅仅适用一种模式,有些则是通用的.某些两种模式通用的工具有时候操作上会略有不同.

创建网页对象

网页对象是在页面交互中使用到的一些基本的操作区域.切片工具(Slice)可以把一幅完整的图像切割成不同的切片对象,并使您能在这些切片对象上添加动作,动画或URL链接(Uniform Resource Locator 全球资源定位).切片同时又允许您在输出时对不同的切片进行不同的属性设置,例如输出不同的文件格式.热区工具(Hotspot)是另一个网页对象创建工具,它可以使您方便的在一幅图像的整体或部分定义URL链接响应区域,添加交互功能.

优化

您可以在Fireworks中对图像进行优化处理,以减小文件大小,使图像在网络中快速被下载.Fireworks提供了强大的图像优化功能.通过图像优化,您可以在保证一定输出品质的前提下获得较小的文件大小.

例如,在某些场合您可以减少照片的色彩数量来减小文件大小,或者通过不同的切割,对每一个切片进行优化设置,以减小总文件的大小.

输出文件

当您完成图像的优化后,您可以按照一定格式输出图像.这些输出的图像可以直接被应用于网页,或者作为其他图像处理程序的素材文件.无论您选择哪种输出格式,源(图像)文件都会以Fireworks默认的PNG格式保留,不会因为输出而改变.您可以使用同一个源文件根据不同应用需要输出多个不同格式,品质和大小的图像.

您也可以在输出时再选择优化图像(而不一定非要先优化再输出图像).当输出图像时,使用输出预览选项,所有的优化属性都可以使用.

蓝骑士编译


关于Fireworks的工作环境--蓝骑士（侠客岛版权所有）

Fireworks基础 > 关于Fireworks的工作环境

关于Fireworks的工作环境

打开Fireworks4,首先看到的界面是:

屏幕上方的文件菜单栏;屏幕左方的工具面板;屏幕右方一些多个小面板复合的面板.当您新建或打开一个文件时,Fireworks会在屏幕的中部放置一个文件窗口.

蓝骑士编译


显示Fireworks文件--蓝骑士（侠客岛版权所有）

Fireworks基础 > 显示Fireworks文件

显示Fireworks文件

在文件窗口,标题栏显示了文件的名字和当前的显示放大率.标题栏下的四个标签,代表了四种不同的显示方式:源文件(Original)标签表示显示和编辑当前文件,其余的三个标签用于输出预览.

自左至右:源文件(Original),预览(Preview),2窗口(2-Up),4窗口(4-Up)

显示源文件的PNG图像:

点击文件窗口源文件(Original)标签显示源文件的PNG图像.

预览文件

预览(Preview)标签里显示图像输出的效果,效果由输出设置决定.2窗口,4窗口用于在多个窗口对几种不同输出设置的效果进行对比,在各个窗口中显示了图像优化后的预显示效果.

预览:

点击文件窗口预览,2窗口,4窗口标签预览输出图像效果.

使用优化面板(Opitimize)和调色板面板(Color Table)可以改变输出设置.这些面板和文件窗口与上一个版本的Fireworks是一致的.

在预览时,您可以检测动画,图像翻转,导航栏等效果.

蓝骑士编译


显示和选择工具--蓝骑士（侠客岛版权所有）

Fireworks基础 > 显示和选择工具

显示和选择工具

Windows操作系统下的Fireworks包括了工具面板(panel)和工具栏(toolbars).Macintosh操作系统下仅有工具面板.

工具面板包含了您用于图像创建,选择和编辑的所有工具.在Windows操作系统中,工具栏分为主工具栏(Main toolbars)和修改工具栏(Modify toolbars),分别提供了许多命令的快速引用.

工具面板(Object)包含了许多创作工具.有一些工具包含在一个工具组中,如上图展开显示的.工具面板中,右下角带有箭头的图标表示这是一个工具组.

点击工具面板上的某个工具可以选中该工具.或使用快捷键从某一个工具快速切换到其他工具.相关快捷键的更多信息请查看 改变快捷键设置.

注:您可以把鼠标放在工具上,稍刻可以看见该工具的提示文字,文字中工具名称后的键盘符号即是对应快捷键.

从工具组中选择工具:

1 | 在右下角带有小箭头的工具上按下鼠标,您看到弹出的工具组选项
2 | 此时拖动鼠标到您需要的工具上,放开鼠标,您所选择的工具就将被选中并出现在工具面板上

注:某一些工具的出现由文件当前处于位图编辑模式还是矢量图编辑模式决定,例如橡皮擦和小刀.

重置工具栏 (只有Windows操作系统可用)

您可以显示和隐藏工具栏,或者把他们独立为浮动面板放置屏幕的某个地方,也可以选择放置在Fireworks软件窗口的上部或底部.

显示和隐藏工具面板和工具栏:

调用主工具栏:选择菜单 Window > Toolbars > Main(窗口 > 工具栏 > 主).

调用修改工具栏:选择菜单 Window > Toolbars > Modify(窗口 > 工具栏 > 修改).

如果工具栏浮置在屏幕(浮动面板状态),您可以通过右上角的小按钮关闭工具栏.

将工具栏浮置:

拖动工具栏上的空白区域,您可以将工具栏浮置为浮动面板.

工具栏嵌入:

1 | 将浮置的工具栏放置在文件菜单的下方
2 | 双击工具栏的标题栏,工具栏嵌入软件窗口

蓝骑士编译


改变工具选项--蓝骑士（侠客岛版权所有）

Fireworks基础 > 显示和选择工具 > 改变工具选项

改变工具选项

工具选项面板(Tool Option)显示了与当前选择的工具相关的一些选项.例如指针工具(Pointer)的工具选项包括了鼠标掠过对象边缘高亮显示,拖动预显示,和显示填充控制柄等.

显示和隐藏工具选项面板:

在工具面板双击该工具.
选择菜单 Window > Tool Option(窗口 > 工具选项).

蓝骑士编译


使用面板--蓝骑士（侠客岛版权所有）

Fireworks基础 > 使用面板

使用面板

面板是一些浮动在屏幕上的控制板,用于帮助您对选择的对象进行属性的编辑.面板还可以对影格,层,对象,色样板等文件属性进行编辑.例如,您可以使用效果面板(Effect)为选中的对象添加效果.

每一个面板都是可以拖动的,所以您可以在屏幕上自由的进行自定义的面板排布.

最小化装载器(Mini-Launcher):在文件窗口的右下角,包含了一些您经常使用的面板的切换图标,这些面板包括:笔触(Stroke),层(Layer),动作(Behaviors)和优化(Optimize)等,通过点击图标切换面板.(注:请区分软件窗口和文件窗口)

对象(Object),笔触(Stroke),填充(Fill)和效果(Effect)面板包含了对象的大量属性设置.

混色器(Color Mixer)和色样(Swatches)面板用于管理当前图像的调色板.

层(Layers)和影格(Frames)面板用于组织文件的结构,包括创建,删除,复制层和影格等多项命令.影格面板用于创建动画图像.

动作(Behaviors)面板用于管理和编辑热区和切片的对应动作.

历史(History)面板列表了您最近完成的一些操作,您可以方便的恢复到历史面板上的以前的步骤.您也可以选择需要的命令进行操作重复,或者保存经常使用的几个动作为单个命令使用.

库(Library)面板包括图片符号(Graphic),按钮符号(Button)和动画符号(animation).您可以简单的把这些符号从库中拖动到文件窗口形成符号的实例(Instance).如果对一个符号进行修改,将同步更新文件窗口中所有该符号形成的实例.

优化(Optimize)面板用于优化文件输出大小和文件输出格式.

项目日志(Project Log)用于对选择的文件进行与上一次相同的输出处理,利用项目日志,您可以对一些需要经过相同处理的文件进行批处理.

信息(Info)面板提供了您所选中的对象的长,宽,x,y坐标等信息,同时,当鼠标在画布上移动时,也能观测所经过点的色彩和坐标信息.

工具选项(Tool Options)面板用于调整当前所选择的工具的基本属性.

样式(Styles)面板用于定义对象或文字的样式效果.Fireworks向用户提供了一些已经完成的样式进行选择,同时您也可以通过网络下载等途径扩展您的样式表.

显示或隐藏面板:

从菜单 Window(窗口) 中选择面板.

所有的面板都有弹出菜单选项

选择面板弹出菜单选项:

1 | 点击面板右上角小箭头,弹出对应的选项菜单
2 | 选择其中您需要的命令

有一些面板上的控制也隐含一些菜单,色彩对话框,滑块,对话框等的选择.例如对象面板(Object)的透明(Transparent)选项后的滑块用于调整对象的透明程度.

使用某些控制隐含的弹出菜单选项:

1 | 点击某项控制旁的下箭头.
2 | 改变选项值:
 | 选择一个选项或色样.
 | 拖动滑块,改变数值.
 | 在键盘上选择您需要查找的选项的第一个字母键击,重复,直到找到您需要的命令

在面板的文本框输入信息:

1 | 点击文本框.
2 | 输入值.
3 | 按 Enter 键完成输入.

组合多个面板:

1 | 拖动一个浮动面板的标签到另一个浮动面板,当出现高亮边框时,释放鼠标.例如拖动笔触面板(Stroke)标签到色彩面板(Color).您可以看见,两个面板组合在一个面板集合中.
2 | 点击某一个面板的标签可以使之当前显示.

从面板集合中移出一个面板:

面板集合也就是某几个面板的集合体.拖动面板集合内某个面板的标签可以将面板放置在面板集合外.

隐藏单个面板(面板单独浮置状态)或面板集合:

点击单个面板(面板单独浮置状态)或面板集合窗口右上方的 X(关闭) 按钮.

隐藏所有面板或显示所有隐藏的面板:

选择菜单 View > Hide Panels(显示 > 隐藏面板).
注: 选择隐藏面板,面板隐藏,再次选择,面板显示.

恢复面板的初始位置:

选择菜单 Commands > Panel Layout Sets > 1024 x 768(命令 > 面板版面设置 > 1024 x 768).
注: 1024 x 768代表一般屏幕显示分辨率,您也可以选择其他分辨率模式.

重新设置Fireworks的软件应用属性:

1 | 退出Fireworks.
2 | 在安装有fireworks 4的文件夹删除名为Fireworks 4 Preferences的txt文件(Windows操作系统). 在System\Preferences文件夹下删除名为Fireworks 4 Preferences的txt文件.(Macintosh操作系统)
3 | 重新启动Fireworks.

蓝骑士编译


使用快捷菜单--蓝骑士（侠客岛版权所有）

Fireworks基础 > 使用快捷菜单

使用快捷菜单

快捷菜单让您可以快速的进入与当前选择关联的命令选项.

显示快捷菜单

在文件窗口点击鼠标右键(Windows操作系统),或鼠标控制键(Macintosh操作系统).

蓝骑士编译


建立Fireworks文件概述--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 建立Fireworks文件概述

建立Fireworks文件概述

当您选择菜单"文件"->"新建"在Fireworks中创建新文件,您就创建了一个便携式网络图像(Portable Network Graphic),也就是PNG文件.PNG是Fireworks的默认文件格式.当您完成图像的制作和处理,您能够将他们以其他常用的网络图像格式输出,例如JPEG,GIF和动态GIF.当您输出时,Fireworks并不改变制作好的PNG图像,所以您能够多次使用同一幅PNG图像输出不同效果的图像.

当您打开一幅PNG图像,您能够自由的放缩显示图像进行观察.您也可以改变文件的尺寸和分辨率.您也可以通过选转画布来上下或左右翻转一幅图像.选择伽玛显示能够让您比较Macintosh操作系统或Windows操作系统下图像的显示效果.

您可以打开Photoshop, FreeHand, Illustrator, 未压缩CorelDRAW®, WBMP, EPS, 和动态GIF文件.此外,您也可以通过数码相机和扫描仪输入图像,或者将文件输出为其他文件格式,例如swf.

蓝骑士编译


多窗口显示--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 浏览和显示文件 > 多窗口显示

多窗口显示

使用多窗口可以以不同的放缩率对一个文件在多个窗口中观察比较.您在某一个窗口中对文件进行修改,其余的显示窗口会同步显示.

以不同的放缩率新开一个窗口:

1 | 选择菜单"窗口"-> "新窗口".
2 | 为新窗口设定一个放缩率.

多窗口显示窗口排列:

选择菜单"窗口"-> "水平排列"或者选择菜单"窗口"-> "竖直排列".

关闭显示窗口:

点击文件窗口右上角的关闭按钮.

蓝骑士编译


文件显示模式--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 浏览和显示文件 > 文件显示模式

文件显示模式

显示模式会影响文件在屏幕上的表达,有时表达不一定是一种真实的数据或文件品质的反映.

全显示模式会以尽可能丰富的细节来表达文件.
草稿模式用一些1像素的线条来勾勒文件,填充部分用双交叉线表示.
Macintosh 伽玛修正 (Windows操作系统) 或 Windows 伽玛修正 (Macintosh操作系统) 按照对应的其他操作系统的全屏模式来显示文件.例如您在Windows操作系统创作文件,您可以通过Macintosh 伽玛修正模式来显示文件在Macintosh操作系统的显示效果,反之亦然.

切换显示模式:

在菜单"显示"下选择全显示或相应的伽玛修正显示模式.

蓝骑士编译


改变画布--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 改变画布

改变画布

您可以在创建新图像是定义画布.在你进行创作过程中,您也可以随时修改画布.包括重新定义尺寸,色彩,改变图像分辨率等属性.此外,您还可以对话不进行旋转或裁剪,剪辑.

蓝骑士编译


改变文件尺寸,色彩和分辨率--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 改变画布 > 改变文件尺寸,色彩和分辨率

改变文件尺寸,色彩和分辨率

改变文件尺寸,色彩和分辨率在Fireworks中是一件非常容易的事.

改变文件尺寸:

1 | 选择菜单"修改"-> "画布尺寸".
2 | 点击九方格中的箭头,决定你添加或裁剪画布的方向,完成后点击确定.
 | 注: 默认选择为中心的箭头,画布的修改将从四周向中心收缩或从中心向四周扩展.
3 | 在长和宽的文本输入框中输入新的尺寸值.

改变画布色彩:

1 | 选择菜单"修改"-> "画布色彩".
2 | 从下列选项选择:
 | 白色
 | 透明
 | 自定义
 | 如果选择自定义,点击色块在弹出的色彩对话框选择您需要的色彩.
3 | 点击确定.

重新定义文件尺寸,包括文件中的所有内容:

1 | 选择菜单"修改"-> "图像尺寸". 此时弹出图像尺寸对话框.
2 | 在长和宽的文本框输入新的值.
 | 您也可以同时改变单位,不用像素单位.如果此时您没有选择重采样图像,那么图像的分辨率会受到影响.
3 | 在打印尺寸文本框输入长和宽,您也可以改变它的单位.
4 | 在分辨率文本框选择您需要的分辨率.
 | 您可以在像素/英尺和像素/厘米两者间选择合适的单位.
5 | 为了保持图像的长和宽比例固定,选中"保持比例".不选中,则长和宽的尺寸可以分别定义,两者不再有原来比例关系.
6 | 选择重采样图像用于在图像尺寸发生改变时,自动增加像素或减少像素保持分辨率.
7 | 点击确定.

蓝骑士编译


关于重定义图像尺寸--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 改变画布 > 关于重定义图像尺寸

关于重定义图像尺寸

Fireworks的重采样与其他的一些应用程序有所区别,它包含了基于像素的位图图像和基于路径的矢量对象.

当位图图像重采样时,图像会通过增加或减少像素点时文件放大或缩小.
当矢量对象重采样时,矢量对象的改变很少,这是因为路径直接通过数学计算得到,不需要增加数值或减少数值.

但是,由于在Fireworks中矢量对象仍然是以像素图像的方式显示的,所以一些笔触和填充在重采样后会发生变化,这是因为组成笔触和填充的像素发生了变化.

注: 轨迹,热点和切片也会随着图像的尺寸改变而跟随改变.

看来,对图像的尺寸重定义是个很独特的问题.到底什么时候可以在放缩图像时增加像素或减少像素,什么时候可以改变分辨率来重新调整图像大小?

您可以选择上面的其中一种方式.当您选择调整分辨率,你实际改变了像素点的单位面积分布,从而造成图像的放缩.(譬如,原来每平方厘米100个像素点,现在要提高分辨率,就要求每平方厘米400个像素点,那么图像必须收缩才可以使原来的面积获得更多的像素点.--蓝骑士注)当您选择另一种方式,您实际在增加一些原来没有的点或减少原来的点.(也就是上例中每平方厘米少的300个点是通过插值计算添加上去的.)

减少采样点或删除像素会减小文件的大小,但同时也会降低文件的品质.

增加采样点或增加像素,会增加文件的大小,品质上也会有所负的影响,这是因为添加的点并不是真正的图像反映,而是一种计算机处理结果.
上图是原始图像和减少采样点的比较(假设能上图中的减少采样点图像放大到原始图像尺寸,那么您就能看见图像品质被降低了.--蓝骑士注)

旋转画布

在一些左右反转或上下颠倒的图像,通过画布旋转修正非常的适宜.您可以旋转画布180度,顺时针90度,或逆时针90度.

当您旋转画布时,画布上的所有内容一起被旋转.

原始图像和旋转180度的图像比较

旋转画布:

1 | 选择菜单"修改"-> "旋转画布".
2 | 选择旋转属性.

裁剪画布

如果您的文件包含了一些多余的空白边,您可以通过裁剪画布除去.当然您也可以通过图像剪切除去空白边,详细请参看剪切路径或剪切位图图像.

原始图像

裁剪画布后的图像

裁剪画布:

选择菜单"修改"->"裁剪画布",Fireworks自动完成对空白边的剪切删除.

画布的每一边经裁剪后,与文件中的对象或图片的最外边对齐.

如果文件包含多个影格,裁剪画布按照所有影格中所有对象的最外对象的对外边对齐裁剪,并不会只针对当前影格.

您也可以选择菜单"修改"->"适合画布".该命令会自动扩展画布,使得画布能包含文件中的所有的对象.

蓝骑士编译


使用标尺,辅助线,和网格--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 使用标尺,辅助线,和网格

使用标尺,辅助线,和网格

为了帮助您在创作中能精确的定位和排版对象,Fireworks提供了标尺,辅助线和网格.您可以在文件中放置辅助线,并让对象可以吸附到这些辅助线.或者您也可以开启网格功能,并决定对象可以吸附到网格.

使用标尺

标尺主要帮助您在工作中整理,定位和排版文件中对象.标尺任何时候都是以像素为单位,不会因为您设置不同的文件单位而改变.

显示和隐藏标尺:

选择菜单"显示"-> "标尺".

文件边缘将出现竖直和水平的两条标尺.

使用辅助线Working with guides

辅助线显示您在画布上移动时标尺对应的点位置改变情况,为您放置和排列对象提供帮助.使用辅助线可以确定您文件的重要部分,例如空边,文件中心点,创作的区域等.您也可以将切片的图像按照辅助线确定的表格输出HTML文件.

为了更好的帮助您排列对象,Fireworks还提供了对象吸附到辅助线的功能.

通过锁定辅助线,您也可以创作过程中它们被不小心移动.

注: 辅助线并不真正绘制在层上或者随着您的文件输出,他们仅仅是您创作的辅助工具.

创建水平或竖直辅助线:

1 | 点击并拖动对应的标尺所在的位置.
2 | 将辅助线放置到画布,释放鼠标.
 | 您可以通过拖动再次调整辅助线.

移动辅助线到指定位置:

1 | 双击辅助线.(注意:此时辅助线不要锁定--蓝骑士注)
2 | 在弹出对话窗口输入辅助线的位置数值.
3 | 点击确定.

显示和隐藏辅助线:

选择菜单"显示"-> "辅助线" -> "显示辅助线".

对象吸附到辅助线:

选择菜单"显示"-> "辅助线"-> "吸附到辅助线".

改变辅助线色彩:

1 | 选择菜单"显示"-> "辅助线" -> "编辑辅助线".
2 | 在弹出对话窗口中,点击色块,在色彩选择对话框选择您需要的色彩,点击确定.

锁定或解开所有的辅助线:

选择菜"显示"-> "辅助线" -> "锁定辅助线".

删除辅助线:

将辅助线拖出画布.

使用网格

适应网格将在画布显示纵横交错的格状线.网格主要用来精确的放置对象.您可以显示,编辑重定义或改变网格色彩.

注: 辅助线并不真正绘制在层上或者随着您的文件输出,他们仅仅是您创作的辅助工具.

显示和隐藏网格:

选择菜单"显示"-> "网格"-> "显示网格".

对象吸附到网格:

选择菜单"显示"-> "网格" -> "吸附到网格".

改变网格的色彩:

1 | 选择菜单"显示" -> "网格" -> "编辑网格".
2 | 在弹出对话窗口中,点击色块,在色彩选择对话框选择您需要的色彩,点击确定.

改变网格单元格的尺寸:

1 | 选择菜单"显示" -> "网格" -> "编辑网格".
2 | 在弹出的对话框输入您希望的网格单元格的尺寸,点击确定.

蓝骑士编译


Creating a new document（侠客岛版权所有）

建立Fireworks文件 > 创建新文件

创建新文件

在Fireworks中创建一幅网络图像,您必须建立新文件或打开一幅已经存在图像.通常对于新文件,在建立时设置好它的属性很重要,这样可以避免在后续的创作中再费力的不断去调整.

如果您希望按照一幅已经存在图像创建相同尺寸的新文件,您可以首先将该图像复制到剪贴板,然后新建文件.查看能够存放在剪贴板中并被导入到Fireworks的文件格式,请参看粘贴到Fireworks.

创建新文件:

1 | 选择菜单"文件"->"新建".此时弹出新建文件对话框.
2 | 输入画布的宽和长,单位可以为像素,英尺或厘米.
 | 任何您创建的图像最后的长宽尺寸都由画布的长宽决定.
3 | 输入分辨率值,单位可以是像素/英尺或者像素/厘米.
4 | 选择白色,透明,或自定义色彩为画布色彩.
 | 使用自定义画布色彩可以点击色块下的小箭头,弹出色彩选择对话框.
5 | 点击确定打开新文件.

按照已经存在的对象的长宽尺寸创建新文件:

1 | 复制下列的任何一个适合的对象到剪贴板:
 | 另一个Fireworks文件
 | 网页浏览器中的图像对象
 | 在粘贴到Fireworks中罗列的文件对象.
2 | 选择"文件"->"新建". 此时打开的新建文件对象框的长宽值已经按照粘贴板中的对象的长和宽设置好.
3 | 设置分辨率和画布色彩后点击确定.
4 | 选择菜单"编辑"->"粘贴",将剪贴板中的对象粘贴到新建的文件.

打开已经存在的文件:

1 | 选择菜单"文件"-> "打开". 此时弹出打开文件对话框.
2 | 选择您需要打开的文件,点击打开.

蓝骑士编译


打开其他应用程序生成的图像--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 打开其他应用程序生成的图像

打开其他应用程序生成的图像

Fireworks可以打开您用其它软件生成的图像文件,例如Photoshop, FreeHand, Illustrator,无压缩CorelDRAW, WBMP, EPS, 和动态GIF等.

当您使用菜单"文件"->"打开"一个上述的图像,Fireworks会自动创建了一个临时的PNG文件,您原始的图像文件并不会被直接改动.

打开Fireworks 1 的文件

在Fireworks 1中, 背景层永远是一幅充满画布的图像,在层上不可以放置其他的对象或图片.而Fireworks 4 的背景层则不受这个约束.

当您在Firworks 4中打开Fireworks 1的文件,Fireworks 1的背景层会自动转换成一个图片对象放置在文件底部的共享层中.同时,Fireworks 1中的URL链接属性会被自动放置在Fireworks 4的网络层.

打开Photoshop 的文件

当您在Fireworks中打开Photoshop的文件时,通常,Photoshop的文字层会被默认的转换成Fireworks的对象,并保留可编辑的属性.同时,您也可以自定义Photoshop文件的输入属性,来决定是否将Photoshop的层转换为Fireworks的影格,文字层是否转换为图像.更多详细请参看改变Photoshop文件输入属性,在Fireworks中导入 Photoshop文件.

注: 在Windows操作系统中,Photoshop文件导入Fireworks时必须包含PSD的文件扩展名,如*.psd.

打开Photoshop文件:

1 | 选择菜单"文件"-> 打开.
2 | 选择需要打开的Photoshoop文件,点击打开.

蓝骑士编译


打开FreeHand, Illustrator, 或CorelDRAW 文件--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 打开其他应用程序生成的图像 > 打开FreeHand, Illustrator, 或CorelDRAW 文件

打开FreeHand, Illustrator, 或CorelDRAW 文件

您能够在Fireworks中打开FreeHand, Illustator ,或CorelDRAW生成的矢量图像,然后在Fireworks中应用矢量工具进行修改和编辑,如笔刷,笔触和材质填充等.

Fireworks能够导入利用CorelDRAW 7或CorelDRAW 8创建的无压缩文件扩展名为CDR的文件.
Fireworks不能够打开或导入压缩的CDR文件或CMX文件.

由于CorelDRAW支持不同于Fireworks的一些功能,所以在导入过程中将会出现下列现象:

主控页的内容会在Fireworks4的每一个帧中重复出现。
在coreldraw中的调和物件只有两端的物件能被导入，导入后两个物件自动群组。
度量标注被转换为矢量物件。
基本文本可以导入，但是大多数的字符属性和段落属性都不支持。
色彩转换为RGB色彩.

打开FreeHand, Illustrator, 或CorelDRAW文件:

1 | 选择"文件"->"打开".
2 | 在如下的矢量文件选项对话框中选择需要的选项:

放缩 定义图像导入后的放缩比例百分比.

宽和高 按像素单位定义导入后的图像宽和高.

分辨率 定义导入后的图像的分辨率.

抗锯齿 光滑导入后的图像,防止边缘锯齿现象.

注: 在文件导入后,改变选择的对象的抗锯齿属性,请使用菜单"修改"->"改变路径"->实块填充,抗锯齿填充,羽化填充选项.

文件转换 定义多页文件导入的控制属性:

打开一页 只导入定义的页.
打开多页到影格 将页作为Fireworks的影格分别导入到影格.
记录层 在导入的文件中保留层的结构.
转换层到影格 将页中的层转换为影格导入到Fireworks.

包含不可见层 将被关闭,不可见的对象一起导入.否则,不可见的对象在文件导入时会被忽略.

包含背景层 导入时包含文件的背景层.否则,背景层将被忽略.

作为图像导入 合成复杂的组,路径,或填充,作为一个图像对象导入到Fireworks.后面的文字框中输入的数字决定了导入时,每次多少这样的组,路径或填充合成为一个图像对象.

打开动态GIFs文件

您可以以两种方式在Fireworks中导入动态GIFs文件:

您能够将动态GIF文件作为一个单独的动画符号导入.动画符号类似按钮符号,您可以在文件窗口中作为一个独立的对象进行编辑和移动.同时您也可以使用库面板创建新的符号.
注: 当您导入动态GIF时, 每个影格的延迟时间会默认的设置为0.20秒.如果需要,您可以调用影格面板来恢复动画影格的播放时间.

您也可以将动态GIF作为普通序列文件导入.GIF中的每一个画面会被导入到各自的Fireworks影格.如果需要,您可以再将这些影格转换为独立的动画符号.

打开EPS文件

如果Fireworks不能将EPS文件(外部页面存储器文件)以矢量图格式打开,Fireworks会自动用位图方式打开EPS文件.

When you import an EPS file into an existing document, the EPS File Options dialog box opens.

当您导入EPS文件到某一个文件窗口,此时将弹出EPS选项对话框.

显示单位 决定打开的对象以什么单位显示.您能够在像素,百分比,英尺,和厘米中选择其中的一个.

分辨率 设定打开文件的显示分辨率.

约束比例Constrain Proportions 按源文件尺寸的百分比打开文件(长和宽的比例属性与源文件保持一致).

抗锯齿 在打开EPS文件时使用抗锯齿属性.

打开WBMP文件

Fireworks可以打开WBMP文件.WBMP是一些1位的单色图像,主要应用于移动电子设备. 这种格式的图像应用在使用无线应用协议 (WAP)的WAP网页.

蓝骑士编译 校对： snl


从扫描仪或数字相机输入--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 从扫描仪或数字相机输入

从扫描仪或数字相机输入

您可以使用TWAIN模块或(Macintosh操作系统)Photoshop插件从扫描仪或数字相机输入图像.输入的图像做为新文件打开.

注: 除非安装合适的软件驱动,模块或插件,否则Fireworks就不能扫描图像.请详细参阅安装,设置,和选项等内容来决定您的外部输入文件适用于哪类模块或插件.

在Macintosh操作系统,Fireworks会自动在Fireworks 4\Output\Xtras文件夹中寻找Photoshop插件,如果您不希望将插件放置在该文件夹,请在Fireworks的属性设置中决定您放置插件的文件夹位置.

告诉Fireworks在哪里寻找Photoshop插件:

1 | 在Fireworks中,选择菜单"编辑"-> "属性".
2 | 选择"文件夹"标签.
3 | 选择Photoshop插件一项.
4 | 点击"浏览"按钮,选择您安放Photoshop插件的文件夹.

从扫描仪或数字相机输入图像:

1 | 连接您的扫描或数字相机到您的电脑.
2 | 安装支持扫描仪和数字相机的软件.
3 | 在Fireworks中,选择菜单"文件"-> "扫描",并选择对应您的设备的TWAIN模块或Photoshop插件输入文件.
 | 绝大部分的TWAIN模块或Photoshop查件此时会弹出对话框让您进行一些属性的设置.
4 | 设置好属性,进行图像的输入.
 | 输入的图像会在Fireworks中作为新窗口打开.

蓝骑士编译


在Fireworks文件中插入对象--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 在Fireworks文件中插入对象

在Fireworks文件中插入对象

您可以将其他应用程序生成的矢量对象,位图图片,或文字,通过输入,拖拽或复制和粘贴等方式插入到Fireworks,譬如通过扫描仪或数字相机输入图像.

拖拽

您可以在下列支持对象拖拽的应用程序中将矢量对象,位图图片或文字通过拖拽的方式输入Fireworks.

FreeHand 7.0 以上版本
Flash 3.0 以上版本
Photoshop 4.0 以上版本
Illustrator 7.0 以上版本
Microsoft Office 97 以上版本
Microsoft Internet Explorer 3.0 以上版本
Netscape Navigator 3.0 以上版本
CorelDRAW 7.0 以上版本

拖拽到Fireworks:

从另一个应用程序窗口拖拽一个对象到Fireworks的文件窗口.

粘贴到Fireworks

您可以将下列格式通过复制和粘贴方式,从剪贴板输入对象到Fireworks

FreeHand 7.0以上版本
Illustrator
PNG
PICT (Macintosh操作系统)
DIB (Windows操作系统)
BMP (Windows操作系统)
ASCII文本
EPS
WBMP

当您从其他应用程序复制和粘贴对象到Fireworks,对象会粘贴在文件窗口的正中央.

不同的编辑模式粘贴会应用不同的数据处理方式

在矢量图编辑模式,一个选定某部分区域粘贴的位图图像会被整体复制和粘贴到文件窗口,然后通过选定区域外透明的来实现图像的显示.矢量对象粘贴仍然保持矢量图格式
在位图编辑模式,当一个选中的对象粘贴输入时,对象仍然浮动在图像上,此时可以进行一些编辑,但当选中取消后,对象会自动融合到当前的位图中去.

蓝骑士编译


粘贴对象重采样--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 在Fireworks文件中插入对象 > 粘贴对象重采样

粘贴对象重采样

当粘贴对象(主要是图像)的分辨率与粘贴处的Fireworks文件的分辨率不相同时,Fireworks会弹出消息窗口,询问粘贴对象是否要重采样.

重采样会在图像中尽可能接近原有品质增加或删除像素点,并调整图像的尺寸.重采样成高分辨率,粘贴部分图像品质会降低.重采样成低分辨率,粘贴部分图像的文件尺寸会减小,但品质也会下降.

在不同分辨率文件间操作,如果要维持粘贴对象原有的长和宽,需要选择重采样.

如果选择不重采样,粘贴对象会被放大或缩小以适应新的分辨率.

蓝骑士编译


输入PNG文件--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 在Fireworks文件中插入对象 > 输入PNG文件

输入PNG文件

您可以在当前创作的图层中输入Fireworks的PNG文件.输入的PNG文件如果包含热点和切片区域,会自动存放在当前创作文件的网络层中.更多信息请参看在层面板中显示和命名切片.

输入PNG文件到当前创作文件:

1 | 选择菜单"文件"-> "输入",此时弹出输入文件对话框.
2 | 浏览并找到您需要输入的文件,点击确定.
3 | 移动鼠标到您需要放置输入图像的位置,此时鼠标定位在输入图像的最左上点:
 | 点击鼠标,按图像原始尺寸输入图像.
 | 按下鼠标并拖拽一定区域,此时图像按照拖拽的区域自动调整图像尺寸,原始图像的长宽比例保持固定.

蓝骑士编译


浏览和显示文件--蓝骑士（侠客岛版权所有）

建立Fireworks文件 > 浏览和显示文件

浏览和显示文件

在Fireworks中,您能自由的控制文件按照一定的放大率,一定数目的窗口和一定的模式显示.此外,您还可以自由的在文件窗口拖动图像进行浏览.这主要是帮助您在图像放大超过窗口容量的时候进行浏览.

放大和缩小文件

Fireworks显示图像的放缩范围是6%到6400%.当图像放大时,宁可以拖动窗口边缘的滚动条进行位置的调节.

放缩的弹出菜单在文件窗口的右下角.放缩和手动的工具在工具面板.

放大:

选择放缩工具,在文件您需要显示的位置点击.
从放缩弹出菜单选择一项设置.
选择菜单"显示"-> "放缩",选择一个选项.

缩小:

从放缩弹出菜单选择一项设置.
选择菜单"显示"-> "放缩",选一个选项.

对特定区域放缩:

选中放缩工具,在文件窗口拖拽一个您需要显示的矩形区域.

对一个特定区域缩小:

选中放缩工具,在文件窗口拖拽一个您需要显示的矩形区域的同时,按住 Alt 键(Windows操作系统) 或 Option 键(Macintosh操作系统).

回到原始的100%尺寸:

在工具面板双击放缩工具.

手动拖拽文件:

1 | 选择手动工具.此时鼠标形状变为手形.
2 | 在文件窗口中拖拽文件.
 | 注: 当拖拽到文件的边缘时,文件边缘的灰色区域会有部分的显示.

放缩文件使适合当前窗口满窗口显示:

双击手动工具.

蓝骑士编译


使用对象概述--蓝骑士（侠客岛版权所有）

使用对象 > 使用对象概述

使用对象概述

当您进入Fireworks的矢量图编辑模式,您可以对矢量对象,文字块,符号,切片和热点,位图图片等进行控制和编辑.当您对某一个对象进行操作时,您必须首先选中该对象.

一旦选中对象,您可以对对象进行移动,复制,删除以及编辑等动作.另外,还可以使用变形工具来旋转,放缩,倾斜对象.如果文件中包含多个对象,还通过堆叠,成组或者排列工具进行编排.

蓝骑士编译


对象变形--蓝骑士（侠客岛版权所有）

使用对象 > 对象变形

对象变形

在矢量图编辑模式您可以通过变形工具和菜单命令放缩,旋转,翻转,扭曲或倾斜对象,对象组.

变形工具

选择变形工具或菜单命令将在所指向对象边缘出现控制柄.

原始对象

旋转,放缩,倾斜,扭曲,垂直翻转,水平翻转的对象

使用变形控制柄编辑选取的对象:

1 | 选择变形工具.当您将鼠标指针在对象上移动,指针将改变为但前的变形控制柄.
2 | 通过拖拽变形柄改变对象.

蓝骑士编译


在信息面板显示变形信息--蓝骑士（侠客岛版权所有）

使用对象 > 对象变形 > 在信息面板显示变形信息

在信息面板显示变形信息

信息面板提供了当前选择对象的坐标和长宽属性.当您对对象操作时,信息面板的数据自动更新.

使用变形工具放缩和旋转对象,信息面板显示长宽的放缩百分比和旋转的度数.
使用变形工具倾斜和扭曲对象,信息面板显示与变形点原始X,Y坐标相对的变形数值.

当您释放鼠标按键,并将指针在物体上移动,此时信息面板将显示指针对应点的色彩值.

当对象变形时使用信息面板观测:

选择菜单"窗口" -> "信息".

蓝骑士编译


对象放缩（侠客岛版权所有）

使用对象 > 对象变形 > 对象放缩

对象放缩

对象放缩用于在水平和竖直方向扩大或缩小对象.

放缩选取的对象:

1 | 显示变形控制柄:
 | 选择放缩变形工具.
 | 选择菜单"修改" -> "变形" -> "放缩".
2 | 拖拽控制柄:
 | 如果对水平和竖直方向同时放缩,选择控制柄四个顶点拖拽.
 | 如果对水平和竖直方向分别放缩,选择控制柄的四条边.

您也可以在信息面板的长宽输入框键入新的长宽数值.

蓝骑士编译


对象旋转--蓝骑士（侠客岛版权所有）

使用对象 > 对象变形 > 对象旋转

对象旋转

对象旋转按照对象旋转中心点旋转.中心点默认为对象中心,也可以手动改变.您可以通过拖拽控制柄手动旋转或使用预设的角度旋转.

旋转90或180度:

选择菜单"修改" ->　"变形"．从子菜单选取旋转命令．

通过拖拽控制柄旋转对象:

1 | 选择任何一个变形工具.
2 | 将指针移动到对象边缘外部，直到出现旋转指针.
3 | 旋转着拖拽.
 | 按住Shift可以约束对象按１５度为单位旋转．

改变旋转中心点:

拖动旋转中心点到您需要的位置.

双击旋转中心点，恢复中心点到对象中心.

蓝骑士编译


对象翻转--蓝骑士（侠客岛版权所有）

使用对象 > 对象变形 > 对象翻转

对象翻转

您可以不移动对象在画布的相对位置,通过水平轴和竖直轴翻转对象.

翻转对象:

选择菜单"修改" -> "变形" ->"水平翻转"或"竖直翻转".

蓝骑士编译


对象倾斜--蓝骑士（侠客岛版权所有）

使用对象 > 对象变形 > 对象倾斜

对象倾斜

对象倾斜是将对象沿着水平或竖直轴进行倾斜.您也可以通过拖拽改变倾斜度.

倾斜对象:

1 | 显示变形控制柄:
 | 选中对象,选择倾斜变形工具.
 | 选中对象,选择菜单"修改" -> "变形" -> "倾斜".
2 | 拖拽控制柄,倾斜对象.

制作透视效果:

拖拽控制柄的四个顶点.

蓝骑士编译


对象扭曲--蓝骑士（侠客岛版权所有）

使用对象 > 对象变形 > 对象扭曲

对象扭曲

当您使用扭曲工具时,你可以拖拽控制柄的边和顶点扭曲对象.

扭曲对象:

1 | 选中对象,显示变形控制柄:
 | 选择扭曲工具.
 | 选择菜单"修改" -> "变形" -> "扭曲".
2 | 拖动控制柄扭曲对象.

蓝骑士编译


数字化变形（侠客岛版权所有）

使用对象 > 对象变形 > 数字化变形

数字化变形

除了拖拽进行放缩,旋转等操作,您还可以键入数值对对象进行数字化变形.

数字化变形:

1 | 选择菜单"修改" -> "变形" -> "数字化变形".
 | 此时弹出数字化变形对话框.
2 | 在下拉菜单中选择您需要的变形类型:
 | 放缩
 | 自定义长宽
 | 旋转
3 | 选择约束属性,放缩或自定义长宽时,水平方向和竖直方向保持的比例变化.
4 | 选择放缩特性选项,放缩是包括填充,笔触和对象的效果.如果不选,仅对路径进行放缩.
5 | 键入您需要的数值,完成数字化变形.

蓝骑士编译


对象组织--蓝骑士（侠客岛版权所有）

使用对象 > 对象组织

对象组织

当您对一个文件中的多个对象操作时,您可以同下面的几种方式组织对象:

您可以将单独的对象组成对象组,保持对象之间的相关性.
您可以安排对象之间的前后关系,也就是对象的堆叠顺序.
您可以将选中的对象进行排列.

对象成组

您可以将独立对象成组,使之成为对象进行整体操作.例如,绘制完花朵的花瓣,您可以将他们成组,使整个花朵作为一个对象组进行移动等操作.

您可以对整个对象组进行编辑.您也可以只选择对象组中的一个对象进行编辑,并且不破坏组的属性.当您不需要对象组操作时,您可以方便的将对象组解散.

选取对象组就像是选取单个对象.

将几个对象成组:

选择菜单"修改" -> "成组".

解散对象组,选择菜单"修改" -> "解散".

蓝骑士编译


在对象组中选取对象--蓝骑士（侠客岛版权所有）

使用对象 > 对象组织 > 在对象组中选取对象

在对象组中选取对象

您既可以通过打散对象组的方法选取其中的对象,也可以通过子选择工具选取对象并且不破坏组的属性.

子选择工具

修改子选择选取的对象只改变选中的对象而不会修改整个组的属性.将子选择选取的对象移动到其他的层,对象将会从对象组中移出.

在对象组中子选择对象

选取对象组中的对象:

选择子选择工具,点击对象选取子对象,或在画布拖拽一定区域选取子对象.按住键盘Shift键,同时鼠标点击对象,用于添加或减少选取的对象.

当子选择选取对象时,选择包含子选择的对象组:

当子选择选取对象时,点击鼠标右键(windows操作系统)或Control键(Macintosh操作系统),您可以选取包含子选择对的对象组.
当子选择选取对象时,选择菜单"编辑" -> "超选择".

选取对象组时,选择所有的子对象:

选取对象组时,点击鼠标右键(windows操作系统)或Control键(Macintosh操作系统),您可以选取对象组包含的所有子对象.
选取对象组时,选择菜单"编辑" -> "子选择".

堆叠对象

在一个层中,Fireworks按照对象创建的顺序由后向前堆叠对象.对象的堆叠影响他们的相互间的显示和遮掩.

注意,层的前后(上下)顺序也会影响对象的显示和遮掩.例如,层面板中层2在层1上,则层2的对象在层1的对象上.通过拖拽层可以改变层的顺序.

选取对象或对象组,在一个层中改变堆叠顺序:

选择菜单"编辑" -> "排列" -> "移至最前","移至最后".
选择菜单"编辑" -> "排列" -> "移前","移后".

如果选取了多个对象或对象组,移动时默认为一个对象,并按照命令移动.

排列对象

排列对象命令能让您按照水平轴或竖直轴排列对象.竖直排列时可以决定排列按照对象最左边缘,中心还是最右边缘对齐.水平排列是可以决定排列按照对象最上边缘,中心还是最下边缘排列.

使用排列对象命令,您还可以调整对象间的等间距,放缩排列对象,或者组合排列命令,进行对象的排列.

排列选中的对象:

选择菜单"修改" -> "排列" -> "最左边缘竖直对齐".
选择菜单"修改" -> "排列" -> "中心竖直对齐".
选择菜单"修改" -> "排列" -> "最右边缘竖直对齐".
选择菜单"修改" -> "排列" -> "最上边缘水平对齐".
选择菜单"修改" -> "排列" -> "中心水平对齐".
选择菜单"修改" -> "排列" -> "最下边缘水平对齐".

调整对象间的等间距:

选择菜单"修改" -> "排列" -> "等分水平间隔".
选择菜单"修改" -> "排列" -> "等分竖直间隔".

在层间安排对象

层面板提供了对象的操作.您可以拖拽"对象显示块"或蓝色小片将层中的对象拖拽到其他的层.

蓝骑士编译


在矢量图编辑模式选取对象--蓝骑士（侠客岛版权所有）

使用对象 > 在矢量图编辑模式选取对象

在矢量图编辑模式选取对象

Fireworks中的一些工具用于选择矢量对象.当您在矢量图编辑模式时,您可以使用这些工具选取文字,符号,网络对象和位图图片.选取像素区域讲述了如何在位图编辑模式选取像素区域.

如果希望选取矢量对象,您可以在下列选项选择:

使用箭头工具选取矢量对象.参看使用箭头工具.
使用子选择(路径选择箭头)工具选取对象的路径点.参看使用子选择工具.
选取对象后面的对象,使用选后工具.参看 使用选后工具.
选取部分区域作为独立文件输出使用输出区域工具.

蓝骑士编译


使用对象面板--蓝骑士（侠客岛版权所有）

使用对象 > 在矢量图编辑模式选取对象 > 使用对象面板

使用对象面板

当您选中一个对象,对象面板会自动识别该对象,并在面板的标题栏显示对象类型,例如矩形,切片,路径,文字等.当有多个对象同时选中,对象面板的标题栏和状态栏显示选中对象的个数.

注:在windows操作系统,上述的对象属性也会在窗口的状态栏显示.

对象面板显示所选中对象的相关信息和设置属性.譬如,您选中一条矢量路径,对象面板显示关于在路径上添加笔触的方式的三个按钮.(分别为:以路径为外边线描绘笔触,以路径为中线描绘笔触,以路径为内边线描绘笔触--蓝骑士注),以及一个关于路径变形时矢量对象变化情况选项的下拉框.

如果选取一个切片对象,您可以在对象面板决定切片是图像切片还是文字切片.并输入URL链接,图片提示文字,定义链接目标,输出时切片名字等切片属性.或者改变切片的色彩.

关于其他对象的具体属性,将在后面的相关部分给与介绍.

蓝骑士编译


使用箭头工具--蓝骑士（侠客岛版权所有）

使用对象 > 在矢量图编辑模式选取对象 > 使用箭头工具

使用箭头工具

当您切换箭头工具时,您可以通过点击或拖拽选取对象.您不可以使用箭头工具选取路径.如果要选取路径请使用子选择工具.参看选取点.

通过点击选取对象:

选择箭头工具并移动到对象上,点击.如果对象不包含填充,请点击对象笔触.

如果希望知道您将选取哪个对象,请打开工具选项面板的鼠标掠过高亮显示的选项.当箭头工具掠过对象时.对象边缘将高亮显示.

通过拖拽选取对象:

选择箭头工具在文件窗口拖拽一定区域,该区域内的对象将被选中.

蓝骑士编译


使用子选择(路径选择箭头)工具--蓝骑士（侠客岛版权所有）

使用对象 > 在矢量图编辑模式选取对象 > 使用子选择(路径选择箭头)工具

使用子选择(路径选择箭头)工具

和箭头工具类似,子选择工具也可以通过点击和拖拽选取对象.但自选择工具还有一些其他功能:

您可以通过子选择工具选取和移动路径上的点.
您可以通过子选择工具控制点的曲柄,编辑路径.参看使用矢量图编辑工具改变路径.
您可以通过子选择工具选取成组对象中的某一个或合成路径.参看成组对象.

使用Alt键(Windows操作系统)或Option键(Macintosh操作系统),您可以方便的在箭头工具和子选择工具键切换.

蓝骑士编译


使用选后工具--蓝骑士（侠客岛版权所有）

使用对象 > 在矢量图编辑模式选取对象 > 使用选后工具

使用选后工具

当您对多个对象操作时,您可以通过选后工具选取某些被其他对象遮盖或较难选取的对象.

选取被其他对象遮盖的对象:

先用箭头工具选中遮盖的最上方物体,然后选择选后工具,点击被遮盖对象,对象被选中

注: 您也可以通过点击层面板对应的对象所在层,来选取对象.

蓝骑士编译


使用层面板选取对象--蓝骑士（侠客岛版权所有）

使用对象 > 在矢量图编辑模式选取对象 > 使用层面板选取对象

使用层面板选取对象

层面板中的每一层下面都包含有一个和对象相对应的"对象指示块"列表.当在窗口中选中某一个对象时,对象所在层的后面将出现一个蓝色的小片,它表示您选中了该对象.

从层面板选取对象:

点击对象指示块或者指示块旁的对象名字.

将对象从一个层移动到另一个层:

将对象指示块从一个层拖动到另一个层.
将对象对应的蓝色小片(对象指示块旁)从一个层拖动到另一个层.

蓝骑士编译


修改选取--蓝骑士（侠客岛版权所有）

使用对象 > 在矢量图编辑模式选取对象 > 修改选取

修改选取

当选中对象后,您也可以很方便的添加对象选取或放弃对象选取.通过一个简单的命令.你可以选取每一个层中的所有对象或者放弃选取.您还可以隐藏边缘参考显示,是的对象看起来和输出,打印时一样.

添加对象选取:

当您用箭头工具(指针工具,子选择工具,选后工具)选取对象时,通过按住键盘Shift键,您可以添加对象的选择.

放弃某个对象的选取而保留其他选取:

按住Shift键然后点击已经选取的对象您可以放弃对象选取.

选取文件中所有对象:

选择菜单"编辑" -> "选取所有",您可以选取文件中所有对象.放弃选取,选择菜单"编辑" -> "取消选取".

注:选取所有对象不包括已经被隐藏的对象.

在选取文件中所有未隐藏对象时,您还需要注意,是否已经将层面板旁的弹出菜单(右上小箭头)下的"单层编辑"选项取消.否则,"选取所有"命令仅对当前您所在的层中的对象产生作用.参看使用层面板选取对象.

隐藏边缘参考显示:

选择菜单"编辑" -> "隐藏边缘".

注:如果隐藏了边缘参考显示,您可以通过观察状态栏(Windows操作系统)或对象面板来确定对象是否选中.

隐藏选中的对象:

选择菜单"显示" -> "选取隐藏".如果希望所有被隐藏对象再次显示,选择菜单"显示" -> "显示所有".

你也可以通过点击层面板中对应的层显示/隐藏图标(眼睛)显示和隐藏对象.

注: 隐藏的对象不会被输出.

蓝骑士编译


移动,复制,克隆和删除对象--蓝骑士（侠客岛版权所有）

使用对象 > 移动,复制,克隆和删除对象

移动,复制,克隆和删除对象

您可以对象进行拖拽,剪切和粘贴,利用键盘的方向键移动,或者在信息面板输入相关数值改变对象在画布中的位置.您也可以通过剪切板,在Fireworks和其他应用程序间交换对象.您可以通过复制命令将剪切板中的对象创建,或者在两个窗口间直接通过拖拽创建对象.如果您不再需要使用某些对象,您可以直接将他们删除.

移动已经选取的对象:

利用箭头工具(指针工具,子选择工具,选后工具)直接拖拽选中的对象.
利用键盘方向键以1个像素单位移动对象.按住Shift键可以扩大为10个像素单位.
在信息面板键入对象最左上顶点的X,Y坐标来精确定位.坐标的(0,0)点默认为画布的最左上顶点.单位为像素.

通过粘贴移动和复制对象:

1 | 选取一个或多个对象.
2 | 选择菜单"编辑" -> "剪切或编辑" -> "复制".对象复制在剪切板.
3 | 选择菜单"编辑" -> 粘贴.

注: 如果您使用剪切板中的对象创建新文件,新文件的画布尺寸默认和对象的尺寸一致.

复制选取的对象:

选择菜单"编辑" -> "复制".

新复制的对象层叠在原来对象的附近,并默认为选中状态.

克隆选取的对象:

选择菜单"编辑" -> "克隆".

克隆的对象层叠在原来对象的正上面,并默认为选中状态.

使用键盘方向键可以按像素单位移动克隆出的新对象,使您能够决定与原来物体键的精确位置关系.

删除选取的对象:

在键盘上使用Delete键或,<- 键.
在对象上点击鼠标右键(Windows操作系统),或Control键(Macintosh操作系统),从弹出菜单中选择"编辑" -> "剪切".
选择菜单"编辑" -> "清除".
选择菜单"编辑" -> "剪切".

蓝骑士编译


使用矢量对象概述（侠客岛版权所有）

使用矢量对象 > 使用矢量对象概述

使用矢量对象概述

矢量对象是用一系列直线和曲线的电脑图象，称 矢量，点和点的连接形成了。一个矢量对象的描边颜色形成了一个路径。他的填色就是路径内部所占的区域。描边和填色决定了图形发布在网络上的样子。

Fireworks 有很多工具使用不同技术来绘制和编辑矢量图形对象。用基本的形状工具，你可以快速画出直线、圆、椭圆、矩形星型，以及从3边到360边的等边多角形。

你可以用铅笔、笔刷和钢笔工具画出自由形状的矢量路径。钢笔工具可以让您通过布置节点来用曲线和直线绘制复杂的形状。

当你绘制好矢量图形后，Fireworks提供了许多编辑他们的方法。你可以通过移动、添加、 删除节点来改变一个对象的形状。你也可以用节点的手柄来改变相邻路径段的形状。自由变形工具可以让您直接通过编辑路径来改变对象的形状。

Modify 菜单上的命令给你更多选项来编辑对象，包括合并多哥对象来形成单个对象、通过多个对象的交错来创建一个对象，还有扩大对象的笔触。你可以导入位图和矢量图形，并在矢量状态下操纵他们。


使用矢量模式编辑工具改变路径形状（侠客岛版权所有）

使用矢量对象 > 使用矢量模式编辑工具改变路径形状 > 修改路径

修改路径

使用修改路径工具将重画所选路段的一个部分，同时保留该路径的笔触，填色和特效属性。

要重绘所选路径的一段：

1 | 选择修改路径。
2 | 直接移动指针到路径上。
 | 指针变化为修改路径箭头。
3 | 拖曳以重绘一段路径，被重绘的路径以红色加亮。
4 | 放开鼠标替换原来路径部分。


使用矢量模式编辑工具改变路径形状（侠客岛版权所有）

使用矢量对象 > 使用矢量模式编辑工具改变路径形状 > 切割路径

切割路径

用裁刀工具将路径切割为多个路径。

注意： 如果你选中了一个位图图象，裁刀工具会变成橡皮擦工具。

要切割所选路径：

1 | 选择裁刀工具。
2 | 按以下步骤做：
 | 拖曳指针掠过路径。
 | 点击路径
3 | 取消选定路径。


使用矢量模式编辑工具改变路径形状（侠客岛版权所有）

使用矢量对象 > 使用矢量模式编辑工具改变路径形状

使用矢量模式编辑工具改变路径形状

你可以使用（Modify）修改菜单上的路径操作来通过合并或者修改现有路径。对于部分路径操作，所选路径堆栈次序决定了操作如何进行。要获得更多关于排布所选对象的堆栈次序，看 堆栈对象.

注意： 使用路径操作会将所有压力和速度信息从受影响路径除去。


使用矢量模式编辑工具改变路径形状（侠客岛版权所有）

使用矢量对象 > R使用矢量模式编辑工具改变路径形状 > 合并路径对象

合并路径对象

你可以将许多路径对象合并为单独的一个路径对象。

用两个开放路径来创建一个连续路径：

1 | 选择细节选取工具。
2 | 选中两个开放路径的终点
3 | 选择 Modify 修改> Join合并

创建合成路径：

1 | 选择两个或两个以上的开放或封闭路径。
2 | 选择 Modify 修改> Join合并

要解散复合路径：

1 | 选择一个复合路径。
2 | 选择 Modify 修改> Split解散

要将多个封闭路径合并为一个路径，这个路径包括了原始路径所占有的整个区域的总和：

选择 Modify > Combine合并 > Union 集合. 联合后的路径继承了位于底层的对象的笔触和填色属性。

通过其他对象的交集来创建新对象

你可以两个或两个以上的通过其他对象的交集来创建新对象。

要创建一个包含选择的所有封闭路径重叠的部分的新路径：

选择 Modify > Combine合并 > Intersect交集。合并后的路径继承了位于底层的对象的笔触和填色属性。


使用矢量模式编辑工具改变路径形状（侠客岛版权所有）

使用矢量对象 > 使用矢量模式编辑工具改变路径形状 > 部分删除路径

部分删除路径

在所选路径中，当一些路径堆叠在其中一条路径的上方，通过重叠的部分指定的区域你可以指定删除该路径的一部分。

要部分删除路径：

1 | 选择能定义要删除部分的路径对象。
2 | 选择 Modify修改 > Arrange排列 > Bring to Front放到最前
3 | 按住Shift并选中要部分删除的路径
4 | 选择 Modify修改 > Combine合并 > Punch打洞。
 | 笔触和填色不变。


使用矢量模式编辑工具改变路径形状（侠客岛版权所有）

使用矢量对象 > 使用矢量模式编辑工具改变路径形状 > 裁剪路径

裁剪路径

通过堆叠在一条路径所包围的区域，可以删除他下方路径在该区域之外的部分。

要裁剪路径：

1 | 选择定义裁剪区域的路径。
2 | 选择 Modify修改 > Arrange排列 > Bring to Front放到最前
3 | 按住Shift并选中要裁剪的路径
4 | 选择 Modify修改 > Combine合并 > > Crop裁剪。
 | 裁剪后的路径继承了位于底层的对象的笔触和填色属性。


使用矢量模式编辑工具改变路径形状（侠客岛版权所有）

使用矢量对象 > 使用矢量模式编辑工具改变路径形状 > 简化路径

简化路径

你可以在保留相同重叠部分的同时，删除部分节点。

要简化路径：

选择 Modify修改 > Alter Path 改变路径> 简化


使用矢量模式编辑工具改变路径形状（侠客岛版权所有）

使用矢量对象 > 使用矢量模式编辑工具改变路径形状 > 扩张笔触

扩张笔触

你可以将一个所选路径笔触的周长转变为一个封闭路径，这个路径是原来路径的变相，形状相似，笔触和填色完全相同。

扩张所选路径的笔触：

1 | 选择 Modify修改 > Alter Path 改变路径> Expand Stroke扩张笔触 ，来打开扩张笔触 对话框。
2 | 设置结果新路径的宽度。
3 | 设置转角样式： miter斜角, round圆角, or beveled斜面。
4 | 如果你选择斜角，请设置斜角限制，来设定何时斜角自动变为斜边。这是斜角边长和宽度的比例。
5 | 选择端点样式： butt烟头形（纵横平行）, square方形, or round园形, and click OK.
 | 代替原路径的封闭路径形状和原来相似，笔触和填色一样。


使用矢量模式编辑工具改变路径形状（侠客岛版权所有）

使用矢量对象 > 使用矢量模式编辑工具改变路径形状 > 内缩或外张路径

内缩或外张路径

你可以以一定数量收缩或扩张一个对象的路径。

收缩或扩张所选路径：

1 | 选择 Modify修改 > Alter Path 改变路径> Inset Path嵌入路径，来打开嵌入路径对话框。
2 | 选择内缩或外张路径的方向：
 | 内缩路径
 | 外张路径
3 | 设置操作前后的宽度差。
4 | 确定转角样式：设置转角样式： miter斜角, round圆角, or beveled斜面。
5 | 如果你选择斜角，请设置斜角限制，来设定何时斜角自动变为斜边。这是斜角边长和宽度的比例。
6 | Click OK.
 | 一个新的有相同笔触和填色属性，但是大小不同的路径对象取代了原来的路径对象。


进入矢量状态（侠客岛版权所有）

使用矢量对象 > 进入矢量状态

进入矢量状态

Fireworks 有两种绘图模式—矢量模式和位图模式。画矢量图形只能在矢量模式中绘制。

注意: 在 Fireworks老版本中，矢量模式被称为对象模式。

当 Fireworks处于位图模式下 ，在画布四周围有默认的条纹框。

从位图模式切换到矢量模式：

有以下方法：

点击文件窗口底部的离开位图模式按钮。
离开位图模式按钮
选择Modify > Exit Bitmap Mode.
按 Esc 键.
选择一个只能在矢量模式下使用的工具，如，钢笔工具。


绘制基本形状（侠客岛版权所有）

使用矢量对象 > 绘制基本形状

绘制基本形状

如果使用基本形状工具来绘制正方、矩形、圆型、椭圆、星状和多边型是很简单的。你可以绘制带有圆角的矩形，并且在绘制完成后修改圆角半径，你还可以画不同角数的星形。

基本形状工具位于工具面板的画图工具部分。在使用任何绘图或填色工具建立对象时，工具自动将当前的笔触和填色应用于该对象。

所有的形状绘制工具

注意： 你可以在位图模式下用基本形状工具来加不同颜色像素。看 在位图模式下绘图.

绘制直线、矩形、以及椭圆

使用直线、矩形、以及椭圆工具来快速绘制基本形状。矩形工具绘制的矩形是一个群组的对象。要单独移动矩形的一个交点，必须先解散群组，或使用细节选取工具（Subselection）。要绘制带有圆角的矩形，看 绘制带有圆角的矩形.

要绘制直线、矩形、以及椭圆：

1 | 选择直线、矩形、以及椭圆工具。
2 | 你可以随意选择笔触和填色属性。
3 | 在画布上拖曳以绘制图形。

对于直线工具，按住Shift拖曳可以画出水平，45斜角以及垂直线段。

对于矩形和椭圆工具，按住Shift拖曳可以画出正圆和正方。

从一个指定的点为中心绘制直线、矩形、以及椭圆：

将指针移到指定的点，然后按 Alt拖曳 (Windows) 或者按住 Option拖曳(Macintosh)。

同时从中心画正圆或正方：

将指针移到指定的点，按住Shift+Alt拖曳(Windows)绘图工具。

调整直线、矩形、以及椭圆的大小：

拖曳一个节点
在信息面板键入新的宽和高。
选择Transform > Scale然后拖曳调节手柄。


绘制基本形状（侠客岛版权所有）

使用矢量对象 > 绘制基本形状 > 绘制带圆角的矩形

绘制带圆角的矩形

你可以使用圆角工具来绘制带圆角的矩形，你可以在绘制之前确定从0% 到100%的圆角半径，也可以使用对象面版来调整圆角弧度，矩形工具绘制的矩形是一个群组的对象。要单独移动矩形的一个交点，必须先解散群组，或使用细节选取工具（Subselection）。要绘制带有圆角的矩形

要绘制带有圆角的矩形：

1 | 双击圆角工具，打开工具选项面板
2 | 确认角的弧度，可以键入值或者从0到100拖曳一个滑钮。
 | ？？？You can adjust the corner roundness as you draw by pressing the Up or Down arrow key repeatedly.

圆滑一个选中的矩形的顶角

在对象面板里的弧度域键入数值并按回车。

绘制多边形

用多边形工具，你可以绘制任何等边多角形，从三角形一直到360边形。

要绘制多边形

1 | 双击多边形工具，打开多边形工具选项面板。
2 | 从形状下拉菜单里选择多边形
3 | 键入多边形的边数：
 | 使用滑钮在 3 到 25 边
 | 在边数值框中键入一个3到360之间的边数。
4 | 拖曳绘制多边形。
 | 要限制多边形的朝向以45度为限递增，可以在绘制时按住Shift，多边形工具总是从中心开始画。


绘制基本形状（侠客岛版权所有）

使用矢量对象 > 绘制基本形状 > 绘制星形

绘制星形

使用多边形工具的星形选项，你可以从三星到360星形，并带有不同顶角锐度。

要绘制星形：

1 | 双击多边形工具打开选项面板。
2 | 从形状下拉菜单里选择星形。
3 | 确定星形的角点数。
4 | 选择自动锐度或键入一个角度。靠近0的值代表尖细长的角，靠近100的值代表粗钝的角。
5 | 在画布上拖曳来绘制星形。
 | 要使星形方向以45度为单位，拖曳的同时按住Shift。多边形工具总是从中心开始画


绘制任意形状路径并填色（侠客岛版权所有）

使用矢量对象 > 绘制任意形状路径并填色

绘制任意形状路径并填色

你可以使用铅笔和笔刷工具来绘制任意形状路径，就象真的铅笔和画笔一样。

铅笔和笔刷工具

你可以变换用铅笔和笔刷工具绘制的路径的笔触和填色属性。同样，你在位图模式下也可以使用铅笔和笔刷工具。

使用铅笔工具

在矢量模式下，铅笔工具以单像素笔触绘制矢量路径。你可以改变所选的用铅笔绘制的对象的原有的笔触，并填色。但是在用铅笔绘制其他对象时，铅笔工具又会自动转花成单像素笔触。

要用单像素笔触绘制一个矢量图形：

1 | 双击铅笔工具，打开选项面板，选择铅笔工具或取消选择：
 | 抗锯齿 在你图象的边缘设置平滑的。
 | 自动删除在笔触中间填色。
 | 保留透明 限制铅笔只在有像素的区域绘制路径，而不会在图象的透明区域。这个选项只能在位图状态下使用。
2 | 也可以在笔触面板中将笔触改为1-Pixel Soft, 以及Colored Pencil或者Graphite 。你也可以用笔触颜色对话框改变笔触的颜色。
3 | 拖曳绘制，要限制路径为水平或垂直直线，拖曳时按住Shift。
4 | 移动鼠标回到路径的放开鼠标以结束路径。

注意： 你可以在位图模式下使用铅笔来绘制像素。查阅 在位图模式下绘图.

使用笔刷工具

笔刷有多种笔触类型，包括喷枪，泼洒，毛笔，蜡笔，非自然笔触。每一种类型都有多种笔触，包括亮、暗毡笔笔尖，油墨泼洒，竹子，缎带，五彩纸屑，3D，牙膏，粘性怪异涂料。

尽管笔触可能看上去象涂料和墨水，但笔触和其他矢量对象一样拥有节点。着说明你可以通过移动节点来改变笔触的形状，形状改变后，笔触会自动重绘，这样你可以修改整个作品而不必自己去擦除重绘笔触。

通过移动矢量节点编辑作品

你也可以对所选中的用笔刷工具绘制的对象，修改笔触、添加填色。在当前文件中，新的笔触和填色设置将保留给下一步。但是如果你在笔刷工具激活下，将类型改变，则会恢复成默认的基本设置。

绘制任意形状矢量路径：

1 | 点击笔刷工具。
 | 笔刷工具的选项（保留透明度）仅在位图模式下适用。
2 | 可以设置笔触和填色属性。
3 | 拖曳绘制，要限制路径为水平或垂直直线，拖曳时按住Shift。
4 | 移动鼠标回到路径的放开鼠标以结束路径。

注意： 你可以在位图模式下使用铅笔来绘制像素。查阅 在位图模式下绘图.


使用钢笔工具 （侠客岛版权所有）

使用矢量对象 > 使用钢笔工具

使用钢笔工具

在Fireworks 中绘制和编辑矢量对象的一种方法是象画连线图一样排布节点。当你用钢笔工具逐次点击个点位置，工具会自动从最新的一个节点到前一个节点绘出这个矢量路径。

点之间的连线不仅限于直线，钢笔工具也可以绘制平滑的称为贝兹曲线的曲线，每个节点的类型—角点和节点—决定了相邻的线段是直线还是曲线。

一个角点表明至少一个相邻的线段是直线。
一个节点表明至少一个相邻的线段是曲线。

不论你是使用钢笔工具还是其他Fireworks绘图工具，所有矢量对象都有控制手柄。每个节点控制手柄的位置决定了相邻线段的位置。你用钢笔工具或细选工具通过拖曳手柄的位置来编辑矢量对象的形状。你也可以通过将一个节点从角点变为曲点来改变这个对象的形状。

钢笔工具

绘制直线线段

用钢笔工具绘制直线段很简单，只要用指针在不同位置点击，每次点击钢笔工具就会放置一个角点。

用直线线段绘制路径：

1 | 选择钢笔工具
2 | 起用选项面板中以下所有选项：
 | 显示钢笔预览可以预览下一步点击将产生的直线段。
 | 显示原色节点来绘制有色彩的节点
3 | 点击放置第一个节点。
4 | 移动指针放置第二个节点，一根直线连接了两个点。
5 | 继续放置节点。直线段连接了点和点直接的隔断。
6 | 结束路径，可以是封闭的也可以是开放的：
 | 双击最后一个节点以结束一个开放的路径。
 | 选择其他工具来以结束一个开放路径。当你在绘制路径时，选用了其他工具，然后又回到钢笔工具时，你的下一次点击将重新开始新对象的绘制。
 | 要结束路径，点击你放置的第一个节点。封闭的路径的开始节点和结束节点是同一个点。

注意：由路径本身重叠造成的环不是封闭的路径。只有开始和结束在同一点的才是封闭的路径。

绘制曲线线段

要绘制曲线线段。你只需要点击并在同时拖曳你放置的节点。当你绘制时，当前的节点会显示控制手柄。

用曲线线段绘制对象：

1 | 选择钢笔工具。
2 | 点击放置第一个角点。
3 | 移动到下一个点的位置，然后点击并拖曳以形成一个曲点。每次点击和拖曳，Fireworks自动延伸线段到新的节点。
4 | 继续放置节点。如果你点击并拖曳一个新的节点，就产生一个曲点，如果你只是点击，就产生一个角点。
5 | 结束一个路径，包括封闭路径和开放路径：
 | 双击最后一点将路径作为开放路径结束。
 | 选择其他工具来以结束一个开放路径。当你在绘制路径时，选用了其他工具，然后又回到钢笔工具时，你的下一次点击将重新开始新对象的绘制。
 | 点击你放置的第一个节点。封闭的路径的开始节点和结束节点是同一个点。

调整直线线段的形状

要调整直线线段

1 | 用选取工具或细节选取工具选择路径。
2 | 用细节选取工具点击一个节点选中他。
 | 选择一个看上去象兰色方块的角点。
3 | 拖曳这个节点到新的位置。

调整一个曲线线段的形状

要调整一个路径线段的贝兹曲线：

1 | 用选取工具或细节选取工具选择路径。
2 | 用细节选取工具点击一个节点选中他。
 | 选中的曲点看上去象兰色圆圈。从曲点延伸出控制手柄。
3 | 拖曳这个点或者它的控制手柄到新的位置。兰色的路径预览显示了如果你放开鼠标后新的路径的样子。
 | 对于这个例子，向下拖曳左控制手柄，注意右控制手柄向上移动了。

要限制手柄移动在45度倍数角度里：

请在拖曳时，按住Shift。

将路径线段转为直线或曲线。

直线线段由角点分割。曲线段包含曲点。

你可以通过转变节点性质来将直线变为曲线或将曲线变为直线。

要将所选路径上的一个角点转变为曲点：

1 | 选择钢笔工具
2 | 点击一个角点并拖曳开去。
 | 手柄延伸，相邻线段弯曲。

要将所选路径上的一个曲点转变为角点：

1 | 选择钢笔工具
2 | 点击一个曲点来转变它。
 | 手柄收缩相邻线段变直。

要移动一个节点：

用细节选取工具拖曳他。

路径重绘以显示这个节点的新位置。

要改变一个线段的形状：

拖曳一个节点的控制手柄。

继续一个已有路径

要继续一个已有路径的绘制：

1 | 选择钢笔工具。
2 | 点击结束节点继续路径的绘制。
3 | 钢笔工具的光标显示你正在给路径添加节点。

合并两个开放路径

你可以连接两个开放路径以形成一个连续路径。连接两个路径时，最上面的路径的笔触，填色，以及特效属性成为新的合并路径的属性。

要合并两个开放路径：

1 | 点击其中一个路径的结束节点。
2 | 移动这个点到另一个路径的结束节点并点击。

自动合并相似开放路径

你可以轻松地将一个路径和另一个有相似笔触和填色属性的路径合并。

要自动合并相似开放路径

1 | 选择一个开放路径。
2 | 使用细节选取工具并拖曳路径的一个结束节点到相似路径的结束节点距离几个像素的范围内。节点自动吸附到相似路径上，合并成一个路径。

在路径上插入和删除节点

你可以在路径上插入和删除节点。添加节点可以使你对路径的特定部分加以控制，删除节点改变了路径的形状或简化了编辑。

要在所选路径上插入节点：

使用钢笔工具，点击路径任何没有节点的部分。

要将曲点转变为角点：

用钢笔工具点击曲点。

要从所选路径上删除节点：

用钢笔工具在所选对象上点击一个角点。
用钢笔工具在所选对象上点击一个双点。
用细节选取工具选择一个节点并按 Delete或 Backspace.

选择节点

你可以用钢笔工具选取一个节点。要选取多个节点，使用细节选取工具并按住Shift点击每个节点。或者使用细节选取工具在节点周围拖曳以选中这个节点。

在用钢笔工具选择节点前，先用选取工具选中路径。否则，钢笔工具会绘制一个新的路径而不是在原有路径上选择一个节点。

要选择一个特定的节点：

1 | 使用细节选取工具。
2 | 点击一个节点，或者按住Shift 逐次点击多个节点。

要显示曲点的手柄：

使用细节选取工具点击节点。如果相邻的节点是曲点，他们的控制手柄也被显示。

要显示角点两边相邻的曲点的控制手柄：

1 | 用细节选取工具从这个点用Alt-drag (Windows) 或 Option-drag (Macintosh)拖曳开去
2 | 要显示下一个点的手柄，重复前面操作。
 | 路径预览显示了如果你放开鼠标将显示的新路径。
 | 用细节选取工具拖曳一个节点控制手柄来编辑相邻路径线段。

要弯曲一个角点相邻的路径线段：

1 | 选择细节选取工具
2 | 选择一个角点
3 | 按住Alt拖曳(Windows)或 按住Option拖曳 (Macintosh) 一个节点手柄来弯曲相邻线段。


使用矢量模式编辑工具改变路径形状（侠客岛版权所有）

使用矢量对象 > 使用矢量模式编辑工具改变路径形状

使用矢量模式编辑工具改变路径形状s

除了拖曳节点和节点手柄之外，你还可以使用许多Fireworks工具直接来编辑矢量对象。

矢量模式编辑工具：任意形状，区域变形，修改路径, 重绘笔刷, 裁刀


使用矢量模式编辑工具改变路径形状（侠客岛版权所有）

使用矢量对象 > 使用矢量模式编辑工具改变路径形状 > 弯曲和变形

弯曲和变形

使用任意形状工具来直接使矢量对象弯曲和变形，而不需要操作节点。你可以推拉路径的任意部分，不论节点定位在哪里。在你改变矢量对象的形状时， Fireworks 自动在路径上添加，移动、移动节点。

任意形状工具拉动路径线段

任意形状工具推动路径线段，路径会相应重绘

当你在所选路径上方移动指针时，会根据指针相对的位置变化成推拉箭头。
指针 | 表示
 | 任意形状工具
 | 当前使用任意形状工具，拉箭头处于拉动所选路径的位置。
 | 当前使用任意形状工具，拉箭头正在拉动所选路径。
 | 当前使用任意形状工具，推箭头处于激活状态。
 | 当前使用区域变形工具，区域变形工具箭头激活。从内圈到外圈的区域表示递减的强度。

当指针在路径上方时，你可以拉动路径。当指针不在路径上方时，你可以拉动路径。你可以改变推动箭头的尺寸。

要推动选中路径：

1 | 选择任意形状工具。
2 | 直接移动指针掠过所选路径。
 | 指针变为拉动箭头
3 | 拖曳路径

要推动所选路径：

1 | 选择任意形状工具。
 | 指针变为推动箭头
2 | 指针稍微离开路径。
3 | 向路径拖曳指针以推动路径。轻推所选路径改变它的形状。

要改变推动箭头的大小，按下列步骤做：

点击不放并按向右方向键或者2以增加指针的宽度。
按向左方向键或者1以减小指针的宽度。.
要设置指针的以及受影响的路径的长度，在选项面板里的尺寸文本框中键入从1到500的值。这个值表示指针以像素为单位的值。

注意： 任意形状工具也可以反映压感笔的压力。

扭曲路径

使用部分变形工具来拉动部分变形工具指针外圈内所有选中路径。

指针的内圈之内是最大强度。内圈和外圈之间以小于完全强度改变路径强度。指针的外圈决定了指针推力的强度。你可以设置该强度。

注意：部分变形工具也可以反映压感笔的压力。

要扭曲所选路径：

1 | 选择部分变形工具。
2 | 拖曳指针穿越路径来重绘路径

要选择部分变形工具指针的大小：

点击不放并按向右方向键或者2以增加指针的宽度。
点击不放并按向左方向键或者1以减小指针的宽度。
要设置指针的以及受影响的路径的长度，在选项面板里的尺寸文本框中键入从1到500的值。这个值表示指针以像素为单位的值。

要设置选择部分变形工具指针的强度：

在选项面板里的强度文本框中键入从1到500的值。这个值表示指针完全强度的百分比。百分比越高，强度越大。


使用位图概述--蓝骑士（侠客岛版权所有）

使用位图 > 使用位图概述

使用位图概述

位图由像素点组成.每一个像素点其实就是很小的色块.当把图像放大后,我们看见的类似马赛克的效果就是把每一个像素点放大后看见的色块.我们生活中的照片也是位图.Fireworks除了能够运用大量的矢量工具在矢量图模式进行图像编辑,也提供了大量的位图模式下的位图编辑工具.

位图编辑工具包括了油漆桶,传统的绘画工具如画刷,橡皮擦等等.位图编辑同样可以进行图像边缘羽化,图像剪切和图像变形等操作.

蓝骑士编译


--蓝骑士（侠客岛版权所有）

使用位图 > 在位图编辑模式编辑

在位图编辑模式编辑

您可以创建或导入位图图形,在位图编辑模式绘制图像,或者将矢量对象转换为位图图形.关于图像导入,请参看在Fireworks文件中插入对象.

Fireworks默认位图图像为位图图形,例如导入JPEG图像将被作为一个位图图形.

您也可以将矢量对象转换为位图图形,包括将多个矢量对象转换为一个位图图形.矢量转换为位图是不可逆的过程,除非您使用 Undo来取消转换的操作.位图图形不可以转换为矢量对象.

创建新的位图图形:

创建新的空的位图图形:

使用圈选或套索工具选择一定区域.
选择菜单 Insert > Empty Bitmap(插入 > 空的位图图形).

矢量对象转换为位图图形:

选择菜单 Modify > Convert to Bitmap(修改 > 转换为位图图形).

在位图编辑模式使用位图绘制工具

您可以使用基本的形状工具,直线工具,画刷等在位图编辑模式进行图像绘制.当您在位图编辑模式,原来的矢量对象将不受到位图编辑的影响.(它们浮动在画布上,而位图编辑针对画布)

如果您选取了一个圈选区域,编辑仅对圈选区域产生效果.关于圈选请参看选择圈选区域

如果您绘制的图形或直线超过画布大小,超出部分将自动被截去.

在位图编辑模式绘制图像:

1 | 选择基本的形状工具,直线工具,铅笔和画刷等工具.
2 | 在对应面板设置相关属性.
3 | 在画布上绘制.

利用油漆桶改变填充色彩

当您使用圈选或套索等工具选取一定色彩区域后,您可以使用油漆桶工具改变填充色彩.

油漆桶工具(Paint Bucket tool)

改变填充色彩:

1 | 选择您希望的填充色Choose a color in the fill color box.
2 | 双击油漆桶工具.
3 | 在工具面板,选择 填充所选区域(Fill Selection).
4 | 在圈选区域点击油漆桶工具.圈选区域将改变色彩.

擦除像素

使用橡皮擦工具擦除像素.

橡皮擦工具(Eraser tool)

默认的,橡皮擦工具显示为橡皮擦形状.您也可以改变工具的显示属性,详细请参看属性设置.

擦除像素:

1 | 双击橡皮擦工具,打开工具选项面板.
2 | 设置橡皮擦色彩属性:
 | Transparent 透明 使被擦除区域透明.
 | Fill Color 填充色 使被擦除区域填充为填充色.
 | Stroke Color 笔触色 使被擦除区域填充为笔触色.
 | Canvas Color 画布色 使被擦除区域填充为背景色.
3 | 选择橡皮擦形状和边缘形状.
4 | 设置 边缘柔化(Edge Softness) 属性使橡皮擦边缘柔化.
5 | 设置 尺寸(Eraser Size) 属性调整橡皮擦大小.
6 | 在您希望擦除的区域拖动橡皮擦工具,擦除像素.

圈选区域羽化

边缘羽化不同于模糊,它不改变图像内部的清晰程度,而仅仅对边缘进行调整.羽化效果常常使图像更好的融合在一起.

圈选区域羽化:

1 | 圈选后,选择菜单 Modify > Marquee > Feather(修改 > 圈选 > 羽化) 打开羽化对话框.
2 | 输入羽化的数值,点击 OK 确定.
 | 羽化数值决定羽化的程度和范围.

蓝骑士编译


克隆图像--蓝骑士（侠客岛版权所有）

使用位图 > 克隆图像

克隆图像

使用像章工具您可以克隆图像.当您使用像章工具,将出现两个光标图像,一个是被克隆图像区域,一个是克隆的图像区域.

像章工具(Rubber Stamp tool)

当您在修补一些图像的时候使用像章工具将非常有用.

像章工具的光标(左上的是被克隆图像区域,右下的是克隆的图像区域)

克隆也可以创建一些有趣的图像效果,例如复制出相同的人脸,或者使图像的某些关键特征.

克隆图像:

1 | 双击像章工具.
2 | 在工具选项面板,设置源(Source)属性:
 | 选择 Fixed 将锁定源区域(蓝色圆).这样您可以对一个区域进行多次克隆.
 | 选择 Aligned 将取消锁定,确定像章两个光标的距离后,两者将一起运动.
3 | 设置图样(克隆的图像)属性:
 | 选择 Image 将只对位图图形进行克隆.
 | 选择 Document 将包括矢量对象.
4 | 在像章尺寸中调整像章的大小.
5 | 在边缘柔化程度中调整像章边缘的柔化程度.
6 | 在您被克隆的区域第一次点击像章确定源区域.
7 | 在放置克隆图像的区域第二次点击像章确定图样区域.然后拖动像章工具开始克隆.
 | 注: 按住 Alt键(Windows操作系统) 或 Option键(Macintosh操作系统)改变源区域.

蓝骑士编译


Cropping a bitmap image（侠客岛版权所有）

使用位图 > 剪辑位图图形

剪辑位图图形

使用菜单 Edit > Crop Selected Bitmap(编辑 > 剪辑位图图形),您可以将选中的区域剪辑为单独的位图图形.该工具常用于剪辑照片中的关键图像.

剪辑工具(Crop tool)

剪辑位图图形:

1 | 选择剪辑工具或菜单 Edit > Crop Selected Bitmap(编辑 > 剪辑为图图形).在位图上出现剪辑控制柄.
2 | 调整控制柄,决定您需要保留的区域:
 | 直接拖动控制柄.
 | 按住 Shift键的同时使用键盘上下左右键进行调整.
3 | 调整好后,双击所选的区域,此时图像剪辑到所选择的大小.选区外的图像被去处.
 | 在剪辑完成前,您可以按下键盘Esc键取消剪辑命令,退出剪辑状态.

蓝骑士编译


进入位图编辑模式--蓝骑士（侠客岛版权所有）

使用位图 > 进入位图编辑模式

进入位图编辑模式

当你选择特定的位图编辑工具如套索(Lasso),在图像上双击,或者在层面板(Layers)种选择位图图像命令,Fireworks自动进入位图编辑模式.当您在位图编辑模式编辑图像时,画布的边缘将出现如下的斑马纹,提示您文件当前正在位图编辑模式操作.

注: 在前一个版本中的Fireworks中,位图编辑模式(bitmap mode)又被称为影像编辑模式(image edit mode).

位图编辑模式时画布边缘的斑马纹提示.

位图模式操作的是画布上的像素,而不是独立的对象.所以,当您进入位图编辑模式时,你需要确定您将对像素点进行操作.

上面分别是: 包含路径和路径点的矢量对象 由像素点组成的位图图形

切换位图编辑模式

要对图像进行像素点的操作,您必须从矢量图编辑模式切换到位图编辑模式.

切换到位图编辑模式:

用下列工具点选画布上的位图图形: 圈选(Marquee), 椭圆圈选(Ellipse Marquee), 套索(Lasso), (多边形套索)Polygon Lasso, 魔术棒(Magic Wand), 橡皮擦(Eraser), 或像章(Rubber Stamp).
使用指针工具(Pointer tool)双击位图图形.
点选层面板(Layers)对象列表中的位图图形的对象显示块(thumbnail).
选中位图图形,选择菜单 Modify > Edit Bitmap(修改 > 位图编辑).

返回矢量图编辑模式:

点击文件窗口下方的 停止(Stop) 按钮.
用任何选取工具(如指针,子选择)在画布内空白区域双击.
用任何选取工具(如指针,子选择)在画布内外白区域双击.
停止(Stop) 按钮
在层面板对象列表中选择矢量对象.
选择菜单 Modify > Exit Bitmap Mode(修改 > 退出位图编辑).
按键盘 Esc 键.

临时隐藏斑马纹:

选择菜单 View > Hide Edges(显示 > 隐藏边缘). 离开位图编辑模式将自动恢复.

设置斑马纹属性:

1 | 选择菜单 Edit > Preferences(编辑 > 属性).
2 | 在属性对话框中,选择 编辑(Editing) 标签.
3 | 取消 显示斑马纹(Display Striped Border) 选项将关闭斑马纹提示,点击 OK 确定.

设置斑马纹环绕文件窗口:

1 | 选择菜单 Edit > Preferences(编辑 > 属性).
2 | 在属性对话框中,选择 编辑(Editing) 标签.
3 | 取消 环绕文件(Expand to Fill Document)选项,点击 OK 确定.
 | 取消环绕文件选项,将使斑马线提示在文件放大时环绕文件窗口,而不是文件.这样,当对文件中较小的位图图形进行放大后编辑时,仍能获得位图编辑模式的斑马线提示.

蓝骑士编译


选取像素区域--蓝骑士（侠客岛版权所有）

使用位图 > 选取像素区域

选取像素区域

在位图编辑模式,基本的选取像素区域工具是 圈选(Marquee), 椭圆圈选(Ellipse Marquee), 套索(Lasso), (多边形套索)Polygon Lasso 和魔术棒(Magic Wand).

圈选工具(Marquee tools)

套索和魔术棒工具(Lasso and Magic Wand tools)

像素区域选取工具定义了您希望进行操作的像素区域.当您选取区域后,您可以对选取的像素进行操作:

您可以通过指针工具,放缩工具拖拽移动和变形选取的区域.
您可以对选取的区域进行编辑,移动,剪切,复制.

圈选区域后,切换工具到指针工具(Pointer tool),您可以将圈选区域作为浮动对象进行拖动和编辑.

蓝骑士编译


圈选工具选项--蓝骑士（侠客岛版权所有）

使用位图 > 选取像素区域 > 圈选工具选项

圈选工具选项

双击圈选,套索或魔术棒工具,在工具选项(Tool Option)面板将显示对应的工具选项.其中的 边缘(Edge) 选项是共有的:

Hard 实线边缘.

Anti-alias 抗锯齿边缘.

Feather 羽化边缘.

样式(Style)选项仅在圈选工具选项中:

Normal 普通.

Fixed Ratio 按照固定长宽比例选取区域.

Fixed Size 按照选定长宽尺寸选取区域.

选取举行或椭圆区域:

1 | 双击 圈选(Marquee)或椭圆圈选(Ellipse Marquee)工具,打开工具选项(Tool Options)面板.
2 | 选择样式(Style)和边缘(Edge).
3 | 在画布上拖拽需要的区域.
 | 注: 按住 Shift 键将选取正方形或正圆的区域.按住 Alt 键(Windows操作系统) 或 Option 键(Macintosh操作系统)按照中心向四周扩散选取区域.

选取不规则区域:

1 | 双击套索工具(Lasso)打开套索工具选项面板.
2 | 选择边缘选项.
3 | 在画布上拖拽出您希望选取的区域.

选择多边形区域:

1 | 双击多边形套索(Polygon Lasso)工具打开工具面板.选择边缘选项.
2 | 在画布上一点一点的选取多边形的定点.
3 | 关闭多边形区域:
 | 点击起点.
 | 在工作区双击.
 | 注: 按下 Shift 键多边形区域边界线段将按照45度整数倍方向选取.

选取类似色彩区域:

1 | 双击 魔术棒(Magic Wand)工具打开工具选项面板.
2 | 选择边缘选项,设置 容差(tolerance) 等级.
 | 容差(Tolerance)设置将决定色彩类似的程度.设置0,则只有与某一个色彩相同的区域才被选中.设置65,则与某一个色彩类似的色彩区域按照65的色彩范围被选中,选取的区域更大.
3 | 设置好属性在画布上点选您希望的色彩.Fireworks自动选取与该色彩类似的色彩区域.
 | 上图为设置容差值87

在圈选和套索的基础上选取类似色彩区域:

1 | 选择圈选和套索区域.
2 | 选择菜单 Edit > Select Similar(编辑 > 选取类似色彩).Fireworks自动根据容差值选取区域.
 | 容差值由当前工具面板设置的容差值决定.

删除圈选:

选取另一个圈选将自动取消前一个圈选.或者在画布外点击.
选择菜单 Edit > Deselect(编辑 > 取消).
退出位图编辑模式.

蓝骑士编译


调整圈选--蓝骑士（侠客岛版权所有）

使用位图 > 调整圈选

调整圈选

当用圈选或套索工具选取一定区域后,您可以移动圈选而不影响其他区域.您也可以对圈选进行编辑.

编辑圈选包括边缘扩展和收缩,边缘光滑,创建浮动圈选等.浮动圈选允许您对圈选区域进行编辑,移动,剪切,复制等.

移动圈选

您可以移动圈选的区域而不影响其他区域.

移动圈选:

利用圈选或套索工具选取区域然后拖拽区域.
选取圈选区域,使用键盘上下左右键按照1像素距离移动圈选.
选取圈选区域,按住Shift键的同时使用键盘上下左右键按照10像素距离移动圈选.

蓝骑士编译


添加或较少圈选区域--蓝骑士（侠客岛版权所有）

使用位图 > 调整圈选 > 添加或较少圈选区域

添加或较少圈选区域

使用特定的键盘键,您可以在原有的圈选上进行添加和减少圈选区域.

添加圈选区域:

按住键盘Shift键,您可以在原来的圈选上添加新的圈选.

减少圈选区域:

按住键盘Alt键(Windows操作系统)或Option键(Macintosh操作系统),选择您希望减少的区域.

复合圈选:

1 | 在圈选的基础上,按住键盘 Alt+Shift键(Windows操作系统)或 Option+Shift键(Macintosh操作系统),圈选第二个圈选进行复合圈选.
2 | 复合圈选后,两个圈选重选的区域保留下来作为圈选区域.
 | 在椭圆圈选上复合矩形圈选
 | 形成的复合圈选

蓝骑士编译


扩展和收缩边界--蓝骑士（侠客岛版权所有）

使用位图 > 调整圈选 > 扩展和收缩边界

扩展和收缩边界

当您选定圈选后,您还可以适当的扩展和收缩圈选边界

扩展边界:

1 | 圈选后,选择菜单 Modify > Marquee > Expand(修改 > 圈选 > 扩展).
2 | 输入您希望扩展的数值,点击 OK 确定.

收缩边界:

1 | 圈选后,选择菜单 Modify > Marquee > Contract(修改 > 圈选 > 收缩).
2 | 输入您希望收缩的数值,点击 OK 确定.

蓝骑士编译


在圈选上选取边界区域--蓝骑士（侠客岛版权所有）

使用位图 > 调整圈选 > 在圈选上选取边界区域

在圈选上选取边界区域

您可以在圈选上选取边界区域,形成边框.然后对圈选区域进行编辑创建图像效果.

原来的圈选

在圈选上选取边界区域

在圈选上选取边界区域:

1 | 圈选后,选择菜单 Modify > Marquee > Border(修改 > 圈选 > 边界区域).
2 | 输入您希望选取的边界区域数值,点击 OK 确定.

蓝骑士编译


光滑圈选边界--蓝骑士（侠客岛版权所有）

使用位图 > 调整圈选 > 光滑圈选边界

光滑圈选边界

有时候使用魔术棒等的工具选取的区域是非常不规则区域,边界常常出现很多锯齿状.此时您可以对圈选进行边界光滑.

光滑前后的效果比较

光滑圈选边界:

1 | 圈选后,选择菜单 Modify > Marquee > Smooth(修改 > 圈选 > 光滑).
2 | 输入您希望选取的边界光滑程度,点击 OK 确定.

创建浮动圈选

当您直接创建圈选后,移动圈选,圈选区域的像素并不跟随圈选而移动.此时您可以先创建浮动圈选,然后可以对浮动圈选进行移动,编辑,剪切和复制等.

创建浮动圈选:

圈选后,切换到指针工具(Pointer tool),选取圈选,此时圈选默认转换为浮动圈选.

您可以移动浮动圈选,当您放置到新的位置后,如果此时圈选取消,则浮动圈选将自动融合到画布上.

蓝骑士编译


使用文字概述--蓝骑士（侠客岛版权所有）

使用文字 > 使用文字概述

使用文字概述

Fireworks的文字编辑功能非常丰富.您可以应用各类字体和尺寸创建文字,调整字距,行距,色彩,基线等文字属性.结合笔触,填充,效果和样式您可以在图像设计中创建生动的文字对象.

当您对文字进行实时效果处理后,例如添加阴影,您仍然可以自由的对文字对象进行调整,例如改变文字的拼写.您也可以复制包含文字的对象,然后在新粘贴的对象中改变其中的文字.(例如处理一些样式相同而文字不同的按钮.)更多的文字应用还包括文字竖直编排,文字变形,文字路径,文字转换为路径以及文字转换为图片等.

Fireworks可以从外部导入文字,并且保持外部文字原来属性.当您导入包含文字的Photoshop文件后,文字仍然可以在Fireworks中进行编辑.如果Fireworks无法在系统中找到您所导入的文字的字体,Fireworks会自动询问进行相近字体的替换.

蓝骑士编译


设置排列--蓝骑士（侠客岛版权所有）

使用文字 > 编辑文字 > 设置排列

设置排列

排列决定了每行文字在段落中的位置关系,包括左对齐,居中,右对齐.默认为左对齐排列.

您也可以应用伸展效果,当你拉伸或缩减文字对象时,文字始终保持充满文字对象.

水平伸展效果

使用文字编辑期或菜单命令设置排列.您可以对文字对象中的一部分段落进行分别设置.

使用文字编辑器设置排列:

1 | 高亮选中您需要排列的段落.
2 | 点击相应的排列按钮.

蓝骑士编译


设置文字色彩--蓝骑士（侠客岛版权所有）

使用文字 > 编辑文字 > 设置文字色彩

设置文字色彩

第一次输入文字时,Fireworks默认为黑色无笔触文字.如果您改变了文字属性,Fireworks将保留当前设置到下一次应用.文字色彩和字体属性在不同的文件中保持连续性.(也就是您在一个文件使用的字体和色彩,在紧接的下一次操作中保留,无论在当前文件还是在其他文件.)

您可以对文字整体定义色彩,也可以对某些或某个字符单独定义.

设置文字色彩:

在文字编辑器中高亮选中您需要改变色彩的文字.
在色彩对话框中选择您希望的色彩.
色彩对话框

蓝骑士编译


光滑文字边缘--蓝骑士（侠客岛版权所有）

使用文字 > 编辑文字 > 光滑文字边缘

光滑文字边缘

使用抗锯齿光滑文字边缘.这使得文字能更好的融入图像.

使用文字编辑器设置抗锯齿.抗锯齿对文本对象中的文字整体作用.

设置抗锯齿:

1 | 打开文字编辑器.
2 | 从抗锯齿下拉框中选择抗锯齿选项:Crisp, Strong, or Smooth.
3 | 点击 OK 确定.
 | 注: 当你打开矢量图像时,例如 FreeHand 生成的文件,Fireworks自动对文字应用抗锯齿属性.您可以打开文字编辑器进行调整.关于打开矢量图像更多信息,请参看打开 FreeHand, Illustrator, 或CorelDRAW 文件.

蓝骑士编译


应用笔触,填充,效果和样式--蓝骑士（侠客岛版权所有）

使用文字 > 应用笔触,填充,效果和样式

应用笔触,填充,效果和样式

您可以在文字上应用笔触,填充,效果和样式.样式表中的样式,无论是图形还是文字样式都可以应用在文字对象上.您还可以保存当前的文字属性为新的样式.

应用笔触,填充,效果和样式的文字对象仍然可以编辑.效果的添加是实时的.

应用笔触,填充,效果和样式

关于样式的更多信息,请参看 关于样式. 关于实时效果的更多信息,请参看 应用实时效果.

蓝骑士编译


保存文字属性--蓝骑士（侠客岛版权所有）

使用文字 > 保存文字属性

保存文字属性

应用笔触,填充,效果和样式的文字可以将属性保存为新样式.保存文字属性仅仅保存文字添加的效果,并不保存文字本身.

保存文字属性为样式:

1 | 创建文字对象,应用效果.
2 | 选中文字对象,并在 Style panel(样式面板)右上角小箭头的弹出菜单中选择 New Style (新样式).
3 | 选择属性并命名.
4 | 点击 OK 确定.

蓝骑士编译


文字路径--蓝骑士（侠客岛版权所有）

使用文字 > 文字路径

文字路径

为了使文字对象能够更自由,不仅仅是块状的文字,您可以创建不规则路径并将文字附着到路径,形成文字路径.文字沿着路径的方向排列,并且保持可编辑性.关于绘制路径的更多信息,请参看 绘制圆角矩形 , 绘制多边形 等.

文字附着的路径将暂时失去笔触,填充,效果等属性.您在文字上添加的效果不会添加到路径上.如果分离文字路径,路径仍然保持原来的效果属性.

文字附着到路径:

1 | 按住 Shift 键复选文字对象和路径.
2 | 选择菜单 Text -> Attach to Path (文字 -> 附着到路径).

分离文字路径:

选择菜单 Text -> Detach from Path (文字 -> 路径分离).

编辑文字路径中的文字:

双击文字路径,打开文字编辑器.
选择 Text(文字工具)点击文字路径.

编辑路径形状:

1 | 选择菜单 Text -> Detach from Path(文字 -> 路径分离).
2 | 编辑路径.
3 | 编辑后,再次将文字附着到路径.

如果附着到路径上的文字超过了路径的长度,Fireworks自动返回路径起点继续将文字附着到路径.

文字路径,文字超过路径长度.

您绘制路径的方向将影响文字路径的方向.例如,如果自右向左绘制路径,文字路径如下图所示.

自右向左的路径

你可以通过翻转方向或文字方向来改变文字路径的方向.您也可以改变文字附着的起点.

改变文字方向:

1 | 选择菜单 Text -> Orientation (文字 -> 方向),选择方向.

改变文字在路径上的方向:

1 | 选择菜单 Text -> Reverse Direction(文字 -> 翻转方向).
 | 文字环绕路径方向
 | 路径竖直方向
 | 文字竖直倾斜路径方向
 | 文字水平倾斜路径方向
 | 水平方位的文字和竖直方位的文字在路径上

移动附着起始点:

1 | 选中文字路径.
2 | 在对象面板,输入偏移值.

蓝骑士编译


文字变形--蓝骑士（侠客岛版权所有）

使用文字 > 文字变形

文字变形

您可以像变形其他对象一样变形文字对象,进行放缩,倾斜,扭曲,翻转等.

变形后的文字保持可编辑性.变形不改变文字属性.更多信息,请参看 变形和扭曲对象.

蓝骑士编译


文字转换为路径--蓝骑士（侠客岛版权所有）

使用文字 > 文字转换为路径

文字转换为路径

当您将文字转换为路径,您可以像编辑其他路径一样对它进行编辑.此时文字已经转换,不能再做为文字对象操作,例如使用文字编辑器.

文字转换为路径主要考虑当您的文件在不同的计算机进行交流协作时,如果对方计算机不包含您所使用的字体,你可以将文字首先转换为路径,以便正确显示.

注: 在浏览器中应用您不必考虑对方的计算机没有安装您使用的字体.因为图像在输出时已经成为位图图像,例如GIF.

文字转换为路径:

选择菜单 Text -> Convert to Paths (文字 -> 转换为路径).

文字转换为路径后,仍然保持着转换前的样子,但您只可以使用矢量工具进行再编辑,不可以使用文字工具.

蓝骑士编译


导入文字--蓝骑士（侠客岛版权所有）

使用文字 > 导入文字

导入文字

您可以通过拖拽或者剪贴的方式将其他文件中的文字导入到Fireworks.

您也可以在Fireworks中选择打开或导入文本文件.

Fireworks可以导入的文本格式:

RTF
ASCII

打开或导入文本文件:

1 | 使用菜单命令:
 | 选择菜单 File -> Open (文件 -> 打开).
 | 选择菜单 File -> Import (文件 -> 导入).
2 | 选择您需要打开的文本文件.
3 | 点击 OK 确定.

蓝骑士编译


从Photoshop导入文字--蓝骑士（侠客岛版权所有）

使用文字 > 导入文字 > 从Photoshop导入文字

从Photoshop导入文字

您可以打开或导入整个Photoshop文件,或者通过拖拽,剪贴的方式导入文字.

拖拽或剪贴将丢失文字的可编辑性,使导入的文字成为位图图形.

打开或导入整个文件,文字保持可编辑性.

注: Photoshop中的文字层层名保留..

蓝骑士编译


输入文字--蓝骑士 （侠客岛版权所有）

使用文字 > 输入文字

输入文字

您可以使用 Text(文字工具)和 Text Editor(文字编辑器)在图像中输入文字.

Text(文字工具)

Text Editor(文字编辑器)

Fireworks的文字在文件中显示为一个带有控制柄的文字对象.

输入文字:

1 | 选择Text(文字工具).
2 | 在画布您希望放置文字对象的地方点击鼠标.
 | 此时自动弹出Text Editor(文字编辑器).
3 | 在属性框中选择您需要的文字属性,如 color(色彩), font(字体), size(大小)等.
4 | 在文字框中输入文字. 换行使用 Enter 键(Windows操作系统) ,Return 键(Macintosh操作系统).
5 | 高亮选中文本框中的文字宁可以再次改变文字的属性.
6 | 在画布中查看您在 Text Editor(文字编辑器)中输入的文字的效果:
 | 选择 Text Editor(文字编辑器)右下角的 Auto-Apply 选项.
 | 点击 Apply按钮.
7 | 点击 OK 完成文字输入.
 | 文字以文字对象出现在画布上.
 | 注: 在 Text Editor(文字编辑器)中Fireworks会记录您使用的文字色彩,应用在下一次的文字输入.

再次打开文字编辑器:

双击画布上的文字对象.

蓝骑士编译


导入 RTF 文本--蓝骑士（侠客岛版权所有）

使用文字 > 导入文字 > 导入 RTF 文本

导入 RTF 文本

当您导入 RTF 文本, Fireworks 保留下列属性:

字体,文字大小,样式(加粗,倾斜,下滑线)
排列 (左对齐,居中,右对齐)
行距
基线
字距
水平放缩
首字符的色彩

RTF 其他信息被忽略.

Fireworks 不能通过拖拽或剪贴导入 RTF 文本.

蓝骑士编译


导入 ASCII 文本--蓝骑士（侠客岛版权所有）

使用文字 > 导入文字 > 导入 ASCII 文本

导入 ASCII 文本

你可以使用任何方法导入 ASCII 文本.导入的文字使用系统默认字体,12 pixels(12像素)大小,当前填充色彩.

蓝骑士编译


调整缺损字体--蓝骑士（侠客岛版权所有）

Using Text > Importing text > 调整缺损的字体

调整缺损字体

如果您打开的文件包含系统没有的字体,Fireworks将弹出字体缺损对话框询问.

您可以选择其他字体替换缺损字体.如果您不选择替换,Fireworks默认使用系统字体.

当文件在其他包含缺损字体的计算机上再次打开,Fireworks会使用原始的字体,忽略替换的字体.

选择替换字体:

1 | 在缺损字体列表中选择一种缺损字体.
2 | 在字体列表中选择替换字体,点击 OK 确定.

保留缺损字体:

点击 No Change (不替换) 按钮.

蓝骑士编译


移动文字对象--蓝骑士（侠客岛版权所有）

使用文字 > 输入文字 > 移动文字对象

移动文字对象

您可以像移动其他对象一样移动文字对象.在文字编辑器打开的情况下,您也可以移动文字对象.

移动文字对象:

拖动文字对象到新的位置.

蓝骑士编译


自动调整--蓝骑士（侠客岛版权所有）

使用文字 > 输入文字 > 自动调整

自动调整

当您输入单行文字时,Fireworks自动调整对象长度,也就是文字对象自动向后延长.如果您减少其中的文字,文字对象自动缩短.当您通过调整控制柄在画布上改变文字对象宽度时,单行文字会自动换行.多行文字不包括自动换行功能.

调整文字对象:

拖拽文字对象的控制柄.

蓝骑士编译


编辑文字--蓝骑士（侠客岛版权所有）

使用文字 > 编辑文字

编辑文字

您可以编辑文字对象的色彩,文字大小,字体,间距,行距基线等文字属性.

使用菜单Text下的选项或者Text Editor您可以对文字对象进行编辑.改变文字对象的某一项属性,使用菜单Text比较方便.改变文字对象的多项属性,使用Text Editor比较方便.

当您编辑文字时,文字上的笔触,填充,效果属性相应的自动重绘.

在文字编辑器中编辑文字:

1 | 双击文字对象.
2 | 在文字框中高亮选中您需要改变的文字.
3 | 改变属性并选择apply应用新的属性.
 | 关于文字属性,请参看本章对应章节.
4 | 点击 OK 完成编辑.

蓝骑士编译


选择字体,文字大小,样式--蓝骑士（侠客岛版权所有）

使用文字 > 编辑文字 > 选择字体,文字大小,样式

选择字体,文字大小,样式

您可以使用菜单Text命令和文字编辑器改变文字字体,文字大小,样式等属性.

注: 如果在Macintosh操作系统上使用 Type 1 字体, 您需要安装有 Adobe Type Manager (Adobe字体管理器) 4.0或以上版本.

文字编辑器默认的按照您选择的字体和文字大小显示文字.一个文字对象可以包含不同字体和文字大小的文字.

您也可以按照系统字体来显示文字编辑器中的文字.(在画布的文字对象中,文字仍然按照您选择的字体和文字大小显示.)

显示系统字体:

在文字编辑器中取消 Show Font (显示字体)选项.

按照默认文字大小和色彩显示:

在文字编辑器中取消 Show Size & Color (显示文字大小和色彩)选项.

在文字编辑器中改变字体,文字大小,样式:

1 | 在文字框中,高亮选中您需要改变的文字.
2 | 在字体下拉框中选择您需要的字体.
3 | 在文字大小下拉框中选择您需要的大小.(也可以直接输入数字.)
4 | 点击对应的按钮应用 bold(加粗), italic(倾斜), 或 underline(下滑线)等样式.
5 | 点击 OK 完成改变.

使用菜单Text命令改变字体,文字大小,样式:

1 | 选择文字对象(单个或多个,Shift键复选对象).
2 | 选择菜单 Text -> Font (文字 -> 字体)的字体子选项,改变文字对象的字体.
3 | 选择菜单 Text -> Size (文字 -> 文字大小)的文字大小子选项,改变文字对象文字大小.
4 | 选择菜单 Text -> Style (文字 -> 样式)的样式子选项,改变文字对象的样式.

蓝骑士编译


设置基线,行距--蓝骑士（侠客岛版权所有）

使用文字 > 编辑文字 > 设置基线,行距

设置基线,行距

基线决定了文字间的错落关系.使用基线可以创建下标和上标字符.

行距决定了行与行之间的间隔.这里的行按照基线为标准.所以行距也是行间基线的间隔.

使用文字编辑器设置行距和基线.

以上右方标注依次为: Kerning(字距), (Leading)行距, (baseline shift)基线, Stretch(伸展).

设置行距和基线:

1 | 在文字编辑器文字框中高亮选中您希望改变的字符.
2 | 在基线下拉框中选择数值,或直接输入数字.(调整单词基线可以创建下标和上标)
3 | 在行距下拉框中选择数值,或直接输入数字.默认为100%.
4 | 点击 OK 确定.

蓝骑士编译


设置字距--蓝骑士（侠客岛版权所有）

使用文字 > 编辑文字 > 设置字距

设置字距

字距调整单词间的间隔来改变文字的疏密程度.一些字体固化了字距,我们可以通过字距调整来改变字体的疏密程度.

字距调整范围在两个字符以内.也就是100%,字附间空隔两个字符.

使用文字编辑器设置字距.

取消自动调整:

在文字编辑器,取消 Auto Kern(自动调整)选项.

设置字距:

1 | 在文字编辑器的文字框选中您需要改变的字符:
 | 如果仅改变两个字符间距,直接将光标放置在字符间.
 | 如果改变一些字符,高亮选中您需要改变的字符.
2 | 输入数字或改变字距下拉框数值.
 | 默认为数值0%.增加数值加大字距,减小数值减少字距.

蓝骑士编译


设置方向和方位--蓝骑士（侠客岛版权所有）

使用文字 > 编辑文字 > 设置方向

设置方向

文字方向,决定了文字自左向右书写还是自右向左书写.默认为自左向右写.

自左向右,自右向左Text flowing left to right and right to left

文字方位决定了文字竖直排列还是水平排列.默认为水平排列.

水平排列,竖直排列

使用文字编辑器设置文字方向和方位.这些设置对文字对象中的文字整体作用.

文字编辑器中的文字方位,排列,文字方向按钮

使用文字编辑器设置文字方位:

点击水平或竖直文字方位按钮.

使用菜单命令设置文字方位:

选择菜单 Text -> Align submenu (菜单 -> 排列的子选项).

使用文字编辑器设置文字方向:

点击自左向右或自右向左文字方向按钮.

蓝骑士编译


应用颜色，笔触和填充概述 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 应用颜色，笔触和填充概述

应用颜色，笔触和填冲概述

Fireworks给您提供了广泛的选择颜色的空间。您可以使用默认色样来保持图形在各种不同的浏览器和操作平台上外观的一致，也可以使用 Windows 或 Macintosh的系统色样。甚至您可以创建自己的颜色和颜色组。

您可以使用几种颜色模型中的任何一种混和出您自己的颜色—16进制，RGB，CMY，HSB，或者 Grayscale。 您也可以察看使用这些颜色模式的文档中的颜色。

fireworks的所绘制的对象的笔触选项可以从极细的、如同铅笔一样，到比较宽的类似喷涂或泼墨状,填充选项的范围从固色填充到到多色渐变和位图图案填充。应用渐变填充和图案填充后，您可以在工作区内进行编辑，您可以对几乎所有的图像进行填充，您还可以为笔触和填充增加纹理,而且，您还能将一个对象上的笔触和填充作为一个样式保存下来，以后您可以将这个样式应用到其他对象上。

编译：Candy


应用笔触 - Candy （侠客岛版权所有）

应用颜色，笔触和填充 > 应用笔触

应用笔触

您可以改变钢笔，铅笔，和笔刷工具的笔触属性，这样您所绘制的下一个矢量对象就具有了新的笔触属性。您也可以将新的笔触属性应用到绘制好了的矢量对象上去。您可以在任何的矢量对象或文字对象上应用笔触。

当前的笔触颜色显示在工具面板上的笔触颜色盒上。使用工具面板可以改变绘图工具的笔触颜色。

在工具面板上前面有一个画笔的图标的是笔触颜色盒。

您也可以在笔触面板上改变笔触的颜色，和其他笔触属性。您可以从各种形状和大小的笔刷中进行选择。

改变绘图工具的笔触颜色。

1 | 在工具面板上的笔触颜色盒上点击颜色盒或颜色盒上的箭头打开颜色盒弹出窗口。
2 | 选择一种颜色。
3 | 选择绘图工具
4 | 拖曳鼠标绘制出对象

改变选中的对象的笔触颜色：

在工具面板上的笔触颜色弹出窗口内选择一种颜色。

反转笔触和填充颜色：

点击混色器或工具面板上的“反转颜色”按钮。

恢复默认颜色：

点击“默认颜色”按钮。

将选定的对象的所有笔触属性移除。：

点击“无笔触或填充”按钮，当前的对象会被设置为无笔触。

使用系统颜色选择器选择一种颜色：

1 | 在颜色盒弹出菜单上选择“系统颜色选择器”。
 | 颜色对话框(Windows) 或Apple颜色选择器(Macintosh)被打开。
2 | 从系统颜色选择器上选择一种颜色，然后点击确定。

这种颜色就成为新的笔触颜色。需要增加颜色到色样面板的信息，参见 自定义色样面板.

编译：Candy


改变笔触 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 改变笔触

改变笔触

您可以改变笔触用各种钢笔或者笔刷的特性创建路径，比如象铅笔一样细的、较宽的类似喷涂或是泼墨状的路径，笔触的纹理可以有更多的创造力。

使用笔触面板和编辑笔触对话框，您可以充分的控制每一个笔刷的各种细微差别，包括包括墨水量，笔尖大小和形状，纹理，边缘效果和外观。并且，灵敏度的设置可以控制在使用压敏笔时压力对笔触的影响，你可以将的笔刷设置保存供下次使用。

最新创造出的笔触的颜色显示在笔触颜色盒上。

使用笔触面板改变应用到对象上的笔触。

显示笔触面板：

选择 窗口 > 笔触

改变选中的对象的笔触属性：

1 | 在笔触面板上，从笔触类别弹出菜单中选择一个笔触类别，如铅笔、油彩或水彩。
2 | 从“笔触名称”弹出菜单中选择一个笔触。
3 | 改变笔触颜色，可以在颜色盒弹出窗口中选择一个色样。
4 | 要想改变边缘柔化效果，可以使用笔尖预览窗旁边的“边缘柔化”滑杆。
5 | 从“纹理”弹出菜单中选择纹理，输入数值定义其强度。需要更多信息，参见 给笔触和填充增加纹理.
 | 注意： 有些笔触类别在默认情况下都有一个纹理应用于笔触的

编译：Candy


改变笔触 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 改变笔触 >保存笔触

保存笔触

您可以改变特定的笔触的墨水量，笔尖形状和笔尖灵敏度。并且将自定义的笔触保存为样式以便在不同的文件中重复使用。

保存自定义的笔触只能当前的文件中应用，使用笔触面板上的选项弹出菜单编辑笔触的笔刷特性。您可以编辑笔触特性或是创建和保存自定义的笔触。

编译：Candy


改变笔触 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 改变笔触 > 创建自定义笔触

创建自定义笔触

使用“编辑笔触”对话框可以改变特定的笔触的属性。

打开编辑笔触对话框：

选择笔触面板选项弹出菜单上的“编辑笔触”，或点击笔触面板上的编辑按钮。

编辑笔触对话框上有三个标签面板：“选项”，“形状”，“灵敏度”

笔触预览窗在编辑笔触面板的底部，显示当前设置的笔刷形状。预览窗中的笔刷从左到右逐渐变细或逐渐减弱或者任何其它的变化都是说明当前的压敏和速度敏感设置。

设置笔刷的一般选项：

1 | 在选项面板上，设定墨水量，间距，流速等。高的流速会造成笔触的流动效果，就象使用了喷雾器一样。 .
2 | 如果你想将笔刷笔触交叠起来制作更为密集的笔触效果，可以选取 Build-up。
3 | 设置笔触的纹理可以修改“纹理”选项。数字越大，纹理就越明显。
4 | 设置边缘纹理，可以在 “边缘纹理”文本框中输入一个数字，然后从 “边缘效果” 弹出菜单中选择一个纹理效果。
5 | 在笔尖文本框内，输入笔刷笔触的笔尖数。如果您选择使用多个笔尖，还要再在下边输入一个“笔尖间距”值，然后选择一个笔尖颜色变化方式，可供选择的变化方式有 “随机”，“一致”，“补偿”，“色调”，或者 “阴影”。
6 | 点击应用将设置应用到选定的笔触上，然后点击确定。

修改笔刷笔尖：

1 | 在“形状”面板上，选择“square”可以产生正方形的笔尖，或者取消选择产生圆形的笔尖。
2 | 输入笔刷笔尖的大小，边缘柔度，笔尖外观和笔尖角度的值。
3 | 点击应用然后点击OK

如果您使用 Wacom 的压敏板和压敏笔，Fireworks 还提供了一些笔触设置通过速度和压力来控制笔触的特性。您可以选择经由写字笔控制的笔触特性。

设置笔尖灵敏度：

1 | 在“灵敏度”面板上，选择您可以从“笔触属性”弹出菜单上选择一个笔触的属性，如“大小”“墨水量”“饱和度”。
2 | 从“影响因素”中选择灵敏数据影响当前笔触属性的角度，然后点击OK。

编译：Candy


改变笔触 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 改变笔触 > 保存笔触设置

保存笔触设置

您可以将编辑好的笔触保存起来用于当前或其他文件。保存笔触设置以便在多个文件中使用可以将它们保存为样式。

保存笔触在当前文件中使用：

1 | 在笔触面板选项弹出菜单上，选择“将笔触保存为”。
2 | 在“将笔触保存为”对话框中，输入笔触的名字，并点击确认。
 | 这个笔触的名字就会被增加到笔触名字弹出菜单中，您就可以在文件中使用。

在其他文件中使用保存的笔触：

1 | 复制一个带有保存笔触的对象：
2 | 将复制的对象粘贴到其它的文档中。
 | 这时保存的笔触就会被添加到那个文档的笔触名字弹出菜单中提供使用了。

重命名笔触：

1 | 取消对所有对象的选择。
2 | 在笔触面板选择要更改名字的笔触。
3 | 在选项弹出菜单上选择“重命名笔触”。
4 | 在“重命名笔触”对话框中输入新的名字并点击确认。

删除一个笔触：

1 | 在选择笔触面板上选择一个笔触。
2 | 在选项弹出菜单上选择“删除笔触”。

笔触应用到路径上的位置

在默认情况下，一个对象的笔刷笔触是位于路径的中间位置的。您可以通过修改选项来将笔触完全放到路径里边或者外边的。这就使得你能控制包含笔触的对象的整体大小，并且可以制作出富有创意的效果来，例如你可以在斜角按钮的边缘使用笔触等。

笔触居中, 笔触居内, 笔触居外

使用对象面板上的笔触放置按钮可以重新安排笔触位置。

将选中的路径的笔触移到居内或居外：

1 | 在对象面板上选择一个笔触放置按钮：居内，居中或居外。
2 | 您可以根据需要选择“填充覆盖笔触”
 | 一般情况下，笔触是覆盖在填充上面，选择这个选项，如果在填充不透明的情况下，在路径内的笔触就会被覆盖而看不到，如果填充有一定的透明度，可能会给路径内的笔触染上色或是混合起来。

编译：Candy


应用填充 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 应用填充

应用填充

在用矩形、圆角矩形、椭圆形形状工具绘图时，您可以随时改变对象的填充属性，你可以绘制出固体填充、渐变填充或是图案填充的对象。

当前填充的颜色会显示在工具面板的颜色盒上，用工具面板可以改变绘图工具的填充颜色。

工具面板上前面有一个油漆桶的图标的是填充颜色盒

你也可以在填充面板上改变绘图工具的填充颜色。你可以从多种的渐变和图案填充中进行选择。而且在绘制完成一个对象以后，你仍然可以改变它的填充属性。

你使用笔刷，铅笔和钢笔工具绘制的对象是没有填充的，你必须在对象绘制完成以后再进行填充。

改变基本形状工具的填充颜色

1 | 在工具面板的填充颜色盒上，点击向下的箭头打开颜色盒弹出窗口，
2 | 在色样内选择一种颜色
3 | 选择矩形、椭圆形或多边形工具。
4 | 拖曳鼠标绘制出对象

编译：Candy


改变填充 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 改变填充

改变填充

您可以将路径的填充改变为固色填充，抖动填充，图案填充或是渐变填充，从单色的填充到象绸缎，波纹或折痕的渐变填充。另外您可以改变一个填充的各种属性，包括颜色，边缘，纹理和透明度。

您可以保存自定义的渐变填充，以便在当前或其他文件中使用。要想在多个文件中使用保存的渐变填充，您可以将它存为样式。新创建的填充会将显示在工具面板上的填充颜色盒中并被指定为当前颜色。

使用填充面板编辑填充属性

编译：Candy


改变填充 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 改变填充 > 改变固色填充

改变固色填充

固色填充是将一种单一的颜色填充在对象的内部，您可以在工具面板、填充面板或混色器上改变一个对象的填充颜色。

编辑选中的对象的固色填充：

1 | 在填充面板上的填充类型弹出菜单内选择“固色”
2 | 在颜色盒弹出窗口内选择一种颜色。
 | 这种颜色就会应用到选中的对象上去，并成为当前激活的填充颜色。

编译：Candy


改变填充 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 改变填充 > 应用渐变填充

应用渐变填充

填充类型中除了“无填充”“固色填充”“图案填充”“抖动填充”以外都是渐变 填充。渐变填充混合不同的颜色产生出多彩多姿的效果。

分别应用绸缎，放射，线形渐变填充的对象

应用渐变填充的选中的对象

1 | 在填充面板上从填充类型弹出菜单上选择一种渐变填充。
2 | 从填充名字弹出菜单上选择一种颜色组合，如Red，Green，Blue 或Pastels
 | 渐变填充会被应用到对象上去并成为当前的填充应用色。

编译：Candy


改变填充 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 改变填充 > 改变渐变填充

改变渐变填充

您可以使用编辑渐变填充弹出窗口，编辑，保存，重命名或删除渐变填充。

编辑渐变弹出窗口

打开编辑渐变弹出窗口：

1 | 选择一个具有渐变填充的对象或是在填充类型弹出菜单上选择一种渐变填充。
2 | 做下面的任意一步：
 | 点击填充面板上的编辑按钮。
 | 从填充面板选项弹出菜单上选择“编辑渐变”。
 | “编辑渐变”弹出窗口打开当前的渐变色出现在色道和预览区。

调整填充中颜色之间的过渡色：

左右拖动色样即可。

给渐变中添加新的色样：

点击色道与预览区之间的区域。

从渐变中移除一个色样：

将色样拖离“编辑渐变”弹出窗口

改变色样的颜色：

1 | 点击色样。
2 | 从弹出的颜色窗口中选一种颜色。

当您完成对渐变色的编辑以后，按Enter键或点击“编辑渐变”弹出窗口以外的地方。新的渐变填充就会出现在任何被选取的对象上，同时成为当前的应用填充。

编译：Candy


选择颜色 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 选择颜色

选择颜色

在您创作图像时，您可以使用色样面板选择一种新的颜色，色样面板上的颜色同样出现在笔触与填充面板，混色器，和工具面板的颜色弹出窗口。

色样面板

打开色样面板:

选择 窗口 > 色样.

工具面板上的颜色盒

颜色盒弹出窗口

打开颜色盒弹出窗口

点击颜色盒或颜色盒旁的箭头.

编译：Candy


将填充保存为样式 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 >将填充保存为样式

将填充保存为样式

您可以将任何对渐变填充的改变保存为样式，以便在不同的文件中使用。您也可以保存渐变填充，这样就只在当前的文件中使用。

编译：Candy


将填充保存为样式 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 将填充保存为样式 > 保存与重复使用渐变填充

保存与重复使用渐变填充

您可以将编辑过的渐变填充的设置保存起来，这样只能在当前的文档内使用，要想在多个文档中使用，必须将渐变填充存为样式。

保存渐变填充在当前文档中使用：

1 | 在填充面板的选项弹出菜单上选择“保存渐变为”
2 | 在“保存渐变”对话框内输入一个名字然后点击OK。

在其他文档内使用保存的渐变填充：

1 | 复制包含有保存的渐变填充的对象。
2 | 粘贴到其他文档中。

这样保存的渐变填充就会被添加到那个文档的填充面板上供使用了。

重命名一个渐变填充：

1 | 在填充面板上选择一个填充。
2 | 选择选项弹出菜单上的“重命名渐变”。
3 | 在“重命名渐变”对话框中输入所起的名字然后点击OK。

删除一个保存的渐变填充：

1 | 在填充面板上选择一个填充。
2 | 选择选项弹出菜单上的“删除渐变”。

编译：Candy


将填充保存为样式 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 将填充保存为样式 > 应用图案填充

应用图案填充

除了固色与渐变填充外，您还可以使用位图图象来给路径对象进行填充。 叫做 图案 填充. Fireworks自带了十几种的图案填充，包括 Berber Rug, Photinia Leaves, 和Bricks.

您也可以使用一个位图文件进行图案填充，可以用做图案的文件格式有： PNG, GIF, JPEG, BMP, TIFF, 和 PICT (只有Macintosh系统能使用)。如果图案是一个 32-bit 的透明图象，这个透明将会影响填充，如果图象不是32-bit，就一定是不透明的。

如果想把外部的图案放在“填充名称”弹出菜单中供所有的文档使用，可以将图案文件复制到 Fireworks 4\Configuration\Patterns 文件夹中

应用图案填充到选定的对象：

1 | 在填充面板上的“填充类型”弹出菜单中选择“图案”
2 | 选择图案：
 | 在“图案名称”弹出菜单中选择一种图案。
 | 要使用外部图案，在“图案名称”弹出菜单中选择“其他”并找到要填充的图案文件。

这样图案填充就会出现在被选取的对象上并同时成为当前的应用填充。

注意： 尽管图案填充成为当前的应用填充并会应用到随后绘制的对象上，但是不会显示在工具面板、填充面板和混色器上的填充颜色盒上。

编译：Candy


渐变填充和图案填充的变形和扭曲 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 渐变填充和图案填充的变形和扭曲

渐变填充和图案填充的变形和扭曲

对于应用到对象上的图案或渐变填充您可以进行移动、旋转、倾斜，改变宽度等处理。 当您选中了具有图案或渐变填充的对象或是油漆桶工具时。在对象上或是周围会出现一组句柄，拖动这些句柄可以调整填充。

使用填充句柄交互式的调整图案或渐变填充。

在对象内部移动填充：

拖动圆形句柄，或者用油漆桶工具在填充内点击新的位置。

旋转填充：

拖动与句柄相连的线条。

调整填充的宽度和倾斜度：

拖动正方形句柄

编译：Candy


设置硬边，去锯齿或羽化的填充边缘 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 设置硬边，去锯齿或羽化的填充边缘

设置硬边，去锯齿或羽化的填充边缘

在Fireworks里, 您可以将填充的边缘设置为普通的硬线条或是使用去锯齿或羽化将边缘变的柔和。在默认情况下，边缘都经过了去锯齿处理。去锯齿通常用在圆形对象，如正圆形和椭圆形上，通过巧妙的将边缘与背景融合去除边缘的锯齿。

羽化却是明显的将边缘与背景混合，使边缘产生柔和的效果。— 就象发光一样。

改变选中对象的填充边缘：

1 | 在填充面板上，在“边缘”弹出菜单上的“硬边”，“去锯齿”，“羽化”中选择选择一个选项。
2 | 如果羽化边缘，则还需要选择边缘羽化的象素数。默认是10。 您可以在0-100中选择。数字越大，羽化的象素越多。

编译：Candy


给笔触或填充增加纹理 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 给笔触或填充增加纹理

给笔触或填充增加纹理

您可以通过给笔触或填充增加纹理创造出空间的效果。您可以使用Fireworks 自带的纹理，也可以使用自己的纹理，需要更多使用外部纹理的信息，参见 使用外部文件作为图案与纹理.

增加纹理到笔触

纹理可以改变笔触的亮度，但不会改变笔触的色调，使笔触少一些呆板，多一些生气。纹理使用在较宽的笔触效果会更显著，Fireworks内自带了一些纹理可以选择如：Chiffon, Oilslick和Sandpaper.

使用笔触面板给笔刷笔触增加纹理。

纹理弹出菜单上可以预览被高亮显示的笔触。

给选中的对象的笔触增加纹理：

1 | 在笔触面板上的“笔触类型”弹出菜单上选择一种笔触类型，然后在“笔触名称”弹出菜单上指定一种笔触。
2 | 选择一种纹理：
 | 在“纹理”弹出菜单上选择一种纹理。
 | 要使用外部纹理在“纹理”弹出菜单上选“其他”。并找到要使用的纹理文件。您可以使用以下格式的文件作为纹理：PNG, GIF, JPEG, BMP, TIFF, 和PICT (只有在Macintosh系统中使用).
3 | 输入一个控制深度的百分比值，范围从0-100。数值越高纹理越强烈。

编译：Candy


增加纹理到填充 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 给笔触或填充增加纹理 >增加纹理到填充

增加纹理到填充

纹理可以改变填充的亮度，但不会改变填充的色调，使填充少一些呆板，多一些生气。 您可以给任何填充增加纹理。Fireworks自带了一些纹理可供选择，如：Chiffon, Oilslick,和 Sandpaper. 您也可以将位图文件作为纹理，可以使您创建出任何类型的自定义纹理。

使用填充面板增加纹理到填充
.

纹理弹出菜单上可以预览被高亮显示的纹理。

给选中的对象的填充增加纹理：

1 | 在填充面板上的“填充类型”弹出菜单上选择一种填充类型。
2 | Choose a texture:
 | 在“纹理”弹出菜单上选择一种纹理。
 | 要使用外部纹理，在纹理“弹出菜单”上选“其他”，并找到要使用的纹理文件。
3 | 输入一个控制深度的百分比值，范围从0-100。数值越高纹理越强烈。
4 | 如果想给填充引进透明色，就选择“透明”。纹理的百分比也控制透明度。

编译：Candy


使用外部文件作为图案和纹理 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 使用外部文件作为图案和纹理

使用外部文件作为图案和纹理

您可以调用外部的位图文件作为纹理。您可以使用以下格式的位图文件：PNG, GIF, JPEG, BMP, TIFF, 和PICT (只能在Macintosh系统中使用)。 如果你想将外部纹理放到“纹理”弹出菜单中供所有的文档使用，可以将纹理文件复制到Fireworks 4\Configuration\Textures文件夹中。

使用外部纹理：

1 | 在填充面板上的“填充类型”弹出菜单中选择一种填充类型
2 | 如果您没有将纹理增加到“纹理”弹出菜单上，在“纹理”弹出菜单上选择“其他”，并找到纹理文件，反之，直接在“纹理”弹出菜单上选择纹理。
3 | 输入一个控制深度的百分比值，范围从0-100。数值越高纹理越强烈。
4 | 要使纹理的较亮的区域变的透明，选择“透明”，纹理的百分比也控制透明度。

编译：Candy


抖动处理网络安全色 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 抖动处理网络安全色

抖动处理网络安全色

有时，您也许需要使用非网络安全色，比如，您公司的标志的颜色是非网络安全色，为了使颜色尽可能地接近网络安全色，以便在使用网络安全调色板导出文件的时候不致发生改变和抖动，就要使用网络抖动填充。

网络抖动是使用网络安全调色板上的两种颜色组合成最接近您所需要的颜色的一种手段，注意网络抖动会增加文件的大小。

两种网络安全色组合成网络抖动填充

使用网络抖动填充：

1 | 选中包含非网络安全色的对象
2 | 在填充面板上选择“网络抖动”作为填充类型
 | 对象上的非网络安全填充颜色会显示在“填充类型”旁的填充颜色盒内，两种网络安全抖动色会出现在下边的棋盘状色块上。网络抖动填充将会应用到选中的对象上，并成为当前的应用填充。

注意： 对网络抖动色的边缘进行消除锯齿处理或者羽化处理，会生成非网络安全色。

创造在网络浏览器中真正透明的视觉效果：

1 | 在填充面板上，给选中的对象应用“网络抖动填充”。
2 | 选择“透明”
3 | 使用“索引透明”或者“Alpha 通道透明”将对象导出为 GIF 或者 PNG 文件。

当你在网络浏览器中查看图形的时候，网页背景会透过所有的透明的网络抖动填色，制造出透明的效果。需要注意的是，不是所有的浏览器都支持PNG格式的文件。

编译：Candy


选择颜色 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 选择颜色 > 应用颜色

应用颜色

您可以通过色样面板或颜色盒弹出窗口来给路径对象的笔触和填色应用颜色。

将颜色应用到选定的对象

1 | 点击笔触或填充颜色盒
2 | 选择一种颜色:
 | 在色样面板上, 点击一个颜色应用到选定的笔触或填充对象上，这个颜色就会被指定为当前颜色盒的应用色。
 | 打开颜色盒弹出窗口点击一种色样或者在色值文本框中输入您要选择的颜色的16进制色值。

编译：Candy


颜色取样 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 颜色取样

颜色取样

您可以从屏幕上的任何地方选取任意颜色，包括其他打开的fireworks文档, 应用到选定的对象，这个过程叫做颜色取样; 这样在您需要使编辑的图像成为一个整体的时候，可以使您识别和使用精确的颜色,您也可以查看任意颜色的16进制的色值，不管在这个颜色应用到选定的对象之前还是之后。

注意：您必须使用 24- 或 32-bit颜色模式.

从屏幕的任意地方选取颜色应用到选定的地方：

1 | 选择工具面板上的笔触或填色颜色盒，会显示颜色盒的弹出窗口，这时鼠标指针变为吸管的形状。
2 | 点击屏幕上的任何地方选取一种颜色，这种颜色会被应用到当前选中的对象。
 | 注意: 点击时按住Shift键可选择网络安全色。

识别一种颜色十六进制数值：

1 | 打开笔触、填色或效果的颜色弹出窗口，这时鼠标变为吸管的形状。
2 | 将您的鼠标移到一种颜色上，这种颜色的16进制数值会显示在颜色盒弹出窗口上。
 | 注意: 点击颜色值文本框可以输入一种颜色的色值

改变颜色设置：

在颜色盒面板上的选项弹出菜单中选择一种颜色设置。

编译：Candy


自定义色样面板 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 自定义色样面板

自定义色样面板

在色样面板上您可以增加，减少，替换，和排序，这些改变会自动在颜色盒弹出窗口上更新。

您也可以增加或删除整个色样组 ，需要更多信息, 参见 改变色样组.

注意: 选择 编辑 > 撤消 并不能撤消对色样所做的增加和删除。

从当前的Fireworks文档中选择一种颜色增加到色样面板：

1 | 在工具面板上选择吸管工具.
2 | 点击你想要添加的颜色。
3 | 在色样面板上，将鼠标指针移动到最后一个色样后面空白的地方，指针变为油漆桶的形状。
4 | 点击一下鼠标颜色就增加到色样中去了。

从屏幕上的任何地方选择一种颜色增加到色样面板。

1 | 打开一个颜色盒弹出窗口，指针变为吸管的形状。
2 | 点击屏幕上的任何地方（包括其他的Fireworks文档），选择一种颜色。
3 | 在色样面板上，将鼠标指针移动到最后一个色样后面空白的地方，指针变为油漆桶的形状。
4 | 点击一下鼠标颜色就增加到色样中去了。
 | 注意: 当颜色盒弹出窗口上的选项弹出菜单中的“转化为网络安全色”被选中时，滴管工具所选取的任何非网络安全色都会被转化为最接近的网络安全色。

保存选择的颜色样品

1 | 将颜色增加到色样面板
2 | 在色样面板的选项弹出菜单上, 点击“保存色样”。
3 | 这时会打开“输出色样”对话框。 选择一个文件名和保存的目录。

替换一种色样

1 | 在工具面板上选择吸管工具。
2 | 选择一种颜色。
 | 这种颜色会被应用到选中的对象上，并成为当前激活的笔触或填色的颜色。
3 | 按住Shift键点击色样面板上的一个色样。
 | 鼠标指针变为油漆桶的形状。
4 | 点击色样可以替换为新的颜色。

在色样面板上删除一个色样：

1 | 按住Control键(Windows)或Command键(Macintosh)。鼠标指针变为剪刀的形状。
2 | 点击一个色样可以从色样面板上删除。

清除整个色样面板:

从色样面板的选项弹出菜单中选择清除色样。

返回到默认的色样：

从色样面板的选项弹出菜单中选择Windows 或 Macintosh系统调色板。

将色样按颜色排序：

从色样面板的选项弹出菜单中选择“按颜色排序”。

编译：Candy


改变色样组 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 改变色样组

改变色样组

您可以很容易的切换色样组，或是创建您自己的色样组，在Fireworks中有以下的色样组可以选择Color Cubes, Continuous Tone colors, Macintosh System colors, Windows System colors, Grayscale,输入的 ACT or GIF 文件自定义色样组。

使用色样面板选择一种色样组.

色样面板选项弹出菜单

选择一个色样组：

从色样面板的选项弹出菜单中选择一个色样组。

选择一个自定义的色样组：

1 | 从色样面板的选项弹出菜单中选择“替换色样”。
2 | 浏览文件夹并且选择一个文件。
3 | 点击打开。
 | 自定义色样组的色样会替换掉当前的色样。

注意: 要得到更多创建自定义色样组的信息，参见最优化调色板.

在色样面板上添加一个色样组到当前色样：

1 | 从色样面板的选项弹出菜单中选择“增加色样”。
2 | 浏览文件夹并且选择一个色样文件，点击OK。
 | Fireworks可以从 Photoshop ACT文件或GIF文件中增加色样。新的色样被添加到当前色样的后面。

保存自定义色样组：

1 | 从色样面板的选项弹出菜单中选择“保存色样”。
2 | 输入新的色样组的名字，点击保存

编译：Candy


创建颜色 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 创建颜色

创建颜色

您可以创建自己的颜色并把它们应用到对象上、增加到色样面板上或是产生新的颜色组，可以使用混色器创建颜色，或是使用系统颜色采集器选择颜色。

使用混色器创建颜色。

使用混色器查看当前颜色的数值，并且创建新的颜色。.

您可以使用下面这些颜色模式创建自己的颜色。RGB, 16进制, HSB, CMY, 和灰度

在默认状态下，混色器将RGB颜色识别为16进制值，可以显示红(R)绿(G)蓝(B)三种颜色成份的色值。16进制RGB数值范围是从00到FF. 值的
选择 | 表示颜色成分：
RGB | 红绿蓝三种颜色的值，从0到255。 0-0-0 是黑色，255-255-255是白色。
16进制 | 红绿蓝三种颜色的16进制值从00到FF. 00-00-00 是黑色，FF-FF-FF 是白色。
HSB | 色相，饱和度，亮度, 色相的值的范围从0到 360度，饱和度和亮度的值的范围从0 到 100%.
CMY | 黄，品红，青三种颜色的成份值，从 0 to 255. 0-0-0 is 是白 and 255-255-255 是黑.
灰度 | 黑色所占的百分比，从0到100%, 0 是白色，100 是黑色,中间是不同深浅的灰色

您可以在混色器的选项弹出菜单中选择一种颜色模式。当前的颜色成分会随着颜色模式的不同而发生变化

显示混色器：

选择 窗口 > 混色器

将几种颜色模式的颜色栏循环切换：

按住单击混色器底部的颜色栏。

混色器的选项不会发生变化。

将颜色栏上的一种颜色应用到选中的对象：

1 | 在混色器上点击笔触或填色颜色盒使其激活。
2 | 将鼠标指针移到颜色栏上. 指针变为吸管的形状。
3 | 点击选取一种颜色。
 | 这种颜色就会被应用到选中的对象上，并且成为当前的笔触或填色的应用色。

在混色器上创建一种颜色

1 | 当您混合颜色时，取消所有对象的选中状态，以防止把不需要编辑的对象的颜色给改变掉。
2 | 点击笔触或填色的颜色盒，使新创建的颜色可以放置在这里。
3 | 从混色器选项弹出菜单中选择一种颜色。
4 | 指定颜色成分值：
 | 在颜色成分文本框内输入数值
 | 使用弹出滑杆
 | 在颜色栏上选取一种颜色

您可以将颜色增加到色样面板以便下次使用。 需要更多的信息，参见 自定义色样面板.

编译：Candy


创建颜色 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 创建颜色 > 使用系统颜色选择器创建颜色

使用系统颜色选择器创建颜色

您可以使用Windows颜色对话框(Windows)或Apple颜色选择器(Macintosh)创建颜色。

显示系统颜色选择器

双击任何一个颜色盒。
在颜色盒弹出窗口上点击颜色选择器按钮。

编译：Candy


查看颜色值 - Candy（侠客岛版权所有）

应用颜色，笔触和填充 > 查看颜色值

查看颜色值

在信息面板，颜色盒弹出窗口，或是混色器上，可以查看颜色的色值。在颜色盒弹出窗口上，您可以查看任何的应用程序的任何地方的色值，包括桌面上，在混色器或颜色盒弹出窗口上您可以查看当前笔触或填色的色值。

显示信息面板：

选择 窗口 > 信息。

显示混色器：

做下面的任何一步

选择 窗口 > 混色器
点击颜色面板上的混色器标签。

使用信息面板查看文件的任何部分的颜色值：

将鼠标指针移动到您想查看颜色的对象上。

查看当前的笔触或填色的颜色值：

做下面的任意一步：

在混色器上查看RBG或其他颜色系统的色值。
在颜色盒弹出窗口上查看颜色的16进制值。

在默认的情况下，在信息面板和混色器上显示颜色的RGB数值， 在颜色盒弹出窗口上显示颜色的16进制值。不过，您可以在任何时候改变信息面板和混色器上的颜色值显示方式。

显示其他的颜色模式的颜色信息：

从信息面板或混色器面板的选项弹出菜单上选择另一种颜色模式。

编译：Candy


修正颜色和色调概述（侠客岛版权所有）

修正颜色和色调 > 修正颜色和色调概述

修正颜色和色调概述

在外挂功能菜单上的滤镜以及特效面板可以帮助你改进并加强你的位图图象的颜色。 Fireworks 包含了很多新的调整颜色的滤镜。你可以调整对比和亮度，色调、饱和度和色调范围 。

另外，你可以模糊或锐化一幅图片，并通过对图象加色或反转颜色使之改头换面。但你不仅限于这些滤镜。你可以添加Photoshop插件到在外挂功能菜单以及特效面板上。

这些滤镜主要用于位图图形，比如数码照片。当然你也可以向矢量图形应用滤镜。通过外挂功能菜单向矢量图形应用滤镜，将使矢量图形转变为位图。

用undo取消操作命令或历史面板可以撤消滤镜或插件创建的特效。另外，用特效面板所应用的滤镜和插件可以通过特效面板撤消并编辑。


反转图象颜色值（侠客岛版权所有）

修正颜色和色调 > 反转图象颜色值

反转图象颜色值

你可以使用色彩反转滤镜来将一个对象的每个颜色变成在色轮中的互补色。比如一个红色图象对象（R=255, G=0, B=0）加以色彩反转，就变成青色 (R=0, G=255, B=255).

原始图象

色彩反转后

要反转色彩:

1 | 选择一个矢量或位图对象
2 | 选择外挂功能 > 调整颜色 > 色彩反转


模糊图象（侠客岛版权所有）

修正颜色和色调 > 模糊图象

模糊图象

你可以使用Blur模糊命令将位图图象的像素模糊。模糊选项包括模糊，强模糊，和高斯模糊。强模糊是模糊的差不多3倍强。高斯模糊提供队每个像素的加权平均来获得模糊的效果，因而使用户可以自由控制模糊的强度。

未使用高斯模糊

使用高斯模糊后

要模糊一幅图片:

1 | 在位图或矢量模式下选择图象.
2 | 选择模糊选项：
 | 选择外挂功能 >模糊 >模糊和强模糊.
 | 从特效面板的特效弹出菜单中选择> 调整颜色> 选择模糊

要使用高斯模糊来模糊图象
1 | 在位图或矢量模式下选择图象.
2 | 打开高斯模糊对话框:
 | 选择外挂功能 > 模糊 >高斯模糊.
 | 从特效面板的特效弹出菜单中选择 模糊 >高斯模糊.
3 | 查看工作区中你所做的变化，选择Preview预览.完成变化之后，图象自动更新
4 | 拖曳模糊半径滑钮来设置模糊的强度，数值在0.1 到250之间. 半径越长模糊效果可以以
5 | 点击OK.


将色彩变化改变为线条 （侠客岛版权所有）

修正颜色和色调 > 将色彩变化改变为线条

将色彩变化改变为线条

你可以使用边界搜索来确定图象中色彩变化大的部分。边界搜索将色彩变化剧烈的硬线条边界改变为线条。在位图中，边界搜索使图象看上去象草稿。

原始图案

使用边界搜索后

在所选对象中将色彩变化改变为线条:

选择边界搜索选项99-1-16:

从特效面板的特效弹出菜单中 选择 其他other> 边界搜索Find Edges
选择外挂功能 > 其他 > 边界搜索


转换图象（侠客岛版权所有）

修正颜色和色调 > 转换图象

转换图象

你可以应用转换透明度滤镜来将一个对象或文字根据其亮暗转换为渐变的透明度

要将所选图象转变为透明度:

选择转换透明度选项:

从特效面板的特效弹出菜单中 选择其他 > 转换透明度
选择外挂功能 > 其他 > 转换透明度


锐化图象（侠客岛版权所有）

修正颜色和色调 > 锐化图象

锐化图象

你可以使用锐化修正模糊的图象。锐化命令包括三个选项：锐化、加强锐化、钝化遮罩。锐化命令通过提高相邻像素的对比来修改模糊图象的焦点。加强锐化以三倍于锐化的程度提高相邻像素的对比。钝化遮罩通过改变图象边缘的对比来锐化图象。钝化遮罩提供最多的控制，因此是锐化图象最好的选择。

原始图案

锐化之后

要锐化图象:

1 | 在位图或矢量模式下选择图象。
2 | 选择锐化选项:
 | 选择外挂功能 > 锐化 > 锐化或加强锐化。
 | 从特效面板的特效弹出菜单中选择 锐化 >锐化或加强锐化

注意: 如果锐化太多，可能使图象质量降低。

要使用钝化遮罩来锐化图象：

1 | 在位图或矢量模式下选择图象
2 | 打开钝化遮罩对话框:
 | 从特效面板的特效弹出菜单中选择 锐化 >钝化遮罩
 | 选择外挂功能 > 锐化 >钝化遮罩
3 | 选择Preview预览查看工作区中你所做的变化。
4 | 拖曳锐化总量滑钮在1%到500%之间选择锐化效果的程度
5 | 拖曳像素半径滑钮在0。1到250之间选择图象半径
 | 半径越大，像素周围被影响的区域越大，锐化效果越明显
6 | 拖曳阈值滑钮在0到255之间确定受影响的最小值。常用为2到25。
 | 阈值高就只影响相邻对比大的像素。阈值低则影响包括相邻对比小的像素。
 | 阈值为0则锐化图象中所有像素。
7 | 点击OK.


修正颜色和色调概述 （侠客岛版权所有）

修正颜色和色调 > 修正颜色和色调概述 > 使用滤镜和插件来作为即时特效

使用滤镜和插件来作为即时特效

在Fireworks中, 你可以应用Photoshop 插件和外挂功能菜单上的内建滤镜应用到图象上，并用特效面板使之成为即时特效。看 使用Photoshop插件作为即时特效以及使用Fireworks外挂功能作为即时特效 .


使用色调分布来调整色调范围（侠客岛版权所有）

修正颜色和色调 > 使用色调分布来调整色调范围

使用色调分布来调整色调范围

你可以使用色调分布滤镜来使图象集中更多像素到亮色调，中间色调，暗色调。有完整色调范围的图象在所有三个色调范围中拥有平均的像素。在亮色调中像素较多的图象看上去象洗过的样子，而中间色调较多的图象看上去很单调不丰富。暗色调过多的图象不能很好地表现细节。

色调分布滤镜将最亮的像素设为黑色而最亮的像素设为白。然后相应调整中间色调分布。这样产生的图案有最清晰的细节

原始图像像素集中于亮色调

色调分布调整过的图像

使用色调分布对话框里的直方图来查看位图的像素分布。直方图是位图图象在亮色调，中间色调，暗色调像素分布的图解显示。

Histogram

使用直方图来确定修改图象色调范围的最佳方案。在亮色调或暗色调有大量像素的图案说明你可以用色调分布或色调分布曲线来改进这幅图象。

纵轴表示从最暗 (0) 到最亮(255)的颜色值.水平轴从左到右的数值：左边表示暗的像素，右边表示亮的像素，中间表示表示中间色调。一般，你应该先调整亮色调和暗色调，然后调整中间色调，这样让你在不影响高光区和阴影的同时调整图象的亮度。

To adjust highlights, midtones, and shadows:要调整亮色调、暗色调、中间色调：

1 | 在位图或矢量模式下选择图象。
2 | 打开色调分布对话框：
 | 选择外挂功能 Xtras > Adjust Color调整颜色 > Levels色调分布
 | 从特效面板的特效弹出菜单中选择 Adjust Color调整颜色 > Levels色调分布
3 | 要查看工作区中你所做的变化，选择Preview预览.完成变化之后，图象自动更新
4 | 从通道弹出菜单中，选择选用单独颜色通道（红、蓝、绿）还是全部颜色通道。
5 | 拖曳输入直方图下面的输入色调值滑钮来调整亮色调、暗色调、中间色调
 | 右边的滑钮在0到255调整亮色调的值,中间的滑钮在10到0。19之间调整中间色调的值，左边的滑钮在0到255调整暗色调的值。当你移动这些滑钮，相应数值会自动输入到输入色调值框内。
 | 注意: 暗色调的数值不能比亮色调的更高，相反也一样。
6 | 拖曳输出色调值滑钮来调整图象的亮度范围
 | 拖曳右边的滑钮在在0到255调整亮色调的值，左边的滑钮在0到255调整暗色调的值，相应数值会自动输入到输出色调值框内。

要获得关于用吸管按钮来调整色调范围的信息，看 使用吸管来来调整色调范围.


使用色调分布来调整色调范围（侠客岛版权所有）

修正颜色和色调 > 使用色调分布来调整色调范围 > 自动调整色调范围

自动调整色调范围

使用自动调整色调滤镜，你可以自动定义图象中最亮的和最暗的像素，自动调整色调滤镜和色调分布滤镜是一样的，只是这回 Fireworks会帮你做调整。

要自动调整亮色调、暗色调、中间色调：

1 | 在位图或矢量模式下选择图象。
2 | 选择自动调整色调滤镜:
 | 选择外挂功能 Xtras> Adjust Color调整颜色> Auto Levels自动调整色调
 | 从特效面板的特效弹出菜单中选择 选择 Adjust Colors调整颜色 > Auto Levels 自动调整色调.

注意 : 你也可以通过点击色调分布或色调曲线对话框的自动按钮来自动调整亮色调、暗色调、中间色调。


使用色调分布来调整色调范围（侠客岛版权所有）

修正颜色和色调 > 使用色调分布来调整色调范围 > 使用色调曲线来调整色调范围

使用色调曲线来调整色调范

色调曲线的特点和色调分布相似，但是对色调范围提供了更精确的控制。色调分布滤镜能够让你在亮色调、暗色调、中间色调调整色调范围，那么色调曲线能够让你在色调范围内单独调节任何颜色，而不是仅仅三个参数。比如：你可以用色调曲线修正由于光线条件造成的图象的颜色失真。

色调曲线对话框里的网格表示以下亮度值:

水平轴表示像素的原始亮度值（在Input输入框内显示）
垂直轴表示像素的新亮度值（在Output输入框内显示）

当你打开色调曲线对话框，对角线表示未做任何变化，所以输入和输出框对于任何像素都相等。

要调整色调范围内的特定一点:

1 | 在位图或矢量模式下选择图象。
2 | 打开色调曲线对话框:
 | 选择外挂功能 Xtras> Adjust Color调整颜色> Curves色调曲线
 | 从特效面板的特效弹出菜单中选择 Adjust Color调整颜色 > Curves色调曲线
3 | 要查看工作区中你所做的变化，选择Preview预览.完成变化之后，图象自动更新
4 | 从通道弹出菜单中，选择选用单独颜色通道（红、蓝、绿）还是全部颜色通道。
5 | 要调整曲线，在网格的对角线点击一点，并拖曳到新的位置。
 | 曲线上的每个点都有自己的输入和输出值。当你拖曳某一点时，其输入和输出值自动更新。
 | 色调曲线表示0到255的亮度值，0表示暗区色调.
 | 拖曳某一点后的修正曲线

注意: 点击自动按钮将产生和色调分布对话框中自动按钮所产生的相同的一样的效果

要删除曲线上的点T:

将这一点从网格里拖曳出去

注意: 你不能删除曲线的端点。


使用色调分布来调整色调范围 （侠客岛版权所有）

修正颜色和色调 > 使用色调分布来调整色调范围 > 使用吸管来来调整色调范围

使用吸管来来调整色调范围

你可以使用色调分布或色调曲线的亮色调、暗色调、中间色调三个吸管按钮来调整对应的色调范围。

比如，你的某一幅图象可能有太多白色色素，因而看上去象洗的发白一样，点击亮色区吸管，然后点击图象中某个不是白色的像素。图象的高亮区会相应重新映射，使图象对比更明显。

要使用吸管来来调整色调范围:

1 | 打开色调分布或色调曲线对话框，在通道弹出菜单中选择一个颜色通道.
2 | 选择合适的吸管:
 | 亮色调吸管： (吸管头上是白色墨水) 重新设置高亮区颜色值.
 | 暗色调吸管： (吸管头上是黑墨水) 重新设置阴影色调区颜色值.
 | 中间色调吸管： (吸管头上是灰墨水) 重新设置中间色调区颜色值.
3 | 选择一个图象中的色素并点击ok


调整亮度和对比（侠客岛版权所有）

修正颜色和色调 > 调整亮度和对比

调整亮度和对比

亮度/对比滤镜调整图象中所有像素的亮度和对比度。使用这个命令可以影响图象的亮色调，中间色调，暗色调。

在图象不需要细致修改时，你可以使用亮度/对比滤镜。要获得更多高级修改操作方法，看 反转图象颜色值、 和 使用色调曲线来调整色调范围.

原始图象

调整亮度以后

要调整亮度或对比:

1 | 在矢量或位图模式下选择图象.
2 | 选择Xtras外挂功能>Adjust Color调整颜色> Brightness/Contrast亮度/对比. 亮度/对比对话框打开。
3 | 要查看工作区中你所做的变化，选择Preview预览.完成变化之后，图象自动更新
4 | 拖曳亮度/对比滑钮来调整设置。数值变化范围在 -100和 100之间.
5 | Click OK.


应用填充颜色（侠客岛版权所有）

修正颜色和色调 > 应用填充颜色

应用填充颜色

你可以使用填色来快速改变某个对象的颜色，既可以用现有的颜色替换像素或者将颜色混合到一个现有的对象上。使用混合颜色，会将当前颜色混合到对象的上方。将颜色混合到现有的对象类似与色调/饱和度滤镜；但是，他让你可以从色样面板快速选用一个特定颜色。

要向一个所选对象或像素选区使用填充颜色特效:

1 | 特效面板的特效弹出菜单中选择 Adjust Color调整颜色 >Color Fill填充颜色.
2 | 选择一种混合模式，默认是普通.
 | 要获知各种颜色混合模式的信息，看关于颜色混合模式.
3 | 从颜色框对话框弹出菜单找到颜色填冲
4 | 选择填色的不透明度的百分比数值，并点击进入。


调整色调和饱和度（侠客岛版权所有）

修正颜色和色调 > 调整色调和饱和度

调整色调和饱和度

你可以使用色调/饱和度来调整颜色，色彩的纯度（称为其 saturation饱和度), 已经在图象中该颜色的亮度。

原始图象

调整饱和度后

要调整饱和度:

1 | 在矢量或位图模式下选择图象。
2 | 打开色调/饱和度对话框：
 | 在特效面板的特效弹出窗口选择 Adjust Color调整颜色 > Hue/Saturation色调/饱和度
 | 选择外挂功能 Xtras > Adjust Color调整颜色 > Hue/Saturation色调/饱和度
3 | 选择Preview预览来查看在工作区域中你操作的变化，当你应用变化时，图象自动更新。
4 | 选择彩色化使RGB彩色图象变成单一彩色的双色调图，或者向灰阶图上色。
 | 当你选择彩色化，色调和饱和度的值会变化。色调在0到360之间，饱和度在0到100之间变化。
5 | 拖曳饱和度滑钮来调整色彩的纯度，数值范围在0到100之间。
6 | 拖曳色调滑钮来调整图象的颜色，数值范围在-180到180之间。
7 | 拖曳亮度滑钮来调整色彩的亮，数值范围在0到100之间。
8 | 点击 OK.


应用实时特效概述--蓝骑士（侠客岛版权所有）

应用实时特效 > 应用实时特效概述

应用实时特效概述(Live effects)

Fireworks的效果添加是实时显示的.在编辑对象时,您可以随时看到对象添加效果后的图像.效果可以进行开关控制,通过打开或关闭效果,您可以对不同的效果组合进行比较.

使用Fireworks提供的笔触(stroke)和填充(fill)功能,您已经可以在网页图像中产生很多的效果.现在,再加上效果(effect)功能,您可以由此进一步加强您的创作本领,丰富图像的变化.

例如制作浮雕效果的按钮,产生光晕,或者为文字制作阴影,在效果面板里,您可以非常简单的通过命令来实现这些变化.另外,通过简单的勾选,您就可以在面板中对对象的效果进行打开和关闭的操作,来比较前后的视觉差异.

在Fireworks 4中,您还可以使用外挂(Xtra)滤镜,例如高斯模糊(Gaussian Blur)和锐化(Sharpen)等等.许多Photoshop的插件(plug-ins)也都能很好的在Fireworks下工作.

蓝骑士编译


对实时特效排序（侠客岛版权所有）

应用实时特效 > 改变实时特效 > 对实时特效排序

对实时特效排序

您可以对添加在对象上的效果进行排序.效果添加的顺序影响到最后图像的样式.

通常,添加到对象内部的效果,最好排在外部效果前.例如内斜角添加在外斜角,光晕,阴影等对象外部效果前.

对实时特效排序:

在效果面板,直接拖动某一个效果到您希望的位置.

在效果列表上方的效果比下放的效果先添加到对象上.

蓝骑士编译


删除实时特效--蓝骑士（侠客岛版权所有）

应用实时特效 > 改变实时特效 > 删除实时特效

删除实时特效

您可以非常方便的删除添加在对象上实时特效.

对于临时取消实时特效,请参看 控制实时特效 .

删除单个实时特效:

1 | 在效果面板,选中您希望删除的效果.
2 | 点击效果面板右下角的 Delete(删除) 按钮,或拖拽效果到 Delete(删除) 按钮上.

删除所有特效:

在效果面板的下拉框中选择 None(没有) 选项.

蓝骑士编译


创建自定义实时特效--蓝骑士（侠客岛版权所有）

应用实时特效 > 创建自定义实时特效

创建自定义实时特效

使用效果面板右上角的菜单选项,您可以保存自定义的实时特效,重命名效果,或删除效果.Fireworks 4自动将您自定义的实时特效保存在特效文件夹中.在随后创作的文件中,您都可以调用已经保存下来的自定义特效.

您可以将多个效果组合形成新效果,保存为自定义特效.

保存自定义特效:

1 | 选择效果面板右上角弹出菜单中 Save Effect As(保存效果为...).
 | 效果面板弹出菜单
2 | 在随后弹出的对话框中输入效果的名字,点击 OK. 效果自动添加到效果面板的下拉框选项中.

重命名自定义的特效:

1 | 选中您希望重命名的自定义特效.
2 | 在效果面板弹出菜单中选择 Rename Effect(重命名效果) .
3 | 输入新的效果名字,点击 OK.
 | 您不可以定重命名Fireworks自带的标准效果.

删除自定义特效:

1 | 选中您希望删除的自定义特效.
2 | 在效果面板弹出菜单中选择 Delete Effect(删除特效).

蓝骑士编译


保存实时特效为样式--蓝骑士（侠客岛版权所有）

应用实时特效 > 创建自定义实时特效 > 保存实时特效为样式

保存实时特效为样式

您可以将实时特效保存为样式,在以后的创作中调用.更多信息请参看 关于样式表 .

蓝骑士编译


使用效果默认设置--蓝骑士（侠客岛版权所有）

应用实时特效 > 创建自定义实时特效 > 使用默认效果设置

使用效果默认设置

如果您经常使用某一些效果,您可以将这些效果的组合作为效果默认设置.以后的创作中,通过调用默认设置,您可以在效果列表中快速的建立您经常使用的效果组合.

保存效果组合为默认效果设置:

1 | 选中您经常使用的效果组合.
2 | 在效果面板的弹出菜单中选择 Save Defaults(保存为默认设置).

应用默认设置:

在效果面板的下拉框中,选择 Use Defaults(使用默认设置).

蓝骑士编译


控制实时特效--蓝骑士（侠客岛版权所有）

应用实时特效 > 控制实时特效

控制实时特效

如果一个文件中包含大量的实时特效,Fireworks在打开该文件,或对该文件中的对象进行编辑时,会花费大量的时间在画布上实时绘制这些效果.有时候这会影响到创作的速度和效率.

您可以临时取消实时特效,使得对象在打开或编辑时,不会花费大量的时间去绘制这些效果.等对象编辑完成,再恢复实时特效,将效果添加上去.

恢复或临时取消一个效果:

选中或不选中效果列表效果前的勾选框.

恢复或临时取消所有效果:

在效果面板的弹出菜单中,选择 All On(全部打开) 或 All Off(全部关闭).

更多信息请参看 删除实时特效 .

蓝骑士编译


多个对象应用实时特效--蓝骑士（侠客岛版权所有）

应用实时特效 > 多个对象应用实时特效

多个对象应用实时特效

当您在对象群组上应用实时特效,效果添加到对象群组上.也就是说,如果您取消对象群组,添加在对象群组上的效果不会应用到单个对象上.

您可以使用对象面板中的 Subselection(子选择) 工具,选中对象群组中的某一个对象单独添加效果.详细请参看 选择群组对象 .

蓝骑士编译


应用实时特效--蓝骑士（侠客岛版权所有）

应用实时特效 > 应用实时特效

应用实时特效

使用效果(Effect)面板,您可以选择您需要的实时特效.一个对象可以添加多个效果.当您在对象上添加特效,该效果自动加入面板中的效果列表.勾选列标签的选项框,您可以打开或关闭一个效果.

效果(Effect)面板

对象添加特效:

1 | 选中对象,在效果面板上的特效下拉框中选择一个效果.
 | 选中的效果加入效果列表.
2 | 如果下拉框中选中的效果弹出编辑窗口,您可以输入属性值,编辑特效.
 | 点击 OK ,直接回车,或和鼠标点击其他区域,您可以关闭特效属性编辑窗口.
 | 注: 在位图模式,特效面板不可使用.(因为位图模式没有对象可以添加特效)
3 | 重复 1,2 的步骤,您可以添加多个效果.

蓝骑士编译


使用Fireworks外挂(Xtras)功能--蓝骑士（侠客岛版权所有）

应用实时特效 > 使用Fireworks外挂(Xtras)功能

使用Fireworks外挂(Xtras)功能

在Fireworks中,您可以在效果面板的实时特效选项中选择外挂(Xtra)滤镜.这样,外挂滤镜在效果面板中可以进行开关控制.使得滤镜的使用更加的随心所欲(想要就要,想不要就不要).

直接使用菜单的外挂(Xtras)滤镜,将使对象进入位图模式,效果添加的添加是不可逆的.一旦添加,将不可修改.而通过效果面板里的外挂滤镜,则这些效果随时可以进行编辑和取消.

注: 应用菜单的外挂滤镜,除非通过撤消(Undo)命令取消操作,否则,滤镜不可以再改变.

蓝骑士编译


使用Photoshop插件(plug-ins)--蓝骑士（侠客岛版权所有）

应用实时特效 > 使用Photoshop插件(plug-ins)

使用Photoshop插件(plug-ins)

当您在Fireworks中安装了Photoshop的插件(plug-ins),您就可以在菜单 Xtras(外挂) 和 效果面板中使用这些插件.

在效果面板中使用插件(plug-ins),和外挂(Xtras)滤镜一样,在对象上产生实时特效,保留对象和效果的可编辑性.在菜单中使用插件,则效果添加完成后不可再修改效果的属性.

Photoshop的部分插件不可以做为实时特效使用.

注: Fireworks只有安装PNG文件中所使用的插件,才能正确显示该插件的实时特效.Fireworks无法显示没有安装插件的实时特效. 如果您已经将实时特效内置,形成内置特效(Built-in),即使没有安装插件,Fireworks也能正确显示文件中的特效.

(实时特效是一种浮动的,可编辑,可拆卸的特效,它分开保存对象和对象上的效果属性.内置特效则将效果与对象合并,保存被效果化的对象.)

安装Photoshop插件(plug-ins):

1 | 点击效果面板(Effect panel)右上角小箭头,在弹出菜单中选择 Locate Plugins(定位插件).
2 | 找到Photoshop插件所在的文件夹,点击 OK.
3 | 重新启动 Fireworks ,插件完成安装.
 | 注: 如果您在电脑中改变了插件的文件位置,请重复上面的步骤,重新定位.

在对象上应用Photoshop插件的实时特效:

选中对象,在效果面板的下拉框中选择需要的插件.

蓝骑士编译


应用传统特效--蓝骑士（侠客岛版权所有）

应用实时特效 > 应用传统特效

应用传统特效

使用Fireworks,您可以创建斜角(bevels),阴影(drop shadows),光影(glows)和浮雕(embossing)等网页特效.每一个效果都可以进行属性设置,而且可以随时修改.

选择斜角(bevels),阴影(drop shadows),光影(glows)和浮雕(embossing)等效果时,将在效果面板弹出属性编辑窗口,您可以调整属性.属性编辑窗口中的选项根据您选择的效果的不同而有所不同.

您可以在画布中观察到属性改变后的效果,因而,您可以实时的调试出您需要的属性值.如果您希望再次改变效果属性,请参看改变实时特效.

内斜角(Inner Bevel)的属性编辑窗口

蓝骑士编译


应用斜角(bevel)--蓝骑士（侠客岛版权所有）

应用实时特效 > 应用传统特效 > 应用斜角(bevel)

应用斜角(bevel)

对按钮应用斜角可以增加立体感.您可以创建内斜角和外斜角.

内斜角(Inner Bevel)和外斜角(Outer Bevel)

应用斜角效果:

1 | 在效果面板选择斜角选项:
 | 选择下拉框中的 Bevel and Emboss -> Inner Bevel (斜角和浮雕 -> 内斜角)
 | 选择下拉框中的 Bevel and Emboss -> Outer Bevel (斜角和浮雕 -> 外斜角)
2 | 在弹出的属性窗口设置属性.
3 | 回车或鼠标点击其他区域完成属性设置,关闭属性窗口.

蓝骑士编译


应用浮雕(emboss)--蓝骑士（侠客岛版权所有）

应用实时特效 > 应用传统特效 > 应用浮雕(emboss)

应用浮雕(emboss)

使用浮雕(Emboss)效果可以使对象从背景中浮现或凹下.浮雕效果制作按钮时,使按钮产生生动的点击效果.您可以使用下凹(inset)或浮现(raised)浮雕效果.

蓝色画布上的下凹浮雕(Inset Emboss)和浮现浮雕(Raised Emboss).

应用浮雕效果:

1 | 打开效果面板.
2 | 在下拉框中选择浮雕命令:
 | Bevel and Emboss -> Inset Emboss (斜角和浮雕 -> 下凹浮雕)
 | Bevel and Emboss > Raised Emboss (斜角和浮雕 -> 浮现浮雕)
3 | 在弹出的属性窗口设置属性.
 | 如果您希望原来的对象也显示,选中 Show Object(显示对象) 选项.
4 | 回车或鼠标点击其他区域完成属性设置,关闭属性窗口.
 | 注: 考虑低版本的兼容性,低版本文件在 4 中打开默认为浮雕效果 Show Object(显示对象)选项不选中.

蓝骑士编译


应用阴影和光晕--蓝骑士（侠客岛版权所有）

应用实时特效 > 应用传统特效 > 应用阴影和光晕

应用阴影和光晕

在Fireworks中应用阴影(drop shadows),内部阴影(inner shadows),和光晕(glows)非常的方便.您可以定义阴影的角度,就像调整照射在物体上的灯光位置.

阴影(drop shadows),内部阴影(inner shadows), 和光晕(glows)

应用阴影,内部阴影:

1 | 打开效果面板.
2 | 在下拉框中选择阴影命令:
 | Shadow and Glow > Drop Shadow (阴影和光晕 -> 阴影)
 | Shadow and Glow > Inner Shadow (阴影和光晕 -> 内部阴影)
3 | 在弹出的属性窗口设置属性:
 | 点击小箭头拖动画块调整阴影距离和雾化程度.
 | 调整透明度.
 | 选择 Knock Out (隐藏对象) 选项隐藏对象只显示阴影.
4 | 回车或鼠标点击其他区域完成属性设置,关闭属性窗口.

应用光晕:

1 | 打开效果面板.
2 | 在下拉框中选择 Shadow and Glow > Glow (阴影和光晕 -> 光晕).
3 | 在弹出的属性窗口设置属性:
 | 点击小箭头拖动画块调整光晕距离和雾化程度.
 | 调整透明度.
 | 点击色彩对话框,设置光晕色彩.
4 | 回车或鼠标点击其他区域完成属性设置,关闭属性窗口.

关于效果的更多信息,请参看利用拾色器调整色调.

蓝骑士编译


改变实时特效--蓝骑士（侠客岛版权所有）

应用实时特效 > 改变实时特效

改变实时特效

使用效果面板的属性(Info)按钮,您可以随时改变实时特效.

改变实时特效:

1 | 在效果面板,点击属性(Info)按钮弹出属性设置窗口..
 | 注: 如果是不可编辑的效果,属性按钮将被灰掉,例如自动色级调整特效(Auto Levels).
 | 阴影效果的属性窗口
2 | 调整相关属性.
3 | 回车或鼠标点击其他区域完成属性设置,关闭属性窗口.

蓝骑士编译


层和遮照概述--蓝骑士（侠客岛版权所有）

层和遮照 > 层和遮照概述

层和遮照概述

尽管我们在图像创作时看见的仅仅只是一个画布,但Fireworks通过层,已经将文件分解成不同的层次.文件最终将由许多层和每一个层里的许多对象组成.Fireworks的层面板包含了所有层的列表以及每一个层中对象的列表.Fireworks的一个层等同于Photoshop的层组合,Fireworks每个层里的对象等同于Phtoshop的层.(简单的说,Fireworks的结构是对象+层,Photoshop的机构是层+层组合)

遮照和混色技术是Fireworks中另两个强大的图像创作功能.您可以通过对象的混色做出独特的效果.Fireworks提供了几种不同的混色模式以供选择.

遮照同样是一项强大而独特的功能.您可以将矢量对象或位图图片通过遮照显示某些区域.例如,画一个椭圆对象,遮照某一张图像,或者将椭圆剪切到剪贴板,作为遮照粘贴到某一张图像,这是,在椭圆外部的图像好像被裁剪了,图像仅仅显示在椭圆内部的部分.

关于层

每一个在文件中创建的对象一定在某一个层中.您可以在创作图像前创建好所有的层,也可以在需要时创建.画布在所有的层下方,本身并不是一个层.关于画布的修改和操作,请参看改变画布.

您可以在层面板中查看对象的堆叠次序.对象在画布上的堆叠按照层面板中的层和对象显示块的上下排列次序堆叠.也就是层面板中排在上的对象,在画布中排在前.Fireworks按照您创建对象的先后顺序堆叠对象.先创建对象的自动排列在新创建对象的下面(从屏幕上看下去).对象的显示受到堆叠顺序的影响,会产生前面的对象遮盖后面的对象.您也可以通过层面板或菜单命令改变对象的堆叠顺序.

层面板包含了当前文件里的所有层.被选中的层,层面板中将高亮显示.您可以点击打开层,查看层里包含的所有对象.对象在层面板中对应的层下面按照"对象显示块"显示.

遮照也在层面板中显示.使用层面板,您可以创建遮照.选择用于遮照的对象的对象显示块,您可以对遮照进行编辑.更多信息,参看编辑遮照.

您也可以在层面板中对不透明和混色模式进行控制.更多信息,参看调整不透明度以及混色模式.

当您希望在编辑某一个层时不会改动其他的层以及层里的对象,您可以在层面板的弹出菜单(右上角小箭头)选择"单层编辑"命令.层名字旁的记号笔(Windows操作系统)或子弹头(Macintosh操作系统)标记表明当前的哪一个层可以被编辑.选择"单层编辑"命令,只有标记的当前层的所有对象可以被选中,其他层的对象都不会选中.

蓝骑士编译


使用"显示所选区域/隐藏所选区域"命令--蓝骑士（侠客岛版权所有）

层和遮照 > 创建空遮照 > 使用"显示所选区域/隐藏所选区域"命令

使用"显示所选区域/隐藏所选区域"命令

使用"显示所选区域/隐藏所选区域"命令作用于位图编辑模式."显示所选区域"创建所选区域显示的遮照图像."隐藏所选区域"创建所选区域隐藏的遮照图像.

(矢量对象,文字对象在使用"显示所选区域/隐藏所选区域"创建遮照图像前,必须先转为位图图形:选中对象,选择菜单 Modify > Convert to Bitmap(修改 -> 转换为位图图形).然后进行遮照操作.)

使用"显示所选区域/隐藏所选区域"命令创建遮照图像:

1 | 选择圈选或套索工具,使被遮照对象进入位图编辑模式.在画布上选择需要进行遮照操作的一定区域.
2 | 选择遮照方式:
 | 选择菜单 Modify > Mask > Reveal Selection(修改 -> 遮照 -> 显示所选区域),选择的区域内的图像显示.
 | 选择菜单 Modify > Mask > Hide Selection(修改 -> 遮照 -> 隐藏所选区域),选择的区域内的图像隐藏.

蓝骑士编译


编辑遮照--蓝骑士（侠客岛版权所有）

层和遮照 > 编辑遮照

编辑遮照

遮照图像可以进行编辑,删除和失效.失效遮照是指临时移除遮照效果,但仍然保留遮照的关系.失效的遮照可以被再次有效.

通过选择层面板的对象指示块可以便捷的选取遮照对象和被遮照对象进行编辑.当能选中遮照时,对应的遮照对象显示块旁显示"遮照标记"和"当前编辑标记".

层面板中的对象显示块可以在层面板弹出菜单(右上角小箭头)选择显示块大小.也可以关闭对象显示块节省内存.

编辑遮照对象:

1 | 选择遮照对象:
 | 在层面板点击遮照对象的对象显示块.
 | 在层面板的弹出菜单(右上角小箭头)选择编辑遮照对象.
 | 双击遮照对象的移动控制柄.
2 | 改变遮照对象:
 | 从工具面板选取适当工具编辑遮照对象.
 | 拖拽遮照对象移动控制柄.
 | 对遮照对象应用效果.

尽管遮照对象本身并不在遮照图像中显示,但遮照对象的效果可以在遮照图像中表达.

编辑被遮照对象(不改变遮照对象):

1 | 在层面板选择被遮照对象的对象显示块.
2 | 对被遮照对象进行编辑.
 | 注: 当您选取遮照图像时,笔触面板和填充面板显示被遮照对象的相应属性.

移动遮照对象和被遮照对象:

1 | 点击层面板遮照对象显示块间的"连接标记"
 | 如果遮照对象和被遮照对象不连接,两者可以独立的移动.
2 | 在画布中拖拽对象进行移动.

将矢量遮照转换为位图遮照:
1 | 在层面板,选取遮照对象显示块.(此时选中遮照对象)
2 | 选择菜单 Modify > Convert to Bitmap(修改 -> 转换为位图).
 | 注: 您可以将矢量遮照转换为位图遮照,不可以将位图遮照转换为矢量遮照.

遮照失效或有效:

1 | 选取遮照对象.
2 | 失效或有效遮照:
 | 在层面板弹出菜单(右上角小箭头)选择"遮照失效"或"遮照有效".
 | 选择菜单 Modify > Mask > Disable,Enable Mask(修改 -> 遮照 -> 遮照失效,遮照有效).

当遮照失效时,遮照对象的对象显示块上将出现一个红色的 X 对角线.点击 X 对角线可以重新有效遮照.

去除遮照:

1 | 选择遮照图像.
2 | 删除遮照:
 | 从层面板的弹出菜单(右上角小箭头)选择"删除遮照".
 | 选择菜单 Modify > Mask > Delete Mask(修改 -> 遮照 -> 删除遮照).
3 | 在删除前选择是否应在被遮照对象上应用遮照效果:
 | 选择 应用(Apply)将保留遮照图像为独立的位图图形.遮照不再可以被编辑.
 | 选择 拆除(Discard) 将拆除遮照对象,恢复被遮照对象.

蓝骑士编译


遮照时使用对象面板--蓝骑士（侠客岛版权所有）

层和遮照 > 遮照时使用对象面板

遮照时使用对象面板

遮照时使用对象面板可以让您确定您当前正在操作的遮照类型.当选择遮照对象时,您可以改变遮照的类型.

矢量遮照可以按照遮照对象的路径遮照.此时被遮照对象按照遮照对象的路径区域显示.在对象面板上选中 路径轮廓(Path Outline)进入路径遮照方式.勾选 显示笔触和填充(Show Fill and Stroke)选项可以显示遮照对象的笔触和填充效果.遮照对象路径以外的区域将被遮盖,不显示.这种遮照方式与FreeHand的"内部粘贴"操作类似.

位图遮照可以选择Alpha通道方式.明显的,遮照图像将显亮.

矢量遮照和位图遮照都包含了 灰级显示(Grayscale Appearance)方式.灰级显示也就是遮照图像取决于遮照对象和背景色之间的明亮关系.遮照对象上明亮的像素点显示被遮照对象,较暗的像素点显示背景色.

蓝骑士编译


对象的混色--蓝骑士（侠客岛版权所有）

层和遮照 > 对象的混色

对象的混色

混色也就是将对象的色彩根据不同的混色模式产生透明和色彩交互.混色模式决定了色彩混色的计算方法,同时也可以在对象不透明度上添加一定的控制.

蓝骑士编译


关于混色模式--蓝骑士（侠客岛版权所有）

层和遮照 > 对象的混色 > 关于混色模式

关于混色模式

选择混色模式将对选中的对象的显示效果产生影响.不同层中的对象可以具有不同的混色模式.

当不同混色模式的对象成组时,对象组采用的混色模式将覆盖对象原来的混色模式.解散对象组,对恢复原来的混色模式.

混色模式包含下面的概念:

混色是在底色上使用的应用色.
不透明度决定了混色模式的效果不透明程度.
底色是混色的对象.
结果色是混色应用于底色后产生的色彩效果.

下面是Fireworks的混色模式:

Normal 无混色.

Multiply 底色乘混色,生成更深的结果色.

Screen 底色乘混色的反转色作为结果色,生成一种漂白的效果.

Darken 选取底色和混色中较深的颜色作为结果色,底色中亮于混色的色彩将被混色替代.

Lighten 选取底色和混色中较浅的颜色作为结果色,底色中暗于混色的色彩将被混色替代.

Difference 将底色和混色进行差值计算,亮度较低的颜色会从亮度较高的颜色中被减去.

Hue 组合混色的色调和底色的亮度和饱和度,生成结果色.

Saturation 组合混色的饱和度和底色的亮度和色调,生成结果色.

Color 组合混色的色调和饱和度和底色的亮度,生成结果色,使保留某些单色图像的灰度级.

Luminosity 组合混色的亮度和底色的色调和饱和度,生成结果色.

Invert 反转底色.

Tint 给底色添加灰色.

Erase 删除所有的底色像素,包括画布的背景色.

蓝骑士编译


混色举例--蓝骑士（侠客岛版权所有）

层和遮照> 对象的混色 > 混色举例

混色举例
Original image | Normal | Multiply
Screen | Darken | Lighten
Difference | Hue | Saturation
Color | Luminosity | Invert
Tint | Erase |

混色模式的应用还与您选择在矢量图编辑模式还是位图编辑模式有关.

在矢量图编辑模式,混色模式对所选中的对象产生作用.
在位图编辑模式,混色模式可以直接对由矢量对象转换过来浮动像素产生作用.
在位图编辑模式,对于非浮动像素图像,混色模式对随后在画布上绘制的笔刷,填充等新像素产生作用.

调整不透明度和应用混色

您可以通过层面板调整选取对象的不透明度以及应用混色.对象的不透明度在0-100间选择.0代表全透明.

在层面板设置对象不透明度和混色模式.

设置对象不透明度:

在不透明度文本框输入数值或点击小箭头,拖动数值滑块.

设置混色模式:

1 | 选取上方的一个对象.
2 | 点击层面板混色模式下拉框,选择一项混色模式.

设置默认的混色模式:

1 | 为防止此时有对象选中,选择菜单 Edit > Deselect(编辑 -> 撤销选取) 撤销对对象的选取.
2 | 然后在层面板混色模式下拉框中选取一项混色模式作为默认混色模式.

蓝骑士编译


应用实时色彩填充效果--蓝骑士（侠客岛版权所有）

层和遮照 > 应用实时色彩填充效果

应用实时色彩填充效果

实时"色彩填充"效果让您可以实时的调整对象的不透明度,混色模式等属性.这与您通过几个对象进行混色和不透明具有相同的效果.

Fireworks的实时"色彩填充"效果与Photoshop的色彩填充效果可以完全匹配.您可以导入一张包含色彩填充效果的Photoshop图像,Fireworks自动完成两者的转换.同样,您也可以导出具有实时"色彩填充"效果的Fireworks图像到Photoshop.

应用实时"色彩填充"效果:

1 | 选择应用的对象.
2 | 在效果面板的下拉菜单的"色彩调整"子菜单里选择"色彩填充".
3 | 选择合适的色彩,混色模式和不透明度.

蓝骑士编译


结合Photoshop--蓝骑士（侠客岛版权所有）

层和遮照 > 结合Photoshop

结合Photoshop

遮照可以输出到Photoshop.遮照对象将自动转换为Photoshop的遮照层,并且可以保留可编辑性.保留可编辑性,在输出到Photoshop时选择Settings(设置): Maintain Editability over Appearance(保留可编辑属性).

蓝骑士编译


导入Photoshop遮照层--蓝骑士（侠客岛版权所有）

层和遮照 > 结合Photoshop > 导入Photoshop遮照层

导入Photoshop遮照层

在Photoshop您可以使用遮照层产生遮照.Fireworks完全支持在导入Photoshop图像时包含遮照层的遮照属以及遮照对象的可编辑性.遮照层默认为位图遮照导入.

关于Photoshop遮照层的详细信息,请参看Photoshop遮照.

蓝骑士编译


导入Photoshop层组--蓝骑士（侠客岛版权所有）

层和遮照 > 结合Photoshop > 导入Photoshop层组

导入Photoshop层组

Photoshop的层对应于Fireworks的对象,Photoshop的层组对应于Fireworks的对象组.所以,Photoshop层组在导入Fireworks时,自动转换为Fireworksd的层,层组中的层转换为Fireworks层中的对象.Fireworks不支持Photoshop"组遮照效果"的导入.

关于Photoshop"组遮照效果"的详细信息,请参看 Photoshop组.

蓝骑士编译


网络层--蓝骑士（侠客岛版权所有）

层和遮照 > 网络层

网络层

网络层出现在每一个Fireworks文件的最顶层,它是一个特殊层.网络层中包含了切片和热点等与网络有关的对象.用于Fireworks输出网页文件时实现交互.

您不可以去处共享,删除,复制,移动或重命名网络层.(也就是说您只可以对网络层里的对象进行操作而不可以对网络层本身进行任何操作).网络层永远被文件中的所有影格共享,并且在不关闭显示网络层的情况下,每一个影格都可以看见网络层中的对象.

在网络层中重命名切片或热区对象:

1 | 在层面板鼠标双击切片或对象的显示块..
2 | 在弹出对话框中输入新名字,回车,或鼠标在对话框外点击一下..
 | 注:当您给切片命名,文件输出时切片将按照新名字输出.

蓝骑士编译


使用层--蓝骑士（侠客岛版权所有）

层和遮照 > 使用层

使用层

但您创建一个新层时,新层默认添加在当前层的下方.并且自动成为当前层,层显示高亮选中状态.复制层,则Fireworks创建一个与需要复制的层具有相同对象的新层.复制层时复制过来的对象包含了原来对象的属性.改变复制层中的对象不会影响原来的层.

每一个层可以被独立的编辑.也就是说,在一个层中对该层对象的改变不会影响其他层的对象.

添加层:

在下列的步骤中任意选择一种方法添加新层:

在层面板的弹出菜单(右上角小箭头)选择"新建层"命令.弹出对话框中输入新层的名字,在文本框下选择共享影格选项.点击确定.(共享影格概念:所选择的层将出现在文件所有的影格中,共享.改变共享层,所有影格同步).
点击层面板右下角的"新建/复制层"按钮.
选择菜单 Insert -> Layer(插入 -> 层).

层选中:

在下列的步骤中任意选择一种方法选中层:

在层面板点击层

在画布上选取某一个对象,则该对象所在的层在层面板被选中

您在画布上绘制或粘贴的对象一定出现在当前选中的层里.

展开或合上层:

点击层面板中层左方的"+"号(Windows操作系统)或三角符号(Macintosh操作系统),展开或合上层.

命名层:

1 | 在层面板中,双击层的名字区域.
 | 弹出层命名对话框.
2 | 在对话框的文本框中输入新的名字,回车,或在对话框外点击完成命名.
 | 注:层中的对象也可以命名.方法类似,双击对象显示块旁的对象名字区域,命名.

删除层:

选中希望删除的层,点击层面板右下角的"删除"按钮,或直接将层拖拽到"删除"按钮上释放.

显示或隐藏层,对象:

点击层面板中层或对象显示块右方的第二格方格.

眼睛标记形象的示意当前的层或对象显示块处于显示还是隐藏状态.

显示或隐藏多层,多个对象:

鼠标在层面板中层或对象显示块右方的第二格方格上下拖拽.

显示或隐藏所有的层和对象:

在层面板的弹出菜单(右上角小箭头)选择"显示所有"或"隐藏所有"命令.

注:被隐藏的层和对象不输出.

锁定层:

为了防止层何曾中的对象被修改,您可以锁定层.点击层面板中层或对象显示块右方紧邻的方格.

锁标记形象的示意但前的层已经被锁定.

锁定多层:

鼠标在层面板中层或对象显示块右方紧邻的方格上下拖拽.

锁定或解开所有的层:

在层面板的弹出菜单(右上角小箭头)选择"锁定所有层"或"解开所有层"命令.

注:锁定的层里的所有对象均不可被编辑.

在影格中共享层:

在层面板的弹出菜单(右上角小箭头)选择"共享层"命令.层后出现以下小标记.

注: 如果层共享,您对共享层的改变会在所有影格同步.共享层在您制作动画背景图案时,比较有用.

关闭或打开"单层编辑":

在层面板的弹出菜单(右上角小箭头)选择"单层编辑"命令."记号笔"标记出现或消失在层旁,形象的示意出当前您可以单层编辑的层.

在层面板移动对象

通过层面板您可以方便的在一个层里或两个层间移动对象.移动后,对象在文件中的顺序关系也将改变.使用菜单的排列命令您也可以改变对象的顺序.一个层中最上方的对象,在文件窗口中同样在该层的最上方.

在层面板,对象以对象显示块出现在层的下方.当您选中某个对象显示块时,该层同时被高亮选中.

通过展开层您可以查看该层里面所有的对象显示块.展开层点击"+"号(Windows操作系统)或三角符号(Macintosh操作系统).

移动一个对象到另一个层:

在层面板中拖拽该对象的对象显示块到其他层.

注: 您也可以在一个层中通过拖拽对象显示块来排列对象的顺序关系.例如将某个对象提前或置后.

复制选中的对象到另一个层:

按住 Alt 键(Windows操作系统) 或 Option 键(Macintosh操作系统) ,在层面板拖拽对象显示块到其他层.

重命名对象:

1 | 双击层面板中的对象显示块的名字区域.
2 | 在弹出对话框中输入新的名字,回车,或在对话框外点击完成命名.

复制层

您可以在层面板中复制层,并选择复制的地点.复制的层包含了原来层的所有对象和属性.复制的层的名字原来层多一个数字标号.

复制层:

1 | 选择下列的一种方式复制层:
 | 在层面板中拖拽层到"新建/复制层"按钮上.
 | 选中层,在层面板的弹出菜单(右上角小箭头)选择"复制层"命令.
2 | 如果您选择第二种方法,您还可以决定层的复制数量和复制的层的排列位置.
 | 注: 网络层永远在最顶层.所以,如果您选择在最顶层复制,这里的最顶层默认为网络层下的第一层.

排列层

在层面板中移动层可以改变层的排列顺序.最上方的层出现在画布的最前方.(同样,在层中移动对象显示块可以改变对象的排列顺序.层中最上方的对象,画布上出现在该层的最前方.)

移动层:

选中某一个层,并在层面板中上下拖动.

蓝骑士编译


遮照图像--蓝骑士（侠客岛版权所有）

层和遮照 > 遮照图像

遮照图像

使用遮照用于创建部分被遮掩的图像效果.一个对象或图形可以对另一个对象或图形遮照.遮照可以被编辑.

(概念:这里,把用于遮照的对象称为遮照对象,把被遮照的对象称为被遮照对象.遮照形成的图形称为遮照图像)

您可以使用矢量对象或位图图形作为遮照对象和被遮照对象.

遮照时分成以下两部分:

矢量的路径可以勾勒出被遮照对象的某个区域的图像.该区域与路径围绕区域一致.遮照对象在被遮照对象的上方.

遮照对象本身的像素变化可以影响被遮照对象的显示. 这Photoshop中,对应于图层遮照.通常,通过对遮照对象定义渐变或其他效果,可以产生非常丰富的遮照图像.

编辑不同的笔触和填充的属性,您可以创造出许多独特的遮照图像.

被遮照对象和遮照对象

矢量遮照

位图遮照

蓝骑士编译


创建位图遮照和矢量遮照--蓝骑士（侠客岛版权所有）

层和遮照 > 创建位图遮照和矢量遮照

创建位图遮照和矢量遮照

您可以使用层面板或菜单的命令创建遮照.矢量对象和位图图形都可以作为遮照对象.遮照对象还可以由多个对象组成.

创建位图遮照:

1 | 选择被遮照对象.
2 | 点击层面板右下角的"添加遮照"按钮.
3 | 使用位图工具绘制遮照对象.(此时在位图编辑模式.)
 | 注: 位图绘制工具包括笔刷,笔,矩形,椭圆,多边形等用于位图编辑模式的工具.

创建矢量遮照:

1 | 创建矢量路径,矢量对象,或文字对象,作为遮照对象.
2 | 剪切或复制遮照对象.
 | 如果遮照对象包含多个对象,Shift键按住用于复选.
3 | 选择被遮照对象.
4 | 使用粘贴为遮照(Paste as Mask)命令形成遮照:
 | 选择菜单 Edit > Paste as Mask(编辑 -> 粘贴为遮照).
 | 选择菜单 Modify > Mask > Paste as Mask(修改 -> 遮照 -> 粘贴为遮照).

蓝骑士编译


为对象创建遮照--蓝骑士（侠客岛版权所有）

层和遮照 > 为对象创建遮照

为对象创建遮照

任何对象都可以作为被遮照对象.使用"粘贴为遮照"命令可以将剪贴板中的对象作为遮照对象为被遮照对象创建遮照.您也可以使用多个对象作为遮照对象.

使用剪贴板对象作为遮照对象:

1 | 创建作为遮照对象的对象.可以是一个对象也可以是多个对象.
 | Shift键按住可以复选多个对象.
2 | 将对象放入剪贴板作为遮照对象:
 | 选择菜单 Edit > Cut(编辑 -> 剪切).
 | 选择菜单 Edit > Copy(编辑 -> 复制).
3 | 选择被遮照对象.
4 | 选择菜单 Edit > Paste as Mask(编辑 -> 粘贴为遮照) 或 选择菜单 Modify > Mask > Paste as Mask(修改 -> 遮照 -> 粘贴为遮照).
 | 如果遮照已经存在,通过剪贴板"粘贴为遮照",您可以在弹出对话框选择替换原有遮照对象,或将新对象添加到原有遮照对象中,形成多个对象遮照.

区域内遮照:

1 | 选择被遮照对象.
2 | 选择菜单 Edit > Cut(编辑 -> 剪切).
3 | 选择遮照对象.
4 | 选择菜单 Edit > Paste Inside(编辑 -> 区域内遮照).

使用多个对象作为遮照对象

您可以选择多个对象并将他们通过成组为遮照(Group as Mask)命令创建遮照图像.多个对象中顺序在最上方的图像作为遮照对象,下面的对象作为被遮照对象.(关于对象的顺序关系,请注意在层面板中观察对象指示块的上下关系.您可以对多个层间的对象"成组为遮照")

您既可以将对象成组为位图遮照,也可以成组为矢量遮照."成组为遮照"默认为位图遮照.您也可以在通过设置键盘快捷键,定义对应的成组为矢量遮照快捷键.快捷键设置在快捷键对话框"命令"选项的"其他"(Miscellaneous)一项里.您也可以在对象面板里选择位图遮照还是矢量遮照.详细请参看 遮照中使用对象面板.

多个对象成组为遮照:

1 | Shift键复选多个对象.
2 | 选择菜单 Modify > Mask > Group as Mask(修改 -> 遮照 -> 成组为遮照).

蓝骑士编译


使用文字遮照--蓝骑士（侠客岛版权所有）

层和遮照 > 为对象创建遮照 > 使用文字遮照

使用文字遮照

文字也可以作为遮照对象创建文字遮照效果.调整笔触面板和填充面板里的属性,您可以改变遮照的效果.您也可以在对象面板选择文字遮照是位图遮照还是矢量遮照.更多信息请参看 遮照中使用对象面板.

使用文字创建遮照:

1 | 使用文字编辑器创建文字.
 | 参看 输入文字.
2 | 将文字对象剪切或复制到剪贴板.
3 | 选择被遮照对象,选择菜单 Edit > Paste as Mask(编辑 -> 粘贴为遮照).
 | 文字遮照默认为矢量遮照.

蓝骑士编译


创建空遮照--蓝骑士（侠客岛版权所有）

层和遮照 > 创建空遮照

创建空遮照

您可以在对象上添加空遮照.既可以是"显示遮照",也就是显示遮照的区域,也可以是"隐藏遮照",就是遮照的区域被隐去.

(空遮照主要用于位图编辑模式的遮照)

蓝骑士编译


使用"显示所有/隐藏所有"命令--蓝骑士（侠客岛版权所有）

层和遮照 > 创建空遮照 > 使用"显示所有/隐藏所有"命令

使用"显示所有/隐藏所有"命令

"显示所有"命令添加一个空的全透遮照,是被遮照对象全部显示."隐藏所有"命令添加一个空的全遮遮照,使对象全部被遮盖.

(通过后续的位图操作,您可以创建不同的遮照图像.例如显示被遮照对象某一部分,或被遮照对象某一部分被遮盖.)

使用"显示所有"和"隐藏所有"命令创建空遮照:

1 | 选择被遮照对象.
2 | 创建空遮照:
 | 选择菜单 Modify > Mask > Reveal All(修改 -> 遮照 -> 显示所有),用于显示被遮照对象.
 | 选择菜单 Modify > Mask > Hide All(修改 -> 遮照 -> 隐藏所有),用于隐藏被遮照对象.
3 | 在层面板的对象显示块中选择遮照对象.
4 | 选择绘图工具编辑遮照图像.

蓝骑士编译


使用库、样式和 URLs 概述——茕若（侠客岛版权所有）

使用库、样式和 URLs > 使用库、样式和 URLs 概述

使用库、样式和 URLs 概述

本章内容共涵盖了三个面板，你可以使用它们对符号，样式以及 URLs 进行存储和再利用。符号存储在库（Library）面板。同样的，样式存储在样式（Styles）面板，URLs 存储在 URL 面板。

样式面板包含了一组预置的 Fireworks 样式以供选择。如果你想使用那些你以前使用过的笔触、填充以及其他独特的对象属性，你可以把这些属性作为一个样式保存起来。简单的将其保存在样式面板中，然后把这组属性应用到其他对象上，这要远远胜于每次都重建这些属性。

符号存储在库面板中。符号可以分为三类：按钮、图形和动画。你可以创建新的符号，复制符号，导入现有的符号，编辑符号。

URLs 或者 Universal Resource Locator 存储在 URL 面板中。一个 URL 就是指一个具体的网页或文件在因特网上的地址。如果你需要多次使用同一网址，你可以在把它加入到 URL 面板中，你可以在URL库中组织、组合你的网址。

茕若编译


关于样式——茕若（侠客岛版权所有）

使用库、样式和 URLs > 关于样式

关于样式

通过创建样式，你可以保存一套预先定义好的填充、笔触、特效，或者文本属性，并可以重复使用它。Fireworks 中的样式同文本处理程序中的样式相比，更像画家调色板上的混合色。当你给对象应用样式时，这个对象就拥有了样式的特征。

Fireworks 拥有许多的预定义样式。你可以添加自己的样式，也可以对样式进行修改或者删除。Fireworks CD-ROM 和 Macromedia 的网站上也有许多的预定义样式，你可以把它们引入到程序中使用。你也可以导入样式并与其他 Fireworks 用户分享，或者从其他的 Fireworks 文档中导入样式。

茕若编译


使用样式——茕若（侠客岛版权所有）

使用库、样式和 URLs > 使用样式

使用样式

使用样式面板可以储存样式，也可以给对象或者文本应用样式。 选择 Window > Styles（窗口 > 样式）打开样式面板。

样式面板

在你给对象应用一个样式的时候，你可以在稍后不影响原始对象的前提下对样式进行更新。Fireworks 并不跟踪你究竟给对象应用了哪些样式。如果你删除的是你自己创建的样式你就不可能恢复它。如果你删除了一个 Fireworks 自己提供的样式，你可以使用样式面板 Options（选项）弹出菜单上的 Reset Styles（重置样式）恢复那些已删除的预置样式。不过这样一来，就会删除你的自定义样式。

给被选取对象或者文本块应用样式：

点击样式面板上的样式。

创建一个新的样式：

1 | 创建一个使用了你想保存为样式的笔触、填充、特效或文本属性的对象或文本。
2 | 点击样式面板底部的 New Style（新样式）按钮。
3 | 选择你想让成为样式一部分的属性，按你的希望命名它，然后点击 OK 按钮。
 | 这时一个描述样式的图标会出现在样式面板上。

编辑样式：

1 | 选择 Edit > Deselect（编辑 > 取消选定）。
2 | 双击样式面板上的样式。
3 | 在 Edit Style（编辑样式）对话框中选择或取消选择你希望应用的样式部件，然后点击 OK。

在现有样式的基础上创建新样式：

1 | 给被选取对象应用现有样式。
2 | 编辑对象的属性。
3 | 将编辑好的属性保存为新的样式。

删除样式：

1 | 从样式面板上选择你要删除的样式。
 | 如果想选择多个样式进行删除，在点选的同时按住 Shift 键就可以了。
2 | 点击样式面板上的 Delete Style（删除样式）按钮。

导出样式：

1 | 从样式面板选择一个或更多的样式。
 | 如果想选择多个样式，在点选的同时按下 Shift 键。
2 | 从样式面板的 Options 弹出菜单中选择 Export Styles（导出样式）按钮。
3 | 为保存样式的文档输入名字和位置。
4 | 点击保存。

导入样式：

1 | 从样式面板的 Options 弹出菜单中选择 Import Styles（导入样式）按钮。
2 | 选择要导入的样式文档。
 | 所有在样式文档中的样式都会被导入，并被直接的放置在样式面板中选定样式的后面。

将样式面板重置为默认状态：

从 Option 弹出菜单中选择 Reset Styles（重置样式）。

注： 重置样式为默认状态会覆盖所有你保存的自定义样式。

改变样式预览图标的尺寸：

从样式面板的 Options 弹出菜单中选择 Large Icons（大图标），以此来在大、小预览尺寸间转换。

茕若编译


关于符号和实体——茕若（侠客岛版权所有）

使用库、样式和 URLs > 关于符号和实体

关于符号和实体

一个符号代表了一个对象、文本块、或是群组，它也可以是一个图形、动画、或按钮。实体是一个原始的 Fireworks 对象的代表。这个原始的对象被指定为符号。当符号对象(也就是原始对象)被编辑后，实体(原始对象的副本)也会根据符号的修改而自动得以修改。

无论何时你想要重新使用一个图形元素，符号对你来说都是有用的。它们可以在文档间交叉使用。符号对于在多帧中制作按钮和动画也是十分必要的。有关创建动画的更多介绍，参阅创建动画符号。

使用符号和实体可以非常容易地修改许多一样对象的副本，实现了 Rollover 状态间的部件共享，迅速制作和修改动画。

茕若编译


使用符号库——茕若（侠客岛版权所有）

使用库、样式和 URLs > 使用符号库

使用符号库

符号的创建和保存是在库（Library）面板中进行的。库面板存储了图形、按钮和动画符号。你可以从任何对象、文本块、或是组创建符号。一个符号中可以包含其他符号。

创建新的符号：

1 | 按下面的一条执行：
 | 从零开始创建一个新的符号，选择 Insert > New Symbol（插入 > 新符号），或者在库面板的 Options 弹出菜单中选择 New Symbol（新符号）按钮。
 | 从现存的对象中创建一个符号，选定对象然后选择 Insert > Convert to Symbol（插入 > 转换成符号）。
2 | 在 Symbol Properties（符号属性）对话框中的 Name 文本框中输入符号的名字。
3 | 在 Graphic、Animation、或Button（图形、动画、或按钮）中选择一个符号类型，然后点击 OK。
4 | 如果你是从零开始创建一个新的符号，那么 Symbol Editor 或 Button Editor 将打开。创建一个作为符号使用的对象，然后关闭编辑器。
 | 符号就会出现在库和文档中。

要了解更多关于创建按钮符号的信息，请参阅 从库中插入按钮。 要了解更多关于创建动画符号的信息，请参阅 创建动画符号。

放置实体

你可以给当前文档添加一个或者多个同一符号的实体。

为了放置实体，从库面板上拖动符号到当前文档中。

箭头图标表示这是一个实体

更改符号

你可以在 Symbol Editor 中修改符号，这将自动修改所有关联的实体

注：修改一个实体同样会影响到符号和所有其他实体。要想仅仅修改一个实体，请参阅中断实体与符号的联系。

改变符号：

1 | 打开 Symbol Editor：
 | 双击实体。
 | 双击库面板中的符号对象。
2 | 对符号进行更改，然后关闭窗口。
 | 符号和其所有实体都会反映出你的修改变化。

重命名符号：

1 | 双击库面板中的符号名字。
2 | 在 Symbol Properties（符号属性）对话框中更改名字，然后点击 OK。

复制符号：

1 | 在库面板上选取你要复制的符号。
2 | 从 Options 弹出菜单中选择 Duplicate（复制）按钮。

删除符号：

1 | 在库面板上选取你要删除的符号。
2 | 从 Options 弹出菜单中选择 Delete（删除）。
3 | 如果符号正被使用，点击 Delete。符号和它的所有实体都会被删除。

选取库中所有当前文档中尚未应用的符号：

从库面板的 Options 弹出菜单中选择 Select Unused Items（选择未使用项目）。

中断实体与符号的联系

通常情况下，修改一个实体也会同时修改符号和所有其它的实体。不过，你可以在不影响符号或者其它实体的情况下修改某一个实体，方法是在修改之前先切断符号与实体的联系。

从符号中释放一个实体：

1 | 选取文档中的实体。
2 | 选择 Modify > Symbol > Break Link(修改 > 符号 > 中断联系）。
 | 实体恢复成为一个群组。库面板中的符号就不再与该群组相关联。按钮符号会停止作为按钮的功能，同样动画符号也会停止作为动画的功能。
 | 注：为了把释放的实体作为一个对象进行编辑，选取实体然后选择 Modify > Ungroup （修改 > 取消群组）。

使用来自其他库中的符号

你可以导出符号将其用于其它的文档,或者从其它的文档中导入符号。

如果你修改了原始文档中的符号，你可以对导入到其它文档中的该符号进行更新。

举例来说，假设你在一个主文件中制作了一个你的公司的标志的符号。然后你又将这个标志元素导入到其它文档中。如果标志变化了，你就可以在主文件中修改标志，然后更新所有导入符号的文件。

你可以通过在当前文档中编辑符号，从而自动切断导入符号同原始文档的联系。在切断联系之后，你就可以独立于原始符号而对导入符号进行编辑。

导出符号：

1 | 在库面板的 Options 弹出菜单中选择 Export Symbols（导出符号）。
2 | 选取要导出的元素并点击 Export（导出）。
3 | 查找文件夹，输入符号文件的名字，然后点击保存。
 | Fireworks 会将符号保存在一个单独的 PNG 文件中。

使用拖放或复制粘贴的方法导入符号：

将符号拖动到当前文档中。
将符号粘贴到当前文档中。

使用库面板导入符号：

1 | 在库面板的 Options 弹出菜单中选择 Import Symbols（导入符号）。
2 | 选择包含符号文件的文件夹，选择这个文件，然后点击打开。
3 | 选取要导入的符号，然后点击 Import（导入）。
 | 导入的符号出现在库面板中，其文件类型旁边会有"(imported)" 的字样。

更新从其它文档中导入的符号：

1 | 在原始文档中，修改符号并保存文件。
2 | 在导入符号的文件中从库面板中选取符号。
3 | 在库面板的 Options 弹出菜单中选择 Update（更新）。
 | 注：为了更新所有导入的符号，在库面板中选取所有的符号然后再选择 Update。

茕若编译


关于 URL 面板——茕若（侠客岛版权所有）

使用库、样式和 URLs > 关于 URL 面板

关于 URL 面板

给一个 Web 对象分配 URL 地址就是给它创建一个文件链接。这个文件一定是个网页。你可以给热区、按钮和切割对象分配 URLs。如果你可能需要输入同一网址若干次的话，你可以在 URL 面板上建立一个 URL 库，然后将常用的 URLs 存在库中。使用 URL 面板可以添加、编辑和组织你的 URLs。

例如，如果你的网站包含几个返回你主页的浏览按钮，在 URL 面板中增加一个你主页的 URL 地址。然后通过在 URL 库中选择它来给每个浏览按钮分配URL。在多个文档间可以使用查找和替换来更改 URL 地址。具体请参阅查找和替换。

URL 库在随后的其它创作中都可以使用，作为共享内容它被保存在 Fireworks 中。

URL 面板

茕若编译


使用URLs——茕若（侠客岛版权所有）

使用库、样式和 URLs > 使用 URLs

使用 URLs

在库中你可以将 URLs 组合到一起。这会把相关的 URLs 放在一起，使它们更容易被访问。你既可以保存 URLs 到默认的 URL 库 URs.htm 中，也可以把它保存在自己创建的新库中。URLs被存储在 Fireworks 4\Settings\URL Libraries 文件夹中的一个 HTML 书签文件中。这些文件名的名字会出现在 URL 面板中。

创建新的 URL 库：

1 | 从 URL 面板的 Options 弹出菜单中选择 New URL Library（新建URL库）。
2 | 在文本框中输入新的 URL 库的名字，点击 OK 按钮。
 | 新库的名字会出现在 URL 面板上的 Library 弹出菜单中。

向 URL 库中添加新的 URL：

1 | 从 Library 弹出菜单中选择一个库。
2 | 在 Link 文本框中输入一个 URL。
3 | 点击添加(＋)标记。
 | 添加标记会把当前的 URLs 添加到库中。

通过添加那些在你文档中使用的 URls 你可以进一步组织你的 URLs。

向 URL 库中添加旧的 URLs：

1 | 从 Library 弹出菜单中选择一个库。
2 | 从 URL 面板的 Options 弹出菜单中选择 Add Used URLs to Library（向库中添加旧的URLs）。

给Web对象指定URL：

1 | 选取对象。
2 | 键入URL：
 | 从 URL 面板的 Options 弹出菜单中选择 Add URl（添加 URL）。键入一个绝对的或相对的 URL 然后点击 OK。
 | 在 Link 文本框中键入一个 URL。点击添加(+)标记。
 | URL 地址会出现在 URL 预览窗口中。
 | 请参阅给按钮添加 URL，给热区指定 URLs，and 给 rollovers 效果指定 URL 链接。

编辑 URL：

1 | 在 URL 预览窗中选取要编辑的 URL地址。
2 | 从 URL 面板的 Options 弹出菜单中选择 Edit URL（编辑 URL）。
3 | 编辑 URL。如果你要更新在文档中的所有该链接，选择 Change All Occurrences in Document（更改所有文档中出现的链接）就可以了。
4 | 点击 OK。

从 URL 预览面板中删除选定的 URL地址：

点击 URL 面板底部的 Delete URL from library（从库中删除URL）按钮。

从库中删除所有未使用的URLs：

从 URL 面板的 Options 弹出菜单中选择 Clear Unused URLs（清除未使用 URLs）。

导入 URL 地址：

1 | 从 URL 面板的 Options 弹出菜单中选择 Import URLs（导入 URLs）。
2 | 选择一个 HTML 文件，点击打开。
 | 所有包含在该文件中的 URLs 都会被导入。

导出 URL 地址：

1 | 从 URL 面板中选择要导出的 URL 地址。
2 | 从 Options 弹出菜单中选择 Export URLs（导出 URLs）。
3 | 键入文件的名字，点击保存。
 | 一个 Fireworks 书签文件被创建。这个文件包含了你导出的 URLs。

茕若编译


使用 URLs——茕若（侠客岛版权所有）

使用库、样式和 URLs > 使用 URLs > 输入绝对或相对 URLs

输入绝对或相对 URLs

当你在URL 面板上输入 URL 地址时，你可以输入绝对的，也可以输入相对的 URL 地址：

如果你要链接的网页不在你自己的网站，就必须使用绝对 URL。
如果你要链接的网页在你自己的网站，你就可以使用绝对或者相对 URL。

绝对 URLs 是一个包括了服务器协议的完整的 URLs，通常是以 http:// 开头。例如，http://www.macromedia.com/support/fireworks 就是 Macromedia Fireworks Support 网页的绝对 URL。绝对 URLs 不管源文档所在何处都保持精确，但是如果目标文档被移动，绝对 URL 就不能正确链接了。

相对 URLs 是指同包含源文档文件夹是相对的。下边这些都是显示了相对 URLs 导航语法的例子：

file.htm 链接到与源文件同一文件夹中的文件。
../../file.htm， 链接到比包含源文件的文件夹高两级的文件夹中的文件。每个 ../ 表示一级。
htmldocs/file.htm 链接到名为 htmldocs 的文件夹中的文件，该文件夹位于包含源文件的文件夹中。

相对 URLs 通常是用来链接相同文件夹中的两个文件的最简捷的方法。

茕若编译


创建按钮和导航栏概述 - Candy （侠客岛版权所有）

创建按钮和导航栏 > 创建按钮和导航栏概述

创建按钮和导航栏概述

Fireworks里,即使您不懂JavaScript，也可以创建出各种各样的JavaScript按钮，Fireworks 按钮编辑器可以引导您完成创建按钮的任务。最后产生一个方便的按钮符号，您可以对它进行移动和变形就象是一个单一的对象。您可以快速的复制按钮创建出一个导航栏，并且很容易的修改按钮各帧上的文字。

按钮是通过后台运行的JavaScript控制的，当您输出按钮时，Fireworks会自动产生在浏览器中显示所需要的JavaScript。 在Macromedia Dreamweaver 中，您可以很容易将JavaScript 和 HTML代码插入网页，同样，您也可以将代码剪切与粘贴到任何的HTML文件。

导航栏是一组按钮，当页面的其他部分发生变化时，导航栏依然保持不变或看上去保持不变。

编译：Candy


创建按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 创建按钮 > 编辑按钮文字

编辑按钮文字

在Fireworks里,可以很容易的修改反转按钮上的文字而不需要对每一帧进行修改。

同时改变所有状态下按钮的文字

1 | 选择文档中的按钮
2 | 在对象面板的“按钮文字”内输入新的文字然后按Enter。
 | 按钮所有状态下的文字会被更新。

在按钮编辑器内同时改变按钮的所有状态的文字：

1 | 改变按钮的任何一种状态下的文字。
 | 出现一个信息框问您是否更新按钮的所有状态的文字。
2 | 点击Yes.

编译：Candy


创建按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 创建按钮 > 使用斜面效果绘制按钮的各个状态

使用斜角效果绘制按钮的各个状态

您可以使用任何对象创建翻转的状态，然而，按钮是JavaScript翻转中较为常见的类型， Fireworks 中包含了一些实时效果来简化创建常见的按钮外观的工作。可以先给对象应用内斜角或外斜角，然后再从“按钮预制效果”弹出菜单中选择“凸起”“强调”“嵌入”或“反转”。
按钮的预制效果 | 简介
凸起 | 使斜角看上去是从下边的对象向上凸起。
强调 | 按钮颜色发亮。
嵌入 | 使斜角看上去是嵌入到下边的对象。
反转 | 使斜角看上去是嵌入到下边的对象同时颜色发亮。

例如, 如果您要创建一个有四种状态的按钮，您可以给“ Up” 状态应用凸起，给“ Down ”状态应用强调，等等。

需要更多关于实时效果的信息，参见 应用实时效果.

编译：Candy


从库中插入按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 从库中插入按钮

从库中插入按钮

库可以帮助您更有效率的创建网站内外观统一的按钮。 您可以创建一个原始的按钮符号，作为您的网站内所有的按钮的来源。

在当前的文档内使用按钮符号，将按钮符号输入库， 然后将符号拖到画布创建一个新的分身。

注意：编辑一个分身将会破坏分身与原始符号之间的连接。

如果要修改网站内的按钮，您只需修改原始的符号，然后使用库面板上的更新命令，您的文档中的按钮就会改变。 需要更多使用库面板的信息，参见关于符号与分身.

编译：Candy


从库中插入按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 从库中插入按钮 > 输入复制的按钮符号到当前文档

输入复制的按钮符号到当前文档

输入复制的按钮符号到当前文档：

1 | 选择“窗口” > “库”，打开库面板
2 | 在选项弹出菜单上选择“输入符号”
3 | 定位到您以前创建的按钮符号或Fireworks文档，点击“打开” 。
4 | 点击“输入”将复制的符号放入库内。

编译：Candy


从库中插入按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 从库中插入按钮 > 从库中插入一个按钮

从库中插入按钮

从库中插入按钮：

1 | 打开库面板。
2 | 将按钮符号拖入文档。

编译：Candy


从库中插入按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 从库中插入按钮 > 输入预先安装的按钮符号

输入预先安装的按钮符号

Fireworks包含了几个按钮的样式。

在当前文档中输入预先安装的按钮符号：

1 | 选择“插入” >“库”> “按钮”
2 | 在按钮列表中选择。
3 | 点击“输入”

编译：Candy


用按钮创建导航栏 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 用按钮创建导航栏

用按钮创建导航栏

导航栏, 又称 nav bar, 就是一组按钮，在网页上其它部分都发生变化之后，而导航条仍然保持，或者看上去仍然保持不变。使用导航栏可以创建出贯穿整个网站的一致的导航帮助。快速创建导航条的一个简单的方法就是复制一组按钮，然后修改每个按钮上的文本和链接地址。导航栏在各个网页看上去都是同样的，但每个网页的链接都有特别的功能。

尽管导航栏上的每个按钮看上去都是一样的，但是显示不同的文字。只创建一个按钮符号的问题是，按钮上有不同的文字，但当您更新网站中所有按钮的外观时就不会发生改变。 您可以通过创建嵌套的按钮符号来解决这个问题。 创建一个按钮符号只使用图象元素没有文字。然后建立第二个按钮使用先前按钮的图象信息，并添加文字在非共享层上。复制这个按钮来创建导航栏。

使用嵌套符号创建导航栏：

1 | 创建一个使用图象元素没有文字的按钮符号。
 | 按钮自动显示在库中
2 | 选择 “插入” > “新按钮”
3 | 按钮编辑器显示“Up”状态工作区域。
4 | 从库中将原始按钮拖入新按钮的“Up”状态工作区域。
5 | 在层面板上选择原始按钮所在层上面的非共享层。
6 | 给新按钮的每个按钮状态添加文字。
7 | 在“ Down ”和 “Over While Down ”标签下，选取“ Include ”选项。
8 | 关闭按钮编辑器。
9 | 在文档内复制这个按钮
10 | 用对象面板修改每个复制按钮上的文字。

注意：您可以嵌套一系列的制作出方便的导航栏。

更新简单导航条上所有按钮的图形：

使用按钮编辑器编辑原始按钮（没有文字的按钮）。

Fireworks自动更新所有的按钮， 因为文字是在另一个按钮符号上的，更新图象时就不会有影响。

您还可以使用“Down” 和 “Over While Down” 状态来创建出更为复杂的导航条。

编译：Candy


将翻转图象转化为按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 >将Fireworks翻转图象转化为按钮

将Fireworks翻转图象转化为按钮

您可以从以前制作的翻转图象中创建按钮。您可以将这些翻转图象，包括以前版本的 Fireworks所制作的翻转图象，转化为按钮。获得使用按钮符号的方便。

将翻转图象的所有成分转化为按钮，新的按钮会放置在库中。按钮会自动创建自己的切片，所以不在需要原来的翻转图象的热点和切片。

将Fireworks翻转图象转化为按钮：

1 | 在帧面板上的弹出菜单上选择“在洋葱皮上显示所有帧”
2 | 选中反转图象的所有部件
3 | 选择“插入”> “转化为符号”
4 | 输入名称，选择类型“按钮”，点击OK。

编译：Candy


插入外部按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 插入外部按钮

插入外部按钮

您可以从一个Fireworks库中或另一个Fireworks文档中选择按钮。当您从外部输入按钮时，Fireworks会记住来源。以后，如果源文件变化了，您也可以更新输入的按钮。

给文档插入现成的按钮：

1 | 选择“插入”>“库” > “其他”选择你需要插入的按钮所在的库或Fireworks文档。
2 | 从库中选择一个符号点击“输入”。

更新输入的按钮：

1 | 在库面板上选择要更新的符号。
2 | 在选项弹出菜单上选择“更新”。
 | Fireworks 就会更新输入的按钮，保持与源文件相同的外观。

编译：Candy


关于按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 关于按钮

关于按钮

在Fireworks中按钮是实际上是一个封装的翻转图象，包含了按钮的四种状态。 每种状态下按钮的表现响应着一种鼠标行为：

“Up”状态是在默认或是空闲的情况下按钮显示的样子。
“Over”状态是在浏览器中鼠标掠过按钮时的表现。
“Down”状态是当按钮被点击后的表现，通常它是出现在目标网页中的。
“Over While Down ”状态就是当鼠标掠过处于“ Down” 状态下按钮的时候按钮的表现。 。

您可以创建一个按钮，或是将现有的对象转化为按钮。 按钮编辑器帮助您编辑按钮的所有状态,包括触发按钮变化的感应区域 —按钮编辑器自动创建的切片。

网络上许多的按钮只有两个状态—“Up” 和“ Over”。“ Over ”状态最有用因为它可以非常典型地提醒用户点击鼠标将会有事情发生。 “ Up” 和“Down” 状态传达出来的是一个静止的状态 ，“ while the Over While Down ”状态能警告用户点击是不会有任何结果产生的

按钮编辑器创建的按钮不仅仅是普通的JavaScript翻转图象：

按钮是一种特殊类型的符号， 您可以从库中将按钮符号的分身拖入文档。需要更多关于符号的信息，参见关于符号和分身.
按钮经过封装的. 当您在文档中移动按钮时，所有同该按钮相关的部件和按钮状态都会同时被拖动不需要编辑每一帧。
要编辑按钮很容易。双击按钮, 然后在按钮编辑器中编辑。
被选中的按钮在对象面板上有一个方便的文本框 ，您可以在里面输入文字，同步更新所有状态下按钮的文字。
就象其他的符号一样，按钮上有一个定位点，定位点是一个中心点帮助您排列文字和不同的按钮状态.

编译：Candy


创建按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 创建按钮

创建按钮

创建JavaScript按钮和导航栏最简单的办法就是使用按钮编辑器。在按钮编辑器上每个面板都有一些提示来帮助你做出设计方案。 按钮编辑器帮助您绘制按钮的所有状态设置按钮的链接地址。

按钮第一帧的任何一个前景层上创建， 当您创建一个不规则形状的按钮时,要注意Fireworks只使用第一帧的背景层，而不管其他帧的背景层。

按钮编辑器

编译：Candy


创建按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 创建按钮 >创建一个按钮

创建按钮

您可以在按钮编辑器中创建一个按钮，如果您的按钮是导航栏的一部分，您需要使用按钮的所有四中状态，不过如果您的按钮是单独的放在一个页面上的，您也许只需要“Up”和“Over”

注意: 当您创建或插入一个按钮时，Fireworks将自动将它放在第一帧上。按钮只能在第一帧上工作，如果按钮被移到其他帧，将不能正常工作。

创建一个按钮：

1 | 选择“插入” > “新按钮” 打开按钮编辑器。
 | 按钮编辑器打开时是在“Up”标签下
2 | 在按钮编辑器的工作区内，放一个显示在“Up”状态标签下的图象:
 | 使用绘图和编辑工具创建图象。
 | 将一个图象输入或拖入按钮编辑器.
3 | 如果需要在按钮上显示文字，可以使用文字工具。
 | 注意: 使文字中心对齐是不错的选择，这样在你以后编辑文字时，文字依然保持在按钮上的中间位置
4 | 点击 “Over ”标签.
5 | 选择“洋葱皮”这样您就可以直观的对每个按钮状态下的图象进行排列
6 | 放入按钮的“ Over ”状态下的图象：
 | 点击 “Copy Up Graphic”粘贴一个从 “ Up ”状态下复制来的图形到“Over”窗口然后进行编辑修改其外观。
 | 创建一个独特的 “Over” 状态的图象。
 | 在“ Over”窗口输入一个图象。
 | 如果需要在按钮上显示文字，可以使用文字工具。

编译：Candy


创建按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 创建按钮 > 添加“Down”状态

添加“Down”状态

在浏览器里，按钮的“Down”状态显示按钮被点击后仍然留在网页上时的表现，这个状态通常用在导航栏上。 许多按钮只存在于一个网页上，因此就不需要“Down”与“Over While Down”状态。

给按钮添加“Down”状态：

1 | 点击按钮编辑器上的“Down”标签
2 | 将图象放入按钮编辑器:
 | 点击“ Copy Up Graphic”从“Up”状态复制一个图象到“Down”窗口然后进行编辑修改其外观。
 | 创建一个独特的 “Down” 状态的图象。
 | 在“Down” 窗口输入一个图象。
 | 如果需要在按钮上显示文字，可以使用文字工具。
3 | 如果您需要在网页下载时就显示“Down” 状态，可以选中“下载时显示“Down” 状态” Show Down State Upon Load box.
 | 注意: 当您在“Down” 状态的工作区插入一个图象时，导航栏的“Down” 状态会自动被选中。

编译：Candy


创建按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 创建按钮 > 添加“Over While Down”状态

添加“Over While Down”状态

“Over While Down”状态就是鼠标掠过处于“Down”状态下的按钮的表现。和“Down”状态一样，“Over While Down”状态通常被用于导航栏。

给按钮添加“Over While Down”状态：

1 | 点击按钮编辑器上的“Over While Down”标签。
2 | 将图象放入按钮编辑器:
 | 点击“ Copy Up Graphic”从“Up”状态复制一个图象到“Over While Down”窗口然后进行编辑修改其外观。
 | 创建一个独特的 “Over While Down” 状态的图象。
 | 在“Over While Down” 窗口输入一个图象。
 | 如果您想在按钮上显示文字，可以使用文字工具。
 | 注意 当您在“Over While Down” 状态的工作区插入一个图象时，导航栏的“Over While Down” 状态会自动被选中。

编译：Candy


创建按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 创建按钮 > 给按钮附加链接

给按钮附加链接

给按钮附加链接可以是按钮链接到另一个网页，或是同一个网页的一个锚点，使用链接向导输入链接的URL。您可以输入当鼠标经过按钮时所显示的替代文字，和状态栏上显示的文字，链接向导也可以控制按钮输出时的设置和命名规则。 需要更多关于命名规则的信息，参见 自动命名切片.

使用按钮编辑器给按钮附加链接：

1 | 点击按钮编辑器上的“感应区域标签”。
 | 感应区域包含了一个单独的切片
 | 注意在默认情况下，按钮编辑器会自动创建切片。当“自动设置感应区域”被选中时切片的大小就是用于构筑按钮的所有图象的大小。
2 | 点击“链接向导”按钮，给按钮附加链接。
3 | 点击“链接”标签在第一个输入框内输入链接地址， 需要更多静态相对链接的信息,参见输入相对或绝对链接.
4 | 如果需要，您可以在剩下的输入框内输入替代文字，和状态栏上显示的信息
5 | 如果需要设置链接所打开的目标窗口，点击“目标”标签,在列表中选择一个目标或输入一个目标。
6 | 点击OK.

当您关闭按钮编辑器时，按钮会显示在库中，按钮的一个分身会出现的文档内，当您作为一个整体移动按钮或改变按钮的大小时，按钮的所有状态都会被移动和改变大小。

在文档中放置多个按钮副本：

将按钮从库中拖入文档。

您也可以按住Alt (Windows)或 Option (Macintosh)键拖动按钮的一个分身创建新的分身。

编译：Candy


创建按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 创建按钮 >改变按钮

改变一个按钮

当您编辑一个按钮符号时，所有的分身都会改变。

如果您从库中或其他Fireworks文档中导入按钮，那么在当前文档中编辑按钮会破坏按钮与先前文档的链接。

编辑已有的按钮符号：

1 | 双击按钮打开按钮编辑器。
2 | 点击任何按钮状态标签。
3 | 选取按钮对象并进行编辑。这和你在文档中编辑其它对象是一样的。

编译：Candy


创建按钮 - Candy（侠客岛版权所有）

创建按钮和导航栏 > 创建按钮 > 绘制和编辑感应区域

绘制和编辑感应区域

按钮的感应区域就是在浏览器中鼠标掠过是触发翻转的区域。

在“自动设置感应区域”被选中时，Fireworks会自动创建一个大小足够容纳所有状态的切片。如果您需要将切片设置为不同的形状和大小。您可以对切片进行编辑。如果您想绘制不同的切片，可以不选“自动设置感应区域”

当按钮编辑器打开时，在按钮的“感应区域”标签下的网络对象会出现在文档的 Web 层上。

绘制切片或热点网络对象：

1 | 双击一个按钮。
2 | 点击按钮编辑器上的“感应区域”标签。
3 | 取消选择“自动感应区域”。
4 | 选择切片或热点工具，在按钮编辑器内进行绘制。

编辑按钮的感应区域：

1 | 双击一个按钮。
2 | 点击“感应区域”标签。
3 | 使用指针工具，切片工具，或多边形切片工具，移动，改变形状或重绘当前的感应区域。

编译：Candy


热区和切片概述--蓝骑士（侠客岛版权所有）

使用热区和切片 > 热区和切片概述

热区和切片概述

热区和切片是您创建网页交互对象,例如鼠标掠过图像切换,图像地图等网页特效的基本工具.

热区和切片称为网页对象.也就是说,他们并不保存在图像中,而是最后生成的HTML文件中的一段交互式HTML代码.您可以通过层面板(Layers panel)中的网络层(Web Layer)查看,选择和重命名网页对象.

本章叙述了创建热区和切片的基本概念和方法.

蓝骑士编译


关于切片--蓝骑士（侠客岛版权所有）

使用热区和切片 > 关于切片

关于切片

切片将Fireworks文件切割成多个小碎片,并输出图像碎片.用户下载时,按照碎片的先后顺序下载.就像拼图一样,图像切割不会破坏图像的整体性.切片有三大优点:优化图像,创建交互和删除部分图像.您可以在删除图像的地方进行文字编辑.

蓝骑士编译


优化图像--蓝骑士（侠客岛版权所有）

使用热区和切片 > 关于切片 > 优化图像

优化图像

网络图像设计的一大挑战是如何尽可能的减小图像的大小,加快页面的下载.切片提供了强大的功能,使您可以尽可能的减小图像大小.Fireworks支持将不同切片根据需要定义为不同的图像格式.

蓝骑士编译


创建交互--蓝骑士（侠客岛版权所有）

使用热区和切片 > 关于切片 > 创建交互

创建交互

您可以通过切片创建页面交互.当用户鼠标在切片区域操作时,进行相应的变化.例如,创建图像翻转.

切片还可以创建图像,导航栏,弹除菜单等效果.

您也可以在切片中加入文字,或定义为文字区域,在HTML编辑器中进行文字编辑.

图像更替

使用切片的另一个原因是,您可以在网页中更新图像的某一部分区域,而不必更新整幅图片.例如,有一个需要每个月更新的标志在图像中,如果不使用切片,每次您需要更新整幅图像.而现在,将该标志单独切片,您只需要更新这部分的图像碎片,用户在浏览时也只需要下载很小的文件,就可以看到更新的页面,而不必重新下载.

蓝骑士编译


创建切片--蓝骑士（侠客岛版权所有）

使用热区和切片 > 创建切片

创建切片

您可以使用两种方法创建切片:在对象上自动插入切片或手工绘制.如果您希望整个对象是可交互操作的,您可以自动在对象上插入切片,该切片默认为矩形.

您可以通过菜单 Insert -> Slice(插入 -> 切片)将热区转换为切片.

您可以手工绘制切片.切片工具有矩形切片工具(Slice)和多边形切片工具(Polygon).

切片的红色辅助线是切割图像的依据.当图像切片输出时,图片按照切片的红色辅助线切割成图像碎片.

注: 您可以复制和粘贴切片对象到其它Fireworks文件
.

在对象上添加切片:

1 | 选中对象.
 | 通过Shift键可以复选多个对象.
2 | 选择菜单 Insert -> Slice(插入 -> 切片).切片默认为包含对象的矩形切片.
3 | 如果您选择了多个对象,讲坛除下面的对话框:
 | 点击 Single 将创建一个包含所选择对象的矩形切片.
 | 点击 Multiple 将在每个对象上创建切片.

绘制矩形切片:

1 | 选择矩形切片工具(Slice).
2 | 在对象上拖拽一定区域,形成切片.切片辅助线自动出现.

蓝骑士编译


切片重叠--蓝骑士（侠客岛版权所有）

使用热区和切片 > 创建切片 > 切片重叠

切片重叠

有时候在绘制切片或自动添加时会造成切片重叠.Fireworks默认最上方的切片为主响应对象.切片重叠常常会造成一些设计上的缺陷,建议尽量避免.

蓝骑士编译


在切片上添加链接--蓝骑士（侠客岛版权所有）

使用热区和切片 > 创建切片 > 在切片上添加链接

在切片上添加链接

您可以使用对象面板(Object)在切片上添加链接.

1 | 选择菜单 Window -> Object(窗口 -> 对象)打开对象面板.
2 | 在链接(link)文本框中输入 URL 地址.
3 | 在提示信息<alt>文本框中输入图像提示信息.
4 | 在目标(target)文本框中输入HTML的目标名字(或在下拉框中选择框架目标).关于目标请参看 选择目标选项.

蓝骑士编译


创建文字切片--蓝骑士（侠客岛版权所有）

使用热区和切片 > 创建切片 > 创建文字切片

创建文字切片

文字切片将以文本格式出现在页面(而不保存为图像).文字切片创建对应的HTML表格中的单元格.该单元格可以进行文字编辑.

文字切片使您可以快速的更新网站中的相关文字信息.因此,Fireworks除了制作网页图像,也可以进行文字的部分编辑.

创建文字切片:

1 | 创建切片.
2 | 在对象面板(Object),在下拉框选择 Text(文字).
3 | 在文本框中输入文字.
4 | 文字的格式可以是:
 | 文字及HTML的文字标签.
 | 文字及目标HTML文件的自定义标签.(目标HTML就是您将输出Fireworks文件到该文件的站点HTML文件).

文字切片中的文字在您的PNG文件中不显示.当您输出或预览HTML文件时,您可以看见文字切片的文字.

注: 在不同的操作系统和不同的浏览器中,文字切片的文字显示样式将会有所不同.

蓝骑士编译


创建多边形切片--蓝骑士（侠客岛版权所有）

使用热区和切片 > 创建切片 > 创建多边形切片

创建多边形切片

仅仅使用矩形切片,常常不能适用任何情况.例如,有时候矩形切片出现重叠,或者对象是不规则形状的对象,这时候我们可以使用多边形切片,在对象上绘制您需要的切片形状.这常常在做图像翻转时切片发生重叠时使用.

您也可以直接按照矢量路径的形状,在对象上自动形成多边形切片.

自动创建多边形切片:

1 | 选中对象.
2 | 选择菜单 Insert -> Hotspot(插入 -> 热区).
3 | 选择菜单 Insert -> Slice(插入 -> 切片).
 | 热区被转换为切片.(圆形热区转换为矩形切片)

手工绘制多边形切片:

1 | 选择多边切片工具.
2 | 在画布上点击鼠标放置多边形的各顶点.Fireworks自动用直接用直线连接各顶点.
3 | 当对于有柔边效果的图像切片时,请尽量将柔边效果包含在切片中,避免最后图像翻转时产生明显的界限.
4 | 切换其他工具退出多边形切片工具.Fireworks保留您切割出来切片形状.

注: 请注意不要太多的使用多边形切片,这会增加javascript的代码,造成文件的增加.既减慢了下载的速度,也增加了浏览器处理的时间.

转换矢量路径为切片:

1 | 选择矢量路径.
2 | 选择菜单 Insert -> Hotspot(插入 -> 热区).
3 | 选择菜单 Insert -> Slice(插入 -> 切片).
 | 切片根据矢量途径的形状,自动应用矩形切片或多边形切片.

蓝骑士编译


显示切片和切片延展线--蓝骑士（侠客岛版权所有）

使用热区和切片 > 创建切片 > 显示切片和切片辅助线

显示切片和切片辅助线

如果对象上有切片,因为对象被切片的遮挡,所以编辑对象时可能会不方便.这时您可以选择隐藏切片,是对象被直接操作.您可以关闭所有的切片,也可以选择关闭其中的一个.

当您绘制切片时,Fireworks自动显示切片辅助线做为后续Fireworks切割图像的依据.您不可以像编辑标尺辅助线一样编辑切片辅助线,在您添加,移动切片时,辅助线会有所改变.更多信息请参看 使用标尺,辅助线,和网格 .

切片和切片辅助线在预览时可以显示.

您可以为不同切片定义不同色彩,以此管理多个切片.您也可以改变切片辅助线的色彩.

隐藏某一个切片或热区:

点击层面板(Layers)对应的网络层(Web layer)下的切片或热区对象显示块前的"眼睛"图标.

注: 点击"眼睛"图标或图标所在的空区域,进行对象显示和隐藏的切换.

隐藏或显示所有热区,切片和切片辅助线:

在工具面板选中热区工具或切片工具,点击最下方的 View(显示) 下对应的按钮.
点击层面板网络层前的"眼睛"图标.

隐藏和显示切片辅助线:

选择菜单 View -> Slice Guides(显示 -> 切片辅助线).

改变切片对象色彩:

选中切片,在对象面板(Object)中选择切片色彩.

改变辅助线色彩:

1 | 选择菜单 View -> Guides -> Edit Guides(显示 -> 辅助线 ->编辑辅助线).
2 | 选择新的Slice Color,切片辅助线色彩.

蓝骑士编译


切片图像优化--蓝骑士（侠客岛版权所有）

使用热区和切片 > 创建切片 > 切片图像优化

切片图像优化

您可以对不同的切片定义不同的图像优化格式,从而对整幅图像进行优化.

蓝骑士编译


创建热区和图像地图--蓝骑士（侠客岛版权所有）

使用热区和切片 > 创建热区和图像地图

创建热区和图像地图

网页设计师在网页中应用热区和图像地图,可以使页面的浏览更加的简捷.热区(hotspot)也就是在网页上图像对应的某一个区域添加 URL(全球资源定位) 链接.图像地图(image map)也就是在网页中的某一幅图像上应用多个热区,方便浏览者进入不同的链接.Fireworks支持不同形状的热区定义,自动输出图像地图的HTML代码到页面.

注: 因为图像地图其实就是热区的组合,所以本部分内容主要讲述创建热区.关于图像地图输出时的更多设置,请参看 输出图像地图 .

当您确定在图像的某个区域添加链接,您可以使用以下的两种方法创建热区:

使用热区工具(Hotspot)中的矩形(Rectangle),圆(Circle)和多边形(Polygon)直接在对象上绘制区域.
选中对象,在对象上插入热区(热区区域与对象相等).

创建矩形和圆形热区:

1 | 选择热区工具 (Hotspot)中的矩形(Rectangle)和或圆(Circle).
2 | 在画布上您希望绘制热区的区域,拖拽热区工具.绘制的时候按住 Alt 键(Windows操作系统) 或 Option 键(Macintosh操作系统) 您可以对热区进行中心放缩.

热区并不一定都是矩形或圆形.您同样可以创建多边形的热区多边形热区工具主要处理复杂形状的图像地图.

创建多边形热区:

1 | 选择多边形(Polygon)热区工具.
2 | 在画布上点击鼠标放置多边形的各顶点(就像您使用钢笔(pen)工具一样).无论是开放或封闭的路径,填充的区域显示您定义的热区形状.

在对象上添加热区:

1 | 选择菜单 Insert -> Hotspot(插入 -> 热区).
 | 如果您选择了多个对象添加热区,Fireworks弹出对话框询问:是否为所选择的所有对象创建一个矩形热区(Single)或者单独为每一个对象创建热区(Multiple).
2 | 点击 Single 或 Multiple 按钮. 热区自动添加在网络层中.

您也可以将圆形热区转变为多边形热区.请参看 改变热区 .

蓝骑士编译


在层面板中显示和命名切片--蓝骑士（侠客岛版权所有）

使用热区和切片 > 在层面板中显示和命名切片

在层面板中显示和命名切片

您可以使用层面板的网络层对网页对象例如热区和切片进行管理.您可以选中,显示和命名列表中的对象.

使用层面板选择和显示切片:

1 | 选择菜单 Windows -> Layers(窗口 -> 层面板)打开层面板.
2 | 使用"+"号(Windows操作系统)或三角形(Macintosh操作系统)展开网络层(Web Layer)对象列表.
 | 您在图像上使用的所有网页对象在列表中显示.
3 | 点击选择某一个切片对象.
 | 在画布中,对应的切片高亮显示.

切片将图像自动切割成多个图像碎片,并输出多个碎片文件.所以,每一个切片需要定义文件名.如果图像有多个层,则每一个层输出不同的切片图像.

一幅图像被切片切割成多个图像碎片.

输出时Fireworks自动对切片命名.关于命名原则,您也可以进行设置.

点击网络层中的切片对象,在下方的文字框中输入该切片自定义的名字.
选中切片,在对象面板选择自动命名.Fireworks将按照当前的命名原则在输出时自动命名关于命名设置,请参看 定义切片命名 .
不选择自动命名,您需要手工在文字框中为每一个切片输入名字.

蓝骑士编译


在网络层中命名切片--蓝骑士（侠客岛版权所有）

使用热区和切片 > 在层面板中显示和命名切片 > 在网络层中命名切片

在网络层中命名切片

最直接的对每个切片独立命名的方法是在网络层中命名切片.

在网络层中命名切片:

1 | 选择菜单 Window -> Layers(窗口 ->层面板)显示层面板.
2 | 使用"+"号(Windows操作系统)或三角形(Macintosh操作系统)展开网络层(Web Layer)对象列表.
 | 您在图像上使用的所有网页对象在列表中显示.
3 | 双击对应的网页对象显示块的名字.
4 | 在弹出窗口输入名字.

蓝骑士编译


自动命名切片--蓝骑士（侠客岛版权所有）

使用热区和切片 > 自动命名切片

自动命名切片

如果您不想手工输入切片名字,您也可以选择根据您设置的命名原则让Fireworks自动命名.

通过一系列的选项,您可以自由的定义切片的命名原则.自动命名可以根据六个基本单元进行组合.
选项 | 描述
None | 无.
doc.name | 文件名.
"slice" | "slice"关键字.(使您看到文件名中包含slice的知道这是一个切片文件)
Slice # (1,2,3...) Slice # (01,02,03...) Slice # (A,B,C...) Slice # (a,b,c...) | 数字或字符标签.
row/column (r3_c2, r4_c7...) | Row (r##) Col (c##)行或列 最后输出时,切片对应的在表格中的位置.
Underscore Period Space Hyphen | 空格符(依次为下滑线,点,空格,横线)

例如,当前文件名为"mydoc",当前选择命名原则是:doc.name + "slice" + Slice # (A,B,C...),则最后的结果是"mydocsliceA".

自动命名切片:

1 | 选择一个或多个切片.
2 | 在对象面板,选择Auto-Name Slices(自动命名切片).
3 | 当您输出时,您只需要为整个文件取一个文件名(不带后缀),Fireworks根据您定义的命名原则,自动在输出时对切片命名,并将每一个切片文件保存为对应的格式.
 | 选择菜单 File -> HTML setup(文件 -> HTML设置)您可以定义命名原则.
 | HTML Setup(HTML设置)对话框

改变命名原则:

1 | 选择菜单 File -> HTML Setup(文件 ->HTML设置)打开HTML设置对话框.
2 | 点击Document Specific(文件定义)标签.
3 | 选择您的命名原则.

例如,进行如下选择:doc.name + "slice" + Slice # (A,B,C...):

注: 点击 Set Defaults(设置为默认方案)将把当前设置的命名原则作为默认原则.

蓝骑士编译


自定义切片名字--蓝骑士（侠客岛版权所有）

使用热区和切片 > 自动命名切片 > 自定义切片名字

自定义切片名字

您可以自定义切片名字.例如,文件中包含导航栏,您可以定义包含返回首页链接的切片名字为"home"

自定义切片名字:

1 | 选中某一个切片,在对象面板,取消 Auto-Name Slices(自动命名)选项.
2 | 在文字框中输入自定义的切片名字.如果您不输入文字,Fireworks默认为自动命名.您不需要添加源文件扩展名.Fireworks自动会在您输入的名字前加入源文件扩展名.例如,切片属于名为"hello"的图像,则输出切片时,切片命名为"hello"+"切片名".

如果该切片对应的有多个影格图像,Fireworks自动的按照影格顺序在切片名后添加数字.例如,您命名切片"home",则后面的影格的切片名字依次为"home_f2","home_f3".您也可以在HTML设置对话框中改变这种命名原则.

改变多影格切片命名原则:

1 | 选择菜单 File -> HTML Setup(文件 ->HTML设置)打开HTML设置对话框.
2 | 点击Document Specific(文件定义)标签.
3 | 在Frames(影格)后的选项中选择命名原则.
 | 例如,选择:Underscore + Rollover (over, down, overdown) ,将创建"切片名"+"_over"的切片名.

注: 点击 Set Defaults(设置为默认方案)将把当前设置的命名原则作为默认原则.

蓝骑士编译


使用嵌套表格和单元格间隔--蓝骑士（侠客岛版权所有）

使用热区和切片 > 自动命名切片 > 使用嵌套表格和单元格间隔

使用嵌套表格和单元格间隔

在HTML设置对话框中,您可以选择Table(表格)标签,设置Fireworks输出的表格的属性.属性包括嵌套表格和单元格间隔的选择.

蓝骑士编译


更新Fireworks生成的HTML文件中的切片--蓝骑士（侠客岛版权所有）

使用热区和切片 > 更新Fireworks生成的HTML文件中的切片

更新Fireworks生成的HTML文件中的切片

如果您修改了某一个切片图像,您可以只更新Fireworks生成的HTML文件中对应的这一个切片,而不必更新所有图像.

更新一个切片:

1 | 编辑切片图像.
2 | 选中切片.
3 | 选择菜单 File -> Export(文件 -> 输出).
4 | 勾选 Selected Slices Only(仅更新选中的切片)选项.
5 | 输出切片到文件夹.

如果您不改变切片的文件名,更新的切片将替换原来的切片.

蓝骑士编译


在热区上添加链接--蓝骑士（侠客岛版权所有）

使用热区和切片 > 在热区上添加链接

在热区上添加链接

URL(全球资源定位),也就是Internet上的文件地址.当您在热区上添加链接,通过点击该热区,用户将被带往链接所指向的地址.您可以使用对象面板(Object)在热区上添加链接.

在热区上添加链接:

1 | 选择菜单 Window -> Object (窗口 -> 对象)打开对象面板.
2 | 在链接(link)文本框中输入 URL 地址.
3 | 在提示信息<alt>文本框中输入图像提示信息.
4 | 在目标(target)文本框中输入HTML的目标名字(或在下拉框中选择框架目标).关于目标请参看 选择目标选项.
5 | 您可以在颜色对话框中选择热区的颜色(该颜色不会在最后的网页中出现,仅仅是创作时的参考色彩).

蓝骑士编译


在URL面板管理URLs--蓝骑士（侠客岛版权所有）

使用热区和切片> 在热区上添加链接 > 在URL面板管理URLs

在URL面板管理URLs

如果您经常使用一些链接地址(URLs),您可以创建一个URL库,将这些常用的地址存放在URL库中.

蓝骑士编译


定义 alt(图像提示) 信息--蓝骑士（侠客岛版权所有）

使用热区和切片> 在热区上添加链接 > 定义 alt(图像提示) 信息

定义 alt(图像提示) 信息

Alt(图像提示)信息是在图像下载过程或图像下载失败时,出现在图像位置上的提示信息.一些新版本的浏览器也支持当鼠标放在图像上出现图像提示信息.

定义 alt(图像提示) 信息:

在对象面板的<alt>文本框输入文字.

蓝骑士编译


选择目标选项--蓝骑士（侠客岛版权所有）

使用热区和切片 > 在热区上添加链接 > 选择目标选项

选择目标选项

目标(target)是框架页面中所对应的页面.您可以定义热区的目标使得链接指向您希望的框架页面中的某一个页面.

定义目标:

在目标(target)文本框中输入HTML的框架页名字(或)..
在目标下拉框中选择框架目标

以下是目标下拉框中存在的默认目标:

_blank 在新窗口中浏览页面.(开新窗口)
_parent 如果有多层框架嵌套,在上一级框架页面中显示链接页面.
_self 在同一个框架页面或窗口中显示链接页面.(如果原来有框架,则框架的其它部分不改变).
_top 在浏览器中去除原来的框架,完整的显示链接所指向的页面.

蓝骑士编译


改变热区--蓝骑士（侠客岛版权所有）

使用热区和切片 > 改变热区

改变热区

网页对象和矢量对象类似,您可以使用指针工具(Pointer),子选择工具(Subselection),和变形工具(Transform)等工具改变热区的形状和大小.但不是所有的矢量工具都适用.

使用指针工具和子选择工具改变热区:

1 | 选择指针工具(Pointer)和子选择工具(Subselection).
2 | 拖拽对象:
 | 矩形热区改变位置和大小,但保持形状.
 | 圆形热区改变位置和大小,但保持形状.
 | 多边形热区根据拖拽情况改变形状.

改变热区图形(矩形,圆形,多边形):

1 | 选择菜单 Window -> Object (窗口 -> 对象)打开对象面板.
2 | 选择矩形(Rectangle),(圆形)Circle,或多边形(Polygon).

蓝骑士编译


在热区上应用拖拽功能(drag-and-drop)--蓝骑士（侠客岛版权所有）

使用热区和切片 > 在热区上应用拖拽功能(drag-and-drop)

在热区上应用拖拽功能(drag-and-drop)

您可以在热区上应用拖拽功能(drag-and-drop)创建图像翻转.在热区上应用拖拽功能(drag-and-drop)和在切片上应用相同.

注: 热区仅仅作为图像翻转的触发区域,不可以被其他热区或切片所指向.(这是因为热区是不可更换区域,与切片不同).在热区上应用拖拽功能(drag-and-drop)时,需要画布上存在被指向的切片对象.

当您在热区上应用拖拽功能(drag-and-drop)功能,Fireworks自通通过蓝线显示指向关系.

蓝骑士编译


输出图像地图--蓝骑士（侠客岛版权所有）

使用热区和切片 > 输出图像地图

输出图像地图

当您在Fireworks完成图像地图,您必须进行图像和HTML输出.

Fireworks产生的是客户端执行的图像地图.也就是图像地图中的链结和图像输出为网页形式.

输出被切割的图像地图将产生图像切片.更多信息请参看 创建切片 .

输出图像地图:

1 | 优化图像准备输出.
2 | 选择菜单 File -> Export(文件 -> 输出).
3 | 选择保存HTML文件的文件夹,并对命名HTML文件.
 | 如果您已经创建本地站点,建议将HTML文件保存到本地站点中.
4 | 选择 Save as(保存为...) 选项 HTML and Images(HTML和图像).
5 | 输出HTML选项,选择 Export HTML File(输出HTML文件).
6 | 输出Slices(切片),选择 None(无).
7 | 如果希望图像保存在其它文件夹,选择 Put Images in Subfolder(图像放在其它文件夹),并点击 Browser 确定文件夹的位置.
8 | 点击 Save(保存)输出图像地图.

您可以选择Copy to Clipboard(复制到剪贴板),将图像地图的HTML代码复制到剪贴板,然后粘贴到HTML编辑器如Dreamweaver中.

当您输出HTML文件时,Fireworks可以使用HTML的解释语句自动在HTML中添加注释表明Fireworks自动生成的代码的起始和结束.默认的,Fireworks输出不包括注释语句.您可以在HTML后的Options(选项)中进行HTML输出设置.

如果您以前已经输出过HTML文件,您也可以通过菜单的Update HTML(更新HTML)命令更新HTML代码.

蓝骑士编译


创建 rollovers 效果概述——茕若（侠客岛版权所有）

创建 rollovers 效果 > 创建 rollovers 效果概述

创建 rollovers 效果概述

Button Editor（按钮编辑器）允许你使用单一的切割来传达视觉效果。有时你可能需要创建一些比按钮编辑器中所能够创建的更为复杂的 rollover 行为。例如，你可能想要创建一个不相交的 rollover 效果——在远离光标的区域显示一幅图像，或是想要创建一个当光标经过图像时出现的可定义的弹出菜单。

本章讲述了怎样使用切割和帧建立简单的和复杂的 rollover 效果。本章还讲述了怎样创建弹出菜单。

Fireworks 将切割对象、热区对象、以及拖放行为作为创建 rollovers 效果的基本构件。使用拖放行为你可以把切割和热区链接到目标切割上，这样就会创建出 rollover 效果和替换图案效果。

茕若编译


使用拖放行为创建替换图案效果（侠客岛版权所有）

创建 Rollovers 效果 > 使用拖放行为创建替换图案效果 > 使用拖放行为创建不相交的 rollovers 效果

使用拖放行为创建不相交的 rollovers 效果

不相交的 rollover 效果比使用单一切割创建的替换图案效果稍稍复杂一些。作为响应当光标滑过或点击触发图像时，一幅图像会出现在网页的不同区域。它的每幅图像都存放在不同的帧中。因此不相交的 rollovers 效果需要两个 Web 对象：一个是用来触发效果的切割或热区。另一个用来覆盖交换区域的目标切割。

在你选择一个作为触发器的 Web 对象时你有三种选择：

如果触发区域不是一个 rollover 效果或不会更改外观，那就绘制一个热区。
如果你打算更改触发区域外观，那就绘制一个切割。
如果你想使用按钮编辑器建立一个触发器，那就放置一个按钮符号，你可以如同给热区或切割对象指派行为一样给按钮符号指派行为。

同使用单一切割的替换图案效果一样，创建不相交的 rollover 效果也包含两个步骤。首先你必须建立触发和目标 Web 对象以及存放替换图案的帧。第二步，你要使用拖放行为线连接触发区与目标区。

茕若编译


使用拖放行为来创建替换图案效果——茕若（侠客岛版权所有）

创建 Rollovers 效果 > 使用拖放行为来创建替换图案效果 > 建立 Web 对象、图像和帧

建立 Web 对象、图像和帧

建立 Web 对象、图像和帧

为不相交的 rollover 效果建立 Web 对象、目标和帧:

1 | 选择你想要触发不相交的 rollover 效果的图像。
2 | 给图像指派一个 Web 对象：
 | 选择 Insert -> Slice（插入 -> 切割）或 Insert -> Hotspot（插入 -> 热区）来把整幅图像封装在 Web 对象中。
 | 使用 Slice（切割）工具或 Hotspot（热区）工具来把图像的一部分绘制成 Web 对象。
3 | 使用帧面板创建一个新的帧：
 | 选择 Windows -> Frames（窗口 -> 帧），然后点击 New/Duplicate Frame 按钮。
4 | 放置作为目标的替换图案。
5 | 选择 Insert -> Slice（插入 -> 切割）给作为目标的替换图案指派一个切割。

茕若编译


使用拖放行为来创建替换图案效果——茕若（侠客岛版权所有）

创建 Rollovers 效果 > 使用拖放行为来创建替换图案效果 > 使用拖放行为来创建不相交的 rollover 效果

使用拖放行为来创建不相交的 rollover 效果

创建不相交的 rollover 效果的第二步是使用拖放行为线来连接作为触发器的 Web 对象与目标切割。

为不相交的 rollover 效果建立一个替换图案行为：

1 | 选取覆盖在触发区域上的 Web 对象。
2 | 将光标置于 Web 对象中心的拖放行为控制柄上。
 | 光标会变成一个手形。
3 | 点击按住鼠标按钮不放，光标会变成一个拳头。
4 | 拖动这个拳头到覆盖在你想要替换的图案上的切割。
 | 一条线会把作为触发器的 Web 对象的中心与目标切割的左上角连接起来，同时 Swap Image From 对话框出现。
5 | 从 Swap Image From 弹出菜单中，选取存放替换图案的帧。

茕若编译


删除拖放行为——茕若（侠客岛版权所有）

创建 Rollovers 效果 > 删除拖放行为

删除拖放行为

你可以使用 Pointer 工具删除拖放行为关系（即那些蓝线）。

删除指派给热区或切割的拖放行为：

1 | 选取热区或切割。
 | Web 对象会显示出任何与它关联的拖放行为关系（蓝线）。
2 | 点击你想要删除的蓝线。
 | 一个对话框会出现并要求你确认你想要删除替换图案行为。
3 | 点击 OK 删除这个行为。

茕若编译


给 rollovers 效果指定 URL 链接——茕若（侠客岛版权所有）

创建 Rollovers 效果 > 给 rollovers 效果指定 URL 链接

给 rollovers 效果指定 URL 链接

如果要把你的 rollover 链接到其他的网页，你应该给 rollover 的热区或切割对象指定一个 URL 链接。

给选定的热区或切割分配一个链接：

在对象面板的 URL link 弹出菜单中选择或键入一个 URL 地址。
从 URL 面板中选取一个 URL 地址。

茕若编译


创建弹出菜单——茕若 （侠客岛版权所有）

创建 Rollovers 效果 > 创建弹出菜单

创建弹出菜单

所谓弹出菜单是指当光标滑过或点击触发切割或热区时显示的菜单。它们不需要漫长的下载时间就给你的页面增加了极大的浏览机动性。你可以定义弹出菜单的外观使之与你站点的总体外观和感觉相称。一个弹出菜单类似于一张表格：每个菜单条目就像一个表格单元。通过选择字体类型，单元颜色，以及背景图像样式你可以自己定义菜单。

Set Pop－Up Menu 向导由始至终的指引你建立菜单。菜单的建立可以分为两个阶段。，在第一个阶段中你可以键入菜单文本，创建子菜单，还要给每个菜单条目分配 URL 地址。

第二个阶段允许你定义菜单的外观，指定背景图像，字体，以及菜单条目的 Up 和 Over 状态。

茕若编译


创建弹出菜单 （侠客岛版权所有）

创建 Rollovers 效果 > 创建弹出菜单 > 创建弹出菜单条目

创建弹出菜单条目

以下步骤指引了如何为弹出菜单创建基本菜单条目。

创建弹出菜单条目：

1 | 在你想要触发弹出菜单的对象上放置一个切割或热区。
2 | 选择 Insert -> Pop-Up Menu（插入 -> 弹出菜单）。
 | Set Pop-Up Menu Wizard（设置弹出菜单向导）出现。
3 | 在文本框中键入菜单项。
4 | 在链接框中指定菜单项的 Web 地址。
5 | 如果需要，设置一个 Web 目标。
6 | 点击 Add Menu (+)按钮来向预览列表里添加项目。
7 | 为了创建子菜单，从预览列表里选择你要降级的项目，然后点击Indent Menu（缩进菜单）按钮。未了把该项目返回到上一级，你可以点击 Outdent（突出）按钮。
 | 注：列表中的首项不能被降级为子菜单。
8 | 重复步骤 3 到步骤 7 在列表中加入所有的菜单项。
9 | 点击下一步按钮继续。

茕若编译


创建弹出菜单——茕若 （侠客岛版权所有）

创建 Rollovers 效果 > 创建弹出菜单 > 设置弹出菜单外观

设置弹出菜单外观

一旦你完成键入菜单文本，向导的下一步将让你定义菜单的外观。

设置弹出菜单外观：

1 | Cells（单元）允许你选择 HTML 或 Image：
 | HTML 选项设定你用 HTML 格式作为菜单 Up 和 Over 状态的背景。
 | Image 选项让你使用图像作为菜单 Up 和 Over 状态的背景。
2 | 选择适当的字体，然后输入其他的字体信息，例如尺寸、调整以及字样。
3 | 在 Up State 和 Over State 两个区域中定义菜单的外观：
 | 如果在第一步中你选择 HTML，那么你将为每种状态选择文本和单元颜色。
 | 如果在第一步中你选择 Image，那么你将选择菜单使用的两个背景图像。
4 | 点击完成。

当你插入一个弹出菜单时，一个蓝色的菜单轮廓将出现在切割上或是切割附近。这个轮廓看起来就像一个用拖放行为线连接到切割上的空的表格。

注： 轮廓中单元的数目和主菜单项目的数目一致。轮廓中单元的数目不包括子菜单项目。

茕若编译


创建弹出菜单——茕若 （侠客岛版权所有）

创建 Rollovers 效果 > 创建弹出菜单 > 编辑弹出菜单

编辑弹出菜单

你可以编辑弹出菜单的内容，重新整理菜单的项目，在画布中任意移动弹出菜单的轮廓。通过打开 Set Pop-Up Menu 向导更新菜单的内容你可以编辑弹出菜单。有两种方法打开 Set Pop-Up Menu 向导：

双击弹出菜单的轮廓。
在行为面板上双击切割的 Show Pop-Up Menu 行为。

更改菜单项的文本：

1 | 打开 Set Pop-Up Menu 向导。
2 | 选择菜单项目。
 | 菜单项目的细节包括 Text（文本），Target（目标），和 Link（链接）区域。
3 | 编辑菜单项目。
4 | 点击 Change（更改）按钮。

在菜单中重新整理菜单项目：

1 | 打开 Set Pop-Up Menu 向导。
2 | 在预览列表中拖动菜单项目到一个新的位置。

茕若编译


创建弹出菜单——茕若 （侠客岛版权所有）

创建 Rollovers 效果 > 创建弹出菜单 > 更改弹出菜单的位置

更改弹出菜单的位置

你可以移动菜单的轮廓使得弹出菜单在画布中出现的位置相应改变。缺省的，菜单出现在分配给它的切割的位置。

移动弹出菜单：

1 | 选择与弹出菜单相关联的切割。
2 | 拖动其轮廓到新的位置。

茕若编译


关于 rollovers 效果——茕若（侠客岛版权所有）

创建 Rollovers 效果 > 关于 rollovers 效果

关于 rollovers 效果

所谓 JavaScript rollovers 效果是指当你移动光标经过图形或是点击该图形时，浏览器中的图形改变其外观。这种效果包括按钮和替换图案。

无论 rollovers 的形态如何，其工作原理都是一样的：当光标滑过或点击一个图形时触发另一个图形的显示。轮换图像应被放置在两个或更多的帧上。触发器通常是一个 Web 对象，也就是一个切割或热区。Web 对象可以被指派一个或更多的行为。

最简单的 rollovers 效果就是直接把第一帧上的图像替换为它下面第二帧的图像。你可以建立更为复杂的 rollovers 效果：替换图案效果可以从任意帧上替换图像；不相交的 rollovers 效果可以在远离光标区域显示图像。

茕若编译


创建弹出菜单——茕若 （侠客岛版权所有）

创建 Rollovers 效果 > 创建弹出菜单 > 导出弹出菜单

导出弹出菜单

Fireworks 会产生所有在浏览器中查看菜单所需的 Javascript 代码。当你的文档导出时，Javascript 代码与其他文件一样被导出到相同的位置，其导出的文件名为 menu.js。当你的文件上传时，该文件应被上传到与包含弹出菜单的网页相同的目录位置。如果你想更改该文件的位置，那么所有 Fireworks HTML 代码中指向 menu.js 的超级链接都要被更换为新的自定义位置。

如果你的文档包含几个弹出菜单，Fireworks 不会建立额外的 menu.js 文件；每个文档只使用一个 menu.js 文件。

当你包含子菜单，Fireworks 产生一个名为 Arrow.gif 的图象文件。这个图像是个小箭头，它出现在主菜单项目的后面，告诉用户这里存在着一个子菜单。不管你的文档里包含几个子菜单，Fireworks 总是使用 Arrow.gif 文件。

茕若编译


创建不规则形状的 rollovers 效果——茕若 （侠客岛版权所有）

创建 Rollovers 效果 > 创建不规则形状的 rollovers 效果

创建不规则形状的 rollovers 效果

Fireworks 大大简化了创建不规则形状的 rollovers 效果的工作量。使用 polygon slices（多边形切割）工具可以把一个切割对象绘制成任何形状。要了解创建多边形切割的有关信息，请参阅创建非矩形切割。

Fireworks 允许你使用每个对象作为一个 rollover，而不必再写另外的 JavaScript 代码就可以进行相应切割的交换。

使用规则的易处理的形状建立的 rollover 效果只需要一个切割就已经足够。而对于那些复杂的形状，你就需要将几个切割组合在一起来覆盖目标区域。

Fireworks 会输出多个切割和状态来重建不规则形状的外观。Fireworks 所创建的 JavaScript 会同时显示几个触发切割，它们中的每一个都包含了不规则形状的一部分。

创建不规则形状的 rollovers 效果：

1 | 使用 Polygon Slice（多边形切割）工具绘制出和每个对象匹配的多边形切割。
 | Fireworks 会创建出多个切割来，自动地为不规则切割对象定义出多个矩形切割区域。
2 | 为每个建立 rollover 效果的切割指定替换图案行为。
3 | 导出文件。

茕若编译


使用重叠切割来创建 rollovers 效果——茕若（侠客岛版权所有）

创建 Rollovers 效果 > 使用重叠切割来创建 rollovers 效果

使用重叠切割来创建 rollovers 效果

如果在不相交的 rollover 效果中你所使用的对象是不规则形状且彼此位置靠近，那么它们的边界框（由切割辅助线定义的）经常会发生重叠。矩形切割会完全替换由绿色的切割加亮区定义的矩形块，包括任何背景。如果在第二帧上的替换图像和第一帧上的图像结合的非常紧密，那么效果中触发图像部分可能会变得十分模糊。使用 Polygon Slice 可以阻止这种情况的发生。

注：虽然切割的边界框彼此交叠，Polygon Slice 工具会使你避免切割种绿色的部分重叠在一起。请参阅 创建非矩形切割。

使用重叠切割来创建 rollovers 效果：

1 | 在第一帧的图像上插入一个矩形切割。
2 | 从帧面板中选择第二帧。
3 | 点击帧面板底部的 Onion Skinning（洋葱皮效果）按钮打开洋葱皮效果，这样第一帧上的图像的轮廓线就始终是可见的了。
4 | 使用 Polygon Slice 工具，绘制一个覆盖在第二帧图像上的切割，你要小心绘制以免盖住绿色切割高亮区下的第一帧图像。
5 | 给触发切割建立替换图案行为。
 | 在预览时，替换图案的显示不会剪裁掉触发图像的任何部分。

茕若编译


使用外部文件作为 rollover 效果的源图——茕若（侠客岛版权所有）

创建 Rollover 效果 > 使用外部文件作为 rollover 效果的源图

使用外部文件作为 rollover 效果的源图

可以用作 rollover 效果源图的图像格式有 GIF，动画 GIF，JPEG 和 PNG。当选择用来作为 rollover 效果源图的文件是一个外部文件时，那么当 rollover 效果在浏览器中被触发时该文件就会和目标切割进行交换。

该图形文件的宽和高必须和将要与之交换的切割的宽和高相同。如果二者尺寸不同，浏览器就会自动调整外部文件的尺寸以适应切割对象的尺寸。而这很可能会损害到图形的质量，尤其是对 GIF 动画而言。

如果你是个高级的 HTML 用户，值得你注意的是这种预先载入可能会中断你作为 rollover 状态的动画 GIFs 。取消选择 Preload Images 选项会使你避免这个问题的出现。

选取外部文件作为 rollover 效果的源图；

1 | 在 Swap Image，Nav Bar Over，或 Nav Bar Down 对话框中选择 Image File。
2 | 查找要用的文件。
3 | 如果需要取消选择 Preload Images（如果你的外部文件是一个 GIF 动画文件的话）。

茕若编译


使用切割上的热区创建复杂交互效果——茕若（侠客岛版权所有）

创建 Rollovers 效果 > 使用切割上的热区创建复杂交互效果

使用切割上的热区创建复杂交互效果

Fireworks 允许你在切割上面放置热区。这给你选择触发器的位置与尺寸带来了极大的灵活性。

例如，如果你想要光标滑过替换图案中心时出现 rollover 效果，那么你可以在作为触发器的图像的中心放置一个小的热区。这将会阻止它底下替换图像的交互效果的出现。

当你在切割上放置一个热区时，只有热区会被指定行为，而切割则不会被指派行为。

在切割上建立一个作为触发器的热区：

1 | 在你想要替换的图像的上面插入一个切割。
2 | 在你想要触发 rollover 效果的切割区域绘制一个热区。
3 | 从热区到切割拖出一条行为线。
 | Swap Image 对话框出现。
4 | 从 Swap Image From 列表中选择存放替换图案的帧。
5 | 然后点击 OK。

茕若编译


使用行为面板创建简单的 rollovers 效果——茕若 （侠客岛版权所有）

创建 Rollovers 效果 > 使用行为面板创建简单的 rollovers 效果

使用行为面板创建简单的 rollovers 效果

一个简单的 rollover 效果是指当光标滑过或点击触发图像时，在光标下出现一幅新的图像。这是最容易建立的 rollover 效果，因为它只需要一个切割，其画布中的触发区域与目标区域是相同的。

一个简单的 rollover 效果通常把替换的图像放在第二帧上。

茕若编译


使用行为面板创建简单的 rollovers 效果——茕若 （侠客岛版权所有）

创建 Rollovers 效果 > 使用行为面板创建简单的 rollovers 效果 > 建立切割、图像、和帧

建立切割、图像、和帧

创建一个简单的 rollover 效果需要两个阶段。第一个阶段包括建立切割，产生效果的两幅图像以及存放它们的帧。尽管组成 rollover 效果的两幅图像在画布中处于同一位置，但它们却不在同一帧上。

为简单 rollover 效果建立切割、图像和帧：

1 | 选择你想要触发 rollover 效果的图像。
2 | 选择 Insert -> Slice（插入 -> 切割）给图像分配一个切割。
3 | 使用帧面板建立一个新的帧：
 | 选择 Window -> Frame（视窗 -> 帧），然后点击 New/Duplicate Frame（新建/复制 帧）按钮。
 | 注： 如果你已经有了第二帧，那么你就不必再另建一个帧。
4 | 如果新建的帧没有被高亮显示，在帧面板上选择它。
5 | 在画布上切割所占据的区域放置第二幅图像：
 | 使用绘制和编辑工具来创建图形。
 | 导入或拖动一个图形到切割上。

茕若编译


使用行为面板创建简单的 rollovers 效果——茕若 （侠客岛版权所有）

创建 Rollovers 效果 > 使用行为面板创建简单的 rollovers 效果 > 给切割应用简单的 rollover 行为

给切割应用简单的 rollover 行为

当建立了图像与帧后，你就可以给切割应用简单的 rollover 行为。

应用简单的 rollover 行为：

1 | 选择切割。
 | 注：切割在两个帧间是共享的。如果你已经打开 Show Hotspots and Slices（显示热区和切割），不管你在哪个帧中工作切割都将是可见的。
2 | 选择 Window -> Behaviors（窗口 -> 行为）来打开行为面板。
3 | 从 Add Action(+)（添加动作）弹出菜单中选择 Simple Rollover（简单 Rollover 效果）

茕若编译


使用行为面板——茕若（侠客岛版权所有）

创建 Rollover 效果 > 使用行为面板

使用行为面板

你可以使用行为面板来创建、编辑和删除指派给所选切割或热区的行为。

行为面板允许你创建其它类型的效果，允许你详细指定触发效果的事件的类型（例如点击）。在编辑现有行为时行为面板也给了你更多的灵活性。

使用行为面板给所选切割或热区指派行为：

1 | 点击行为面板上的 Add Action (+)按钮。
2 | 从 Add Action (+)弹出菜单中选择行为。

以下行为是可选的：

Simple Rollover 创建一个使用第一帧作为 Up 状态，第二帧作为 Over 状态的 rollover 效果。一旦你选择了这个行为，你就必须在第二帧里创建一个图形，使用同一个切割来创建 Over 状态。这个选项实际上是一个包含了Swap Image 和 Swap Image Restore 的行为组。
Swap Image（替换图案） 使用切割下边另一帧的内容，或者使用外部文件的内容来替换指定切割的内容。
Swap Image Restore（替换图案恢复）将 rollover 恢复到它第一帧上的默认外观。
Set Nav Bar Image（设置导航栏图像） 设置切割成为导航栏的一部分。每个被当作导航栏一部分的切割都必须有这个行为。这个选项实际上是一个包含了 Nav Bar Over，Nav Bar Down，和 Nav Bar Restore 的 行为 组。
Nav Bar Over（导航栏 Over 状态）如果当前被选取切割将作为导航栏的一部分，可以用此行为为其指定 Over 状态，有时候还需要指定 Over While Down 状态。
Nav Bar Down （导航栏 Down 状态）如果当前被选取切割将作为导航栏的一部分，可以用此行为为其指定 Down 状态。
Nav Bar Restore（导航栏恢复）将导航条上所有其它的切割恢复到其 Up 状态。
Set Pop-Up Menu（设置弹出菜单） 该行为将给切割或热区指定一个弹出菜单。
Set Text of Status Bar（设置状态栏文本）允许你为多数浏览器窗口底部的状态栏定义显示文本。

在 Fireworks 4 中的行为与 Dreamweaver 4 中的行为完全兼容。当你导出 Fireworks 的 rollover 效果到 Dreamweaver 4 时，你可以使用 Dreamweaver 4 的行为面板编辑这个行为。

注：弹出菜单可以在 Dreamweaver 4 中使用，但是它们必须在 Fireworks 中编辑。

改变激活行为的鼠标事件：

1 | 选取包含有你要修改的行为的作为触发器的切割或热区。
 | 所有与 Web 对象相关联的行为都会显示在行为面板中。
2 | 选择你想要编辑的行为。
 | 所有被选取的行为，除了简单的 Rollover 行为，都会显示一个与它相关的事件列表。
3 | 从列表中选择一个新的事件。
 | 注：OnLoad 事件是指网页一被载入立即触发相关行为。例如，如果你把不相交的 rollover 效果的触发事件改换为 Onload 事件，其替换图案就会迅速的显示出来。

茕若编译


使用拖放行为创建替换图案效果——茕若（侠客岛版权所有）

创建 Rollovers 效果 > 使用拖放行为创建替换图案效果

使用拖放行为创建替换图案效果

你可以使用拖放行为来创建替换图案 rollovers 效果。对于指定当光标滑过时热区或切割发生的变化来说拖放行为是一个快速有效的方法。在 Fireworks 4 以前，你不得不通过行为面板来建立替换图案事件。拖放行为是一种快速的创建 rollovers 效果的方法，它使你只需要在触发切割或热区和目标切割间拖动拖放行为控制柄就能完成制作。拖放行为控制柄指的是位于切割中心的带有十字的一个圆形。

当你选定一个触发 Web 对象时，Fireworks 会显示出它的行为关系。缺省的，一个拖放行为关系通过一条蓝线来表示。

茕若编译


使用拖放行为创建替换图案效果——茕若（侠客岛版权所有）

创建 Rollovers 效果 > 使用拖放行为创建替换图案效果 > 使用单一切割创建替换图案效果

使用单一切割创建替换图案效果

只有一个切割的替换图案效果一般来说是指：当光标经过或点击按钮与图像时，这些按钮或图像会发生改变。

为了创建这种类型的 rollover 效果，你应从切割的行为控制柄向切割边缘拖出一条拖放行为线。而你的替换图案可以来自于任何帧。

创建替换图案效果可以分为两个阶段：第一阶段包括建立切割，替换图案以及放置它的帧。

为替换图案效果建立切割、替换图案和帧：

1 | 选择你想要触发 rollover 事件的图像。
2 | 选择 Insert -> Slice （插入 -> 切割）来给图像指派一个切割。
3 | Create a new frame using the Frames panel:
 | 选择 Window -> Frames（窗口 -> 帧），然后点击 New/Duplicate Frame 按钮。
4 | 如果新建的帧没有被高亮显示，在面板中选择它。
5 | 把第二张图像放置在画布中切割所占据的区域：
 | 使用绘制和编辑工具来创建一个图形。.
 | 导入或拖动一个图形到切割上。

茕若编译


使用拖放行为创建替换图案效果——茕若（侠客岛版权所有）

创建 Rollovers 效果 > 使用拖放行为创建替换图案效果 > 指派拖放行为

指派拖放行为

第二个阶段是给切割指派替换图案行为。

使用拖放行为完成创建替换图案效果：

1 | 选择覆盖在触发区域上的切割。
 | 注：你可以选择任何帧上的切割。
2 | 将光标置于切割中心的拖放行为控制柄上。
 | 光标会变成一个手形。
3 | 点击按住鼠标按钮不放，光标会变成一个拳头。
4 | 拖动这个拳头到切割的边缘。
 | 一个蓝色的拖放行为线会从切割的中心连接到切割的左上角。
 | Swap Image（替换图案）对话框出现。
5 | 从 Swap Image From 弹出菜单中选择替换图案所在的帧。
6 | 选择 File -> Preview in Browser（文件 -> 在浏览器中预览）或点击 Preview 标签来观察浏览器中的 rollover 效果。

茕若编译


创建动画概述--蓝骑士（侠客岛版权所有）

创建动画 > 创建动画概述

创建动画概述

动画图像可以使您的站点更加生动.Fireworks中,您可以创建动画广告条,动画标志,动画卡通等多种类型的动画图像.

在Fireworks中,动画的制作思想是通过动画符号(symbol)在不同影格的不同设置,造成视觉上的变化.当影像随着影格播放,就形成了动画.

您可以编辑动画符号的属性进行调整,创建位移,淡入淡出,旋转等等的变化.

由于您可以在一个文件中操作多个符号对象,所以,您可以创建各种更复杂的动画效果.

动画图像只有在图像优化格式选择 Animated GIF(动态GIF)格式时才可以产生.这一点非常重要.在优化面板(Optimize)您可以对文件输出的其他属性进行调整.Fiteworks输出动画格式主要是 Animated GIF 或 Flash SWF.

蓝骑士编译


层共享--蓝骑士（侠客岛版权所有）

创建动画 > 影格的操作 > 层共享

层共享

在Fireworks中,动画文件由影格组成,而每一个影格又由层组成.所以您可以对每一个影格中的对象进行单独的控制.

有时候有些对象希望出现在所有影格,例如背景图案,此时您可以使用层共享命令(share the layer across frames),使该影格该层的对象,被其他影格的该层共享.

对于共享的层,您可以在任何影格中对层中的对象进行编辑.

层共享:

1 | 在层面板双击希望共享的层.
2 | 在弹出对话框中选择Share Across Frames(层共享).

注: 共享层中的对象将出现在所有影格对应的层中.例如,将某一影格的层5共享,则其他影格中的层5都被该层替换.(所以,某些时候为避免共享的层破坏其他影格中的层,您可以单独新建一个层出来,放置共享对象,作为共享层)

取消共享:

1 | 在层面板双击共享层.
2 | 在弹出对话框中取消Share Across Frames(层共享).
3 | 选择取消共享方式:
 | 仅将原来共享层中的对象放置在当前影格,然后取消共享.
 | 将原来共享层中的对象复制到每一个影格,然后取消共享.

蓝骑士编译


使用洋葱皮--蓝骑士（侠客岛版权所有）

创建动画 > 影格的操作 > 使用洋葱皮

使用洋葱皮

洋葱皮主要帮助您观察前后几个影格的图像,使您可以比较和衡量图像间的差别,更好的完成动画."洋葱皮"这一名词来源于传统的动画制作工艺.传统的动画常常将画面绘制在透明的胶片上,然后将胶片重叠观察动画的效果.

当洋葱皮功能打开时,如下图所示,您可以看见几个影格中的图像.当前影格为正常显示,前后的影格则依次变灰.

上图中间的小鸟即是当前影格中的图像.

默认的,在不离开当前影格的情况下,您也可以对前后影格的对象进行编辑.也就是在一个画面中,控制几个影格的编辑.

调整洋葱皮的显示:

1 | 在影格面板(Frames),点击 Onion Skinning(洋葱皮) 按钮.
2 | 在菜单中选择:
 | No Onion Skinning(无洋葱皮) 关闭洋葱皮功能,仅显示当前影格.
 | Show Next Frame(下一个影格) 显示当前影格下面的一个影格.
 | Before and After(前后影格) 显示当前影格前后的影格.
 | Show All Frames(显示所有影格) 显示所有影格.
 | Custom(自定义) 自定义洋葱皮的显示.
 | Multi-Frame Editing(多影格编辑) 使您可以在一个影格中对洋葱皮显示的其他影格的对象可以进行编辑.
 | Deselect this option(取消多影格编辑) 取消多影格编辑,您仅可以编辑当前影格的对象.

蓝骑士编译


中间帧--蓝骑士（侠客岛版权所有）

创建动画 > 中间帧

中间帧

"中间帧"也是一个传统动画工艺中的名词.传统动画创作中,常常由设计师绘制动画片断的前后关键帧,由画师根据关键帧绘制中间帧.

在Fireworks中,对同一个符号的两个或多个实例应用中间帧(tween)功能,软件自动根据实例绘制出中间帧. 中间帧常常用于创建比较复杂的动画.

例如,创建下面的大雁飞上天空的动画.

绘制实例中间帧:

1 | 选择同一个符号的两个或多个实例.
2 | 选择菜单 Modify -> Symbols -> Tween Instances(修改 -> 符号 -> 绘制实例中间帧).
3 | 在弹出对话框输入画面的数目.
4 | 选择 Distribute to Frames(分散到影格) 选项,Fireworks将自动创建影格放置各个帧.否则,Fireworks将图像创建在一个影格中.点击 OK 完成.
 | 如果您不选择该选项,您也可以以后通过影格面板的 Distribute to Frames(分散到影格) 按钮实现同样的功能.

预览动画

在动画创作过程中您可以随时在画布上查看动画的效果.或者在预览窗口查看动画出后的效果.

在画布预览动画:

使用画布底部的影格浏览器预览动画.

影格浏览器

预览时请注意下列事项:

动画的速度由影格面板中的影格延迟时间决定.
被取消影格输出的影格(影格列表中带红色 X 的影格)将不被显示.

在画布上预览的是动画的源文件,而动画最后输出的是优化后的动态GIF,所以,画布山谷蓝的图像品质要好于最后的输出动画.
必须在优化面板中(Optimize)选择 Animated GIF(动态GIF)格式.

在预览窗口预览动画:

1 | 点击文件窗口中的预览标签(Preview).
2 | 使用影格控制器.

注: 不推荐在 2-Up(二窗口) 或 4-Up(四窗口) 预览动画.

在浏览器中预览动画:

选择菜单 File -> Preview in Browser(文件 -> 在浏览器预览),并在子菜单中选择浏览器类型.

蓝骑士编译


动画输出--蓝骑士（侠客岛版权所有）

创建动画 > 动画输出

动画输出

当您完成动画的创作,您可以对动画进行输出设置.输出设置主要包括动画播放的控制,文件的优化等等.完成设置,您可以输出动画.

注: 如果您要制作动画,您必须在优化面板(Optimize)将文件格式设置为 Animated GIF(动态GIF).

设置动画播放属性:

您可以点击影格面板左下角的按钮设置动画的循环播放属性.动画的循环播放属性决定了最后输出的动画的播放次数.

设置循环属性:

1 | 选择菜单 Window -> Frames(窗口 -> 影格) 打开影格面板.
2 | 点击影格面板左下角的 looping(循环) 按钮.
3 | 选择循环次数.
 | 选择4代表动画一共播放5次,然后停止.选择Forever动画将一直循环播放,不停止.

设置透明属性

您可以设置动画的透明色彩,使得动画中的某些颜色被透明掉.

设置透明色彩:

1 | 在优化面板的下方的下拉框中选择 Index Transparency(索引色透明) 或 Alpha Transparency(Alpha透明).
2 | 使用 transparency(透明工具)选取您希望透明的色彩.

优化动画

优化动画将减小您输出的文件大小,加快图像的下载.

优化动画:

1 | 在优化面板中选择输出格式 Animated GIF(动态GIF).
 | 如果优化面板没有打开,您可以使用菜单 Window -> Optimize(窗口 -> 优化) 打开面板.
2 | 设置 Palette(调色板), Dither(抖动色),和 Transparency(透明) 属性. 关于优化的更多信息请参看 GIFs 和 PNGs文件的优化设置.
3 | 在影格面板,设置影格的延迟时间,决定动画的播放速度. 更多信息请参看设置影格延迟时间.

输出为动态GIF, SWF, 或多个文件

输出动画时,您可以选择按照动态GIF,SWF,或复合文件中的一种输出.通常选择动态GIF格式用于输出网络动画图像.

当您在不同的影格多次使用相同的符号时,选择输出复合文件格式将有利于文件尺寸的减小.

如果您输出SWF格式,您可以将SWF文件导入到Macromedia Flash或其他相关软件中使用.详细请参看输出到Macromedia Flash.

注: 无论最后输出为何种格式,只要您制作动画,您必须在优化面板选择 Animated GIF (动态GIF)格式.

输出 Animated GIF(动态GIF):

1 | 在优化面板进行优化设置,详细请参看GIFs 和 PNGs文件的优化设置.
2 | 选择菜单 File -> Export(文件 -> 输出).
3 | 输入文件名字,保存文件.

输出复合文件:

1 | 选择菜单 File -> Export(文件 -> 输出).
2 | 在文件类型中选择 Layers to Files(层到文件) 或 Frames to Files(影格到文件).
3 | 输入文件名字,保存文件.

输出 Flash SWF 文件:

1 | 选择菜单 File -> Export(文件 -> 输出).
2 | 在文件类型中选择 Flash SWF.
3 | 点击 Options(选项) 按钮对输出的 SWF 进行设置.
4 | 输入文件名字,保存文件.

蓝骑士编译


使用已经存在的动画文件--蓝骑士（侠客岛版权所有）

创建动画 > 使用已经存在的动画文件

使用已经存在的动画文件

您可以适应已经存在的动画文件如动态GIF.导入动态GIF分为导入到当前文件和做为新文件打开两种方式.

Fireworks将导入的动态GIF文件作为一个动画符号放置在当前影格.如果导入的动画文件影格长度超过当前的动画影格长度,Fireworks将询问是否增添影格.

导入的动态GIF文件将丢失原来的影格延迟时间信息,而由当前的影格延迟时间决定.由于导入的动画作为动画符号,您可以使用动画符号的相关控制进行调整.例如改变运动路径等.

当您使用打开动态GIF命令,Fireworks将打开新文件,在影格列表显示动画各个影格.这与导入文件作为动画符号不同.打开的新文件保留了原来动画的影格延迟时间信息.

当您输出动画时,你需要在优化面板将输出格式设为动态GIF.

导入Animated GIF(动态GIF):

1 | 选择菜单 File -> Import(文件 -> 导入).
2 | 确定文件位置,打开文件,将动画导入到当前动画.

打开Animated GIF(动态GIF):

选择菜单 File -> Open(文件 ->　打开）,确定文件位置,打开动画.

蓝骑士编译


使用多个文件创建一个动画--蓝骑士（侠客岛版权所有）

创建动画 > 使用多个文件创建一个动画

使用多个文件创建一个动画

Fireworks支持将多个文件按照一个动画文件格式打开.如果您仅仅通过几个已经存在的图片的合成制作动画,使用该项功能将非常简便.

使用多个文件创建一个动画:

1 | 选择菜单 File -> Open(文件 -> 打开).
2 | 通过Shift键复选多个图像文件.
3 | 勾选 Open as Animation(打开为动画) 选项.点击 OK 完成.
 | Fireworks将多个图像文件在一个文件窗口中打开,每一个图像放置在一个影格中.

蓝骑士编译


关于动画--蓝骑士（侠客岛版权所有）

创建动画 > 关于动画

关于动画

在Fireworks中您可以通过动画符号(animation symbols)创建动画.动画符号的运动将对应的分配到各个影格中.动画的长度由影格的长度决定.您可以在一个动画中使用多个动画符号.

创建动画主要有下面四个步骤:

1 | 创建动画符号.
2 | 在符号属性对话框中对动画符号进行设置.包括运动角度,运动距离,放缩,透明变化,旋转角度等.
3 | 在影格面板(Frames)中调整影格延迟时间(Frame Delay),控制动画速度.
4 | 在优化面板选择文件输出格式为动态GIF(Animated GIF).

蓝骑士编译


使用动画符号--蓝骑士（侠客岛版权所有）

创建动画 > 使用动画符号

使用动画符号

动画符号的原理和电影的原理类似.下面的例子是三只天鹅飞过芦苇塘,每一只天鹅都是动画的一个成员,或者称为角色.

您创建的任何对象或导入的对象都可以作为动画符号.每一个符号都有自己独立的属性.所以您可以针对不同的对象创建不同的动画形式,例如移动,淡入淡出等.

注:如果您将对象转换为动画符号,您需要注意,此时应该在优化面板(Optimize)选择动态GIF格式(Animated GIF),否则将不能输出动画图像.更多详细请参看 优化动画 .

您可以在任何时候通过符号编辑器(符号编辑窗口)改变符号的图形.通过动画属性对话框或对象面板,改变符号动画的属性.符号编辑器将只对当前选中的符号进行编辑,而不会影响画布上其它的对象.

当您创建动画符号,符号自动添加到当前文件的库中.当您需要在此使用动画符号时,您只需要从库中该符号拖动一个实例(Instance)到画布上.

创建动画符号

当您创建动画符号后,您可以在动画属性对话框中设置动画符号的属性.包括位移,旋转等等.如果您不设置影格数目,Fireworks默认新创建的动画符号含有五个影格,每个影格延迟时间是0.20秒.

新建动画符号:

1 | 选择菜单 Insert -> New Symbol(插入 ->新符号).
2 | 在符号属性对话框中(Symbol Properties dialog),输入新建符号的名字.
3 | 选择动画符号(Animation),点击 OK 确定.
4 | 在符号编辑器中,绘制对象.
 | 您可以像在画布上绘制对象一样在符号编辑器中进行创作.符号编辑器既可以在位图编辑模式,也可以在矢量图编辑模式.
5 | 完成符号的创作,关闭符号编辑器.
 | Fireworks将符号存放在库中,并在画布中央放置一个符号的实例.
6 | 选中动画符号,在对象面板您可以为动画添加新的影格.

对象转换为动画符号:

1 | 选中对象.
2 | 选择菜单 Modify -> Animate -> Animate selection(修改 -> 动画 -> 选中).
3 | 在动画属性对话框中进行设置.关于设置的详细信息,请参看 编辑符号属性 .
 | 完成设置,对象自动转换为动画符号.并将符号存放在库中,在画布上放置动画符号的实例.

编辑符号属性

您可以随时改变动画符号的属性,对速度,方向,位移,旋转等属性进行修改,从而创建复杂的动画效果.

任何动画的关键属性是动画的影格数目.它决定了您的动画的画面数量.当您设置好影格数目,Fireworks自动在对应数目的影格中加入动画的画面.如果文件中存在的影格少于您定义的数目,Fireworks自动在文件中添加影格.

在动画属性对话框或对象面板,您可以进行动画属性的调整.

对象面板

改变动画符号属性:

1 | 选中动画符号.
2 | 选择菜单 Modify -> Animate -> Settings(修改 -> 动画 -> 设置). 或选择菜单 Window -> Object(窗口 -> 对象)显示对象面板.
3 | 调整下列属性:
 | Frames(影格数目) 影格数目决定了动画符号占用的影格数量.Fireworks 4提供最大影格数目为1600.影格数目旁的滑块最大可以设置到60,但您可以在文字框中输入您希望的数字.Fireworks的默认值是5.
 | Movement(位移) 位移按照像素单位设置动画的移动距离.允许输入范围是0-250,Fireworks默认为72.
 | Direction (方向) 决定动画运动的方向,输入范围为0-360度.
 | 注: 您也可以在画布上对动画路径进行后续的修改(例如扩大位移,改变方向等).详细请参看 编辑动画路径 .
 | Scaling 放缩决定了动画的开始到结束的尺寸变化,放缩的选择范围为0-250%.Fireworks默认为100%.
 | Opacity(不透明度) 决定了动画显示的不透明程度.常用于制作淡入淡出效果.允许变化范围为0-100%.Fireworks默认为100%.
 | Rotation(旋转度) 决定了动画的旋转角度.滑块最大范围为0-360度.您也可以在文字框中输入您希望的数字.Fireworks默认为0度.
 | CW and CCW(旋转方向) 旋转按照顺时针或逆时针方向.CW为顺时针方向.CCW为逆时针方向.

从库中删除符号:

1 | 打开库面板(Library),选择您希望删除的动画符号.
2 | 拖动符号到面板右下角的删除按钮上(垃圾箱标记).

删除动画符号的动画属性:

选择菜单 Modify -> Animate -> Remove animation(修改 -> 动画 -> 删除动画).

动画符号改变为图片符号(Graphic).如果您以后再将该图片符号改变为动画符号,则原来的动画属性自动恢复.

编辑符号的图像

使用符号编辑器您可以编辑符号的图像.您可以像在画布上绘制图像一样在符号编辑器的编辑窗口绘制符号的图像.符号编辑器仅对您选中的符号进行编辑.

因为放置在画布上的是符号实例(Instance),而符号编辑器编辑的是符号,所以,改变一个符号,对所有该符号的实例都有影响.

编辑选中的符号的图像:

1 | 选中符号,您可以使用下列方法打开符号编辑器:
 | 双击符号.
 | 选择菜单 Modify -> Symbol -> Edit Symbol(修改 -> 符号 -> 编辑符号).
 | 如果打开了动画属性对象框,点击 Edit(编辑) 按钮.
2 | 在符号编辑器中进行图像编辑.
3 | 关闭符号编辑器完成编辑.

编辑动画路径

当您选中一个动画符号,将出现对应的动画路径.路径决定了动画的位移和方向.路径上的关键点代表对应的影格.

绿色的关键点是动画的起点,红色的关键点是动画的终点.蓝色的点是中间关键点.每一个关键点的位置代表影格中图像的位置.如果某一个关键点上的图像当前显示了,代表当前正在该关键点对应的影格中.例如下右图,第四个关键点的图像显示了,代表当前正在第四影格编辑.

您可以通过拖动关键点改变运动的方向和位移.

改变位移和方向:

1 | 拖动某一个关键点到新的位置.
 | 绿色的关键点代表动画的起点,红色的关键点代表动画的终点.
 | 在拖动的过程中按住Shift键,您可以按照45度整数倍改变运动的方向.

蓝骑士编译


影格的操作--蓝骑士（侠客岛版权所有）

创建动画 > 影格的操作

影格的操作

Fireworks主要通过影格的播放形成动画,所以管理影格对于动画创作非常重要.您可以打开影格面板(Frames),查看影格列表.通过影格列表您实现创建新影格,排列影格顺序,移动对象,设置影格延迟时间等等操作.

每一个影格都有一些相关属性,通过设置这些属性,我们可以控制动画显示.

蓝骑士编译


设置影格延迟时间--蓝骑士（侠客岛版权所有）

创建动画 > 影格的操作 > 设置影格延迟时间

设置影格延迟时间

影格延迟(frame delay)决定了每一个动画画面的停留时间,以百分之一秒为单位.例如设置影格延迟50,表示影格画面停留半秒钟,设置300,表示3秒.

设置影格延迟时间:

1 | 选择一个或多个影格:
 | 按住Shift键鼠标点选用于连续的选中多个影格.
 | 按住Control键(Windows操作系统) 或 Command 键(Macintosh操作系统)鼠标点选用于个别的选中多个影格.
2 | 在影格面板右上角小箭头的弹出菜单中选择 Properties(属性) , 或者在高亮选中的影格的时间数字区域,双击鼠标打开影格属性对话框.
3 | 在影格延迟时间中输入数值.
4 | 回车或鼠标点击其他区域完成属性设置,关闭属性窗口.

蓝骑士编译


显示或隐藏影格--蓝骑士（侠客岛版权所有）

创建动画 > 影格的操作 > 显示或隐藏影格

显示或隐藏影格

您可以显示和隐藏影格,观察动画的效果.如果影格被隐藏,预览播放时将不显示该影格画面,输出时也不输出该影格.

显示或隐藏影格:

1 | 在影格面板右上角小箭头的弹出菜单中选择 Properties(属性) , 或者在高亮选中的影格的时间数字区域,双击鼠标打开影格属性对话框.
 | 此时在影格列表中弹出影格属性对话框.
2 | 取消 Include when Exporting(输出时包含影格) 选项.
 | 在影格列表的影格延迟时间区域将出现红色的 X .
3 | 回车或鼠标点击其他区域完成属性设置,关闭属性窗口.

蓝骑士编译


影格命名--蓝骑士（侠客岛版权所有）

创建动画 > 影格的操作 > 影格命名

影格命名

当您创建动画,Fireworks在影格面板中显示影格列表.影格默认依次命名为Frame1,Frame2....当您调整影格的顺序,影格列表仍然按照Frame1,Frame2..的数字顺序依次排列,但此时影格的内容将会发生改变.

您可以自定义影格的名字以便在管理影格时一目了然.自定义的影格在移动时,影格名字跟随着影格移动.

改变影格名字:

1 | 在影格列表中,双击影格的名字.
2 | 在弹出的文字框中,输入新的名字,回车完成命名.

蓝骑士编译


添加,移动,复制,删除影格--蓝骑士（侠客岛版权所有）

创建动画 > 影格的操作 > 添加,移动,复制,删除影格

添加,移动,复制,删除影格

在影格面板中您可以添加,移动,复制,删除影格.

在当前影格下添加新影格:

点击影格面板下方的 New/Duplicate Frame(新建/复制影格) 按钮.

在指定位置添加新影格:

1 | 在影格面板右上角小箭头的弹出菜单中选择 Add Frames(添加影格).
2 | 在弹出窗口中输入添加新影格的数目.
3 | 选择插入方式: before the current frame(在当前影格上开始插入), after...(在当前影格下开始插入), at the beginning(在影格列表顶部),at the end(在影格列表底部),点击 OK 完成.

复制影格:

将希望复制的影格拖动到 New/Duplicate Frame(新建/复制影格) 按钮上复制出新影格.

复制影格到指定位置:

1 | 在影格面板右上角小箭头的弹出菜单中选择 Duplicate Frame(复制影格).
2 | 输入复制的数目,选择插入的位置(同添加新影格),点击 OK 完成.

复制影格使得几个影格中出现相同的对象,可以对这些对象进行控制形成动画.

移动影格:

在影格列表中拖动影格.

删除影格:

选中影格,点击 Delete Frame(删除影格按钮)panel.
拖动希望上出的影格到 Delete Frame(删除影格按钮).
在影格面板右上角小箭头的弹出菜单中选择 Delete Frame(删除影格).

蓝骑士编译


在影格间移动对象--蓝骑士（侠客岛版权所有）

创建动画 > 影格的操作 > 在影格间移动对象

在影格间移动对象

使用影格面板您可以在影格间移动对象.

在影格件移动对象:

选中对象,在影格面板上拖动影格列表后的蓝色小片到其他影格.

蓝骑士编译


优化图形概述——茕若（侠客岛版权所有）

优化图形 > 优化图形概述

优化图形概述

网络图形设计的最终目标就是，设计制作出下载十分迅速的优美图像来。为了能够做到这一点，你必须为你的图像选择一种具有最佳压缩比的文件格式，同时最大程度地保持图像的质量不受损失。这种平衡的举动就是图形优化——也就是寻找到最佳的颜色，压缩比和质量的混合方案。

在 Fireworks 中，优化设置只能够应用于被导出的图像。因而，在图像的设计制作过程中你可以自由随意地进行创作，丝毫不用担心颜色的限制或是应用后的效果。然后在你准备导出你的图像时，再对优化设置进行选择，定义，比较，这才是最佳的方法。

在 Fireworks 中，对图像的优化是由三部分的工作组成：

首先是选择一个最佳的文件储存格式。不同的文件格式对于压缩文件中颜色信息有着各自不同的方法。所以对于不同的类型的图形选择适当的文件格式可以极大地缩小文件的尺寸。
其次是设置文件格式的明细选项。每一种网络文件格式对于控制图像压缩都有一套独特的选项供你选择。举例来说，对于 GIF 图像，你可以进行抖动处理，来补偿图像中较少的颜色，对于 JPEG 图像，你可以进行平滑处理，对图像进行细微的模糊处理，借此来帮助 JPEG 图像的压缩，减小文件尺寸。
最后是调整图像中的颜色。方法是通过限制图像使用某一套具体的颜色，也就是常说的色板，来限制颜色的使用数目。然后，对色板上不使用的颜色进行清理。色板上的颜色越少，也就意味着图像中的颜色越少，结果当然就是缩小了文件的尺寸了。减少颜色数的使用也会使缩减图像的质量，所以你必须对各种不同的色板进行测试，在图像质量和文件尺寸之间寻找出最佳的平衡点。

茕若编译


选择文件格式——茕若（侠客岛版权所有）

优化设置 > 选择文件格式

选择文件格式

由于拥有相当高的压缩比，GIF，JPEG 都是网络开发中经常用到的图形文件格式。由于不是所有的网际浏览器都支持 PNG 格式，所以它的使用还不十分普及。压缩确保文件了在 Internet 间的快速传递。可是，图形的效果会由于不同的文件格式而有比较大的差别，这主要取决于每中文件格式的压缩方法。因此，究竟选用哪一种文件格式，主要还是取决于你图形的设计和应用范围。

茕若编译


选择文件格式——茕若（侠客岛版权所有）

优化图形 > 选择文件格式 > 选择 GIF 格式

选择 GIF 格式

Graphics Interchange Format（图形交换格式），或者简称为 GIF，是一种流行的网络图形格式。GIF 格式最多包含 256 种颜色。尽管当图形中包含的颜色超过 256 种时其质量会明显下降，这种格式仍提供了良好的压缩方法。此外，GIF 还可以包含透明区域和多帧动画。

无损压缩的压缩图像通常在图像被压缩后不会造成图像质量上的损失。GIF 文件的压缩是通过水平方向扫描像素行，寻找一致的颜色区域，然后将文件中相同的像素区域进行压缩而成。GIF格式只是在图像包含较少颜色时才能提供无损压缩，例如经常使用的线条或几何作品。

因此，拥有纯色重复区域的图像在导出为 GIF 格式时压缩效果最佳。GIF 格式通常是卡通类图形，标志，拥有透明区域的图形和动画的最佳保存格式。矢量对象经常被保存为 GIF 格式。

注：如果对图形进行过抖动和消除锯齿处理，那么所产生的 GIF 文件通常比较大。

茕若编译


选择文件格式——茕若（侠客岛版权所有）

优化图形 > 选择文件格式 > 选择 JPEG 格式

选择 JPEG 格式

JPEG 是由 Joint Photographic Experts Group（联合图片专家组）专门为照片或高彩图像开发的一种格式。JPEG 支持百万以上的颜色(24-bit)，而 GIF 仅支持 256 色。JPEG 通常用来保存高质量照片数据。

JPEG 是一种有损压缩格式，也就是说，在图像被压缩过程中将会有一些数据丢失，从而最终降低文件的质量。不过，通常这种数据丢失并不会对图像质量造成很大的或者说显著的影响。

在导出 JPEG 格式文件的时候，你可以利用 Optimize（优化）面板上的 Quality 弹出滑标来控制文件压缩时图像质量的受损程度。

百分比越高，图像质量保存越好，但压缩比就越低，生成的文件就越大。
百分比越低，生成的文件就越小，但生成文件的图像质量就比较差。

使用 2-Up 和 4-Up 预览方式来测试和比较 JPEG 在不同的 Quality 设置下不同的效果，预计文件大小。

JPEG 格式对于扫描的照片，纹理图像，拥有渐进色的图像，以及那些超过 256 色 的图像来说是最佳的保存格式。

茕若编译


选择文件格式——茕若（侠客岛版权所有）

优化图形 > 选择文件格式 > 选择 PNG 格式

选择 PNG 格式

Portable Network Graphic（便携网络图形），或者简称为 PNG，是最为适合的网络图形格式。然而，在没有插件的情况下，并不是所有的网络浏览器都能够充分利用 PNG 格式的特性的。因此他还不是一种网络种普及的格式。PNG 格式可以支持高达 32-bit 的颜色，可以包含透明度或者 alpha 通道，也可以进行渐变处理。

PNG 格式的压缩不造成文件任何的损失，即使在高彩的情况下也如此。他跨越像素行和栏进行压缩。对于高彩图像，JPEG 产生的质量较高。PNG 允许 32-bit 色图像包含透明度，但是产生的图像尺寸较大。

PNG 格式是创建复杂的即时透明，高彩图形，和良好的低色压缩图形的最佳格式。

PNG 是 Fireworks 本身的文件格式。可是，Fireworks 的 PNG 文件中包含有一些当你导出用于网络的 PNG 图形时并不保存的额外的源文件信息。

茕若编译


为 GIFs 和 PNGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 GIFs 和 PNGs 选择优化设置

为 GIFs 和 PNGs 选择优化设置

对于 GIFs 和 8-bit 的 PNGs (PNG8) 来说，Fireworks 的优化设置基本类似。

茕若编译


为 GIFs 和 PNGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 GIFs 和 PNGs 选择优化设置 > 选择色深

选择色深

所谓色深（Color depth），就是指包含在导出的图形中的颜色数。GIF 图像永远都是以 8-bit 颜色 (256 种颜色) 或者更少的颜色导出的。你可以以更高的色深来导出 PNG 图形。

色深越高，导出的文件就越大，这尤其不适合于网络图形。你可以在导出拥有连续色调的照片图像或者复杂的渐变混色图像时使用 24- 或 32-bit 色深的 PNG 格式或是 JPEGs 格式。

茕若编译


为 GIFs 和 PNGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 GIFs 和 PNGs 选择优化设置 > 选择色板

选择色板

每个导出后的 GIFs 和 8-bit PNGs 文件都包含有一个色板。色板 （color palette），就是一个包含有能够用于文件的最多可达 256 种颜色的列表。只有在色板上定义的颜色才能够出现在图形中；可是，有些色板上还会包含一些图形中没有用到的颜色。在图形优化过程中调整色板会影响到导出图像的颜色。有关色板的更为详细的介绍，请参阅 优化色板。

茕若编译


为 GIFs 和 PNGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 GIFs 和 PNGs 选择优化设置 > 为补偿损失色进行抖动处理

为补偿损失色进行抖动处理

通过对两种近似的颜色进行像素到像素的替换，对当前色板上没有的近似的颜色进行抖动处理。抖动处理，尤其对于导出拥有复杂的混色或者渐变色，或者将照片图像导出为索引图像格式（如 GIF）的时候，是非常有帮助的。

抖动处理会极大地提升文件的尺寸。

在导出图像时进行抖动处理：

在 Optimize 面板上的 Dither（抖动）文本框内输入一个百分比数值。

茕若编译


为 GIFs 和 PNGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 GIFs 和 PNGs 选择优化设置 > 为减小文件尺寸设定损失值

为减小文件尺寸设定损失值

为了让 GIF 文件压缩得比通常情况下更小，你可以在 Optimize 面板上输入一个 Loss（损失）值。Loss 值设置得越高，生成的文件就越小，但图像质量也就越差。

通常 Loss 设置在 5 和 15 之间所产生的效果最好。

茕若编译


为 GIFs 和 PNGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 GIFs 和 PNGs 选择优化设置 > 定义透明区域

定义透明区域

不管是 GIF，还是 PNG 格式，你都可以设置透明区域，这样在网络浏览器中网页的背景就可以透过图像的透明区域被看到。有关透明设置的更为详细的介绍，请参阅 指定透明色。

茕若编译


在工作区中进行优化——茕若（侠客岛版权所有）

优化图形 > 在工作区中进行优化

在工作区中进行优化

Fireworks 的优化控制选项非常方便地被放在工作区中的面板上：

Optimize（优化）面板包含了控制图像优化的选项。
Color Table（色表）面板上显示的是当前导出色板的颜色。
Preview (预览)窗显示的是导出后图形的预览。

注：在 Fireworks 中，所有的优化控制选项在工作区都可以找到。不过，你还是可以通过选择 File -> Export Preview（文件 -> 导出预览），在导出前对图像进行优化。有关更为详细的介绍，请参阅 导出文件时进行优化和预览。

你可以选择一些常用的优化设置，来快速设定文件格式，应用一些明细格式选项。当然你也可以调整预设优化设置。

如果预设优化选项不能满足你对图像更为精确的优化要求，你可以使用 Optimize 面板创建自定义优化设置。

选择预设优化选项；

从 Optimize 面板的 Settings（设定）弹出菜单中选择一个设置。

以下预设选项是可选的：

GIF Web 216 强制所有色彩转换为网络安全色（Websafe colors）。这个色板最多包含 216 种颜色。参阅 设置网络安全色。

GIF WebSnap 256 会把所有非网络安全色转换为与之相近的网络安全色。该色板最多包含 256 种颜色。

GIF WebSnap 128 同样也会把所有非网络安全色转换为与之相近的网络安全色。该色板最多包含 128 种颜色。

GIF Adaptive 256 该色板包含所有在图形中使用的实际颜色，其最多包含 256 种颜色。

JPEG - Better Quality 该选项将 quality 设定为 80，smoothing 设定为 0。其结果将产生质量较高但体积较大的图形。

JPEG - Smaller File 该选项将 quality 设定为 60，smmothing 设定为 2。其结果会产生体积小但质量较低的图形。

注： 你为图形选择的 GIF 设置类型应该根据图形中颜色的数量而定。一个含有 128 种颜色的色板最适合那些使用较少颜色的小型文件。

请参阅选择文件格式。

为图像指定优化设置：

1 | 在 Optimize 面板上，选择一个文件格式。
2 | 设定文件格式明细选项。例如 color（颜色），dither（抖动），以及 quality（质量）。
3 | 根据需要，从 Optimize 面板的 Options 弹出菜单中选择其它的优化设置。

茕若编译


为 GIFs 和 PNGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 GIFs 和 PNGs 选择优化设置 > 删除所有面板上的无用的颜色

删除所有色板上无用颜色

在导出前删除图像中不使用的颜色可以缩减文件的尺寸。

删除无用颜色：

在 Optimize 面板的 Options 弹出菜单中选择 Remove Unused Colors（删除无用颜色）。

取消选择 Remove Unused Colors 将导致图像包含了色板上所有的颜色，其中也包括那些导出图像中没有用到的颜色。

茕若编译


为 GIFs 和 PNGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 GIFs 和 PNGs 选择优化设置 > 交错：分段下载

交错：分段下载

当在网际浏览器中查看的时候，交错图像会迅速地以低分辨率出现，然后在继续下载过程中再过渡到高分辨率。

让导出的 GIF 或 PNG 产生交错：

从 Optimize 面板的 Options 弹出菜单中选择 Interlaced（交错）。

茕若编译


为 JPEGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 >为 JPEGs 选择优化设置

为 JPEGs 选择优化设置

JPEGs 始终是以 24-bit 颜色保存的。JPEG 压缩方法是专门用于压缩过渡色和渐变色的。 这种格式对压缩照片和高彩图像有着显著的效果。选择性 JPEG 压缩允许你使用不同级别压缩图像的不同部分。

茕若编译


为 JPEGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 JPEGs 选择优化设置 > 选择性 JPEG 压缩

选择性 JPEG 压缩

选择性 JPEG 压缩允许你使用不同级别来压缩 JPEG 图形的不同区域。对于图像中特别重要的区域应使用高级别进行压缩，而图像中非重要性区域，例如背景，应使用低级别进行压缩。这样整个图像的尺寸得以减小，而关键区域的图像质量得以维持。

压缩 JPEG 的选定区域：

1 | 使用 Marquee（选区）工具，选择图形中要压缩的区域。
2 | 选择 Modify -> Selective JPEG -> Save Selection as JPEG Mask（修改 －> 选择性 JPEG －> 保存选区为 JPEG 遮照）。
3 | 从 Optimize 面板的 Settings 弹出菜单中选择一种 JPEG 格式
4 | 点击 Optimize 面板的 Selective Quality（选区质量）按钮。Selective JPEG Settings（选择的 JPEG 设置） 对话框出现。
5 | 选择 Enable Selective Quality（使质量可以选择）然后在文本框中键入一个压缩值。
 | 一个较低的值会使选择的 JPEG 覆盖区与图像其他区域相对压缩的更多。一个较高的值会使选择的 JPEG 覆盖区与图像其他区域相对压缩的较少。
6 | 给高亮选区选择一种覆盖色。这不会影响到输出结果。
7 | 选择 Preserve Text Quality（保护文本质量）。不管 Selective Quality 的值是多少，所有的文本项将自动的以高质量导出。
8 | 选择 Preserve Button Quality（保护按钮质量），所有的按钮符号将自动的以高质量导出。
9 | 点击 OK。
 | 注： 你可以通过转到 Preview 标签或选择 File -> Preview（文件 －> 预览）来查看压缩的效果。

修改选择性压缩区域：

1 | 选择 Modify -> Selective JPEG -> Restore JPEG Mask as Selection（修改 -> 选择性 JPEG -> 恢复 JPEG 遮照为选区）。
 | 选区被高亮表示。
2 | 使用 Marquee 工具 或者其他选区工具来改变选区大小。
3 | 选择 Modify -> Selective JPEG -> Save Selection as JPEG Mask（修改 －> 选择性 JPEG －> 保存选区为 JPEG 遮照）。
4 | 如需要，在 Optimize 中更改 Selective Quality 设定。

注：要想撤销选区，选择 Modify -> Selective JPEG -> Remove JPEG Mask（修改 -> 选择性 JPEG -> 移除 JPEG 遮照）。

茕若编译


为 JPEGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 JPEGs 选择优化设置 > 降低质量以减小文件尺寸

降低质量以减小文件尺寸

调整 Optimize 面板上的 Quality（质量）设置可以提高或者降低 JPEG 图像的质量。选择较低的图像质量其结果将导致文件变小。

茕若编译


为 JPEGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 JPEGs 选择优化设置 > 模糊边缘以提升压缩比

模糊边缘以提升压缩比

在 Optimize 面板上设置 Smoothing（平滑）有助于降低 JPEG 图像文件的尺寸。平滑处理可以模糊那些在 JPEG 格式中不能很好压缩的较硬的图像边缘。设定的数字越大，模糊的越厉害，生成的文件尺寸也就越小。

将 Smoothing 值设为 3 将在减小文件的尺寸的同时保持合理的质量。

茕若编译


为 JPEGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 JPEGs 选择优化设置 > 锐化颜色边缘和细节

锐化颜色边缘和细节

从 Optimize 面板的 Options 弹出菜单中选择 Sharpen JPEG Edges（锐化 JPEG 图像边缘）有助于保留图像中两种颜色之间精细的边缘。在导出 JPEG 格式文件的时候对文本或者精细的边缘应用 Sharpen JPEG Edges 可以保持这些区域的锐化。

选择 Sharpen JPEG Edges (锐化 JPEG 图像边缘)会提升文件的尺寸。

茕若编译


为 JPEGs 选择优化设置——茕若（侠客岛版权所有）

优化图形 > 为 JPEGs 选择优化设置 > 渐变式 JPEGs

渐变式 JPEGs

从 Optimize 面板的 Options 弹出菜单中选择 Progressive JPEG（渐变式 JPEG）可以导出渐变 JPEG。渐变式 JPEGs，就如同交错 GIF 图像一样，会在浏览器中先以低分辨率出现，然后在持续下载过程中再显现出完整的分辨率来。

有些旧版本的位图编辑程序不能打开渐变式 JPEG 格式。

茕若编译


优化色板——茕若（侠客岛版权所有）

优化图形 > 优化色板

优化色板

以 8-bit 或更少颜色导出的 GIFs 和 PNGs 文件会使用一个色板来对导出图像文件使用的颜色进行储存和定位。优化和自定义色板可以使用 Color Table 面板来进行。

茕若编译


优化色板——茕若（侠客岛版权所有）

优化图形 > 优化色板 > 选择合适的色板

选择合适的色板

我们可以从 Optimize 面板上的 Palette（调色板）弹出菜单中选择一个色板，然后再对其进行优化。

在默认情况下以下色板是可选的：

Adaptive 属于常规色板，这个色板来自于用户在文档中实际使用的颜色。Adaptive 色板最常使用于生成高质量的图像。

Web Adaptive 是一种适配色板，在这个色板上，那些接近网络安全色的颜色会被转换成最为接近的网络安全色。

Web 216 是一种包含 216 种通用于 Windows 和 Macintosh 计算机颜色的色板。这一色板常被称之为 Websafe 网络安全色板或浏览器安全色板，这是因为这个色板能够在各种平台上不同的浏览器中生成较为一致的结果。

Exact 是一种包含有图像使用的原有颜色的色板。只有当图像中包含的颜色数等于或者少于 256 种才可以使用这个色板。如果图像中的颜色超过了 256 种，色板会自动转为 Adaptive。

System (Windows) 和 System (Macintosh) 分别包含有 Windows 或者 Macintosh 平台标准定义的 256 种颜色。

Grayscale 是一种包含有 256 中或或少量的灰色渐变色色板。选择这个色板会将导出图像转换成灰度图像。

Black and White 仅仅包含白色和黑色的两色色板。

Uniform 是一种基于 RGB 像素值的数学色板。

Custom 是一种经过修改，或者来自外部的色板或 GIF 文件的色板。

导入一个色板：

1 | 载入一个 ACT 或 GIF 色板：
 | 从 Color Table 面板的 Options 弹出菜单中选择 Load Palette。
 | 从 Optimize 面板的 Palette 弹出菜单中选择 Custom（自定义）。
2 | 查找 ACT 或者 GIF 文件，然后点击打开。
 | ACT 或 GIF 文件中的颜色就会被添加到 Color Table 面板上。

茕若编译


在工作区中进行优化——茕若（侠客岛版权所有）

优化图形 > 在工作区中进行优化 > 指定切割的优化设置

指定切割的优化设置

你可以为切割文档中的每一个切割部分指定一个不同的优化设置。举例来说，如果切割中的一部分包含的是照片，导出格式选择 JPEG 最好，而同时另一部分只是一个单色区域，导出为 GIF 格式可能获得更好的压缩效果，这时你就可以对其分别进行优化设置了。通过在不同部分设置切割，你可以为不同部分进行不同的优化导出。

在你在 Web 层上选取了一个切割对象后，Optimize 面板就会显示出该切割的优化设置。

为一个切割部分设置优化选项：

1 | 选取切割对象。
 | 如果切割对象不可见，点击 Tools 面板中的 Show Hotspots and Slices（显示热区和切割）按钮。这些按钮是用来显示和隐藏 Web 层的。
2 | 在 Optimize 面板上输入优化设置。
 | 被选取的切割就根据指定的优化设置做好了导出的准备。
 | 有关切割的更为详细的介绍，请参阅 创建切割。

茕若编译


优化色板——茕若（侠客岛版权所有）

优化图形 > 优化色板 > 设定色板上的颜色数量

设定色板上的颜色数量

在 Optimize 面板的 Colors 选项中输入或选择一个数字，这样就可以设定导出图像的色板上所允许的最大的颜色数。在图像中Fireworks 经常只使用实际颜色优化图像。这可能会低于你指定的最大颜色数。在 Color Table 面板左下角的数字表明图像中可以看到的实际颜色数。减少色板上的颜色数可以减小文件的尺寸。

如果你设定的颜色数比图像中实际使用的颜色数要少，会令图像丢失一些颜色，首当其冲的是应用最少的颜色。那些丢失的颜色会转成色板上与之最为接近的颜色。这么做会降低图像的尺寸与质量。

茕若编译


优化色板——茕若（侠客岛版权所有）

优化图形 > 优化色板 > 查看色板中的颜色

查看色板中的颜色

Color Table 面板显示的是在 8-bit 或者更低的色深的情况下当前预览窗中的颜色，同时该面板也允许你修改图像的色板。当你在预览模式下色表会自动进行更新。如果你同时优化一个以上的切割，或是你优化的图像不是一种像 GIF 的 8-bit 格式，Color Table 面板将显示为空。

在有些色样上出现了许多不同的微小的符号，这是表明个别颜色的不同的特性的，如下所示：
符号 | 意义
 | 表明该颜色被编辑过，并且只对导出文档产生影响。这并不会改变文档中的颜色。
 | 表明该颜色被锁定。
 | 表明该颜色是透明色。
 | 表明该颜色是网络安全色。
 | 表明该颜色拥有多个属性。在这个例子中，该颜色既是网络安全色，又是被锁定色，同时还被编辑过。

如果你编辑文档，Color Table 面板可能不再显示文档中所有的颜色。在这种情况下，面板的标题会变成 Colors (Rebuild)，这就表明你必须重建颜色表。

更新 Color Table 面板上的颜色来反映文档中的编辑操作：

从 Color Table 面板的 Options 弹出菜单中选择 Rebuild Color Table（重建色表）。

选取一个颜色：

点击 Color Table 面板上的颜色。

选取多个颜色：

按住 Control(Windows)或 Command(Macintosh)键的同时逐个点击你要选取的颜色。

选取某一范围内的颜色：

1 | 点击一个颜色。
2 | 按住 Shift 键点击第二个颜色。

预览文档中包含同一指定颜色的所有像素：

1 | 点击文档窗中的 Preview 标签。
2 | 在 Color Table 面板上点击并按住一个色样。
 | 包含被选取颜色的像素就会暂时性地变成另一种高亮颜色，直到你松开鼠标按钮为止。

注：如果你是使用 2-Up 或 4-Up 方式预览像素的话，任意选择一个查看窗口，但不要选取 Original 窗口。

茕若编译


优化色板——茕若（侠客岛版权所有）

优化图形 > 优化色板 > 锁定色板上的颜色

锁定色板上的颜色

你可以将色板上个别的颜色加以锁定，这样当需要更换色板或者减少色板上的颜色数的时候你就能够将这些被锁定的颜色删除或者更换掉。如果在颜色被锁定之后你转到了其它的色板，被锁定的颜色也会被添加到新的色板上的。

锁定一个选取的颜色：

点击 Color Table 面板底部的 Lock（锁定）按钮，或者从 Options 弹出菜单中选择 Lock Color（锁定颜色）。

取消对颜色的锁定：

1 | 先在 Color Table 面板上选取颜色。
2 | 点击 Color Table 面板底部的 Lock 按钮，或者取消对 Options 弹出菜单中 Lock Color 的选取。

取消对所有颜色的锁定：

从 Color Table 面板的 Options 弹出菜单中选择 Unlock All Colors（取消锁定所有颜色）。

茕若编译


优化色板——茕若（侠客岛版权所有）

优化图形 > 优化色板 > 编辑色板上的颜色

编辑色板上的颜色

通过在 Color Table 面板上进行必要的编辑，你就可以改换面板上的颜色。编辑颜色将会替换掉导出的图像中的所有该颜色实体。编辑行为并不会替换原始图像中的颜色。

编辑一个颜色：

1 | 打开系统颜色检选器（system color picker）：
 | 选取一个颜色，点击 Color Table 面板底部的 Edit Color（编辑颜色）按钮。
 | 在 Color Table 面板上双击一个颜色。
2 | 使用系统颜色检选器更换颜色。
 | 在预览区域内，新选的颜色会替换所有被替换颜色的实体。

注: 鼠标右键点击（Windows）或者按住 Control 键点击（Macintosh）色板上的颜色可以调出一个有关颜色的编辑选项的快捷菜单。

茕若编译


优化色板——茕若（侠客岛版权所有）

优化图形 > 优化色板 > 设置网络安全色

设置网络安全色

所谓网络安全色（Websafe colors），就是指那些通用于 Macintosh 和 Windows 平台的颜色。当你在 256 色的计算机上通过网际浏览器查看的时候这些颜色不发生抖动。

Fireworks 应用使用网络安全色有几种方法。

强迫所有使用的颜色均为网络安全色：

选择 Web 216 色板。

创建一个支持网络安全色的适配色板：

选择 Web Adaptive 色板。那些同网络安全色接近的非网络安全色会被转换成与自己最为接近的网络安全色。

强迫一种颜色转换成近似的网络安全色：

1 | 在 Color Table 面板上选取颜色。
2 | 点击 Snap to Websafe 按钮。
 | 你在 Color Table 面板上将颜色更换为网络安全色的操作并不会影响到原始的图像，而只是影响到图像的导出版本。

茕若编译


优化色板——茕若（侠客岛版权所有）

优化图形 > 优化色板 > 保存色板

保存色板

你可以把自己定义的色板保存为一个外部色板文件，以后在处理其它的 Fireworks 文档或者在其它支持外部色板文件的程序中加以使用，比如说 Adobe Photoshop，Macromedia FreeHand 以及 Flash 5。

保存自定义色板：

1 | 从 Color Table 面板 Options 弹出菜单中选择 Save Palette（保存色板）。
2 | 为保存色板设定一个名字然后选择目标文件夹。
3 | 点击保存。
 | 你可以将保存的色板文件载入 Swatches 面板或者在导出其它文档的时候使用。

茕若编译


指定透明色——茕若（侠客岛版权所有）

优化图形 > 指定透明色

指定透明色

你可以在导出 PNG 或者 GIF 文件的时候让画布的颜色和文件中其它的颜色显示为透明。在这样做的时候，网页背景色或背景图案就可以透过图形的透明部分被看到。这样可以让图形看上去成为网页背景的一部分，而不仅仅是停留在背景之上。

在 Fireworks 中，不管是在源图窗口还是在预览窗口，透明区域都是用如同西洋棋盘一样的相间的灰色和白色方格表示。

你也可以将画布的颜色设置为透明的。（参阅 更改画布。）如果工作区被设置为透明，你可以在 Transparency 弹出菜单中选择 Alpha Transparency 来优化你的透明设置。

使用 Optimize 面板上的 Transparency eyedropper（透明滴管）按钮可以使一个颜色在浏览器中显示为透明。

注：将被优化过的颜色设定为透明并不会影响当前的图像，而只会影响到图像的导出版本。你可以在预览窗口看到导出的图像的效果。有关导出的介绍，参阅 导出文件时进行优化和预览。

选取用来设置透明的颜色：

1 | 点击 Preview，2-Up，或 4-Up 标签。在 2-Up 或 4-Up 窗口中，点击除源图外的图形查看。
2 | 在 Optimize 面板上，从面板底部的 Transparency 弹出菜单中选择 Index Transparency（索引透明）。
 | 画布的颜色在预览的时候被设定成了透明。
3 | 要想选择不同的颜色，点击 Set Transparency 按钮。
 | 这时的光标变成了滴管图案。
4 | 选择要设定为透明的颜色：
 | 点击 Color Table 面板上的色样。
 | 点击文档中的颜色。
 | 有关Preview 窗口，Optimize 面板，和 Color Table 面板的介绍，参阅 在工作区中进行优化。

添加颜色到透明色中或从透明色中移除颜色：

1 | 点击 Preview，2-Up，或 4-Up 标签。在 2-Up 或 4-Up 窗口中，点击除源图外的查看方式。
2 | 在 Optimize 面板上，点击 Add to Transparency 或 Remove from Transparency 按钮。
 | Add to Transparency button （添加到透明色按钮）
 | Remove from Transparency button（从透明色中移除按钮）
3 | 选择另一种要设定为透明或要删除的颜色：
 | 点击 Color Table 面板上的色样。
 | 在预览中点击一种颜色。

茕若编译


通过消除锯齿处理使应用颜色同目标背景色匹配——茕若（侠客岛版权所有）

优化图形 > 通过消除锯齿处理使应用颜色同目标背景色匹配

通过消除锯齿处理使应用颜色同目标背景色匹配

所谓消除锯齿（Anti-aliasing）就是通过将对象的颜色融进画布颜色令对象看上去更加平滑。例如，如果对象是黑色的，画布颜色是白色的，消除锯齿功能就会添加一些灰色阴影给对象周围的像素，令黑色与白色之间能够平滑地过渡。

为了防止出现光晕，最好将你的画布的颜色设定的与网页背景色匹配，先从对象到画布消除锯齿，然后再将画布设定为透明。

如果你打算进行消除锯齿处理的图形需要多次导出，而每次导出时背景色又不同的话，请使用 Optimize 面板上的 Matte（底色）弹出菜单。这对于那些将要以不同的背景色出现在网页中的图形来说是非常有用的。

改变消除锯齿色来配合目标网页的背景色：

在 Optimize 面板的 Matte 弹出菜单中选择颜色。试着令其最大程度地同目标网页中的背景色匹配。

注：这个处理对于那些有着柔软边缘的对象效果明显。

茕若编译


删除网络图形的光晕——茕若 （侠客岛版权所有）

优化图形 > 删除网络图形的光晕

删除网络图形的光晕

当在浏览器中观看一幅有着透明画布颜色且经过消除锯齿处理的图形的时候，常常会看到一道颜色不协调的像素光环，又叫光晕，出现在图形四周。

当你将画布颜色设为透明时，来自消除锯齿处理时的像素就保留了下来。在你将图形放到一个与消除锯齿色不同的背景色的网页中时，消除锯齿对象周围的像素就有可能呈现在网页背景之上。这就形成了光晕，尤其在深色背景上引人注意。

对于使用 Fireworks 本身创建的文件或者导入的 Photoshop 文件来讲，你可以通过将画布颜色同网页背景色匹配的方法来避免出现光晕。

对于丢失了源文件的 GIF 文件，以及按照索引色（通常是透明的画布颜色）进行了消除锯齿处理的导入图像文件，你必须要将光晕给删除掉。要想把光晕删除掉，可以使用 Optimize 面板将光晕透明中的消除锯齿色设的淡一点。

你可以使用 Index Transparency（索引透明）并手工使用 Optimize 面板上 Eyedropper（滴管）按钮对光晕颜色进行修正。

去除图形上的光晕：

1 | 点击 Preview，2-Up，或 4-Up 标签。在 2-Up 或 4-Up 窗口中，点击除源图外的查看方式。
 | Optimize 面板会在 Transparency 弹出菜单中显示 Index Transparency。
2 | 选择 Zoom 工具进行放大，直到你可以分辨出图形中对象周围的像素为止。
3 | 点击 Optimize 面板上的 Add to Transparency 按钮。
 | 这时的光标就变成了滴管图案。
4 | 点击构成光晕的杂色像素，令其透明。

茕若编译


在工作区中进行优化——茕若（侠客岛版权所有）

优化图形 > 在工作区中进行优化 > 使用切割覆盖层

使用切割覆盖层

在 Preview，2-Up，和 4-Up 查看方式下，切割覆盖层可以将当前被优化的区域同文档其它区域区别开来。切割覆盖层，默认情况下切割覆盖层是开启的，它使用一种暗淡的、透明的白色将还没有被优化的区域显示出来。切割覆盖层在 Original 查看方式下是不显示的。

当准备对被选切割进行优化的时候，未被优化部分就显得暗淡了。

如果没有切割被选取，那么切割区域就会变得暗淡，而文档其它区域就会被优化。

在 Preview，2-Up，或 4-Up 窗中你可以选定区域来进行优化。当有切割被选中后，其覆盖层就会关闭。通过按住 Shift 键使用 Pointer 工具进行点击来选取多个切割区域。

选取要优化的区域：

1 | 点击 Preview，2-Up，或 4-Up 标签。
2 | 点击要优化的区域。

隐藏或显示切割覆盖层：

选择 View -> Slice Overlay（显示 -> 切割覆盖层）。

当你对显示切割的原始图形和隐藏切割的优化图形进行比较的时候，你会发现在 2-Up 和 4-Up 预览窗内隐藏切割覆盖层是非常有用的。

茕若编译


在工作区中进行优化——茕若（侠客岛版权所有）

优化图形 > 在工作区中进行优化 > 保存和重复使用优化设置

保存和重复使用优化设置

你可以将你的自定义设置保存起来，以便以后在图形优化或者批处理过程中使用它们。保存自定义预设会将下边这些内容保存起来：

Optimize （优化）面板上的设置。
Color Table（色表）面板上的色板。
你在 Frames（帧）面板上选择的帧延迟设置（只对 GIF 动画有效）。

将自定义优化设置保存为预设：

1 | 点击 Optimize 面板上的保存按钮。
2 | 为你的优化预设输入一个名字，点击 OK 按钮。
 | 保存后的优化设置会出现在 Optimize 面板的 Setting 弹出菜单的最下边。以后所有的文档都可以使用。预设文件会保存在 Fireworks 4\Configuration\Export Settings 文件夹中。

与其他的 Fireworks 用户分享保存的优化设置：

将保存的优化预设文件从 Fireworks 4\Configuration\Export Settings 文件夹中复制到其它计算机的同一文件夹中。

删除自定义的预设优化设置：

1 | 在 Optimize 面板的 Settings 弹出菜单中，选择你要删除的优化设置。
2 | 点击 Optimize 面板底部的 Delete 按钮。
 | Fireworks 本身附带的预设优化是不能够被删除掉的。

茕若编译


预览优化设置和行为——茕若（侠客岛版权所有）

优化图形 > 预览优化设置和行为

预览优化设置和行为

Preview 窗中显示的是图像基于当前的优化设置导出以后的效果。另外，你也可以在导出之前利用 Preview 窗口测试行为和 Rollover 效果。

预览基于当前的优化设置的图像：

点击文档窗口左上角的 Preview 标签。

在预览窗口显示或隐藏切割对象和切割辅助线：

点击 Tools 面板中的 Show/Hide Hotspots and Slices (显示/隐藏热区和切割)按钮。

茕若编译


预览优化设置和行为——茕若（侠客岛版权所有）

优化图形 > 预览优化设置和行为 > 预览按钮和 rollover 效果

预览按钮和 rollover 效果

在 Preview 窗口移动 pointer 工具到 rollover 或按钮之上，看一看这些对象在网际浏览器中的表现。

注： 你必须查看第一帧来预览按钮或 rollover 效果。为了转到第一帧，在 Frame 面板中点击它。

茕若编译


预览优化设置和行为——茕若（侠客岛版权所有）

优化图形 > 预览优化设置和行为 > 评估文件下载时间

评估文件下载时间

Preview 窗口会显示出图像的合计大小和预计下载时间。这里预计出的文件下载时间是一个平均时间，是指当下载使用 28.8K 的调制调节器时按照当前的优化设置下载所有的图像切割部分及其所有的 rollover 状态时所使用的时间。

茕若编译


预览优化设置和行为——茕若（侠客岛版权所有）

优化图形 > 预览优化设置和行为 > 比较优化设置

比较优化设置

如果你想比较一下同一幅图形在不同的优化设置下的效果有何不同，可以使用 2-Up 和 4-Up 标签将文档窗分割成两个或四个预览窗口。你可以为每一个浏览窗口指定不同的优化设置，然后比较每种设置选择对图像的不同影响。

当你使用 2-Up 或 4-Up 预览方式的时候，第一个窗口显示的是原始图形。在这种查看方式下，你可以继续对图形的编辑，并将原始图形与优化后的版本进行比较。

在每一个预览窗口的底部显示的是当前预览设置的一些统计信息，包括文件的格式，预计下载时间，文件大小，色板，和使用的颜色数。

预览窗口

比较两个或四个不同的优化设置：

1 | 点击文档窗口左上角的 2-Up 或 4-Up 标签。
2 | 点击任意一个分离预览窗，选取它。
3 | 在 Optimize 面板和 Color Table 面板上输入你指定的设置。
4 | 选取其他的预览窗口，指定不同的优化设置，然后同第一个窗口进行比较。
 | 当你选择了 2-Up 或 4-Up 预览方式后，第一个窗口中显示的是原始的 Fireworks PNG 文档，这样方便你将其与不同的优化版本进行比较。你还可以将这个查看窗口转换成其它的优化版本。

在 2-Up 或 4-Up 预览方式下将原始文档窗口转换成优化版本：

1 | 选取包含原始文档的窗口。
2 | 在文档窗口中，从 Preview 弹出菜单中选择 Export Preview（导出预览）。

在 2-Up 或 4-Up 预览方式下将任意一个优化查看窗口转换成原始文档查看窗口：

1 | 选取任意一个优化版本查看窗口。
2 | 在文档窗口底部的 Preview 弹出菜单中选择 Original（不是 Preview）。

茕若编译


导出概述——茕若（侠客岛版权所有）

导出 > 导出概述

导出概述

当你在 Fireworks 中创建完图形后，你可以很容易地对其进行优化并导出成为常用的网络格式，当然也可以导出矢量程序的格式。导出和优化设置并不会改变原始的 Fireworks 文档。

在将图形导出成网络格式之前，你可以对要导出的文件进行优化。有关图像优化的详细介绍，参阅 在工作区进行优化。

如果你想让优化成为整个导出过程的一部分，Export Preview（导出预览）对话框会提供除选择性压缩外所有的优化选项。导出预览对话框会显示任何你所作的修改，所以你可以看到你的修改是如何影响图像的质量和文件大小的。

如果你是第一次接触有关网络图形的导出和优化处理的，可以使用 Export Wizard （导出向导）。这个向导可以指导你完成导出并及时提供有关设置方面的建议。

你也可以导出图形到其它的矢量应用程序，例如 Macromedia FreeHand 和 Flash，Adobe Illustrator 以及 Photoshop。你还可以将 Fireworks 的路径拷贝并粘贴到矢量程序中去。

茕若编译


导出切割——茕若（侠客岛版权所有）

导出 > 导出切割 > 导出切割时使用空白表格单元或嵌套表格

导出切割时使用空白表格单元或嵌套表格

Fireworks 会为切割图像导出一个 HTML 文件时，切割将在网页的表格中进行重新组合。你可以使用空白表格单元或者嵌套表格为切割文档导出一个表格来：

空白表格单元是指那些为了在浏览器中查看时保证表格单元排列正确的图像。
嵌套表格就是一个表格内再放入一个表格。嵌套表格不使用空白表格单元。这种表格在浏览器中可能载入的更慢，但因为它不包含空白表格单元，所以它的 HTML 代码更容易被编辑。

你可以为每个文档的切割对象设定独特的表格导出设置。如果需要，你也可以使用 HTML Setup 对话框中的 Set Default 按钮来给所有的新文档应用默认设置。

对导出 HTML 表格进行定义：

1 | 选择 File -> HTML Setup（文件 -> HTML 设置），或者点击 Export 对话框中的 Options 按钮。
2 | 转到 Table 标签，然后选择表格导出选项。
3 | 在 Space with 中选择一个设置：
 | Nested Tables - no Spacers 创建嵌套表格，不使用空白表格单元。
 | Single Table - no Spacers 创建单一表格，不使用空白表格单元。这个选项可能会令表格在某些情况下显示出错。
 | 1-Pixel Transparent Spacer 使用 1 x 1 pix 的透明 GIF 图像来作为空白表格单元，根据需要在 HTML 中进行表格调整。
4 | 为文本切割选择一个单元颜色：
 | 选择 Use Canvas Color 使单元颜色与画布颜色相同。
 | 取消选择 Use Canvas Color 允许你从选色框中选择一个颜色。
5 | 从 Contents（内容）弹出菜单中选择填充空白单元的物体：
 | None 选项使得空白单元保持为空。
 | Spacer Image 选项使你在空白表格中放置一个小的名为 spacer.gif 的透明图像。
 | Non-breaking Space 选项使你在空白单元中放置一个空格 HTML 标签。这个单元也会显示为空。
 | 注：空白单元只在 Export 对话框上的 Include Areas without Slices 项被取消选定的情况下才会出现。
6 | 点击 OK。

茕若编译


导出矢量路径——茕若（侠客岛版权所有）

导出 > 导出矢量路径

导出矢量路径

你可以导出矢量路径，这些路径可以被其他的矢量应用程序打开，包括 Macromedia FreeHand，Adobe Illustrator 7 及后续版本，或者 Flash 3 及后续版本。此外，你也可以将矢量路径拷贝并粘贴到其它的矢量程序中。

在你为 FreeHand 或 Illustrator 导出文件时，对象的外观可能不尽相同，这取决于 FreeHand 或 Illustrator 是否支持 Fireworks 的某些特定功能。

下边这些功能在 FreeHand 和 Illustrator 中是不被支持的，所以是不会出现在导出的文件中的：

Live Effects （即时特效）
Blending modes（混色模式）
Texture（纹理），pattern（图案），Web dither fills（网络抖动填充），和 所有的 gradient fills（渐变填充）(FreeHand)
Slice objects and image maps（切割对象和图像地图）
许多的文本格式选项
辅助线，网格，和画布颜色
位图图像 (FreeHand)

另外，对象的边缘会被设成钝边，垂直文本会变成水平文本。

茕若编译


导出矢量路径——茕若（侠客岛版权所有）

导出 > 导出矢量路径 > 导出到 FreeHand 和 Illustrator

导出到 FreeHand 和 Illustrator

你可以从 Fireworks 中将矢量导出到 FreeHand 或 Illustrator 中用在你的打印图形中，或者在更加复杂的路径编辑工具中进行编辑处理。

将图形导出到 FreeHand 或 Illustrator：

1 | 选择 File -> Export（文件 -> 导出）。
2 | 从 Save as 弹出菜单中选择 Illustrator 7
3 | 点击 Options 按钮。
4 | 在 Illustrator Export Options 对话框中选择以下一项：
 | Export Current Frame Only 选项保留层的名字。
 | Convert Frames to Layers 选项将每个帧导出成为一个层。
5 | 选择 FreeHand Compatible 来导出用于 FreeHand 的文件。
 | 选择 FreeHand Compatible 会忽略图像本身，而将图像中的渐变填充转换成实色填充。
6 | 点击 OK。
7 | 在 Export 对话框中，键入文件名字，选择存放目录，然后点击保存。

茕若编译


导出矢量路径——茕若（侠客岛版权所有）

导出 > 导出矢量路径 > 导出到 Macromedia Flash

导出到 Macromedia Flash

你可以将 Fireworks 路径导出到 Macromedia Flash 中用在你站点里的 Flash 图形或动画中。

注: 为了你准备导出的 Fireworks 路径中不包含任何的位图特征，你可以使用 Edit -> Copy as Vectors（编辑 -> 复制为矢量）将矢量路径直接拷贝和粘贴到 Flash 中。

除非你在 Flash SWF Export Options 对话框中选择了 Maintain Appearance，不然某些格式属性在导出后会丢失的。笔触大小和颜色始终会得以保留。

导出时可能会丢失的格式包括：

Live Effects（即时特效）
Opacity and Blending（不透明和混色）模式（带有不透明属性的对象会变成带有 alpha 通道的符号）
Masks（遮照）
切割对象，图像地图，行为（例如，rollover 效果就会丢失）。
某些文本格式选项，如字距调整，位图笔触等
Feather edges（羽化边缘）
Layers（层）
对象所应用的消除锯齿（Flash 的播放器会在文档一级应用消除锯齿功能，因此，当文档导出的时候会应用消除锯齿功能的）。

在导出到 Flash 的时候，你可以就如何导出对象做出一些选择。

导出图形到 Flash：

1 | 选择 File -> Export（文件 -> 导出）。
2 | 从 Save as 弹出菜单中选择 Flash SWF。
3 | 点击 Options 按钮。
4 | 为了维持文档外观，选择一个或全选这些选项：
 | Choose Objects: Maintain Appearance 转换矢量对象为位图对象，同时保留应用的笔触和填充的外观。编辑行为有丢失。
 | Choose Text: Convert to Paths 把文本转换为路径，保留任何自定义的字句调整或你在 Fireworks 中输入的空格。
5 | 为了保留主要路径的可编辑性，选择 Objects：Maintain Paths 和 Text：Maintain Editability。此时特效和格式都会丢失。
6 | 使用 JPEG quality 弹出滑块来设置 JPEG 图像的质量。
7 | 选择要导出的帧和每秒的帧速度。
8 | 点击 OK。
9 | 在 Export 对话框中，输入文件名，选择存放目录，然后点击保存。

茕若编译


导出矢量路径——茕若（侠客岛版权所有）

导出 > 导出矢量路径 > 拷贝和粘贴所选路径

拷贝和粘贴所选路径

使用 Copy as Vectors 可以将被选取的 Fireworks 路径复制到其他的程序，如 FreeHand，Flash，Adobe Photoshop，Illustrator，或者 CorelDRAW 中。

Copy as Vectors 只能够拷贝 Fireworks 路径。

拷贝选取的 Fireworks 路径：

1 | 选择 Edit -> Copy as Vectors（编辑 -> 复制为矢量）。
2 | 转到其他程序中打开着的文档。
3 | 把路径粘贴到其他程序中。

茕若编译


导出到 Dreamweaver 库中——茕若（侠客岛版权所有）

导出 > 导出到 Dreamweaver 库中

导出到 Dreamweaver 库中

Dreamweaver 库中的项目简化了编辑和更新 Web 站点内经常使用的组件的过程，例如一个浏览条。一个库项目属于 HTML 文档的一部分，它们存放在你站点根目录下一个名为 library 的目录中。这些项目会出现在 Dreamweaver 的 Library 面板中。你可以拖动一个复件将其放置在你网站的任何页面中。

在 Dreamweaver 文档中你不能直接的编辑库里项目。你只能编辑主库项目。然后，你可以在 Dreamweaver 中更新放置在你站点中的每个该项目的复件。

你也可以从 Fireworks 中导出 Dreamweaver HTML 文档。关于使用 Dreamweaver 文件的详情，请参阅 将 Fireworks 文件转入 Dreamweaver 中。

导出图形到 Dreamweaver 中：

1 | 选择 File -> Export（文件 -> 导出）。
2 | 从 Save as 弹出菜单中选择 Dreamweaver Library。
3 | 在你的 Dreamweaver 站点中选择一个库文件夹来放置你的文件。如果这不是一个库文件夹，Select Folder 对话框会出现，你可以使用它查找或创建文件夹。选择一个文件夹然后点击打开。
4 | 如果你的图像包含切割，选择切割选项。更多信息请参阅 导出切割。
5 | 选择 Put Images in Subfolder 来选择一个单独的文件夹保存图像。
6 | 点击保存。

茕若编译


导出到 Director——茕若（侠客岛版权所有）

导出 > 导出到 Director

导出到 Director

Fireworks 和 Director 的联合是十分强有力的。Fireworks 现在允许你导出图形到 Director 7 和 8 中，也可以重新导入 Director 的图形。导出的过程保留了图形中的行为与切割。你可以安全的导出那些带有 rollover 效果的切割图像和分层的图像。这会使得 Director 用户充分利用 Fireworks 的图形设计工具和优化功能。

导出图形到 Director 中：

1 | 选择 File -> Export（文件 -> 导出）
2 | 从 Save as 弹出菜单中选择 Director。
3 | 从 Source 弹出菜单中选择选项：
 | Fireworks Layers 导出文档中的每一个层。
 | Fireworks Slices 导出文档中的切割。
4 | 选择 Trim Images 来自动修整导出图像，使它与每一帧上的对象相适应。
5 | 选择 Put Images in Subfolder 来选择一个存放图像的文件夹。
6 | 在 Export 对话框中，输入一个文件名，选择存放的文件夹。点击保存。
 | 注：如果你的 Director 版本不支持导入 Fireworks 文档。在导入前安装 Fireworks Import Xtra for Director 插件。请转到 http://www.macromedia.com 来下载免费的 Fireworks Import Xtra for Director 插件。

茕若编译


导出到 Photoshop（侠客岛版权所有）

导出 > 导出到 Photoshop

导出到 Photoshop

将一个导入到 Photoshop 中的 Fireworks 图像再作为其他 Photoshop 图形重新导回到 Fireworks 时，其编辑属性仍会维持原样不变。有关编辑属性、外观和文件尺寸的导出选项使你可以为特定图形定义最合理的导出方法。Photoshop 用户可以导入 Fireworks 中建立的图形，然后在 Photoshop 中继续对其进行编辑。

导出图形到 Photoshop：

1 | 选择 File -> Export（文件 -> 导出）。
2 | 从 Save as 弹出菜单中选择 Photoshop PSD。
3 | 在 Setting 弹出菜单中选择以下一项：
 | Maintain Editability over Appearance 把对象转换到层上，保留可编辑的特效，然后转换文本到可编辑的 Photoshop 文本层中。
 | Maintain Fireworks Appearance 把每个对象转换到一个单独的 Photoshop 层中，把特效转换为对象，把文本转换为图像。
 | Smaller Photoshop File 把所有层都合并为一个全景图像。
 | Custom 允许你为对象、特效以及文本选择特定的设置选项。详情请参阅 为了导出到 Photoshop 将文件自定义。
4 | 在 Export 对话框中，输入文件名，选择保存目录，然后点击保存。
 | 注：Photoshop 5.5 及其早期版本不能打开拥有超过 100 个层的文件。如果你要导出的 Fireworks 文档包含超过 100 个对象，你就必须删除或合并一些层。

茕若编译


导出到 Photoshop——茕若（侠客岛版权所有）

导出 > 导出到 Photoshop > 为了导出到 Photoshop 将文件自定义

为了导出到 Photoshop 将文件自定义

当你导出一个文件到 Photoshop 中时，你可以为导出对象、特效和文本选择自定义设置。

为了导出到 Photoshop 自定义设置：

1 | 在 Export 对话框中，从 Settings 弹出菜单中择 Custom。
2 | 在 Objects 弹出菜单中选择下面一项：
 | Convert to Photoshop Layers 转换单独的 Fireworks 对象到 Photoshop 层中。
 | Flatten Each Fireworks Layer 将每个 Fireworks 层合并到一个Photoshop 层中。
3 | 在 Effects 弹出菜单中选择下面一项：
 | Maintain Editability 把 Fireworks 即时特效转换成 Photoshop 相对应的特效。如果在 Photoshop 中不包含这些特效，那么它们将被删除。
 | Render Effects 合并特效到对象中。这些特效不能在 Photoshop 中进行编辑。
4 | 在 Text 弹出菜单中选择下面一项：
 | Maintain Editability 转换文本到一个可编辑的 Photoshop 层中。Photoshop 中不支持的文本格式将被丢弃。
 | Render Text 将文本转换成一个图像对象。

茕若编译


导出 WBMP 格式——茕若（侠客岛版权所有）

导出 > 导出 WBMP 格式

导出 WBMP 格式

Wireless Bitmap（WBMP）是一种移动计算机设备使用的图形格式。这种格式特定使用于 Wireless Application Protocol（WAP）网页中。

将一个图形导出成为 WBMP 格式：

1 | 在 Optimize 面板，从 format type（格式类型）弹出菜单中选择 WBMP。
 | 注：因为这是一种 1-bit 格式，所以只有黑白两种颜色可见。
2 | 选择 File -> Export（文件 -> 导出）。
3 | 从 Save as type 弹出菜单中选择一种格式。通常选择 Images Only or HTML and Images。
4 | 在 Export 对话框中，输入文件名，选择存放目录，然后点击保存。

茕若编译


导出图像——茕若（侠客岛版权所有）

导出 > 导出图像

导出图像

当你在工作区中完成优化后使用 File -> Export（文件 -> 导出）来导出图形。这样做可以绕过导出预览对话框而直接打开 Export 对话框

Export dialog box（导出对话框）

导出图像：

1 | 选择 File -> Export（文件 -> 导出)。
2 | 选择存放 HTML 文件的地方。
 | 具有代表性的最佳的存放地方就是你自己的本地站点文件夹。
3 | 键入文件名。
4 | 从保存类型弹出菜单中选择 HTML and Images。
 | 注： 图像只能被导出成为图像，不可能被导出成为 HTML 文本。
5 | 如果你的图像包含切割，选择切割选项。详情参阅 导出切割。
6 | 选择 Put Images in Subfolder 来选择一个独立的文件夹来保存图像。如果你没有选择文件夹，你的图像将被放置在自动创建的名为 Images 的文件夹中。
 | 注：Fireworks 会自动在 HTML 文件和图像之间生成链接。
7 | 点击保存。

茕若编译


导出 Css 层——茕若（侠客岛版权所有）

导出 > 导出 Css 层

导出 Css 层

Cascading Style Sheets（CSS）允许你制作一个更小、更快速的网页。CSS 层使你可以创建定义不同的元素样式表，例如标题、链接和外观。这些都是导出用户经常使用的，他们可以在导出后使用它对 HTML 作进一步的处理。CSS 层可以与另一个 CSS 层相互重叠。通常在 Fireworks 中是不允许 HTML 重叠的。

将一个图形导出成为 CSS 层：

1 | 选择 File -> Export（文件 -> 导出）。
2 | 从 Save as type 弹出菜单中选择 CSS Layers。
3 | 在 Source 弹出菜单中选择下面中的一项：
 | Fireworks Layers 导出所有层作为 CSS 层。
 | Fireworks Frames 导出所有帧作为 CSS 层。
 | Fireworks Slices 导出文档中的切割作为 CSS 层。
4 | 选择 Trim Images 来自动调整导出图像和导出层使它们与对象尺寸相当。
5 | 选择 Put Images in Subfolder 来为图像选择存放目录。
6 | 在 Export 对话框中输入文件名，选择存放目录，然后点击保存。

茕若编译


导出到 Lotus Domino Designer——茕若（侠客岛版权所有）

导出 > 导出到 Lotus Domino Designer

导出到 Lotus Domino Designer

导出图像到 Lotus Domino Designer 中，结果会产生一个 GIF 或 JPEG 格式的图像文件。这要取决于你在导出前选择的优化设置。

导出图形到 Lotus Domino Designer 中：

1 | 选择 File -> Export（文件 -> 导出）。
2 | 从 Save as type 弹出菜单中选择 Lotus Domino Designer。
3 | 在 Source 弹出菜单中选择下面中的一项：
 | Fireworks Frames 把最上面的四个帧导入文件。
 | Fireworks Layers 把最上面的四个层导入文件。
 | Fireworks Slices 导出每个切割开始的四个帧作为一个单独的文件。
4 | 选择 Trim Images 来自动调整导出图像使它们与每个帧上的对象尺寸相当。
5 | 在 Export 对话框中输入文件名，选择存放目录，然后点击保存。

茕若编译


使用 Update HTML 命令——茕若（侠客岛版权所有）

导出 > 使用 Update HTML 命令

使用 Update HTML 命令

Update HTML（更新 HTML）命令用来更新 Fireworks 生成的 HTML 和图像，或是只更新图像。当你要更新 HTML 来保存你在 Dreamweaver 中所作的改变时，在 Dreamweaver 中使用 Launch and Edit 命令即可。

更新 HTML：

1 | 选择 File -> Update HTML（文件 -> 更新 HTML）。
2 | 从 Locate HTML File 对话框中选择要更新的文件。
3 | 点击打开。
4 | I如果没有发现 Fireworks 生成的 HTML，点击确定来在文档末尾插入新的 HTML。
5 | 如果发现了 Fireworks 生成的 HTML，选择下面一项并点击确认：
 | Replace Images and their HTML 替换以前的 Fireworks HTML。
 | Update Images Only 仅重写图像。
6 | Select Images Folder 对话框打开。选择一个文件夹来放置图像并点击打开。

茕若编译


使用 Update HTML 命令——茕若（侠客岛版权所有）

导出 > 使用 Update HTML 命令 > 编辑放置在 Dreamweaver 中的 Fireworks 图像

编辑放置在 Dreamweaver 中的 Fireworks 图像

在 Dreamweaver 中启动编辑图形就可以编辑放置在 Dreamweaver 中的 Fireworks 图像。在 Dreamweaver 内部编辑 GIFS 和 JPEGS 时，你既可以使用 Fireworks 的源文件，也可以在不影响源文件的情况下优化图像。

在你启动编辑前，确认你已将 Fireworks 作为你 Dreamweaver 的外部编辑程序。有关在 Dreamweaver 中使用 Fireworks 图像的详情，请参阅 编辑放置在 Dreamweaver 中的 Fireworks 文件。

在 Dreamweaver 中选择 Edit and Launch Fireworks 来更新 Fireworks 图形。要在其他的 HTML 编辑器中编辑原始的 Fireworks 源文件，你需要在 Fireworks 中选择 File -> Update HTML（文件 -> 更新 HTML）来更新 HTML 和图像。

茕若编译


使用 Update HTML 命令——茕若（侠客岛版权所有）

导出 > 使用 Update HTML 命令 > HTML 设置

HTML 设置

HTML Setup（HTML 设置）使你可以定义 Fireworks 如何导出 HTML 文档。这些设定既可以指定当前文档也可以被作为所有 HTML 文档导出的缺省设置来使用。那些在 Document Specific 标签中所作的更改仅对当前文档有效。General 和 Table 标签中设置的是通用的属性。

定义 Fireworks 如何导出 HTML 文档：

1 | 选择 File -> HTML Setup（文件 -> HTML 设置）或点击 Export 对话框的 Options 按钮。
2 | 在 General（常规）标签对下列选项进行选择：
 | 选择一个 HTML Style 来给导出的 HTML 文档设定样式。
 | 从 Extension 弹出菜单中选择一个文件扩展名或是键入一个新名。
 | 选定 Include HTML Comments 来在文档中包含关于从何处剪贴的注释。
 | 选定 Lowercase File Name 使 HTML 文件名、扩展名以及图像文件名在导出时小写。
 | 从 File Creator 弹出菜单中选择一个关联程序（Macintosh).。当你打开 HTML 文件时你指定的程序将自动打开。
3 | 在 Table（表格）标签中为你的 HTML 表格选择设置。有关如何定义要导出的 HTML 表格的详情，请参阅 HTML 设置。
4 | 在 Document Specific（文档设定）标签中你可以进行下列选择：
 | 在 Slice Auto-naming 弹出菜单中为自动命名切割选择一个规则。
 | 在 Alternate Image Description 文本框中键入文本。在你从 Web 下载图像时或是下载失败时这些文字将出现在图像占位符上。在一些浏览器中当鼠标经过图像时它也会出现在提示条中。这对那些视力不好的 Web 用户来说也是一个帮助。
 | 在使用不包含帧的 HTML 文档时选择 Multiple Nav Bar HTML Pages（多重导航栏 HTML 页面）。
5 | 点击 Set Defaults 把这些设定保存为你全局的缺省设置。
6 | 点击 OK。

茕若编译


导出结果——茕若（侠客岛版权所有）

导出 > 导出结果

导出结果

在你导出生成 HTML 的时候，Fireworks 会生成下面的文件来帮助你在网页上重建图像：

它会生成一个包含了重组切割图像或者创建 rollover 效果所必需的 JavaScript 和表格的 HTML 文件。Fireworks 所生成的 HTML 文件允许包含与导出图像的链接，以及将网页背景色设定为图像画布颜色或者图形的底色。
它会生成一个或多个图像文件，这取决于你在文档中创建了多少个切割，以及你给按钮或者 rollover 效果设置了多少种状态。
如果需要，它还会生成一个名为 Spacer.gif 的文件，这是一个透明的 1 x 1 pix 的 GIF 图像，当切割图像需要在 HTML 表格中重组的时候，Fireworks 用它来解决空格问题。你可以选择是否导出 spacer（分隔符）。详情请参阅 导出切割图像时使用空白表格单元或嵌套表格。

许多导出选项在导出过程中是可选的，这会影响到 Fireworks 导出文件的结果。例如导出你的文件到其他 Macromedia 应用程序（例如 Flash）时这些选项就都可选。 关于这些选项的详情请参阅本章后面章节。

茕若编译


使用导出向导进行导出——茕若（侠客岛版权所有）

导出 > 使用导出向导进行导出

使用导出向导进行导出

使用导出向导可以帮助我们一步一步地完成整个的导出程序。回答有关文件存放地点和用途等问题，然后导出向导就会对文件类型和优化设置提出建议。

如果你喜欢给优化文件设定一个文件尺寸的话，那么导出向导就会在优化过程中强制文件符合你所设定的尺寸。

Export Wizard（导出向导）

使用导出向导导出图形：

1 | 选择 File -> Export Wizard（文件 -&gr; 导出向导）。
2 | 回答每个面板上提出的问题，点击 Continue 去到下一个面板。
 | （Analysis Results）分析结果屏幕出现，同时提出有关文件格式的建议。
 | 注： 在第一个面板上选择 Target Export File Size（导出文件目标尺寸）可以为优化文件设定尺寸上限。
3 | 点击 Exit。
 | 在 Export Preview 窗口，2-Up Preview 窗口中会显示两个推荐的导出选项。
4 | 点击包含有你要使用的文件格式的预览区域。
5 | 如果需要，对优化设置进行更多的修改。
6 | 点击 Export 按钮。
7 | 在 Export 对话框中，输入文件的名字，选择切割选项和存放文件的文件夹，点击保存。

茕若编译


导出文件时进行优化和预览——茕若（侠客岛版权所有）

导出 > 导出文件时进行优化和预览

导出文件时进行优化和预览

Export Preview 对话框和四个导出图像预览窗口显示了大多数 Fireworks 的优化控制选项。Options 标签包含了所有的能在 Optimize 面板和 Color Table 面板中找到的优化控制项。有关优化图像的详情，请参阅 在工作区中进行优化。在 Export Preview 对话框中的 Animation（动画）面板上的选项也可以在 Frames 面板上找到。有关动画的详情，请参阅 使用帧进行工作。

Export Preview 对话框只优化那些不包含切割或所有切割使用同一设置的图像。要想优化那些使用不同设置的切割，你应使用 Optimize 面板。通过点击 Optimize to Size 向导 Export Preview 对话框允许你按目标限制尺寸导出图像。你也可以在 Optimize 面板上的 Options 弹出菜单中选择这个选项。

除了对优化进行控制以外，导出预览还有一个十分独特的用途。例如，在批处理过程中进行优化自定义设置时或是当你从 Dreamweaver 中打开 Fireworks 对其中的图像进行优化时，Export Preview 都会出现。

如何使用 Export Preview 对话框导出图形：

1 | 选择 File -> Export Preview（文件 -> 导出预览）。
2 | 选择导出和优化的选项设置。
3 | 点击 Export 按钮。
4 | 在 Export 对话框中，输入文件的名字，选择保存类型和文件存放文件夹，点击保存。

茕若编译


导出文件时进行优化和预——茕若（侠客岛版权所有）

导出 > 导出文件时进行优化和预览 > 在导出预览对话框中预览优化效果

在导出预览对话框中预览优化效果

对话框的预览区域会精确地显示图形根据当前的导出设置导出后的效果，预计的文件大小，下载时间等。

你可以使用分割查看的方式比较不同设置，找到一个文件最小而图像质量也可接受的方案。你还可以在 Export Preview 对话框中使用 Optimize to Size 向导来限制文件的大小。

在导出 GIF 动画或者 JavaScript rollover 效果时，预计的文件大小是包括图像所有帧的大小。

注： 要想加快 Export Preview 的刷屏速度，就取消 Preview 选项。如果你想在进行设置修改的时候停止预览刷屏，敲击 Esc 键。

在 Export Preview 对话框中预览优化效果：

1 | 选择 File -> Export Preview（文件 -> 导出预览）。
2 | 要想在预览窗口放大或缩小，选择 Zoom 工具。点击可以放大预览图形。按住 Alt（Windows）或 Option（Macintosh）键点击可以缩小预览图形。
3 | 要想改变查看区域，选择 Pointer 工具在预览窗口拖动即可，或者按住空格键在预览窗口拖动也可以。
 | 当多个查看区域同时打开的时候，所有的预览图形都会被缩放到同样大小，而其所有的预览图形都会同步摇动，以显示图像的同一部分。
4 | 如果你想在 Export Preview 对话框中比较不同的优化设置，你可以点击一个 split-view（分割查看）按钮，将预览窗口分成两个或者四个。
 | 每个预览窗口都可以显示一个不同导出设置的图形。
5 | 如果你想在一个限定的文件大小的范围内优化图形，可以点击 Optimize to Size 向导。输入一个kb单位的文件尺寸。
 | Optimize to Size 向导会使用下边这些方法来尝试满足文件尺寸的要求：
 | 调整 JPEG 图像的质量
 | 修改 JPEG 图像的平滑度
 | 修改 8-bit 图像的颜色数。
 | 改变 8-bit 图像的抖动设置
 | 启用或禁用优化设置

茕若编译


将文档中的帧或层导出成为多个文件——茕若（侠客岛版权所有）

导出 > 将文档中的帧或层导出成为多个文件

将文档中的帧或层导出成为多个文件

Fireworks 能够使用一个单独的导出命令就将同一文档中的所有层或帧都导出为单独的图形文件。每个帧或层都会被导出成为一个使用 Optimize 面板中指定的优化设置的独立图像文件。层或帧的名字决定了每个导出文件的名字。

将帧或层导出成为多个文件：

1 | 选择 File -> Export（文件 -> 导出）。
2 | 选择以下一项：
 | 要想将帧导出成为多个文件，选择 Frames to Files。
 | 要想将层导出成为多个文件，选择 Layers to Files。
 | 注：文件导出的是当前帧上的所有层。
3 | 选择 Trim Images（修整图像）可以自动对导出图像进行修剪以适应每帧的对象。
 | 如果你想让导出的帧或层与文档尺寸相当，就取消对 Trim Images 的选择。
4 | 选择一个存放位置，然后点击保存。

茕若编译


导出图形的一部分——茕若（侠客岛版权所有）

导出 >导出图形的一部分

导出图形的一部分

使用 Export Area（导出区域）工具来导出 Fireworks 图形的一部分。

导出文档中的一部分：

1 | 从 Tools 面板中选择 Export Area 工具。
2 | 拖出一个选框定义出文档中要导出的部分。
 | 释放鼠标键之后，导出区域保持被选状态。
3 | 按需求调整导出区域大小：
 | 按住 Shift 键拖动控制柄可以保持宽高比例的情况下调整导出区域。
 | 按住 Alt（Windows）或 Option（Macintosh）键拖动控制柄可以从中心点开始调整导出区域。
 | 按住 Alt+Shift（Windows）或 Option+Shift（Macintosh）键拖动控制柄可以在保持宽高比例不变的情况下从中心点开始调整导出区域。
 | 使用方向键可以移动选框。按住 Shift 键的同时使用箭头键也可以调整选框大小。
4 | 双击导出区域选框内部来打开 Export Preview 对话框。
5 | 在 Export Preview 对话框中调整导出设置，点击 Export 按钮。
6 | 在 Save as 探出菜单中选择 Images Only。
7 | 在 Export Preview 对话框中，输入文件名字，选择存放文件夹，点击保存。
 | 注：要想取消导出，双击导出区域选框外边，敲击 Esc 键，或者选择其它工具。

茕若编译


导出切割——茕若（侠客岛版权所有）

导出 > 导出切割

导出切割

有些网络设计者创建出图形之后，再把图形切成的若干部分。这个过程叫做切割。切割有时是十分有用的。例如，当你想要把图像的一部分导出成为 GIF，另一部分导出成为 JPEG 时，使用切割就可以充分发挥每种格式的优势。这些切割后的部分日后在网页中可以利用 HTML 表格进行重组。有关切割的详细介绍，请参阅 创建切割。

使用 Export Preview 对话框允许你在导出过程中优化切割。但是，在 Export Preview 对话框中只允许你使用新的同一设置优化所有切割。事实上你可以在工作区中优化单独的切割，详情请参阅 在工作区中进行优化。

导出选定切割：

1 | 确定切割的优化设置：
 | 选择 File -> Export（文件 -> 导出），这样将不进行其他的优化设置。
 | 选择 File -> Export Preview（文件 -> 导出预览），这样可以先更改优化设置，然后再点击 Export。
2 | 选择一个切割方法：
 | None 选项会阻止你导出切割，即使你再文档中绘制了切割也一样。
 | Export Slices 导出由切割对象定义的切割。选择 Include Areas without Slices 来导出切割和图形。如果你在导出前选择了单个的切割，选定 Selected Slice Only 项就会只导出你选择的切割。
 | Slice Along Guides 导出由现有辅助线定义的切割。
3 | 在 Export 对话框中，输入一个文件名，选择存放文件夹，然后点击保存。
 | 每个导出的切割都可以有自己独特的优化设置，这些设置都是你在 Optimize 面板上为每个切割定义的。
 | 注：为了导出一个单独的选定切割，右击（Windows）或按住 Control 键点击（Macintosh）然后选择 Export Selected Slice（导出选定切割）。

茕若编译


结合Dreamweaver,Fireworks概述--蓝骑士（侠客岛版权所有）

结合Dreamweaver和Fireworks > 结合Dreamweaver,Fireworks概述

结合Dreamweaver,Fireworks概述

独特的结合特性使得应用Macromeida Dreamweaver 4 和 Fireworks 4进行交互协作制作网页,对于您而言将非常的得心应手.Dreamweaver 和 Fireworks能够共享和管理HTML文件中的许多内容,例如链接,图像地图,切片,网页特效等等.使用Dreamweaver 和 Fireworks将大大提高您网页设计和编辑的效率,结合两者为您提供了一个高效的工作流程.

如果您希望在Dreamweaver中修改Fireworks生成的图像和表格,你可以调用Fireworks进行修改,修改后的内容将自动在Dreamweaver中完成更新,这样,您就不需要再手工的一点点重新整理和编辑了.如果您仅仅需要优化一下图像,您可以快速的调用Fireworks提供的图像优化对话框(而不必打开图像软件),输入新的设置,简单快捷的完成图像的优化.

蓝骑士编译


在Dreamweaver中应用Fireworks文件--蓝骑士（侠客岛版权所有）

结合Dreamweaver和Fireworks > 在Dreamweaver中应用Fireworks文件

在Dreamweaver中应用Fireworks文件

您可以使用不同的方式在Dreamweaver中通过插入(insert)命令放置Fireworks图像文件或HTML文件.在Fireworks中,您也可以通过输出(export)命令,直接将文件放置到Dreamweaver定义的站点文件夹中,提供Dreamweaver的后续调用.

在Dreamweaver中插入Fireworks图像

您可以在Dreamweaver中直接插入Fireworks生成的GIF, JPEG, 或 PNG 图像.

插入Fireworks图像:

1 | 在Dreamweaver文件中,将光标放置在您需要插入图像的位置.
2 | 选择下列的一项操作:
 | 选择菜单 Insert -> Image (插入 -> 图像).
 | 点击对象面板的"一般类别"中的"插入图像"按钮(Objects panel: Common category:Insert Image).
3 | 在弹出的对话框中选择您希望插入的Fireworks图像,点击 Open(打开) 按钮.
 | 如果您选择的Fireworks图像不在当前的Dreamweaver站点中,Dreamweaver将弹出信息框,询问是否将文件复制到当前站点下.

在Dreamweaver中插入Fireworks的HTML文件

您可以在Dreamweaver中插入Fireworks的HTML文件.Fireworks的HTML文件中包括了关联的图像链接,切片信息,和javascipt脚本语言.插入HTML文件使您在Dreamweaver页面中非常方便的加入Fireworks生成的图像和网页特效.

插入Fireworks HTML文件:

1 | 在Dreamweaver中,首先在您的站点中保存当前文件.
2 | 将光标放置在你希望插入HTML文件的地方.
3 | 选择下列的一项操作:
 | 选择菜单Insert -> Interactive Images -> Fireworks HTML (插入 -> 交互图像 -> Fireworks HTML).
 | 点击对象面板的"一般类别"中的"插入Fireworks HTML"按钮(Objects panel: Common category:Insert Fireworks HTML).
4 | 在弹出对话框,点击 Browse(浏览) 选择您希望的Fireworks HTML文件.
5 | 如果选中对话框下的Delete File After Insertion(插入后删除文件)选项,HTML文件插入页面后,源文件将被删除(放入垃圾箱 Recycle Bin (Windows操作系统) 或 垃圾箱 Trash (Macintosh操作系统).
 | 使用该选项前请确认您不再需要使用源HTML文件.该选项不影响图像文件.仅仅删除单独的HTML源文件.
 | 注: 如果HTML源文件在网络驱动器(network drive),将被永久删除,不会放入垃圾箱.
6 | 点击 OK 按钮插入HTML文件.插入时包含了HTML源文件关联的图像,切片和JavaScript脚本语言.

在Dreamweaver中复制和粘贴Fireworks HTML文件

一个快速的方法是直接复制和粘贴Fireworks HTML文件.

复制和粘贴Fireworks HTML文件:

1 | 在Fireworks中,选择菜单 Edit -> Copy HTML Code (编辑 -> 复制HTML源代码).
2 | 按照向导完成设置.
 | 向导将图像输出到您的文件夹,将HTML源代码复制到剪贴板.
3 | 在Dreamweaver中,将光标放置在你希望插入Fireworks HTML文件的地方,选择 Edit -> Paste (编辑 -> 粘贴).
 | 所有的HTML源文件中关联的图像和JavaScript脚本语言都默认的输入到Dreamweaver文件中.图像的链接自动完成更新.

输出和粘贴Fireworks HTML文件到Dreamweaver:

1 | 在Fireworks中, 选择 File -> Export (文件 -> 输出).
2 | 在输出对话框中,确定您输出文件和图像的Dreamweaver站点下的相关文件夹.
3 | 在Save as(另存为)的下拉框中选择HTML and Images格式.
4 | 在HTML的下拉框中选择Copy to Clipboard 方式.
5 | 在Dreamweaver中,将光标放置在你希望插入Fireworks HTML文件的地方,选择 Edit -> Paste (编辑 -> 粘贴).
 | 所有的HTML源文件中关联的图像和JavaScript脚本语言都默认的输入到Dreamweaver文件中.图像的链接自动完成更新.

输出Fireworks文件到Dreamweaver

Fireworks中的File -> Export命令让您可以输出和保存优化后的图像以及HTML文件到您希望的Dreamweaver站点相关文件夹下.您可以在Dreamweaver打开输出后的文件进行编辑.

您可以选择将Fireworks文件输出为CSS样式表层(Cascading Style Sheet layers)或Dreamweaver的库文件.(Dreameraver库文件一般包含站点页面中经常使用或经常更新的一些对象,例如导航栏等.库对象实际上是一段对应的HTML代码,存放在固定命名为Library的文件夹下.你可以简单的在页面编辑时,拖拽使用库对象.)

输出Fireworks图像和HTML文件:

1 | 在Fireworks中,选择菜单 File -> Export (文件 -> 输出).
2 | 在Save as(另存为)的下拉框中选择HTML and Images格式.
3 | 在HTML的下拉框中选择Export HTML File 方式.
4 | 确定输出的Dreamweaver站点下的文件夹.
5 | 点击 Save 按钮输出文件.

输出Fireworks文件为CSS样式表层:

1 | 在Fireworks中,选择菜单 File -> Export (文件 -> 输出).
2 | 在Save as(另存为)的下拉框中选择CSS Layers (.htm)格式.
3 | 确定输出的Dreamweaver站点下的文件夹.
4 | 点击 Save 按钮输出文件.

输出Fireworks文件为Dreamweaver的库对象:

1 | 在Fireworks中,选择菜单 File -> Export (文件 -> 输出).
2 | 在Save as(另存为)的下拉框中选择Dreamweaver Library (.lbi)格式.
3 | 选择Dreamweaver站点根目录下的Library文件夹输出.
 | 如果您还没有Library文件夹,Fireworks询问是否创建.
4 | 点击 Save 按钮输出文件.

蓝骑士编译


在Dreamweaver中调用Fireworks--蓝骑士（侠客岛版权所有）

结合Dreamweaver和Fireworks > 在Dreamweaver中调用Fireworks

在Dreamweaver中调用Fireworks

你可以在Dreamweaver中直接调用Fireworks对Fireworks生成的图像,切片,表格进行编辑和处理.调用Fireworks您需要在Dreamweaver中将Fireworks设为主扩展图像编辑器.

在Dreamweaver中将Fireworks设置为主扩展图像编辑器

Dreamweaver 4 提供了属性设置,可以决定编辑Dreamweaver页面中的图像所使用的软件.如果您希望能在Fireworks中编辑对网络图像格式GIF,JPEG,PNG进行快速编辑,您需要对应的将这几种格式的主图像编辑器设为Fireworks.

如果您使用的是Fireworks 4以前的版本,在Dreamweaver中进行扩展图像编辑将有影响.Fireworks 3不支持表格和切片的编辑.Fireworks 2不支持PNG格式的编辑.

在Dreamweaver 4中将Fireworks 4设置为主扩展图像编辑器:

1 | 在Dreamweaver中,选择菜单 Edit -> Preferences (编辑 -> 属性),选择 Types/Editors(类型/编辑器).
2 | 在Extensions(文件扩展名)列表中,选择网络图像格式(.gif, .jpg, or .png).
3 | 在Editors(编辑器)列表中,选择Fireworks 4,点击 Make Primary(设为主编辑器) 按钮.
4 | 重复2,3步骤,你可以对其他文件格式进行设置.

关于设计注释和源文件

当您在Fireworks中将源PNG文件按照一定形式(例如 Image and HTML)输出到Dreamweaver站点,Fireworks会自动添加输出文件的设计注释(Design Note).注释中包含了相关的信息,也包含了与源PNG文件的关联.

当您在Dreamweaver对Fireworks输出的文件进行编辑,Dreamweaver通过设计注释,自动调用源PNG图像.所以,建议您将网络图像源PNG文件一起保存在您设计的站点下.这样,下次对页面相应的Fireworks文件进行修改时,或者是小组远程协作时,Fireworks总能正确的找到并打开源PNG文件进行编辑,更新页面.

对Fireworks的源PNG文件进行调用和编辑属性的设置

设置Fireworks的调用和编辑(launch-and-edit)属性可以让您定义在其他应用程序,例如Macromedia Director或Dreamweaver,打开源PNG的方式.

定义Fireworks调用和编辑(launch-and-edit)属性:

1 | 在Fireworks中,选择菜单 Edit -> Preferences(编辑 -> 属性),点击 Launch and Edit (调用和编辑)标签(Windows操作系统) 或在下拉框中选择 Launch and Edit(调用和编辑)(Macintosh操作系统).
2 | 定义在外部应用程序编辑和优化Fireworks文件时,源PNG的属性:
 | Always Use Source PNG(总是使用源文件) 在外部程序中,调用Fireworks编辑Fireworks文件时,通过设计注释自动调用源PNG文件.编辑后同步更新外部程序中的图像和源PNG.
 | Never Use Source PNG(不使用源文件) 在外部程序中,调用Fireworks编辑Fireworks文件时,不使用源文件(所以可以没有源PNG).编辑后仅仅对外部应用程序中的Fireworks文件更新,不改变源PNG.
 | Ask When Launching(调用时询问) 在外部程序中,调用Fireworks编辑Fireworks文件时,显示对话询问..

蓝骑士编译


在Dreamweaver中编辑Fireworks文件--蓝骑士（侠客岛版权所有）

结合Dreamweaver和Fireworks > 在Dreamweaver中编辑Fireworks文件

在Dreamweaver中编辑Fireworks文件

您可以在Dreamweaver直接调用Fireworks编辑Fireworks生成的文件.完成编辑后,自动在Dreamweaver中进行更新.

Fireworks能够识别和保护在Dreamweaver中已经对Fireworks文件做过的改动,例如链接,图像地图,文字切片等等.利用Dreamweaver的属性监测器(Property inspector)您可以观察哪些内容属于Fireworks文件.例如,Fireworks生成的表格将在属性监测器中明确显示"Fireworks Table".

编辑Fireworks生成的图像

您可以在Dreamweaver中调用Fireworks编辑图像.

在Dreamweaver中调用和编辑Fireworks生成的图像:

1 | 在Dreamweaver中,选择菜单 Window -> Properties (窗口 -> 属性),打开属性监测器.
2 | 选择下列的一项操作:
 | 选择图像(属性监测器将确认图像是否是Fireworks文件,如果是Fireworks生成的图像,显示关联的源PNG文件名).在属性监测器点击 Edit(编辑) 按钮.
 | 按住 Control 键(Windows操作系统) 或 Command 键(Macintosh操作系统), 双击您希望编辑的图像.
 | 鼠标右键(Windows操作系统) 或鼠标Control键 (Macintosh操作系统)点击您希望编辑的图像,在弹出菜单中选择 Edit With Fireworks 4 (使用Fireworks 4编辑).
 | 如果此时您没有正在使用Fireworks,Dreamweaver将自动调用Fireworks.
3 | 如果有弹出信息框,请确认打开源PNG的方式.
4 | 在Fireworks中编辑图像.Fireworks文件窗口显示您当前正在编辑Dreamweaver中的图像.
 | Fireworks将识别和保存此前在Dreamweaver中对Fireworks文件做过的修改.
5 | 当您完成编辑后,点击文件窗口中的 Done 按钮进行相应的Dreamweaver更新.
 | 点击 Done 将更新Dreamweaver的图像.更新后的图像使用此时Fireworks中的优化面板设置的格式和属性进行输出.
 | 注: 如果您在Dreamweaver的站点(Site)窗口打开图像文件进行编辑,上述提到的Dreamweaver和Fireworks的一些协作属性将不起作用.即使该图像文件时Fireworks生成的文件并且有关联的源PNG,Fireworks也不会打开源PNG.使用Dreamweaver和Fireworks的协作特性仅在Dreamweaver的文件窗口产生作用.

编辑Fireworks生成的表格

当您调用Fireworks编辑Fireworks生成的表格的一部分,例如其中的某一个切片,Fireworks自动调用源PNG打开整个表格进行编辑.

在Dreamweaver中调用和编辑Fireworks生成的表格:

1 | 在Dreamweaver中,选择菜单 Window -> Properties (窗口 -> 属性),打开属性监测器.
2 | 选择下列的一项操作:
 | 在您希望编辑的表格内部点击一下,选择Dreamweaver文件窗口左下角的状态栏里的 TABLE 标签选中整个表格.(属性监测器将确认表格是否是Fireworks文件,如果是Fireworks生成的表格,显示关联的源PNG文件名).在属性监测器点击 Edit(编辑) 按钮.
 | 点击表格的左上角表格边框选中表格(属性监测器将确认表格是否是Fireworks文件,如果是Fireworks生成的表格,显示关联的源PNG文件名).在属性监测器点击 Edit(编辑) 按钮.
 | 选择表格中您希望编辑的切片(属性监测器将确认表格是否是Fireworks文件,如果是Fireworks生成的表格,显示关联的源PNG文件名).在属性监测器点击 Edit(编辑) 按钮.
 | 按住 Control 键(Windows操作系统) 或 Command 键(Macintosh操作系统), 双击您希望编辑的Fireworks生成的切片.
 | 在您希望编辑的切片上点击鼠标右键 (Windows操作系统) 或 鼠标控制键 (Macintosh操作系统),在弹出菜单中选择 Edit With Fireworks 4 (使用Fireworks 4 编辑)命令.
 | 如果此时您没有正在使用Fireworks,Dreamweaver将自动调用Fireworks. 与表格关联的源PNG文件自动在文件窗口打开.
3 | 在Fireworks中编辑图像.Fireworks文件窗口显示您当前正在编辑Dreamweaver中的图像.
 | Fireworks将识别和保存此前在Dreamweaver中对Fireworks文件做过的修改.
4 | 当您完成编辑后,点击文件窗口中的 Done 按钮进行相应的Dreamweaver更新.
 | 点击 Done 按钮将按照当前的优化设置和属性设置输出HTML和切片文件,自动在Dreamweaver的文件中更新,并保存修改后的PNG文件.

蓝骑士编译


优化Dreamweaver中Fireworks生成的图像--蓝骑士（侠客岛版权所有）

结合Dreamweaver和Fireworks > 优化Dreamweaver中Fireworks生成的图像

优化Dreamweaver中Fireworks生成的图像

您可以在Dreamweaver中快速调用Fireworks的图像输出设置功能,而不必打开整个Fireworks.Fireworks的图像输出设置功能提供了诸如图像格式设置,优化属性设置,动画属性设置,文件大小设置等非常简洁和使用的图像输出处理功能,大大方便了随时对图像进行的一些网络适用性调整.

在Dreamweaver中改变Fireworks图像的优化设置:

1 | 在Dreamweaver中,选择您希望处理的图像,选择菜单 Commands > Optimize Image in Fireworks (命令 -> 使用Fireworks优化图像).
2 | 如果有弹出信息框,确认是否调用源PNG图像进行修改.
3 | 在Fireworks的输出设置对话面板中,设置图像优化属性:
 | 设置优化属性,请选择 Options(选项)标签. 更多信息,请参看 输出时进行优化设置和预览.
 | 设置文件尺寸属性,请选择 File(文件)标签. 更多信息,请参看 调整Fireworks图像尺寸.
 | 设置动画文件属性,请选择 Animation(动画)标签. 更多信息,请参看 编辑Fireworks动画文件.
4 | 当您完成图像的设置,点击 Update(更新) 按钮完成修改.
 | 点击 Update(更新) 按钮将自动更新Dreamweaver里的图像文件,如果您使用了源PNG文件进行修改,自动保存修改后的 .
 | 如果您改变了图像的格式,例如将图像从GIF格式变为JPEG格式,Dreamweaver链接检测器将检测到文件名的改动,并弹出对话框询问是否相应的修改链接.在弹出对话框中选择 OK ,Dreamweaser自动完成链接的修改.如果您将一幅命名为 my_image.gif 的图像改为 my_image.jpg,则整个站点中,与 my_image.gif 相关的链接将自动更改为 与 my_image.jpg 的链接.

调整Fireworks图像的尺寸

在Dreamweaver中调用Firewokrs图像输出设置功能,您可以调整图像的尺寸.

修改图像尺寸:

1 | 在Fireworks的输出设置对话面板中,选择 File(文件) 标签.
2 | 您可以按照百分比或者输入数值调整图像尺寸.选中 Constrain(约束) 选项将等比例的调整图像.
3 | 选中下方的 Export Area (输出区域)选项,您可以定义输出图像在Dreamweasver中显示:
 | 拖动预览窗口中的图像控制柄,调整输出的区域
 | 在文本框中输入数值,定义输出区域.

调整动画属性设置

您也可以对Dreamweaver中Fireworks生车各动画文件通过优化命令进行属性调整.调整时与使用Fireworks Frames(影格)面板一致.

编辑动画文件:

1 | 在Fireworks的输出设置对话面板中,选择 Animation(动画) 标签.
2 | 选择下列的一种方式预览动画效果:
 | 显示单影格影像.在左放的影格列表中选择该影格.或者在右下方的动画控制栏中选择.
 | 显示动画.点击右下角的动画控制栏中的 Play/Stop (播放/停止)控制按钮.
3 | 编辑动画:
 | 点击垃圾箱图标在弹出菜单中设置影格处理方式..
 | 设置影格延迟时间.选择您希望设置的影格,在时间数值输入文本框中,输入数值.数值以1/100秒为单位.
 | 设置动画的循环属性,点击 Looping(循环) 按钮,在弹出菜单中选择数值.
 | 设置 Auto-Crop(自动剪切)功能对动画前后影格进行自动判别,影像相同的区域合并,不同区域单独输出.这将减小文件的大小.
 | 设置 Auto-Difference(自动区别)功能,动画按照前后影格中像素的改变输出,像素相同的合并,不同的单独输出.这将减小文件的尺寸.

蓝骑士编译


更新Dreamweaver中Fireworks生成的HTML代码--蓝骑士（侠客岛版权所有）

结合Dreamweaver和Fireworks > 更新Dreamweaver中Fireworks生成的HTML代码

更新Dreamweaver中Fireworks生成的HTML代码

在Fireworks中选择菜单 File -> Update HTML (文件 -> 更新HTML)命令.Fireworks自动将Dreamweaver中使用的关联的图像或表格进行代码更新.更新HTML命令使您对源PNG的修改能直接应用到源PNG对应的网页中去,而不必再对页面进行编辑.该命令也可以在Dreamweaver没有打开的情况下进行.

更新Dreamweaver中使用的Fireworks HTML代码:

1 | 在Fireworks中,选择菜单 File -> Update HTML (文件 -> 更新HTML).
2 | 在弹出窗口中找到您需要更新的页面,点击 Open(打开)确定.
3 | 确定您保存图像文件的文件夹,点击 Choose(选中)确定.
 | Fireworks自动更新Dreamweaver中对应的 HTML 和 JavaScript 代码.
 | 如果Fireworks无法在单前页面更新 HTML 代码(有可能该页面文件不包含Fireworks文件),它将给出在Dreamweaver文件中插入HTML代码的选项.默认的,Fireworks将JavaScript代码放在页面的起始部分,HTML代码在页面的尾部.

蓝骑士编译


创建网页相册--蓝骑士（侠客岛版权所有）

结合Dreamweaver和Fireworks > 创建网页相册

创建网页相册

在Dreamweaver中应用创建网页相册命令让您可以快速创建一个相册站点.这一命令通过Javascript调用Fireworks处理选中文件夹下的一系列图像,创建缩略图和大图.并自动完成缩略图与大图的链接,完成页面.使用创建网页相册,您必须在系统中安装有Dreamweaver和Fireworks.

在您开始创建前,请先将需要处理的图像统一放在一个文件夹下(该文件夹可以不在站点内),并确认图像的扩展名为(.gif, .jpg, .jpeg, .png, .psd, .tif, 或 .tiff)之一.不在上述格式的图像文件不会包含在网页相册中.

创建网页相册:

1 | 在Dreamweaver中,选择菜单 Commands -> Create Web Photo Album (命令 -> 创建网页相册).
2 | 在 Photo Album Title(相册标题)文本框中,输入标题.标题将显示在缩略图页面上部的灰色背景的表格中.
 | 如果需要,您还可以在Subheading Info(子标题)和 Other Info (其他信息)文本框中添加补充文字说明.
3 | 点击Source Images Folder(源图像文件夹)后的 Browser (浏览)按钮选择相册的源图像文件夹.点击 Destination Folder(目标文件夹)后的 browser 按钮选择保存HTML和处理后图像的文件夹.
 | destination folder(目标文件夹)不能已经包含网页相册文件;如果包含,新创建的相册图像如果和原来相册图像重名,将发生覆盖.
4 | 确定缩略图的属性:
 | 在 Thumbnail Size(缩略图尺寸)下拉框中选择缩略图尺寸大小.缩略图按照源图像的百分比放缩到这里定义的尺寸范围.(不一定充满单元格)
 | 选择Show Filenames(显示文件名)将在缩略图下显示相应的文件名.
 | 输入列的数值决定缩略图表格的列数.
5 | 在 Thumbnail Format(缩略图格式)下拉框中选择缩略图文件格式:
 | GIF WebSnap 128 128色网络安全色GIF格式.
 | GIF WebSnap 256 256色网络安全色GIF格式.
 | JPEG - Better Quality JPEG高品质格式.
 | JPEG - Smaller File JPEG小文件格式.
6 | 在 Photo Format(图像格式) 下拉框中选择大图保存格式.大图由源图像处理获得.
 | 注: 创建网页相册不使用源图像直接作为大图显示是因为GIF,JPEG外的其他一些图像格式不能在浏览器中正确显示. 另外,对于源图像是GIF,JPEG,进行再压缩等处理会降低一定的图像品质.
7 | 选择 Scale(放缩)百分比决定是否对源图像进行放缩处理获得大图.
 | 设置100%将创建于源图像尺寸相等的大图.注意,放缩的设定将对每一张图像作用.
8 | 选择 Create Navigation Page for Each Photo(为每一幅图像创建浏览页)将为每一幅图像创建单独的浏览页,其中自动包括 Back(上一页), Home(返回), Next(下一页)的导航链接.
 | 如果您选中该选项,缩略图将指向单独的大图页面,否则,缩略图指向大图.
9 | 点击 OK 创建网页相册.
 | 如果此时Fireworks没有打开,Dreamweaver自动启动Fireworks进行图像处理. 档图像处理结束,Dreamweaver完成缩略图页面.
10 | 当弹出信息框提示"Album Created"(相册完成),您可以点击 OK.此时在缩略图页面中显示相册缩略图表格.缩略图按照文件名排列.

注: 当图像处理开始后在Dreamweaver创建相册面板上点击 Cancel 按钮并不能停止处理过程,而仅仅取消相册页面的建立.

蓝骑士编译


自动化重复任务概述（侠客岛版权所有）

自动化重复任务 > 自动化重复任务概述

自动化重复任务概述

网络设计师经常受重复任务的苦，比如将图象优化或转变以适应一定的要求。Fireworks的威力之一就是他自动操作和简化一些枯燥单调的绘制，编辑，文件转化任务的能力。

要加快你的编辑进程，使用Find and Replace来在一个或多个文件中查找和替换某元素。你可以查找和替换例如：URLs、字体、颜色、文字、以及在历史面板中创建的命令。

使用Batch Process（批处理）来成批转换图象文件或者他们的调色板。批处理可以为一组文件提供自定义优化设置。你还可以批量改变文件尺寸，使批处理成为做略图的理想工具。

使用历史面板来创建常用对象特性的快捷键或者创建可以完成一系列复杂操作的脚本。Fireworks可以理解并执行 JavaScript，所以高级用户可以通过写JavaScript命令并在Fireworksz中执行的方式来自动完成很复杂的任务。你可以控制几乎每个Fireworks命令，或者用 JavaScript命令进行设置。


批处理（侠客岛版权所有）

自动化重复任务 > 批处理

批处理

批处理是自动转变一组图象文件的便捷方式。在批处理时，从以下选项中选择：

将选中的文件转化为其他格式。
将选中的文件转化为相同格式，但是优化设置。
改变输出文件图象大小。
查找和替换URLs、字体、颜色、文字和非网络安全色
通过加前缀和后缀将一组文件重命名（很不错的功能哦*^_^*）
对所选文件执行commands命令.

要进行批处理:

1 | 选择 File >批处理（Batch Process）.
2 | 选择要进行批处理的文件. 从不同文件夹选择文件, 或者通过文件类型来将他们聚集在一起。
 | 增加（add） 增加所选文件和文件夹到批处理文件列表. 如果文件夹被选中，其中所有有效的可读的文件都被加到批处理中来.
 | 注意: 有效的文件是指已经创建、命名、保存的文件. 文件的最新状态没有被保存，你会被要求保存这个文件，然后可以继续进行批处理. 如果你不保存该文件，整个批处理 进程灰终止.
 | 增加全部（Add All）在当前选中的文件夹中增加全部有效的文件到批处理文件列表
 | 移除（Remove）从批处理文件列表移除所选文件。
3 | 选择"include files from Project Log（包括项目日志中文件）" 来增加全部项目日志里的文件。 这些文件不会出现在批处理文件列表中，但是被包含在批处理进程中。
4 | 选择"include Current Open files（包括当前打开文件”来增加全部当前打开文件。这些文件不会出现在批处理文件列表中，但是被包含在批处理进程中
5 | 点击下一步.
6 | 要在批处理中加一个任务， 在批处理选项列表中选择 Add.
 | 每个任务仅可添加一次， commands除外.
7 | 要将列表重新排序, 选择批处理包含列表中的任务并点击升序降序按钮。
 | 注意: 显示在批处理包含列表中的任务的顺序就是这些任务在批处理中执行的顺序。
8 | 选择批处理包含列表中的一个任务来查看该任务的附加选项。 根据需要选择每个选项的设置。
9 | 要从批处理包含列表中的任务中移除一个任务，选择批处理包含列表中包含的任务，并点击移除（Remove）.
10 | 点击 Next.
11 | 选择批处理过的文件的保存选项:
 | 和原始文件同一地点将文件存在和原始文件相同的地点，如果文件名和原来一样，而且文件格式一样就覆盖原始文件。
 | 自定义地点 让你选择在哪里保存批处理过的文件。
12 | 选择备份（Backups） 来选择原始文件的备份选项. 备份原来的文件总是比较安全。有关的更多信息，见 备份批处理过的文件.
13 | 点击保存脚本（ Save Script ）来作为一个脚本保存. 有关的更多信息，见 将批处理保存为脚本.
14 | 点击保存你的批处理脚本.


批处理（侠客岛版权所有）

自动化重复任务 > 批处理 > 改变批处理优化设置

改变批处理优化设置

在批处理对话框里添加输出（Export）以改变文件优化设置。

在批处理进程中设置文件的输出设置应用:

1 | 从设置弹出菜单中选择一个选项:
 | 使用每个文件自身的设置（Use Settings from Each File） 在批处理过程中保持每个文件原来的输出设置. 比如, 在批处理含有 GIF和 JPEG图象的文件夹时,输出结果仍然是GIF和 JPEG图象，而且仍然使用原始的调色盘和压缩设置。
 | 自定义（Custom） 让你为批处理输入自定义的输出设置，或者你可以选择编辑在输出预览对话框输入各种设置，点击 OK.
2 | 选择预设的输出设置，比如GIF安全色216(GIF Web 216)或者高质量JPEG(JPEG - Better Quality).所有文件都会转化为这种设置
3 | 点击 Next 继续批处理.


批处理（侠客岛版权所有）

自动化重复任务 > 批处理 > 用批处理改变图片大小

用批处理缩放图片大小

在批处理对话框里添加缩放（Scale）以改变图片输出的宽和高。

设置批处理文件的缩放属性.

1 | 在缩放弹出菜单中选择一个选项:
 | 选择不缩放(No Scaling)保持输出文件大小不变。
 | 选择按尺寸缩放（Scale to Size）并键入宽和高，使图象按精确的宽和高缩放。
 | 选择适应范围（ Scale to Fit Area）并键入最大宽度和高度值，使图片在这个特定最大范围内合适的缩放大小。
 | 注意: 选择适应范围来制作一批图案的缩略图（特别是大小不一的图片）
 | 选择按百分比缩放（Choose Scale to Percentage）将图片按百分比缩放.
2 | 点击下一步继续批处理 .


批处理（侠客岛版权所有）

自动化重复任务 > 批处理 > 在批处理过程中查找和替换

在批处理过程中查找和替换

在批处理对话框中添加查找和替换在在批处理过程中查找和替换按钮、热区、或切片中的文字、字体、颜色或URLs

批量替换只对PNG 文件或者矢量文件比如FreeHand, 未压缩的CorelDRAW, 以及Illustrator 文件有效。 批量替换对GIF和JPEG文件无效

要选择批处理过程中的查找和替换选项:

注意: 当你在批处理过程中使用查找和替换URLs的话, 不会产生新的文件。
1 | 点击Edit打开批量替代对话框.
2 | 在查找弹出菜单中选择一个查找属性
3 | 在查找选项中, 键入或选择要查找的特定元素。
4 | 在替换（Change To） 选项,键入或选择特定元素作为找到的元素的替换.
5 | 要将替换的文件加到项目日志中，这样很容易下次找到他们。选择更新项目日志（Update Project Log）.
6 | 点击 OK保存查找和替换设置。
7 | 点击 Next继续批处理.
 | 更多关于查找和替换选项的信息,见查找和替换.


批处理（侠客岛版权所有）

自动化重复任务 > 批处理 > 在批处理过程中改变文件名

在批处理过程中改变文件名

在批处理对话框中添加改名（Rename）来改变输出文件的名字

要设置批处理文件的名字选项:

1 | 在重命名弹出菜单中选择一个属性.
 | 原来名字（Original Name）保持文件名不.
 | 添加前缀（Add Prefix）让你键入作为添加到文件名前的文字，比如,如果你键入 "flash_", 那么 cat.gif 就会在输出时重命名为 flash_cat.gif.
 | 添加后缀（Add Suffix） 让你键入作为添加到文件后面的文字，比如,如果你键入 "_help", 那么dreamweaver.gif 就会在输出时重命名为 dreamweaver_help.gif
2 | 点击 Next 继续批处理.


批处理（侠客岛版权所有）

自动化重复任务 > 批处理 > 在批处理中执行commands命令

在批处理中执行commands命令

添加commands命令选项启用应用于文件的JavaScript命令.

要为批处理文件设置命令选项:

1 | 点击命令选项左边的加号标记(Windows)或三角标记(Macintosh) 来查看可用的命令。
2 | 选择一个命令并点击Add 添加到批处理包含列表（Include in Batch list）.
 | 这些命令无法编辑.
 | 更多关于命令（commands）的信息, 见 Creating command scripts using the History panel使用历史面板创建命令脚本.
 | 注意: 有的命令在批处理中无法使用。选择那些在文件中使用时，不需要指定对象的命令。


批处理（侠客岛版权所有）

自动化重复任务 > 批处理 > 批处理时将文件备份

批处理时将文件备份

你可以将批处理的原始文件进行备份，备份放在原始文件各自的Original Files子目录里

要备份批处理文件:

1 | 选择批处理对话框中的备份（Backups）.
2 | Choose how you want to back up the files:
 | 覆盖原有备份Overwrite Existing Backups 覆盖原来的备份文件
 | 添加备份（Incremental Backups）保持所有的备份拷贝。当你运行一个新的批处理，一个数字会附加在新备份拷贝名字的后面。
 | 注意: 如果备份没有选中, 批处理以相同文件根式输出，如果文件名不变，就会覆盖原始文件，但是，批处理以不同格式输出会创建一个新文件，这样就不讳移除原始文化。
3 | 点击Batch完成批处理, 或者点击Back 回到批处理对话框.


批处理（侠客岛版权所有）

自动化重复任务 > 批处理 > 将批处理保存为脚本

将批处理保存为脚本

将将批处理设置保存为跨平台的脚本™ 以方便以后重新进行批处理。

要创建一个批处理脚本:

1 | 在批处理对话框，点击保存脚本（Save Script）.
2 | 为脚本键入一个名字和描述，并点击保存.
 | 注意: 如果你将脚本保存在文件夹 Fireworks 4\Configuration\Commands folder, 它会出现在命令）Commands）菜单。

要运行一个批处理脚本:

1 | 按以下步骤:
 | 选择 File > Run Script.
 | 直接双击脚本名称。
2 | 选择一个脚本，并点击打开.
3 | 选择应用脚本的文件:
 | 当前打开文件处理所有打开文件。
 | 项目日志 (所有文件)处理项目日志中列出的所有文件。
 | 项目日志(所选文件) 处理项目日志中当前选中的所有文件。
 | 自定义 让你选择要处理的文件.
 | 注意: 点击处理文件弹出菜单旁边的按钮来选择处理的文件
4 | 点击 OK.
 | 更多关于选择文件的信息，见批处理.


批处理（侠客岛版权所有）

自动化重复任务 > 批处理 > 通过拖曳运行脚本

通过拖曳运行脚本

如果有一个批处理过程是你经常要重复做的，将他存为脚本，然后将硬盘上的这个脚本拖曳到你桌面上的Fireworks 图表就可以运行这个批处理。

拖曳一个脚本文件到Fireworks 应用程序（.exe）可以立即运行这个脚本。你也可以将一个脚本文件加上可读的文件或文件夹拖曳到Fireworks 应用程序，立即处理这些文件。
可以多次拖曳多文件脚本文件和多个图象文件到Fireworks来处理这些文件，一次处理一个脚本。


项目日志（侠客岛版权所有）

自动化重复任务 > 项目日志

项目日志

项目日志帮助你追踪并控制在一组文件中，当你使用批处理或者查找和替换时所做的变化。任何由查找和替换所做的变化都记录在项目日志中.


查找和替换（侠客岛版权所有）

自动化重复任务 > 查找和替换

查找和替换

使用查找和替换来对文件中的某个元素进行查找和替换，比如URLs、字体、颜色、文字。查找和替换可以对当前文件或一组文件进行。

当你使用查找和替换时，Fireworks可以追踪并储藏在项目日志面板中的一个变换的日志。查找和替换只对PNG 文件或者矢量文件比如FreeHand, 未压缩的CorelDRAW, 以及Illustrator 文件有效。

查找和替换面板

要查找和替换文件中的元素:

1 | 打开文件.
2 | 打开查找和替换面板:
 | 选择 Edit > Find and Replace查找和替换
 | 选择 Window> Find and Replace查找和替换
 | 按Control-F (Windows) or Command-F (Macintosh).
3 | 从搜索search弹出菜单中，选择搜索来源.
4 | 从查找 Find pop-up弹出菜单中，选择要查找的属性。
5 | 设置查找Find 和换为Change To选项.
6 | 选择你要进行的查找和替换操作:
 | 查找Find可以确认下一个符合的元素，查找到的元素变成被选择状态
 | 替换Replace将找到的元素以设定的转化选项进行改变.
 | 替换所有（Replace All）在搜索范围内查找并替换所有符合的元素 。
 | 注意: 在一组文件中替换对象会自动保存文件，你就不能通过反转Edit > Undo这些变化了。


项目日志（侠客岛版权所有）

自动化重复任务 > 项目日志 > 用项目日志管理搜索

用项目日志管理搜索

使用项目日志来检索选中的文件，将所选文件用最后的输出设定输出，或将其进行批处理。

项目日志记录每个改变了的文件，显示含有变化的文件的影格，以及时间和日期。

手动将文件添加到项目日志来追踪你计划要经常编辑的文件。

要手动添加文件到项目日志:

1 | 选择 Window > 项目日志.
2 | 在项目日志弹出菜单中选择添加文件（ Add Files）并浏览到你要添加的文件。
3 | 选择文件并点击添加.

要打开列在 项目日志中的文件:

双击项目日志中的文件名。

要除去项目日志中的一条记录:

选择一条或几条记录，并在项目日志选项弹出菜单中选择清除选择（ Clear Selection from the Project Log）

要移除项目日志中所有的例句：

项目日志选项弹出菜单中选择清除清除所有 (Clear All from the Project Log)。

要使用原来输出设定输出项目日志中的文件。

从选项弹出菜单，选择文件和并再次输出。


项目日志（侠客岛版权所有）

自动化重复任务 > 项目日志 > 查看并打印项目日志

查看并打印项目日志

The latest version of the 项目日志的最新版本会保存在 Fireworks 4\Settings 文件夹的一个HTML文件里，在浏览器里打开Project_Log.htm来查看并打印项目日志。


脚本（侠客岛版权所有）

自动化重复任务 > 脚本

脚本

在 Fireworks里你可以通过创建脚本来降低一些重复任务的乏味。只要执行你要在脚本里执行的步骤，然后使用历史面板将其保存为命令。或者你可以通过自己写JavaScript代码，在Fireworks中运行。

对于一些类似编辑文字；应用颜色、笔触、填色；改变文件大小和解析度；设置特定画布颜色；应用多种特效或者将对象扭曲。用JavaScript，通过Fireworks可以解释的特定JavaScript命令，你可以几乎可以控制每个命令或设置。


脚本（侠客岛版权所有）

自动化重复任务 > 脚本 > 拓展 Fireworks

拓展 Fireworks

Macromedia Dreamweaver也使用 JavaScript. 你可以写在Dreamweaver中控制Fireworks 的脚本。有关 JavaScript API的文件, 浏览 http://www.macromedia.com/support/fireworks/extend.html.


脚本（侠客岛版权所有）

自动化重复任务 > 脚本 > 使用历史面板创建命令脚本

使用历史面板创建命令脚本

历史面板记录你在 Fireworks中操作的一系列步骤的列表。每个步骤在历史面板中记录为一个独立行，最近的排列在最前面。程序默认面板只记忆20步。然而你可以随时改变这个值。

要改变历史面板记忆的操作数，从Edit菜单中选择Preferences，并在Undo Steps文本框中键入一个新值。历史面板在内存中记录这些信息，所以当心记忆数值太大会妨碍电脑操作。

历史面板将一组步骤保存为你可以重复使用的命令。保存的命令以JSF文件格式保存在Fireworks 4\Configuration\Commands文件夹中。

你可以在任何Fireworks文件中执行这些保存的命令。他们不是指定文件的。

使用历史面板取消操作或重复操作:

拖曳点历史面板左边的记忆标记滑钮到你要回复的最后一步。
点击历史面板左边的记忆标记滑钮
历史面板中未操作的步骤会成为灰色。

要改变历史面板记录的操作步骤数：

1 | 选择 Edit > Preferences.
2 | 将Undo Steps 改为你要历史面板记录的最大步骤数。
 | 注意: 步骤记录数越大需要越多系统内存。

清除历史面板上所有步骤：

从历史面板的选项弹出菜单中选择清除历史（Clear History）来释放内存和硬盘空间。

将操作记录从历史面板中清除，就不能用Undo功能了。

将步骤保存为命令:

1 | 选择要保存为命令的步骤:
 | 点击一个步骤，然后Shift-点击其他的一系列要保存的步骤。
 | Control-点击 (Windows) 或 Command-点击 (Macintosh) 来选择不连续的步骤.
2 | 点击历史面板最底部的Save按钮.
3 | 为命令键入一个名字并 点击 OK.
 | 这个命令会出现在 Commands菜单中.


脚本（侠客岛版权所有）

自动化重复任务 > 脚本 > 执行步骤或命令

执行步骤或命令

你可以随时执行已经记录的命令或历史面板中的一系列操作。

回放一个保存的命令:

1 | 如果有必要，选择一个或多个对象。
2 | 从command菜单选择一个命令。

回放选中的一系列步骤:

1 | 选择一个或多个对象。
2 | 选择历史面板中的步骤。.
3 | 点击历史面板底部的回放（Replay）按钮.

标有一个X的步骤是不可重复的，就不能重新执行。

隔离的记录行表示选中了不同的对象。由覆盖隔离的记录行的步骤创建的命令可能导致无法预料的运行结果。

要在多文件中向对象执行所选步骤:

1 | 选择一系列步骤.
2 | 点击历史面板部的复制（Copy ）按钮。
3 | 选择任意Fireworks文件中的一个或多个对象。
4 | 选择Edit > Paste.

要重复最后一:

选择 Edit > Repeat.


脚本（侠客岛版权所有）

自动化重复任务 > 脚本 > 重命名和删除命令

重命名和删除命令

你可以重命名和删除在Commands菜单中的命令

重命名命令:

1 | 选择 Commands > Edit Command List.
2 | 选择一个命令.
3 | 点击 Rename, 键入一个新名字,并点击 OK.

在 Fireworks里删除一个命令:

1 | 选择 Commands > Edit Command List.
2 | >选择一个命令并点击Delete.

在 Fireworks以外要删除一个命令:

从Fireworks 4\Configuration\Commands文件夹里删除相应JSF 文件


脚本（侠客岛版权所有）

自动化重复任务 > 脚本 > 编辑并自定义一个脚本

编辑并自定义一个脚本

命令脚本是保存为JavaScript。你可以打开并在文字编辑器里编辑他们，比如 NotePad (Windows) or SimpleText (Macintosh)。

你可以用JavaScript写脚本，并用特定Fireworks命令来控制 Fireworks命令和设置。更多关于在 Fireworks中使用JavaScript的信息，见 拓展 Fireworks.

要以JavaScript 在文字编辑器里编辑所选的步骤:

1 | 选择一系列步骤。
2 | 点击历史面板底部的复制（Copy）按钮.
3 | 打开文本编辑器程序
4 | 粘贴这些步骤.


查找和替换（侠客岛版权所有）

自动化重复任务 > 查找和替换 > 选择搜索源

选择搜索源

Fireworks 可以执行五种搜索源之任何一种。在搜索search弹出菜单中，选择你要查找和替换的范围选项：

Search Selection 搜索选择只查找和替换在当前选中的对象或文字中的元素。
Search Frame 搜索影格只查找和替换在当影格中的元素。
Search Document 搜索文件只查找和替换在当文件中的元素。
Search Project Log 搜索项目日志只查找和替换在项目日志列出的文件中的元素。要获得更多这方面的信息，看 用项目日志管理搜索.
Search Files搜索多文件查找和替换在多个文件中的元素。如果你选搜索多文件，浏览到你要搜索的文件，点击Add添加到查找和替换列表中.点击 Add All 将当前文件夹中所有文件添加到查找和替换列表中。(windows中是按住shift或ctrl多选.)-Flashcat语


查找和替换（侠客岛版权所有）

自动化重复任务 > 查找和替换 > 查找和替换多个文件

查找和替换多个文件

当你在多个文件中查找和替换时，选择从选项弹出菜单选中替换选项，来设置搜索到的多个文件在打开后如何处理。

在搜索到后保存并关闭:

1 | 从查找和替换面板的选择选项弹出菜单选中替换选项。
2 | 在替换选项对话框选中保存并关闭（Save and Close）点击ok.
 | 每个文件在进行了查找和替换以后被保存并关闭。只有原来打开的文件保持打开。
 | 注意: 如果保存并关闭（Save and Close）被取消，而你又要批量处理很大量的文件，那么Fireworks可能会因为内存溢出，而放弃批处理。
3 | 在备份弹出菜单中的下列选项中选择一个：
 | 要查找和替换原始文件并不做备份，选不要（no banckups）。改变后的文件替换原始文件。
 | 要在查找和替换后给每个改变的文件创建唯一一个备份，选择覆盖原有备份（Overwrite Existing Backups）。
 | 如果执行另外的查找和替换操作，原始文件会替换备份。备份保存在称为“原始文件Original Files”的子目录里。
 | 要在查找和替换过程中保存所有变换的文件，选则累加备份（Incremental Backups）。

原始文件被移到当前文件夹下的原始文件子目录，而且有一个增加的数字附在每个文件名后面。

如果你执行另外的查找和替换操作，原始文件会被保存到原始文件子目录，并且文件名的后缀数字也加一。

比如：一个叫Drawing.png的文件，第一次进行查找和替换，备份文件命名为Drawing-1.png，第二次对这个文件进行查找和替换，备份文件命名为Drawing-2.png。依次类推。


查找和替换（侠客岛版权所有）

自动化重复任务 > 查找和替换 > 查找和替换文字

查找和替换文字

在查找和替换面板的查找弹出菜单选择 查找文字，在 Fireworks文件中搜索并替换 单词, 字句, 或字符串。在查找选项中，键入要搜索的文字，并在替换选项键入替换文字。

你还可以选择 进一步定义搜索的选项：

在文字定义的整个词语和查找选项中出现的形式必须完全匹配，而不是某个词部分匹配
搜索文字时匹配条件区分大小写。
常规表述（Regular Expressions ）表示是部分匹配


查找和替换（侠客岛版权所有）

自动化重复任务 > 查找和替换 > 查找和替换字体font

查找和替换字体font

在查找和替换面板的查找弹出菜单选择 查找字体，在一个或多个文件中搜索并替代字体。

在查找框和替换框键入确定的字体或字体属性：

最小Min设置要查找的最小字体点数值。
最大Max设置要查找的最大字体点数值。


查找和替换（侠客岛版权所有）

自动化重复任务 > 查找和替换 > 查找和替换颜色

查找和替换颜色

从查找弹出菜单中选择 查找颜色，来搜索并替换Fireworks文件中的 颜色。

在应用到（Apply to）下拉框中选择一个项目，以决定查找到和替换的颜色应用到哪种形式上： 选择 an item from the Apply to pop-up menu to determine how the 颜色 found in the 查找and 替换 are applied:

填色（Fills） 查找和替换所有的填色，除了带有图案的。
笔触（Strokes）只查找和替换笔触的颜色
填色 & 笔触对于填色和笔触的 颜色都有效.
特效（Effects）只查找和替换特效的颜色。
所有属性（All Properties）查找和替换包括填色和笔触和特效的 颜色.

编译：Flashcat


查找和替换（侠客岛版权所有）

自动化重复任务 > 查找和替换 > 查找和替换URLs

查找和替换URLs

从查找弹出菜单中选择查找URLs，来搜索并替换Fireworks文件中分配到网络对象上的URLs。

你还可以选择进一步定义搜索的选项：

在文字定义的整个词语和查找选项中出现的形式必须完全匹配，而不是某个词部分匹配.
搜索文字时匹配条件区分大小写
常规表述（Regular Expressions ）表示是部分匹配.


查找和替换（侠客岛版权所有）

自动化重复任务 > 查找和替换 > 查找和替换非网络安全色

查找和替换非网络安全色

非网络安全色是没有包括在Web216调色盘里的颜色。一个颜色如果在Macintosh和Windows平台上会有色差就是非网络安全色。从查找弹出菜单中选择查找非网络安全色，来搜索所有非网络安全色并替换为网络安全色。

注意: 查找非网络安全色不会查找或替换位图对象中的像素。


针对Photoshop使用者概述（侠客岛版权所有）

针对Photoshop使用者 > 针对Photoshop使用者概述

针对Photoshop使用者概述

如果你是一个Adobe Photoshop使用者，但是对Macromedia Fireworks不熟悉，你将会发现两种程序之间有一些共同点。比如Photoshop 5.5和Fireworks都提供了灵活的工具和特性来以网络格式创建修改、优化图片。其他Fireworks特性，比如层面板和历史面板，在Photoshop中也有相似的对应功能，但是有一些功能的区别。

这一章主要讨论Photoshop 5.5 和 Fireworks 4之间的区别。如果你是一个想学Fireworks的Photoshop使用者，这一章是为你设的。


滤镜和色调的调整（侠客岛版权所有）

针对Photoshop使用者 > 滤镜和色调的调整

滤镜和色调的调整

Fireworks 4和Photoshop5.5都提供了向文件应用特别效果的滤镜。在Fireworks中要使用滤镜，你通过选择一个对象，然后从（Xtras）外挂功能菜单中选择一个滤镜命令。你还可以在外挂功能菜单下找到用于滤镜和色调调整的滤镜，比如：亮度/对比（Brightness/Contrast）者（色调曲线（Curves）。当你向一个矢量对象应用滤镜时，Fireworks会将它转化为位图对象。

Fireworks允许你向外挂功能菜单添加Photoshop滤镜以及其他插件滤镜。另外你还可以将许多滤镜，包括Photoshop 插件，作为可编辑的特效。


特效（侠客岛版权所有）

针对Photoshop使用者 > 特效

特效

Fireworks 4和Photoshop5.5都提供了一系列图象效果，比如阴影和光晕，你可以向文件中的元素应用，并随时修改。

在Photoshop中，你可以使用层的特效来加强所选层的效果。在Fireworks中，你可以使用特效面板来向所选对象添加一个或多个特效。当你使用了一个特效，它就会在该对象的特效面板中列出来，方便你修正特效设置、开关特效，或将特效全部去除。

此外，特效面板让你使用许多滤镜作为特效，包括大多数Photoshop插件滤镜。这个特性说明矢量和位图对象一样都可以应用滤镜，而且随时修改滤镜设置。


任务自动化（侠客岛版权所有）

针对Photoshop使用者 > 任务自动化

任务自动化

在Fireworks4和Photoshop5.5中你都可以自动完成重复的任务。Fireworks中的 File > Batch Process 命令让你向一批文件应用自动完成的任务，这和在Photoshop中一样。在Photoshop中，比如 Actions面板和 File > Automate 菜单。Fireworks中的Commands菜单让你可以在你的文件中运行自动化的命令脚本。你可以从不同的内建命令中选，或创建你自己的命令。

在Fireworks中要记录和创建你自己的命令脚本，你可以使用历史面板，历史面板显示了你最近执行的任务，这和Photoshop中的History面盘一样。选中需要的一系列步骤并从历史面板选项弹出菜单中选择保存为命令。Fireworks将你的新命令添加到Commands菜单。

Fireworks 命令保存为你的Fireworks文件夹中的JavaScript文件。由于Fireworks可以解释JavaScript,你可以编辑你保存的命令或自己写代码，来执行许多Fireworks任务。


动画 （侠客岛版权所有）

针对Photoshop使用者 > 动画

动画

和Photoshop 5.5，一样，Fireworks 4允许你创建Animated GIF文件，此外，Fireworks还提供了使用本体来轻松复制元件和过渡动画元素。

创建和预览动画

在Photoshop 5.5包含的ImageReady程序中，你可以使用Animation面板来创建和预览动画影格。

在Fireworks中，你可以使用Frames影格面板来来创建动画影格。象ImageReady Animation面板一样，影格面板让你指定一些选项，比如影格延迟frame delay和循环looping。要在Fireworks里预览你的动画，你可以使用文件窗口底部的影格控制。

创建并运动元件（symbols）

在Fireworks中，你可以创建一个特别的对象，称为元件（ymbols）由于元件可以在文件中被复制成许多可更新的对象分身stances, 他们对创建动画特别有用。比如你可以在不同影格放置相同元件的不同分身，然后同时更新所有分身的内容。

分身还提供了让你使用运动创建动画的方法。在Fireworks中，你可以在在两个或多个统一元件的不同分身之间运动以创建中间分身到每个独立桢。Fireworks会自动确认运动分身的许多属性，包括：位置、变形、不透明度、特效等。


网络优化（侠客岛版权所有）

针对Photoshop使用者 > 网络优化

网络优化

关于优化以适应网络输出，Fireworks 4和Photoshop 5.5包含的程序ImageReady很相似。

和ImageReady一样，Fireworks提供了在文件窗口查看原始和优化文件的带标签面板。Fireworks的优化（Optimize）面板相当于ImageReady中的对应优化面板，可以让你选择预设或自定义的优化选项。除了GIF, JPEG, 和 PNG，Fireworks支持优化其他图象格式如：TIFF, PICT, 和 BMP。

一旦你在Fireworks中设置了优化选项，你选File > Export 来保存并输出你文件的优化版本。和在ImageReady中一样，从Fireworks 输出一个优化文件不会影响你的原文件。


输出Fireworks文件到Photoshop（侠客岛版权所有）

针对Photoshop使用者 > 输出Fireworks文件到Photoshop

输出Fireworks文件到Photoshop

Fireworks提供多方面的支持来以Photoshop (PSD)文件格式输出。输出设置让你控制在Photoshop中再次打开时文件中那些元素保持可编辑性。

以Photoshop (PSD)文件格式输出:

1 | 选择 File > Export.
2 | 在输出对话框中，命名你的文件并在Save As菜单中选择Photoshop PSD。
3 | 要确认群组输出设置，从Settings菜单中选择一个选项。这些选项提供了在Fireworks文件中对象、特效等的个别输出选项的预设集合。个别输出选项在第4步描述。
 | 保持编辑性优于外观（Maintain Editability over Appearance）将对象转化为Photoshop层，特效、文字保持可编辑性。如果你打算在Photoshop中要做大量编辑而不必保存Fireworks图象现在的精准外观，选择这个选项。
 | 保持Fireworks外观（Maintain Fireworks Appearance）将对象转化为Photoshop层，特效、文字转化为渲染过的特效、文字（Render Effects，Render Text）如果你想在Photoshop中保持控制，但也希望保持Fireworks图象现在的原始外观。
 | 较小Photoshop文件 将Fireworks每个层的对象压平转化为Photoshop的一个层，特效、文字转化为渲染过的特效、文字。如果你输出一个文件有数量巨大的Fireworks对象，选择这个选项。
4 | 要指定个别输出设置，选择Settings菜单中的Custom，然后在对象、特效、文字菜单中选择选项
 | 对象Objects: 转化为Photoshop层Convert to Photoshop Layers将每个Fireworks对象转化为一个Photoshop层，每个Fireworks遮罩转为Photoshop层遮罩.
 | 对象Objects: 压平每个Fireworks层Flatten Each Fireworks Layer将每个Fireworks层压平转化为一个Photoshop层。当你选择这个选项，你就不能在Photoshop中编辑每个Fireworks对象。你也损失了以下属性比如：对象间关联的复合模式。
 | 特效Effects: 保持可编辑Maintain Editability 将Fireworks特效Live Effect转化为相应的Photoshop中的层效果layer effects。双重特效以及没有对应层效果的特效在输出时被忽略。
 | 特效Effects: 渲染效果Render Effects 将特效合并到所基于的对象上。当你选择这个选项，你保留了特效的外观，代价是不能再编辑它了。
 | 文字Text:保持可编辑Maintain Editability 将Fireworks文字转化为Photoshop中的可编辑文字层。
 | 文字Text: 渲染文字Render Text将Fireworks文字转化为Photoshop的位图。如果你选这个，你保留了文字的外观，但不能再次编辑
5 | 点击Save输出hotoshop文件。


在Fireworks中使用Photoshop快捷键（侠客岛版权所有）

针对Photoshop使用者 > 在Fireworks中使用Photoshop快捷键

在Fireworks中使用Photoshop快捷键

要使你更方便的在两程序中切换使用，你可以在Fireworks中设置和Photoshop一样的快捷键来操作菜单命令。

使用Photoshop 快捷键操作Fireworks菜单命令:

1 | 在Fireworks, 选择 Edit > Keyboard Shortcuts.
2 | 从当前设置（Current Set）弹出菜单中选择Photoshop.
3 | 如果愿意，也可以为特定菜单命令自定义快捷键。更多信息，见 改变快捷键设置.
4 | 点击 OK.


在Fireworks中导入Photoshop文件 （侠客岛版权所有）

针对Photoshop使用者 > 在Fireworks中导入Photoshop文件

在Fireworks中导入Photoshop文件

Fireworks提供了对导入Photoshop (PSD)文件绝佳的支持，保留了文件的许多属性，包括：层、蒙版、可编辑的文字。这样，你可以将Photoshop图象在Fireworks中进一步处理，优化以适应网络，而不会因此，不能导回 Photoshop。

确定Photoshop文件导入选项

Fireworks中的import preference选项让你确定如何处理导入的Photoshop文件中的层和文字。根据你选择的选项，你可以控制导入文件保留的可编辑性和显示的程度。

确定Photoshop文件导入选项:

1 | 选择 Edit > Preferences, 然后点击 Import标记(Windows) 或从弹出菜单中选择 Import(Macintosh).
2 | 确认导入选项:
 | 层Layers: 转化为Fireworks 对象（Convert to Fireworks Objects） 将Photoshop文件中的每个层转化为 Fireworks中单个层上的独立位图对象。
 | 层Layers: 影格间共享（Share Layer Between Frames）将导入的层拷贝到Fireworks文件的每个影格。
 | 层Layers:转为影格（Convert to Frames） 将Photoshop文件中的每个层转化为 Fireworks中每个单独的影格。这个选项特别对于输入你要做动画的图象有用。
 | 文字Text: 可编辑（Editable） 将Photoshop中的文字转化为Fireworks文字。该选项让你使用Fireworks文字编辑工具来编辑导入的文字，转化的文字可能和原来的文字看上去略有不同。
 | Text:保留外观（Maintain Appearance）将Photoshop中的文字转化为Fireworks中的位图对象。该选项保留了文字的原始外观，但是你就不能用Fireworks文字编辑工具来编辑它了。
 | 压平复合图象（Use Flat Composite Image） 将Photoshop文件以多层的压平的图象导入。这个选项仅在Photoshop文件中含有复合图象时有用。
3 | 点击OK.

导入或打开Photoshop文件

当你在Fireworks中导入或打开Photoshop文件时，他转化为一个 PNG 文件，这个 PNG 文件使用了你设定的import preferences。除了在导入选项中设定的保存层和文字的设置，Fireworks 保留和转化了以下Photoshop特性:

层的膜版转化为Fireworks 对象膜版.
层特效转化为Fireworks特效（Live Effects）,如果有相对应的特效。比如：阴影（Drop Shadow）转化为 Fireworks中的特效.
层的复合模式转化为Fireworks中对应对象的复合模式，如果Fireworks支持这个复合模式。
通道面板中的第一个 alpha 通道会转化成Fireworks图象的透明区域，Fireworks不支持更多的Photoshop alpha通道。

Fireworks不支持Photoshop的修改层（adjustment layers），修剪群组（ clipping groups），以及路径，在导入时Fireworks会忽略这些特性。

导入一个Photoshop文件到Fireworks:

1 | 选择file > Import 或者 file > Open ,找到需要的Photoshop (PSD) 文件.
2 | 点击 Open. Photoshop文件会转化为PNG 并在Fireworks中打开.


位图以及矢量编辑（侠客岛版权所有）

针对Photoshop使用者 >位图以及矢量编辑

位图以及矢量编辑

在Photoshop 5.5中, 你可以通过改变像素的群组来创建和编辑图象,这种像素也就是位图的基本构造单位。Fireworks既提供了相应的位图编辑支持，也提供了广泛的矢量编辑能力，这种能力过去常和绘图软件例如：Macromedia FreeHand 或 Adobe Illustrator联系在一起。

Fireworks让你能够在同一个文件中同时使用位图和矢量对象。两种图象都有相关不同的编辑模式。

矢量模式

矢量模式是Fireworks默认的编辑状态。在矢量模式中，你可以使用各种绘图工具来创建 矢量对象. 或称为路径对象, 矢量对象由路径线段连接的可调整点构成，不象位图对象，矢量对象由可以方便选取和编辑的不连续的元素组成。

比如，你可以绘制一个形状象矩形的矢量对象，然后对轮廓加上笔触颜色，在内部加上填充颜色。你可以随时选择这个矩形进行各类编辑，比如改变它的笔触颜色或改变它的形状大小，而不会影响文件中的其他对象。

复合模式

你可以通过导入以位图格式保存的图象在Fireworks中创建一个新的位图对象，比如Photoshop (PSD). 你也可以将矢量对象转化为位图对象：选择 Modify > Convert to Bitmap.

当你双击一个位图对象，就会进入位图模式，程序会以在文件窗口或位图本身四周加条纹框来提示你。在位图模式下，你可以使用各种工具来编辑，移动，绘制以及修改像素，就象在Photoshop中一样，你可以通过点击状态栏(Windows)文件窗口底部(Macintosh)的的Stop按钮来离开位图模式。


渐变 （侠客岛版权所有）

针对Photoshop使用者 > 渐变

渐变

Fireworks 和 Photoshop 5.5都允许你在一个区域里填入渐变颜色 both let you fill an area with a gradient—一种填色由两种或更多颜色平滑过渡复合而成。然而两个程序在位图和矢量特性的不同影响渐变如何应用和编辑。

创建渐变

在Photoshop 5.5中,你使用渐变工具拖曳向整个层或像素选区应用渐变。

在Fireworks中，你可以以矢量对象的一种填色来应用渐变。在选择合适的对象后，你可以在填色面板的填色类型弹出菜单中选择一个渐变种类。（渐变填色排在弹出菜单横线分隔的下面）。和其他填色一样，Fireworks在对象的内部应用渐变。

Fireworks也允许你在位图里画渐变，和Photoshop一样。在位图模式下，你可以使用拉索，选取，或魔术棒工具来创建位图选区，然后从填色面板中选择一个渐变类型，然后使用油漆通工具paint Bucket,并点击或在位图选区中拖曳，这样就可以填入选区。

编辑渐变

在Photoshop 5.5中,你必须在向图象应用渐变前，确认颜色和渐变的形状。

在Fireworks中，你可以随时在矢量对象内部编辑渐变填色。只要选择含有渐变填色的对象并在填色面板中改变填色的设置就可以。你甚至可以拖曳对象内部的填色手柄来调节渐变的位置，角度和宽度。老的渐变填色会立刻更新为新的渐变设置。


层 （侠客岛版权所有）

针对Photoshop使用者 > 层

层

尽管Fireworks层面板看上去和Photoshop 5.5的层面板，在Fireworks里层根据你选择的编辑模式有大不同，

在矢量模式下的层

在矢量模式下可以象Macromedia FreeHand或Adobe Illustrator这些绘图软件一样操作层。你可以认为Fireworks层可以包含任何你想要包含的对象。当你绘制一个矢量对象，它变成一个当前层的一个新的对象。层面板列出每个对象，包括对象名字和略图，每个对象作为一个在所属层上的独立项。

你可以轻易将对象在层面板里上下拖动，以改变他们在某个层的堆栈顺序，或者整个移到另一个层。你还可以编辑和删除对象而不影响同一层里别的对象。

在位图模式下的层

当你创建一个新的位图图象，它会变成一个当前层里的位图对象。这个位图对象当你进入位图模式操作起来和Photoshop层是一样的。

比如，当你在位图模式下在一个位图对象上绘制时，你替换了该对象上原来的像素，不论它们是有色的还是透明的，一旦一个元素创建了，就成为位图对象的永久部分，要创建一个位图对象以外的元素，你必须先离开位图模式。


群组（侠客岛版权所有）

针对Photoshop使用者 > 群组

群组

使用Photoshop 5.5 剪裁群组，你可以在一个组里用一个层作为另一个层的蒙版。尽管Fireworks没有提供完全对应剪裁群组的对应功能，你还是可以通过在层面板里组合对象形成矢量蒙版和位图蒙版来完成各类遮罩特效。

在Fireworks中， Modify > Group 命令让你可以将所选对象群组，这样他们可以作为一个行动整体。如果你移动，变化，或改变群组的属性，群组中所有的对象都会变化。Fireworks中的群组对象就好象Photoshop中的关联层一样。


遮罩（蒙版）（侠客岛版权所有）

针对Photoshop使用者 > 遮罩

遮罩

Fireworks提供了和Photoshop 5.5中的层遮罩类似的遮罩特性。

要在Fireworks向一个对象添加一个空遮罩，你可以选择该对象，并点击层面板底部的新遮罩按钮。一个遮罩略图出现在层面板中对象略图的旁边，很象在Photoshop中层遮罩出现在层略图旁边一样。然后和在Photoshop中一样，你可以在文件窗口中绘制，创建一个新的位图遮罩。

除了位图遮罩，你还可以在Fireworks中创建矢量遮罩，方法是将矢量或文字对象粘贴为遮罩。然后你可以用矢量绘图工具比如钢笔来修正这个遮罩。


文字 （侠客岛版权所有）

针对Photoshop使用者 > 文字

文字

Fireworks和Photoshop5.5 都提供了在文件中创建和编辑文字的支持。你也从一个程序输出文字到另一个而不损失文字的可编辑性。

在Photoshop中,你可以在一个打字层上创建文字，并使用打字工具对话框来编辑他的内容和属性。类似的， you create 文字 on a type layer and edit its content and attributes using the Type Tool dialog box. Similarly, 在Fireworks中你将文字创建为当前层上的文字对象，并使用文字编辑器来编辑。

由于Fireworks将文字以对象对待，你可以用多种方法操纵并修改文字。就象在Photoshop中一样, 你可以随时选择、移动、删除和缩放文字，不仅如此，你还可以移动文字对象到任何层，在一个范围内自动回行，将文字附加到路径，以及应用变形、填色、笔触、样式以及特效到文字。经过这些编辑，文字仍然完全可以在文字编辑器中编辑。文字编辑器也允许你应用例如：字体、大小、以及颜色等属性到文字块的任何一个单独字符。


Fireworks HTML 概述 （侠客岛版权所有）

Fireworks HTML > Fireworks HTML 概述

Fireworks HTML 概述

Fireworks 是专为网络制作的图形设计程序。许多 Fireworks用户比如图形艺术家，可能没有技术背景，因此将在 Fireworks中建立的作品放到网上可能在一开始是一项艰巨的任务。许多有技术背景的使用者，例如网络设计师，可能也面临同样问题。因为他们已经习惯传统的网络设计程序在一个软件包里完成所有任务。这一章的目的是不论你的背景，帮助你理解使用Fireworks生成的HTML将涉及到的问题。


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ > 如果我在Fireworks文件里做了修改，如何更新相关的 HTML?

如果我在Fireworks文件里做了修改，如何更新相关的 HTML?

当你更新输出到Dreamweaver的页面，你在Fireworks外所做的变化不会受影响，相反，如果你修改Fireworks生成的HTML，并需要更新，这些变化会被覆盖掉。使用Update HTM命令。 When you update HTML exported to Dreamweaver, the changes you have made outside Fireworks are not affected. However, if you change the Fireworks-generated HTML and this needs to be updated, the changes will be overwritten. Use the Update HTML command.

如果你使用其他的HTML编辑器， Update HTML 命令会给你只替换图象的选择这样你对HTML所做的变化可以保留。


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ > 人们是否使用Fireworks来制作整个网页?

人们是否使用Fireworks来制作整个网页?

不，但它可以作到。

Fireworks 擅长视觉元素的处理，例如鼠标掠过的图象轮换、图形、图象地图、热区、以及优化图象。设计师使用Fireworks 来做这所有的事.

设计师经常同时使用其他程序，如 Photoshop其他图形设计软件，和网络设计软件如Dreamweaver and Adobe GoLive.


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ > 如何更新输出到Dreamweaver的Fireworks图片?

如何更新输出到Dreamweaver的Fireworks图片?

在Dreamweaver 里启动Fireworks然后编辑图片。Fireworks 和 Dreamweaver之间的联系保留了对 HTML的编辑。要看更详细信息。看 在Dreamweaver里编辑Fireworks文件.


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ > 要将Fireworks和其他程序整合使用在同一个工作流程中有何方法可以推荐？

要将Fireworks和其他程序整合使用在同一个工作流程中有何方法可以推荐？

完成一个协调的工作流程的最好方法是使用Fireworks 和 Dreamweaver。特别是在Fireworks里创建鼠标掠过图象轮换和图形然后放在Dreamweaver里。只要你在Dreamweaver里放置了这些元素，你可以直接在 Dreamweaver里启动Fireworks。

在Dreamweaver中使用Launch and Edit启动和编辑可以保持HTML中的连接。 (看在 Dreamweaver中启动Fireworks.) Fireworks使用相对路径，所以有必要将图象和 HTML文件放在相同的文件结构中。要了解更多相对路径的信息，看填入绝对和相对路径.

编译： Flashcat


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ >如果我没有Dreamweaver怎么办?

如果我没有Dreamweaver怎么办?

Fireworks 允许你输出 Generic, FrontPage, 和 GoLive 等格式。 File > HTML Setup 允许你为你喜欢的输出方式设置统一参数。

编译： Flashcat


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ > 为什么把代码粘贴到 Microsoft FrontPage 98, 代码会变化而且连接会断掉?

为什么把代码粘贴到 Microsoft FrontPage 98, 代码会变化而且连接会断掉?

把图象和页面放在正确的位置很重要。如果可能。把文件输出到你放置站点的地方。 Fireworks使用相对路径，所以如果页面或图象移动了，连接可能断掉。

编译： Flashcat


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ > 如果有问题到那里获得技术支持?

如果有问题到那里获得技术支持?

你可以使用以下资源： 在线帮助和技术要点 http://www.macromedia.com/support/fireworks.

本次中文帮助的翻译站点交流区 hhttp://www.paladinland.com/bbs.htm.


什么是HTML文件（侠客岛版权所有）

Fireworks HTML > 什么是HTML文件

什么是HTML文件

HTML文件是包含以下元素的文本文件：

页面中的文字
定义文件、文字、图象及到其他文件的链接的格式和结构的HTML 标签。
HTML 标签被包含在象这样的括号中:
<TAG> 受影响的文字 </TAG>
开始的标签告诉浏览器，比如：以一定方式格式化文字或包含图片.结束标签(</TAG>), 表示格式化结束。


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ

Fireworks HTML FAQ

以下部分列出了你可能在使用Fireworks HTML时遇到的问题的答案。


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ > 我对HTML代码不熟悉怎么办?

我对HTML代码不熟悉怎么办?

Fireworks自动生成代码。你即使不懂代码依然可以使用它。只要你不对文件进行移动和重命名，产生的代码不进行任何修改就可以自动执行。


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ > 我如何将Fireworks HTML 插入一个HTML文件?

我如何将Fireworks HTML 插入一个HTML文件?

有多种选择可以将HTML插入一个 文件。 There are several options for inserting HTML code into a file:

选择 Edit > 将 Fireworks 产生的HTML 代码复制，打开 HTML 编辑器粘贴到合适部位。
在文本字编辑器中打开Fireworks生成的 HTML文件。 选中，需要的内容，包括HTML说明来指定插入到其他文件的设置。你不用复制 <HTML> 和 <BODY> 标签, 因为这些在目标文件中已经有了。
使用编辑器的 Update HTML. 如果没有指定的Fireworks生成的 HTML文件，则你插入的代码被插入了文件。


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ > 如果我只想使用 Fireworks HTML的一部分而不是全部怎么办?

如果我只想使用 Fireworks HTML的一部分而不是全部怎么办?

Fireworks HTML 有详细的说明告诉你各段代码的关系，但首先你必须在HTML设置对话框中选定包含 HTML 说明。 比如，如果是 JavaScript则会被包含在 <SCRIPT> 和 </SCRIPT> 标签之间。所有 HTML以 <!开头，以 -->结束。任何这两个记号之间的内容不会被解释为 HTML 或 JavaScript 代码。

当你选择包含 HTML 说明后，要复制的 HTML 应有以下说明：

<!-----BEGIN COPYING THE HTML HERE---->

<!----STOP COPYING THE HTML HERE------>


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ > 如何在 HTML文件中插入一个按钮?

如何在 HTML文件中插入一个按钮?

按钮是用JavaScript写成的. 在 HTML中，查找 <SCRIPT>和 </SCRIPT> 标签之间的内容并复制到你的目标文件中。

要插入单个按钮，也许单独给按钮单独建立一个文件更为方便，当你输出时，只含有这个按钮的代码。


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ > 如何将切片插入HTML文件？

如何将切片插入HTML文件？

切片被输出成图象。 HTML通过表格来定位切片。

粘贴所有 <TABLE> 部分，包括这个标签，到你想要切片出现的位置。

粘贴所有这个图象的紧跟</TABLE> 的 <MAP>部分


Fireworks HTML FAQ（侠客岛版权所有）

Fireworks HTML > Fireworks HTML FAQ > 要把JavaScript贴到HTML中要了解JavaScript的那些知识？

要把JavaScript贴到HTML中要了解JavaScript的那些知识？

JavaScript 包含在输出的HTML文件中的 <SCRIPT> and </SCRIPT> 之间. 复制时将 <SCRIPT> and </SCRIPT> 标签包含在内。

按照生成的 Fireworks HTML中说明的指导来进行。记住HTML Setup 中要选中Include HTML Comments.

粘贴 <HEAD> and </HEAD>标签之间的JavaScript。 HTML 表格粘贴到 <BODY> and </BODY> 标签之间。

如何用书粗输出的新的HTML取代旧的版本?

你可以通过以下方法来取代旧的：

使用 Update HTML. 你可以选择只更新图象或同时更新图象和HTML.
新文件的HTML粘贴到旧文件中.
再输出 HTML一次，并覆盖旧版本。
要完全覆盖老的版本，请更新 HTML并选择替代图象和HTML。


（侠客岛版权所有）

 Acknowledgments

Project Management: Erick Vera and Stuart Manning

Writing: Lynn Flink, Stephanie Gowin, Sarah Hanily, Robin Hunt-Smith, Gavan Murphy, and Pamela Lu

Editing: Gary White

Multimedia Design and Production: John "Zippy" Lehnus and Noah Zilberberg

Help Design and Production: Chris Basmajian, Sherri Harte, and Rocky Angelucci

Help Engineering: Jed Hartman


�����͵���Ȩ���У�

 Trademarks & Disclaimers

Trademarks
Afterburner, AppletAce, Attain, Attain Enterprise Learning System, Attain Essentials, Attain Objects for Dreamweaver, Authorware, Authorware Attain, Authorware Interactive Studio, Authorware Star, Authorware Synergy, Backstage, Backstage Designer, Backstage Desktop Studio, Backstage Enterprise Studio, Backstage Internet Studio, Design in Motion, Director, Director Multimedia Studio, Doc Around the Clock, Dreamweaver, Dreamweaver Attain, Drumbeat, Drumbeat 2000, Extreme 3D, Fireworks, Flash, Fontographer, FreeHand, FreeHand Graphics Studio, Generator, Generator Developer's Studio, Generator Dynamic Graphics Server, Knowledge Objects, Knowledge Stream, Knowledge Track, Lingo, Live Effects, Macromedia, Macromedia M Logo & Design, Macromedia Flash, Macromedia Xres, Macromind, Macromind Action, MAGIC, Mediamaker, Object Authoring, Power Applets, Priority Access, Roundtrip HTML, Scriptlets, SoundEdit, ShockRave, Shockmachine, Shockwave, Shockwave Remote, Shockwave Internet Studio, Showcase, Tools to Power Your Ideas, Universal Media, Virtuoso, Web Design 101, Whirlwind and Xtra are trademarks of Macromedia, Inc. and may be registered in the United States or in other jurisdictions including internationally. Other product names, logos, designs, titles, words or phrases mentioned within this publication may be trademarks, servicemarks, or tradenames of Macromedia, Inc. or other entities and may be registered in certain jurisdictions including internationally.

Apple, the Apple Logo, Macintosh, Power Macintosh, Mac OS, and LaserWriter are registered trademarks of Apple Computer, Inc. Adobe, Adobe Type Manager, Illustrator, and Photoshop are trademarks of Adobe Systems Incorporated. CorelDRAW is a registered trademark of Corel Corporation or Corel Corporation Limited in Canada, the United States and/or other countries. Java and all Java-based marks are trademarks or registered trademarks of Sun Microsystems, Inc. in the U.S. and other countries. GIF-LZW is licensed under U.S. Patent No. 4,558,302 and foreign counterparts. This software is based in part on the work of the Independent JPEG Group. The Graphics Interchange Format is Copyright � CompuServe Incorporated. GIF is a Service Mark and the property of CompuServe Incorporated. Portions Copyright � 1988�1992 Sam Leffler. Portions Copyright � 1991, 1992 Silicon Graphics. Images � 1999 PhotoDisc, Inc.

This guide contains links to third-party Web sites that are not under the control of Macromedia, and Macromedia is not responsible for the content on any linked site. If you access a third-party Web site mentioned in this guide, then you do so at your own risk. Macromedia provides these links only as a convenience, and the inclusion of the link does not imply that Macromedia endorses or accepts any responsibility for the content on those third-party sites.

Apple Disclaimer
APPLE COMPUTER, INC. MAKES NO WARRANTIES, EITHER EXPRESS OR IMPLIED, REGARDING THE ENCLOSED COMPUTER SOFTWARE PACKAGE, ITS MERCHANTABILITY OR ITS FITNESS FOR ANY PARTICULAR PURPOSE. THE EXCLUSION OF IMPLIED WARRANTIES IS NOT PERMITTED BY SOME STATES. THE ABOVE EXCLUSION MAY NOT APPLY TO YOU. THIS WARRANTY PROVIDES YOU WITH SPECIFIC LEGAL RIGHTS. THERE MAY BE OTHER RIGHTS THAT YOU MAY HAVE WHICH VARY FROM STATE TO STATE.

Fireworks was created by Macromedia, Inc. Copyright © 2000 Macromedia, Inc. All rights reserved. U.S. Patents 5,353,396, 5,361,333, 5,434,959, 5,467,443, 5,500,927, 5,594,855 and 5,623,593. Other patents pending. These Help Pages may not be copied, photocopied, reproduced, translated, or published in any electronic or machine-readable form in whole or in part without prior written approval of Macromedia, Inc.

First Edition: December 2000

Macromedia, Inc.
600 Townsend St.
San Francisco, CA 94103

�����͵���Ȩ���У�


（侠客岛版权所有）

 Fireworks 4中文帮助鸣谢

翻译者（排名不分前后）Flashcat、蓝骑士、Candy、茕若、
整理：Flashcat
本次活动还得到了以下朋友的帮助：
POpover、hotson、水青清、龙睦云雨、闲、（以上朋友参与了dw中文帮助的翻译）、火凤凰、uni以及其他许多朋友。
本中文翻译是版权作品， 侠客岛及翻译小组成员版权所有未经许可，严禁转载，只供学习参考免费使用
如果有任何问题，欢迎大家到 侠客岛论坛和我们讨论

继续征求参与dw4中文帮助的朋友 联系我们


中文帮助内容（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML

Fireworks 4中文帮助鸣谢

编译：Flashcat


Help Contents（侠客岛版权所有）

Introduction 简介
Introduction overview 简介概述
System requirements 系统需求
Installing Fireworks 安装Fireworks
Learning Fireworks 学习Fireworks
What's new in Fireworks 4 Fireworks 4新特性

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML

Fireworks 4 Help CreditsFireworks 4中文帮助鸣谢

编译： Flashcat


帮助内容（侠客岛版权所有）

Introduction 简介

Tutorial 教程
Tutorial overview 教程概述
View the completed Web page观察完成的页面
Open the Start file打开Start文件
Add vector shapes 添加矢量图形
Create buttons 创建按钮
Import and modify bitmap images导入和修改位图图形
Create a disjoint rollover 创建一个分隔的图象轮换
Export your Fireworks file into HTML输出HTML
Use Fireworks with Dreamweaver 结合使用Fireworks 和Dreamweaver
Take the next steps 下一步

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML

Fireworks 4 Help CreditsFireworks 4中文帮助鸣谢

编译： Flashcat


中文帮助主题（侠客岛版权所有）

介绍

教程

Fireworks基础
Fireworks概述
关于矢量图和位图
关于Fireworks的工作流程
关于Fireworks的工作环境
显示Fireworks文件
显示和选择工具
改变工具选项
使用面板
使用快捷菜单
设置属性
设置编辑属性
设置启动和编辑属性
管理扩展文件夹和缓存磁盘
设置导入Photoshop文件属性
改变键盘快捷键设置
创建自定义快捷键
创建候选快捷键
删除自定义快捷键或自定义快捷键方案
为当前的快捷键方案创建参考表
恢复和重复动作

建立Fireworks文件

使用对象

使用矢量对象

使用位图

使用文字

应用颜色，笔触和填充

更改颜色和色调

应用实时效果

层和遮照

使用库，样式和URLs

建立按钮和导航栏

使用热区和切片

创建图象变换

创建动画

优化图象

输出

结合Dreamweaver和Fireworks

自动重复任务

针对Photoshop用户

Fireworks HTML

Fireworks 4中文帮助鸣谢


中文帮助主题（侠客岛版权所有）

介绍

教程

Fireworks基础

建立Fireworks文件
建立Fireworks文件概述
创建新文件
打开其他应用程序生成的图像
打开FreeHand, Illustrator, 或CorelDRAW 文件
从扫描仪或数字相机输入
在Fireworks文件中插入对象
粘贴对象重采样
输入PNG文件
浏览和显示文件
多窗口显示
文件显示模式
改变画布
改变文件尺寸,色彩和分辨率
关于重定义图像尺寸
使用标尺,辅助线,和网格

使用对象

使用矢量对象

使用位图

使用文字

应用颜色，笔触和填充

更改颜色和色调

应用实时效果

层和遮照

使用库，样式和URLs

建立按钮和导航栏

使用热区和切片

创建图象变换

创建动画

优化图象

输出

结合Dreamweaver和Fireworks

自动重复任务

针对Photoshop用户

Fireworks HTML

Fireworks 4中文帮助鸣谢


中文帮助主题（侠客岛版权所有）

介绍

教程

Fireworks基础

建立Fireworks文件

使用对象
使用对象概述
在矢量图编辑模式选取对象
使用对象面板
使用指针工具
使用子选择工具
使用选后工具
使用层面板选取对象
修改选取
移动,复制,克隆和删除对象
对象变形
在信息面板显示变形信息
对象放缩
对象旋转
对象翻转
对象倾斜
对象扭曲
数字化变形
组织对象
在对象组中选取对象

使用矢量对象

使用位图

使用文字

应用颜色，笔触和填充

更改颜色和色调

应用实时效果

层和遮照

使用库，样式和URLs

建立按钮和导航栏

使用热区和切片

创建图象变换

创建动画

优化图象

输出

结合Dreamweaver和Fireworks

自动重复任务

针对Photoshop用户

Fireworks HTML

Fireworks 4中文帮助鸣谢


中文帮助内容（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects使用矢量对象
Working with vector objects overview使用矢量对象概述
Entering vector mode进入矢量状态
Drawing basic shapes绘制基本形状
Drawing rectangles with rounded corners 绘制带圆角的矩形
Drawing stars 绘制星形
Drawing and painting freeform paths绘制任意形状路径并填色
Using the Pen tool 使用钢笔工具
Reshaping paths using vector mode editing tools使用矢量模式编辑工具改变路径形状
Bending and reshaping vector objects 弯曲和变形
Redrawing paths 修改路径
Cutting paths into multiple objects 切割路径
Reshaping vector objects using path operations使用矢量模式编辑工具改变路径形状
Combining path objects 合并路径对象
Removing portions of a path object 部分删除路径
Cropping a path 裁剪路径
Simplifying a path 简化路径
Expanding a stroke 扩张笔触
Contracting or expanding a path 内缩或外张路径

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML

Fireworks 4 Help CreditsFireworks 4中文帮助鸣谢

编译：Flashcat


中文帮助主题（侠客岛版权所有）

介绍

教程

Fireworks基础

建立Fireworks文件

使用对象

使用矢量对象

使用位图
使用位图概述
进入位图编辑模式
选取像素区域
圈选工具选项
调整圈选
添加或较少圈选区域
扩展和收缩边界
在圈选上选取边界区域
光滑圈选边界
在位图编辑模式编辑
克隆图像
剪辑位图图形

使用文字

应用颜色，笔触和填充

更改颜色和色调

应用实时效果

层和遮照

使用库，样式和URLs

建立按钮和导航栏

使用热区和切片

创建图象变换

创建动画

优化图象

输出

结合Dreamweaver和Fireworks

自动重复任务

针对Photoshop用户

Fireworks HTML

Fireworks 4中文帮助鸣谢


中文帮助主题（侠客岛版权所有）

介绍

教程

Fireworks基础

建立Fireworks文件

使用对象

使用矢量对象

使用位图

使用文字
使用文字概述
输入文字
移动文字对象
自动调整
编辑文字
选择字体,文字大小,样式
设置基线,行距
设置字距
设置方向
设置排列
设置文字色彩
光滑文字边缘
应用笔触,填充,效果和样式
保存文字属性
文字路径
文字变形
文字转换为路径
导入文字
从Photoshop导入文字
导入 RTF 文本
导入 ASCII 文本
调整缺损的字体

应用颜色，笔触和填充

更改颜色和色调

应用实时效果

层和遮照

使用库，样式和URLs

建立按钮和导航栏

使用热区和切片

创建图象变换

创建动画

优化图象

输出

结合Dreamweaver和Fireworks

自动重复任务

针对Photoshop用户

Fireworks HTML

Fireworks 4中文帮助鸣谢


中文帮助内容（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills应用颜色，笔触和填充
Applying colors, strokes, and fills overview应用颜色，笔触和填充概述
Choosing colors选择颜色
Applying colors应用颜色
Sampling colors颜色取样
Customizing the Swatches panel自定义色样面板
Changing swatch groups改变色样组
Creating colors 创建颜色
Creating colors using system color pickers使用系统颜色选择器创建颜色
Viewing color values 查看颜色值
Applying strokes应用笔触
Changing strokes 改变笔触
Saving strokes 保存笔触
Creating custom strokes 创建自定义笔触
Saving stroke settings 保存笔触设置
Applying fills 应用填充
Changing fills改变填充
Changing a solid fill改变固色填充
Applying a gradient fill应用渐变填充
Changing a gradient fill改变渐变填充
Saving fills as styles将填充保存为样式
Saving and reusing gradient fills保存与重复使用渐变填充
Applying a pattern fill应用图案填充
Transforming and distorting gradient and pattern fills渐变填充和图案填充的变形和扭曲
Setting hard-edged, anti-aliased, or feathered fill edges设置硬边，去锯齿或羽化的填充边缘
Adding texture to strokes and fills给笔触或填充增加纹理
Adding texture to a fill增加纹理到填充
Using external files as patterns and textures使用外部文件作为图案和纹理
Dithering with Websafe colors抖动处理网络安全色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML

Fireworks 4 Help CreditsFireworks 4中文帮助鸣谢

侠客岛及翻译小组成员版权所有


中文帮助内容（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 修正颜色和色调
Adjusting color and tone overview修正颜色和色调概述
Using filters and plug-ins as Live Effects使用滤镜和插件来作为即时特效
Using Levels to adjust tonal range使用色调分布来调整色调范围
Adjusting the tonal range automatically自动调整色调范围
Adjusting the tonal range using Curves 使用色调曲线来调整色调范围
Adjusting the tonal range with the eyedroppers 使用吸管来来调整色调范围
Adjusting brightness and contrast调整亮度和对比
Applying color fills应用填充颜色
Adjusting hue and saturation调整色调和饱和度
Inverting an image's color values反转图象颜色值
Blurring an image模糊图象
Changing color transitions to lines将色彩变化改变为线条
Converting an image转换图象
Sharpening an image锐化图象

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML

Fireworks 4 Help CreditsFireworks 4中文帮助鸣谢

编译：Flashcat


中文帮助主题（侠客岛版权所有）

介绍

教程

Fireworks基础

建立Fireworks文件

使用对象

使用矢量对象

使用位图

使用文字

应用颜色，笔触和填充

更改颜色和色调

应用实时效果
应用实时特效概述
应用实时特效
使用Fireworks外挂(Xtras)功能
使用Photoshop插件(plug-ins)
应用传统特效
应用斜角
应用浮雕
应用阴影和光晕
改变实时特效
对实时特效排序
删除实时特效
创建自定义实时特效
保存实时特效为样式
使用默认效果设置
控制实时特效
多个对象应用实时特效

层和遮照

使用库，样式和URLs

建立按钮和导航栏

使用热区和切片

创建图象变换

创建动画

优化图象

输出

结合Dreamweaver和Fireworks

自动重复任务

针对Photoshop用户

Fireworks HTML

Fireworks 4中文帮助鸣谢


中文帮助主题（侠客岛版权所有）

介绍

教程

Fireworks基础

建立Fireworks文件

使用对象

使用矢量对象

使用位图

使用文字

应用颜色，笔触和填充

更改颜色和色调

应用实时效果

层和遮照
层和遮照概述
网络层
使用层
遮照图像
创建位图遮照和矢量遮照
为对象创建遮照
使用文字遮照
创建空遮照
使用"显示所有/隐藏所有"命令
使用"显示所选区域/隐藏所选区域"命令
编辑遮照
遮照时使用对象面板
对象的混色
关于混色模式
混色举例
应用实时色彩填充效果
结合Photoshop
导入Photoshop遮照层
导入Photoshop层组

使用库，样式和URLs

建立按钮和导航栏

使用热区和切片

创建图象变换

创建动画

优化图象

输出

结合Dreamweaver和Fireworks

自动重复任务

针对Photoshop用户

Fireworks HTML

Fireworks 4中文帮助鸣谢


中文帮助内容（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库、样式和 URLs
Using libraries, styles, and URLs overview使用库、样式和 URLs 概述
About styles关于样式
Using styles使用样式
About symbols and instances关于符号和实体
Using the symbol library使用符号库
About the URL panel关于 URL 面板
Working with URLs 使用 URLs
Entering absolute or relative URLs输入绝对或相对 URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML

Fireworks 4 Help CreditsFireworks 4中文帮助鸣谢

侠客岛及翻译小组成员版权所有


中文帮助内容（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars创建按钮和导航栏
Creating buttons and navigation bars overview创建按钮和导航栏概述
About buttons关于按钮
Creating buttons创建按钮
Creating a button创建一个按钮
Adding a Down state添加“Down”状态
Adding an Over While Down state添加“Over While Down”状态
Attaching a URL to the button给按钮附加链接
Changing a button改变按钮
Drawing and editing in the active area 绘制和编辑感应区域
Editing button text 编辑按钮文字
Using bevel effects to draw button states使用斜面效果绘制按钮的各个状态
Inserting buttons from the library 从库中插入按钮
Importing a copy of a button symbol into the current document 输入复制的按钮符号到当前文档
Inserting a button from the library从库中插入一个按钮
Importing a preinstalled button symbol输入预先安装的按钮符号
Creating a navigation bar with buttons用按钮创建导航栏
Converting Fireworks rollovers into buttons将Fireworks翻转图象转化为按钮
Inserting a button from an external source插入外部按钮

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML

Fireworks 4 Help CreditsFireworks 4中文帮助鸣谢

侠客岛及翻译小组成员版权所有


中文帮助主题（侠客岛版权所有）

介绍

教程

Fireworks基础

建立Fireworks文件

使用对象

使用矢量对象

使用位图

使用文字

应用颜色，笔触和填充

更改颜色和色调

应用实时效果

层和遮照

使用库，样式和URLs

建立按钮和导航栏

使用热区和切片
热区和切片概述
创建热区和图像地图
在热区上添加链接
在URL面板管理URLs
定义 alt(图像提示)信息
选择目标选项
改变热区
在热区上应用拖拽功能(drag-and-drop)
输出图像地图
关于切片
优化图像
创建交互
创建切片
切片重叠
在切片上添加链接
创建文字切片
创建多边形切片
显示切片和切片辅助线
切片图像优化
在层面板中显示和命名切片
在网络层中命名切片
自动命名切片
自定义切片名字
使用嵌套表格和单元格间隔
更新Fireworks生成的HTML文件中的切片

创建图象变换

创建动画

优化图象

输出

结合Dreamweaver和Fireworks

自动重复任务

针对Photoshop用户

Fireworks HTML

Fireworks 4中文帮助鸣谢


中文帮助内容（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers创建 rollovers 效果
Creating rollovers overview创建 rollovers 效果概述
About rollovers关于 rollovers 效果
Creating simple rollovers using the Behaviors panel 使用行为面板创建简单的 rollovers 效果
Setting up the slice, images, and frames建立切割、图像、和影格
Applying the simple rollover behavior to the slice给切割应用简单的 rollover 行为
Using the Behaviors panel 使用行为面板
Using drag-and-drop behaviors to create swap image effects使用拖放行为创建替换图案效果
Creating a swap image rollover using a single slice 使用单一切割创建替换图案效果
Attaching drag-and-drop behaviors指派拖放行为
Creating disjoint rollovers using drag-and-drop behaviors使用拖放行为创建不相交的 rollovers 效果
Setting up the Web objects, images, and frames建立 Web 对象、图像和帧
Using drag-and-drop behaviors to create the disjoint rollover使用拖放行为来创建不相交的 rollover 效果
Deleting drag-and-drop behaviors 删除拖放行为
Assigning URL links to rollovers给 rollovers 效果指定 URL 链接
Creating pop-up menus创建弹出菜单
Creating pop-up menu entries创建弹出菜单条目
Setting the appearance of a pop-up menu 设置弹出菜单外观
Editing a pop-up menu编辑弹出菜单
Changing the position of a pop-up menu更改弹出菜单的位置
Exporting a pop-up menu导出弹出菜单
Creating odd-shaped rollovers 创建不规则形状的 rollovers 效果
Creating rollovers with overlapping slices使用重叠切割来创建 rollovers 效果
Using external files as rollover images使用外部文件作为 rollover 效果的源图
Using hotspots on top of slices for complex interactivity使用切割上的热区创建复杂交互效果

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML

Fireworks 4 Help CreditsFireworks 4中文帮助鸣谢

侠客岛及翻译小组成员版权所有


中文帮助主题（侠客岛版权所有）

介绍

教程

Fireworks基础

建立Fireworks文件

使用对象

使用矢量对象

使用位图

使用文字

应用颜色，笔触和填充

更改颜色和色调

应用实时效果

层和遮照

使用库，样式和URLs

建立按钮和导航栏

使用热区和切片

创建图象变换

创建动画
创建动画概述
关于动画
使用动画符号
影格的操作
设置影格延迟时间
显示或隐藏影格
影格命名
添加,移动,复制,删除影格
在影格间移动对象
层共享
使用洋葱皮
中间帧
动画输出
使用已经存在的动画文件
使用多个文件创建一个动画

优化图象

输出

结合Dreamweaver和Fireworks

自动重复任务

针对Photoshop用户

Fireworks HTML

Fireworks 4中文帮助鸣谢

侠客岛及翻译小组成员版权所有


中文帮助内容（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics优化图形
Optimizing graphics overview 优化图形概述
Optimizing in the workspace在工作区中进行优化
Specifying optimization settings for slices指定切割的优化设置
Using the slice overlay使用切割覆盖层
Saving and reusing optimization settings保存和重复使用优化设置
Previewing optimization settings and behaviors预览优化设置和行为
Previewing buttons and rollovers预览按钮和 rollover 效果
Estimating file download time评估文件下载时间
Comparing optimization settings比较优化设置
Selecting file formats 选择文件格式
Choosing GIF选择 GIF 格式
Choosing JPEG选择 JPEG 格式
Choosing PNG选择 PNG 格式
Choosing optimization settings for GIFs and PNGs为 GIFs 和 PNGs 选择优化设置
Choosing the color depth选择色深
Choosing a color palette 选择色板
Dithering to approximate lost colors为补偿损失色进行抖动处理
Setting loss to reduce file size为减小文件尺寸设定损失值
Defining transparent areas 定义透明区域
Removing all unused colors from the palette删除所有面板上的无用的颜色
Interlacing: Downloading in segments交错：分段下载
Choosing optimization settings for JPEGs为 JPEGs 选择优化设置
Selective JPEG compression选择性 JPEG 压缩
Reducing quality to reduce file size降低质量以减小文件尺寸
Blurring edges to increase compression模糊边缘以提升压缩比
Sharpening color edges and fine detail 锐化颜色边缘和细节
Progressive JPEGs 渐变式 JPEGs
Optimizing color palettes优化色板
Choosing the appropriate color palette选择合适的色板
Setting the number of colors in the palette设定色板上的颜色数量
Viewing colors in a palette查看色板中的颜色
Locking colors in a palette锁定色板上的颜色
Editing colors in a palette编辑色板上的颜色
Setting Websafe colors设置网络安全色
Saving palettes保存色板
Assigning transparency指定透明色
Anti-aliasing to match the target background color通过消除锯齿处理使应用颜色同目标背景色匹配
Removing halos from Web graphics删除网络图形的光晕

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML

Fireworks 4 Help CreditsFireworks 4中文帮助鸣谢

侠客岛及翻译小组成员版权所有


中文帮助内容（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting输出
Exporting overview 导出概述
Exporting an image导出图像
Results of exporting 导出结果
Exporting with the Export Wizard 使用导出向导进行导出
Optimizing and previewing during export导出文件时进行优化和预览
Previewing optimization in the Export Preview在导出预览对话框中预览优化效果
Exporting frames or layers as multiple files将文档中的帧或层导出成为多个文件
Exporting an area导出图形的一部分
Exporting a slice 导出切片
Using spacers or nested tables when slicing导出切割时使用空白表格单元或嵌套表格
Exporting vector paths导出矢量路径
Exporting to FreeHand and Illustrator导出到 FreeHand 和 Illustrator
Exporting to Macromedia Flash> 导出到 Macromedia Flash
Copying and pasting selected paths拷贝和粘贴所选路径
Exporting to Dreamweaver libraries导出到 Dreamweaver 库中
Exporting to Director导出到 Director
Exporting to Photoshop导出到 Photoshop
为了导出到 Photoshop 将文件自定义
导出 WBMP 格式
导出 Css 层
导出到 Lotus Domino Designer
Using the Update HTML command使用 Update HTML 命令
Editing Fireworks images placed in Dreamweaver编辑放置在 Dreamweaver 中的 Fireworks 图像
HTML Setup HTML 设置

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML

Fireworks 4 Help CreditsFireworks 4中文帮助鸣谢

侠客岛及翻译小组成员版权所有


中文帮助主题（侠客岛版权所有）

介绍

教程

Fireworks基础

建立Fireworks文件

使用对象

使用矢量对象

使用位图

使用文字

应用颜色，笔触和填充

更改颜色和色调

应用实时效果

层和遮照

使用库，样式和URLs

建立按钮和导航栏

使用热区和切片

创建图象变换

创建动画

优化图象

输出

结合Dreamweaver和Fireworks
结合Dreamweaver,Fireworks概述
在Dreamweaver中应用Fireworks文件
在Dreamweaver中调用Fireworks
在Dreamweaver中编辑Fireworks文件
优化Dreamweaver中Fireworks生成的图像
更新Dreamweaver中Fireworks生成的HTML代码
创建网页相册

自动重复任务

针对Photoshop用户

Fireworks HTML

Fireworks 4中文帮助鸣谢


Help Contents（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和遮照

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks自动化重复任务
Automating repetitive tasks overview自动化重复任务概述
查找和替换
Selecting the source for the search选择搜索源
查找和替换多个文件
查找和替换文字
查找和替换字体fonts
查找和替换颜色
查找和替换URLs
查找和替换非网络安全色
Batch processing批处理
Changing optimization settings with a batch process改变批处理优化设置
Scaling graphics with a batch process 用批处理改变图片大小
find & replace during a batch process在批处理过程中查找和替换
Changing file names with a batch process在批处理过程中改变文件名
Performing commands with a batch process在批处理中执行命令
Backing up batch-processed files批处理时将文件备份
Saving batch processes as scripts将批处理保存为脚本
Running scripts by dragging and dropping通过拖曳运行脚本
Project Log项目日志
Managing searches with the Project Log 用项目日志管理搜索
Viewing and printing the Project Log查看并打印项目日志
Scripting脚本
Extending Fireworks拓展 Fireworks
Creating command scripts using the History panel使用历史面板创建命令脚本
Playing steps or commands 执行步骤或命令
Renaming and deleting commands重命名和删除命令
Editing or customizing a script编辑并自定义一个脚本

针对Photoshop使用者针对Photoshop用户

Fireworks HTML

Fireworks 4 Help Credits中文帮助鸣谢

编译：Flashcat


中文帮助内容（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

针对Photoshop使用者
针对Photoshop使用者概述
Using Photoshop shortcuts in Fireworks在Fireworks中使用Photoshop快捷键
Importing Photoshop files into Fireworks在Fireworks中导入Photoshop文件
Bitmap and vector editing位图以及矢量编辑
Gradients渐变
Layers层
Groups群组
Masks遮罩
Text文字
Filters and tonal adjustments滤镜和色调的调整
Effects特效
Task automation任务自动化
Animation动画
Web optimization 网络优化
Exporting Fireworks files to Photoshop输出Fireworks文件到Photoshop

Fireworks HTML

Fireworks 4 中文帮助鸣谢

编译：Flashcat


Help Contents（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML
Fireworks HTML overview 概述
什么是HTML文件 ？
Fireworks HTML Frequently Asked Questions常见问题
我对HTML代码不熟悉怎么办?
我如何将Fireworks HTML 插入一个HTML文件?
如果我只想使用 Fireworks HTML的一部分而不是全部怎么办?
如何在 HTML文件中插入一个按钮?
如何将切片插入HTML文件？
要把JavaScript贴到HTML中要了解JavaScript的那些知识？
如果我在Fireworks文件里做了修改，如何更新相关的 HTML?
人们是否使用Fireworks来制作整个网页？
如何更新输出到Dreamweaver的Fireworks图片?
要将Fireworks和其他程序整合使用在同一个工作流程中有何方法可以推荐？
What if I don't have Dreamweaver?如果我没有Dreamweaver怎么办?
为什么把代码粘贴到 Microsoft FrontPage 98, 代码会变化而且连接会断掉?
如果有问题到那里获得技术支持?

Fireworks 4 Help Credits Fireworks 4中文帮助鸣谢

编译： Flashcat


中文帮助内容（侠客岛版权所有）

Introduction 介绍

Tutorial 教程

Fireworks Basics 基础

Setting up a Fireworks Document 建立Fireworks文件

Working with Objects 使用对象

Working with Vector Objects 使用矢量对象

Working with Bitmaps 使用位图

Using Text 使用文字

Applying Colors, Strokes, and Fills 应用颜色，笔触和填色

Adjusting Color and Tone 更改颜色和色调

Applying Live Effects 应用实时效果

Layers and Masking 层和蒙版

Using Libraries, Styles, and URLs 使用库，样式和URLs

Creating Buttons and Navigation Bars 建立按钮和导航栏

Using Hotspots and Slices 使用热区和切片

Creating Rollovers 创建图象变换

Creating Animation 创建动画

Optimizing Graphics 优化图象

Exporting 输出

Using Dreamweaver and Fireworks Together 整合Dreamweaver和Fireworks

Automating Repetitive Tasks 自动重复任务

Fireworks for Photoshop Users 针对Photoshop用户

Fireworks HTML

Fireworks 4中文帮助鸣谢
Acknowledgments
Trademarks & Disclaimers
Fireworks 4中文帮助鸣谢


（侠客岛版权所有）

汉化： Flashcat


Index（侠客岛版权所有）

Numerics
2-Up view 2-up 视窗
4-Up view 4-up 视窗
A
absolute URLs, entering 绝对地址，写入
ACT swatches ACT 色样
activating, bitmap mode 激活，位图模式
adding 增加
frames 影格
styles 样式
adjusting 调整
hue or saturation 色调 或 饱和度
tonal range 色调范围
tonal range using eyedropper 使用吸管
aligning 排列
button state graphics 按钮状态图形
objects 对象
alpha, converting images to alpha透明度，转换图形
alternate text 改变文字
animation 动画
adding frames 增加影格
creating from multiple files 从多文件中创作（动画）
custom frame viewing 自定义影格视图
deleting frames 删除影格
disabling layer sharing 取消层共享
editing Fireworks animations 编辑Fireworks动画
exporting 输出
exporting as Flash file 以Flash 文件输出
exporting as multiple files 以多文件输出
inserting frames 插入影格
looping 循环
managing frames 影格的管理
moving objects to another frame 移动对象到另一影格
multi-frame editing 多影格编辑
onion skinning 洋葱皮效果
opening 打开
optimizing 优化
playing 播放
previewing 预览
reordering frames 重排影格顺序
setting frame delay 设置影格延时
sharing layers across frames 不同影格共享层
transparency 透明度
turning frames on and off 打开关闭影格
viewing all frames 显示所有影格
viewing before and after frames 显示前后影格
viewing multiple frames 显示多影格
viewing next frame 显示下一影格
anti-alias 抗锯齿
removing halos 消除光晕
ssmoothing text edges 平滑文字边缘
target background color 目标背景颜色
anti-aliased edges, creating 抗锯齿边缘，创建
Apple Color Picker 苹果机颜色拾取器
arranging, frames 编排，影格
Auto Levels Xtra 自动控制色调外挂功能
auto-naming slice objects 自动命名切片对象
changing default naming convention 改变默认命名规则
B
backing up, during Find and Replace 在查找替换时，备份
baseline shift 基线微调
Batch Process dialog box 批处理对话框
batch processing 批处理
backing up 备份
files 文件
commands 命令
file names 文件名
Find and Replace 查找和替换
how to 怎样做
optimization settings 优化设置
saving as scripts 保存脚本
saving files 保存文件
scaling graphics 调整图形尺寸
batch scripts 批处理脚本
dragging and dropping 拖放
running 运行
behaviors 行为
Behaviors panel 行为面板
Dreamweaver 4
nav bar down 导航栏down状态
nav bar over 导航栏over状态
nav bar restore 导航栏状态复原
previewing 预览
set pop-up menu 设置弹出式菜单
set text of status bar 设置状态栏文字
simple rollover 简单的图象变换
swap image 替换图案
beveled edges 边缘斜角
bitmap graphics 位图图形
bitmap masks 位图蒙版
creating 建立
using an existing object 使用现有对象
bitmap mode 位图模式
activating 激活
defined 定义
hiding striped border 隐藏位图的条纹边框
leaving 离开（位图模式）
settings 设置
blend colors of overlapping objects 重叠物体的颜色混合
blending 混合
applying 应用
Layers panel 层面板
set blending mode 设置混合模式
set default blending mode 设置默认混合模式
blending modes 混合模式
color 颜色
darken 暗模式
difference 交错模式
erase 擦除模式
hue 色调模式
invert 反色模式
lighten 亮模式
luminosity 亮度模式
multiply 累加模式
saturation 饱和度模式
screen 屏幕模式
tint 上色模式
blending objects 混合对象
Blur More Xtra 强模糊外挂功能
Blur Xtra 模糊外挂功能
blurring 模糊
Border command 边框命令
brightness 亮度
Brightness/Contrast Xtra 亮度/对比附加功能
Bring Forward command 置前命令
Bring to Front command 置于最前命令
broken HTML links HTML断链
Brush tool 笔刷工具
brushes 笔刷
saving settings 保存设置
setting tip 设置笔尖
stroke options 笔触选项
Button Editor, creating symbols 按钮编辑器，建立符号
Button Library, importing symbols 按钮库，导入符号
button symbol, importing 按钮符号，导入
buttons 按钮
active area 感应区域
adding 增加
Down state 鼠标down状态
Over While Down state 鼠标over和down状态
attaching URLs 附加URLs
bevel effects 斜角效果
Button Editor 按钮编辑器
converting from Fireworks 2 format 转变Fireworks 2格式
creating 创建
defined 定义
editing 编辑
editing text on 编辑按钮文字
exporting 输出
functionality defined 功能定义
inserting from libraries 从按钮库插入
Link Wizard 链接向导
navigation bars 导航栏
overview 概述
simple rollover 简单图象变换效果
C
cache files 缓存文件
canvas 画布
modifying charteristics 改变特性
modifying resolution 改变分辨率
rotating 旋转
trimming 删剪
centerpoint, drawing from 从中心绘制图形
circles 圆
Clipboard 剪贴板
cloning, images 克隆图形
CMY color model 黄品青颜色模式
color 颜色
adding from screen to a palette 从屏幕向调色板加颜色
applying from Swatches panel 使用色样颜色
changing stroke 改变笔触
choosing color depth 选择颜色范围
choosing working palette 选择操作面板
clearing Swatches panel 清空色样面板
color models 色彩模式
creating in Color Mixer 在混色器里创建
deleting from Swatches panel 从色样中删除
dithering with Websafe 抖动为网络安全色
finding and replacing 查找和替换
finding and replacing non-Websafe 查找和替换非网络安全色
Gradient fill 简编填色
inverting values 反转色值
obtaining using Eyedropper tool 用吸管获取颜色
overview 概述
picking from color bar 从颜色栏取色
removing unused colors 移除不用的颜色
replacing a swatch 替换色样
resetting default 恢复默认
sampling 采样
saving custom palette 保存自定义调色板
setting preferences 设置系统参数
sorting Swatches panel 色样排序
color bar, choosing a color 颜色栏，取色
color box 颜色盒
Apple Color Picker 苹果机颜色拾取器
System color picker 系统颜色拾取器
color correction 颜色修正
Auto Levels 自动色调分布
automatic 自动化
brightness and contrast 亮度和反差
Curves 色调曲线
Levels 色调分布
using eyedropper 使用吸管
color fills 填色
Color Mixer 混色器
creating colors 创建颜色
color models 颜色模式
CMY 黄品青
Grayscale 会阶
Hexadecimal 16进制
HSB （色调/饱和度/亮度）
RGB
color palette 调色板
adding from screen to 从屏幕加颜色
appending to current palette 向现有调色板添加
choosing 选择（调色板）
choosing custom 选择自定义（调色板）
choosing working 选择当前（调色板）
clearing 清除（调色板）
color models 色彩模式
creating colors 创建颜色
deleting colors 删除颜色
editing 编辑颜色
importing 导入
locking colors 锁定颜色
optimizing 优化
replacing color 替代颜色
saving 保存
saving custom swatches 保存自定义色样
setting number of colors 设置颜色数
sorting 排序
viewing 查看
Color Table 色表
edited swatch 编辑色样
locked swatch 锁定色样
panel 面板
selecting a color 选择颜色
selecting multiple colors 多选颜色
selecting range of colors 选择一系列颜色
swatch with multiple attributes 多属性色样
transparent swatch 透明色样
updating 更新
Websafe swatch 网络安全色样
colorize, images 改变色彩，图象
combining paths 合并路径
commands 命令
batch processing 批处理
saving 保存
composite paths 复合路径
compositing 复合
compression, blurring edges 压缩，模糊边缘
configuring Fireworks 设置 Fireworks
Constrain Proportion 限制比例
constraining, rotation 限制旋转
context menus 右键菜单
Contract command 收缩命令
contracting paths 收缩路径
contrast 收缩
copying, pixels 复制像素
copying and pasting, Fireworks HTML 复制/粘贴Fireworks HTML
CorelDRAW files, opening from Fireworks 打开CorelDRAW文件
corner points （直线）节点
Create Web Photo Album command 创建网络像册
Crop command 裁剪命令
CSS Layers CSS层
exporting 输出
exporting from Fireworks 从Fireworks输出
curve points 曲线节点
curve segments, editing 编辑曲线段
Curves Xtra 色调曲线外挂功能
custom shortcut sets 自定义快捷设置
conventions 快捷常规
deleting 删除
cutting paths 切割路径
D
Deselect command 取消选择命令
Design Notes, for Dreamweaver and Fireworks integration 设计笔记，用于Dreamweaver、Fireworks整合使用
designing entire Web pages 设计全页面
Director, exporting to Director,输出
disjoint rollover 调换影象rollover
creating 建立
display modes, switching 切换显示模式
distorting objects 扭曲对象
Distortion Transform tool 扭曲变形工具
dithering 抖动
with Websafe colors 扭曲变形工具
document 文件
default mode 默认状态
display mode 显示状态
multiple views 多视图
tiling views 视图排列
document redraw 文件重绘
downsampling 减少采样点
drag-and-drop behaviors 拖放行为
blue line 兰线
creating disjoint rollovers 创建调换影象
creating disjoint rollovers with 创建调换影象
definition 定义
deleting 删除
for single slice 使用单一切片
dragging and dropping 拖放
dragging pop-up menus 拖动弹出式菜单
drawing绘制
bending adjacent segment 弯曲相邻线段
changing adjacent segments 改变相邻线段
converting straight paths to curved 直线转为曲线
distorting objects 扭曲对象
selecting a point 选择一个点
splitting paths 切割路径
Dreamweaver
edit Fireworks images in 编辑Fireworks图象
exporting to 输出
Dreamweaver 4 behaviors Dreamweaver 4行为
Dreamweaver and Fireworks integration 整合Dreamweaver和Fireworks
creating Web photo albums 建立网络相册
Design Notes 设计笔记
editing Fireworks animations 编辑Fireworks动画
exporting CSS Layers 输出CSS层
exporting Dreamweaver library items 输出Dreamweaver图库物件
external editor preference 自定义外部编辑器
inserting Fireworks files 插入Fireworks文件
Launch and Edit preferences 启动及编辑自定义
launching and editing Fireworks images 启动及编辑Fireworks图象
launching and editing Fireworks tables 启动及编辑Fireworks表格
launching and optimizing Fireworks images 启动及优化Fireworks图象
Optimize Image in Fireworks command 用 Fireworks命令优化图象
resizing Fireworks images 缩放Fireworks图象
updating Fireworks HTML 更新Fireworks HTML
Dreamweaver libraries, exporting from Fireworks 从Fireworks输出Dreamweaver库文件
E
edges, showing and hiding 边，显示/隐蔽
Edit Gradient dialog box 编辑渐层对话框
Edit Stroke dialog box 编辑笔触对话框
Edit Stroke Options panel 编辑笔触选项面版
Edit Stroke Sensitivity panel 编辑笔触灵敏度面版
Edit Stroke Shape panel 编辑笔触形状面版
editing 编辑
buttons 按钮
rollovers 变化影像
Effect panel 效果面版
effects 效果
applying filters as 应用滤镜
applying to grouped objects 应用于群组对象
applying to objects 应用于对象
beveled edges 斜角边缘
buttons and 按钮
disabling 取消效果
editing 编辑
embossing 浮雕
finding and replacing 查找/替代
glow 光晕
Live 实时
plug-ins 插件
reactivating 重激活
removing 移除
reordering 改序
saving as styles 存为样式
setting defaults 设置默认
shadow 阴影
speeding up redraw 加速重绘
Ellipse tool 椭圆工具
ellipses, drawing 画椭圆
embossing 浮雕
Empty Bitmap command 空白位图命令
EPS files, opening in Fireworks 打开EPS文件
erasing, pixels 擦除像素
Expand command 扩大
Expand Stroke command 扩大笔触命令
expanding paths 扩大路径
expanding strokes 扩大笔触
Export Area tool 输出区域工具
Export dialog box 输出对话框
Export Preview 输出预览
comparing optimization settings 比较优化设置
exporting 输出
optimizing 优化
panning area 查看区域
previewing 预览
previewing optimization 预览优化
zooming 放大缩小
Export Wizard 输出向导
using 使用
exporting 输出
an area 部分区域
animated GIFs GIF动画格式
animations as multiple files 动画多文件形式
buttons 按钮
CSS Layers CSS层
CSS Layers from Fireworks 由Fireworks生成CSS层
customizing files for Photoshop 为Photoshop自定义文件
Fireworks files to Dreamweaver 由Fireworks输出到Dreamweaver
for Photoshop 用于Photoshop
frames as multiple files 每桢/文件输出
images 图象
layers as multiple files 每桢/文件输出
library items from Fireworks 输出成library
overview 概述
results 结果
slices 切片
styles 样式
symbols 符号
to Director 输出到Director
to Dreamweaver 输出到Dreamweaver
to Flash 输出到Flash
to FreeHand 输出到FreeHand
to Illustrator 输出到Illustrator
to Lotus Domino Designer 输出到Lotus Domino
to Photoshop 输出到Photoshop
to WBMP format 输出为WBMP格式
vector paths 输出为适量路径
Extending Fireworks, scripting resource 输出为脚本资源
extensibility 可拓展性
external editors 外部编辑器
Fireworks. See Dreamweaver and Fireworks integration 整合
preference 自定义
external files, converting to rollovers 使用外部文件制作影象替换
F
Feather command 羽化命令
feathered edges, creating 创建羽化边缘
feathering 羽化
file download time 文件下载时间
file format 文件格式
choosing GIF 选择GIF格式
choosing JPEG 选择JPEG格式
choosing PNG 选择PNG格式
file names, changing in a batch process 批处理变化文件名方式
file size 文件大小
reducing quality 降低质量
setting loss to reduce size 设置损失以缩小文件
Fill Color 填色
applying 应用
fill edges, changing 改变填色边缘
Fill panel 填色面板
fills
adding external patterns to list 增加拓展图案到列表里
adding texture 增加纹理
adjusting 调整
applying color fills 应用填色效果
applying Gradient 应用渐变
applying Pattern 应用图案
applying Solid 应用实色
changing color for basic shape tools 改变形状绘图工具的颜色
dither fill 抖动填色
drawing over strokes 用笔触画图
editing Gradient 编辑渐变
editing Solid 编辑实色
feathering or anti-aliasing 羽化或抗锯齿
finding and replacing 查找和替换
moving 移动
resetting default color 恢复默认颜色
rotating 旋转
saving Gradient 保存渐变颜色
setting for drawing tools 设置画图工具
swapping stroke and fill colors 替换笔触和填色
transforming Gradient 渐变变形
transforming Pattern 图案变形
transparency illusion 透明假象
filters 滤镜
applying as effects 以效果方式应用
as Live Effects 实时效果
Find and Replace 查找和替换
batch processed files 批处理文件
colors 色彩
font 字体
multiple files 多文件
non-Websafe colors 非网络安全色
selecting source for search 选择搜索源
text 文字
URLs
uses 用途
Find and Replace panel 查找和替换面板
Find Edges Xtra 边界查找附加功能
finding and replacing 查找和替换
Fireworks
configuring 设置
converting Fireworks 2 buttons 转变Fireworks 2按狃
Help 帮助
installing 安装
new features 新特性
newsgroup 新组
resources for learning 学习资源
setting preferences 设置自定义
Support Center 支持中心
System requirements 系统要求
work environment 操作环境
workflow 工作流
Fireworks and Dreamweaver integration. 整合Fw和Dw See 看 Dreamweaver and Fireworks integration 整合Fw和Dw
Flash
exporting animations for 输出动画
exporting to 输出
flipping objects 翻转对象
font 字体
changing using the Text menu 使用文字菜单改变
Find and Replace 查找和替换
handling missing fonts 处理缺少字体
style 样式
type size 字体大小
frame delay (animations) 影格延迟（动画）
frame delay default setting 影格延迟默认设定
frames 影格
adding 增加
custom viewing 自定义显示
deleting 删除
disabling layer sharing 取消层共享
exporting 输出
inserting 插入
managing 管理
moving objects to another frame 从其他影格移动对象
multi-frame editing 多影格编辑
onion skinning 洋葱皮
reordering 记录
setting delay 设置延迟
sharing layers for animation 动画层共享
turning off onion skinning 关闭 洋葱皮
turning on and off 打开/关闭
viewing all 显示所有
viewing before and after 显示前后影格
viewing next 显示后影格
Frames panel 影格面板
freeform paths 自由变形路径
FreeHand
exporting to 输出
opening files 打开
G
Gaussian Blur Xtra 高斯模糊附加功能
GIF
choosing a color palette 选择调色板
choosing GIF 选择GIF
optimization settings 优化设置
swatches 色样
glow effects 光晕效果
Gradient editor 渐变编辑器
Gradient fills 渐变填色
adding new color 填加新颜色
adjusting 调整
adjusting color transition 调整颜色变化
applying 应用
changing colors 改变颜色
converting images to transparency 图象转为透明
deleting saved 删除已保存的
Edit Gradient dialog box 编辑渐变对话框
editing 编辑
moving 移动
removing colors 移除颜色
renaming 重命名
reusing in another document 再其他文件中重新使用
rotating 旋转
saving 保存
sharing between documents 文件间共享
transforming 变形
graphics, exporting 输出图象
Grayscale color model 灰阶模式
grid 网格
altering cell size 改变网格单元大小
changing default color 改变默认颜色
showing/hiding 显示/隐藏
snapping objects to 吸附
grouping objects 群组对象
guides 辅助线
locking 锁定
snapping objects to 吸附
H
halos, removing 移除光晕
handles, transform 手柄，变形
Help 帮助
Fireworks
Online 在线
TechNotes 技术要点
Hexadecimal color model 16进制颜色模式
Hide All 隐藏所有
Hide Panels command 隐藏面板
Hide Selection 隐藏选择
hiding 隐藏
edges 边缘
panels 面板
toolbars 工具栏
histogram 直方图
History panel 历史面板
hotspots 热点
applying drag-and-drop behaviors 应用拖放行为
assigning URLs 分配URL
creating 建立
editing shape 编辑形状
on top of slices 在切片上方
HSB color model HSB颜色模式
HTML
broken links 断链
comments 评论
copying and pasting from Fireworks to Dreamweaver 从Fireworks复制和粘贴到Dreamweaver
files 文件
insert into an existing HTML file 插入原有HTML文件
inserting buttons 插入按钮
inserting from Fireworks into Dreamweaver 从Fireworks插入到Dreamweaver
inserting slices 插入切片
overview 概述
replacing older version 替代老版本
Setup HTML设置
Document Specific tab 文件特定标签
General tab 常规标签
Tables tab 表格标签
updating Fireworks HTML placed in Dreamweaver 更新已放在Dreamweaver中的Fireworks HTML
hue 色调
Hue/Saturation Xtra 色调/饱和度外挂功能
I
Illustrator
exporting to 输出
opening files 打开文件
opening from Fireworks 从Fireworks打开
image edit mode, 图象编辑状态see 看bitmap mode 位图模式
image maps 图象地图
creating 创建
exporting 输出
images 图象
creating 创建
exporting 输出
painting 绘制
selecting 选择
selecting pixels 选择像素
striped border 条纹
import text 导入文字
ASCII text ASCII码文字
Photoshop files Photoshop文件
RTF files RTF文件
Import Xtra for Director 导入Director外挂功能
importing 导入
from digital camera 从数码相机导入
Photoshop files Photoshop文件
PNG files PNG文件
styles 样式
symbols 元件
inserting 插入
Fireworks HTML into Dreamweaver 向Dreamweaver插入Fireworks HTML
Fireworks images into Dreamweaver 向Dreamweaver插入Fireworks图象
Inset Path command 插入路径命令
installing 安装
Fireworks
Photoshop plug-ins Photoshop插件
instances 分身
defined 定义
placing 放置
placing in document 放入文件
tweening
interlacing, downloading in segments 链接显示，分步下载
interpolation (scaling) 插补像素（缩放）
Intersect command 交错命令
Invert Xtra 反转片外挂功能
J
joining paths 合并路径
JPEG
choosing 选择
editing selected areas 编辑选择区域
optimization settings 优化设置
progressive 渐进显示
selective JPEG compression 可选JPEG压缩
Sharpen JPEG Edges JPEG尖锐化边缘
K
kerning 字距调整
keyboard shortcuts 快捷键
changing current set 改变现有设置
custom shortcuts 自定义快捷键
Knife tool 裁刀工具
L
Launch and Edit 启动和编辑
preferences 自定义
launching Fireworks from Dreamweaver. 从Dreamweaver启动Fireworks See 看 Dreamweaver and Fireworks integration 整合Dreamweaver and Fireworks
layers 层
disabling sharing across frames 取消影格间共享
exporting 输出
sharing across frames for animation 动画中影格间共享
Layers panel 层面板
blending 混合
naming slices 命名切片
opacity 不透明度
viewing slices 查看切片
leading 行距
learning Fireworks 学习Fireworks
newsgroup 新组
lessons 教程
Levels Xtra 色调分布外挂功能
library items, exporting from Fireworks 输出库元素
Library panel 库面板
Line tool 线条工具
lines, drawing 绘制线条
Link Wizard 链接向导
Live Effects, 实时效果 see 看effects 效果
Lotus Domino Designer, exporting to 输出到Lotus Domino
M
苹果机(Mac)系统要求
marquee圈选
contracting缩小选区
deselecting取消选区
expanding扩展选区
removing移除选区
selecting area around设定选区边界
smoothing选区 光滑
masks 遮照
creating empty masks创建空遮照
deleting删除遮照
disabling使遮照不可编辑
editing编辑遮照
editing an object without affecting 不影响遮照编辑对象
enabling使遮照可编辑
grouping objects to form a mask利用成组对象遮照
text as a mask 文字遮照
using an existing object利用存在对象遮照
Merge Images command 合并图像命令
merging paths 合并路径
Mini-Launcher 最小化装载器
mode 模式
activating bitmap mode 切换位图模式
entering vector 进入矢量图模式
mouse events 鼠标事件
N
nav bar down behavior导航栏按下动作
nav bar over behavior导航栏鼠标掠过动作
nav bar restore behavior导航栏恢复动作
navigating导航
navigation bars, creating创建导航栏
nested tables嵌套表格
Numeric Transform command数字化变形
O

object mode,see vector mode对象模式,参看矢量模式
Object panel in masking 遮照时的对象面板
objects对象
distorting 扭曲变形
removing an effect 去处效果
odd-shaped rollovers 不规则图形切片
onion skinning 洋葱皮
Button Editor按钮编辑器
custom viewing 自定义查看方式
defined 定义
multi-frame editing 多帧编辑
turning off 关闭
viewing all frames 查看所有影格
viewing before and after frames查看前后影格
viewing next frame查看下一影格
opacity 不透明度
adjusting调整
Layers panel层面板
opening 可打开文件格式
animated GIFS 动态GIF
animated GIFs 动态GIF
CorelDRAW files CorelDraw文件
Fireworks 1 files Fireworks 1文件
FreeHand files FreeHand文件
Illustrator files Illustator文件
multiple files as animations 序列图像
Photoshop files Photoshop图像
WBMP files WBMP文件
optimization settings 图像最优化设置
changing in a batch process批处理输出
comparing 对比
comparing two or four settings 2画面,4画面对比
deleting preset settings 删除自定义设置
GIF GIF图像
JPEG JPEG图像
PNG PNG图像
preset optimization settings自定义设置
preset options 预选设置选项
previewing 预览
reusing 重复使用
saving 保存
sharing with another user 与其他用户共享
Optimize Image in Fireworks command最优化图像命令
optimizing 最优化处理
animations 动画
Fireworks images from Dreamweaver 在Dreamweaver中应用
in the workspace工作区
overview 图像优化总论
using Export Wizard使用输出向导
ovals, drawing 椭圆绘制
overlapping slices 切片重叠
P
palette 调色板
adding from screen to 从屏幕获取色彩
choosing 选择
choosing custom 选择自定义色板
choosing working 选择工作色板
color models色彩模式
creating colors创建色彩
replacing color色彩取代
saving custom swatches 保存自定义色板
panels 面板
description 种类
Edit Stroke Options 编辑笔划选项
Edit Stroke Sensitivity编辑笔划敏感度
Edit Stroke Shape 编辑笔划形状
Effect效果
Fill 填充
Find and Replace 填充并取代
Frames 影格
hiding 隐藏
Library库
removing tabbed panel 移出面板
Stroke 笔划
Styles 样式
Swatches 色板
Tool Options 工具选项
URL panel URL面板
panning 平面移动
Paste as Mask 遮照粘贴
Paste Inside 内部粘贴
pasted images 重采样粘贴图像
paths 路径
adding stroke texture 添加笔划纹理
bending adjacent segment弯曲临近段
changing adjacent segment 改变临近段
changing shape 改变形状
converting straight to curved 变直线为曲
copy and paste拷贝并粘贴
creating custom strokes 创建自定义笔划
cropping 切割路径
editing strokes 编辑笔划
resetting default colors 重置默认色彩
selecting a point选择点
splitting 分离联合
swapping stroke and fill colors 反转笔划和填充色彩
Pattern fills 图案填充
adding external to list 添加外部图案到列表
adjusting 调整
applying 应用
moving 移动
rotating 旋转
transforming 变形
Pen tool 钢笔工具
adding points 添加点
curved segments 曲线段
deleting points 删除点
resuming path重置路径
straight segments 直线段
Pencil tool 铅笔工具
perspective illusion 透视效果
Photoshop Photoshop
customizing files for export 自定义输出
exporting to 输出到
grouped layers 群组层
import options导入选项
layer masks 遮照层
working with Photoshop masks 使用Photoshop遮照
Photoshop and Fireworks Photoshop和Fireworks
animation动画
automation自动处理
bitmap and vector editing 位图和矢量图编辑
clipping groups 群组剪切
effects效果
exporting PSD files from Fireworks Fireworks输出PSD文件
filters 滤镜
gradients色彩渐变
grouping 群组
history 历史
importing PSD files into Fireworks导入PSD文件
keyboard shortcuts 键盘快捷键
layer masks 遮照层
layers层
masking遮照
optimizing files 文件优化
text文字
tonal adjustments 图像调整
Photoshop plug-ins Photoshop插件
Acquire installation 获取路径
applying应用
installing 安装
Pick Distance 选中范围
pixels 像素
adjusting tonal range 色调调整
adjusting tonal range using Curves色调曲线修正
adjusting tonal range using eyedropper 使用吸管色调曲线修正
Auto Levels 自动色调修正
bitmap mode 位图模式
cloning 克隆
contracting selection border收缩选区边界
copying复制
cutting 剪切
erasing橡皮擦擦除
expanding selection border 扩展选区边界
feathering 羽化
moving 移动
painting 填色
selecting 选取
selecting area around marquee 选取圈选区边缘
selecting freeform area 选取任意区域
selecting polygonal area 选取多边形区域
selecting similar colors 选取相似色彩
smoothing marquee border 光滑圈选区域
tonal range色调修正
playing animations 播放动画
plotting points 标识点
plug-ins 插件
as Live Effects 实时效果
PNG PNG
choosing a color palette 选择调色板
choosing PNG 选择PNG
optimization settings 最优化设置
point handles 曲柄
displaying 显示
points 点
adding 添加
bending adjacent segment 弯曲临近段
changing adjacent segment 改变临近段
converting 转换
converting straight to curved 转换直线成曲线
deleting删除
moving 移动
selecting 选择
Polygon Slice tool 多边形切片工具
Polygon tool 多边形工具
stars 星形
polygons 多边形
constraining 约束
pop-up menu, dragging 弹出菜单拖动
pop-up menu outline 弹出菜单外框
pop-up menus 弹出菜单
creating 创建
description描述
designing appearance设计外观
editing 编辑
entering menu text 输入菜单文字
exporting 输出
preferences 参数
color defaults 色彩默认
editing options 编辑选项
folder options 文件夹选项
Import 输入
import options输入选项
interpolation options插值选项
Launch and Edit 装载和编辑
setting 设置
Undo steps回复步数
preview预览
buttons 按钮
pixels containing specific color 约束色彩
rollovers 鼠标掠过
selecting an area to optimize 选择最优化区域
Preview tab 预览标签
progressive JPEGs 渐进式JPEG
Project Log 项目日志
adding 添加
exporting a file 输出文件
logging Find and Replace changes 记录查找和替换
opening files 打开文件
printing 打印
removing all entries 去处所有记录
removing an entry 去处单个记录
searching 查找
viewing 查看
pulling paths路径牵引
Punch command 打孔命令
pushing and pulling paths 路径推拉
pushing paths 路径推动
R
RAM, see System requirements内存,参看系统要求
Rectangle tool 矩形工具
rectangles矩形
drawing绘制
rounded corners圆角
Redraw Path tool路径重绘工具
redrawing paths路径重绘
reducing points减少点
reference sheet
relative URLs, entering进入相对URL路径
Remove from Transparency button从透明中移除
removing移除
effects效果
parts of a path部分路径
Rename Stroke dialog box笔划重命名对话框
renaming重命名
Gradient fills渐变填充
strokes笔划
symbols标识
reordering, effects效果记录
repeating actions动作重复
replacing替换
replaying animations动画重放
resampling重采样
bitmap objects位图对象
described描述
downsampling向下采样
resampling up向上采样
vector objects矢量对象
reshaping vector objects矢量对象变形
resizing Fireworks images from Dreamweaver在Dreamweaver中重定义Fireworks图像尺寸
results of exporting输出结果
Reveal All显示所有
Reveal Selection显示所选部分
RGB color modelRGB色彩模式
rollovers鼠标掠过
active area响应区域
adding添加
Down state按下状态
Over While Down state按下状态鼠标掠过
attaching URLs添加链接
bevel effects斜角效果
converting from Fireworks 2 format转换自Fireworks2格式
creating创建
defined定义
editing编辑
inserting from libraries插入库对象
navigation bars导航栏
odd-shaped rollovers不规则翻转
simple rollovers简单翻转
swap image图像翻转
with overlapping slices使用重叠切片
rotating旋转
constraining约束
objects对象
relocating axis of rotation重置旋转轴
Rounded Rectangle tool圆角矩形工具
rulers标尺
S
saturation饱和度
Save Stroke dialog box笔划保存对话框
Scale Transform tool放缩变形工具
scaling, objects对象放缩
scaling graphics图片放缩
scaling images, interpolation options放缩图片,插值选项
scratch disks临时文件磁盘
searching查找
segments, converting线段的转换
selecting选择
additional objects对象的添加
area around marquee圈选边界区域
contracting marquee border收缩圈选边界
deselecting an object取消对象选择
deselecting marquee取消圈选
expanding marquee border扩展圈选边界
feathering edges羽化边缘
freeform area of pixels选择任意区域
grouped objects群组对象
images影像
pixels像素
points点
polygonal area of pixels选择多边形区域
similar colors相似色彩
smoothing marquee border光滑圈选边界
Selective JPEG compression选择性JPEG压缩
Enable Selective Quality使品质选择允许
overlay color色彩覆盖
preserve button quality保持按钮品质
preserve text quality保持文字品质
Selective Quality button品质选择按钮
Send Backward command向后移动命令
Send to Back command移动到最后命令
set设置
pop-up menu behavior弹出菜单动作
text of status bar状态栏文字
shadow effects阴影效果
Sharpen More Xtra扩展功能之更多锐化
Sharpen Xtra扩展功能之锐化
sharpening锐化
shortcut sets快捷建设置
reference sheet参考表
secondary shortcuts候选快捷键
Show/Hide hotspots and slices显示/隐藏热点和切片
showing显示
edges边缘
panels面板
rulers标尺
Tool Options panel工具选项面板
toolbars工具栏
simple rollover简单翻转
applying simple rollover behavior应用简单翻转动作
creating创建
simple rollover behavior简单翻转动作
Simplify command简化命令
simplifying paths简化路径
Skew Transform tool倾斜变形工具
skewing, objects对象倾斜
slanting, objects对象倾斜
slice guides, viewing显示切面引导线
slice objects切片对象
auto-naming自动命名
definition定义
editing Fireworks table slices from Dreamweaver从Dreamweaver编辑Fireworks表格切片
updating更新
Slice tool切片工具
slices切片
creating创建
exporting输出
optmization settings设置最优化
overlapping slices切片重叠
polygon多边形
show/hide slice overlay显示/隐藏重叠切片
text slices文字切片
using nested tables使用嵌套表格
using spacer使用间隔
using the slice overlay重叠使用切片
slicing切片
definition定义
for interactivity为了交互性
Smooth command光滑命令
Snap Distance吸附距离
Solid fills固色填充
adding texture添加纹理
applying应用
spacers间隔
Split command分离命令
squares正方形
stacking, objects对象层叠
stars星形
constraining约束
straight segments, editing编辑直线段
striped border纹理边界
Stroke panel笔划面板
strokes笔划
adding external textures to list添加外部纹理到列表
adding texture添加纹理
changing centering改变中心
changing color of drawing tools改变绘画色彩的工具
choosing a stroke选择笔划
creating custom创建自定义笔划
deleting删除
drawing fill over填充
edge边缘
editing编辑
finding and replacing查找和替换
renaming重命名
reorienting再调整
resetting default color重新设置默认色彩
saving settings保存设置
setting sensitivity设置敏感度
swapping stroke and fill colors反转笔划和填充色彩
using in another document在其他文件调用
styles样式
adding添加
applying应用
basing on existing styles基于存在的样式
defined定义
deleting删除
editing编辑
enlarging preview icons扩大预览图标
exporting输出
importing输入
new新建
resetting to defaults重置并保存为默认
saving effects as保存效果为
Styles panel样式面板
Subselection tool, auto-join paths子选择工具,自动联合路径
Support Center支持中心
swap image behavior翻转图片动作
swap image rollover鼠标掠过翻转图片
creating disjoint rollover创建复杂翻转
with single slice使用单一切片
swatches, Windows System colors色板,Windows系统色彩
Swatches panel色板面板
appending a palette添加调色板
clearing清除
deleting a color删除色彩
replacing a color色彩替换
saving custom保存为自定义
sorting分类
Symbol Library物件库
Symbol Properties dialog box物件属性对话框
symbols物件
breaking a link断开链接
creating创建
creating instances创建实例
defined定义
deleting删除
duplicating复制
editing编辑
exporting输出
importing输入
modifying定义
placing instances in document在文件中放置实例
tweening运动
System color picker系统色彩提取
color boxes色盒
System requirements系统要求
T
text 文字
color色彩
direction 方向
editing编辑
entering进入
finding and replacing 查找和替换
orientation 倾向
overview总览
slices 切片
text alignment文字排列
center中心
justified自动行间调整 
left左
right右
stretch自动行宽调整
text attributes, saving 文字属性保存
text block 文字对象
auto-sizing 自动尺寸
moving移动
resizing 尺寸重定义
Text Editor文字编辑器
text paths 文字路径
attaching text to path 文字附着路径
changing shape of path改变路径形状
converting text to path转换文字为路径
detaching from path 从路径分离
editing text attached to a path 编辑附着路径的文字
moving starting point of text 一定文字起点
placing text on a path放置文字在路径
text style 文字样式
bold 加粗
effects效果
fill填充
italic倾斜
stroke笔划
underline下滑线
Text Tool文字工具
texture纹理
adding to fills添加到填充
adding to strokes添加到笔划
thumbnails对象指示
tonal range色调修正范围
adjusting automatically自动调整
adjusting with Curves利用色调曲线调整
adjusting with Levels利用色级调整
tool groups工具组
Tool Options panel工具选项面板
toolbars工具栏
docking置入
rearranging重新排布
showing and hiding显示和隐藏
unlocking置出
tools工具
changing options改变选项
changing stroke color改变笔划色彩
choosing选取
choosing alternate tools选取某一工具
displaying显示
Distortion Transform不规则变形
in Tools panel在工具面板
Scale Transform放缩变形
Skew Transform倾斜变形
Tools panel工具面板
Transform变形
Tools panel工具面板
choosing tools改变工具
contents内容
displaying显示
ToolTips工具提示
transform text变形文字
Transform tools变形工具
Distortion Transform tool不规则变形工具
Scale Transform tool放缩变形工具
Skew Transform too倾斜变形工具
transforming变形
by dragging通过拖拽
numerically数字化
objects对象
transparency透明
adding or removing colors添加或删除色彩
animation动画
converting images to gradient transparency转换图像为渐变透明
selecting a color选择色彩
transparency illusion透明影像
transparent areas透明区域
triangles三角形
trimming canvas裁减画布
Tutorial教程
Tween Instances command实例运动命令
tweening运动
characteristics特征
defined定义
objects对象
types of color palettes 调色板类型
adaptive最适用色
black and white黑白
custom自定义
exact精确色
grayscale灰阶
system (Macintosh)Mac系统色
system (Windows)Windows 系统色
uniform均衡色
Web 216网页标准色
Web adaptive网页最适用色
U
Undo 撤销操作
setting number设置数目
ungrouping objects对象群组取消
Union command 洋葱皮命令
Unsharp Mask Xtra 非锐化遮照扩展功能
Update HTML更新HTML代码
Update HTML command 更新HTML命令
updating slices 更新切片
URL Library URL库
adding URLs 添加URL
adding used URLs 添加已使用的URL
creating创建
entering absolute or relative URLs进入绝对或相对URL
overview 总览
URL panel URL面板
URLs URLs
assigning to a Web object指定网页对象链接
assigning to rollovers 指定鼠标掠过链接
attaching to buttons附着到按钮
finding and replacing查找和替换
selecting target options选择目标选项
V
valid files 有效文件
vector graphics矢量图片
vector masks 矢量遮照
converting to bitmap mask 转换为位图遮照
creating创建
using an existing object使用存在对象
vector mode矢量模式

activating切换
entering进入
vector objects, reshaping 矢量对象重绘
vector paths, exporting矢量路径输出
W
WBMP files, opening from Fireworks 打开WBMP文件
WBMP format, exporting to WBMP格式输出
Web photo albums, creating创建网页相册
Websafe colors 网页保护色
Windows, System requirements for Windows系统要求
Windows System Colors, as a swatch group Windows系统色彩
Wizard 向导
Export 输出
Link 链接
Optimize to Size尺寸优化
workflow工作流程
X
Xtras 扩展功能
as Live Effects 实时效果
Auto Levels 自动色调修正
Blur模糊
Blur More 更模糊
Brightness/Contrast亮度/对比度
Curves 色调曲线修正
Find Edges寻找边缘
Gaussian Blur 高斯模糊
Hue/Saturation 色相/饱和度
Invert 色彩反转
Levels 色调修正
Sharpen 锐化
Sharpen More 更锐化
Unsharp Mask 非锐化遮照
Z
zooming 放缩
into a specific area 特定区域放缩

整理：火凤凰


（侠客岛版权所有）

数字
2-Up view 2-Up视窗
4-Up view 4-Up视窗
编译： Flashcat


（侠客岛版权所有）

I
Illustrator
 | exporting to 输出
 | opening files 打开文件
 | opening from Fireworks 从Fireworks打开
image edit mode, 图象编辑状态see 看bitmap mode 位图模式
image maps 图象地图
 | creating 创建
 | exporting 输出
images 图象
 | creating 创建
 | exporting 输出
 | painting 绘制
 | selecting 选择
 | selecting pixels 选择像素
 | striped border 条纹
import text 导入文字
 | ASCII text ASCII码文字
 | Photoshop files Photoshop文件
 | RTF files RTF文件
Import Xtra for Director 导入Director外挂功能
importing 导入
 | from digital camera 从数码相机导入
 | Photoshop files Photoshop文件
 | PNG files PNG文件
 | styles 样式
 | symbols 元件
inserting 插入
 | Fireworks HTML into Dreamweaver 向Dreamweaver插入Fireworks HTML
 | Fireworks images into Dreamweaver 向Dreamweaver插入Fireworks图象
Inset Path command 插入路径命令
installing 安装
 | Fireworks
 | Photoshop plug-ins Photoshop插件
instances 分身
 | defined 定义
 | placing 放置
 | placing in document 放入文件
 | tweening
interlacing, downloading in segments 链接显示，分步下载
interpolation (scaling) 插补像素（缩放）
Intersect command 交错命令
Invert Xtra 反转片外挂功能
汉化： Flashcat


（侠客岛版权所有）

J
joining paths 合并路径
JPEG
 | choosing 选择
 | editing selected areas 编辑选择区域
 | optimization settings 优化设置
 | progressive 渐进显示
 | selective JPEG compression 可选JPEG压缩
 | Sharpen JPEG Edges JPEG尖锐化边缘
汉化： Flashcat


（侠客岛版权所有）

K
kerning 字距调整
keyboard shortcuts 快捷键
 | changing current set 改变现有设置
 | custom shortcuts 自定义快捷键
Knife tool 裁刀工具
汉化： Flashcat


（侠客岛版权所有）

L
Launch and Edit 启动和编辑
 | preferences 自定义
launching Fireworks from Dreamweaver. 从Dreamweaver启动Fireworks See 看 Dreamweaver and Fireworks integration 整合Dreamweaver and Fireworks
layers 层
 | disabling sharing across frames 取消影格间共享
 | exporting 输出
 | sharing across frames for animation 动画中影格间共享
Layers panel 层面板
 | blending 混合
 | naming slices 命名切片
 | opacity 不透明度
 | viewing slices 显示切片
leading 行距
learning Fireworks 学习Fireworks
 | newsgroup 新组
lessons 教程
Levels Xtra 色调分布外挂功能
library items, exporting from Fireworks 输出库元素
Library panel 库面板
Line tool 线条工具
lines, drawing 绘制线条
Link Wizard 链接向导
Live Effects, 实时效果 see 看effects 效果
Lotus Domino Designer, exporting to 输出到Lotus Domino
汉化： Flashcat


（侠客岛版权所有）

M
苹果机(Mac)系统要求
marquee圈选
 | contracting缩小选区
 | deselecting取消选区
 | expanding扩展选区
 | removing移除选区
 | selecting area around设定选区边界
 | smoothing选区 光滑
masks 遮照
 | creating empty masks创建空遮照
 | deleting删除遮照
 | disabling使遮照不可编辑
 | editing编辑遮照
 | editing an object without affecting 不影响遮照编辑对象
 | enabling使遮照可编辑
 | grouping objects to form a mask利用成组对象遮照
 | text as a mask 文字遮照
 | using an existing object利用存在对象遮照
Merge Images command 合并图像命令
merging paths 合并路径
Mini-Launcher 最小化装载器
mode 模式
 | activating bitmap mode 切换位图模式
 | entering vector 进入矢量图模式
mouse events 鼠标事件
蓝骑士


（侠客岛版权所有）

N
nav bar down behavior导航栏按下动作
nav bar over behavior导航栏鼠标掠过动作
nav bar restore behavior导航栏恢复动作
navigating导航
navigation bars, creating创建导航栏
nested tables嵌套表格
Numeric Transform command数字化变形
蓝骑士


（侠客岛版权所有）

O
object mode,see vector mode对象模式,参看矢量模式
Object panel in masking 遮照时的对象面板
objects对象
 | distorting 扭曲变形
 | removing an effect 去处效果
odd-shaped rollovers 不规则图形切片
onion skinning 洋葱皮
 | Button Editor按钮编辑器
 | custom viewing 自定义显示方式
 | defined 定义
 | multi-frame editing 多帧编辑
 | turning off 关闭
 | viewing all frames 显示所有影格
 | viewing before and after frames显示前后影格
 | viewing next frame显示下一影格
opacity 不透明度
 | adjusting调整
 | Layers panel层面板
opening 可打开文件格式
 | animated GIFS 动态GIF
 | animated GIFs 动态GIF
 | CorelDRAW files CorelDraw文件
 | Fireworks 1 files Fireworks 1文件
 | FreeHand files FreeHand文件
 | Illustrator files Illustator文件
 | multiple files as animations 序列图像
 | Photoshop files Photoshop图像
 | WBMP files WBMP文件
optimization settings 图像最优化设置
 | changing in a batch process批处理输出
 | comparing 对比
 | comparing two or four settings 2画面,4画面对比
 | deleting preset settings 删除自定义设置
 | GIF GIF图像
 | JPEG JPEG图像
 | PNG PNG图像
 | preset optimization settings自定义设置
 | preset options 预选设置选项
 | previewing 预览
 | reusing 重复使用
 | saving 保存
 | sharing with another user 与其他用户共享
Optimize Image in Fireworks command最优化图像命令
optimizing 最优化处理
 | animations 动画
 | Fireworks images from Dreamweaver 在Dreamweaver中应用
 | in the workspace工作区
 | overview 图像优化总论
 | using Export Wizard使用输出向导
ovals, drawing 椭圆绘制
overlapping slices 切片重叠
蓝骑士


（侠客岛版权所有）

P
palette 调色板
 | adding from screen to 从屏幕获取色彩
 | choosing 选择
 | choosing custom 选择自定义色板
 | choosing working 选择工作色板
 | color models色彩模式
 | creating colors创建色彩
 | replacing color色彩取代
 | saving custom swatches 保存自定义色板
panels 面板
 | description 种类
 | Edit Stroke Options 编辑笔触选项
 | Edit Stroke Sensitivity编辑笔触灵敏度
 | Edit Stroke Shape 编辑笔触形状
 | Effect效果
 | Fill 填充
 | Find and Replace 填充并取代
 | Frames 影格
 | hiding 隐藏
 | Library库
 | removing tabbed panel 移出面板
 | Stroke 笔触
 | Styles 样式
 | Swatches 色板
 | Tool Options 工具选项
 | URL panel URL面板
panning 平面移动
Paste as Mask 遮照粘贴
Paste Inside 内部粘贴
pasted images 重采样粘贴图像
paths 路径
 | adding stroke texture 添加笔触纹理
 | bending adjacent segment弯曲临近段
 | changing adjacent segment 改变临近段
 | changing shape 改变形状
 | converting straight to curved 变直线为曲
 | copy and paste拷贝并粘贴
 | creating custom strokes 创建自定义笔触
 | cropping 切割路径
 | editing strokes 编辑笔触
 | resetting default colors 重置默认色彩
 | selecting a point选择点
 | splitting 分离联合
 | swapping stroke and fill colors 反转笔触和填充色彩
Pattern fills 图案填充
 | adding external to list 添加外部图案到列表
 | adjusting 调整
 | applying 应用
 | moving 移动
 | rotating 旋转
 | transforming 变形
Pen tool 钢笔工具
 | adding points 添加点
 | curved segments 曲线段
 | deleting points 删除点
 | resuming path重置路径
 | straight segments 直线段
Pencil tool 铅笔工具
perspective illusion 透视效果
Photoshop Photoshop
 | customizing files for export 自定义输出
 | exporting to 输出到
 | grouped layers 群组层
 | import options导入选项
 | layer masks 遮照层
 | working with Photoshop masks 使用Photoshop遮照
Photoshop and Fireworks Photoshop和Fireworks
 | animation动画
 | automation自动处理
 | bitmap and vector editing 位图和矢量图编辑
 | clipping groups 群组剪切
 | effects效果
 | exporting PSD files from Fireworks Fireworks输出PSD文件
 | filters 滤镜
 | gradients色彩渐变
 | grouping 群组
 | history 历史
 | importing PSD files into Fireworks导入PSD文件
 | keyboard shortcuts 键盘快捷键
 | layer masks 遮照层
 | layers层
 | masking遮照
 | optimizing files 文件优化
 | text文字
 | tonal adjustments 图像调整
Photoshop plug-ins Photoshop插件
 | Acquire installation 获取路径
 | applying应用
 | installing 安装
Pick Distance 选中范围
pixels 像素
 | adjusting tonal range 色调范围
 | adjusting tonal range using Curves色调曲线修正
 | adjusting tonal range using eyedropper 使用吸管色调曲线修正
 | Auto Levels 自动色调修正
 | bitmap mode 位图模式
 | cloning 克隆
 | contracting selection border收缩选区边界
 | copying复制
 | cutting 剪切
 | erasing橡皮擦擦除
 | expanding selection border 扩展选区边界
 | feathering 羽化
 | moving 移动
 | painting 填色
 | selecting 选取
 | selecting area around marquee 选取圈选区边缘
 | selecting freeform area 选取任意区域
 | selecting polygonal area 选取多边形区域
 | selecting similar colors 选取相似色彩
 | smoothing marquee border 光滑圈选区域
 | tonal range色调范围
playing animations 播放动画
plotting points 标识点
plug-ins 插件
 | as Live Effects 实时效果
PNG PNG
 | choosing a color palette 选择调色板
 | choosing PNG 选择PNG
 | optimization settings 最优化设置
point handles 曲柄
 | displaying 显示
points 点
 | adding 添加
 | bending adjacent segment 弯曲临近段
 | changing adjacent segment 改变临近段
 | converting 转换
 | converting straight to curved 转换直线成曲线
 | deleting删除
 | moving 移动
 | selecting 选择
Polygon Slice tool 多边形切片工具
Polygon tool 多边形工具
 | stars 星形
polygons 多边形
 | constraining 约束
pop-up menu, dragging 弹出菜单拖动
pop-up menu outline 弹出菜单外框
pop-up menus 弹出菜单
 | creating 创建
 | description描述
 | designing appearance设计外观
 | editing 编辑
 | entering menu text 输入菜单文字
 | exporting 输出
preferences 参数
 | color defaults 色彩默认
 | editing options 编辑选项
 | folder options 文件夹选项
 | Import 输入
 | import options输入选项
 | interpolation options插值选项
 | Launch and Edit 装载和编辑
 | setting 设置
 | Undo steps回复步数
preview预览
 | buttons 按钮
 | pixels containing specific color 约束色彩
 | rollovers 鼠标掠过
 | selecting an area to optimize 选择最优化区域
Preview tab 预览标签
progressive JPEGs 渐进式JPEG
Project Log 项目日志
 | adding 添加
 | exporting a file 输出文件
 | logging Find and Replace changes 记录查找和替换
 | opening files 打开文件
 | printing 打印
 | removing all entries 去处所有记录
 | removing an entry 去处单个记录
 | searching 查找
 | viewing 显示
pulling paths路径牵引
Punch command 打孔命令
pushing and pulling paths 路径推拉
pushing paths 路径推动
蓝骑士


（侠客岛版权所有）

R
RAM, see System requirements内存,参看系统要求
Rectangle tool 矩形工具
rectangles矩形
drawing绘制
rounded corners圆角
Redraw Path tool路径重绘工具
redrawing paths路径重绘
reducing points减少点
reference sheet
relative URLs, entering进入相对URL路径
Remove from Transparency button从透明中移除
removing移除
effects效果
parts of a path部分路径
Rename Stroke dialog box笔触重命名对话框
renaming重命名
Gradient fills渐变填充
strokes笔触
symbols标识
reordering, effects效果记录
repeating actions动作重复
replacing替换
replaying animations动画重放
resampling重采样
bitmap objects位图对象
described描述
downsampling向下采样
resampling up向上采样
vector objects矢量对象
reshaping vector objects矢量对象变形
resizing Fireworks images from Dreamweaver在Dreamweaver中重定义Fireworks图像尺寸
results of exporting输出结果
Reveal All显示所有
Reveal Selection显示所选部分
RGB color modelRGB色彩模式
rollovers鼠标掠过
active area响应区域
adding添加
Down state按下状态
Over While Down state按下状态鼠标掠过
attaching URLs添加链接
bevel effects斜角效果
converting from Fireworks 2 format转换自Fireworks2格式
creating创建
defined定义
editing编辑
inserting from libraries插入库对象
navigation bars导航栏
odd-shaped rollovers不规则翻转
simple rollovers简单翻转
swap image图像翻转
with overlapping slices使用重叠切片
rotating旋转
constraining约束
objects对象
relocating axis of rotation重置旋转轴
Rounded Rectangle tool圆角矩形工具
rulers标尺
蓝骑士


（侠客岛版权所有）

S
saturation饱和度
Save Stroke dialog box笔触保存对话框
Scale Transform tool放缩变形工具
scaling, objects对象放缩
scaling graphics图片放缩
scaling images, interpolation options放缩图片,插值选项
scratch disks临时文件磁盘
searching查找
segments, converting线段的转换
selecting选择
 | additional objects对象的添加
 | area around marquee圈选边缘区域
 | contracting marquee border收缩圈选边界
 | deselecting an object取消对象选择
 | deselecting marquee取消圈选
 | expanding marquee border扩展圈选边界
 | feathering edges羽化边缘
 | freeform area of pixels选择任意区域
 | grouped objects群组对象
 | images影像
 | pixels像素
 | points点
 | polygonal area of pixels选择多边形区域
 | similar colors相似色彩
 | smoothing marquee border光滑圈选边界
Selective JPEG compression选择性JPEG压缩
 | Enable Selective Quality使品质选择允许
 | overlay color色彩覆盖
 | preserve button quality保持按钮品质
 | preserve text quality保持文字品质
Selective Quality button品质选择按钮
Send Backward command向后移动命令
Send to Back command移动到最后命令
set设置
 | pop-up menu behavior弹出菜单动作
 | text of status bar状态栏文字
shadow effects阴影效果
Sharpen More Xtra外挂功能之更多锐化
Sharpen Xtra外挂功能之锐化
sharpening锐化
shortcut sets快捷建设置
 | reference sheet参考表
 | secondary shortcuts候选快捷键
Show/Hide hotspots and slices显示/隐藏热点和切片
showing显示
 | edges边缘
 | panels面板
 | rulers标尺
 | Tool Options panel工具选项面板
 | toolbars工具栏
simple rollover简单翻转
 | applying simple rollover behavior应用简单翻转动作
 | creating创建
simple rollover behavior简单翻转动作
Simplify command简化命令
simplifying paths简化路径
Skew Transform tool倾斜变形工具
skewing, objects对象倾斜
slanting, objects对象倾斜
slice guides, viewing显示切面引导线
slice objects切片对象
 | auto-naming自动命名
 | definition定义
 | editing Fireworks table slices from Dreamweaver从Dreamweaver编辑Fireworks表格切片
 | updating更新
Slice tool切片工具
slices切片
 | creating创建
 | exporting输出
 | optmization settings设置最优化
 | overlapping slices切片重叠
 | polygon多边形
 | show/hide slice overlay显示/隐藏重叠切片
 | text slices文字切片
 | using nested tables使用嵌套表格
 | using spacer使用间隔
 | using the slice overlay重叠使用切片
slicing切片
 | definition定义
 | for interactivity为了交互性
Smooth command光滑命令
Snap Distance吸附距离
Solid fills固色填充
 | adding texture添加纹理
 | applying应用
spacers间隔
Split command分离命令
squares正方形
stacking, objects对象层叠
stars星形
 | constraining约束
straight segments, editing编辑直线段
striped border纹理边界
Stroke panel笔触面板
strokes笔触
 | adding external textures to list添加外部纹理到列表
 | adding texture添加纹理
 | changing centering改变中心
 | changing color of drawing tools改变绘画色彩的工具
 | choosing a stroke选择笔触
 | creating custom创建自定义笔触
 | deleting删除
 | drawing fill over填充
 | edge边缘
 | editing编辑
 | finding and replacing查找和替换
 | renaming重命名
 | reorienting再调整
 | resetting default color重新设置默认色彩
 | saving settings保存设置
 | setting sensitivity设置灵敏度
 | swapping stroke and fill colors反转笔触和填充色彩
 | using in another document在其他文件调用
styles样式
 | adding添加
 | applying应用
 | basing on existing styles基于存在的样式
 | defined定义
 | deleting删除
 | editing编辑
 | enlarging preview icons扩大预览图标
 | exporting输出
 | importing输入
 | new新建
 | resetting to defaults重置并保存为默认
 | saving effects as保存效果为
Styles panel样式面板
Subselection tool, auto-join paths子选择工具,自动联合路径
Support Center支持中心
swap image behavior翻转图片动作
swap image rollover鼠标掠过翻转图片
 | creating disjoint rollover创建复杂翻转
 | with single slice使用单一切片
swatches, Windows System colors色板,Windows系统色彩
Swatches panel色板面板
 | appending a palette添加调色板
 | clearing清除
 | deleting a color删除色彩
 | replacing a color色彩替换
 | saving custom保存为自定义
 | sorting分类
Symbol Library物件库
Symbol Properties dialog box物件属性对话框
symbols物件
 | breaking a link断开链接
 | creating创建
 | creating instances创建实例
 | defined定义
 | deleting删除
 | duplicating复制
 | editing编辑
 | exporting输出
 | importing输入
 | modifying定义
 | placing instances in document在文件中放置实例
 | tweening运动
System color picker系统色彩提取
 | color boxes色盒
System requirements系统要求
蓝骑士


（侠客岛版权所有）

A
absolute URLs, entering 绝对地址，写入
ACT swatches ACT 色样
activating, bitmap mode 激活，位图模式
adding 增加
 | frames 影格
 | styles 样式
adjusting 调整
 | hue or saturation 色调 或 饱和度
 | tonal range 色调范围
 | tonal range using eyedropper 使用吸管
aligning 排列
 | button state graphics 按钮状态图形
 | objects 对象
alpha, converting images to alpha透明度，转换图形
alternate text 改变文字
animation 动画
 | adding frames 增加影格
 | creating from multiple files 从多文件中创作（动画）
 | custom frame viewing 自定义影格视图
 | deleting frames 删除影格
 | disabling layer sharing 取消层共享
 | editing Fireworks animations 编辑Fireworks动画
 | exporting 输出
 | exporting as Flash file 以Flash 文件输出
 | exporting as multiple files 以多文件输出
 | inserting frames 插入影格
 | looping 循环
 | managing frames 影格的管理
 | moving objects to another frame 移动对象到另一影格
 | multi-frame editing 多影格编辑
 | onion skinning 洋葱皮效果
 | opening 打开
 | optimizing 优化
 | playing 播放
 | previewing 预览
 | reordering frames 重排影格顺序
 | setting frame delay 设置影格延时
 | sharing layers across frames 不同影格共享层
 | transparency 透明度
 | turning frames on and off 打开关闭影格
 | viewing all frames 显示所有影格
 | viewing before and after frames 显示前后影格
 | viewing multiple frames 显示多影格
 | viewing next frame 显示下一影格
anti-alias 抗锯齿
 | removing halos 消除光晕
 | smoothing text edges 平滑文字边缘
 | target background color 目标背景颜色
anti-aliased edges, creating 抗锯齿边缘，创建
Apple Color Picker 苹果机颜色拾取器
arranging, frames 编排，影格
Auto Levels Xtra 自动色调修正外挂功能
auto-naming slice objects 自动命名切片对象
 | changing default naming convention 改变默认命名规则
汉化： Flashcat


（侠客岛版权所有）

T
text 文字
 | color色彩
 | direction 方向
 | editing编辑
 | entering进入
 | finding and replacing 查找和替换
 | orientation 倾向
 | overview总览
 | slices 切片
text alignment文字排列
 | center中心
 | justified自动行间调整 
 | left左
 | right右
 | stretch自动行宽调整
text attributes, saving 文字属性保存
text block 文字对象
 | auto-sizing 自动尺寸
 | moving移动
 | resizing 尺寸重定义
Text Editor文字编辑器
text paths 文字路径
 | attaching text to path 文字附着路径
 | changing shape of path改变路径形状
 | converting text to path转换文字为路径
 | detaching from path 从路径分离
 | editing text attached to a path 编辑附着路径的文字
 | moving starting point of text 一定文字起点
 | placing text on a path放置文字在路径
text style 文字样式
 | bold 加粗
 | effects效果
 | fill填充
 | italic倾斜
 | stroke笔触
 | underline下滑线
Text Tool文字工具
texture纹理
 | adding to fills添加到填充
 | adding to strokes添加到笔触
thumbnails对象指示
tonal range色调范围
 | adjusting automatically自动调整
 | adjusting with Curves利用色调曲线调整
 | adjusting with Levels利用色级调整
tool groups工具组
Tool Options panel工具选项面板
toolbars工具栏
 | docking置入
 | rearranging重新排布
 | showing and hiding显示和隐藏
 | unlocking置出
tools工具
 | changing options改变选项
 | changing stroke color改变笔触色彩
 | choosing选取
 | choosing alternate tools选取某一工具
 | displaying显示
 | Distortion Transform不规则变形
 | in Tools panel在工具面板
 | Scale Transform放缩变形
 | Skew Transform倾斜变形
 | Tools panel工具面板
 | Transform变形
Tools panel工具面板
 | choosing tools改变工具
 | contents内容
 | displaying显示
ToolTips工具提示
transform text变形文字
Transform tools变形工具
 | Distortion Transform tool不规则变形工具
 | Scale Transform tool放缩变形工具
 | Skew Transform too倾斜变形工具
transforming变形
 | by dragging通过拖拽
 | numerically数字化
 | objects对象
transparency透明
 | adding or removing colors添加或删除色彩
 | animation动画
 | converting images to gradient transparency转换图像为渐变透明
 | selecting a color选择色彩
transparency illusion透明影像
transparent areas透明区域
triangles三角形
trimming canvas裁减画布
Tutorial教程
Tween Instances command实例运动命令
tweening运动
 | characteristics特征
 | defined定义
 | objects对象
types of color palettes 调色板类型
 | adaptive最适用色
 | black and white黑白
 | custom自定义
 | exact精确色
 | grayscale灰阶
 | system (Macintosh)Mac系统色
 | system (Windows)Windows 系统色
 | uniform均衡色
 | Web 216网页标准色
 | Web adaptive网页最适用色
蓝骑士


（侠客岛版权所有）

U
Undo 撤销操作
 | setting number设置数目
ungrouping objects对象群组取消
Union command 洋葱皮命令
Unsharp Mask Xtra 非锐化遮照外挂功能
Update HTML更新HTML代码
Update HTML command 更新HTML命令
updating slices 更新切片
URL Library URL库
 | adding URLs 添加URL
 | adding used URLs 添加已使用的URL
 | creating创建
 | entering absolute or relative URLs进入绝对或相对URL
 | overview 总览
URL panel URL面板
URLs URLs
 | assigning to a Web object指定网页对象链接
 | assigning to rollovers 指定鼠标掠过链接
 | attaching to buttons附着到按钮
 | finding and replacing查找和替换
 | selecting target options选择目标选项
蓝骑士


（侠客岛版权所有）

V
valid files 有效文件
vector graphics矢量图片
vector masks 矢量遮照
 | converting to bitmap mask 转换为位图遮照
 | creating创建
 | using an existing object使用存在对象
vector mode矢量模式
 | activating切换
 | entering进入
vector objects, reshaping 矢量对象重绘
vector paths, exporting矢量路径输出
蓝骑士


（侠客岛版权所有）

W
WBMP files, opening from Fireworks 打开WBMP文件
WBMP format, exporting to WBMP格式输出
Web photo albums, creating创建网页相册
Websafe colors 网络安全色
Windows, System requirements for Windows系统要求
Windows System Colors, as a swatch group Windows系统色彩
Wizard 向导
 | Export 输出
 | Link 链接
 | Optimize to Size尺寸优化
workflow工作流程
蓝骑士


（侠客岛版权所有）

X
Xtras 外挂功能
 | as Live Effects 实时效果
 | Auto Levels 自动色调修正
 | Blur模糊
 | Blur More 更模糊
 | Brightness/Contrast亮度/对比度
 | Curves 色调曲线修正
 | Find Edges寻找边缘
 | Gaussian Blur 高斯模糊
 | Hue/Saturation 色相/饱和度
 | Invert 色彩反转
 | Levels 色调修正
 | Sharpen 锐化
 | Sharpen More 更锐化
 | Unsharp Mask 非锐化遮照
蓝骑士


（侠客岛版权所有）

Z
zooming 放缩
 | into a specific area 特定区域放缩
 | 蓝骑士


（侠客岛版权所有）

B
backing up, during Find and Replace 在查找替换时，备份
baseline shift 基线微调
Batch Process dialog box 批处理对话框
batch processing 批处理
backing up 备份
files 文件
commands 命令
file names 文件名
Find and Replace 查找和替换
how to 怎样做
optimization settings 优化设置
saving as scripts 保存脚本
saving files 保存文件
scaling graphics 调整图形尺寸
batch scripts 批处理脚本
dragging and dropping 拖放
running 运行
behaviors 行为
Behaviors panel 行为面板
Dreamweaver 4
nav bar down 导航栏down状态
nav bar over 导航栏over状态
nav bar restore 导航栏状态复原
previewing 预览
set pop-up menu 设置弹出式菜单
set text of status bar 设置状态栏文字
simple rollover 简单的图象变换
swap image 替换图案
beveled edges 边缘斜角
bitmap graphics 位图图形
bitmap masks 位图蒙版
creating 建立
using an existing object 使用现有对象
bitmap mode 位图模式
activating 激活
defined 定义
hiding striped border 隐藏位图的条纹边框
leaving 离开（位图模式）
settings 设置
blend colors of overlapping objects 重叠物体的颜色混合
blending 混合
applying 应用
Layers panel 层面板
set blending mode 设置混合模式
set default blending mode 设置默认混合模式
blending modes 混合模式
color 颜色
darken 暗模式
difference 交错模式
erase 擦除模式
hue 色调模式
invert 反色模式
lighten 亮模式
luminosity 亮度模式
multiply 累加模式
saturation 饱和度模式
screen 屏幕模式
tint 上色模式
blending objects 混合对象
Blur More Xtra 强模糊外挂功能
Blur Xtra 模糊外挂功能
blurring 模糊
Border command 边框命令
brightness 亮度
Brightness/Contrast Xtra 亮度/对比附加功能
Bring Forward command 置前命令
Bring to Front command 置于最前命令
broken HTML links HTML断链
Brush tool 笔刷工具
brushes 笔刷
saving settings 保存设置
setting tip 设置笔尖
stroke options 笔触选项
Button Editor, creating symbols 按钮编辑器，建立符号
Button Library, importing symbols 按钮库，导入符号
button symbol, importing 按钮符号，导入
buttons 按钮
active area 感应区域
adding 增加
Down state 鼠标down状态
Over While Down state 鼠标over和down状态
attaching URLs 附加URLs
bevel effects 斜角效果
Button Editor 按钮编辑器
converting from Fireworks 2 format 转变Fireworks 2格式
creating 创建
defined 定义
editing 编辑
editing text on 编辑按钮文字
exporting 输出
functionality defined 功能定义
inserting from libraries 从按钮库插入
Link Wizard 链接向导
navigation bars 导航栏
overview 概述
simple rollover 简单图象变换效果
汉化： Flashcat


（侠客岛版权所有）

C
cache files 缓存文件
canvas 画布
 | modifying charteristics 改变特性
 | modifying resolution 改变分辨率
 | rotating 旋转
 | trimming 删剪
centerpoint, drawing from 从中心绘制图形
circles 圆
Clipboard 剪贴板
cloning, images 克隆图形
CMY color model 黄品青颜色模式
color 颜色
 | adding from screen to a palette 从屏幕向调色板加颜色
 | applying from Swatches panel 使用色样颜色
 | changing stroke 改变笔触
 | choosing color depth 选择颜色范围
 | choosing working palette 选择操作面板
 | clearing Swatches panel 清空色样面板
 | color models 色彩模式
 | creating in Color Mixer 在混色器里创建
 | deleting from Swatches panel 从色样中删除
 | dithering with Websafe 抖动为网络安全色
 | finding and replacing 查找和替换
 | finding and replacing non-Websafe 查找和替换非网络安全色
 | Gradient fill 简编填色
 | inverting values 反转色值
 | obtaining using Eyedropper tool 用吸管获取颜色
 | overview 概述
 | picking from color bar 从颜色栏取色
 | removing unused colors 移除不用的颜色
 | replacing a swatch 替换色样
 | resetting default 恢复默认
 | sampling 采样
 | saving custom palette 保存自定义调色板
 | setting preferences 设置系统参数
 | sorting Swatches panel 色样排序
color bar, choosing a color 颜色栏，取色
color box 颜色盒
 | Apple Color Picker 苹果机颜色拾取器
 | System color picker 系统颜色拾取器
color correction 颜色修正
 | Auto Levels 自动色调修正
 | automatic 自动化
 | brightness and contrast 亮度和反差
 | Curves 色调曲线
 | Levels 色调分布
 | using eyedropper 使用吸管
color fills 填色
Color Mixer 混色器
 | creating colors 创建颜色
color models 颜色模式
 | CMY 黄品青
 | Grayscale 会阶
 | Hexadecimal 16进制
 | HSB （色调/饱和度/亮度）
 | RGB
color palette 调色板
 | adding from screen to 从屏幕加颜色
 | appending to current palette 向现有调色板添加
 | choosing 选择（调色板）
 | choosing custom 选择自定义（调色板）
 | choosing working 选择当前（调色板）
 | clearing 清除（调色板）
 | color models 色彩模式
 | creating colors 创建颜色
 | deleting colors 删除颜色
 | editing 编辑颜色
 | importing 导入
 | locking colors 锁定颜色
 | optimizing 优化
 | replacing color 替代颜色
 | saving 保存
 | saving custom swatches 保存自定义色样
 | setting number of colors 设置颜色数
 | sorting 排序
 | viewing 显示
Color Table 色表
 | edited swatch 编辑色样
 | locked swatch 锁定色样
 | panel 面板
 | selecting a color 选择颜色
 | selecting multiple colors 多选颜色
 | selecting range of colors 选择一系列颜色
 | swatch with multiple attributes 多属性色样
 | transparent swatch 透明色样
 | updating 更新
 | Websafe swatch 网络安全色样
colorize, images 改变色彩，图象
combining paths 合并路径
commands 命令
 | batch processing 批处理
 | saving 保存
composite paths 复合路径
compositing 复合
compression, blurring edges 压缩，模糊边缘
configuring Fireworks 设置 Fireworks
Constrain Proportion 限制比例
constraining, rotation 限制旋转
context menus 右键菜单
Contract command 收缩命令
contracting paths 收缩路径
contrast 收缩
copying, pixels 复制像素
copying and pasting, Fireworks HTML 复制/粘贴Fireworks HTML
CorelDRAW files, opening from Fireworks 打开CorelDRAW文件
corner points （直线）节点
Create Web Photo Album command 创建网络像册
Crop command 裁剪命令
CSS Layers CSS层
 | exporting 输出
 | exporting from Fireworks 从Fireworks输出
curve points 曲线节点
curve segments, editing 编辑曲线段
Curves Xtra 色调曲线外挂功能
custom shortcut sets 自定义快捷设置
 | conventions 快捷常规
 | deleting 删除
cutting paths 切割路径
汉化： Flashcat


（侠客岛版权所有）

D
Deselect command 取消选择命令
Design Notes, for Dreamweaver and Fireworks integration 设计笔记，用于Dreamweaver、Fireworks整合使用
designing entire Web pages 设计全页面
Director, exporting to Director,输出
disjoint rollover 调换影象rollover
 | creating 建立
display modes, switching 切换显示模式
distorting objects 扭曲对象
Distortion Transform tool 扭曲变形工具
dithering 抖动
 | with Websafe colors 扭曲变形工具
document 文件
 | default mode 默认状态
 | display mode 显示状态
 | multiple views 多视图
 | tiling views 视图排列
document redraw 文件重绘
downsampling 减少采样点
drag-and-drop behaviors 拖放行为
 | blue line 兰线
 | creating disjoint rollovers 创建调换影象
 | creating disjoint rollovers with 创建调换影象
 | definition 定义
 | deleting 删除
 | for single slice 使用单一切片
dragging and dropping 拖放
dragging pop-up menus 拖动弹出式菜单
drawing绘制
 | bending adjacent segment 弯曲相邻线段
 | changing adjacent segments 改变相邻线段
 | converting straight paths to curved 直线转为曲线
 | distorting objects 扭曲对象
 | selecting a point 选择一个点
 | splitting paths 切割路径
Dreamweaver
 | edit Fireworks images in 编辑Fireworks图象
 | exporting to 输出
Dreamweaver 4 behaviors Dreamweaver 4行为
Dreamweaver and Fireworks integration 整合Dreamweaver和Fireworks
 | creating Web photo albums 建立网络相册
 | Design Notes 设计笔记
 | editing Fireworks animations 编辑Fireworks动画
 | exporting CSS Layers 输出CSS层
 | exporting Dreamweaver library items 输出Dreamweaver图库物件
 | external editor preference 自定义外部编辑器
 | inserting Fireworks files 插入Fireworks文件
 | Launch and Edit preferences 启动及编辑自定义
 | launching and editing Fireworks images 启动及编辑Fireworks图象
 | launching and editing Fireworks tables 启动及编辑Fireworks表格
 | launching and optimizing Fireworks images 启动及优化Fireworks图象
 | Optimize Image in Fireworks command 用 Fireworks命令优化图象
 | resizing Fireworks images 缩放Fireworks图象
 | updating Fireworks HTML 更新Fireworks HTML
Dreamweaver libraries, exporting from Fireworks 从Fireworks输出Dreamweaver库文件
汉化： Flashcat


（侠客岛版权所有）

E
edges, showing and hiding 边，显示/隐蔽
Edit Gradient dialog box 编辑渐层对话框
Edit Stroke dialog box 编辑笔触对话框
Edit Stroke Options panel 编辑笔触选项面版
Edit Stroke Sensitivity panel 编辑笔触灵敏度面版
Edit Stroke Shape panel 编辑笔触形状面版
editing 编辑
 | buttons 按钮
 | rollovers 变化影像
Effect panel 效果面版
effects 效果
 | applying filters as 应用滤镜
 | applying to grouped objects 应用于群组对象
 | applying to objects 应用于对象
 | beveled edges 斜角边缘
 | buttons and 按钮
 | disabling 取消效果
 | editing 编辑
 | embossing 浮雕
 | finding and replacing 查找/替代
 | glow 光晕
 | Live 实时
 | plug-ins 插件
 | reactivating 重激活
 | removing 移除
 | reordering 改序
 | saving as styles 存为样式
 | setting defaults 设置默认
 | shadow 阴影
 | speeding up redraw 加速重绘
Ellipse tool 椭圆工具
ellipses, drawing 画椭圆
embossing 浮雕
Empty Bitmap command 空白位图命令
EPS files, opening in Fireworks 打开EPS文件
erasing, pixels 擦除像素
Expand command 扩大
Expand Stroke command 扩大笔触命令
expanding paths 扩大路径
expanding strokes 扩大笔触
Export Area tool 输出区域工具
Export dialog box 输出对话框
Export Preview 输出预览
 | comparing optimization settings 比较优化设置
 | exporting 输出
 | optimizing 优化
 | panning area 显示区域
 | previewing 预览
 | previewing optimization 预览优化
 | zooming 放大缩小
Export Wizard 输出向导
 | using 使用
exporting 输出
 | an area 部分区域
 | animated GIFs GIF动画格式
 | animations as multiple files 动画多文件形式
 | buttons 按钮
 | CSS Layers CSS层
 | CSS Layers from Fireworks 由Fireworks生成CSS层
 | customizing files for Photoshop 为Photoshop自定义文件
 | Fireworks files to Dreamweaver 由Fireworks输出到Dreamweaver
 | for Photoshop 用于Photoshop
 | frames as multiple files 每桢/文件输出
 | images 图象
 | layers as multiple files 每桢/文件输出
 | library items from Fireworks 输出成library
 | overview 概述
 | results 结果
 | slices 切片
 | styles 样式
 | symbols 符号
 | to Director 输出到Director
 | to Dreamweaver 输出到Dreamweaver
 | to Flash 输出到Flash
 | to FreeHand 输出到FreeHand
 | to Illustrator 输出到Illustrator
 | to Lotus Domino Designer 输出到Lotus Domino
 | to Photoshop 输出到Photoshop
 | to WBMP format 输出为WBMP格式
 | vector paths 输出为适量路径
Extending Fireworks, scripting resource 输出为脚本资源
extensibility 可拓展性
external editors 外部编辑器
 | Fireworks. See Dreamweaver and Fireworks integration 整合
 | preference 自定义
external files, converting to rollovers 使用外部文件制作影象替换
汉化： Flashcat


（侠客岛版权所有）

F
Feather command 羽化命令
feathered edges, creating 创建羽化边缘
feathering 羽化
file download time 文件下载时间
file format 文件格式
 | choosing GIF 选择GIF格式
 | choosing JPEG 选择JPEG格式
 | choosing PNG 选择PNG格式
file names, changing in a batch process 批处理变化文件名方式
file size 文件大小
 | reducing quality 降低质量
 | setting loss to reduce size 设置损失以缩小文件
Fill Color 填色
 | applying 应用
fill edges, changing 改变填色边缘
Fill panel 填色面板
fills
 | adding external patterns to list 增加拓展图案到列表里
 | adding texture 增加纹理
 | adjusting 调整
 | applying color fills 应用填色效果
 | applying Gradient 应用渐变
 | applying Pattern 应用图案
 | applying Solid 应用实色
 | changing color for basic shape tools 改变形状绘图工具的颜色
 | dither fill 抖动填色
 | drawing over strokes 用笔触画图
 | editing Gradient 编辑渐变
 | editing Solid 编辑实色
 | feathering or anti-aliasing 羽化或抗锯齿
 | finding and replacing 查找和替换
 | moving 移动
 | resetting default color 恢复默认颜色
 | rotating 旋转
 | saving Gradient 保存渐变颜色
 | setting for drawing tools 设置画图工具
 | swapping stroke and fill colors 替换笔触和填色
 | transforming Gradient 渐变变形
 | transforming Pattern 图案变形
 | transparency illusion 透明假象
filters 滤镜
 | applying as effects 以效果方式应用
 | as Live Effects 实时效果
Find and Replace 查找和替换
 | batch processed files 批处理文件
 | colors 色彩
 | font 字体
 | multiple files 多文件
 | non-Websafe colors 非网络安全色
 | selecting source for search 选择搜索源
 | text 文字
 | URLs
 | uses 用途
Find and Replace panel 查找和替换面板
Find Edges Xtra 边界查找附加功能
finding and replacing 查找和替换
Fireworks
 | configuring 设置
 | converting Fireworks 2 buttons 转变Fireworks 2按狃
 | Help 帮助
 | installing 安装
 | new features 新特性
 | newsgroup 新组
 | resources for learning 学习资源
 | setting preferences 设置自定义
 | Support Center 支持中心
 | System requirements 系统要求
 | work environment 操作环境
 | workflow 工作流
Fireworks and Dreamweaver integration. 整合Fw和Dw See 看 Dreamweaver and Fireworks integration 整合Fw和Dw
Flash
 | exporting animations for 输出动画
 | exporting to 输出
flipping objects 翻转对象
font 字体
 | changing using the Text menu 使用文字菜单改变
 | Find and Replace 查找和替换
 | handling missing fonts 处理缺少字体
 | style 样式
 | type size 字体大小
frame delay (animations) 影格延迟（动画）
frame delay default setting 影格延迟默认设定
frames 影格
 | adding 增加
 | custom viewing 自定义显示
 | deleting 删除
 | disabling layer sharing 取消层共享
 | exporting 输出
 | inserting 插入
 | managing 管理
 | moving objects to another frame 从其他影格移动对象
 | multi-frame editing 多影格编辑
 | onion skinning 洋葱皮
 | reordering 记录
 | setting delay 设置延迟
 | sharing layers for animation 动画层共享
 | turning off onion skinning 关闭 洋葱皮
 | turning on and off 打开/关闭
 | viewing all 显示所有
 | viewing before and after 显示前后影格
 | viewing next 显示后影格
Frames panel 影格面板
freeform paths 自由变形路径
FreeHand
 | exporting to 输出
 | opening files 打开
汉化： Flashcat


（侠客岛版权所有）

G
Gaussian Blur Xtra 高斯模糊附加功能
GIF
 | choosing a color palette 选择调色板
 | choosing GIF 选择GIF
 | optimization settings 优化设置
 | swatches 色样
glow effects 光晕效果
Gradient editor 渐变编辑器
Gradient fills 渐变填色
 | adding new color 填加新颜色
 | adjusting 调整
 | adjusting color transition 调整颜色变化
 | applying 应用
 | changing colors 改变颜色
 | converting images to transparency 图象转为透明
 | deleting saved 删除已保存的
 | Edit Gradient dialog box 编辑渐变对话框
 | editing 编辑
 | moving 移动
 | removing colors 移除颜色
 | renaming 重命名
 | reusing in another document 再其他文件中重新使用
 | rotating 旋转
 | saving 保存
 | sharing between documents 文件间共享
 | transforming 变形
graphics, exporting 输出图象
Grayscale color model 灰阶模式
grid 网格
 | altering cell size 改变网格单元大小
 | changing default color 改变默认颜色
 | showing/hiding 显示/隐藏
 | snapping objects to 吸附
grouping objects 群组对象
guides 辅助线
 | locking 锁定
 | snapping objects to 吸附
汉化： Flashcat


（侠客岛版权所有）

H
halos, removing 移除光晕
handles, transform 手柄，变形
Help 帮助
Fireworks
Online 在线
TechNotes 技术要点
Hexadecimal color model 16进制颜色模式
Hide All 隐藏所有
Hide Panels command 隐藏面板
Hide Selection 隐藏选择
hiding 隐藏
edges 边缘
panels 面板
toolbars 工具栏
histogram 直方图
History panel 历史面板
hotspots 热点
applying drag-and-drop behaviors 应用拖放行为
assigning URLs 分配URL
creating 建立
editing shape 编辑形状
on top of slices 在切片上方
HSB color model HSB颜色模式
HTML
broken links 断链
comments 评论
copying and pasting from Fireworks to Dreamweaver 从Fireworks复制和粘贴到Dreamweaver
files 文件
insert into an existing HTML file 插入原有HTML文件
inserting buttons 插入按钮
inserting from Fireworks into Dreamweaver 从Fireworks插入到Dreamweaver
inserting slices 插入切片
overview 概述
replacing older version 替代老版本
Setup HTML设置
Document Specific tab 文件特定标签
General tab 常规标签
Tables tab 表格标签
updating Fireworks HTML placed in Dreamweaver 更新已放在Dreamweaver中的Fireworks HTML
hue 色调
Hue/Saturation Xtra 色调/饱和度外挂功能
汉化： Flashcat


Using Flash Help&--Overview（侠客岛版权所有）

 Adding the SWF MIME type for Macintosh Internet Explorer users

The movies in Flash Help are Shockwave Flash movies. They are installed on your local hard drive. To use Internet Explorer 3.0 or 4.0 on a Macintosh to view these movies or any Shockwave Flash movies stored locally, you must change your Internet Explorer MIME type Preferences.

To add the SWF MIME type to your Internet Explorer browser preferences on a Macintosh:

1 | Launch Internet Explorer.
2 | Choose Edit > Preferences.
3 | Under Receiving Files, choose File Helpers.
4 | Click Add to add the following information:
 | Representation:
 | Description: Shockwave Flash Extension: .swf MIME type: application/x-shockwave-flash
 | File Type:
 | Application: Flash (browse to where your local copy of Flash is located) File Type: SWFL File Creator: MFL2
 | Handling:
 | How to handle: View with Plugin Application: Shockwave Flash NP-PPC or Shockwave Flash NP-68K (Browse to the appropriate plugin for your machine.)
5 | Click OK.
 | Note: In some versions of Internet Explorer, you may need to repeat this process twice in order to make the changes take effect.
6 | Click the browser's Back button to return to the help topic.
To view older FutureSplash files, repeat these steps with SPL.


Visit the Support Center
Contents Index Search
侠客岛及作者版权所有


other_nav.gif（侠客岛版权所有）

（侠客岛版权所有）


（侠客岛版权所有）

欢迎使用 Fireworks 4 中问帮助!

Fireworks 4 中文帮助

要下载和更新, 到Fireworks支持中心.

Fireworks 4 中文帮助 由侠客岛网站组织翻译，版权产品，翻录必究.