我什么都要--就是没钱

我没钱，但我什么都想要 现在的宽带越来越普及了，好多地方家家户户都有，呵呵，当然也有好多地方没有的,有了宽带，于是好多人就想自己架个网站玩玩，一方面呢，自己的宽带闲着也是闲着，不好好利用有点可惜，另方面呢，就当自己是想学点技术，还有一方面呢是想做点好事，或有什么好东东大家分享一下，陶冶一下情操！！只是....只是听说电脑可以做很多事，自己也知，但就是无从下手。
呵呵！！没关系，看了下面的我的这篇拙作，别的我不敢说，不过让你的一台普通机子，和一条ADSL，成为一台有自己的网页，自己的FTP服务，自己论坛服务，自己的邮件服务器！！！的这么一台功能强劲的服务器，应该是没有问题的！！（嘿嘿--脸有点红）
第一步 | 准备材料 |  |
第二步 | 申请免费域名 | 建议大家用国产免费域名解析软件“花生壳”
第三步 | 安装WEB网页服务 |  |
第四步 | 安装FTP远程文件传输服务 |  |
第五步 | 用Imail架设自己域名的邮件服务器 | 另：用Mdaemon架设自己域名的邮件服务器
第六步 | 安装超级雷傲论坛 | 另：用瘟2000的IIS5安装雷傲论坛
第七步 | 搞定 |  |
 | 开始什么都没有，现在终于有了！！ |  |
 | http://XXXXXX.dns2go.com | 个人网页 |
 | FTP://XXXXXX.dns2go.com | FTP文件传输服务 |
我终于有了自己的 | superman@XXXXXX.dns2go.com | 我的私人信箱 | 容量不限
 | daddy@XXXXXX.dns2go.com | 爸爸私人信箱 |
 | mam@XXXXXX.dns2go.com | 妈妈私人信箱 |
 | sister@XXXXXX.dns2go.com | 小妹信箱 | 100M够了，省得她老是放MP3
 | 。。。 |  |
 | 。。。 | 要几个信箱都行 |
准备材料
材料就不用我说了，只要一台破机加一条ADSL就行了。ADSL呢，最好是拨号上网的，动态IP也没关系，因为动态IP的便宜！（呵呵，其实我还不喜欢固定IP的，因为固定IP一般电信都是做了手脚的，就像局域网一样，可以访问别人，但别人进不来），动态IP一般都是很单纯的（老天，我竟然能说出这么有深度的话），不但可以访问别人，而且别人也可访问你哟！！
至于机器嘛，有以下配置就行了，这个配置我想现在大家都有吧，当然了，越高越好，只要钱多，不过我们本着艰苦朴素的优良传统，讲的是实用，不求最贵，但求最好，只是如果低于这个配置，那就比较困难了。
CPU | 赛扬600 | 足矣 |
内存 | 128M | 最好256M |
主板 | 810集成主板 | 足矣 |
硬盘 | 20G | 最好7200转40G |
软驱 | 要 |  |
光驱 | 要 |  |
显示器 | 15寸 |  |
这么普通的配置我想大家都有的吧，呵呵，等一下，我们就用这个东东，架一台服务器哟！ 操作系统最好是装 Windows 2000 server版,（有win 2000高级服务器版就更好啦） 其他的版本如Windows 2000PRO专业版，Windows XP只玩玩WEB和FTP文件传输可以，想架自己的邮件服务器就不大行了。当然了，如果是Windows 98那当然不行了， Windows 2000 server 装好之后，再装ADSL拨号软件，一般都是电信提供的 Enter 3000，我建议大家用 Winopet2.51这个ADSL拨号软件（现在是4.0版啦） 装好之后打开IE 能上网就算搞定了。该准备的就都准备好了！！呵呵 还有，我建议大家硬盘分区用FAT32，而不要用NTFS，因为是自己玩玩，又不是什么专业服务器，因为自己的电脑自己肯定还要装其他系统玩，用了NTFS只会增加自己的痛苦，而且自己用NTFS比FAT23性能根本好不到哪去。 |  |  |

如有关于本站点的问题或建议，请向 shunsheng@163.net 發郵件。
版权所有(C) 2000 孤星雲鶴---歡迎翻錄，請注明出處。
OICQ：34024155


第二步：申请免费域名 ：
 特别申明：因DNS2GO从2002年10月1日开始收费，强烈建议大家用国产同类产品，“花生壳”
完全可以达到相同的效果。

   没有名字怎么行，当然要先申请名字啦，没有名字别人怎么知道我存在，呵呵，但是我们的ADSL是动态IP，每次断线再拨上去，IP就都变了，这可如何是好，有没有两全的办法，嘿嘿，

我们看中了 DNS2GO 这个软件，这玩意不错，个儿小，量足，功能还挺棒，他不但可以免费提供（我喜欢）一个自定的域名，还可以自动将域名指向你每次不同的动态IP上。 （下载地址）
   先下载个客户端， 下载后安装就可以了，（本站下载的是中文版，只要解压到你的硬盘任一目录就可以了。绿色免安装），因为现在我们还没有帐号和密码，于是我们就上网去申请（因为用软件申请老是出错，上网去申请，几分钟搞定。我们在网址栏中敲入：http://dns2go.deerfield.com//signup/ 并回车，于是就到了他的申请网页。我们选第一个 DNS2GO Domain Name (e.g.you.dns2go.com)点NEXT下一步。

于是出现了这个画面
注册一个你喜欢但又未被人登记的网域名称。
申请过免费信箱的这里就轻车熟路了，这里不但你的域名可以自定，而且服务器也可以自定，比如我这里申请的
shunsheng.dns2go.com这样的域名。还可以申请
shunsheng.d2g.com这样的域名。
（嘿嘿，shunsheng换成你的名字就行了）

选一个别人没注册过的名字按下一步接着就到了这个画面.
除了那个EMAIL地址一定要真实外，其他的乱填就是了。
Email 地址，我建议大家用 hotmail 的，因为那样最快，10分钟之内肯定会回信，嘿嘿163.或其他的可要几个小时，或者要一天，当然了，如果信箱是假的，那你就别想收到注册码。

一直填写完毕，并点 Register Now! 按扭，接着就到了下面这个画面
选select 之后点下一步。

下面这个画面是说DNS2GO除了有免费域名解析外，还有很多增值服务，不过，嘿嘿，要钱的，而且是美金，这些钱以美国的生活水平，可能只是一顿夜消的钱，但我们是贫下中农，没钱给他，（有也不给）呵呵所以除了免费域名之外，什么都不要，。按NEXT 下一步。

出现这个画面，搞定，他提示请下载客户端软件，我们已经下载了，于是就不用再下载了，我们等着他的密码和帐号传到我们的信箱就是了。

等啊等，信箱里终于来了我的DomainName及RegistrationKey（帐号和密码）（别告诉我先前填了假电邮地址，如果是这样的话，现在又要考耐性，从头来过）， 打开客户端将这些资料输入Registration的相关栏位中。

将你得到的域名和注册码填到框里,点确定
（别告诉我你和我一样的名字吧）

哈哈，右下角那架小飞机闪了闪，呵呵，连上了。

呵呵，以后只要你在网上，他就会自动帮你解析了！
DNS2go会保存于系统文件中，于是你每次上网时，它会自动监视你每次上网的IP地址，自动追踪并将其与你申请的网域名称（如shunsheng.dns2go.com，你用你的啦）相对应。
以后别人只要用固定的http://shunsheng.dns2go.com（你用你的啦)就可连接上你架设的网页服务器（虽然现在还没，不过马上就要有了），尽管你上网时所分配的IP地址每次都不同，都不受影响。
你可别小看他，以后所有对外服务的解析全靠他了，呵呵，所以要排在第一位来讲哟。
第一步摆平了，我们就接着第二步吧！！
（建议大家用国产同类免费软件“花生壳”）

如有关于本站点的问题或建议，请向 shunsheng@163.net 發郵件。
版权所有(C) 2002 孤星雲鶴---歡迎翻錄，請注明出處。


第二步：免费域名花生壳

第二步：申请免费域名 ：(花生壳篇）

   特别申明：因DNS2GO从2002年10月1日开始收费，建议大家用完全可以达到相同的效果。我们的ADSL是动态IP，每次断线再拨上去，IP就都变了，这可如何是好，有没有两全的办法，嘿嘿。
我们看中了 国产同类产品，“花生壳”这个软件，这玩意不错，个儿小，量足，功能还挺棒，他不但可以免费提供（我喜欢）一个自定的域名，还可以自动将域名指向你每次拨号不同的动态IP上。

我们先到上网去申请域名的同时，也顺便去下载他的客户端软件。
（我们在网址栏中敲入：http://www.vicp.net 并回车，于是就到了他的申请网页。

点击右边的，“申请傲锐护照” 出现如下画面。

看到“完全免費”几个字，我们心里不知有多爽，点申请。

呵，输一个别人没用过的名字，输入帐号迈密码，信箱，下一步。

搞定，说明我们的护照申请完成，这里要说明一点，护照并不代表你的域名，也就是说，你一个护照可以申请很多个域名哟，我们接下去。

又回来了，呵呵，这次我们有护照了，于是就点，我要注册花生壳。

阅读条款，有点老套，我们点立即注册花生壳。

这里我们输入刚才的护照用户名和密码，按登录。

哈哈，精彩的时刻来了，我们想要的免费域名出现了，这里，我们同样输入别人没有用过的用户名，
（这里的名字可以和护照名一样，也可以不一样，反正可以同时申请好几个呢。
这里我们写了 shunsheng5000.vicp.net(你用你的啦）

带*号的全填上，按确定。

哈哈，出现了，你已成功注册“花生壳” ，也就是说我们已成功地申请了一个http://shunsheng5000.vicp.net这个免费的域名，接下去，我们只要下载他的 PeanutHull客户端软件并安装就行了。
我们点本地下载，并安装。

这个软件同时支持简体，繁体，英文，三个语系，我们选简体就是了

输入用户名和公司名，乱写就是了。按下一步

接着叫你输入你的护照帐号和密码， 注意：这里不是你的域名，是输入你的护照名哟，

按下一步。直到安装完成。

我们就可以看到，花生壳在输入你的护照名之后，自动地显示你的域名列表，如我申请是shunsheng5000.vicp.net这个域名，你还可以用这个护照申请更多个的域名，都同时指向你的电脑。

哈哈，右下角看到一个小小的立方体，如果是红绿蓝三色，那说明你的域名解析成功，
呵呵，以后只要你在网上，他就会自动帮你解析了！
花生壳会保存于系统文件中，于是你每次上网时，它会自动监视你每次上网的IP地址，自动追踪并将其与你申请的网域名称（如俺的是shunsheng5000.vicp.net，你用你的啦）相对应。
以后别人只要用固定的http://shunsheng5000.vicp.net（你用你的啦)就可连接上你架设的网页服务器（虽然现在还没，不过马上就要有了），尽管你上网时所分配的IP地址每次都不同，都不受影响。
你可别小看他，以后所有对外服务的解析全靠他了，呵呵，所以要排在第一位来讲哟。
第一步摆平了，我们就接着第二步吧！！


架WEB服务器

第三步：安装WEB服务

   名字搞定了，现在大伙都知我的电脑以后叫啥了，接着就是架个HTTP的WEB网页浏览服务了。

这次我们看中的是 apache 这个软件，呵呵，好处多多，个小，量足，也是不要钱，安装极为方便，超级傻瓜式的，点几次鼠标就搞定。看看某网站对他的评价，你就知这玩意如何了！！
（最流行的HTTP服务器软件之一。快速、可靠、可通过简单的API扩展，Perl/Python解释器可被编译到服务器中，完全免费，完全源代码开放。如果你需要创建一个每天有数百万人访问的Web服务器，Apache可能是最佳选择。）
乖乖，每天数百万的访问量呢我们是不敢奢求，再说我们的ADSL也受不了，不过东西倒是要的。

我们先点击下载来的apache_1.3.22-win32-x86.exe安装它

点Next 下一步出现这个画面，呵呵，我们刚才申请的域名，现在派上用场了，按申请来的名字填上去就行了，（看清了，是你自己的，别把我的也写上去了）其实这里乱填也无所谓，乱写对单一的WEB服务没有影响。

点下一步，这一步注意了，因为apache 默认的安装路径是
X:/Program files/APache Group/Apache 这个目录下，这么长的目录对以后其他的服务有非常不好的影响，所以我们到这一步要指定目录安装，不要默认安装，点Custom自定义安装。

并指定安装目录 c:\

点OK

点下一步至完成。

至此，apache 安装完毕，我们现在可以看到在C盘根目录下有个新文件Apache点其中的htdocs这个目录，这目录以后就是WEB的默认目录了。将里面的任一文件改名成 index.html 就行了，因为WEB的默认首页文件就是index.html，以后只要将这个文件替换成你自己做的网页就行了。

打开IE浏览器地地址栏输入你的域名，（这里是shunsheng.dns2go.com)如果没上网也没关系，只要在地址栏输入127.0.0.1这个IP地址就可以看到本机的WEB首页了，哈哈。爽!

换成自己的index.html看看（别告诉我你和我一样的吧！！）

过瘾，呵呵，WEB网页浏览服务我们已搞定了，
接下我们去架FTP服务。


架ftp服务

第四步：安装FTP文件传输服务

   既然别人已经可以看自己做网页了，也差不多了，不过如果,想远程维护自己的网页，或是和别人对传文件，或是和别人交流软件和文件，那用FTP是最好不过了。

这次我们看中的是 Serv-U 这个软件，这个应该是当今最常用的FTP软件，它设置简单，功能强大，性能稳定。你现在就可以建立你自己的FTP服务器了。）
（背台词--没办法）

   少罗嗦，我们现在就装它，
点击下载来的文件安装它。这次安装没什么问题，一路默认就是了，一般会自己装在你的
X:\Program Files\Serv-U的默认目录，没关系，

安装完毕，出现此画面，按Finish

弹出配置向导框，按next 下一步

问你是否使用图标菜单，默认用YES下一步 N ext

下一步

这里注意了，让你输入IP地址，但我们是动态的IP地址，每次都是要变的，（括号中是说若为动态IP地址，则留空），我们正是动态的IP地址，我们留空，下一步 Next

输入你的域名，我们刚好申请了一个免费的域名，于是就填上去，因为我们是靠DNS2go的软件进行IP解析的，所以这里写不写域名没有关系统，如果不写，那系统就会自动取名为 Wizard Generated Domain(向导产生域）这个默认域名，没关系，既然我们有域名，那就写上去吧！并按下一步 Next

出现这样对话框，意思是说是否允许匿名登录你的FTP，我们这里允许匿名登录，其实匿名登录也没什么不好，放几首MP3让人家下载一下也好。
当然了，如果你什么时候不想“闲杂人等”看到你的FTP，那也没关系，装好之后只要将用户里的 Anonymous 这个帐号删除就行了。

我们这里允许。按YES 下一步 。

接着他问你，别人不用密码就能看到的目录名是什么，请指定，呵呵，这们当然指定一个不重要的目录给他了。

不过你放心，只要默认的，那别人只能看，不能删的，只读，我们就指定一个 f:/mp3这个目录给他吧。当然你也可以指定你的目录，不用和我一样。按下一步。

来到这个画面，这个画面是系统的默认选项，这里就要注意了，系统问你是否锁定当前目录。比如说，我可以让别人浏览我的F：/MP3目录，而MP3目录下有个VCD的子目录，那如果你锁定当前目录的话，那别人只能看MP3目录里的文件，但不能看VCD子目录里的文件。如果不锁定，则可以看F：/MP3里的所有文件，包括子目录和子目录里的文件，有几层看几层。

但你可以完全放心，你指定F：/MP3的这个目录可以给别人看，即使不锁定，别人也只能看这个目录和子目录的，F：/根目录是看不到的，呵呵，不然还不死定。

选不锁定，下一步

搞定，现在你的FTP就可以匿名访问了。接着问你是否创建指定帐号。我们选是的
选YES 下一步，下面就和上面差不多的了，只不过上面是匿名而下面是指定帐号而以，道理一样。

指定帐号名，这里我们创建一个downlaod这个帐号

下一步，密码我们用downlaod 当然你可以用其他的，最好不要学我，用难一点的。最好经常变

指定目录，我们指定f:/download的目录，这里注意，等下看到都是download分不清，其实很简单，就是说 有个 downlaod 的用户可以用 downlaod这个密码来访问你的F：/download 这个目录。按下一步

同样的道理，问你是否锁定当前目录，我们不锁定，这样别人登录之后就可以看你的f:/download这个目录里的文件，包括子目录也可以看。

接着问你这个帐号是否有特权，当然不给他了，要给也可以，看你喜欢，如果你给这个帐号有特权，嘿嘿，那这个帐号就什么都可以做。

下一步，搞定

出来这个画面。说明你现在设置的都可以了，呵呵，如果还要更详细的设置，或是让一些帐号可以具有上传的权限（就是从远处写到你的硬盘）都可以在里面设置。

比如你要让一个upload的帐号具有上传的功能，则只要在目录访问（Dir Access)这个设置栏里勾上 第二个 Write就可以了，注意，勾一个选项一定要接一下保存的安钮，就是红框框起的那个按钮，否则设置不会生效的。（呵呵，我下图这个设置是不安全的，也就是upload这个帐号可以对F：/upload这个目录做任何事哟！！）

缓口气。现在你在你的浏览器里 输入 ftp://你的域名.dns2go.com(这里是ftp://shunsheng.dns2go.com)回车，呵呵，怎么样，是不是看到你的MP3目录，再按右键，用upload帐号和密码就可以看到你的 f:/upload的目录，还可以上传哟。现在别人只要在浏览器里输入你的ftp://你的域名.dns2go.com 就可以看到并下载文件了。呵呵，当然别人如果是上传，用浏览器很不方便，一般都用CuteFTP这个软件。FTP到现在也基本上安装完成了，有些人也许会说别人没法登入，解决方法是，点管理工具--Internet服务将系统默认的FTP服务和WEB服务关闭就是，因为我们已经有了，不用那些系统自带的东东了，电脑重启后一般就都可以用了。

怎么样，FTP服务也搞定了。接下去就有点难度了，我们要架一个属于自己的邮件服务器，而且要很牛B的那种！！


imail邮件服务器

第五步：安装属于自己的邮件服务器
(1.配置服务器) (2)

   接着我们就要在自己的破机上开始装一个很牛B的邮件服务器，呵呵，这次我们看中的是 Ipswitch,公司的Imail7.05 这个软件。我们看看某个网站对它的广告就知一二了！
（这是一个高性能的，基于标准的SMTP/POP3/IMAP4/LDAP邮件服务器。通过一个简单直观的图形用户界面，非常易于管理。主要特色包括：多域名支持，远程管理，Web邮件，可创建邮递清单（mailing lists），反垃圾邮件支持，等等。。。。。）很牛B吧！

那！这次是不是像前几次那样，看到软件就装呢？！错了，因为这个玩意功能强大，用到系统的各项参数很多，所以不能着急，（不急才怪，巴不得现在就要！！）这次我们要配置我们的Windows2000服务器先。
呵呵，我们开始已经成功申请了 shunsheng.dns2go.com 这个域名并指向我们这台宝贝电脑了。可问题是，我们电脑自己并不认识这个域名，而邮件服务器又要用到它，怎么办呢！小意思，按下面做就是了。

开始我们要指定我们的网卡的IP地址，点控制面板---点网络和拨号连接--点我们自己机上的这块网卡，点TCP/IP属性 ，我们看到他两个都是自己获得IP和DNS地址，这可不行，我们需要将IP改成固定的，大家就改成下面这样吧。（也许有人会问为什么不改成192.168.0.1呢？？嘿嘿，那个IP地址以后双网卡多机共享上网时会用到。不过和这个内容无关，暂且不提,我们就改成192.168.0.2）

接着我们开始设置WINDOWS 2000的DNS解析，点开始--程序--管理工具--DNS就可以了（如果没有也没关系，只要点控制面板---新增/删除程序---添加/删除windows组件----网络服务---勾上域名系统DNS--就有了）

我们点DNS后会出现这个画面，我们点正向搜索区域按右键--新建区域

会弹出这个画面，选第二个标准主要区域（S) 点下一步

出现这个画面，我们输入dns2go.com 就可以了，下一步

出现这个画面，他会自动帮你取文件名为 dns2go.com.dns 没关系，下一步

完成 （呵呵，别急，还有呢）

区域搞定了，我们现在要增加我们的主机了，点刚成的 dsn2go.com 按右键，新建主机。

弹出这个画面，因为我申请到的是 shunsheng.dns2go.com ，所以我的主机名就是 shunsheng,(你用你的名啦），IP地址输入192.168.0.2按添加主机。

弹出了成功地创建了主机记录 shunsheng.dns2go.com 确定，呵呵胜利在望了

嘿嘿，有些人以为好了，但装好之后出现只能发信，没法收信！我们需要解析一下，重新按 dns2go.com 按右键，点属性

点名称服务器，点中间那个编辑按钮，

编辑记录，在服务器名输入 shunsheng.dns2go.com （你用你的名啦）并按解析，IP地址192.168.0.2会自动跑到列表框中，嘿嘿，这才没错呢！！全部确定，退回桌面，这回才是真正搞定DNS解析呢！！哈哈

开个DOS窗口 看看自己刚才的杰作有没有成果，ping shunsheng.dns2go.com 回车，哈哈

自动返回192.168.0.2IP地址，搞定，DNS域名解析成功！！

有人会问，ADSL拨号上网不是动态IP吗！！？ 没关系，他是他的，这是内部的，两人相安无事，别担心那些！不然就是说上三天三夜，说得头大还是听不懂。

搞了这么久，才搞定邮件服务器的前奏，（晕死人！）接下去我们要玩真格的了，要开始安装Imail来得到属于自己的很牛B的信箱。

   (2)


imail邮件服务器-Imail安装

第五步：安装属于自己的邮件服务器
（1） (2.Imail的安装和配置)

   闲话少说，我们现在就开始安装IMAIL，解开下载来的 IMAIL，（要养成先看readme.txt的好习惯哟）

双击imailec.exe安装,出现欢迎窗口，next 下一步，出现这个画面，要你输入你的域名，呵呵，我们开始申请的那个域名现在派上用场了，写上shunsheng.dns2go.com ,（你用你的名啦），

Next 下一步，imail的默认路径都是X:\Imail，这里又要注意了，你必须安装在x:\Imail目录，绝对不能安装在长目录名下，如x:\program file\Imail 目录下，邮件服务器运行时肯定会出错。我们这里就 Browse 指定它装在c:\Imail目录下.

Next 下一步 来到这个画面，我们只要勾上这些服务就行了，太多用不着，太少功能不够，大至说一下，如果没勾上 Imail Web Service 就无法基于网页收发信，Imail Web Calendar Service 是基于网页日程表，POP3 和 SMTP 是收发信一定要的。

照这个图勾选，按Next 下一步

来到这个画面，问你是否添加新用户，呵呵我们先不着急，因为洋文太多，看不懂，没关系，点NO，

再点软体动物（就是俺啦）汉化的IMAIL的汉化包，虽然功力不怎么样，甚至有些单词可能都翻译得不对，但对初学都还是有点帮助的，嘿嘿（脸有点红）

汉化时注意 ，要指向你的IMail安装目录，因为我默认是c:\imail 下。如果你也是安装在c:\imail 下，那安装就是了。

汉化搞定，接着我们点开始菜单的 Imail Administrator

来到如下图Imail 的主界面。点你域名下的 User 按右键 点Add User 新增用户，嘿嘿，精采的来了。

弹出这个画面，叫你输入新用户名，嘿嘿 你喜欢什么名就输入什么名，我就输入 superman 下一步

输入姓和名，这里可以不输入，作用不大，如果你喜欢就输吧，按下一步

输入密码，呵呵自己可要记牢哟

下一步，搞定，
现在一个叫superman@shunsheng.dns2go.com 的这么有个性又牛B的信箱就搞定了，按这个方法你就可以建立随便几个什么名的信箱了，如
爸爸的私人信箱就是 daddy@shunsheng.dns2go.com
妈妈的私人信箱就是 mam@shunsheng.dns2go.com

小妹的私人信箱就是 sister@shunsheng.dns2go.com

（嘿嘿，我这里是shunsheng.dns2go.com,你换成你的名啦）

接下去的界面很容易理解了，不修改就可以用了，（不过小妹老是在老爸老妈面前参我奏折，嘿嘿，来点火药味浓一点的），点sister用户，再点右边窗口的目录，看到信箱的最大容量了吧，嘿嘿，输入10000000 再点应用，搞定
现在小妹的信箱就是10M大小啦。

（注：容量大小单位是字节数，0代表无限大小，10000000代表10兆容量。最大信件数目道理一样，0代表无数目限制，比如，限制了10M的容量，并限制了最大信件数目为15，那么超过10M的信无法传进来，如果没有超过10M，但超过有15封信，则第15封之后的信都会退回，还可以设置单封信的最大的容量。呵呵，功能实在太爽了，说也说不完，光心动没用的，赶快动手架一个吧）

呵呵，成绩如何现在就可以见分晓了，打开收信的玩意，有些人喜欢foxmail,我们就用微软的Outlook Express，道理一样，打开后点工具---点用户----点添加----邮件 就出来这个画面了，

输入我的私人信箱，下一步。

输入邮件地址，嘿嘿派上用场了，输入 superman@shunsheng.dns2go.com

按下一步

输入POP3和SMTP，呵呵两个都输入 shunsheng.dns2go.com (你用你的名啦）

输入刚才创建的我私人信箱的帐号和密码
下一步

完成，叫自己给自己发封信看看，呵！搞定，叫别人从远处发封信给你看看，能收，哈哈，爽！

而且IMAIL还完全支持WEB在线收发哟，用过免费信箱的同志们，我想都很清楚了吧，像网易，新浪，既可以用outlook收发，又可以在网上直接登录之后收发！
Imail 的WEB默认登录端口是8383

就是说你在别的地方只要在IE地址栏中输入 http://shunsheng.dns2go.com:8383 回车就可以登录了

输入你的用户名和密码，呵呵

界面呢虽然没有网易和163那么的花里胡俏，不过该有的功能可一点不少哟，最主要的是容量自己定。名字特牛B特有个性，要什么就有什么，信箱要几个有几个，哈哈，爽。怎么样，心动了吧，动手吧。过了这个村可没这个店了！
古语云：花开堪折直须折，莫待无花空折枝。（老天，我怎么突然冒出一句这么有内涵的诗句来了！嘿嘿）

 （1）

至此，想要的基本上都有了，接下我们就要在自己破机上搞个超级雷傲论坛玩玩。也是现在最牛B的那种。


组网案例：搭建企业邮局

一、 方案分析---企业需求

二、 方案实施
1.所需资料
2.邮件系统搭建立
3.多域名系统处理办法

三、 总结及常见题解决办法

一、 方案分析---企业需求

所谓企业邮局，是一种类似于虚拟主机的服务。直观地说企业邮局就是以企业自己的域名为后缀的电子邮件系统，企业的每一个员工或每一个部门都可以拥有一个myname@mycompany.com这样一个E-mail系统。
目前不少企事业单位所使用的电子邮箱都是当地电信部门或者ISP提供的邮箱如abc@public.szptt.net.cn或者网上免费电子邮箱如 abc@yahoo.com.这些电子邮箱对于私人使用还是比较方便的，还是对于一个单位来说却有不少不足之处
（1）不利于整个单位的统一形象和对外宣传；
（2）邮箱空间是固定不变或一般都偏小，灵活性差；
（3）不利于单位管理员的统一管理；
（4）出现故障不易得到迅速解决。
因此现在企业都需求有一个针对企事业单位的集团电子邮件管理系统
以克服上述不足，并要求邮局系统具有以下优点：：
（1）统一的后缀有利于形象统一和对外宣传；
（2）易于管理的界面能够使管理员对所在单位人员的邮箱进行统一管理；
（3）邮箱空间能够根据不同人员的使用情况进行自动调节；
（4）出现问题能够保证迅速得到解决。
以满足企事业自身发展的需要。

二、 方案实施
1.所需资源及资料。
2.邮件系统搭建立。
3.多域名系统处理办法。

说到邮件服务器，人们往往最容易想到的是老牌的Exchange Servr和经典的IMail Server。这确实是两个好东东，但是，无法回避的现实是，前者一般就适合在企业内部网中使用；而后者呢，虽然既可以在企业内部网中使用，也更适合做互联网上的邮件服务器，但是对于我们中国用户来说，不支持新邮件帐户申请、Web方式对中文的兼容性较差（从WEB所发的信件基本上都是乱码的问题到目前一直未解决）！所以我们需要一个适合中小型企业邮件服务器软件，这次我们看好的是MDaemon这个软件，由美国德克萨斯州的Alt-N技术有限公司（Alt-N Technologies, LTD.）出品
其公司的WinGate等产品都广为人知实际上早在上个世纪的90年代中期（1996年）就已推出了其最初的版本，然而几经周折，直到近一年来才慢慢地开始引起人们广泛的关注，和其他邮件服务器端软件相比，它除了支持比如各种邮件协议和虚拟邮件主机等常用的那些功能之外，最大的特色在于它的 WebMail：有22种语言界面可供轻松转换；支持通过Web页面，在线申请新邮件帐户；Web页面中功能完整，甚至可以直接满足商用目的！至少在这些方面，当今同类软件中，无出其右者！
接下去我们详细讲解如何用MDaemon创建一个完整的企业邮局系统。
a、软件的安装

（1）下载地址：http://gwbn.onlinedown.net/down/md505en.exe（9.82MB）
汉化包 ：http://www.hu.zj.cninfo.net/~htonsoft/soft/mdeamon504cn.rar
华军下载,正式全功能30天测试版

（2）请先卸载或停止原有的所有邮件服务器软件的所有服务，以免造成端口冲突。

1、软件的安装
（1）双击安装文件"md505en.exe"，即可开始MDaemon的安装工作。
点击后，第一步出现这个画面。先选择安装语言，先用英文安装吧

接着出现版权所说，没关系，点 I Agree下一步

问你选择你的安装目录，你可以指定安装目录，也可以使用默认目录，我们就用默认目录吧
（特别要注意，好多软件对长文件名很敏感，所以建议尽量安装于根目录下。不是安装于 X:/program files/XXX,这种长文件名的目录下。否则可能会出现很多问题）
按下一步

接着请输入你的注册信息，呵呵，这里输入自己的大名或公司名就可以了。
输完按下一步。

接着请选择要安装的组件，我们按默认（也就是全选），按下一步

接着电脑告诉你，该要的信息都要齐了，要开始安装了。
按下一步开始安装

一直到安装进度完成，会弹出 DNS配置，上面的是主要IP地址，下面的是备份IP地址，其实就是附属IP。在这里您可以写诸如 域名 和 实际IP的 。如果，没有固定IP,所以这里不用填，按下一步。

接下去这个画面是说请设置你的第一个帐号，三个文本输入框分别是：
填写用户全名：这里的东东就是以后您在写信的时候出现的名字，可以是中文
信箱名： 就是帐号啦，您在这里输入的就是您以后要使用的帐号，你就是你的信箱名,你怎么写随便，别用中文就可以。
密码： 登录信箱的密码
下面的复选框分别是：
This account is the Postmaster ( 这个帐号是管理员帐号 )
This account has Administrator level web access ( 这个帐号是有WEB方式管理员权限的)

根据你的需要选择，选好后，按下一步。

问你是不是要把邮件服务器添加到服务器的系统服务里

（当然要了）这样你的服务器在不登录的情况下就可以开始正常运行邮件系统。
按下一步。

接下来这个画面
那个勾选项是问你是否进行高级选项的进阶安装，呵呵，不用了，直接按下一步

安装完成，是否启动，并查看说明档，呵呵按完成，搞定。

现在安装完毕的还是英文版的，为了操作方便，我们使用汉化版，下载的压缩包里还有一个汉化包，
（我无聊时汉化的）接着~
点（开始）——>（程序）——>（MDaemon）——>（Stop MDaemon ）
关掉？没错是关掉！如果你想汉化的话，不过你认为你的E文不错的话，可以不用汉化，重新启动一下就可以用了，
这里是介绍汉化的。邮件服务器关掉后请解压缩mdeamon504cn.zip文件就看到了汉化文件了，进入这个目录，把这个目录中所有的文件都COPY到你刚才安装完毕的邮件服务器文件目录中的APP目录里面，覆盖掉APP目录中相同的文件 ，汉化完成了，
重新启动机器 。呵呵就可以在右下角看到一个小信封，右键一点，呵呵，弹出这个菜单。

点开启 MDaemon 来到下面这个画面，菜单极多，别怕，菜单多了，设置多了，说明功能很强，也许有人会问怎么会全都是繁体字的，唉，因为这么好的软件，我当然希望更多的人用啦，如果是简体字，则台湾同胞或香港同志的电脑就无法使用，这也是为了照顾一下台湾和香港的同志。

呵呵，出现这个主界面说明我们的安装基本上好了，
接下去，我们就开始设置
1修改默认邮件主机名称
2创建第一个E-Mail地址

现在你可以在浏览器的地址栏输入： http://你的域名:3000 （这里我们用http://shunsheng.dns2go.com:3000作为范例讲解） 回车 （其实端口可以自定义的)
可以出现登录画面，但是进了你进到信箱后看到的域名可能不是 youname@shunsheng.dns2go.com的，可能是yourname@company.mail,这当然不是我们想要的，为什么呢？这是因为我们的主域名没有设置呢，于是我们就点菜单中的设定，下主要网域设定。弹出这个画面。
填上我们申请的域名，（你用你的啦）
下面网域IP,因为我们是动态的，所以不填或用127.0.0。1确定就搞定了，
如果是固定IP地址，则这里填你的域名和固定IP地址。
接下来的设置：
是设置ISP的中继主机（也就是邮件收发代理）IP或域名。（必须选择第一或第二项才可以的）
例如你想使用163.net做中继。可以先去申请个163.NET的信箱帐号，然后选这个项目，在上面的ISP网关主机IP或网域名称里添上163.net （注意！现在很多的ISP都需要SMTP认证，就是说要先认证帐号和密码才能发信，怎么设置呢？也不难的，看到下面出来的“我的ISP要在我传送邮件前，先登录服务器”看到了就点呀！哦，出来了个新的窗口！把那个什么ESMTP的选择勾选了先！！名称就是用你申请来的帐号了，密码也是！）说到这里，也许你想到如果你自己的邮件服务器也有这样的功能就好了，可以的！看到最顶端的POP检查了吗？选择它，然后勾选“在使用SMTP服务器寄信前。。。。。”这个选项，下面的输入框能输入东东了吧，。名字、密码写上这样设定后你的客户如果要用POP3就必须知道你的邮件服务器设定的密码和帐号了，告不告诉你的客户你自己看着办。
再回来看，
第一项：是问你是不是要把所有的信都通过这个ISP来发送
第二项：是问你是不是仅把不能投递的信件通过这个主机发送（有什么用呢？就是说如果你的邮件服务器IP被目的邮件服务器封掉，例如你想往国外的某个朋友那里写信，现在不是说很多国外的邮件服务器封闭了中国邮件IP地址了吗？这一项就有用了，你可以去国外的邮件服务器申请一个帐号和密码，把上面的IP或域名设置为你在国外申请的信箱服务器，视情况设定ESMTP，然后就可以把你在本地发不出去的信件利用国外的这个主机发送了）
第三项：是问你是不是用你自己的服务器发送所有邮件。（选这个就不能选代理邮件服务器了）
选了这个后最下面的选择项又不一样了，“重试邮件队列”就出来了，你可以进去看看，根据你的需要进行设置，这里的选择很简单，你自己就能看明白的。
________________________________________________________________

我们再看上面的其它设定：
连接埠：就是设定服务端口号，你可以修改，但要注意了，修改完毕后最好重新启动服务器。这里只有两个项目要大家注意的——最下面的远端设置栏目 MDConfig是你可以在本地用MDConfig来控制远端服务器上的MDadmon，这个服务的端口设定，你可以改，但别忘了，在你本地的MDConfig上也要相应改动，这个软件在（开始）——（程序）——（MDadmon）——（MDConfig) WebCconfig就是利用浏览器来控制远端MDaemon其WEB登陆方式是：http://你的域名:端口号 例如我的WEB远程控制就是http://shunsheng.dns2go.com:3001（关于这个控制办法大家可以自己测试）
DNS设定：如果你用的是动态IP，别动这个选择，如果是固定IP，你可以进去进行相应的设置。
连线超时：是设定连线空闲超过多唱时间定义为超时的，也是很简单易懂，不多介绍了。
... ... 其它的都是不难的，大家可以自己进行相应的设定，无关大局的。 还有一个比较重要的是：
剔除—— 这是设定服务器对帐号和邮件的删除自动控制的，进去看到这么几个项目：
自动删除帐号........ 就是说，你的客户申请帐号后，多少天没有登录，就自动删除这个帐号。
删除老邮件........... 就是说，你的服务器里的信件如果多少天没有被操作就自动删除这个邮件。
下面的那个不是很重要。

————————————————————————————————

接下去就是

大家可能比较关心如何设置WEB申请和WEB支持了，下面我们就说明一下如何使用WEB支持服务器
现在我们进行下面的操作：首先打开 （档案）看看里面的 WorldClient服务器 选项前面是不是有个勾？如果没有选择它，激活它。
然后打开 （设定） 打开 WorldClient服务器,

_____________________________________________________
会出现如下这个画面
_________________________________________________

启用WorldClient服务器这个选择一定要选择打勾，下面的3000就是WEB页面的端口号，找一个空闲的端口号添上就可以了，端口很多的，不是吗？就拿默认断口3000为例吧，我的ADSL上网的机器动态域名是shunsheng.dns2go.com
那么登录WEB就是域名后面加:3000 (http://shunsheng.dns2go.com:3000) （你用你的域名）
记住，你如果改变了端口号码，就一定要重新启动WordClient服务（对了，就是这个界面上的那个不算短的按键）
3000下面的就是设置超时时间了，多唱时间没有请求页面便视为超时的选择，您可以看自己的情况进行设置。(单位：分钟) 再下面的那个超时选择呢？是用户在编写信件的时候多长时间空间就视为超时。
（超时会怎样？苯呐！！就是邮件踢你出去！！） 下面的IP地址绑定劝大家不要设置的好，不是要对网络服务吗？
大家很想得到的在线申请在哪设定呢？对了！就是那个“允许通过WorldClient客户端来申请和创建新的MDaemon用户！前面只要打勾就OK了！
默认语言 也就是你的邮件服务器将使用什么语言，包括新建用户默认语言。
默认风格 新安装的邮件系统有三个风格可选择的，(你也可以自己增加新的风格，或修改风格)

搞定之后，我们在浏览器地址栏输入
http://shunsheng.dns2go.com:3000一回车，就可出现这个画面

输入开始安装时创建的管理员名字和密码看看，呵呵，清晰明了，无半点网易或163那一大堆连关都来不及关的垃圾广告，COOL!!

我们前期要做的事基本上都做好了，接下去我们就要为默认邮件主机增加用户，

呵呵，我开始就说了，MDaemon支持在线申请新帐号，
申请新帐号也很简单。点上面那个创建新帐号，呵呵
输入 sister,密码按完成，一个叫sister@shunsheng.dns2go.com的信箱马上搞定。

我们还可以很方便地从控制台中添加帐号（也就是增加新的信箱）
只要点菜单中的使用者帐号中的帐号管理员，会弹出如下画面
点新增按钮

接着单击右下侧的"New"（新建）按钮，在随之出现的名为"Account Editor"（帐号编辑器）的窗口中，进入"Account"（帐号）项，在"Full name"（用户全名）下可为任意内容；而"Mailbox name"（邮箱名）处即为邮件用户名，此处填入"mother"，并确保其后的邮件主机名为"shunsheng.dns2go.com"；然后在"Account password"（用户密码）处输入相应内容，最后按"确定"退出。

网页收发和设置都没问题了，我们用就用OE或FOXmail收发一下以检验我们的劳动是否有成果

打开 outlook 创建新帐号。

pop3和smtp都用自己的域名（你用你的域名）

帐号和密码

完成，叫自己给自己发封信看看，呵！搞定，叫别人从远处发封信给你看看，能收，！

到此本也该拍拍身上的灰尘搞定走人了。

但我们不满足，这么好的东东，我们不但要他的和163一样牛B的信箱，而且还要他支持多域名的信箱。

下面最激动人心的多域名设定教程就要开始了
比如：我们有以下的域名，并都指向此一台服务器，我们想要的是以各自的域名为后缀的信箱
http://shunsheng.dns2go.com （IP策略是动态IP--已设定好)
http://shunsheng2.dns2go.com (IP策略和主域共用）
http://shunsheng.d2g.com (IP策略和主域共用）
http://shunsheng2000.dyndns.org （固定IP61.144.185.61）

我们刚才已经建立好了一个登录地址为 http://shunsheng.dns2go.com:3000
信箱为 XXXX@shunsheng.dns2go.com 的邮件系统，
那么MDaemon是否支持多域名呢？答案是肯定的，
MDaemon可以添加任意多的从域，就是第二域名了，它可以是不同的从域绑定不同的IP，也可以是不同的从域绑定相同的IP。例如：我们下面要讲的是：
XXXX@shunsheng2000.dyndns.org是绑定到不同IP上的（IP为61.144.185.61）
XXXX@shunsheng.d2g.com 和XXXX@shunsheng2.dns2go.com是绑定到相同IP上的（就是和XXXX@shunsheng.dns2go.com使用相同的IP绑定）
我们下面就要讲如何设定多域名了

不同从域绑定不同IP的添加
因为MDaemon支持多域相同或不同IP信箱系统，MDaemon可以自动检测IP地址，并使其对应相对的域名。
比如：
我们要添加的XXXX@shunsheng2000.dyndns.org是不同域绑定不同IP的多域名信箱。其IP为61.144.185.61
如：我们的shunsheng.dns2go.com是主域；
sshunsheng.d2g.com是从域IP是共用的（对应动态IP127.0.0.1 ）。
shunsheng2000.dyndns.org是从域，IP地址是不同的（对应61.144.185.61），
那么在登录远程信箱的时候要注意的是：登录主域信箱不需要输入信箱全名，
而登录从域信箱就必须要填写信箱的全名，注册信箱帐号也是这样。
如：
我们已经设置完成了主域是XXXX@shunsheng.dns2go.com的主域信箱系统，
已经开通的帐号是superman密码是：aaaaaaa
则：
登录信箱的地址是： http://shunsheng.dns2go.com:3000
信箱名：superman
密码：aaaaaaa
这个帐号全名是 superman@shunsheng.dns2go.com

----------------------------------------------
接下去我们在下面将设置XXXXXX@shunsheng2000.dyndns.org的信箱系统，

首先：
双击右下角任务托盘中的信封标志，弹出了信箱控制界面，然后
（设定）——>（次要网域）

就出现了上面的菜单，网域名称中写入我们要设定的 shunsheng2000.dyndns.org
IP地址我们写入绑定的 61.144.185.61
后面的绑定监听勾选
然后按需要设定下面的自动控制
点击 新增
这样就设置好了 shunsheng2000.dyndns.org的域名信箱

同样的道理

我们设置 shunsheng.d2g.com 的域名信箱(IP策略和主域共用)

还是那个次要网域的设置界面，现在在网域名称里添shunsheng.d2g.com
IP地址不要添，后面的绑定也不要勾选
然后看情况设定你的自动控制选择
点击 新增
shunsheng2.dns2go.com道理一样(IP策略和主域共用)。
于是我们就可以在主界面的左边看到如下这个画面。
说明一共有四个域名同时在工作，
（你要加几个就有几个，只要你的域名都能正确解析到你的服务器就行）。

至此，该设定的地方基本上都设定好了，接下去

我们要测试一下，看看是不是都可以使用打开你的浏览器在地址栏输入 （注意都是以我的机器为例我的次域是）

http://shunsheng.d2g.com:3000 （只要次域名能正确解析到你的电脑，则你要几个次域都可以）
出现这个画面（当然还没有帐号）接下去我们就要新建立从域名的帐号。

选择 创建新帐号

接下来就要注意了：创建新帐号的时候，
如果要创建的是主域的帐号就不用填写全名了，只添信箱的名字就可以了，不写域名，系统会默认为主域帐号的
例如：
在帐号里添写 test
密码 0123456789
密码确认 0123456789
全名 测试帐号

这样就添加了 test@shunsheng.dns2go.com 的帐号

(不写信箱后缀，则系统自认为是主域名）

如果你要添加次域名的信箱，则帐号里一定要写信箱全名，即信箱名和后缀都要写
如在帐号里添写 aa@shunsheng.d2g.com
密码 aaaaaaa
密码确认 aaaaaaa
全名 系统管理员
这样就添加了 aa@shunsheng.d2g.com 的帐号
（同样的：从域名shunsheng.dyndns.org 也要用这种方法创建新帐号）

同样的道理，用Outlook 或是foxmail 收发次网域信箱的邮件时

则pop3和smtp栏中写上你的次网域域名，
并且，在帐号和密码中
你的帐号一定要写全名（也就是包含帐号和@后缀）

总结：
添加次要网域的帐号是必须要填写全名的（就是：信箱名@后缀域名 格式）
登录次要网域 WEB页面的帐号也是必须要填写全名的（就是：信箱名@后缀域名 格式）
用OE或foxmail收发次要网域的帐号也是必须要填写全名的（就是：信箱名@后缀域名 格式）
而添加主要网域的帐号只添加信箱名就可以了。

三、 总结及常见题解决办法
（1）问：为什么我在局域网工作站端收发邮件时，SMTP服务器和POP3服务器地址用"shunsheng.dns2go.com"均不行；而改用MDaemon服务器的IP地址"192.168.0.1"就可以了呢？
答：这种情况对远程网页收发和使用 OE都没问题，局域网中说明服务器对域名"shunsheng.dns2go.com"的解析出了问题。
解决方法是：首先得确保在MDaemon的服务器里面的DNS管理器中已做好了域名"shunsheng.dns2go.com"和IP地址"192.168.0.1"之间的映射工作。
其次再将工作站的DNS服务器列表中添加好MDaemon服务器的IP地址"192.168.0.1"即可。
（2）问：我在局域网工作站端没有将MDaemon服务器的IP地址添加到自己的DNS服务器列表中，则我的POP3服务器和SMTP服务器地址是什么？我的E-Mail地址又是什么呢？
答：此时，你的POP3服务器和SMTP服务器地址均只能为MDaemon服务器的IP地址"192.168.0.1"；但你的对外的E-Mail地址还是"username@shunsheng.dns2go.com"。
如果你在局域网和互联网上都有"shunsheng.dns2go.com"的邮件需要收发，则建议你将工作站的网关和唯一的DNS服务器地址均设为"192.168.0.1"，在进行收发邮件的设置时，互联网上的邮件按原正常方法进行设置，而局域网上的邮件，SMTP服务器和POP3服务器地址均设为"192.168.0.1"即可。
（3）问：我的WebMail的登录界面和登录进去之后的界面都是英文的，能不能将它汉化呢？
答：MDaemon的WebMail界面支持包括简体中文和繁体中文在内的共22种不同的语言，因此你不再需要汉化包，只在服务器端直接进行转换设置即可！具体操作如下：点菜单"Setup"（设置）菜单下的"WordldClient/RelayFax"以打开WordldClient和RelayFax的属性窗口。紧接着进入"Options"（操作）项，将"Language"后改选为"zh (Chinese)"（简体中文），再"确定"退出即可。
（4）问：能不能够通过WebMail在线申请新的邮件帐户呢？
答：MDaemon支持此种功能！不过，默认的，这项功能是没有被开放的，需要进行如下操作来实现它：同样在上问的WordldClient和RelayFax的属性窗口中，同样进入"Options"（操作）项，将"Allow users to create new accounts"（允许用户建立新帐户）勾选中，再"确定"退出即可。然后，你再在浏览器中进入其登录界面，是不是可以发现在"签收"下多了一个名为"创建新帐号"的按钮？是了，点这里就可以在线申请你的新邮件帐户了！

   完


安装雷傲超级论坛

第六步：安装雷傲超级论坛
(1.配置Perl语言解释器） （2）

   说实话，这台和自己风雨多年的破机，都折腾到这个份上了，如果再不装个超级论坛什么的玩玩，那就太对不起自己的爱机了。（还好没有对不起人民，对不起党）。在这也不多罗嗦了，现在就做。开始呢，也不用着急，运行论坛得装个 PERL 语言解释器。听不懂没关系，下载来装就是了。点下载来的ActivePerl-5.6.1.631-MSWin32-x86.msi 安装。好象有8M多大小。

出现这个画面，下一步

下一步，到这里就又要注意了，因为雷傲论坛的程序的perl解释器的默认路径是
c:\usr这个目录，所以呢，我们到这一步安装时，要指定安装目录是
c:\usr,这样以后就可以节约很多很多的时间。

指定后，出现这个画面，下一步

下一步

出现这个画面，这四个选项全部选定，下一步

下一步，开始安装

完成，呵呵搞定

我们就可以在C盘根目录下看到一个新 usr 这个目录，呵呵，搞定。

这个目录里面的内容大约有35M大小光景就没错了。

到此，雷傲论坛需要的PERL已搞定，接下去就开始安装雷傲论坛了。

（2）


安装雷傲超级论坛

第六步：安装雷傲超级论坛
（1） (2.安装超级论坛）

   装好perl，现在就可以安装调试论坛了。

先去下载个雷傲论坛的最新版本，大约有1M大小吧，解开后如下，里面有三个目录（add-on,和cgi-bint和non-cgi)和10多个说明帮助，我们只用其中的两个目录，（要养成先看readme的好习惯哟）。

接下去注意啦，我们点apache的目录， 分别在cgi-bin这个目录和htdocs这个目录中各建立一个 lb5000的子目录。并将雷傲安装文件里的cgi-bin目录里所有文件全部拷贝到 c:\apache\cgi-bin\lb5000这个目录中，如下图所示。

并将雷傲安装文件里的non-cgi目录里所有文件全部拷贝到 c:\apache\htdocs\lb5000这个目录中，如下图所示。

接下去就要花点心思了。点apache\conf目录下有个httpd.conf这个文件，用记事本打开

找到 ServerAdmin 后面换成你的信箱地址，
下面还有个 ServerName 后面换成你的域名，你这里域名应该是
XXXXX.dns2go.com （我是shunsheng.dns2go.com ，你用你的名啦）
（嘿嘿，其实你如果都是按这个说明一步步做的，那这个文件就根本不用改了。因为你会发现，这里都是正确的。）

呵呵，该做的事都做了，接下去玩真格的了。

在你的浏览器地址栏输入
http://shunsheng.dns2go.com/cgi-bin/lb5000/install.cgi回车
（你用你的名啦）

如果出现这个画面，那你就有99％以上的成功机会了，接下去我们照着向导做就是了

往下拉，找到这一行。

c:/apache/cgi-bin/lb5000/ 这一行没错，
就是下面一行要自己输入，c:\apache\htdocs\lb5000/
(我发现正反的斜杠好象没什么关系，不过最好是一样，）

继续往下拉，因为要用的SMTP发信，所以这里要输入SMTP服务器，我这里是
shunsheng.dns2go.com (你用你的啦）

往下拉，输入你的发送和接收邮件地址，
（你用你自己的那个很牛B的邮件地址）

接下去是写上你的论坛详细资料，嘿嘿，你喜欢怎么写就怎么写。

拉到底，按下一步，出现这个画面

都是正确，都是找到，嘿嘿，胜利在望，点下面进行第三步。

第三步是叫你输入管理员身份，嘿嘿，密码当然要复杂一点了，（还有，尽量不要用这个帐号去发言，要发言自己再去注册一个帐号，因为这是超级管理员帐号哟）

按下面那个提交按钮

来到这个画面，嘿嘿他说
恭喜，您的LB5000已经成功安装好了！！！嘿嘿

点进入管理中心开始设置。

点论坛管理。

来到这个画面，点右边的 增加分类（同时增加一个论坛）

随便创建一个论坛，就叫技术论坛吧，以后什么吹件论坛啦，电影论坛啦，都可创建了，

这里我们先创建一个技术论坛。并按提交，

呵呵，说我们的新的分类和论坛已经建立，赶紧点 进入您的论坛 看看

成功了，虽然内容朴素一点，但麻雀虽小，五脏俱全哟，

以后什么吹件论坛啦，电影论坛啦，都可创建了。

好处真是说也说不完，不用等了，想让自己那台沉睡多年的爱机，发挥点余热，多多为人民服务，多多贡献于社会。快自己装一个吧。（嗖，嗖，嗖，我，闪，闪，闪）

（完）


安装雷傲超级论坛

Windows 2000 IIS5安装雷傲超级论坛
(1.配置Perl和服务器） （2）

   现在网上大约有一半的WEB服务器是用Apahce 架设的，也有一半是用 IIS来安装WEB服务，一方面呢，IIS是瘟2000系统自带的，安装省事，而且是自家的东东，兼容性也很好，另一方面呢，它直接支持ASP，呵呵，现在大多数网站都用它。还有CGI，现在有一大部分的论坛都利用CGI运行的，下面我们就一起来用
Windows 2000 IIS5安装雷傲超级论坛。
同样的运行论坛得装个 PERL 语言解释器。点下载来的ActivePerl-5.6.1.631-MSWin32-x86.msi 安装（华军软件有免费下载）。有8M多大小。

出现这个画面，下一步

下一步，到这里就又要注意了，因为好多CGI程序的perl解释器的默认路径是
X:\usr这个目录，所以呢，我们到这一步安装时，要指定安装目录是
c:\usr ,这样以后就可以节约很多很多的时间。
（其他用其他目录也行，只是在安装其他软件时指定解释器的时候麻烦一点，但最好装在根目录下，而
不要装X:\program files\perl 这么长的目录，对以后安装很不好）

指定后，出现这个画面，下一步

下一步

出现这个画面，这四个选项全部选定，下一步

下一步，开始安装

完成，呵呵搞定

我们就可以在C盘根目录下看到一个新 usr 这个目录，呵呵，搞定。

这个目录里面的内容大约有35M大小光景就没错了。

到此，PERL已搞定，接下去就开始配置服务器了。
（呵呵，和以前一样，接下去就不一样了）

接下去，当然是装windows 2000的IIS5了，点控制面板，点新增/移除程序 --点windows组件。
安装IIS就行了。
运行时可能要你放入安装光盘，下一步，下一步，直到安装完成。
＊（这一步，我想大家在安装WINDOWS时就已装好了，就当我罗嗦，呵呵）

注意：接下去就要留点神了。

接下去，点开始，运行，输入 regedit, 开始编辑注册表，一听到编辑注册表，好多人就怕了，其实不用怕，
找到: HKEY_LOCAL_MACHINE\System\Currentcontrlset\Services\W3svc\Parameters\ScriptMap\
我们看到只有一个默认，现在我们需要增加两项内容。
在右边空白处点右键，新建---字符串值，增加以下键值:
键名: ".cgi" 键值: "C:\USR\BIN\perl.exe %s %s"
键名: ".pl" 键值: "C:\USR\BIN\perl.exe %s %s"

（c:\usr\bin\perl.exe 就是你解释器的路径）`

搞定后，注册表就摆平了，现在要开始设置IIS了。
点管理工具里的 Internet 信息服务，点默认的WEB站点，按右键，点属性

找到主目录菜单，点应用程序设置右边的 配置

点添加-出现 添加/编辑应用程序扩展名映射的对话框。
在可执行文件里写上C:\usr\bin\perl.exe %s %s

扩展名写上 .cgi 不要忘记有个点的。下面还要勾上--脚本引擎

同理，加上C:\usr\bin\perl.exe %s %s
扩展名是 .pl

确定后，接着点菜单的ISAPI 筛选器，点添加，
在筛选器名称 里写 cgi
可执行文件里写 c:\usr\bin\perlis.dll

全部确定到桌面，至此，架论坛所需的服务器设置全部搞定。
也就是说现在你的服务器已经支持CGI程序了。

接下去就是如何安装超级雷傲论坛了。

（2）


安装雷傲超级论坛

Windows 2000 IIS5安装雷傲超级论坛
 （1） (2.安装超级论坛）

   装好perl， 并且服务器也配置好了，现在就可以安装调试论坛了。

先去下载个雷傲论坛的最新版本，大约有1M大小吧，解开后如下，里面有三个目录（add-on,和cgi-bint和non-cgi)和10多个说明帮助，我们只用其中的两个目录，（要养成先看readme的好习惯哟）。

这里，我们将 cgi-bin 和 non-cgi这两个目录拷贝到你的 IIS默认目录中，
一般都是 X:\inetpub\wwwroot\
（X就是你的系统目录了，一般都是C：我这是E，道理一样）

搞定之后，嘿嘿，接着就是老套了）

在你的浏览器地址栏输入
http://127.0.0.1/cgi-bin/install.cgi回车
（当然最好是用你申请的那个XXX.dns2go.com域名进行调试， 如果没上网就用这个IP进行调试，当然了，如果你在别的电脑，那完全可以用那个XXX.dns2go.com的域名进行调试了。）

如果出现这个画面，那你就有99％以上的成功机会了，接下去我们照着向导做就是了

往下拉，找到这一行。

注意，这里就是你的WEB的绝对路径了，
也就是你的IIS的默认WEB站点的路径，一般都是x:\inetpub\wwwroot这个目录
(我发现正反的斜杠好象没什么关系，不过最好是一样，）

接着是你的LB5000的各项外部访问路径,这里就要用到你申请的那个免费域名啦。
（把shunsheng.dns2go.com换成你的名就行啦）

继续往下拉，因为要用的SMTP发信，所以这里要输入SMTP服务器，我这里是
shunsheng.dns2go.com (你用你的啦）
输入你的发送和接收邮件地址，
（你用你自己的那个很牛B的邮件地址）

接下去是写上你的论坛详细资料，嘿嘿，你喜欢怎么写就怎么写。

拉到底，按下一步，出现这个画面

都是正确，都是找到，嘿嘿，胜利在望，点下面进行第三步。

第三步是叫你输入管理员身份，嘿嘿，密码当然要复杂一点了，（还有，尽量不要用这个帐号去发言，要发言自己再去注册一个帐号，因为这是超级管理员帐号哟）

按下面那个提交按钮

来到这个画面，嘿嘿他说
恭喜，您的LB5000已经成功安装好了！！！嘿嘿

点进入管理中心开始设置。

点论坛管理。

来到这个画面，点右边的 增加分类（同时增加一个论坛）

随便创建一个论坛，就叫技术论坛吧，以后什么吹件论坛啦，电影论坛啦，都可创建了，

这里我们先创建一个技术论坛。并按提交，

呵呵，说我们的新的分类和论坛已经建立，赶紧点 进入您的论坛 看看

成功了，虽然内容朴素一点，但麻雀虽小，五脏俱全哟，

以后什么吹件论坛啦，电影论坛啦，都可创建了。

至此，Windows 2000 IIS5安装雷傲超级论坛--搞定

（完）


完成--后记

后记+罗嗦

   虽然呢，俺这篇涂鸦是针对菜鸟的，老鸟看了，肯定会发出一阵阵冷笑。（或者是狂笑）
不过呢，菜鸟阶段也是每个玩电脑的人的必经之路，至于能不能成为老鸟那就要看自己了，
话虽这么说，大家也知道电脑能做很多事，电脑的功能很是牛B，只要自己好好学，肯定能出名堂。
但是大家肯定都有这个体会，那就是现在根本不同当年那个摇头晃脑背古文的年代。利用功能极强的电脑，很快就能搞出自己的认为比较牛B的东东，并马上产生离自己预料不远的效果，才能令自己产生更强的学习劲头，并增加自己更多的兴趣。
可以这么说，你看到别人做出一个很牛B的东东，于是你就产生了这样的想法，他有的电脑，我也有，那我也能不能做出那个东东来呢，于是你就会去找。去学。
嘿嘿，如果按老师一天到晚上课那样，：“菜单file，代表文件，可以创建新文件，可以另存文件，EDIT是编辑，可以编辑文件。。。。。。。帮助，关于。是这个软件的版本信息”
这么老师在上面口吐白沫地讲，自己天昏地暗地听，从头听到尾，自己还不知这个软件到底是什么用的，只是听老师和过来人，人云亦云地说 这个软件很有用。于是自己又和别人说，电脑很有用，怎么有用，自己学呗！但到底怎么有用，嘿嘿。。不知！！

我的目的就是这里，以超级傻瓜式的说明先让大家各个功能都可以建立，等建立之后，大家就会有兴趣自己一个一个菜单去翻，一个一个功能去试，电脑就是这样，多翻多试就熟。呵呵，不然，我又会像书本一样，file代表，。。edit..代表。。。。那样肯定听得看得人都会口吐白沫，耐性再好的人也最多只看个5行到10行。

总之一句话，学什么都是要兴趣，并有良好的方法。（嘿嘿，背台词）

好了，罗嗦了一通，有问题或是颠三倒四不对的地方，请大家多多到论坛去大声说出来，谢谢。

以下是安装这些东东所需要的资源下载地址

1. windows2000 server(简体中文服务器版） |  | 大小405M | 本地低速下载 | （速度慢没办法，我只有一条ADSL而以）我建议大家去街上花个5元钱买张“正”版，省事
2. dns2go | 免费域名申请加解析软件 | 大小1M | 本地高速下载 | （汉化正式版）
3. apache1.323 | 架WEB 服务器软件 | 大小5M | 高速下载 | （免费软件，正式版）
4. ActivePerl | 装论坛用的perl语言解释器 | 大小8M | 华军高速下载 | （免费软件，正式版）
5. Serv-u4.02 | 架FTP 服务器软件 | 大小2M | 本地高速下载 | （正式版）
6. Imail7.05 | 架邮件服务器软件 | 大小10M | 本地高速下载 | （正式无限用户版）
6a.MDaemon5.04 | 更牛B的邮件服务器软件 | 大小18M | 本地高速下载 | （正式版+国际中文汉化包）
7. 雷傲超级论坛2002-2-11shadow版 |  | 大小1M | 本地高速下载 | （正式版）

以上软件若下不了，则请直接到主页下载

版权所有，软体动物，欢迎翻录