CHINAUI2003交互界面-理论研究板块大礼包

肥鸟cuckoo 小林

2003-12-31


中国UI设计网--[U.I]. 交互界面-理论研究浏览：图形界面、数字色彩的一些词语中英文对照

>> 欢迎 cuckoo [ 发短信 :: 发表的主题 :: 参与的主题 :: 我能做什么 ] 我的收件箱 (0 新)
中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：图形界面、数字色彩的一些词语中英文对照

您是本帖的第 336 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 图形界面、数字色彩的一些词语中英文对照
anyone 帅哥哟，离线，有人找我吗？

头衔：-= 副头头 =-
等级：管理员
文章：1230
积分：2649
注册：2003-1-13
楼顶
发贴心情 图形界面、数字色彩的一些词语中英文对照

Dialogue Design
人机对话设计

Grid System in Graphical User Interface Design
图形用户界面设计中的格网系统

Icon Design
图标设计

Metaphor Design
隐喻设计

Principles of Effective Visual Communication
有效的视觉通讯原理

User Interface Design for Multimedia and Online Services
多媒体和在线服务中的用户界面设计

Color reproduction
色彩重现

Gamut mapping and cross-media design
全色域绘图和交叉媒体设计

Human interface
数字色彩中人机界面

Print
印刷

Tone reproduction
色调重现

Video & computer graphics
视频与计算机图形学

Color calibration in digital film systems
色彩校正和数字影像系统

Color Film Exposure in CRT Image Recorders
CRT屏幕摄影机中的彩色底片暴光原理

CRT film recording
CRT屏幕摄影机

Digital film scanning and laser film recording
数字底片扫描和激光记录

Digital tone reproduction
数字色调复制

Behind Gamma's Disguise
后Gamma修正

Motion picture and video post production color
动作图象和视频后处理色彩

Perception & visual acuity
感知和视觉洞察

Tonal Scales and Solitaire Cine-3 Lookup Tables
色调比例

----------------------------------------------
-= cHinAuI.coM =-
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：203.212.6.131 2003-1-23 17:01:04
编辑这个贴子 鲜花(0) 鸡蛋(0)
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
不错哦！记下~~

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.95.152 2003-11-4 18:04:06
编辑这个贴子
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
很有帮助！纪录。

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-5 11:01:39
编辑这个贴子
子木1977 美女呀，离线，快来找我吧！ 双子座1977-5-26

等级：初级用户
文章：81
积分：238
注册：2003-10-20
第4楼
发贴心情
又学到不少东西，收录^_^...

----------------------------------------------
有心，就有翼——飞翔

点击查看用户来源及管理<br>发贴IP：218.79.103.159 2003-11-19 9:41:42
编辑这个贴子
xyz890 帅哥哟，离线，有人找我吗？

等级：活跃分子
文章：215
积分：382
注册：2003-8-29
第5楼
发贴心情
收录^_^

----------------------------------------------
来也匆匆，去也慢慢，其实我不想走 [image] http://www.su163.com/

点击查看用户来源及管理<br>发贴IP：218.92.136.226 2003-11-26 14:30:53
编辑这个贴子
耶里路亚 美女呀，离线，快来找我吧！

等级：初级用户
文章：21
积分：102
注册：2003-11-5
给耶里路亚发送一个短消息 把耶里路亚加入好友 查看耶里路亚的个人资料 搜索耶里路亚在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给耶里路亚 OICQ 引用回复这个贴子 回复这个贴子 第6楼
发贴心情
学习。。。。。
点击查看用户来源及管理<br>发贴IP：210.22.5.36 2003-11-28 10:59:11
编辑这个贴子
anasy 美女呀，离线，快来找我吧！

等级：初级用户
文章：4
积分：8
注册：2003-11-26
第7楼
发贴心情
学习........

----------------------------------------------
鱼们拈花微笑，风与经幡
我与阿难——角色已转变......

点击查看用户来源及管理<br>发贴IP：61.149.189.207 2003-11-28 23:32:48
编辑这个贴子

本主题贴数7，分页： [1]
*快速回复：图形界面、数字色彩的一些词语中英文对照
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：5,015.625毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：好用户界面的检验表[转载]

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：好用户界面的检验表[转载]

您是本帖的第 299 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 好用户界面的检验表[转载]
why 美女呀，离线，快来找我吧！ 天秤座1979-10-23

等级：初级用户
文章：66
积分：214
注册：2003-3-19
楼顶
发贴心情 好用户界面的检验表[转载]
好用户界面的检验表
译自msdn，有不妥的地方请各位指正

Checklist for a Good Interface
好用户界面的检验表
The following checklist summarizes the information in the previous section and in this book. Use it to help you confirm that your application is signed to provide the best user experience:
使用下面的条目来确定你的应用程序界面设计能带给用户最佳的体验。
Your application installs easily in a minimum number of steps.
你的应用程序通过最少的步骤而方便的安装。
Your application installation does not require the system to restart.
你的应用程序安装不需要系统重新启动。
Users do not have to read a Readme file before using your application.
用户不必在使用程序前阅读自述文件。
User-generated data files are stored by default in the My Documents flder.
由用户生成的数据文件能默认的保存在“我的文挡”文件夹中。
Your application avoids cryptic file names that are visible to users.
你的应用程序不会用意义含糊的名字的命名用户可见的文件。
Your application does not create folders outside of the Program Files folder.
你的应用程序不会在Program Files文件夹外建立新的文件夹。
Your application does not write files to the root of the hard disk.
你的应用程序不会把文件写在硬盘的根目录。
If your application uses a disk cache, it also registers with the Disk Cleanup utility.
如果你的应用程序使用一个磁盘缓冲，它要被磁盘清理应用所记录。
Your application does not include entries to its Help, Readme, and Uninstall files on the Start menu.
你的应用程序没有把它的帮助，自述文件和卸载文件添加在开始菜单中。
Your application does not install icons to the Windows desktop without the user's permission.
你的应用程序在未经用户许可的情况下不会将图标放在windows桌面上。
If your application is run at startup, it loads without displaying splash screens and dialog boxes.
如果你的应用程序在启动时运行，在加载时不显示弹出窗口和对话框。
Your application does not use the taskbar notification area for status, for launching applications or utilities, or for querying properties. It uses the notification area only to alert the user of an important change.
你的应用程序不使用任务栏的布告区来显示状态、载入的应用程序或者请求的属性；

仅在发生重要变化时通过任务栏的布告区提醒用户。
Your application appropriately applies the color choices the user selected in Display properties in Control Panel.
你的应用程序能够适当的应用用户在控制面板的显示设置里选择的颜色。

Your application is keyboard accessible.
你的应用程序是可通过键盘操作的。
Your application works correctly if the user increases the size of the default font.
你的应用程序在用户增大默认字体的情况下仍能正常工作。
Your application supports the standard set of keyboard shortcuts, where applicable.
你的应用程序在适用的地方可以使用标准的键盘快捷方式。
Your application's uninstall process leaves no remaining files or registry entries other than files created by the user.
你的应用程序卸载后除用户创建的文件外，不应残留任何文件和注册表项目。
Your application does not use jargon in its user interface text. Use industry-specific or technical terms only if they are clearly understood by the user.
你的应用程序的用户界面上不能使用行话，只有在确定用户可以准确理解的情况下才

能使用专业术语和技术名词。
Your application adjusts appropriately when the user changes the display resolution as well as for multiple-monitor configurations.
你的应用程序在用户改变显示器分辨率甚至使用多显示器的情况下能够适当的调节。

[转载于设计联盟，作者：pentera]设计联盟

----------------------------------------------
Every mile and every year,
Time and Distance disappear I cannot explain this.
Dear No, I will not even try.

点击查看用户来源及管理<br>发贴IP：61.149.151.14 2003-11-7 14:36:42
编辑这个贴子 鲜花(0) 鸡蛋(0)
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
非常不错，大家一直都在疑惑什么是好的用户界面呢！

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-7 14:42:12
编辑这个贴子
Rokey 帅哥哟，在线，有人找我吗？

等级：管理员
文章：1508
积分：2702
注册：2003-4-12
第3楼
发贴心情
很有参考价值,刚入门的同学也能看懂的

----------------------------------------------
---------------------------------------------------------------------------
Rokey project
http://www.rokey.net/

点击查看用户来源及管理<br>发贴IP：210.76.108.158 2003-11-7 14:43:48
编辑这个贴子
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第4楼
发贴心情
中英文对照~太棒啦！

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.91.206 2003-11-17 11:46:15
编辑这个贴子
烛音 帅哥哟，在线，有人找我吗？

等级：实习版主
文章：5185
积分：7083
注册：2003-5-22
第5楼
发贴心情
虽然没有告诉我们怎么做，但是我们明白了我们要达到的目标

感谢why的中英文对照！

----------------------------------------------
http://www.cqppi.com/1/1.html

点击查看用户来源及管理<br>发贴IP：211.158.68.183 2003-11-17 11:50:57
编辑这个贴子
子木1977 美女呀，离线，快来找我吧！ 双子座1977-5-26

等级：初级用户
文章：81
积分：238
注册：2003-10-20
第6楼
发贴心情
强烈学习中，感谢^_^...

----------------------------------------------
有心，就有翼——飞翔

点击查看用户来源及管理<br>发贴IP：218.79.103.159 2003-11-19 10:01:19
编辑这个贴子
honghonge 帅哥哟，离线，有人找我吗？

等级：活跃分子
文章：211
积分：574
注册：2003-7-2
第7楼
发贴心情
可惜没有对各项的评估标准进行详细说明
点击查看用户来源及管理<br>发贴IP：218.58.28.117 2003-11-20 11:41:48
编辑这个贴子
lovem 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：94
积分：192
注册：2003-4-30
给lovem发送一个短消息 把lovem加入好友 查看lovem的个人资料 搜索lovem在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给lovem OICQ 访问lovem的主页 引用回复这个贴子 回复这个贴子 第8楼
发贴心情
呵呵，可惜微软有些软件就不符合上面一些条款，前几天按照IE6，装完了，连提示也不提示就重起，还好没打开其他什么软件，呵呵……

----------------------------------------------
我喜欢呀我喜欢……

点击查看用户来源及管理<br>发贴IP：61.48.132.66 2003-11-20 21:05:47
编辑这个贴子
why 美女呀，离线，快来找我吧！ 天秤座1979-10-23

等级：初级用户
文章：66
积分：214
注册：2003-3-19
第9楼
发贴心情
Your application does not use the taskbar notification area for status, for launching applications or utilities, or for querying properties. It uses the notification area only to alert the user of an important change.
你的应用程序不使用任务栏的布告区来显示状态、载入的应用程序或者请求的属性； 仅在发生重要变化时通过任务栏的布告区提醒用户。

问个比较弱的问题：应用程序的任务栏是干嘛的？包括些什么？

----------------------------------------------
Every mile and every year,
Time and Distance disappear I cannot explain this.
Dear No, I will not even try.

点击查看用户来源及管理<br>发贴IP：61.149.154.219 2003-11-21 11:29:26
编辑这个贴子
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第10楼
发贴心情
不知道是不是指状态栏
IE的任务栏主要显示链接信息，PS和word等软件显示文件打小、分几页以及存储还是打印等状态

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-21 13:43:30
编辑这个贴子
jay 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：42
积分：131
注册：2003-5-4
第11楼
发贴心情
我的理解是使用windows的任务栏右边的Tray
-------------------------
Your application does not include entries to its Help, Readme, and Uninstall files on the Start menu.
你的应用程序没有把它的帮助，自述文件和卸载文件添加在开始菜单中。

这个我不大同意，在开始菜单里执行卸载程序总比在控制面板里执行迅速

点击查看用户来源及管理<br>发贴IP：219.128.129.128 2003-11-25 13:18:17
编辑这个贴子
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第12楼

以下是引用jay在2003-11-25 13:18:17的发言：
我的理解是使用windows的任务栏右边的Tray

哦，是我理解错误，
我本人是很讨厌那些放在托盘里的东西，只有QQ的利用率比较高。

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-25 15:24:02
编辑这个贴子

本主题贴数12，分页： [1]
*快速回复：好用户界面的检验表[转载]
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：906.250毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：完善使用者人机界面的十大设计法则 [转帖]

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：完善使用者人机界面的十大设计法则 [转帖]

您是本帖的第 369 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 完善使用者人机界面的十大设计法则 [转帖]
anyone 帅哥哟，离线，有人找我吗？

头衔：-= 副头头 =-
等级：管理员
文章：1230
积分：2649
注册：2003-1-13
楼顶
发贴心情 完善使用者人机界面的十大设计法则 [转帖]

一个成功的医疗器材设计与使用者界面的品质有着深厚的关系，特别是当相关研发能力与应用技术愈见成熟，而投入市场的竞争者越来越多时，使用者界面的品质会变成产品层次区分时的一个重要指标。

随着人们对于医疗保健之重视，医疗器材的市场已从以往的专业医疗机构转战至一般的居家医护生活中；因此，如何在新的市场中，占有绝对的市场力并赢得先机，除了广泛的销售管道及优秀的能力外，优良的使用者界面设计，才是最好的行销利器。

一个优良的使用者界面设计，简而言之，就是要符合使用者的需求，考虑到使用者的身、心理状况；一个友善便利的使用者界面，不但可增加使用之方便性，亦可减少使用错误率，使医疗器材发挥最大的功能，达到造福使用者的目的；当然，对于制造厂商而言，其研发的行为才更具社会意义与经济价值。那么，如何才能设计出真正优良的使用者界面，又该如何去评估其设计之合理性呢？美国国家研究中心的专家针对此一问题提出了十大设计法则，详述如下。

一、减少显示器的视觉密度

一般医疗器材需表达的信息很多，易造成显示/操作界面看起来非常拥挤，所有信息挤在一团，别说偶一用之的使用者，连长期使用的医护专业人员都未必一眼就能获得所需的信息或知道如何正确使用之。因此，设计使用者界面时，务必要考虑到内容的配置与空间裕度的保留，适当的留白将使整个界面看起来清楚而美观。有几点适当保留空间的方法可供参考：把次要信息用选项功能或连结功能将其置于选项中，需要时再选取即可；降低品牌识别图像之大小，像品牌logo、名称等，无需为了彰显品牌形象而刻意放大之；使用简单的图形，尽量2-D平面化，不要使用过度复杂的图像；使用空白空间，而非线条去区分文字内容，尽量使整个界面简易化；使用简洁的语句表达讯息，避免内容过多。

二、提供使用者搜寻工具及指引

有些使用者在移动医疗器材后，就搞不清楚刚才费力找出的讯息又跑到那里去了，造成这种结果的原因是因为使用者根本不了解此使用者界面之结构为何？美国国家研究中心建议，在主/次标题上置放显著而有意义的标题，像「查询」、「设定」或「回主画面」等简单易懂的语句；也可将查询内容编页，像15之1，15之2等，让使用者大约知道有多少信息。至于搜寻之选项或控件，应该放置在明显且固定的位置上，只要操作者需要时，可以很快找到所需的功能，同时减少测试的时间及使用失误率。

三、设计合理的文字区规划

有些医疗器材的显示屏看起来像个棋盘，毫无秩序可言；当然有时候别出心裁的界面设计或许会带给使用者眼睛一亮、赏心悦目的视觉感，但无论如何，井然有序的文字区规划，才易达成最有效、最舒适的效果。 试着让说明具有顺畅地阅读连贯性；举个例来说，一个向中对齐与一个向左对齐的文字区块，明显地，向左对齐的区块读起来顺畅多了，因为使用者在读完一行字后，自然而然往左下方继续读下去，不需要重新找寻开头，相较之下，向中对齐的区块看起来混乱多了。因此，有规矩地文字区规画将可大幅度提增使用者界面的品质。

四、增加视觉平衡感

显示界面的平衡性相当重要，尤其在垂直轴的两侧，轻重感的一致性对操作者而言，心理感受影响更大。不对称的视觉平面，会让人觉得整个画面是倾斜的，再不就是好像少了什么东西；而对称的视觉平面，看起来既整洁又整体，识别性高，又符合使用者心理学。 至于如何增加视觉平衡感，有以下方法：注重空白区间与文字区块的使用比例；减少过度花俏的强调方式，如过多的画底线、粗体或3-D图形；将所有内容区块(包括空白区间)置于一完整之方块中，使之有整体感。

五、避免多色彩之应用

一个使用者界面中(包括背景和操作组件)，最好不要超过3到5种颜色，最好大区域使用浅灰阶色调，如浅灰、白色等；重要操作组件则以红、蓝、绿等彩度较高的颜色来表达，但颜色不宜过多，且区域不可以太大，否则看起来过度混乱，反而失去当初欲强调重点的用意了。

六、选用清楚大方的字型

一个界面中，最好不要有太多的字型，更不宜选用字型太复杂或软弱无力的字体，如斜体字等，越简洁清楚则辨识性越佳。

七、使用组织化分类说明

实验证明表格式的界面结构辨识性最优，同属性的信息应归纳在同一层级下，以达完善分类，简易配置之功。

使用简明扼要的词句言简意垓地点出重点，叙述性的文字只会让使用者失去耐性，并让整体界面看起来复杂难懂。

九、精简图像(Icon)

避免使用复杂的图像，以象形符码的表示为最佳，只要能引起使用者的共识，越简单越好。

十、避免界面设计之不一致性

无论以色彩或字体来表示某项含意，一定要前后一致，红色代表危险、粗体代表强调，决不可随意应用，否则会造成使用者之混淆。

一个成功的医疗器材设计与使用者界面的品质有着深厚的关系，特别是当相关研发能力与应用技术愈见成熟，而投入市场的竞争者越来越多时，使用者界面的品质会变成产品层次区分时的一个重要指标；此外，医疗器材之使用安全性也与界面设计的良窳有关，因为设计上的缺失将会直接或间接的造成使用时的误失，严重时，还可能造成使用者的伤害或死亡，由此可知，一项产品，尤其与人体有着密切关系的医护用品，在设计时绝对不可不谨慎。

当然，有时因为科技技术尚未成熟或设计者对使用者的需求不完全了解，在设计时不免会有未臻完美的情况发生；但无论如何，完善体贴的使用者界面设计，对制造者或设计者而言，都应将其视为自己应尽的职责，并引以为傲。希望上述之设计法则，能让厂商在设计医疗产品时，有更明确而完整的设计引导与概念，进而研发出更人性化、更便利的医疗产品，以达造福人类之功。

----------------------------------------------
-= cHinAuI.coM =-
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：203.212.6.131 2003-1-22 10:01:40
编辑这个贴子 鲜花(0) 鸡蛋(0)
ziyeke 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：200
积分：425
注册：2003-1-21
第2楼
发贴心情
verygood！！再这里穴道不东西呢
点击查看用户来源及管理<br>发贴IP：202.108.243.145 2003-1-22 13:16:38
编辑这个贴子
子木1977 美女呀，在线，快来找我吧！ 双子座1977-5-26

等级：初级用户
文章：81
积分：238
注册：2003-10-20
第3楼
发贴心情
仔细看过后，感觉工作中还有许多没有考虑到的地方，受益了：）

----------------------------------------------
有心，就有翼——飞翔

点击查看用户来源及管理<br>发贴IP：218.79.100.151 2003-11-18 16:35:21
编辑这个贴子

本主题贴数3，分页： [1]
*快速回复：完善使用者人机界面的十大设计法则 [转帖]
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：296.875毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：[转帖]工业设计中的人机工程学

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：[转帖]工业设计中的人机工程学

您是本帖的第 123 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： [转帖]工业设计中的人机工程学
Toyota 美女呀，离线，快来找我吧！

等级：活跃分子
文章：339
积分：698
注册：2003-11-3
楼顶
发贴心情 [转帖]工业设计中的人机工程学

国际人机工程学会（International Ergonomics Association）对本学科所下的定义为：人机工程学是研究人在某种工作环境中的解剖学、生理学和心理学等方面的各种因素；研究人和机器及环境的相互作用；研究在工作中、家庭生活中和休假时怎样统一考虑工作效率、人的健康、安全和舒适等问题的学科。

从科学性和技术性方面，给人机工程学下定义： 人机工程学是研究"人-机-环境"系统中人、机、环境三大要素之间的关系，为解决系统中人的效能、健康问题提供理论与方法的科学。（赵江洪 教授）

人机工程学和工业设计在基本思想与工作内容上有很多一致性：人机工程学的基本理论“产品设计要适合人的生理，心理因素”与工业设计的基本观念“创造的产品应同时满足人们的物质与文化需求”，意义基本相同，侧重稍有不同；工业设计与人机工程学同样都是研究人与物之间的关系，研究人与物交接界面上的问题。由于工业设计在历史发展中溶入了更多的美的探求等文化因素，工作领域还包括视觉传达设计等方面，而人机工程学则在劳动与管理科学中有广泛应用，这是二者的区别。

工业设计是一项综合性的规划活动，是一门技术与艺术相结合的学科,同时受环境/社会形态、文化观念以及经济等多方面的制约和影响,即工业设计是功能与形式、技术与艺术的统一,工业设计的出发点是人,设计的目的是为人而不是产品,工业设计必须遵循自然与客观的法则来进行.这三项明确地体现了现代工业设计强调“用”与“美”的高度统一，“物”与“人”的完美结合，把先进的技术科学和广泛的社会需求作为设计风格的基础，概而言之，工业设计的主导思想以人为中心，着重研究“物”与“人”之间的协调关系。

人机工程学，在美国有人称之为人类工程学“HUMAN ENGINEERING”，人因工程学“HUMAN FACTORS (ENGINEERING)”，在欧洲有人称之为“ERGONOMICS”，生物工艺学，工程心理学，应用实验心理学以及人体状态学等待。日本称之为“人间工学”，我国目前除使唤用上述名称外，还有译成工效学、宜人学、人体工程学、人机学、运行工程学、机构设备利用学、人机控制学等。人体工程不的命名已经充分体现了该学科是“人体科学”与“工程技术”的结合，实际上，这一学科就是人体科学，环境科学不断向工程科学渗透和交叉的产物，它是以体科学中的人类学、生物学、心理学、卫生学、解剖学、生物力学、人体测量学等为“一肢”；以环境科学中的环境保护学、环境医学 、环境卫生学、环境心理学、环境监测技术等学科为“另一肢”，而以技术科学中的工业设计、工业经济、系统工程、交通工程、企业管理等学科为“躯干”，形象地构成了本学科的体系，从人机工程学的构成体系来看就是一门综合性的边缘学科，其研究的领域是多方面，可以说与国民经济的各个部门都有密切的关系。

人机工程学的研究内容及其对设计学科的作用可以概括为......

1、为工业设计中考虑“人的因素”提供人体尺度参数：应用人体测量学、人体力学、生理学、心理学等学科的研究方法，对人体结构特征和肌能特征进行研究，提供人体各部分的尺寸、体重、体表面积、比重、重心以及人体各部分在活动时相互关系和可及范围等人体结构特征参数提供人体各部分的发力范围、活动范围、动作速度、频率、重心变化以及动作时惯性等动态参数分析人的视觉、听觉、触觉、嗅觉以及肢体感觉器官的肌能特征，分析人在劳动时的生理变化、能量消耗、疲劳程度以及对各种劳动负荷的适应能力，探讨人在工作中影响心理状态的因素，及心理因素对工作效率的影响等。人体工程学的研究，为工业设计全面考虑“人的因素”提供了人体结构尺度，人体生理尺度和人的心理尺度等数据，这些数据可有效地运用到工业设计中去。

2、为工业设计中“产品”的功能合理性提供科学依据：现代工业设计中，如搞纯物质功能的创作活动，不考虑人机工程学的需求，那将是创作活动的失败。因此，如何解决“产品”与人相关的各种功能的最优化，创造出与人的生理和心理肌能相协调的“产品”，这将是当今工业设计中，在功能问题上的新课题。人体工程学的原理和规律将设计师在设计前考虑的问题。

3、为工业设计中考虑"环境因素"提供设计准则：通过研究人体对环境中各种物理因素的反应和适应能力，分析声、光、热、振动、尘埃和有毒气体等环境因素对人体的生理、心理以及工作效率的影响程序，确定了人在生产和生活活动中所处的各种环境的舒适范围和安全限度，从保证人体的健康、安全、合适和高效出发，为工业设计方法中考虑"环境因素"提供了设计方法和设计准则。 以上几点充分体现了人机工程学为工业设计开拓了新设计思路，并提供了独特的设计方法和理论依据。 社会发展，技术进步，产品更新，生活节奏紧张，这一切必然导致"产品"质量观的变化。人们将会更加重视"方便"、"舒适"、"可靠"、"价值"、"安全"、和"效率"等方面的评价，人机工程学等边缘学科的发展和应用，也必须会将工业设计的水准提到人们所追求的那个崭新高度。

人机工程学在解决系统中人的问题上，主要有两条途径：（1） 使机器、环境适合于人；（2） 通过最佳训练方法，使人适应于机器和环境。

----------- 来自人机在线

----------------------------------------------
我是天使
一个孤单浪漫的天使
喜欢绕着地球飞
却为找不到甜密爱情而心灰

点击查看用户来源及管理<br>发贴IP：202.104.103.196 2003-11-12 16:10:05
编辑这个贴子 鲜花(0) 鸡蛋(0)
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
这类文章太多啦！

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.91.206 2003-11-17 11:52:51
编辑这个贴子
怒放 帅哥哟，离线，有人找我吗？ 巨蟹座1979-7-4

头衔：白金怒放
等级：V.I.P
文章：402
积分：986
注册：2003-3-28
给怒放发送一个短消息 把怒放加入好友 查看怒放的个人资料 搜索怒放在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给怒放 OICQ 访问怒放的主页 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
太泛泛，大部分都看过
点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-12-4 11:47:44
编辑这个贴子

本主题贴数3，分页： [1]
*快速回复：[转帖]工业设计中的人机工程学
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：328.125毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：数字化产品与人机界面设计

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：数字化产品与人机界面设计

您是本帖的第 109 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 数字化产品与人机界面设计
Toyota 美女呀，离线，快来找我吧！

等级：活跃分子
文章：339
积分：698
注册：2003-11-3
楼顶
发贴心情 数字化产品与人机界面设计
我们可以将数字化产品分为两类：一类是由数字化设备生产的产品，它们本身不具有数字化，如由数控机床、加工中心加工生产的某些产品；另一类是本身具有数字化的产品，如数码相机，扫描仪等。

广义的人机界面：在人机系统模型中，人与机之间存在一个相互作用的“面”，称为人-机界面，人与机之间的信息交流和控制活动都发生在人机界面上。机器的各种显示都“作用”于人，实现机-人信息传递；人通过视觉和听觉等感官接受来自机器的信息，经过脑的加工、决策，然后作出反应，实现人-机的信息传递。人机界面的设计直接关系到人机关系的合理性。研究人机界面主要针对两个问题：（1） 显示；（2） 控制。

狭义的人机界面是指计算机系统中的人机界面。人机界面（Human-Computer Interface），又称人机接口、用户界面（User Interface）、人机交互（Human-Computer Interaction），是计算机科学中最年轻的分支科学之一。它是计算机科学和认知心理学两大科学相结合的产物，同时也吸收了语言学、人机工程学和社会学等科学的研究成果。通过30余年的发展，已经成为一门以研究用户及其与计算机的关系为特征的主要学科之一。尤其，80年代以来，随着软件工程学的迅速发展和新一代计算机技术研究的推动，人机界面设计和开发已成为国际计算机界最为活跃的研究方向。

随着计算机技术、网络技术的发展，人机界面学的发展，会朝着以下几个方向发展：
1、高科技化
信息技术的革命，带来了计算机业的巨大变革。计算机越来越趋向平面化、超薄型化；便捷式、袖珍型电脑的应用，大大改变了办公模式；输入方式已经由单一的键盘、鼠标输入，朝着多通道输入化发展。追踪球、触模屏、光笔、语音输入等竞相登场；多媒体技术、虚拟现实及强有力的视觉工作站提供真实、动态的影像和刺激灵感的用户界面，在计算机系统中，各显其能，使产品的造型设计更加丰富多彩，变化纷呈。
计算机辅助产品设计的软件也不断推陈出新,CAD、CAM、SGI、Alias、Pro/D、Pro/E等的出现，改变了设计师以往的工作方式，给设计师提供了更为广阔的造型空间，使得他们能够充分利用先进的计算机技术，设计出优美的造型；大幅度缩短了产品开发周期和上市时间，为企业赢得了市场，也为用户建立起了一种良好的为实现功能的桥梁。图1.7便是Pro/DESIGNER辅助设计的照相机，采用了有生产力的直觉式操作新型用户界面，使最常用功能的步骤已经减少了65%之多。
2、自然化
早期的人机界面很简单，人机对话都是机器语言。由于硬件技术的发展以及计算机图形学、软件工程、人工智能、窗口系统等软件技术的进步，图形用户界面(Graphic User Interface)、直观操作(Direct Manipulation)、"所见即所得"(What you see is what you get)等交互原理和方法相继产生并得到了广泛应用,取代了旧有"键入命令"式的操作方式，推动人机界面自然化向前迈进了一大步。然而，人们不仅仅满足于通过屏幕显示或打印输出信息，进一步要求能够通过视觉、听觉、嗅觉、触觉以及形体、手势或口令，更自然地"进入"到环境空间中去，形成人机"直接对话"，从而取得"身临其境"的体验。

此时的设计，更应该充分发挥整合、协调的作用，在图形艺术、心理学、人机工程学等方面作深入的研究。在软界面设计中，尽可能使用自然语言，发展图、文、声、光等多种形式，使画面空间更加生动、逼真，模拟甚至超过人的现实生活。在硬界面设计中，均衡人与机之间的功能分配，充分发挥人的效能，使人能够"享受"到高科技成果；各种命令语言、按键设置更加明确，操作方式更加自然，使软界面和硬界面协调起来。
3、人性化
现代设计的风格已经从功能主义逐步走向了多元化和人性化。今天的消费者纷纷要求表现自我意识、个人风格和审美情趣，反映在设计上亦使产品越来越丰富、细化，体现一种人情味和个性。一方面要求产品功能齐全、高效，适于人的操作使用，另一方面又要满足人们的审美和认知精神需要。
现代电脑设计，已经摆脱了旧有的四方壳纯机器味的淡漠。坚锐的棱角被圆滑；单一的米色不再一统天下；机器更加紧凑、完美，被赋予了人的感情。软界面中颜色、图标的使用，屏幕布局的条理性，软件操作间的连贯性和共通性，都充分考虑了人的因素，使之操作更简单、友好。
建立自然化、人性化的人机界面已成为当今资讯社会研究的主课题。我们继续采用的图形用户界面(WIMP)有其内在的不足，在人机交互界面中，计算机可以使用多种媒体而用户只能同时用一个交互通道进行交互，从计算机到用户的通信带宽要比用户到计算机的大得多，这是一种不平衡的人机交互。目前，人机交互正朝着从精确向模糊，从单通道向多通道以及从二维交互向三维交互的转变，发展用户与计算机之间快捷、低耗的多通道界面。
4、和谐的人机环境
今后计算机应能听、能看、能说，而且应能"善解人意"，即理解和适应人的情绪或心情。未来计算机的发展是以人为中心，必须使计算机易用好用，使人以语言、文字、图像、手势、表情等自然方式与计算机打交道。外国大公司如IBM、微软等在中国国内建立的研究院大多以人机接口为主要研究任务。我们必须在技术竞争中，特别是在汉语语音、汉字识别等方面取得主动权。这里，在软件方面要重点解决：汉语识别与自然语言理解，虚拟现实技术，文字识别，手势识别，表情识别等。力争在5－10年内使汉语识别成为较流行的人机交互方式，手势识别、表情识别等新技术开始应用。
面对日新月异的科学技术，设计应站在新的角度上审视自己，笔者以为应该：
1、紧跟时代步伐 随着高技术含量的增加，现代产品的品质发生了变化，高技术产品在完善功能的同时提升了美学价值。高科技是我们认识世界和改造世界的一种手段，只有掌握了先进的生产工具，才能使我们的"器"更加锋利，设计出来的产品才会具有时代特点，跟上时代步伐。
2、了解人 设计师必须用一种全新的语言，反映文化与社会中的人性要求，深入人深层的潜意识，沟通人类的情感，并使之交流与融合。因此，设计师必须通过设计语言使用户能读懂产品的设计理念，向人们暗示一种设计情感的溶入，"引起用户在使用方式和情感上的共鸣"，不仅要传达工业技术的力量，更要根植于更为广泛深入的历史与文化结构中。
-----------引自人机在线

----------------------------------------------
我是天使
一个孤单浪漫的天使
喜欢绕着地球飞
却为找不到甜密爱情而心灰

点击查看用户来源及管理<br>发贴IP：202.104.103.196 2003-11-12 16:12:22
编辑这个贴子 鲜花(0) 鸡蛋(0)
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
人机在线的文章~~哪里是理论源泉啊！

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.91.206 2003-11-17 11:47:57
编辑这个贴子

本主题贴数2，分页： [1]
*快速回复：数字化产品与人机界面设计
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：437.500毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：[原创] 用户界面浅析--[GUI]图形用户界面(适合新手)

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：[原创] 用户界面浅析--[GUI]图形用户界面(适合新手)

您是本帖的第 394 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： [原创] 用户界面浅析--[GUI]图形用户界面(适合新手)
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 楼顶
发贴心情 [原创] 用户界面浅析--[GUI]图形用户界面(适合新手)
不知道“算盘”算不算最早的用户界面，用户界面走到今天真是千锤百炼，要做到易用就更是难上加难，目前我想做得是普及用户界面的基本知识，以便更多的设计师接受它、发扬它。我希望用户界面在我们手中可以展现出更多的光彩。

分别有以下几个讨论方向
[GUI]图形用户界面
[WUI]网页用户界面
[HUI]手持设备用户界面
UI在项目中的实现

先从图形用户界面[GUI]开始吧！

图形用户界面有时被称为WIMP，表现了它的四种特有属性，即窗口（Window）、图标（Icon）、菜单(Menu)、鼠标指针(Pointing Device)。它的特点是操作直观、提供指针支持及界面图形化。目前图形户界面虽然不能达到较好的易用性，但是针对特定任务我们精心设计，在效果和满意度上绝对优于非图形界面。

窗口，是交互的基础区域，主要包括标提栏、支持移动和大小缩放、菜单栏、工具栏以及操作区。通常是矩形，但是现在很多软件都把它做成不规则形，例如一些音乐的播放器，看上去会更有活力和个性。

图标，是用于标是一个对象的图形标志，使一个标题或功能可以有更直观的操作。我们制作的图标有很大一部分来源于术语符号，例如最小化、关闭等，初次接触的用户可能并不理解其含义，需要区记忆；另一部分图标则是来源于生活，比较象形的，比如喇叭就是调节音量，房子表示HOME，信封表示邮件等。我们在设计时应尽量避免创造新的符号，尽量使用象形的图形。

菜单，是供用户选择的动作命令。在一个软件中，所有的用户命令都应包含在菜单中。菜单通常要通过窗口来显示，常见类型有工具栏（包括图形工具栏）、下拉式、弹出式（右键菜单）和级联式（多层次的菜单）。

指针，是一个图形，用以对指点设备（鼠标或轨迹球）输入到系统的位置进行可是化描述。图形界面的指针常用的有系统的箭头、十字、文本输入I、等待沙漏等。

由于鼠标的发明为人机交互注入了新的活力，我们一直都在研究更为恰当和易用的交互方法，其中还会包括很多人为的和环境的因素，欢迎大家各抒己见，归纳一些自己在交互设计中的经验或问题易大家分享

相关文章
用户界面浅析--手持设备用户界面 (新手)
用户界面浅析--网页用户界面 (适合新手)
用户界面浅析--UI在项目中的实现 (新手)

[此贴子已经被作者于2003-10-30 15:22:35编辑过]

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-10-30 10:57:10
编辑这个贴子 鲜花(0) 鸡蛋(0)
gellen 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：172
积分：366
注册：2003-7-15
给gellen发送一个短消息 把gellen加入好友 查看gellen的个人资料 搜索gellen在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给gellen OICQ 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
太好了!
点击查看用户来源及管理<br>发贴IP：211.94.168.70 2003-11-12 14:27:23
编辑这个贴子
子木1977 美女呀，离线，快来找我吧！ 双子座1977-5-26

等级：初级用户
文章：81
积分：238
注册：2003-10-20
第3楼
发贴心情
版主的浅析很细致入微，学习 ^_^....

----------------------------------------------
有心，就有翼——飞翔

点击查看用户来源及管理<br>发贴IP：218.79.100.151 2003-11-18 16:42:53
编辑这个贴子
耶里路亚 美女呀，离线，快来找我吧！

等级：初级用户
文章：21
积分：102
注册：2003-11-5
给耶里路亚发送一个短消息 把耶里路亚加入好友 查看耶里路亚的个人资料 搜索耶里路亚在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给耶里路亚 OICQ 引用回复这个贴子 回复这个贴子 第4楼
发贴心情
哈，又学习到了很多。。。
点击查看用户来源及管理<br>发贴IP：210.22.5.36 2003-11-28 11:41:00
编辑这个贴子

本主题贴数4，分页： [1]
*快速回复：[原创] 用户界面浅析--[GUI]图形用户界面(适合新手)
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：312.500毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：界面设计概述

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：界面设计概述

您是本帖的第 521 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 界面设计概述
anyone 帅哥哟，离线，有人找我吗？

头衔：-= 副头头 =-
等级：管理员
文章：1230
积分：2649
注册：2003-1-13
楼顶
发贴心情 界面设计概述

界面设计是开发中最重要的方面，并将涉及到整个开发队伍。
有效的界面设计经常是预见的过程，设计目标是开发者根据自己对用户需求的理解而制定的。
设计界面的艺术综合了技术、艺术，心理学上的技能——它需要左脑和右脸都参与。
优秀的界面简单且用户乐于使用，这意味着设计需适应硬件的局限。
数字时代的开创人他。Marvin Minsky在其有趣的书《思维的社会》中提出下面的思想：无论是人类的思维还是人工智能的思维，都是由原本简单的元素相连而组成，当这些元素组成一个整体时，他们就成为无限复杂的，我们称之为思想和感情的东西，这些思想和感情可以转化为人类的体验。
多媒体在所有方面(创意、筹措资金、设计、开发等)是清楚地遵循这一理论的媒体。在实际推出一个产品时，为了使项目形成，各种各样原本不连贯的思想和行为被连接起来加以操纵。使这些要素(实际上并不简单——人类从来就不简单)向统一的目标工作是开发过程中的关键挑战之一。除非每一个环节在生产过程中和生产之后同步进行，否则产品根本不能算完成。但因为必须作出产品(否则，为何在此浪费时间?)，Minsky的理论在多媒体开发中还有一个更重要的应用，就是多媒体和用户间联系的关键点：用户界面。
制作优秀多媒体界面的挑战主要是编排不同元素(有些并不简单)，并使之成为一个连贯整体，既要在实质上又要在观念上实现这一点。从实质上讲，众多才艺、技能和感觉联合构成用户看到的实际内容；在观念上，用户界面反映了这些部分的总和而非这些部分本身。若多媒体产品意味着展示或传达许多不同的思想，那么用户界面就是使用所有这些思想的中心点。若多媒体产品传达或展示仅仅一种思想．界面须使开发中的所有元素为这一个目标服务。

界面是一个窗口
按照Minsky的全方位观点，成功的界面设计不仅仅依赖于图片或声音，还依赖于比图片和声音更精细的元素。真正丰富多彩的是用户和多媒体本身(即计算机)带到工作台来的期望度。这些期望构成了用户和机器会话的每一个方面，我将机器称作硬件和软件的统一体。当然，机器，如个人计算机，其内存有限，只能有这
么多的预置程序．这些预置程序可能非常简单而且毫不宽容；每一个多媒体产品都有最低的硬件要求，这可以很好地说明人的期望是受限制的并且要视机器而定。
主要期望
机器在与用户对话时，首先要确定用户在等待计算机反应时能忍耐多长时间，例如在计算机象棋比赛期间给机器规定的时间限制。另一个要事先给机器规定的例子是，多媒体产品中选择项的范围宽度，或各种各样分散的选择项应集成的程度。因我们设计计算机是要它与人类而非其他机器一起工作，我们更喜欢可选顶少而集中，不喜欢有无限的选择。
人机对话更重要的是用户对工作台和优秀多媒体设计的期望度。优秀多媒体设计在内容选择上优先考虑用户最明显的期望。用户买一张关于意大利文艺复兴的光盘时，至少期望看到艺术和音乐(照片和声音)的例子，但界面设计远不只要满足这种显而易见的期望。
用户的臆测
设计也是一个猜测用户到底具有多少基本文化和认知常识的问题。例如，当一个人看到屏幕上的红色按钮时，红色象征什么?它意昧“注意”吗?它意味“停止”吗?
用户看到屏幕上的箭头指向右会假定(也许是错误的)那个按钮是在指示他向前浏览，也即到下一页、下一种思想等等。相反，箭头指向左面通常是向后倒的移动，例如返回到前一页。因为我们从左到右阅读(对于西方语言如此)时，这一假设很自然，我们的眼睛朗右移动以获取更多的信息。但当箭头指向上或向下时，它意
味着什么?它对多数用户的意义相同吗?屏幕上的内容意义是否明确，或是否需要通过标号甚至帮助按钮来进一步说明?
界面设计者，也即多媒体开发组的科学掌舵人主要是要回答类似的问题。从艺术、技术，有时是商业角度看，界面设计也许是整个项目中最重要的决策。
理想界面
对于不同的开发商和产品来说理想的界面有着多种不同的意义，换言之，唯一的理想界面并不存在。可是为了最终用户，你必须作出最佳选择，因为这种选择在用户从视觉和感知方面接触多媒体时起着重要作用。用户界面是内容对与其交互者产生最初和持续印象的地方，它包括整个产品的视觉和感觉效果，更进一步，包括对开发设计者的视觉和感觉。用户界面是如此重要，它能决定一个游戏是有趣还是乏味，也可以决定一个参考资料性多媒体产品是有用还是无用。产品内容充实但界面无吸引力或笨拙仍是一种失败，反之，一个令人注目的界面能使很普通的内容看起来比它实际上更有吸引力。界面占据了用户多媒体体验的核心部分。如何组织用户的多媒体体验?它的结构是逻辑的吗?例如交互性是以清晰易懂、因果方式来规划吗?或者它是否更
开放，鼓励用户自己去探究?界面显眼到成为体验的一部分吗?或它是否内容突出?你将在这一章看到有关这些界面设计问题的例子。这些决策是产品的其余部分发展的核心，它决定了每一件事情的进度。因为多媒体本质上是计算机程序，界面设计的过程没有给人很好的即兴创作机会。不象任意加人多媒体的单个元素——视频、文本、音频和图象，装配的多媒体产品不易以再编辑一段视频或混合一段音乐的“后期制作”方式修改。界面无论假设如何感觉如何，它是开发商和用户的路径图，但问题有那样多不相同的可能性，你如何挑一个出来?显然，须就每一个项目的特定目标和挑战对上述问题做出回答，解决它们而向最终用户给出你所设计的体验。
原因和结果＝挑战和对策
由于多媒体产品总是为某类用户制作的，在设计用户界面时要考虑的最重要的因素是用户的期望。总体规划的过程一半是市场意识，一半是创意想象。市场的现实无论好坏通常是一个大因素，这一点无论对于实际的开发阶段(预算允许什么)还是产品推出后(用户使用你的产品时的容易程度和亲切程度如何)都是如此。在任何多媒体产品的创作期间，等式结构里的两个因素(市场意识和创意设想)总是在不断变化中协调存在，它是一种因果的共存关系。我们应该把这两种因素看成挑战和对策，看成多媒体项目中的相互对立的两极．而这两极最终是要相遇的。在整个项目期间，尤其在界面设计期间，挑战和对策会分化演变为更小的挑战和对策。尽管这里涉及的是创见和经济决策，其中却也贯穿着这样一个基本物理定律：每一个行为都会导致一个大小相等、方向相反的电影制片人的组织才能、导游的沉着以及计算机编程者的精确。
一致性
设计者与客户以及或执行开发商紧密配合，为用户制作有吸引力，功能多样，并且最重要的是要具有统一性的多媒体体验。设计者肩负着开发者的期待、预想、限制。设计者将所有生产要素(内容以及风格)转换成相关工具，对这些工具用户在多媒体体验期间能通通使用。存在很多理由支持这种一致性作为全部界面的指导原则，优秀界面设计者应留意所有这些，显然，希望有统一的视觉。即使多媒体意味着若干不同界面的陈
列，通过分支不同主题或部分，用户的主要界面必须有到所有这些分支的路径。无论用户想看什么，都必须从界面中浏览所有的产品对话，对话以某种形式展现出全部体验，一致性方面的任何不和谐将使用户迷惑，并且立刻削弱产品的整体功能。
形式符合功能
尽管制作界面的创新外观存在极大的可能性，统一的外观仍很重要，如同杂志的页面布局或计算机应用功能。当同这一媒介对话时，用户应能作出智能选择，以便享受体验或发现它的用处。例如，当用户发现一个下拉菜单是一个浏览工具并作出某一选择，但在产品的其它地方用了同样方法却是不同意义的，那么只能不在新节点上应用。已建立的认同范例是以后的模型。
这些范例包括：从上到下、从左到右(英语习惯)阅读；Window98或Machintosh工作桌面，它的菜单条用期望的结果下拉；或即使电话，在按键之后有一个拨号音、连接和通话，这并不是说界面设计者不能在这些范例内做无章但有创造性的事情。在界面设计中，形式应当符合功能。值得记住的是当设计者为用户建立了某一功能，用户希望这一功能在全部多媒体体验中是一致的。
屏幕设计基础
设计界面类似于面对一幅空白画布，每一位艺术家在开始做画之前准备调色版、画笔和构思，多媒体也不例外。设计界面的过程开始于将在制作整个产品中使用的所有视觉和听觉元素，这些元素必须产生于艺术家和技术家的想象。到现在，正象纸和笔能做的，我将以一个有关烹调光盘设计为例简要地讨论辅助软件。
组织该是为你的烹调光盘设计发头炮的时候了。你可用手工也可用机器产生聚集系列必要的设计元素。目的是将这些元素组成连贯的顺序或分支框图．并让用户对设计有直接的体验。
为这个目的，方案组织软件很有帮助，现有很多软件包能够满足需要，分布范围很广，从产生简单流程图到能跟踪全过程责任和资金的详细流程图，一些较有名的软件包对艺术导演、编程员、市场部，以及界面设计者均很有用。首屏在联机环境也可指主页，尽管Web站点主页经常包括部分或全部主菜单，技术参数与固定媒体如光盘很不同，Web站点是实时传送的媒体，可能有大量的图象，因你无法等待图象经过电话线慢慢下载，用户常常以小时为单位，对在线多媒体较长的下载时间意味着挫折以及现在的潜在用户离开。
首屏是一个广告性的图象——位于用户启动多媒体程序和实际使用程序的中间和暂时性的步骤。
若首屏是多媒体产品的大门，那么，主菜单即是前厅，这里，用户选择何处可以交互对话，是即刻开始还是稍后使用光盘。我无法过多地陈述设计和实现一个功能性和吸引人的主菜单的重要性：这是用户重复返回的地方。不同的目录、帮助选项、退出项，退出项是每一主菜单均需要但不会有开发商真正想实现的附加项。在单击鼠标和所要信息之间的任何无关的步骤均不受欢迎(至少对于光盘是如此)，对Web站点此规则有很大的灵活性。主菜单应直观且体现出允许用户立即访问产品的重要特征毫无疑问，你的产品不允许一次简单的单击就退出程序，当用户单击退出，出现一个对话框，询问用户是否确实想退出，这样做的理由很简单：给出用户改变主意和重新进入产品的机会。为什么要这样做?首先，没有人愿意看到观众离开剧场，若退出按钮放置太靠近浏览选项，用户可能错误地退出，为他们改变主意给出—个选项是有用的特征。太多的亮点排列过密会使用户难以分辨每一按钮的用途。选择按钮引出一串其他按钮表，此选择按钮必须与它引出的新按钮有明显的区别。

----------------------------------------------
-= cHinAuI.coM =-
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：203.212.6.131 2003-1-22 21:12:51
编辑这个贴子 鲜花(0) 鸡蛋(0)
Aderwan 帅哥哟，离线，有人找我吗？ 狮子座1984-7-27

头衔：AGI会员
等级：实习版主
文章：1477
积分：2721
注册：2003-5-6
给Aderwan发送一个短消息 把Aderwan加入好友 查看Aderwan的个人资料 搜索Aderwan在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给Aderwan OICQ 访问Aderwan的主页 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
这么经典的话题都没人顶啊！我来！！！顶！！！！！！

----------------------------------------------
>>> 路漫漫，其修远兮，吾将上下而求索!

点击查看用户来源及管理<br>发贴IP：218.87.50.218 2003-6-10 0:57:21
编辑这个贴子
纳兰若焉 美女呀，离线，快来找我吧！ 双鱼座1976-3-19

等级：初级用户
文章：23
积分：102
注册：2003-6-9
给纳兰若焉发送一个短消息 把纳兰若焉加入好友 查看纳兰若焉的个人资料 搜索纳兰若焉在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给纳兰若焉 OICQ 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
UP～

----------------------------------------------
现在才开始作UI！表奇怪哦~~

点击查看用户来源及管理<br>发贴IP：61.185.220.115 2003-6-10 9:17:20
编辑这个贴子
圆枯碌 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：134
积分：279
注册：2003-4-24
第4楼
发贴心情
强顶

----------------------------------------------
设计立足于市场和消费者喜爱基础之上。
除非你是苹果公司！

点击查看用户来源及管理<br>发贴IP：61.144.174.93 2003-6-10 11:25:18
编辑这个贴子
Aderwan 帅哥哟，离线，有人找我吗？ 狮子座1984-7-27

头衔：AGI会员
等级：实习版主
文章：1477
积分：2721
注册：2003-5-6
给Aderwan发送一个短消息 把Aderwan加入好友 查看Aderwan的个人资料 搜索Aderwan在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给Aderwan OICQ 访问Aderwan的主页 引用回复这个贴子 回复这个贴子 第5楼
发贴心情
再顶，我已经保存了！！

----------------------------------------------
>>> 路漫漫，其修远兮，吾将上下而求索!

点击查看用户来源及管理<br>发贴IP：218.64.38.104 2003-6-12 22:16:53
编辑这个贴子
粗线条 帅哥哟，离线，有人找我吗？

等级：高级会员
文章：801
积分：1624
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第6楼
发贴心情
至顶，存档，回家，阅读，分析，领悟，应用。

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.95.152 2003-11-7 10:44:50
编辑这个贴子
子木1977 美女呀，在线，快来找我吧！ 双子座1977-5-26

等级：初级用户
文章：81
积分：238
注册：2003-10-20
第7楼
发贴心情
支持楼上说的，“存档，阅读，分析，领悟，应用” ^_^...

----------------------------------------------
有心，就有翼——飞翔

点击查看用户来源及管理<br>发贴IP：218.79.100.151 2003-11-18 16:37:46
编辑这个贴子
粗线条 帅哥哟，离线，有人找我吗？

等级：高级会员
文章：801
积分：1624
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第8楼
发贴心情
呵呵!我才看见这个!欣欣~~你怎么总跟我帖子阿!这么巧~~

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.81.243 2003-12-16 9:10:39
编辑这个贴子
晨明 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：65
积分：161
注册：2003-10-14
第9楼
发贴心情
好贴，顶下！
点击查看用户来源及管理<br>发贴IP：61.51.233.164 2003-12-17 16:44:23
编辑这个贴子

本主题贴数9，分页： [1]
*快速回复：界面设计概述
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：1,625.000毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：软件设计中的可用性 [转自Microsoft MSDN]

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：软件设计中的可用性 [转自Microsoft MSDN]

您是本帖的第 146 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 软件设计中的可用性 [转自Microsoft MSDN]
x3d 帅哥哟，在线，有人找我吗？

等级：初级用户
文章：119
积分：314
注册：2003-5-12
给x3d发送一个短消息 把x3d加入好友 查看x3d的个人资料 搜索x3d在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给x3d OICQ 引用回复这个贴子 回复这个贴子 楼顶
发贴心情 软件设计中的可用性 [转自Microsoft MSDN]
软件设计中的可用性
Microsoft Corporation
2000年10月
摘要：本文介绍了可用性的概念，说明为什么可用性应当是所有软件设计项目中的一个重要部分。

目录

简介
可用性定义
常见问题
资源

--------------------------------------------------------------------------------

简介

在工作中体现可用性

在创建软件的环境中，术语“可用性”表示一种方法，它将用户而不是系统摆在过程的中心。这一方法称作以用户为中心的设计，它从设计过程的一开始就将用户关心的问题和意见考虑在内，并提出在任何设计决策中用户的需要都应摆在首位。

这种方法最显著的特点就是可用性测试。在测试中，用户使用产品的界面进行工作，通过界面进行交互，就他们的观点和关心的问题与设计人员和开发人员进行交流。

本文讨论了可用性的概念，并讨论了为什么可用性在所有软件设计项目中都是一个重要部分。本文的第一部分定义了在软件开发环境中可用性意味着什么，以及它与衡量产品价值的其它方面间的关联。第二部分回答了一些常见的问题，包括：为什么可用性很重要，以及如何在开发过程中体现以用户为中心的设计理念等。本文在结尾处列出了一些书籍、论文和组织机构名称，帮助您加深对可用性的了解，并在项目中应用可用性。

本文中讨论的大部分概念在零售和内部软件开发中均有所应用。在阅读本文时，请注意“用户”和“产品”等词语，并思考如何将其应用到您的项目和最终用户中。

可用性定义

易于使用

可用性是衡量使用一种产品来执行指定任务的难易程度的尺度，它与实用性和受欢迎度等相关概念是有差异的。

可用性与实用性

决定产品可接受性的核心属性是其有用性，它用于评价实际使用产品时，是否能达到设计人员期望产品实现的目标。有用性的概念可以进一步划分为实用性和可用性。虽然这些术语间有联系，但它们却不能相互替代。

实用性指产品执行任务的能力。根据设计，产品执行的任务越多，其实用性就越高。

让我们以二十世纪八十年代末问世的典型 Microsoft® MS-DOS® 字处理程序为例。此类程序提供了多种强大的文本编辑和处理功能，但需要用户学习和记忆几十个令人费解的按键后才能执行这些功能。可以说此类应用程序具有很高的实用性（它们为用户提供了必要的功能），但其可用性却较差（用户必须花费大量的时间和精力来学习和使用它们）。与之形成对比的是，一个设计合理的简单的应用程序（如计算器）使用起来很容易，但其实用性却有欠缺。

这两种性质都是一种产品被市场接受所必需的，而且它们都是总的有用性概念的一部分。显然，若程序很好用但没有什么有价值的功能，那么没有人会使用它；如果程序的功能强大但却很难使用，那么用户也很可能会拒绝这个程序而转向其它的替代品。

可用性测试帮助您判断用户使用产品执行特殊任务的难易程度。但是，它并不能直接帮助您判断产品自身是否有价值、是否实用（在可用性测试中，用户可能会主动提出一些关于实用性的意见，但任何意见都应通过其它更可靠的研究方法予以验证）。

喜欢它与使用它

受欢迎度往往表示产品中可取的特性。如果人们喜欢某产品，就更有可能使用它，并将它推荐给其他人。但是，与实用性一样，您一定要小心不要将受欢迎度和可用性混淆。

人们喜欢某产品的原因往往与实用性和可用性无关。他们可能被产品的样式和引人注目的外观吸引，或被心目中所赐予的该产品的地位吸引。人们倾向于喜欢很好用的产品，但这并不是说人们普遍喜爱的产品就是可用的。

可用性是指人们是否可以使用该产品来执行他们需要执行的任务。可用性测试主要用于评价性能而不是评价喜爱程度，但标准化的调查问卷也可以用来衡量人们对产品的喜爱程度。

发现、学习与有效性

可用性包含很多方面，但通常这一术语特指发现、学习和有效性这三种属性。

发现表示针对某种特定的需要去寻找并找到产品的某一功能。可用性测试可用于确定用户找到某一功能所用的时间，以及在整个过程中用户犯了多少错误（关于定位的错误选择）。

学习表示用户弄清楚如何运用所发现的功能来完成现有任务的过程。可用性测试可以确定这个过程的长短，以及在学习该功能期间用户犯了多少错误。

有效性表示用户“掌握”了某项功能，不再需要进一步学习即可使用。可用性测试可以确定有经验的用户使用该功能时执行必要步骤所需的时间。

可用性的这三个基本方面在很大程度上受到当前任务性质和用户执行任务的频率的影响。有些功能的使用频率很低或者使用起来十分复杂，导致用户基本上每次使用时都要重新学习；对于这些功能，Microsoft 通常开发了使用向导，在整个使用过程中对用户予以指导。

光喊口号是不够的

软件设计人员有时以为简单的口号，如“使产品更可用”，就可以解决可用性问题。虽然对可用性的积极态度是重要的，但是只有在具体的产品创建环境中，通过对普通用户进行恰当的可用性测试，才能为设计人员提供所需的信息，使产品可以满足用户的需要。“使产品更可用”应当成为每个软件设计人员的座右铭，但是这句话只对那些了解“可用性”含义的设计人员才有意义。而对普通用户进行测试就是可以找到的最可靠的途径。

常见问题

为什么要强调可用性问题呢？

如果您还没有在产品设计过程中将可用性因素考虑在内，您可能会问：可用性为什么是必要的，或可用性为什么是可取的？毕竟，不进行任何可用性工作，也可能发售一个可以工作的、没有错误的产品。但是，通过引入以用户为中心的设计理念可以使产品在很多方面得以很大改进。

减少用户拨打技术支持电话的次数是执行可用性测试的最佳理由。较差的可用性是用户拨打软件技术支持热线的主因，而每个软件公司主管以及信息服务经理都知道产品支持的成本是多么昂贵。此外，用户不得不寻求技术支持增加了用户对产品的潜在不满情绪。如果用户发现贵公司的产品使用起来十分容易，那么他们就不必频繁地打电话寻求技术支持了。

对于内部使用的软件，之所以将可用性作为开发过程中的一个重要部分，其原因还在于它减少了培训费用。对用户而言，可用性强的软件学习起来比可用性不受重视的产品学习起来要容易得多。用户能够更快地了解产品的各项功能，并能长久地掌握它，这直接减少了培训费用和时间。

可用性测试有助于促进用户对产品的接受程度。有很多因素决定了用户对产品的接受程度，这些因素包括可用性、实用性和受欢迎度。对于零售产品，用户的接受程度往往直接影响对产品的重复购买或对产品的忠诚度，这说明用户可能将产品推荐给其他人。对于内部应用程序，用户的接受程度决定用户是否愿意使用该软件执行任务，而这些软件就是针对这些任务设计的，这有助于提高生产效率。提高可用性是提高用户对产品的接受程度的一个因素。

可用性可将您的产品与您的竞争对手的产品区分开来。如果两个产品在实用性方面从本质上讲是一样的，那么人们很可能认为可用性更好的产品高出一筹。此外，由于 Microsoft® Windows® 的外观和感受以及随附的编程准则划定了基本用户界面的使用区域的标准，因此很多执行相似功能的程序其外观与操作在相当大的程度上是相似的。这些相似性表明，即使可用性上的细微差异也会对用户的喜好产生重大的影响。

最后请记住，每个产品最终都要进行可用性测试。用户每次使用您的产品时，都是在对它进行可用性测试，而他们对可用性优劣的意见将会影响他们是否继续使用该产品。将产品推向市场之前，对产品进行测试，可以有助于确保用户对产品的满意程度。

它的花费是多少？

软件设计人员和项目经理往往担心，如果采用以用户为中心的设计过程并执行适当的可用性测试，恐怕要占用大量的时间并花费大量的金钱。事实上，花费在关注用户方面的时间和金钱通常是相当少的，而且与不这样做而导致的花费相比，这点花费也是微不足道的。

例如，设想一下在开发周期的后期而不是在前期（产品仍处在开发阶段时）对设计进行修正您要花费多少时间和金钱吧！如果您一直等到 Beta 测试时期才使用户接触到产品以便进行可用性测试，就会发现自己不得不将花费了大量时间开发的程序的各部分分拆重做。而若等到产品真正发布时，如果要根据负面反馈进行修改或支持较差的设计，因为产品支持的庞大开销或用户对产品的接受程度较差等原因，很可能要支付高昂的费用。

合理的可用性研究通常只需要两周或更短的时间，并可以显著减少开发周期后期进行修改所需的时间和金钱。进行测试所需的花费将根据您的产品的性质以及所测试的界面部分的不同而有所不同。

可以认为可用性测试与代码测试是类似的。成功的项目经理在计划开发项目时总是会考虑到代码测试。他们并不认为代码测试是项目时间表或预算外的额外部分，而是将代码测试作为开发过程的一部分而计入成本。因为若不进行代码测试，那么花费反而会高得多。对于可用性测试，情况也是如此。

怎样获得可用性？

在理解可用性的重要性基础上，软件设计人员有时试图“获得”一些可用性，就好象可用性是一种成分，他们可以简单地把它添加到产品中，这样产品就更可用了。然而，可用性应当是设计过程本身的一部分，不是您可以在设计过程的随便某一地方添加的“东西”。可用性专家提到“用户关注的”与“以用户为中心的设计”的原因是：可用性取决于将用户的需要一直作为设计过程的中心。以用户为中心的设计根据需要的不同，包含的内容不单单是在界面中按照一组规则，对按钮和菜单布置进行管理。可用性测试是对设计工作进行检查的良机，而不是在产品中“添加”可用性的一种方法。

Gould、Boies 和 Lewis (1991) 为以用户为中心的设计定义了 4 个重要的原则：

及早以用户为中心：设计人员应当在设计过程的早期就致力于了解用户的需要。
综合设计：设计的所有方面应当齐头并进的发展，而不是顺次发展。使产品的内部设计与用户界面的需要始终保持一致。
及早并持续性地进行测试：当前对软件测试的唯一可行的方法是根据经验总结出的方法，即若实际用户认为设计是可行的，它就是可行的。通过在开发的全过程引入可用性测试，可以使用户有机会在产品推出之前就设计提供反馈意见。
反复式设计：大问题往往会掩盖小问题的存在。设计人员和开发人员应当在整个测试过程中反复对设计进行修改。
为什么应当将用户融入进来？

设计人员应当认识到他们自己不是普通的用户。与一般的用户相比，他们对正在开发的系统有着更深入的了解。因此，对大多数用户而言不明确或造成混淆的界面，可能对那些从事项目设计工作的人员来说是非常清晰的。某些软件设计人员可以在一定程度上代表普通用户，但他们绝对不能代替实际使用产品的真正用户。

因此，通过在早期关注普通用户的需要，并根据用户测试结果经常改进设计，以用户为中心的软件设计人员会提出更好的设计，并生产出更好的产品。

更好的设计将得到用户更好的认可。零售软件增加买进点的利益是很明显的：这增加了销售额。对于为内部使用而开发的软件，认可也是十分重要的：买进点增加将导致生产效率增加，并减少了对技术支持的需求。显然，从开发的一开始就将用户融入进来，并向用户表明您看重他们所关心的问题和需求，这将使用户更愿意协助您开发出更好的软件。

遵循这些准则就足够了吗？

Microsoft 为 Windows 计算平台开发了一系列界面准则，以此确保 Windows 程序具有一致的外观和感受。其它公司为非 Windows 计算平台开发了类似的准则，并且象 Jakob Nielsen 这样的专家撰写了大量关于设计可用 Web 页的文章。通过关于这些主题的大量信息，设计人员有时认为生产可用产品所需的全部工作就是严格遵守准则和规范。

这种想法的错误之处在于：准则在本质上是通用的。准则必须应用到各种各样不同的情况之中，因此它不能总是针对您正在设计的特定的应用程序制订最佳的行动方案。遵守一组合理编写的准则有助于您设计出风格一致的界面，但是您不能保证它是可用的，除非通过真正的用户对它进行了测试。当您的确要使用准则时，不要象使用详尽的说明书一样，希望根据准则执行的方法所生成的所有结果都是最好的。两个设计人员可以用两种不同的方法实施同一个准则，而两种实施方案对特定情况却不一定同等适用。而且，有时候严格遵守准则可能导致很差的结果，或在准则之间发生冲突。只有采用以用户为中心的设计，才可以在问题产生前排除它们。

对这个问题的另一种理解方式是：应当使以用户为中心的设计理念成为设计决策的决定因素，而不是以用户界面准则为决定因素。

是否需要创建可用性实验室？

不要以为可用性测试就意味着创建昂贵的实验室，在天花板上安装摄像机，安装单向镜，以及采用其它以小组为中心的设陷技术。的确，进行大量测试的公司通常认为建立专用的实验室十分方便，并且可用性顾问往往可以为客户提供各种各样的设施和设备，但您也可以在各种各样的设置和环境中执行有用、有效的可用性测试。

一种方法只需要一个测试人员（该测试人员对有人参与的研究工作与数据收集十分精通），在用户工作时坐在用户后面观察用户如何执行任务，这在会议室或办公室里就可以轻而易举地办到。Dumas 和 Redish (1999) 提供了大量关于使用观察法进行测试的信息。

随着可用性测试的进一步进行，您可以添加诸如摄像机、单向镜等设备，或其它帮助实时观察和记录用户显示器的工具。不必一下子添加所有的设备，即使一件一件地添加，也可以使您从可用性测试中获得更多有价值的东西。

另一种方法是，您可以将测试外包给可用性顾问。关于为您寻找合适顾问的几点提示信息，请参见下文的“我如何开始？”。

我如何开始？

一旦您决定将以用户为中心的设计原理运用到您的开发过程中，就需要决定是自己雇佣可用性专业人员还是将可用性测试外包给供应商。

可用性专业人员协会 (UPA) 有一份供应商指南，有助于找到为您执行测试的可用性顾问。

有些咨询部门还可以帮助您创建您自己的可用性实验室或开发内部的可用性程序，在您的设计过程中引入可用性理念。

如果您宁愿自己雇佣可用性专业人员，那么 Human Factors and Ergonomics Society 有职业介绍服务，使您可以找到潜在的雇员。很多可用性专业人员还属于 ACM Special Interest Group on Computer-Human Interaction (SIGCHI) 和 UPA，您也可以在他们的出版物和会刊上刊登招聘广告。

无论您选择哪种途径，请记住：您将要雇佣的是测试服务人员，而不是那些自己访问您的界面，并告诉您界面上有哪些错误的人员。设计人员不是普通用户的原则同样也适用于可用性专业人员。

关于这些公司和组织的信息，请参见下文的“资源”，您从中可以找到更多的关于可用性测试和以用户为中心的设计的内容。

资源

文献和书籍

Beyer、Hugh 和 Karen Holtzblatt。Contextual Design: Defining Customer-Centered Systems。San Francisco: Morgan Kaufmann, 1997。(ISBN: 1558604111)

Dumas、Joseph S. 和 Janice C. Redish。A Practical Guide to Usability Testing。 London: Intellect Books, 1999。(ISBN: 1841500208)

Gould、John D.、Stephen J. Boies 和 Clayton Lewis。"Making Usable, Useful, Productivity: Enhancing Computer Applications。" Communications of the ACM (January 1991): 72-86。

Hackos、JoAnn T. 和 Janice C. Redish。User and Task Analysis for Interface Design。New York: John Wiley and Sons, 1998。(ISBN: 0471178314)

Nielsen, Jakob。Usability Engineering。Boston: AP Professional, 1994。(ISBN: 0125184069)

Shneiderman 和 Ben。Designing the User Interface: Strategies for Effective Human-Computer Interaction。Reading, MA: Addison Wesley, 1998。(ISBN: 0201694972)

组织

ACM Special Interest Group on Computer-Human Interaction (SIGCHI)（英文）：UI 从业者的最大的组织。
英国 HCI 小组（英文）：英国计算机协会的专家组。有关合约资源请参见顾问目录。
人文因素和人类工程学组织（英文）。
可用性专家协会（英文）：参见其顾问目录以获得合约资源。
其它联机资源

HCI 书目（英文）：人机交互出版物与资源。
Microsoft 用户经验与 UI 设计资源（英文）。
Useit.com（英文）

点击查看用户来源及管理<br>发贴IP：211.162.42.201 2003-11-6 16:34:47
编辑这个贴子 鲜花(0) 鸡蛋(0)
x3d 帅哥哟，在线，有人找我吗？

等级：初级用户
文章：119
积分：314
注册：2003-5-12
给x3d发送一个短消息 把x3d加入好友 查看x3d的个人资料 搜索x3d在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给x3d OICQ 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
文章出处：
http://www.microsoft.com/China/msdn/msdnonline/features/articles/uidesign.ASP#uidesign_topic2
点击查看用户来源及管理<br>发贴IP：211.162.42.201 2003-11-6 16:37:11
编辑这个贴子
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
收藏！谢谢！

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.91.206 2003-11-17 11:44:31
编辑这个贴子
子木1977 美女呀，离线，快来找我吧！ 双子座1977-5-26

等级：初级用户
文章：81
积分：238
注册：2003-10-20
第4楼
发贴心情
每天都能学到新东西，好开心，慢慢吸收中^_^...

----------------------------------------------
有心，就有翼——飞翔

点击查看用户来源及管理<br>发贴IP：218.79.103.159 2003-11-19 9:57:38
编辑这个贴子
小平 美女呀，离线，快来找我吧！

等级：活跃分子
文章：320
积分：593
注册：2003-7-28
第5楼
发贴心情
谢谢！

----------------------------------------------
!@! # $ %| ^-^ &!& *!* (!) ^_+

点击查看用户来源及管理<br>发贴IP：61.51.107.13 2003-11-20 14:10:16
编辑这个贴子

本主题贴数5，分页： [1]
*快速回复：软件设计中的可用性 [转自Microsoft MSDN]
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：515.625毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：关于UI相关工作职位的一些说明

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：关于UI相关工作职位的一些说明

您是本帖的第 393 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 关于UI相关工作职位的一些说明
dozer 帅哥哟，离线，有人找我吗？

等级：中级会员
文章：466
积分：784
注册：2003-6-15
楼顶
发贴心情 关于UI相关工作职位的一些说明
作者是Scott Bunkun..

To: 云儿林,

我翻译得比较粗糙。。也没有翻译完。。也请注意，这主要是描述了美国的情况，比如project manager，在中国或许有不同的定义和定位。在微软有特别的含义..

In most corporations there are several different job functions that CS, design and usability related jobs are divided into. Here抯 the general rule of thumb:

Software developer: 软件开发人员。 Someone that writes code.是写code的人。需要我说更多的吗？OK.... Need I say more? Ok. There are so many flavors of this that it抯 difficult to list them all. Most of the time, developers are expected to own certain areas of a product or website, creating new code and maintaining old code, to meet requirements. This could mean working on Quake IV, or it could mean working on an accounting program. The more specialized the job, the more requirements applicants often need to get it (e.g. Quake IV would require significant programming experience in 3d rendering environments, before the folks on that team would hire you. The accounting team might require that you know relational databases, or SQL. You get the point.).

Tester / QA: 测试人员： A person responsible for assessing, maintaining and verifying the quality of production code for a product or website. This role can vary from being very tactical, focused on building components and automating test passes, to someone that is running sophisticated analysis tools, and overseeing project plans and architectures. Most of the time, it抯 more tactical, where a tester is partnered with a developer or team of developers, to help them manage quality. This role tends to be good for people that like to break things, or are good at breaking things in a systematic way.

Usability engineer: Someone that drives the research and analysis aspects of UI design. They run lab studies, site visits, and other forms of usability methods. They may contribute to the design, or help shape the process the team goes through for generating and refining ideas, but their primary obligations are often more analytical than creative. They are (or should be anyway) involved early to guide requirements, checkpoint along the way, and verify if necessary at the end. However in some organizations, usability is seen as the verifier of usability quality, instead of contributing to generating the designs, in which case usability studies are done late in the process. From company to company, and org to org, the philosophy around usability varies significantly. YMMV.
易用星工程师：　是驱动对UI设计方面的研究与分析的人。他们进行实验室研究，站点访问和其他形式的易用性测试方法。他们也可以对设计有贡献，或者帮助团队确定产生和完善想法的过程，但是他们的主要职责常常是分析多于创造。他们（或者他们应该）涉及在早期引导需求、过程中检查、如果必要在后期验证。但是在一些组织中，易用性被视为对易用性质量的验证者，而不是对产生涉及做出贡献的人，用户案例易用性研究是在开发过程的后期被完成。不同的公司和组织，关于易用性的观念，差别很大。
Interaction/UI/Product Designer:交互/UI/产品设计师：
是对一个项目的用户界面和功能设计驱动创造性方面的人。典型地他们会参与一些需求分析，产生想法，做原型，并和开发团队共同创建它。这可以是一个领导者的角色，设计师驱动项目的早期阶段。或者也可以是一个被动的角色，设计师跟随工程师、市场人员、项目经理的引导。一些组织中寻求去寻找一个最佳的平衡，而一些组织并不这样。最容易的辨别方式，是去看他们的产品，并自己做出判断，而这样会更好，即如果你有机会，就去要求团队中的人向你解释某个特别的设计决定是由谁做出的。
Someone that drives the creative aspects of the functional and user interface design for a project. They typically take some set of requirements, generate ideas, wireframes, and prototypes, and then work with a development team to build it. This can be a leadership role, where the designer is driving the earlier phases of a project, or it can be a passive role, where the designer follows the lead of the engineers, marketers or project managers. Some organizations manage to find a good balance, some don抰. Easiest way to tell is to look at their products and judge the results for yourself, or even better, if you have the opportunity, ask someone from that team to explain to you how a specific design decision was made.
Visual/Graphic Designer:视觉/图形设计师：这个角色是集中于网站或软件产品的视觉和美术设计方面。有时这会被认为是对ＵＩ设计核心的贡献，有时则不是（参见上面提到的易用性工程师职位） 。在一些情况下，视觉设计师也许主要负责品牌、企业形象或其他主题设计。在其他情况下，一个视觉设计师负责实际的产品设计工作，提供需要产品所需要的所有设计工作（图标、主题、背景，等）。This role is focused on aesthetics and visual design for a website or a software product. Sometimes this is seen as a core, central contribution, sometimes not (See usability engineer above). In some cases, the visual designer might be focused on branding, corporate presence, or other thematic design work. In other cases, a visual designer works on actual products, and provides all of the design work needed to produce the product (icons, themes, backgrounds, etc.).
Information Architect : 信息架构师。这是一个最近的工作定义。。。。这个头衔常常用于网站工作的类型。This is more recent job definition. As best I can generalize it, this is an interaction designer, who's focus is on organizing information,我所能进行的最好的解释是，这是一个交互设计师的角色， 他的主要职责是组织信息，但是他也可以应用….but who may employ skills and tactics from usability engineers, designers or project managers. This title is use most often for web type jobs. In other situations this job title means the application of library science skills for classification of information, including hierarchies, taxonomies and effective use of metadata.
在其他情况下，这个工作头衔意味着对于信息的归类（包括层次、分类学，元数据的有效使用等）实验室科学技巧的应用。

Project managers:项目经理；一些组织中把功能设计（产品应该有什么特点，他们应该怎样工作/行为)的职责交给项目经理。
Some organizations give functional design (what features should the product have? how will they work/behave? etc.) responsibilities to project managers. 如果没有设计师或易用性工程师，则项目经理经常承担任何设计思考的职责。。。If no designer or usability engineer is on staff, the project manager often gets the responsibility for any design thinking they can find time for. 在一些组织中，...In some organizations, project managers are hired with some background in usability or design, so that they can manage this extra aspect of the job relatively well (Microsoft sometimes hires people with UI experience for their ?A href="../other/projman.htm">program manager?role). In the best cases, the project manager is partnered with someone with deep expertise in design, and the time bandwidth to focus on that contribution, freeing the project manager to actually manage the project.

UI Developers: UI开发人员：Many organizations delegate the design responsibility for user interfaces or websites to the engineers that implement them. Since from a purely functional perspective, these are actually the folks that build the stuff, there is a certain logic to this responsibility. It is a known fact the Macintosh user interface was conceived and built almost entirely without usability engineers or trained interface designers (Same for many other software products, games, or websites). However, in most mature software development organizations, the engineer role is specialized to the point where it抯 unlikely to find engineers with significant proficiency or agility to both design and implement great user interfaces. They exist, but they抮e rare. (If you happen to work with one, be nice to them. If you happen to be one, ask for more money).

Now while these jobs are somewhat standard across the industry, this doesn抰 necessarily suggest that this delineation of work leads to the best or most usable software or websites. For whatever reason, this just seems to be the common way to break up the work. I suspect the origins of these roles are based on both the ability to find people to play them (e.g. visual designers) and the biases and structures of most organizations and the ease of fitting people in these roles into existing organizations.
A good general rule: the smaller the organization, the fuzzier the roles tend to be.一个好的通用原则是：组织越小，那么这些角色的界限就越模糊。在微软，一个5万人的公司，在大多数产品组里面的角色都被很好地定义了。但是，即使在那样的大公司，在公司中更小的组织和团队中觉得都更多地相互重叠。 At Microsoft, a company of ~50,000 people, the roles on most established product teams are well defined. But even at such a large company, there are many smaller organizations and teams within the company where the roles overlap more, or have blurrier distinctions. It often makes more sense to pay attention to the size of the product or the team the job will be part of, than the company or larger organization. (The best question to ask is often: How many other people of this job type will be working on this project, or this team?)
So when you see a job description that combines everything listed above (the kitchen sink UI job, for example), it means one of two things: 1) the person that wrote the job description is looking for a superhero 2) the person that wrote the job description doesn抰 know what they抮e talking about 3) The organization or team is small enough that they抮e looking for someone that抯 very agile, and has a wide variety of skills. In #3, even if they list everything as a requirement, it probably really isn抰. That抯 a good rule of thumb: Generally speaking, hiring managers will hire the best candidates they can, even if that means only some of the requirements are met. In a tight job market, hiring managers are apt to set a very high bar, since they know odds are better that they抣l find someone close to it.

点击查看用户来源及管理<br>发贴IP：218.80.63.100 2003-10-28 9:50:13
编辑这个贴子 鲜花(0) 鸡蛋(0)
酚麻 帅哥哟，离线，有人找我吗？

等级：超级版主
文章：1505
积分：2514
注册：2003-1-21
给酚麻发送一个短消息 把酚麻加入好友 查看酚麻的个人资料 搜索酚麻在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给酚麻 OICQ 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
谢谢 dozer! 又进一步的了解了UI行业。

----------------------------------------------

点击查看用户来源及管理<br>发贴IP：219.238.180.98 2003-10-28 10:02:03
编辑这个贴子
Rokey 帅哥哟，在线，有人找我吗？

等级：管理员
文章：1508
积分：2702
注册：2003-4-12
第3楼
发贴心情
真是好,谢谢dozer!

----------------------------------------------
---------------------------------------------------------------------------
Rokey project
http://www.rokey.net/

点击查看用户来源及管理<br>发贴IP：210.76.108.146 2003-10-28 10:20:33
编辑这个贴子
jiliy 帅哥哟，离线，有人找我吗？

等级：高级会员
文章：389
积分：546
注册：2003-3-4
第4楼
发贴心情
即使在那样的大公司，在公司中更小的组织和团队中觉得都更多地相互重叠。

嗯！

----------------------------------------------
他说，经商其实不用很多技巧，只要坚定自己的信心，把事情做得最好，做得到位，就能成功。他很欣赏三宅一生说的一句话：“做我喜欢的东西，让别人去接受。”他把这句话转作“让我做菜，你就得接受这个味。”他认为这样的态度是从根本上考虑，从长远考虑。只有干自己擅长的事，坚持专业精神，才能够把东西做到极致。有很多设计师迫于生存，牺牲掉专业的东西，这样就永远没有自己的风格。

点击查看用户来源及管理<br>发贴IP：218.246.32.115 2003-10-28 10:24:15
编辑这个贴子
blandboy 帅哥哟，离线，有人找我吗？ 天蝎座1978-11-8

等级：初级用户
文章：124
积分：379
注册：2003-5-30
第5楼
发贴心情
E文的，看不懂，翻译也不是很详细~~~~~~~~还不如不翻！
点击查看用户来源及管理<br>发贴IP：202.102.138.27 2003-10-28 10:28:41
编辑这个贴子
yunerlin 美女呀，离线，快来找我吧！

等级：初级用户
文章：9
积分：69
注册：2003-6-24
第6楼

就目前国内软件也，感觉到没有哪一家公司在前台界面上提供如此全面的职位。我们常说的界面美工，往往只停留在界面美化上，而这又是远远不够的。谢谢dozer的翻译，我们要学的确实还有很多！

点击查看用户来源及管理<br>发贴IP：218.108.148.86 2003-10-28 13:02:38
编辑这个贴子
子木1977 美女呀，离线，快来找我吧！ 双子座1977-5-26

等级：初级用户
文章：81
积分：238
注册：2003-10-20
第7楼
发贴心情
不断前进中，以大家为榜样^_^...

----------------------------------------------
有心，就有翼——飞翔

点击查看用户来源及管理<br>发贴IP：218.79.103.159 2003-11-19 10:08:36
编辑这个贴子

本主题贴数7，分页： [1]
*快速回复：关于UI相关工作职位的一些说明
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：593.750毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：界面设计、交互设计及程序开发

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：界面设计、交互设计及程序开发

您是本帖的第 630 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 界面设计、交互设计及程序开发
anyone 帅哥哟，离线，有人找我吗？

头衔：-= 副头头 =-
等级：管理员
文章：1230
积分：2649
注册：2003-1-13
楼顶
发贴心情 界面设计、交互设计及程序开发

来源： 网络项目管理学会 作者： 九点

    在网络项目开发过程中，这个阶段也叫做构建阶段，是工作量最大、最艰苦也是最难以控制的阶段。不管一座大楼的设计蓝图多宏伟，若没有管道工、泥瓦匠、水电工等各种工匠一砖一瓦地艰辛积累，密切协作，这座大楼始终是空中楼阁、海市蜃楼。

本章包括以下内容：
一：界面设计打开用户之门
二：交互设计建立沟通的桥梁
三：程序开发是系统的基石
四：本阶段的重点工作
五：总结

一：界面设计打开用户之门
    对于以Web服务为模式的项目，无论是访问用户还是系统管理员，主要工作都是通过浏览器的界面交互完成。给系统设计合理友好的操作界面就像给人穿衣服一样，合体舒适的搭配能给人耳目一新的感觉，反之则令人敬而远之，甚至失去进一步深入了解的兴趣，这无疑不是开发人员所期望的结果。
    以网站为表现方式的系统界面设计所涉及的知识远远超过了美术的范畴，作为一个优秀的Web界面设计师来说，需要掌握的不仅仅是电脑制图的能力，还应该具备心理学、广告创意、美术工艺、排版艺术等多方面的综合素质，系统界面绝不是孤芳自赏令人难以理解的抽象画，而应该成为绝大多数用户共同接受的最方便的日用品。
    关于Web美工创作的操作技巧不是本文所关注的，我们希望知道的是用户最需要的是什么样的界面？根据笔者的经验，在进行产品设计和项目开发的界面设计中是有所不同的。产品通常是指可大量分发销售的成熟性的产品，具体用户是不确定的，而项目大多是针对具体客户的需求进行开发，不具备二次销售的条件，当然，在二者之间总还是能找到共同点的。
    产品设计由于面对的是未知的用户，因此界面设计必须挖掘的是用户习惯和观念的共性，大众化产品（例如邮件系统、BBS、门户网站等）、商业应用产品（例如交易系统、电子办公系统）或专业应用产品（例如财务系统、杀毒系统）等等，需要考虑的是所有人或某一类的人的共同习惯和审美观念，而不是刻意地出奇招、不断地考验用户的智商和耐心。
    项目开发则相反，面对明确的具体用户考虑更多的是个性化设计，也许有些是非常规的要求，但是用户已经具有特殊的偏好和习惯时，应尽可能满足用户的需求进行设计。在笔者参与某个行业的办公系统设计过程中，用户就提出了非常特别的要求，所有的界面不能出现外国人和外国场景的形象，每一页都需要变换颜色，另外站点标题要大得出乎寻常，失去比例，这时候美工只能迁就用户的心理和习惯，可是这样的设计用到产品设计上，大多人都会感到不舒服。
    不管是产品设计还是项目开发，界面设计都应该遵循以下共同的规则：
* 界面风格需要一致：
    每个新的系统对用户来说都是一次新的学习过程，如果界面风格经常变化，不保持统一，无疑更增加了用户的学习难度，也许会导致用户的厌烦。比如：第一页的导航条是图片型的放在页面顶部横排的，而在第二页导航条却成了文字型居左竖排，用户会为了捉摸不清设计师的意图而大光其火。再比如，有些设计师考虑到用户方便，在页面上放置了后退的按钮，但是要是不注意保持一致的话，用户也许会糊涂后退、回首页、BACK、上一页这些按钮究竟有什么区别?也许非常恼火你是不是拿他在开涮！
* 界面元素对象化：
    在程序设计中需要注重模块化，而界面设计中对象化同样非常重要。将界面元素对象化，比如底部版权信息、导航条等，图片、JS也尽可能复用，比如站点标志、搜索按钮、滚动信息的JS文件等等；
* 建立标准的文档管理和设计规范：界面设计涉及的要素比较多，文件类型复杂，而界面文件往往还需要另外通过程序进行编译，这就要求了界面设计人员必须建立规的设计规范和标准的文档管理方法：
* 制定文件命名标准
* 设定文件统一路径
* 保存原始创作文件（例如PSD、Fla源文件）
* 最终完成文件（经过用户认可的文件）
* 单独管理摸版文件（经过编译或嵌入程序的文件）
* 考虑用户偏好习惯和方便性：
    我们经常可以听到界面设计师说：“怎么在我机器上看得好好的，怎么在你那里就变样了？”其实道理很简单，用户的操作环境和习惯与设计环境是有差别的，界面设计同程序一样需要进行测试，主要测试的对象为：
* 浏览器类型和版本兼容问题：假如有个很重要的菜单是需要IE5.5支持的，但是用户万一使用的是IE4.0版本，那么这个菜单就再也打不开，结果可想而知；
* 分辨率：界面设计师的屏幕也许是17寸的，分辨率甚至做到1280×960都是可以接受的，但是用户的如果用的14寸显示器，分辨率只能达到640×480，界面布局看起来会很可笑；
* 字体大小：利用样式表精确控制页面元素，特别是字体是很重要的。有不少用户喜欢更改浏览器默认的字体显示大小，当设计师看到用户将字体显示调整成最大而将表格撑得乱七八糟的时候，或许会痛心疾首的；
* 考虑特殊情况：用户或许在浏览器设置了禁止显示图片或禁止JS脚本等，有必要为图片设置好尺寸以免影响其他元素的显示，并有其他的方式代替JS需要显示的效果和信息。
* 编写帮助：
    无论多么出色的界面设计对用户来说都是陌生的，那么编写站点帮助或软件帮助是个非常有效的办法，把你的设计意图和使用介绍明明白白地告诉用户，在用户遇到困难的时候能够得到最快的帮助，不但可以降低用户的不满程度，同时可以帮助用户更加系统深入地学习和掌握。

二：交互设计建立沟通的桥梁
    作为交互设计人员应该读读Alan Cooper的《软件创新之路》，被誉为“VB之父”地Alan Cooper明确地提出了将程序开发划分为交互设计和编码设计两大部分，笔者非常赞同。
    “软件越来越难用，越来越难学。”我们不止一次地听到用户如此地抱怨，也许程序员认为机器就是如此理解程序的，随着系统的日益复杂和功能的不断强大，软件原来越难用，门槛越来越高是很正常的，但是别忘记用户才是系统的所有者和使用者，期望用户成为计算机专家的要求显然是难以接受的。在国内无论是从事商务的技术人员还是技术型的商务人员都极其缺乏，交互设计师就理所当然地应该成为彼此沟通的桥梁。

    程序员和用户的差别是很明显的，因此通过交互设计建立良好的沟通是非常需要的。

（一）交互设计师的侧重点并不在程序的编码实现，而注重于用户如何最好地与系统交互操作，在设计中重点需要考虑的是：
* 系统易用性：
    并非每个用户都是计算机的熟练用户，面对隐藏的层和特殊设计的菜单可能会抓瞎，用户不见得能明白双击左键能自动滚屏或者怎样能让自动滚屏停下来、直接看最下面的结果？交互设计师特别需要重视的就是系统的易用性。有条件的话，可以让不同的陌生用户从首页开始操作，不给予任何提示和帮助，观察用户的上手和熟练程度，记录并查找所有的陷阱和缺陷，加以改进。
* 流程简便：
    “简单就是美”，在系统交互设计方面更是如此，如何用最少的操作，最明显的提示和帮助，完成一项流程的操作是需要花大力气进行优化的。
* 盲点测试：
    用户的操作并不是严格的按照系统的提示顺序进行，也不一定会按照系统的提示要求去做，而程序员在设计的过程中是按照既定的逻辑进行开发的，测试中也难免以自己的习惯操作，这时就可能出现盲点，即系统存在未被测试到的状态环境。编写测试软件或利用其他测试工具可以大大提高测试的可靠性。
    例如一份表单正常提交以后，假如用户利用历史记录后退，回到提交前的状态，这时候修改了提交内容，又再一次提交，那么结果是什么呢？再比如，假如设计的弹出窗口的尺寸是700×500，且不可改变大小，隐藏滚动条，而用户万一使用640×480的分辨率，那么弹出的窗口中，用户如何能点击到最下面的按钮？
* 出错及异常提示：
    凡是软件都是有BUG的，因此对各种出错或异常状态给予用户一个友好的提示和帮助，并提示用户大概是由于什么原因，那么用户会愉快的多。
    笔者遇到过一个用户注册系统，用户注册后希望修改密码，有的能做成功，而有些人怎么也改不了，检查了很长时间才发现由于密码设置的是不少于三位不大于八位，许多用户密码超过了八位，因此无法修改成功，但是由于没有提示出错原因，所以用户就不断拼命地提交，最后只好愤怒地去投诉。
    再例如发布信息的时候，可能会因为填写时间过长，提交时被系统拒绝数据丢失，那么用户辛辛苦苦撰写的内容永远消失了，还有什么比这个更令用户沮丧的吗？在填写的输入部分给用户一个时间提示，或允许后退找回刚才的内容，至少可以让用户容易接受一些。
* 利用用户环境测试
    利用用户的操作环境进行测试，用户的服务器、网络线路和客户机也许跟开发环境差别巨大，用户的机器配置、网络环境对系统的要求是不一样的。比如设计客户端的APPLET时也许会因为客户机的内存不足而崩溃，也可能因为文件过大，远程访问时处理时间过长而响应失败，。

    （二）Web的交互设计师需要掌握的技能主要是javascript、VBscript、Dhtml、Flash等，还需要了解心理学、人因工程学、系统工程等方面的经验和知识，认真把握每个交互动作的合理性和可行性，这个交互也许是个链接，也可能是个表单、提示窗口或者是滚动条的拉动距离，检查是否最优化和最合理的方式。
    举个很简单的例子，在链接列表过多出现翻页的时候，程序员很自然地会将上一页、下一页的翻页按钮放在了最底下，但是列表很长的时候，用户每次翻页的时候都需要把滚动条拉到最下面才可以点击到翻页按钮，用户可能就会抱怨，明明知道在某一页，却每次要点击后拉滚动条寻找翻页按钮，而如果将翻页按钮在列表的上面也放一条，并且设置直接跳转到某页的按钮，则大大减轻了用户的工作量，类似的例子在我们的设计中屡见不鲜。

三：程序开发是系统的基石
    程序员进行编码，构成了系统的基础。在进行系统分析和软件建模以后，程序开发便进入实质性的过程。但是在程序员动手之前不单需要和系统分析员打交道，还要和界面工程师，交互设计师，业务流程分析员以及客户交流，除了理解程序逻辑以外，同时需要理解界面设计和交互设计的要求，使得程序开发成功的可能性大大提高，达到事半功倍的效果。
    随着网络开发技术的日益发展和用户需求的不断增长，系统开发中的编码工作日益繁重，不仅仅需要考虑性能和功能的实现，而且需要考虑今后的维护和扩展，需要考虑到系统的集成和稳定，许多稍微复杂一些的系统开发便不再是一个人能独立完成的，因此程序开发需要遵照严格规范的开发过程。
* 文档规范：软件即文档。
    良好的文档习惯是系统开发极其重要的，文档是程序的一部分，程序员花一定时间进行文档编写是份内的工作。具备完整的文档记录，对于系统今后的二次开发、查错、升级具有重大的作用。可以说即使代码全部扔掉，只要文档完整，很快就可以再造一个系统出来，而只保留了代码，缺乏文档的时候，就像被抽了脊梁的标本，再难站起来恢复原样。
* 编码规范：编码规范包含了程序排版、注释、命名、可读性、变量、程序效率、质量保证、代码编译、代码测试和版本控制等等注意事项。
    程序员最常见的问题之一：“别人写的代码看不懂，与其改写不如重写”。基本上都是没有按照编码规范开发的缘故。所以我们经常听说某个程序员离职以后，他所写的那些模块就没法维护和管理了。
* 代码复用：代码复用是程序员的梦想，也是系统成熟度的重要标志，关于代码复用方法的讨论不在本文之列，但是做为代码复用是程序员走向成熟和提升的必经之路。
* 测试测试再测试：笔者在软件工程的讨论会上，微软的一位项目经理在介绍微软如何保证产品质量时说：“微软质量保证的秘密就是：测试测试再测试！”在IE4.0的开发小组中，200名开发程序员意外还有200多名测试工程师，而且测试工程师的水平甚至高于开发工程师。测试是系统质量最直接有效的手段。在国内的开发环境达到这样的投入和水平显然是不太现实的，但是尽可能提高测试环境和加强测试管理，是程序员和测试工程师共同的方向。

四：本阶段的重点工作：
    在这个阶段是整个项目组参与角色最多，也是协作最密切最难控制的过程，笔者认为做为项目经理特别需要关注以下问题：
    1：建立项目小组的沟通渠道：
    沟通是项目小组具有密切协作形成凝聚力的最重要的手段，在项目开发过程随着各个角色的工作进展，冲突和矛盾是必不可少的，无论是通过论坛、邮件、会议、口头还是私下沟通，项目管理人员有责任和义务建立小组通畅及时的沟通渠道，根据有经验的HR经理分析：有效的沟通应该是在问题发生的48小时之内，否则解决的效率会降低75％。
    2：建立文档规范和管理办法，借助PVCS、WINCVS等相关工具建立整个项目小组的文档；
    2：建立BUG报告系统，在内部预先创建测试环境，将BUG尽可能早地消除掉。
    3：测试和文档工程师的工作自始自终地贯穿着项目开发过程，这在以后的文章中会继续介绍。

五：总结
* 沟通是本阶段最需要注意的问题；
* 建立文档管理体系；
* 建立测试环境和测试标准；
* 界面设计是为用户设计的，不是用来自己欣赏的艺术品；
* 为用户着想，人性化设计是项目成功的保证；
* 代码复用，对象化模块化设计是界面设计、交互设计和程序开发共同追求的目标。

----------------------------------------------
-= cHinAuI.coM =-
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：203.212.6.131 2003-1-22 21:03:00
编辑这个贴子 鲜花(0) 鸡蛋(0)
imqq 帅哥哟，离线，有人找我吗？ 天蝎座1978-11-15

等级：初级用户
文章：125
积分：226
注册：2003-5-12
第2楼
发贴心情
这篇文章很好，建议大家都来认真看一下

一个成功的设计者应该懂得去接受各种新的理论。。在从理论中实践

----------------------------------------------
一个焦灼不安的城市小人物，一个在生活重压下寻找出路的小市民，一个在梦想和坠落间彷徨的普通人。

点击查看用户来源及管理<br>发贴IP：211.93.24.136 2003-6-2 10:28:09
编辑这个贴子
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
收，不错！

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.13 2003-6-2 13:08:34
编辑这个贴子
yunyuyao 美女呀，离线，快来找我吧！ 魔羯座1979-12-28

等级：中级会员
文章：639
积分：870
注册：2003-4-14
第4楼
发贴心情
嗯，真的不错啊

----------------------------------------------
……云雾散去，太阳出来，不见了妩媚妖娆温柔可爱，只留下那瞬间空白……

            设计设计，我爱设计．．．＾－＾

点击查看用户来源及管理<br>发贴IP：218.58.33.164 2003-6-2 13:51:13
编辑这个贴子
cooya 帅哥哟，离线，有人找我吗？ 天秤座1976-10-5

等级：初级用户
文章：124
积分：206
注册：2003-6-1
第5楼
发贴心情
晕，各种理论。是不是太多了。人的精力是有限的。总不能吃的草，挤的是血吧？

----------------------------------------------
＝＝＝＝＝＝＝＝随梦入天堂 * 生命真色彩＝＝＝＝＝＝＝＝

http://www.cashfiesta.com/php/join.php?ref=cooya

点击查看用户来源及管理<br>发贴IP：202.111.168.39 2003-6-2 14:26:17
编辑这个贴子
imqq 帅哥哟，离线，有人找我吗？ 天蝎座1978-11-15

等级：初级用户
文章：125
积分：226
注册：2003-5-12
第6楼
发贴心情
这个文章已经发表很久了。是我在最后一页找到的。
。我是觉得里面有一些是值得你去研究一下。。

。。

----------------------------------------------
一个焦灼不安的城市小人物，一个在生活重压下寻找出路的小市民，一个在梦想和坠落间彷徨的普通人。

点击查看用户来源及管理<br>发贴IP：211.93.36.136 2003-6-2 14:58:27
编辑这个贴子
sunny66 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：7
积分：61
注册：2003-6-4
第7楼
发贴心情
请教各位有没有关于UI设计与程序员开发中数据关系很好结合的方式？

比如：有些数据关系直接影响设计，有些设计会影响数据开发的复杂度和日后维护量。

点击查看用户来源及管理<br>发贴IP：218.58.69.26 2003-6-4 15:54:38
编辑这个贴子
yorky 帅哥哟，在线，有人找我吗？ 金牛座1978-4-26

等级：高级会员
文章：1285
积分：2187
注册：2003-6-12
给yorky发送一个短消息 把yorky加入好友 查看yorky的个人资料 搜索yorky在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给yorky OICQ 引用回复这个贴子 回复这个贴子 第8楼
发贴心情 文章不错！
好东西！！！！！

----------------------------------------------

四大皆空之－－
爱空空情空空，自己流浪在街中；
人空空钱空空，单身苦命在打工；
事空空业空空，想来想去就发疯；
手机空没钱充，生活所迫不轻松！

点击查看用户来源及管理<br>发贴IP：61.144.148.47 2003-6-17 14:40:38
编辑这个贴子
yunxiao 帅哥哟，离线，有人找我吗？ 双子座1977-6-7

等级：版主
文章：226
积分：431
注册：2003-1-22
第9楼
发贴心情
我觉得还要建立一个与开发分离的质量监督关节，保证整个开发过程能始终很好的执行开始制定的计划。否则项目收尾时一赶工，代码也不重用了，之间的沟通也少了，界面上的功能能省的也就省了，经常出现“哦，这个呀，你自己看着办吧”

----------------------------------------------

点击查看用户来源及管理<br>发贴IP：202.108.200.114 2003-6-17 16:08:55
编辑这个贴子
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第10楼
发贴心情
睁大眼睛~~看各种各样的~~理论~~

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.91.206 2003-11-17 11:54:27
编辑这个贴子
子木1977 美女呀，离线，快来找我吧！ 双子座1977-5-26

等级：初级用户
文章：81
积分：238
注册：2003-10-20
第11楼
发贴心情
大家都说好的文章，一定好好阅读^_^...

----------------------------------------------
有心，就有翼——飞翔

点击查看用户来源及管理<br>发贴IP：218.79.103.159 2003-11-19 10:19:41
编辑这个贴子
honghonge 帅哥哟，离线，有人找我吗？

等级：活跃分子
文章：211
积分：574
注册：2003-7-2
第12楼
发贴心情
多学科的集成，一个人绝对做不到。所以为什么大公司都有那么多眼花缭乱的岗位，不过这篇文章有些笼统，知其然，而不知其所以然。
点击查看用户来源及管理<br>发贴IP：218.58.28.117 2003-11-20 11:32:41
编辑这个贴子

本主题贴数12，分页： [1]
*快速回复：界面设计、交互设计及程序开发
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：6,328.125毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：html内TAB页的实现方式探讨

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：html内TAB页的实现方式探讨

您是本帖的第 310 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： html内TAB页的实现方式探讨
烛音 帅哥哟，在线，有人找我吗？

等级：实习版主
文章：5186
积分：7085
注册：2003-5-22
楼顶
发贴心情 html内TAB页的实现方式探讨

此主题相关图片如下：
按此在新窗口浏览图片
如图：实际上这个TAB页并非真正意义上的TAB页，当点击领料申请，该图片显示第二种状态，其它三个图片隐为第一种状态。其它同理。

我现在的实现方式是把四个图片的第一种状态放在四个表格内，新建四个图层(与图片一二三四重叠，初始化隐藏，分别放入四个图片的第二种状态)，当点图片一，显示图层一，隐藏图层二三四。点图片二，显示图层二，隐藏图层一三四。

可是程序员说：因为它这里是把表格数据绑定在图片上的，并未采用页中页或者弹出新页，所以她希望的方式是用脚本直接控制图片的两种状态，而不要采用层。
[采用这种方式的好处在于：使同级的操作可以任意跳转]

大家有什么好的想法？有知道的朋友请踊跃发言。

----------------------------------------------
http://www.cqppi.com/1/1.html

点击查看用户来源及管理<br>发贴IP：211.158.65.243 2003-11-5 12:07:09
编辑这个贴子 鲜花(0) 鸡蛋(0)
blackeyes 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：16
积分：86
注册：2003-3-6
第2楼
发贴心情
你的意思是说不用层的交替来实现tab图的鼠标事件而直接用客户端脚本来控制实现吗？
点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-5 12:20:38
编辑这个贴子
烛音 帅哥哟，在线，有人找我吗？

等级：实习版主
文章：5186
积分：7085
注册：2003-5-22
第3楼
发贴心情
本来层也是用的JS脚本，需要的是不利用图层的控制方法。不过刚才程序员已经解决了，她用的是服务器端的脚本控制。

尽管如此，我们还是可以探讨一下客户端的解决办法。

----------------------------------------------
http://www.cqppi.com/1/1.html

点击查看用户来源及管理<br>发贴IP：211.158.65.243 2003-11-5 12:37:44
编辑这个贴子
blackeyes 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：16
积分：86
注册：2003-3-6
第4楼
发贴心情
我知道你以前是用JS来控制层的显示与否来实现
但我还是没明白你是想只控制tab按钮的图片呢？还是想控制tab内容？
如果只是图片的话，不用图层也是可以直接在客户端JS控制的
但如果是tab的内容的话可以用页中页来控制
点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-5 13:00:17
编辑这个贴子
烛音 帅哥哟，在线，有人找我吗？

等级：实习版主
文章：5186
积分：7085
注册：2003-5-22
第5楼
发贴心情
我说的是控制图片本身

----------------------------------------------
http://www.cqppi.com/1/1.html

点击查看用户来源及管理<br>发贴IP：211.158.65.243 2003-11-5 13:08:50
编辑这个贴子
blackeyes 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：16
积分：86
注册：2003-3-6
第6楼
发贴心情
试试这个：

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<title>CCTV信息管理系统</title>
<meta name="Author" content="Kinkky Hsu">
<meta http-equiv="Content-Type" content="text/html; charset=gb2312">
<script language="javascript" type="text/javascript">
<!--
function MM_preloadImages() { //v3.0
var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();
var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)
if (a[i].indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a[i];}}
}

function MM_swapImgRestore() { //v3.0
var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a[i])&&x.oSrc;i++) x.src=x.oSrc;
}

function MM_findObj(n, d) { //v4.01
var p,i,x; if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++) x=d.forms[i][n];
for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=MM_findObj(n,d.layers[i].document);
if(!x && d.getElementById) x=d.getElementById(n); return x;
}

function MM_swapImage() { //v3.0
var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array; for(i=0;i<(a.length-2);i+=3)
if ((x=MM_findObj(a[i]))!=null){document.MM_sr[j++]=x; if(!x.oSrc) x.oSrc=x.src; x.src=a[i+2];}
}
//-->
</script>
</head>

<body leftmargin="0" topmargin="0" marginwidth="0" marginheight="0" onLoad="MM_preloadImages('images/menu_body_01_a.gif','images/menu_body_02.gif','images/menu_body_03.gif','images/menu_body_04.gif','images/menu_body_01.gif','images/menu_body_02_a.gif','images/menu_body_03_a.gif','images/menu_body_04_a.gif')">
<TABLE width="217" border=0 cellPadding=0 cellSpacing=0>
<TBODY>
<TR>
<TD width="73"><A
onmouseover="MM_swapImage('Image25','','images/menu_body_01_a.gif',1);MM_swapImage('Image26','','images/menu_body_02.gif',1);MM_swapImage('Image27','','images/menu_body_03.gif',1);MM_swapImage('Image28','','images/menu_body_04.gif',1);MM_swapImage('Image29','','images/menu_body_05.gif',1);MM_showHideLayers('content01','','show','content02','','hide','content03','','hide','content04','','hide')"
onmouseout=MM_swapImgRestore()
href="dss_background.htm"><IMG height=20
alt=行业动态 src="images/menu_body_1.gif" width=73
border=0 name=Image25></A></TD>
<TD width="72"><A
onmouseover="MM_swapImage('Image25','','images/menu_body_01.gif',1);MM_swapImage('Image26','','images/menu_body_02_a.gif',1);MM_swapImage('Image27','','images/menu_body_03.gif',1);MM_swapImage('Image28','','images/menu_body_04.gif',1);MM_swapImage('Image29','','images/menu_body_05.gif',1);MM_showHideLayers('content01','','hide','content02','','show','content03','','hide','content04','','hide')"
onmouseout=MM_swapImgRestore()
href="dss_background1.htm"><IMG
height=20 alt=媒体政策 src="images/menu_body_02.gif"
width=72 border=0 name=Image26></A></TD>
<TD width="72"><a
onMouseOver="MM_swapImage('Image25','','images/menu_body_01.gif',1);MM_swapImage('Image26','','images/menu_body_02.gif',1);MM_swapImage('Image27','','images/menu_body_03_a.gif',1);MM_swapImage('Image28','','images/menu_body_04.gif',1);MM_swapImage('Image29','','images/menu_body_05.gif',1);MM_showHideLayers('content01','','hide','content02','','hide','content03','','show','content04','','hide')"
onMouseOut=MM_swapImgRestore()
href="dss_background2.htm"><img height=20
alt=媒体概况 src="images/menu_body_03.gif" width=72
border=0 name=Image27></a></TD>
<TD width="72"><A
onmouseover="MM_swapImage('Image25','','images/menu_body_01.gif',1);MM_swapImage('Image26','','images/menu_body_02.gif',1);MM_swapImage('Image27','','images/menu_body_03.gif',1);MM_swapImage('Image28','','images/menu_body_04_a.gif',1);MM_swapImage('Image29','','images/menu_body_05.gif',1);MM_showHideLayers('content01','','hide','content02','','hide','content03','','hide','content04','','show')"
onmouseout=MM_swapImgRestore()
href="dss_background3.htm"><IMG height=20
alt=相关链接 src="images/menu_body_04.gif" width=73
border=0 name=Image28></A></TD>
</TR>
</TBODY>
</TABLE>
</body>
</html>

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-5 13:47:00
编辑这个贴子
eworker 美女呀，离线，快来找我吧！

等级：实习版主
文章：1863
积分：2665
注册：2003-7-17
第7楼
发贴心情
不懂为什么非要拒绝用层？只要对象命名控制得好，动态数据即使用JS也没什么问题啊？

----------------------------------------------
批评是对我最大的帮助。
http://www.chinaui.com/bbs/list.asp?boardid=12

点击查看用户来源及管理<br>发贴IP：159.226.83.133 2003-11-5 14:00:54
编辑这个贴子
zaza 美女呀，离线，快来找我吧！

头衔：单刀侠
等级：实习版主
文章：926
积分：1735
注册：2003-5-16
第8楼
发贴心情
前几天刚做过这个！
用层做的效果：
http://asp.6to23.com/zazayun/UI/tab/1.htm
用table做的效果：
http://asp.6to23.com/zazayun/UI/tab/2.htm

用table做的就是直接用客户端脚本来控制图片按钮的显示与否！注，上述按钮均为图片;
两种在这里显示的效果一样，但是放到页面中的时候层做的效果显然要差一些！至于区别嘛，自己去看喽！
有兴趣的话点这里下载代码：

点击浏览该文件

[此贴子已经被作者于2003-11-5 14:07:07编辑过]

----------------------------------------------
我把自己扔在深夜的角落里
只有手指间一闪一灭的亮
是我唯一的希望

-----痛并快乐的舞者,酷酷za

主页
http://www.yaya25.com/

点击查看用户来源及管理<br>发贴IP：218.18.225.216 2003-11-5 14:03:30
编辑这个贴子
eworker 美女呀，离线，快来找我吧！

等级：实习版主
文章：1863
积分：2665
注册：2003-7-17
第9楼
发贴心情
显示的效果不一样！而且我觉得放到页面中的时候层做的效果显然要好看一些……郁闷！
BTW：不管怎样，页中页不是好的编码模式，单一页上用层用表格都可以实现烛音说的功能，我所说的使用层并非1.htm中的DW的自动编码，那个实际上并不是做在一个页面里的。

[此贴子已经被作者于2003-11-5 14:59:55编辑过]

----------------------------------------------
批评是对我最大的帮助。
http://www.chinaui.com/bbs/list.asp?boardid=12

点击查看用户来源及管理<br>发贴IP：159.226.83.133 2003-11-5 14:26:59
编辑这个贴子
烛音 帅哥哟，在线，有人找我吗？

等级：实习版主
文章：5186
积分：7085
注册：2003-5-22
第10楼
发贴心情
我也不主张用页中页，特别是涉及到数据绑定的时候，对程序员来说是一个头痛的问题。
我现在没有使用图层，也没有采用zaza的方法，我这边编好html，程序员使用服务器端脚本控制，效果不错。
此主题相关图片如下：
按此在新窗口浏览图片

----------------------------------------------
http://www.cqppi.com/1/1.html

点击查看用户来源及管理<br>发贴IP：211.158.65.243 2003-11-5 16:10:31
编辑这个贴子
darkvn 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：117
积分：231
注册：2003-6-24
给darkvn发送一个短消息 把darkvn加入好友 查看darkvn的个人资料 搜索darkvn在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给darkvn OICQ 引用回复这个贴子 回复这个贴子 第11楼
发贴心情
好像是个技术问题，不应该在理论版讨论吧？

这个客户端实现的方法有很多了，table实现是我比较推荐的，不过可能对设计有些要求。

以前做的一网站有用到，js还是我写的。你可以参考一下。

首页
http://www.netland.com.cn/
产品资料
http://www.netland.com.cn/NetlandDoc/ProdDoc/3CS17206.asp?productID=2982

----------------------------------------------
EGG 2004 - Flash Blog .4Beta

点击查看用户来源及管理<br>发贴IP：218.19.174.42 2003-11-5 16:21:25
编辑这个贴子
小平 美女呀，离线，快来找我吧！

等级：活跃分子
文章：320
积分：593
注册：2003-7-28
第12楼
发贴心情 我是用CSS实现的

此主题相关图片如下：
按此在新窗口浏览图片

----------------------------------------------
!@! # $ %| ^-^ &!& *!* (!) ^_+

点击查看用户来源及管理<br>发贴IP：61.51.107.181 2003-11-7 10:04:53
编辑这个贴子
MagiColor 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：20
积分：89
注册：2003-2-14
第13楼
发贴心情
一个比较简单的办法 利用 tbody
这是最初级的效果，还可以用css,和图片进行美化……
[code]
<!doctype html public "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
<title> New Document </title>
<meta http-equiv="Content-Type" content="text/html; charset=gb2312">
<meta name="Generator" content="EditPlus">
<meta name="Author" content="田耕">
<meta name="Keywords" content="">
<meta name="Description" content="">
<style type="text/css">
body,table,tr,td{
font-size:12px;
color:#000000;
}
.sec1 {
background-color: #99CC99;
cursor: hand;
color: #000000;
border-left: 1px solid #FFFFFF;
border-top: 1px solid #FFFFFF;
border-right: 1px solid gray;
border-bottom: 1px solid #FFFFFF
}
.sec2 {
background-color: #D4D0C8;
cursor: hand;
color: #000000;
border-left: 1px solid #FFFFFF;
border-top: 1px solid #FFFFFF;
border-right: 1px solid gray;
font-weight: bold;
}
.main_tab {
background-color: #D4D0C8;
color: #000000;
border-left:1px solid #FFFFFF;
border-right: 1px solid gray;
border-bottom: 1px solid gray;
}
</style>

<script language="javascript">
<!--
function secBoard(n,x,y)
{
for(i=0;i<secTable.cells.length;i++){
secTable.cells[i].className="sec1";
secTable.cells[n].className="sec2";}
for(i=0;i<mainTable.tBodies.length;i++){
mainTable.tBodies[i].style.display="none";
mainTable.tBodies[n].style.display="block";}
weizi.innerHTML="<b>"+x.toUpperCase()+"</b>展馆<b>"+y+"</b>楼展厅";
}
//-->
</script>
</head>

<body bgcolor="#FFFFFF" text="#000000" leftmargin="0" topmargin="0">

<table width="588" border="0" cellspacing="1" cellpadding="4" align="center">
<tr>
<td width="82%">当前位置：展馆分布 > <span id="weizi"><b>A</b>展馆<b>1</b>楼展厅</span></td>
<td width="18%"> </td>
</tr>
<tr>
<td colspan="2" height="1" bgcolor="#000000"></td>
</tr>
<tr>
<td colspan="2" height="4"></td>
</tr>
<tr>
<td colspan="2">

<table border=0 cellspacing=0 cellpadding=0 width=400 id=secTable>
<tr height=20 align=center>
<td class=sec2 width=10% onClick="secBoard(0,'a','1')">A展馆1楼展厅</td>
<td class=sec1 width=10% onClick="secBoard(1,'a','2')">A展馆2楼展厅</td>
<td class=sec1 width=10% onClick="secBoard(2,'b','1')">B展馆1楼展厅</td>
<td class=sec1 width=10% onClick="secBoard(3,'b','2')">B展馆2楼展厅</td>
<td class=sec1 width=10% onClick="secBoard(4,'c','1')">C展馆1楼展厅</td>
<td class=sec1 width=10% onClick="secBoard(5,'c','2')">C展馆2楼展厅</td>
</tr>
</table>
<table border=0 cellspacing=0 cellpadding=0 width=578 height=160 id=mainTable class=main_tab>
<tbody style="display:block;">
<tr>
<td align="center"><br>
一<br>
</td>
</tr>
</tbody> <tbody style="display:none;">
<tr>
<td align="center"><br>
二<br>
</td>
</tr>
</tbody> <tbody style="display:none;">
<tr>
<td align="center"><br>
三<br>
</td>
</tr>
</tbody> <tbody style="display:none;">
<tr>
<td align="center"><br>
四<br>
</td>
</tr>
</tbody><tbody style="display:none;">
<tr>
<td align="center"><br>
五<br>
</td>
</tr>
</tbody><tbody style="display:none;">
<tr>
<td align="center"><br>
六<br>
</td>
</tr>
</tbody>
</table>
</td>
</tr>
</table>
</body>
</html>
[/code]

点击查看用户来源及管理<br>发贴IP：218.25.43.18 2003-11-7 10:21:55
编辑这个贴子
烛音 帅哥哟，在线，有人找我吗？

等级：实习版主
文章：5186
积分：7085
注册：2003-5-22
第14楼
发贴心情
看了 MagiColor 的代码，觉得非常不错。

不过我这边现在是让程序员用服务器端的脚本控制，她把数据绑定到tab按钮上，一个页面实现多个数据表的呈现，很好的避免了界面冗余代码。

----------------------------------------------
http://www.cqppi.com/1/1.html

点击查看用户来源及管理<br>发贴IP：211.158.67.66 2003-11-7 13:25:18
编辑这个贴子
浮世尘缘 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：37
积分：119
注册：2003-9-24
第15楼
发贴心情
代码真的不错啊 支持！

----------------------------------------------
天下风云出我辈 一入江湖岁月催
皇图霸业谈笑中 不胜人生一场醉

点击查看用户来源及管理<br>发贴IP：61.243.219.142 2003-11-13 9:16:15
编辑这个贴子

本主题贴数18，分页： [1] [2]
*快速回复：html内TAB页的实现方式探讨
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：3,875.000毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：一个名片式CD-ROM案例

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：一个名片式CD-ROM案例

您是本帖的第 948 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 一个名片式CD-ROM案例
anyone 帅哥哟，离线，有人找我吗？

头衔：-= 副头头 =-
等级：管理员
文章：1230
积分：2649
注册：2003-1-13
楼顶
发贴心情 一个名片式CD-ROM案例
基本情况
5月底开始接触此项目，同时开始参与报价竞标，制作片头动画和主界面；6月初竞标演示；竞标结果：重新制作竞标方案，进入第二轮竞标阶段；第二轮竞标制作时间比较长，7月中旬演示第二套竞标方案，竞标成功，我们开始草拟合同，并与客户讨论价格与合同事宜，客户在价格上并未压价，只是在合同上有所分歧，不过双方迅速达成一致，只等签约。但到最后，竞争对手再次压低价格，客户方面出现波动，我们冷静与客户解释，最后于7月26日签约。制作日期为3个月，到10月28日交货，不过，中途客户要求交货日期提前至18日，好参加展会。

项目描述
制作10000张名片式CD-ROM，内容为：13分钟视频，公司所有产品（200多种）介绍，集团沿革，公司介绍，研究发展，销售网络，售后服务等视频、文字、图片内容。

客户信息
台资焊材企业，在国内业界处于领先地位。与我们接触的为其资讯课课长，技术出身的管理人员，工作严谨。

我方信息
昆山林达广告策划印务有限公司创立于1995年，经过7年发展，形成以广告策划、制版印刷、多媒体演示、展示装修、礼仪公关为一体的大型综合广告企业。

日 志
5月23日
我们的市场人员开始接触此项目，获得客户的口头需求建议书（RFP），内容为：制作大概10000张名片式CD-ROM，内容主要有十几分钟视频，一本产品介绍书籍的所有内容及其相关的200多张图片，主要用于展览会上使用。

5月24日
我们开始评估是否参与竞标（评估表），根据评估结果，我们决定开始参与竞标，于是我们开始整理资料与初步报价，资料主要为我们做过的一些作品，包括网站、CD-ROM、触摸屏、影视广告、影视片头及其一些设计作品。

5月27日
我们组织市场人员与技术人员同时前往客户处展示我们准备的资料，突出强调我们的设计和创意能力，并将我们的初步报价呈送客户。客户基本认可我们的设计能力和报价，但却表示担心我们缺乏制作机械钢铁行业作品的经验，不过同意我们参与竞标，并提供了一些资料给我们，要求我们在一定时间内制作出竞标作品。

5月28日
我们开始制定参与竞标项目的人员和时间进度，并进行了初步分析，讨论竞标作品中的重点问题和内容结构框架。

5月29日～6月3日
开始制作竞标作品，但由于种种原因，真正制作开始于2日。

6月4日
我们市场人员将竞标作品给予客户演示，此前，竞争对手已经将竞标作品给予客户演示，并获得客户的好感，我们顿时感觉到压力，但是凭借我们优秀的解说能力和对客户的真诚，最重要的是我们的技术人员对这个项目进行了详尽的分析（口头）而再次获得客户的信任，因此顺利进入了第二轮竞标。其实第一轮竞标可以说我们已经败下阵来。

6月5日
针对昨天出现的问题，我们分析：1.作品创意不强；2.制作时间仓卒；3.无详细的书面项目解决方案。
于是我们分别对客户所在的行业、客户自身和竞争对手进行分析。
客户所在的行业：焊材业，传统机械化工行业，与钢铁关系密切，故应该出现钢铁及焊接场景。
客户自身/资讯课课长：多次接触，发现客户喜欢动感的，快节奏的片头动画，但强调他们身处的为传统行业，不要过于前卫的界面。
竞争对手：与客户一样，同为台资企业，故关系方面比我们有优势。我们通过别人获得了一些竞争对手的作品，发现：竞争对手作品丰富；片头多动感十足；视频采用他们自己的压缩技术压缩并生成可执行文件，方便调用；大部分采用FLASH技术制作。但有一个致命缺陷，即调用视频时，不小心点击视频后面的界面时，视频就会隐藏于界面后面无法再调用出来。
通过以上分析，我们开始重新安排工作和进度：项目经理，负责整个项目的审核控制；设计师，负责用户界面及光盘盘面的设计；文案，负责项目文案和项目解决方案（项目申请书）的撰写；动画师，负责片头动画及其他动画效果的设计制作；程序员，负责多媒体程序的编写；视频制作人员，负责将VCD中的一段压缩；市场人员，负责与客户的沟通；时间从6月6日～7月6日，8日开始演示。技术方面，由于这么多内容要放入50M名片式CD-ROM中，故决定大量采用FLASH技术制作，包括片头动画，而交互整合则采用Director软件制作。
这是最后的机会了，如果竞标不成功就一切前功尽弃。大家都鼓足了干劲，做好充分准备。
（界面故事板、文案、动画故事板、人员安排表、时间进度表）

6月6日～7月6日
我们开始制作，首先从资料库中调出各种资料查看，设计创意人员开始讨论，并画出设计草图（包括界面设计与片头动画设计），项目经理审核通过后，根据界面故事板和动画故事板开始设计制作。视频制作人员开始选取VCD中的一段进行压缩，VCD视频有13分钟，134M，故决定采用MPEG4压缩方式并将视频与音频分开压缩（大大减少体积），由于本项目运行于Windows系统中，于是采用MS-MPEG4 V2而非DivX压缩，以便获得尽可能多的客户端环境支持，在压缩的同时，在视频左上角打上test字样，以保护我们的权益。
最后，文案人员与技术人员合作撰写完一份详细的《申请书》。而多媒体程序员则将设计的界面进行分割，并将片头动画、视频等各种元素用Director整合在一块，简单测试过后，即宣告作品完成。
（申请书）

7月8日
我们将竞标作品刻于50M名片式CD-R中，市场人员带予客户演示，但仍然出现问题：客户电脑上视频放不出，而音频放得出。由于技术人员没有一同前往，无法当场解决，于是我们的市场人员向客户道歉并承诺第二天一定解决这个问题，出师不利。回来后，技术人员立刻分析，由于我们将视频和音频分开压缩，而视频采用MPEG4压缩，音频则采用MP3压缩，如果客户电脑上没有安装相应解码器，就会出现只有音频而无视频现象。而我们的大部分电脑可以连上Internet，故可以自动下载解码器。于是我们从Microsoft网站上下载解码器——wmpcdcs8.exe，安装，测试，通过，但我们仍怀着忐忑不安的心情准备前往客户处。

7月9日
这次，我们技术人员和市场人员一同前往，谢天谢地，客户通过了，而且反应还不错。接下来，心情舒畅，开始洽谈合同事宜。我们将已经草拟好的合同范本给予客户，客户略看后，说要呈递给他们老总看，过几天再联系。

7月15日
漫长的几天终于过去了，今天客户打电话过来，让我们去谈合同事项。当我们兴奋地过去后，他们竟叫了一位法律专业的员工与我们谈合同内容。争执几番，终于将内容敲定，客户答应我们几天后即可确定签署合同。事情到这，看样子，我们竞标成功了，但奇怪的是，客户对价格始终不压，难道我们报价低了？也许是，后来我们通过不同渠道了解到，竞争对手的价格是8.5元/张，咳，怎么不早知道，其实，早了也不可能知道，看来我们在价格上的确有很大优势，再加上我们设计制作比竞争对手都优秀，没有理由不与我们合作，想到这，我们不由高兴起来，可谁也没料到，糟糕的事情在后面。

7月19日
我们正等待合同签署的时候，客户突然打电话过来说，我们竞争对手跟他说，不管客户开什么价，他们都做，我们愣了一下，然后问客户什么意思，客户说，这么低的价格，他们当然要考虑考虑。看来，这个周末不好过了。

7月22日
我们迅速展开公关，并耐心与客户解释，我们反对价格战，我们也不会参与价格战，这个行业是需要高技术、高智慧的行业，这么低的价格，无疑是恶性竞争，并且质量肯定会下降……，还好，客户同为技术出身，沟通起来还方便，客户似乎被我们的诚意再次感动，答应优先考虑我们。

7月26日
OK，合同终于签署了，皆大欢喜，产品交付日期定为10月28日。客户要求我们每周进驻两天他们那儿制作，我们当时没答应，毕竟我们不可能一天到晚做这个项目。

7月27日
项目进入执行阶段
1．明确项目目标
将13分钟视频，一本产品介绍样本的内容及相关介绍做成一套多媒体系统，刻于50M的名片式CD-ROM中，并生产10000张，在10月28日之前，送至客户处。
与开始的目标相比，少了一些内容，比如大量的图片。
2．工作结构分析
将整个项目分为：前期分析、资料收集、界面风格设计、设计制作（界面设计、程序设计、动画设计、视频制作、文字录入、盘面设计、音频制作、整合）、α测试、β测试、光盘生产、光盘测试、交付使用，同时指定相应负责人。
3．制定时间进度
时间为7月29日至10月28日。
（计划：①.项目目标、②.工作分析结构、③.责任矩阵、④.节点网络图、⑤.进度表）

7月29日
将27日制定的计划传真给客户并获得认可，同时，我们同意每个星期进驻客户处一天，时间定于每周二。

7月30日～8月2日
由于客户负责人回台湾，而接替他的另一个负责人B（负责客户广告展览事项）比较忙，难以联系，故这几天项目进展不大。

8月5日
客户负责人终于从台湾回来了，整个项目又重新由他负责，这时项目开始有所进展，不过，由于在他离开这几天项目无大进展，客户负责人看起来有些生气，虽然主要责任不在我方，但我们还是小心翼翼地在两个负责人间保持接触，不过我们比较倾向于与原来客户负责人，即资讯课课长合作，毕竟他工作比较严谨。
依据合同，我们发票开出，不过由于客户不能接收全部款项发票，所以我们决定分两次开，这一次先开预付款发票。
我们的人员开始与客户另一负责人B共同进行项目分析，内容包括：目标、用户、风格、内容、功能、技术、平台。我们先草拟了一份项目分析，因为我们知道，如果什么都不准备就与客户讨论，那将会陷于无尽的讨论之中，所以，宁肯我们给定一个方向，再与客户一起探讨，这样效率才能提高。共同探讨下来，收获不少，但也发现了不少问题，首先“用户”搞错，我们错认为此次名片式CD-ROM的主要用户为各个经销商和代理商，终端客户的少，但客户纠正到，他们的产品直接销售给船厂等终端客户的多，而给经销商和代理商的倒少。其次，内容方面则增加了一本产品介绍的样本，还好，内容仍不算多。结构框架则由我们初定的“企业沿革、公司介绍、公司产品、重点产品、销售网络、售后服务”改为“集团沿革、公司介绍、公司产品、重点产品、研究发展、销售网络、售后服务”，并明确了各个栏目的内容。
回到公司，文案人员将今天讨论的内容重新整理成文档。

8月6日
带着新整理的文档，我们再次拜访客户，重新明确了各个栏目内容，并让客户开始收集缺少的资料。同时决定下周二开始进驻客户处。

8月7日～8月8日
将我们与客户分析的结果再次整理成详细的《分析报告》，传真给客户获得初步确认。

8月8日～8月9日
正式进入制作阶段，根据《项目制作手册（制作版）》在“××焊材CD-ROM”文件夹中建立“working”、“program”、“sample”、“pic”、“doc”，分别为“制作中的文件”、“最终整合文件”、“案例”、“原始图片”、“文档”。
开始进行界面风格设计，客户已经推翻了竞标时候设计的界面，要求重新设计界面，我们在表示遗憾的同时只好同意重新设计。这很正常，在必要的时候我们要据理力争，但在一些情况下我们不得不满足客户的要求。
我们从sample文件夹中挑选了几种风格的界面图片，有网页界面也有CD-ROM界面，发给客户，以确定客户想采用何种界面。其实，在大多数情况下，客户并不知道将来的产品会是什么模样，因此询问客户要求采用什么样的界面是不太现实的，而应该由我们去引导客户，由我们提供几种界面或功能给客户，让其选择，这样客户才能最终明白将来的产品会是什么模样。没多长时间，客户就确定了采用什么风格的界面，咳，可惜，没有采用我们看好的一种风格界面。
风格已定，设计就不难了，很快，我们就设计出了一套界面。

8月13日
第一次进驻客户处。
客户要求将他们公司网站上的一个动画加至界面上，动画大小：800×70。好，省下了制作一段动画的时间。
界面修改完毕，客户通过。一切挺顺利，项目按照计划稳步进行。
我们从客户网站上将动画下载下来，才发现有问题，这个动画的边缘并非直角，而是弧线，于是尝试着分解Flash，用SWFBrowser，分解出来的元素全部居于左上角，而“硕思闪客精灵”倒挺好用，可却是试用版，只能分解前几个元素。无奈，只得暂时放弃，改用其他方法。看时间，快回公司了，上chinavisual逛一逛，并将修改过的文件打包发回公司。

----------------------------------------------
-= cHinAuI.coM =-
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：203.212.6.131 2003-1-22 20:45:00
编辑这个贴子 鲜花(0) 鸡蛋(0)
anyone 帅哥哟，离线，有人找我吗？

头衔：-= 副头头 =-
等级：管理员
文章：1230
积分：2649
注册：2003-1-13
第2楼
发贴心情
8月14日～8月19日
设计师将余下的几个界面按照确定的风格设计完毕，发E-mail给客户，认可通过。而客户那边资料也已经收集完毕，只等我们去拿。
那个动画弧线问题也已经解决，不用分解，只是在Director中将动画拉大，弧线部分用两个小图片覆盖住即可，只是在Director中多用了两个通道。
动画工程师将第一个栏目“集团沿革”的动画做好，而程序员则整理了以前所做项目的一些程序，还好，程序都比较好改，很多都已经做成behavior。我们习惯将一些程序做成通用的behavior，这样也方便以后项目调用。文案人员则完成《客户确认文档》，包括项目分析报告、资料内容详细说明、片头动画、界面风格等需要客户签字确认的内容。

8月20日
第二次进驻客户处。
将上个星期的制作成果给客户看，客户比较满意栏目中的动画，并未提出什么修改意见，但对片头动画提出要做一些修改，如：修改动画中出现的钢块，使效果更明显；背景颜色问题；开头增加公司标志和名称；增加企业经验理念、宗旨……。我们知道，要做这么多增加与修改，最终使双方都满意，不仅需要将良好的技术，更需要优秀的沟通技巧和解说能力。
客户改变进度，说交货日期提前至18日，因为21日有展会，天哪。解释无效，我们只得更改进度。

8月21日～8月26日
进度加快。
片头动画按照客户要求进行了修改；剩余几个栏目的动画，参照第一个栏目的风格全部制作完毕，并用Director将各种元素整合在一块，最终除“公司产品”、“重点产品”外，其余全部做完；客户提供的产品资料开始输入电脑，并按照计划制作成网页。

8月27日
第三次进驻客户处。
客户对我们的进度比较满意。各个栏目已经初具规模，视频压缩也已经完毕，开始给客户演示。
客户开始对一些内容及设计提出了不同意见了，我们知道，这时候，客户脑海中已经有了一个完整的产品形象了，因此他们知道，哪些是他们满意的，哪些是他们不满意的，而这在项目前期是不会出现这情况的。
客户提出了不少意见，如文字的滚动条不好看（采用Director的滚动文本）、文字颜色单一等。双方对一些问题进行激烈的讨论，甚至是争论，我们坚持从艺术、美观的角度去对待这个项目，而客户坚持实用的角度，传达的信息尽量多，双方都据理力争，我们在采纳客户意见的同时，仍加入了我们的想法，毕竟我们是专业的，我们知道怎样做才能将客户的信息有效地传达出去。
再次修改片头动画，边修改边让客户确认，就在回公司的前一段时间，客户通过了。但他们老总还没有看，由于时间来不及，我们已经先回公司，留下做好的片头动画让他们老总看。

8月28日～9月2日
客户打电话说，他们老总通过了，终于解决了一个难题。
我们继续解决客户提出的其他意见，如“公司介绍”的视频问题、“研究发展”和“售后服务”的空白问题、“销售网络”的地图动画问题等。
修改同时，技术人员开始设计制作“公司产品”栏目，文案人员则重新修订了《客户确认文档》。

9月3日
第四次进驻客户处。
将修改后的内容给客户看，并递交《客户确认文档》以签字确认。
客户除“公司产品”和“重点产品”外，其他栏目的意见逐渐减少，只有一些诸如空白处太大，增加一些图片之类的问题，我们在强调美观的同时，仍然作出了相应的调整。
现在开始制作重点的“公司产品”。我们演示我们制作的“公司产品”效果图，客户初步通过，但并非特别满意。经过与客户的讨论，产品介绍划定为三个层次。
临走时，客户提供了另一本新版产品手册。

9月4日～9月9日
客户对“公司产品”提出修改意见，推翻了以前的方案，我们迅速作出反应，重新设计了一套方案，并发E-mail给客户，获得通过，开始制作动画。这么长时间，我们发现，与客户合作得比较默契。（演变图）
另一本新版产品手册开始录入，并制作成网页。光盘盘面（83×59mm；中心圆孔直径18mm）开始设计。

9月10日
第五次进驻客户处，进度有所落后。
盘面的三个设计稿提交给客户；继续对“公司产品”动画做细微的修改，最终通过，好，又解决一个难题。

9月11日～9月16日
第一本产品介绍网页制作完毕，发E-mail给客户校对。
开始设计“重点产品”栏目动画，设计完毕后马上开始制作，第二天发给客户，一次性通过。
加快第二本产品介绍网页的制作速度。由于产品太多，因此制作了一个模板，以便制作人员调用。

9月17日
第六次进驻客户处。
进度已经落后，为控制项目进度，进驻的次数和时间明显增多。这时候才发现，在客户那，效率能提高不少，不会在公司那样有那么多杂事。
由于面临国庆长假期，故应赶在国庆前全部做完，并转入测试阶段。
接下来做的就是细微的修改，如“销售网络”的地图问题、“研究发展”的一些文字修改、产品介绍网页的一些问题。由于是一些细微修改，故显得比较繁琐。

9月19日
第七次进驻客户处。
客户返回一部分校对稿，比较好，错得不多，因此很快就修改完毕。
开始与客户讨论背景音乐问题。

9月24日
第八次进驻客户处。
继续做细微修改，除产品介绍的网页外，其余都已经修改完毕。现在工作重点就是产品介绍的网页和测试工作。但奇怪的是，第一批产品介绍的校对稿还没全部返回到我们这。
（测试单）

9月25日～9月26日
修改接近结束，由于客户方面决定在国庆期间组织人员校对，于是我们将所有的产品介绍网页和各个栏目的文字打印出来给客户，天哪，三百多页，从中午12:00一直打到下午4:00，差点将打印机打坏。

9月30日
一切OK，进度可以保证。国庆长假，终于可以好好休息一下了。

10月8日
第九次进驻客户处。
我们继续进行测试。
客户确定了盘面设计，采用了第三稿，客户在打印确认稿上签字后，我们晚上开始出菲林打样。
客户返回了所有校对稿，我们迅速展开修改工作，但却发现一些问题，不少地方原来是正确的却校对错了，而一些错误的却没有校对出来，看样子，校对得不太仔细。
离交货日期18日才10天了，而其中光盘生产时间起码得用掉7天，也就是说留下来得测试校对时间只有3天了。

10月9日
第十次进驻客户处。
客户确认菲林和打样稿。
我们继续测试，发现在某些电脑上运行，会出现找不到视频现象，我们改变相对路径仍不行，无奈，只得将视频和音频从video文件夹中调到根目录，虽然不好看，但问题解决。看来插件时不时仍会出错。继续测试，一切OK，万事具备，只等校对了。
客户的校对速度似乎仍没提高，我们开始与客户沟通，寻找解决办法。看样子，进度不能保证了。

10月10日
第十一次进驻客户处。
由于10000张光盘量比较大，如果发生错误，责任太大，于是，客户正式宣布，无法保证产品网页校对的准确性，21日的展会决定不投入此次制作的光盘，进度延后。
客户负责人发火了，将客户方面的校对人员批评了一通。虽然不是责怪我们，但我们总觉得也有一部分责任，项目开始前没有估计好产品校对工作的难度。

10月11日～10月15日
客户主动延后交货日期，改为28日交货，这下我们有充足的校对时间了。我们重新制定计划，展开最后的校对工作。
客户方面派了一个技术负责人到我们公司对所有的产品介绍网页逐一校对，效果不错，连文字没有对齐都校对出来了。几遍下来，几乎没有什么错误了。

10月16日
刻录一张完整的光盘给客户老总，过最后一关，测试，没问题，校对，仍没问题。

10月17日
客户反馈信息：文字有错乱。电话这头，我们吓了一跳，不可能啊？初步分析，可能是系统问题。一问，果然如此，他们使用的是繁体系统。客户知道，这并非我们技术问题，于是顺利地在最后的光盘上面确认签字，并在《授权书》上盖章。

10月18日
一切顺利，但仍不能松懈。将签字确认盘、盘面设计文件及相关版权声明等文件一同寄到光盘生产厂商。接下来，跟进之余，只有等待了。

10月26日
光盘顺利生产出来并送到我们公司，10000张，分了12个箱子，随机拆开测试，很好，没问题。
由于我们特意要求加装塑料外壳并塑封，而非平常的塑料套，整张名片式光盘看起来十分精美。

10月28日
送货，客户签收。

11月7日
我们送发票的同时，得到北京展览会反馈的信息，客户上下对这光盘都很满意，尤其是那塑料外壳，起到点睛作用。

11月11日
尾款回收，客户在我们的《客户满意调查表（CD-ROM/触摸屏）》均打上“非常好”。
至此，总耗时5个多月的“××焊材名片式CD-ROM”项目完美结束。
（客户满意调查表（CD-ROM/触摸屏））

lovem: tit_zam@263.net

----------------------------------------------
-= cHinAuI.coM =-
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：203.212.6.131 2003-1-22 20:45:10
编辑这个贴子
anyone 帅哥哟，离线，有人找我吗？

头衔：-= 副头头 =-
等级：管理员
文章：1230
积分：2649
注册：2003-1-13
第3楼
发贴心情
经验集锦

1，竟标作品的制作。我是深有体会，我们公司总是注重于商务方面，市场人员和老板在许多莫明的问题上拖延了大部分时间，而真正到制作人员手里基本上就是今天做明天要，甚至晚上做，白天就要，这样能做出什么东西可想而知。
2，我做东西从不用mpeg4，用mpg，indeo 5,10的avi，mov这几种格式，原因很多。
3，一般尽量让客户来你那里看样，实在不行才去他那里，去的时候尽量带自己的笔记本电脑，而不用他们任意的电脑。
4，我们公司做的有通用的合同样本，而不是每个合同还要专门去研究。
5，你们的名片光盘也太贵了吧，竟有报8块多，是含制作费了吧
6，竟标后不能等客户通知你们，市场人员要跟上呀！！！
7，让程序人员参加策划及界面设计。
8，每次修改一定要白纸黑字的写清楚，并让客户签字。
9，多个部分的内容可同时做呀，我看lovem写的怎么都是一块块的做？（指网页那部分，人手不够？）
10，一般做网页之类文字内容，我们主要是自己校对，而客户方面总是会偷懒，不要太相信他们，万一没查出来错，以后可能会很麻烦的。
11，三百页的文字就打4个小时，太慢了吧，去买台激光。

1.这种情况应该是每个公司都会有不同的规定,客户的权限也是有限定的.
2.这是你的情况而已,我都不用标准的avi编码,相信吗?(这是事实)
4.这比较规范,而且节约时间.
7.非常同意,虽然我一点也不喜欢编程序:)
8.严重同意!
9.这也是视具体情况而定的,有时候作品需要按部就班来做,而有的部分则可灵活处理,并无定论.
10.好像都是自己校对的啊......
11.依人而定,哈哈......

1.哈哈，深有体会。
2.这次我也考虑用别的格式，但，50M内要放入13分钟的视频，还有其他图片问题程序，不用MPEG4，还能用什么呢，考虑用REAL，可MEDIAPLAY不支持，咳。
4.我们有通用CD-ROM合同，但客户要求做修改。
5.呵呵，其实没有这么贵的，稍便宜一点，不过我们还是觉得便宜了。
7.同意。
8.这一点比较难操作，我们只是要求出现重大修改的情况下，让客户签字，而且限制修改次数。
9.哈哈，这一点大家可能不太清楚了，其实整个项目主要制作人员就没几个，的确人手不够，一个人兼好几个角色，不过为了方便项目管理，还是要区别对待的。对我们公司而言，我们不可能全部投入这次项目之中，经常是多个项目同时进行。而对我个人来说，又有一堆杂事需要处理，长分散我的精力，所以我发出在客户那儿能提高效率的感慨，实属无奈。 :-(
10.这一点我不太同意，起码在这次的项目中，不能这么做，他们的专业方面我们不太懂，而且这样我们的责任太大。

问题与经验

1、FLASH（5.0制作）在D8.0中声音与动画不同步，经常动画已经结束，声音还在继续。是因为D8.0对FLASH5.0支持程度不高，改用D8.5即可。

2、FLASH调入D中速度变慢。可以在FLASH中适当提高速度。

3、用MPEG4方式压缩视频可将视频与音频分开压缩，体积大为减少。但某些电脑上会出现声音与画面不同步现象。
尽量采用微软支持的压缩方式，以获得较多客户端支持。

4、使用视频XTRA，注意路径问题，建议将视频放于和DIR文件相同目录下。

5、程序尽量写成行为，虽然不利于程序员牢记代码，但却能提高效率，注意管理好行为，不要随意修改，不然会出现意想不到的问题，而且很难找出原因。

6、为防止客户随意修改制作内容，项目分析报告、动画脚本、界面风格、栏目框架与内容、重要的视频音频等均要求客户签字确认，尽量让客户高层或有绝对权利的负责人确认签字。

7、webxtra显示速度慢问题。可将其调用的网页文件提前显示，不过可将网页文件事先缩小，需要时候放到原大。

----------------------------------------------
-= cHinAuI.coM =-
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：203.212.6.131 2003-1-22 20:47:57
编辑这个贴子
can 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：4
积分：59
注册：2003-2-10
第4楼
发贴心情
精华中的精华。不好意思，见到这么好的文章顶一下了。

作者是谁来着？很想交流一下。

：）

点击查看用户来源及管理<br>发贴IP：218.14.184.28 2003-2-12 11:16:43
编辑这个贴子
photoli 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：107
积分：240
注册：2003-1-22
第5楼
发贴心情
强！好文章系统有条理！！
点击查看用户来源及管理<br>发贴IP：218.247.167.168 2003-2-12 16:58:54
编辑这个贴子
娃娃 美女呀，离线，快来找我吧！

等级：初级用户
文章：31
积分：136
注册：2003-2-18
第6楼
发贴心情
这是什么？工作日记吗？
个人的感情色彩很浓。
点击查看用户来源及管理<br>发贴IP：211.100.14.13 2003-2-20 14:51:12
编辑这个贴子
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第7楼
发贴心情
先顶一下再说！

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.95.152 2003-11-7 12:03:12
编辑这个贴子
xiapingbo 帅哥哟，离线，有人找我吗？ 处女座1981-8-26

等级：论坛支柱
文章：1845
积分：2655
注册：2003-6-10
给xiapingbo发送一个短消息 把xiapingbo加入好友 查看xiapingbo的个人资料 搜索xiapingbo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给xiapingbo OICQ 访问xiapingbo的主页 引用回复这个贴子 回复这个贴子 第8楼
发贴心情
以前我也做过 这个东西不过做的水准没好高所以也没有这么的细致化

----------------------------------------------
http://seover.126.com/
记得江东诗句好，淡烟乔木是绵州。
----------------------------------------------
格言：
滚滚长江东逝水，浪花淘尽英雄。
是非成败转头空。
青山依旧在，几度夕阳红。
白发渔樵江渚上，惯看秋月春风。
一壶浊酒喜相逢。
古今多少事，都付笑谈中。

点击查看用户来源及管理<br>发贴IP：218.6.242.9 2003-11-7 13:52:33
编辑这个贴子
小d 美女呀，离线，快来找我吧！

等级：初级用户
文章：64
积分：243
注册：2003-10-24
第9楼
发贴心情
对于UI的概念，我还是真的很模糊呀！

----------------------------------------------
－－－－有思想，有意义，做个新鲜人－－－－

点击查看用户来源及管理<br>发贴IP：202.102.240.75 2003-11-9 14:15:16
编辑这个贴子
麦子 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：100
积分：199
注册：2003-8-24
给麦子发送一个短消息 把麦子加入好友 查看麦子的个人资料 搜索麦子在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给麦子 OICQ 引用回复这个贴子 回复这个贴子 第10楼
发贴心情
顶先
辛苦了
点击查看用户来源及管理<br>发贴IP：61.175.170.114 2003-11-10 9:18:10
编辑这个贴子
mint 美女呀，离线，快来找我吧！

等级：初级用户
文章：37
积分：121
注册：2003-9-4
第11楼
发贴心情
好帖子，我一个字一个字看下来的。

我以前也做过这样的企业介绍盘，但是都是单人运作，而且对方要求制作的时间往往很紧凑，修改也不会太多。现在看了你的这个流程，我想今后我会在合同和文档方面多多注意一些，以求可以达到你这样的赢利，呵呵，说笑话的，不过你的流程真的让我受益非浅啊！！

还有我对direct还不是非常在行，｛webxtra显示速度慢问题。可将其调用的网页文件提前显示，不过可将网页文件事先缩小，需要时候放到原大。｝这一段是什么意思，可不可以解释一下呢，不胜感激！

点击查看用户来源及管理<br>发贴IP：202.96.98.90 2003-11-10 14:10:37
编辑这个贴子
菲菲 美女呀，离线，快来找我吧！

等级：初级用户
文章：102
积分：240
注册：2003-10-3
给菲菲发送一个短消息 把菲菲加入好友 查看菲菲的个人资料 搜索菲菲在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给菲菲 OICQ 访问菲菲的主页 引用回复这个贴子 回复这个贴子 第12楼
发贴心情
好文章，长见识了：）

----------------------------------------------
每一颗心都要学会倾听，
倾听来自心灵深处的脉脉低语，
倾听来自四季的风的呼唤，
倾听草木的发芽，
倾听鸟儿的歌唱，
倾听一切有生命的世界......

点击查看用户来源及管理<br>发贴IP：61.237.205.151 2003-11-11 19:35:52
编辑这个贴子
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第13楼
发贴心情
这么精细的描述~~我只有顶一下子啦！

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.91.206 2003-11-17 12:54:28
编辑这个贴子
子木1977 美女呀，离线，快来找我吧！ 双子座1977-5-26

等级：初级用户
文章：81
积分：238
注册：2003-10-20
第14楼
发贴心情
好文章值得用心的体会^_^...

----------------------------------------------
有心，就有翼——飞翔

点击查看用户来源及管理<br>发贴IP：218.79.103.159 2003-11-19 12:45:00
编辑这个贴子
neostream 美女呀，离线，快来找我吧！

等级：初级用户
文章：103
积分：249
注册：2003-10-31
第15楼
发贴心情
不小心点击视频后面的界面时，视频就会隐藏于界面后面无法再调用出来
。。。。flash可以直接调用视频，或者loadmovie，对手也太差了些
还有师傅告戒我，进度定下来后千万不要按这进度一步一步地做，他说不要想着明天是不是还有事做，今天能做完下星期的事就抓紧时间做完它
点击查看用户来源及管理<br>发贴IP：218.75.230.180 2003-11-19 14:33:01
编辑这个贴子

本主题贴数22，分页： [1] [2]
*快速回复：一个名片式CD-ROM案例
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：1,500.000毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：以用户为中心的软件产品开发方法[转自ccw.com.cn]

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：以用户为中心的软件产品开发方法[转自ccw.com.cn]

您是本帖的第 91 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 以用户为中心的软件产品开发方法[转自ccw.com.cn]
x3d 帅哥哟，在线，有人找我吗？

等级：初级用户
文章：119
积分：314
注册：2003-5-12
给x3d发送一个短消息 把x3d加入好友 查看x3d的个人资料 搜索x3d在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给x3d OICQ 引用回复这个贴子 回复这个贴子 楼顶
发贴心情 以用户为中心的软件产品开发方法[转自ccw.com.cn]
为“上帝”服务
---以用户为中心的软件产品开发方法[转自ccw.com.cn]
张丽萍 刘正捷 陈军亮
01-9-20 上午 09:25:59

--------------------------------------------------------------------------------

在软件开发领域有多种设计方法，虽然它们各具特点，但有一点是共同的：力图使开发的产品在技术和功能上满足用户需求。那么，如何保证软件的可用性呢？以用户为中心的设计方法是实现这一目标的重要途径。
用户中心论
以用户为中心的设计方法是软件开发的一种思想和方法论，它注重所开发软件产品的可用性。按照ISO 9241-11的定义，以用户为中心的关键点是强调产品的最终使用者与产品之间的“交互质量”，它包括三方面特性：有效性、效率和满意度，其宗旨就是在软件开发过程中要紧紧围绕用户，在系统设计和测试过程中，要有用户的参与，以及时获得用户的反馈信息。实现这一目标通常要利用原型与用户进行交互，根据用户的反馈意见不断改进设计。遵循这种思想来开发软件，可以使软件产品具有易于理解、便于使用的优点，从而减少培训费用，减轻对用户的压力，提高用户的满意度。
主要原则
可用性需求与技术和功能需求具有同等重要的地位。以用户为中心的设计方法旨在把用户的观点和需求融入到软件开发过程中，它是对已有开发策略的补充，而非替代。根据ISO 13407国际标准的定义，以用户为中心的设计方法有以下几个主要原则：
1. 在用户与系统之间合理地分配功能
明确任务分工，确定哪些任务由人来完成，哪些由软件或硬件实现。
2. 用户的积极参与
以用户为中心的设计方法的主要优势之一是用户方的积极参与，参与的程度取决于设计活动的明确程度。其策略是让用户，特别是那些对软件使用环境真正了解的用户充分参与开发过程。
3. 不断改进设计方案
从模拟屏幕布局的纸面原型到能够实际运行的计算机原型，根据用户对前一设计方案的反馈进行改进。让用户使用这些原型来完成现实世界中的各种任务操作，并根据用户的反馈完善系统设计。
4. 多方参与的设计队伍
以用户为中心的软件开发是一个合作的过程，得益于各方人员的积极参与。视具体情况，设计队伍中可能包括以下人员：项目经理、可用性分析人员、用户培训与支持人员、软件工程师、质量保证人员以及最终用户。
关键活动
为了将可用性需求有机地结合到软件开发过程中，在ISO 13407标准中，规定了以下4项以用户为中心的活动：
● 理解并详细定义使用环境；
● 详细定义用户及组织机构的要求；
● 提出设计方案并建立原型；
● 进行基于用户的评估。
上述这4项活动需要反复进行，直至达到具体的可用性目标（如下图）。
按此在新窗口浏览图片

1. 理解并详细定义系统的使用环境
进行该项活动的目的是要了解以下信息：
● 用户特点
包括用户所掌握的知识、技能、经验、所受到的正规教育和培训、身体状况、习惯等。
● 用户执行的任务
这里应该注重任务的高层次基本特性，如任务的目标、执行频率和执行时间等，而不仅仅考虑具体的功能。
● 用户所处的环境
环境一般与组织机构、技术、物理等方面的因素有关。
这项活动完成后要形成书面文档，详细记录用户、任务及环境特点。
2. 定义用户及组织机构对系统的需求
一个软件的成功与否很大程度上取决于需求分析的执行情况。ISO 9241-11标准中列出了有关用户与组织机构需求定义的详细指南。通常，在最后形成的用户及组织机构的系统需求报告中，应包括以下几方面的内容：
● 明确与设计过程相关的用户及其他人员的范围;
● 明确描述设计目标;
● 指出各种不同需求的优先级;
● 规定用来测试设计的可测量的基准程序;
● 各方人员认同用户及系统需求的证明;
● 法定的或法律规定的要求。
3. 提出系统设计方案并建立原型
最初的设计方案可以基于先前的经验或来自某些设计指南，然后根据用户的反馈，对其逐步改进。一般来说，原型方法适用于整个设计阶段，其建立可以通过多种手段实现，也可以利用计算机模拟，建立一个能够提供交互界面并在功能上与最终产品十分接近的原型。
通过建立和使用原型，促进了开发队伍与用户之间的沟通和交流。即使是一个简单的系统，在对它编程之前，也要通过原型对不同的设计选项进行仔细研究，以便及早发现开发后期可能出现的问题。
4. 基于用户的系统或原型评估
用户评估是开发过程中十分重要的活动，它能确定用户和组织机构需求目标的完成情况，并为优化系统设计方案提供信息。与其他几项以用户为中心的活动一样，用户评估活动要尽早实施，从而对原型或系统有调整的时间和余地，否则，就会“牵一发而动全身”，为所做的修改付出极大代价。通常，用户评估活动由以下步骤组成：
● 制订评估计划;
● 采集和分析数据;
● 报告评估结果并提出修改建议;
● 反复测试直到实现目标;
● 跟踪系统或原型的变化。

[此贴子已经被作者于2003-11-6 16:56:57编辑过]
点击查看用户来源及管理<br>发贴IP：211.162.42.201 2003-11-6 16:56:20
编辑这个贴子 鲜花(0) 鸡蛋(0)
小林 美女呀，离线，快来找我吧！

等级：版主
文章：342
积分：601
注册：2003-6-12
给小林发送一个短消息 把小林加入好友 查看小林的个人资料 搜索小林在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给小林 OICQ 访问小林的主页 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
挺全面的了。

----------------------------------------------
/○\
/■\ Human Factors makes the world easy and simple.
<|

点击查看用户来源及管理<br>发贴IP：61.175.193.152 2003-11-6 19:56:48
编辑这个贴子
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
收藏吧！回去慢慢研究~~最近我哪里都已经堆砌好多理论啦！

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.91.206 2003-11-17 13:03:19
编辑这个贴子

本主题贴数3，分页： [1]
*快速回复：以用户为中心的软件产品开发方法[转自ccw.com.cn]
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：312.500毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：[转帖]关于软件原型方法若干问题的讨论

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：[转帖]关于软件原型方法若干问题的讨论

您是本帖的第 132 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： [转帖]关于软件原型方法若干问题的讨论
blackeyes 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：16
积分：86
注册：2003-3-6
楼顶
发贴心情 [转帖]关于软件原型方法若干问题的讨论
关于软件原型方法若干问题的讨论
2003-07-29■Blueski■系统分析员之窗

    1 引子

    太多了！终于签下合同-->得到了“正式”的客户提供的“需求书”的几片纸-->凭借自己的理解立即投入开发-->“木已成舟”，生米终于熬成粥-->用户拒绝接受？-->艰难地修改，反复修改，开发人员厌倦了，而用户对系统用之无味，弃之可惜，遂成鸡肋。-->由此后期收款遥遥无期，软件公司不再和用户保持沟通-->互相埋怨，扯皮由此而生。或者，一个项目拆成为多期，从而收取一部分款项，而很多的开发都作废。这样的案例真是何其多也！

    究其主要原因，与其说是没有搞定关键客户，或者项目管理不当，不如说是没有帮助客户解决其问题，对客户真正的需求研究不够。实际上，原型方法是解决此类问题、确保项目成功的最佳途径。
我在写此文的同时，也试图寻找资料，不知道是本就没有，还是自己所不幸而未找到。看来原型并没有明确的标准，而目前不同软件公司的理解和做法各不相同也就不奇怪了。但从软件过程的角度来考察，原型法仍有着通用的优化的做法。本文试图从作者的实践经验出发，对原型方法进行思考与探讨。

    另外，本文是发散型的，在研究原型的同时，也讨论了原型相关的内容。原型本质上有些象是抛砖引玉，而本文也旨在抛砖引玉，但无意于一概地论定什么。

    2 什么是原型

    2.1 原型的定义

    原型(prototype)即把系统主要功能和接口通过快速开发制作为“软件样机”，以可视化的形式展现给用户，及时征求用户意见，从而明确无误地确定用户需求。同时，原型也可用于征求内部意见，作为分析和设计的接口之一，可方便于沟通。

    2.2 原型的主要价值

    原型法主要价值是可视化，强化沟通，降低风险，节省后期变更成本，提高项目成功率。一般来说，采用原型法后可以改进需求质量；虽然投入了较多先期的时间，但可以显著减少后期变更的时间；原型投入的人力成本代价并不大，但可以节省后期成本；对于较大型的软件来说，原型系统可以成为开发团队的蓝图；另外，原型通过充分和客户交流，还可以提高客户满意度。

    2.3 基本要求

    对原型的基本要求包括：

    * 体现主要的功能；

    * 提供基本的界面风格；

    * 展示比较模糊的部分，以便于确认或进一步明确，防患于未然。

    * 原型最好是可运行的，至少在各主要功能模块之间能够建立相互连接。

    2.4 处理方法

    原型的处理方法基本上有2种不同类型，即抛弃型和演化型（不同的软件工程书籍称发不同，实质意义则类似）。可以抛弃原型，在取得的明确需求基础上重新开始设计与开发；也可在原型的基础上继续开发。一般小项目不采用抛弃型原型，否则成本和代价似乎会偏高。

    2.5 表达工具

    原型的表达工具可以有很多，如果是演化型的原型，当然优先选用软件本身的开发工具。否则还可以应用各种快速显示的工具，例如，HTML，Powerpoint等等，只要能够充分而形象地表达就可以了。

    根据笔者的经验，在原型系统中，可以采用一些与常规不同的做法，例如，可以在界面上比较显著的地方写明当前模块或界面的主要目的，由哪些角色操作，能解决其什么问题。这么做可以使得用户或开发团队成员一开始就有非常清楚的概念；又如，对于决策分析，你可以直接把一些分析结果画成图，并且配上一些文字说明，这样可以避免输入大量初始数据，等等。

    3 原型在软件过程的地位

    软件的根本目的是实现用户的需求，提供用户日常使用，解决用户工作中有所不便的问题，提高其工作效率，改进质量，加强管理控制，最终直接或间接地提高其效益。因此软件开发本质上就是需求的处理和实现，而软件原型对需求确定来说具有非常重要的意义。原型方法包括2个基本过程，即原型制作和原型评价。
如果从需求角度看软件过程，我们不妨可以把软件过程这样划分：

    3.1 需求收集和分析

    搜集需求得到需求说明书，了解软件要做什么，做成什么样，解决用户什么问题。

    这时候软件公司以书面文档方式提出，例如需求问询表等。

    3.2 提供原型并进行评价

    制定原型开发计划，根据用户需求及不确定的高风险部分进行原型开发，在内部进行原型评价，请客户进行原型评价，以保证确实反映了用户的真正想法。

    3.3 实现需求

    当前的软件开发过程常常采用迭代方式进行开发，逐步求精，以降低风险和成本。对迭代的次数，每次迭代的里程碑，要实现的目标，及可提交的成果必须有可验证的清晰的计划。项目管理是一种艺术，迭代规划及里程碑定义都是一种挑战、一种艺术，但项目管理不在本文讨论范围。

    3.4 需求变更

    需求变更是正常的，也是难免的，应允许用户和开发团队自身对需求进行变更。变更处理的关键在于跟踪和控制，如何使产生的影响应得到控制，这属于配置管理的内容，也不在本文讨论范围。
原型在软件过程中的定位如下图所示：
按此在新窗口浏览图片
图1 软件原型的定位

    实际上我们可以把原型看得更为广义一些。任何用户或者内部演示的材料，都可以看作为原型。例如，如果你的产品是某种通用的或者行业解决方案，虽然你其实还没有产品，但先做出一个原型，再加一个漂亮的白皮书，就可以在市场上进行预销售了。

    对于抛弃型和演化型原型来说，也不是绝对的。演化型原型中必然会不断抛弃一些内容，而抛弃型原型，尽管在完成历史使命后不再使用，但很多思想以及部分设计还是可以继承的。

    4 原型方法的一般过程

    基于原型方法在整个需求过程中的地位，我们需要把原型法和需求处理放在一起进行讨论。采用原型法的一般过程如下图所示：
按此在新窗口浏览图片

图2：原型法的处理过程

    在上图中已经清楚地描述了原型的处理过程，值得一提的是，原型不仅用于给用户或者最终用户进行评议，同时完全可以在公司内部组织评议，看看我们周围吧，多数程序员对技术的兴趣远远高于对需求的兴趣，因此其对系统的理解并不会比市场人员或者项目经理理解的深多少。这里的公司内部人员角色可以包括很多，系统分析员/程序员自身、项目经理、部门经理、用户代表、领域专家、测试人员等等，不同的角色往往会在其不同立场对系统提出中肯的意见来。

    另外值得注意的是界面设计的引入。我们认为将界面风格在原型阶段即进行基本确定是一种优化的做法，因为软件前期对界面的确定可以避免后期开发时对界面进行统一调整所带来的不必要的成本花费，良好的界面也可以使客户增加对系统的好感，当然，但愿用户不要只是欣赏界面而忽略了他们对系统功能的思考。要知道，如果仅仅是让用户看到美观的界面，那么整个原型几乎是白做了。

    5 使用原型方法的相关问题探讨

    5.1 为什么要采用原型法？

    原型对一个项目取得成功具有重要的意义。俗话说：隔行如隔山，实际上软件公司很难保证其制作的软件正好就是用户所需要的，用户也很难一次性把其真实的要求完全提交，开始阶段提出的往往只是对系统的期望，和比较模糊的设想而已。而原型系统为用户提供了一个靶子，看着原型系统，用户往往就能进一步提出他们的真正想法。显然软件公司明确用户需求的最佳方式就是为用户提供原型并由用户进行评价。

    也许，跳过原型可以节省时间和前期成本，但你应该注意到，跳过原型的话，后期变更的成本会明显增加。

    5.2 为什么在需求说明书之外需要原型？

    1）眼见为实，文字具有歧义性，不同的人理解都不相同；

    2）最终用户往往在看到一套可运行的系统的基础上，才可能提出其真实的意见，如果到最终提交时才看到 这样的系统就为时太晚。这也是以前无数软件开发留下的教训；

    3）便于发现问题，及时纠正；

    4）便于进一步展开，并取得用户的细节需求；

    5）体现原型的其它功能：便于公司内部如经理、市场部等对软件提出意见，便于开发人员对整个产品达成统一认识，等等。对内部人员来说，同样地，一套形象的原型也远胜过一堆专业术语文字；也就是说，原型对软件公司内部也十分重要。这些评价工作无形之中改进了项目质量。

    5.3 原型方法有什么风险？

    任何方法都是有利有弊，在我们可以探讨一下原型方法可能存在的风险。以下是一般软件公司所担心的风险：需要付出前期进度和人力成本；由于程序员对问题的不了解而效率低下，受客户牵制而在原型上反复修改；因为仓促设计而做不利于进一步在其基础上继续开发；由于过早展示原型给客户，使得客户可能提高其期望值，并提出更多离谱的要求，等等。

    值得一提的是原型方法的主要价值之一就是尽早揭示软件中可能存在的风险及不确定因素，尤其是关于用户需求一致性方面的风险。

    5.4 原型方法和其它方法或过程的关系如何，是否一致？

    生命周期法中并不包括原型，或者说没有明确提供原型的概念和定义。原型可以认为是需求分析中的一个子部分。另外，应该说原型方法是对生命周期法的有益补充和完善。

    RUP中是最优化的统一软件过程，但RUP中似乎没有提到原型，RUP的核心过程是在迭代中精化。我个人的见解是，原型非常类似于第一次迭代的过程和结果。实际上，如果把原型看作为第一轮交付的成果，那么原型的很多不利之处，诸如花费前期成本等等，这些担心都将变得不复存在。

    XP方法对原型非常推崇，这是因为XP方法非常强调需求的重要性，甚至要求客户参与开发过程。但原型方法和XP也有区别。XP是分批交付，先做一个几个功能点的版本，完成后再每个开发周期往上面加其它功能点，而原型法一般要求做出比较完整，能覆盖主要功能点的粗略的版本。XP方法仁者见仁，智者见智，不一而举。

    5.5 如何避免项目团队做原型的时候出现部分人员闲置？

    在项目管理中，对人力资源的调配应和项目进展相匹配。实际上在用户接触到原型制作的同时，可以进行项目计划、架构设计、技术培训以及技术难点攻关等等。

    如果从广义上理解原型的话，架构设计者甚至可以设计出一种用户开发团队使用的所谓框架原型，包含了主要的设计成分、模板和示例。

    比较理想的结果是，当原型完成后，需求分析、架构设计和界面风格设计都趋于完成，从这一点可以看到，原型方法可以作为快速软件开发的重要手段。

    5.6 如果避免项目在原型上停滞不前？

    应使用有经验的开发人员，避免因为程序员不熟悉业务而延误进度；不要在界面设计上犹豫不决而占据时间；如果用户对原型提出了很多意见，其中部分比较明确的意见可以在开发过程中进行实现；和客户的交流应该简洁明了，而不是似是而非；另外，原型方法在项目过程中占据的时间应该在项目计划中保留出来，而不仅仅是隐含在需求调研与分析的一个部分。

    5.7 如何避免用户看了原型后漫无边际地提要求？

    首先，应该充分尊重客户，想想其它行业的服务质量吧。有没有听说过这样的说法，项目管理也是客户满意度的管理；软件是一种对客户的关怀，等等。确实，客户提出的思路可能和你已经形成的思路不同，一下子打乱了你的思路，也许项目经理并不介意，但这确是让设计者特别心烦的事情。如果确有把握，或者你可以不做到原型中去。有时候，即使原型很完美，用户也会额外地提出一些意见，这也是人之常情。但不管怎样，你不能认为用户根本不懂软件，让他们到时用就行了，抱这样想法的多半会付出代价。

    其次应该进行坦诚协商，多数用户其实都是通情达理的。如果你在签订合同时答应满足任何要求，而此时又无法忍受用户的要求，那么孰是孰非应是题外之意了。一般来说，比较合理的做法可以通过增加费用、延长进度或者把需求实现分阶段来提交，以保持工作的延续性。对有些软件，尤其是信息管理系统来说，客户的实施时间其实并不是主要的，客户最需要的不是及时，而是合用。

    其实，客户有着很多种类型，确实，个别客户会参考同类产品来提要求，极个别用户并不真正懂得计算机技术而对技术路线、技术手段等提出其意见，等等。但我们为什么还可以反过来想一下，如果是等到软件全部提交的时候，这部分用户仍有会提出同样的意见。提早暴露并解决分歧，对双方睹是有利的。如果软件公司明知可能存在矛盾，仍然先做好，然后等到用户提出反对后，再提出补充收费，如果喜欢，也无话可说。

    总之，原型应本着对软件需求的基本理解来做，这样才能预防不一致性的发生。尤其应该针对不清楚的地方制作原型，从而尽量暴露问题，引发用户的联想，不能回避问题，掩盖问题（以免用户提出太多的想法），很多问题虽然一时掩盖了，但最终还是要发生的。

    5.8 如何避免在原型基础上继续开发时的可维护性降低？

    问题是这样的，制作原型时常希望快速提供原型，往往不及对软件结构或者数据库进行细致设计。所以在此基础上继续设计和开发的话，有必要在开发前先进行调整。同时，在设计原型前就有必要确定，该原型是要抛弃的，还是要演化要继承的。对于要演化的原型，其设计不能过于粗略，显然这直接影响到今后的开发成本。

    6 小结

    原型方法是可视化的方法，已成为快速软件开发常用的手段。软件公司或部门一旦得到了原型方法的回报，就会坚持使用。原型不是绝对必要，但非常有意义。

[此贴子已经被作者于2003-11-7 13:37:24编辑过]
点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-5 16:09:24
编辑这个贴子 鲜花(0) 鸡蛋(0)
Rokey 帅哥哟，在线，有人找我吗？

等级：管理员
文章：1508
积分：2702
注册：2003-4-12
第2楼
发贴心情
好,谢谢

----------------------------------------------
---------------------------------------------------------------------------
Rokey project
http://www.rokey.net/

点击查看用户来源及管理<br>发贴IP：210.76.108.158 2003-11-5 17:00:24
编辑这个贴子
烛音 帅哥哟，在线，有人找我吗？

等级：实习版主
文章：5186
积分：7085
注册：2003-5-22
第3楼
发贴心情
如果是做BS，可以直接用DW做html原型。

如果是CS，我的办法是用PSD，充分利用图层组，每一图层组可以是一个块，几个块可以组成一个流程。我们在演示的时候，先把所有图层组隐藏，一步一步演示，其操作流程也是可以演示得非常清楚，当然，视觉效果就更加显而易见了。
[这样做的好处在于以后的详细设计就可以在这个基础上进行。]

----------------------------------------------
http://www.cqppi.com/1/1.html

点击查看用户来源及管理<br>发贴IP：211.158.65.243 2003-11-5 17:35:30
编辑这个贴子
blackeyes 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：16
积分：86
注册：2003-3-6
第4楼
发贴心情
原型的方法可以在软件研发流程的各个阶段使用，这篇文章谈到的应用重点是在需求阶段；
烛音谈到的是原型制作工具和呈现方式，其实原型是根据不同的项目大小，不同的项目阶段，其原型要求也是不同的，表现形式也是各异的，以后有空整理一些东西给大家分享；
贴这篇文章一是想让大家了解原型方法的意义和价值，再就是想引起大家的讨论，各自谈谈自己在实际工作中已经应用了的经验，或者是以前没应用过，现在是不是可以考虑应用这样的方法到实际工作上去。
点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-5 18:24:47
编辑这个贴子
木子 帅哥哟，在线，有人找我吗？ 天秤座1983-10-23

等级：高级会员
文章：918
积分：1540
注册：2003-4-30
第5楼
发贴心情
支持，
希望楼主多贴一些这样的帖子。

----------------------------------------------
——+++++U

点击查看用户来源及管理<br>发贴IP：219.139.215.22 2003-11-6 9:13:05
编辑这个贴子
pyb123 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：8
积分：76
注册：2003-7-16
第6楼
发贴心情
工作经验！宝贵！
点击查看用户来源及管理<br>发贴IP：61.144.207.70 2003-11-13 14:14:18
编辑这个贴子
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第7楼
发贴心情
对于有些成熟项目来说，没有原型设计这一步。

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.91.206 2003-11-17 15:27:46
编辑这个贴子

本主题贴数7，分页： [1]
*快速回复：[转帖]关于软件原型方法若干问题的讨论
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：671.875毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：框架设计具体是做那些事啊？

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：框架设计具体是做那些事啊？

您是本帖的第 137 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 框架设计具体是做那些事啊？
麦子 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：100
积分：199
注册：2003-8-24
给麦子发送一个短消息 把麦子加入好友 查看麦子的个人资料 搜索麦子在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给麦子 OICQ 引用回复这个贴子 回复这个贴子 楼顶
发贴心情 框架设计具体是做那些事啊？
如题，
这些方面我可是还真的是个婴儿啊，

点击查看用户来源及管理<br>发贴IP：61.175.170.226 2003-11-5 18:04:10
编辑这个贴子 鲜花(0) 鸡蛋(0)
blackeyes 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：16
积分：86
注册：2003-3-6
第2楼
发贴心情
能说明白一点吗？
编码有框架设计，web网站内容也有框架设计，界面排版设计也有框架设计
你到底是说哪个？
点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-5 18:31:21
编辑这个贴子
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第3楼
发贴心情 [转帖]基于构件开发的应用框架设计 （可以参考）
谢晓芹 柳西玲（转载自计算机世界报）

    框架必须是健壮的、可扩展的、灵活的，且支持动态内容，它要求基于开放或共享标准。框架的设计要力求做到：完备性、灵活性、可扩展性、可理解性，同时抽象能用于不同的场合；用户能轻松地添加和修改功能，定制框架；用户和框架的交互清晰，文档齐全。框架设计的一个核心问题就是发现可重用的设计和“热点”，以保证框架具备充分的灵活性，使用户能在已有构件的基础上生成应用程序，实现“零代码编写”的理想目标。
一、如何设计应用框架？
    目前在框架设计方面成熟的技术较少，大体可分为两类：实践法与系统法。
1. 实践法
    许多专家甚至认为框架不可能是系统设计的结果，而只是在从底向上设计中的一个结果。实践法也可以说是实例(Example)驱动的设计方法,它是从若干个具体的典型应用中，抽象出相似点来构建框架，框架反过来又应用于不同的问题，并在解决不同问题的过程中得到更新，在框架的设计和实现的两步中，不断反复。等到框架逐渐成熟时，需要修改和反复的内容就会越来越少。
    具体步骤为：
    分析问题领域，确定所需框架。从一类应用而不是单个的程序去分析、比较各种不同的软件解决方案，寻求这些方案的共性和每个程序的唯一性特征。这些共性，尤其是那些经常被多个程序使用的部分将成为框架的基础。然后定义框架体系结构并设计，包括设计用户与框架间的交互、给用户提供的最终工具等。
    框架的实现。包括框架核心类的实现、框架的测试、框架的试运行、框架的反复更新。
    框架的部署。包括文档的提供、分发过程，为用户提供技术支持，维护和更新框架。
    这种方法也就是先在具体类基础上进行泛化，提取出抽象类。抽象化也是框架开发的一个关键。不过，根据这种方法设计出的框架的可适用性很大程度上依赖于其基于的具体应用。
    由于框架的开发具有反复性，且需要深入了解应用领域，因此框架的开发很难按进度表进行。框架的设计者也需要和应用开发者紧密合作，因为框架只有在使用它开发应用的过程中才能发现其哪些部分有待改进。
2. 系统法
    由于有人认为框架的设计也可以通过系统的方法得到，因此人们提出了逐步泛化的框架设计方法。此时框架的设计分两步：
    第一步是问题的泛化。它要求解决如下问题:问题领域中的哪些概念可以表现为变量，并且需要统一处理？是否可以发现一些具体的概念，它们能被泛化为一个更抽象的概念？
    第二步是框架的设计。在这一步中，泛化是从反向考虑，以实现每一级的框架。换言之，最先实现最通用的框架，然后实现次通用的框架，以此类推。如图1所示, 其中，框架0就是最终要实现的框架。
    这一步需要解决如下问题：系统的哪一部分可能需要改变？用户需要在什么地方向框架中加入自己的代码？
    采用两步的设计方法可以避免在早期的开发过程中局限于应用专用的类和体系结构，并且有利于使用通用的设计模式。
    框架的设计是一个反复的过程，在这个过程中需要领域和设计两方面的专家意见，框架用户和框架开发者之间的交流对框架的设计也很重要，因为框架是在不断反复的过程中逐步成熟的。
3. 框架设计与应用设计
    框架的设计和应用的设计到底有何不同？一般而言，两者的侧重点不同。设计应用系统时，要求对专用领域的重要概念有深入的了解。这些概念通过建模演变成类，并作为实现整个应用的构建块。而设计框架时，重点在识别出必须具备灵活性的地方，也就是“热点”，这也是框架的关键所在。
    构件库系统基于框架而不是具体的类，使得构件库系统的使用更具灵活性。但在框架基础上构建具体的应用时, 类的使用和开发总是随之而来，在框架上生成应用可以通过创建子类、配置各构件对象、调整实例等来获得。
4. 框架文档
    文档必须包括如下内容:框架的目的，如何使用框架，框架的设计细节等。
二、框架采用哪些支持工具？
    一般而言，没有支持工具的框架很难被使用。任何一个框架的提出总是配有一系列工具软件，这样基于框架的应用开发才切实可行。这些工具允许用户与应用框架交互、配置和构筑新的应用。下列工具通常被使用：
    浏览工具 用户可以利用它浏览框架的类层次结构等信息。
    编辑工具 用户用来调整和修改框架元素的属性等，如修改类或构件等。
    帮助系统 为用户使用本框架系统提供向导功能，如可以采用HTML格式。
    测试系统 用来测试生成的应用系统，通常支持仿真操作。
    文档工具 帮助创建应用系统的文档，如Javadoc工具。理解并学会使用框架是一件费时的工作，这也是框架设计方法的唯一不足之处，因此要求框架的文档必须齐备。
    配置管理工具 使用框架而不是具体的对象虽然提供了复用性，但它同时也带来了开发上的复杂性。框架内包含各种构件或构件库，一个框架可能需要和其他框架通信。一个框架也可能由其他子框架系统组成，这样一种组成结构必然提出配置管理的问题。例如，如何在多个框架内共享构件？如何由构件或子框架组装新框架？框架内的构件如何通信与协作？不同的框架间如何交互？
    使用这些高级工具的最终目的就是减少编码和记忆的工作量,简化用户的操作。理想情况下，用户可以不用编一句代码而实现新系统的构建。例如，在一可视化界面上，通过选取一些图标就能生成可执行程序。目前已有一些类似的工具，如University of Geneva开发的Vista系统。
三、都有哪些著名的框架系统?
    目前有许多框架系统，例如用户界面方面的框架有MVC、ET++等，其中ET++采用C++语言实现，运行于Unix等系统中；针对其他领域的则有FOIBLE、MacApp、FACE (Framework Adaptive Composition Environment)等。
    早期一些框架系统多采用传统的面向过程语言实现，现在面向对象语言为软件和设计的重用提供了更强有力的支持。由于框架开发的学习曲线较复杂，因此框架开发的语言最好能对框架的文档建立提供有效的方法；框架的使用要求开发语言具备高可移植性;框架的设计其实也是一些高层的决策，很自然采用高级语言来实现。Java语言由于具有平台独立性以及轻量级的链接过程、自动垃圾回收、简单语言结构、标准软件包、面向对象等特性，因此可以说Java是进行框架构筑的合适语言。现在市场上已出现了许多采用Java语言编写的框架系统。
    LEC India Software Centre Pvt. Ltd.公司研制了一个面向EJB 构件的应用框架系统。它主要面向基于EJB的应用程序，是一个服务器端的框架，能在EJB构件的开发中解决稳定性以及其他一些企业级的特性等问题。
    现在又出现了许多采用J2EE编程环境的应用框架，如Pacific技术服务公司开发的一套多层框架，能用来开发Web应用服务器；Jcorporate公司开发的Expresso Framework是一使用java来建造分布式、重用、基于构件的安全的Web应用程序的应用框架。
四、 如何设计知识工程应用框架?
    在知识爆炸的时代，如何从数据中提取信息，从信息中提取知识已成为一个重要的应用领域。越来越多的知识处理应用系统急待开发，若能有一个成熟可靠的知识处理框架系统，将大大加快此类应用系统的开发。针对这种情况，清华大学知识工程研究室结合自己的经验,目前提出了在知识工程应用领域的框架，主要针对网络计算模式下的知识获取、传输、管理和应用，基于Web的数据挖掘与知识发现等内容，所有的代码均采用Java实现。
    将应用框架结构化为框架的框架，划分为如下三个子框架：
    (1) 领域专用构件框架:提供领域专用的构件模型集合，并为分层的构件模型提供统一接口。
    (2) 可视化组装框架:提供整个框架系统的图形化界面，并为可视化组装和操作构件提供工具。
    (3) 连接框架:为构件间的交互、通信提供机制。
    框架内各构件的分布如图2所示。
    建立的基于框架的构件系统具有如下性能：
    实现面向产品化、实用性的构件库系统，并具开放性、可扩展性；
    支持异构环境中的框架、构件的互联和通信;
    实现新旧系统的兼容性；
    提供一致的接口分配；
    遵循重要构件标准（如CORBA）；
    构件具有透明本地化、平台无关性特点；
    系统的配置、数据交换基于XML和Java的标准化格式；
    支持个性化信息服务定制和可重构。
    良好的用户学习曲线。
    框架的设计本身也是一个循环迭代的过程，它在不断应用于实践的过程中，得到更新和提高。我们也在不断的完善这套系统。目前一些公用构件如电子表单自动生成系统、数据提取和文件转换系统等作为大粒度构件已得到广泛使用。
    框架能使应用程序的开发简单，价格低廉，但是开发框架不是一件容易的事。它是一个需要领域和设计经验的反复过程。为了保证框架的灵活性，必须提取和发现热点。设计模式可以简化这个过程，因为它提供了对过去经验的抽象。应用框架能高度抽象同一领域内的问题，进而降低开发难度和强度。虽然框架和构件技术已经出现许多年了，开始走入实用,但还不成熟，有大量问题有待研究。

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-6 9:51:56
编辑这个贴子
yue 美女呀，离线，快来找我吧！ 天秤座1976-9-30

等级：中级会员
文章：412
积分：659
注册：2003-3-15
第4楼
发贴心情
框架设计还是架构设计?
点击查看用户来源及管理<br>发贴IP：220.184.132.1 2003-11-6 14:46:19
编辑这个贴子
麦子 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：100
积分：199
注册：2003-8-24
给麦子发送一个短消息 把麦子加入好友 查看麦子的个人资料 搜索麦子在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给麦子 OICQ 引用回复这个贴子 回复这个贴子 第5楼
发贴心情
谢谢大家了，
我自己也不知道是框架还是架构啊，如blackeyes 说的那三种应该是编码和界面排版吧
比如说吧：我现在是做软件界面的（除了写程序什么多做的那种）一个软件，怎么部局那应该是也是我份内事，但这部局怎么实现特是不是框架或架构设计？
叹问题太多了，因为是对这行太不了解了吧，HO
点击查看用户来源及管理<br>发贴IP：61.175.170.191 2003-11-7 9:04:38
编辑这个贴子
烛音 帅哥哟，在线，有人找我吗？

等级：实习版主
文章：5186
积分：7085
注册：2003-5-22
第6楼
发贴心情
麦子，这不是架构设计，可能你说的是用户操作流程设计吧！

----------------------------------------------
http://www.cqppi.com/1/1.html

点击查看用户来源及管理<br>发贴IP：211.158.67.66 2003-11-7 9:54:11
编辑这个贴子
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第7楼
发贴心情
框架设计

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.91.206 2003-11-17 12:59:20
编辑这个贴子
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第8楼
发贴心情
粗线条你想说什么？请描述清晰！

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-17 13:19:10
编辑这个贴子

本主题贴数8，分页： [1]
*快速回复：框架设计具体是做那些事啊？
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：29,390.630毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：浅谈B/S结构应用软件的优化

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：浅谈B/S结构应用软件的优化

您是本帖的第 128 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 浅谈B/S结构应用软件的优化
tianeyi 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：2
积分：68
注册：2003-8-21
楼顶
发贴心情 浅谈B/S结构应用软件的优化
目前Internet应用的B/S（Browser/Server）结构已经越来越多的应用在Intranet的企事业单位内部，诸如OA，CRM，ERP，CMS等大规模的集成应用系统，由于这种结构的可维护性强、开发成本低、及技术的不断发展，B/S结构更已成为了当今应用软件的首选体系结构。
但是B/S结构应用系统还是存在着诸多问题，比如界面风格凌乱、操作不便、流程烦琐等，如果能减少这些问题，B/S结构应用系统将一定能更为用户所接受。作者从事了多年的软件UI工作，在B/S系统的优化方面也积累了些许经验，也许能为大家带来些帮助。

1、统一界面

相信很多开发人员都有这样的经验，软件项目验收到最后，往往用户提出最多的问题并不是开发人员擅长的数据处理、事务逻辑等问题，而是系统的前端显示，例如：表格的样式、数据的样式、脚本错误、操作流程简化等，这些用户认为很简单的问题却经常需要开发人员花费项目近1/3的时间来完成。

·规范<Head>区代码
很多应用系统的前端Head区过分凌乱有些甚至没有，导致有时网页会显示为乱码，所以在系统开发初期一定要规范Head区代码，统一书写。

·统一脚本及CSS文件
由于系统开发人员习惯于从其它地方直接拷贝原代码，这就导致脚本文件过于繁多，增加变量或函数命名重复的可能，而且经常会看到在Head区会引用4，5个JS文件或是CSS文件，事实是这些都是没有必要的。
对于CSS文件应该准备好一份使用说明，这样可以避免开发人员对一个标签进行多次定义。

·简化HTML代码
对body区域的样式控制最好在CSS中定义为默认样式。
表格的嵌套尽量不要操作两层，否则不利于阅读及今后的修改。
对其中的表格、表单、按钮、链接、菜单等的样式统一应用CSS定义，这样可以使开发人员更易于控制。
对于表单数据检验最好通过初始化脚本完成，而不要为每一个页面写入不同的脚本。
尽量自己来开发脚本控件，而不要直接粘贴别人的代码，一方面他们的代码不易控制，另一方面由于编写的人不同书写格式、规范都不同，这就会增加出错的可能。

2、操作方便

由于应用系统需要处理大量的信息，这就需要用户做频繁的重复录入工作，如果能提供更多的快捷键，及尽量让用户少用鼠标，则一定可以使软件更受用户欢迎。

重定义Tab顺序，不要使用系统默认顺序。
如果可以，为每个表单加入回车跳转至下一个表单的脚本。
每次打开新窗口时使新窗口得到焦点。

3、简化流程

由于B/S结构的应用系统几乎所有的数据处理都由服务器完成，所以经常使得用户为了查看一条记录，需要打开3、4次的窗口。

当每条信息的数据量不会很大时最好在读取每页记录时将记录的全部信息一起读出，然后由前端界面的隐藏层来显示。
对于记录条目不是很多的列表，分页最好利用脚本来实现。
对于不必要的交互行为最好使用脚本来实现。
这样可以简化用户在使用过程的操作流程。

还有很多的方法可以对B/S结构的应用系统进行优化，这里就不再一一详述了，随着Flash MX2004的发布，F/S（SAFlashPlayer/Server）结构也将会是一种全新的结构体系，总之对于应用系统开发，前期准备越充份，后期收尾就会越顺利。

点击查看用户来源及管理<br>发贴IP：61.51.60.61 2003-11-18 12:13:26
编辑这个贴子 鲜花(0) 鸡蛋(0)
shupeichong 帅哥哟，在线，有人找我吗？

等级：初级用户
文章：151
积分：300
注册：2003-6-23
第2楼
发贴心情
这么好的帖子不能沉下去。嘿嘿，，

还有一些B/S结构的问题，比如在B/S模式下，由于操作步骤是通过页面转换来实现的所以在B/S下的流程往往会有多个连续的页面组成，但是这样频繁的转换页面会使用户等待时间变长，会让系统的直观性下降。

所以在流程的简化中应该还有一部分就是利用不同的区域来尽量显示多的内容。

这是偶在设计的时候遇到的一个棘手问题，多谢楼主意见给了偶启发。嘿嘿。。

点击查看用户来源及管理<br>发贴IP：202.14.238.240 2003-12-25 9:02:44
编辑这个贴子
烛音 帅哥哟，在线，有人找我吗？

等级：实习版主
文章：5186
积分：7085
注册：2003-5-22
第3楼
发贴心情
嗯，好贴子，
对于经常的页面跳转和不断地弹出新窗口，简单的交互却给用户带来繁琐的操作。
我们可以采用页中页和隐藏表格/表格行等方法来处理，直观且简便。

----------------------------------------------
http://www.cqppi.com/1/1.html

点击查看用户来源及管理<br>发贴IP：211.158.66.167 2003-12-25 9:36:56
编辑这个贴子
x3d 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：119
积分：314
注册：2003-5-12
给x3d发送一个短消息 把x3d加入好友 查看x3d的个人资料 搜索x3d在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给x3d OICQ 引用回复这个贴子 回复这个贴子 第4楼
发贴心情
前面两点并不是B/S模式的问题.
而是你所在的开发团队问题,多研究一下软件工程
而后面一点,正是说明人机交互的重要性
点击查看用户来源及管理<br>发贴IP：218.5.43.198 2003-12-25 17:55:36
编辑这个贴子
uicat 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：38
积分：120
注册：2003-8-11
第5楼
发贴心情
顶
点击查看用户来源及管理<br>发贴IP：219.232.160.165 2003-12-25 21:13:12
编辑这个贴子

本主题贴数5，分页： [1]
*快速回复：浅谈B/S结构应用软件的优化
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：468.750毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：转贴MS文档

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：转贴MS文档

您是本帖的第 95 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 转贴MS文档
eworker 美女呀，离线，快来找我吧！

等级：实习版主
文章：1863
积分：2665
注册：2003-7-17
楼顶
发贴心情 转贴MS文档
虽然讲的是游戏安装和维护的最佳方法 ，但对其他程序的UI也有一定参考作用

游戏安装和维护的最佳方法
Dave Bartolomeo
Microsoft Corporation

2003 年 7 月 25 日

摘要：本文介绍几种最佳方法，帮助用户减少在安装游戏上所花的时间，省去不必要的技术求援，并使用户尽可能快速轻松地开始玩游戏。（本文包含一些指向英文站点的链接。）

初始安装
用户购买游戏是因为他们喜欢玩游戏，而不是因为他们喜欢安装游戏。对最终用户来说，安装游戏的过程应该尽可能地快速、简单和轻松。最终用户憧憬的理想情况是根本看不到安装 UI，而是直接将游戏 CD 放到光驱中，开始玩游戏。

简化安装 UI
在现有的游戏安装 UI 中，有几个很常见的因素会影响最终用户所期望的体验：

询问用户一些不必要的问题。例如，许多游戏软件都会询问用户是否要安装 DirectX。如果游戏需要 Microsoft® DirectX® 才能运行，而目前还没有安装相应版本的 DirectX，游戏就应该直接安装 DirectX。
询问用户一些大多数人会给出相同答案的问题。对一般用户来说，选择默认的安装路径、“开始”菜单中的位置等就完全可以了。至于那些希望更改这些选项的用户，可以为他们提供一个“高级选项”页面。
安装 UI 应该设计成使一般用户可以尽可能快地开始玩游戏。如果用户的计算机上启用了“自动运行”（默认情况下为启用），安装程序就应该认为用户可能希望尽可能快地开始玩游戏，因此可以忽略所有不必要的问题。安装程序应该将游戏安装到默认的安装路径，最好使用“即需即装”的方式（请参阅下文）。这种安装方法使得用户可以在自动启动安装过程之前更改各种安装选项。但是，在更改选项的过程中，应该提示用户可以使用某个按键来选择高级安装选项，如果用户在 5 到 10 秒内未使用该键，则继续使用默认选项自动进行安装。

如果用户的计算机上没有启用“自动运行”，安装程序就应该认为用户不希望安装程序自动开始安装游戏。如果安装程序是通过“自动运行”以外的方式启动的，它应该启动高级安装 UI。

减少安装所需的时间
目前，大多数 Microsoft® Windows® 游戏的安装过程都需要 5 到 30 分钟。与之相比，大多数游戏机游戏则要快得多，从用户插入游戏 CD 到开始玩游戏，整个过程只需要不超过 30 秒的时间。这种差别的原因在于，大多数 Windows 游戏是从计算机的硬盘开始运行大部分（如果不是全部）内容；而游戏机游戏由于没有地方永久存储大量内容，需要从源介质运行内容。虽然从本地硬盘加载内容会提高游戏过程中的加载速度，但缺点是需要将所有内容从源介质复制到硬盘中的某个位置。大多数 Windows 游戏选择在安装过程中将所有内容一次性地复制到硬盘中。这样一来，用户在可以玩游戏之前，必须花上几分钟时间盯着进度栏，等待这个过程结束，从而影响了用户最初的体验。

有两种方法可以最大程度地减少安装游戏所花的时间：“最小安装”和“即需即装”。

最小安装
在“最小安装”方案中，游戏只将所需的最少内容安装到硬盘中，通常只包括游戏的可执行文件和 DLL。其余内容则直接从源介质进行访问。这就大大减少了安装所需的时间，因为游戏的可执行文件一般不会超过 10-20 MB。这样做的缺点是由于在游戏过程中需要从较慢的源介质加载内容，因此会延长加载时间。

要在基于 Windows Installer 的安装方式中创建“最小安装”配置：

将所有要安装到硬盘中的组件组合成一个标记为本地安装的部件。这个部件称为“自动运行”部件。
将所有要从源介质运行的组件组合成一个标记为“从源介质运行”的部件。
当打开某个可能位于源介质上的文件时，使用 MsiGetComponentPath API 来确定该文件的路径，而不是对路径进行硬编码。这样可以确保即使用户的 CD/DVD 驱动器的驱动器号被更改，也可以找到相应的文件。
应该压缩 CD/DVD 上的内容。由于 CD/DVD 驱动器的传输速率较低，解压缩内容所花的 CPU 时间通常是微乎其微的。
内容应该被组合成多个大的连续文件，并按顺序进行访问。与硬盘相比，CD/DVD 驱动器的寻道时间比较长，而且，除非是读取大的连续文件，否则大多数 CD/DVD 驱动器都不会达到峰值传输速率。
CD/DVD 上的内容应该按照可能的访问顺序进行排列。当按文件的磁盘布局顺序访问文件时，寻道时间就会大大减少。
即需即装
与“最小安装”方案一样，在“即需即装”方案中，游戏最初只将启动游戏所需的文件安装到硬盘中。不同的是，采用这种安装方式，不必在每次需要时从源介质访问其余内容，而是在首次需要时将内容的各个部分实际安装到硬盘中，以后需要使用时，就从本地硬盘进行访问。虽然初始安装所需的时间与“最小安装”方案差不多，但在首次访问内容的各个部分之后，加载时间将减少。

要在基于 Windows Installer 的安装方式中创建“即需即装”配置：

将所有要初始安装到硬盘中的组件组合成一个标记为本地安装的部件。请注意，这个部件与“最小安装”方案中的“自动运行”部件是一样的。
根据可能一起使用的组件分成一组的原则，将其余内容组合成多个部件。例如，在分级游戏中，将某一给定级别上使用的所有内容组合成一个部件。请注意，Windows Installer 允许多个部件共用一个组件，因此，如果有多个级别要使用同一项内容，则可以将该内容添加到这些级别的部件中，而无需复制该内容。所有这些部件可以标记为“已通知”，即初始安装时将不会安装它们，但以后需要时可以安装。
当需要某个文件时，首先检查是否已经使用 MsiQueryFeatureState API 安装了该文件。如果尚未安装（即，其状态为 INSTALLSTATE_ADVERTISED），则调用 MsiConfigureFeature API 在本地安装该部件。打开已安装的文件时，使用 MsiGetComponentPath API 来确定文件的路径。虽然这对于本方案来说并不是必不可少的（因为内容总是先被安装到硬盘中，然后再被使用），但除了可以更容易地支持“即需即装”方案以外，还可以支持“最小安装”方案。
如果可能，预先考虑可能先需要什么内容，并在空闲时间进行后台安装。当游戏不需要消耗计算机的全部性能时，例如在情节介绍、剪切场景、操作菜单等时，进行后台安装非常合适。
在游戏的选项菜单中提供一个选项，用来强制安装所有其余内容。要实现这一点，可以创建一个部件，作为所有即需即装部件的父部件，然后调用 MsiConfigureFeature API 在本地安装这个主控部件，同时也就安装了子部件。
在内容的布局上，除了将可能需要同时使用的内容安排在一起（例如，一个级别的所有内容应该放在一起）外，其他的安排方式应该与“最小安装”类似。
安装后游戏的运行
自动运行
用户要玩已经安装好的游戏，只需将 CD/DVD 放到光驱中即可。CD/DVD 上的“自动运行”可执行文件所做的第一件事就是检查是否已经安装了游戏，如果安装了，则启动游戏。如果游戏是使用基于 Windows Installer 的安装方式安装的，可以通过单独调用 MsiQueryProductState API 来检查是否安装了该游戏。

将“即需即装安装”转换成“完全安装”
虽然与完全安装相比，“即需即装”安装使用户可以更快地开始玩游戏，但用户可能希望将游戏内容的其余部分明确安装到本地硬盘。用户可能希望无需源介质就可以玩游戏，也可能只是希望省去由于安装所需内容而导致的较长的游戏中加载时间。如果游戏采用的 Windows Installer 安装方式，则可以在游戏的选项用户界面中提供一个选项，用来安装其余内容。当用户选择这个选项后，游戏会调用 MsiConfigureFeature API 来强制本地安装其余部件，而无需另外的单独安装应用程序来执行这项操作。

维护
与游戏机游戏相比，Windows 游戏的一个优点是发行商在游戏发行之后的更新发行上要相对轻松一些。不管这些更新是引入了新的内容，还是仅修改了错误，有一点很重要，那就是更新过程对最终用户来说应该尽可能的简单。对于联机游戏，更新过程尤其重要，因为在联机游戏中，通常需要所有用户都运行最新版本的游戏才能进行连接。

自动检查更新
用户应该不必总是记着自己去查找修补程序。如果游戏有了可用的更新，至少应该通知用户，而理想的情况是已经下载了修补程序。

有一种简单的方法可以检查游戏的更新，就是连接到指向由发行商托管的 Web 服务器的特定 URL，并下载一个文本文件和一个 URL，前者用于指定游戏最新可用版本的版本号，后者用来下载将游戏更新到最新版本的程序包。

每次用户玩游戏时都要检查更新，以确保用户运行的是最新的版本。但是，如果只是在用户刚好要玩游戏之前找到新的更新，用户可能被迫推迟玩游戏，直到下载完更新。当更新较大或连接较慢时，这种推迟可能需要几个小时。为避免用户在玩游戏之前被迫等待，游戏可以使用“任务计划程序”服务来安排定期检查新的更新。如果检测到更新，游戏会自动下载该更新，这样，下次用户玩游戏时，更新可能已经全部下载，可以进行安装。

自动下载修补程序
一旦检测到新的可用更新，游戏应该立即开始下载更新。由于检查更新的任务通常是在后台静默运行的，因此下载过程应该尽可能地不影响用户的正常操作。后台智能传输服务 (BITS) 是一项操作系统功能，可以使应用程序从 Internet 下载文件，即使应用程序并未运行。只有当用户登录且计算机已经连接到网络后，BITS 下载作业才可以运行。BITS 本身不会试图将计算机强制连接到网络。如果用户断开网络连接或注销，BITS 作业将被暂停，并在下次用户登录并连接到网络时继续下载。应用程序可以将其 BITS 作业配置成仅利用处于未使用状态的网络带宽，以防止这项作业影响其他任何可能使用网络的应用程序（例如联机游戏）。Windows XP 和 Windows 2000 Service Pack 3 都提供了 BITS。

----------------------------------------------
批评是对我最大的帮助。
http://www.chinaui.com/bbs/list.asp?boardid=12

点击查看用户来源及管理<br>发贴IP：61.188.197.107 2003-12-14 22:29:54
编辑这个贴子 鲜花(0) 鸡蛋(0)
chinasea 帅哥哟，离线，有人找我吗？

等级：活跃分子
文章：278
积分：544
注册：2003-6-14
给chinasea发送一个短消息 把chinasea加入好友 查看chinasea的个人资料 搜索chinasea在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给chinasea OICQ 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
多谢，有启发
点击查看用户来源及管理<br>发贴IP：218.26.151.54 2003-12-17 1:23:34
编辑这个贴子

本主题贴数2，分页： [1]
*快速回复：转贴MS文档
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：2,640.625毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：[原创]用户参与之初体验

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：[原创]用户参与之初体验

您是本帖的第 161 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： [原创]用户参与之初体验
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 楼顶
发贴心情 [原创]用户参与之初体验

（一）项目最应该向用户了解的内容
1. 定位产品的目标用户群。
2. 用户希望用我们的产品完成什么任务。
3. 用户希望如何完成任务（难点，用户很难清晰描述自己的想法）。
4. 用户对产品功能设计、界面设计和信息设计的喜好程度及原因。
5. 对于难以取舍的问题，让用户决定什么更重要。

（二）在不同的阶段使用不同的用户参与方法
    分析是一门科学，设计是一门艺术，把他们完美结合起来是我们工作的目标。用户参与的主要方法有
¨ 焦点小组
¨ 可用性测试
¨ 专家座谈
¨ 上门进行用户访谈问卷调查（电话、传单）

１．需求采集阶段
    通常采用焦点小组或专家座谈的形式，引导用户提出相关见解，找出亮点作为重点开发功能。不同产品的用户在各自的行业内都是专家（或特定人群的典型用户），没有谁比他们更精于自己的工作和生活，我们要做的就是精心挖掘，其次要注意以下几点：
¨ 同事和经理提供技术支持。
¨ 让真正的用户参与。
¨ 可能涉及的其他用户。
¨ 项目委托方的一些要求。
¨ 用户使用同类软件的感受。
¨ 用户需要什么和不需要什么同样重要。
¨ 不要强加自己的看法给用户，注意正确引导。
    我们在此活动中，对功能、用户界面特性、数据、任务流、以及整体用户界面需求和设计是否科学等等进行有效验证，获取的信息主要有
¨ 选择必有功能和增值功能。
¨ 使用环境、任务流和操作模式的改进建议。
¨ 功能排列和布局的改进建议。
¨ 优先级和同级别的取舍。
¨ 图形和术语的应用。

２．设计阶段
    需求确定后，面向需求的设计进入可是化的交互设计，我们通常是通过“交互原型”来设计的，本阶段用户主要参与：
¨ 操作逻辑
¨ 一致性因素
¨ 屏幕流程、步骤、内容、图形风格、页面布局。
¨ 注意用户使用习惯
    通常采用“可用性测试”的形式。可以把希望解决的问题或项目组内意见不统一的交互方式做成可操作模型，通过用户的使用发现问题。在此阶段可以针对不同的问题进行多次测试。

３．构造阶段
    通过编码人员的加入和单元测试的进行，一些细节问题会被发现例如：图形和文字在不同设备和分辨率方面的可读性和操作中的小故障等等，需要很快做出修改决定，这时可以通过邮件确认或电话访谈的方式寻求用户帮助。

４．产品测试阶段
    通常采用“可用性测试”的形式对Beat版本测试，是对可靠性和交互的最后检验。

特别提醒
¨ 同一产品在不同的阶段进行参与设计的用户最好是不同的人，如果让同一个人从头至尾参与测试和研究，那他很容易被项目组同化，很难有自己的见解了。
¨ 在引导用户时尽量不要问“你希望他是怎样的”或“你理想中的XX是什么样”，因为用户在软件设计方面完全是外行，如果你问“您经常用它做什么”、“那一部做起来最难”或“您希望对那些方面进行改进”那用户就能够表达的比较充分了。
¨ 在选择用户时，一定要把初级用户和高级用户分到不同的小组，否则会造成，一部分人说，一部分人听的现象，不能充分利用资源。

[此贴子已经被作者于2003-11-17 13:04:02编辑过]

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-3 18:55:54
编辑这个贴子 鲜花(0) 鸡蛋(0)
yue 美女呀，离线，快来找我吧！ 天秤座1976-9-30

等级：中级会员
文章：412
积分：659
注册：2003-3-15
第2楼
发贴心情
d
点击查看用户来源及管理<br>发贴IP：220.184.64.144 2003-11-7 16:07:37
编辑这个贴子
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
特别提醒着几点说得很贴切！谢谢！

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.91.206 2003-11-17 13:01:33
编辑这个贴子
errantry 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：142
积分：269
注册：2003-2-26
第4楼
发贴心情
只是简要总结了一下，加上自己的经验。
Practitioner's Handbook for User Interface Design and Development这本书还是比较贴近软工的。

----------------------------------------------
^((1??\d{1,2}|2[0-4]\d|25[0-5]\.){3}(1??\d{1,2}|2[0-4]\d|25[0-5])$

点击查看用户来源及管理<br>发贴IP：218.22.24.83 2003-11-18 11:49:04
编辑这个贴子
麦子 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：100
积分：199
注册：2003-8-24
给麦子发送一个短消息 把麦子加入好友 查看麦子的个人资料 搜索麦子在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给麦子 OICQ 引用回复这个贴子 回复这个贴子 第5楼
发贴心情
顶
点击查看用户来源及管理<br>发贴IP：61.175.170.233 2003-11-18 12:18:51
编辑这个贴子

本主题贴数5，分页： [1]
*快速回复：[原创]用户参与之初体验
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：6,562.500毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：用户界面原型开发：技巧和技术

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：用户界面原型开发：技巧和技术

您是本帖的第 165 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 用户界面原型开发：技巧和技术
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 楼顶
发贴心情 用户界面原型开发：技巧和技术
Scott W. Ambler
总裁，Ronin International
来自《IBM DeveloperWorks》

在开发原型 UI 时，请尝试这些技巧。本列表改编自 The Object Primer 2nd Edition 的第 8 章。

每名专业软件开发人员至少要基本了解用户界面设计技巧和了解用户界面开发如何适应于整个软件过程，这一点是很重要的。这是一个事实，而不管开发技术是面向对象的、基于组件的或者甚至是过程化的。我发现以下技巧和技术，在我以前的 UI 原型开发中非常管用，希望这对您会有所帮助。

1 与真正的用户一起进行原型开发。
原型开发的最佳人选是那些以后将实际使用这些完成的应用的人员。正是这些人，从成功的实现中获得最多，也正是这些人，是真正知道自己需求的人。

2 使用原型开发工具。
对能使您快速地将屏幕集中在一起的原型开发工具进行投资。由于您可能不想保留编写的原型代码（快速编写的代码很少值得保留），如果原型开发工具生成一种与您准备开发的不同类型的代码，您不必过分担心。

3 让 SME 使用原型。
就象您在买车前想开一下来试车一样，在开发应用之前，您的用户应该能够试测一下该应用。此外，通过参与原型上机实验，他们可以快速地确定系统是否满足他们的要求。一个好的方法是请求他们象它是真的系统一样使用这个原型，来完成一些用例方案。

4 理解基础业务。
在开发原型之前，您需要理解原型将要支持的基础业务。换句话说，UI 原型要基于需求。越了解业务，就越有可能构建出支持该业务的原型。

5 不要在编写好的代码上花费大量的时间。
在原型开发过程之初，随着对业务了解的深入，会抛弃许多已做过的工作。所以，在可能不会保留的代码上花费大量的精力，往往是毫无意义的。

6 原型仅仅表示您实际上构建的功能。
如果没有可能交付该功能，那么就不要进行原型开发。
让界面专家来帮助您设计。用户界面专家知道如何开发易于使用的界面，而您有可能在这方面不擅长。如果您从来没有上过有关人类因素方面的课程，那最好把 UI 原型开发留给这方面的专家来做。

7 解释原型是什么。
关于 UI 原型开发，开发人员最常见的抱怨是当他们的用户说，“非常好，今天下午安装它。”发生这种情况是由于用户没有认识到在这一点上需要在系统上耗费几个月的时间。发生这种情况的原因很简单：从用户的观点来看，一个功能齐全的应用是由菜单紧密相连的一组屏幕和报告。遗憾的是，这确实是原型看起来的样子。为了避免这种问题，您应该指出原型就象建筑师建造的用来描述房屋设计的泡沫塑料模型一样。它不是工作模型。

8尽可能地避免实现决策。
在如何命名这些用户界面项时，要小心谨慎。要努力做到使名称保持一般性，所以不要暗示太多有关实现技术。例如，在用例中，我不愿意使用“ UI23 Security Login Screen”这样的名称，因为它暗示我想用图形用户界面（GUI）技术来实现这个主要的 UI 项。我喜欢用“UI23 Security Login”这样的名称，它不会暗示任何类型的实现技术。

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-12-1 10:10:02
编辑这个贴子 鲜花(0) 鸡蛋(0)
小平 美女呀，离线，快来找我吧！

等级：活跃分子
文章：320
积分：593
注册：2003-7-28
第2楼
发贴心情
用户界面原型是由我们来做的吗？还是由程序员来做呀？我们公司好像都是程序员来做的。

----------------------------------------------
!@! # $ %| ^-^ &!& *!* (!) ^_+

点击查看用户来源及管理<br>发贴IP：61.51.109.198 2003-12-1 11:14:12
编辑这个贴子
小林 美女呀，离线，快来找我吧！

等级：版主
文章：342
积分：601
注册：2003-6-12
给小林发送一个短消息 把小林加入好友 查看小林的个人资料 搜索小林在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给小林 OICQ 访问小林的主页 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
前期的有我们来做。
属于设计阶段的工具。

----------------------------------------------
/○\
/■\ Human Factors makes the world easy and simple.
<|

点击查看用户来源及管理<br>发贴IP：61.175.193.152 2003-12-1 11:15:19
编辑这个贴子
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第4楼
发贴心情
以前讲过，用户原型分低保真、中保真和高保真三种。

初步设计低保真交互原型，可根据需要画出简单交互图，经项目组讨论确定大体方案，我们主导；

在初步交互方案确定的基础上，创建更高级交互原型，使用快速开发工具或多媒体制作工具，设计并制作详细交互原型。其原型达到的标准应能够完整展示软件全部或部分主要功能的操作方式，且准确模拟用户实际使用的操作方式。其中，原型的目的是为了采取由用户参与评估和测试的方法，向设计人员和程序员提供有关UI设计的重要依据。

高保真基本上是我们的产品了，需要程序员负责大部分的实现，但交互依然是我们主导。

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-12-1 12:07:46
编辑这个贴子

本主题贴数4，分页： [1]
*快速回复：用户界面原型开发：技巧和技术
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：343.750毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：[转帖]用户界面设计-西门子技术部用户界面设计中心

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：[转帖]用户界面设计-西门子技术部用户界面设计中心

您是本帖的第 167 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： [转帖]用户界面设计-西门子技术部用户界面设计中心
blackeyes 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：16
积分：86
注册：2003-3-6
楼顶
发贴心情 [转帖]用户界面设计-西门子技术部用户界面设计中心
用户界面设计-西门子技术部用户界面设计中心

    用户界面对大多数计算机使用者而言，就是人和计算机进行沟通的载体。我们常说的一个软件对用户是否友好、是否体贴用户指的就是用户界面这个问题。人性化的设计是计算机软件工程的重要指标，因为软件最终是要服务于用户，用户是我们设计的中心。国际上用户界面的设计已经形成了一套标准，ISO9241中对此有非常明确的规定。西门子做为一个跨国大公司非常重视产品的用户界面，因为它是用户对产品的最直接印象。为此西门子按照ISO9241标准，分别在德国慕尼黑、美国普林斯顿和中国北京设立了三个用户界面设计中心，使西门子的产品更加适合用户的需求，提高产品的竞争力。

    用户界面设计在产品开发过程中扮演着重要的角色 ；然而我们发现国内的许多开发者还停留在很不科学的阶段，普遍错误做法是：首先发现某一领域有产品空缺—立项，然后往往不经过周密的市场调查就匆匆上马—抢占市场，不过经常是到了开发的后期甚至于直到产品进入市场才发现最初的想法并不切合实际，即使打“补丁”也都为时以晚，而且还会引起竞争者的注目。

按此在新窗口浏览图片
    图1

    我们可以这样说，能否开发出成功的产品与是否注重市场和用户成正比。表1就列出了产品开发过程中由于更改所带来的成本比例。我们可以看出，及早进行深入的用户研究对整个产品开发是多么重要，不然，根据我们界面设计中心开发产品的经验，到了项目后期，功能上的更改将造成巨大的损失—可能占到项目预算的30％左右。尽管很多国内的开发者虽然也做市场调研，也做用户研究，但是在何时以何种规模进行，得到的结果如何应用于产品，如何控制成本等都是非常具体细致的问题。从一定意义上说一个软件用户界面的好坏其实根本上反映了开发者对用户的了解深度，而这直接决定了一个产品是否能够最终赢得用户、赢得市场。

    科学的产品研发过程是一个把技术与用户和市场紧密结合的过程。图1简要概括了西门子用户界面设计中心开发产品的流程，在所有环节中我们非常强调一点，就是面向用户的设计，用户始终是我们关注的焦点。在项目的开始阶段，做为开发者应该进行充分的市场调研和用户分析，研究用户的需求究竟在哪里，他们期待什么样的产品来满足他们的需求，以及相当关键的一点，他们愿意为这样的产品支付多少等等;以此为基础我们可以初步界定这个产品的功能模式以及分析技术实现的可行性 ；这样在项目的初期我们就对整个市场以及相关的风险有了非常感性的了解，这一阶段所获得的信息是指导之后各个阶段的总纲 ；西门子非常重视项目初期的用户市场研究，匆匆上马是万万不可取的，这样只会浪费时间，丧失稍纵即逝的市场机会，只有循序渐进的操作才能保证以最少的风险高效的达到目标—好的开始是成功的一半。接着进入原型设计阶段，一个成功的样品并非一蹴而就，它往往是不断改进的结果，在设计与再设计之间极其关键的一步是测试，除了必要的功能性测试之外这里更加强调的是研究用户对产品的接受程度，这也是国内很多开发者所普遍忽视的一点。有人可能会问，既然已经做了先期的用户市场调研，为何还要多此一举的做用户测试呢？其实道理很简单，因为设计者或者程序员所设想的和用户的真正想法有差别，有时甚至是大相径庭 ；而使用性测试保证了产品能够最终符合用户的期待。举一个很简单的例子，有一个软件的一个功能叫做“ISP配置”—设计人员大概认为他们的用户都是从事IT行业的。实际上一般的消费者很难搞明白“ISP设置”到底是什么东西；改进其实很简单—“服务商配置”就容易理解的多。只有经过反复测试的产品才是合格的高质量产品，才能获得客户的满意，西门子用户界面设计中心为使西门子产品当地化做了许多的测试，包括工业控制、医疗、交通、移动设备、家庭自动化等等；通过测试的产品西门子才可以放心的投入市场。

按此在新窗口浏览图片
    表1

    我们也积极帮助一些合作伙伴开发和测试产品。 开发者们在我们的实验室观察用户如何使用他们的产品后，所发出的感慨通常是 ：哦，原来用户是这样理解，这样使用的！

    总而言之，产品不是开发者意愿的体现，而应该是用户需求的体现，因为他们是产品的最终购买者和使用者。

    在上一期中我们对用户界面设计的概念及其在产品研发过程中的重要性作了简要阐述，并介绍了西门子用户界面设计中心所实践的科学的产品开发流程，它始终以用户为中心，奉行“面向用户的设计”理念，从而把技术与用户和市场紧密结合起来。

    优秀的用户界面设计是使产品赢得用户、赢得市场的基础，但如何判断用户界面设计的优劣呢？怎样的用户界面设计才能提高产品的市场竞争力呢？这里我们需要引入一个概念，即“使用性”的概念。使用性是一种关于用户和系统间相互作用的特殊性质，它描述的是“某产品在特定的使用环境中为特定的目标用户所使用，从而快速、有效、满意的完成特定任务的程度”(ISO9241第11章)。因此，用户界面的使用性决定着人机交互的效率和效果。一个具备较好使用性的用户界面能够让用户全神贯注于其正在进行的工作，而不是去注意他在使用什么操作界面和系统工具。

    随着计算机硬件、软件和网络产品的发展和更新换代，产品的使用性得到了越来越多的重视，甚至还逐渐延伸到了工业产品和生活用品的设计和生产领域。然而产品使用性的好坏已不能用“对用户是否友好”这个单一的、程式化的概念来概括，它是能用科学的方法进行测量和评估的。产品的使用性有着丰富的内涵，通常可归纳为五个方面，也可以说是衡量产品使用性的五个标准，即：

    可学性:简单易学，用户能很快开始工作;

    效率性:使用效率高，用户能高效率的工作;

    可记忆性:使用方法容易记忆，无需重新学习;

    容错性:错误率低，避免灾难性操作错误发生;

    满意度:用户能带着愉悦的心情去工作。

    由此可见，一个具备良好使用性的产品既应该满足用户方便而高效使用的需要，又应当拥有突出的情感吸引力和用户满意度，从而体现产品生产者对目标用户的关怀。

按此在新窗口浏览图片
    对使用性的研究可以追溯到早期西欧和美国的心理学家进行的劳动心理学和工程心理学的研究，当时他们强调的是劳动环境和工程技术设计对劳动者的影响。如今，使用性研究已经形成了一门跨专业的系统学科即使用性工程学，它涉及人体工效学、认知心理学、行为心理学、社会学、计算机科学、语言学、美学等众多独立的学科，贯穿于从了解用户需求到产品投放市场的整个产品开发过程。使用性研究在中国起步较晚，但是随着它在学术界和计算机相关产品及工业产品生产中的迅速传播和发展，已经带来了显著的经济效益，主要体现在:(1)销售量的增加和用户满意度的提高;(2)产品市场竞争力的增强;(3)产品开发和产品维护成本的降低;(4)用户工作效率的提高;(5)电话支持次数的减少;(6)培训成本的降低。

    作为较早开始进行使用性研究的企业之一，西门子公司已经把使用性作为一项战略性的产品策略。在产品开发过程中，根据用户需求分析和市场调研的结果做出产品原型并对其进行使用性评估，根据评估结果进行再设计、再评估，如此循环反复，最终获得的便是充分体现用户需求的高品质产品。

按此在新窗口浏览图片
    使用性检查和使用性测试是进行产品使用性评估的两种主要方法。使用性检查是由使用性工程师完成的。他们根据用户界面设计的基本原则和其个人对界面设计的认知程度，对被测产品/界面进行评估，针对使用性问题提出改进方案。而使用性测试是有用户参与的使用性评估，其目的是在产品投入市场之前让潜在的用户帮助产品研发人员发掘产品原型中的使用性问题，并了解其对于该产品/界面的整体印象和改进建议。

    对于企业管理层、产品研发部门和市场及销售部门来说，使用性测试为他们提供了一个直接观察用户、获得用户对产品反馈的宝贵机会，这些直接影响着他们对产品开发的决策。大量个案研究证明，通过对5－6个目标用户的测试便可以发现75％以上的使用性问题。左图清楚的表明了参加测试的用户数量与发现使用性问题多少的比例关系。我们可以看出，参加测试的用户代表不是越多越好，因为随着参加测试用户的增加，每一个新用户所发现的新的使用性问题数量在逐渐减少，这为我们安排测试时间和控制测试成本提供了参考。

    西门子使用性实验室是完全按照ISO9241标准建立起来的，装配有完备的使用性测试设备，自成立以来已经为众多网络产品、软硬件产品和工业产品进行了使用性检查/测试。事实证明，只有经过科学的用户研究和使用性评估的产品才能具备强大的市场竞争力，赢得目标用户群体的青睐。

    联系人：周卫博士

    电话：(010)64721888-3517

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-7 13:38:29
编辑这个贴子 鲜花(0) 鸡蛋(0)
eworker 美女呀，离线，快来找我吧！

等级：实习版主
文章：1863
积分：2665
注册：2003-7-17
第2楼
发贴心情
马上存档……

----------------------------------------------
批评是对我最大的帮助。
http://www.chinaui.com/bbs/list.asp?boardid=12

点击查看用户来源及管理<br>发贴IP：159.226.83.133 2003-11-7 13:48:15
编辑这个贴子
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
ui涉及到的领域真的是太广啦！无止境学习中！

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.91.206 2003-11-17 12:56:43
编辑这个贴子

本主题贴数3，分页： [1]
*快速回复：[转帖]用户界面设计-西门子技术部用户界面设计中心
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：4,062.500毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：献丑，3年前毕业论文的翻译部分.

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：献丑，3年前毕业论文的翻译部分.

您是本帖的第 121 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 献丑，3年前毕业论文的翻译部分.
pi1ot 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：4
积分：12
注册：2003-12-9
楼顶
发贴心情 献丑，3年前毕业论文的翻译部分.
我记得程序员杂志发表过一个更完整的版本.

用户界面设计提示与技巧（节选）
AmbySoft Inc. 白皮书
Scott W. Ambler
资深面向对象设计顾问
AmbySoft Inc.
本部分包括了有助于程序员进行面向对象的用户界面设计的一系列技巧。
1. 一致性，一致性，一致性！必须保证用户界面的一致性，这是最重要的。如果你可以通过在某个列表框里双击其中一个条目来触发一个事件，那你必须保证在所有的列表框里双击条目都会产生相似的反应。所有窗口里的按钮都应该放在同一个位置，按钮标题与提示的措辞应保持一致，还应保持一致的色彩设置。一致的用户界面会使得使用者建立起关于应用程序工作流程的正确理解，而用户对应用程序工作流程的正确理解会带来更低的训练与支持费用。
2. 制订并严格遵守标准。使得你能够真正的保持一致性原则的唯一一个解决办法是制订一个用户界面设计标准并严格遵守。最好的办法是遵循当前的行业标准，同时根据你个人的应用程序的特殊需要不断的加以增添和完善。行业标准，例如IBM（1993）与Microsoft（1995）指定的用户界面设计规范可以满足一般用户界面设计者95%-99%的需要。采用行业标准不仅可以吸收同行的优秀建议，而且可以更容易的使你的应用程序用户界面与最终用户已经使用或者购买的其他同类软件产品的用户界面保持近似。
3. 更简单的解释你的规则。你的软件用户需要知道如何使用你为他们提供的软件产品。如果你的应用程序界面严格遵守一致性原则的话某个界面使用规则你只需要解释一遍，这比一步又一步的向用户解释每一个使用环节的每一个使用方法要简单的多。
4. 为初学者与专家都提供足够的支持。虽然一个图书目录能为一个随意的浏览者提供足够的图书馆藏书信息，但这不是最有效的为专业用户以及图书馆员提供服务的方法。图书馆员是经过专业训练的能够熟练运用复杂的信息检索系统在图书馆里查阅信息的人员。这意味着你必须为专业人员准备一套更复杂但功能更强大的搜索手段来满足他们的特殊需要。
5. 在窗口之间进行导航与指引是非常重要的。如果从一个窗口进入到另一个窗口变得很困难或者复杂，你的用户会有强烈的失败感并放弃使用软件。用户会试图尽量使得自己的工作流程与界面转接流程合拍，如果用户成功的做到这一点的话就会觉得在使用你的应用程序时非常顺手。但必须注意，不同的使用者有不同的工作流程，你的界面转接流程必须足够灵活以适应各种不同的用户习惯与需求。界面流程图可以很方便的用来设计并实现一个优秀的用户界面窗口转接流程。
6. 在一个窗口中的使用导引也非常重要。西方人的阅读习惯是从左到右，由上至下。因为人们已对此习以为常所以你在界面设计中必须遵循从左到右，由上至下的原则。如果你将窗口中的控件元素以令人舒适的顺序加以组织的话用户在使用中会对界面产生一种亲切感。
7. 适当的用户界面的标签与消息内容措辞。显示在用户界面上的文字是你的用户了解当前系统状态的最主要也是最重要的信息来源。拙劣的措辞在用户看来只会导致拙劣的用户界面。使用完整的词语与句子，尽量不采用缩写的短语与代码可以使你的信息被更好的理解。信息的语气必须是确定的，暗示用户一切都处于控制之中，同时保证使用户得知如何进行下一步动作。例如下列信息：“你输入了错误的信息”或者“账号长度必须为8位”。而且，提示信息必须保持一致的措辞以及显示位置的一致性。虽然“必须输入用户名”、“应该输入账号”的措辞分开来看没有问题，但它们没有保持一致。因此，如果以第一句为标准的话，第二句应改为“必须输入账号”来保持措辞的一致性。
8. 理解每一个控件。你必须保证使用正确的控件来完成某个特定的任务，这有助于增强用户界面的一致性与第一次使用该应用软件时的简易性。保证正确的使用每一个控件的唯一方法就是熟悉并且理解你所采用的用户界面设计标准与特点。
9. 仔仔细细的观察别的应用软件用户界面。除非你确定别的应用软件用户界面设计与你的项目遵循同一个标准。绝对不能事先在潜意识中认为另外的应用软件用户界面设计是正确的。虽然通过观察别的用户界面设计来吸取设计灵感与思想是个好办法，但在你能够保证自己拥有判断一个优秀的用户界面与一个拙劣的用户界面之间的区别之前不要这么做。已经有很多的开发者与设计者错误的模仿了某些后来证明是不正确的用户界面设计思想。
10. 适当的使用色彩。必须加以控制的使用色彩，如果你在某一处使用了色彩来表达信息的话就必须保证用户还可以从别的方面获得同样的信息，因为很有可能你的软件用户是一个色盲。如果你使用高亮色来突出屏幕上的某个信息，你就必须同时使用一种别的手段来保证色盲用户也能正确的注意到这个信息，比如在画面上显示一个提示符号。使用色彩同样要求保持严格的一致性以保证用户界面的一致性。另外，在不同的平台之间很难保证一致的色彩表现，在一个系统上表现不错的色彩设计在另一个系统上很可能表现很糟糕。我们经常在一些会议上听到某些人说“在我家里的机器上看起来很不错的。”
11. 遵循色彩对比度规则。如果你决定在界面上使用色彩你就必须保证在各种可能情况下窗口文本的可读性。最好的解决办法是遵循色彩对比度规则：即在浅色背景上显示深色文本或者在深色背景上显示浅色文本。阅读白色背景上的蓝色文本非常轻松但红色背景与蓝色文本搭配就不是那么令人舒适了，因为红色与蓝色没有足够的对比度来保证文本的可读性，而白色与蓝色就有足够的对比度。
12. 使用适当的字体。古体字如果出现在威廉·莎士比亚的剧本封面上看起来确实很不错，但如果显示在屏幕上就会使用户阅读起来很困难。使用容易阅读的字体，例如Times Roman等印刷字体。另外在使用字体时应该很小心的保持一致性。一个使用了两到三种不同字体效果的窗口比使用了五、六种字体的窗口看起来要舒服的多。记住当你每一次改动字体的大小、类型（粗体、斜体、下划线、……）、字体、颜色时你实际上都是在使用另一种不同的字体。
13. 禁止使用，而不是不显示。你会发现在某一个特定的时候无法为你的用户提供应用程序的所有功能，例如在用户删除一个条目之前必须先选择一个条目，而在选择一个条目之前删除功能是无法使用的。这时（在选择一个条目之前）是禁止使用删除按钮还是根本不显示删除按钮？答案是前者。在一个控件无法使用时禁止它会使你的用户建立对你的软件产品的工作流程的准确理解。如果你不显示该控件的话就会增加用户对软件产品工作流程建立准确的理解的难度，因为用户现在只知道什么是可用的，而不知道什么是不可用的。这时那句古老的格言“Out of sight is out of mind”就显得很有道理。
14. 使用非破坏性功能的默认按钮。一般每一个窗口都有一个默认的按钮，当用户按下回车键时就相当于按下该按钮。问题是用户偶尔会因为无意按下回车键而使得该默认按钮生效。因此必须保证默认的按钮功能不存在潜在的破坏性，比如删除或者保存（因为用户这时候很可能并不想保存）。
15. 区域的组织排列。当一个窗口有一个以上的输入框控件的时候，如果你加以组织排列的话窗口看起来会很吸引人并且提高了用户的工作效率。正如第一节所述，左对齐是最好的控件排列方法，也就是说所有输入控件的左边界处于同一条竖直线并一个一个的从上到下排列起来。同时每个输入控件相应的标签以右对齐的方式位于输入控件的左边。这是组织窗口区域的最简单而有效的方式。
16. 对齐数据。一般来说一列数据应以下列方式对齐：整形数右对齐，浮点数以小数点为基准对齐，字符串左对齐。
17. 不要把窗口塞的过于拥挤。拥挤的窗口非常难于理解并且难于使用。试验结果表明（Mayhew，1992）整体窗口布局的密度不应大于40%，局部密度不应该大于62%。
18. 将窗口元素加以有效的分组。逻辑上有关联的条目应该放到一起以表明它们在逻辑上的关联性，相互毫无关系的条目则应该分开。你可以用空白区域将它们分开，也可以使用箱型控件分别加以包括以达到分组的目的。
19. 当前要处理的窗口应该显示在用户关心的地方。当你的用户通过双击一个对象来显示其编辑/细节窗口时他（或她）的注意力都被集中到了这一点。因此接下来显示的窗口也应该显示在这一区域而不是别的什么地方。
20. 弹出菜单不应该是用来调用软件功能的唯一手段。如果你隐藏了软件产品的主要功能的话用户是不会试图自己去发掘它们的。开发者最容易犯的错误就是滥用弹出菜单，也叫上下文相关菜单。一般来说当用户使用鼠标在屏幕上显示弹出菜单时该菜单内容应该只与用户当前点击区域的内容有关。

点击查看用户来源及管理<br>发贴IP：219.234.217.100 2003-12-9 17:02:28
编辑这个贴子 鲜花(0) 鸡蛋(0)
pi1ot 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：4
积分：12
注册：2003-12-9
第2楼
发贴心情 原文
附录2 文献翻译(原文)
User Interface Design Tips and Techniques (Part)
AmbySoft Inc. White Paper
Scott W. Ambler
Senior Object-Oriented Consultant
AmbySoft Inc.
In this section we will cover a series of user interface design tips that will help you to improve the object-oriented interfaces that you create.
1. Consistency, consistency, consistency. The most important thing that you can possibly do is make sure that your user interface works consistently. If you can double-click on items in one list and have something happen then you should be able to double-click on items in any other list and have the same sort of thing happen. Put your buttons in consistent places on all of your windows, use the same wording in labels and messages, and use a consistent color scheme throughout. Consistency in your user interface allows your users to build an accurate mental model of the way that it works, and accurate mental models lead to lower training and support costs.
2. Set standards and stick to them. The only way that you’ll be able to ensure consistency within your application is to set design standards and then stick to them. The best approach is to adopt an industry standard and then fill any missing guidelines that are specific to your needs. Industry standards, such as the ones set by IBM (1993) and Microsoft (1995), will often define 95%-99% of what you need. By adopting industry standards you not only take advantage of the work of others you also increase the chance that your application will look and feel like other applications that your users purchase or have built.
3. Explain the rules. Your users need to know how to work with the application that you built for them. When an application works consistently it means you only have to explain the rules once. This is a lot easier than explaining in detail exactly how to use each and every feature in an application step by step.
4. Support both novices and experts. Although a library-catalog metaphor might be appropriate for casual users of a library system, library patrons, it probably is not all that effective for expert users, librarians. Librarians are highly trained people who are able to use complex search systems to find information in a library, therefore you should consider building a set of search screens to support their unique needs.
5. Navigation between screens is important. If it is difficult to get from one screen to another then your users will quickly become frustrated and give up. When the flow between screens matches the flow of the work that the user is trying to accomplish, then your application will make sense to your users. Because different users work in different ways, your system will need to be flexible enough to support their various approaches. Interface-flow diagrams can be used during the Model Stage (Ambler, 1998b) to model the flow between screens.
6. Navigation within a screen is important. In Western societies people read left to right and top to bottom. Because people are used to this should you design screens that are also organized left to right and top to bottom. You want to organize navigation between widgets on your screen in a manner that users will find familiar to them.
7. Word your messages and labels appropriately. The text that you display on your screens is a primary source of information for your users. If your text is worded poorly then your interface will be perceived poorly by your users. Using full words and sentences, as opposed to abbreviations and codes makes your text easier to understand. Your messages should be worded positively, imply that the user is in control, and provide insight into how to use the application properly. For example, which message do you find more appealing “You have input the wrong information” or “An account number should be 8 digits in length.”? Furthermore, your messages should be worded consistently and displayed in a consistent place on the screen. Although the messages “The person’s first name must be input.” and “An account number should be input.” are separately worded well, together they are inconsistent. In light of the first message, a better wording of the second message would be “The account number must be input” to make the two messages consistent.
8. Understand your widgets. You should use the right widget for the right task, helping to increase the consistency in your application and probably making it easier to build the application in the first place. The only way that you can learn how to use widgets properly is to read and understand the user-interface standards and guidelines that your organization has adopted.
9. Look at other applications with a grain of salt. Unless you know that another application follows the user-interface standards and guidelines of your organization, you must not assume that the application is doing things right. Although it is always a good idea to look at the work of others to get ideas, until you know how to distinguish between good user-interface design and bad user-interface design you have to be careful. Too many developers make the mistake of imitating the user interface of another application that was poorly designed.
10. Use color appropriately. Color should be used sparingly in your applications, and if you do use it you must also use a secondary indicator. The problem is that some of your users may be color blind – if you are using color to highlight something on a screen then you need to do something else to make it stand out if you want these people to notice it, such as display a symbol beside it. You also want to use colors in your application consistently so that you have a common look and feel throughout your application. Also, color generally does not port well between platform – what looks good on one system often looks poor on another system. We have all been to presentations where the presenter said “it looks good on my machine at home.”
11. Follow the contrast rule. If you are going to use color in your application you need to ensure that your screens are still readable. The best way to do this is to follow the contrast rule: Use dark text on light backgrounds and light text on dark backgrounds. It is very easy to read blue text on a white background but very difficult to read blue text on a red background. The problem is that there is not enough contrast between blue and red to make it easy to read, whereas there is a lot of contrast between blue and white.
12. Use fonts appropriately – Old English fonts might look good on the covers of William Shakespeare’s plays, but they are really hard to read on a screen. Use fonts that are easy to read, such as serif fonts like Times Roman. Furthermore, use your fonts consistently and sparingly. A screen using two or three fonts effectively looks a lot better than a screen that uses five or six. Never forget that you are using a different font every time you change the size, style (bold, italics, underlining, ...), typeface, or color.
13. Gray things out, do not remove them. You often find that at certain times it is not applicable to give your users access to all the functionality of an application. You need to select an object before you can delete it, so to reinforce your mental model the application should do something with the Delete button and/or menu item. Should the button be removed or grayed out? Gray it out, never remove it. By graying things out when they shouldn’t be used people can start building an accurate mental model as to how your application works. If you simply remove a widget or menu item instead of graying it out then it is much more difficult for your users to build an accurate mental model because they only know what is currently available to them, and not what is not available. The old adage that out of sight is out of mind is directly applicable here.
14. Use non destructive default buttons. It is quite common to define a default button on every screen, the button that gets invoked if the user presses the Return/Enter key. The problem is that sometimes people will accidentally hit the Enter/Return key when they do not mean to, consequently invoking the default button. Your default button shouldn’t be something that is potentially destructive, such as delete or save (perhaps your user really did not want to save the object at that moment).
15. Alignment of fields. When a screen has more than one editing field you want to organize the fields in a way that is both visually appealing and efficient. As shown in Figure 1 I have always found that the best way to do so is to left-justify edit fields, or in other words make the left-hand side of each edit field line up in a straight line, one over the other. The corresponding labels should be right justified and placed immediately beside the field. This is a clean and efficient way to organize the fields on a screen.
16. Justify data appropriately. For columns of data it is common practice to right justify integers, decimal align floating point numbers, and left justify strings.
17. Do not create busy screens. Crowded screens are difficult to understand and hence are difficult to use. Experimental results (Mayhew, 1992) show that the overall density of the screen should not exceed 40%, whereas local density within groupings shouldn’t exceed 62%.
18. Group things on the screen effectively. Items that are logically connected should be grouped together on the screen to communicate that they are connected, whereas items that have nothing to do with each other should be separated. You can use whitespace between collections of items to group them and/or you can put boxes around them to accomplish the same thing.
19. Open windows in the center of the action. When your user double-clicks on an object to display its edit/detail screen then his or her attention is on that spot. Therefore it makes sense to open the window in that spot, not somewhere else.
20. Pop-up menus should not be the only source of functionality. Your users cannot learn how to use your application if you hide major functionality from them. One of the most frustrating practices of developers is to misuse pop-up, also called context-sensitive, menus. Typically there is a way to use the mouse on your computer to display a hidden pop-up menu that provides access to functionality that is specific to the area of the screen that you are currently working in.
点击查看用户来源及管理<br>发贴IP：219.234.217.100 2003-12-9 17:03:18
编辑这个贴子
qnzu 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：14
积分：83
注册：2003-7-22
第3楼
发贴心情
ding
点击查看用户来源及管理<br>发贴IP：202.103.207.72 2003-12-17 19:47:08
编辑这个贴子
eworker 美女呀，离线，快来找我吧！

等级：实习版主
文章：1863
积分：2665
注册：2003-7-17
第4楼
发贴心情
不错，翻译很辛苦啊，谢了。

----------------------------------------------
批评是对我最大的帮助。
http://www.chinaui.com/bbs/list.asp?boardid=12

点击查看用户来源及管理<br>发贴IP：159.226.83.35 2003-12-18 11:16:51
编辑这个贴子

本主题贴数4，分页： [1]
*快速回复：献丑，3年前毕业论文的翻译部分.
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：671.875毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：编程应该考虑的程序界面和易用性的问题【转贴】

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：编程应该考虑的程序界面和易用性的问题【转贴】

您是本帖的第 83 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 编程应该考虑的程序界面和易用性的问题【转贴】
jiliy 帅哥哟，离线，有人找我吗？

等级：高级会员
文章：389
积分：546
注册：2003-3-4
楼顶
发贴心情 编程应该考虑的程序界面和易用性的问题【转贴】
这篇文章是一位程序员写的在编程时应考虑的关于界面和易用性的问题。虽然没有易用性工程师和UI人员写的那么专业，但是都是作者的积累的经验的总结。

－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－
编程应该考虑的程序界面和易用性的问题 wangledong（原作） （转 [image] http://www.csdn.net/）

关键字 界面 BCB C++Builder

编程应该考虑的程序界面和易用性的问题

一个非常成功的程序，除了它有强大或专业的功能外，无一例外的都有友好的界面和易于操作的特点。怎样做到界面有好和易于操作就是我们要讨论的。

一、 界面要美观，
一个程序不能以完成基本的要求为目的，在完成功能的前提下，对程序界面要进行合理的布局，一般来说主菜单在最程序的最上面，下面是工具栏，其余的空间作为客户区。
A、主菜单的设置
主菜单的标题不要过长，一般以2-4字为宜，通常为2个字，同时为标题设定一个快捷键，一般以标题的英文的第一个字母为快捷键，通常设定为快捷键的字母为大写。如果主菜单个数太少，出于美观考虑可以给菜单项加入图标，在美观的同时增加了主菜单的长度。菜单的个数不能超过窗体宽度，否则菜单将折行显示。影响界面效果。
对下拉菜单应适当的加入图标来进行美化，但不要对每个选项都加入图标，密密麻麻的反而不好，图标只是一个点缀作用。下面是我作的程序的菜单大家参考一下（不好意思，好像在夸我一样^_^）
B、对工具栏的设置
工具栏根据需要可以选用ToolBar或Panel加SpeedButton来实现，用ToolBar的好处是方便，但如果将ShowCaption设为True则不能调整按钮的大小。用Panel加SpeedButton则方便的多，缺点是你需要多写一些代码。这里我着重说说用SpeedButton作工具按钮。SpeedButton有个Flat属性，当把它设为True的时候，当鼠标经过的时候按钮会浮起来，利用这一点，如果把SpeedButton的Transparent属性设为True的话（默认是True）如果在SpeedButton的下面放一个和SpeedButton一样大小的图片，在鼠标移动到按钮上的时候，按钮就会把图片的边框遮住，这样就可以很简单的实现一种比较漂亮的按钮，下图就是采用这种方式实现的按钮，最后一个是鼠标经过时的效果。
SpeedBtton还有个属性是Glyph它可以加入一个位图，如果位图的宽和高不相等，它
将位图自动分割为宽高相等的几个图片，SpeedButton默认会自动处理4个连在一起的
图片，如高度是16宽度是64的位图，SpeedButton会自动将它分为4个图片，默认时
SpeedButton显示第一幅图，当不可用的时候显示第二幅，当鼠标单击的时候显示第三
幅，当按钮按下的时候显示第四幅。值的一提的是如果你只用一幅图片，当按钮不可用
的时候SpeedButton会自动把这幅图的边界变灰，这样就要求你用的这幅图片有个黑色
的边界，不然当按钮不可用的时候，图片就看不到了，或看不全。建议至少为每个
SpeedButton作两幅图，一个正常的，一个不可用的。
C、字体的设置
在中文Windows下，宋体9号字是标准字体，不要为了美观而采用一些特殊的字体，
你要考虑到用户的计算机上也许没用你的这种字体，在设置字体的时候，建议采用宋体
9号字，才用BCB5编程的时候要注意，BCB默认的字系是西方，在2000下编程设置字
体的时候，如果你要设置为宋体9号字，你不要忘了把这个字系改为GB2312_CHARSET，
不然你的程序在98下运行会很难看。
D、控件的设置
在设计窗体的时候，要考虑当窗体大小变化的情况，应该让用户在调整窗体大小的
时候不影响正常的使用，如在标准界面下按钮可用而且位置适当，可是如果用户把窗体
调小的时候呢？如果你的按钮不随窗体的大小而变化的话，按钮就有可能看不到的，这
显然是不可以的。实现这一功能的最简单的方法是使用Panel控件，通过设置Panel控
件的Align属性来实现这一功能。
二、 操作符合大部分人的习惯
编写软件的目的是给别人用，那么这就要求这个程序不但你用着舒服，而且让别人
使用起来也很容易上手，这样才能让用户喜欢用你的软件。如按ESC键退出，Enter键
确认，光标键移动等。一些常用的按钮应该象Windows的一些程序那样，如应用、确定、
取消、退出，这些按钮应该尽可能的放在窗体的右下方，不要为了你的界面安排，将退
出按钮放到窗体的上方，我就遇到这样一个程序，我想退出了，确让我找了半天的退出
按钮。测试这一点的最好方法就是让别人来用你的软件，听听他们的意见。
三、 不要给用户太多的局限
我们编写的程序要尽量的为用户考虑，如你不能因为窗体上的控件不好摆，你就把
窗体设为不可调整大小，不要因为自己的方便便要求用户必须用多少多少的分辨率，多
少多少的色彩等，应该考虑最大多数的需求。可以有用户来设置的，就由用户来设置。
让用户感觉用这个软件很随便，这才识目的。
四、 尽量简化用户的操作
对于功能比较一个单一却很常用操作，应该尽量为它设置快捷键或在工具栏上添加
它的按钮，不要让用户到一层一层的菜单里面去找。对于由程序可以实现的判断尽量由
程序来完成，如用户录入数据的时候，当用户输入完一项的时候，程序应能自动进入到
下一项，二不需要用户手工去干预它。

上面是我编程的一些经验的总结，希望大家能够少走一些弯路，我说的也不全面，权当一个抛砖引玉的作用，希望大家能够多多总结经验，多多交流，共同进步！

----------------------------------------------
他说，经商其实不用很多技巧，只要坚定自己的信心，把事情做得最好，做得到位，就能成功。他很欣赏三宅一生说的一句话：“做我喜欢的东西，让别人去接受。”他把这句话转作“让我做菜，你就得接受这个味。”他认为这样的态度是从根本上考虑，从长远考虑。只有干自己擅长的事，坚持专业精神，才能够把东西做到极致。有很多设计师迫于生存，牺牲掉专业的东西，这样就永远没有自己的风格。

点击查看用户来源及管理<br>发贴IP：218.246.32.115 2003-11-4 16:22:02
编辑这个贴子 鲜花(0) 鸡蛋(0)
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
看来看去大多还是UI设计应该做的东西，
我们可以不急于承担全部这些工作，可以多和编程人员讨论、学习，毕竟中国的UI起步前，一直是由编程人员兼顾的。

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-4 17:58:46
编辑这个贴子

本主题贴数2，分页： [1]
*快速回复：编程应该考虑的程序界面和易用性的问题【转贴】
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：375.000毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：给UI新手的－－UI开发的流程是什么样的

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：给UI新手的－－UI开发的流程是什么样的

您是本帖的第 443 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 给UI新手的－－UI开发的流程是什么样的
jiliy 帅哥哟，离线，有人找我吗？

等级：高级会员
文章：389
积分：546
注册：2003-3-4
楼顶
发贴心情 给UI新手的－－UI开发的流程是什么样的
首先要知道软件的原型开发方法，我们只有了解了软件开发过程的各个阶段，才能比较清楚的了解UI的开发流程中要做的工作。开发方法也可以用于人机交互部分的开发，这时必须把与交互界面以及系统使用性能的相关内容结合到系统分析、设计和评估中，典型的人机交互部分的开发生命周期。

生存周期 主要任务 主要文档
－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－
可行性研究与计划 查用户界面要求和环境 可行性报告（交互部分）
－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－
需求分析 用户特性分析；任务分析； 交互规格需要说明；
交互建立模型 交互形式语言定义
－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－
概要设计 任务设计；环境设计 概要设计说明
－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－
详细设计 交互类型设计；交互设计 交互设计说明；
交互显示布局设计 交互设计准则 －－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－
原型建立与实现 帮助出错信息设计； 帮助和错误信息设计说明；
原型设计 原型系统说明
－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－
集成测试 交互测试和评估 交互测试和评估报告
确认测试
－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－
运行和维护 对修改要求进行评价； 运行记录；
对程序修改扩充； 软件问题报告；
修改有关文档 软件修改报告

这是自己的一点点总结，望补充～～

----------------------------------------------
他说，经商其实不用很多技巧，只要坚定自己的信心，把事情做得最好，做得到位，就能成功。他很欣赏三宅一生说的一句话：“做我喜欢的东西，让别人去接受。”他把这句话转作“让我做菜，你就得接受这个味。”他认为这样的态度是从根本上考虑，从长远考虑。只有干自己擅长的事，坚持专业精神，才能够把东西做到极致。有很多设计师迫于生存，牺牲掉专业的东西，这样就永远没有自己的风格。

点击查看用户来源及管理<br>发贴IP：218.246.32.115 2003-10-20 18:38:33
编辑这个贴子 鲜花(0) 鸡蛋(0)
小平 美女呀，离线，快来找我吧！

等级：活跃分子
文章：320
积分：593
注册：2003-7-28
第2楼
发贴心情
谢谢Jiliy！

----------------------------------------------
!@! # $ %| ^-^ &!& *!* (!) ^_+

点击查看用户来源及管理<br>发贴IP：61.51.108.228 2003-10-20 19:06:20
编辑这个贴子
泪染霜林 帅哥哟，离线，有人找我吗？ 白羊座1985-4-13

等级：初级用户
文章：2
积分：52
注册：2003-10-20
给泪染霜林发送一个短消息 把泪染霜林加入好友 查看泪染霜林的个人资料 搜索泪染霜林在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给泪染霜林 OICQ 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
挺有帮助，但暂时用不着。。。

----------------------------------------------
十八周岁以下的青少年请在父母的正确指导之下与本人聊天。

点击查看用户来源及管理<br>发贴IP：61.141.56.3 2003-10-20 21:21:33
编辑这个贴子
阿U 帅哥哟，离线，有人找我吗？ 处女座1983-9-1

等级：高级会员
文章：1052
积分：2135
注册：2003-6-27
给阿U发送一个短消息 把阿U加入好友 查看阿U的个人资料 搜索阿U在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给阿U OICQ 访问阿U的主页 引用回复这个贴子 回复这个贴子 第4楼
发贴心情
好久不见了哟~！

----------------------------------------------
－= 相信自己，创造自己，比证明自己更重要 ！=－
----------------------------------------------
My Web [image] http://liangbin.go.nease.net/
┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄

点击查看用户来源及管理<br>发贴IP：202.104.104.85 2003-10-20 22:21:06
编辑这个贴子
jiliy 帅哥哟，离线，有人找我吗？

等级：高级会员
文章：389
积分：546
注册：2003-3-4
第5楼
发贴心情
这个表画的有点乱，见谅了～～

----------------------------------------------
他说，经商其实不用很多技巧，只要坚定自己的信心，把事情做得最好，做得到位，就能成功。他很欣赏三宅一生说的一句话：“做我喜欢的东西，让别人去接受。”他把这句话转作“让我做菜，你就得接受这个味。”他认为这样的态度是从根本上考虑，从长远考虑。只有干自己擅长的事，坚持专业精神，才能够把东西做到极致。有很多设计师迫于生存，牺牲掉专业的东西，这样就永远没有自己的风格。

点击查看用户来源及管理<br>发贴IP：218.246.32.115 2003-10-21 9:18:24
编辑这个贴子
村里的猫 帅哥哟，离线，有人找我吗？ 双子座1981-5-24

头衔：村长
等级：高级会员
文章：967
积分：1344
注册：2003-6-19
给村里的猫发送一个短消息 把村里的猫加入好友 查看村里的猫的个人资料 搜索村里的猫在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给村里的猫 OICQ 访问村里的猫的主页 引用回复这个贴子 回复这个贴子 第6楼
发贴心情
顶。。。好东西。收了。。。好久不见你了。

----------------------------------------------
---- 个人意见。仅供参考 -----
全力支持chinaui及ui事业
--------------------------------------
http://wodessnh.51.net/

点击查看用户来源及管理<br>发贴IP：218.18.128.130 2003-10-21 9:39:00
编辑这个贴子
shupeichong 帅哥哟，在线，有人找我吗？

等级：初级用户
文章：151
积分：300
注册：2003-6-23
第7楼
发贴心情
好东西，呵呵，还有一点点的问题，

就是一般在概要设计的时候就需要有一些界面模型和必要摸板的提供了，这样的工作更有利于概要设计的验收。

点击查看用户来源及管理<br>发贴IP：219.234.32.69 2003-10-21 10:51:21
编辑这个贴子
yu 美女呀，离线，快来找我吧！

等级：初级用户
文章：68
积分：221
注册：2003-7-30
第8楼
发贴心情
好东东，谢谢您
点击查看用户来源及管理<br>发贴IP：61.185.214.98 2003-10-21 11:04:19
编辑这个贴子
粗线条 帅哥哟，在线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第9楼
发贴心情
可以~~以此作参考！但由于工作的环境和开发的环境不同~~也未必都按照这个程序！有协议项目为主的软件开发~~就常常舍去原型设计这块~

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.95.152 2003-10-21 11:17:18
编辑这个贴子
jiliy 帅哥哟，离线，有人找我吗？

等级：高级会员
文章：389
积分：546
注册：2003-3-4
第10楼

以下是引用shupeichong在2003-10-21 10:51:21的发言：
好东西，呵呵，还有一点点的问题，

就是一般在概要设计的时候就需要有一些界面模型和必要摸板的提供了，这样的工作更有利于概要设计的验收。

实际上，我们在做界面前，是一定要将功能逻辑扭转关系及交互方式（UI架构）确定下来，这一阶段的UI测试方式，就是客户对这两块操作的评价，得出量化数据，再修改再测试。只有在架构上没有问题后，才开始界面原型（模型）的制作。
所以我们并不将界面原型（模型）放进概要设计阶段。界面设计师在架构趋于稳定的时候开始设计。

----------------------------------------------
他说，经商其实不用很多技巧，只要坚定自己的信心，把事情做得最好，做得到位，就能成功。他很欣赏三宅一生说的一句话：“做我喜欢的东西，让别人去接受。”他把这句话转作“让我做菜，你就得接受这个味。”他认为这样的态度是从根本上考虑，从长远考虑。只有干自己擅长的事，坚持专业精神，才能够把东西做到极致。有很多设计师迫于生存，牺牲掉专业的东西，这样就永远没有自己的风格。

点击查看用户来源及管理<br>发贴IP：218.246.32.115 2003-10-21 11:18:35
编辑这个贴子
菲菲 美女呀，离线，快来找我吧！

等级：初级用户
文章：102
积分：240
注册：2003-10-3
给菲菲发送一个短消息 把菲菲加入好友 查看菲菲的个人资料 搜索菲菲在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给菲菲 OICQ 访问菲菲的主页 引用回复这个贴子 回复这个贴子 第11楼
发贴心情
好呀，谢谢jiliy,收藏了。：）

----------------------------------------------
每一颗心都要学会倾听，
倾听来自心灵深处的脉脉低语，
倾听来自四季的风的呼唤，
倾听草木的发芽，
倾听鸟儿的歌唱，
倾听一切有生命的世界......

点击查看用户来源及管理<br>发贴IP：61.237.204.93 2003-10-28 20:54:06
编辑这个贴子
子木1977 美女呀，离线，快来找我吧！ 双子座1977-5-26

等级：初级用户
文章：81
积分：238
注册：2003-10-20
第12楼
发贴心情
虽然做设计工作已经三年多了，但真正做UI 设计还是刚刚开始（以前做的纯属为了工作，谈不上设计），做为一名新手，在这里面真的学习到了许多东西，感谢^_^...

----------------------------------------------
有心，就有翼——飞翔

点击查看用户来源及管理<br>发贴IP：218.79.103.159 2003-11-19 11:25:06
编辑这个贴子
lorena 美女呀，离线，快来找我吧！

等级：初级用户
文章：27
积分：67
注册：2003-11-11
第13楼
发贴心情
好东西顶一下
点击查看用户来源及管理<br>发贴IP：61.149.140.48 2003-12-16 16:52:27
编辑这个贴子

本主题贴数13，分页： [1]
*快速回复：给UI新手的－－UI开发的流程是什么样的
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：546.875毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：与用户界面相关的需求拟定，希望大家多多补充！

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：与用户界面相关的需求拟定，希望大家多多补充！

您是本帖的第 86 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 与用户界面相关的需求拟定，希望大家多多补充！
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 楼顶
发贴心情 与用户界面相关的需求拟定，希望大家多多补充！
我们在座设计的时候经常会有很多改动影响我们，最多的可能就是需求变更带给我们的影响，为了尽量避免这种反复，我们可以把与用户界面相关的需求提出来做为主要关注点。
与功能需求一样，用户界面相关的需求也需要评审，并作为设计依据进行跟踪。
关键点
1. 用户界面大体风格描述
2. 应用程序平台
3. 用户界面标准
4. 与平台上主流软件的一致性
5. 屏幕行为（例如进入程序后第一界面，焦点默认于左上角底一个按钮，还是无焦点状态）
6. 用户的交互方法（例如快捷键和右键菜单）
7. 系统时间会应用户的反馈时间。
8. 各种特色的控件交互
9. 窗口位置、大小
10. 软件导航的数据与软件同步
11. 帮助
12. 错误的预防和恢复
13. 标准色、图标指针的标准应用

可用性需求
这类需求是最难描述和衡量的，没有一个准确定位，大多是通过用户参与反馈的，比如安装不要超过15分钟等定义等，要根据你软件自身的特性来定义的，制定可以从一下方向着手：
1. 以用户为导向的任务和工作流的主要特性为
--支持任务中断
--中断后用户界面的处理
2. 遵循一致性的标准
--遵循操作系统的一致性标准
--遵循主流软件的一致性标准
3. 可以与其他软件顺利集成，例如常用的剪贴板命令（拷贝、粘贴等）。

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-7 16:18:20
编辑这个贴子 鲜花(0) 鸡蛋(0)
yue 美女呀，离线，快来找我吧！ 天秤座1976-9-30

等级：中级会员
文章：412
积分：659
注册：2003-3-15
第2楼
发贴心情
谢谢!非常好!
关键点补充一下
声音行为
初始化设计
无信息显示的设计
点击查看用户来源及管理<br>发贴IP：220.184.64.144 2003-11-7 16:39:45
编辑这个贴子

本主题贴数2，分页： [1]
*快速回复：与用户界面相关的需求拟定，希望大家多多补充！
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：265.625毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：[转帖]优爱公司工作流程

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：[转帖]优爱公司工作流程

您是本帖的第 478 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： [转帖]优爱公司工作流程
anyone 帅哥哟，离线，有人找我吗？

头衔：-= 副头头 =-
等级：管理员
文章：1230
积分：2649
注册：2003-1-13
楼顶
发贴心情 [转帖]优爱公司工作流程
优爱公司将严格按照如下流程为客户工作：

1）熟悉行业（熟悉您的软件所涉及的行业，以便制作出适合行业特征的界面风格）
2）了解软件（了解您软件的工程进度，做出针对您进度的工作计划）。
3）与软件开发工程师和市场人员讨论界面风格（广泛听取研发和市场人员的意见，做出最适合市场的软件）。
4）人机分析（对您的软件进行人机分析，增强您软件的易用性）。
5）做方案（做出设计方案，并明确细节思想）。
6）审定方案（与技术和市场人员一起审定方案，并听取修改意见）。
7）修改——审定（将有几次重复）
8）细化、制作界面（开始制作软件界面）。
9）与软件开发工程师合作把界面加入到程序中。
10）细部修改，完成。
11）进行软件包装盒、光盘盘面、盘套等的设计工作。
12）后期跟踪服务（在完成项目后，对您的软件进行跟踪服务，即对您软件从发布到推出新版本之间的小规模修改进行调整，包括对帮助协调文件的制定、DEMO演示等全访问服务）。

优爱公司对人机界面设计概念的率先提出，将促进国内软件行业的创新浪潮，我们期待与国内各软件开发商的广泛合作，为中国的软件行业的国际水准化提供的完善的协助服务。

一个强大成功的公司，必有统一的对外形象。只有统一的形象才更能够在客户心中留下深刻的印象。这就要求公司在对外的所有形象上保持设计风格一致性，优爱公司探索推出了一整套公司对外宣传解决方案。

----------------------------------------------
-= cHinAuI.coM =-
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：203.212.6.131 2003-1-22 9:42:35
编辑这个贴子 鲜花(0) 鸡蛋(0)
anyone 帅哥哟，离线，有人找我吗？

头衔：-= 副头头 =-
等级：管理员
文章：1230
积分：2649
注册：2003-1-13
第2楼
发贴心情
成功案例

http://www.uidesign.com.cn/uidesign/cgal/jhal.htm

----------------------------------------------
-= cHinAuI.coM =-
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：203.212.6.131 2003-1-22 9:43:40
编辑这个贴子
bluesky 帅哥哟，离线，有人找我吗？ 天蝎座1980-10-25

头衔：-=站长=-
等级：管理员
文章：498
积分：1406
注册：2002-10-26
第3楼
发贴心情 知道这个公司
看他们网站上的介绍，每个成员都好牛啊。可是作品真的很一般。

----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.99.78.10 2003-1-22 9:46:14
编辑这个贴子
anyone 帅哥哟，离线，有人找我吗？

头衔：-= 副头头 =-
等级：管理员
文章：1230
积分：2649
注册：2003-1-13
第4楼
发贴心情
取其精华。其实ui设计重要的是能被认可。也许他们有好的创意和想法。却没有被采纳而已。ui理念的推广是多方因素的。

我们能做的只是设计。走出更好的、更有实践性的设计道路。是吧。

----------------------------------------------
-= cHinAuI.coM =-
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：203.212.6.131 2003-1-22 11:13:26
编辑这个贴子
ziyeke 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：200
积分：425
注册：2003-1-21
第5楼
发贴心情
ui做的不错啊，虽然设计的很土但是中国首都北京就没有几个象样的能够推出这种理念的软件公司。
点击查看用户来源及管理<br>发贴IP：202.108.243.145 2003-1-22 12:48:57
编辑这个贴子
anyone 帅哥哟，离线，有人找我吗？

头衔：-= 副头头 =-
等级：管理员
文章：1230
积分：2649
注册：2003-1-13
第6楼
发贴心情
其实能真正按照这个流程走的情况很小，这个直接反映在公司的作品上。

----------------------------------------------
-= cHinAuI.coM =-
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：203.212.6.131 2003-1-22 15:47:10
编辑这个贴子
nodel 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：8
积分：80
注册：2003-10-9
第7楼
发贴心情
我看了一下觉得还不错。有了这样的理念、思想，他们定能为中国本土的人机界面事业创出一条属于中国自己的界面设计之路。这样总比等待老外进攻紫禁城好吧：》他们也需要一个从稚到熟的成长过程。
点击查看用户来源及管理<br>发贴IP：211.160.90.125 2003-10-31 21:53:06
编辑这个贴子

本主题贴数7，分页： [1]

锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

Powered by：DVBBS Ver5.0 Final
Copyright © 2003 ChinaUI.com , 页面执行时间：4,953.125毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：[译]好的GUI设计准则

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：[译]好的GUI设计准则

您是本帖的第 313 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： [译]好的GUI设计准则
why 美女呀，离线，快来找我吧！ 天秤座1979-10-23

等级：初级用户
文章：66
积分：214
注册：2003-3-19
楼顶
发贴心情 [译]好的GUI设计准则

好的GUI设计准则
图形用户界面已经成为用户界面的选择。尽管GUI很流行，让人吃惊的是，很少有程序有好的界面设计。此外，很难找到怎么设计好界面的信息。在这篇文章里，我描述了所有好的界面遵循的基本规则，包括该做什么，不能做什么。
但在开始构造好的设计之前，我得先解释设计不好的原因。 如果你想偏离可靠而正确的路子，用这种方法，就能知道错误的路会通向哪里，但愿你可以重回到正确设计的道路上。

不考虑用户
开发者通常根据自己知道的进行设计，而不是通过用户。这个多年来的问题在许多软件开发外的领域也普遍存在，比如测试，文档，等之类的。出现在界面上是最糟糕的，因为用户立刻能觉得自己没法用这个产品。坚决避免这种错误。

用户控制
GUI设计师们很明显喜欢控制应用，不断的通过灰化和黑化菜单项来控制用户的航线。对用户进行控制是和驱动事件设计完全对立的，应该是用户，而不是软件来指示发生什么事件。作为一个开发者，如果你花大量的时间来动态的灰化和禁用控制，你需要重新检查一下你的设计方法，并且认识到你可能正在控制你的用户，他们可能不愿意被控制。当事情快速变化，加强用户界面的机动性应该成为改变的一个关键。允许用户执行应用，用那些你从来没有想过的方式，可能让人恐慌，但他们会满意你这个开发者，给了用户权利。

放太多功能于顶层
检查下1985年生产的录象机和1995年生产的，你会发现它的界面发生了惊人的变化。1985的录象机有大量的按钮集中在面板上，很多都不知道是干什么的。1995年的录象机仅有用户常用几个关键的功能按钮：播放，前进，后退，停止和推出。这种机型可能有比10年前的更多的功能特色，但那些功能都放置在一个一个拉出面板或者滑动门后面，只有需要时才用，而不是放在表面上。

GUI成功案例
现在我们来探讨一下成功的GUI例子吧。这些成功的GUI案例拥有许多共同的特征。最重要的一点是，好的GUI通常让人直觉就会用，甚过了那些基于特征的配对物所带来的。一个办法就是尽可能的去比喻现实世界。一个例子是，近来我在调查按钮上的VISA和MASTERCARD的标志图形，判断用户是怎样打算付帐。这个图形立刻就能给用户直觉，更快知道这个应用。

GUI另一个重要的特征是迅速，或者更专业的叫响应。许多速度问题是通过GUI设计来处理而不是通过硬件。速度依赖于应用类型，成为用户意识里判断进程是响应或中断的因素。举个例子，如果你的应用是基于在线事物处理（OLTP），缓慢的执行速度很快就会导致用户想要抛弃这个系统。

有几个办法可以让你的GUI看上去有快的响应。避免刷新屏幕，除非绝对必要。还有一个办法是让所有确定的域铺满整个屏幕，而不是一块一块的出现。而且，依据用户的技能，可以设计一些功能让那些高级用户可以快速到达每个域的每条数据记录。这样的功能包括记录，加速键，带有含义的工具栏按钮，和所有允许加快用户对GUI和数据入口的速度的。

[待续]

[此贴子已经被作者于2003-11-18 16:03:49编辑过]

----------------------------------------------
Every mile and every year,
Time and Distance disappear I cannot explain this.
Dear No, I will not even try.

点击查看用户来源及管理<br>发贴IP：61.149.151.85 2003-11-4 9:51:00
编辑这个贴子 鲜花(0) 鸡蛋(0)
网络机器猫 帅哥哟，离线，有人找我吗？

等级：中级会员
文章：531
积分：848
注册：2003-5-18
给网络机器猫发送一个短消息 把网络机器猫加入好友 查看网络机器猫的个人资料 搜索网络机器猫在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给网络机器猫 OICQ 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
给新人捧场！鼓掌~~~pa!pa!pa!pa!

----------------------------------------------
~~~~ 共享、互勉、共进 ~~~~
这是基于Internet的“三个代表”

点击查看用户来源及管理<br>发贴IP：218.77.57.92 2003-11-4 9:58:23
编辑这个贴子
blackeyes 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：16
积分：86
注册：2003-3-6
第3楼
发贴心情
这样的准则太多了 网络上到处都是 有共性的东西 也有个性的东西
有没有一个公共的标准呢？
点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-5 14:04:26
编辑这个贴子
zbird 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：49
积分：133
注册：2003-10-8
第4楼
发贴心情
放太多功能于顶层
检查下1985年生产的录象机和1995年生产的，你会发现它的界面发生了惊人的变化。1985的录象机有大量的按钮集中在面板上，很多都不知道是干什么的。1995年的录象机仅有用户常用几个关键的功能按钮：播放，前进，后退，停止和推出。这种机型可能有比10年前的更多的功能特色，但那些功能都放置在一个一个拉出面板或者滑动门后面，只有需要时才用，而不是放在表面上。
//-------------------------------
恩，
我觉得这条很好。
点击查看用户来源及管理<br>发贴IP：210.178.228.226 2003-11-6 20:16:17
编辑这个贴子
yue 美女呀，离线，快来找我吧！ 天秤座1976-9-30

等级：中级会员
文章：412
积分：659
注册：2003-3-15
第5楼
发贴心情
控制用户这项我不很清楚,能具体说说吗?
点击查看用户来源及管理<br>发贴IP：220.184.64.144 2003-11-7 11:34:46
编辑这个贴子
why 美女呀，离线，快来找我吧！ 天秤座1979-10-23

等级：初级用户
文章：66
积分：214
注册：2003-3-19
第6楼
发贴心情
关于控制用户，原来参与一个项目时，我就曾犯过这方面的错误。。。
当时，出于一个目的，让软件操作简单，没有很多菜单，让整个流程是线形的，下一步下一步下一步。。。。
翻译这篇文章时，汗~~
老实说，现在我还不是很明白这一点是否就必须遵循。。。

----------------------------------------------
Every mile and every year,
Time and Distance disappear I cannot explain this.
Dear No, I will not even try.

点击查看用户来源及管理<br>发贴IP：61.149.149.229 2003-11-8 13:10:15
编辑这个贴子
yue 美女呀，离线，快来找我吧！ 天秤座1976-9-30

等级：中级会员
文章：412
积分：659
注册：2003-3-15
第7楼
发贴心情
我现在也是
下一步下一步下一步。。。。
我想关键在与你的用户是什么类型的，不过这个好像是废话！

[此贴子已经被作者于2003-11-8 22:35:37编辑过]
点击查看用户来源及管理<br>发贴IP：218.108.180.191 2003-11-8 22:33:33
编辑这个贴子
why 美女呀，离线，快来找我吧！ 天秤座1979-10-23

等级：初级用户
文章：66
积分：214
注册：2003-3-19
第8楼
发贴心情 [译]好的GUI设计准则[2]
做什么和不做什么
每个优秀的开发者应该有一个设计好GUI的目标。但怎样来实现它呢？下面会提供一些准则：象任何优秀的职业人一样，你需要一些准则，可以获得可重复的成功设计。我们用下面这些准则来做客户的项目，并且已经传授了国内国际2万多名学生。它们一样会带给你帮助的。

理解人们
程序必须反射用户的想法和行为。要充分理解用户，开发首先要理解一般大众，因为我们所有人都有一些共同特征。人通过识别来学习比通过记忆要容易的多。永远要试着提供一列数值来选择，比根据用户记忆里的关键值来选要强的多。普通人能记住大约2000到3000个词，但却可以认出5000多个词。

认真对待不同的观点
许多设计师常不自觉的就掉进了观点的圈套中，当进行icon设计或整个应用行为时。我最近看到一个为某会计系统设计的表示向上滚动的按钮。为了表示这个功能，这个设计师用了很多艺术效果来创造一个类似肉色滚轴效果的icon.但这个系统的用户根本不知道这个icon代表什么，尽管设计师的觉得它可以给人很好的直觉。下面给了一个公认标准的icon列表，会帮助你清除这个问题。

此主题相关图片如下：
按此在新窗口浏览图片

为清晰设计
GUI程序经常不清楚怎样结束的。一个增加程序清晰度的有效办法就是开发，和应用一系列保留词汇。用户常抱怨某个术语不是很清楚或者不协调。我常看到开发者聚在一起激烈的讨论，关于某个按钮或菜单项上使用词汇哪个恰当，但仅仅能看到临近大楼里的各部门的开发人员在讨论同一个问题。当程序发布时，才发现一个屏幕上写的是“项目”，另一个却写着“产品”，第三个写着“商品”，而这三个全都是指同一个东西。这种不连贯最终会让用户晕菜。

图2：这是一个保留词汇清单的例子。程序开发团队可以增加以完整和扩张这个表。
（部分翻译，不准的见谅啊 [image] ）

此主题相关图片如下：
按此在新窗口浏览图片

为一致性设计
好的GUI程序在整个程序应用中都保持了一致性行为，而且是建立在用户先前对其他成功的程序了解之上的。在写商业软件时，尽可能的提供用户多的一致性行为。举个例子，Embassy Suites 和 Courtyard Marriot 酒店连锁迅速增长，归因于他们在商务旅行者中间的名声，他们知道在那里会住上很亲切的房间并有一整套很舒服的设施。这个底线就是商务旅行者不会在每个新城市都试图去寻找一个新的兴奋的住宿地方。你软件的商业用户有着相似的需求。你软件里所提供的每个新的兴奋的体验都可能变成焦虑诱导体验或者昂贵的求救电话费。

[待续]

原文见： http://axp16.iie.org.mx/Monitor/v01n03/ar_ihc2.htm

----------------------------------------------
Every mile and every year,
Time and Distance disappear I cannot explain this.
Dear No, I will not even try.

点击查看用户来源及管理<br>发贴IP：61.149.146.70 2003-11-14 15:53:45
编辑这个贴子
eworker 美女呀，离线，快来找我吧！

等级：实习版主
文章：1863
积分：2665
注册：2003-7-17
第9楼
发贴心情
why经常翻译一些好东东，谢谢勤奋的why！

----------------------------------------------
批评是对我最大的帮助。
http://www.chinaui.com/bbs/list.asp?boardid=12

点击查看用户来源及管理<br>发贴IP：220.166.108.167 2003-11-16 20:09:27
编辑这个贴子
小小的猫儿 美女呀，在线，快来找我吧！

等级：中级会员
文章：674
积分：1399
注册：2003-8-24
第10楼
发贴心情
楼主很热心，很勤奋啊。
不但提供好的原文，还提供了翻译。
感谢！：）
点击查看用户来源及管理<br>发贴IP：211.159.89.254 2003-11-17 14:49:01
编辑这个贴子
why 美女呀，离线，快来找我吧！ 天秤座1979-10-23

等级：初级用户
文章：66
积分：214
注册：2003-3-19
第11楼
发贴心情 [译]好的GUI设计准则[3]
让反馈可见
如果你曾经焦急等待过一个操作的完成，你就知道在反馈的可见性方面有多么糟糕。如果你能让用户知道要忍受多久才能完成一个操作，他们会非常感激你。一般，当一个操作要花费7到10分钟时，多数用户希望有一个对话框，带有进度显示条。但这个数字因为用户的不同类型和程序的整个特征而有很大的差异。

让反馈有声
上周，我有幸乘坐了带有愉快声音提示到哪一层的电梯。该大楼还相当新，起初，职员觉得这个声音太可爱了。但六个月后，职员们开始不再注意它，甚至觉得它不再是帮助，而是烦人的东西。同样的事情也发生在你的GUI中，虽然没有电梯里烦人的声音，但每个人都能听到工作间的所有噪音。当在近百个工作站都设置了声音，那么在这个开放的工作环境中，就出现了一个真正的噪音。然而，声音反馈在一些情况下还是很有用的，当你需要警告用户即将面临严重问题，比如某个进程继续可能会损失数据或软件。让用户可以关掉声音反馈，除非错误必须被通知。

保持文字清楚
开发者常试着增加一些词语以使反馈文字化。然而，最终这些消息表述的也不是很清楚。要让文字标签，错误提示信息，在线帮助信息清晰的表述出来，不是很容易的事情。把文字化的反馈交给那些有经验的技术作者来处理是最有效的办法。

给出可循路径
如果你的用户说了些类似这样的话，比如，“我不知道怎么打开这个窗口的，但现在进来了，却不知道怎么出去”。那么你没有给出可循路径（或者，这个例子叫可折回路径）。给出可循路径做起来比说起来要难的多。它开始于一个直观的菜单结构，从那里启动你的特别功能。

你必须弄明白菜单结构，合并它们，避免两层以上的层叠菜单。在每个对话框都给出一个描述性的标题栏，这会帮助用户记住按了什么按钮或菜单项才会打开当前窗口的。

给出键盘支持
键盘是用户的常用设备，提供了一种有效的输入数据和文本的方式。在GUI设计中，我们经常假设用户将鼠标作为首要的交互设备。但这对那些习惯打字的或者频繁使用该程序的用户来说，就是浪费时间也没有效率的。

键盘加速器能提供一个有效的方式去打开某个菜单或控制键。使用的按键应该是很容易接触到并且只有1到2个键（比如F3）

关注演示模型
界面的外观和感受是和其他所有方方面面都紧密相关的。它们必须是一致的。建立在用户经验的基础上的屏幕和对方框，应该让用户可以理解怎样和下一个屏幕或操作进行交互。
最重要的是如何找到最合适的界面模型。这个模型应该是经过认真的决策的，比如程序是使用单个还是多文挡界面。这个模型还将验证用户在程序中怎样执行主要任务。
确定了模型表述是否合适将会大大方便后续开发。如果你不在早期确定你的GUI设计模型，以后在更改将会花费大的精力和时间，因为几乎每个窗口都受到影响。

[待续]

原文见： http://axp16.iie.org.mx/Monitor/v01n03/ar_ihc2.htm
欢迎指正。

----------------------------------------------
Every mile and every year,
Time and Distance disappear I cannot explain this.
Dear No, I will not even try.

点击查看用户来源及管理<br>发贴IP：61.149.151.85 2003-11-18 15:38:56
编辑这个贴子
dozer 帅哥哟，离线，有人找我吗？

等级：中级会员
文章：466
积分：784
注册：2003-6-15
第12楼
发贴心情
小姐：不应该是控制用户，不要搞反了。

关于让用户控制的问题，我前两天贴的微软的最新Guideline说的比较好，可以再看看。这不是绝对性的问题。

另外，关于这个所谓的准则中，有些我持保留意见。比如菜单中项目灰掉的问题，Windows就是这么做的，如果不灰，会导致很多错误操作，如果都弹msgbox则很讨厌的。

点击查看用户来源及管理<br>发贴IP：218.80.64.96 2003-11-18 15:51:41
编辑这个贴子
why 美女呀，离线，快来找我吧！ 天秤座1979-10-23

等级：初级用户
文章：66
积分：214
注册：2003-3-19
第13楼
发贴心情
其实我的理解，要不要灰化和禁用，本文没有明确的说是要让用户继续错误的操作下去然后给出msgbox警告，干脆隐藏了不是更好吗？
比如说，在adobe photoshop 中，当你处理一个图片的过程中，选中了滤镜菜单，却发现就所有的滤镜是灰色不能用的。。一次一次，反复多次后，才能记住什么状态时，滤镜不能用。。
从心理上说，这有时候让人有点恼火。
物理上，它增加了人的记忆负荷。。

看了这么多，我觉得这个准则还是有很多参考价值的。比较浅显。其实GUI准则各个公司都不相同，但里面大部分却是相通的。

----------------------------------------------
Every mile and every year,
Time and Distance disappear I cannot explain this.
Dear No, I will not even try.

点击查看用户来源及管理<br>发贴IP：61.149.151.85 2003-11-18 16:19:07
编辑这个贴子
dozer 帅哥哟，离线，有人找我吗？

等级：中级会员
文章：466
积分：784
注册：2003-6-15
第14楼
发贴心情
如果要根据每一个情况动态去显示和隐藏菜单项目，出发点不错，不过：

1.从开发上来讲，是很烦人的事情。

2.从使用上来讲，也是菜单动态不断变化，并不见得是好的方式。以右键菜单为例子，因为菜单一会大，一会小。在不同的状况下动态变化，如果情况比较复杂，则会有多种变化，用起来不一定爽的。
3.灰掉的东西在某种状况下是会随时激活的，灰掉时用户是不会去注意它的，用户不需要去记忆它。
4.习惯是非常重要的易用因素。动态的变化，不容易导致用户养成习惯。象OfficeXP的动态菜单显示，就被Raskin所批评。
5.主流的商业软件从windows系统到adobe..Macromedia..等等几乎都是采用不可以使用时灰掉这种做法。除非该功能永远都不会处于激活状态。

点击查看用户来源及管理<br>发贴IP：218.80.64.96 2003-11-18 16:42:45
编辑这个贴子

本主题贴数14，分页： [1]
*快速回复：[译]好的GUI设计准则
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：625.000毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：原创《如何写“完”UI设计说明书》，为新板块助威！

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：原创《如何写“完”UI设计说明书》，为新板块助威！

您是本帖的第 712 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 原创《如何写“完”UI设计说明书》，为新板块助威！
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 楼顶
发贴心情 原创《如何写“完”UI设计说明书》，为新板块助威！
如何写“完”UI设计说明书
我们中的大多数人都些过UI设计说明书（或UI规格说明书），论坛里也经常会有类似的讨论，对UI设计说明书的框架和结构我就不做过多的说明了。为什么有人写了上百页的UI设计说明书，别人还是看不懂，或者说忽略了细节呢？那今天我们重点讨论一下关于细节阐述和表达的一些经验，以免写出只有自己看得懂的UI设计说明书。

我先说说我总结的一些经验吧，希望大家积极讨论：

我们的目标是：（没有蛀牙，^_^ 玩笑！）
既要清晰描述用户界面原型中的细节和交互方式，又要方便项目组的其他开发人员、需求人员以及测试人员等角色交流察看的说明文档。

主要内容包括：
1. 产品的目标和成功标准，（例如一个全新的预言项目不可能要求用户满意度在90%以上，对升级产品要求就会高一些。）
2. 产品最终用户群及产品用途（了解用户的年龄、职业、产品的使用环境等都是非常必要的）
3. 首先满足基本功能。（例如DVD机的基本功能是播放影碟，可能还有播放CD的功能等等）
4. 主要功能（在产品的几十个功能中通过用户验证和项目组筛选，选取用户最常用到的功能，将其优化，以不同层次展现于界面上。）
5. 用户界面特性。（每一款界面都有自己的特性，比如触摸屏的操作界面与手机的操作界面就算功能完全一样，结构、布局等特点也不会相同的。）

几点注意事项
1. 必须紧贴需求，围绕功能点展开。
2. 描述语言简短精确（这样别人看的时候才不会烦）
3. 保持文本的易维护性，建议使用WORD的大纲视图编写，便于更改和查找。
4. 说明书一定要有版本管理，对每次更新内容要做详细说明。
5. 图标要与名称一同提交，并说明是什么类型，如桌面图标、列表中的图标、工具栏图标、按钮图标、属性框或提示信息框中的图标等等。
6. 注意纪录，包括项目组和用户以及合作伙伴，如果在解释某一特性时令两人以上会感到困惑，那这一部分就需要更清楚的阐述了。
7. 设计与实现同步，这个时最难的了，很多设计由于程序无法实现都被“卡”掉，早期程序也无法确定是否可以实现，伤脑筋！
8. 维护UI设计说明书时不要忘记维护原型，作为UI设计说明书的补充原型是很重要的。

UI设计中容易被忽略的地方
1. 支持错误提示和撤销操作
2. 简便的安装和卸载。
3. 必要的设置和帮助。
4. 异常处理、错误消息的描述和问题回应提示。
5. 除界面上有的图标和按钮外，还要有快节键、菜单访问键、右键菜单、是否支持从其它软件界面内托拽复制文件等操作的说明。
6. 域、菜单和按钮在什么情况下为不可点击状态。
7. 状态区，用来描述界面状态的区域，通常位于页面下方。（PS存储时状态区会显示进度条）
8. 剪贴板行为，用户在我们产品中拷贝的文字或图片的局部，是否可以贴入其他程序。
9. 指针的行为，说明超过多长时间的等待时应出现沙漏状态，在文本输入区光标应有改变、有链接的地方有变为小手等
10. 声音行为，警示音、按钮触发音等
11. 统一消息窗的弹出位置、背景色、大小、布局及特色
12. 菜单栏和下拉选项等程序动作的描述，是向下还是向右弹出等。
13. 动态状态描述，如果要求窗口渐隐或渐显，那就要说明渐隐或渐显过程的时间以及方式（半透明还是马赛克）等。

参考：
怎样写UI规范？？
http://www.chinaui.com/bbs/dispbbs.asp?BoardID=17&ID=4256&replyID=42376&skin=1

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-10-28 18:22:41
编辑这个贴子 鲜花(0) 鸡蛋(0)
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
今天下午赶写的，献丑啦：）

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-10-28 18:24:14
编辑这个贴子
honghonge 帅哥哟，离线，有人找我吗？

等级：活跃分子
文章：211
积分：574
注册：2003-7-2
第3楼
发贴心情
还是不够规范
其实应该叫《用户界面需求规格说明书》和需求有关
概念模型的设计是必要的，谁都不愿意修改花费很多精力才完成的高保真模型
点击查看用户来源及管理<br>发贴IP：218.59.67.200 2003-10-28 18:30:05
编辑这个贴子
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第4楼
发贴心情
哦，我写的不是规范呀！
其实不同的公司叫法和文档结构可能都会有所不同，以前讨论过很多次了，所以我不再归纳，我只是总结了一些经验，当备忘录用吧。
honghonge看来也是很有经验的，谈谈你写《用户界面需求规格说明书》时都注意什么好吗？
期待向你学习：）

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-10-28 18:37:42
编辑这个贴子
小林 美女呀，离线，快来找我吧！

等级：版主
文章：342
积分：601
注册：2003-6-12
给小林发送一个短消息 把小林加入好友 查看小林的个人资料 搜索小林在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给小林 OICQ 访问小林的主页 引用回复这个贴子 回复这个贴子 第5楼
发贴心情
Cuckoo完全是根据自己的经验写出来的，真是太好了，大家要认真的看，不懂的地方可以请教cockoo哦。也可以补充使它更有用。

[此贴子已经被作者于2003-10-28 18:39:32编辑过]

----------------------------------------------
/○\
/■\ Human Factors makes the world easy and simple.
<|

点击查看用户来源及管理<br>发贴IP：218.108.42.3 2003-10-28 18:38:22
编辑这个贴子
eworker 美女呀，离线，快来找我吧！

等级：实习版主
文章：1863
积分：2665
注册：2003-7-17
第6楼
发贴心情
学习ing……谢谢cuckoo

----------------------------------------------
批评是对我最大的帮助。
http://www.chinaui.com/bbs/list.asp?boardid=12

点击查看用户来源及管理<br>发贴IP：220.166.108.204 2003-10-28 18:41:17
编辑这个贴子
dozer 帅哥哟，离线，有人找我吗？

等级：中级会员
文章：466
积分：784
注册：2003-6-15
第7楼
发贴心情 搞一份模版给大家看看，大家一看就学会了。
反正我是从来不写的，也不会写　　:)

[此贴子已经被作者于2003-10-29 9:16:11编辑过]
点击查看用户来源及管理<br>发贴IP：218.80.63.100 2003-10-29 9:14:19
编辑这个贴子
yue 美女呀，离线，快来找我吧！ 天秤座1976-9-30

等级：中级会员
文章：412
积分：659
注册：2003-3-15
第8楼
发贴心情
这几天我也要写这方面的一个模版,不过侧重点不同...完成后,我会share给大家的
点击查看用户来源及管理<br>发贴IP：220.184.70.76 2003-10-29 9:29:42
编辑这个贴子
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第9楼
发贴心情
文章末端的那个参考的连接里有一些朋友提供的模板，大家不妨参考一下！

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-10-29 9:46:18
编辑这个贴子
烛音 帅哥哟，在线，有人找我吗？

等级：实习版主
文章：5185
积分：7083
注册：2003-5-22
第10楼
发贴心情
肥鸟的这篇文章更多的是个人的实战经验和心得，还是有值得借鉴的地方。谢谢分享！

----------------------------------------------
http://www.cqppi.com/1/1.html

点击查看用户来源及管理<br>发贴IP：211.158.64.120 2003-10-29 9:56:36
编辑这个贴子
shupeichong 帅哥哟，在线，有人找我吗？

等级：初级用户
文章：151
积分：300
注册：2003-6-23
第11楼
发贴心情
呵呵，，偶打算制定的规范分了几个部分，

《文件命名规范》
《HTML/JS代码规范》
《目录结构规范》
《JAVA代码规范》
《表单元素使用规范》
《交互设计规范》
其他的规范是需要项目统一提供的
《数据库表命名规范》
《数据表字段详细列表》
等等.......

点击查看用户来源及管理<br>发贴IP：219.234.32.69 2003-10-29 13:51:17
编辑这个贴子
小林 美女呀，离线，快来找我吧！

等级：版主
文章：342
积分：601
注册：2003-6-12
给小林发送一个短消息 把小林加入好友 查看小林的个人资料 搜索小林在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给小林 OICQ 访问小林的主页 引用回复这个贴子 回复这个贴子 第12楼
发贴心情
你一下子写这么多？晕倒，不过支持你！！
早日能看到你的作品。

----------------------------------------------
/○\
/■\ Human Factors makes the world easy and simple.
<|

点击查看用户来源及管理<br>发贴IP：218.108.42.3 2003-10-29 14:41:49
编辑这个贴子
xyz890 帅哥哟，离线，有人找我吗？

等级：活跃分子
文章：215
积分：382
注册：2003-8-29
第13楼
发贴心情
ok

----------------------------------------------
来也匆匆，去也慢慢，其实我不想走 [image] http://www.su163.com/

点击查看用户来源及管理<br>发贴IP：218.92.216.45 2003-10-30 14:15:08
编辑这个贴子
shupeichong 帅哥哟，在线，有人找我吗？

等级：初级用户
文章：151
积分：300
注册：2003-6-23
第14楼
发贴心情
呵呵，那些都是很简短的，组合起来是一个文件。
点击查看用户来源及管理<br>发贴IP：219.234.32.69 2003-10-30 15:23:24
编辑这个贴子
胡杨 帅哥哟，离线，有人找我吗？

头衔：生命的风采
等级：高级会员
文章：836
积分：1067
注册：2003-7-16
第15楼
发贴心情
写得真好。
谢谢
学习ing......

----------------------------------------------
我是沙漠中的胡杨，一直执著地等待属于我心灵之雨的降临！

点击查看用户来源及管理<br>发贴IP：61.186.110.183 2003-10-30 21:16:34
编辑这个贴子

本主题贴数33，分页： [1] [2] [3]
*快速回复：原创《如何写“完”UI设计说明书》，为新板块助威！
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：968.750毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：我之前收藏的

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：我之前收藏的<有关界面设计与测试的规范>

您是本帖的第 407 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 我之前收藏的<有关界面设计与测试的规范>
麦子 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：100
积分：199
注册：2003-8-24
给麦子发送一个短消息 把麦子加入好友 查看麦子的个人资料 搜索麦子在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给麦子 OICQ 引用回复这个贴子 回复这个贴子 楼顶
发贴心情 我之前收藏的<有关界面设计与测试的规范>
我改ID了，认的我吗，

这是我之前没触及UI收藏的，也不知道来与那了

我在工作中总结了一些有关界面设计与测试的规范，与大家共享。 界面设计与测试规则
界面是软件与用户交互的最直接的层，界面的好坏决定用户对软件的第一印象。而且设计良好的界面能够引导用户自己完成相应的操作，起到向导的作用。同时界面如同人的面孔，具有吸引用户的直接优势。设计合理的界面能给用户带来轻松愉悦的感受和成功的感觉，相反由于界面设计的失败，让用户有挫败感，再实用强大的功能都可能在用户的畏惧与放弃中付诸东流。目前界面的设计引起软件设计人员的重视的程度还远远不够，直到最近网页制作的兴起，才受到专家的青睐。而且设计良好的界面由于需要具有艺术美的天赋而遭拒绝。
目前流行的界面风格有三种方式：多窗体、单窗体以及资源管理器风格，无论那种风格，以下规则是应该被重视的。

1：易用性：
按钮名称应该易懂，用词准确，屏弃没楞两可的字眼，要与同一界面上的其他按钮易于区分，能望文知意最好。理想的情况是用户不用查阅帮助就能知道该界面的功能并进行相关的正确操作。

易用性细则：
1):完成相同或相近功能的按钮用Frame框起来，常用按钮要支持快捷方式。
2):完成同一功能或任务的元素放在集中位置，减少鼠标移动的距离。
3):按功能将界面划分局域块，用Frame框括起来,并要有功能说明或标题。
4):界面要支持键盘自动浏览按钮功能，即按Tab键的自动切换功能。
5):界面上首先应输入的和重要信息的控件在Tab顺序中应当靠前,位置也应放在窗口上较醒目的位置。
6):同一界面上的控件数最好不要超过10个，多于10个时可以考虑使用分页界面显示。
7):分页界面要支持在页面间的快捷切换，常用组合快捷键Ctrl+Tab
8):默认按钮要支持Enter及选操作，即按Enter后自动执行默认按钮对应操作。
9):可写控件检测到非法输入后应给出说明并能自动获得焦点。
10):Tab键的顺序与控件排列顺序要一直，目前流行总体从上到下，同时行间从左到右的方式。
11):复选框和选项框按选择几率的高底而先后排列。
12):复选框和选项框要有默认选项，并支持Tab选择。
13):选项数相同时多用选项框而不用下拉列表框。
14):界面空间较小时使用下拉框而不用选项框。
15):选项数叫少时使用选项框，相反使用下拉列表框。
16):专业性强的软件要使用相关的专业术语，通用性界面则提倡使用通用性词眼。
2： 规范性：
通常界面设计都按Windows界面的规范来设计，即包含“菜单条、工具栏、工具厢、状态栏、滚动条、右键快捷菜单”的标准格式，可以说：界面遵循规范化的程度越高，则易用性相应的就越好。小型软件一般不提供工具厢。

规范性细则：
1):常用菜单要有命令快捷方式。
2):完成相同或相近功能的菜单用横线隔开放在同一位置。
3):菜单前的图标能直观的代表要完成的操作。
4):菜单深度一般要求最多控制在三层以内。
5):工具栏要求可以根据用户的要求自己选择定制。
6):相同或相近功能的工具栏放在一起。
7):工具栏中的每一个按钮要有及时提示信息。
8):一条工具栏的长度最长不能超出屏幕宽度。
9): 工具栏的图标能直观的代表要完成的操作。
10):系统常用的工具栏设置默认放置位置。
11):工具栏太多时可以考虑使用工具厢。
12):工具厢要具有可增减性，由用户自己根据需求定制。
13):工具厢的默认总宽度不要超过屏幕宽度的1/5。
14): 状态条要能显示用户切实需要的信息，常用的有：
目前的操作、系统状态、用户位置、用户信息、提示信息、错误信息等，如果某一操作需要的时间较长，还应该显示进度条和进程提示。
15)：滚动条的长度要根据显示信息的长度或宽度能及时变换，以利于用户了解显示信息的位置和百分比。
16)：状态条的高度以放置五好字为宜，滚动条的宽度比状态条的略窄。
17)：菜单和工具条要有清楚的界限;菜单要求凸出显示，这样在移走工具条时仍有立体感。
18)：菜单和状态条中通常使用5号字体。工具条一般比菜单要宽，但不要宽的太多，否则看起来很不协调。
19):右键快捷菜单采用与菜单相同的准则。

3：帮助设施：
系统应该提供详尽而可靠的帮助文档，在用户使用产生迷惑时可以自己寻求解决方法。

帮助设施细则：
1)：帮助文档中的性能介绍与说明要与系统性能配套一致。(我们的系统帮助文档都是系统的祖先时期的说明，让人困惑)。
2)：打包新系统时，对作了修改的地方在帮助文档中要做相应的修改。
3)：操作时要提供及时调用系统帮助的功能。常用F1。
4)：在界面上调用帮助时应该能够及时定位到与该操作相对的帮助位置。也就是说帮助要有即时针对性。
5)：最好提供目前流行的联机帮助格式或HTML帮助格式。
6)：用户可以用关键词在帮助索引中搜索所要的帮助，当然也应该提供帮助主题词。
7)：如果没有提供书面的帮助文档的话，最好有打印帮助的功能。
8 )：在帮助中应该提供我们的技术支持方式，一旦用户难以自己解决可以方便的寻求新的帮助方式。

4：合理性：
屏幕对角线相交的位置是用户直视的地方，正上方四分之一处为易吸引用户注意力的位置，在放置窗体时要注意利用这两个位置。

合理性细则：
1)：父窗体或主窗体的中心位置应该在对角线焦点附近。
2)：子窗体位置应该在主窗体的左上角或正中。
3)：多个子窗体弹出时应该依次向右下方偏移，以显示窗体出标题为宜。
4)：重要的命令按钮与使用较频繁的按钮要放在界面上注目的位置。
5)：错误使用容易引起界面退出或关闭的按钮不应该放在易点位置。横排开头或最后与竖排最后为易点位置。
6)：与正在进行的操作无关的按钮应该加以屏蔽(Windows中用灰色显示，没法使用该按钮)。
7)：对可能造成数据无法恢复的操作必须提供确认信息,给用户放弃选择的机会。
8)：非法的输入或操作应有足够的提示说明。
9): 对运行过程中出现问题而引起错误的地方要有提示，让用户明白错误出处，避免形成无限期的等待。
10):提示、警告、或错误说明应该清楚、明了、恰当。
5：美观与协调性：
界面应该大小适合美学观点，感觉协调舒适，能在有效的范围内吸引用户的注意力。

美观与协调性细则：
1): 长宽接近黄金点比例，切忌长宽比例失调、或宽度超过长度。
2): 布局要合理,不宜过于密集，也不能过于空旷，合理的利用空间。
3): 按钮大小基本相近，忌用太长的名称，免得占用过多的界面位置。
4): 按钮的大小要与界面的大小和空间要协调。
5): 避免空旷的界面上放置很大的按钮。
6)：放置完控件后界面不应有很大的空缺位置。
7): 字体的大小要与界面的大小比例协调, 通常使用的字体中宋体9-12较为美观，很少使用超过12号的字体。
8): 前景与背景色搭配合理协调，反差不宜太大，最好少用深色，如大红、大绿等。常用色考虑使用Windows界面色调。
9): 如果使用其他颜色，主色要柔和，具有亲和力与磁力，坚决杜绝刺目的颜色。
10): 大型系统常用的主色有"#E1E1E1"、"#EFEFEF"、"#C0C0C0"等。
11): 界面风格要保持一致，字的大小、颜色、字体要相同，除非是需要艺术处理或有特殊要求的地方。
12): 如果窗体支持最小化和最大化或放大时，窗体上的控件也要随着窗体而缩放；切忌只放大窗体而忽略控件的缩放。
13)：对于含有按钮的界面一般不应该支持缩放，即右上角只有关闭功能。
14): 通常父窗体支持缩放时，子窗体没有必要缩放。
15)：如果能给用户提供自定义界面风格则更好，由用户自己选择颜色、字体等。

6：菜单位置：
菜单是界面上最重要的元素，菜单位置按照按功能来组织。

菜单设测试细则：
1)：菜单通常采用“常用--主要--次要--工具--帮助”的位置排列，符合流行的Windows风格。
2):常用的有“文件”、“编辑”，“查看”等，几乎每个系统都有这些选项，当然要根据不同的系统有所取舍。
3):下拉菜单要根据菜单选项的含义进行分组，并切按照一定的规则进行排列，用横线隔开。
4): 一组菜单的使用有先后要求或有向导作用时，应该按先后次序排列。
5): 没有顺序要求的菜单项按使用频率和重要性排列，常用的放在开头， 不常用的靠后放置；重要的放在开头，次要的放在后边。
6): 如果菜单选项较多，应该采用加长菜单的长度而减少深度的原则排列。
7): 菜单深度一般要求最多控制在三层以内。
8): 对常用的菜单要有快捷命令方式，组合原则见8。
9):对与进行的操作无关的菜单要用屏蔽的方式加以处理，如果采用动态加载方式——即只有需要的菜单才显示——最好。
10)：菜单前的图标不宜太大，与字高保持一直最好。
11):主菜单的宽度要接近，字数不应多于四个，每个菜单的字数能相同最好。
12)：主菜单数目不应太多，最好为单排布置。
。7:独特性：
如果一味的遵循业界的界面标准，则会丧失自己的个性.在框架符合以上规范的情况下，设计具有自己独特风格的界面尤为重要。尤其在商业软件流通中有着很好的迁移默化的广告效用。

1):安装界面上应有单位介绍或产品介绍，并有自己的图标。
2):主界面，最好是大多数界面上要有公司图标。
3):登录界面上要有本产品的标志，同时包含公司图标。
4):帮助菜单的“关于”中应有版权和产品信息。
5):公司的系列产品要保持一直的界面风格，如背景色、字体、菜单排列方式、图标、安装过程、按钮用语等应该大体一致。

8：快捷方式的组合
在菜单及按钮中使用快捷键可以让喜欢使用键盘的用户操作得更快一些 在西文Windows及其应用软件中快捷键的使用大多是一致的。
菜单中：
1):面向事务的组合有:
Ctrl-D 删除 ；Ctrl-F 寻找 ；Ctrl –H替换；Ctrl-I 插入 ；Ctrl-N 新记录 ；Ctrl-S 保存 Ctrl-O 打开。
2)：列表:
Ctrl-R ，Ctrl-G定位；Ctrl-Tab下一分页窗口或反序浏览同一页面控件；。
3):编辑:
Ctrl-A全选；Ctrl-C 拷贝；Ctrl-V 粘贴；Ctrl-X 剪切；Ctrl-Z撤消操作；Ctrl-Y恢复操作。
4)文件操作:
Ctrl-P 打印；Ctrl-W 关闭。
5):系统菜单
Alt-A文件；Alt-E编辑；Alt-T工具；Alt－W窗口；Alt－H帮助。
6):MS Windows保留键:
Ctrl-Esc 任务列表 ；Ctrl-F4 关闭窗口； Alt-F4 结束应用；Alt-Tab 下一应用 ；Enter 缺省按钮/确认操作 ；Esc 取消按钮/取消操作 ；Shift-F1 上下文相关帮助 。
按钮中：
可以根据系统需要而调节，以下只是常用的组合。
Alt-Y确定(是)；Alt-C取消；Alt-N 否；Alt-D删除；Alt-Q退出；Alt-A添加；Alt-E编辑；Alt-B浏览；Alt-R读；Alt-W写。
这些快捷键也可以作为开发中文应用软件的标准,但亦可使用汉语拼音的开头字母。
9:安全性考虑：
在界面上通过下列方式来控制出错几率，会大大减少系统因用户人为的错误引起的破坏。开发者应当尽量周全地考虑到各种可能发生的问题,使出错的可能降至最小。如应用出现保护性错误而退出系统,这种错误最容易使用户对软件失去信心。因为这意味着用户要中断思路,并费时费力地重新登录,而且已进行的操作也会因没有存盘而全部丢失。

安全性细则：
1)：最重要的是排除可能会使应用非正常中止的错误。
2)：应当注意尽可能避免用户无意录入无效的数据。
3)：采用相关控件限制用户输入值的种类。
4)：当用户作出选择的可能性只有两个时,可以采用单选框。
5)：当选择的可能再多一些时,可以采用复选框,每一种选择都是有效的,用户不可能输入任何一种无效的选择。
6)：当选项特别多时，可以采用列表框，下拉式列表框。
7)：在一个应用系统中,开发者应当避免用户作出未经授权或没有意义的操作。
8)：对可能引起致命错误或系统出错的输入字符或动作要加限制或屏蔽。
9):对可能发生严重后果的操作要有补救措施。通过补救措施用户可以回到原来的正确状态。
10):对一些特殊符号的输入、与系统使用的符号相冲突的字符等进行判断并阻止用户输入该字符。
11)：对错误操作最好支持可逆性处理，如取消系列操作。
12):在输入有效性字符之前应该阻止用户进行只有输入之后才可进行的操作。
13):对可能造成等待时间较长的操作应该提供取消功能。
14)：特殊字符常有；;’”><,｀‘：“［”｛、\|｝］+=)-(_*&&^%$#@!~,.。?/还有空格。
15)：与系统采用的保留字符冲突的要加以限制。
16)：在读入用户所输入的信息时，根据需要选择是否去掉前后空格。
17)：有些读入数据库的字段不支持中间有空格，但用户切实需要输入中间空格，这时要在程序中加以处理。

10:多窗口的应用与系统资源：
设计良好的软件不仅要有完备的功能，而且要尽可能的占用最底限度的资源。
1)： 在多窗口系统中，有些界面要求必须保持在最顶层，避免用户在打开多个窗口时，不停的切换甚至最小化其他窗口来显示该窗口。

2)：在主界面载入完毕后自动卸出内存，让出所占用的WINDOWS系统资源。
3)：关闭所有窗体，系统退出后要释放所占的所有系统资源 ，除非是需要后台运行的系统。
4)：尽量防止对系统的独占使用。

＝＝＝＝＝

[此贴子已经被作者于2003-8-24 22:07:55编辑过]
点击查看用户来源及管理<br>发贴IP：61.175.170.161 2003-8-24 22:06:44
编辑这个贴子 鲜花(0) 鸡蛋(0)
eworker 美女呀，离线，快来找我吧！

等级：实习版主
文章：1863
积分：2665
注册：2003-7-17
第2楼
发贴心情
好！收藏。

----------------------------------------------
批评是对我最大的帮助。
http://www.chinaui.com/bbs/list.asp?boardid=12

点击查看用户来源及管理<br>发贴IP：218.6.133.217 2003-8-24 22:15:31
编辑这个贴子
麦子 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：100
积分：199
注册：2003-8-24
给麦子发送一个短消息 把麦子加入好友 查看麦子的个人资料 搜索麦子在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给麦子 OICQ 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
还有一些PDF文件，不过全是英文的，我自己其实看不懂，只是那时收藏着先，为以后学好了E文再看，哈，，，，
要的话我上传来
点击查看用户来源及管理<br>发贴IP：61.175.170.161 2003-8-24 22:18:44
编辑这个贴子
leekf 帅哥哟，在线，有人找我吗？

等级：初级用户
文章：177
积分：321
注册：2003-8-5
给leekf发送一个短消息 把leekf加入好友 查看leekf的个人资料 搜索leekf在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给leekf OICQ 引用回复这个贴子 回复这个贴子 第4楼
发贴心情
PDF文件,需要的呀，最好能译好，不过也没关系了，漫漫看了

----------------------------------------------
不是我不想穿，只是我没想好

点击查看用户来源及管理<br>发贴IP：218.72.12.151 2003-8-24 22:43:17
编辑这个贴子
cry 美女呀，离线，快来找我吧！

等级：初级用户
文章：8
积分：63
注册：2003-8-21
第5楼
发贴心情
我也要，发到我的邮箱里吧。为什么改ID？可你还是打着mailang的招牌，呵呵

----------------------------------------------
抛砖头@引玉

点击查看用户来源及管理<br>发贴IP：216.100.137.129 2003-8-25 2:24:40
编辑这个贴子
fabit 美女呀，离线，快来找我吧！

等级：初级用户
文章：21
积分：82
注册：2003-7-30
第6楼
发贴心情
这篇东东好像是北京优爱公司网站上的吧
点击查看用户来源及管理<br>发贴IP：195.92.168.167 2003-8-25 4:00:21
编辑这个贴子
小平 美女呀，离线，快来找我吧！

等级：活跃分子
文章：320
积分：593
注册：2003-7-28
第7楼
发贴心情
楼上的你怎么那么厉害？！一眼就看出来了！你是那个公司的？

----------------------------------------------
!@! # $ %| ^-^ &!& *!* (!) ^_+

点击查看用户来源及管理<br>发贴IP：61.51.220.172 2003-8-25 10:26:16
编辑这个贴子
fabit 美女呀，离线，快来找我吧！

等级：初级用户
文章：21
积分：82
注册：2003-7-30
第8楼
发贴心情
只是因为以前看到过就记住了
点击查看用户来源及管理<br>发贴IP：195.92.168.166 2003-8-26 1:22:33
编辑这个贴子
菲菲 美女呀，离线，快来找我吧！

等级：初级用户
文章：102
积分：240
注册：2003-10-3
给菲菲发送一个短消息 把菲菲加入好友 查看菲菲的个人资料 搜索菲菲在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给菲菲 OICQ 访问菲菲的主页 引用回复这个贴子 回复这个贴子 第9楼
发贴心情
不错,感谢楼主,收藏了!:)

----------------------------------------------
每一颗心都要学会倾听，
倾听来自心灵深处的脉脉低语，
倾听来自四季的风的呼唤，
倾听草木的发芽，
倾听鸟儿的歌唱，
倾听一切有生命的世界......

点击查看用户来源及管理<br>发贴IP：211.93.58.22 2003-11-5 14:39:28
编辑这个贴子
晨明 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：65
积分：161
注册：2003-10-14
第10楼
发贴心情
这里谢过了，收藏了！
点击查看用户来源及管理<br>发贴IP：61.51.226.142 2003-11-6 12:40:36
编辑这个贴子
yue 美女呀，离线，快来找我吧！ 天秤座1976-9-30

等级：中级会员
文章：412
积分：659
注册：2003-3-15
第11楼
发贴心情
很有帮助!谢谢
点击查看用户来源及管理<br>发贴IP：220.184.132.1 2003-11-6 14:32:52
编辑这个贴子
子木1977 美女呀，离线，快来找我吧！ 双子座1977-5-26

等级：初级用户
文章：81
积分：238
注册：2003-10-20
第12楼
发贴心情
收藏，仔细阅读中。。。

----------------------------------------------
有心，就有翼——飞翔

点击查看用户来源及管理<br>发贴IP：218.79.103.159 2003-11-19 11:07:12
编辑这个贴子

本主题贴数12，分页： [1]
*快速回复：我之前收藏的<有关界面设计与测试的规范>
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：546.875毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：[原创]网站项目前期UI定义说明

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：[原创]网站项目前期UI定义说明

您是本帖的第 158 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： [原创]网站项目前期UI定义说明
yue 美女呀，离线，快来找我吧！ 天秤座1976-9-30

等级：中级会员
文章：412
积分：659
注册：2003-3-15
楼顶
发贴心情 [原创]网站项目前期UI定义说明
如何使用该文档?
目的
相关定义流程和参与人员
修改说明
使用人员
（一）UI开发技术规范
Frame(帧，框架)在页面中运用的问题
表格的嵌套方式
考虑不同的浏览器和分辨率
目录结构规范，文件名命名规范
（二）UI控件定义
列表和翻页
表单
全局导航栏
当前栏目标识
头部尾部区域
等等......(不详细列举,涉及公司保密)
（三）图形设计规范
统一的CI形象
主页，一级页面，二级页面， 三级页面设计规范
等等......(不详细列举,涉及公司保密)
（四）交互设计规范
命令语言设计
数据输入方式
等等......(不详细列举,涉及公司保密)
点击查看用户来源及管理<br>发贴IP：220.184.71.5 2003-10-30 17:12:20
编辑这个贴子 鲜花(0) 鸡蛋(0)
eworker 美女呀，离线，快来找我吧！

等级：实习版主
文章：1863
积分：2665
注册：2003-7-17
第2楼
发贴心情
谢谢yue……期待更多的优秀作品。

----------------------------------------------
批评是对我最大的帮助。
http://www.chinaui.com/bbs/list.asp?boardid=12

点击查看用户来源及管理<br>发贴IP：220.166.113.139 2003-10-30 23:32:04
编辑这个贴子
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
嗯，很不错，我也贴一个以前待过的网站的设计和制作规范，出发点部太相同，做一个对比供大家参考吧

一、 目的原则
二、 设计规范
Ø 结构设计规范：
1． 逻辑结构：
2． 物理结构：
3． 文件设置：
Ø 命名设计规范：
三、 制作规范
Ø 页面规范：标题、样式表、页面字符、屏幕分辨率、窗口标题格式、弹出窗口要求、网站的安全性等。
Ø 页面元素规范：
1． 文字要求：
2． 图片要求：
3． 广告条的国际通用标准
4． 表格要求
…………

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-10-31 11:43:09
编辑这个贴子
yue 美女呀，离线，快来找我吧！ 天秤座1976-9-30

等级：中级会员
文章：412
积分：659
注册：2003-3-15
第4楼
发贴心情
谢谢大家!很久没上来了^^
最近忙着别的杂事.目前本人已经接近破产的边缘了.....
明年以前,月付按揭要8k
点击查看用户来源及管理<br>发贴IP：220.184.132.1 2003-11-6 14:24:16
编辑这个贴子

本主题贴数4，分页： [1]
*快速回复：[原创]网站项目前期UI定义说明
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：328.125毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：2Advanced设计理念..

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：2Advanced设计理念..

您是本帖的第 136 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 2Advanced设计理念..
ILOHC 帅哥哟，离线，有人找我吗？ 巨蟹座1982-6-30

头衔：ILOHC
等级：中级会员
文章：477
积分：658
注册：2003-7-17
给ILOHC发送一个短消息 把ILOHC加入好友 查看ILOHC的个人资料 搜索ILOHC在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给ILOHC OICQ 访问ILOHC的主页 引用回复这个贴子 回复这个贴子 楼顶
发贴心情 2Advanced设计理念..
自称为“革命性设计技术”之主的2Advanced向Ultrashock的Craig Grannell阐述了动画理念和Flash设计技术。

在上个世界90年代末，人们对糟糕、丑陋的web商业作品变得越来越厌倦，糟糕的作品处处皆是。那么你该怎么办？当然，成立自己的设计机构。无论如何，不象那些转瞬即逝的小公司消失的甚至连一些痕迹都找不到，2Advanced经历了从小到大的发展过程，现在已经成为了公认的Flash设计技术的一支领先力量。

尽管如今拥有了一批高端的客户，包括Bacardi，福特汽车，AOL，NHL的匹兹堡企鹅队以及华纳兄弟等等，作为现今的主席和首席执行官的Eric Jordan的个人作品展示平台，2Advanced的开端是相当的不起眼。而在2000年之后发生了一些历史性的事件，促成了公司的成长和正规化。

“我们现在拥有着一批独具才能、但却非常均衡的人员组合”，首席运营官Tony Novak说道，“我们团队有着非常宽广的知识面，使得我们在各种各样的情况面前可以应付自如。由此导致了在Flash、交互性、视频、动画、3D以及传统应用方案的2Advanced风暴。事实上，团结协作在这个团队中变得越来越流行。

或许令人惊奇的是，传统的应用解决方案经常会转换为高级的Flash工程，象Eric Jordan介绍的那样：“一个公司往往通过一台个人计算机的操作界面来进行物理上的机械控制，而我们则通过Flash技术来创造这些界面，发送、收取并对这些界面进行监视。”Flash使得团队可以传造出一个能让用户直观使用的界面，以次来对他们所居住的建筑或使用的机
器进行操作和控制。

2Advanced大力拥护Macromedia的得意应用程序的真正精粹在于：“它对感觉、融合的动作、艺术、声音和交互性有着吸引力，制造一种体验大大多于完成一个工程。”Eric解释到，“你可以抓住一个人的想象力，以他们在网上从未敢想象过的方式，一种你不能用静态设计来达到的方式。它同时也是自我包含的，HTML会产生不可避免的终端和暂停，Flash则要优雅许多。”2Advanced的艺术总监Shane Mielke(Pixelranger的owner)补充说：“利用Flash，你可以把电视里的运动法则照搬到web上去，Flash会在同一个市场层上胜出，利用它显而易见的交互性。”他认为Flash为web的远景充满了燃料，它将是一个媒体的敛合体。

交互性是2Advanced作品的一个重要因素。因为Flash，HTML重重束缚的拘谨被去除，公司也发现它可以制造经久不衰的组件来加强用户的体验。Eric告诉我们：“因为声音和动作可以组合为一体，因此我们可以创造交互性的环境，仿效一切我们所能想象到的。”Tony插话：“这同样使我们在作品中添加情感，这使得人们可以从千千万万个URL中区别出我们的作品。”

盘子里的Flash?

但是Flash真的能在网上设计中体现出如此大的优势吗？或者它现在已经达到如此的高度会不会已经开始变得过时？Eric回答道：“不一定。Flash仍然很令人兴奋，目前仍是唯一一种激发人们对web兴趣的方法。”他不能预见2Advanced停止使用Flash的日期：“当宽带普及后，Internet就像电视那么快时，会有新的东西诞生，但在这之前，Flash是一个好的跳板。”

尽管2Advanced把Flash作为一个每天必须进行的项目，这个团队仍然希望有更新的发展。Eric希望早日摆脱整合视频和播放质量效果等问题的厌烦。“目前，你仍然需要额外的程序来创造特殊效果，输出图片序列并且把它们导回Flash中。”而Pixelanger希望增加可用性，就像可以直接编写HTML那样简单易行；Tony则希望ActionScript变得更加强大：“当我们为Flash电影添加高级效果时，我们需要更多的控制方法、运行库和底层的控制手段。”这样一个公司对抄袭、盗版头疼不已，Tony同时希望能看到对SWF文件更强的保护手段，让源文件代码远离那些爱Copy的手。

所有这些技术如果没有专家解释的话都会是无用的，2Advanced在他们的动画中包含了各种各样的魔术式的小技巧--他们任何一个工程的重要组成因素。Eric解释说：“对于运动图形你需要掌握的最大的技巧就是要有很强的节奏感，去感觉一下科幻电影中物体的运动方式，你会发现什么的。”

他继续解释说你必须仔细检查每一帧，保证每个物体的动作形成一个完美的流程。“你必须明白物体运动的物理原理，当一个物体远离视野的时候会慢慢的减速，这给人一个活生生的运动的感觉。”

Pixelranger认为创造动画时速度是一个有用的因素。“眼睛可以被心理和深度感觉所欺骗，如果事情发生的相当慢，眼睛可以慢慢地去分解整个的过程。如果速度相当的快，会使人们不禁再看一遍去看究竟发生了什么。”

如此的高速同样可以帮助提高带宽，Eric补充说：“高速度动画的图像可以拥有较低的质量，因为运动中的图形总会有些模糊，所以图形的细节往往会被人忽视。这样动画的大小就会减小。”

充分准备

你必须小心，避免让老的PC，或者MAC机因为迟缓的Flash插件而停顿。Eric说：“我们优化一切，无论在何种媒介上演示。不同的平台和图形芯片是影响动画流畅度的因素，你不会预见可能发生的差别。因此你必须对最坏的情景做好充分的准备。”

选择一个中等的帧速率是2Advanced的主要解决办法，另外他们在创建符号（Symbol）时也会非常小心，目的是让符号在Flash电影中得到重复的使用。另外避免大的图形、在同一时刻避免作太多的事情也是其他很明显、但是经常被忽略的细节。

那么2Advanced的未来是怎样的？“我们决定永远做交互性的锋刃，因为我们相信新媒体技术仍然会继续下去，”Tony说，“我们努力的研究视频和3D，以期在Flash中应用。”他同时声明2Advanced并不在乎数量的增长：“作为一个规模不断增长的公司，未来将会更难以维持，这已被许多这个行业内的失败所证明。你最终只会为收益率而接受项目。”同时驱使公司进步的更多的是创造，而不是钱。Eric说：“2Advanced给了人们吸收Flash潜能和交互性设计的机会，我们一直承担着风险，但是这样做刺激着我们设计者的创造性，使我们沉浸在motion-rich的环境而不是普通、静态的网站。”

----------------------------------------------
心！总是悄悄的泛起一点忧郁，特别是在追忆往事的时间。一台电脑、一首情深的歌、一杯酸柠茶，生活就是那么的简陋。

点击查看用户来源及管理<br>发贴IP：218.88.42.35 2003-11-5 10:50:58
编辑这个贴子 鲜花(0) 鸡蛋(0)
blackeyes 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：16
积分：86
注册：2003-3-6
第2楼
发贴心情
确实很眩，把艺术设计与web技术结合到了极致
补充链接：
http://www.2advanced.com/
http://www.ultrashock.com/
点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-11-5 12:50:12
编辑这个贴子
木子 帅哥哟，在线，有人找我吗？ 天秤座1983-10-23

等级：高级会员
文章：918
积分：1540
注册：2003-4-30
第3楼
发贴心情
没有最好的工具，只有更好的设计师
经典

[此贴子已经被作者于2003-11-6 9:19:08编辑过]

----------------------------------------------
——+++++U

点击查看用户来源及管理<br>发贴IP：219.139.215.22 2003-11-6 9:18:47
编辑这个贴子
lsm2008 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：1
积分：54
注册：2003-5-11
第4楼
发贴心情
是呀，说的很对，希望他们能给flasher们带出一条新的，光明的路...
点击查看用户来源及管理<br>发贴IP：218.17.205.175 2003-12-24 17:45:14
编辑这个贴子
LOVEM 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：94
积分：192
注册：2003-4-30
给LOVEM发送一个短消息 把LOVEM加入好友 查看LOVEM的个人资料 搜索LOVEM在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给LOVEM OICQ 访问LOVEM的主页 引用回复这个贴子 回复这个贴子 第5楼
发贴心情
200K/s ，还可以下！

----------------------------------------------
我喜欢呀我喜欢……

点击查看用户来源及管理<br>发贴IP：61.48.11.84 2003-12-25 12:20:50
编辑这个贴子

本主题贴数5，分页： [1]
*快速回复：2Advanced设计理念..
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：500.000毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：Alan Cooper：垃圾，都是垃圾！

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：Alan Cooper：垃圾，都是垃圾！

您是本帖的第 174 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： Alan Cooper：垃圾，都是垃圾！
eworker 美女呀，离线，快来找我吧！

等级：实习版主
文章：1863
积分：2665
注册：2003-7-17
楼顶
发贴心情 Alan Cooper：垃圾，都是垃圾！
昨天整理硬盘发现的一篇旧文，不过现在看来也饶有趣味。

Alan Cooper：垃圾，都是垃圾！
2001年12月15日上午10:00-12:00，“交互设计之父”Alan Cooper作客UMLCHINA讨论组的聊天室，畅谈交互设计。Alan Cooper是软件交互设计的先知和传播者，客户咨询公司Cooper Interaction Design的创始人和总裁。他设计了第一个可视化开发工具Visual Basic，他的公司帮助IBM、3M、Ericsson、Sun、Visa...等客户开发了许多具有市场竞争力的产品。要更多了解Alan Cooper的思想，请看以下资料：（1）《非程序员》第七期的第一篇文章“交互设计之父Alan Cooper访谈”；（2）去书店买他的著作：《软件创新之路--冲破高技术营造的牢笼》。以下是交流实录。由dewen翻译。错误难免，如有疑问，请对照原文。

fly cat: 大家对您的《软件创新之路--冲破高技术营造的牢笼》这本书有很深的印象，在这本书中你想说的是什么呢？
alancooper: 我尽力想阐明另外一条关于软件如何设计和发展的思路。
extreme: 能告诉我在哪儿能下载这本书的英文版本吗？谢谢！
alancooper: 我想可能没有地方能够下载到该书完整的英文版本，你可以从Amazon.com在线购买一本。
umlchina: Cooper先生，你认为Windows的界面怎样？和Mac比较呢？从交互设计的角度出发！
alancooper: 我认为Windows和Mac的界面是相似的。
umlchina: 相似－－那是好还是坏呢？
alancooper: 在1984年是同样的好，但在2001年，就是同样的过时、灰暗和单调了。
yuminghui: 绝大部分中国大学生仅仅知道简单的VB编程，但是却认为自己是顶尖高手。
alancooper: 在美国也是如此。
yuminghui: 我指的是那些年轻的家伙，包括那些刚开始编程的人。他们在开始时不应该用VB或UML等类型的工具。
alancooper:优秀的程序人员编程不依赖于任何具体的程序设计语言。
boss_ch: 你认为Windows XP的界面怎样？
alancooper: 我认为Windows XP和其他的Windows及Mac是一样的。
extreme: 据说C#将很快取代VB，Cooper你对此怎么看呢？
alancooper: C#看起来象一个很好的语言。
guodd: 顶尖的程序员是否象艺术家？
alancooper: 我不认为编程是一种艺术，我觉得它像一种工艺，就象制陶或吹制玻璃。
fly cat: 你强调了交互设计的重要性，不过在我看来，当一个程序需要人机交互的时候，它是有用的。不过对于有些程序来说.... 例如对于实时监控设备的内嵌系统，还有用吗？你认为呢？
alancooper: 我不认为交互设计对于程序员做任何系统都是有效的，交互设计是针对交互设计师的。
fly cat: 编程是工艺，但是设计是艺术？
alancooper: 设计也是一种工艺。
extreme: Cooper先生，你认为作为一个交互设计师需要什么样的背景或知识基础。
alancooper: 好的交互设计师需要接受交互设计方法的培训。
extreme: 你是说，绘画或者艺术？
alancooper: 艺术意味着在软件设计或规划方面没有规则。
shenqw: 交互设计师需要懂得编程吗？
alancooper: 交互设计师需要懂得什么对于程序设计人员是重要的，但是不需要知道怎样编程。
fly cat: 什么样的工作背景对交互设计师来说是最重要的？技术或市场？
alancooper: “技术和市场”，两者都不需要，交互设计的字义本身就已经说明了它自己。
extreme: 我猜想他可能需要懂得心理学方面的知识，你说呢？
alancooper: 交互设计师必须知道哪些对于心理学家是重要的。
yuminghui: 这样说来老板需要招聘心理学专家参加项目了？
alancooper: 不，正好相反，因为有了交互设计师，所以他们再也不需要心理学专家参加项目了。心理学专家不能设计交互系统。
wrymy: 现在流行的网页设计，例如HTML、XML等，我们发现想找一个界面友好的网站是很困难的，特别是企业网站。Web页面上的控制是非常困难的，特别是当界面很复杂时！
alancooper: “网页的控制非常困难”，千真万确！
shenqw: 但是交互设计师怎样知道他们应当在屏幕上显示什么东西？
alancooper: 这和程序员知道该在编辑器中输入什么样的代码一样！
wrymy: 那么你对于网页的编写有什么建议吗？
alancooper:把所有的交互组件放在一个页面上。
extreme: 如果某人想成为一个交互设计师，他应该怎样做呢？
alancooper: 停止编程。
extreme: 为什么要停止编程？
alancooper: 因为程序员和设计师的目标是有冲突的，你不可能同时做好两件事情。
umlchina: “程序员和设计师之间有冲突”：但是他们在同一个团队中。
alancooper: 不，程序员和设计师的“目标”是有冲突的。
extreme: 看来我没有机会成为一个交互设计师了，因为我是如此地喜欢编程。
alancooper: 如果你如此喜欢编程，为什么你想成为交互设计师？
fly cat: Cooper先生，你能简要描述一下交互设计的实质吗？
alancooper: 让技术为用户服务，而不是让用户服务技术。
extreme: 那么，你认为作为一个程序员或PM应当了解交互设计吗？
alancooper: 好的交互设计师在你采用他们的计划时可以给出令人信服的原因。
umlchina: 一个好的交互设计师一般使用哪些工具？你能介绍一个吗？
alancooper: 我们用定性的现场调查技术，用户建模方法，设计原则，设计模板，许多纸和白色书写板。
extreme: 但是如果作为一个PM对此没有任何了解，我怎样知道那小子将带领我们走向成功呢？
alancooper: 对，你怎样才能知道呢？编程方面的知识能帮助你吗？我认为不能。
extreme: 那么，什么能帮助我？
alancooper: 一个交互设计师。
extreme: 但是我认为现在在中国发现一个好的交互设计师不是很容易。
alancooper: 寻找一个好的交互设计师和寻找一个好的程序员同样的困难，在任何地方都是如此。
wrymy: 我认为extreme的意思说，怎样判定交互设计师设计的好坏呢？
alancooper: 为什么程序员要越过交互设计师来参加判断呢？
hdw1978: 灵感，在绝大多数的案例中，你从哪里得到灵感？
alancooper: 程序员从哪里得到灵感？
umlchina: 有什么好的参考书能告诉我们怎样一步一步来做交互设计？
alancooper: 还没有，但是我们现在正在编一本。
fly cat: 我有一个感觉，Cooper先生是想鼓励我们自己寻找答案，而不是直接告诉我们。
alancooper: 交互设计不是工程类学科。
umlchina: 对于新书的编写你有什么计划吗？
alancooper: 在Cooper有两个高级设计师从事教材编写的工作。
extreme: 我建议Cooper先生做一个中国的培训计划，以便能给我们一些实际的指导。
alancooper: 这是一个好注意。
shenqw: 什么样的人能够成为交互设计师？他们应当有哪些方面的能力？
alancooper: 交互设计师需要具备凭空想象复杂行为的能力，交互设计应当在任何代码编写之前做。交互设计师必须能够在代码被写出来之前，想象它是做什么的。
fly cat: 但是我认为如果交互设计师没有实际的经验的话，他们想建立威信是非常困难的。
alancooper: 确实如此
extreme: 这种凭空想象复杂行为的能力能够训练出来吗？
alancooper: 只有当你生来就是个天才，才不用接受训练。就象如果你生来就是编程天才，就不需要编程能力训练一样。
fly cat: 我感到很困惑。
alancooper: 困惑--这是一个非常好的开始！
fly cat: 然后呢？
alancooper: 然后你得作好准备学习一种非常困难、非常不同的技术。
alancooper: 我不懂一个工程师为什么想做交互设计师？工程师们厌恶交互设计师所做的工作。交互设计师要处理的是人。没有CPU、编程语言、操作系统！
extreme: 我们只是想能更好地和交互设计师沟通。
alancooper: 这真是太好了！
shenqw: 按你的观点，交互设计师必须有一些编程经验吗？
alancooper: 为什么你这样认为呢？
fly cat: 因为如果他没有编程方面的经验，他想让程序员听他的将非常困难。
alancooper: 你的意思是工程师不听从交互设计师的安排？为什么不呢？
hzmajw: 艺术家能从事交互设计师的工作吗？或者办公室助理能从事交互设计工作吗？
alancooper: 交互设计不是艺术。办公助理能写代码吗？交互设计与写代码相比是一个复杂的、老练的、困难的工作。
fly cat: 在交互设计师建立他的威信前，形势是非常困难的。成为一个好的程序员也是建立他的威信和自信的一种方法。
alancooper: 为什么交互设计师要向程序员证明自己？为什么不是程序员向交互设计师证明自己？
fly cat: 但是在实际中，这是现实存在的。
alancooper: 我的工作就是要改变现实。
shenqw: 好，交互设计师不需要编程经验。那他怎样在代码被写出来之前想象它是做什么的呢？
alancooper: 那是交互设计师要做的，如果你不能做到这一点，你就不是一个交互设计师。
developerly: 在你成为一个设计师之前，你做过编码方面的工作吗？
alancooper: 仅仅做了大约15年。
extreme: Whao！仅仅15年！
fly cat: 在我看来，你也需要通过VB之父这种经历来建立你的权威。
alancooper: 我编写了VB的可视化部分的代码。
developerly: 那么你认为你的编码经历对你的设计工作曾有过帮助吗？
alancooper: 在我的公司，我们有40位交互设计师，他们没有一个人写过代码，他们只是将代码要实现的功能形象化。
extreme: 这样的话，你怎样让我相信一个好的设计师不需要了解任何编程方面的东西呢？
alancooper: 许多Cooper's的设计师从来没有写过一行代码。
umlchina: 有没有交互设计方面的工具？
alancooper: 有，但是没有一个能脱离软件。
alancooper: 你们刚才问我的问题，和六年前加州的程序员们问我的问题差不多。
extreme: 那也是为什么我们要来这里听一些意见的原因。
alancooper: 我真的感激你们的参与和对此的兴趣。
fly cat: 好象一个好的程序员很难成为一个好的交互设计师。
alancooper: 为什么他们想成为交互设计师？
umlchina: 既不是艺术家，也不是程序员，想开发这样一个新的职位是很难的。
alancooper: 对，没错。我们现在已经做到了。
fly cat: 在中国，程序员的发展之路是：编码-->设计-->管理。
alancooper: 我认为这是不正确的。应当是初级程序员-->程序员-->高级程序员；初级设计师-->中级设计师-->高级设计师；初级管理者-->中级管理者-->高级管理者。程序员通常是一个差的设计师和差的管理者。所有的工作职称都含糊不清和令人困惑。
jazy: 我想你的意思是交互设计师负责表达，程序员负责逻辑，缺少任何一部分都将做不成事情。
alancooper: 你说得对。“缺少任何一部分都将一事无成”：对，对，对！！！！！
hzmajw: 每个人都应当考虑哪种角色最适合他自己。当他有目标时，他将能把他的工作做得很好。
alancooper: 真正喜欢编程，而且确实精于编程的人，应当继续编程，做别的都是浪费。
extreme: 但是有时候老板需要你成为一个PM，那应该怎么办？
alancooper: 那老板应当回去编程。
extreme: 你现在已经成为一个著名的交互设计师了，这是否意味着你不再喜欢编程了？
alancooper: 我喜欢，但是我对它不再有足够的兴趣了。
fly cat: 但是我认为，当我们年轻时，我们喜欢做一些编程方面的工作，去了解一些事情，然后我们有了更多的经验，自然地我们就想做一些设计方面的工作。
alancooper: 这仅仅对有些人来说是对的。
umlchina: 根据你的交互设计观点来看哪一种手机更好？Motolora, Nokia, Ericsson?
alancooper: 我认为他们都是垃圾。
umlchina: 但是...他们都很笨吗？加上microsoft、IBM？他们都是一样的笨？
alancooper: 手机不应该成为一团。为什么我需要将键盘举到我的耳边？为什么作为一个和人交流的工具要有号码？我认为手机应当是隐形的，一个带小型麦克风的听筒放在头部。
extreme: 隐形是什么意思？藏在衣服里？
alancooper: “藏在衣服里？”，这是一个好的开始。
fly cat: 蓝牙？！
alancooper: 蓝牙是一个好的主意，但不是一个非常好的协议。手机最重要的部分是如何控制它，而不是如何通话。为什么手机需要用到我的双手、双眼、一只耳以及我全部的注意力？
品雪: 有很多这样的例子：用户告诉你需要在很短的期限内完成项目，然后给你提出许多不断变化的需求来。这里还能有某种交互设计吗？
alancooper: 这只能说明那里的管理非常差。
品雪: 您对这样的坏环境有什么建议吗
alancooper: 建议，在没有完成软件行为描述文档前，告诉管理者不要让你们开始编码。功能和表达不是一回事。特征和行为不是一回事。
extreme: 你认为我们能怎样将行为文档化？
alancooper: 画图形。
extreme: 用什么工具？photoshop?
alancooper: 用铅笔。我们经常用白板。PowerPoint也挺好的。
extreme: 那么，我们到哪里和怎样发现这样的设计师呢？
alancooper: 他们就在那里。可能不在编程人员中，可能在技术支持，测试，文档编写...等人员中。当交互设计师被压抑如此长的时间之后，寻找他们是非常困难的。
umlchina对品雪说: 我认为交互设计是对产品的，而不是对项目的。
alancooper: 产品和项目，其中的差别是不明显的。对于用户来说，没有一个比设计更重要。
fly cat: 在美国，交互设计师是否已经普及了？
alancooper: 正在不断发展。
umlchina: web将何去何从？HTML作为交互设计并不适合？
alancooper: HTML是垃圾。
fly cat: 在美国推广交互设计遇到的最大困难是什么？
alancooper: 让高级主管相信不需要花费很多金钱和时间，他们的软件可以有重大的变化。
umlchina: 但是它简单。
extreme: 也流行。
alancooper: 所以是犯罪。
extreme: 但是对于在互联网上的信息交流，它做得非常好。
alancooper: 不，完全不是这样。
umlchina: 流行<-->犯罪？
alancooper: HTML<--->犯罪！许多HTML的限制能通过好的设计来弥补，但是很少有程序员能听从设计师的意见。越过HTML的限制也需要大量复杂的代码。
fly cat: 你考虑过在中国推广你的观念吗？仅仅依靠书是不够的。
alancooper: 我现在正在推广它们。回去也请告诉你们的老板！
extreme: 我非常希望能在中国看到你的书的英文版本。
alancooper: 我也想看到我的书在中国销售。
kenxia: 多少钱？我希望它不要太昂贵。
alancooper: 对书我没有办法控制，它由出版商决定。
fly cat: 你能列举几个不是你们公司的好的交互设计师吗？可能他们和你做同样的事，但是不叫交互设计。
alancooper: Rob Haitani设计了Palm Pilot。Ben Schneiderman设计了SmartMoney.com marketmap。
kenxia: 你认为C++怎样？
alancooper: 学习C++和学习弹钢琴一样容易。
umlchina: WEB将走向哪里？既然HTML是垃圾。
alancooper: 更聪明的浏览器。它应当能记住信息，将相关资料写到磁盘上，和服务器交互通信。它应当有更好的交流方式，比如象拖拉、卷动、刷新。
extreme，umlchina: “往磁盘上写信息”安全吗？“聪明的浏览器记录资料”与隐私权相冲突吧？
alancooper: 对，那是需要解决的问题。但是解决起来并不困难。
fly cat: 如果交互设计师做错了一些事情呢？他们在项目中的地位是如此重要，所以很容易毁了所有的事情。
alancooper: 如果程序员做错了一些事情呢？
extreme: 解雇他！
alancooper: 对，专业人员不能犯错误。
smilemac: Alan你好，对于一个项目中有限的时间及好的交互设计之间的冲突你是怎样看的？
alancooper: 为什么有时间限制？谁将时间定得这么短？为什么定得这么短？他缩短时间是为了什么？
joy_wind: 时间就是金钱。
alancooper: 浪费了的时间是金钱。
joy_wind: 老板关心他的钱，我们关心项目。
alancooper: 管理者将时间期限定得短是因为他们不知道程序员在做什么。交互设计师能告诉管理者程序员在做什么。交互设计师能给程序员争取更多的时间。
extreme: 按你书中的观点，管理者必须布置一些事情。
alancooper: 仅仅是因为在程序被做出来之前，他不知道它是什么样子的。
smilemac: 例如市场压力、预算、管理水平等等，这些都可能造成项目时间限制，许多产品是它们之间相互妥协的结果。
alancooper: “...市场压力，预算...”，所有的都是管理者掩饰他对程序不了解的借口。
fly cat: 我认为交互设计关注的焦点是用户的需求而不是设计。
alancooper: 对！！！就象我在前面所说的，交互设计和用户界面设计不是一回事！
extreme: 那么谁负责确定软件将要做什么？交互设计师吗？
alancooper: 交互设计师就是具有能非常好地解答上述问题，以便别人顺利完成任务的人。
extreme: 谁控制过程？交互设计师吗？
alancooper: 过程应该由管理者来控制。
joy_wind: 交互设计师的工作职责是什么？
alancooper: 程序的外观和行为应该由交互设计师控制。技术和编码应当由程序员控制。
kenxia: 控制？通过权力还是通过技巧？
alancooper: 今天程序员通过什么来控制呢？他们好象不需要特定的技能来做设计。
extreme: 这样的话，交互设计师看起来象分析员。
alancooper: 交互设计师的工作之一就是分析。但是“分析”不是设计。
joy_wind: 交互设计师是否更像建筑师？
alancooper: 对，对，对！！！
extreme: 但是一个毫无编程知识的家伙怎样来做分析呢？
alancooper: 那程序员怎样能决定用户想要什么呢？
extreme: 我不是说程序员应当了解需求，我仅仅是想说，一个交互设计师应当了解一些编程知识以便做一些分析工作。
alancooper: 为什么？我觉得你的真正意思是你担心交互设计师将会让你去干一些愚蠢的事情！
extreme: 对，我不认为一个对编程毫无了解的人能做好分析工作。
alancooper: 但是一个好的专业交互设计师不会设计出不能实现的、难以运行的东西。
品雪: 你说的分析主要是关于用户知识领域。
alancooper: 对！
tipsyy: 那么请告诉我，交互设计师在一个项目中负责做什么？他担负什么样的职责？
alancooper: 交互设计师应当负责程序做什么和怎样表达。我们设计项目的第一部分是针对问题域详细研究项目。
smilemac: 交互设计师和项目管理者可以是同一个人吗？
alancooper: 为什么？为什么让一个领域的专家工作于另一个领域？
fly cat: 时间快到了，你们认为结束聊天好吗？
alancooper: 我想我必须走了。很高兴有机会和大家谈话。非常感谢大家！！！！！

----------------------------------------------
批评是对我最大的帮助。
http://www.chinaui.com/bbs/list.asp?boardid=12

点击查看用户来源及管理<br>发贴IP：159.226.83.33 2003-12-23 10:09:42
编辑这个贴子 鲜花(0) 鸡蛋(0)
透蓝 帅哥哟，离线，有人找我吗？ 狮子座1982-8-17

头衔：教主
等级：实习版主
文章：2156
积分：3543
注册：2003-2-23
给透蓝发送一个短消息 把透蓝加入好友 查看透蓝的个人资料 搜索透蓝在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给透蓝 OICQ 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
我觉得工艺也有它的艺术价值。。。。

----------------------------------------------
==============================================
以上内容仅代表个人意见
==============================================

点击查看用户来源及管理<br>发贴IP：220.169.241.168 2003-12-23 11:08:04
编辑这个贴子
eworker 美女呀，离线，快来找我吧！

等级：实习版主
文章：1863
积分：2665
注册：2003-7-17
第3楼
发贴心情
以下是引用透蓝在2003-12-23 11:08:04的发言：
我觉得工艺也有它的艺术价值。。。。

同意透蓝，发这篇文并非因他说的全对，呵呵，只是因为Alan Cooper太有意思啦。

----------------------------------------------
批评是对我最大的帮助。
http://www.chinaui.com/bbs/list.asp?boardid=12

点击查看用户来源及管理<br>发贴IP：159.226.83.40 2003-12-23 11:17:28
编辑这个贴子
小林 美女呀，离线，快来找我吧！

等级：版主
文章：342
积分：601
注册：2003-6-12
给小林发送一个短消息 把小林加入好友 查看小林的个人资料 搜索小林在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给小林 OICQ 访问小林的主页 引用回复这个贴子 回复这个贴子 第4楼
发贴心情
我也喜欢认为交互设计是工艺。

说明它有一套做事的程序，它也有很多发挥的地方。

----------------------------------------------
/○\
/■\ Human Factors makes the world easy and simple.
<|

点击查看用户来源及管理<br>发贴IP：61.175.193.152 2003-12-23 13:22:32
编辑这个贴子
dozer 帅哥哟，离线，有人找我吗？

等级：中级会员
文章：466
积分：784
注册：2003-6-15
第5楼
发贴心情
这个家伙很厉害。需要这样的大师为中国的程序员洗脑。

那些一再追问交互设计师是否需要有编程背景的主导思想就是：你技术都不懂，凭什么对我指手画脚？ 在国内一个PM如果技术不好，是很难让下面的人服从的。在这种大环境下，往往是技术主导着产品，要实现以用户为中心的设计是多么的困难。

但是，alan cooper也提到“但是一个好的专业交互设计师不会设计出不能实现的、难以运行的东西。”。。我的理解是：这点很重要，这需要做设计的人多学习很多东西，需要有大量的经验，包括行业方面的知识，比如要设计pROJECT MANAGEMENT,如果连项目管理方面的知识都很缺乏，如何去设计一个好的软件？

我的另外的理解是，交互设计需要了解编程方面的知识，不一定需要写代码，但是应该知道说设计的东西意味着的代价是什么，是否对程序员造成额外的负担，或者超出程序员的能力。。毕竟想像力是容易失去控制的。。似乎每个人都可以做设计，但是没有经验的设计者对开发者是一个恶梦的制造者。

点击查看用户来源及管理<br>发贴IP：218.80.75.38 2003-12-23 14:45:04
编辑这个贴子
烛音 帅哥哟，在线，有人找我吗？

等级：实习版主
文章：5186
积分：7085
注册：2003-5-22
第6楼
发贴心情
这个家伙的书看了很有意思，不谈实作，只谈逻辑与概念，我觉得不错。他在谈到微软的部分的时候，让人认识到，再大的公司其实也有技术和管理方面的漏洞。

----------------------------------------------
http://www.cqppi.com/1/1.html

点击查看用户来源及管理<br>发贴IP：211.158.67.195 2003-12-23 15:24:12
编辑这个贴子
x3d 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：119
积分：314
注册：2003-5-12
给x3d发送一个短消息 把x3d加入好友 查看x3d的个人资料 搜索x3d在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给x3d OICQ 引用回复这个贴子 回复这个贴子 第7楼
发贴心情
什么时候叫CCTV把它请到对话栏目去
点击查看用户来源及管理<br>发贴IP：218.5.43.198 2003-12-23 16:59:59
编辑这个贴子
LOVEM 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：94
积分：192
注册：2003-4-30
给LOVEM发送一个短消息 把LOVEM加入好友 查看LOVEM的个人资料 搜索LOVEM在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给LOVEM OICQ 访问LOVEM的主页 引用回复这个贴子 回复这个贴子 第8楼
发贴心情
看完，果然让我明白不少，现在正在经历6～7年前美国的阶段，希望大家能赶超啊！

----------------------------------------------
我喜欢呀我喜欢……

点击查看用户来源及管理<br>发贴IP：61.48.11.84 2003-12-25 11:59:02
编辑这个贴子
uicat 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：38
积分：120
注册：2003-8-11
第9楼
发贴心情
有道理
点击查看用户来源及管理<br>发贴IP：61.144.254.210 2003-12-25 16:10:15
编辑这个贴子
yue 美女呀，离线，快来找我吧！ 天秤座1976-9-30

等级：中级会员
文章：412
积分：659
注册：2003-3-15
第10楼
发贴心情
不错的!我以前刚做图形设计的时候认为,自己要做的东西需要赋予生命力.
但是后来知道产品设计不同,设计阶段谁都喜欢做,但真正做好一个产品需要的是设计以外的大量的让人没兴趣的烦躁工作.
点击查看用户来源及管理<br>发贴IP：218.109.195.22 2003-12-26 23:07:25
编辑这个贴子
mhxm 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：38
积分：106
注册：2003-6-3
第11楼
发贴心情
看完，果然让我明白不少，成名以后都特牛！忘了当初眼前黑黑的时候。不知有没有自传类的文章，对话里面信息太粗糙了，争论了一些没有结果的东西，真想看看他们成长时，是否有上帝特别关爱，我从不相信完美的环境，也不存在，一个指引者应该传授别人自己的挫折和经验，太霸气只能曲高和寡，盼着能找到更多的资料，这位外国先生说话滴水不漏，版权意识真令人佩服，说不定只好花点钱供一供他了，哈哈！刚才同事带回一支远香斋的铁公鸡，啃得我牙疼，希望这老外不要也像只铁公鸡才好，哈哈！大家都喝一杯！创意感觉说不定更好，干！ 再过个十年八年，等大家都胡子大把时，也弄个专家当当！
点击查看用户来源及管理<br>发贴IP：210.77.194.42 2003-12-27 0:52:17
编辑这个贴子
yue 美女呀，离线，快来找我吧！ 天秤座1976-9-30

等级：中级会员
文章：412
积分：659
注册：2003-3-15
第12楼
发贴心情
以下是引用mhxm在2003-12-27 0:52:17的发言：
看完，果然让我明白不少，成名以后都特牛！忘了当初眼前黑黑的时候。不知有没有自传类的文章，对话里面信息太粗糙了，争论了一些没有结果的东西，真想看看他们成长时，是否有上帝特别关爱，我从不相信完美的环境，也不存在，一个指引者应该传授别人自己的挫折和经验，太霸气只能曲高和寡，盼着能找到更多的资料，这位外国先生说话滴水不漏，版权意识真令人佩服，说不定只好花点钱供一供他了，哈哈！刚才同事带回一支远香斋的铁公鸡，啃得我牙疼，希望这老外不要也像只铁公鸡才好，哈哈！大家都喝一杯！创意感觉说不定更好，干！ 再过个十年八年，等大家都胡子大把时，也弄个专家当当！

我喜欢他的发言!也希望你能够尊重他!
点击查看用户来源及管理<br>发贴IP：220.184.112.52 2003-12-30 11:01:49
编辑这个贴子

本主题贴数12，分页： [1]
*快速回复：Alan Cooper：垃圾，都是垃圾！
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：984.375毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：[译]Fitts的UI法则在WEB中的应用

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：[译]Fitts的UI法则在WEB中的应用

您是本帖的第 293 个阅读者 浏览上一篇主题 刷新本主题 平板显示贴子 　 浏览下一篇主题
* 贴子主题： [译]Fitts的UI法则在WEB中的应用
why 美女呀，离线，快来找我吧！ 天秤座1979-10-23

等级：初级用户
文章：66
积分：214
注册：2003-3-19
楼顶
发贴心情 [译]Fitts的UI法则在WEB中的应用
nothing can be contributed for the new board but an article i translated some days ago...i know my enlish is limited,so i am sorry...

Fitts's UI Law Applied to the Web
Scott Berkun
Microsoft Corporation

May/June 2000

Summary: Discusses Fitts's UI Law and how it applies to designing Web pages. (3 printed pages)

Fitts的UI法则在WEB中的应用

概要：探讨了Fitts的UI法则以及怎么应用在设计网页中

Interface design is difficult in part because everything requires interpretation. A design that works for one task or one user might not be appropriate for another. In other types of engineering, like architecture or bridge building, designers can always rely on laws of physics and gravity to make designs work. There is at least one immutable rule for interface design that we know about, and it's called Fitts's Law. It can be applied to software interfaces as well as Web site design because it involves the way people interact with mouse or other pointing devices. Most GUI platforms have built-in common controls designed with Fitts's Law in mind. Many Web designers, however, have yet to recognize the powerful little facts that make this concept so useful.

The basic idea in Fitts's Law is that any time a person uses a mouse to move the mouse pointer, certain characteristics of objects on the screen make them easy or hard to click on. The farther the person has to move the mouse to get to an object, the more effort it will take to get to. The smaller the object is, the harder it will be to click on. Pretty simple, right? It means that the easiest objects to locate and target are the ones closest to the mouse's current position and that have large target spaces. Fitts wrote several papers describing these findings, with significant mathematical rigor, expressing in formulas how you can measure the impact of different velocities, distances, and target sizes on a user's ability to click on objects. The worst possible object is one that is very far away from the current position of the cursor, and very small in size.

We tend to put toolbars on the top, bottom, and sides of the screen because of the unnatural boundary created by the edges of the screen. According to Fitts's Law, these targets are almost infinitely targetable, since they are impossible to go past. You could move your mouse as hard as you wanted to into the upper-left corner, and never get past the first pixel on the screen (unless you have a virtual desktop). Even without these boundaries, there are good visual and organizational reasons to put strips of commands at the top of the screen. It helps frame the page and provides a visual anchor that is easy to refer to. With the exception of physical screen borders, the shorter the distance you make the user navigate to perform a common task, the easier it will be for the user to target it precisely.

界面设计是比较难，因为每件东西都要求有充分的根据。一个设计适合完成某项任务或者适合一个用户却不一定适合另外一项工作或用户。在其他工程中，比如建筑或架设桥梁，设计师总可以依赖一些物理的重力的原理来完成设计工作。而界面设计当中，至少我们知道有一个不变的法则，叫“Fitts法则”。它可以象在网站中一样的运用软件界面中，因为它包含了人们用鼠标或其他设备进行交互的方式。多数GUI平台的常用控制设计都建立在Fitts法则之上。很多网页设计师，已经意识到这些法则非常有用。

Fitts法则最基本的观点就是任何时候，当一个人用鼠标来移动鼠标指针时，屏幕上的目标的某些特征会使得点击变得轻松或者困难。目标离的越远，到达就越是费劲。目标越小，就越难点中。漂亮简单，对么？这意味着要是目标定位越容易，距离鼠标当前位置就应该越近，目标占用空间应该有更大。Fitts花了好几页来描述这些发现，用明显数学式的严谨，用公式表达出了怎样去测量不同速度距离目标尺寸对用户点中目标的影响。目标和鼠标指针越远，尺寸越小，就越难点中目标。

我们倾向与把工具栏拖到顶部，底部，或者屏幕两边，因为屏幕产生的边缘。根据Fitts法则，这些目标已经无限接近，既然他们不可能跑出去。。你可以尽可能的移动你的鼠标到左上角，但你永远不可能点到屏幕外边去（如果你没有一个真实的桌面）。即使没有这些边界，还是有视觉很好的组织好的理由将命令条放到屏幕顶部。它帮助画出了页面结构，提供一个可见的锚点，容易。。排除显示器的边框，用户导航条到执行一个普通任务之间的距离越短，用户准确点中目标就越容易。

此主题相关图片如下：
按此在新窗口浏览图片

Figure 1. The blue line represents the boundary of the clickable region.

Something you can do to ensure that objects are easy to click on is to give them large target spaces. Take a look at the examples in Figure 1. The blue line represents the area of the button that can be clicked on. The design on the left requires the user to target a very small space. Most of the button is wasted space, since only the area around the text is clickable. With Fitts's Law, depending on how far they have to move the mouse to get to this button, it can be very difficult to target it without making mistakes. In some cases, only the text itself is clickable, which can be very small depending on the font size used. The design on the right makes use of the entire available space, and is much easier to target. If you are reading this on the Web, try to target each of these buttons by starting at different parts of the screen. You'll notice the effect of Fitts's Law, and how you have to pay more attention to targeting the example on the left.

图1：蓝色线框是可点击范围的边界。

要确保物体容易被点中，你可以使它的空间大一些。看看图1，蓝色线画出了按钮可响应区域。左边的设计给用户一个很小的区域能点。很多按钮都很浪费空间，因为只有按钮上的文字可以被激活。根据Fitts法则，鼠标移动到按钮的距离越远，用户就越难准确的点中目标。在一些案例中，只有文字本身可以点击，而文字可能因为用的字体而显得很小。右边的设计充分利用了整个可用的区域，因而更容易点中。如果你是正在网上读这篇文章，可以去点一下这两按钮，让鼠标从屏幕的各个不同部分去试一下。你将发现Fitts法则的效果，你不得不花更大的精力去点中左边的按钮。

此主题相关图片如下：
按此在新窗口浏览图片

Figure 2. The example on the right shows how a larger clickable space is easier to target.

Figure 2 shows examples that illustrate how Fitts's Law can make buttons easier to click. Most Web browsers change the mouse cursor when the mouse is over a clickable target. This is a nice reinforcement, but the user shouldn't have to rely on that to figure out what is clickable on the screen. In both of these examples, the visuals imply that the clickable area is the entire space between the white borders. What you imply to a user should almost always be exactly what you give them. If you force your user to spend a lot of time wandering around the screen figuring out what they can click on and what they can't, they might not want to come back again.

Another important area where Fitts's Law is often ignored is on search results pages. Many search services offer the ability to jump from page to page in the results list in any order you like. Though it's rare that this kind of access is needed, it's not a problem by itself. What often happens is that the designer uses small fonts and poor spacing for the individual page choices. The results are several very small targets in close proximity to one another. Applying Fitts's Law to this example, it's clear that the individual items are difficult targets, and the likelihood of errors or the user needing extra time to target it properly are very high. The simplest solution is to replace the strip of individual pages with a large, easy to target "next page of results (11-20)" link. If your search results are ranked, the user will almost always want to view them in the set order anyway. Why make things more complex than necessary?

图2：右边的例子显示了大的可响应区域容易被点中

图2是Fitts法则让按钮容易被点中的图解例子。当鼠标在可点击区域时，大多数浏览器会改变指针形状。这是个很好的提醒，但用户不会依赖这个来找到屏幕上什么是可点的。在这两个例子里，这些图表明了白色边框中间的整个区域都是可以点击的。你告诉用户的应该就是你想给他们的。如果你强迫用户花很多时间在屏幕上摸索哪些可以点，哪些不能，他们恐怕再也不想来访问了。

Fitts法则经常被忽略的另一个重要区域是搜索结果页面。许多搜索服务允许从一个结果页面跳转到其他任何一页。但这很少被用，虽然服务本身并没有问题。通常，设计师用很小的文字和可怜的小区域来放每页的序号。结果，这些小序号都挤在一起。运用Fitts法则到这个例子中，很明显，每个单独项都是不同的目标，用户通常就不得不花额外的时间来点中目标。最简单的办法就是把这条页码换成大的容易点中的目标链接“下一页结果（11-20）”。如果你将搜索结果分类，用户就总想要看看他们。为什么总要增加不必要的麻烦呢？

此主题相关图片如下：
按此在新窗口浏览图片

Figure 3. An example of small click targets in close proximity, making it difficult to target them easily.

More Fitts
Searching the Web for Fitts's Law will reveal many of the specific papers and applications that have been developed in the decades since the initial studies were done. There is a deep legacy of work on cognitive/motor skills in relation to how user interaction with computers really works. Several interesting starting points are listed below:

Tradeoffs in Targeted Movements: A Literature Survey of Related Work ( [image] http://www.cogsci.soton.ac.uk/bbs/LinkCited/bbs.plamondon.html)
Drag Drop vs. Point and Click: An Interesting Study Relying on Fitts's Law ( [image] http://www.cs.sfu.ca/~inkpen/Papers/TR20_DD/tr20.html)
The HCI bibliography is a great reference for existing research on any UI topic, including Fitts's Law ( [image] http://www.hcibib.org/).
图3。一个例子，显示了小的靠的很近相似目标很难被准确点中。

更多Fitts法则
在网上搜一下Fitts法则，会找到很多很详细的文章，还有从开始到现在发展了数十年的应用。有一个关于计算机与用户交互的识别/运转方面的高级技巧，我列了几个有趣的标题在下边：
移向目标过程中的平衡：文化调查( [image] http://www.cogsci.soton.ac.uk/bbs/LinkCited/bbs.plamondon.html)
拖拽与点击：一个基于Fitts法则的有趣研究( [image] http://www.cs.sfu.ca/~inkpen/Papers/TR20_DD/tr20.html)
HCI圣经是个非常棒的参考，有各种UI主题的研究结果，包括Fitt's法则。( [image] http://www.hcibib.org/).

Human Factor Information
Scott Berkun is currently the UI design and usability training manager at Microsoft. He was a usability engineer on Internet Explorer versions 1.0 and 2.0, UI program manager on Internet Explorer 3.0 to 5.0, and lead program manager for Consumer Windows before moving to his current position.

人机因素专栏信息

Scott Berkun是微软公司UI设计和可用性培训主管。他是IE1.0和2.0可用性工程师，IE3.0到5.0的UI程序经理，此前还是Consumer Windows 的程序经理。

Have comments, or suggestions for future columns? Want Scott to speak at your event or conference? Write to
hfactor@microsoft.com.

Check out the previous columns and UI design resources at
http://msdn.microsoft.com/ui/

----------------------------------------------
Every mile and every year,
Time and Distance disappear I cannot explain this.
Dear No, I will not even try.

点击查看用户来源及管理<br>发贴IP：61.149.148.253 2003-10-28 15:06:59
编辑这个贴子 鲜花(0) 鸡蛋(0)

本主题贴数6，分页： [1]

*树形目录 顶端
主题： [译]Fitts的UI法则在WEB中的应用 (10680字) － why，2003年10月28日
回复： 慢慢研究吧............收藏............. (39字) － 大傻不傻，2003年10月29日
回复： 收藏！并发奋学习英语！ (22字) － 粗线条，2003年10月29日
回复： 看完了谢谢 (12字) － 麦子，2003年10月28日
回复： 谢谢WHY MM很好。 (16字) － 小林，2003年10月28日
回复： 收藏先~ (7字) － 大阿波，2003年10月28日

*快速回复：[译]Fitts的UI法则在WEB中的应用
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：16,671.880毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：中国UI需要些好的东西-界面设计

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：中国UI需要些好的东西-界面设计

您是本帖的第 148 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 中国UI需要些好的东西-界面设计
lime 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：52
积分：198
注册：2003-3-28
给lime发送一个短消息 把lime加入好友 查看lime的个人资料 搜索lime在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给lime OICQ 引用回复这个贴子 回复这个贴子 楼顶
发贴心情 中国UI需要些好的东西-界面设计
界面设计是开发中最重要的方面，并将涉及到整个开发队伍。
有效的界面设计经常是预见的过程，设计目标是开发者根据自己对用户需求的理解而制定的。
设计界面的艺术综合了技术、艺术，心理学上的技能——它需要左脑和右脸都参与。
优秀的界面简单且用户乐于使用，这意味着设计需适应硬件的局限。
    数字时代的开创人他。Marvin Minsky在其有趣的书《思维的社会》中提出下面的思想：无论是人类的思维还是人工智能的思维，都是由原本简单的元素相连而组成，当这些元素组成一个整体时，他们就成为无限复杂的，我们称之为思想和感情的东西，这些思想和感情可以转化为人类的体验。 　　多媒体在所有方面(创意、筹措资金、设计、开发等)是清楚地遵循这一理论的媒体。在实际推出一个产品时，为了使项目形成，各种各样原本不连贯的思想和行为被连接起来加以操纵。使这些要素(实际上并不简单——人类从来就不简单)向统一的目标工作是开发过程中的关键挑战之一。除非每一个环节在生产过程中和生产之后同步进行，否则产品根本不能算完成。但因为必须作出产品(否则，为何在此浪费时间?)，Minsky的理论在多媒体开发中还有一个更重要的应用，就是多媒体和用户间联系的关键点： 用户界面。 　　制作优秀多媒体界面的挑战主要是编排不同元素(有些并不简单)，并使之成为一个连贯整体，既要在实质上又要在观念上实现这一点。从实质上讲，众多才艺、技能和感觉联合构成用户看到的实际内容；在观念上，用户界面反映了这些部分的总和而非这些部分本身。若多媒体产品意味着展示或传达许多不同的思想，那么用户界面就是使用所有这些思想的中心点。若多媒体产品传达或展示仅仅一种思想．界面须使开发中的所有元素为这一个目标服务。

界面是一个窗口
    按照Minsky的全方位观点，成功的界面设计不仅仅依赖于图片或声音，还依赖于比图片和声音更精细的元素。真正丰富多彩的是用户和多媒体本身(即计算机)带到工作台来的期望度。这些期望构成了用户和机器会话的每一个方面，我将机器称作硬件和软件的统一体。当然，机器，如个人计算机，其内存有限，只能有这
么多的预置程序．这些预置程序可能非常简单而且毫不宽容；每一个多媒体产品都有最低的硬件要求，这可以很好地说明人的期望是受限制的并且要视机器而定。

主要期望
    机器在与用户对话时，首先要确定用户在等待计算机反应时能忍耐多长时间，例如在计算机象棋比赛期间给机器规定的时间限制。另一个要事先给机器规定的例子是，多媒体产品中选择项的范围宽度，或各种各样分散的选择项应集成的程度。因我们设计计算机是要它与人类而非其他机器一起工作，我们更喜欢可选顶少而集中，不喜欢有无限的选择。
人机对话更重要的是用户对工作台和优秀多媒体设计的期望度。优秀多媒体设计在内容选择上优先考虑用户最明显的期望。用户买一张关于意大利文艺复兴的光盘时，至少期望看到艺术和音乐(照片和声音)的例子，但界面设计远不只要满足这种显而易见的期望。

用户的臆测
    设计也是一个猜测用户到底具有多少基本文化和认知常识的问题。例如，当一个人看到屏幕上的红色按钮时，红色象征什么?它意昧“注意”吗?它意味“停止”吗?
用户看到屏幕上的箭头指向右会假定(也许是错误的)那个按钮是在指示他向前浏览，也即到下一页、下一种思想等等。相反，箭头指向左面通常是向后倒的移动，例如返回到前一页。因为我们从左到右阅读(对于西方语言如此)时，这一假设很自然，我们的眼睛朗右移动以获取更多的信息。但当箭头指向上或向下时，它意 味着什么?它对多数用户的意义相同吗?屏幕上的内容意义是否明确，或是否需要通过标号甚至帮助按钮来进一步说明? 界面设计者，也即多媒体开发组的科学掌舵人主要是要回答类似的问题。从艺术、技术，有时是商业角度看，界面设计也许是整个项目中最重要的决策。 理想界面
    对于不同的开发商和产品来说理想的界面有着多种不同的意义，换言之，唯一的理想界面并不存在。可是为了最终用户，你必须作出最佳选择，因为这种选择在用户从视觉和感知方面接触多媒体时起着重要作用。用户界面是内容对与其交互者产生最初和持续印象的地方，它包括整个产品的视觉和感觉效果，更进一步，包括对开发设计者的视觉和感觉。用户界面是如此重要，它能决定一个游戏是有趣还是乏味，也可以决定一个参考资料性多媒体产品是有用还是无用。产品内容充实但界面无吸引力或笨拙仍是一种失败，反之，一个令人注目的界面能使很普通的内容看起来比它实际上更有吸引力。界面占据了用户多媒体体验的核心部分。如何组织用户的多媒体体验?它的结构是逻辑的吗?例如交互性是以清晰易懂、因果方式来规划吗?或者它是否更 开放，鼓励用户自己去探究?界面显眼到成为体验的一部分吗?或它是否内容突出?你将在这一章看到有关这些界面设计问题的例子。这些决策是产品的其余部分发展的核心，它决定了每一件事情的进度。因为多媒体本质上是计算机程序，界面设计的过程没有给人很好的即兴创作机会。不象任意加人多媒体的单个元素——视频、文本、音频和图象，装配的多媒体产品不易以再编辑一段视频或混合一段音乐的“后期制作”方式修改。界面无论假设如何感觉如何，它是开发商和用户的路径图，但问题有那样多不相同的可能性，你如何挑一个出来?显然，须就每一个项目的特定目标和挑战对上述问题做出回答，解决它们而向最终用户给出你所设计的体验。

原因和结果＝挑战和对策
    由于多媒体产品总是为某类用户制作的，在设计用户界面时要考虑的最重要的因素是用户的期望。总体规划的过程一半是市场意识，一半是创意想象。市场的现实无论好坏通常是一个大因素，这一点无论对于实际的开发阶段(预算允许什么)还是产品推出后(用户使用你的产品时的容易程度和亲切程度如何)都是如此。在任何多媒体产品的创作期间，等式结构里的两个因素(市场意识和创意设想)总是在不断变化中协调存在，它是一种因果的共存关系。我们应该把这两种因素看成挑战和对策，看成多媒体项目中的相互对立的两极．而这两极最终是要相遇的。在整个项目期间，尤其在界面设计期间，挑战和对策会分化演变为更小的挑战和对策。尽管这里涉及的是创见和经济决策，其中却也贯穿着这样一个基本物理定律：每一个行为都会导致一个大小相等、方向相反的电影制片人的组织才能、导游的沉着以及计算机编程者的精确。 一致性
    设计者与客户以及或执行开发商紧密配合，为用户制作有吸引力，功能多样，并且最重要的是要具有统一性的多媒体体验。设计者肩负着开发者的期待、预想、限制。设计者将所有生产要素(内容以及风格)转换成相关工具，对这些工具用户在多媒体体验期间能通通使用。存在很多理由支持这种一致性作为全部界面的指导原则，优秀界面设计者应留意所有这些，显然，希望有统一的视觉。即使多媒体意味着若干不同界面的陈
列，通过分支不同主题或部分，用户的主要界面必须有到所有这些分支的路径。无论用户想看什么，都必须从界面中浏览所有的产品对话，对话以某种形式展现出全部体验，一致性方面的任何不和谐将使用户迷惑，并且立刻削弱产品的整体功能。 形式符合功能
    尽管制作界面的创新外观存在极大的可能性，统一的外观仍很重要，如同杂志的页面布局或计算机应用功能。当同这一媒介对话时，用户应能作出智能选择，以便享受体验或发现它的用处。例如，当用户发现一个下拉菜单是一个浏览工具并作出某一选择，但在产品的其它地方用了同样方法却是不同意义的，那么只能不在新节点上应用。已建立的认同范例是以后的模型。
    这些范例包括：从上到下、从左到右(英语习惯)阅读；Window98或Machintosh工作桌面，它的菜单条用期望的结果下拉；或即使电话，在按键之后有一个拨号音、连接和通话，这并不是说界面设计者不能在这些范例内做无章但有创造性的事情。在界面设计中，形式应当符合功能。值得记住的是当设计者为用户建立了某一功能，用户希望这一功能在全部多媒体体验中是
一致的。

屏幕设计基础
    设计界面类似于面对一幅空白画布，每一位艺术家在开始做画之前准备调色版、画笔和构思，多媒体也不例外。设计界面的过程开始于将在制作整个产品中使用的所有视觉和听觉元素，这些元素必须产生于艺术家和技术家的想象。到现在，正象纸和笔能做的，我将以一个有关烹调光盘设计为例简要地讨论辅助软件。
组织该是为你的烹调光盘设计发头炮的时候了。你可用手工也可用机器产生聚集系列必要的设计元素。目的是将这些元素组成连贯的顺序或分支框图．并让用户对设计有直接的体验。
    为这个目的，方案组织软件很有帮助，现有很多软件包能够满足需要，分布范围很广，从产生简单流程图到能跟踪全过程责任和资金的详细流程图，一些较有名的软件包对艺术导演、编程员、市场部，以及界面设计者均很有用。首屏在联机环境也可指主页，尽管Web站点主页经常包括部分或全部主菜单，技术参数与固定媒体如光盘很不同，Web站点是实时传送的媒体，可能有大量的图象，因你无法等待图象经过电话线慢慢下载，用户常常以小时为单位，对在线多媒体较长的下载时间意味着挫折以及现在的潜在用户离开。

    首屏是一个广告性的图象——位于用户启动多媒体程序和实际使用程序的中间和暂时性的步骤。
若首屏是多媒体产品的大门，那么，主菜单即是前厅，这里，用户选择何处可以交互对话，是即刻开始还是稍后使用光盘。我无法过多地陈述设计和实现一个功能性和吸引人的主菜单的重要性：这是用户重复返回的地方。不同的目录、帮助选项、退出项，退出项是每一主菜单均需要但不会有开发商真正想实现的附加项。在单击鼠标和所要信息之间的任何无关的步骤均不受欢迎(至少对于光盘是如此)，对Web站点此规则有很大的灵活性。主菜单应直观且体现出允许用户立即访问产品的重要特征毫无疑问，你的产品不允许一次简单的单击就退出程序，当用户单击退出，出现一个对话框，询问用户是否确实想退出，这样做的理由很简单：给出用户改变主意和重新进入产品的机会。为什么要这样做?首先，没有人愿意看到观众离开剧场，若退出按钮放置太靠近浏览选项，用户可能错误地退出，为他们改变主意给出—个选项是有用的特征。太多的亮点排列过密会使用户难以分辨每一按钮的用途。选择按钮引出一串其他按钮表，此选择按钮必须与它引出的新按钮有明显的区别。
（出处不详）

----------------------------------------------
-----UI-------
春天！

点击查看用户来源及管理<br>发贴IP：159.226.213.158 2003-12-9 16:29:57
编辑这个贴子 鲜花(0) 鸡蛋(0)
酚麻 帅哥哟，离线，有人找我吗？

等级：超级版主
文章：1505
积分：2514
注册：2003-1-21
给酚麻发送一个短消息 把酚麻加入好友 查看酚麻的个人资料 搜索酚麻在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给酚麻 OICQ 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
四年前在 DOLCN 上，曾读过的较早的一篇有关界面的文章。

当时很喜欢这篇文章，使我坚定了做UI的信念。

现在在 DOLCN 上好象已经没了。

----------------------------------------------

点击查看用户来源及管理<br>发贴IP：219.238.180.98 2003-12-10 14:14:20
编辑这个贴子

本主题贴数2，分页： [1]
*快速回复：中国UI需要些好的东西-界面设计
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：312.500毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：为什么伟大的技术不能做出伟大的产品？[推荐]

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：为什么伟大的技术不能做出伟大的产品？[推荐]

您是本帖的第 367 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 为什么伟大的技术不能做出伟大的产品？[推荐]
dozer 帅哥哟，离线，有人找我吗？

等级：中级会员
文章：466
积分：784
注册：2003-6-15
楼顶
发贴心情 为什么伟大的技术不能做出伟大的产品？[推荐]
Why Great Technologies Don't Make Great Products

为什么伟大的技术不能做出伟大的产品？
作者： Scott Berkun [ 微软公司 ]
译: Dozing_Runner [ Envocis Software ]
Feb,2003

我们都热爱技术，这正是我们从事这个行业的原因。我们有一个心照不宣的信念，认为技术可以拯救世界。我们精于创造技术并把它们包装成窗口或网站，但我们经常失败于把它们以让我们的顾客容易使用并欣赏的方式集成起来。有时我们会对很难实施或很难创建的东西感到敬畏，却没有对用它们来实现的目标给予尊重。
多年来,我注意到我们对技术的热爱并不总是带领我们处在正确的方向上，在这个专栏力我将尝试去描述这个问题。

玩乐雇佣条款 The Fun Employment Clause
你的经理可能已经对你表达了一个愿望，做很酷的项目并玩得开心。这不是故事的全部，隐含的真相是所谓的“玩乐雇佣条款”： 如果(而且只有如果)你能确保用户对产品有一个愉快的体验，你是被雇佣来玩的。这是因为最终用户支付你的工资――他们支付我们所有的工资，这意味着你所做的一切应该最终让用户获得好处，你的公司也因此受益。你想要去扩大你公司的目标与用户的目标之间的交集。
你写的每一行代码，你发现的每一个bug,你所做的任何市场调研都应该以某种形式帮助用户。无论你的工作多么不明显或间接，你还是被“玩乐雇佣条款”所约束。例如，你修补一个设备驱动程序，改进可靠性，或优化服务器性能将使产品变得让用户感到更好。做市场研究能够帮助产品定位于合适的对象，从而可以满足他们的需求。如果你没有能把你的工作与它是怎样帮助客户联系起来，把你的时间花在别的地方吧。你越是经常从最终用户的角度来思考你的工作，思考你的团队的工作，你越有可能帮助去创造一个伟大的产品。

我们不是我们的用户We Are Not Our Users

在这个行业中我们形成了类似的思维方式。在大部分时间我们是和那些在数学测试中获得高分的人一起渡过，我们认识那些有股票期权的人，我们和那些能从拆卸计算机中获得乐趣的人在一起工作。我们忘记了在我们这个行业中的人跟世界上的其他人是非常不一样的。这正是为什么进入易用性实验室似乎就象一次进入模糊地带的旅行， 似乎那些用户是少数，是从某个扭曲和更缓慢的宇宙来参观我们。现实是：我们是压倒性的少数，那些在易用性实验室的参观者才是多数派，他们是使用我们产品并支付我们薪水的人。
并没有其他方式可以替代观看某个人使用你创造的东西，这是唯一的方式可以验证你设想的目标是否和现实相匹配。你愿意一个外科医生在手术之前和手术之后都不对你进行检查吗？你希望一个建筑合同商在没有和你讨论计划且确保你能得到你所要的的情况下就重新装修你的厨房吗？好的工匠在制造产品之前愿意首先考虑产品将被如何使用。我们具有惊人的创造能力，也容易掉入陷阱，掉入所创造的产品只吸引我们自己而不是吸引客户这种陷阱。除了通过易用性测试和其他形式的客户反馈，并没有其他方式可以了解你有多么偏离方向。你必须在整个产品周期花时间与用户沟通，反复更新开发团队对于他们正在做什么以及是在为谁做的看法。

什么为主导？用户还是技术？Which Came First: the User or the Technology?

技术专家和真正的设计人员在对于怎样做产品的方式上有根本的差异。技术人员趋向于以技术开始。我们让开发团队开发一项技术，然后硬塞进一个用户界面，对整个框架的用户体验（user experience）完全是被技术所支配。这确保了用户体验将是一个糟糕的妥协，产品将不是被设计为用户使用的产品，而是被设计为一堆技术的载体。我们的所作所为显得好像技术比产品更重要。 伟大的产品是以这种方式设计的吗？ 大师级的厨师直到最后一分钟才弄清事物对顾客是什么一种味道吗？ 裁缝是在衣服都被缝好以后才去量顾客的尺寸吗？
任何行业中的好工匠都明白用户将会使用他们的作品，他们将考虑用户之所想来做出每一个决定。软件或Web开发并无不同。去餐厅吃饭或去电影院看电影的人和使用我们产品的人是同样的人。我们需要培养一种兴趣，即去了解其他领域中的产品是如何开发的，他们是如何实现所需要的效果。汽车、CD播放器、器具等的制造者，除了他们做那个行业比我们做软件的时间更长外，都会面临和我们同样的挑战，需要在工程、商务、易用性之间实现平衡。通过了解他们开发方式的差异，我们可以从他们的成功和失败中学到很多。
Why Simple Products Are Great Products为什么简单的产品是伟大的产品？
最强有力的工程技艺是那种我们不会留意到的技术。工程师和开发人员的真正力量体现在把非常复杂的东西转换为难以置信的简单事物。汽车中的自动传动系统显著地具有比手动传动系统更多的工程技术。汽车工业、城市建筑、消费类电子产品中的最佳作品都体现了伟大的工程是如何聚焦于隐藏复杂性而不是显现它们。
增加产品价值的最佳方式是增加它的功能却没有增加复杂性。当你想增加一个新的feature，是否有办法增加了它却没有为之增加一个用户界面？它能被可靠地自动化吗？或者，为了包含新的功能，是否可以通过新的、改进过的方式替代旧的，来调整、甚至去掉原先的功能？想一下汽车工业是怎么做的，想一下他们怎样以对用户影响最小的方式来增加重大的feature。就象动力方向盘是对于普通方向盘的一个新添加功能一样，防锁死刹车系统是对标准刹车踏板UI的补充。要获得新特性的好处，司机不需要训练或重新学习。这种设计努力―――使复杂的特性让用户看起来很简单―――制造出了伟大的产品。

The Real Meaning of Software as a Service 软件作为服务的真正含义

当你走进一家运动用品商店，询问一个关于背包的问题，你期待得到尊重，你希望售货员按你的水平和你交谈，处理你的问题，以礼貌和公平的方式解决你的问题。软件用户或web 用户也是一样，他们期待被尊重地对待并得到优质服务。客户或顾客总是正确的。
当我们把出现的一个错误信息认为是用户的错误而不是开发人员的错误时，我们犯了一个严重的错误。如果一个用户试图从一个网站上购物，出现了服务器数据库问题，这是谁的错？　是我们的错误！ 我们没有足够聪明到去确保用户从不遇到这样的问题。要么是因为项目经理和设计师没能创建适当的界面设计，要么是因为开发、测试组没有能发现重大的缺陷。网站上的错误信息比用户在软件中遇到的错误信息更糟。当我们的产品中出现错误的时候，我们提供了礼貌和有帮助的支持了吗？我们是否以顾客至上的方式对待客户了？几乎从来没有。通常我们是以这样的错误信息做出回应：“ Server error 152432. Scripting service failure” 。 每一条错误信息意味着一个陷入麻烦中的用户。想像你的用户，坐在那里，会议迟到，感到沮丧，只是因为他们没有完成他们非常想完成的事情。你希望让你的用户在那一刻看到什么？他们应该得到哪种服务？　你放到产品中的每一个错误信息是一个提供良好服务的机会。如果你想把提供优质服务作为你的网站或产品的一部分的话，你必须把错误信息和错误处理规划在你的schedule中。项目经理应该总是把错误信息处理作为一个任务添加到开发、测试团队的schedule中，但是记住：没有什么伟大的错误信息。一个伟大的错误是一个通过一流的产品设计和错误处理代码所消除的错误。
超越只提供错误信息的服务不是去责备用户，而是向用户提供很大的帮助。在用户的体验过程中，可以有很多机会提供给用户好的服务。观看某人使用你的网站的主要功能，自问它能否达到在一家好的商店或餐厅中得到的服务水平，一个好的服务员知道何时中断你，何时让你一个人呆在哪里，知道怎样以彬彬有礼的方式服务你。你的网站或软件质量越是能接近用户日常生活中得到的良好服务水平，你将越是接近于拥有一个伟大的产品。

投入时间去创造伟大的产品Making Time to Create Great Products

把什么都做好是困难的，写好代码比写差代码花更多的时间。如果你团队的管理部门是致力于制造伟大的产品，那么他们应该采取措施去调整团队的目标和schedule以便符合能做出伟大产品的现实。这是他们的工作，如果他们没有能那么做，让他们知道这些就是你的工作。如果问题是在于你想了解怎样把UI交互性设计或易用性集成到开发流程中，那么去询问团队中从事设计和易用性测试工作的人员。好的产品设计来自于好的流程，很多团队还没有认识到这点。在很多情况下，在易用性工程（usability engineering）上投资最终能节约时间和金钱，因为你开始就设计得很好，而不是在产品发布之后试图去打补丁。
领导得很好的团队会让每个人都明白他们个人的所作所为作是怎样影响客户的。针对用户所拥有的问题，针对功能和技术怎么去解决用户的问题，在产品开发流程开始之前，应该把产品管理、产品计划和易用性测试等包含在一个构架里。没有一个构架，管保你是在构建一个不解决任何问题的技术。你应该每天问自己你正在解决什么样的问题。它是谁的问题，投资你的时间在里面是否合理。
如果你的目标是让产品易用而且你知道怎么才能做到，那么你应该安排你的项目的进度日程以确保它。说“我没有时间”去开发产品的一个关键性方面总是一种逃避.它真的意味着你的团队没有很好地计划或者目标和计划没有很好地匹配。如果你把用户对产品的体验作为一个低优先级的事项，那么也许你应该去重新评估你的项目优先级。如果你相信什么事是重要的，你可以为其制定计划日程。

Where Does Greatness Come From?伟大来自何方？
通过变成一个用户至上的鼓吹者你可以帮助做出一个伟大的产品，我坚信是整个团队都重视并致力于用户才是产生重大差别的原因。把这篇文章发给你团队中的同事，去进行易用性测试，如果团队中没有人了解该怎么做的话，学习怎么去做。和产品设计师讨论什么地方出错了，询问你的易用性工程师他们是怎么从事工作的，询问你怎样才可以支援他们。你的正式工作头衔并不重要，用户支付你的薪水跟你做什么无关。如果你从事UI方面的工作.帮助你团队中的其他人拓展他们的视野，邀请他们参与。当你读到关于设计方面的好文章或好书，把它传递给那些最需要他们的人。

点击查看用户来源及管理<br>发贴IP：218.80.67.214 2003-8-1 9:21:28
编辑这个贴子 鲜花(0) 鸡蛋(0)
dozer 帅哥哟，离线，有人找我吗？

等级：中级会员
文章：466
积分：784
注册：2003-6-15
第2楼
发贴心情
这是今年2月份翻译的一篇文章，是由微软的前IE5程序经理，现在的UI design and Usabiliyt training manager所写的。。很有道理的。。

把这篇文章装给你的程序员同事和项目经理看看吧。。

点击查看用户来源及管理<br>发贴IP：218.80.67.214 2003-8-1 9:23:40
编辑这个贴子
fatone 帅哥哟，离线，有人找我吗？ 双子座1978-5-31

等级：论坛支柱
文章：2453
积分：2855
注册：2003-5-6
第3楼
发贴心情
好伟大哦，说得我糊涂了……

----------------------------------------------
******************************************
我是一只鸟，但不要拿我去做菜，尽管我是菜鸟
******************************************

点击查看用户来源及管理<br>发贴IP：61.183.120.154 2003-8-1 10:02:04
编辑这个贴子
黑暗生物 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：48
积分：135
注册：2003-8-1
第4楼
发贴心情
只剩下崇拜了!
点击查看用户来源及管理<br>发贴IP：218.104.102.27 2003-8-1 11:01:46
编辑这个贴子
dozer 帅哥哟，离线，有人找我吗？

等级：中级会员
文章：466
积分：784
注册：2003-6-15
第5楼
发贴心情
程序员普遍都很自我，把这文章转发给他们看吧。
点击查看用户来源及管理<br>发贴IP：218.80.67.214 2003-8-1 12:06:13
编辑这个贴子
eworker 美女呀，离线，快来找我吧！

等级：实习版主
文章：1863
积分：2665
注册：2003-7-17
第6楼
发贴心情
好文，不过现在国内少有地方能够产生伟大的技术，更别说别的了……

----------------------------------------------
批评是对我最大的帮助。
http://www.chinaui.com/bbs/list.asp?boardid=12

点击查看用户来源及管理<br>发贴IP：159.226.83.133 2003-8-1 12:26:46
编辑这个贴子
jiliy 帅哥哟，离线，有人找我吗？

等级：高级会员
文章：389
积分：546
注册：2003-3-4
第7楼
发贴心情
太棒了，微软就是微软，伟大就是伟大！！！！

----------------------------------------------
他说，经商其实不用很多技巧，只要坚定自己的信心，把事情做得最好，做得到位，就能成功。他很欣赏三宅一生说的一句话：“做我喜欢的东西，让别人去接受。”他把这句话转作“让我做菜，你就得接受这个味。”他认为这样的态度是从根本上考虑，从长远考虑。只有干自己擅长的事，坚持专业精神，才能够把东西做到极致。有很多设计师迫于生存，牺牲掉专业的东西，这样就永远没有自己的风格。

点击查看用户来源及管理<br>发贴IP：211.147.216.79 2003-8-1 13:17:18
编辑这个贴子
dozer 帅哥哟，离线，有人找我吗？

等级：中级会员
文章：466
积分：784
注册：2003-6-15
第8楼
发贴心情
“是以技术为中心，还是以用户为中心”？

现实状况是，一些自视甚高的程序员没有伟大的技术，还自以为是。

点击查看用户来源及管理<br>发贴IP：218.80.67.214 2003-8-1 13:35:18
编辑这个贴子
dozer 帅哥哟，离线，有人找我吗？

等级：中级会员
文章：466
积分：784
注册：2003-6-15
第9楼
发贴心情
很遗憾，这样的文章沉的这么快。。

我当时看这文章的时候很有感慨的。。觉得是很好的文章。。值得开发团队的每个人去仔细阅读和体会。

其中的一些道理，需要通过实践才能体会得更深...

点击查看用户来源及管理<br>发贴IP：61.151.242.5 2003-8-2 9:22:16
编辑这个贴子
foxmsdn 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：1
积分：54
注册：2003-9-3
第10楼
发贴心情
顶起来。
点击查看用户来源及管理<br>发贴IP：61.145.231.194 2003-12-20 10:35:44
编辑这个贴子
x3d 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：119
积分：314
注册：2003-5-12
给x3d发送一个短消息 把x3d加入好友 查看x3d的个人资料 搜索x3d在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给x3d OICQ 引用回复这个贴子 回复这个贴子 第11楼
发贴心情
我收藏夹里面有,不过只是大概看了一遍,晚上再研究研究
点击查看用户来源及管理<br>发贴IP：218.5.43.198 2003-12-22 9:25:35
编辑这个贴子

本主题贴数11，分页： [1]
*快速回复：为什么伟大的技术不能做出伟大的产品？[推荐]
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：1,343.750毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：[转帖]可用性工程对IT产品的影响

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：[转帖]可用性工程对IT产品的影响

您是本帖的第 137 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： [转帖]可用性工程对IT产品的影响
村里的猫 帅哥哟，离线，有人找我吗？ 双子座1981-5-24

头衔：村长
等级：高级会员
文章：967
积分：1344
注册：2003-6-19
给村里的猫发送一个短消息 把村里的猫加入好友 查看村里的猫的个人资料 搜索村里的猫在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给村里的猫 OICQ 访问村里的猫的主页 引用回复这个贴子 回复这个贴子 楼顶
发贴心情 [转帖]可用性工程对IT产品的影响
可用性工程对IT产品的影响

大连海事大学欧盟可用性中国支持中心 刘正捷 张丽萍 陈燕

--------------------------------------------------------------------------------

我们常常感到困惑：一个性能、质量都很不错的IT产品却得不到用户的认可，无法获得预期的市场效果。原因何在？可用性达不到用户的要求！事实上，大量IT产品成功与失败的实例表明，在决定产品成功与否的诸多因素中，可用性起着至关重要的作用。

可用性:用户能否用产品做他想做的事？效率如何？在使用过程中是否感到愉快和满意？

通俗地讲，可用性（Usability）就是用户评价产品是否有效、易学、高效、好记、少错和令人舒适满意的质量指标。大家都有这样的经验：具有同样功能的产品并不一定同样好用，其差别就在于它们的可用性质量不同。因此，可用性是决定产品是否具有竞争力的关键因素。按照ISO 9241-11国际标准的定义，可用性是某个特定产品在特定使用环境下为特定用户用于特定用途时所具有的有效性（effectiveness）、效率（efficiency）和用户主观满意度（satisfaction）。其中，“有效性”是指用户完成特定任务和达到特定目标时所具有的正确性和完整程度；“效率”是指用户完成任务的正确性和完整程度与所使用资源（如时间）之间的比率；“满意度”是指用户在使用产品过程中具有的主观满意和接受程度。

长期以来，IT行业一直有着重视技术创新而忽视人类因素的倾向，这导致多数产品存在程度不同的可用性问题。据研究机构近期对发达国家的统计：商用计算机用户的有效生产率仅有30%～40%；48%的软件缺陷属于可用性问题；在计算机应用系统开发项目中，31%的项目因可用性质量问题而失败，51%的项目只获得部分成功；90%的企业网站可用性较差；70%的企业对其网站设计不够满意；用户在商业网站上找到所要信息的几率只有42%；网上购物者最终放弃寻找欲购商品的几率为62%；51%的网站可用性问题是由于未运用最基本的可用性原则造成的。这些数据说明目前的IT产品存在严重的可用性问题。在我国，由于产业发展水平相对落后，产品的可用性问题更加严重。

可用性工程方法

可用性工程（Usability Engineering）是IT产品及其用户界面开发的一种工程方法论，贯穿于产品整个生命周期的各个阶段，包括从需求获取、可用性问题分析、设计方案的开发以及测试评估在内的一整套实用方法，泛指以提高产品可用性质量为目的的一系列过程、方法、技术和标准,其核心是以用户为中心的设计方法论（user-centered design，UCD）。它强调从用户的角度来进行产品的设计开发，这使它有别于传统和常规的开发方法。

可用性工程可以用于各类交互式IT产品的开发，包括计算机软硬件、网站、信息家电以及以嵌入式软件为核心的各种交互式仪器设备，还可用来设计用户手册、联机帮助和培训课程。

近年来，人们开发了几十种不同的可用性工程方法，用于产品生命周期的各个阶段。这些方法的运用可以使所开发的产品具有较高的可用性质量。例如，HP公司在一个网络监控软件新版本的设计中系统地采用了可用性工程方法，获得了令人满意的结果。下表是以传统方法开发的旧版本与新版本可用性质量的比较。

具体说来，在产品开发过程中运用可用性工程方法可以实现以下目标：

。准确而详细地理解用户特征、用户任务和使用环境；
。明确定义产品可用性质量的用户需求；
。基于同类产品或产品的原有版本，建立产品可用性质量基准；
。在产品生命周期的各个阶段，随时、快速、准确地获得用户反馈，发现可用性问题，及时改进产品设计；
。检验和确认产品是否满足可用性质量的用户需求；
。减少后期维护，避免无效开发，从而降低开发成本，缩短生产周期；
。评估和认证产品是否符合有关可用性的国际标准；
。定性或定量地评估产品的可用性质量，按照国际标准向采购方提供产品可用性质量测试报告；
。对同类产品的可用性进行比较分析，了解自己产品的竞争力，以针对性地改进产品和制定相应的产品发展策略；
。评估和改进产品开发过程的可用性能力成熟度（UMM）并获得国际标准认证。

应用现状

可用性工程的工业应用始于20世纪80年代，最初主要在一些大型IT企业中应用。从90年代开始，可用性工程在IT工业界迅速普及，目前，国外主要的IT企业都建立了规模较大的产品可用性部门，大多数网站都有可用性专业人员，出现了一批可用性工程专业咨询机构。

IBM、微软、HP、Oracle、Sun、Motorola、诺基亚、Philips、西门子等企业都有十几年甚至更长时间的可用性工程实际运用历史。例如，IBM在1969年就成立了企业的可用性部门，并开始在产品开发过程中采用可用性工程方法，逐步形成了自己的可用性工程规范。目前，IBM在全球设有25个可用性实验室，专职人员超过500人，他们有这样一个口号：“可用性方面的投入是一本万利的”。微软的可用性部门成立于1989年，现在已有14个可用性实验室、员工近200人，可用性工程已被系统地运用于微软的各类产品开发过程。

在工业界，可用性工程活动的范围广泛、形式多样，典型活动包括可用性规划、现场研究（观察、采访）、专家评审、原型开发及用户界面设计、可用性测试和评价（反馈收集型测试、绩效评估型测试、竞争力测试）、企业可用性指南、标准及开发过程规范的制定等。过去，可用性工作主要集中于产品生命周期的中、后期，现在有越来越重视前期的倾向，这就要求可用性专业人员具有更强的设计能力。

可用性部门的人员构成具有鲜明的多学科交叉特征，其人员主要来自人机工程学、认知心理学、工业工程学、视觉设计、计算机科学等专业，许多人具有复合的专业背景。这种人员组成为在技术运用中多角度地考虑人的因素提供了保障。

一个从未涉足过可用性工程的企业如何开展自己的可用性工程呢？通常有如下几种方式：

直接招募有经验的可用性专业人员，建立自己的可用性部门，这种方法适合于有一定规模的企业；
将有关工作委托给某个可用性专业咨询机构，这种方法适合于中小企业，也适合于大型企业；
聘请有经验的可用性专业人员与本企业开发人员一起进行某项可用性工作，通过可用性专业人员的示范作用，让开发人员从实例中学习可用性工程的某些技能，掌握简单而有效的可用性工程方法。

差距

应当说，可用性工程在发达国家已经是一个技术发展和市场需求都比较成熟的领域。随着信息技术日益深入地融入人类社会和面向大众，可用性工程将不断发展和完善，并在工业界获得越来越广泛的应用。

受多年来计划经济以及产业和市场发展水平的影响，目前可用性工程在国内IT工业界的应用基本上还是一片空白，在产品设计开发中重视技术而忽视人类因素的现象还普遍存在，造成很多产品和服务不同程度地存在可用性质量问题。随着国内IT产业日趋成熟，市场竞争会愈加激烈，国内企业能否在这种激烈的竞争中生存、发展和壮大，关键取决于其产品和服务的竞争力。因此，国内IT企业迫切需要掌握可用性工程这类能提高产品和服务质量的有效手段。作为欧盟可用性中国支持中心，我们的职责是可用性工程技术资源的引进、本地化和推广应用。希望通过我们的努力，国内IT工业界有越来越多的人了解和掌握可用性工程，在越来越多的企业、部门和产品领域运用可用性工程，从而促进产品和服务可用性质量的普遍提高，增强整个行业的国际竞争力。

----------------------------------------------
---- 个人意见。仅供参考 -----
全力支持chinaui及ui事业
--------------------------------------
http://wodessnh.51.net/

点击查看用户来源及管理<br>发贴IP：218.18.31.120 2003-10-15 13:08:23
编辑这个贴子 鲜花(0) 鸡蛋(0)
小林 美女呀，离线，快来找我吧！

等级：版主
文章：342
积分：601
注册：2003-6-12
给小林发送一个短消息 把小林加入好友 查看小林的个人资料 搜索小林在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给小林 OICQ 访问小林的主页 引用回复这个贴子 回复这个贴子 第2楼
发贴心情
不错，刘正捷他还建了一个实验室，他资格很老的。

----------------------------------------------
/○\
/■\ Human Factors makes the world easy and simple.
<|

点击查看用户来源及管理<br>发贴IP：218.108.42.3 2003-10-15 14:04:50
编辑这个贴子
粗线条 帅哥哟，离线，有人找我吗？

等级：高级会员
文章：803
积分：1628
注册：2003-2-27
给粗线条发送一个短消息 把粗线条加入好友 查看粗线条的个人资料 搜索粗线条在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给粗线条 OICQ 访问粗线条的主页 引用回复这个贴子 回复这个贴子 第3楼
发贴心情
恩还不错~~但似乎单调了一些！

----------------------------------------------
虽然，我是一根粗线条。心中却有一座不倒城堡。

点击查看用户来源及管理<br>发贴IP：218.79.95.152 2003-10-16 14:51:40
编辑这个贴子

本主题贴数3，分页： [1]
*快速回复：[转帖]可用性工程对IT产品的影响
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：421.875毫秒


中国UI设计网--[U.I]. 交互界面-理论研究浏览：[转]界面设计及原型开发的几篇文章

中国UI设计网 → [U.I]. 交互界面-理论研究 → 浏览：[转]界面设计及原型开发的几篇文章

您是本帖的第 178 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： [转]界面设计及原型开发的几篇文章
why 美女呀，离线，快来找我吧！ 天秤座1979-10-23

等级：初级用户
文章：66
积分：214
注册：2003-3-19
楼顶
发贴心情 [转]界面设计及原型开发的几篇文章
界面设计

（出处不详）

界面设计是开发中最重要的方面，并将涉及到整个开发队伍。
有效的界面设计经常是预见的过程，设计目标是开发者根据自己对用户需求的理解而制定的。
设计界面的艺术综合了技术、艺术，心理学上的技能——它需要左脑和右脸都参与。
优秀的界面简单且用户乐于使用，这意味着设计需适应硬件的局限。
    数字时代的开创人他。Marvin Minsky在其有趣的书《思维的社会》中提出下面的思想：无论是人类的思维还是人工智能的思维，都是由原本简单的元素相连而组成，当这些元素组成一个整体时，他们就成为无限复杂的，我们称之为思想和感情的东西，这些思想和感情可以转化为人类的体验。

    多媒体在所有方面(创意、筹措资金、设计、开发等)是清楚地遵循这一理论的媒体。在实际推出一个产品时，为了使项目形成，各种各样原本不连贯的思想和行为被连接起来加以操纵。使这些要素(实际上并不简单——人类从来就不简单)向统一的目标工作是开发过程中的关键挑战之一。除非每一个环节在生产过程中和生产之后同步进行，否则产品根本不能算完成。但因为必须作出产品(否则，为何在此浪费时间?)，Minsky的理论在多媒体开发中还有一个更重要的应用，就是多媒体和用户间联系的关键点： 用户界面。

    制作优秀多媒体界面的挑战主要是编排不同元素(有些并不简单)，并使之成为一个连贯整体，既要在实质上又要在观念上实现这一点。从实质上讲，众多才艺、技能和感觉联合构成用户看到的实际内容；在观念上，用户界面反映了这些部分的总和而非这些部分本身。若多媒体产品意味着展示或传达许多不同的思想，那么用户界面就是使用所有这些思想的中心点。若多媒体产品传达或展示仅仅一种思想．界面须使开发中的所有元素为这一个目标服务。

界面是一个窗口
    按照Minsky的全方位观点，成功的界面设计不仅仅依赖于图片或声音，还依赖于比图片和声音更精细的元素。真正丰富多彩的是用户和多媒体本身(即计算机)带到工作台来的期望度。这些期望构成了用户和机器会话的每一个方面，我将机器称作硬件和软件的统一体。当然，机器，如个人计算机，其内存有限，只能有这
么多的预置程序．这些预置程序可能非常简单而且毫不宽容；每一个多媒体产品都有最低的硬件要求，这可以很好地说明人的期望是受限制的并且要视机器而定。

主要期望
    机器在与用户对话时，首先要确定用户在等待计算机反应时能忍耐多长时间，例如在计算机象棋比赛期间给机器规定的时间限制。另一个要事先给机器规定的例子是，多媒体产品中选择项的范围宽度，或各种各样分散的选择项应集成的程度。因我们设计计算机是要它与人类而非其他机器一起工作，我们更喜欢可选顶少而集中，不喜欢有无限的选择。
人机对话更重要的是用户对工作台和优秀多媒体设计的期望度。优秀多媒体设计在内容选择上优先考虑用户最明显的期望。用户买一张关于意大利文艺复兴的光盘时，至少期望看到艺术和音乐(照片和声音)的例子，但界面设计远不只要满足这种显而易见的期望。

用户的臆测
    设计也是一个猜测用户到底具有多少基本文化和认知常识的问题。例如，当一个人看到屏幕上的红色按钮时，红色象征什么?它意昧“注意”吗?它意味“停止”吗?
用户看到屏幕上的箭头指向右会假定(也许是错误的)那个按钮是在指示他向前浏览，也即到下一页、下一种思想等等。相反，箭头指向左面通常是向后倒的移动，例如返回到前一页。因为我们从左到右阅读(对于西方语言如此)时，这一假设很自然，我们的眼睛朗右移动以获取更多的信息。但当箭头指向上或向下时，它意 味着什么?它对多数用户的意义相同吗?屏幕上的内容意义是否明确，或是否需要通过标号甚至帮助按钮来进一步说明? 界面设计者，也即多媒体开发组的科学掌舵人主要是要回答类似的问题。从艺术、技术，有时是商业角度看，界面设计也许是整个项目中最重要的决策。

理想界面
    对于不同的开发商和产品来说理想的界面有着多种不同的意义，换言之，唯一的理想界面并不存在。可是为了最终用户，你必须作出最佳选择，因为这种选择在用户从视觉和感知方面接触多媒体时起着重要作用。用户界面是内容对与其交互者产生最初和持续印象的地方，它包括整个产品的视觉和感觉效果，更进一步，包括对开发设计者的视觉和感觉。用户界面是如此重要，它能决定一个游戏是有趣还是乏味，也可以决定一个参考资料性多媒体产品是有用还是无用。产品内容充实但界面无吸引力或笨拙仍是一种失败，反之，一个令人注目的界面能使很普通的内容看起来比它实际上更有吸引力。界面占据了用户多媒体体验的核心部分。如何组织用户的多媒体体验?它的结构是逻辑的吗?例如交互性是以清晰易懂、因果方式来规划吗?或者它是否更 开放，鼓励用户自己去探究?界面显眼到成为体验的一部分吗?或它是否内容突出?你将在这一章看到有关这些界面设计问题的例子。这些决策是产品的其余部分发展的核心，它决定了每一件事情的进度。因为多媒体本质上是计算机程序，界面设计的过程没有给人很好的即兴创作机会。不象任意加人多媒体的单个元素——视频、文本、音频和图象，装配的多媒体产品不易以再编辑一段视频或混合一段音乐的“后期制作”方式修改。界面无论假设如何感觉如何，它是开发商和用户的路径图，但问题有那样多不相同的可能性，你如何挑一个出来?显然，须就每一个项目的特定目标和挑战对上述问题做出回答，解决它们而向最终用户给出你所设计的体验。

原因和结果＝挑战和对策
    由于多媒体产品总是为某类用户制作的，在设计用户界面时要考虑的最重要的因素是用户的期望。总体规划的过程一半是市场意识，一半是创意想象。市场的现实无论好坏通常是一个大因素，这一点无论对于实际的开发阶段(预算允许什么)还是产品推出后(用户使用你的产品时的容易程度和亲切程度如何)都是如此。在任何多媒体产品的创作期间，等式结构里的两个因素(市场意识和创意设想)总是在不断变化中协调存在，它是一种因果的共存关系。我们应该把这两种因素看成挑战和对策，看成多媒体项目中的相互对立的两极．而这两极最终是要相遇的。在整个项目期间，尤其在界面设计期间，挑战和对策会分化演变为更小的挑战和对策。尽管这里涉及的是创见和经济决策，其中却也贯穿着这样一个基本物理定律：每一个行为都会导致一个大小相等、方向相反的电影制片人的组织才能、导游的沉着以及计算机编程者的精确。

一致性
    设计者与客户以及或执行开发商紧密配合，为用户制作有吸引力，功能多样，并且最重要的是要具有统一性的多媒体体验。设计者肩负着开发者的期待、预想、限制。设计者将所有生产要素(内容以及风格)转换成相关工具，对这些工具用户在多媒体体验期间能通通使用。存在很多理由支持这种一致性作为全部界面的指导原则，优秀界面设计者应留意所有这些，显然，希望有统一的视觉。即使多媒体意味着若干不同界面的陈
列，通过分支不同主题或部分，用户的主要界面必须有到所有这些分支的路径。无论用户想看什么，都必须从界面中浏览所有的产品对话，对话以某种形式展现出全部体验，一致性方面的任何不和谐将使用户迷惑，并且立刻削弱产品的整体功能。

形式符合功能
    尽管制作界面的创新外观存在极大的可能性，统一的外观仍很重要，如同杂志的页面布局或计算机应用功能。当同这一媒介对话时，用户应能作出智能选择，以便享受体验或发现它的用处。例如，当用户发现一个下拉菜单是一个浏览工具并作出某一选择，但在产品的其它地方用了同样方法却是不同意义的，那么只能不在新节点上应用。已建立的认同范例是以后的模型。
    这些范例包括：从上到下、从左到右(英语习惯)阅读；Window98或Machintosh工作桌面，它的菜单条用期望的结果下拉；或即使电话，在按键之后有一个拨号音、连接和通话，这并不是说界面设计者不能在这些范例内做无章但有创造性的事情。在界面设计中，形式应当符合功能。值得记住的是当设计者为用户建立了某一功能，用户希望这一功能在全部多媒体体验中是
一致的。

屏幕设计基础
    设计界面类似于面对一幅空白画布，每一位艺术家在开始做画之前准备调色版、画笔和构思，多媒体也不例外。设计界面的过程开始于将在制作整个产品中使用的所有视觉和听觉元素，这些元素必须产生于艺术家和技术家的想象。到现在，正象纸和笔能做的，我将以一个有关烹调光盘设计为例简要地讨论辅助软件。
组织该是为你的烹调光盘设计发头炮的时候了。你可用手工也可用机器产生聚集系列必要的设计元素。目的是将这些元素组成连贯的顺序或分支框图．并让用户对设计有直接的体验。
    为这个目的，方案组织软件很有帮助，现有很多软件包能够满足需要，分布范围很广，从产生简单流程图到能跟踪全过程责任和资金的详细流程图，一些较有名的软件包对艺术导演、编程员、市场部，以及界面设计者均很有用。首屏在联机环境也可指主页，尽管Web站点主页经常包括部分或全部主菜单，技术参数与固定媒体如光盘很不同，Web站点是实时传送的媒体，可能有大量的图象，因你无法等待图象经过电话线慢慢下载，用户常常以小时为单位，对在线多媒体较长的下载时间意味着挫折以及现在的潜在用户离开。

    首屏是一个广告性的图象——位于用户启动多媒体程序和实际使用程序的中间和暂时性的步骤。
若首屏是多媒体产品的大门，那么，主菜单即是前厅，这里，用户选择何处可以交互对话，是即刻开始还是稍后使用光盘。我无法过多地陈述设计和实现一个功能性和吸引人的主菜单的重要性：这是用户重复返回的地方。不同的目录、帮助选项、退出项，退出项是每一主菜单均需要但不会有开发商真正想实现的附加项。在单击鼠标和所要信息之间的任何无关的步骤均不受欢迎(至少对于光盘是如此)，对Web站点此规则有很大的灵活性。主菜单应直观且体现出允许用户立即访问产品的重要特征毫无疑问，你的产品不允许一次简单的单击就退出程序，当用户单击退出，出现一个对话框，询问用户是否确实想退出，这样做的理由很简单：给出用户改变主意和重新进入产品的机会。为什么要这样做?首先，没有人愿意看到观众离开剧场，若退出按钮放置太靠近浏览选项，用户可能错误地退出，为他们改变主意给出—个选项是有用的特征。太多的亮点排列过密会使用户难以分辨每一按钮的用途。选择按钮引出一串其他按钮表，此选择按钮必须与它引出的新按钮有明显的区别。

link: http://www.sawin.com.cn/doc/SD/GUI/interfacedesign.htm

----------------------------------------------
Every mile and every year,
Time and Distance disappear I cannot explain this.
Dear No, I will not even try.

点击查看用户来源及管理<br>发贴IP：61.149.154.87 2003-12-5 13:49:39
编辑这个贴子 鲜花(0) 鸡蛋(0)
why 美女呀，离线，快来找我吧！ 天秤座1979-10-23

等级：初级用户
文章：66
积分：214
注册：2003-3-19
第2楼
发贴心情 用户界面设计：从抽象到实现
用户界面设计：从抽象到实现

               ——基于规范抽象组件的抽象原型

作者：Larry Constantine,Helmut Windl,James Noble,Lucy Lo
本文选自：ULMChina
2002年08月06日

2000年7月，一群同行召集起来就以使用为中心的（usage-centered）设计的现状和未来开了个会。这次会议不仅作为一个论坛来回顾和巩固在以使用为中心方面累积的经验，它更是一个研讨会，用来精炼和改进这种方法，特别强调和其他设计开发过程与模型的交叉渗透。那次讨论衍生出许多概念上和实践上的突破，其中之一是抽象原型，很引人注目的一种改进形式。它基于任务模型，简化并加速了高质量用户界面设计的生产。

抽象原型

抽象原型是以使用为中心设计的一个强有力工具（Constantine, 1998; Constantine & Lockwood, 1999），允许设计者描述一个用户界面的内容和全局组织，而无需详细说明其外观或行为。因此，它是待设计用户界面结构的模型。我们和我们的客户发现，抽象原型是一座有效的桥梁，它沟通了基于任务案例（本质用例）的任务模型和实际原型形式的最终设计。在文章和在软件中都是这样。尤其通过集中关注内容、组织和功能，而非布局、外观和行为，我们一再认识到，抽象原型有助于可靠的体系结构和创造性的变革（Constantine, 1998）。如果有恰当的任务模型作驱动，抽象原型能帮助设计者作出实用而新颖的用户界面解决方案（Constantine, 2000）。

当前技术水平状况

在进行以使用为中心的设计时，内容模型和导航图构成了抽象原型最常见的组成部分。内容模型包含一系列由抽象组件组装成的视图（交互语境），抽象组件亦即用户完成每个视图支持任务所需的工具和原料。导航图对内容模型进行补充，它表现用户界面里所有视图（交互语境）相互连接时可能的路径和转换。

常规的内容模型中，最典型的是贴纸形式，每个视图通常由一张单独的标签纸表示，纸上粘贴着抽象组件。简单图示符（小图标）用来区分原料和工具，原料给用户提供感兴趣的容器和信息，工具则为用户操作这些原料或执行其他的动作。

其他抽象原型的变体形式包括“线框（wire-frame）”模型和抽象布局图表。如图2所示，线框模型描绘可见用户界面元素的相对大小和位置。区域的色彩编码也可以用来说明元素对应的类型，或者信息、功能的相对重要性或优先权。这种变体形式在基于web应用的图形设计者中有一定程度的流行。

如图3所示，抽象布局图表是一种“低保真度”的原型形式。它显示了用户界面元素的相对大小和位置，但没有确切的外观。

各式各样形式的纸上（图表）原型可以按照从最抽象到最具体或者说最实际作如下排列：

1.常规的（完全抽象）内容模型；

2.线框（wire-frame）模型

3.抽象布局图表

4.低保真度纸上模型（粗略的草图）

5.高保真度纸上模型（真实的细节设计）
抽象时的难题

尽管已经证明抽象原型作为设计工具很有效，但也证实对某些设计者是块绊脚石，尤其那些相对缺乏经验或对以使用为中心的设计还在入门阶段的设计者。最常见的问题包括：

● 用抽象术语命名或描述组件的困难

● 区别工具和原料的困难

● 将抽象组件转化为物理组件的困难

● 通过抽象视图布置屏幕和其他用户界面上下文的困难

在命名组件用以支持任务案例的时候，经常发现缺少经验的设计者在抽象条件下思考是困难的。他们常常竭力去设计近似的不承担义务的抽象名字。应该叫做“Employee Record”，还是“Employee Record Holder”，或是“Employee Description Holder”，抑或别的什么名字？如果没有对术语进行仔细的选择，设计者可能在实现真正的用户界面时，不经意地混淆想象中的假定和组件应该具有的最终形式。比如说，一个名为“Employee Data Grid”的组件，可能意味着特别的用户界面数据控制。

因此，以使用为中心的设计不赞成用过于特殊或一体化的技术名词或行话来做抽象组件的名称。比如，相对于用“Search Criteria Entry Field”，是否用“Sought-Person Description Holder”更值得鼓励。然而不幸的是，即使这种习惯在所有特定执行中都作为义务遵守，如果严格地遵循，会在后期把抽象原型转化为执行模型时带来自身的问题。如果由于抽象的影响，应用领域的精确术语，例如实际域的类或方法的引用在上下文模型中被弃用，那么，模型——尽管如预料中那样直接得自任务模型——也可能和其他设计模型以及项目其它部分已制定的词汇表脱离。

遵循推荐的抽象组件命名协议（比如，"Name Holder"、"Constraint Stuff Getter"，诸如此类），设计者最终能得到的不但和最终物理设计脱离，而且和其他模型脱离的模型。这些脱离的联系最后必须在设计里恢复和重建以完成和建造设计。（比如，在一个项目里，设计组常常必须在设计可视原型前回顾每个视图中哪个域对象相互关联。）

高度抽象组件组成的内容模型也难以和外行或开发组的其他部分共享：基本上，如果开发的时候你不在场，那么它们对你而言没有什么意义。

刚起步的设计者还为这样的问题所折磨：要满足任务模型的某个特定要求，到底应该用主动组件还是用被动组件？也就是说，该用抽象工具还是抽象原料？可进行编辑的显示项是主动工具还是被动原料？争论还在持续！

沟通语义隔阂的桥梁

暂且不考虑上述困难，对于多数设计者，一旦他们有过一些实践，就会发现自任务案例派生的初始内容模型通常较为直接。基本上，所要做的就是一步一步完成任务案例解说，确定用户界面所需的工具和原料来完成每个步骤。如图4的例子可以看到，立足于建模的角度，任务模型和内容模型之间的语义隔阂相当小。从各个步骤到抽象工具和原料之间存在着映射，映射即使不是完美的一一对应，也是相对简单的。

相反，充分抽象的内容模型和好的最终设计之间的语义隔阂通常可能非常巨大。实际的纸上模型看起来和内容模型毫无相似之处。在用户界面的抽象模型和实际模型之间存在着许多决策和困难的权衡。必须选择或设计实际的用户界面组件，必须决定屏幕布局，还必须解决其它外观和行为等方面的问题。非常熟练能干的设计者往往有能力较为轻松地跃过这类隔阂，尤其是在对以使用为中心的设计有过实践之后。而入门者和呆板的设计者通常会在这点上被绊倒。其结果可能是混乱不堪。

尽管最初发明抽象内容模型是用来帮助将任务模型转换为实际原型，但经验表明，它太过接近任务模型，又太过远离完成一个可视化交互设计的目标。相对于其收益，最初构思的抽象原型常常被证明太难于开发。

建造更好的桥梁

对一系列项目经验的回顾凸显了抽象原型法的许多缺点，但也让我们确信，任务模型和最终用户界面设计或实现模型之间的模型中介有整体上的优势。对于初学者，比起典型没有使用原型而达成的初始设计，抽象原型看来能通往实质上更好的设计。对于高级的成熟设计者，抽象原型促进创造性思考，导向更为创新的解决方案。

需要一个抽象原型的变体，它位于更接近最终设计的位置，用以充当任务模型和实现模型之间更优秀的翻译者。这样一个模型的修正形式要求：

（1）在开始更容易、更自然地开发；

（2）更容易转化成实际的可视交互设计；

（3）通过域模型更有效和模型的其余部分连接。

关于（3），一个显而易见的解决方法是，保证抽象组件的描述和名字使用领域和用户的词汇表，如同以使用为中心的设计中的其它所有模型。

要达到目标（1）和（2），我们认为用一组标准的抽象组件来构造抽象布局图表的形式能最好地构建抽象原型。对于经验较少的设计者，标准的抽象工具和原料能简化并引导抽象原型的构建，还能压缩最终设计的选择。比如，可以有一个设计者能够进行选择的列表，里面是抽象选择器可能的实现。对于更为高级的设计者，一组简单、标准化的抽象组件可以加速和简化建模过程，让设计者专注于细致的问题和创造性的解决方案。标准化抽象组件还应该能够让认可和描述某些模式更容易，这些模式支持特殊的可视、交互设计方案。尽管我们不相信描述抽象问题的标准方法能称心如意地把用户设计过程变成依葫芦画瓢，但它也许可以帮助设计组对某些标准问题作出好的解决方案来。

规范抽象组件

如同图形用户界面提供一套标准的实际组件工具包给设计者选择，规范抽象组件提供了一套标准的抽象组件"工具包"用于抽象原型构建。这套建议的规范抽象组件是经过多次持续求精和反复的尝试性应用之后才作出的。当前版本决不是一个理论最小集或无懈可击的，但我们相信它是实用有效的，它覆盖了在以使用为中心的用户界面设计中出现的所有公共案例。

表1概要地说明了这套规范抽象组件。规范抽象组件用名字和简单图表或图示符作标识，后者给高级设计者作为图形速记符号，并帮助抽象原型的可视化识别和判读。（我们敏锐地意识到，要让这样一种速记成为真正的捷径，适当的工具是必须的。）新的符号分别来源于两套已经用于表示工具和原料符号的主题和变种。尽管不是所有的符号第一眼看上去都能显得合乎直觉，但我们已经竭力使其在初次看到时就能充当有效的提示。

如表1所概述，建议的规范抽象组件包括：

（a）普通或通用抽象组件

（b）一套核心的附加基本抽象组件和

（c）少数辅助的专用组件，也就是那些即使理论上不需要但实践的观点公认经常是需要的。（可选的组件在表 1中用灰色高亮突出。）所有原料是一般容器的有效特殊化，而所有工具则是一般操作/动作的特殊化，所以一般组件总是可以用于任何目的。

原料

有三种基本的抽象原料：

● 容器（普通的）

● 元素

● 集合

加上一种辅助组件

● 通知

抽象原料建议的命名约定是完全使用内容的名字，亦即对象、类、数据元素，或类似的表示。如果阐明了模型的话，添加诸如"持有者"或"容器"之类术语也是可接受的，但不是必需的（例如，"当前机器配置"或"被翻译语言持有者"）。对于集合的约定是，或者使用复数来暗示是多个内容（例如，"特殊符号"），或者描述集合的种类或类型（"地址列表"），以此达到适当和必需的明确性。

无论是在纸上，还是在CASE工具里，或预打印表格中，抽象组件可以用图表单独标记，也可以用图表加上跟随用户提供名字的组件类型。例如：

● 集合：个人地址列表

● 个人地址列表

事实上，公告是一个消息容器或指示器，应该由表达的消息、条件和事件来命名（例如："太多条目"或"机器不同步"或"开启"）。

工具

操作和动作是两类截然不同的抽象工具。操作是在原料上进行作业的抽象工具，动作则是导致或触发某些行为的抽象工具。类属于动作/操作，有八种基本抽象工具。

1.动作：

1)启动 开始

2)终止 退出

2. 操作

1)选择

2)创建

3)删除

4)修改

5)移动

6)复制

3.辅助工具

1)接受

2)转向 连接

对于建模，接受工具可以当作一个主动原料使用，即一个容器从用户处取得输入；也可以当作一个操作容器的工具使用。对于一切实践上的目的，最一般的工具是启动/开始。

命名抽象工具建议的约定仅仅是说明动作。对于一般的动作，前缀"做"或"开始"是可选的（例如，"做符号检查"或"打印符号表"）。对于模型预定目的的结果清晰的地方，可以使用图形符号或只用名字。假设图形符号和动作名称在多数情况下可以互相替代。因此下边是对同一组件的三种不同描述方法：

● 关闭配置

● 配置

● 关闭：配置

在需要清晰的地方，操作原料的工具（操作）应该给原料命名。抽象原型里，操作只能放置在操作的原料上或一起放置在任何这样便于用图表表示和有意义的地方。

这在实践上整个看起来像什么？我们现在相信，对于多数的用户界面设计，最有用的抽象原型形式是抽象布局图表，其抽象组件的大小和相对位置是有意义的。

图5是一个使用规范组件的抽象布局的例子。它只是特意用作说明，并不是可仿效或值得仿效的。如例子所示，有时候其它组件内的抽象组件嵌套既是必要的又是有利的。

正如已经讨论过的，不同的抽象原型形式有不同程度的抽象。另外一种有价值，尤其对基于Web工程或非常大型的设计问题很有用的变体是基于文本的非图形形式，它仅仅列出视图和它们的内容。如下例子所示（基于图5的简单翻译），不管有没有图形符号，使用抽象规范组件改善了可读性，有助于阐述基于文本的内容模型。（注意抽象组件的嵌套。）

actions:

initiate/start

terminate/quit

operations

.select

.create

.delete

.modify

.move

.duplicate

auxiliary tools:

.accept

.go/link

源自规范原型的设计过程

无论对于经验丰富的、成熟的设计者，还是经验与才能都一般的设计者，在抽象原型里使用一套规范组件总是提供了潜在的好处。从规范原型到实际原型或最终原型的转化包括了两个并发而且相互依赖的关联动作：可视化设计和交互设计。

可视化设计包括：

（a）可视化组件的选择或设计，以实现每个规范组件能够结合

（b）界面上这些可视化组件在视图或上下文里的布局。

交互设计包括：

（a）交互习惯用语的选择或设计

（b）描述界面和底层系统必要的行为，

（c）组织视图或上下文之间及内部的交互工作流或次序。

对于常规设计，每个规范组件只需要用一个或多个标准用户界面窗口小部件实现。要达到最佳效果，设计者应该对每个抽象组件在各式各样可选实现做出决定。构造纸上原型的实验布局是基于这些方案的初始选择。典型地，实际用户界面组件的选择蕴含着许多交互设计，而布局则决定了工作流。为有效支持任务案例，应该相对于被支持的精炼任务案例，和组件选择与布局一起，检查作为结果的交互设计。

在以高性能或突破性设计为目标的地方，规范模型为创造性设计提供额外指导。使用规范组件使得有经验的设计者更易于辨认和区分模式或隐含了某种问题或解决方案的公共状况。比如，对以往设计工作的回顾表明，确定配置的成熟时机往往是发现新的用户界面控制--既能高效使用又能更好利用屏幕真实状态。例如在高级设计组的手里，容器、集合或内含（嵌套）工具元素之间的嵌套结合常常可以变成有效的非标准用户界面控制。

概括地说，基于规范原型的创新设计的过程是这样进行的：首先，记录联系紧密或成组的抽象组件，尤其是嵌套的联合。对于每一个这样的组或联合：

1.识别常规/例程实现和创新的部分；

2.选择有希望的联合；

3.合成并精炼。

应用实例

作为一个简化的例子，考虑图6显示的抽象原型部分。其中，条目的集合可以被用户任意按新的顺序重排。许多可视设计的近似途径是可能的，除了其他的以外，还包括：

● 一个可编辑的顺序数字列表

● 一个列表，有up和down按钮，可以在表内移动选中的项

● 一个临时储存列表，允许在主列表内移去和重新插入项

每一个近似途径中包括了略微不同的可视化组件和布局发布。

交互设计包括识别可能的界面行为以及解决这个问题的交互习惯用语。包括：

● 点击选择源点和目标

● 拖放

● 编辑顺序数字

● 点击移上或移下按钮

一个有前途的、同时支持新手和更高级使用模式的联合应该既支持在列表内用上-下按钮移动，又支持用拖放移动。初始设计可能类似于图7（a），它凸显了几个问题。如果将上-下按钮和滚动条按钮放在他们通常的位置上，很容易造成混淆。如果只是简单地移到左边，则它们可能容易被忽略，并且它们的功能可能不清晰。

这样的问题可以用适当的可视交互设计来解决。如图7（b）所示，通过把上-下按钮移到左边，改变它们的形状，以及用彩色图示符突出它们，可以增强它们的独立性。如果一开始屏蔽（变灰）了上-下按钮，然后，当选了列表中的条目时，激活并用彩色高亮，那就能通过这种逐步启动的方式使界面带有启发性。可以在列表内拖放条目是一个值得采用的功能，尤其对高级用户而言，但这种功能是一种没有给用户合适反馈的隐式行为。只要列表中的条目被选中，在鼠标向下时把光标变成上-下移动的形式，可以移动的信息就能够传达给用户。

结论

使用规范抽象组件的抽象布局图表提供了一个令人兴奋的新工具，它可以平滑和加速以使用为中心的设计过程。如本文所描述的，这些“规范原型”。

● 由特殊的抽象组件构造，它们从用标准符号描述的一小套标准组件中选择

● 显示布局，包括相对大小，位置和组件的嵌套或覆盖

● 和整个项目中其它所有模型使用相同的用户与应用领域标准词汇表

因此，抽象原型能简单而直接地从任务案例构造，并且比先前的抽象原型形式更接近最终设计。规范原型允许设计者轻易地对特殊的用户界面内容建模，以及试验大概的布局而无需提交外观或图形设计的细节。设计者拥有一整套标准但抽象的组件，并从中进行选择，用来表达用户界面设计的内容和大概布局。由于作为结果的模型在忽略细节的时候更为接近实际用户界面，规范原型促进了最终设计，而不至于失去创造性或非标准实现的可能性。

未来的研究可以进一步提高规范原型的价值。对于任何特殊的执行环境，可以预先对每一个不同的规范组件把不同的有用实现编成目录。特别对于新手，这样的指导相当有用。对于更高级的设计者，可以根据规范组件的联合和构造来组织和描述用户界面设计模式。

术语表

----------------------------------------------
Every mile and every year,
Time and Distance disappear I cannot explain this.
Dear No, I will not even try.

点击查看用户来源及管理<br>发贴IP：61.149.154.87 2003-12-5 13:55:49
编辑这个贴子
why 美女呀，离线，快来找我吧！ 天秤座1979-10-23

等级：初级用户
文章：66
积分：214
注册：2003-3-19
第3楼
发贴心情
[已删除]
[此贴子已经被作者于2003-12-5 14:18:49编辑过]

----------------------------------------------
Every mile and every year,
Time and Distance disappear I cannot explain this.
Dear No, I will not even try.

点击查看用户来源及管理<br>发贴IP：61.149.154.87 2003-12-5 13:56:55
编辑这个贴子
cuckoo 美女呀，在线，快来找我吧！ 巨蟹座1977-6-30

头衔：水晶肥鸟
等级：实习版主
文章：1675
积分：2292
注册：2003-3-14
给cuckoo发送一个短消息 把cuckoo加入好友 查看cuckoo的个人资料 搜索cuckoo在[U.I]. 交互界面-理论研究的所有贴子 点击这里发送电邮给cuckoo OICQ 访问cuckoo的主页 引用回复这个贴子 回复这个贴子 第4楼
发贴心情
用户界面原型开发：技巧和技术

几经发过了

----------------------------------------------
人机交互促成我们心灵的交互……
----------------------------------------------

点击查看用户来源及管理<br>发贴IP：211.100.14.14 2003-12-5 14:06:14
编辑这个贴子
lorena 美女呀，离线，快来找我吧！

等级：初级用户
文章：27
积分：67
注册：2003-11-11
第5楼
发贴心情
好东西!谢谢beauty WHY")
点击查看用户来源及管理<br>发贴IP：61.51.125.174 2003-12-23 11:20:18
编辑这个贴子
hatpdb 帅哥哟，离线，有人找我吗？

等级：初级用户
文章：17
积分：50
注册：2003-12-25
第6楼
发贴心情
我为什么没有早点读到这么好的文章啊?
点击查看用户来源及管理<br>发贴IP：211.162.157.177 2003-12-26 20:52:32
编辑这个贴子

本主题贴数6，分页： [1]
*快速回复：[转]界面设计及原型开发的几篇文章
你的用户名: 还没注册? 密码: 忘记密码?
内容
  • HTML标签： 不可用
  • UBB标签： 可用
  • 贴图标签： 可用
  • Flash标签：不可用
  • 表情字符转换：可用
  • 上传图片：可用
  • 最多15KB
    • 邮件回复 显示签名 [Ctrl+Enter直接提交贴子]

    锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

    Powered by：DVBBS Ver5.0 Final
    Copyright © 2003 ChinaUI.com , 页面执行时间：484.375毫秒