无标题文档

落伍者论坛精华文档（最后整理时间:2003/07/22）
整理：GOAO chm电子文档制作： 同风 （落伍ID：0129）
落伍者论坛：http://www.im286.com http://www.im286.net
同风中文网：http://www.51one.com http://www.51one.net


无标题文档

PHP部分

1. PHP 在Windows 2003 Enterprise Server 、IIS6.0 下的安装 -- 小林
2. W2K+PHP+MYSQL+TOMCAT+JSP完全整合安装手册 -- axin
3. APACHE+MYSQL+PHP+ZendOptimizer图文安装手册。 -- 星晴ぃ
4. win2000+apache+php+mysql+mod_perl+perl+mod_ssl+openssl+
ZendOptimizer安装攻略 -- xdiy
5. PHP 基础 之 php.ini中文版 -- 街舞
6. PHP 安全问题 大家注意一下 -- 街舞
7. 经验积累，献给PHP爱好者 -- 剑枫
8 . Arvan的函数(类)库。[另外希望有高手加入自己的函数] -- arvan


落伍者论坛 - 网站建设专栏 - 经验积累，献给PHP爱好者 - powered by Discuz!

落伍者论坛
» 0129: 退出 | 短消息 | 控制面板 | 搜索 | 帮助 落伍者下载 落伍者镜像 永久感谢 落伍专用FTP

落伍者论坛 » 网站建设专栏 » 经验积累，献给PHP爱好者

作者:
标题: 经验积累，献给PHP爱好者 上一主题 | 下一主题
剑枫
落伍者

积分 8242
发贴 7729
注册 2002-1-14
来自 西监狱213号房
经验积累，献给PHP爱好者

1、关于PHP重定向
方法一：header("Location: index.php");
方法二：echo "<script>window.location =\"$PHP_SELF\";</script>";
方法三：echo "<META HTTP-EQUIV=\"Refresh\" CONTENT=\"0; URL=index.php\">";

2、获取访问者浏览器
function browse_infor()
{
$browser="";$browserver="";
$Browsers =array("Lynx","MOSAIC","AOL","Opera","JAVA","MacWeb","WebExplorer","OmniWeb");
$Agent = $GLOBALS["HTTP_USER_AGENT"];
for ($i=0; $i<=7; $i++)
{
if (strpos($Agent,$Browsers[$i]))
{
$browser = $Browsers[$i];
$browserver ="";
}
}
if (ereg("Mozilla",$Agent) && !ereg("MSIE",$Agent))
{
$temp =explode("(", $Agent); $Part=$temp[0];
$temp =explode("/", $Part); $browserver=$temp[1];
$temp =explode(" ",$browserver); $browserver=$temp[0];
$browserver =preg_replace("/([\d\.]+)/","\\1",$browserver);
$browserver = " $browserver";
$browser = "Netscape Navigator";
}
if (ereg("Mozilla",$Agent) && ereg("Opera",$Agent))
{
$temp =explode("(", $Agent); $Part=$temp[1];
$temp =explode(")", $Part); $browserver=$temp[1];
$temp =explode(" ",$browserver);$browserver=$temp[2];
$browserver =preg_replace("/([\d\.]+)/","\\1",$browserver);
$browserver = " $browserver";
$browser = "Opera";
}
if (ereg("Mozilla",$Agent) && ereg("MSIE",$Agent))
{
$temp = explode("(", $Agent); $Part=$temp[1];
$temp = explode(";",$Part); $Part=$temp[1];
$temp = explode(" ",$Part);$browserver=$temp[2];
$browserver =preg_replace("/([\d\.]+)/","\\1",$browserver);
$browserver = " $browserver";
$browser = "Internet Explorer";
}
if ($browser!="")
{
$browseinfo = "$browser$browserver";
}
else
{
$browseinfo = "Unknown";
}
return $browseinfo;
}
//调用方法$browser=browseinfo() ;直接返回结果

3、获取访问者操作系统
function osinfo() {
$os="";
$Agent = $GLOBALS["HTTP_USER_AGENT"];
if (eregi('win',$Agent) && strpos($Agent, '95')) {
$os="Windows 95";
}
elseif (eregi('win 9x',$Agent) && strpos($Agent, '4.90')) {
$os="Windows ME";
}
elseif (eregi('win',$Agent) && ereg('98',$Agent)) {
$os="Windows 98";
}
elseif (eregi('win',$Agent) && eregi('nt 5\.0',$Agent)) {
$os="Windows 2000";
}
elseif (eregi('win',$Agent) && eregi('nt',$Agent)) {
$os="Windows NT";
}
elseif (eregi('win',$Agent) && eregi('nt 5\.1',$Agent)) {
$os="Windows XP";
}
elseif (eregi('win',$Agent) && ereg('32',$Agent)) {
$os="Windows 32";
}
elseif (eregi('linux',$Agent)) {
$os="Linux";
}
elseif (eregi('unix',$Agent)) {
$os="Unix";
}
elseif (eregi('sun',$Agent) && eregi('os',$Agent)) {
$os="SunOS";
}
elseif (eregi('ibm',$Agent) && eregi('os',$Agent)) {
$os="IBM OS/2";
}
elseif (eregi('Mac',$Agent) && eregi('PC',$Agent)) {
$os="Macintosh";
}
elseif (eregi('PowerPC',$Agent)) {
$os="PowerPC";
}
elseif (eregi('AIX',$Agent)) {
$os="AIX";
}
elseif (eregi('HPUX',$Agent)) {
$os="HPUX";
}
elseif (eregi('NetBSD',$Agent)) {
$os="NetBSD";
}
elseif (eregi('BSD',$Agent)) {
$os="BSD";
}
elseif (ereg('OSF1',$Agent)) {
$os="OSF1";
}
elseif (ereg('IRIX',$Agent)) {
$os="IRIX";
}
elseif (eregi('FreeBSD',$Agent)) {
$os="FreeBSD";
}
if ($os=='') $os = "Unknown";
return $os;
}
//调用方法$os=os_infor() ;

4、文件格式类
$mime_types = array(
'gif' => 'image/gif',
'jpg' => 'image/jpeg',
'jpeg' => 'image/jpeg',
'jpe' => 'image/jpeg',
'bmp' => 'image/bmp',
'png' => 'image/png',
'tif' => 'image/tiff',
'tiff' => 'image/tiff',
'pict' => 'image/x-pict',
'pic' => 'image/x-pict',
'pct' => 'image/x-pict',
'tif' => 'image/tiff',
'tiff' => 'image/tiff',
'psd' => 'image/x-photoshop',

'swf' => 'application/x-shockwave-flash',
'js' => 'application/x-javascript',
'pdf' => 'application/pdf',
'ps' => 'application/postscript',
'eps' => 'application/postscript',
'ai' => 'application/postscript',
'wmf' => 'application/x-msmetafile',

'css' => 'text/css',
'htm' => 'text/html',
'html' => 'text/html',
'txt' => 'text/plain',
'xml' => 'text/xml',
'wml' => 'text/wml',
'wbmp' => 'image/vnd.wap.wbmp',

'mid' => 'audio/midi',
'wav' => 'audio/wav',
'mp3' => 'audio/mpeg',
'mp2' => 'audio/mpeg',

'avi' => 'video/x-msvideo',
'mpeg' => 'video/mpeg',
'mpg' => 'video/mpeg',
'qt' => 'video/quicktime',
'mov' => 'video/quicktime',

'lha' => 'application/x-lha',
'lzh' => 'application/x-lha',
'z' => 'application/x-compress',
'gtar' => 'application/x-gtar',
'gz' => 'application/x-gzip',
'gzip' => 'application/x-gzip',
'tgz' => 'application/x-gzip',
'tar' => 'application/x-tar',
'bz2' => 'application/bzip2',
'zip' => 'application/zip',
'arj' => 'application/x-arj',
'rar' => 'application/x-rar-compressed',

'hqx' => 'application/mac-binhex40',
'sit' => 'application/x-stuffit',
'bin' => 'application/x-macbinary',

'uu' => 'text/x-uuencode',
'uue' => 'text/x-uuencode',

'latex'=> 'application/x-latex',
'ltx' => 'application/x-latex',
'tcl' => 'application/x-tcl',

'pgp' => 'application/pgp',
'asc' => 'application/pgp',
'exe' => 'application/x-msdownload',
'doc' => 'application/msword',
'rtf' => 'application/rtf',
'xls' => 'application/vnd.ms-excel',
'ppt' => 'application/vnd.ms-powerpoint',
'mdb' => 'application/x-msaccess',
'wri' => 'application/x-mswrite',
);
5、php生成excel文档
<?
header("Content-type:application/vnd.ms-excel");
header("Content-Disposition:filename=test.xls");
echo "test1\t";
echo "test2\t\n";
echo "test1\t";
echo "test2\t\n";
echo "test1\t";
echo "test2\t\n";
echo "test1\t";
echo "test2\t\n";
echo "test1\t";
echo "test2\t\n";
echo "test1\t";
echo "test2\t\n";
?>
//改动相应文件头就可以输出.doc .xls等文件格式了
6、时间比较问题
举一个简单例子说明:比如一个论坛对当天发表的贴子用new图片标记一下。
方法一：
//$db->rows[$i][date]中为数据库中datetime字段值.
$today=time();
$theDay=date("Y-m-d H:i:s",$today-24*3600);
$newTag=$db->rows[$i][date]>=$theDay?"<img src='../image/newinfor.gif'>":"";
方法二：
$newTag=$db->rows[$i][date]>=date("Y-m-d 00:00:00")?"<img src='../image/newinfor.gif'>":"";
2002-11-22 21:43
堕落恶魔
落伍者

积分 3292
发贴 3310
注册 2002-12-4
来自 断仇谷
怎么一堆表情符号

高考考砸了。。。日。。。
2003-6-5 10:09
小刀
落伍者

积分 2744
发贴 2727
注册 2002-2-25
good!

过了10岁， 还能找到心心相印的伴侣吗？
2003-6-5 10:24
谁知道
落伍者

积分 917
发贴 944
注册 2002-11-21
来自 深圳
此贴为盗版
先声明 下
是我发地 但不是我写地

彻底黑掉这个论坛我给500元报酬 http://www.0530.cn
2003-6-5 10:26

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.023304 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - Arvan的函数(类)库。[另外希望有高手加入自己的函数] - powered by Discuz!

落伍者论坛 » 网站建设专栏 » Arvan的函数(类)库。[另外希望有高手加入自己的函数]

<< [1] [2] [3] >>
作者:
标题: Arvan的函数(类)库。[另外希望有高手加入自己的函数] 上一主题 | 下一主题
Arvan
落伍者

积分 1380
发贴 1202
注册 2002-10-28
Arvan的函数(类)库。[另外希望有高手加入自己的函数]

以前建的函数库今天给弄丢了，到现在只能一个一个自己写了。有些是从我写的已有函数中找回的，有些是新写的。

希望对大家有帮助，同时如果有个中高手看到其中的不足之处也敬请指出。

由于时间有限，增加的速度可能不怎么快，见谅!

以下是我学PHP的心得：
实话告诉你们，写PHP最好的老师就是PHP给出的错误信息。我不骗人，我最喜欢的就是看到错误信息出现在我眼前.不要怕犯错!!!

下面开始:
这是一个读mp3 tag的类,不怎么完善，也可一用

Code: [Copy to clipboard]
/**********
| +---------------------------------------------------
| CLASS NAME: GetTag
| +---------------------------------------------------
| Author: Arvan [E-mail:Arvan@5n9.com QQ:8817776]
| Create date: 2003-6-25
| Note:
| using for getting MP3Tag.
| +---------------------------------------------------
| Warning: Genre could be fetched, but hard to sort
| +---------------------------------------------------
**********/

class GetTag{
var $filename;
var $fd;
var $debug;
function GetTag($filename){
$this->filename = $filename;
$fd = fopen($filename, "r");
$this->fd = $fd;
@fseek($fd, -128, SEEK_END);
$Tag = fread($fd, 3);
if($Tag=="TAG"){
$this->debug = true;
}
}

function GetSongName(){
$fd = $this->fd;
@fseek($fd, -125, SEEK_END);
return fread($fd, 30);
if (!$debug){
return "UNKNOWS";
}
}

function GetArtist(){
$fd = $this->fd;
@fseek($fd, -95, SEEK_END);
return fread($fd, 30);
if (!$debug){
return "UNKNOWS";
}
}

function GetAlbum(){
$fd = $this->fd;
@fseek($fd, -65, SEEK_END);
return fread($fd, 30);
if (!$debug){
return "UNKNOWS";
}
}

function GetYear(){
$fd = $this->fd;
@fseek($fd, -35, SEEK_END);
return fread($fd, 4);
if (!$debug){
return "UNKNOWS";
}
}

function GetComment(){
$fd = $this->fd;
@fseek($fd, -31, SEEK_END);
return fread($fd, 30);
if (!$debug){
return "UNKNOWS";
}
}

function GetGenre(){
$fd = $this->fd;
@fseek($fd, -1, SEEK_END);
$genre = fread($fd, 1);
return $genre;
if (!$debug){
return "UNKNOWS";
}
}
} // end class GetTag

/*****
//example

$t = new GetTag("NovemberRain.mp3");
$songname = $t->getsongname(); //song's name
$Artist = $t->GetArtist(); //Artist
$Album = $t->GetAlbum(); //Album

echo $songname."<br>".$Artist."<br>".$Album;

return:
november rain
guns n' roses
use your illusion
*****/

PS:如果此贴子处于顶置，请大家不要发诸如"t”，“顶”之类的无意义的贴子了。

另外，如果使用从这里的贴子中复制的代码，请注意全角是否对你的程序有影响，因这直接复制过去的有很多全角字符

[ Last edited by Arvan on 2003-7-16 at 08:46 PM ]

我坐在楼顶的边沿上抽烟，一根接一
根，好像要一直抽到永远，就像那深邃的
天空，没有尽头......
2003-7-16 19:56
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20
原来丢失也不是什么坏事情

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-7-16 20:00
Arvan
落伍者

积分 1380
发贴 1202
注册 2002-10-28
标题缩进函数，避免出现半个汉字

Code: [Copy to clipboard]
function SubTitle($title, $length) {
if (strlen($title)>$length) {
$temp = 0;
for($i=0; $i<$length; $i++){
if (ord($title[$i]) > 128){
$temp++;
}
if ($temp%2 == 0){
$title = substr($title,0,$length);
}else{
$title = substr($title,0,$length-1);
}
}
}
return $title;
}

我坐在楼顶的边沿上抽烟，一根接一
根，好像要一直抽到永远，就像那深邃的
天空，没有尽头......
2003-7-16 20:01
Arvan
落伍者

积分 1380
发贴 1202
注册 2002-10-28
字串处理函数，Encode用于存入数据库前使用，Decode于表单中的value中使用

Code: [Copy to clipboard]
/**
+--------------------------------------------------
| 函数名：Encode($str)
| 作用：转换html代码和转行等。
| 参数：
| @param: $str：要转换的字符串
| 返回值：转换后的字符串。
+--------------------------------------------------
*/
function Encode($str){
if(!get_magic_quotes_gpc()){
$str = addslashes($str);
}
$str = htmlspecialchars($str);
$str = str_replace("\r\n","<br>",$str);
$str = str_replace("\r","<br>",$str);
$str = str_replace("\n","<br>",$str);
$str = str_replace(" ","　",$str);
$str = str_replace("'","’",$str);
return $str;
}
/**
+--------------------------------------------------
| 函数名：Decode($str)
| 作用：与Encode相反，用于修改时还原回本来的字符串
| 参数：
| @param: $str：要转换的字符串。
| 返回值：转换后的字符串。
+--------------------------------------------------
*/
function Decode($str){
$str = str_replace("<br>","\r\n",$str);
$str = str_replace("<br>","\r",$str);
$str = str_replace("<br>","\n",$str);
$str = str_replace("<","&lt;",$str);
$str = str_replace(">","&gt;",$str);
$str = str_replace("’","'",$str);
return $str;
}

我坐在楼顶的边沿上抽烟，一根接一
根，好像要一直抽到永远，就像那深邃的
天空，没有尽头......
2003-7-16 20:04
Arvan
落伍者

积分 1380
发贴 1202
注册 2002-10-28
这个数据库操作的类是我朋友写的，我一直在用

Code: [Copy to clipboard]
/*****
// +-------------------------------------------------
// | Id: unt_db.php
// +-------------------------------------------------
// | Author：weekend Arvan(Modify)
// +-------------------------------------------------
// | Note:
// | 数据库操作的类
// |
// |
// +-------------------------------------------------
*****/

class TDb{
var $host;
var $user;
var $password;
var $database;

var $n;
var $result="";
var $conn="";

var $debug = true;
var $errMsg = "";

function TDb($host,$user,$password,$database){
$this->host=$host;
$this->user=$user;
$this->password=$password;
$this->conn=@mysql_connect($host,$user,$password) or die("<br><br><b>Err:</b>SQL busy,please try again later!");

$this->set_db($database);

$this->errMsg ="";
$this->n = 0;
}//end func db

function exec($sql, $db_name = ''){
if (($db_name != '') && ($db_name != $this->database)){
$old_db = $this->database;
$this->set_db($db_name);
}
$this->n = 0;
$this->result=@mysql_query($sql,$this->conn);
if (mysql_error() != ""){
$this->errMsg = mysql_error();
if ($this->debug){
echo "<br><br><b>Err:</b>Fail to execute this SQL query：$sql<br><br>$this->errMsg";
}else{
echo "<br><br><br><b>Err:</b>Please check the query is normal and make sure that It's allowed！";
}
exit;
}
$this->n = @mysql_affected_rows();
if($old_db != ''){
$this->set_db($old_db);
}
return true;
}

function get_data(){
if($this->result==""){
echo "<br><br><b>Err:</b>There is no result please run method exec(\$sql) first";
exit;
}
$count=0;
while($row=mysql_fetch_array($this->result)){
$data[$count]=$row;
$count++;
}
mysql_free_result($this->result);
return $data;
}//end func getData

function get_ins_id(){
return mysql_insert_id();
}

function free(){
mysql_close($this->conn);
}

function set_db($db_name){
if($db_name != $this->database){//select new table while they are different
@mysql_select_db($db_name) or die("<br><b>Err:</b>Fail to select $db_name table, make sure it's allowed to do this!");
$this->database=$db_name;
}
return true;
}

function get_cur_db(){
return $this->database;
}
}//end class db

我坐在楼顶的边沿上抽烟，一根接一
根，好像要一直抽到永远，就像那深邃的
天空，没有尽头......
2003-7-16 20:09
Arvan
落伍者

积分 1380
发贴 1202
注册 2002-10-28
使用JAVASCRIPT的ALERT.呵呵，自己看看有没有用，没测试，不知有没有错。：)

Code: [Copy to clipboard]
function Alert($str, $url=''){
if (empty($url)){
$js = <<<EOT
<script language="javascript">
alert("$str");
</script>
EOT;
}else{
$js = <<<EOT
<script language="javascript">
alert("str");
location.href = "$url";
</script>
EOT;
}
echo $js;
}

我坐在楼顶的边沿上抽烟，一根接一
根，好像要一直抽到永远，就像那深邃的
天空，没有尽头......
2003-7-16 20:27
剑枫
落伍者

积分 8242
发贴 7729
注册 2002-1-14
来自 西监狱213号房
有没关于模半应用的文章

★★重拳出击强力打造落伍最长水渠★★
2003-7-16 20:35
Arvan
落伍者

积分 1380
发贴 1202
注册 2002-10-28

Quote:
Originally posted by 剑枫 at 2003-7-16 08:35 PM:
有没关于模半应用的文章

模板我用的是phplib里的类

我坐在楼顶的边沿上抽烟，一根接一
根，好像要一直抽到永远，就像那深邃的
天空，没有尽头......
2003-7-16 20:36
剑枫
落伍者

积分 8242
发贴 7729
注册 2002-1-14
来自 西监狱213号房

Quote:
Originally posted by Arvan at 2003-7-16 08:36 PM:

模板我用的是phplib里的类

FT的呢

★★重拳出击强力打造落伍最长水渠★★
2003-7-16 20:37
Arvan
落伍者

积分 1380
发贴 1202
注册 2002-10-28

Quote:
Originally posted by 剑枫 at 2003-7-16 08:37 PM:

FT的呢

没用过

我坐在楼顶的边沿上抽烟，一根接一
根，好像要一直抽到永远，就像那深邃的
天空，没有尽头......
2003-7-16 20:47
walker
落伍者

积分 291
发贴 318
注册 2002-2-14

Quote:
Originally posted by 剑枫 at 2003-7-16 08:37 PM:

FT的呢

我以前用的时候 似乎不支持循环嵌套的。

欢迎来到 <<风之谷>>FTP资源共享站
2003-7-16 20:48
准备早起的鸟
落伍者

积分 1354
发贴 1352
注册 2003-2-25
来自 安徽滁州
有没有smarty中文比较全的文档？

Quote:
出售 php,mysql,asp.net,asp,高速空间,自己的服务器,托管在电信,服务好有保障。
服务器托管,3000元/年,需要者请联系QQ:55025

2003-7-16 21:19
godamen
落伍者

积分 1933
发贴 1912
注册 2002-8-19
来自 上海浦东

Quote:
Originally posted by walker at 2003-7-16 20:48:

我以前用的时候 似乎不支持循环嵌套的。

可以，只是不方便

php+mysql超强电影程式出售　QQ:11822350

C1G工作室[留言本，探针，下载，订单]
2003-7-16 21:22
Arvan
落伍者

积分 1380
发贴 1202
注册 2002-10-28

Quote:
Originally posted by 准备早起的鸟 at 2003-7-16 09:19 PM:
有没有smarty中文比较全的文档？

没有，我只是自己要用到什么的时候就写出来......这不是好习惯，因为可能早已经有更好的存在了。不过是改不了了。：)

我坐在楼顶的边沿上抽烟，一根接一
根，好像要一直抽到永远，就像那深邃的
天空，没有尽头......
2003-7-16 21:36
让爱做主
又脏又丑农村户口

积分 17166
发贴 17150
注册 2002-7-23
来自 摸摸镇捏捏村
PHP跟哪门语言有关系

Quote:
国际玉米 70元/年 国内玉米 200元/年 各类虚拟主机特价出售
至强型论坛空间 ASP+ACCESS 可选SQL 演示：http://bbs.jetdown.com/ 业务联系QQ：365285

2003-7-16 21:39
<< [1] [2] [3] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.030775 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - Arvan的函数(类)库。[另外希望有高手加入自己的函数] - powered by Discuz!

落伍者论坛 » 网站建设专栏 » Arvan的函数(类)库。[另外希望有高手加入自己的函数]

<< [1] [2] [3] >>
作者:
标题: Arvan的函数(类)库。[另外希望有高手加入自己的函数] 上一主题 | 下一主题
剑枫
落伍者

积分 8242
发贴 7729
注册 2002-1-14
来自 西监狱213号房

Quote:
Originally posted by walker at 2003-7-16 08:48 PM:

我以前用的时候 似乎不支持循环嵌套的。

什么最好呢

★★重拳出击强力打造落伍最长水渠★★
2003-7-16 22:04
星期天
落伍者

积分 1119
发贴 1050
注册 2003-2-16
来自 广西防城港市
在学

http://www.lzh520.com
-------御缘永远的家！
千贴留念：P免费提供10个主叶下载！！
http://im286.com/viewthread.php?tid=260519&fpage=3
2003-7-16 23:45
walker
落伍者

积分 291
发贴 318
注册 2002-2-14
eval() [image] 最快 哈哈

lib的就可以了。

欢迎来到 <<风之谷>>FTP资源共享站
2003-7-17 01:25
yjj798
落伍者

积分 2326
发贴 1910
注册 2002-5-22
来自 石家庄
哇，学习一下这多单词不认识

yjj798 我的电脑
2003-7-17 02:40
梦
杜鹃滴血

积分 2948
发贴 2698
注册 2002-5-6
来自 古墓苍狼
我贴一个没做完的,好向pear上来的，那上边各种类都有。什么cache,session等
还有phpclass.org基本你要什么有什么了。当然如果做自己的系统都的改
我这里的用户分组管理。排序，HTML生成等。分页。模板。数据库。用户登录。zip输出。chche输出等全是类。基本分开的。要用的时候在调用。小的向发信，上传等也是的。主要是为了兼容等。这些类我都在整理中。所有的类基本上很难独立出来。都有一些继承关系等。因为这个是给我系统定做的。

Code: [Copy to clipboard]
<?PHP
/**
* Pager class
*
* Handles paging a set of data. For usage see the FAQ.
*
*/
class PAGES {

var $pageListURL;
var $_perPage;
//var $perListPage;

function PAGES( $params = array() )
{
global $HTTP_GET_VARS;
global $Config,$perListPage;

$this->_currentPage = max( ( int )@$HTTP_GET_VARS['pageID'], 1 );
//$this->_perPage = $Config['perPage'];
$this->_perPage = $perListPage;

$this->_itemData = null;

foreach ( $params as $name => $value )
{
$this-> {'_' . $name} = $value;
}

if ( $this->_itemData !== null )
{
$this->_totalItems = count( $this->_itemData );
}
$this->_generatePageData();
}

function getPageData( $pageID = null )
{
if ( isset( $pageID ) )
{
if ( !empty( $this->_pageData[$pageID] ) )
{
return $this->_pageData[$pageID];
}
else
{
return false;
}
}

if ( !isset( $this->_pageData ) )
{
$this->_generatePageData();
}

return $this->getPageData( $this->_currentPage );
}

function getPageIdByOffset( $index )
{
if ( !isset( $this->_pageData ) )
{
$this->_generatePageData();
}

if ( ( $index % $this->_perPage ) > 0 )
{
$pageID = ceil( ( float )$index / ( float )$this->_perPage );
}
else
{
$pageID = $index / $this->_perPage;
}

return $pageID;
}

function getLinks()
{
global $lang;

$url = $this->_getLinksUrl();
$prev = $this->_getprevLink( $url, $lang['prev_page'] );
$pages = $this->_getPageLinks( $url );
$next = $this->_getNextLink( $url, $lang['next_page'] );

return array( $prev, $pages, $next, 'prev' => $prev, 'pages' => $pages, 'next' => $next );
}

function _generatePageData()
{
if ( $this->_itemData !== null )
{
$this->_totalItems = count( $this->_itemData );
}
$this->_totalPages = ceil( ( float )$this->_totalItems / ( float )$this->_perPage );
$i = 1;
if ( !empty( $this->_itemData ) ) {
foreach ( $this->_itemData as $key => $value )
{
$this->_pageData[$i][$key] = $value;
if ( count( $this->_pageData[$i] ) >= $this->_perPage )
{
$i++;
}
}
}
else
{
$this->_pageData = array();
}
}

function _getLinksUrl()
{
global $HTTP_SERVER_VARS;
$querystring = array();
$qs = array();
if ( !empty( $HTTP_SERVER_VARS['QUERY_STRING'] ) )
{
$qs = explode( '&', $HTTP_SERVER_VARS['QUERY_STRING'] );
for ( $i = 0, $cnt = count( $qs ); $i < $cnt; $i++ )
{
list( $name, $value ) = explode( '=', $qs[$i] );
if ( $name != 'pageID' )
{
$qs[$name] = $value;
}
unset( $qs[$i] );
}
}

foreach ( $qs as $name => $value )
{
$querystring[] = $name . '=' . $value;
}

return $HTTP_SERVER_VARS['SCRIPT_NAME'] . '?' . implode( '&', $querystring ) . ( !empty( $querystring ) ? '&' : '' ) . 'pageID=';
}

function _getprevLink( $url, $link = '<< prev' )
{
global $HTTP_SERVER_VARS;
//global $pageListURL;

if ( $this->_currentPage > 1 )
{
if (!$this->pageListURL)
{
$this->pageListURL = $HTTP_SERVER_VARS['PHP_SELF'];
}

$pagsID = $this->_currentPage - 1;
$prev = "<a href=".$this->pageListURL."?pageID=$pagsID>$link<a>";
//$prev = sprintf( '<a href="%s%d'.$pageListURL.'" %s>%s</a>',
//$url,
//$this->_currentPage - 1,!empty( $this->_linkClass ) ? 'class="' . $this->_linkClass . '"' : '',
//$link );
}
else
{
$prev = '';
}

return $prev;
}

function _getPageLinks( $url )
{
$params['itemData'] = range( 1, max( 1, $this->_totalPages ) );
$pager = &new PAGES( $params );
$links = $pager->getPageData( $pager->getPageIdByOffset( $this->_currentPage ) );

foreach ( $links as $key => $value )
{
if ( $links[$key] != $this->_currentPage )
{
$links[$key] = sprintf( '<a href="%s%d" %s>%d</a>',
$url,
$links[$key],
!empty( $this->_linkClass ) ? 'class="' . $this->_linkClass . '"' : '',
$links[$key] );
}
}

return implode( ' ', $links );
}

function _getNextLink( $url, $link = 'Next >>' )
{
if ( $this->_currentPage < $this->_totalPages )
{
$next = sprintf( '<a href="%s%d" %s>%s</a>',
$url,
$this->_currentPage + 1,
!empty( $this->_linkClass ) ? 'class="' . $this->_linkClass . '"' : '',
$link );
}
else
{
$next = '';
}

return $next;
}
}

?>

www.wps2000.net重新开放
http://www.wps2000.net/
PHP论坛：http://forum.wps2000.net/Forum.php?ForumID=28
2003-7-17 09:09
小林
o○万帖俱乐部老八^_^ ○ o

积分 11252
发贴 11181
注册 2002-10-29
来自 『新都人.COM』

Quote:
Originally posted by Arvan at 2003-7-16 20:36:

模板我用的是phplib里的类

模板好象SMART不错

万维主机-Sunking

『统一行动，开始删贴！』
2003-7-17 10:12
准备早起的鸟
落伍者

积分 1354
发贴 1352
注册 2003-2-25
来自 安徽滁州
smarty没完整中文档，郁闷。
对于不需要经常更新的页面smarty好像不错。

Quote:
出售 php,mysql,asp.net,asp,高速空间,自己的服务器,托管在电信,服务好有保障。
服务器托管,3000元/年,需要者请联系QQ:55025

2003-7-17 11:51
梦
杜鹃滴血

积分 2948
发贴 2698
注册 2002-5-6
来自 古墓苍狼
把上次的无限分类贴出来

Code: [Copy to clipboard]
<?PHP
/*
CREATE TABLE `category` (
`categoryID` int(10) unsigned NOT NULL auto_increment,
`categoryParentID` int(10) unsigned NOT NULL default '0',
`categoryName` varchar(50) NOT NULL default '',
KEY `cate_id` (`categoryID`)
) TYPE=MyISAM AUTO_INCREMENT=11 ;

#
# 导出表中的数据 `category`
#

INSERT INTO `category` VALUES (1, 0, '一级类别1');
INSERT INTO `category` VALUES (2, 1, '二级类别1');
INSERT INTO `category` VALUES (3, 1, '二级类别2');
INSERT INTO `category` VALUES (4, 1, '二级类别3');
INSERT INTO `category` VALUES (5, 2, '三级类别21');
INSERT INTO `category` VALUES (6, 2, '三级类别22');
INSERT INTO `category` VALUES (7, 2, '三级类别23');
INSERT INTO `category` VALUES (8, 3, 'rfwesdfsd');
INSERT INTO `category` VALUES (9, 4, '54534w43');
INSERT INTO `category` VALUES (10, 5, '66666');
有问题请不要问我就行了。其他OK。欢迎修改使用。这是简单的。

*/
mysql_connect( "localhost", 'root', '' );
mysql_select_db( "test" );
$cate_table = "category";

function _GetCategory( $category_id = 0, $depth = 1 )
{
global $cate_table;

$sql = "SELECT * FROM $cate_table ORDER BY categoryID DESC";
$result = mysql_query( $sql );

while ( $row = mysql_fetch_array( $result ) )
{
$array[$row[categoryParentID]][$row[categoryID]]
= array(
'id' => $row[categoryID],
'parent' => $row[categoryParentID],
'name' => $row[categoryName]
);
}

if ( !isset( $array[$category_id] ) )
{
return "";
}

foreach( $array[$category_id] AS $key => $category )
{
echo " <OPTION VALUE=".$category['id']." ";
if ( $category['parent'] == 0 )
{
echo " class='main' ";
}
if ( $depth > 1 )
{
echo ">" . str_repeat( "--", $depth - 1 ) . " " . $category['name'] . "</option>n";
}
else
{
echo ">" . $category['name'] . "</option>\n";
}

_GetCategory( $key, $depth + 1 );
}
unset( $array[$category_id] );
}

?>
<select name="categoryID">
<option selected value="">-------------</option>
<?=_GetCategory();?>
</select>

[ Last edited by 梦 on 2003-7-17 at 03:57 PM ]

www.wps2000.net重新开放
http://www.wps2000.net/
PHP论坛：http://forum.wps2000.net/Forum.php?ForumID=28
2003-7-17 15:40
梦
杜鹃滴血

积分 2948
发贴 2698
注册 2002-5-6
来自 古墓苍狼

Quote:
Originally posted by 准备早起的鸟 at 2003-7-17 11:51 AM:
smarty没完整中文档，郁闷。
对于不需要经常更新的页面smarty好像不错。

我不用
太大。懒的看。我也不喜欢有逻辑处理的模板。向phplib这种更适合真正的程序和美工分离。加那么多。if,else之类的很多美工不一定懂。
web语言模板的本意就是要把程序和美工分开。做做不到那模板没必要。浪费速度。

www.wps2000.net重新开放
http://www.wps2000.net/
PHP论坛：http://forum.wps2000.net/Forum.php?ForumID=28
2003-7-17 15:59
ipseeker
落伍者

积分 1502
发贴 1497
注册 2003-2-14

Quote:
Originally posted by 梦 at 2003-7-17 03:59 PM:

我不用
太大。懒的看。我也不喜欢有逻辑处理的模板。向phplib这种更适合真正的程序和美工分离。加那么多。if,else之类的很多美工不一定懂。
web语言模板的本意就是要把程序和美工分开。做做不到那模板没必要。 ...

同意
在模板中加入逻辑关系，我也不喜欢

Quote:
QQ：311973
ICQ：326006
没事儿别加我

2003-7-17 16:43
准备早起的鸟
落伍者

积分 1354
发贴 1352
注册 2003-2-25
来自 安徽滁州
smarty可以“编译”php文件，模板使用上用的变量比phplib少。俺以前也用phplib，现在学习smarty中。

Quote:
出售 php,mysql,asp.net,asp,高速空间,自己的服务器,托管在电信,服务好有保障。
服务器托管,3000元/年,需要者请联系QQ:55025

2003-7-17 18:19
Arvan
落伍者

积分 1380
发贴 1202
注册 2002-10-28
今天写的分页类

由于是上班时候写的，所以如果全部由部贴出来恐怕对不起公司，所以我把其中的表单跳转删去了。别见怪哦。。。

格式写法是比较标准的了

Code: [Copy to clipboard]
class PageBar
{
var $total;
var $onepage;
var $num;
var $pagecount;
var $total_page;
var $offset;
var $linkhead;

function PageBar($total, $onepage, $form_vars='')
{
$pagecount = $_GET['pagecount'];
$this->total = $total;
$this->onepage = $onepage;
$this->total_page = ceil($total/$onepage);

if (empty($pagecount))
{
$this->pagecount = 1;
$this->offset = 0;
}
else
{
$this->pagecount = $pagecount;
$this->offset = ($pagecount-1)*$onepage;
}

if (!empty($form_vars))
{

$vars = explode("|", $form_vars);
$chk = $vars[0];
$chk_value = $_POST["$chk"];
if (empty($chk_value))
{
$formlink = "";
}
else
{
for ($i=0; $i<sizeof($vars); $i++)
{
$var = $vars[$i];
$value = $_POST["$var"];
$addchar = $var."=".$value;

$formlink = $formlink.$addchar."&";
}
}
}
else
{
$formlink = "";
}

$linkarr = explode("pagecount=", $_SERVER['QUERY_STRING']);
$linkft = $linkarr[0];

if (empty($linkft))
{
$this->linkhead = $_SERVER['PHP_SELF']."?".$formlink;
}
else
{
$linkft = (substr($linkft, -1)=="&")?$linkft:$linkft."&";
$this->linkhead = $_SERVER['PHP_SELF']."?".$linkft.$formlink;
}

}
#End function PageBar();

function offset()
{
return $this->offset;
}
#End function offset();

function pre_page($char='')
{
$linkhead = $this->linkhead;
$pagecount = $this->pagecount;
if (empty($char))
{
$char = "[<]";
}

if ($pagecount>1)
{
$pre_page = $pagecount - 1;
return "<a href=\"$linkhead"."pagecount=$pre_page\">$char</a>";
}
else
{
return '';
}

}
#End function pre_page();

function next_page($char='')
{
$linkhead = $this->linkhead;
$total_page = $this->total_page;
$pagecount = $this->pagecount;
if (empty($char))
{
$char = "[>]";
}
if ($pagecount<$total_page)
{
$next_page = $pagecount + 1;
return "<a href=\"$linkhead"."pagecount=$next_page\">$char</a>";
}
else
{
return '';
}
}
#End function next_page();

function num_bar($num='', $color='', $left='', $right='')
{
$num = (empty($num))?10:$num;
$this->num = $num;
$mid = floor($num/2);
$last = $num - 1;
$pagecount = $this->pagecount;
$totalpage = $this->total_page;
$linkhead = $this->linkhead;
$left = (empty($left))?"[":$left;
$right = (empty($right))?"]":$right;
$color = (empty($color))?"#ff0000":$color;
$minpage = (($pagecount-$mid)<1)?1:($pagecount-$mid);
$maxpage = $minpage + $last;
if ($maxpage>$totalpage)
{
$maxpage = $totalpage;
$minpage = $maxpage - $last;
$minpage = ($minpage<1)?1:$minpage;
}

for ($i=$minpage; $i<=$maxpage; $i++)
{
$char = $left.$i.$right;
if ($i==$pagecount)
{
$char = "<font color='$color'>$char</font>";
}

$linkchar = "<a href='$linkhead"."pagecount=$i'>".$char."</a>";
$linkbar = $linkbar.$linkchar;
}

return $linkbar;
}
#End function num_bar();

function pre_group($char='')
{
$pagecount = $this->pagecount;
$linkhead = $this->linkhead;
$num = $this->num;
$mid = floor($num/2);
$minpage = (($pagecount-$mid)<1)?1:($pagecount-$mid);
$char = (empty($char))?"[<<]":$char;
$pgpagecount = ($minpage>$num)?$minpage-$mid:1;
return "<a href='$linkhead"."pagecount=$pgpagecount'>".$char."</a>";
}
#End function pre_group();

function next_group($char='')
{
$pagecount = $this->pagecount;
$linkhead = $this->linkhead;
$totalpage = $this->total_page;
$num = $this->num;
$mid = floor($num/2);
$last = $num;
$minpage = (($pagecount-$mid)<1)?1:($pagecount-$mid);
$maxpage = $minpage + $last;
if ($maxpage>$totalpage)
{
$maxpage = $totalpage;
$minpage = $maxpage - $last;
$minpage = ($minpage<1)?1:$minpage;
}

$char = (empty($char))?"[>>]":$char;
$ngpagecount = ($totalpage>$maxpage+$last)?$maxpage + $mid:$totalpage;

return "<a href='$linkhead"."pagecount=$ngpagecount'>".$char."</a>";
}
#End function next_group();

function whole_num_bar($num='', $color='')
{
$num_bar = $this->num_bar($num, $color);
$pre_group = $this->pre_group();
$pre_page = $this->pre_page();
$next_page = $this->next_page();
$next_group = $this->next_group();

return $pre_group.$pre_page.$num_bar.$next_page.$next_group;
}
#End function whole_bar();

}
#End class PageBar;

/*****
//example

$total = 1000;
$onepage = 20;

$pb = new PageBar($total, $onepage);
$offset = $pb->offset();
$pagebar = $pb->whole_num_bar();

echo $offset."<br>".$pagebar;

return:
0
[<<] [1][2][3][4][5][6][7][8][9][10][>][>>]

*****/

[ Last edited by Arvan on 2003-7-18 at 07:07 PM ]

我坐在楼顶的边沿上抽烟，一根接一
根，好像要一直抽到永远，就像那深邃的
天空，没有尽头......
2003-7-17 18:55
ipseeker
落伍者

积分 1502
发贴 1497
注册 2003-2-14
phplib看过
smarty没研究过，据一个高手说，smarty已经复杂到“等于另外一个语言了”，呵呵，所以更加没有兴趣了

Quote:
QQ：311973
ICQ：326006
没事儿别加我

2003-7-17 23:07
walker
落伍者

积分 291
发贴 318
注册 2002-2-14

Code: [Copy to clipboard]
/*
+---------------------------------------------------------------------+
| 页面跳转函数
+---------------------------------------------------------------------+
| jump2url(提示信息, 跳转到的地址, 停留时间 单位:秒)
+---------------------------------------------------------------------+
| by WalkerLee ( http://www.walkerlee.net) QQ:808075
+---------------------------------------------------------------------+
| 创建/修改 时间: 2003年7月14日 12:20:33 / 2003年7月15日 5:05:56
+---------------------------------------------------------------------+
*/

function jump2url($msg, $url = "javascript:history.go(-1)", $sec = 5)
{
?>
<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=gb2312">
<meta http-equiv="refresh" content="<?=$sec?>;url=<?=$url?>">
<link rel=stylesheet href=style.css type=text/css>
</head>

<body>
<br>
<div align="center">
<center>
<table border="1" cellpadding="0" cellspacing="0" style="border-collapse: collapse" bordercolor="#666666" width="90%" height="50">
<tr>
<td bgcolor="#F7F7F7">
<p align="center"><br><font color="blue">提示信息 : <?=$msg?></font><br><br>( <a href=<?=$url?>>过 <?=$sec?> 秒后,页面将自动跳转,或者,您也可以点击这里</a> )<br><br></td>
</tr>
</table>
</center>
</div>

</body>

</html>
<?
exit;
}

欢迎来到 <<风之谷>>FTP资源共享站
2003-7-18 09:01
walker
落伍者

积分 291
发贴 318
注册 2002-2-14

Code: [Copy to clipboard]
/*
+---------------------------------------------------------------------+
| 删除目录函数
+---------------------------------------------------------------------+
| delfile(路径)
+---------------------------------------------------------------------+
| 创建/修改 时间: -- / --
+---------------------------------------------------------------------+
| 作者： Lee.MaRS
+---------------------------------------------------------------------+
*/

function delfile($path)
{
$handle = opendir($path);
@chdir($path);

while(($file = readdir($handle)) != "")
{
if (($file == ".") OR ($file == "..")) continue;
if (is_dir($file)) delfile($file);
else @unlink($file);
}

closedir($handle);
@chdir("..");
@rmdir($path);

}

[ Last edited by walker on 2003-7-18 at 09:07 AM ]

欢迎来到 <<风之谷>>FTP资源共享站
2003-7-18 09:03
<< [1] [2] [3] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.035084 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - Arvan的函数(类)库。[另外希望有高手加入自己的函数] - powered by Discuz!

落伍者论坛 » 网站建设专栏 » Arvan的函数(类)库。[另外希望有高手加入自己的函数]

<< [1] [2] [3] >>
作者:
标题: Arvan的函数(类)库。[另外希望有高手加入自己的函数] 上一主题 | 下一主题
Arvan
落伍者

积分 1380
发贴 1202
注册 2002-10-28

Quote:
Originally posted by walker at 2003-7-18 09:03 AM:
[code]
/*
+---------------------------------------------------------------------+
| 删除目录函数
+---------------------------------------------------------------------+
| delfile(路径)
+----- ...

没有检查文件属性？

我坐在楼顶的边沿上抽烟，一根接一
根，好像要一直抽到永远，就像那深邃的
天空，没有尽头......
2003-7-18 19:26
walker
落伍者

积分 291
发贴 318
注册 2002-2-14
o 是波

欢迎来到 <<风之谷>>FTP资源共享站
2003-7-18 19:38
梦
杜鹃滴血

积分 2948
发贴 2698
注册 2002-5-6
来自 古墓苍狼
（转载的于PHPX一位网友 [image] 。经本人测试。完全可以用。且效果比较好。）

Code: [Copy to clipboard]
<?

$FILENAME = "ResizeImage/".time()."";
// image height
$RESIZEWIDTH = 80;
// image width
$RESIZEHEIGHT = 100;

function ResizeImage( $im, $maxwidth, $maxheight, $name )
{
$width = imagesx( $im );
$height = imagesy( $im );
if ( ( $maxwidth && $width > $maxwidth ) || ( $maxheight && $height > $maxheight ) )
{
if ( $maxwidth && $width > $maxwidth )
{
$widthratio = $maxwidth / $width;
$RESIZEWIDTH = true;
}
if ( $maxheight && $height > $maxheight )
{
$heightratio = $maxheight / $height;
$RESIZEHEIGHT = true;
}
if ( $RESIZEWIDTH && $RESIZEHEIGHT )
{
if ( $widthratio < $heightratio )
{
$ratio = $widthratio;
}
else
{
$ratio = $heightratio;
}
} elseif ( $RESIZEWIDTH )
{
$ratio = $widthratio;
} elseif ( $RESIZEHEIGHT )
{
$ratio = $heightratio;
}
$newwidth = $width * $ratio;
$newheight = $height * $ratio;
if ( function_exists( "imagecopyresampled" ) )
{
$newim = imagecreatetruecolor( $newwidth, $newheight );
imagecopyresampled( $newim, $im, 0, 0, 0, 0, $newwidth, $newheight, $width, $height );
}
else
{
$newim = imagecreate( $newwidth, $newheight );
imagecopyresized( $newim, $im, 0, 0, 0, 0, $newwidth, $newheight, $width, $height );
}
ImageJpeg ( $newim, $name . ".jpg" );
ImageDestroy ( $newim );
}
else
{
ImageJpeg ( $im, $name . ".jpg" );
}
}

if ( $_FILES['image']['size'] )
{
if ( $_FILES['image']['type'] == "image/pjpeg" )
{
$im = imagecreatefromjpeg( $_FILES['image']['tmp_name'] );
} elseif ( $_FILES['image']['type'] == "image/x-png" )
{
$im = imagecreatefrompng( $_FILES['image']['tmp_name'] );
} elseif ( $_FILES['image']['type'] == "image/gif" )
{
$im = imagecreatefromgif( $_FILES['image']['tmp_name'] );
}
if ( $im )
{
if ( file_exists( "$FILENAME.jpg" ) )
{
unlink( "$FILENAME.jpg" );
}
ResizeImage( $im, $RESIZEWIDTH, $RESIZEHEIGHT, $FILENAME );
ImageDestroy ( $im );
}
}

?>

<img src="<? echo( $FILENAME . ".jpg?reload=" . rand( 0, 999999 ) );
?>"><br><br>

<form enctype="multipart/form-data" method="post">
<br>
<input type="file" name="image" size="50" value="browse"><p>
<input type="submit" value="upload">
</form>

</body>
</html>

www.wps2000.net重新开放
http://www.wps2000.net/
PHP论坛：http://forum.wps2000.net/Forum.php?ForumID=28
2003-7-19 09:17
锋芒未露
落伍者

积分 591
发贴 555
注册 2002-5-6
来自 CHINA
我的程序中必定有的函数

Code: [Copy to clipboard]
//===============================
// 获取表单值或uri
//===============================
function get_param($param_name)
{
$param_value = "";
if(isset($_POST[$param_name]))
$param_value = $_POST[$param_name];
else if(isset($_GET[$param_name]))
$param_value = $_GET[$param_name];

return $param_value;
}
//===============================
//gzip压缩输出
//===============================
function gzipOutput($text,$level=1){
$returntext=$text;
$encoding = false;
if (function_exists("crc32") and function_exists("gzcompress") ){
if (strpos(" ".$_SERVER['HTTP_ACCEPT_ENCODING'],"x-gzip")) {
$encoding = "x-gzip";
}
if (strpos(" ".$_SERVER['HTTP_ACCEPT_ENCODING'],"gzip")) {
$encoding = "gzip";
}
if ($encoding) {
header("Content-Encoding: $encoding");
$size = strlen($text);
$crc = crc32($text);
$returntext = "\x1f\x8b\x08\x00\x00\x00\x00\x00";
$returntext .= substr(gzcompress($text,$level),0,-4);
$returntext .= pack("V",$crc);
$returntext .= pack("V",$size);
}
}
return $returntext;
}

//==================================
// 获取用户IP
//==================================
function GetIP() {
$ip = getenv("REMOTE_ADDR");
$ip1 = getenv("HTTP_X_FORWARDED_FOR");
$ip2 = getenv("HTTP_CLIENT_IP");
($ip1) ? $ip = $ip1 : null ;
($ip2) ? $ip = $ip2 : null ;
return $ip;
}
//===================================
//特殊字符转换为html
//===================================
function toHtml($strValue)
{
return htmlspecialchars($strValue);
}
//===================================
//获取mysql版本
//===================================
function getMysqlV(){
return get_db_value("SELECT VERSION() as version");
}
//========
function doublesubstr($str,$start,$len)//字符位置从0开始
{
$strlen=$start+$len;
for($i=0;$i<$strlen;$i++)
{
if(ord(substr($str,$i,1))>0xa0)
{
$tmpstr.=substr($str,$i,2);
$i++;
}
else

$tmpstr.=substr($str,$i,1);

}
return $tmpstr;

}
//-----------------------------------
function is_number($string_value)
{
if(is_numeric($string_value) || !strlen($string_value))
return true;
else
return false;
}

2003-7-21 18:14
梦
杜鹃滴血

积分 2948
发贴 2698
注册 2002-5-6
来自 古墓苍狼
乱贴。不过是自己写的，不懂就算了。我的程序没注释的

Code: [Copy to clipboard]
function InsertOption($name,$lastID)
{
global $DB,$table_prefix;

$option_TABLE = $table_prefix.$name.'Option';
$optionID = $name.'OptionID';
$optionList_TABLE = $table_prefix.$name.'OptionList';
$nameID = $name.'ID';

$SQL = "SELECT $optionID FROM $option_TABLE ";
$Result = $DB->query($SQL);

while ( $Row = $DB->queryArray($Result) )
{
$option = 'option_'.$Row[$optionID];
$SQL = " INSERT INTO $optionList_TABLE SET $nameID='$lastID',$optionID='$Row[$optionID]',value='".$_POST[$option]."',createDate='".time()."' ";
$DB->query($SQL);
}
}

function EditOption($name,$editID)
{
global $DB,$table_prefix;

$option_TABLE = $table_prefix.$name.'Option';
$optionID = $name.'OptionID';
$optionList_TABLE = $table_prefix.$name.'OptionList';
$nameID = $name.'ID';

$SQL = "SELECT $optionID FROM $option_TABLE ";
$Result = $DB->query($SQL);

while ( $Row = $DB->queryArray($Result) )
{
$option = 'option_'.$Row[$optionID];
$SQL = " UPDATE $optionList_TABLE SET value='".$_POST[$option]."',createDate='".time()."' WHERE $nameID='$editID' AND $optionID='$Row[$optionID]' ";
$DB->query($SQL);
}
}

function DisplayAddOption($name)
{
global $DB,$table_prefix,$TEMPLATE;

$option_TABLE = $table_prefix.$name.'Option';
$optionID = $name.'OptionID';

$SQL = "SELECT * FROM $option_TABLE ";
$SQL .= " ORDER BY orderByID ASC,$optionID DESC ";
$Result = $DB->query($SQL);
$optionList = '';
$TEMPLATE->setFile("OptionTextFile","OptionText.html");
$TEMPLATE->setFile("OptionTextareaFile","OptionTextarea.html");

while ( $Row = $DB->queryArray($Result) )
{
$option_name = 'option_'.$Row[$optionID];
switch ($Row['types'])
{
case 'text':
case 'password':
$TEMPLATE->replace(array(
"option_field_name" => $Row['optionFieldName'],
"option_name" => $option_name,
"option_type" => $Row['types'],
"option_size" => $Row['length']
));
$OptionText = $TEMPLATE->parse("OptionText","OptionTextFile");
$TEMPLATE->replace('option_list',$OptionText,true);
break;
case 'textarea':
$TEMPLATE->replace(array(
"option_field_name" => $Row['optionFieldName'],
"option_name" => $option_name,
"option_cols" => $Row['length'],
"option_rows" => $Row['rows']
));
$OptionTextarea = $TEMPLATE->parse("OptionTextarea","OptionTextareaFile");
$TEMPLATE->replace('option_list',$OptionTextarea,true);
break;
}
}
}

function DisplayEditOption($name,$tableNameID)
{
global $DB,$table_prefix,$TEMPLATE;

$option_TABLE = $table_prefix.$name.'Option';
$optionList_TABLE = $table_prefix.$name.'OptionList';
$optionID = $name.'OptionID';
$nameID = $name.'ID';

$SQL = "SELECT * FROM $option_TABLE ";
$SQL .= " ORDER BY orderByID ASC,$optionID DESC ";
$Result = $DB->query($SQL);
$optionList = '';
$TEMPLATE->setFile("OptionTextFile","OptionTextEdit.html");
$TEMPLATE->setFile("OptionTextareaFile","OptionTextareaEdit.html");

while ( $Row = $DB->queryArray($Result) )
{
$SQL = "SELECT value,$optionID,$nameID FROM $optionList_TABLE WHERE $optionID='$Row[$optionID]' AND $nameID='$tableNameID' ";
$listRow = $DB->queryFirstRow($SQL);

$option_name = 'option_'.$Row[$optionID];
switch ($Row['types'])
{
case 'text':
case 'password':
$TEMPLATE->replace(array(
"option_field_name" => $Row['optionFieldName'],
"option_name" => $option_name,
"option_type" => $Row['types'],
"option_size" => $Row['length'],
"option_value" => $listRow[value]
));

$OptionText = $TEMPLATE->parse("OptionText","OptionTextFile");
$TEMPLATE->replace('option_list',$OptionText,true);
break;
case 'textarea':
$TEMPLATE->replace(array(
"option_field_name" => $Row['optionFieldName'],
"option_name" => $option_name,
"option_cols" => $Row['length'],
"option_rows" => $Row['rows'],
"option_value" => $listRow[value]
));

$OptionTextarea = $TEMPLATE->parse("OptionTextarea","OptionTextareaFile");
$TEMPLATE->replace('option_list',$OptionTextarea,true);
break;
}
}
}

function DisplayViewOption($name,$tableNameID)
{
global $DB,$table_prefix,$TEMPLATE;

$option_TABLE = $table_prefix.$name.'Option';
$optionList_TABLE = $table_prefix.$name.'OptionList';
$optionID = $name.'OptionID';
$nameID = $name.'ID';

$SQL = "SELECT * FROM $option_TABLE ";
$SQL .= " ORDER BY orderByID ASC,$optionID DESC ";
$Result = $DB->query($SQL);
$optionList = '';
$TEMPLATE->setFile("OptionTextFile","OptionTextView.html");
$TEMPLATE->setFile("OptionTextareaFile","OptionTextareaView.html");

while ( $Row = $DB->queryArray($Result) )
{
$SQL = "SELECT value,$optionID,$nameID FROM $optionList_TABLE WHERE $optionID='$Row[$optionID]' AND $nameID='$tableNameID' ";
$listRow = $DB->queryFirstRow($SQL);

$option_name = 'option_'.$Row[$optionID];
$TEMPLATE->replace(array(
"option_field_name" => $Row['optionFieldName'],
"option_value" => $listRow[value]
));

$OptionText = $TEMPLATE->parse("OptionText","OptionTextFile");
$TEMPLATE->replace('option_list',$OptionText,true);

}
}

function ChanageOrder($name,$Compositor,$ID,$OrderID)
{
global $_GET,$DB,$table_prefix;

$nameID = $name."ID";
$TABLE = $table_prefix.$name;

if ($Compositor=='DESC')
{
$SQL = " SELECT $nameID,orderByID FROM $table_prefix$name WHERE orderByID>$OrderID ORDER BY orderByID ASC LIMIT 1 ";
}
else
{
$SQL = " SELECT $nameID,orderByID FROM $table_prefix$name WHERE orderByID<$OrderID ORDER BY orderByID DESC LIMIT 1 ";
}

if ( $Row = $DB->queryFirstRow($SQL) )
{

$SQL = "UPDATE $TABLE SET orderByID='$Row[orderByID]' WHERE $nameID='$ID' ";
$DB->query($SQL);
$SQL = "UPDATE $TABLE SET orderByID='$OrderID' WHERE $nameID='$Row[$nameID]' ";
$DB->query($SQL);
}

}

www.wps2000.net重新开放
http://www.wps2000.net/
PHP论坛：http://forum.wps2000.net/Forum.php?ForumID=28
2003-7-21 18:53
<< [1] [2] [3] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.030467 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网络技术专版 - 图解：PHP 在Windows 2003 Enterprise Server 、IIS6.0 下的安装 - powered by Discuz!

落伍者论坛 » 网络技术专版 » 图解：PHP 在Windows 2003 Enterprise Server 、IIS6.0 下的安装

作者:
标题: 图解：PHP 在Windows 2003 Enterprise Server 、IIS6.0 下的安装 上一主题 | 下一主题
小林
o○万帖俱乐部老八^_^ ○ o

积分 11252
发贴 11181
注册 2002-10-29
来自 『新都人.COM』
图解：PHP 在Windows 2003 Enterprise Server 、IIS6.0 下的安装

有朋友反映在win2000中IIS和PHP工作好好的， 在win2003 enterprise server中，按照2000下的做法PHP不工作。其实在Windows2003下安装也是很简单的，只不过Win2003在IIS6.0的安全方面下了些功夫，所以安装起来要稍费点功夫了。
步骤1，先去www.php.net下在一个安装程序，我是装的是：php-4.2.3-installer.exe，你也可以去找最新的版本，在安装php-4.2.3-installer.exe之前保证你的IIS6.0启动了，并能够访问。
图1：安装好以后，在默认网站-->应用程序配置

步骤二：点击 web服务扩展 -->新建web服务扩展.

步骤三： 扩展名-->php,然后添加

步骤四：找到php.exe的路径添加上去。

步骤五： 确定就可以了！

步骤六： 选择php的服务扩展，然后点击允许。

步骤七： 好了，在IE里面来phpinfo();就可以完成了！

万维主机-Sunking

『统一行动，开始删贴！』
2003-6-21 21:29
looboo
落伍者

积分 575
发贴 548
注册 2002-8-14
不错

高速论坛空间170元/年，送国际域名+专业邮局
支持MS SQL2000大型数据库的论坛空间只要250元/年
详细介绍：http://www.yydns.cn/host_zl-1.htm
QQ:1630507 可开正规发票
2003-6-22 08:38
caibirdvv
落伍者

积分 242
发贴 251
注册 2002-6-21
来自 秦皇岛
能找一个在XP下安装的不？？？
2003-6-22 09:06
L.G.
专栏版主

积分 1420
发贴 1406
注册 2003-3-5
来自 山东·济南
+精华收藏！

方便朋友查找！

网络里呆久了，没什么意思；
出去？也没意思！
于是，我要去入伍，彻底抛弃这些，你们下次见了我，敬礼吧！
2003-6-22 15:12

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.091080 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - win2000+apache+php+mysql+mod_perl+perl+mod_ssl+openssl+ZendOptimizer安装攻略 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » win2000+apache+php+mysql+mod_perl+perl+mod_ssl+openssl+ZendOptimizer安装攻略

<< [1] [2] [3] >>
作者:
标题: win2000+apache+php+mysql+mod_perl+perl+mod_ssl+openssl+ZendOptimizer安装攻略 上一主题 | 下一主题
xdiy
落伍者

积分 1006
发贴 1013
注册 2002-4-11
win2000+apache+php+mysql+mod_perl+perl+mod_ssl+openssl+ZendOptimizer安装攻略

一、前期准备情况 Apache2(Win32) 完全模块化安装perl,php,ssl

1。一个安装好的WIN2000服务器，注意：如果你的机器上已经安装了IIS，将IIS里的所有web站点停掉或端口改成别的先。

2。下载软件

APACHE：版本：2.0.44 地址：http://apache.linuxforum.net/dist/httpd/binaries/win32/apache_2.0.44-win32-x86-no_ssl.exe

perl： 版本： 4.3.1地址：http://www.chinaz.com/download/download.asp?LINK=149129994325800&Url=1

PHP： 版本： 4.3.1地址：http://www.php.net/get/php-4.3.1-Win32.zip/from/cn.php.net/mirror

MYSQL： 版本：4.0.12 地址：http://mysql.linuxforum.net/Downloads/MySQL-4.0/mysql-4.0.12-win.zip
ZendOptimizer 版本：地址：http://2.0.3-windows-i386.exe/

还有几个小东西,很重要,后面的安装会用到(不会全用到,有些文件是编译好的，可以直接用)
下载地址1: http://www.xdiy.net/soft/serv.rar
下载地址1: http://www.techxy.com/xdiy/serv.zip
包子里面是:mod_perl 1.9/ mod_ssl 2.0.43/ OpenSSL 0.9.6h/ mod_jk/ ApacheModuleGzip.dll
gd 2.0.9/ gdpm/ perldiver 1.1/ 中文php.ini/editplus /php_gd_gif.dll 等

二、安装开始

1。APACHE安装

1.1：运行apache_2.0.44-win32-x86-no_ssl.msi，

假设我的安装的默认路径是 X:\ ,这样就安装在x盘下的APACHE2的路径下，同时默认域为domain.com。

1.2：（作一个虚拟主机，此步可以不做）

编辑X:\apache2\conf\httpd.conf

找到 #NameVirtualHost *

修改为 NameVirtualHost 192.168.0.1 #注意这个IP为你自己主机设的IP

找到 ServerName domain.com 修改为 #ServerName domain.com

找到ServerAdmin * (*是你安装apache时所填写的邮箱地址)修改为 #ServerAdmin

接下来添加以下语句:#……的是我的注释，不用加，看一下就可以了

<VirtualHost 192.168.0.1>
ServerAdmin webmaster@domain.com
#主机管理员(联系人)的邮箱地址
ServerName domain.com
#主机名(主机头名)
ServerAlias domain.com www1.domain.com
#主机名(同样可以生效的主机头名)
DocumentRoot X:/VirtualHost/domain.com/www.domain/wwwroot
#该虚拟主机的的www根目录.
ErrorLog X:/VirtualHost/domain.com/www.domain/logs/www.domain-error_log
#错误日志文档,也可以是../logs/www.domain-error_log
CustomLog X:/VirtualHost/domain.com/www.domain/logs/www.domain-access_log common
ScriptAlias /cgi-bin /cgi-bin
#指定perl脚本运行目录,当然,不指定的话整个目录全部可以运行
ScriptAlias /php4/ "/php-bin"
#指定php脚本运行目录,当然,不指定的话整个目录全部可以运行
ErrorDocument 400 /400.html
#自定义错误文件,要注意的是错误文件一定要放在根目录下,
#或者单另作一个虚拟主机,比方errors.domain.com,将错误文件放在其根目录下.
#则此时错误文档应为"ErrorDocument 400 http://errors.domain.com/400.html"
</VirtualHost>

***如果你选择设置虚拟主机的话,请将浏览器设置INTERNET选项-连接-局域网设置
选择 “使用代理服务器”，地址：192.168.0.16 (写你主机的IP,本机调试127.0.0.1) 端口：80
如果局域网中只有你一台机子开机中,应改添127.0.0.1同本机调试一样

1.3：将文件名 X:\apache2\htdocs\index.html.en 改为c:\apache\htdocs\index.html

1.4：访问http://localhost/或http://domain.com./能看到页面就OK!

2。安装MYSQL

2.1: 解压 mysql-4.0.12-win.zip 到目录 X:\MYSQL

2.2: 进入D:\MYSQL 运行SETUP.EXE 一路回车,默认安装到 X:\MYSQL

3。安装PHP

3.1: 解压php-4.3.1-Win32.zip 到目录 X:\PHP

3.2: 进入X:\PHP,开始配置PHP

3.3: 将文件名 php.ini-dist 改为 php.ini
(或者使用上面的那个serv.rar包中的那个PHP.INI文件,可以不用修改直接使用)

3.4: 打开php.ini,
找到 ;extension=php_gd.dll,将前面的分号去掉
找到 ;extension=php_gd2.dll,将前面的分号去掉
相同位置添加 extension=php_gd_gif.dll,这个文件上面我提供的serv.rar里面有

3.5: 拷贝 php.ini 和 php4ts.dll 到WIN2000的系统安装目录下的system32和system目录下

3.6: 打开APACHE的配置文件httpd.conf文件,添加如下语句(位置随便):

LoadModule php4_module X:/php/sapi/php4apache.dll

AddType application/x-httpd-php .php4

ScriptAlias /php4/ "C:/php/"

Action application/x-httpd-php4 "/php4/php.exe"

添加由PHP解析的扩展名:
AddType application/x-httpd-php4 .php .php3 .php4 .php2

#mod_perl
LoadFile "c:/usr/bin/perl58.dll"
LoadModule perl_module modules/mod_perl.so

#mod_ssl
LoadModule ssl_module modules/mod_ssl.so

LoadModule gzip_module modules/ApacheModuleGzip.dll
注:ApacheModuleGzip.dll(即:mod_gzip),在包包里面有.可以压缩静态的web页面。

<<记得把把serv.rar里面的mod_ssl.so,mod_perl.so,ApacheModuleGzip.dll放到X:\apache2\modules目录里面>>

4。安装ZendOptimizer
4.1: 安装ZendOptimizer-2[1].1.0a-Windows-i386.exe 到目录 X:\zend
剩下的步骤呵呵,自己选好了

5。安装PERL

5.1: 安装ActivePerl-5.8.0.804-MSWin32-x86.msi 到目录 C:\usr,
注意你的windows Installer 服务应该打过windows service pack的补丁

6.其它设置

6.1: 找到DirectoryIndex,添加以下语句
DirectoryIndex index.html index.html.var index.htm index.php index.shtml
DirectoryIndex index.php3 index.php4 index.cgi index.pl index.html

如果还想增加SSI，需把下面两行前面的#号去掉。
AddType text/html .shtml
AddHandler server-parsed .shtml

6.2: 查找出所有的"Options FollowSymLinks"，全部改为"Options ALL",注意大小写.不用加""号。
查找出所有的"AllowOverride None"，全部改为"AllowOverride ALL" ,注意大小写.不用加""号。

6.3: 找出#ScriptAlias /cgi-bin/ "X:/Apache2/cgi-bin/"，把前面的#号去掉

6.4: 找到 AddHandler cgi-script .cgi后面加上.pl ,即
AddHandler cgi-script .cgi .pl

6.5: 重新启动Apache HTTP Server

7: 测试

7.1: 编写测试文件 env.php (拷贝到目录 可以执行的php的目录下)

文件内容: （其实就一行)

<? phpinfo(); ?>

访问: http://localhost/info.php 或 http://domain.com/info.php

如果看到PHP的欢迎测试页面,说明安装成功!

编写测试文件 env.cgi (拷贝到目录 可以执行的cgi的目录下)

文件内容:

#!/usr/bin/perl
print "Content-type:text/html\n\n";
print "K O 了";
exit;

访问: http://localhost/cgi-bin/env.cgi 或 http://cgi-bin/env.cgi

如果看到cgi的测试页面,说明安装成功!

到目前为止,你的系统已经配置完成了! 在看看我提供的serv.rar里面的东东还有剩下没用的没?
如果有的话放到合适的位置

你已经配置好了 win2000+apache+php+mysql+mod_perl+perl+mod_ssl+ZendOptimizer

再有就是mod_ssl和openssl在serv.rar那个包里面是已经编译过的，可以直接使用
如果真要用到这两个东东，应该对ca了解一些才行，
相关网站：http://www.wise-tech.com.cn/bbs/forum/openssl/Default.asp
zdnet

Xdiy写于落伍者 2003/03/30 my QQ：82557379

[ Last edited by vidar on 2003-3-30 at 03:17 PM ]
2003-3-30 13:13
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20
可以加精华了

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-3-30 13:14
v8088
落伍者

积分 3334
发贴 3353
注册 2002-10-1
厉害！！
2003-3-30 13:15
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20
把表情符号去掉

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-3-30 13:16
仙鹤
落伍者

积分 982
发贴 1168
注册 2002-5-22
来自 fiyour.co.sr
厉害哦

http://fiyour.co.sr
http://fiyour.qqvip.com/bbs
http://fiyour.qqvip.com/music
fiyour@vip.sina.com
[img]http://fiyour.1816.net/images/write03.gif[/img]
2003-3-30 13:17
shrzfm
落伍者

积分 1751
发贴 1737
注册 2001-7-21
支持原创~

近7000多教程、资源
http://www.371e.com/ 科瑞科技网络课堂
2003-3-30 13:17
ltj1231
落伍者

积分 6051
发贴 5640
注册 2002-12-27
来自 宁波
不错

--------------------------------------------------------------------------
出售2对7无情侣
2003-3-30 13:21
xdiy
落伍者

积分 1006
发贴 1013
注册 2002-4-11

Quote:
Originally posted by 西瓜 at 2003-3-30 01:16 PM:
把表情符号去掉

我也不想加亚，谁知道怎么变成那个样子了
2003-3-30 13:22
yake666
落伍者

积分 601
发贴 607
注册 2002-5-13
来自 http://www.sh63.cn
http://www.sh163.cn/
NOW收购这文章
：）T

上海163热线国际域名70元
.cn域名220元 服务器托管3800年www.sh163.cn
2003-3-30 13:23
gaochong
落伍者

积分 1662
发贴 1675
注册 2002-11-20
来自 HTUM.COM
不错,可是怎么才能支持asp呢?
2003-3-30 13:23
敢败吓疯
落伍者

积分 6595
发贴 6398
注册 2001-5-30
没有ASP的？

我的主页：飞牌精品软件 http://www.ayxz.com/
大量正版软件下载，注册机，破解器，电脑书籍下载，游戏下载等。
2003-3-30 13:24
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20

Quote:
Originally posted by xdiy at 2003-3-30 01:22 PM:
我也不想加亚，谁知道怎么变成那个样子了

发的时候可以选择的

你编辑一下

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-3-30 13:24
xdiy
落伍者

积分 1006
发贴 1013
注册 2002-4-11

Quote:
Originally posted by gaochong at 2003-3-30 01:23 PM:
不错,可是怎么才能支持asp呢?

asp？
当然可以，两种方法
1，安装iasp，可以支持，再安装一个给apache用的odbc就可以了（这个方法我已经安装成攻了，至于在那里下载，我就不知道了，软件是我在星晴刻的碟上找到的）
2。昨天在网上看到一些介绍mod_asp的文章，但是支持apache的版本太低，似乎没办法和a2。0结合使用，落伍不是有人已经调试成功了吗？
2003-3-30 13:31
gaochong
落伍者

积分 1662
发贴 1675
注册 2002-11-20
来自 HTUM.COM
"再安装一个给apache用的odbc就可以了"

我装了iasp,但是只能保证asp谈针正常显示,而当运行login.asp时,总是出现"禁止从站点外提交数据",请问这是什么原因,是不是没有apache的odbc,该怎么办才好?
2003-3-30 13:47
xdiy
落伍者

积分 1006
发贴 1013
注册 2002-4-11
找地方下载亚，有这个东西的
2003-3-30 13:54
<< [1] [2] [3] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.036925 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - W2K+PHP+MYSQL+TOMCAT+JSP完全整合安装手册 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » W2K+PHP+MYSQL+TOMCAT+JSP完全整合安装手册

作者:
标题: W2K+PHP+MYSQL+TOMCAT+JSP完全整合安装手册 上一主题 | 下一主题
axin
落伍者

积分 3198
发贴 3074
注册 2002-8-13
这篇文章我找了他半个月，绝对要看，加入精华

WIN2000 + PHP + MYSQL + TOMCAT + JSP 完全整合安装手册

--------------------------------------------------------------------------------

作者: Apollo 2002-7-18 0:20:57

一、前期准备情况

1。一个安装好的WIN2000服务器，注意：如果预装了IIS，请先将IIS服务停掉或禁用。

2。下栽软件

APACHE：版本：1.3.22 地址：http://www.5line.net/web_soft/apache_1.3.22-win32-x86.msi

JDK：版本： 1.3 地址：http://www.5line.net/web_soft/j2sdk1_3_0-win.exe

PHP： 版本： 4.0.4 地址：http://www.5line.net/web_soft/php4.0.4pl1-win32.zip

MYSQL： 版本：3.23.32 地址：http://www.5line.net/web_soft/mysql-3.23.32-win.zip

TOMCAT：版本： 4.0.4 地址： http://www.5line.net/web_soft/jakarta-tomcat-4.0.4.exe

Mod_jk：这是Jakarta组织开发的使Apache支持Tomcat的插件，比ApacheJserv更强大，因为ApacheJserv

只能用在Apache上，而不能用在别的WebServer 上，Mod_jk可以和很多服务器搭配起来用。

下载地址：http://jakarta.apache.org/builds/jakarta-tomcat/release/v3.3/bin/win32/i386/

（如果在提供的网址内找不到相应的软件，请在各大网上软件库找，一般都有！或发邮件至info@5line.net）

3。准备好足够的干粮和水，作好反复安装和重新启动的心理准备，但只要细心按照要求去做，一次成功不是什么

难事！

4。做一口深呼吸，别在想MM了！开始安装！

二、安装开始

1。APACHE安装

第一步：运行apache_1.3.22-win32-x86.msi，一路点确定和接受就行，基本比较傻瓜，为了方便期间和符合我

的习惯我安装的默认路径是 c:\ ,这样就安装在C盘下的APACHE的路径下，同时默认域为root.dev。

第二步：（我在这里作了一个虚拟主机，此步可以不做，根据你自己的需求）

编辑c:\apache\conf\httpd.conf

找到 #NameVirtualHost *

修改为 NameVirtualHost 192.168.0.16 #注意这个IP为你自己主机设的IP

找到 ServerName root.dev

修改为 #ServerName root.dev

添加

<VirtualHost 192.168.0.16>

ServerAdmin root@localhost

ServerName root.dev

DocumentRoot c:/apache/htdocs

ErrorLog c:/apache/logs/error_log

TransferLog c:/apache/logs/access_log

ScriptAlias /cgi-bin c:/apache/cgi-bin

</VirtualHost>

第三步：将文件名 c:\apache\htdocs\index.html.en 改为c:\apache\htdocs\index.html

第四步：重新启动，访问 http://root.dev/ 浏览正常，显示APACHE欢迎页

------------小小的成功！可以喝口水了！----------------------------

2。MYSQL安装

第一步: 解压 mysql-3.23.32-win.zip 到目录 D:\MYSQL

第二步: 进入D:\MYSQL 运行SETUP.EXE 一路回车,默认安装到 C:\MYSQL

------------这一步应该没有什么问题!-------------------------------

3。PHP安装

第一步: 解压 php4.0.4pl1-win32.zip 到目录 D:\PHP

第二步: 将D:\PHP下拷贝到C盘根目录下

第三步: 进入C:\PHP ,开始配置PHP

将文件名 php.ini-dist 改为 php.ini

同时拷贝 php.ini 和 php4ts.dll 到WIN2000的系统安装目录下

的 system32和system目录下 (很重要,别忘了)

再次修改APACHE的配置文件httpd.conf (忘了吧!在c:\apache\conf\httpd.conf)

添加:

LoadModule php4_module c:/php/sapi/php4apache.dll

AddType application/x-httpd-php .php4

ScriptAlias /php4/ "C:/php/"

Action application/x-httpd-php4 "/php4/php.exe"

AddType application/x-httpd-php4 .php

第四步: 重新启动系统

第五步: 测试

编写测试文件 info.php (拷贝到目录 c:\apache\htdocs\ 下)

文件内容 [image] 就一行)

<? phpinfo(); ?>

访问: http://localhost/info.php 或 http://root.dev/info.php

如果看到PHP的欢迎测试页面,说明安装成功!

到目前为止,你的系统已经可以运行PHP程序了!

你已经配置好了 win2000+apache+php+mysql

----------------成功在望!吃些干粮,想5分钟MM,上趟厕所,或者骚扰一下隔壁的大哥---------

---如果你能确定2件事就可以往下进行了:

1.你的智商确实比中国足协的那堆废物高

2.真的很想进入JSP的世界遨游

4。JDK的安装

第一步：直接运行 j2sdk1_3_0-win.exe，一路回车安装，我这里默认的安装路径为d:\\jdk1.3

第二步：配置环境变量

在我的电脑上点击鼠标右键-属性-点选高级-点选环境变量

弹出环境变量对话框，新建以下变量名和值：

-------------------------------------

变量名：path

变量值：d:\jdk1.3\bin

变量名：JAVA_HOME

变量值：d:\jdk1.3

变量名：CLASSPATH

变量值：.\;d:\jdk1.3\lib\dt.jar;d:\jdk1.3\lib\tools.jar;

第三步：重新启动计算机使配置的环境变量生效

5。TOMCAT安装

第一步：直接运行安装jakarta-tomcat-4.0.4.exe，我这里默认的安装路径是c:\Apache Tomcat 4.0

这时如果单独启动TOMCAT（到Tomca目录下运行startup.bat启动Tomcat或在菜单栏运行start

tomcat），就已经可以运行JSP文件了,但是我们还没有将APACHE和TOMCAT集成在一起，因为

虽然TOMCAT有内置的一个APACHE的HTTP服务，但是他仅仅对JSP程序体现出比较好的执行效率

和性能，对于静态页面的处理速度远不如APACHE，所以为了一个完美的WEB系统，我们要将

APACHE和TOMCAT集成在一起！

（下面就是集成他们的具体配置步骤，请注意仔细认真，我搞了1天才终于搞定！）

第二步：先配置APACHE

打开c:\apache\conf\httpd.conf

添加以下语句：

#------------------------------------------

LoadModule jk_module libexec/mod_jk.dll

AddModule mod_jk.c

JkWorkersFile "c:\Apache Tomcat 4.0\conf\worker.properties"

JkLogFile logs/mod_jk.log

JkLogLevel info

JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "

JkMount /*.jsp ajp13

JkMount /servlet/* ajp13

#-----------------------------------------------------

注意：以上语句的基本意思是：

第一、二句：指定APACHE和TOMCAT连接插件的位置和名称

第三句：指出mod_jk工作所需要的工作文件的位置

第七、八句：是将所有和jsp和servlet的请求通过Apj13的协议送给Tomcat，让Tomcat来处理

第三步：将下载的mod_jk.dllcopy到安装Apache目录下的libexec下就可以了

第四步：TOMCAT配置

首先是在c:\Apache Tomcat4.0\conf目录下建一个worker.properties

文件内容如下：

#----------------------------------------------------------

# $Header: /home/cvs/jakarta-tomcat/src/etc/Attic/workers.properties,v 1.3.2.2 2000/10/16 01:59:22 larryi Exp $

# $Revision: 1.3.2.2 $

# $Date: 2000/10/16 01:59:22 $

#

#

# workers.properties -

#

# This file provides jk derived plugins with with the needed information to

# connect to the different tomcat workers.

#

# As a general note, the characters $( and ) are used internally to define

# macros. Do not use them in your own configuration!!!

#

# Whenever you see a set of lines such as:

# x=value

# y=$(x)something

#

# the final value for y will be valuesomething

#

# Normaly all you will need to modify is the first properties, i.e.

# workers.tomcat_home, workers.java_home and ps. Most of the configuration

# is derived from these.

#

# When you are done updating workers.tomcat_home, workers.java_home and ps

# you should have 3 workers configured:

#

# - An ajp12 worker that connects to localhost:8007

# - An ajp13 worker that connects to localhost:8009

# - A jni inprocess worker.

# - A load balancer worker

#

# However by default the plugins will only use the ajp12 worker. To have

# the plugins use other workers you should modify the worker.list property.

#

#

#

# workers.tomcat_home should point to the location where you

# installed tomcat. This is where you have your conf, webapps and lib

# directories.

#

workers.tomcat_home=c:\Apache Tomcat 4.0

#

# workers.java_home should point to your Java installation. Normally

# you should have a bin and lib directories beneath it.

#

workers.java_home=d:\jdk1.3

#

# You should configure your environment slash... ps= on NT and / on UNIX

# and maybe something different elsewhere.

#

ps=\

# ps=/

#

#------ ADVANCED MODE ------------------------------------------------

#---------------------------------------------------------------------

#

#

#------ DEFAULT worket list ------------------------------------------

#---------------------------------------------------------------------

#

#

# The workers that your plugins should create and work with

#

worker.list=ajp12, ajp13

#

#------ DEFAULT ajp12 WORKER DEFINITION ------------------------------

#---------------------------------------------------------------------

#

#

# Defining a worker named ajp12 and of type ajp12

# Note that the name and the type do not have to match.

#

worker.ajp12.port=8007

worker.ajp12.host=localhost

worker.ajp12.type=ajp12

#

# Specifies the load balance factor when used with

# a load balancing worker.

# Note:

# ----> lbfactor must be > 0

# ----> Low lbfactor means less work done by the worker.

worker.ajp12.lbfactor=1

#

#------ DEFAULT ajp13 WORKER DEFINITION ------------------------------

#---------------------------------------------------------------------

#

#

# Defining a worker named ajp13 and of type ajp13

# Note that the name and the type do not have to match.

#

worker.ajp13.port=8009

worker.ajp13.host=localhost

worker.ajp13.type=ajp13

#

# Specifies the load balance factor when used with

# a load balancing worker.

# Note:

# ----> lbfactor must be > 0

# ----> Low lbfactor means less work done by the worker.

worker.ajp13.lbfactor=1

#

# Specify the size of the open connection cache.

#worker.ajp13.cachesize

#

#------ DEFAULT LOAD BALANCER WORKER DEFINITION ----------------------

#---------------------------------------------------------------------

#

#

# The loadbalancer (type lb) workers perform wighted round-robin

# load balancing with sticky sessions.

# Note:

# ----> If a worker dies, the load balancer will check its state

# once in a while. Until then all work is redirected to peer

# workers.

worker.loadbalancer.type=lb

worker.loadbalancer.balanced_workers=ajp12, ajp13

#

#------ DEFAULT JNI WORKER DEFINITION---------------------------------

#---------------------------------------------------------------------

#

#

# Defining a worker named inprocess and of type jni

# Note that the name and the type do not have to match.

#

worker.inprocess.type=jni

#

#------ CLASSPATH DEFINITION -----------------------------------------

#---------------------------------------------------------------------

#

#

# Additional class path components.

#

worker.inprocess.class_path=$(workers.tomcat_home)$(ps)classes

#

# The XML parser provided with Tomcat

#

worker.inprocess.class_path=$(workers.tomcat_home)$(ps)lib$(ps)jaxp.jar

worker.inprocess.class_path=$(workers.tomcat_home)$(ps)lib$(ps)parser.jar

#

# Tomcat`s implementation

#

worker.inprocess.class_path=$(workers.tomcat_home)$(ps)common$(ps)lib$(ps)jasper.jar

worker.inprocess.class_path=$(workers.tomcat_home)$(ps)common$(ps)lib$(ps)servlet.jar

worker.inprocess.class_path=$(workers.tomcat_home)$(ps)common$(ps)lib$(ps)webserver.jar

#

# Javac as available from Java2SE

#

worker.inprocess.class_path=$(workers.java_home)$(ps)lib$(ps)tools.jar

#

# Setting the command line for tomcat

# Note: The cmd_line string may not contain spaces.

#

worker.inprocess.cmd_line=-config

worker.inprocess.cmd_line=$(workers.tomcat_home)/conf/jni_server.xml

worker.inprocess.cmd_line=-home

worker.inprocess.cmd_line=$(workers.tomcat_home)

#

# The JVM that we are about to use

#

# This is for Java2

#

worker.inprocess.jvm_lib=$(workers.java_home)$(ps)jre$(ps)bin$(ps)classic$(ps)jvm.dll

#

# And this is for jdk1.1.X

#

#worker.inprocess.jvm_lib=$(workers.java_home)$(ps)bin$(ps)javai.dll

#

#

# Setting the place for the stdout and stderr of tomcat

#

worker.inprocess.stdout=$(workers.tomcat_home)$(ps)inprocess.stdout

worker.inprocess.stderr=$(workers.tomcat_home)$(ps)inprocess.stderr

#

# Setting the tomcat.home Java property

#

worker.inprocess.sysprops=tomcat.home=$(workers.tomcat_home)

#

# Java system properties

#

# worker.inprocess.sysprops=java.compiler=NONE

# worker.inprocess.sysprops=myprop=mypropvalue

#

# Additional path components.

#

# worker.inprocess.ld_path=d:$(ps)SQLLIB$(ps)bin

#

#--------------------------------------配置文件完毕-------------------------------------

在这个文件中需要注意的是要修改只有两个地方，一个是workers.tomcat_home，

这是指定Tomcat工作的目录，另外一个是workers.java_home，这是指定Jdk的目

录，大家可以做适当修改！我这里的配置没有修改，都是符合我安装系统的配置！

其次，配置TOMCAT核心文件,打开 c:\Apache Tomcat4.0\conf\server.xml

修改如下：

将<!-- Define an AJP 1.3 Connector on port 8009 -->

<!--

<Connector className="org.apache.ajp.tomcat4.Ajp13Connector"

port="8009" minProcessors="5" maxProcessors="75"

acceptCount="10" debug="0"/>

-->

的<!-- --> 去掉，这句话熟悉XML的人都知道它是注释，因为默认的Tomcat4

是没有启用Apj13的8009的端口即mod_jk所使用，修改后如下：

<Connector className="org.apache.ajp.tomcat4.Ajp13Connector"

port="8009" minProcessors="5" maxProcessors="75"

acceptCount="10" debug="0"/>

然后保存，现在你的Tomcat和Apache的配置基本完成了。

第五步：所有配置基本完成，重新启动计算机，开始整体测试！

测试：大家首先启动Apache，然后在浏览器里输入http://localhost，/ 如果能看到Apache的欢迎页面，那么恭喜您，第一步成功了。然后回到Tomca目录下

运行startup.bat启动Tomcat，再打开浏览器输入：http://localhost:8080/

如果看到可爱的Tomcat，那么恭喜您，Tomcat也没有问题，最后最重要的是

Apache下可以解释jsp和Servlet,把下面的代码copy到文本编辑器中命名为

hello.jsp,

内容如下:

<%@ page contentType="text/html;charset=gb2312"%>

<html>

<body>

<%String str="Hello World!";%>

<%str=str+"你好";%>

<%=str%>

</body>

</html>

将它保存到C:\\Apache Tomcat 4.0\\webapps\\ROOT下，然后在浏览器里输入

http://localhost/hello.jsp如果看到了Hello,那么您的确成功了

------------------至此你已经大功告成，可以哼一个小曲了--------------------------

我的这个配置文档是经过考验，确实可以正常通过并运行的，希望能给你有所帮助，如果在进

行过程中有任何问题，请通知我！

我的QQ：5359496，11035181 EMAIL：info@5line.net

其次我再阐述两个问题：

1。由于我在配置APACHE中使用了虚拟主机，所以访问地址可以是：

http://localhost和http://root.dev,但是如果想http://root.dev访问成功的话，请在

浏览器里做如下设置：

INTERNET选项-连接-局域网设置

选择 “使用代理服务器”，地址：192.168.0.16 (写你主机的IP) 端口：80

2。对于APACHE主机下访问的JSP文件，实际上物理上不存在与APACHE的主机上，而是存在在

TOMCAT的主机目录里，例如：

http://localhost/hello.jsp 中hello.jsp文件实际不在 c:\apache\htdocs\下，而在

C:\Apache Tomcat 4.0\webapps\ROOT 下。这点请注意，不要混淆概念！

http://www.justdn.org/
JustDN OF iZz Studio
2002-12-12 12:41

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.037906 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - PHP 安全问题 大家注意一下 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » PHP 安全问题 大家注意一下

作者:
标题: PHP 安全问题 大家注意一下 上一主题 | 下一主题
街舞
淡淡微笑无奈的我

积分 3123
发贴 3017
注册 2001-9-14
来自 YouID.COM
PHP 安全问题 大家注意一下

落伍者好几个人的主机存在以下漏洞

cmd 的 shell_exec passthru escapeshellcmd 等漏洞

包括个人主机 和 个人商业主机 希望大家注意

我发现问题的主机 已经 PM给本人了

因为有的漏洞 需要FTP权利所以我不能更多的人主机检查

PHP本身是安全的 但默认安装存在着多种多样的问题

建议 个人主机

1 删除apache 虚拟目录
2 关闭php 错误提示 error_reporting = E_ALL & ~E_NOTICE
3 启动safe_mode 设定php 运行目录 safe_mode_exec_dir=
4 用 disable_functions 屏蔽 passthru , exec , system , phpinfo , popen , chroot , scandir , chgrp , chown , escapeshellcmd , escapeshellarg , shell_exec , proc_open , proc_get_status 等危险函数

附加 expose_php = Off 关闭决定 PHP WEB标市

linix 主机还注意 设定 php 程序目录权限

不要用 root 改动 WEB目录 防止目录权限漏洞

mysql 不要使用root 启动 另起mysql 帐户

今天就发现了这么多问题 给大家贴出 注意一下

昨天比较忙 这个算我给大家的生日礼物把

年轻人应该多多学习，努力工作

+[EBD中文论坛]+ +[河北LINXU协会]+ +[YouID.COM]+

2003-7-11 18:17
小林
o○万帖俱乐部老八^_^ ○ o

积分 11252
发贴 11181
注册 2002-10-29
来自 『新都人.COM』
昨天你生日？
送上迟来的祝福

生日快乐：）

万维主机-Sunking

『统一行动，开始删贴！』
2003-7-11 18:20
不飘不浮
落伍者

积分 2159
发贴 2225
注册 2002-8-14
linux不受影响吧？

QQ：725912

特别定制ASP程序 价格QQ联系
PHP+MYSQL主机便宜卖～100RMB 100M 数据库大小不限制 演示 免费提供二级玉米
2003-7-11 18:21
会飞的蛋壳
落伍者

积分 5416
发贴 5196
注册 2002-6-26
来自 www.mxav.com
谢谢 街舞 最近发现险情的踪迹了吗？

梦想影视 www.mxav.com
梦想软件 down.mxav.com

2003-7-11 18:22
街舞
淡淡微笑无奈的我

积分 3123
发贴 3017
注册 2001-9-14
来自 YouID.COM
一样 有发现linux主机 有此漏洞

就是 cmd.命令变一下 ls /root 呵呵

年轻人应该多多学习，努力工作

+[EBD中文论坛]+ +[河北LINXU协会]+ +[YouID.COM]+

2003-7-11 18:22
crazynet
落伍者

积分 5761
发贴 5763
注册 2002-6-10
来自 那一射时的风情
好帖
顶…………

Quote:
杰特数据在线-专业的域名注册、虚拟主机、企业邮箱服务提供商

2003-7-11 18:23
街舞
淡淡微笑无奈的我

积分 3123
发贴 3017
注册 2001-9-14
来自 YouID.COM

Quote:
Originally posted by 会飞的蛋壳 at 2003-7-11 06:22 PM:

险情另有工作 CTB 将由 ccxx funxi 绝续开发

年轻人应该多多学习，努力工作

+[EBD中文论坛]+ +[河北LINXU协会]+ +[YouID.COM]+

2003-7-11 18:24
会飞的蛋壳
落伍者

积分 5416
发贴 5196
注册 2002-6-26
来自 www.mxav.com

Quote:
Originally posted by 街舞 at 2003-7-11 18:24:

险情另有工作 CTB 将由 ccxx funxi 绝续开发

他还上学不？

梦想影视 www.mxav.com
梦想软件 down.mxav.com

2003-7-11 18:25
thunderbird
落伍者

积分 510
发贴 505
注册 2002-12-4
不懂，有什么危险的？？？
2003-7-11 18:26
街舞
淡淡微笑无奈的我

积分 3123
发贴 3017
注册 2001-9-14
来自 YouID.COM
type ../../../conn.asp 得到你的数据库地址
下载 你的数据库 地址

ls /root

得到你的主机的目录分配 权利大点 可以修改你的conf文件

年轻人应该多多学习，努力工作

+[EBD中文论坛]+ +[河北LINXU协会]+ +[YouID.COM]+

2003-7-11 18:29
thunderbird
落伍者

积分 510
发贴 505
注册 2002-12-4
还是不懂，有什么危险的？？？
2003-7-11 18:34
LOOX
落伍者

积分 2559
发贴 2667
注册 2002-6-23
来自 eom.cn
恭喜发财阿，咔咔

虎虎唧唧咕咕嘎！！
本站代理广东华联网络有限公司http://www.163icp.com空间 粤ICP备060138，价格从优。QQ16802757
2003-7-11 18:36
街舞
淡淡微笑无奈的我

积分 3123
发贴 3017
注册 2001-9-14
来自 YouID.COM
2000 主机 shell_exec 可以使用 命令远程关闭计算机

添加2000用户 编辑启动脚本

年轻人应该多多学习，努力工作

+[EBD中文论坛]+ +[河北LINXU协会]+ +[YouID.COM]+

2003-7-11 18:36
准备早起的鸟
落伍者

积分 1354
发贴 1352
注册 2003-2-25
来自 安徽滁州
：）

Quote:
出售 php,mysql,asp.net,asp,高速空间,自己的服务器,托管在电信,服务好有保障。
服务器托管,3000元/年,需要者请联系QQ:55025

2003-7-11 18:38
blueoxygen
落伍者

积分 423
发贴 424
注册 2002-10-16
好贴，收藏了

【全国知名的校园网enwell空间】自己的孩子||【HYWAVE多媒体】兼职公司||【个人主页】
2003-7-11 18:58

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.030858 second(s), 5 queries, Gzip enabled


落伍者论坛 - 代码交流专栏 - PHP 基础 之 php.ini中文版 - powered by Discuz!

落伍者论坛 » 代码交流专栏 » PHP 基础 之 php.ini中文版

作者:
标题: PHP 基础 之 php.ini中文版 取消高亮 | 上一主题 | 下一主题
街舞
淡淡微笑无奈的我

积分 3123
发贴 3017
注册 2001-9-14
来自 YouID.COM
PHP 基础 之 php.ini中文版

[PHP]
; PHP还是一个不断发展的工具，其功能还在不断地删减
; 而php.ini的设置更改可以反映出相当的变化，
; 在使用新的PHP版本前，研究一下php.ini会有好处的

;;;;;;;;;;;;;;;;;;;
; 关于这个文件 ;
;;;;;;;;;;;;;;;;;;;

; 这个文件控制了PHP许多方面的观点。为了让PHP读取这个文件，它必须被命名为
; 'php.ini'。PHP 将在这些地方依次查找该文件：当前工作目录；环境变量PHPRC
; 指明的路径；编译时指定的路径。
; 在windows下，编译时的路径是Windows安装目录。
; 在命令行模式下，php.ini的查找路径可以用 -c 参数替代。

; 该文件的语法非常简单。空白字符和用分号';'开始的行被简单地忽略（就象你可能
; 猜到的一样）。 章节标题（例如 : [Foo]）也被简单地忽略，即使将来它们可能
; 有某种的意义。
;
; 指示被指定使用如下语法：
; 指示标识符 = 值
; directive = value
; 指示标识符 是 *大小写敏感的* - foo=bar 不同于 FOO = bar。
;
; 值可以是一个字符串，一个数字，一个 PHP 常量 (如： E_ALL or M_PI), INI 常量中的
; 一个 (On, Off, True, False, Yes, No and None) ，或是一个表达式
; (如: E_ALL & ~E_NOTICE), 或是用引号括起来的字符串("foo" [image].
;
; INI 文件的表达式被限制于位运算符和括号。
; | bitwise OR
; & bitwise AND
; ~ bitwise NOT
; ! boolean NOT
;
; 布尔标志可用 1, On, True or Yes 这些值置于开的状态。
; 它们可用 0, Off, False or No 这些值置于关的状态。
;
; 一个空字符串可以用在等号后不写任何东西表示，或者用 None 关键字:
;
; foo = ; 将foo置为空字符串
; foo = none ; 将foo置为空字符串
; foo = "none" ; 将foo置为字符串'none'
;
; 如果你值设置中使用常量，而这些常量属于动态调入的扩展库（不是 PHP 的扩展，就是
; Zend 的扩展），你仅可以调入这些扩展的行*之后*使用这些常量。
;
; 所有在 php.ini-dist 文件里设定的值与内建的默认值相同（这是说，如果 php.ini
; 没被使用或者你删掉了这些行，默认值与之相同）。

;;;;;;;;;;;;;;;;;;;;
; 语言选项 ;
;;;;;;;;;;;;;;;;;;;;

engine = On
; 使 PHP scripting language engine（PHP 脚本语言引擎）在 Apache下有效。
short_open_tag = On
; 允许 <? 标识（这种简单表示）。否则 仅有 <?php and <script> tags 将被识别。
asp_tags = Off
; 允许ASP-style <% %> tags
precision = 14
; 浮点类型数显示时的有效位数

y2k_compliance = Off
; 是否打开 2000年适应 (可能在非Y2K适应的浏览器中导致问题)

output_buffering = Off
; 输出缓存允许你甚至在输出正文内容之后发送 header（标头，包括cookies）行
; 其代价是输出层减慢一点点速度。你可以使用输出缓存在运行时打开输出缓存，
; 或者在这里将指示设为 On 而使得所有文件的输出缓存打开。
output_handler = ; 你可以重定向你的脚本的所有输出到一个函数，
; 那样做可能对处理或以日志记录它有用。
; 例如若你将这个output_handler 设为"ob_gzhandler",
; 则输出会被透明地为支持gzip或deflate编码的浏览器压缩。
; 设一个输出处理器自动地打开输出缓冲。

implicit_flush = Off
; 强制flush（刷新）让PHP 告诉输出层在每个输出块之后自动刷新自身数据。
; 这等效于在每个 print() 或 echo() 调用和每个 HTML 块后调用flush()函数。
; 打开这项设置会导致严重的运行时冲突，建议仅在debug过程中打开。

allow_call_time_pass_reference = On
; 是否让强迫函数调用时按引用传递参数。这一方法遭到抗议，
; 并可能在将来版本的PHP/Zend里不再支持。
; 受到鼓励的指定哪些参数按引用传递的方法是在函数声明里。
; 你被鼓励尝试关闭这一选项并确认你的脚本仍能正常工作，以保证在将来版本的语言里
; 它们仍能工作。（你将在每次使用该特点时得到一个警告，而参数将按值而不是按引用
; 传递）。

; Safe Mode 安全模式
safe_mode = Off
safe_mode_exec_dir =
safe_mode_allowed_env_vars = PHP_
; ？Setting certain environment variables
; ？may be a potential security breach.
; 该指示包含用逗号分隔的前缀列表。安全模式中，用户仅可以替换
; 以在此列出的前缀开头的环境变量的值。
; 默认地，用户将仅能 设定以PHP_开头的环境变量，（如: PHP_FOO=BAR）。
; 注意: 如果这一指示为空，PHP 将让用户更改任意环境变量!

safe_mode_protected_env_vars = LD_LIBRARY_PATH
; 这条指示包含一个用逗号分隔的环境变量列表，那是最终用户将不能用putenv () 更改的。
; 这些变量甚至在safe_mode_allowed_env_vars 设置为允许的情况下得到保护。

disable_functions =
; 这条指示让你可以为了安全的原因让特定函数失效。
; 它接受一个用逗号分隔的函数名列表。
; 这条指示 *不受* 安全模式是否打开的影响。

; 语法高亮模式的色彩。
; 只要能被<font color=???>接受的东西就能工作。

highlight.string = #DD0000
highlight.comment = #FF8000
highlight.keyword = #007700
highlight.bg = #FFFFFF
highlight.default = #0000BB
highlight.html = #000000

; Misc 杂项
expose_php = Off
; 决定 PHP 是否标示它装在服务器上的事实（例如：加在它 —PHP—给Web服务
; 发送的信号上）。
; （我个人的意见，在出现什么power-by的header的时候，把这关掉。）
; 它不会有安全上的威胁, 但它使检查你的服务器上是否安装了PHP成为了可能。

;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

max_execution_time = 30 ; 每个脚本的最大执行时间, 按秒计
memory_limit = 8388608 ; 一个脚本最大可使用的内存总量 (这里是8MB)

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
; Error handling and logging ;
; 出错控制和登记 ;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
; 错误报告是按位的。或者将数字加起来得到想要的错误报告等级。
; E_ALL - 所有的错误和警告
; E_ERROR - 致命性运行时错
; E_WARNING - 运行时警告（非致命性错）
; E_PARSE - 编译时解析错误
; E_NOTICE - 运行时提醒(这些经常是是你的代码的bug引起的，
;也可能是有意的行为造成的。(如：基于未初始化的变量自动初始化为一个
;空字符串的事实而使用一个未初始化的变量)

; E_CORE_ERROR - 发生于PHP启动时初始化过程中的致命错误
; E_CORE_WARNING - 发生于PHP启动时初始化过程中的警告(非致命性错)
; E_COMPILE_ERROR - 编译时致命性错
; E_COMPILE_WARNING - 编译时警告(非致命性错)
; E_USER_ERROR - 用户产生的出错消息
; E_USER_WARNING - 用户产生的警告消息
; E_USER_NOTICE - 用户产生的提醒消息
; 例子:
; error_reporting = E_ALL & ~E_NOTICE ; 显示所有的错误，除了提醒
; error_reporting = E_COMPILE_ERROR|E_ERROR|E_CORE_ERROR ; 仅显示错误
error_reporting = E_ALL & ~E_NOTICE ; 显示所有的错误，除了提醒
display_errors = On ; 显示出错误信息(作为输出的一部分)
; 在最终发布的web站点上，强烈建议你关掉这个特性，并使用
; 错误日志代替（参看下面）。
; 在最终发布的web站点继续让 display_errors 有效可能
; 暴露一些有关安全的信息，例如你的web服务上的文件路径、
; 你的数据库规划或别的信息。
display_startup_errors = Off ; 甚至当display_erroes打开了，发生于PHP的启动的步骤中
; 的错误也不会被显示。
; 强烈建议保持使 display_startup_errors 关闭，
; 除了在改错过程中。
log_errors = Off ; 在日志文件里记录错误（服务器指定的日志，stderr标准错误输出，或error_log(下面的））
; 正如上面说明的那样，强烈建议你在最终发布的web站点以日志记录错误
; 取代直接错误输出。

track_errors = Off ; 保存最近一个 错误/警告 消息于变量 $php_errormsg (boolean)
;error_prepend_string = "<font color=ff0000>" ; 于错误信息前输出的字符串
;error_append_string = "</font>" ; 于错误信息后输出的字符串
;error_log = filename ; 记录错误日志于指定文件
;error_log = syslog ; 记录错误日志于系统日志 syslog (NT 下的事件日志, Windows 95下无效)
warn_plus_overloading = Off ; 当将‘+’用于字符串时警告

;;;;;;;;;;;;;;;;;
; Data Handling ;
;;;;;;;;;;;;;;;;;
variables_order = "EGPCS" ; 这条指示描述了PHP 记录
; GET, POST, Cookie, Environment and Built-in 这些变量的顺序。
; （以 G, P, C, E & S 代表，通常以 EGPCS 或 GPC 的方式引用）。
; 按从左到右记录，?#等〈芍怠?

register_globals = On ; 是否将这些 EGPCS 变量注册为全局变量。
; 若你不想让用户数据不在全局范围内混乱的话，你可能想关闭它。
; 这和 track_vars 连起来用更有意义 — 这样你可以通过
; $HTTP_*_VARS[] 数组访问所有的GPC变量。

register_argc_argv = On ; 这条指示告诉 PHP 是否声明 argv和argc 变量
; （注：这里argv为数组,argc为变量数）
; （其中包含用GET方法传来的数据）。
; 若你不想用这些变量，你应当关掉它以提高性能。

track_vars = On ; 使$HTTP_*_VARS[]数组有效，这里*在使用时用
; ENV, POST, GET, COOKIE or SERVER替换
post_max_size = 8M ; PHP将接受的POST数据最大大小。

gpc_order = "GPC" ; 这条指示被人反对。用 variables_order 代替。

; Magic quotes
magic_quotes_gpc = On ; 在输入的GET/POST/Cookie数据里使用魔术引用
; （原文就这样，呵呵，所谓magic quotes 应该是指用转义符加在引用性的控制字符上，如 '....）
magic_quotes_runtime= Off ; 对运行时产生的数据使用魔术引用，
; 例如：用SQL查询得到的数据，用exec()函数得到的数据，等等
magic_quotes_sybase = Off ; 采用 Sybase形式的魔术引用（用 '' 脱出 ' 而不用 '）

; 自动在 PHP 文档之前和之后添加文件
auto_prepend_file =
auto_append_file =

; 象4.04b4一样，PHP 默认地总是在 “Content-type:” 头标输出一个字符的编码方式。
; 让输出字符集失效，只要设置为空。
; PHP 的内建默认值是 text/html
default_mimetype = "text/html"
;default_charset = "iso-8859-1"

;;;;;;;;;;;;;;;;;;;;;;;;;
; Paths and Directories ;
;;;;;;;;;;;;;;;;;;;;;;;;;
include_path = ; include 路径设置，UNIX: "/path1:/path2" Windows: "\path1;\path2"
doc_root = ; php 页面的根路径，仅在非空时有效
user_dir = ; 告知 php 在使用 /~username 打开脚本时到哪个目录下去找，仅在非空时有效
;upload_tmp_dir = ; 存放用HTTP协议上载的文件的临时目录（诿恢付ㄊ笔褂孟低衬系模?
upload_max_filesize = 2097152 ; 文件上载默认地限制为2 Meg
extension_dir = c:\php\ ; 存放可加载的扩充库（模块）的目录
enable_dl = On ; 是否使dl()有效。
; 在多线程的服务器上 dl()函数*不能*很好地工作，
; 例如IIS or Zeus，并在其上默认为禁止

;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;
file_uploads = On ; 是否允许HTTP方式文件上载
;upload_tmp_dir = ; 用于HTTP上载的文件的临时目录（未指定则使用系统默认）
upload_max_filesize = 2M ; 上载文件的最大许可大小

; Fopen wrappers ;
;;;;;;;;;;;;;;;;;;
allow_url_fopen = On ; 是否允许把URLs当作http:.. 或把文件当作ftp:...
2003-1-28 16:00
街舞
淡淡微笑无奈的我

积分 3123
发贴 3017
注册 2001-9-14
来自 YouID.COM
;;;;;;;;;;;;;;;;;;;;;;
; 动态扩展 ;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;
; 若你希望一个扩展库自动加载，用下面的语法：
; extension=modulename.extension
; 例如，在windows上，
; extension=msql.dll
; or 在UNIX下,
; extension=msql.so
; 注意，这只应当是模块的名字，不需要目录信息放在里面。
; 用上面的 extension_dir 指示指定扩展库的位置。

;Windows 扩展
;extension=php_nsmail.dll
extension=php_calendar.dll
;extension=php_dbase.dll
;extension=php_filepro.dll
extension=php_gd.dll
;extension=php_dbm.dll
;extension=php_mssql.dll
;extension=php_zlib.dll
;extension=php_filepro.dll
;extension=php_imap4r2.dll
;extension=php_ldap.dll
;extension=php_crypt.dll
;extension=php_msql2.dll
;extension=php_odbc.dll
; 注意， MySQL的支持现在是内建的，因此，不需要用它的dll

;;;;;;;;;;;;;;;;;;;
; 模块设定 ;
; Module Settings ;
;;;;;;;;;;;;;;;;;;;

[Syslog]
define_syslog_variables = Off ; 是否定义各种的系统日志变量
; 如：$LOG_PID, $LOG_CRON, 等等。
; 关掉它是个提高效率的好主意。
; 运行时，你可以调用函数define_syslog_variables()，来定义这些变量

[mail function]
SMTP = localhost ;仅用于win32系统
sendmail_from = me@localhost.com ;仅用于win32系统
;sendmail_path = ;仅用于unix, 也可支持参数（默认的是'sendmail -t -i'）

[Debugger]
debugger.host = localhost
debugger.port = 7869
debugger.enabled = False

[Logging]
; 这些配置指示用于示例的日志记录机制。
; 看 examples/README.logging 以得到更多的解释
;logging.method = db
;logging.directory = /path/to/log/directory

[Java]
;java.class.path = .\php_java.jar
;java.home = c:\jdk
;java.library = c:\jdk\jre\bin\hotspot\jvm.dll
;java.library.path = .\

[SQL]
sql.safe_mode = Off

[ODBC]
;uodbc.default_db = Not yet implemented
;uodbc.default_user = Not yet implemented
;uodbc.default_pw = Not yet implemented
uodbc.allow_persistent = On ; 允许或禁止 持久连接
uodbc.check_persistent = On ; 在重用前检查连接是否还可用
uodbc.max_persistent = -1 ; 持久连接的最大数。-1 代表无限制
uodbc.max_links = -1 ; 连接的最大数目（持久和非持久）。-1 代表无限制
uodbc.defaultlrl = 4096 ; 控制 LONG 类型的字段。返回变量的字节数，0 代表通过（？）0 means passthru
uodbc.defaultbinmode = 1 ; 控制 二进制数据。0 代表?????Handling of binary data. 0 means passthru, 1 return as is, 2 convert to char
; 见有关 odbc_binmode 和 odbc_longreadlen 的文档以得到 uodbc.defaultlrl 和 uodbc.defaultbinmode 的解释。

[MySQL]
mysql.allow_persistent = On ; 允许或禁止 持久连接
mysql.max_persistent = -1 ; 持久连接的最大数。-1 代表无限制
mysql.max_links = -1 ; 连接的最大数目（持久和非持久）。-1 代表无限制
mysql.default_port = ; mysql_connect() 使用的默认端口，如不设置，mysql_connect()
; 将使用变量 $MYSQL_TCP_PORT，或在/etc/services 下的mysql-tcp 条目(unix)，
; 或在编译是定义的 MYSQL_PORT(按这样的顺序)
; Win32环境，将仅检查MYSQL_PORT。
mysql.default_socket = ; 用于本地 MySql 连接的默认的套接字名。为空，使用 MYSQL 内建值

mysql.default_host = ; mysql_connect() 默认使用的主机（安全模式下无效）
mysql.default_user = ; mysql_connect() 默认使用的用户名（安全模式下无效）
mysql.default_password = ; mysql_connect() 默认使用的密码（安全模式下无效）
; 注意，在这个文件下保存密码通常是一个*坏*主意
; *任何*可以使用PHP访问的用户可以运行
; 'echo cfg_get_var("mysql.default_password" [image] '来显示那个密码!
; 而且当然地，任何有读该文件权力的用户也能看到那个密码。

[mSQL]
msql.allow_persistent = On ; 允许或禁止 持久连接
msql.max_persistent = -1 ; 持久连接的最大数。-1 代表无限制
msql.max_links = -1 ; 连接的最大数目（持久和非持久）。-1 代表无限制

[PostgresSQL]
pgsql.allow_persistent = On ; 允许或禁止 持久连接
pgsql.max_persistent = -1 ; 持久连接的最大数。-1 代表无限制
pgsql.max_links = -1 ; 连接的最大数目（持久和非持久）。-1 代表无限制

[Sybase]
sybase.allow_persistent = On ; 允许或禁止 持久连接
sybase.max_persistent = -1 ; 持久连接的最大数。-1 代表无限制
sybase.max_links = -1 ; 连接的最大数目（持久和非持久）。-1 代表无限制
;sybase.interface_file = "/usr/sybase/interfaces"
sybase.min_error_severity = 10 ; 显示的错误的最低严重性
sybase.min_message_severity = 10 ; 显示的消息的最低重要性
sybase.compatability_mode = Off ; 与旧版的PHP 3.0 兼容的模式。若打开，这将导致 PHP 自动地
; 把根据结果的 Sybase 类型赋予它们，
; 而不是把它们全当成字符串。
; 这个兼容模式不会永远留着，
; 因此，将你的代码进行需要的修改，
; 并将该项关闭。

[Sybase-CT]
sybct.allow_persistent = On ; 允许或禁止 持久连接
sybct.max_persistent = -1 ; 持久连接的最大数。-1 代表无限制
sybct.max_links = -1 ; 连接的最大数目（持久和非持久）。-1 代表无限制
sybct.min_server_severity = 10 ; 显示的错误的最低严重性
sybct.min_client_severity = 10 ; 显示的消息的最低重要性

[bcmath]
bcmath.scale = 0 ; 用于所有bcmath函数的10十进制数数字的个数number of decimal digits for all bcmath functions

[browscap]
;browscap = extra/browscap.ini
browscap = C:\WIN\SYSTEM\inetsrv\browscap.ini
[Informix]
ifx.default_host = ; ifx_connect() 默认使用的主机（安全模式下无效）
ifx.default_user = ; ifx_connect() 默认使用的用户名（安全模式下无效）
ifx.default_password = ; ifx_connect() 默认使用的密码（安全模式下无效）
ifx.allow_persistent = On ; 允许或禁止 持久连接
ifx.max_persistent = -1 ; 持久连接的最大数。-1 代表无限制
ifx.max_links = -1 ; 连接的最大数目（持久和非持久）。-1 代表无限制
ifx.textasvarchar = 0 ; 若打开，select 状态符返回一个 ‘text blob’字段的内容，而不是它的id
ifx.byteasvarchar = 0 ; 若打开，select 状态符返回一个 ‘byte blob’字段的内容，而不是它的id
ifx.charasvarchar = 0 ; 追踪从固定长度的字符列里剥离的空格。
; 可能对 Informix SE 用户有效。
ifx.blobinfile = 0 ; 若打开，text和byte blobs 的内容被导出到一个文件
; 而不是保存到内存。
ifx.nullformat = 0 ; NULL（空）被作为空字段返回，除非，这里被设为1。
; 这种情况下（为1），NULL作为字串NULL返回。

[Session]
session.save_handler = files ; 用于保存/取回数据的控制方式
session.save_path = C:\win\temp ; 在 save_handler 设为文件时传给控制器的参数，
; 这是数据文件将保存的路径。
session.use_cookies = 1 ; 是否使用cookies
session.name = PHPSESSID
; 用在cookie里的session的名字
session.auto_start = 0 ; 在请求启动时初始化session
session.cookie_lifetime = 0 ; 为按秒记的cookie的保存时间，
; 或为0时，直到浏览器被重启
session.cookie_path = / ; cookie的有效路径
session.cookie_domain = ; cookie的有效域
session.serialize_handler = php ; 用于连接数据的控制器
; php是 PHP 的标准控制器。
session.gc_probability = 1 ; 按百分比的'garbage collection（碎片整理）'进程
; 在每次 session 初始化的时候开始的可能性。
session.gc_maxlifetime = 1440 ; 在这里数字所指的秒数后，保存的数据将被视为
; '碎片(garbage)'并由gc 进程清理掉。
session.referer_check = ; 检查 HTTP引用以使额外包含于URLs中的ids无效
session.entropy_length = 0 ; 从文件中读取多少字节
session.entropy_file = ; 指定这里建立 session id
; session.entropy_length = 16
; session.entropy_file = /dev/urandom
session.cache_limiter = nocache ; 设为{nocache,private,public},以决定 HTTP 的
; 缓存问题
session.cache_expire = 180 ; 文档在 n 分钟后过时
session.use_trans_sid = 1 ; 使用过渡性的 sid 支持，若编译时许可了
; --enable-trans-sid
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"

[MSSQL]
;extension=php_mssql.dll
mssql.allow_persistent = On ; 允许或禁止 持久连接
mssql.max_persistent = -1 ; 持久连接的最大数。-1 代表无限制
mssql.max_links = -1 ; 连接的最大数目（持久和非持久）。-1 代表无限制
mssql.min_error_severity = 10 ; 显示的错误的最低严重性
mssql.min_message_severity = 10 ; 显示的消息的最低重要性
mssql.compatability_mode = Off ; 与旧版的PHP 3.0 兼容的模式。

[Assertion]
; ？？？？？
;assert.active = On ; ？assert(expr); active by default
;assert.warning = On ; issue a PHP warning for each failed assertion.
;assert.bail = Off ; don't bail out by default.
;assert.callback = 0 ; user-function to be called if an assertion fails.
;assert.quiet_eval = 0 ; eval the expression with current error_reporting(). set to true if you want error_reporting(0) around the eval().

[Ingres II]
ii.allow_persistent = On ; 允许或禁止 持久连接
ii.max_persistent = -1 ; 持久连接的最大数。-1 代表无限制
ii.max_links = -1 ; 连接的最大数目（持久和非持久）。-1 代表无限制
ii.default_database = ; 默认 database (format : [node_id::]dbname[/srv_class]
ii.default_user = ; 默认 user
ii.default_password = ; 默认 password

[Verisign Payflow Pro]
pfpro.defaulthost = "test.signio.com" ; 默认的 Signio 服务器
pfpro.defaultport = 443 ; 连接的默认端口
pfpro.defaulttimeout = 30 ; 按秒计的默认超时时间

; pfpro.proxyaddress = ; 默认的代理的 IP 地址（如果需要）
; pfpro.proxyport = ; 默认的代理的端口
; pfpro.proxylogon = ; 默认的代理的登录（logon 用户名）
; pfpro.proxypassword = ; 默认的代理的密码

[Sockets]
sockets.use_system_read = On ; 使用系统的read() 函数替代 php_read()封装
; Local Variables: （局部变量）
; tab-width: 4
; End:
2003-1-28 16:01
独孤飞逸
落伍者

积分 2141
发贴 2150
注册 2002-5-30
来自 SH
太好了~E文的真不好，修改也不敢修改
2003-1-28 16:07
魔力闪客
落伍者

积分 3393
发贴 3316
注册 2002-7-12
支持

8错
2003-1-29 08:59
龙慧
落伍者

积分 4751
发贴 4637
注册 2002-11-20
经典。。值得收藏！！
2003-1-29 10:27
fzsky
落伍者

积分 6716
发贴 6432
注册 2002-10-15
我已经藏了
2003-1-29 10:31
uneed
落伍者

积分 11892
发贴 12147
注册 2002-1-13
藏！
2003-1-29 10:32
yjj798
落伍者

积分 2326
发贴 1910
注册 2002-5-22
来自 石家庄
有图标呀，禁用表情符号

yjj798 我的电脑
2003-7-11 16:09
伏地魔
落伍者

积分 1662
发贴 1487
注册 2002-9-20
Good

够酷BBS Gò Kà Bì Bì Sī
2003-7-11 16:24
孤竹
落伍者

积分 330
发贴 330
注册 2002-4-19
不错!

[IMG]http://www.cyhzs.com/non-cgi/myimages/mainlogo.jpg[/IMG]
[IMG]http://www.cyhzs.com/non-cgi/usr/59/59_1.jpg[/IMG]
2003-7-11 17:18
XiEJEsEn
落伍者

积分 1858
发贴 1838
注册 2001-11-6
来自 <拒绝自伤的檬檬>
看过了

盼你怜我如花,爱我如己,今生死而无憾.此心苍天可表,日月为鉴,纵然你还是不爱我.
2003-7-11 18:04
blueoxygen
落伍者

积分 423
发贴 424
注册 2002-10-16
这个好像和那个版本不一样？

【全国知名的校园网enwell空间】自己的孩子||【HYWAVE多媒体】兼职公司||【个人主页】
2003-7-11 18:23

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.047365 second(s), 5 queries, Gzip enabled


无标题文档

MYSQL部分

1. MySQL管理员指南 -- 亚当夏娃
2. 利用数据库来破解md5[转] -- 那个那个谁
3. 最佳做法检查表(SQL Server官方推荐安全配置方案)[轉帖] -- Jay
4. SQL语法参考手册 -- vku
5. 解决 Mysql 占用系统资源过大的问题 -- dreamyboy


落伍者论坛 - 网站建设专栏 - 精华III: MySQL管理员指南 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 精华III: MySQL管理员指南

作者:
标题: 精华III: MySQL管理员指南 上一主题 | 下一主题
亚当夏娃
落伍者

积分 5125
发贴 5105
注册 2002-9-22
来自 八闽社区
精华III: MySQL管理员指南

Mysql数据库介绍
MySQL是一个真正的多用户、多线程SQL数据库服务器。SQL（结构化查询语言）是世界上最流行的和标准
化的数据库语言。MySQL是以一个客户机/服务器结构的实现，它由一个服务器守护程序mysqld和很多不同的
客户程序和库组成。

SQL是一种标准化的语言，它使得存储、更新和存取信息更容易。例如，你能用SQL语言为一个网站检索
产品信息及存储顾客信息，同时MySQL也足够快和灵活以允许你存储记录文件和图像。

MySQL 主要目标是快速、健壮和易用。最初是因为我们需要这样一个SQL服务器，它能处理与任何可不昂
贵硬件平台上提供数据库的厂家在一个数量级上的大型数据库，但速度更快，MySQL就开发出来。自1996年以
来，我们一直都在使用MySQL，其环境有超过 40 个数据库，包含 10,000个表，其中500多个表超过7百万行
，这大约有100 个吉字节(GB)的关键应用数据。

Mysql数据库特点
1. 使用核心线程的完全多线程。这意味着它能很容易地利用多CPU（如果有）。
2. 可运行在不同的平台上。
3. 多种列类型：1、 2、 3、4、和 8 字节长度的有符号/无符号整数(INT)、FLOAT、DOUBLE、CHAR、
VARCHAR、TEXT、BLOB、DATE、TIME、DATETIME、 TIMESTAMP、YEAR、SET和ENUM类型。
4. 利用一个优化的一遍扫描多重联结（one-sweep multi-join）非常快速地进行联结(join)。
5. 在查询的SELECT和WHERE部分支持全部运算符和函数。
6. 通过一个高度优化的类库实现SQL函数库并且像他们能达到的一样快速，通常在查询初始化后不应该有任
何内存分配。
7. 全面支持SQL的GROUP BY和ORDER BY子句，支持聚合函数( COUNT()、COUNT(DISTINCT)、AVG()、STD()、
SUM()、 MAX()和MIN() )。
8. 支持ANSI SQL的LEFT OUTER JOIN和ODBC语法。
9. 你可以在同一查询中混用来自不同数据库的表。
10. 一个非常灵活且安全的权限和口令系统，并且它允许基于主机的认证。口令是安全的，因为当与一个服
务器连接时，所有的口令传送被加密。
11. ODBC for Windiws 95。
12. 具备索引压缩的快速B树磁盘表。
13. 每个表允许有16个索引。每个索引可以由1～16个列或列的一部分组成。最大索引长度是 256 个字节(在
编译MySQL时，它可以改变)。一个索引可以使用一个CHAR或VARCHAR字段的前缀。
14. 定长和变长记录。
15. 用作临时表的内存散列表。
16. 大数据库处理。我们正在对某些包含 50,000,000 个记录的数据库使用MySQL。
17. 所有列都有缺省值，你可以用INSERT插入一个表列的子集，那些没用明确给定值的列设置为他们的缺省
值。
18. 一个非常快速的基于线程的内存分配系统。
19. 没有内存漏洞。用一个商用内存漏洞监测程序测试过(purify)。
20. 包括myisamchk，一个检查、优化和修复数据库表的快速实用程序。
21. 全面支持ISO-8859-1 Latin1 字符集。
22. 所有数据以 ISO-8859-1 Latin1 格式保存。所有正常的字符串比较是忽略大小写的。
23. DELETE、INSERT、REPLACE和UPDATE 返回有多少行被改变(受影响)。
24. 函数名不会与表或列名冲突。例如ABS是一个有效的列名字。对函数调用的唯一限制是函数名与随后的
"("不能有空格。
25. 所有MySQL程序可以用选项--help或-?获得联机帮助。
26. 服务器能为客户提供多种语言的出错消息。
27. 客户端使用TCP/IP 连接或Unix套接字（socket）或NT下的命名管道连接MySQL。
28. MySQL特有的SHOW命令可用来检索数据库、表和索引的信息，EXPLAIN命令可用来确定优化器如何解决一
个查询。

MySQL服务器的启动与停止

一、启动服务器的方法
启动服务器由三种主要方法：

1、 直接调用mysqld。
#./mysqld&
这可能是最不常用的方法，建议不要多使用。

2、调用safe_mysqld脚本，最好的方法。
#./safe_mysqld -O join_buffer=128M -O key_buffer=128M -O record_buffer=256M -O sort_buffer=128M -O table_cache=2048 -O tmp_table_size=16M -O max_connections=2048 &

3、调用mysql.server脚本。
safe_mysqld脚本安装在MySQL安装目录的bin目录下，或可在MySQL源代码分发的scripts目录下找到。
mysql.server脚本安装在MySQL安装目录下的share/mysqld目录下或可以在MySQL源代码分发的support_files
目录下找到。如果你想使用它们，你需要将它们拷贝到适当的目录下mysql/bin下。
#./mysql.server start

Sun Solariys开机自动启mysql的方法
写一个启动和关闭的批处理文件Web (在路径/etc/init.d 下), 内容如下:

#!/bin/sh
OPT_=$1

case "$OPT_" in
start)
/bin/echo "$0 : (start)"
#
# Your service startup command goes here.
#
/usr/local/apache/bin/apachectl start
/home3/mysql/bin/safe_mysqld -O join_buffer=128M -O key_buffer=128M -O record_buffer=256M -O sort_buffer=128M -O table_cache=2048 -O tmp_table_size=16M -O max_connections=2048 &

# NOTE: Must exit with zero unless error is severe.
exit 0
;;
stop)
/bin/echo "$0 : (stop)"
#
# Your service shutdown command goes here.
#
/usr/local/apache/bin/apachectl stop

# NOTE: Must exit with zero unless error is severe.
exit 0
;;
*) /bin/echo ''
/bin/echo "Usage: $0 [start|stop]"
/bin/echo " Invalid argument ==> \"${OPT_}\""
/bin/echo ''
exit 0
;;
esac
确认此文件有可执行的权利
#chmod 500 web
#cd /etc/rc2.d
#ln -s ../init.d/web S99mysql
在系统启动时，S99mysql脚本将自动用一个start参数调用。注意头字母必须大写。

二、停止服务器的方法
1、要手工停止服务器，使用mysqladmin：
#mysqladmin -u 用户名 -p'密码' shutdown
2、 调用mysql.server脚本，最好的方法。
#./mysql.server stop
3、 直接杀掉OS的进程号
#kill -9 进程号
这可能是最不常用的方法，建议不要多使用。

要自动停止服务器，你不需做特别的事情。只需要加另外一个关闭程序。
#cd /etc/rc0.d
#ln -s ../init.d/web K01mysql
在系统启动时，K01mysql脚本将自动用一个stop参数调用。

MySQL目录结构和常用命令
一、 数据目录的位置
这是默认的mysql目录结构
bin info libexec share var
include lib man sql-bench

一个缺省数据目录被编译进了服务器，如果你从一个源代码分发安装MySQL，典型的缺省目录为
/usr/local/var，如果从RPM文件安装则为/var/lib/mysql，如果从一个二进制分发安装则是
/usr/local/mysql/data。
作为一名MySQL管理员，你应该知道你的数据目录在哪里。如果你运行多个服务器，你应该是到所有数据目录
在哪里，但是如果你不知道确切的位置，由多种方法找到它：

1、使用mysqladmin variables从你的服务器直接获得数据目录路径名。查找datadir变量的值，在Unix上，其输出类似于：
%mysqladmin -u username -p'*****' variables

+----------------------+----------------------+
| variable_name | Value |
+----------------------+----------------------+
| back_log | 5 |
| connect_timeout | 5 |
| basedir | /var/local/ |
| datadir | /usr/local/var/ |
....
2、查找mysql运行的路径
%ps -ef | grep mysqld

二、数据目录结构
每个数据库对应于数据目录下的一个目录。
在一个数据库中的表对应于数据目录下的文件。
数据目录也包含由服务器产生的几个状态文件，如日志文件。这些文件提供了关于服务器操作的重要信息。
对管理特别在出了问题而试图确定问题原因时很有价值。

1、数据库表的表示
数据库目录中有3种文件：一个样式（描述文件）、一个数据文件和一个索引文件。每个文件的基本名是表
名，文件名扩展名代表文件类型。扩展名如下表。数据和索引文件的扩展名指出表使用老式IASM索引或新式
MyISAM索引。

MySQL文件类型
文件类型 文件名扩展名 文件内容
样式文件 .frm 描述表的结构（它的列、列类型、索引等）
数据文件 .ISD(ISAM)或.MYD(MyISAM) 包含表里所有的数据
索引文件 .ISM(ISAM)或.MYI(MyISAM) 包含数据文件上的所有索引的索引树

当你发出一条CREATE TABLE tbl_name时语句定义表的结构时，服务器创建一个名为tbl_name.frm的文件，它
包括该结构的内部编码，同时也创建一个空数据和索引文件，初始化为包含指出无记录和无索引的信息（如
果CREATE TABLE语句包括索引指定，索引文件反映出这些索引）。对应于表的文件的属主和模式被设置为只
允许MySQL服务器用户访问。

下面介绍一下常用的mysql命令
进入mysql数据库
#./mysql -u 用户名 -p'密码'
查看所有的数据库
mysql> show databases;
进入一个特定的数据库
mysql> use 数据库名;
查看数据库里所有的表
mysql> show tables;
把表改名
mysql> alter table 表名1 rename 表名2;
例子：mysql>alter table dept rename dept2;

2、 建索引的注意事项：
先要把要加索引的字段设为非空
mysql> alter table 表名 change 字段名 字段名 字段描述 not null;
例子：
我们创建这样一个表
mysql> create table employee
( id int(5) not null,
depno int(5),
name varchar(20) not null,
cardnumber bigint(15) not null);

mysql> alter table employee change depno depno int(5) not null;
加索引
mysql> alter table 表名 add index 索引名 (字段名1[，字段名2 …]);
例子： mysql> alter table employee add index emp_name (name);

加主关键字的索引
mysql> alter table 表名 add primary key (字段名);
例子： mysql> alter table employee add primary key(id);

加唯一限制条件的索引
mysql> alter table 表名 add unique 索引名 (字段名);
例子： mysql> alter table employee add unique emp_name2(cardnumber);

查看某个表的索引
mysql> show index from 表名;
例子： mysql> show index from employee;

删除某个索引
mysql> alter table 表名 drop index 索引名;
例子： mysql>alter table employee drop index emp_name;

晶
2003-7-6 12:43
亚当夏娃
落伍者

积分 5125
发贴 5105
注册 2002-9-22
来自 八闽社区
MySQL用户管理
MySQL管理员应该知道如何设置MySQL用户账号，指出哪个用户可以连接服务器，从哪里连接，连接后能做什
么。MySQL 3.22.11开始引入两条语句使得这项工作更容易做：GRANT语句创建MySQL用户并指定其权限，而
REVOKE语句删除权限。两条语句扮演了mysql数据库的前端角色，并提供与直接操作这些表的内容不同的另一
种方法。CREATE和REVOKE语句影响4个表：

授权表内容：
user 能连接服务器的用户以及他们拥有的任何全局权限
db 数据库级权限
tables_priv 表级权限
columns_priv 列级权限

还有第5个授权表（host），但它不受GRANT和REVOKE的影响。
当你对一个用户发出一条GRANT语句时，在user表中为该用户创建一条记录。如果语句指定任何全局权限（管
理权限或适用于所有数据库的权限），这些也记录在user表中。如果你指定数据库、表和列级权限，他们被
分别记录在db、tables_priv和columns_priv表中。

在下面的章节中，我们将介绍如何设置MySQL用户账号并授权。我们也涉及如何撤权和从授权表中删除用户。

一、创建用户并授权
GRANT语句的语法看上去像这样：

GRANT privileges (columns)
ON what
TO user IDENTIFIED BY "password"
WITH GRANT OPTION
要使用该语句，你需要填写下列部分：

privileges
授予用户的权限，下表列出可用于GRANT语句的权限指定符：
权限指定符 权限允许的操作：
ALTER 修改表和索引
CREATE 创建数据库和表
DELETE 删除表中已有的记录
DROP 抛弃（删除）数据库和表
INDEX 创建或抛弃索引
INSERT 向表中插入新行
REFERENCE 未用
SELECT 检索表中的记录
UPDATE 修改现存表记录
FILE 读或写服务器上的文件
PROCESS 查看服务器中执行的线程信息或杀死线程
RELOAD 重载授权表或清空日志、主机缓存或表缓存。
SHUTDOWN 关闭服务器
ALL 所有；ALL PRIVILEGES同义词
USAGE 特殊的“无权限”权限

columns
权限运用的列，它是可选的，并且你只能设置列特定的权限。如果命令有多于一个列，应该用逗号分开它们.

what
权限运用的级别。权限可以是全局的（适用于所有数据库和所有表）、特定数据库（适用于一个数据库中的
所有表）或特定表的。可以通过指定一个columns字句是权限是列特定的。

user
权限授予的用户，它由一个用户名和主机名组成。MySQL中的一个用户名就是你连接服务器时指定的用户名，
该名字不必与你的Unix登录名或Windows名联系起来。缺省地，如果你不明确指定一个名字，客户程序将使用
你的登录名作为MySQL用户名。这只是一个约定。你可以在授权表中将该名字改为nobody，然后以nobody连接
执行需要超级用户权限的操作。

password
赋予用户的口令，它是可选的。如果你对新用户没有指定IDENTIFIED BY子句，该用户不赋给口令（不安全）。
对现有用户，任何你指定的口令将代替老口令。如果你不指定口令，老口令保持不变，当你用IDENTIFIED BY
时，口令字符串用改用口令的字面含义，GRANT将为你编码口令，不要象你用SET PASSWORD 那样使用password()
函数。

WITH GRANT OPTION子句是可选的。如果你包含它，用户可以授予权限通过GRANT语句授权给其它用户。你可
以用该子句给与其它用户授权的能力。

用户名、口令、数据库和表名在授权表记录中是大小写敏感的，主机名和列名不是。
举例：创建一个超级用户test1
mysql> grant all privilleges on *.* to test1@localhost identified by '123456' with grant option;
创建一个只能查询的用户 test2
mysql> grant select on *.* to test2@localhost identified by '9876543';

二、撤权并删除用户
要取消一个用户的权限，使用REVOKE语句。REVOKE的语法非常类似于GRANT语句，除了TO用FROM取代并且没有
INDETIFED BY和WITH GRANT OPTION子句：

REVOKE privileges (columns) ON what FROM user

user部分必须匹配原来GRANT语句的你想撤权的用户的user部分。privileges部分不需匹配，你可以用GRANT
语句授权，然后用REVOKE语句只撤销部分权限。REVOKE语句只删除权限，而不删除用户。即使你撤销了所有
权限，在user表中的用户记录依然保留，这意味着用户仍然可以连接服务器。要完全删除一个用户，你必须
用一条DELETE语句明确从user表中删除用户记录：

#mysql -u root mysql
mysql>DELETE FROM user
->WHERE User="user_name" and Host="host_name";
mysql>FLUSH PRIVILEGES;
DELETE语句删除用户记录，而FLUSH语句告诉服务器重载授权表。（当你使用GRANT和REVOKE语句时，表自动
重载，而你直接修改授权表时不是。）
举例：删除用户test1
mysql> revoke all on *.* from test2@localhost;
mysql> use mysql;
mysql> delete from user where user='test' and host='localhost';
mysql> flush privileges;
MySQL数据库备份
在数据库表丢失或损坏的情况下，备份你的数据库是很重要的。已经知道表被破坏，用诸如vi或Emacs等编辑
器试图直接编辑它们，这对表绝对不是件好事！

备份数据库两个主要方法是用mysqldump程序或直接拷贝数据库文件（如用cp、cpio或tar等）。每种方法都
有其优缺点：

mysqldump与MySQL服务器协同操作。直接拷贝方法在服务器外部进行，并且你必须采取措施保证没有客户正
在修改你将拷贝的表，一般在数据库关闭情况下做。mysqldump比直接拷贝要慢些。mysqldump生成能够移植
到其它机器的文本文件，甚至那些有不同硬件结构的机器上。直接拷贝文件可以移植到同类机器上，但不能
移植到其它机器上，除非你正在拷贝的表使用MyISAM存储格式。

一、使用mysqldump备份和拷贝数据库
当你使用mysqldump程序产生数据库备份文件时，缺省地，文件内容包含创建正在倾倒的表的CREATE语句和包
含表中行数据的INSERT语句。换句话说，mysqldump产生的输出可在以后用作mysql的输入来重建数据库。

Mysqldump参数如下：
#mysqldump -u 用户名-p'密码' 数据库名 [表名] > 操作系统下文件名

举例：#./mysqldump -u root -p'123456' samp_db>samp.db.txt
输出文件的开头看起来象这样：
# MySQL Dump 6.0
#
# Host: localhost Database: samp_db
#---------------------------------------
# Server version 3.23.2-alpha-log
#
# Table structure for table 'absence'
#
CREATE TABLE absence(
student_id int(10) unsigned DEFAULT '0' NOT NULL,
date date DEFAULT '0000-00-00' NOT NULL,
PRIMARY KEY (student_id,date)
);
#
# Dumping data for table 'absence'
#
INSERT INTO absence VALUES (3,'1999-09-03');
INSERT INTO absence VALUES (5,'1999-09-03');
INSERT INTO absence VALUES (10,'1999-09-08');
......
文件剩下的部分有更多的INSERT和CREATE TABLE语句组成。
输出单个的表：
#mysqldump samp_db student score event absence >grapbook.sql
#mysqldump samp_db member president >hist-league.sql

缺省地，mysqldump在写入前将一个表的整个内容读进内存。这通常确实不必要，并且实际上如果你有一个大
表，几乎是失败的。你可用--quick选项告诉mysqldump只要它检索出一行就写出每一行。为了进一步优化倾
倒过程，使用--opt而不是--quick。--opt选项打开其它选项，加速数据的倾倒和把它们读回。

二、使用直接拷贝数据库的备份和拷贝方法
另一种不涉及mysqldump备份数据库和表的方式是直接拷贝数据库表文件。典型地，这用诸如cp、tar或cpio
实用程序。本文的例子使用cp。
%cd DATADIR
%cp -r samp_db /usr/archive/mysql
单个表可以如下备份：

%cd DATADIR/samp_db
%cp member.* /usr/archive/mysql/samp_db
%cp score.* /usr/archive/mysql/samp_db
....
当你完成了备份时，你可以重启服务器（如果关闭了它）或释放加在表上的锁定（如果你让服务器运行）。
要用直接拷贝文件把一个数据库从一台机器拷贝到另一台机器上，只是将文件拷贝到另一台服务器主机的适
当数据目录下即可。要确保文件是MyIASM格式或两台机器有相同的硬件结构，否则你的数据库在另一台主机
上有奇怪的内容。你也应该保证在另一台机器上的服务器在你正在安装数据库表时不访问它们。

建一个sh文件bakmysql.sh
#!/bin/sh
cd /usr/local/mysql/
tar cvf /mount2/mysqlvar.tar var

可以设到操作系统自动运行。
root用户crontab文件
/var/spool/cron/crontabs/root增加以下内容

0 2 1 * * /mount2/bakmysql.sh

#/etc/rc2.d/S75cron stop
#/etc/rc2.d/S75cron start
重新击活Sun Solaris自动处理进程

三、用备份恢复数据
数据库损坏的发生有很多原因，程度也不同。如果你走运，你可能仅损坏一两个表（如掉电），如果你倒霉
，你可能必须替换整个数据目录（如磁盘损坏）。在某些情况下也需要恢复，比如用户错误地删除了数据库
或表。不管这些倒霉事件的原因，你将需要实施某种恢复。
如果表损坏但没丢失，尝试用myisamchk或isamchk修复它们，如果这样的损坏可有修复程序修复。

1、 恢复整个数据库
Mysqldump参数如下：
#mysqldump -u 用户名-p'密码' 数据库名 < 操作系统下文件名

举例：
先在Mysql里创建另一个数据库
mysql> create database test;
然后将备份的数据导入
#mysqldump -u root -p'123456' test2 < samp.db.txt

晶
2003-7-6 12:43
梦
杜鹃滴血

积分 2948
发贴 2698
注册 2002-5-6
来自 古墓苍狼
mysql太简单了。
没太多的管理。多用几次就会了

www.wps2000.net重新开放
http://www.wps2000.net/
PHP论坛：http://forum.wps2000.net/Forum.php?ForumID=28
2003-7-6 12:44
yjj798
落伍者

积分 2326
发贴 1910
注册 2002-5-22
来自 石家庄
好教材

yjj798 我的电脑
2003-7-6 12:45
夜客在线
落伍者

积分 3042
发贴 3146
注册 2001-5-18
不错。收了：

http://www.yearcon.com/showthread.php?s=&threadid=3974

Serv_UPlus FTP 电影下载
http://www.AVfox.com
http://www.yearcon.com

2003-7-6 12:47
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20
这个假精华做得不错

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-7-6 12:47
落叶追风
落伍者

积分 694
发贴 721
注册 2002-1-14
我想知道怎么通过MYSQL语句修改目录中的文件和修改好后如何覆盖。
2003-7-6 12:48
亚当夏娃
落伍者

积分 5125
发贴 5105
注册 2002-9-22
来自 八闽社区

Quote:
Originally posted by 西瓜 at 2003-7-6 12:47 PM:
这个假精华做得不错

那就加一个真的精华吧

晶
2003-7-6 12:52

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.034904 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 最佳做法检查表(SQL Server官方推荐安全配置方案)[轉帖] - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 最佳做法检查表(SQL Server官方推荐安全配置方案)[轉帖]

作者:
标题: 最佳做法检查表(SQL Server官方推荐安全配置方案)[轉帖] 上一主题 | 下一主题
Jay
落伍者

积分 4620
发贴 4619
注册 2002-9-28
来自 原產臺北 出口巴西 轉銷大陸
最佳做法检查表(SQL Server官方推荐安全配置方案)[轉帖]

最佳做法检查表(SQL Server官方推荐安全配置方案)

以下检查表总结了本白皮书中讨论的各种最佳做法。有关详细信息，请参阅上面的讨论。

管理员检查表

在安装之前设置环境
物理安全 确保服务器的物理安全

防火墙 在服务器和 Internet 之间放置防火墙。
总是在外围防火墙上阻止 TCP 端口 1433 和 UDP 端口 1434。如果命名实例在其他端口上侦听，则还要阻止这些端口。
在多层环境中，使用多个防火墙创建屏蔽子网

服务隔离 隔离服务，降低受到威胁的服务被利用来危害其他服务的风险。
绝对不要在域控制器上安装 SQL Server。
以单独的 Windows 帐户身份运行单独的 SQL Server 服务。
在多层环境中，在单独的计算机上运行 Web 逻辑和业务逻辑

服务帐户 创建 Windows 帐户，尽可能只让其具有运行 SQL Server 服务所需的最小特权。

文件系统 使用 NTFS。
对关键的数据文件使用 RAID

安装
最新版本和 Service Pack 总是安装最新的 Service Pack 和安全修补程序。

服务帐户 使用尽可能具有最低特权的帐户运行 SQL Server 服务。
用企业管理器将服务与 Windows 帐户相关联。

身份验证模式 要求使用 Windows 身份验证与 SQL Server 连接。

强密码 即使在使用 Windows 身份验证时，也总是为 sa 帐户指派强密码。
对所有 SQL Server 帐户都总是使用强密码。

安装之后的配置选项和设置
删除或保护旧安装文件 在安装之后删除或存档下列文件：sqlstp.log、sqlsp.log 和 setup.iss。对于默认安装，这些文件位于 <系统驱动器>:\Program Files\Microsoft SQL Server\MSSQL\Install 文件夹中；对于命名实例，这些文件位于 <系统驱动器>:\Program Files\Microsoft SQL Server\ MSSQL$<实例名称>\Install 文件夹中。

如果当前系统是从 SQL Server 7.0 升级的，请删除下列文件：%Windir% 文件夹中的 setup.iss；Windows Temp 文件夹中的 sqlsp.log。

为命名实例选择静态端口 为 SQL Server 的命名实例分配静态端口。

设置登录审核级别 将登录审核级别设置为“失败”或“全部”。

启用安全审核 对 Sysadmin 操作、固定角色成员身份更改、所有与登录相关的活动以及密码更改启用安全审核。
在选择适当的审核选项之后，应该编写审核脚本，将它包装在存储过程中，并将该存储过程标记为 AutoStart。

即使在 Windows 身份验证模式下也要保护 sa 帐户的安全 即使在配置为要求进行 Windows 身份验证的服务器上，也要为 sa 帐户指派强密码。

删除示例数据库 从生产服务器中删除示例数据库。

安全操作
安全模型 学会使用 SQL Server 安全模型。

备份策略 定期备份所有数据并将副本存放在安全的非现场位置。
测试灾难恢复系统。

减少功能、减小受攻击范围 通过只运行环境所必需的服务和功能，减小系统受到攻击的范围。

减少管理员 限制少数几个受信任用户拥有 sysadmin 固定服务器角色的成员身份。

强密码 确保对于所有的 SQL Server 帐户使用复杂密码。

跨数据库所有权链接 如果系统不使用跨数据库所有权链接，请禁用它。

Xp_cmdshell 在默认情况下，只有 sysadmin 角色的成员能够执行 xp_cmdshell。不应更改此默认设置。
不要将执行 xp_cmdshell 的权限授予 sysadmin 角色成员以外的用户。

加密 安装证书以启用 SSL 连接。
证书应该使用服务器的完全限定的 DNS 名称。
在 SQL Server 服务帐户下使用 EFS 加密数据库文件。
如果应用程序要求加密数据，请考虑使用诸如 Protegrity 和 Application Security Inc. 之类的供应商的产品。

角色和组 将用户汇集到 SQL Server 角色或 Windows 组中以简化权限管理。

权限 绝对不要向 public 数据库角色授予权限。

分布式查询 在支持分布式查询的环境中设置 SQL Server 时，使用链接服务器（而不要使用远程服务器）。
仅将链接服务器的访问权限授予那些需要它的登录。
对于除 sysadmin 固定服务器角色的成员以外的所有用户，禁止对除 SQL OLE DB 以外的所有提供程序进行特殊 (ad hoc) 数据访问。
只允许对受信任的提供程序进行特殊数据访问。

来宾帐户 不要启用来宾帐户。

服务帐户 如果需要更改与 SQL Server 服务相关联的帐户，请使用 SQL Server 企业管理器。
如果更改多个服务，则必须使用企业管理器将所做的更改分别应用于每个服务。

建议的定期管理过程
Microsoft 基准安全分析器 (MBSA) 将 MBSA 添加到每周维护计划中，并按照计划中的任何安全建议操作。

扫描登录 定期扫描帐户，查看是否有使用空密码的帐户，并删除使用空密码的帐户或为它们指派强密码。
删除不再使用的帐户。

枚举固定角色成员成份 定期扫描固定服务器和数据库角色，确保只将成员身份授予受信任用户。

启动过程 验证已被标记为 AutoStart 的存储过程是否安全。

登录到用户的映射 确保数据库用户与服务器级登录之间的映射正确无误。
定期运行带有 report 选项的 sp_change_users_login，确保映射按预期方式工作。

直接更新目录 不允许直接更新目录。

跨数据库所有权链接 使用 sp_dboption 枚举和验证启用了跨数据库所有权链接的数据库。

修补实例的最佳做法
实例检测和枚举 保留您所负责的 SQL Server 的所有版本和语言清单。
在清单中包括 MSDE 实例。
使用 SQL Scan 和 SQL Check（可从 Microsoft 网站获取），扫描域中的 SQL Server 实例。

公告 订阅 Microsoft 安全公告。

修补应用程序 维护与生产系统的配置相匹配并且可用于测试新修补程序的测试系统。
在将修补程序应用于生产系统之前，认真测试修补程序。
考虑修补不需要太多测试的开发系统。

开发人员检查表

除上面的所有项目外，开发人员应将下列内容视为最佳做法。

常规
有效地使用所有权链接 在单个数据库中使用所有权链接来简化权限管理。
尽可能避免使用跨数据库所有权链接。
如果必须使用跨数据库所有权链接，请确保这两个数据库总是部署为单个管理单元。

使用角色来简化权限管理和所有权 向角色指派权限，而不要直接向用户指派权限。
如果希望在删除拥有对象的用户时不必更改应用程序，则可以让角色拥有对象，而不是让用户直接拥有对象。

打开加密功能（SSL 或 IPSEC） 对服务器启用加密连接，并考虑只允许建立加密连接。
如果允许使用 SQL Server 身份验证，则强烈建议您使用 IPSec 加密网络层或者使用 SSL 加密会话。

不将 SQL Server 错误传播回到用户 您的应用程序不应该将 SQL Server 错误返回给最终用户，而是将它们记录到日志中或者将它们传输给系统管理员。

防止受到 SQL 插入攻击 通过先验证所有的用户输入，然后将其传输到服务器，防止受到 SQL 插入攻击。
只允许具有最小特权的帐户将用户输入的内容发送到服务器，从而限制可能受损的范围。
使用必需的最小特权运行 SQL Server 本身。

多层选项
同一个域/受信任域（完整的 Windows 身份验证） 如果应用程序服务器和数据库服务器位于同一个域中或者位于受信任域中，则应使用 Windows 身份验证，并配置"完全提供"功能（所有客户端上下文都与 SQL Server 建立通道连接）。这样，可以审核访问 SQL Server 的所有用户，允许执行 Windows 安全策略，并且无需将凭据存储在中间层。在该方案中，客户端连接到应用程序服务器，应用程序服务器从而模拟客户端并连接到 SQL Server。

应用程序服务器上的每个用户都必须在数据库服务器上有一个有效的 Windows 登录，且必须启用委派功能。

该方案中进行交互的所有系统（包括域控制器）都必须运行 Windows 2000 或更高版本。

用来运行应用程序的帐户必须能够委派其他帐户（即，必须针对此帐户打开 Active Directory 用户帐户选项"帐户可委派其他帐户"）。

客户端帐户必须能够被委派（确保取消选中 Active Directory 用户帐户选项"敏感帐户，不能被委派"）。

应用程序服务必须有一个有效的服务主体名称 (SPN)。
注意 如果安全计划要求最小化用户对数据库服务器的访问权限或者企业策略禁止委派，建议不要在跨数据库或 Internet 级别的安装中使用"完全提供"功能。

混合方案（部分 Windows 身份验证） 如果在面向 Internet 的层中，并非每个用户都有一个单独的 Windows 域帐户，则建议将身份验证分成几个阶段。在验证用户身份的外层，如果不加密整个会话，至少应该使用 SSL 加密凭据。应该使用 Windows 身份验证连接到数据库服务器，并在特权很小、只具有执行数据库服务器功能所必需的权限的单独安全上下文中转发事务信息。这样，可以将中间层有效地作为服务器和 Internet 之间的附加防御层。

注意 建议不要在中间层和 SQL Server 之间使用 SQL Server 身份验证，因为使用 SQL Server 身份验证需要存储凭据。如果必须在中间层和 SQL Server 之间使用 SQL Server 身份验证，那么应该创建几个帐户，并让它们分别具有与不同种类的用户对应的不同级别的特权。这要求您向中间层中添加逻辑，以便按照所需的特权级别分配连接。

不同的非信任域或没有域（不进行 Windows 身份验证） 如果不能在各层之间使用 Windows 身份验证，则应要求对登录序列进行 SSL 加密。最好加密整个会话。

还应使用 DPAPI 加密必须存储的凭据。

应将加密凭据存储在用 ACL 保护的注册表项中。

软件供应商检查表

除上面的所有项目外，下列安全开发做法也已被证明对于提高各种开发环境中代码的质量及安全性非常有用。

安全过程
了解各种安全问题 确保开发小组的成员了解主要的安全问题：当前存在的威胁、安全趋势、更改安全环境以及受到攻击的情形。

要求对所有开发人员和测试人员进行相关的安全培训。

增强对跨站点脚本、缓冲区溢出、SQL 插入和危险的 API 等问题的认识。

确定对产品构成威胁的各种具体类型，例如拒绝服务、特权升级、欺骗、篡改数据、信息泄漏和丢弃。

针对每个组件逐一分析产品受到的安全威胁。

基于产品构建安全威胁检查表。

在产品开发周期的每个阶段（从设计到测试）增加安全审核步骤。

安装 MSDE 如果将 MSDE 与应用程序一起分发，则应遵守下列附加准则：

使用"Windows 安全模式"作为默认设置安装 MSDE。

绝对不要使用空的 sa 密码。

在向客户分发 MSDE 时，应使用 Microsoft 提供的安装程序，而不要使用合并模块。

在安装将只作为本地数据存储运行的 MSDE 实例时，应该禁用服务器网络库。

如果产品中包括 MSDE，则应让您的客户知道这一点。他们将来可能需要安装或接受 MSDE 特定的软件更新程序。

MSDE 在默认情况下安装 SQL Server 代理，但是将服务启动类型保持为"手动"。如果应用程序不使用 SQL Server 代理，则应将此设置更改为"禁用"。在产品文档中包括安全性最佳做法信息。

附录：查找详细信息

建议参阅的书目：

Inside Microsoft&reg; SQL Server™ 2000（Microsoft&reg; SQL Server™2000 内幕），作者：Kalen Delaney。版权所有 2000，Microsoft Press。ISBN：0-7356-0998-5。
Writing Secure Code, Second Edition（编写安全代码，第二版），作者：Michael Howard 和 David LeBlanc。
http://go.microsoft.com/fwlink/?LinkId=16316
本书回顾了在对组件/应用程序进行设计、编码和测试时最常遇见的安全缺陷，它是非常有用的培训资源。本书包含安全性最佳做法和检查表。本书还提供了在设计安全应用程序、编写可抵御反复攻击的可靠代码以及测试应用程序是否存在安全缺陷时使用的策略。

Hacking Exposed Windows 2000（Windows 2000 面临的攻击威胁），作者：Joel Scambray 和 Stuart McClure。
本书收集了黑客的攻击途径。其中详细讲述了如何闯入 Windows 2000 计算机，从而增强如何防止类似攻击的意识。本书中还有一整节专门介绍了 SQL Server 以及如何使用它来攻击整个系统。

Quote:

MC FORUM 2003(V2.0製作中。。。)

2003-6-25 12:20
Jay
落伍者

积分 4620
发贴 4619
注册 2002-9-28
来自 原產臺北 出口巴西 轉銷大陸
Designing Secure Web-Based Applications for Microsoft&reg; Windows&reg; 2000（设计面向 Microsoft&reg; Windows&reg; 2000 的基于 Web 的安全应用程序），作者：Michael Howard。
http://go.microsoft.com/fwlink/?LinkId=15415
本书是帮助您理解 Microsoft Windows 2000、Internet Explorer、Internet 信息服务、SQL Server 和 COM+ 安全概念的坚实基础。它介绍在设计不同种类和级别安全性的软件时需要考虑的关键事项，并展示被隔离的安全性"孤岛"如何进行交互。本书还介绍了核心安全问题（如风险分析、威胁、身份验证、授权和隐私），并说明了如何通过对环境和应用程序应用适当的安全性来降低风险。经理、开发人员和测试人员均可以利用本书中的知识，从安全角度查看组件、进行威胁分析以及采取适当的响应措施（增强代码/设计的安全性并相应地改进测试套件）。

Building Secure ASP.NET Applications（构建安全的 ASP.NET 应用程序），作者：J.D.Meier 等。
http://go.microsoft.com/fwlink/?LinkId=15416
本指南介绍了一些针对特定情形的实用方法，使用这些方法可以构建面向 Windows 2000 和 .NET Framework 1.0 的安全的 ASP.NET 应用程序。本指南重点介绍了在分布式 .NET Web 应用程序各层内及层与层之间进行身份验证、授权和安全通信的关键要素。

Firewalls and Internet Security, second edition（防火墙和 Internet 安全，第二版），作者：William R. Cheswick、Steven M. Bellovin 和 Aviel D. Rubin。Addison-Wesley，2003。
这是对 Internet 安全的权威介绍。强烈建议您参考本书。

建议使用的工具、白皮书和演示文稿

http://go.microsoft.com/fwlink/?LinkId=15417
此站点汇集了指向 SQL Server 安全白皮书、企业最佳做法、安全公告等的大量链接。

http://go.microsoft.com/fwlink/?LinkId=15419
The Microsoft Baseline Security Analyzer Tool（Microsoft 基准安全分析器工具）。此工具可帮助分析系统的安全性。建议管理员定期运行此工具。此工具执行 SQL Server 特定的一些检查操作。

http://go.microsoft.com/fwlink/?LinkId=15422
SQL Server Critical Update Wizard（SQL Server 关键更新程序向导。

Microsoft SQL Server 和安全站点

http://go.microsoft.com/fwlink/?LinkId=15423
Microsoft 网站中专门介绍安全性的区域。

http://go.microsoft.com/fwlink/?LinkId=15424
主要的 SQL Server 站点，通过其中的链接可下载最新的 Service Pack、最新的公告和其他资源。

http://go.microsoft.com/fwlink/?LinkId=15425
TechNet 资源站点

http://go.microsoft.com/fwlink/?LinkId=15426
MSDN 资源站点

白皮书

http://go.microsoft.com/fwlink/?LinkId=15428
SQL Server 开发人员中心。包含最近的技术白皮书和下载程序。

http://go.microsoft.com/fwlink/?LinkId=16263
上述白皮书是在最初发行 SQL Server 2000 时编写的，它是本白皮书中各部分内容的基础。

http://go.microsoft.com/fwlink/?LinkId=15429
SQL Server 安全相关内容的许多链接。

Quote:

MC FORUM 2003(V2.0製作中。。。)

2003-6-25 12:21
飞天虾
落伍者

积分 5259
发贴 5309
注册 2002-9-16
来自 辽宁-鞍山
收藏了先 有时间慢慢学习

玉米 70/个 CN 200/个 熟人先注后款 网络实名：350/年 空间优惠可以试用 http://www.vlike.net

玉米买卖交易论坛
2003-6-25 12:24
Jay
落伍者

积分 4620
发贴 4619
注册 2002-9-28
来自 原產臺北 出口巴西 轉銷大陸
哦。。誰加的精華？？？謝謝。。。

看來以後要多發技術帖，不要亂灌水了。。。

Quote:

MC FORUM 2003(V2.0製作中。。。)

2003-6-25 12:27
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20

Quote:
Originally posted by Jay at 2003-6-25 12:27 PM:
哦。。誰加的精華？？？謝謝。。。

看來以後要多發技術帖，不要亂灌水了。。。

废话，快来拍我马屁

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-6-25 12:28
Jay
落伍者

积分 4620
发贴 4619
注册 2002-9-28
来自 原產臺北 出口巴西 轉銷大陸

Quote:
Originally posted by 西瓜 at 2003-6-25 12:28:

废话，快来拍我马屁

你屬馬的？？

加分呀。。。

Quote:

MC FORUM 2003(V2.0製作中。。。)

2003-6-25 12:29
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20

Quote:
Originally posted by Jay at 2003-6-25 12:29 PM:

你屬馬的？？

加分呀。。。

都给你精华了，，你还想怎么样~~

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-6-25 12:30
问情剑
落伍者

积分 1242
发贴 1336
注册 2001-10-21
来自 忆风中文小站
精华够精华

可我用不起SQL！

忆风中文小站
2003-6-25 12:31
Jay
落伍者

积分 4620
发贴 4619
注册 2002-9-28
来自 原產臺北 出口巴西 轉銷大陸

Quote:
Originally posted by 西瓜 at 2003-6-25 12:30:

都给你精华了，，你还想怎么样~~

好吧。給你面子，切一刀。。

Quote:

MC FORUM 2003(V2.0製作中。。。)

2003-6-25 12:31

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.030027 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 利用数据库来破解md5[转] - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 利用数据库来破解md5[转]

<< [1] [2] >>
作者:
标题: 利用数据库来破解md5[转] 上一主题 | 下一主题
那个那个谁
落伍者

积分 10995
发贴 11017
注册 2002-4-15
利用数据库来破解md5[转]

破解MD5 KBUG（原作）
为什么密码位数短的MD5不安全？

一个长度为4的纯小写字母生成的密码在数据库的帮助下可以在0.005s内被破解。这个时间还包括了连接数据库的时间，运行的环境是在我900MHZ的个人PC上。

注意，我们要讨论的是一种破解密码的思维，而不提供一种具体的方法。如果你的希望和我们不一致，那么后边将不是你所需要的内容了。

前几天看MD5的资料时，我突然冒出个想法：

如果借助数据库的海量存储和检索优势，破解较短长度的单向MD5应该不是很大的问题。

首先，我们假设密码长度为6的话（这是很多论坛采用的长度），如果密码都由小写字母构成的话，这个数据库要存储266条数据，每条数据的长度为6＋40＝46字节，那么这个数据库的大小是14210125696byte，大约为14G。对于一个大型数据库来说这样的数据量并不大。

为了使我的计算机可以比较快的实现我的想法，我假设密码长度为四位小写字母了。下边就让我们来看看过程。

我运行的环境：

Windows XP Pro，Apache1.3，MySql 3.23.49，PHP 4.0.6。

主频900MHZ，内存256M。

首先我在Mysql里建立了一个md库和一个md表用于存放密码和加密后的MD5字符。

表的结构如下：

然后通过程序来向里边添加数据：

Code: [Copy to clipboard]
<?php

// Connecting, selecting database

$link = mysql_connect("localhost", "root", "") or die("Could not connect");

print "Connected successfully<br>";

mysql_select_db("md") or die("Could not select database");

function getmicrotime()

{

list($usec, $sec) = explode(" ",microtime());

return ((float)$usec + (float)$sec);

}

$time_start = getmicrotime();

set_time_limit ( 0 );

echo '<html><head>

<meta http-equiv="Content-Type" content="text/html; charset=gb2312">

<title>md5</title>

<style>

<!--

html { font-family: Verdana; font-size: 9pt }

-->

</style>

</head>

<body>';

// create the password

for ($i = 97 ; $i < 123 ; $i++ )

{

for( $j = 97 ; $j < 123 ; $j++ )

{

for ( $k = 97 ; $k < 123 ; $k++ )

{

for( $l = 97 ; $l < 123 ; $l++ )

{

$name = chr($i).chr($j).chr($k).chr($l);

echo $name.' '.$md.'<br>';

$md = md5( $name );

mysql_query("INSERT INTO `md` (`pass`, `passmd`) VALUES ('$name', '$md');",$link);

}

}

}

}

$time_end = getmicrotime();

$time = $time_end - $time_start;

echo '<center>Runtime: '.$time.' seconds</center></font>';

echo '</body></html>';

?>

通过运行这个程序构建数据用掉了我大概五分钟的时间。

然后，一个很简单的脚本就可以实现密码的破解查询了。

Code: [Copy to clipboard]
<?php

$link = mysql_connect("localhost", "root", "") or die("Could not connect");

print "Connected successfully<br>";

mysql_select_db("md") or die("Could not select database");

function getmicrotime()

{

list($usec, $sec) = explode(" ",microtime());

return ((float)$usec + (float)$sec);

}

echo '<html><head>

<meta http-equiv="Content-Type" content="text/html; charset=gb2312">

<title>md5</title>

<style>

<!--

html { font-family: Verdana; font-size: 9pt }

INPUT {

BORDER-RIGHT: #000000 1px solid; BORDER-TOP: #000000 1px solid; BORDER-LEFT: #000000 1px solid; BORDER-BOTTOM: #000000 1px solid; FONT-FAMILY: Verdana

}

-->

</style>

</head>

<body>';

$time_start = getmicrotime();

set_time_limit ( 0 );

if ( 2 == $step )

{

$result = mysql_query( "SELECT * FROM `md` WHERE `passmd`='$inpass' LIMIT 0, 30 " , $link );

while ($row = mysql_fetch_array($result))

{

echo '<p>The password is <b>'.$row[0].'</b><p>';

echo '<a href="index.php?">click here to goback</a>';

}

}else

{

echo

'

<form method="post" >

<input name="inpass"><INPUT TYPE="hidden" name="step" value="2">

<INPUT TYPE="submit">

</form>

';

}

$time_end = getmicrotime();

$time = $time_end - $time_start;

echo '<center>Runtime: '.$time.' seconds</center></font>';

echo '</body></html>';

?>

这样，很容易的就实现了密码破解。

下边是演示：

查询页面

查询结果

如果数据库足够大的话，破解MD5应该就不是什么困难的事情了，而且真正使用的密码并不是像理论上那么多，人们总是很习惯的使用简单好记的密码。在时间上，采用分布式计算是个好的选择。一旦这样的一个公用数据库建立起来，MD5将不再安全。一个好的办法是加长你的密码，长于13位的密码是比较有保障的。

PS:看不清楚的人可以到:
http://www.csdn.net/develop/Read_Article.asp?Id=19029
去观看!
2003-6-25 22:17
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20
前几天有人发了

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-6-25 22:17
Jay
落伍者

积分 4620
发贴 4619
注册 2002-9-28
来自 原產臺北 出口巴西 轉銷大陸
發過了。。。不錯。。。

Quote:

MC FORUM 2003(V2.0製作中。。。)

2003-6-25 22:21
那个那个谁
落伍者

积分 10995
发贴 11017
注册 2002-4-15
还打算进金华~
2003-6-25 22:22
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20

Quote:
Originally posted by 那个那个谁 at 2003-6-25 10:22 PM:
还打算进金华~

不给

搞破坏的不给

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-6-25 22:23
那个那个谁
落伍者

积分 10995
发贴 11017
注册 2002-4-15

Quote:
Originally posted by 西瓜 at 2003-6-25 22:23:

不给

搞破坏的不给

没有狼，羊也不会进步

[ Last edited by 那个那个谁 on 2003-6-25 at 10:25 PM ]
2003-6-25 22:24
蚂蚁
落伍者

积分 415
发贴 415
注册 2002-7-20

Quote:
Originally posted by 那个那个谁 at 2003-6-25 10:24 PM:

没有狼，羊也不会进步

[ Last edited by 那个那个谁 on 2003-6-25 at 10:25 PM ]

的确是这样的。支持进精华！！！

硬盘版游戏、电影、等下载资源，完全免费。>>>>http://3.126.com/
2003-6-25 22:27
被风吹倒的男子
强行加入万贴俱乐部的会员

积分 4428
发贴 4443
注册 2002-6-17
来自 帅哥的家乡
好文章啊好文章！！！！！！！！！

Quote:

论坛型主机（支持jsp/php/asp）：
基本型： 100m/50人在线/250元
专业A： 100m/100人在线/500元
专业B： 300m/150人在线/1100元
专业C： 500m/300人在线/1800元

2003-6-25 22:49
nbinfo
落伍者

积分 6677
发贴 6489
注册 2002-8-7
来自 CHINA 中国 SEX
那ACCESS下的加密密码怎么破

本站出售 音乐程序 分2种ACCESS版本跟MSSQL版本，包括35000首歌曲文件
联系QQ ：19755866 805570
演示地址http://www.nbsky.net/
主机租用托管
2003-6-25 23:00
被风吹倒的男子
强行加入万贴俱乐部的会员

积分 4428
发贴 4443
注册 2002-6-17
来自 帅哥的家乡

Quote:
Originally posted by nbinfo at 2003-6-25 11:00 PM:
那ACCESS下的加密密码怎么破

我---倒----了

Quote:

论坛型主机（支持jsp/php/asp）：
基本型： 100m/50人在线/250元
专业A： 100m/100人在线/500元
专业B： 300m/150人在线/1100元
专业C： 500m/300人在线/1800元

2003-6-25 23:03
酷雨
落伍者

积分 1252
发贴 1252
注册 2002-8-6
动网的怎么破？

感谢 红孩儿↑输狂了
http://www.fqiu.com/
2003-6-25 23:03
Arvan
落伍者

积分 1380
发贴 1202
注册 2002-10-28
md5是并肯定是32位的,作者不会连这也搞不清楚吧.还varchar(40)?

我坐在楼顶的边沿上抽烟，一根接一
根，好像要一直抽到永远，就像那深邃的
天空，没有尽头......
2003-6-25 23:07
梦
杜鹃滴血

积分 2948
发贴 2698
注册 2002-5-6
来自 古墓苍狼
有屁用
关键你没字典
你机器速度也不快
就算你字典好。我有8位以上。数字和英文混在一起。再加点其他符号。你慢慢破吧。
MD5本身是不错的东西。你穷搞
什么加密都不行。

www.wps2000.net重新开放
http://www.wps2000.net/
PHP论坛：http://forum.wps2000.net/Forum.php?ForumID=28
2003-6-25 23:12
Dialog
落伍者

积分 767
发贴 723
注册 2003-3-19
问题是你有必要完全是MD5的吗？
我比如MD5后再加个注册时间。不就好了吗？

落伍，where the web begins!
2003-6-25 23:13
被风吹倒的男子
强行加入万贴俱乐部的会员

积分 4428
发贴 4443
注册 2002-6-17
来自 帅哥的家乡

Quote:
Originally posted by 天行 at 2003-6-25 11:12 PM:
有屁用
关键你没字典

作者提到如果可以建立一个网络数据库的话~………………

Quote:

论坛型主机（支持jsp/php/asp）：
基本型： 100m/50人在线/250元
专业A： 100m/100人在线/500元
专业B： 300m/150人在线/1100元
专业C： 500m/300人在线/1800元

2003-6-25 23:14
<< [1] [2] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.033347 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - SQL语法参考手册 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » SQL语法参考手册

作者:
标题: SQL语法参考手册 上一主题 | 下一主题
vku
落伍者

积分 1846
发贴 1942
注册 2002-10-14
SQL语法参考手册

１、建表格：
CREATE TABLE table_name(
column1 DATATYPE [NOT NULL] [NOT NULL PRIMARY KEY],
column2 DATATYPE [NOT NULL],
...）
说明：
DATATYPE --是资料的格式，详见表。
NUT NULL --可不可以允许资料有空的（尚未有资料填入）。
PRIMARY KEY --是本表的主键。

２、更改表格
ALTER TABLE table_name
ADD COLUMN column_name DATATYPE
说明：增加一个栏位（没有删除某个栏位的语法。
ALTER TABLE table_name
ADD PRIMARY KEY (column_name)
说明：更改表得的定义把某个栏位设为主键。
ALTER TABLE table_name
DROP PRIMARY KEY (column_name)
说明：把主键的定义删除。

３、建立索引
CREATE INDEX index_name ON table_name (column_name)
说明：对某个表格的栏位建立索引以增加查询时的速度。

４、删除
DROP table_name
DROP index_name

二、的资料形态 DATATYPEs
smallint
16 位元的整数。
interger
32 位元的整数。
decimal(p,s)
p 精确值和 s 大小的十进位整数，精确值p是指全部有几个数(digits)大小值，s是指小数
点後有几位数。如果没有特别指定，则系统会设为 p=5; s=0 。
float
32位元的实数。
double
64位元的实数。
char(n)
n 长度的字串，n不能超过 254。
varchar(n)
长度不固定且其最大长度为 n 的字串，n不能超过 4000。
graphic(n)
和 char(n) 一样，不过其单位是两个字元 double-bytes， n不能超过127。这个形态是为
了支援两个字元长度的字体，例如中文字。
vargraphic(n)
可变长度且其最大长度为 n 的双字元字串，n不能超过 2000。
date
包含了 年份、月份、日期。
time
包含了 小时、分钟、秒。
timestamp
包含了 年、月、日、时、分、秒、千分之一秒。

三、资料操作 ＤＭＬ （Data Manipulation Language)
资料定义好之後接下来的就是资料的操作。资料的操作不外乎增加资料（insert)、查询资料（query）、更改资料（update) 、删除资料（delete）四种模式，以下分 别介绍他们的语法：

１、增加资料：
INSERT INTO table_name (column1,column2,...)
VALUES ( value1,value2, ...)
说明：
1.若没有指定column 系统则会按表格内的栏位顺序填入资料。
2.栏位的资料形态和所填入的资料必须吻合。
3.table_name 也可以是景观 view_name。

INSERT INTO table_name (column1,column2,...)
SELECT columnx,columny,... FROM another_table
说明：也可以经过一个子查询（subquery）把别的表格的资料填入。

２、查询资料：
基本查询
SELECT column1,columns2,...
FROM table_name
说明：把table_name 的特定栏位资料全部列出来
SELECT *
FROM table_name
WHERE column1 = xxx
[AND column2 > yyy] [OR column3 <> zzz]
说明：
1.'*'表示全部的栏位都列出来。
2.WHERE 之後是接条件式，把符合条件的资料列出来。

SELECT column1,column2
FROM table_name
ORDER BY column2 [DESC]
说明：ORDER BY 是指定以某个栏位做排序，[DESC]是指从大到小排列，若没有指明，则是从小到大
排列

组合查询
组合查询是指所查询得资料来源并不只有单一的表格，而是联合一个以上的
表格才能够得到结果的。
SELECT *
FROM table1,table2
WHERE table1.colum1=table2.column1
说明：
1.查询两个表格中其中 column1 值相同的资料。
2.当然两个表格相互比较的栏位，其资料形态必须相同。
3.一个复杂的查询其动用到的表格可能会很多个。

整合性的查询：
SELECT COUNT (*)
FROM table_name
WHERE column_name = xxx
说明：
查询符合条件的资料共有几笔。
SELECT SUM(column1)
FROM table_name
说明：
1.计算出总和，所选的栏位必须是可数的数字形态。
2.除此以外还有 AVG() 是计算平均、MAX()、MIN()计算最大最小值的整合性查询。
SELECT column1,AVG(column2)
FROM table_name
GROUP BY column1
HAVING AVG(column2) > xxx
说明：
1.GROUP BY: 以column1 为一组计算 column2 的平均值必须和 AVG、SUM等整合性查询的关键字
一起使用。
2.HAVING : 必须和 GROUP BY 一起使用作为整合性的限制。

复合性的查询
SELECT *
FROM table_name1
WHERE EXISTS (
SELECT *
FROM table_name2
WHERE conditions )
说明：
1.WHERE 的 conditions 可以是另外一个的 query。
2.EXISTS 在此是指存在与否。
SELECT *
FROM table_name1
WHERE column1 IN (
SELECT column1
FROM table_name2
WHERE conditions )
说明：
1. IN 後面接的是一个集合，表示column1 存在集合里面。
2. SELECT 出来的资料形态必须符合 column1。

其他查询
SELECT *
FROM table_name1
WHERE column1 LIKE 'x%'
说明：LIKE 必须和後面的'x%' 相呼应表示以 x为开头的字串。
SELECT *
FROM table_name1
WHERE column1 IN ('xxx','yyy',..)
说明：IN 後面接的是一个集合，表示column1 存在集合里面。
SELECT *
FROM table_name1
WHERE column1 BETWEEN xx AND yy
说明：BETWEEN 表示 column1 的值介於 xx 和 yy 之间。

３、更改资料：
UPDATE table_name
SET column1='xxx'
WHERE conditoins
说明：
1.更改某个栏位设定其值为'xxx'。
2.conditions 是所要符合的条件、若没有 WHERE 则整个 table 的那个栏位都会全部被更改。

４、删除资料：
DELETE FROM table_name
WHERE conditions
说明：删除符合条件的资料。

说明：关于WHERE条件后面如果包含有日期的比较，不同数据库有不同的表达式。具体如下：
(1)如果是ACCESS数据库，则为：WHERE mydate>#2000-01-01#
(2)如果是ORACLE数据库，则为：WHERE mydate>cast('2000-01-01' as date)
或：WHERE mydate>to_date('2000-01-01','yyyy-mm-dd')
在Delphi中写成：
thedate='2000-01-01';
query1.SQL.add('select * from abc where mydate>cast('+''''+thedate+''''+' as date)');

如果比较日期时间型，则为：
WHERE mydatetime>to_date('2000-01-01 10:00:01','yyyy-mm-dd hh24:mi:ss')

来自：网络东西

网络东西：网络无限东西最好 http://VKU.126.com
2003-7-9 13:12
niba
落伍者

积分 3508
发贴 3526
注册 2002-6-13
小乌,看看大乌吧

http://kusite.myetang.com/show/mysql-doc/manual_toc.html

S1.似融网络www.sron.net
S2.似融网络niba.vipcn.com
2003-7-9 13:13
魔力闪客
落伍者

积分 3393
发贴 3316
注册 2002-7-12
打包吧

仿榕树下文章系统 完成度80% 演示
同学录MX1.0 完成度 90% 演示
[swf=468,60]http://www2.sti.com.cn/demo/sw/jv.swf[/swf]
2003-7-9 13:14

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.024612 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - !!!!!!解决 Mysql 占用系统资源过大的问题!!!! - powered by Discuz!

落伍者论坛 » 网站建设专栏 » !!!!!!解决 Mysql 占用系统资源过大的问题!!!!

作者:
标题: !!!!!!解决 Mysql 占用系统资源过大的问题!!!! 上一主题 | 下一主题
dreamyboy
落伍者

积分 11168
发贴 11656
注册 2002-10-10
来自 飘逸网络
!!!!!!解决 Mysql 占用系统资源过大的问题!!!!

在 linux 下，经常出现的情况就是使用 VBB 这种论坛系统时，出现缓慢，mysql 假死状态，sleep进程过多等等现像。导致几十个用户，就把系统搞定了。
其实这是 mysql 配置上的问题， 默认的 linux 中， mysql 的配置是 my-large.cnf 配置，该配置适合大型服务器。有高内存，比如2G，4G内存的，适合使用，而一般512M内存 的就不行了。它会占用512M内存来保存系统 mysql 的进程，这些进程长期堆质，并不释放，导致系统缓慢。所以，把配置改变成为 my-small.cnf ，小型配置就可以了。它的配置如下：

# Example mysql config file for small systems.
#
# This is for a system with little memory (<= 64M) where MySQL is only used
# from time to time and it's important that the mysqld deamon
# doesn't use much resources.
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /var/lib/mysql) or
# ~/.my.cnf to set user-specific options.
#
# One can in this file use all long options that the program supports.
# If you want to know which options a program support, run the program
# with --help option.

# The following options will be passed to all MySQL clients
[client]
#password = 你的密码
port = 3306
socket = /tmp/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port = 3306
socket = /tmp/mysql.sock
skip-locking
set-variable = key_buffer=16K
set-variable = max_allowed_packet=1M
set-variable = thread_stack=64K
set-variable = table_cache=4
set-variable = sort_buffer=64K
set-variable = net_buffer_length=2K
server-id = 1

# Uncomment the following if you want to log updates
#log-bin

# Uncomment the following if you are NOT using BDB tables
#skip-bdb

# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /var/lib/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /var/lib/mysql/
#innodb_log_arch_dir = /var/lib/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50

[mysqldump]
quick
set-variable = max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
set-variable = key_buffer=8M
set-variable = sort_buffer=8M

[myisamchk]
set-variable = key_buffer=8M
set-variable = sort_buffer=8M

[mysqlhotcopy]
interactive-timeout

以上配置足够 你的系统高速运行 mysql 了，sleep的进程，很快就被回收，不占资源，这非常适合小型服务器。一般个人托管的服务器也很适合。

. . . . . . . . . . . . . . . . . .
本站高速LINUX主机！全面支持php+mysq！l详细请加我QQ：691932谈，或者MSN：go8go8go@hotmail.com
虚拟主机免费试用3天！！来这里购买的一律优惠！论坛空
间演示：
http://www.go8go.com/vbb或者：http://support.go8go.com/vbb/
LINUX虚拟主机一率买一年送一个月，买两年送三个月，加送5个
10m的信箱，免费绑定域名。
购买空间请联系QQ：691932,拒绝闲聊！

[ Last edited by dreamyboy on 2003-7-14 at 03:29 PM ]

代理高速LINUX虚拟主机业务。联系
QQ：691932，演示：http://www.go8go.com/，
买一年送一个月，两年送三个月！MSN：
我的MSN：go8go8go@hotmail.com,ICQ:195225878
2003-7-14 15:19
小林
o○万帖俱乐部老八^_^ ○ o

积分 11252
发贴 11181
注册 2002-10-29
来自 『新都人.COM』
实验一下

万维主机-Sunking

『统一行动，开始删贴！』
2003-7-14 16:34
让爱做主
又脏又丑农村户口

积分 17166
发贴 17150
注册 2002-7-23
来自 摸摸镇捏捏村
嗯

Quote:
国际玉米 70元/年 国内玉米 200元/年 各类虚拟主机特价出售
至强型论坛空间 ASP+ACCESS 可选SQL 演示：http://bbs.jetdown.com/ 业务联系QQ：365285

2003-7-14 16:34
dreamyboy
落伍者

积分 11168
发贴 11656
注册 2002-10-10
来自 飘逸网络
精华了？//

嘿嘿

我才一下午没有看呢

可惜看的只有两个人。

代理高速LINUX虚拟主机业务。联系
QQ：691932，演示：http://www.go8go.com/，
买一年送一个月，两年送三个月！MSN：
我的MSN：go8go8go@hotmail.com,ICQ:195225878
2003-7-14 17:50
小林
o○万帖俱乐部老八^_^ ○ o

积分 11252
发贴 11181
注册 2002-10-29
来自 『新都人.COM』

Quote:
Originally posted by dreamyboy at 2003-7-14 17:50:
精华了？//

嘿嘿

我才一下午没有看呢

可惜看的只有两个人。

我加的

万维主机-Sunking

『统一行动，开始删贴！』
2003-7-14 17:52
dreamyboy
落伍者

积分 11168
发贴 11656
注册 2002-10-10
来自 飘逸网络

Quote:
Originally posted by 小林 at 2003-7-14 05:52 PM:

我加的

嘿嘿
谢了

我还有好多哟。

慢慢来了
一个星期发一个

代理高速LINUX虚拟主机业务。联系
QQ：691932，演示：http://www.go8go.com/，
买一年送一个月，两年送三个月！MSN：
我的MSN：go8go8go@hotmail.com,ICQ:195225878
2003-7-14 17:56
小林
o○万帖俱乐部老八^_^ ○ o

积分 11252
发贴 11181
注册 2002-10-29
来自 『新都人.COM』

Quote:
Originally posted by dreamyboy at 2003-7-14 17:56:

嘿嘿
谢了

我还有好多哟。

慢慢来了
一个星期发一个

打包给我

万维主机-Sunking

『统一行动，开始删贴！』
2003-7-14 18:03
dreamyboy
落伍者

积分 11168
发贴 11656
注册 2002-10-10
来自 飘逸网络

Quote:
Originally posted by 小林 at 2003-7-14 06:03 PM:

打包给我

我论坛有呢

等我有时间

我就选一个好点的来这里发。

太多了

个人感觉还可以。

可惜比较专业。没有什么人看。

代理高速LINUX虚拟主机业务。联系
QQ：691932，演示：http://www.go8go.com/，
买一年送一个月，两年送三个月！MSN：
我的MSN：go8go8go@hotmail.com,ICQ:195225878
2003-7-14 18:16
小林
o○万帖俱乐部老八^_^ ○ o

积分 11252
发贴 11181
注册 2002-10-29
来自 『新都人.COM』

Quote:
Originally posted by dreamyboy at 2003-7-14 18:16:

我论坛有呢

等我有时间

我就选一个好点的来这里发。

太多了

个人感觉还可以。

可惜比较专业。没有什么人看。

等有空去你坛子看看

万维主机-Sunking

『统一行动，开始删贴！』
2003-7-14 18:17
dreamyboy
落伍者

积分 11168
发贴 11656
注册 2002-10-10
来自 飘逸网络

Quote:
Originally posted by 小林 at 2003-7-14 06:17 PM:

等有空去你坛子看看

好。

代理高速LINUX虚拟主机业务。联系
QQ：691932，演示：http://www.go8go.com/，
买一年送一个月，两年送三个月！MSN：
我的MSN：go8go8go@hotmail.com,ICQ:195225878
2003-7-14 18:18

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.044373 second(s), 5 queries, Gzip enabled


无标题文档

HTML & JS & bbs 部分

1. 不错的代码 -- sAsE
2. 发个技术贴吧:点连接出现图片和进度跳的js -- 被风吹倒的男子
3. 常见网页加密方法和破解对策 -- XiEJEsEn
4. 恶意代码(网页病毒)[破解方法] -- 笨石头
5. IBM站一个网页到底包含了多少技术--看分析 -- 剑枫
6. 主流论坛程序一览 -- renxoyo


落伍者论坛 - 网站建设专栏 - 恶意代码(网页病毒)[破解方法] - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 恶意代码(网页病毒)[破解方法]

作者:
标题: 恶意代码(网页病毒)[破解方法] 上一主题 | 下一主题
笨石头
落伍者

积分 1240
发贴 1151
注册 2003-5-29
来自 心鱼网络
恶意代码(网页病毒)[破解方法]

恶意代码(网页病毒)
       专题综述

    如今的网络真是不太平，若您问上网者最讨厌和最害怕的是什么，莫过于所谓的恶意代码（又叫网页病毒）了。稍不留神逛到一个恶意网站上，就会发现自己的IE标题栏换成了其他网站的名字、默认主页成了他家的自留地、系统被改得乱七八糟……更恐怖的还有让你的系统禁止使用、格式化硬盘、安装一个木马在机器上等等。这样一来，岂不是网上哪也不敢去了？

    其实不然，只要我们掌握了一些对付此等恶意代码的"绝招"就可尽情地放心冲浪了，本专题我们就来探讨一下恶意代码的类型及其对付方法：

  恶意代码危害逐个析：

    1.禁止使用电脑

    危害程度：★★★★

    感染概率：＊＊

    现象描述：尽管网络流氓们用这一招的不多，但是一旦你中招了，后果真是不堪设想！浏览了含有这种恶意代码的网页其后果是："关闭系统"、"运行"、"注销"、注册表编辑器、DOS程序、运行任何程序被禁止，系统无法进入"实模式"、驱动器被隐藏。

    解决办法：一般来说上述八大现象你都遇上了的话，基本上系统就给"废"了，建议重装。

    2.格式化硬盘

    危害程度：★★★★★

    感染概率：＊

    现象描述：这类恶意代码的特征就是利用IE执行ActiveX的功能，让你无意中格式化自己的硬盘。只要你浏览了含有它的网页，浏览器就会弹出一个警告说"当前的页面含有不安全的ActiveX，可能会对你造成危害"，问你是否执行。如果你选择"是"的话，硬盘就会被快速格式化，因为格式化时窗口是最小化的，你可能根本就没注意，等发现时已悔之晚矣。

    解决办法：除非你知道自己是在做什么，否则不要随便回答"是"。该提示信息还可以被修改，如改成"Windows正在删除本机的临时文件，是否继续"，所以千万要注意！此外，将计算机上Format.com、Fdisk.exe、Del.exe、Deltree.exe等命令改名也是一个办法。

    3.下载运行木马程序

    危害程度：★★★

    感染概率：＊＊＊

    现象描述：在网页上浏览也会中木马？当然，由于IE5.0本身的漏洞，使这样的新式入侵手法成为可能，方法就是利用了微软的可以嵌入exe文件的eml文件的漏洞，将木马放在eml文件里，然后用一段恶意代码指向它。上网者浏览到该恶意网页，就会在不知不觉中下载了木马并执行，其间居然没有任何提示和警告！

    解决办法：第一个办法是升级您的IE5.0，IE5.0以上版本没这毛病；此外，安装金山毒霸、Norton等病毒防火墙，它会把网页木马当作病毒迅速查截杀。

    4.注册表的锁定

    危害程度：★★

    感染概率：＊＊＊

    现象描述：有时浏览了恶意网页后系统被修改，想要用Regedit更改时，却发现系统提示你没有权限运行该程序，然后让你联系管理员。晕了！动了我的东西还不让改，这是哪门子的道理！

    解决办法：能够修改注册表的又不止Regedit一个，找一个注册表编辑器，例如：Reghance。将注册表中的HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼System下的DWORD值"DisableRegistryTools"键值恢复为"0"，即可恢复注册表。

    5.默认主页修改

    危害程度：★★★

    感染概率：＊＊＊＊＊

    现象描述：一些网站为了提高自己的访问量和做广告宣传，利用IE的漏洞，将访问者的IE不由分说地进行修改。一般改掉你的起始页和默认主页，为了不让你改回去，甚至将IE选项中的默认主页按钮变为失效的灰色。不愧是网络流氓的一惯做风。

    解决办法：1.起始页的修改。展开注册表到HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Internet Explorer＼Main，在右半部分窗口中将"Start Page"的键值改为"about:blank"即可。同理，展开注册表到HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼Main，在右半部分窗口中将"Start Page"的键值改为"about:blank"即可。

    注意：有时进行了以上步骤后仍然没有生效，估计是有程序加载到了启动项的缘故，就算修改了，下次启动时也会自动运行程序，将上述设置改回来，解决方法如下：

    运行注册表编辑器Regedit.exe，然后依次展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Run主键，然后将下面的"registry.exe"子键（名字不固定）删除，最后删除硬盘里的同名可执行程序。退出注册编辑器，重新启动计算机，问题就解决了。

    2.默认主页的修改。运行注册表编辑器，展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Internet Explorer＼Main，将Default-Page-URL子键的键值中的那些恶意网站的网址改正，或者设置为IE的默认值。

    3.IE选项按钮失效。运行注册表编辑器，将HKEY_CURRENT_USER＼Software＼Policies＼Microsoft＼Internet Explorer＼Control Panel中的DWORD值"Settings"=dword:1、"Links"=dword:1、"SecAddSites"=dword:1全部改为"0"，将HKEY_USERS.DEFAULT＼Software＼Policies＼Microsoft＼Internet Explorer＼Control Panel下的DWORD值"homepage"的键值改为"0"。

    6.篡改IE标题栏

    危害程度：★

    感染概率：＊＊＊＊＊

    现象描述：在系统默认状态下，由应用程序本身来提供标题栏的信息。但是，有些网络流氓为了达到广告宣传的目的，将串值"Windows Title"下的键值改为其网站名或更多的广告信息，从而达到改变IE标题栏的目的。非要别人看他的东西，而且是通过非法的修改手段，除了"无耻"两个字，再没有其它形容词了。

    解决办法：展开注册表到HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Internet Explorer＼Main下，在右半部分窗口找到串值"Windows Title"，将该串值删除。重新启动计算机。

    7.篡改默认搜索引擎

    危害程度：★★★

    感染概率：＊

    现象描述：在IE浏览器的工具栏中有一个搜索引擎的工具按钮，可以实现网络搜索，被篡改后只要点击那个搜索工具按钮就会链接到网络注氓想要你去的网站。

    解决办法：运行注册表编辑器，依次展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Internet Explorer＼Search＼Customize＼Search和HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Internet Explorer＼Search＼SearchAssistant,将CustomizeSearch及SearchAssistant的键值改为某个搜索引擎的网址即可。

    8.IE右键修改

    危害程度：★★

    感染概率：＊＊＊

    现象描述：有的网络流氓为了宣传的目的，将你的右键弹出的功能菜单进行了修改，并且加入了一些乱七八糟的东西，甚至为了禁止你下载，将IE窗口中单击右键的功能都屏蔽掉。

    解决办法：1.右键菜单被修改。打开注册表编辑器，找到HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explore＼rMenuExt，删除相关的广告条文。

    2.右键功能失效。打开注册表编辑器，展开到HKEY_CURRENT_USER＼Software＼Policies＼Microsoft＼Internet Explorer＼Restrictions，将其DWORD值"NoBrowserContextMenu"的值改为0。

    9.篡改地址栏文字

    危害程度：★★

    感染概率：＊＊＊

    现象描述：中招者的IE地址栏下方出现一些莫名其妙的文字和图标，地址栏里的下拉框里也有大量的地址，并不是你以前访问过的。

    解决办法：1.地址栏下的文字。在HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼ToolBar下找到键值LinksFolderName，将其中的内容删去即可。

    2.地址栏中无用的地址。在HKEY_CURRENT_USER＼Software＼Microsoft＼Internet ExplorerType＼URLs中删除无用的键值即可。

    10.启动时弹出对话框

    危害程度：★★★

    感染概率：＊＊

    现象描述：1.系统启动时弹出对话框，通常是一些广告信息，例如欢迎访问某某网站等等。2.开机弹出网页，通常会弹出很多窗口，让你措手不及，恶毒一点的，可以重复弹出窗口直到死机。

    解决办法：1.弹出对话框。打开注册表编辑器，找到HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Winlogon主键，然后在右边窗口中找到"LegalNoticeCaption"和"LegalNoticeText"这两个字符串，删除这两个字符串就可以解决在启动时出现提示框的现象了。

    2.弹出网页。点击"开始-运行-输入msconfig",选择"启动"，把里面后缀为url、html、htm的网址文件都勾掉。

    11.IE窗口定时弹出

    危害程度：★★

    感染概率：＊＊

    现象描述：中招者的机器每隔一段时间就弹出IE窗口，地址指向网络注氓的个人主页。不晓得是不是网络流氓以为这样你就会经常光顾？

    解决办法：点击"开始-运行-输入msconfig",选择"启动"，把里面后缀为hta的都勾掉，重启。

笨石头，
在落伍的世界里寻找失落的灵魂！
注:富贵不是我的!
2003-6-7 08:41
hotworm
玩的就是心跳

积分 6453
发贴 6434
注册 2001-7-21
来自 旮旯
对帖子的名字编辑了一下，省得让人误会

需要字体 请点祝福吧　　　　　落伍者专用qq：29642474

跟我帖，有好处。但别灌水！
2003-6-7 08:47
笨石头
落伍者

积分 1240
发贴 1151
注册 2003-5-29
来自 心鱼网络
知道了
呵呵

笨石头，
在落伍的世界里寻找失落的灵魂！
注:富贵不是我的!
2003-6-7 08:49
则卷大饼
落伍者

积分 561
发贴 530
注册 2002-9-17
谢谢阿

不要怕！！我很温柔的
[imghttp://dplayer.xaonline.com/coolpic/dplay0019.gif/img]
2003-6-7 09:08
lazyboy
落伍者

积分 2313
发贴 2834
注册 2002-8-4
来自 南京
好
支持

Quote:
新影像传播：
http://www.51movie.net/
雷诺虚拟主机网：
http://www.6998.com/
我爱你中文城市：
http://www.521.us/
雷诺商务业务联系QQ：273245 30992886

2003-6-7 09:37
lllkkk
落伍者

积分 73
发贴 100
注册 2001-5-25
好，谢谢

中文成人网
激情成人论坛
激情色情链
2003-6-7 17:13
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20
不错

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-6-7 17:14
以及
落伍者

积分 894
发贴 947
注册 2002-6-21
不错要转了

中国曹氏网http://chinacao.126.com
2003-6-7 17:29
梦幻精灵
落伍者

积分 2610
发贴 2609
注册 2002-6-10
好东西
收下啦!

软件，文章，音乐，商务，电影，笑话，游戏，新闻，图库，聊天，短信，旅游，FLASH，邮局，留言，江湖，论坛
------华轩网络CN86.com------
2003-6-7 17:33

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.027526 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 发个技术贴吧:点连接出现图片和进度跳的js - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 发个技术贴吧:点连接出现图片和进度跳的js

作者:
标题: 发个技术贴吧:点连接出现图片和进度跳的js 上一主题 | 下一主题
被风吹倒的男子
强行加入万贴俱乐部的会员

积分 4428
发贴 4443
注册 2002-6-17
来自 帅哥的家乡
发个技术贴吧:点连接出现图片和进度跳的js

要求斑竹精华!!!!!!!!!!
申明:不是我写的js
是我从别人代码中挖出来的
嘿嘿~~~~~~~~~~~~~
效果样式如同

http://www.rain5.com/cdb/index.php

随便去点个连接,看到那个跳出来的"今天你灌水了么的图片和小进度条了么?就是这个效果"
我的空间人去的多了容易挂,如果我那里的不可以看
可以到http://www.3dapple.com/看类似效果

说说具体的方法吧
首先
下载js文件
http://www.rain5.com/cdb/actions/adv.js

然后是调用方式
在需要显示这个效果的head里放入一下代码

Code: [Copy to clipboard]
<script language="javascript">Adv("","","","<img border=0 src=actions/water.gif>","提示信息");</script>

<script language="javascript">Adv("","");</script>

其中第一个script是导入刚才下载的那个js的,需要设置路径
第2个 script是调用导入的script的,需要设置图片路径,图片设置为你想显示的图片的路径
ok搞定

常见问题说明:
建议调用的图片的宽度超过400
否则容易出点小问题
不要问我为什么
我不知道
我也是经验得到的

Quote:

论坛型主机（支持jsp/php/asp）：
基本型： 100m/50人在线/250元
专业A： 100m/100人在线/500元
专业B： 300m/150人在线/1100元
专业C： 500m/300人在线/1800元

2003-7-1 10:56
随心所欲
我会尽力帮你

积分 5900
发贴 6116
注册 2002-6-30
这样的才是好帖子啊，呵呵，鼓励鼓励

暑假优惠供应ASP+ACCESS+FSO+CGI虚拟主机，QQ:626318
2003-7-1 11:00
ajie.net
醒了醒了

积分 7450
发贴 7616
注册 2002-2-13
捏一下~

买地/种玉米 http://www.hyidc.com/
暑假大优惠：国际玉米 60 元 国内玉米 180元
QQ:82409 mail:info@hyidc.com
2003-7-1 11:02
Antonio
落伍者

积分 4411
发贴 4336
注册 2002-12-8
来自 www.freebar.net
COOL收藏

find free space music and films
感谢xqsheng送我国际域名
100M ASP CGI ACCESS空间只卖150 玉米75
联系webmaster@bizsz.com
QQ：9943943
2003-7-1 11:04
天灰灰
落伍者

积分 8175
发贴 7713
注册 2002-10-16
来自 囡天小屋
恩`好`

骨灰地带
2003-7-1 11:04
nbinfo
落伍者

积分 6677
发贴 6489
注册 2002-8-7
来自 CHINA 中国 SEX
我决的还是不要加的 好加了看起来反而让人决的 速度更慢了

本站出售 音乐程序 分2种ACCESS版本跟MSSQL版本，包括35000首歌曲文件
联系QQ ：19755866 805570
演示地址http://www.nbsky.net/
主机租用托管
2003-7-1 11:05
被风吹倒的男子
强行加入万贴俱乐部的会员

积分 4428
发贴 4443
注册 2002-6-17
来自 帅哥的家乡

Quote:
Originally posted by nbinfo at 2003-7-1 11:05 AM:
我决的还是不要加的 好加了看起来反而让人决的 速度更慢了

嘿嘿

Quote:

论坛型主机（支持jsp/php/asp）：
基本型： 100m/50人在线/250元
专业A： 100m/100人在线/500元
专业B： 300m/150人在线/1100元
专业C： 500m/300人在线/1800元

2003-7-1 11:59
loudong
落伍者

积分 423
发贴 430
注册 2002-12-1
空间快还行,要不会卡的~~~~
2003-7-1 21:52
被风吹倒的男子
强行加入万贴俱乐部的会员

积分 4428
发贴 4443
注册 2002-6-17
来自 帅哥的家乡

Quote:
Originally posted by loudong at 2003-7-1 09:52 PM:
空间快还行,要不会卡的~~~~

你到我的rain5注册了??

Quote:

论坛型主机（支持jsp/php/asp）：
基本型： 100m/50人在线/250元
专业A： 100m/100人在线/500元
专业B： 300m/150人在线/1100元
专业C： 500m/300人在线/1800元

2003-7-2 21:31
问题青年
落伍者

积分 766
发贴 757
注册 2002-7-15
版权都搞没了 ......

问题青年到此一游
2003-7-2 21:35
稻草人㊣
落伍者

积分 927
发贴 821
注册 2002-11-20
支持

欢迎大家光临我的小论坛：）
http://bbs.q520.com
2003-7-2 21:46

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.025431 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 常见网页加密方法和破解对策 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 常见网页加密方法和破解对策

作者:
标题: 常见网页加密方法和破解对策 上一主题 | 下一主题
XiEJEsEn
落伍者

积分 1858
发贴 1838
注册 2001-11-6
来自 <拒绝自伤的檬檬>
常见网页加密方法和破解对策

(转)
常见网页加密方法和破解对策（一）

右键弹出窗口加密。程序如下：

<script language="JavaScript">
<!--
document.onmousedown=click
function click() {
if ( event.button==2) {alert('不准查看源文件') }
if ( event.button==3) {alert('不准查看源文件') }
}
//-->
</script>

此法对IE有特效，但在NC中右键定义为无法控制的帮助菜单，所以NC中event对象
无button属性，在NC中右键->View Source可看源码。
老式程序没有if (event.button==3)的判断句，不知哪位老前辈想出——先按下
左钮不放再按下右钮，然后松开左钮再松开右钮，快捷菜单就会弹出，点击查看
源文件就能看到源码。(左右键法？………^_^)
本菜鸟自编的变形：
<script language="JavaScript">
<!--
document.onmousedown=click
function click() {
{window.location="index.html"; alert('不准查看源文件'); }
}
//-->
</script>

由于在NC中无法定义左右键，只有加上window.location="index.html"令其一旦
激活鼠标事件就转向首页或其它Web页，否则在NC中右键按了“确定”后，还会弹
出快捷菜单。缺点是在IE5.0左键也被禁止,不过在NC4.5只要按在链接上,仍能正
常转向Web页。
用乱码显示链接、调用地址加密。
利用某些函数把URL字符转换成ASCII码，从而达到隐藏链接Frame页面和*.js,*.
asp等脚本的目的。
返回ASCII码escape(character),ASCII码为%XX格式,XX是十六进制，如空格键为
%20。
返回字符unEscape(string)
如：

<!—var Words=" %3Cframeset%20BORDER%3D%220%22%20FRAMEBORDER%3D%220%22
%20FRAMESPACING%3D%220%22%20rows%3D%22100%25%22%3E%0D%0A%20%20%3Cframe
%20SRC%3D%22http%3A//XXX.XXX.COM/XXX/XXX/%22%20NAME%3D%22oos1%22%20"//
-->
</script>

我们只要运行以下语句，可还原“乱码”
<script LANGUAGE="JAVASCRIPT">
var Words="乱码"
document.write(unescape(Words))
</script>

什么？？没有输出！呵呵，原乱码是完整的JavaScript语句，当然不能显示，把
%3C删去破坏其格式，输出frameset BORDER="0" FRAMEBORDER="0" FRAMESPACIN
G="0" rows="100%"> 再把下一个%3C删去，所有字符都出来了哦。
此法常与右键弹出窗口加密、调用脚本显示页面等共同使用。也可用全部保存法
，清空缓存法破解。

输入地址法(NC不适用)
查看首页源文件，发现调用ok.js，在浏览器地址栏输入http://www./*.163.net/
ok.js,确定把ok.js保存在硬盘。用记事本编辑ok.js找到一行if(str=="abc098"
)，嗯，密码是abc098。如果没有指定*.js类型,可在文件类型中增加“打开”—
>windows\wscript，“编辑”—>windows\notepad。(此法对特定脚本适用。本站
的澳门回归倒计时就是参考了www.oyo.com.cn的*.js源文件,精确到秒的好东东。
)

全部保存法(NC不适用)
利用IE的“文件”—>“另存为”把本页保存选择“Web页，全部(*.htm;*.html)
"。你会发现在存档的目录下有一和页面同名的子目录，里面包含了所有作用于该
页面，而目标不在本页的图片和脚本文件，及Frames页源码。

清空缓存法(NC,IE通用)
把windows\Temporary Internet Files或Edit\Preferences\advanced\cache\di
sk cache folder的内容清空。然后浏览网站，源码、Frames页、脚本就在Tempo
rary Internet Files和disk cache folder中。但在NC中，所有脚本都改了名，
辨认麻烦。(看多个网站，需多次清空和拷出源码保存，苦！^_^)

关掉JavaScript法(IE不适用)
在NC中把advanced\Enable JavaScript屏蔽,可避免运行JavaScript,但对乱码和
脚本无能为力，脚本可是特殊效果的关键哦。（具体见附：）

关掉Java法(NC,IE通用)
由于目前常用JavaScript的简单加密，关掉IE和NC的Java并不能屏蔽JavaScript
，无实用价值。除非是用Java加密。

总结：建议使用全部保存法，只需存一次盘。一晚可存几十个网页，第二天再研
究。可见IE和NC的不同在于对脚本语言的支持不同，实乃我等剽窃者的一大福音
。^@^

附：
Java由Sun开发，Web页中标识符为<Applet>，脚本后缀名为.class。
JavaScript由Netscape开发，标识符为<script language="JavaScript">。
JScript由Microsoft开发，标识符为<script language="JScript">，该标识符在
NC中会被忽略。
Java和JavaScript两者不同。在IE高级-->Java VM中只能屏蔽Java，不能屏蔽Ja
vaScript。只有NC能屏蔽两者。
JScript绝大部分与JavaScript相同，除少数命令不同,一般可认为JScript等于J
avaScript，但在IE5.0中这种差别得到了强化，可见微软对网景的残酷打击。

常见网页加密方法和破解对策（二）

关于口令密码校验

<script LANGUAGE="JAVASCRIPT">
<!--
loopy()
function loopy() {
var pass =""
while (pass != "login") //login为密码
{pass = prompt("请输入密码")}
alert("登陆成功")
}
//-->
</script>

此法用了while()死循环，如果密码不对,连用右键和菜单查看源文件的机会都没
有,只有关闭Javascript了,不过IE无此功能,用NC吧。
只能输入三次密码的变形：

<script LANGUAGE="JavaScript">
<!-- Begin
function password() {
var testV = 1;
var pass1 = prompt('请输入密码：','');
while (testV < 3) {
if (!pass1)
history.back();
if (pass1 == "password") { //password为密码
alert('登陆成功!');

window.location="time.html"; //正确链接的URL.html
break;
}
testV+=1;
var pass1 =
prompt('密码不对,请重新输入');
}
if (pass1!="password" & testV ==3)
history.go(-1); //失败则返回前一个文档,可用window.location="***/***.ht
ml"替换
return " ";
}
document.write(password());
</script>

以下为一实例(同样也隐去地址，请原谅。)
首页源码
<script language="JavaScript"><!--
function dw(skey,msg)
{document.write(codeIt(skey,msg));}
var key = "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvw
xyz!\"\ \|#$%&\'()*+,-.\/:;<=>?@[\\]^_\t\`{}~\n";
function codeIt (mC, eS)
{var wTG, mcH = mC.length / 2, nS = "", dv;
for (var x = 0; x < eS.length; x++)
{wTG = mC.indexOf(eS.charAt(x));
if (wTG > mcH) {dv = wTG - mcH; nS = nS + mC.charAt(48 - dv);}
else {dv = mcH - wTG;nS = nS + mC.charAt(48 + dv);}}
return nS;}//--></script>

<script>
dw(key,"FgwhqjfW,\[*;#\[;=EX.ydy%whqjfXD00FYKK0tnysE\n0tnys}E\n0KKD00F
IgwhqjfD");</script> <script>
dw(key,"FgwhqjfW,\[*;#\[;=EX.ydy%whqjfXW%&?EXdjulwhJfbfXDW00FIgwhqjfD"
);</script> <script>
dw(key,"FgwhqjfW,\[*;#\[;=EX.ydy%whqjfXW%&?EXdjjgJfbfXDWWWW00FIgwhqjfD
");</script> <script>
dw(key,"FgwhqjfW,\[*;#\[;=EX.ydy%whqjfXD00FYKK0telwfqklWmyqlPO030mumxu
hEvkwemulfJynnJeguhlymuJdyneu0jyggEvkwemulfJynnJjyggckhvJdyneu0ulwhajf
qklPO0jyggckhvPO020KKD00FIgwhqjfD");</script> <script>
dw(key,"FgwhqjfWnylseysuEX.ydy%whqjfXDFYKK0telwfqklW*uc qlvkcPO3cqlvkc
JkjulPXvulspqJrfmXLXXLXruqsrfE`\n\nLcqvfrE{`\nLfkknxyhEaugLvqhuwfkhqug
EaugLgfyfegEaugLgwhknnxyhgEaugLhugqZuEaugLmulexyhElkXOG20IIWKKDFIgwhqj
fD");</script>

其实源文件并不复杂，只不过有几串特长字符让人迷惑罢了。查看源文件，没有
进入会员区的调用和链接，故此五行乱码一定是JavaScript的调用和链接。观察
发现函数codeIt是密码计算式，函数dw是输出JavaScript语句，试着把第一行的
F删去，破坏其语句结构发现输出script LANGUAGE="JavaScript">再把gwhqjfW,
\[*;#\[;=EX.ydy%whqjfXD00F删去。输出!-- flag=0 flag2=0 -->由此可得出五
行乱码为
script LANGUAGE="JavaScript">"> <!-- flag=0 flag2=0 -->-> t/script>
script LANGUAGE="JavaScript">" SRC="vpencr.txt"> t/script>
script LANGUAGE="JavaScript">" SRC="vpps.txt"> t/script>
script LANGUAGE="JavaScript">"> t!-- function main() { member=document
.all.username.value pass=document.all.password.value encryption() pass
word() } --> t/script>
script LANGUAGE="JavaScript"> !-- function NewWindow(){window.open("de
ngji.htm","","height=400,width=340,toolbar=yes,directories=yes,status=
yes,scrollbars=yes,resize=yes,menubar=no");} // --> t/script>
当然实际中困难重重,曾头脑发昏地考虑用计算器算出每个nS值—^@^,而且F的值
有出入,应为"<",但已经无关紧要了。
在IE地址栏输入vpencr.txt，vpps.txt，dengji.htm的URL，获得vpencr.txt和v
pps.txt,并证实dengji.htm
的URL正确。
vpencr.txt（密码表）源码
function encryption()
{
mm = "Z"
k = "j"
b = "p"
mmmm = "&"
ccc = "6"
l = "i"
c = "q"
m = "s"
abcd = "m"
o = "n"
u = "z"
e = "d"
gg = "U"
p = "u"
jj = "O"
v = "a"
j = "y"
x = "c"
t = "h"
h = "k"
vv = "C"
*
*
*
*
*
y = "t"
lll = "."
mmm = ","
cccc = "]"
g = "l"
dddd = "{"
eeee = "}"
ffff = ""
gggg = "|"
hhhh = "!"
iiii = "@"
jjjj = "#"
kkkk = "$"
llll = "%"
nnnn = "("
}
奇怪，这个密码表我好象在哪见过？:)
vpps.txt源码
function password()
{
if(member==h+l+g+g+p+m+v)
{
if(pass==v+y+y+v+x+h)
{alert("PASS、、、欢迎来到成员区")
window.location.href = y+u+lll+t+y+abcd
flag2=1}
}
if(member=="")
{}
else
{
if(flag==3)
{window.location.href = "http://***.***.com"
flag2=1}
if(flag2==1) {}
else
{alert ("现在要格式化你的硬盘！！！！————骗你的，呵呵")
flag=flag+1}
}
}
对照vpencr.txt，member=h+l+g+g+p+m+v=killusa, pass=v+y+y+v+x+h=attack,

href=y+u+lll+t+y+abcd=tz.htm。搞定！当然也可把会员区的URL改为window.op
en(y+u+lll+t+y+abcd,"","location=0");叫他进了会员区也不知道自己在哪个目
录下。

使用密码表好象成了一种潮流，好处很多啦，无须特殊转换，就能使"鸡"＝"鸭"
^@^，只不过当前个人主页没有文件权限，看懂密码表比看懂函数计算式容易多了
。有一些个人主页就是直接调用密码表，不隐藏地址，很容易被人copy下分析。

盼你怜我如花,爱我如己,今生死而无憾.此心苍天可表,日月为鉴,纵然你还是不爱我.
2003-6-18 08:38
esun
落伍者

积分 591
发贴 576
注册 2002-7-30
GOOD

我的站 http://www.iwantfly.com/
BBS站 http://bbs.iwantfly.com/
2003-6-18 08:40
XiEJEsEn
落伍者

积分 1858
发贴 1838
注册 2001-11-6
来自 <拒绝自伤的檬檬>
好文章不敢独自享用!

ASP 编程中 15 个非常有用的例子
1.如何用Asp判断你的网站的虚拟物理路径
答：使用Mappath方法
< p align="center" >< font size="4" face="Arial" >< b >
The Physical path to this virtual website is:
< /b >< /font >
< font color="#FF0000" size="6" face="Arial" >
< %= Server.MapPath("\")% >
< /font >< /p >
2.我如何知道使用者所用的浏览器？
答：使用the Request object方法
strBrowser=Request.ServerVariables("HTTP_USER_AGENT")
If Instr(strBrowser,"MSIE") < > 0 Then
    Response.redirect("ForMSIEOnly.htm")
Else
    Response.redirect("ForAll.htm")
End If

3.如何计算每天的平均反复访问人数
答：解决方法
< % startdate=DateDiff("d",Now,"01/01/1990")
if strdate< 0 then startdate=startdate*-1
avgvpd=Int((usercnt)/startdate) % >
显示结果
< % response.write(avgvpd) % >
that is it.this page have been viewed since November 10,1998

4.如何显示随机图象
< % dim p,ppic,dpic
ppic=12
randomize
p=Int((ppic*rnd)+1)
dpic="graphix/randompics/"&p&".gif"
% >
显示
< img src="< %=dpic% >" >

5.如何回到先前的页面
答：< a href="< %=request.serverVariables("Http_REFERER")% >" >preivous page< /a >
或用图片如：< img src="arrowback.gif" alt="< %=request.serverVariables("HTTP_REFERER")% >" >

6.如何确定对方的IP地址
答：< %=Request.serverVariables("REMOTE_ADDR)% >

7.如何链结到一副图片上
答：< % @Languages=vbscript % >
< % response.expires=0
strimagename="graphix/errors/erroriamge.gif"
response.redirect(strimagename)
% >

8.强迫输入密码对话框
答：把这句话放载页面的开头
< % response.status="401 not Authorized"
response.end
% >

9.如何传递变量从一页到另一页
答：用 HIDDEN 类型来传递变量
< % form method="post" action="mynextpage.asp" >
< % for each item in request.form % >
< input namee="< %=item% >" type="HIDDEN"
value="< %=server.HTMLEncode(Request.form(item)) % >" >
< % next % >
< /form >

10.为何我在 asp 程序内使用 msgbox，程序出错说没有权限
答：由于 asp 是服务器运行的，如果可以在服务器显示一个对话框，那么你只好等有人按了确定之后，你的程序才能继续执行，而一般服务器不会有人守着，所以微软不得不禁止这个函数，并胡乱告诉你 (:) 呵呵) 没有权限。但是ASP和客户端脚本结合倒可以显示一个对话框，as follows:
< % yourVar="测试对话框"% >
< % script language='javascript' >
alert("< %=yourvar% >")
< /script >

11.有没有办法保护自己的源代码，不给人看到
答：可以去下载一个微软的Windows Script Encoder，它可以对asp的脚本和客户端javascript/vbscript脚本进行加密。。。不过客户端加密后，只有ie5才能执行，服务器端脚本加密后，只有服务器上安装有script engine 5（装一个ie5就有了）才能执行。

12.怎样才能将 query string 从一个 asp 文件传送到另一个？
答：前者文件加入下句： Response.Redirect("second.asp?" & Request.ServerVariables("QUERY_STRING"))

13.global.asa文件总是不起作用?
答：只有web目录设置为web application, global.asa才有效，并且一个web application的根目录下 global.asa才有效。IIS4可以使用Internet Service Manager设置application setting 怎样才能使得htm文件如同asp文件一样可以执行脚本代码？

14.怎样才能使得htm文件如同asp文件一样可以执行脚本代码？
答：Internet Sevices Manager - > 选择default web site - >右鼠键- >菜单属性-〉主目录- > 应用程序设置（Application Setting）- > 点击按钮 "配置"- > app mapping - >点击按钮"Add" - > executable browse选择 \WINNT\SYSTEM32\INETSRV\ASP.DLL EXTENSION 输入 htm method exclusions 输入PUT.DELETE 全部确定即可。但是值得注意的是这样对htm也要由asp.dll处理，效率将降低。

15.如何注册组件
答：有两种方法。
第一种方法：手工注册 DLL 这种方法从IIs 3.0一直使用到IIs 4.0和其它的Web Server。它需要你在命令行方式下来执行，进入到包含有DLL的目录，并输入：regsvr32 component_name.dll 例如 c:\temp\regsvr32 AspEmail.dll 它会把dll的特定信息注册入服务器中的注册表中。然后这个组件就可以在服务器上使用了，但是这个方法有一个缺陷。当使用这种方法注册完毕组件后，该组件必须要相应的设置NT的匿名帐号有权限执行这个dll。特别是一些组件需要读取注册表，所以，这个注册组件的方法仅仅是使用在服务器上没有MTS的情况下，要取消注册这个dll，使用：regsvr32 /u aspobject.dll example c:\temp\regsvr32 /u aneiodbc.dll

第二种方法：使用MTS(Microsoft Transaction Server) MTS是IIS 4新增特色，但是它提供了巨大的改进。MTS允许你指定只有有特权的用户才能够访问组件，大大提高了网站服务器上的安全性设置。在MTS上注册组件的步骤如下：
1) 打开IIS管理控制台。
2) 展开transaction server，右键单击"pkgs installed"然后选择"new package"。
3) 单击"create an empty package"。
4) 给该包命名。
5) 指定administrator帐号或则使用"interactive"（如果服务器经常是使用administrator 登陆的话）。
6) 现在使用右键单击你刚建立的那个包下面展开后的"components"。选择 "new then component"。
7) 选择 "install new component" 。
8) 找到你的.dll文件然后选择next到完成。
要删除这个对象，只要选择它的图标，然后选择delete。
附注：特别要注意第二种方法，它是用来调试自己编写组件的最好方法，而不必每次都需要重新启动机器了。

盼你怜我如花,爱我如己,今生死而无憾.此心苍天可表,日月为鉴,纵然你还是不爱我.
2003-6-18 08:43
踏雪寻妹
别支签字笔揣颗平常心

积分 10049
发贴 10005
注册 2001-7-29
来自 笑看红尘
把表情去了好吗

天见犹怜！
可怜我又小又瘪又下垂像排骨！
谁不愿冰肌玉乳？
谁不想酥胸半露？
然而硅胶终太假，注射太可怕.
上苍啊，赐我一个999块钱的戴安芬吧！
从此，变作娇娘美如花…
强烈BS某些见不得别人有个性签名的淫！
万维主机,中国商务网专业主机供应网站!
2003-6-18 08:43
XiEJEsEn
落伍者

积分 1858
发贴 1838
注册 2001-11-6
来自 <拒绝自伤的檬檬>

Quote:
Originally posted by 踏雪寻妹 at 2003-6-18 08:43 AM:
把表情去了好吗

去了!

盼你怜我如花,爱我如己,今生死而无憾.此心苍天可表,日月为鉴,纵然你还是不爱我.
2003-6-18 08:46

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.029006 second(s), 5 queries, Gzip enabled


落伍者论坛 - 资源讨论专栏 - [分享]：主流论坛程序一览 - powered by Discuz!

落伍者论坛 » 资源讨论专栏 » [分享]：主流论坛程序一览

作者:
标题: [分享]：主流论坛程序一览 上一主题 | 下一主题
renxoyo
落伍者

积分 1964
发贴 1892
注册 2002-12-25
来自 闪光科技
[分享]：主流论坛程序一览

主流论坛程序一览
ASP论坛

动网论坛
演示： http://www.dvbbs.net/

BBSXP论坛
演示： http://www.bbsxp.com/

雪人论坛
演示： http://www.xinboard.net/

上校论坛
演示： http://www.shangxiao.com/

网虫中国资讯论坛
演示： http://www.zsbmi.com/asp/bbs/

百特网盟论坛
演示： http://www.unionbyte.com/tech/

ARBBS
演示： http://arbbs.hw365.com/bbs/

5237 论坛
演示： http://bbs.5237.net/

CVB论坛（武夷月夏论坛）
下载和演示： http://www.yemeng.net/cvb/

前沿论坛
演示： http://www.websamba.com/jchzi/bbs

CPB论坛
演示： http://www.pwsite.net/bbs/

极限论坛
演示： http://www.yinlang.com/41888/

vieBoard
演示： http://www.facesun.com/project/vieb...ortal_close.asp

FSF超级ASP论坛
演示： http://free.5308.com/ayxz/free/forum/default.asp

星空无限BBSXP
演示： http://qjsm.com/asp/index.asp

eXciteForum
演示： http://202.102.243.226/qsing/fapp/default.asp

CID4U修改美化的动网论坛
演示： http://test.cnzzz.com/cid4ubye/

清风论坛
下载： http://www.chinanetboy.com/code/dow...l=asp/qfbbs.zip

莱因网络技术论坛
演示： http://www.studiodl.com/bbs/main.asp

陈氏论坛
演示： http://www.chztv.com/cbbs/

信心社区ACCESS版 （演示为sql版）
演示： http://bbs.xxsky.com/

青年公社
演示： http://city.wudu.net/

Web Wiz Forums（有简体语言包）
演示： http://www.webwizguide.info/forum/

Snitz Forums （站长站有汉化版下载）
演示： http://forum.snitz.com/forum/

闪一派论坛
演示： http://www.beozone.com/Club/

晓宇听幽论坛
http://ps.luohuedu.net/xigua/bbs/xoyu.asp

6K论坛
演示： http://www.18asp.com/freeuser/lijia/index.asp

－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－

ASP.NET论坛

精英论坛
演示： http://bbs.itelite.com/ForumGroup.aspx

印象论坛
演示： http://www.nowboard.com/

－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－

PHP论坛

VBB（世界最出名啊！）
演示： http://www.vbulletin.com/
几个中文汉化官方网站：
仙镜论坛http://www.faeryboard.com/
紫桐社区 http://www.tsing.com/ztbbs/
篝火社区 http://www.gouhuo.com/bbs/
VBB 中文阵线联盟 http://www.cnvbb.com/

PHPBB
演示： http://www.phpbb.com/
中文汉化官方网站:
http://www.cnphpbb.com/
http://www.phpbb.com.cn/

WDB文本论坛（官方站已经关闭）
PTB 文本论坛 http://zghao.51.net/cgi-bin/ptb/
南宫紫剑修改版 http://qbit.w18.net/wdb/index.php
阿宝修改版 http://www.zaozao.net/bbs/
梦想论坛 http://freedim.net/~hfddk/wdb/
水晶修改版 http://love8.my.freedim.net/wdb/
feixin修改版 http://fxstudio.51.net/sharebbs/
aker 美化版 http://tengxian.51.net/bbs/

Discuz! Board （CDB ）
演示： http://www.discuz.net/

华育论坛
演示： http://www.hycenter.net/hybbs/

YaBB中文版
演示： http://ourphp.com/forum/

疯狂论坛
演示： http://www.ofyou.com/fastcb/

时代论坛社区
演示： http://trail.51.net/bbs/

绿野论坛
演示： http://www.lvye.org/bbs/wwwthreads.php

CTB文本论坛
演示： http://ctb.11cn.org/

IBF论坛
演示： http://forums.invisionpower.com/
中文汉化论坛：
华酷论坛 http://www.szdown.net/forums/index.php
水柠檬Yeah!board http://www.yeahboard.com/bbs/yeahboard.php

SRPBoard
演示： http://srpboard.org/SRPBoard/SRPBoard.php

skyboard中文版
演示： http://www.send2u.org/kr/board/

时代论坛
演示: http://trail.51.net/bbs/

UBBThreads
演示： http://community.infopop.net/2/OpenTopic?a=cfrm

FASTBOARD
http://www.fastboard.org/forum/

MercuryBoard
演示: http://forums.mercuryboard.com/

WBB2论坛
演示： http://www.jgws.com/fallen/wbb2/index.php

－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－

CGI论坛

CGI论坛越来越没人用了，我只摘录一些常见的！

雷傲
演示： http://leoboard.com/cgi-bin/leoboard.cgi

UltraThreads
演示： http://www.rorz.org/perl/ut/forum_show.cgi

YxBBS (bbs3000修改版)
演示： http://www.yxbs.net/cgi-bin/bbs/list.cgi

YABBCN 论坛
演示： http://www.f8f8.com/cgi-bin/yabbcn/YaBB.pl

－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－

JSP论坛

雷霆论坛
演示： http://www.developersbus.com:8080/%...ngboard/home.do

阿菜论坛
演示： http://www.justhis.com/forum/

BBS-CS
演示： http://www.laoer.com/

凌云论坛
演示： http://www.unix-now.com/lybbs/index.jsp

学生型ASP主机100M,每年只需98元!
100MPHP,50MMySQL ，完美支持VBB、FB、DISCUZ等各类PHP论坛,178元/年.
QQ：3640408
论坛演示:http://www.sgbbs.net/
2003-7-14 16:06
zhlsk
落伍者

积分 821
发贴 839
注册 2002-11-26
来自 天府之国（成都）
晕。。。。。。。。。。。。。去网建或代码交流发！！！
2003-7-14 16:07
sainte
落伍者

积分 430
发贴 439
注册 2001-10-1
怎么又出来一个精英论坛。。。？

精英论坛
演示： http://bbs.itelite.com/ForumGroup.aspx
2003-7-14 17:24
星期天
落伍者

积分 1119
发贴 1050
注册 2003-2-16
来自 广西防城港市
真多

http://www.lzh520.com
-------御缘永远的家！
千贴留念：P免费提供10个主叶下载！！
http://im286.com/viewthread.php?tid=260519&fpage=3
2003-7-14 17:25
seefantasy
落伍者

积分 97
发贴 115
注册 2002-12-12
discuz好还是VBB好？ 我看到有人说discuz速度要快一些？
2003-7-14 17:38
seefantasy
落伍者

积分 97
发贴 115
注册 2002-12-12
没人回答/
2003-7-14 17:49
zwxman
落伍者

积分 792
发贴 801
注册 2002-9-7
8錯

免费电影下载，清纯MM贴图
2003-7-14 17:49
to77
落伍者

积分 895
发贴 881
注册 2001-10-2
太多了，看不过来

感谢西瓜大哥！
2003-7-14 17:52
小林
o○万帖俱乐部老八^_^ ○ o

积分 11252
发贴 11181
注册 2002-10-29
来自 『新都人.COM』
看过N次了

万维主机-Sunking

『统一行动，开始删贴！』
2003-7-14 17:54
dreamyboy
落伍者

积分 11168
发贴 11656
注册 2002-10-10
来自 飘逸网络

Quote:
Originally posted by 小林 at 2003-7-14 05:54 PM:
看过N次了

代理高速LINUX虚拟主机业务。联系
QQ：691932，演示：http://www.go8go.com/，
买一年送一个月，两年送三个月！MSN：
我的MSN：go8go8go@hotmail.com,ICQ:195225878
2003-7-14 17:56
zen
落伍者

积分 60
发贴 60
注册 2002-5-23
有些打不開
2003-7-14 18:15
ajie.net
醒了醒了

积分 7450
发贴 7616
注册 2002-2-13
精一个

买地/种玉米 http://www.hyidc.com/
暑假大优惠：国际玉米 60 元 国内玉米 180元
QQ:82409 mail:info@hyidc.com
2003-7-14 18:44
独孤飞逸
落伍者

积分 2141
发贴 2150
注册 2002-5-30
来自 SH
N次看过~

落伍好朋友：WILLI、丁丁
感谢华英雄送我空间~
代理商务中国、有个网络空间、玉米等等，需要的请联系QQ：44167471
新论坛开张大家捧场：bbs.joy9.com
斑竹不要扣我分啊~
2003-7-14 19:10
zhlsk
落伍者

积分 821
发贴 839
注册 2002-11-26
来自 天府之国（成都）

Quote:
Originally posted by 小林 at 2003-7-14 05:54 PM:
看过N次了

2003-7-14 19:11

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.029874 second(s), 5 queries, Gzip enabled


落伍者论坛 - 资源讨论专栏 - 转 不错的代码 - powered by Discuz!

落伍者论坛 » 资源讨论专栏 » 转　不错的代码

作者:
标题: 转　不错的代码 上一主题 | 下一主题
sAsE
落伍者

积分 5162
发贴 4600
注册 2003-2-14
转　不错的代码

经常上网的朋友可能会到过这样一些网站，一进入首页立刻会弹出一个窗口，或者按一个连接或按钮弹出，通常在这个窗口里会显示一些注意事项、版权信息、警告、欢迎光顾之类的话或者作者想要特别提示的信息。其实制作这样的页面效果非常的容易，只要往该页面的HTML里加入几段Javascript代码即可实现。下面俺就带您剖析它的奥秘。

【1、最基本的弹出窗口代码】

其实代码非常简单：

<SCRIPT LANGUAGE="javascript">
<!--
window.open ('page.html')
-->
</SCRIPT>

因为这是一段javascripts代码，所以它们应该放在<SCRIPT LANGUAGE="javascript">标签和</script>之间。<!-- 和 -->是对一些版本低的浏览器起作用，在这些老浏览器中不会将标签中的代码作为文本显示出来。要养成这个好习惯啊。 window.open ('page.html') 用于控制弹出新的窗口page.html，如果page.html不与主窗口在同一路径下，前面应写明路径，绝对路径(http://)/和相对路径(.. /)均可。 用单引号和双引号都可以，只是不要混用。 这一段代码可以加入HTML的任意位置，<head>和</head>之间可以，<body>间</body>也可以，越前越早执行，尤其是页面代码长，又想使页面早点弹出就尽量往前放。

【2、经过设置后的弹出窗口】

下面再说一说弹出窗口的设置。只要再往上面的代码中加一点东西就可以了。 我们来定制这个弹出的窗口的外观，尺寸大小，弹出的位置以适应页面的具体情况。

<SCRIPT LANGUAGE="javascript">
<!--
window.open ('page.html', 'newwindow', 'height=100, width=400, top=0, left=0, toolbar=no, menubar=no, scrollbars=no,resizable=no,location=no, status=no')
//写成一行
-->
</SCRIPT>

参数解释：

<SCRIPT LANGUAGE="javascript"> js脚本开始；
window.open 弹出新窗口的命令；
'page.html' 弹出窗口的文件名；
'newwindow' 弹出窗口的名字（不是文件名），非必须，可用空''代替；
height=100 窗口高度；
width=400 窗口宽度；
top=0 窗口距离屏幕上方的象素值；
left=0 窗口距离屏幕左侧的象素值；
toolbar=no 是否显示工具栏，yes为显示；
menubar，scrollbars 表示菜单栏和滚动栏。
resizable=no 是否允许改变窗口大小，yes为允许；
location=no 是否显示地址栏，yes为允许；
status=no 是否显示状态栏内的信息（通常是文件已经打开），yes为允许；
</SCRIPT> js脚本结束

【3、用函数控制弹出窗口】

下面是一个完整的代码。
<html>
<head>
<script LANGUAGE="JavaScript">
<!--
function openwin() {
window.open ("page.html", "newwindow", "height=100, width=400, toolbar=no, menubar=no, scrollbars=no, resizable=no, location=no, status=no"

//写成一行
}
//-->
</script>
</head>
<body onload="openwin()">
...任意的页面内容...
</body>
</html>

这里定义了一个函数openwin(),函数内容就是打开一个窗口。在调用它之前没有任何用途。怎么调用呢？

方法一：<body onload="openwin()"> 浏览器读页面时弹出窗口；
方法二：<body onunload="openwin()"> 浏览器离开页面时弹出窗口；
方法三：用一个连接调用：
<a href="#" onClick="openwin()">打开一个窗口 </a>注意：使用的“#”是虚连接。
方法四：用一个按钮调用：
<input type="button" onclick="openwin()" value="打开窗口">

【4、同时弹出2个窗口】

对源代码稍微改动一下：
<script LANGUAGE="JavaScript">
<!--
function openwin() {
window.open ("page.html", "newwindow", "height=100, width=100, top=0, left=0,toolbar=no, menubar=no, scrollbars=no, resizable=no, location=no, status=no"
//写成一行
window.open ("page2.html", "newwindow2", "height=100, width=100, top=100, left=100,toolbar=no, menubar=no, scrollbars=no, resizable=no, location=no, status=no"
//写成一行
}
//-->
</script>

为避免弹出的2个窗口覆盖，用top和left控制一下弹出的位置不要相互覆盖即可。最后用上面说过的四种方法调用即可。
注意：2个窗口的name(newwindows和newwindow2)不要相同，或者干脆全部为空。

OK？

【5、主窗口打开文件1.htm，同时弹出小窗口page.html】

如下代码加入主窗口<head>区：

<script language="javascript">
<!--
function openwin() {
window.open("page.html","","width=200,height=200"
}
//-->
</script>
加入<body>区：
open即可。

【6、弹出的窗口之定时关闭控制】

下面我们再对弹出的窗口进行一些控制，效果就更好了。如果我们再将一小段代码加入弹出的页面(注意是加入到page.html的HTML中，可不是主页面中，否则 ...)，让它10秒后自动关闭是不是更酷了？

首先，将如下代码加入page.html文件的<head>区：
<script language="JavaScript">

function closeit() {

setTimeout("self.close()",10000) //毫秒

}

</script>
然后，再用<body onload="closeit()"> 这一句话代替page.html中原有的<BODY>这一句就可以了。(这一句话千万不要忘记写啊！这一句的作用是调用关闭窗口的代码，10秒钟后就自行关闭该窗口。)

【7、在弹出窗口中加上一个关闭按钮】

<FORM>
<INPUT TYPE='BUTTON' VALUE='关闭' onClick='window.close()'>
</FORM>
呵呵，现在更加完美了！

【8、内包含的弹出窗口-一个页面两个窗口】

上面的例子都包含两个窗口，一个是主窗口，另一个是弹出的小窗口。 通过下面的例子，你可以在一个页面内完成上面的效果。

<html>
<head>
<SCRIPT LANGUAGE="JavaScript">
function openwin()
{
OpenWindow=window.open("", "newwin", "height=250, width=250,toolbar=no,scrollbars="+scroll+",menubar=no" [image];
//写成一行
OpenWindow.document.write("<TITLE>例子</TITLE>"
OpenWindow.document.write("<BODY BGCOLOR=#ffffff>"
OpenWindow.document.write("<h1>Hello!</h1>"
OpenWindow.document.write("New window opened!"
OpenWindow.document.write("</BODY>"
OpenWindow.document.write("</HTML>"
OpenWindow.document.close()
}
</SCRIPT>
</head>
<body>
打开一个窗口
<input type="button" onclick="openwin()" value="打开窗口">
</body>
</html>

看看 OpenWindow.document.write()里面的代码不就是标准的HTML吗？只要按照格式写更多的行即可。千万注意多一个标签或少一个标签就会出现错误。记得用OpenWindow.document.close()结束啊。

【9、终极应用--弹出的窗口之Cookie控制】

回想一下，上面的弹出窗口虽然酷，但是有一点小毛病(沉浸在喜悦之中，一定没有发现吧？)比如你将上面的脚本放在一个需要频繁经过的页面里(例如首页)， 那么每次刷新这个页面，窗口都会弹出一次，是不是非常烦人？:-(

有解决的办法吗？Yes! ;-) Follow me.

我们使用cookie来控制一下就可以了。

首先，将如下代码加入主页面HTML的<HEAD>区：

<script>
function openwin(){
window.open("page.html","","width=200,height=200"
}
function get_cookie(Name) {
var search = Name + "="
var returnvalue = "";
if (document.cookie.length > 0) {
offset = document.cookie.indexOf(search)
if (offset != -1) {
offset += search.length
end = document.cookie.indexOf(";", offset);
if (end == -1)
end = document.cookie.length;
returnvalue=unescape(document.cookie.substring(offset, end))
}
}
return returnvalue;
}

function loadpopup(){
if (get_cookie('popped')==''){
openwin()
document.cookie="popped=yes"
}
}

</script>

然后，用<body onload="loadpopup()">（注意不是openwin而是loadpop啊！） 替换主页面中原有的<BODY>这一句即可。你可以试着刷新一下这个页面或重新进入该页面，窗口再也不会弹出了。真正的Pop-Only-Once！

写到这里弹出窗口的制作和应用技巧基本上算是完成了

歓迎するwǒ xīn fēi yáng
最新最齊的免費空間.안정의 고속의 상업의 공간.
2003-7-2 16:32
haogong
落伍者

积分 2656
发贴 2651
注册 2002-12-23
来自 isphp.net
最讨厌弹出窗口！！！

你还在这教人怎么弹出更多，弹出更大，靠:

别人笑我太疯颠 我笑他人看不穿
不见五陵豪杰墓 无花无酒锄作田
2003-7-2 16:33
耗子尻大象
落伍者

积分 161
发贴 161
注册 2003-3-19
不错，很好
2003-7-2 16:33
爱我家
落伍者

积分 1429
发贴 1187
注册 2002-8-11
来自 爱我家社区
讨厌和使用就不一样!

顶！建议置顶！

欢迎到爱我家社区欢迎到武术吧我的QQ现在改了：674910！
2003-7-2 16:34
loubin
落伍者

积分 3930
发贴 3639
注册 2003-2-14
好

不想灌水了。。。

2003-7-2 16:35
边缘Monarchy
落伍者

积分 3719
发贴 3736
注册 2002-12-15
来自 瑪雅·中國臺灣站
狂支持!!

5ua.com china165.com欲转让有意者联系QQ:9404806
來這裏下載黑白會員區軟件
2003-7-2 16:35
SHCS
今天你落伍了没有？

积分 6367
发贴 5778
注册 2003-2-15
来自 我的家
不错,加入精华~论坛就是多一点这样的贴子

兄弟:zwei 91love xupan 新明天 hailongcoboo sAsE
wuyemin....
姐妹:小巫仙
MYQQ:710599 102015
申请xrea x-beat是中国人拿下日本帝国的第一步-----SHCS
2003-7-2 16:35
tlyfat
落伍者

积分 2784
发贴 2742
注册 2003-3-19
收

虚心者向你求教
望不吝赐教！

真正的共产主义→黄金论坛
网络收费账号免费提供

2003-7-2 16:36
星期天
落伍者

积分 1119
发贴 1050
注册 2003-2-16
来自 广西防城港市
我刚想找呢~呵

http://www.lzh520.com
-------御缘永远的家！
千贴留念：P免费提供10个主叶下载！！
http://im286.com/viewthread.php?tid=260519&fpage=3
2003-7-2 16:38
天花
落伍者

积分 1131
发贴 1164
注册 2002-7-5
来自 广西那个山清水秀的地方
不错不错````精华？

智商高的朋友进来回答我的问题！
问题→ http://www.im286.com/viewthread.php?tid=229496
2003-7-2 16:42
ltj1231
落伍者

积分 6051
发贴 5640
注册 2002-12-27
来自 宁波
good

good

--------------------------------------------------------------------------
出售2对7无情侣
2003-7-2 16:44
dreamyboy
落伍者

积分 11168
发贴 11656
注册 2002-10-10
来自 飘逸网络
注意符号呀。。。。。

代理高速LINUX虚拟主机业务。联系
QQ：691932，演示：http://www.go8go.com/，
买一年送一个月，两年送三个月！MSN：
我的MSN：go8go8go@hotmail.com,ICQ:195225878
2003-7-2 16:46

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.030986 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - IBM站一个网页到底包含了多少技术--看分析 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » IBM站一个网页到底包含了多少技术--看分析

<< [1] [2] >>
作者:
标题: IBM站一个网页到底包含了多少技术--看分析 上一主题 | 下一主题
剑枫
落伍者

积分 8242
发贴 7729
注册 2002-1-14
来自 西监狱213号房
IBM站一个网页到底包含了多少技术--看分析

IBM首页源代码浅析----转
一、浏览器兼容性
作为一个国际大公司的站点，保证能在不同浏览器下的可浏览性是必须考虑的，这点IBM的做法不得不令人佩服。它巧妙的利用一个javascript(ibmcss.js)根据不同的浏览器选择不同的样式表，这也就是为什么我们直接打开保存在硬盘上的IBM页面不能看到用样式表定义的原因。
打开ibmcss.js，分析一下代码，我们就可以发现IBM一共设计了四个样式表: ie1.css , ie6.css , r1.css , ns1.css 。这四个样式表大部分都相同，主要的区别在于字体大小(font-size)的单位：ie6 里用%,r1里用px,ns1里用pt。下面是同样的一条样式在不同css里的定义：

ie6.css: body { font-family: Arial, sans-serif; font-size: 78%; }

r1.css :body,p,b,i,strong,em,dt,dd,dl,sl,caption,th,td,tr,u, blink,select, option,form,div,font,li { font-family: Arial, sans-serif; font- size: 12px; }

ns1.css: body,dt,dd,dl,sl,caption,th,td,tr,select,option,form,font { font-family: Arial, sans-serif; font-size: 9pt; }

而从对ibmcss.js里程序逻辑的分析可以得到下面样式表和浏览器的对应关系：

r1.css : Macintosh IE4.0以上，Macintosh Netscape4.0以上，Netscape5.0以上，
X11 Netscape5.0以上 (Xwindows for linux or unix,I guest )
ie6.css: Windows IE4.0以上，
ns1.css: 其他操作系统Netscape4.0以上
ie1.css: 其他操作系统IE4.0以上

我分别在Windows XP+IE6.0和Linux Rat hat 7.1+NS4.7两个环境下测试了这四个样式表，在IE6里四个样式表

都可以正常显示，只是字体大小略有区别；而在NS4.7里，用ie1.css和ns1.css定义的页面字体模糊不清，而用

r1.css和ie6.css显示的页面可以正常显示。

同时，IBM也考虑到了部分浏览器不支持javascript的情况，在ibmcss.js后紧跟了一句<NOSCRIPT><LINK href="r1.css" type=text/css rel=stylesheet></NOSCRIPT>，对于不支持javascript的浏览器将统一采用r1.css。不过这里有一点我不能理解的是为什么在head里面用了两句同样的<NOSCRIPT>语句，是为了保险起见还是设计者没有精简掉呢，希望大家能一起探讨。

二、规范全面的META内容

作为一个规范的页面，详尽的META内容是必不可少的，这一点IBM一直做得很好，我们可以回顾一下其99年页面里的META内容：
<meta content="ibm international business machines internet" name="keywords">
<meta content="http://www.ibm.com/" name="alias">
<meta content="webmaster@www.ibm.com" name="owner">
<meta
content="The IBM corporate home page, entry point to information about IBM products and services"
name="description">
<meta
content="(PICS-1.1 "http://www.rsac.org/ratingsv01.html"; l gen true comment "RSACi

North America Server" by "epc@www.ibm.com"; for "http://www.ibm.com/"; on

"1997.07.05T21:46-0500" r (n 0 s 0 v 0 l 0))"
http-equiv="PICS-Label">
<meta
content="(PICS-1.0 "http://www.classify.org/safesurf/"; l gen true for

"http://www.ibm.com/"; by "epc@www.ibm.com"; r (SS~~000 1 SS~~100 1))"
http-equiv="PICS-Label">

今天的IBM页面META内容更是丰富，从下面的一些例子我们就可见一斑：

1、基本信息
<META http-equiv=content-type content="text/html; charset=iso-8859-1">
<META http-equiv=Pragma content=no-cache>
<META content=webmaster@www.ibm.com name=Owner>
<META content="Copyright (c) 2001 by IBM Corporation" name=Copyright>
<META content=us name=IBM.Country>
<META content=index,follow name=Robots>
<META content=public name=Security>
<META content=Franklin/IPC name=Source>
<META http-equiv=PICS-Label
content='(PICS-1.1 "http://www.icra.org/ratingsv02.html" l gen true r (cz 1 lz 1 nz 1 oz 1 vz 1)

"http://www.rsac.org/ratingsv01.html" l gen true r (n 0 s 0 v 0 l 0)

"http://www.classify.org/safesurf/" l gen true r (SS~~000 1))'>

2、scheme
<META scheme=rfc1766 content=en-us name=DC.Language>
<META scheme=iso8601 content=2001-08-09 name=DC.Date>

3、描述与关键词
<META
content="The IBM corporate home page, entry point to information about IBM products and services"
name=Description>
<META
content="The IBM corporate home page, entry point to information about IBM products and services"
name=Abstract>
<META
content="ibm,international business machines,internet,e-business,ebusiness,personal

computer,personal system,e-commerce,ecommerce,pc,workstation,mainframe,unix,technical

support,homepage,home page"
name=Keywords>

内容详尽全面，完全符合一个规范页面的要求，这点我想是挺值得我们学习的。

三、Web数据流分析

作为一个国际大公司的站点，仅通过简单的点击计数是远远不能达到营销目的所需的详细程度，从下面的代码我们大致可以猜测出IBM站点使用了Keylime Software公司的Web数据流分析方案（在随后对Keylime Software公司网站访问中证实了这一点）：

<SCRIPT language=JavaScript type=text/javascript><!-- Keylime Software 09/16/2001var kl_version = "1.1.0";var kl_startLoadTime = new Date();var kl_companyId = "23";var kl_siteId = "77.78.0.774";var kl_sessionCookieVisibility = "; domain=ibm.com";var kl_sessionCookiePathVisibility = "; path=/";//--></SCRIPT><SCRIPT language=JavaScript1.2 src="stats.js" type=text/javascript></SCRIPT>

引用:
--------------------------------------------------------------------------------

在电子商务早期阶段时，Web 站点数据流分析通常不过是指在你的主页上安装计数器以及在一个外部日志文件上运行简单的统计程序以记录点击率。但是，业界领导们很快意识到简单的点击计数既不准确也远未达到营销目的所需的详细程度。因此，各公司开始寻找更先进的分析工具，这类工具可以提供谁在访问公司Web 站点以及访问者一旦进入站点后将做些什么的全面信息。...
一些ASP已经开始将基于服务的分析工具包括在他们提供的多种服务中，希望能减少一定的先期技术与财务负担。像Keylime Software公司的iEchoes这类解决方案按每月收费的方式提供对用户不同企业级分析工具的接入。在ASP模型中，你不必为硬件基础设施或培训投资，程序可以立即运行， 并且有时作为合同的一部分，你甚至可以获得咨询服务。不过，基于ASP 的软件通常也存在缺点，如第三方将可以接触到你严密防守的秘密。 ...
引自：网络世界: Web数据流分析超越点击计数 http://www.cnw.com.cn/cnw/2000/33/3312.asp

--------------------------------------------------------------------------------

更详尽的信息可从Keylime Software公司的站点获得：http://www.klsoft.com/

四、ejsmsp.js

该js里包含了丰富的内容，因为用到了SetCookie（），ReadCookie（）等函数，我想这个js的功能之一应该是设置Cookie，以使网页更有个性化，方便浏览者获取想要的信息。从长长的链接列表我们可以感受到IBM为了方便浏览者而精心的考虑，而且在不同的页面ejsmsp.js里的链接列表都不尽相同，真可谓用心良苦

纵观整个页面的源文件，一共用了一个内部javascript和三个外部javascript文件，每个javascript都起了不可或缺的作用，但没有一个是用来实现页面动态效果的，这正好印证了一段话：“dhtml是动态html，动态并不代表会移动的像素。 这里的动态指的是交互。 交互是web design与平面设计最主要的设计差别。 掌握dhtml的思想是至关重要的。"

上面就是我对IBM首页源代码的粗浅分析，由于水平有限，难免有错漏的地方，希望大家多多指教。

★★重拳出击强力打造落伍最长水渠★★
2003-6-5 11:27
江小刀
落伍者

积分 4252
发贴 4245
注册 2002-11-23
来自 行星风系
UP

行星风系http://www.planeting.net
2003-6-5 11:29
柳叶吹风
落伍者

积分 1123
发贴 1091
注册 2003-5-28
这不错了。。。

反对隐身！拒绝调戏！
You go your way , I'll go mine.
2003-6-5 11:30
剑枫
落伍者

积分 8242
发贴 7729
注册 2002-1-14
来自 西监狱213号房
考虑的比较多
这也许就是设计商业站经典前100名的原因吧
据说是 经典

很多设计的书籍上拿他和adobe的也缅当列子

★★重拳出击强力打造落伍最长水渠★★
2003-6-5 11:32
boyXP
落伍者

积分 757
发贴 755
注册 2002-1-31
经典``

弄影短信,给你想要的
http://www.dayxp.com/
2003-6-5 11:34
xboycn
落伍者

积分 4619
发贴 4611
注册 2002-7-5
来自 cn→zj
ＢＬＵＥＩＤＥＡ转的吧？

感谢落伍的朋友：丁丁|Delin|Arvan|imsaul|jarod…
云网数字卡直销商,出售各种数字卡

ＮＢＡ中国
2003-6-5 11:36
剑枫
落伍者

积分 8242
发贴 7729
注册 2002-1-14
来自 西监狱213号房

Quote:
Originally posted by xboycn at 2003-6-5 11:36 AM:
ＢＬＵＥＩＤＥＡ转的吧？

来源不名 已通知联邦调查局 追查”凶手“

★★重拳出击强力打造落伍最长水渠★★
2003-6-5 11:37
semon53
落伍者

积分 1160
发贴 1179
注册 2002-8-8
专业就是专业

哎~~~终于被MM说服了,ID共用。
2003-6-5 22:36
赵明亮
落伍者

积分 3603
发贴 3782
注册 2002-11-21
来自 湖州人在杭州5v6.com
好，巨好～～

最近更新电影列表
老婆被泡，情人被撬，赃款被盗，伟哥失效都碰上的人。。。。
2003-6-5 22:37
okwebhelp
落伍者

积分 1595
发贴 1501
注册 2001-8-17
你们去看看sina，查不多

相当全面和专业的配置服务器和安全手册
http://www.im286.com/viewthread.php?tid=224960
2003-6-5 22:49
剑枫
落伍者

积分 8242
发贴 7729
注册 2002-1-14
来自 西监狱213号房

Quote:
Originally posted by okwebhelp at 2003-6-5 10:49 PM:
你们去看看sina，查不多

★★重拳出击强力打造落伍最长水渠★★
2003-6-5 23:10
Neo98
落伍者

积分 772
发贴 1026
注册 2002-10-24
来自 湖北
看看微软的不错！

代理商务中国产品！更低的预付款诚征代理。http://www.jwsky.com/ http://www.skyidc.com/ QQ:68455835
出售域名：agentsky.com ejbcn.com
2003-6-6 00:44
剑枫
落伍者

积分 8242
发贴 7729
注册 2002-1-14
来自 西监狱213号房

Quote:
Originally posted by Neo98 at 2003-6-6 12:44 AM:
看看微软的不错！

ibm就是微软收藏的100个世界级商业站的其中只一

ibm的有两个也面被选中

★★重拳出击强力打造落伍最长水渠★★
2003-6-6 00:49
梦幻精灵
落伍者

积分 2610
发贴 2609
注册 2002-6-10
倒

软件，文章，音乐，商务，电影，笑话，游戏，新闻，图库，聊天，短信，旅游，FLASH，邮局，留言，江湖，论坛
------华轩网络CN86.com------
2003-6-6 00:52
seyou
落伍者

积分 595
发贴 604
注册 2002-7-25
Blueidea的文章，转的时候请留下作者和出处。有版权的。

[img]http://ads.china.com/ccb/490x95.gif[/img]
2003-6-6 00:58
<< [1] [2] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.029450 second(s), 5 queries, Gzip enabled


无标题文档

网络部分

a,网络技术
1. Serv-U配置图文教程 -- okwebhelp
2. 全国主机城市的DNS服务器 -- 潇寒
3. 世界各地IP段 -- sAsE,SHCS
4. 网络技术常用术语汉语对照 -- hailongcoboo
5. FTP使用精萃--FTP的内部命令 -- 伏地魔
6. 几款ADSL Modem的端口映射做法 -- 闷葫芦
7. 常用端口及其简要说明 -- 木耳
8. 局域网内如何实现邮件服务!! --L.G.
9. DNS完全解惑问答ZT

b,网络资源
1. 50个经典代理位置（收藏） -- jinsu
2. 国内有名的图片站~！建议斑竹之顶一下~！ -- 心点
3. 介绍几个LOGO背景网页素材网站~~~ -- cutefk
4. 【发布】阿江酷站统计最新 IP 库！-- 阿江
5.31例特效加原代码！！！ -- 星期天
6. 一些教程、字体网址 -- vicsy

c,网络安全
1. 常见IP碎片攻击详解 -- 伏地魔


落伍者论坛 - 资源讨论专栏 - 31例特效加原代码！！！ - powered by Discuz!

落伍者论坛 » 资源讨论专栏 » 31例特效加原代码！！！

作者:
标题: 31例特效加原代码！！！ 上一主题 | 下一主题
星期天
落伍者

积分 1119
发贴 1050
注册 2003-2-16
来自 广西防城港市
31例特效加原代码！！！

在网建上发得不到认可~移到资源看一下！
确实不错的东西~不想这样就被埋没啦~~~

http://www.idescn.com/fictiony/2003idea/01.swf
http://www.idescn.com/fictiony/2003idea/01.fla
一个三维弹动的小球

http://www.idescn.com/fictiony/2003idea/02.swf
http://www.idescn.com/fictiony/2003idea/02.fla
数学上一个混沌模型的flash模拟

http://www.idescn.com/fictiony/2003idea/03.swf
http://www.idescn.com/fictiony/2003idea/03.fla
象草籽一样会粘成一团的效果

http://www.idescn.com/fictiony/2003idea/04.swf
http://www.idescn.com/fictiony/2003idea/04.fla
可以用鼠标点击弹动的小球

http://www.idescn.com/fictiony/2003idea/05.swf
http://www.idescn.com/fictiony/2003idea/05.fla
三维的草丛

http://www.idescn.com/fictiony/2003idea/06.swf
http://www.idescn.com/fictiony/2003idea/06.fla
两个小球间的电流束效果

http://www.idescn.com/fictiony/2003idea/07.swf
http://www.idescn.com/fictiony/2003idea/07.fla
类似文本编辑器的AutoComplete功能，你可以打入example或者here等几个词看看

http://www.idescn.com/fictiony/2003idea/08.swf
http://www.idescn.com/fictiony/2003idea/08.fla
一个花筒样的效果，鼠标移上去可以变化颜色

http://www.idescn.com/fictiony/2003idea/09.swf
http://www.idescn.com/fictiony/2003idea/09.fla
运动的三角形碎片，很有设计的感觉

http://www.idescn.com/fictiony/2003idea/10.swf
http://www.idescn.com/fictiony/2003idea/10.fla
用圆组成的飘动的旗帜

http://www.idescn.com/fictiony/2003idea/11.swf
http://www.idescn.com/fictiony/2003idea/11.fla
还是一面差不多的旗帜，不过里面有字

http://www.idescn.com/fictiony/2003idea/12.swf
http://www.idescn.com/fictiony/2003idea/12.fla
电流效果

http://www.idescn.com/fictiony/2003idea/13.swf
http://www.idescn.com/fictiony/2003idea/13.fla
推球的小游戏，用鼠标把球推到篮框里去

http://www.idescn.com/fictiony/2003idea/14.swf
http://www.idescn.com/fictiony/2003idea/14.fla
这次是矩形的碎片，看上去也很有味道

http://www.idescn.com/fictiony/2003idea/15.swf
http://www.idescn.com/fictiony/2003idea/15.fla
一个鼠标跟随效果

http://www.idescn.com/fictiony/2003idea/16.swf
http://www.idescn.com/fictiony/2003idea/16.fla
线状分形的一种，很漂亮

http://www.idescn.com/fictiony/2003idea/17.swf
http://www.idescn.com/fictiony/2003idea/17.fla
两人对下的国际象棋，爆牛B，居然规则都有

http://www.idescn.com/fictiony/2003idea/18.swf
http://www.idescn.com/fictiony/2003idea/18.fla
随风飘动的芦苇杆子，还有倒映呢

http://www.idescn.com/fictiony/2003idea/19.swf
http://www.idescn.com/fictiony/2003idea/19.fla
掉落在波形曲线上的小球，碰撞检测哦

http://www.idescn.com/fictiony/2003idea/20.swf
http://www.idescn.com/fictiony/2003idea/20.fla
过三点做一条抛物线

http://www.idescn.com/fictiony/2003idea/21.swf
http://www.idescn.com/fictiony/2003idea/21.fla
自己生长的树

http://www.idescn.com/fictiony/2003idea/22.swf
http://www.idescn.com/fictiony/2003idea/22.fla
两棵这样的树，附赠一堆草

http://www.idescn.com/fictiony/2003idea/23.swf
http://www.idescn.com/fictiony/2003idea/23.fla
很漂亮的碎片效果，还带阴影的，本人爆喜欢

http://www.idescn.com/fictiony/2003idea/24.swf
http://www.idescn.com/fictiony/2003idea/24.fla
一样的碎片，这次会动了

http://www.idescn.com/fictiony/2003idea/25.swf
http://www.idescn.com/fictiony/2003idea/25.fla
好像长脚蜘蛛一样的东西，不知道用什么做的

http://www.idescn.com/fictiony/2003idea/26.swf
http://www.idescn.com/fictiony/2003idea/26.fla
圆弧线条构成的图案效果

http://www.idescn.com/fictiony/2003idea/27.swf
http://www.idescn.com/fictiony/2003idea/27.fla
围着鼠标转的线条，好像牛皮筋一样

http://www.idescn.com/fictiony/2003idea/28.swf
http://www.idescn.com/fictiony/2003idea/28.fla
好多泡泡好多泡泡

http://www.idescn.com/fictiony/2003idea/29.swf
http://www.idescn.com/fictiony/2003idea/29.fla
小赛车，左右方向键控制

http://www.idescn.com/fictiony/2003idea/30.swf
http://www.idescn.com/fictiony/2003idea/30.fla
神奇的血管效果

http://www.idescn.com/fictiony/2003idea/31.swf
http://www.idescn.com/fictiony/2003idea/31.fla
神奇的血管效果2

http://www.lzh520.com
-------御缘永远的家！
千贴留念：P免费提供10个主叶下载！！
http://im286.com/viewthread.php?tid=260519&fpage=3
2003-7-16 14:23
ldxjy
落伍者

积分 1796
发贴 1850
注册 2002-1-12
upup

好！

俺的论坛,重建初期，不定期送QQ
感谢SEJISHIKONE提供空间！
2003-7-16 14:31
zhlsk
落伍者

积分 822
发贴 840
注册 2002-11-26
来自 天府之国（成都）
好
2003-7-16 14:43
maxit
落伍者

积分 2434
发贴 2345
注册 2002-12-9
来自 Utah, USA
好東西~我抓我抓~

什麽都別説了...我是鐵公雞家族家長;無差別敗家流掌門;間歇性月光嗜好症患者;懶人聯盟幕後黑手;偶像破壞主義忠實信徒;FBI賞金$10W的軍火販子,愛好是鬱悶特長是跑題...你有意見嗎?
2003-7-16 14:54
hailongcoboo
落伍者

积分 3996
发贴 3963
注册 2002-12-11
来自 钟爱那一生
竟发好东西。嘎嘎~UP~！

西安网通空间 西安电信空间
打造落伍最便宜，服务最好的空间 支持asp 可200人在线论坛 100M---200G任何大小都可以 价格实在
演示：http://www.hulunbeier.com.cn/ QQ：822931
2003-7-16 14:57
星期天
落伍者

积分 1119
发贴 1050
注册 2003-2-16
来自 广西防城港市
谢谢支持！我顶上去

http://www.lzh520.com
-------御缘永远的家！
千贴留念：P免费提供10个主叶下载！！
http://im286.com/viewthread.php?tid=260519&fpage=3
2003-7-16 15:52

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.068231 second(s), 5 queries, Gzip enabled


落伍者论坛 - 资源讨论专栏 - 50个经典代理位置（收藏） - powered by Discuz!

落伍者论坛 » 资源讨论专栏 » 50个经典代理位置（收藏）

作者:
标题: 50个经典代理位置（收藏） 上一主题 | 下一主题
jinsu
落伍者

积分 477
发贴 431
注册 2002-5-7
50个经典代理位置（收藏）

50个经典代理位置（收藏）
http://bismark.caltanet.it/proxylist/ ;
http://proxylist.virtualave.net/ ;
http://www.hitbot.f2s.com/proxylist.html ;
http://www.polito.it/~maino/proxylist.html ;
http://www.geocities.com/supermanisdeath/PROXYLIST.html ;
http://proxylist.hypermart.net/list.htm ;
http://members.tripod.com/~webmaster5/proxylist.txt ;
http://www.bol.ucla.edu/services/proxy/proxylist.html ;
http://www.freebsd.dem.ru/txt/proxylist.txt ;
http://www.xecurenet.com/proxylist.htm ;
http://mitternachtop.narod.ru/proxylist/proxy_list.htm ;
http://sponsors.hypermart.net/proxylist.txt ;
http://www.polito.it/~montru/en-proxylist.html ;
http://www.wardom.org/html/proxylist.shtml ;
http://www.fearfactorteam.com/proxy.php?op=proxylist&sortby=ip ;
http://www.freebiechannel.com/proxylist.html ;
http://www.avalanche.km.ru/index.php?location=proxylist&url=list ;
http://ishubin.h1.ru/index.htm?/frames/proxylist.htm ;
http://qyj88.3322.net/proxylist.htm ;
http://www.proxylist.xs3.com/ ;
http://www.top-top.ru/internet/lib/server/proxy/proxylist.htm ;
http://surfs.chat.ru/proxylist.htm ;
http://www15.big.or.jp/~sagawa/proxylist.html ;
http://gipshack.ru/proxylist.php ;
http://hack-info.ru/xakep/proxylist.htm ;
http://setifrance.free.fr/proxylist.htm ;
http://makeeasymoney.narod.ru/proxylist.htm ;
http://xukai.533.net/proxylist.htm ;
http://www.madalf.ru/proxylist.shtm ;
http://www20.brinkster.com/divisionbyzero/proxylist.html ;
http://www5.ocn.ne.jp/~nande/proxylist.html ;
http://www.mmtr.or.jp/customer/proxylist.html ;
http://baskar.chat.ru/proxylist.htm ;
http://underthenet.supereva.it/proxylist.htm?p ;
http://ehiv.myetang.com/proxylist.htm ;
http://e24web.net/proxylist/20020316.shtml ;
http://members.tripod.com/anonimsite/proxylist.htm ;
http://users.pandora.be/divisionbyzero/proxylist.html ;
http://storm.prohosting.com/psozeek/proxylist.txt ;
http://www.kisweb.ne.jp/personal/norihito/proxylist.htm ;
http://www.multiproxy.org/all_list.htm ;
http://www.wi11ie.com/text/proxylist.txt ;
http://cyber.cs.ntou.edu.tw/~hardaway/Document/proxylist.txt ;
http://members.fortunecity.com/proxylist/ ;
http://home6.swipnet.se/~w-61609/Proxies.htm ;
http://www.geocities.com/Silicon ;... /NonSpillArive.html
http://www.united-forum.de/proxy_list.txt ;
http://www.goeway.com/advanced/proxy/proxy_list/proxy_list_01.asp ;
http://mujweb.atlas.cz/www/anonymizer/proxy_list.htm ;
http://onecool.hypermart.net/ch/proxy_list.htm ;

我的永久网站
http://sucow.kom.cn
2003-7-5 22:33
鬼股子
落伍者

积分 2670
发贴 2708
注册 2002-10-22
来自 股市
谢谢你~

永久感谢ceo的QQ
永久感谢SHCS帮俺申请s1.x-beat，好人一生平安
红花因为绿叶才愈发好看，
精华因为灌水才愈发优秀。
2003-7-5 22:33
金星
落伍者

积分 280
发贴 308
注册 2003-6-12
来自 湖北宜昌
顶

欢迎访问 http://www.058.org/
小站开张，欢迎光顾！http://bbs.058.org/ 同时招聘斑竹
2003-7-5 22:34
qdjianhua
落伍者

积分 1340
发贴 1334
注册 2002-8-2
来自 青岛音乐网
让你受累了,真的很感谢!

----->感谢ajie.net送我玉米<-----
2003-7-5 22:34

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.044412 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - DNS完全解惑问答ZT - powered by Discuz!

落伍者论坛 » 网站建设专栏 » DNS完全解惑问答ZT

作者:
标题: DNS完全解惑问答ZT 上一主题 | 下一主题
丁丁
落伍者

积分 7466
发贴 7514
注册 2002-9-26
来自 家网
DNS完全解惑问答ZT

问：什么是“DNS”？其中文为何？

答：DNS，简单地说，就是Domain Name System，翻成中文就是“域名系统”。

问：DNS有什么用途？

答：在一个TCP/IP架构的网络（例如Internet）环境中，DNS是一个非常重要而且常用的系统。主要的功能就是将人易于记忆的Domain Name与人不容易记忆的IP Address作转换。而上面执行DNS服务的这台网络主机，就可以称之为DNS Server。基本上，通常我们都认为DNS只是将Domain Name转换成IP Address，然后再使用所查到的IP Address去连接（俗称“正向解析”）。事实上，将IP Address转换成Domain Name的功能也是相当常使用到的，当login到一台Unix工作站时，工作站就会去做反查，找出你是从哪个地方连线进来的（俗称“逆向解析”）。

问：DNS是怎么运作的？

答：DNS是使用层的方式来运作的。例如：哈工大紫丁香站的Domain Name为bbs.hit.edu.cn，这个Domain Name当然不是凭空而来的，是从.edu.cn所分配下来的。.edu.cn又是从.cn授予（delegation）的。.cn是从哪里来的呢？答案是从“.”，也就是所谓的“根域”（root domain）来的。根领域已经是Domain Name的最上层。而“.”这层是由InterNIC（Internet Network Information Center，互联网信息中心）所管理。全世界的Domain Name就是这样，一层一层的授予下来。

问：当我查一个Domain Name时，DNS是怎么查出它的IP的呢？

答：举个例子，假设今天我们查的Domain Name（作一个dns query）为bbs.hit.edu.cn时，DNS Server会这么处理：

(1) 你所用的电脑（可能是PC，也可能是工作站）送出一个问题给这台电脑所设定的DNS Server，提问：bbs.hit.edu.cn的IP是什么？

(2) 这台DNS会先看看是不是在它的cache中，如果是，就丢出答案。如果不是，就从最上头查起。在DNS Server上面一定有设定“.”要跟谁问。所以，这个时候它就往“.”层的任何一台DNS（目前“.”有13台）问：.cn要问谁？

(3) “.”层的DNS会回答.cn要向谁查（同时你用的DNS会cache起来这个答案）。

(4) 接下来你所用的DNS就会向.cn这层的DNS问：.edu.cn要问谁？

(5) .cn的这层就会回答.edu.cn要向谁查（同时你用的DNS也把这答案cache起来）。

(6)直到bbs.hit.edu.cn回答：bbs.hit.edu.cn的IP是202.118.224.2（又cache起来）。

经过了这么多的过程，终于得到了这个IP，接下来才能作进一步的连线。要注意的是，在每一层都会问一个问题，并且把答案记下来（cache起），而且还会忘掉（看该层的设定是要cache多久）。

问：DNS要怎么设置？

答：如果，只是要使用DNS，那只要在TCP/IP的网络属性中设置即可。设置的方法跟使用的操作系统有关。例如：Windows 9x在“控制面板”→“网络”→“TCP/IP”→“属性”中，找到DNS的部分再来设置。Unix在/etc/resolv.conf这个文件中设置（如果，要架设一台DNS Server，就不是在这里讨论的了）。

问：哪一台 DNS 资料最新？

答：如果你知道DNS是利用阶层架构运作的，那就应该知道，离你最近的DNS，就是最好的。

专业代理神话科技（有个网络）、商务中国、中资源、新网互联等国内多家公司以及香港等公司的虚拟主机、域名服务，欢迎选购！
QQ：46855115 （请注明购买主机或域名，谢谢合作）
2003-7-11 10:55
ejan
落伍者

积分 6870
发贴 6694
注册 2002-5-8
来自 @__________________@
加十分。

偶爱这里所有可爱的版主同志！
A-Do.net[阿杜]网站出售,BBsex.Net [BBS&Sex]和inBJ.Net[在北京]出售！ 详情点击这里!
2003-7-11 10:55
天灰灰
落伍者

积分 8181
发贴 7719
注册 2002-10-16
来自 囡天小屋
TTTTTTTT

骨灰地带
2003-7-11 10:55
SOFZ
落伍者

积分 757
发贴 787
注册 2002-5-29
不错
2003-7-11 10:55
Liguru
落伍者

积分 98
发贴 98
注册 2003-3-19
唉，落伍真是缺乏专业精神。

鲜见有人注明文章出处的。
2003-7-11 12:03
那个那个谁
落伍者

积分 10998
发贴 11020
注册 2002-4-15
单宁酸?
2003-7-11 12:05
丁丁
落伍者

积分 7466
发贴 7514
注册 2002-9-26
来自 家网

Quote:
Originally posted by Liguru at 2003-7-11 12:03 PM:
唉，落伍真是缺乏专业精神。

鲜见有人注明文章出处的。

转了n到手拉，不知道谁泻的

专业代理神话科技（有个网络）、商务中国、中资源、新网互联等国内多家公司以及香港等公司的虚拟主机、域名服务，欢迎选购！
QQ：46855115 （请注明购买主机或域名，谢谢合作）
2003-7-11 12:09
仙鹤
落伍者

积分 1001
发贴 1187
注册 2002-5-22
来自 fiyour.co.sr
好全啊

http://fiyour.co.sr
http://fiyour.qqvip.com/bbs
http://fiyour.qqvip.com/music
fiyour@vip.sina.com
[img]http://fiyour.1816.net/images/write03.gif[/img]
2003-7-11 12:16
苍生一笑
落伍者

积分 6866
发贴 6898
注册 2002-4-10
来自 黑鹰坠落的地方
Tcp/ip

Quote:
到我这里注玉米,免费赠送所注玉米的 Logo(88×31) 一个。联系QQ:42186431
在水边缘那里做主持咯，希望大家能多多捧场
强烈鄙视那些签名鬼大的人！！！

2003-7-11 12:17
niba
落伍者

积分 3519
发贴 3537
注册 2002-6-13
这也行,那偶站上的算什么

S1.似融网络www.sron.net
S2.似融网络niba.vipcn.com
2003-7-11 12:18
Liguru
落伍者

积分 98
发贴 98
注册 2003-3-19

Quote:
Originally posted by 丁丁 at 2003-7-11 12:09:

转了n到手拉，不知道谁泻的

这不是理由啊。

不知道出处至少要交代一下，这和不写是有质的区别的。

所以说国内知识产权意识薄弱，希望大家慢慢重视起来。。。
2003-7-11 12:18
丁丁
落伍者

积分 7466
发贴 7514
注册 2002-9-26
来自 家网
不好意思，下次注意

专业代理神话科技（有个网络）、商务中国、中资源、新网互联等国内多家公司以及香港等公司的虚拟主机、域名服务，欢迎选购！
QQ：46855115 （请注明购买主机或域名，谢谢合作）
2003-7-11 12:20

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.027198 second(s), 5 queries, Gzip enabled


落伍者论坛 - 资源讨论专栏 - FTP使用精萃--FTP的内部命令 - powered by Discuz!

落伍者论坛 » 资源讨论专栏 » FTP使用精萃--FTP的内部命令

作者:
标题: FTP使用精萃--FTP的内部命令 上一主题 | 下一主题
伏地魔
落伍者

积分 1669
发贴 1494
注册 2002-9-20
FTP使用精萃--FTP的内部命令

FTP命令是Internet用户使用最频繁的命令之一，不论是在DOS还是UNIX*作系统
下使用FTP，都会遇到大量的FTP内部命令。 熟悉并灵活应用FTP的内部命令，可
以大大方便使用者，并收到事半功倍之效。
FTP的命令行格式为： ftp -v -d -i -n -g [主机名] ，其中

-v 显示远程服务器的所有响应信息；

-n 限制ftp的自动登录，即不使用；

.n etrc文件；

-d 使用调试方式；

-g 取消全局文件名。

ftp使用的内部命令如下(中括号表示可选项):

1.![cmd[args]：在本地机中执行交互shell，exit回到ftp环境，如：!ls*
.zip.

2.$ macro-ame[args]：执行宏定义macro-name.

3.account[password]：提供登录远程系统成功后访问系统资源所需的补充口
令。

4.append local-file[remote-file]：将本地文件追加到远程系统主机，若
未指定远程系统文件名，则使用本地文件名。

5.ascii：使用ascii类型传输方式。

6.bell：每个命令执行完毕后计算机响铃一次。

7.bin：使用二进制文件传输方式。

8.bye：退出ftp会话过程。

9.case：在使用mget时，将远程主机文件名中的大写转为小写字母。

10.cd remote-dir：进入远程主机目录。

11.cdup：进入远程主机目录的父目录。

12.chmod mode file-name：将远程主机文件file-name的存取方式设置为mo
de，如： chmod 777 a.out 。

13.close：中断与远程服务器的ftp会话(与open对应)。

14.cr：使用asscii方式传输文件时，将回车换行转换为回行。

15.delete remote-file：删除远程主机文件。

16.debug[debug-values]：设置调试方式， 显示发送至远程主机的每条命令
，如： deb up 3，若设为0，表示取消debug。

17.dir[remote-dir][local-file]：显示远程主机目录，并将结果存入本地
文件local-file。

18.disconnection：同close。

19.form format：将文件传输方式设置为format，缺省为file方式。

20.get remote-file[local-file]： 将远程主机的文件remote-file传至本
地硬盘的local-file。

21.glob：设置mdelete，mget，mput的文件名扩展，缺省时不扩展文件名，
同命令行的-g参数。

22.hash：每传输1024字节，显示一个hash符号(#)。

23.help[cmd]：显示ftp内部命令cmd的帮助信息，如：help get。

24.idle[seconds]：将远程服务器的休眠计时器设为[seconds]秒。

25.image：设置二进制传输方式(同binary)。

26.lcd[dir]：将本地工作目录切换至dir。

27.ls[remote-dir][local-file]：显示远程目录remote-dir， 并存入本地
文件local-file。

28.macdef macro-name：定义一个宏，遇到macdef下的空行时，宏定义结束
。

29.mdelete[remote-file]：删除远程主机文件。

30.mdir remote-files local-file：与dir类似，但可指定多个远程文件，
如： mdir *.o.*.zipoutfile 。

31.mget remote-files：传输多个远程文件。

32.mkdir dir-name：在远程主机中建一目录。

33.mls remote-file local-file：同nlist，但可指定多个文件名。

34.mode[modename]：将文件传输方式设置为modename， 缺省为stream方式
。

35.modtime file-name：显示远程主机文件的最后修改时间。

36.mput local-file：将多个文件传输至远程主机。

37.newer file-name： 如果远程机中file-name的修改时间比本地硬盘同名
文件的时间更近，则重传该文件。

38.nlist[remote-dir][local-file]：显示远程主机目录的文件清单，并存
入本地硬盘的local-file。

39.nmap[inpattern outpattern]：设置文件名映射机制， 使得文件传输时
，文件中的某些字符相互转换，如：nmap $1.$2.$3[$1，$2].[$2，$3]，则传输
文件a1.a2.a3时，文件名变为a1，a2。该命令特别适用于远程主机为非UNIX机的
情况。

40.ntrans[inchars[outchars]：设置文件名字符的翻译机制，如ntrans
1R，则文件名LLL将变为RRR。

41.open host[port]：建立指定ftp服务器连接，可指定连接端口。

42.passive：进入被动传输方式。

43.prompt：设置多个文件传输时的交互提示。

44.proxy ftp-cmd：在次要控制连接中，执行一条ftp命令， 该命令允许连
接两个ftp服务器，以在两个服务器间传输文件。第一条ftp命令必须为open，以
首先建立两个服务器间的连接。

45.put local-file[remote-file]：将本地文件local-file传送至远程主机
。

46.pwd：显示远程主机的当前工作目录。

47.quit：同bye，退出ftp会话。

48.quote arg1，arg2...：将参数逐字发至远程ftp服务器，如：quote sys
t.

49.recv remote-file[local-file]：同get。

50.reget remote-file[local-file]：类似于get，但若local-file存在，则
从上次传输中断处续传。

51.rhelp[cmd-name]：请求获得远程主机的帮助。

52.rstatus[file-name]：若未指定文件名，则显示远程主机的状态，否则显
示文件状态。

53.rename[from][to]：更改远程主机文件名。

54.reset：清除回答队列。

55.restart marker：从指定的标志marker处，重新开始get或put，如：res
tart 130。

56.rmdir dir-name：删除远程主机目录。

57.runique：设置文件名唯一性存储，若文件存在，则在原文件后加后缀..
1，.2等。

58.send local-file[remote-file]：同put。

59.sendport：设置PORT命令的使用。

60.site arg1，arg2...：将参数作为SITE命令逐字发送至远程ftp主机。

61.size file-name：显示远程主机文件大小，如：site idle 7200。

62.status：显示当前ftp状态。

63.struct[struct-name]：将文件传输结构设置为struct-name， 缺省时使
用stream结构。

64.sunique：将远程主机文件名存储设置为唯一(与runique对应)。

65.system：显示远程主机的*作系统类型。

66.tenex：将文件传输类型设置为TENEX机的所需的类型。

67.tick：设置传输时的字节计数器。

68.trace：设置包跟踪。

69.type[type-name]：设置文件传输类型为type-name，缺省为ascii，如：
type binary，设置二进制传输方式。

70.umask[newmask]：将远程服务器的缺省umask设置为newmask，如：umask
3。

71.user user-name[password][account]：向远程主机表明自己的身份，需
要口令时，必须输入口令，如：user anonymous my@email。

72.verbose：同命令行的-v参数，即设置详尽报告方式，ftp服务器的所有响
应都将显示给用户，缺省为on.

够酷BBS Gò Kù Bì Bì Sī
2003-7-1 21:57
爱我家
落伍者

积分 1429
发贴 1187
注册 2002-8-11
来自 爱我家社区
好东西啊，为什么没人顶？

欢迎到爱我家社区欢迎到武术吧我的QQ现在改了：674910！
2003-7-1 21:59

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.025794 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - ●●■■●●Serv-U配置图文教程 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » ●●■■●●Serv-U配置图文教程

作者:
标题: ●●■■●●Serv-U配置图文教程 上一主题 | 下一主题
okwebhelp
落伍者

积分 1595
发贴 1501
注册 2001-8-17
●●■■●●Serv-U配置图文教程

第一节 Serv-U的安装和基本设置

一、下载和安装

1、下载。http://download.yesky.com/servlet/mydown.yeskydown?tag=7&objID=29801&se=1
（ServU3b7.zip，1.33M，3.0 Beta build 7）

2、安装。展开压缩文件“ServU3b7.zip”，执行其中的“setup.exe”，即可开始安装；全部选默认选项即可。安装完成后不需重新启动，直接在“开始→程序→Serv-U FTP Server”中就能看到相关文件。如下图：

二、建立第一个可用的FTP服务器

1、比如本机IP地址为“192.168.0.48”，已建立好域名“ftp.bbc.com”的相关DNS记录。

2、打开Serv-U管理器。选上图的“Serv-U Administrator”，即出现“Setup Wizard”（设置向导）。此向导可以帮你轻松地完成基本设置，因此建议使用它。直接选“Next”（下一步）。如下图：

3、请随着安装向导按以下步骤来进行操作：

⑴IP address（IP地址）：输入“192.168.0.48”。（如果使用动态的IP地址，或无合法的IP地址则此项应保持为空。）

⑵Domain name（域名）：输入“ftp.bbc.com”。

⑶Install as system server（安装成一个系统服务器吗）：选“Yes”。

⑷Allow anonymous access（接受匿名登录吗）：此处可根据自己需要选择；比如选“Yes”。

⑸anonymous home directory（匿名主目录）：此处可输入（或选择）一个供匿名用户登录的主目录。

⑹Lock anonymous users in to their home directory（将用户锁定在刚才选定的主目录中吗）：即是否将上步的主目录设为用户的根目录；一般选“Yes”。

⑺Create named account（建立其他帐号吗）：此处询问是否建立普通登录用户帐号；一般选“Yes”。

⑻Account login name（用户登录名）：普通用户帐号名，比如输入“nanshan”。

⑼Password（密码）：设定用户密码。由于此处是用明文（而不是＊）显示所输入的密码，因此只输一次。

⑽Home directory（主目录）：输入（或选择）此用户的主目录。

⑾Lock anonymous users in to their home directory（将用户锁定在主目录中吗）：选“Yes”。

⑿Account admin privilege（帐号管理特权）：一般使用它的默认值“No privilege”（普通帐号）。

⒀最后选“Finish”（结束）即完成设置。如下图：

4、从上图中可以看到，现在已经建立好了一个FTP服务器，服务器地址为“ftp.bbc.com”，其下有两个用户，一个是匿名用户“Anonymous”，其密码为空；一个是普通用户“nanshan”，其密码为在向导中输入的内容。

5、基本权限。比如在左边的面板中选中“nanshan”用户，则在右边的面板中出现如下图的设置窗口。选“Dir Access”（目录存取权限），即可设置此用户在它的主目录（即“Path”）是否对文件拥有“Read”（读）、Write（写）、“Append”（写和添加）、“Delete”（删除）、“Execute”（执行）；是否对目录拥有“List”（显示文件和目录的列表）、“Create”（建立新目录）和“Remove”（修改目录，包括删除，移动，更名）；及“Inherit”（以上权限是否包括它下面的目录树）等等。

三、使用此FTP服务器

1、DOS下的登录格式。如“ftp ftp.bbc.com”。

2、浏览器中的登录格式。如“ftp://ftp.bbc.com/”。

3、FTP客户端应用软件的设置。比如在CuteFTP中，如下图：

[ Last edited by okwebhelp on 2003-6-11 at 07:36 PM ]

相当全面和专业的配置服务器和安全手册
http://www.im286.com/viewthread.php?tid=224960
2003-6-11 19:27
okwebhelp
落伍者

积分 1595
发贴 1501
注册 2001-8-17
请不要回复

相当全面和专业的配置服务器和安全手册
http://www.im286.com/viewthread.php?tid=224960
2003-6-11 19:27
潇寒
落伍者

积分 4149
发贴 3525
注册 2001-6-15
我就回复。

在线银行支付平台，网上商城，空间出租，域名注册，在线电影观看下载，联系QQ：2009884
2003-6-11 19:28
okwebhelp
落伍者

积分 1595
发贴 1501
注册 2001-8-17
第二节 Serv-U 管理器

一、“Local Server”（本地服务器）属性

1、Local Server（本地服务器）：此处可设置是否自动开启FTP服务以及手动开启或停止FTP服务等。

2、License（许可证）：共享版此项无内容。

3、Settings（设置）：

⑴General/Max. speed：可设置最大传输速率（kb/s）。

⑵General/Max. no. of users：可设置连接到本服务器的最多用户数。

⑶General的其他项目均与保持服务器的安全性有关。

4、Activity（活动状态）：

⑴Users（用户）：显示当前登录的用户IP地址等资料及当前工作状态；建议选中“Auto reload”（自动刷新）。如果选中某个用户，单击右键，再选“Kill User”，即可将它从服务器中踢出去。

⑵Blocked IPs（被挡住的IP）：此处用来暂时禁止某些IP访问本系统。单击工具栏的“＋”即可增加即可增加被暂时禁止的IP地址及禁止登录的总时间（从增加之后开始计算）。列表中可以看见被禁止的IP地址及其对应的计算机的完整的域名和离解禁尚有多少时间（以秒为单位）等等。在列表中单击右键即可以选择删除已禁止的IP地址。

⑶Session Log（系统日志）：记录所有登录（或试图登录）到本机的操作痕迹及错误信息等。

二、“Domains”（域名）属性

1、ftp.bbc.com（即选中的FTP服务器名）：此处可修改相应域名、IP地址及端口号等。

2、Settings（设置）：完全允许或禁止登录的IP地址等。

⑴General/Max no. of Users（最大用户数）：此处可以设置允许同时登录到本FTP服务器的最大用户数。

⑵IP Access/Deny access（拒绝）：此处可设置仅仅拒绝登录到本FTP服务器的计算机的IP地址列表。

⑶IP Access/Allow access（允许）：此处可设置仅仅允许登录到本FTP服务器的计算机的IP地址列表。

⑷IP Access/Rule（规则）：此处可输入指定的IP地址或IP地址的范围。接受如“192.168.0.88”之类的单个IP地址；接受如“192.168.0.4-192.168.0.11”之类的IP地址范围；接受如“192.168.0.*”之类的通配符；接受如“192.168.0.1?”之类的单个字符的限制等多种格式。“Add”为添加，“Remove”为删除。

⑸Message（信息）：此处可改变一些提示性显示信息，如“Signon message file”（开始广播）、“Server offline”（服务器未工作）、“No anonymos access”（不接受匿名登录）等等。

3、Activity（活动状态）：

⑴Users（用户）：显示登录到本服务器的用户及其状态；建议选中“Auto reload”（自动刷新）。

⑵Domain Log（系统日志）：记录所有登录（或试图登录）到本服务器的操作痕迹及错误信息等。

4、Groups（组）：

⑴利用Groups（组）可以预先建立好一个或多个确定了属性（读写等）和控制权限（授予或禁止某些IP地址访问）的目录，以后当我们建立新的用户，需要用到这些目录时，就直接添加进去就行了，不用再进行重复设置，组的建立可以大大减轻设置工作量。

⑵建立一个新组：选“Group→右键→New Group”，然后在“Group name”中输入组的名字再按“finish”（结束）即可。如下图：

⑶设置“Dir Access”（目录存取权限）：在此处选“Add”（增加）增加目标目录（可多个），然后再为它们逐个设置存取权限。本项具体设置请参见本教程后文相关内容。

⑷设置“IP Access”（IP控制）：此项的具体设置请参见本文前列相关内容。

⑸组的复制：可以像复制文件一样复制所建立的组。选中组名，单击右键，再选“Copy Group”即可复制此组，选几次就复制几个。真是好功能！^-^

⑹使用“Group”（组）：在“Users”下选中要使用组的用户名，再点击右边面板中“Group(s)”后的图标，选择所需要的组名（可用Ctrl键或Shift键来同时选中多个组；多个组名会自动以逗号进行分隔）。

⑺进入“Dir Access”，再按工具栏的刷新图标（书图标左边的那个），即可看到最后的效果。如下图：

相当全面和专业的配置服务器和安全手册
http://www.im286.com/viewthread.php?tid=224960
2003-6-11 19:28
kuangri
落伍者

积分 4347
发贴 4701
注册 2002-8-28
落伍

横眉冷对秋波,俯首甘为淫棍！！
2003-6-11 19:29
okwebhelp
落伍者

积分 1595
发贴 1501
注册 2001-8-17
第三节 Serv-U用户属性之“Account”（帐号）

一、Account（帐号）选项。如下图：

二、各项说明和应用实例

1、Disable account（禁用帐号）：如果选中它，则此帐号将无法使用。

2、User name（用户名）：此处显示并可改变该用户的登录名；修改后，左边面板的用户名也会自动作相应的变更。

3、Group(s)（组）：如果有建立组，则此处可通过选择组来更多的目录。这些组中目录的属性由建立组时确定，用户在“Dir Access”中不能修改！如果组用户的主目录不在根目录（见下面第5项说明）所包含的目录树之内，则此组用户无法进入。

4、Password（密码）：此项为“<<Encrypted>>”（加密）说明有密码，为保密，因此内容不予显示。如果为空白，则不需密码；如有输入任何密码均显示“<<Encrypted>>”。

5、Home directory（主目录）：此处原则上为用户登录后的根目录；但实际上，当该用户登录后，它的根目录是哪一个还得看“General”（常用）属性中的“Lock user in home directory”（将用户锁定在其主目录中）来决定。

⑴比如此处路径为“d:\myweb”，“General”中相应项为选中，则主目录和根目录均为“d:\myweb”。

⑵再比如此处路径为“d:\myweb”，“General”中相应项为不选中，则主目录为“d:\myweb”，而根目录则为“d:\”。

⑶注意：此处可据情修改，但不能超出“Dir Access”中“Path”所在盘的范围，否则登录后你将什么也看不见！

⑷建议一般不要修改此项！

6、Notes（备注）：此项用来标注一些说明性的文字。

相当全面和专业的配置服务器和安全手册
http://www.im286.com/viewthread.php?tid=224960
2003-6-11 19:29
Jay
落伍者

积分 4620
发贴 4619
注册 2002-9-28
来自 原產臺北 出口巴西 轉銷大陸
很詳細，適合新手使用，建議列個精華

Quote:

MC FORUM 2003(V2.0製作中。。。)

2003-6-11 19:29
okwebhelp
落伍者

积分 1595
发贴 1501
注册 2001-8-17
能不落伍么？我只是想让大家以后查资料可以来落伍，而不用去pconline/yesky/ccidnet/cce

[ Last edited by okwebhelp on 2003-6-11 at 07:37 PM ]

相当全面和专业的配置服务器和安全手册
http://www.im286.com/viewthread.php?tid=224960
2003-6-11 19:30
okwebhelp
落伍者

积分 1595
发贴 1501
注册 2001-8-17
第四节 Serv-U用户属性之“General”（常用）

一、“General”（常用）选项。如下图：

二、各项说明和应用实例

1、Lock user in home directory（将用户锁定在主目录）：如果选中则只允许用户访问“主目录”以下的文件和目录（主目录即为根目录）；如果不选中，则用户可一直访问到主目录所在盘的实际根目录（比如“d:\”）下——当然，可能并没有读其下其他文件目录或写等权限，但是仍建议一般选中此项。

2、Hide 'hidden' files（隐藏“隐含”文件）：在列表时不显示属性为“隐含”的文件。

3、Always allow login（总是接受登录）：本帐户永远有效。

4、Allow only N login(s) from same IP address（只接受同一个IP地址的N个用户登录）：对于限制外部局域网接入的机器数量非常有用！

5、Allow user to change password（接受用户改变密码）：有些FTP客户端有允许用户改变自己FTP密码的功能，此处就是为它们准备的。

6、Max. upload speed（最大上载速率）：可以限制客户端上传文件的最大速率（以kb/s为单位）。

7、Max. download speed（最大下载速率）：下传文件的最大速率（以kb/s为单位）。

8、Idle time-ou（空闲溢出时间）：超过某分钟不工作（读写等操作）就丢弃已产生的连接。

9、Max. no. of users（最大用户数）：允许同时连接到本服务器的最多的用户数目。

10、Logging message file（登录信息文件）：在这里可以输入（或选择）一个事先建立好的文本文件（一般）的完整路径和文件名，登录成功之后就会出现相关提示信息。提示信息如下图：

相当全面和专业的配置服务器和安全手册
http://www.im286.com/viewthread.php?tid=224960
2003-6-11 19:31
okwebhelp
落伍者

积分 1595
发贴 1501
注册 2001-8-17
第五节 Serv-U用户属性之“Dir Access”（目录存取属性）

一、“Dir Access”（目录存取属性）选项。如下图：

二、各项说明和应用实例

1、Path（路径）：目录所在的实际路径；Access（属性）：存取属性；Group（组）：所属组。

2、Files/Read（读）：对文件进行“读”操作（复制、下载；不含查看）的权力。

3、Files/Write（写）：对文件进行“写”操作（上传）的权力。

4、Files/Append（附加）：对文件进行“写”操作和“附加”操作的权力。

5、Files/Delete（删除）：对文件进行删除（上传、更名、删除、移动）操作的权力。

6、Files/Execute（执行）：直接运行可执行文件的权力。

7、Directories/List（列表）：对文件和目录的查看权力。

8、Directories/Create（建立）：建立目录的权力。

9、Directories/Remove（移动）：对目录进行移动、删除和更名的权力。

10、Inherit（继承）：如选中则以上所选属性对所选“Path”中指定目录以下整个目录树起作用；否则就只对当前目录起作用。

11、对于有多个“Path”的情况，有时顺序是至关重要的。比如主目录为“d:\myweb”，其下有一个路径为“d:\myweb\win98”的目录，现在想让当前用户对“d:\myweb\win98”只能有查看权力，而对主目录下其他目录则有完全控制的权力。需要：

⑴“Add”一个“Path”，选择“d:\myweb”，权限为所有都选中（特别要包括“Inherit”）；再“Add”另一个“Path”，选择“d:\myweb\win98”，权限为只选“List”（列表）。

⑵如果主目录在前，另一个目录在后，则你登录进去后就会发现，你对“win98”目录一样有完全控制权！

⑶但是如果你把主目录放在后，另一个目录在前，则结果正是你所需要的。

因此，可以总结出，此处设置的基本规律是，有特殊属性的放在前面，共用属性的放在后面！

相当全面和专业的配置服务器和安全手册
http://www.im286.com/viewthread.php?tid=224960
2003-6-11 19:32
okwebhelp
落伍者

积分 1595
发贴 1501
注册 2001-8-17
第六节 Serv-U用户属性之完结

一、“IP Access”（IP访问）选项。

1、Deny Access（拒绝访问）：选中此项则下面列出的IP地址被拒绝访问此FTP服务器。

2、Allow Access（允许访问）：选中此项则只有下面列出的IP地址被允许访问此FTP服务器。

3、Rule（规则）：在此处输入IP地址，再按向下的手图标则被加进列表；向上的手是删除选中的IP地址。

二、“UL／DL Ratios”（上传／下载比例）选项。

三、“Quota”（配额）选项。

1、Enable disk quota（允许磁盘配额）：如选中此项则可设定上传空间的大小。

2、Current（当前）：这里显示的是已用空间；可通过按“Calculate current”按钮来得到此值。

3、Maximum（最大）：这里可设定最大的上传空间。如下图：

4、以上单位均为“kb”（千字节）。

四、其他操作

1、增加新的FTP服务器：选左边面板中的“Domains→右键→New Domain”，再提示操作即可。需要注意的是，如果它与现有的FTP服务器使用同一个IP地址，则必须选不同的端口号！

2、删除FTP服务器：选中左边面板中的相应服务器名，再选“右键→Delete”即可。

3、建立新用户：选中左边面板中的相应服务器名，再选“右键→New User”即可。

4、删除用户：选中左边面板中的相应用户名，再选“右键→Delete User”即可。

5、复制用户：选中左边面板中的相应用户名（也可在其右边面板的任意处），再选“右键→Copy User”即可。此项也非常有用！如下图所示：

end，我正是步入贴转贴的大门，不过，我要说：转贴也是要保证质量的

相当全面和专业的配置服务器和安全手册
http://www.im286.com/viewthread.php?tid=224960
2003-6-11 19:35

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.030334 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 一些教程、字体网址________ - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 一些教程、字体网址________

作者:
标题: 一些教程、字体网址________ 上一主题 | 下一主题
vicsy
落伍者

积分 3673
发贴 3708
注册 2002-10-1
一些教程、字体网址________

卡通人物面部造型入门
http://www.yesky.com/20020203/217080_6.shtml

FW教程
http://www.tel-net.com.cn/ahua/websheji/effect/effect.asp

国外PS高级教程
http://www.geda-online.com/tutorials.htm

http://robouk.mchost.com/tuts/ps.php

http://www.gurusnetwork.com/tutorials/photoshop/index.html

FW国外教程(含4.0 Mx) - 经典
http://www.solardreamstudios.com/tutorials/fw/

国外精品像素网站
http://www.mrwong.de/index1.htm

韩文字体
http://plaza1.snu.ac.kr/~elf1004/home/home.htm

国外英文字体下载
http://www.1001fonts.com/fonts_overview.html?page=1&category_id=1

http://ff.stoneskin.com/font_list.htm?Font=e1

http://www.fontparadise.com/fonts.asp

LOGO字体
http://www.dsg4.com/04/extra/bitmap/index.html
2003-7-22 10:48
鲜每の℃
落伍者

积分 3290
发贴 3326
注册 2002-8-20
来自 华南理工大学
收了。

中国破解组织联盟CCG
China Cracking Group
看雪学院：http://www.pediy.com/
强烈建议各位朋友去我的论坛。
2003-7-22 10:49
willi
落伍者

积分 4157
发贴 4228
注册 2002-1-29
收藏

Yeke.com|7755.Net|SmsCn.Com for sale

2003-7-22 10:50
nbinfo
落伍者

积分 6688
发贴 6500
注册 2002-8-7
来自 CHINA 中国 SEX
哪来的啊

本站出售 音乐程序 分2种ACCESS版本跟MSSQL版本，包括35000首歌曲文件
联系QQ ：19755866 805570
演示地址http://www.nbsky.net/
主机租用托管
2003-7-22 10:51
0129
落伍者

积分 2596
发贴 2574
注册 2002-12-3
thanks!

努力学习中！
2003-7-22 10:55

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.040912 second(s), 5 queries, Gzip enabled


落伍者论坛 - 资源讨论专栏 - IP段 - powered by Discuz!

落伍者论坛 » 资源讨论专栏 » IP段

作者:
标题: IP段 上一主题 | 下一主题
sAsE
落伍者

积分 5196
发贴 4634
注册 2003-2-14
IP段

 http://freesky.cn/ip.txt
如果还有没有收集到的请联系我

歓迎するwǒ xīn fēi yáng
最新最齊的免費空間.안정의 고속의 상업의 공간.
2003-6-28 18:40
SHCS
今天你落伍了没有？

积分 6371
发贴 5782
注册 2003-2-15
来自 我的家
61.216.13.0 - 61.216.13.255 中国 台湾省（我们一定要解放台湾！！！）台北市
61.217.179.0 - 61.217.179.255 中国 台湾省（我们一定要解放台湾！！！）台南市
61.220.80.0 - 61.220.150.255 中国 台湾省（我们一定要解放台湾！！！）台北市
61.224.0.0 - 61.224.255.255 中国 台湾省（我们一定要解放台湾！！！）台北市
140.112.0.0 - 140.112.255.255 中国 台湾省（我们一定要解放台湾！！！）台湾大学
163.13.0.0 - 163.13.255.255 中国 台湾省（我们一定要解放台湾！！！）教育部
163.28.0.0 - 163.32.77.255 中国 台湾省（我们一定要解放台湾！！！）台北市
163.32.81.0 - 163.32.255.255 中国 台湾省（我们一定要解放台湾！！！）台北市
168.95.0.0 - 168.95.9.255 中国 台湾省（我们一定要解放台湾！！！）中华电信
168.95.10.0 - 168.95.199.255 中国 台湾省（我们一定要解放台湾！！！）台北市
168.95.200.0 - 168.95.255.255 中国 台湾省（我们一定要解放台湾！！！）中华电信
194.112.177.140 - 194.112.177.143 中国台湾
194.117.103.11 - 194.117.103.11 中国 台湾省（我们一定要解放台湾！！！）菲力蒲公司
194.117.103.50 - 194.117.103.50 中国台湾
194.117.103.55 - 194.117.103.55 中国台湾
194.117.103.80 - 194.117.103.80 中国台湾
194.117.103.87 - 194.117.103.87 中国台湾
194.117.103.100 - 194.117.103.100 中国台湾
194.117.103.132 - 194.117.103.132 中国台湾
194.117.103.135 - 194.117.103.135 中国台湾
194.117.103.137 - 194.117.103.137 中国台湾
194.117.103.153 - 194.117.103.153 中国台湾
194.117.103.156 - 194.117.103.156 中国台湾
194.117.103.184 - 194.117.103.185 中国台湾
194.117.103.190 - 194.117.103.190 中国台湾
194.117.103.194 - 194.117.103.194 中国台湾
195.112.176.0 - 195.112.176.3 中国 台湾省（我们一定要解放台湾！！！）菲力蒲公司
199.107.119.0 - 199.107.119.255 中国 台湾省（我们一定要解放台湾！！！）迪斯尼公司
202.178.128.0 - 202.178.132.255 中国 台湾省（我们一定要解放台湾！！！）桃园县
202.181.185.0 - 202.181.185.255 台湾
203.77.0.0 - 203.77.127.255 中国台湾
203.79.128.0 - 203.79.130.255 中国 台湾省（我们一定要解放台湾！！！）北部五股
203.79.132.0 - 203.79.132.255 中国 台湾省（我们一定要解放台湾！！！）中部彰化
203.79.134.0 - 203.79.134.255 中国 台湾省（我们一定要解放台湾！！！）南部嘉义
203.79.228.0 - 203.79.228.255 中国 台湾省（我们一定要解放台湾！！！）北部新竹
203.79.229.0 - 203.79.229.255 中国 台湾省（我们一定要解放台湾！！！）中部台中
203.79.230.0 - 203.79.230.255 中国 台湾省（我们一定要解放台湾！！！）南部高雄
210.58.0.0 - 210.58.35.255 中国 台湾省（我们一定要解放台湾！！！）东森宽频网路
210.58.36.0 - 210.58.36.255 中国 台湾省（我们一定要解放台湾！！！）台南市
210.58.37.0 - 210.58.147.255 中国 台湾省（我们一定要解放台湾！！！）东森宽频网路
210.58.148.0 - 210.58.148.255 中国 台湾省（我们一定要解放台湾！！！）台北市
210.58.149.0 - 210.58.255.255 中国 台湾省（我们一定要解放台湾！！！）东森宽频网路
210.68.73.0 - 210.68.73.255 中国 台湾省（我们一定要解放台湾！！！）台北市
210.71.20.0 - 210.71.20.255 中国 台湾省（我们一定要解放台湾！！！）高雄市
210.85.60.0 - 210.85.135.255 中国 台湾省（我们一定要解放台湾！！！）台北市
210.200.96.0 - 210.200.98.255 中国 台湾省（我们一定要解放台湾！！！）中部南投
210.200.100.0 - 210.200.100.255 中国 台湾省（我们一定要解放台湾！！！）南部台南
210.200.102.0 - 210.200.102.255 中国 台湾省（我们一定要解放台湾！！！）南部屏东
210.200.104.0 - 210.200.104.255 中国 台湾省（我们一定要解放台湾！！！）北部花莲
210.200.108.0 - 210.200.108.255 中国 台湾省（我们一定要解放台湾！！！）北部台东
210.200.110.0 - 210.200.110.255 中国 台湾省（我们一定要解放台湾！！！）北部澎湖
210.200.128.0 - 210.200.128.255 中国 台湾省（我们一定要解放台湾！！！）北部南港
210.200.190.0 - 210.200.190.255 中国 台湾省（我们一定要解放台湾！！！）台南市
210.200.196.0 - 210.200.196.255 中国 台湾省（我们一定要解放台湾！！！）北部宜蓝
210.201.3.0 - 210.201.3.255 中国 台湾省（我们一定要解放台湾！！！）台北市
210.201.9.0 - 210.201.9.255 中国 台湾省（我们一定要解放台湾！！！）中部云林
210.201.19.0 - 210.201.19.255 中国 台湾省（我们一定要解放台湾！！！）高雄市
210.201.20.0 - 210.201.35.255 中国 台湾省（我们一定要解放台湾！！！）台北市
210.203.0.0 - 210.203.255.255 中国 台湾省（我们一定要解放台湾！！！）台北市
210.208.189.0 - 210.208.189.255 中国 台湾省（我们一定要解放台湾！！！）高雄
210.240.186.0 - 210.240.186.255 中国 台湾省（我们一定要解放台湾！！！）台北市
211.20.245.0 - 211.20.245.255 中国 台湾省（我们一定要解放台湾！！！）高雄市
211.23.0.0 - 211.23.159.255 中国 台湾省（我们一定要解放台湾！！！）嘉义市
211.23.160.0 - 211.23.162.255 中国 台湾省（我们一定要解放台湾！！！）台北市
211.23.163.0 - 211.23.255.255 中国 台湾省（我们一定要解放台湾！！！）嘉义市
211.72.90.0 - 211.72.90.255 中国 台湾省（我们一定要解放台湾！！！）高雄市
211.75.72.0 - 211.75.72.255 中国 台湾省（我们一定要解放台湾！！！）桃园市
211.75.96.0 - 211.75.96.255 中国 台湾省（我们一定要解放台湾！！！）桃园市
43.229.0.0 - 43.229.255.255 日本
61.112.0.0 - 61.112.255.255 日本
61.115.0.0 - 61.115.255.255 日本 鬼子（横宾）
61.116.0.0 - 61.117.255.255 日本 鬼子（东京）
61.118.0.0 - 61.118.255.255 日本
61.119.0.0 - 61.119.255.255 日本 鬼子（横宾）
61.123.80.0 - 61.123.90.255 日本 鬼子（东京）
61.124.30.0 - 61.124.45.255 日本 鬼子（九州地区）（福冈）
61.124.100.0 - 61.124.200.255 日本
61.125.130.0 - 61.125.140.255 日本
61.192.0.0 - 61.192.255.255 日本
61.196.0.0 - 61.198.255.255 日本
61.200.0.0 - 61.207.109.255 日本
61.207.110.0 - 61.207.120.255 日本 鬼子横滨
61.207.121.0 - 61.215.255.255 日本
62.52.24.228 - 62.52.24.239 日本
130.34.195.0 - 130.34.195.255 日本 鬼子（仙台）
130.54.104.0 - 130.54.104.255 日本
130.153.0.0 - 130.153.255.255 日本 鬼子（东京电气通信大学）
131.113.55.0 - 131.113.60.255 日本 鬼子（横滨）
133.7.0.0 - 133.9.255.255 日本
133.92.90.0 - 133.92.100.255 日本
143.90.209.0 - 143.90.209.255 日本 鬼子（东京）
150.32.60.0 - 150.32.70.255 日本 鬼子（广岛）
157.6.0.0 - 157.6.255.255 日本
165.76.0.0 - 165.76.247.255 日本
165.76.248.0 - 165.76.248.255 日本 鬼子（大阪）
165.76.249.0 - 165.76.255.255 日本
194.117.100.0 - 194.117.100.107 日本
194.117.100.112 - 194.117.100.255 日本
202.0.65.0 - 202.0.66.255 日本
202.0.72.0 - 202.0.73.255 日本
202.0.76.0 - 202.0.76.255 日本
202.0.93.0 - 202.0.93.255 日本
202.6.98.0 - 202.6.98.255 日本
202.6.103.0 - 202.6.103.255 日本
202.11.0.0 - 202.11.206.255 日本
202.11.208.0 - 202.11.255.255 日本
202.12.8.0 - 202.12.15.255 日本
202.13.0.0 - 202.13.254.255 日本
202.15.0.0 - 202.19.255.255 日本
202.20.90.0 - 202.20.90.255 日本
202.20.110.0 - 202.20.110.255 日本
202.20.123.0 - 202.20.124.255 日本
202.21.112.0 - 202.21.127.255 日本
202.21.150.0 - 202.21.153.255 日本
202.22.64.0 - 202.22.127.255 日本
202.23.0.0 - 202.26.255.255 日本
202.32.0.0 - 202.35.255.255 日本
202.48.0.0 - 202.48.255.255 日本
202.139.192.0 - 202.139.207.255 日本
202.140.0.0 - 202.140.31.255 日本
202.176.0.32 - 202.176.3.255 日本
202.208.0.0 - 202.242.2.98 日本
202.242.2.100 - 202.255.255.255 日本
203.136.0.0 - 203.141.255.255 日本
203.178.0.0 - 203.183.255.255 日本
203.216.0.0 - 203.216.255.255 日本
210.7.128.0 - 210.7.152.255 日本
210.7.154.0 - 210.7.255.255 日本
210.57.119.0 - 210.57.119.255 日本
210.81.0.0 - 210.81.31.255 日本
210.88.0.0 - 210.88.191.255 日本
210.128.0.0 - 210.140.11.255 日本
210.140.15.0 - 210.145.44.29 日本
210.145.44.31 - 210.156.109.255 日本
210.156.111.0 - 210.162.240.193 日本
210.162.240.195 - 210.173.74.199 日本
210.173.74.201 - 210.175.255.255 日本
210.188.0.0 - 210.191.255.255 日本
210.196.0.0 - 210.199.255.255 日本
210.224.0.0 - 210.239.255.255 日本
210.248.0.0 - 210.255.68.233 日本
210.255.68.235 - 211.17.211.179 日本
211.17.211.181 - 211.17.232.145 日本
211.17.232.147 - 211.19.255.255 日本
211.122.0.0 - 211.123.255.255 日本
211.125.0.0 - 211.125.255.255 日本
211.126.0.0 - 211.126.18.255 日本 鬼子（东京）
211.126.20.0 - 211.126.45.255 日本 鬼子（东京）
211.126.190.0 - 211.126.195.255 日本 鬼子（千叶县）
212.63.191.0 - 212.63.191.39 日本
212.63.191.44 - 212.63.191.179 日本
213.160.199.0 - 213.160.199.255 日本
218.40.0.0 - 218.47.255.255 日本
218.118.0.0 - 218.118.255.255 日本
218.132.0.0 - 218.132.255.255 日本
218.222.0.0 - 218.222.255.255 日本
219.0.0.0 - 219.10.255.255 日本
219.50.0.0 - 219.51.255.255 日本
219.112.0.0 - 219.114.255.255 日本
219.141.0.0 - 219.143.255.255 日本
219.160.161.0 - 219.160.161.255 日本
219.163.0.0 - 219.164.255.255 日本
61.37.80.0 - 61.37.81.255 韩国
61.75.0.0 - 61.75.255.255 韩国
61.84.0.0 - 61.84.255.255 韩国
63.105.192.0 - 63.105.207.255 韩国
128.134.125.0 - 128.134.135.255 韩国 汉城
165.194.0.0 - 165.194.255.255 韩国 Chungang大学
165.246.0.0 - 165.246.255.255 韩国 仁川Inha大学
194.117.100.108 - 194.117.100.111 韩国
195.16.186.0 - 195.16.187.255 韩国
203.234.0.0 - 203.234.255.255 韩国
203.239.0.0 - 203.241.255.255 韩国
203.244.0.0 - 203.254.233.255 韩国
203.254.235.0 - 203.255.255.255 韩国
206.48.168.0 - 206.48.171.255 韩国
210.102.0.0 - 210.102.31.255 韩国
210.112.224.0 - 210.112.255.255 韩国
210.118.0.0 - 210.118.31.255 韩国
210.178.0.0 - 210.184.95.255 韩国
210.219.192.0 - 210.219.255.255 韩国
210.220.192.0 - 210.220.255.255 韩国
211.32.0.0 - 211.52.255.255 韩国
211.57.0.0 - 211.57.255.255 韩国
211.104.0.0 - 211.107.255.255 韩国
211.112.0.0 - 211.112.63.255 韩国
211.115.216.0 - 211.115.220.255 韩国
211.117.0.0 - 211.117.1.255 韩国
211.117.39.0 - 211.117.39.255 韩国
211.117.143.0 - 211.117.145.255 韩国
211.171.0.0 - 211.174.255.255 韩国
211.180.0.0 - 211.182.255.255 韩国
211.192.0.0 - 211.193.255.255 韩国
211.195.0.0 - 211.195.255.255 韩国
211.200.0.0 - 211.200.255.255 韩国
211.217.0.0 - 211.217.255.255 韩国
211.221.0.0 - 211.221.255.255 韩国
211.224.0.0 - 211.224.255.255 韩国
211.233.82.0 - 211.233.82.255 韩国
211.238.0.0 - 211.238.255.255 韩国
211.240.0.0 - 211.240.255.255 韩国
212.63.191.40 - 212.63.191.43 韩国
213.160.193.64 - 213.160.193.79 韩国
218.151.250.0 - 218.151.255.255 韩国 汉城
218.159.0.0 - 218.159.255.255 韩国
219.144.0.0 - 219.158.255.255 韩国
146.134.0.0 - 146.134.255.255 巴西
194.117.107.65 - 194.117.107.67 巴西
194.117.107.69 - 194.117.107.69 巴西
194.117.107.74 - 194.117.107.74 巴西
194.117.107.77 - 194.117.107.77 巴西
194.117.107.80 - 194.117.107.80 巴西
194.117.107.85 - 194.117.107.86 巴西
194.117.107.133 - 194.117.107.133 巴西
194.117.108.68 - 194.117.108.71 巴西
194.117.116.240 - 194.117.116.243 巴西
194.117.117.168 - 194.117.117.171 巴西
194.117.164.136 - 194.117.164.139 巴西
195.112.164.124 - 195.112.164.127 巴西
195.112.164.196 - 195.112.164.199 巴西
195.112.164.216 - 195.112.164.219 巴西
195.112.164.244 - 195.112.164.247 巴西
195.112.172.8 - 195.112.172.11 巴西
195.112.172.32 - 195.112.172.35 巴西
195.112.172.96 - 195.112.172.99 巴西
195.112.172.148 - 195.112.172.151 巴西
195.112.172.220 - 195.112.172.223 巴西
195.112.173.36 - 195.112.173.39 巴西
195.112.173.200 - 195.112.173.203 巴西
195.112.173.220 - 195.112.173.223 巴西
195.112.181.47 - 195.112.181.47 巴西
195.112.184.144 - 195.112.184.144 巴西
195.112.185.242 - 195.112.185.242 巴西
195.112.186.56 - 195.112.186.59 巴西
195.112.186.136 - 195.112.186.139 巴西
195.112.186.168 - 195.112.186.171 巴西
195.112.187.0 - 195.112.187.3 巴西
195.112.187.64 - 195.112.187.67 巴西
195.112.187.76 - 195.112.187.83 巴西
195.112.187.108 - 195.112.187.111 巴西
195.112.187.132 - 195.112.187.135 巴西
195.112.188.64 - 195.112.188.67 巴西
195.112.188.172 - 195.112.188.175 巴西
195.112.188.204 - 195.112.188.211 巴西
195.112.188.236 - 195.112.188.239 巴西
195.112.189.152 - 195.112.189.155 巴西
200.0.0.0 - 200.41.179.10 巴西 圣保罗
200.41.179.12 - 200.187.195.255 巴西 圣保罗
200.187.199.0 - 200.255.255.255 巴西 圣保罗
212.63.161.128 - 212.63.161.131 巴西
212.63.177.0 - 212.63.177.7 巴西
212.63.178.48 - 212.63.178.51 巴西
212.63.178.88 - 212.63.178.91 巴西
212.63.178.144 - 212.63.178.147 巴西
212.63.178.240 - 212.63.178.243 巴西
212.63.179.84 - 212.63.179.87 巴西
212.63.179.168 - 212.63.179.171 巴西
212.63.179.192 - 212.63.179.195 巴西
212.63.184.4 - 212.63.184.7 巴西
212.63.184.16 - 212.63.184.19 巴西
212.63.184.76 - 212.63.184.79 巴西
212.63.184.104 - 212.63.184.107 巴西
212.63.184.136 - 212.63.184.139 巴西
212.63.184.160 - 212.63.184.163 巴西
212.63.184.176 - 212.63.184.179 巴西
212.63.187.12 - 212.63.187.15 巴西
212.63.187.36 - 212.63.187.39 巴西
212.63.187.60 - 212.63.187.63 巴西
212.63.187.128 - 212.63.187.131 巴西
212.63.187.136 - 212.63.187.139 巴西
212.63.187.176 - 212.63.187.179 巴西
212.63.187.224 - 212.63.187.227 巴西
212.63.187.240 - 212.63.187.247 巴西
212.63.188.8 - 212.63.188.8 巴西
212.63.188.20 - 212.63.188.20 巴西
212.63.188.31 - 212.63.188.32 巴西
212.63.189.4 - 212.63.189.7 巴西
212.63.189.96 - 212.63.189.99 巴西
212.63.189.128 - 212.63.189.131 巴西
212.63.190.88 - 212.63.190.91 巴西
212.63.190.168 - 212.63.190.171 巴西
212.63.190.224 - 212.63.190.227 巴西
212.63.190.240 - 212.63.190.243 巴西
19.203.239.24 - 19.203.239.31 以色列
62.56.128.0 - 62.56.255.255 以色列
62.68.192.0 - 62.68.195.255 以色列
62.68.199.0 - 62.68.199.255 以色列
62.68.203.0 - 62.68.211.255 以色列
62.68.215.0 - 62.68.215.255 以色列
62.68.219.0 - 62.68.219.255 以色列
62.68.223.0 - 62.68.223.255 以色列
62.90.0.0 - 62.90.255.255 以色列
62.93.142.0 - 62.93.143.255 以色列
62.128.32.0 - 62.128.63.255 以色列
62.184.18.64 - 62.184.18.111 以色列
62.184.165.0 - 62.184.165.39 以色列
62.184.165.64 - 62.184.165.127 以色列
62.184.169.0 - 62.184.169.255 以色列
62.187.161.160 - 62.187.161.191 以色列
62.219.0.0 - 62.219.255.255 以色列
128.139.0.0 - 128.139.255.255 以色列
132.64.0.0 - 132.78.255.255 以色列
138.134.0.0 - 138.134.255.255 以色列
139.92.88.0 - 139.92.89.255 以色列
139.92.91.0 - 139.92.92.255 以色列
139.92.98.0 - 139.92.98.255 以色列
139.92.182.0 - 139.92.185.255 以色列
139.92.206.0 - 139.92.208.255 以色列
139.92.251.0 - 139.92.253.255 以色列
147.161.0.0 - 147.161.255.255 以色列
147.233.0.0 - 147.237.255.255 以色列
149.49.0.0 - 149.49.255.255 以色列
167.216.128.0 - 167.216.255.255 以色列
192.86.25.0 - 192.86.25.255 以色列
192.86.89.0 - 192.86.89.255 以色列
192.114.0.0 - 192.118.52.255 以色列
192.118.53.193 - 192.118.255.255 以色列
192.160.252.0 - 192.160.252.255 以色列
192.206.222.0 - 192.206.222.255 以色列
193.41.202.0 - 193.41.202.255 以色列
193.41.208.0 - 193.41.209.255 以色列
194.90.0.0 - 194.90.255.255 以色列
194.117.111.16 - 194.117.111.23 以色列
194.117.119.79 - 194.117.119.79 以色列
194.117.120.116 - 194.117.120.116 以色列
194.117.123.21 - 194.117.123.21 以色列
194.133.184.0 - 194.133.191.255 以色列
194.161.149.0 - 194.161.149.255 以色列
194.194.58.0 - 194.194.58.255 以色列
194.194.246.0 - 194.194.247.255 以色列
194.194.250.0 - 194.194.251.255 以色列
194.253.86.0 - 194.253.87.255 以色列
195.3.128.0 - 195.3.255.255 以色列
195.8.192.0 - 195.8.223.255 以色列
195.13.68.160 - 195.13.68.175 以色列
195.72.116.0 - 195.72.127.255 以色列
195.79.65.128 - 195.79.65.191 以色列
195.79.200.0 - 195.79.200.127 以色列
195.90.37.0 - 195.90.37.255 以色列
195.112.181.254 - 195.112.181.254 以色列
195.112.182.131 - 195.112.182.131 以色列
195.118.21.0 - 195.118.21.255 以色列
195.154.232.144 - 195.154.232.159 以色列
195.184.139.0 - 195.184.139.255 以色列
195.213.38.0 - 195.213.38.7 以色列
195.213.43.160 - 195.213.43.191 以色列
195.213.44.0 - 195.213.44.63 以色列
195.213.50.112 - 195.213.50.127 以色列
195.213.59.160 - 195.213.59.175 以色列
195.213.69.0 - 195.213.69.127 以色列
195.213.79.64 - 195.213.79.95 以色列
195.213.79.244 - 195.213.79.247 以色列
195.213.81.0 - 195.213.81.63 以色列
195.213.93.16 - 195.213.93.31 以色列
195.213.152.128 - 195.213.152.255 以色列
195.213.225.0 - 195.213.225.63 以色列
195.213.227.0 - 195.213.227.255 以色列
195.213.231.0 - 195.213.231.255 以色列
199.203.8.0 - 199.203.8.255 以色列
199.203.12.0 - 199.203.12.255 以色列
199.203.24.0 - 199.203.25.255 以色列
199.203.27.0 - 199.203.27.255 以色列
199.203.38.0 - 199.203.38.63 以色列
199.203.67.0 - 199.203.67.255 以色列
199.203.101.0 - 199.203.101.255 以色列
199.203.107.0 - 199.203.107.255 以色列
199.203.135.0 - 199.203.135.255 以色列
199.203.141.0 - 199.203.141.255 以色列
199.203.143.0 - 199.203.143.127 以色列
199.203.143.192 - 199.203.143.255 以色列
199.203.146.224 - 199.203.146.255 以色列
199.203.147.160 - 199.203.147.255 以色列
199.203.149.32 - 199.203.149.127 以色列
199.203.154.96 - 199.203.154.127 以色列
199.203.160.64 - 199.203.160.127 以色列
199.203.161.192 - 199.203.161.255 以色列
199.203.175.128 - 199.203.175.255 以色列
199.203.176.80 - 199.203.176.95 以色列
199.203.179.224 - 199.203.179.255 以色列
199.203.180.128 - 199.203.180.255 以色列
199.203.198.192 - 199.203.198.223 以色列
199.203.208.0 - 199.203.208.127 以色列
199.203.209.48 - 199.203.209.63 以色列
199.203.210.128 - 199.203.210.255 以色列
199.203.213.0 - 199.203.213.127 以色列
199.203.216.0 - 199.203.216.127 以色列
199.203.222.0 - 199.203.222.127 以色列
199.203.224.160 - 199.203.224.191 以色列
199.203.230.128 - 199.203.230.255 以色列
199.203.235.96 - 199.203.235.127 以色列
199.203.235.192 - 199.203.235.223 以色列
199.203.236.176 - 199.203.236.191 以色列
199.203.245.208 - 199.203.245.223 以色列
207.232.4.32 - 207.232.4.255 以色列
207.232.7.32 - 207.232.7.127 以色列
207.232.9.160 - 207.232.9.191 以色列
207.232.10.0 - 207.232.10.63 以色列
207.232.10.96 - 207.232.10.255 以色列
207.232.11.64 - 207.232.11.95 以色列
207.232.14.0 - 207.232.14.127 以色列
207.232.19.16 - 207.232.19.31 以色列
207.232.19.64 - 207.232.19.127 以色列
207.232.20.192 - 207.232.20.223 以色列
207.232.23.0 - 207.232.23.63 以色列
207.232.26.0 - 207.232.26.15 以色列
207.232.26.32 - 207.232.26.63 以色列
207.232.26.112 - 207.232.26.127 以色列
207.232.27.64 - 207.232.27.143 以色列
209.88.189.32 - 209.88.189.63 以色列
212.3.192.0 - 212.3.223.255 以色列
212.25.35.0 - 212.25.35.255 以色列
212.25.64.0 - 212.25.127.255 以色列
212.29.192.0 - 212.29.255.255 以色列
212.63.163.108 - 212.63.163.111 以色列
212.63.174.13 - 212.63.174.13 以色列
212.63.180.72 - 212.63.180.75 以色列
212.68.128.0 - 212.68.159.255 以色列
212.77.128.0 - 212.77.159.255 以色列
212.116.160.0 - 212.116.191.255 以色列
212.117.128.0 - 212.117.159.255 以色列
212.143.0.0 - 212.143.255.255 以色列
212.150.0.0 - 212.150.255.255 以色列
212.179.0.0 - 212.179.255.255 以色列
212.199.0.0 - 212.199.127.255 以色列
212.235.0.0 - 212.235.63.255 以色列
213.8.0.0 - 213.8.255.255 以色列
213.57.0.0 - 213.57.255.255 以色列
213.137.64.0 - 213.137.95.255 以色列
213.151.0.0 - 213.151.31.255 以色列
213.183.32.0 - 213.183.63.255 以色列
216.234.174.54 - 216.234.174.54 以色列
217.21.64.0 - 217.21.67.255 以色列
217.21.74.128 - 217.21.74.255 以色列
217.21.80.0 - 217.21.95.255 以色列
62.69.128.0 - 62.69.159.255 科威特
62.100.192.0 - 62.100.223.255 科威特
62.150.0.0 - 62.150.255.255 科威特
62.215.0.0 - 62.215.255.255 科威特
193.188.5.0 - 193.188.5.255 科威特
193.188.48.0 - 193.188.63.255 科威特
193.188.142.0 - 193.188.153.255 科威特
193.188.160.0 - 193.188.191.255 科威特
194.54.192.0 - 194.54.255.255 科威特
194.117.115.164 - 194.117.115.167 科威特
194.117.121.9 - 194.117.121.9 科威特
194.126.32.0 - 194.126.44.255 科威特
194.126.46.0 - 194.126.63.255 科威特
195.39.128.0 - 195.39.191.255 科威特
195.226.224.0 - 195.226.255.255 科威特
212.43.0.0 - 212.43.31.255 科威特
213.189.64.0 - 213.189.95.255 科威特
61.0.50.0 - 61.5.80.255 印度尼西亚
192.188.175.0 - 192.188.175.255 印度尼西亚 Oracle
194.117.103.13 - 194.117.103.14 印度尼西亚
194.117.103.27 - 194.117.103.27 印度尼西亚
195.112.167.108 - 195.112.167.111 印度尼西亚
202.0.81.0 - 202.0.81.255 印度尼西亚
202.0.103.0 - 202.0.103.255 印度尼西亚
202.0.116.0 - 202.0.116.255 印度尼西亚
202.3.96.0 - 202.3.127.255 印度尼西亚
202.20.106.0 - 202.20.109.255 印度尼西亚
202.43.224.0 - 202.43.255.255 印度尼西亚
202.46.0.0 - 202.46.31.255 印度尼西亚
202.46.64.0 - 202.46.255.255 印度尼西亚
202.51.192.0 - 202.51.255.255 印度尼西亚
202.53.224.0 - 202.53.255.255 印度尼西亚
202.137.0.0 - 202.137.31.255 印度尼西亚
202.138.224.0 - 202.138.255.255 印度尼西亚
202.145.0.0 - 202.145.31.255 印度尼西亚
202.146.0.0 - 202.146.31.255 印度尼西亚
202.146.128.0 - 202.146.255.255 印度尼西亚
202.147.224.0 - 202.148.31.255 印度尼西亚
202.149.1.0 - 202.152.255.255 印度尼西亚
202.154.0.0 - 202.155.255.255 印度尼西亚
202.157.0.0 - 202.159.255.255 印度尼西亚
202.164.0.0 - 202.164.31.255 印度尼西亚
202.170.225.0 - 202.170.255.255 印度尼西亚
202.180.0.0 - 202.180.31.255 印度尼西亚
202.183.0.0 - 202.183.31.255 印度尼西亚
202.242.2.99 - 202.242.2.99 印度尼西亚
203.77.224.0 - 203.77.255.255 印度尼西亚
203.109.0.0 - 203.109.31.255 印度尼西亚
203.130.192.0 - 203.130.255.255 印度尼西亚
203.153.0.0 - 203.153.255.255 印度尼西亚
214.0.0.0 - 215.255.255.255 美国 国防部网络(弗吉尼亚州)

兄弟:zwei 91love xupan 新明天 hailongcoboo sAsE
wuyemin....
姐妹:小巫仙
MYQQ:710599 102015
申请xrea x-beat是中国人拿下日本帝国的第一步-----SHCS
2003-6-28 18:40
555555
落伍者

积分 444
发贴 571
注册 2002-1-9
真是好东东~
2003-6-28 18:45
新明天
落伍者

积分 3109
发贴 3018
注册 2003-5-28
来自 新明天家园　www.8o.cn
啊,这东西一搜就一堆了啊

毕业啦，暑假干什么好，卖域名和QQ吧，买的找我：）
2003-6-28 18:55
ldxjy
落伍者

积分 1795
发贴 1849
注册 2002-1-12
科威特？用了后我怕被炸

俺的论坛,重建初期，不定期送QQ
感谢SEJISHIKONE提供空间！
2003-6-28 18:57
dreamyboy
落伍者

积分 11186
发贴 11683
注册 2002-10-10
来自 飘逸网络
发现cscscs在灌水。。。

代理高速LINUX虚拟主机业务。联系
QQ：691932，演示：http://www.go8go.com/，
买一年送一个月，两年送三个月！MSN：
我的MSN：go8go8go@hotmail.com,ICQ:195225878
2003-6-28 18:58
新明天
落伍者

积分 3109
发贴 3018
注册 2003-5-28
来自 新明天家园　www.8o.cn

Quote:
Originally posted by dreamyboy at 2003-6-28 06:58 PM:
发现cscscs在灌水。。。

毕业啦，暑假干什么好，卖域名和QQ吧，买的找我：）
2003-6-28 19:11

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.027604 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 介绍几个LOGO背景网页素材网站~~~ - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 介绍几个LOGO背景网页素材网站~~~

作者:
标题: 介绍几个LOGO背景网页素材网站~~~ 上一主题 | 下一主题
cutefk
落伍者

积分 880
发贴 818
注册 2002-9-17
来自 网安科技
介绍几个LOGO背景网页素材网站~~~

素材精品屋 http://www.sucaiw.com/
建站资源网 http://www.jzzy.com/
点燃灵感 Fireworks专业网站 http://www.fwcn.com/
素材网 http://www.sucai.net/
曙光资源网 http://asproom.my163.com/
.........
2003-1-23 22:20
cutefk
落伍者

积分 880
发贴 818
注册 2002-9-17
来自 网安科技
综合站点
ENGLISH
http://www.webbyawards.com/main/ [网站Oscar ]
http://www.cwd.dk/ [国外著名的认证站]
CHINESE
http://www.yimeng.org/ [不用多说吧]
http://www.cwdcn.com/
http://favoirtes.myrice.com/ [互动学院]
http://www.windbell.net/ [风铃设计工作室]

------------------------------------------------------------------------ -----------

Fireworks站点
ENGLISH
http://www.deja.com/group/macromedia.fireworks
http://extending-fireworks.com/
http://comharsa.com/firefaq/
http://www.citeweb.com/cpd/welcome_page/front_page.htm
http://www.projectfireworks.com/
http://www.playingwithfire.com/
http://www.escogitando.it/en/en.html
http://www.fireworkskit.com/
CHINESE
http://www.fwcn.com/ [ ]
http://www.websheji.com/

------------------------------------------------------------------------ -----------

Flash站点
ENGLISH
http://www.flashkit.com/
http://flashmove.com/
http://www.were-here.com/forum/tutorials/index.shtml
http://flashcfm.com/tutorials.cfm
http://www.enetserve.com/tutorials/
http://flash-mx.html.it/
http://www.flashsites.com/
CHINESE
http://www.flashsun.com/
http://www.flash126.com/ [龙城闪客]

------------------------------------------------------------------------ -----------

Dreamweaver站点
ENGLISH

CHINESE
http://www.bihu.net/
---------------------------------------------------------------------------- -------

photoshop站点
ENGLISH
http://www.teamphotoshop.com/ [教程站]
http://www.eyeball-design.com/fxzone/frames02.htm
http://www.adobe.com/products/tips/photoshop.html
http://rainworld.com/psworkshop/
http://www.digital-creativity.co.uk/
CHINESE
http://www.10designs.com/

------------------------------------------------------------------------ -----------

DHTML站点
ENGLISH
http://www.bratta.com/
CHINESE
http://www.hot4.org/

------------------------------------------------------------------------ -----------

图库站
ENGLISH
http://www.skinz.org/
http://www.coolarchive.com/
http://www.deviantart.com/
http://www.ditto.com/
http://creative.gettyimages.com/source/home/home.asp
http://www.iconbazaar.com/main/index.html
http://www.clip-art.com/
http://www.arttoday.com/
http://www.free-clip-art.net/
http://www.aaaclipart.com/
http://www.bestclipart.com/
http://www.top-animation.com/
CHINESE
http://www.liveday.com/gallery/index.html [Liveday图库]
http://www.viewstock.com/ [景象图片库]
http://cn.gograph.com/ [GoGraph ]
http://sucai.silversand.net/ [碧海银沙图库]
http://www.sophoto.net/ [搜图吧？不知道…… ]
http://ducklee.on.net.cn/index1.htm [海盗图片库 ]
http://meteor.loadskill.com/
http://www.tucoo.com/ [非常图酷]
http://www.wallcoo.com/ [猫猫壁纸酷]
http://www.deskcity.com/ [桌面城市]

------------------------------------------------------------------------ -----------

软件下载
ENGLISH
CHINESE
http://microke.cn.hongnet.com/
http://kahn.xj.cninfo.net/yjq/
http://wqily.myetang.com/
http://lucktony.at.china.com/
http://www.fwcn.com/bbs/showthread.php?threadid=7125

------------------------------------------------------------------------ -----------

字体站
http://www.fwcn.com/bbs/showthread.php?threadid=7137
---------------------------------------------------------------------------- -------

ICON站
ENGLISH
http://www.iconarchive.com/
http://iconfactory.com/
http://icontown.net/
CHINESE
http://www.iconcn.com/ [铅笔头的叶子]

设计类：

--------------------------------------------------

国际知名网站（外文）：

http://www.fwcn.com/bbs/showthread.php?threadid=7138

---------------------------------------------------------

国内知名商业网站（中文）：

http://www.fwcn.com/bbs/showthread.php?threadid=7139

-------------------------------------------------

国内知名网页设计网站（中文）：

整理中..

--------------------------------------------------

国际个人设计类网站（中外文）：

http://www.fwcn.com/bbs/showthread.php?threadid=7140
2003-1-23 22:21
天灰灰
落伍者

积分 8181
发贴 7719
注册 2002-10-16
来自 囡天小屋
非常感谢你的提供！:eek:
2003-1-23 22:22
网迷
落伍者

积分 4263
发贴 4348
注册 2002-6-30
还有我这个呢

http://www.wangmi.net/logo/
2003-1-23 22:23
Is.
禁止访问

积分 17342
发贴 17000
注册 2002-1-23
不错。这就加入精华~
2003-1-23 22:24
天灰灰
落伍者

积分 8181
发贴 7719
注册 2002-10-16
来自 囡天小屋

Quote:
最初由 Jetdown.com 发布
[B]不错。这就加入精华~
[/B]

活活！

支持！
2003-1-23 22:26

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.026186 second(s), 5 queries, Gzip enabled


落伍者论坛 - 资源讨论专栏 - 全国主机城市的DNS服务器 - powered by Discuz!

落伍者论坛 » 资源讨论专栏 » 全国主机城市的DNS服务器

作者:
标题: 全国主机城市的DNS服务器 上一主题 | 下一主题
潇寒
落伍者

积分 4149
发贴 3525
注册 2001-6-15
全国主机城市的DNS服务器

省份 ( 城市 ） DNS 名称 DNS IP ADDRESS
香港 ns1.netvigator.com 205.252.144.228
澳门 vassun2.macau.ctm.net 202.175.3.8
深圳 ns.shenzhen.gd.cn 202.96.134.133
202.96.154.8 /202.96.154.15
北京 ns.bta.net.cn 202.96.0.133
ns.spt.net.cn 202.96.199.133
ns.cn.net 202.97.16.195
202.106.0.20/202.106.148.1
广东 ns.guangzhou.gd.cn 202.96.128.143
dns.guangzhou.gd.cn 202.96.128.68
上海 ns.sta.net.cn 202.96.199.132/202.96.199.133 /202.96.199.133
浙江 dns.zj.cninfo.net 202.96.102.3/202.96.96.68/202.96.104.18
陕西 ns.snnic.com 202.100.13.11
天津 ns.tpt.net.cn 202.99.96.68
辽宁 ns.dcb.ln.cn 202.96.75.68
江苏 pub.jsinfo.net 202.102.29.3
四川 ns.sc.cninfo.net 61.139.2.69
河北 ns.hesjptt.net.cn 202.99.160.68
山西 ns.sxyzptt.net.cn 202.99.198.6
吉林 ns.jlccptt.net.cn 202.98.0.68
山东 202.102.152.3/202.102.128.68
福建 dns.fz.fj.cn 202.101.98.55
湖南 202.103.100.206
广西 10.138.128.40
江西 202.109.129.2/202.101.224.68/202.101.240.36
云南 ns.ynkmptt.net.cn 202.98.160.68
重庆 61.128.128.68
河南: 202.102.227.68/202.102.224.68/202.102.245.12
新疆: 61.128.97.73/61.128.97.74
保定: 202.99.160.68 /202.99.166.4
武汉: 202.103.24.68 /202.103.0.117
西安: 202.100.4.15 /202.100.0.68
成都: 202.98.96.68 /202.98.96.69
重庆: 61.128.192.4
乌鲁木齐: 61.128.97.73
厦门：202.101.103.55
2002-10-30 19:15
sAsE
落伍者

积分 5196
发贴 4634
注册 2003-2-14
好

歓迎するwǒ xīn fēi yáng
最新最齊的免費空間.안정의 고속의 상업의 공간.
2003-6-2 09:29
flyba
落伍者

积分 1654
发贴 1667
注册 2002-12-22
来自 客家首府
好是好,
只是我不知道这个可以拿来做什么呀?

我是我~~
2003-6-2 09:30
flyba
落伍者

积分 1654
发贴 1667
注册 2002-12-22
来自 客家首府
老大们说说!

我是我~~
2003-6-2 09:30
ykjsw
落伍者

积分 4395
发贴 4330
注册 2002-5-26
上网可以设置为当地的

2003 伤感继续中.......

九点音乐网全面改版
2003-6-2 09:42
wking
落伍者

积分 575
发贴 685
注册 2002-8-26
linux里设置网络方便了

◆◆一家人◆◆
2003-6-2 09:49
soft196
落伍者

积分 100
发贴 108
注册 2001-5-15
来自 北京

Quote:
Originally posted by ykjsw at 2003-6-2 09:42 AM:
上网可以设置为当地的

不明白？
2003-6-2 11:32
flyba
落伍者

积分 1654
发贴 1667
注册 2002-12-22
来自 客家首府
意思是可以作代理吗？

我是我~~
2003-6-2 13:19
敢败吓疯
落伍者

积分 6598
发贴 6401
注册 2001-5-30
GOOD，我进行邮件群发就需要这些DNS。

我的主页：飞牌精品软件 http://www.ayxz.com/
大量正版软件下载，注册机，破解器，电脑书籍下载，游戏下载等。
2003-6-5 19:07
kegu
落伍者

积分 1936
发贴 2248
注册 2001-9-30
来自 神啊~救救我吧
太需要了
2003-6-18 03:47
sigouku
落伍者

积分 1648
发贴 1723
注册 2002-12-30
来自 上海
不错.顶一下!

http://bbs.445566.com/
http://qqfans.com/
天天送6,7位QQ,低价售QQ
5无150元/个，6无25元/个，7无3元/个
2003-6-18 03:52

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.026127 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网络技术专版 - 几款ADSL Modem的端口映射做法 - powered by Discuz!

落伍者论坛 » 网络技术专版 » 几款ADSL Modem的端口映射做法

作者:
标题: 几款ADSL Modem的端口映射做法 上一主题 | 下一主题
闷葫芦
落伍者

积分 454
发贴 402
注册 2002-1-9
来自 长沙
几款ADSL Modem的端口映射做法

华硕6000EV/6005HWADSLMODEM中设置端口映射（转发）

在主菜单中点“NAT”，会有个“natchannellist”，以在内部pc192.168.1.2上架设webserver为例子，web的一般默认端口是80，设置如下：在natchannellist里面的mupltipleportforwarding里面填写以下内容：

action:add
channelno:1
protocol:tcp
incomingport,begin:80,end:80
newportbegin:80,end:80
newipaddress:192.168.1.2。

LINKSYSADSL路由器中中设置端口映射（转发）

在主菜单中点“advanced”，接下来的菜单中有个“forwarding”，以在内部pc192.168.1.2上架设webserver为例子，web的一般默认端口是80，设置如下：

extport:80to80
ipaddress:192.168.1.2

然后点击“apply”就可以了。

宽频蓝色小精灵路由器中设置端口映射（转发）

在高级设置页面下点“DistributedServersSetup(VirtualServes,虚拟主机设置)”
每个VirtualServer定义为一个ServicePort，所有对这个端口的访问都会重定向到相应的ServiceIP所对应的计算机。

例如,假如您要：

在计算机192.168.123.10上架设FTP服务器。(port21)
在计算机192.168.123.20上架设Email的smtp服务器。(port25)
在计算机192.168.123.30上架设Web服务器。(port80)
在计算机192.168.123.40上架设Pop服务器。(port110)

那么，您就需要在此页作如下设置：

ServiceServicePortServiceIPEnable

FTP21192.168.123.10√
Email25192.168.123.20√
Web80192.168.123.30√
PostOffice110192.168.123.40√

贝尔6309上做端口映射

这个路由器是在lineconfiguration里面的配置。
以架设web服务器为例子，路由器的Lan地址为192.168.1.1，web服务器的ip地址为192.168.1.2（一定要和路由器的Lan的ip在同一个网段）。具体为：
在“lineconfiguration”的“Nat”的“inbound”里面
port：80
host：192.168.1.2，
protocol:tcp
然后“add”就可以了。ftp则添加21端口的，作email服务器的是要设置25，110的端口

金宝（kinpo）A400上做端口映射

这个路由器的端口转发在“（packetfilter）”里。
以架设web服务器为例子，路由器的Lan地址为192.168.1.1，web服务器的ip地址为192.168.1.2（一定要和路由器的Lan的ip在同一个网段）。具体为：
使能包过滤功能：打勾。
源地址：任意ip，打勾
端口号：80

目标地址：你的内网机器的ip为192.168.1.2，
目标端口：80。

优先级：任意数字咯
协议：tcp
动作：allow。
然后点添加就可以了。

注：如果需要架设其他类型的服务器，那么在设置“端口映射”时侦听的协议和端口有所不同。具体的端口及其描述请看：
下表是一些常见的网络服务和对应的端口号。

服务名称端口号/协议[别名]#注释

ftp-data20/tcp #FTP,data
ftp21/tcp #FTP.control
telnet23/tcp
smtp25/tcpmail #SimpleMailTransferProtocol
time37/tcptimserver
time37/udptimserver
domain53/tcp #DomainNameServer
domain53/udp #DomainNameServer
tftp69/udp #TrivialFileTransfer
gopher70/tcp
http80/tcpwwwwww-http #WorldWideWeb
pop3110/tcp #PostOfficeProtocol-Version3
nntp119/tcpusenet #NetworkNewsTransferProtocol
netbios-ns137/tcpnbname #NETBIOSNameService
netbios-ns137/udpnbname #NETBIOSNameService
netbios-dgm138/udpnbdatagram #NETBIOSDatagramService
netbios-ssn139/tcpnbsession #NETBIOSSessionService
imap143/tcpimap4#InternetMessageAccessProtocol
snmp161/udp #SNMP
snmptrap162/udpsnmp-trap #SNMPtrap
irc194/tcp #InternetRelayChatProtocol
ipx213/udp #IPXoverIP
ldap389/tcp #LightweightDirectoryAccessProtocol
https443/tcpMCom
https443/udpMCom
uucp540/tcpuucpd
ldaps636/tcpsldap #LDAPoverTLS/SSL
doom666/tcp #DoomIdSoftware
doom666/udp #DoomIdSoftware
phone1167/udp #Conferencecalling
ms-sql-s1433/tcp #Microsoft-SQL-Server
ms-sql-s1433/udp #Microsoft-SQL-Server
ms-sql-m1434/tcp #Microsoft-SQL-Monitor
ms-sql-m1434/udp #Microsoft-SQL-Monitor
wins1512/tcp #MicrosoftWindowsInternetNameService
wins1512/udp #MicrosoftWindowsInternetNameService
l2tp1701/udp #LayerTwoTunnelingProtocol
pptp1723/tcp #Point-to-pointtunnellingprotocol
radius1812/udp #RADIUSauthenticationprotocol
radacct1813/udp #RADIUSaccountingprotocol
nfsd2049/udpnfs #NFSserver
knetd2053/tcp #Kerberosde-multiplexor
man9535/tcp #RemoteManServer
2002-12-19 03:06

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.018676 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 国内有名的图片站~！建议斑竹之顶一下~！ - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 国内有名的图片站~！建议斑竹之顶一下~！

作者:
标题: 国内有名的图片站~！建议斑竹之顶一下~！ 上一主题 | 下一主题
心点
落伍者

积分 207
发贴 177
注册 2003-2-15
来自 http://keke321.yeah.net
国内有名的图片站~！建议斑竹之顶一下~！

TUTU坊：http://www.sczz.com/
非常图酷http://www.tucoo.com/

构图网：http://www.goto1.net/

矢量LOGOhttp://www.findlogo.com/find1.htm

美图http://www.6to23.com/s8/

搜图网：http://www.sophoto.net/cgi-bin/imagefolio.cgi

伊美姬网http://www.imagegarden.net/

桌面城市http://www.deskcity.com/

中国图片库http://www.imaginechina.net/

夜*图库http://ycpic.myetang.com/

网页制作大宝库http://www.4gee.com/

流星雨矢量图库http://meteor.loadskill.com/

中华图库http://www.star99.com/photo

素材精品屋http://www.sucaiw.com/

热线素材精品：http://sucai.zjonline.com/

壁纸好莱坞http://jimmy.transfar.com/

Wincustomizehttp://www.wincustomize.com/

axialishttp://www.axialis.com/

Eboy Homehttp://www.eboy.com

ICON Listhttp://www.arkbook.com/icon/

ICON中国http://www.iconcn.com/

图标集中营http://www.51icon.com/

馨雅壁纸http://www.365pic.com/cn/index.php

海龙文化http://www.hellosea.com/civilization/index.asp

中国古代龙 http://zzx.shangdu.com/artchina_design/design_photo/long/page_01.htm

最好的图片搜索引擎http://www.google.com/imghp?hl=zh-CN

非鸟矢量图库http://www.feiniao.net/ai/index.htm

闪吧矢量图库http://www.flash8.net/index_vector.asp

流星雨矢量图库http://meteor.loadskill.com/

梧桐树下矢量图库http://wtsx.my169.com/flash/2000slt/index.htm

广之源矢量素材http://www.coolty.com/Subject.asp

平面设计与桌面出版--矢量素材区http://202.103.233.162/cd/downhtml/down-1.htm

素材网http://gimages.myetang.com/index.htm

猫猫图片酷http://www.tucoo.com/ai/index.htm

http://keke321.yeah.net
2003-6-24 21:29
江小刀
落伍者

积分 4252
发贴 4245
注册 2002-11-23
来自 行星风系
hao

行星风系http://www.planeting.net
2003-6-24 21:31
心宇
落伍者

积分 1852
发贴 1879
注册 2002-4-30
来自 近猪者痴
收藏

LOGO,ASP,Flash Http://I.ZongYZ.Com
我是猪,有点笨,有点懒
但我一直很努力.
感谢帮助我的朋友[WOWO BBCHOST WAYBOY......]
失去中.......
2003-6-24 21:32

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.023826 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网络技术专版 - [不错哦!]局域网内如何实现邮件服务!! - powered by Discuz!

落伍者论坛 » 网络技术专版 » [不错哦!]局域网内如何实现邮件服务!!

作者:
标题: [不错哦!]局域网内如何实现邮件服务!! 上一主题 | 下一主题
L.G.
专栏版主

积分 1420
发贴 1406
注册 2003-3-5
来自 山东·济南
[不错哦!]局域网内如何实现邮件服务!!

    现在许多单位的计算机都组成了局域网，在此，我们把Windows 98组成的对等网，改成一个NT网，在其中一台上安装Windows NT 4.0，通过利用Windows 98 控制面板中的电子邮件和Windows NT 4.0中的Microsoft Mail邮局来完成局域网内电子邮件服务。

    在局域网中建立电子邮件服务分三步：第一步，利用Windows NT 4.0中的“Microsoft Mail邮局”在一台特定的机器上建立好工作组邮局；第二步，在各工作站上利用Windows 98控制面板中的“电子邮件”建立用户专用信箱和配置文件；第三步，设置并用Outlook或其他软件收发邮件。配置的具体步骤如下：

    建立工作组邮局

    作为电子邮件系统中心的工作组邮局用来保存邮局用户的账号，是邮件的中转、存放处，工作组邮局应位于工作组内一台计算机或服务器内的一个共享目录中，其他用户对该目录有完全访问或读写权。

    1、选一台工作站或直接在服务器上建立一个目录作为工作组邮局地点。如工作站A05下的\\A05\netmail,并共享为完全或更改。

    2、在Windows NT的控制面板中双击“Microsoft Mail邮局”，启动“Microsoft工作组邮局管理员”程序， 选择“创建新的工作组邮局”，单击[下一步]。

    3、通过浏览或网上邻居找到并确定工作组邮局地点为\\A05\netmail,单击[下一步]，再单击[下一步]，创建工作组邮局\\a05\netmail\wgpo000。

    4、输入管理员的姓名、信箱、口令,最后单击[确定]，关闭“工作组邮局管理员程序”。

    5、再次双击“Microsoft Mail邮局”，进入2的界面，单击“管理现有的工作组邮局”，单击[下一步]。

6、确定邮局地点\\a05\netmail\wgpo000后，输入邮局管理员密码，进入“邮局管理程序”，单击[添加使用者]按钮，输入要使用局域网电子邮件服务的所有用户姓名、邮箱、口令等，对用户登记配置。

    7、最后单击[关闭]按钮，关闭“邮件管理程序”。

    建立用户邮件箱

    在工作组邮局建立好后，用户可以在各工作站创立自己的邮件箱并配置。

    1、在Windows 98的控制面板中双击“电子邮件”，再单击[添加]按钮,启动“收件箱安装向导”，只选择“Microsoft Mail”。

    2、输入配置文件名（第一次配置时自动给出文件名)。

    3、手工输入或通过浏览找到工作组邮局的地点\\A05\netmail\wgpo000,然后单击[下一步]，从列表中选择邮箱名称，再单击[下一步]，输入口令，再三次单击[下一步]，再单击[完成]，最后单击[关闭]，就完成了用户邮箱设置。

    4、选择配置文件名，单击[属性]设置按钮，进行属性设置，在“传递”选项卡中，将邮件发至“个人文件夹”。

    5、完成用户配置后，单击[关闭]退出即可。

    收发邮件

    配置并用Microsoft Outlook收发邮件。启动Microsoft Outlook，单击“工具”菜单中的“服务”，选择“Microsoft Mail”后单击“属性”，在“连接”选项卡中选择“局域网”，其他选项可相应设置也可不设置，单击[确定]并按提示单击“文件”菜单中的“退出并注销”，退出Outlook。再次启动Microsoft Outlook，双击“收件箱”图标就可使用收件箱收发邮件了。

    本文章在Windows NT 4.0中文版和Windows 98中文版下完全通过。

网络里呆久了，没什么意思；
出去？也没意思！
于是，我要去入伍，彻底抛弃这些，你们下次见了我，敬礼吧！
2003-3-26 22:37
L.G.
专栏版主

积分 1420
发贴 1406
注册 2003-3-5
来自 山东·济南
也给俺加个分吧!!~~

要不,给加精华!~~

好歹,俺也对网络这块儿,很热情哦!!!

网络里呆久了，没什么意思；
出去？也没意思！
于是，我要去入伍，彻底抛弃这些，你们下次见了我，敬礼吧！
2003-3-26 22:40
小小鸟
落伍者

积分 319
发贴 319
注册 2002-6-9
想给你加..可惜到现在我还不知道怎么给人加分...
2003-3-27 07:36
L.G.
专栏版主

积分 1420
发贴 1406
注册 2003-3-5
来自 山东·济南

Quote:
Originally posted by 小小鸟 at 2003-3-27 07:36 AM:
想给你加..可惜到现在我还不知道怎么给人加分...

是不是我们等级不够????

网络里呆久了，没什么意思；
出去？也没意思！
于是，我要去入伍，彻底抛弃这些，你们下次见了我，敬礼吧！
2003-3-28 13:34
木耳
搬凳子晒太阳

积分 3727
发贴 3458
注册 2001-9-28
来自 青马企业
加了精华了

谈谈人生，谈谈理想，一辈子其实就这么几年。
2003-3-28 13:37
L.G.
专栏版主

积分 1420
发贴 1406
注册 2003-3-5
来自 山东·济南
谢谢~~木耳好好哦~~~

嘴嘴~~

网络里呆久了，没什么意思；
出去？也没意思！
于是，我要去入伍，彻底抛弃这些，你们下次见了我，敬礼吧！
2003-3-29 16:24
苦寒
禁止发言

积分 2275
发贴 896
注册 2002-4-22
来自 www.5kz.com
好！

[url]http://www.5kz.com[/url] [url]http://bbs.5kz.com[/url]
FTP：www.5kz.com kuhan 111111 228
2003-3-30 19:55

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.025440 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网络技术专版 - 常用端口及其简要说明 - powered by Discuz!

落伍者论坛 » 网络技术专版 » 常用端口及其简要说明

作者:
标题: 常用端口及其简要说明 上一主题 | 下一主题
木耳
搬凳子晒太阳

积分 3727
发贴 3458
注册 2001-9-28
来自 青马企业
常用端口及其简要说明

整理 CptFan

0 通常用于分析操作系统。这一方法能够工作是因为在一些系统中“0”是无效端口，当你试图使用一种通常的闭合端口连接它时将产生不同的结果。一种典型的扫描：使用IP地址为0.0.0.0，设置ACK位并在以太网层广播。

1 tcpmux 这显示有人在寻找SGI Irix机器。Irix是实现tcpmux的主要提供者，缺省情况下tcpmux在这种系统中被打开。Iris机器在发布时含有几个缺省的无密码的帐户，如lp, guest, uucp, nuucp, demos, tutor, diag, EZsetup, OutOfBox, 和4Dgifts。许多管理员安装后忘记删除这些帐户。因此Hacker们在Internet上搜索tcpmux并利用这些帐户。

7 Echo 你能看到许多人们搜索Fraggle放大器时，发送到x.x.x.0和x.x.x.255的信息。常见的一种DoS攻击是echo循环（echo-loop），攻击者伪造从一个机器发送到另一个机器的UDP数据包，而两个机器分别以它们最快的方式回应这些数据包。另一种东西是由DoubleClick在词端口建立的TCP连接。有一种产品叫做“Resonate Global Dispatch”，它与DNS的这一端口连接以确定最近的路由。Harvest/squid cache将从3130端口发送UDP echo：“如果将cache的source_ping on选项打开，它将对原始主机的UDP echo端口回应一个HIT reply。”这将会产生许多这类数据包。

11 sysstat 这是一种UNIX服务，它会列出机器上所有正在运行的进程以及是什么启动了这些进程。这为入侵者提供了许多信息而威胁机器的安全，如暴露已知某些弱点或帐户的程序。这与UNIX系统中“ps”命令的结果相似。再说一遍：ICMP没有端口，ICMP port 11通常是ICMP type=11。

19 chargen 这是一种仅仅发送字符的服务。UDP版本将会在收到UDP包后回应含有垃圾字符的包。TCP连接时，会发送含有垃圾字符的数据流知道连接关闭。Hacker利用IP欺骗可以发动DoS攻击。伪造两个chargen服务器之间的UDP包。由于服务器企图回应两个服务器之间的无限的往返数据通讯一个chargen和echo将导致服务器过载。同样fraggle DoS攻击向目标地址的这个端口广播一个带有伪造受害者IP的数据包，受害者为了回应这些数据而过载。

21 ftp 最常见的攻击者用于寻找打开“anonymous”的ftp服务器的方法。这些服务器带有可读写的目录。Hackers或Crackers 利用这些服务器作为传送warez (私有程序) 和pr0n(故意拼错词而避免被搜索引擎分类)的节点。

22 ssh PcAnywhere 建立TCP和这一端口的连接可能是为了寻找ssh。这一服务有许多弱点。如果配置成特定的模式，许多使用RSAREF库的版本有不少漏洞。（建议在其它端口运行ssh）。还应该注意的是ssh工具包带有一个称为make-ssh-known-hosts的程序。它会扫描整个域的ssh主机。你有时会被使用这一程序的人无意中扫描到。UDP（而不是TCP）与另一端的5632端口相连意味着存在搜索pcAnywhere的扫描。5632（十六进制的0x1600）位交换后是0x0016（使进制的22）。

23 Telnet 入侵者在搜索远程登陆UNIX的服务。大多数情况下入侵者扫描这一端口是为了找到机器运行的操作系统。此外使用其它技术，入侵者会找到密码。

25 smtp 攻击者（spammer）寻找SMTP服务器是为了传递他们的spam。入侵者的帐户总被关闭，他们需要拨号连接到高带宽的e-mail服务器上，将简单的信息传递到不同的地址。SMTP服务器（尤其是sendmail）是进入系统的最常用方法之一，因为它们必须完整的暴露于Internet且邮件的路由是复杂的（暴露+复杂=弱点）。

53 DNS Hacker或crackers可能是试图进行区域传递（TCP），欺骗DNS（UDP）或隐藏其它通讯。因此防火墙常常过滤或记录53端口。需要注意的是你常会看到53端口做为UDP源端口。不稳定的防火墙通常允许这种通讯并假设这是对DNS查询的回复。Hacker常使用这种方法穿透防火墙。

67&68 Bootp和DHCP UDP上的Bootp/DHCP：通过DSL和cable-modem的防火墙常会看见大量发送到广播地址255.255.255.255的数据。这些机器在向DHCP服务器请求一个地址分配。Hacker常进入它们分配一个地址把自己作为局部路由器而发起大量的“中间人”（man-in-middle）攻击。客户端向68端口（bootps）广播请求配置，服务器向67端口（bootpc）广播回应请求。这种回应使用广播是因为客户端还不知道可以发送的IP地址。

69 TFTP(UDP) 许多服务器与bootp一起提供这项服务，便于从系统下载启动代码。但是它们常常错误配置而从系统提供任何文件，如密码文件。它们也可用于向系统写入文件。

79 finger Hacker用于获得用户信息，查询操作系统，探测已知的缓冲区溢出错误，回应从自己机器到其它机器finger扫描。

80 web站点默认80为服务端口，采用tcp或udp协议。

98 linuxconf 这个程序提供linux boxen的简单管理。通过整合的HTTP服务器在98端口提供基于Web界面的服务。它已发现有许多安全问题。一些版本setuid root，信任局域网，在/tmp下建立Internet可访问的文件，LANG环境变量有缓冲区溢出。此外因为它包含整合的服务器，许多典型的HTTP漏洞可能存在（缓冲区溢出，历遍目录等）

109 POP2 并不象POP3那样有名，但许多服务器同时提供两种服务（向后兼容）。在同一个服务器上POP3的漏洞在POP2中同样存在。

110 POP3 用于客户端访问服务器端的邮件服务。POP3服务有许多公认的弱点。关于用户名和密码交换缓冲区溢出的弱点至少有20个（这意味着Hacker可以在真正登陆前进入系统）。成功登陆后还有其它缓冲区溢出错误。

111 sunrpc portmap rpcbind Sun RPC PortMapper/RPCBIND。访问portmapper是扫描系统查看允许哪些RPC服务的最早的一步。常见RPC服务有：rpc.mountd, NFS, rpc.statd, rpc.csmd, rpc.ttybd, amd等。入侵者发现了允许的RPC服务将转向提供服务的特定端口测试漏洞。记住一定要记录线路中的daemon, IDS, 或sniffer，你可以发现入侵者正使用什么程序访问以便发现到底发生了什么。

113 Ident auth 这是一个许多机器上运行的协议，用于鉴别TCP连接的用户。使用标准的这种服务可以获得许多机器的信息（会被Hacker利用）。但是它可作为许多服务的记录器，尤其是FTP, POP, IMAP, SMTP和IRC等服务。通常如果有许多客户通过防火墙访问这些服务，你将会看到许多这个端口的连接请求。记住，如果你阻断这个端口客户端会感觉到在防火墙另一边与e-mail服务器的缓慢连接。许多防火墙支持在TCP连接的阻断过程中发回RST，着将回停止这一缓慢的连接。

119 NNTP news 新闻组传输协议，承载USENET通讯。当你链接到诸如：news://comp.security.firewalls/. 的地址时通常使用这个端口。这个端口的连接企图通常是人们在寻找USENET服务器。多数ISP限制只有他们的客户才能访问他们的新闻组服务器。打开新闻组服务器将允许发/读任何人的帖子，访问被限制的新闻组服务器，匿名发帖或发送spam。

135 oc-serv MS RPC end-point mapper Microsoft在这个端口运行DCE RPC end-point mapper为它的DCOM服务。这与UNIX 111端口的功能很相似。使用DCOM和/或RPC的服务利用机器上的end-point mapper注册它们的位置。远端客户连接到机器时，它们查询end-point mapper找到服务的位置。同样Hacker扫描机器的这个端口是为了找到诸如：这个机器上运行Exchange Server吗？是什么版本？这个端口除了被用来查询服务（如使用epdump）还可以被用于直接攻击。有一些DoS攻击直接针对这个端口。

137 NetBIOS name service nbtstat (UDP) 这是防火墙管理员最常见的信息。

139 NetBIOS File and Print Sharing 通过这个端口进入的连接试图获得NetBIOS/SMB服务。这个协议被用于Windows“文件和打印机共享”和SAMBA。在Internet上共享自己的硬盘是可能是最常见的问题。大量针对这一端口始于1999，后来逐渐变少。2000年又有回升。一些VBS（IE5 VisualBasic Scripting）开始将它们自己拷贝到这个端口，试图在这个端口繁殖。

143 IMAP 和上面POP3的安全问题一样，许多IMAP服务器有缓冲区溢出漏洞运行登陆过程中进入。记住：一种Linux蠕虫（admw0rm）会通过这个端口繁殖，因此许多这个端口的扫描来自不知情的已被感染的用户。当RadHat在他们的Linux发布版本中默认允许IMAP后，这些漏洞变得流行起来。Morris蠕虫以后这还是第一次广泛传播的蠕虫。这一端口还被用于IMAP2，但并不流行。已有一些报道发现有些0到143端口的攻击源于脚本。

161 SNMP(UDP) 入侵者常探测的端口。SNMP允许远程管理设备。所有配置和运行信息都储存在数据库中，通过SNMP客获得这些信息。许多管理员错误配置将它们暴露于Internet。Crackers将试图使用缺省的密码“public”“private”访问系统。他们可能会试验所有可能的组合。SNMP包可能会被错误的指向你的网络。Windows机器常会因为错误配置将HP JetDirect remote management软件使用SNMP。HP OBJECT IDENTIFIER将收到SNMP包。新版的Win98使用SNMP解析域名，你会看见这种包在子网内广播（cable modem, DSL）查询sysName和其它信息。

162 SNMP trap 可能是由于错误配置

177 xdmcp 许多Hacker通过它访问X-Windows控制台， 它同时需要打开6000端口。

513 rwho 可能是从使用cable modem或DSL登陆到的子网中的UNIX机器发出的广播。这些人为Hacker进入他们的系统提供了很有趣的信息。

553 CORBA IIOP (UDP) 如果你使用cable modem或DSL VLAN，你将会看到这个端口的广播。CORBA是一种面向对象的RPC（remote procedure call）系统。Hacker会利用这些信息进入系统。

600 Pcserver backdoor 请查看1524端口。
一些玩script的孩子认为他们通过修改ingreslock和pcserver文件已经完全攻破了系统-- Alan J. Rosenthal.

635 mountd Linux的mountd Bug。这是人们扫描的一个流行的Bug。大多数对这个端口的扫描是基于UDP的，但基于TCP的mountd有所增加（mountd同时运行于两个端口）。记住，mountd可运行于任何端口（到底在哪个端口，需要在端口111做portmap查询），只是Linux默认为635端口，就象NFS通常运行于2049端口。

1024 许多人问这个端口是干什么的。它是动态端口的开始。许多程序并不在乎用哪个端口连接网络，它们请求操作系统为它们分配“下一个闲置端口”。基于这一点分配从端口1024开始。这意味着第一个向系统请求分配动态端口的程序将被分配端口1024。为了验证这一点，你可以重启机器，打开Telnet，再打开一个窗口运行“natstat -a”，你将会看到Telnet被分配1024端口。请求的程序越多，动态端口也越多。操作系统分配的端口将逐渐变大。再来一遍，当你浏览Web页时用“netstat”查看，每个Web页需要一个新端口。

1025，1026 参见1024

1080 SOCKS 这一协议以管道方式穿过防火墙，允许防火墙后面的许多人通过一个IP地址访问Internet。理论上它应该只允许内部的通信向外达到Internet。但是由于错误的配置，它会允许Hacker/Cracker的位于防火墙外部的攻击穿过防火墙。或者简单地回应位于Internet上的计算机，从而掩饰他们对你的直接攻击。WinGate是一种常见的Windows个人防火墙，常会发生上述的错误配置。在加入IRC聊天室时常会看到这种情况。

1114 SQL 系统本身很少扫描这个端口，但常常是sscan脚本的一部分。

1243 Sub-7木马（TCP）

1524 ingreslock 后门许多攻击脚本将安装一个后门Shell于这个端口（尤其是那些针对Sun系统中sendmail和RPC服务漏洞的脚本，如statd, ttdbserver和cmsd）。如果你刚刚安装了你的防火墙就看到在这个端口上的连接企图，很可能是上述原因。你可以试试Telnet到你的机器上的这个端口，看看它是否会给你一个Shell。连接到600/pcserver也存在这个问题。

2049 NFS NFS程序常运行于这个端口。通常需要访问portmapper查询这个服务运行于哪个端口，但是大部分情况是安装后NFS运行于这个端口，Hacker/Cracker因而可以闭开portmapper直接测试这个端口。

3128 squid 这是Squid HTTP代理服务器的默认端口。攻击者扫描这个端口是为了搜寻一个代理服务器而匿名访问Internet。你也会看到搜索其它代理服务器的端口：8000/8001/8080/8888。扫描这一端口的另一原因是：用户正在进入聊天室。其它用户（或服务器本身）也会检验这个端口以确定用户的机器是否支持代理。

5632 pcAnywere 你会看到很多这个端口的扫描，这依赖于你所在的位置。当用户打开pcAnywere时，它会自动扫描局域网C类网以寻找可能得代理（译者：指agent而不是proxy）。Hacker/cracker也会寻找开放这种服务的机器，所以应该查看这种扫描的源地址。一些搜寻pcAnywere的扫描常包含端口22的UDP数据包。

6776 Sub-7 artifact 这个端口是从Sub-7主端口分离出来的用于传送数据的端口。例如当控制者通过电话线控制另一台机器，而被控机器挂断时你将会看到这种情况。因此当另一人以此IP拨入时，他们将会看到持续的，在这个端口的连接企图。（译者：即看到防火墙报告这一端口的连接企图时，并不表示你已被Sub-7控制。）

6970 RealAudio RealAudio客户将从服务器的6970-7170的UDP端口接收音频数据流。这是由TCP7070端口外向控制连接设置的。

13223 PowWow PowWow 是Tribal Voice的聊天程序。它允许用户在此端口打开私人聊天的连接。这一程序对于建立连接非常具有“进攻性”。它会“驻扎”在这一TCP端口等待回应。这造成类似心跳间隔的连接企图。如果你是一个拨号用户，从另一个聊天者手中“继承”了IP地址这种情况就会发生：好象很多不同的人在测试这一端口。这一协议使用“OPNG”作为其连接企图的前四个字节。

17027 Conducent 这是一个外向连接。这是由于公司内部有人安装了带有Conducent "adbot" 的共享软件。Conducent "adbot"是为共享软件显示广告服务的。使用这种服务的一种流行的软件是Pkware。有人试验：阻断这一外向连接不会有任何问题，但是封掉IP地址本身将会导致adbots持续在每秒内试图连接多次而导致连接过载：
机器会不断试图解析DNS名—ads.conducent.com，即IP地址216.33.210.40 ；216.33.199.77 ；216.33.199.80 ；216.33.199.81；216.33.210.41。（译者：不知NetAnts使用的Radiate是否也有这种现象）

27374 Sub-7木马(TCP)

30100 NetSphere木马(TCP) 通常这一端口的扫描是为了寻找中了NetSphere木马。

31337 Back Orifice “elite” Hacker中31337读做“elite”/ei’li:t/（译者：法语，译为中坚力量，精华。即3=E, 1=L, 7=T）。因此许多后门程序运行于这一端口。其中最有名的是Back Orifice。曾经一段时间内这是Internet上最常见的扫描。现在它的流行越来越少，其它的木马程序越来越流行。

31789 Hack-a-tack 这一端口的UDP通讯通常是由于"Hack-a-tack"远程访问木马（RAT, Remote Access Trojan）。这种木马包含内置的31790端口扫描器，因此任何31789端口到317890端口的连接意味着已经有这种入侵。（31789端口是控制连接，317890端口是文件传输连接）

32770~32900 RPC服务 Sun Solaris的RPC服务在这一范围内。详细的说：早期版本的Solaris（2.5.1之前）将portmapper置于这一范围内，即使低端口被防火墙封闭仍然允许Hacker/cracker访问这一端口。扫描这一范围内的端口不是为了寻找portmapper，就是为了寻找可被攻击的已知的RPC服务。

33434~33600 traceroute 如果你看到这一端口范围内的UDP数据包（且只在此范围之内）则可能是由于traceroute。参见本站相关部分
2003-1-23 21:11

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.021629 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 常见IP碎片攻击详解 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 常见IP碎片攻击详解

作者:
标题: 常见IP碎片攻击详解 上一主题 | 下一主题
伏地魔
落伍者

积分 1670
发贴 1495
注册 2002-9-20
常见IP碎片攻击详解

本文简单介绍了IP分片原理，并结合Snort抓包结果详细分析常见IP碎片攻击的原理和特征，
最后对阻止IP碎片攻击给出一些建议。希望对加深理解IP协议和一些DoS攻击手段有所帮助。

1. 为什么存在IP碎片
-=-=-=-=-=-=-=-=-=-=-=
链路层具有最大传输单元MTU这个特性，它限制了数据帧的最大长度，不同的网络类型都有一
个上限值。以太网的MTU是1500，你可以用 netstat -i 命令查看这个值。如果IP层有数据包
要传，而且数据包的长度超过了MTU，那么IP层就要对数据包进行分片（fragmentation）*
作，使每一片的长度都小于或等于MTU。我们假设要传输一个UDP数据包，以太网的MTU为150
0
字节，一般IP首部为20字节，UDP首部为8字节，数据的净荷（payload）部分预留是
1500-20-8=1472字节。如果数据部分大于1472字节，就会出现分片现象。

IP首部包含了分片和重组所需的信息：

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Identification |R|DF|MF| Fragment Offset |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|<-------------16-------------->|<--3-->|<---------13---------->|

Identification：发送端发送的IP数据包标识字段都是一个唯一值，该值在分片时被复制到
每个片中。
R：保留未用。
DF：Don't Fragment，“不分片”位，如果将这一比特置1 ，IP层将不对数据报进行分片。
MF：More Fragment，“更多的片”，除了最后一片外，其他每个组成数据报的片都要把比特
置1。
Fragment Offset：该片偏移原始数据包开始处的位置。偏移的字节数是该值乘以8。

另外，当数据报被分片后，每个片的总长度值要改为该片的长度值。

每一IP分片都各自路由，到达目的主机后在IP层重组，请放心，首部中的数据能够正确完成
分片的重组。你不禁要问，既然分片可以被重组，那么所谓的碎片攻击是如何产生的呢？

2. IP碎片攻击
-=-=-=-=-=-=-=-=-=-=-=
IP首部有两个字节表示整个IP数据包的长度，所以IP数据包最长只能为0xFFFF，就是65535字
节。如果有意发送总长度超过65535的IP碎片，一些老的系统内核在处理的时候就会出现问题
，
导致崩溃或者拒绝服务。另外，如果分片之间偏移量经过精心构造，一些系统就无法处理，
导致死机。所以说，漏洞的起因是出在重组算法上。下面我们逐个分析一些著名的碎片攻
击程序，来了解如何人为制造IP碎片来攻击系统。

3. ping o' death
-=-=-=-=-=-=-=-=-=-=-=
ping o' death是利用ICMP协议的一种碎片攻击。攻击者发送一个长度超过65535的Echo Req
uest
数据包，目标主机在重组分片的时候会造成事先分配的65535字节缓冲区溢出，系统通常
会崩溃或挂起。ping不就是发送ICMP Echo Request数据包的吗？让我们尝试攻击一下吧！
不管IP和ICMP首部长度了，数据长度反正是多多益善，就65535吧，发送一个包：

# ping -c 1 -s 65535 192.168.0.1
Error: packet size 65535 is too large. Maximum is 65507

不走运，看来Linux自带的ping不允许我们做坏事。

65507是它计算好的：65535-20-8=65507。Win2K下的ping更抠门，数据只允许65500大小。
所以你必须找另外的程序来发包，但是目前新版本的*作系统已经搞定这个缺陷了，所以你
还
是继续往下阅读本文吧。

顺便提一下，记得99年有“爱国主义黑客”（“红客”的前辈）发动全国网民在某一时刻开
始ping某美国站点，试图ping死远程服务器。这其实是一种ping flood攻击，用大量的Echo
Request包减慢主机的响应速度和阻塞目标网络，原理和ping o' death是不一样的，这点要
分清楚。

4. jolt2
-=-=-=-=-=-=-=-=-=-=-=
jolt2.c是在一个死循环中不停的发送一个ICMP/UDP的IP碎片，可以使Windows系统的机器死
锁。我测试了没打SP的Windows 2000，CPU利用率会立即上升到100%，鼠标无法移动。

我们用Snort分别抓取采用ICMP和UDP协议发送的数据包。

发送的ICMP包：
01/07-15:33:26.974096 192.168.0.9 -> 192.168.0.1
ICMP TTL:255 TOS:0x0 ID:1109 IpLen:20 DgmLen:29
Frag Offset: 0x1FFE Frag Size: 0x9
08 00 00 00 00 00 00 00 00 .........

发送的UDP包：
01/10-14:21:00.298282 192.168.0.9 -> 192.168.0.1
UDP TTL:255 TOS:0x0 ID:1109 IpLen:20 DgmLen:29
Frag Offset: 0x1FFE Frag Size: 0x9
04 D3 04 D2 00 09 00 00 61 ........a

从上面的结果可以看出：
* 分片标志位MF=0，说明是最后一个分片。
* 偏移量为0x1FFE，计算重组后的长度为 (0x1FFE * 8) + 29 = 65549 > 65535，溢出。
* IP包的ID为1109，可以作为IDS检测的一个特征。
* ICMP包：
类型为8、代码为0，是Echo Request；
校验和为0x0000，程序没有计算校验，所以确切的说这个ICMP包是非法的。
* UDP包：
目的端口由用户在命令参数中指定；
源端口是目的端口和1235进行OR的结果；
校验和为0x0000，和ICMP的一样，没有计算，非法的UDP。
净荷部分只有一个字符'a'。

jolt2.c应该可以伪造源IP地址，但是源程序中并没有把用户试图伪装的IP地址赋值给src_a
ddr，
不知道作者是不是故意的。

jolt2的影响相当大，通过不停的发送这个偏移量很大的数据包，不仅死锁未打补丁的Windo
ws
系统，同时也大大增加了网络流量。曾经有人利用jolt2模拟网络流量，测试IDS在高负载
流量下的攻击检测效率，就是利用这个特性。

5. teardrop
-=-=-=-=-=-=-=-=-=-=-=
teardrop也比较简单，默认发送两个UDP数据包，就能使某些Linux内核崩溃。Snort抓取的结
果如下：

第一个：
01/08-11:42:21.985853 192.168.0.9 -> 192.168.0.1
UDP TTL:64 TOS:0x0 ID:242 IpLen:20 DgmLen:56 MF
Frag Offset: 0x0 Frag Size: 0x24
A0 A8 86 C7 00 24 00 00 00 00 00 00 00 00 00 00 .....$..........
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
00 00 00 00 ....

* MF=1，偏移量=0，分片IP包的第一个。
* 结构图：

|<-------20-------->|<------8------>|<---------------28---------------->|
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| IP | UDP | Data |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

第二个：
01/08-11:42:21.985853 192.168.0.9 -> 192.168.0.1
UDP TTL:64 TOS:0x0 ID:242 IpLen:20 DgmLen:24
Frag Offset: 0x3 Frag Size: 0x4
A0 A8 86 C7 ....

* MF=0，偏移量=0x3，偏移字节数为 0x3 * 8 = 24，最后一个分片。
* 结构图：

|<-------20-------->|<--4-->|
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| IP | Data |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

如果修改源代码，第二片IP包的偏移量也可以为0x4，偏移字节数就是 0x4 * 8 = 32。

下面的结构图表示了接收端重组分片的过程，分别对应于偏移字节数为24和32两种情况：

|<-------20-------->|<------8------>|<---------------28---------------->|
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| IP | UDP | Data |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|
| +-+-+-+-+
|<------------- 24 ------------->| Data |
| +-+-+-+-+
|<--4-->|

|
| +-+-+-+-+
|<------------------- 32 ------------------>| Data |
| +-+-+-+-+
|<--4-->|

可以看出，第二片IP包的偏移量小于第一片结束的位移，而且算上第二片IP包的Data，也未
超过第一片的尾部，这就是重叠现象（overlap）。老的Linux内核（1.x - 2.0.x）在处理这
种重叠分片的时候存在问题，WinNT/95在接收到10至50个teardrop分片时也会崩溃。你可以
阅读teardrop.c的源代码来了解如何构造并发送这种数据包。

6. 如何阻止IP碎片攻击
-=-=-=-=-=-=-=-=-=-=-=
* Windows系统请打上最新的Service Pack，目前的Linux内核已经不受影响。
* 如果可能，在网络边界上禁止碎片包通过，或者用iptables限制每秒通过碎片包的数目。
* 如果防火墙有重组碎片的功能，请确保自身的算法没有问题，否则被DoS就会影响整个网络
。
* Win2K系统中，自定义IP安全策略，设置“碎片检查”。

PS:网建版快100000贴了

够酷BBS Gò Kù Bì Bì Sī
2003-7-9 15:49

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.019715 second(s), 5 queries, Gzip enabled


落伍者论坛 - 资源讨论专栏 - 网络技术常用术语汉语对照 - powered by Discuz!

落伍者论坛 » 资源讨论专栏 » 网络技术常用术语汉语对照

作者:
标题: 网络技术常用术语汉语对照 上一主题 | 下一主题
hailongcoboo
落伍者

积分 3996
发贴 3963
注册 2002-12-11
来自 钟爱那一生
网络技术常用术语汉语对照

lan 局域网
wan 广域网
utp 非屏蔽的双绞线
stp 屏蔽的双绞线
atm 异步传输模式
fddi 光纤分布式数据接口
csma/cd 载波侦听多路访问方法
msau 多站访问单元
atm 异部传输模式
pvc 永久虚拟回路
hub 集线器
pstn 公共交换电话网
isdn 综合业务数字网
adsl 非对称数字用户线路
bridge 网桥
switch 交换机
router 路由器
gateway 网关
vpn 虚拟专用网络
pri 主数率接口
bri 基本数率接口
mac 媒体访问控制
osi 开放式系统互连
tcp/ip 传输控制协议/网际协议
ipx/spx 网际数据包交换/系列数据包交换
ftp 文件传输协议
smtp 简单邮件传输协议
tcp 传输协议
ip 网际协议
appletalk 可路由协议组
irda 红外线数据协议
slip 串行线路网际协议
ppp 点到点协议
pptp 点到点隧道协议
l2tp 第二层隧道协议
ipsec internet协议安全
netbeui netbios增强型用户接口
http 超文本传输协议
udp 用户报文协议
arp 地址解析协议
icmp internet控制报文协议
igmp internet组管理协议
dns 域名系统
wins windows internet名称服务
udp 用户数据报协议
crc 循环冗余码校验
dhcp 动态主机配置协议
apipa 自动私有ip地址
cidr 无类域内路由选择
url 统一资源定位符
nat 网络地址翻译器
iana internet分配数据机构
www 万维网
ncsa 国家计算机安全协会
itsec 信息技术安全评价标准
cse 通信安全机构
ous 目录林的组织单元
pki 公用密钥基础结构
ace 访问控制条目
efs 加密文件系统
s/mime 安全的多目标邮件扩展
tls 传输层安全
pap 密码认证协议
gpo 组策略对象lan 局域网
wan 广域网
utp 非屏蔽的双绞线
stp 屏蔽的双绞线
atm 异步传输模式
fddi 光纤分布式数据接口
csma/cd 载波侦听多路访问方法
msau 多站访问单元
atm 异部传输模式
pvc 永久虚拟回路
hub 集线器
pstn 公共交换电话网
isdn 综合业务数字网
adsl 非对称数字用户线路
bridge 网桥
switch 交换机
router 路由器
gateway 网关
vpn 虚拟专用网络
pri 主数率接口
bri 基本数率接口
mac 媒体访问控制
osi 开放式系统互连
tcp/ip 传输控制协议/网际协议
ipx/spx 网际数据包交换/系列数据包交换
ftp 文件传输协议
smtp 简单邮件传输协议
tcp 传输协议
ip 网际协议
appletalk 可路由协议组
irda 红外线数据协议
slip 串行线路网际协议
ppp 点到点协议
pptp 点到点隧道协议
l2tp 第二层隧道协议
ipsec internet协议安全
netbeui netbios增强型用户接口
http 超文本传输协议
udp 用户报文协议
arp 地址解析协议
icmp internet控制报文协议
igmp internet组管理协议
dns 域名系统
wins windows internet名称服务
udp 用户数据报协议
crc 循环冗余码校验
dhcp 动态主机配置协议
apipa 自动私有ip地址
cidr 无类域内路由选择
url 统一资源定位符
nat 网络地址翻译器
iana internet分配数据机构
www 万维网
ncsa 国家计算机安全协会
itsec 信息技术安全评价标准
cse 通信安全机构
ous 目录林的组织单元
pki 公用密钥基础结构
ace 访问控制条目
efs 加密文件系统
s/mime 安全的多目标邮件扩展
tls 传输层安全
pap 密码认证协议
gpo 组策略对象

西安网通空间 西安电信空间
打造落伍最便宜，服务最好的空间 支持asp 可200人在线论坛 100M---200G任何大小都可以 价格实在
演示：http://www.hulunbeier.com.cn/ QQ：822931
2003-6-30 21:44
SHCS
今天你落伍了没有？

积分 6371
发贴 5782
注册 2003-2-15
来自 我的家
不错~~

兄弟:zwei 91love xupan 新明天 hailongcoboo sAsE
wuyemin....
姐妹:小巫仙
MYQQ:710599 102015
申请xrea x-beat是中国人拿下日本帝国的第一步-----SHCS
2003-6-30 21:45
叮咚
落伍者

积分 987
发贴 868
注册 2003-3-19
没一个看得懂的。晕。

7天收入2000元，你也可以！详情点击这里
2003-6-30 21:45
sAsE
落伍者

积分 5197
发贴 4635
注册 2003-2-14
有的重复了

歓迎するwǒ xīn fēi yáng
最新最齊的免費空間.안정의 고속의 상업의 공간.
2003-6-30 21:45
hailongcoboo
落伍者

积分 3996
发贴 3963
注册 2002-12-11
来自 钟爱那一生
冲冲数。西西~

西安网通空间 西安电信空间
打造落伍最便宜，服务最好的空间 支持asp 可200人在线论坛 100M---200G任何大小都可以 价格实在
演示：http://www.hulunbeier.com.cn/ QQ：822931
2003-6-30 21:46
冷剑无痕
落伍者

积分 770
发贴 811
注册 2003-2-15
辛苦了~~~~~~~~~~
2003-6-30 22:00

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.049024 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 【发布】阿江酷站统计最新 IP 库！ - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 【发布】阿江酷站统计最新 IP 库！

作者:
标题: 【发布】阿江酷站统计最新 IP 库！ 上一主题 | 下一主题
阿江
落伍者

积分 2817
发贴 2655
注册 2001-10-4
【发布】阿江酷站统计最新 IP 库！

    '=================================
    '
    ' 阿江酷站访问统计系统
    ' 专用 IP 库
    ' 适用版本 1.2-1.3
    '
    ' Ajiang info@ajiang.net
    ' http://www.ajiang.net/
    '
    '=================================

    阿江酷站访问统计系统自2001年底推出以来，受到广大网友的大力支持和厚爱，但是因为电信IP资源的调整，导致使用原有的IP库已经无法识别目前国内正在使用的大多数IP地址了，很多朋友反映“访问者地区”一栏中显示“未知”的过多。现在可以使用这个新的IP库来解决这一问题。

    【安装方法】

    直接上传IP.mdb覆盖原IP库即可。

    （如果原IP库已改名，请注意将文件名修改到和inc_config.asp中的设置相同。）

    【更新旧数据】

    安装了新的IP库以后，后续的访问数据即可自动以新IP库为基础判断来访者地区，但是原来的旧数据并不会更新，更新旧数据的办法是：

    1、 登录进入管理员控制台；
    2、 点击“用新的IP库刷新所有记录”。（如果存在“继续未完成的更新”的连接，则请点击此连接。）

    警告：更新过程极耗费服务器资源，因此建议广大站长在凌晨访问量较少的时候进行上述操作，数据库中现有数据超过5000的最好放弃对旧数据的更新。

    【赞助商】

    阿江统计后续版本将得到以下赞助商资助。当您有一天免费使用到了更新版本的阿江统计时，请别忘记了和阿江一起感谢他们：

    百优科技 http://www.100u.com/

    - 虚拟主机提供商的后起之秀，百优主机在速度、稳定性和控制面板
      功能等诸多方面都处在国内领先水平。
    - 从百优科技注册国际域名将长期无条件获得60元的超低价位。

    【下载】

    请从阿江（ http://www.ajiang.net/ ）首页相应栏目下载。

    【新版预告】

    1、阿江统计2.0版

    将在最近两个月内推出，推出前将发布数量不确定的测试版本。新版本将

    - 使用更合理的数据结构以节省磁盘空间并适应较大的访问量
    - 增加完全基于IP的防刷新机制
    - 更加合理的来路统计分析，可能增加搜索引擎关键词分析

    2、阿江酷站访问统计1.9版

    将在2.0版发布前后发布，继续保持1.X版本日志型的数据结构，但同时可以保持1.X版本强大的自定义查询功能。该版本主要修改1.3版中已发现的问题，并进行大规模的代码优化。

阿江 ajiang.net
2003-7-14 20:16
boysee
落伍者

积分 4803
发贴 4916
注册 2002-8-10
没明白这两个软件有啥区别。。。。

卖FTP高速空间，1G=150元，5G=700，10G=1300（每G130元）抢购中。。。。
域名75元每个，赠送20M高速空间和10M企业邮局
联系QQ：108721
2003-7-14 20:17
孙悟空
落伍者

积分 448
发贴 455
注册 2002-11-25
好

  • 代理智能文章系统(新闻)
  • 点击观看演示
  • 全国统一售价1500元 QQ:57600528
  • N级分类 自由模板 靜态生成
    2003-7-14 20:17
    小林
    o○万帖俱乐部老八^_^ ○ o

    积分 11270
    发贴 11199
    注册 2002-10-29
    来自 『新都人.COM』
    参与评分
    用户名: 小林 [退出登录]
    作者: 阿江
    评分: 积分 6 点
    标题: 【发布】阿江酷站统计最新 IP 库！

    好！！！！！！！

    万维主机-Sunking

    『统一行动，开始删贴！』
    2003-7-14 20:18
    kacha
    落伍者

    积分 4345
    发贴 4604
    注册 2002-12-15
    来自 SK PUB 2003
    爽。。
    刚来就看到这么爽的。

    llor.yeah.net 豁出去了
    2003-7-14 20:19
    o○雨缘○o
    落伍者

    积分 879
    发贴 879
    注册 2002-12-8
    来自 河南下载网
    好

    河南下载网---注册机----破解补丁----游戏外挂......
    http://www.ei30.com/image/ei30.gif

    http://www.ei30.com/
    2003-7-14 20:20
    可苦可乐
    落伍者

    积分 2715
    发贴 2646
    注册 2001-8-5
    来自 国际互联网新闻中心
    很好啊

    『不签名了』
    2003-7-14 20:23
    willi
    落伍者

    积分 4157
    发贴 4228
    注册 2002-1-29
    3Q

    Yeke.com|7755.Net|SmsCn.Com for sale

    2003-7-14 20:29
    radeon2
    落伍者

    积分 643
    发贴 653
    注册 2001-7-29
    感谢
    2003-7-14 20:29
    阿江
    落伍者

    积分 2817
    发贴 2655
    注册 2001-10-4
    不知道现在还有多少用户在使用我的这个统计器。

    阿江 ajiang.net
    2003-7-14 20:39
    鱼
    落伍者

    积分 32
    发贴 32
    注册 2003-3-19
    不错

    \\\ ///
    ( @ @ )
    ----oOOo-(_)-oOOo-----
    www.51Z.net
    Oooo
    oooO ( )
    ( ) ) /
    \ ( (_/
    \__)
    2003-7-14 20:41

    快速回复主题
    标题: (可选)
    选项:
    禁用 URL 识别
    禁用 Smilies
    禁用 Discuz! 代码
    使用个人签名
    接收新回复邮件通知
    [完成后可按 Ctrl+Enter 发布]

    可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

    论坛跳转:

    < 联系我们 - 落伍者 >

    Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
    Processed in 0.027986 second(s), 5 queries, Gzip enabled


无标题文档

域名&空间部分

a,域名部分
1. [转贴]域名命名的学问 [作者：洋愚君]
2. [原创]我来谈谈超酷域名的构想与发掘-- fm216
WEB服务器部分
1. 在apache下限制每个虚拟主机的并发数-- yake666
2. 构建DNS服务器简易指南


落伍者论坛 - 网站建设专栏 - [原创]我来谈谈超酷域名的构想与发掘！！！ - powered by Discuz!

落伍者论坛 » 网站建设专栏 » [原创]我来谈谈超酷域名的构想与发掘！！！

<< [1] [2] >>
作者:
标题: [原创]我来谈谈超酷域名的构想与发掘！！！ 上一主题 | 下一主题
fm216
落伍者

积分 480
发贴 450
注册 2002-10-3
[原创]我来谈谈超酷域名的构想与发掘！！！

再谈网站域名的构想和选取~
作为网站域名构想，是关系到网站长远发展的重要部分，一个好的域名可以给你带来很大的访问量，而生硬难记的域名也许没几个人知道。构想一个域名，就要看你的网站的性质了。
一个网站可以找个很好记的名字，或者用热门关键字，如：QQ、mm、flash、51、5i、88、163、365、xx等等，有意义或无意义都可以用数字加字母组合而成的名字，现在好多个人网站都是这样，不过垃圾网站占了好多，但不乏有好网站，成名网站有:vv66、k666、hao123、qq163、oicq88、im286等。还有就是用数字或字母的音译来表示网站内容，如：7t7t、5iasp、51job、51windows、51font、51soft等等。再有是逆向思维方式造域名，单词反写，反写或反意著名网站的名字等，如：23to6,doog，nothotmail等。还有关于模仿大站点的很多，如:,west163,siwna,sina-1,wps2000.net,eteng,soohu,cctv17……
一个专业些的网站需要一个有创意的名字，英文单词组合，自造词，纯数字或数字加字母组合，都是不错的选择，但最好不要用拼音缩写，因为全是声母很难念下去。yesky和eastart是个不错的英文单词组合，前者是yes和sky的组合，后者是east和start的组合或者可以看成是east和art的组合，我造过的是flashice.com、leafly（霖雨飞叶）、bbstart（起步者bbs）、hereyes（here yes或者her eyes的组合）。
一个商业机构的网站要有一个很响亮的好记的名字，ourgame、9sky、tencent（十分钱的腾讯公司）,bizcn等，或者可以用纯数字：163、263、363、2911、8848、3721、5945甚至6169等等，关键是好记！门户网站的名字一般都是自造词，简短好记，有些没什么意义，但美国人就是喜欢自造词或生僻词作为新的品牌商标名称，如：yahoo!,sohu,sina,lycos,google等，还有些用公司的名称(缩写)，三个字母的居多，如:AOL,IBM,MSN,TNT,AMD,TCL……还有些可以用中文的拼音，关键是好记为主，再者与网站名字相关。
大概就说这么多，因为知识有限，想不起那么多了~呵呵
构想域名切忌：
一、拼音缩写型，如lsjlt(零时间论坛）还不如0time呢，除非特别好记，如dxs（大学生）。
二、超长型，虽然好记，但超长的域名永远不可能成为门户网站。
三、牛头不对马嘴型的：如果谁把“五颜六色”给这样解释：5y6color，人家一定会认为你是个白痴。
ok，说了这么多，差不多了，来看看几个命名事例讲解：

一、我知道CDB为什么改叫Discuz~~~~~~~~~~~

"Discuz!"这不是C老大的昵称的改写嘛~
他女朋友叫因为----Because,他叫所以-----Therefor
because---->缩写'cuz----->加前缀反意discuz
通过"因为"自造一个"所以"单词,还有就是与discuss讨论有关,很形象.
后面加“！”和“yahoo！”一样,有那种兴奋的呼叫的感觉~啊！这就是Discuz!
呵呵,Crossday如能看到这段话，说说我想的对不?！是不是很聪明呢?

二、大家知道我为什么叫fm216和LaziestBee吗?
我深究过昵称这东西隐含意义的,fm是调频,我以前喜欢无线电.
216是我名字缩写zlb的变形,那ZLB中的LB不是LaziestBee缩写嘛~~想了好久才找到这么可爱的个性昵称的~~呵呵~那次在英语聊天室中老外都说:your nickname (LaziestBee) is lovely.
LaziestBee.126.com/yeah.net
fm216.126.com/yeah.net都被我占了~hehe~

三、flashice
一以前刚喜欢flash时想用flash+短单词造个用户名，用来申请邮箱什么的，后来想来想去后缀单词不能超过三个字母，而且可以连读，于是找以元音开头的简短且简单的单词，从高考单词词汇书上找到一个合适的ice，觉得不错，冷冷的冰一闪一闪的，就是我的网站名字由来！

THE END

[ Last edited by fm216 on 2003-7-5 at 03:15 PM ]

http://www.flashice.com/叶子
http://bbs.flashice.com/坛子
2003-7-4 19:03
边缘Monarchy
落伍者

积分 3754
发贴 3771
注册 2002-12-15
来自 瑪雅·中國臺灣站
恩 不错

5ua.com china165.com欲转让有意者联系QQ:9404806
來這裏下載黑白會員區軟件
2003-7-4 19:06
fm216
落伍者

积分 480
发贴 450
注册 2002-10-3
大家没反应？？？

http://www.flashice.com/叶子
http://bbs.flashice.com/坛子
2003-7-4 19:15
会飞的蛋壳
落伍者

积分 5416
发贴 5196
注册 2002-6-26
来自 www.mxav.com
呵呵,Crossday如能看到这段话，说说我想的对不?！是不是很聪明呢?

呵呵

梦想影视 www.mxav.com
梦想软件 down.mxav.com

2003-7-4 19:43
mali
落伍者

积分 1142
发贴 1184
注册 2002-2-4
顶
2003-7-4 19:43
lights
落伍者

积分 2101
发贴 2185
注册 2002-12-7
来自 河北石家庄
支持 ~ 写的的确不错
2003-7-4 19:45
losbern
落伍者

积分 1079
发贴 1095
注册 2002-12-8
还好

浙江ISP数据中心 主机支持FSO JSP ASP PHP CGI 自主管理，邮局系统，Web 站点、数据库、DNS 等服务的详细管理。诚招合作商 qq 706263 msn agent[@]zjisp.net
2003-7-4 19:48
紫雨
落伍者

积分 1480
发贴 1477
注册 2001-12-18
主要是大家不懂啊1！！
2003-7-4 19:57
随心所欲
我会尽力帮你

积分 5913
发贴 6129
注册 2002-6-30
倒~~
早看见就早给你加精华了
不过建议你把那个连接去掉，免得别人以为你做广告只嫌

暑假优惠供应ASP+ACCESS+FSO+CGI虚拟主机，QQ:626318
2003-7-4 19:58
fm216
落伍者

积分 480
发贴 450
注册 2002-10-3
ok，谢了！

http://www.flashice.com/叶子
http://bbs.flashice.com/坛子
2003-7-4 19:59
jarod
落伍者

积分 10800
发贴 11100
注册 2002-4-17
自恋

GAMER游戏网 我的破游戏网站,喜欢游戏和想下载游戏的过来看看。恒久空间演示。
笨GOGO 关于英语和留学生的论坛。
2003-7-4 20:00
小林
o○万帖俱乐部老八^_^ ○ o

积分 11270
发贴 11199
注册 2002-10-29
来自 『新都人.COM』
不错

万维主机-Sunking

『统一行动，开始删贴！』
2003-7-4 20:10
小艾
落伍者

积分 1428
发贴 1426
注册 2002-10-25
来自 南华大学
支持
收下了
2003-7-4 20:23
红孩儿
落伍者

积分 12899
发贴 13219
注册 2002-4-29
来自 青春专门店　www.4y.cn
http://www.4y.cn/

代理商务中国,新网互联所有产品(http://www.4y.cn/)
国际域名: 85 元.送6无QQ,20M空间,2个邮箱
处理:y2008.com(奥运),98块,送farewell.cn(单词:再见)
2003-7-4 20:26
willi
落伍者

积分 4157
发贴 4228
注册 2002-1-29
写的不错

Yeke.com|7755.Net|SmsCn.Com for sale

2003-7-4 23:16
<< [1] [2] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.027324 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 在apache下限制每个虚拟主机的并发数！！！！ - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 在apache下限制每个虚拟主机的并发数！！！！

作者:
标题: 在apache下限制每个虚拟主机的并发数！！！！ 上一主题 | 下一主题
yake666
落伍者

积分 601
发贴 607
注册 2002-5-13
来自 http://www.sh63.cn
在apache下限制每个虚拟主机的并发数！！！！

来自http://www.allabc.com/
论坛：http://seecee.dev-c.nl/forumdisplay.php?fid=4

下载模块：

http://www.nowhere-land.org/programs/mod_vhost_limit/mod_vhost_limit-0.4.tar.gz

官方网址： http://www.nowhere-land.org/programs/mod_vhost_limit/

安装：

apxs -c mod_vhost_limit.c -o /path/to/libexec/mod_vhost_limit.so

在 httpd.conf 加入：

LoadModule vhost_limit_module libexec/mod_vhost_limit.so
AddModule mod_vhost_limit.c

配置：

MaxClients 150
ExtendedStatus On

NameVirtualHost *

<VirtualHost *>
ServerName server1
DocumentRoot /some/where/1
MaxVhostClients 100
</VirtualHost>

<VirtualHost *>
ServerName server2
DocumentRoot /some/where/2
MaxVhostClients 30
</VirtualHost>

<VirtualHost *>
ServerName server3
DocumentRoot /some/where/3
</VirtualHost>

其中： server1 被限制为 100 个并发线程数。 server2 被限制为 30 个并发线程数。 server3 没有被限制。

注：需 mod_status 的 ExtendedStatus On 支持！！

如超出限制的并发数在客户端就会出现503错误：

Service Temporarily Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
--------------------------------------------------------------------------------

Apache/1.3.27 Server at server1 Port 80

在 error_log 中将会有类似以下的错误提示：
[Mon Jun 23 15:22:24 2003] [error] client access to server1 deferred, MaxVhostClients 100 exceeded

希望对大家有用！！

也希望斑竹来个精：）

上海163热线国际域名70元
.cn域名220元 服务器托管3800年www.sh163.cn
2003-6-28 13:56
uneed
落伍者

积分 11897
发贴 12152
注册 2002-1-13
好，收了

不卖美国主机啦，有租美国服务器的找我。。。优QQ：88903066（请注名购空间）
2003-6-28 13:59
准备早起的鸟
落伍者

积分 1354
发贴 1352
注册 2003-2-25
来自 安徽滁州
好东西
2003-6-28 14:12
yake666
落伍者

积分 601
发贴 607
注册 2002-5-13
来自 http://www.sh63.cn
也希望斑竹来个精：）

上海163热线国际域名70元
.cn域名220元 服务器托管3800年www.sh163.cn
2003-6-28 14:13
uneed
落伍者

积分 11897
发贴 12152
注册 2002-1-13
小心你精尽人。。

不卖美国主机啦，有租美国服务器的找我。。。优QQ：88903066（请注名购空间）
2003-6-28 14:13
crocodile
落伍者

积分 3068
发贴 3173
注册 2002-4-29
不错， 收下

http://www.truez.com/bbs/228zw?styleid=23
睡眠是甜蜜的
成为顽石更是幸福，
只要世界上还有罪恶与耻辱，
不见不闻、无知无觉，是最大的快乐，
——不要惊醒我吧
2003-6-28 14:16
街舞
淡淡微笑无奈的我

积分 3123
发贴 3017
注册 2001-9-14
来自 YouID.COM
很好 但我没有权利精华 手下了 T

年轻人应该多多学习，努力工作

+[EBD中文论坛]+ +[河北LINXU协会]+ +[YouID.COM]+

2003-6-28 14:35
准备早起的鸟
落伍者

积分 1354
发贴 1352
注册 2003-2-25
来自 安徽滁州
活活
2003-6-28 14:41
夜客在线
落伍者

积分 3042
发贴 3146
注册 2001-5-18
收藏

 http://www.yearcon.com/showthread.php?s=&threadid=3820

Serv_UPlus FTP 电影下载
http://www.AVfox.com
http://www.yearcon.com

2003-6-28 15:06

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.022272 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 构建DNS服务器简易指南ZT - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 构建DNS服务器简易指南ZT

作者:
标题: 构建DNS服务器简易指南ZT 上一主题 | 下一主题
丁丁
落伍者

积分 7466
发贴 7514
注册 2002-9-26
来自 家网
构建DNS服务器简易指南ZT

    在用TCP/IP协议族架设的网络中，每一个节点都有一个唯一的IP地址，用来作为它们唯一的标志。然而，如果让使用者来记住这些毫无记忆规律的IP地址将是不可想象的。人们就需要一种有记忆规律的字符串来作为唯一标记节点的名字。

    然而，虽然符号名对于人来说是极为方便的，但是在计算机上实现却不是那么方便的。为了解决这个需求，应运而生了一个域名服务系统DNS，它运行在TCP协议之上，负责将字符名--域名转换成实际相对应的IP地址。这个过程就是域名解析，负责域名解析的机器就叫域名服务器。

    1、域名解析的方法

    1.1 最早的域名解析方法

    最简单的主机名解析方法是，在一个文件中记录所有主机名及与其对应的IP地址，并保证该文件中主机名的唯一性，通过检索文件中的便可以完成主机名的解析。采用这种最简单的解决方法有其历史原因：
在整个70年代，APRANET只是一个小规模的，由类似的数百台主机组成的团体。于是为了解决主机名解析的问题，将连接到ARPANET上每台主机的名字与对应的地址都保存在HOSTS.TXT文件中。这样每增加一台机器，就必须修改HOSTS.TXT文件一次。随着网络的不断发展，网络中的主机数量爆炸性地增加，这种域名解析的方法已经无法适应新的解析需要。

    1.2 分布式的域名服务器

    这种方法，我们已经在基础篇的第六章中有了详细的叙述，在此就不再重复了。在这种分布式的域名服务器体系中，每一台域名服务器（DNS）负责解析属于自己的这一部分主机的域名。
一般说来，如果你所处在公司或组织所拥有的主机并不多，一般是将域名的解析工作交给自己的ISP的域名服务器来完成。而如果你所在组织拥有的主机比较多，我们就可以组建自己的域名服务器负责解析你所在组织的主机。

    2、域名服务器建立实例

    2.1 实例环境

    假设我们需要建立一台应用于以下情况的一个企业主域名服务器。

    1． 拥有一个C类网段地址，为202.101.55.0

    2． 企业域名注册为company.com。

    3． 域名服务器的IP定为202.101.55.55，主机名为dns.company.com。它同时充当Proxy.

    4． 企业网通过路由器与Internet连接。

    5． 要解析的服务器有：

    www.company.com (202.101.55.1) Web服务器
    mail.company.com (202.101.55.2) E-Mail服务器
2.2 安装前的准备工作

    首先要保证在作为系中统有/etc/resolv.conf和/etc/hosts.conf这两个文件。/etc/resolv.conf文件中内容如下所示：

    domain compay.com
    nameserver 202.101.55.55

    其中第一行指出对于任何希望连到它上面的主机应该搜寻的域。而第二行指出了在哪个地址可以找到需要的域名服务大。/etc/hosts.conf的内容如下所示：

    order hosts,bind
    multi on

    这里的设置告诉主机名称先在/etc/hosts文件中搜索，然后再查询域名服务器。

    2.3 定义文件/etc/named.boot

    要使LINUX系统完成域名服务器的功能，则需要运行一个named的服务进程。这个服务进程可以在安装LINUX时选中。

    named启动时需要读取一个初始化文件--/etc/named.boot，这个文件是named的基本配置文件。它并不包含任何DNS数据，针对前面的假定环境，我们要在这个文件中写入：

    diretory /etc/named
    primary company.com db.company
    primary 0.0.127.IN-ADDR.ARPA db.127.0.0
    primary 55.101.202.IN-ADDR.ARPA db.202.101.55
    cache . db.cache

    下面我们逐行讲解这个文件中的内容：

    1) 在第一行中我们指定named从/etc/named目录下读取DNS数据文件。这个目录可以自行指定并创建，指定后将所有的DNS数据文件均存放在这个目录下；

    2) 第二行指定named作为company.com的主域名服务器，db.company文件中包含了所有*.my.com形式的域名的解析数据。

    3) 第三行则指定named作为127.0.0网段（本地loopback）地址的转换主服务器。其中db.127.0.0文件中包含了所有127.0.0.*形式的地址到域名的转换数据。

    4) 第四行指定named作为202.101.55网段地址转换主服务器，db.202.101.55文件中包含了所有以202.101.55.*形式的地址到域名的转换数据。

    5) 最后一行指定named从db.cache文件中获得Internet的顶层"根"服务器地址。要说明的是，这些数据文件的名称均是自行决定的。
2.4 建立正向域名转换数据文件db.company

    根据/etc/named.boot文件中的定义，我们在/etc/named目录下建立文件db.company，并且在其中写入所有在company.com域内的主机节点。根据前面假定的环境，可以写入：
    @ IN SOA dns.company.com. root.dns.company.com.(
    200002011 ；文件版本号
    28800 ；刷新时间（秒）
    7200 ；重试时间（秒）
    3600000 ；终止时间（秒）
    86400） ；TTL生存时间（秒）
    IN NS dns.company.com
    www IN A 202.101.55.1
    email IN A 202.101.55.2
    proxy IN CNAME

    下面我们就逐句地理解这里的配置。

    1． SOA是主服务器设定文件中一定要设定的命令，我们通常将它放在文件的第一行。

    1） 最前面的符号"@"代表目前所管辖的域。

    2） 接着的"IN"代表地址类别，这里就是固定使用"IN"的。

    3） 接下来就是命令SOA。

    4） 接下来填入域名服务器，记住由于DNS数据文件的特殊格式规定，在最后一定要加上"·"，在这个例子中，我们填入域名服务器："dns.company.com."

    5） 接下来是域名服务器管理员的E-MAIL地址，但要注意的是，E-Mail地址中的分隔符"@"在这里用"·"来代替，在最后也要加上"。"，在这里，我们相应写入："root.dns.company.com."

    6） 接下来在括号内填上各种选项：

    文件版本号：当你修改这个文件的内容时，也要修改这个版本序列号。以此来区分是否有更新。

    更新时间：指定二级服务器向主服务器拷贝数据的更新时间周期。

    重试时间：指定二级服务器在更新出现通信故障时的重试时间。

    终止时间：指定二级服务器重新执行更新动作后仍然无法完成更新任务而终止更新的时间。

    生存时间：指定当域名服务器询问某个域名和其IP地址后，在域名服务器上放置的时间。

注：二级服务器所设定的域名服务器是主服务器的备份主机。

    2． 在第二行中，我们用NS命令指定这个域的域名服务器。在这里我们指出这个域的域名服务器是"dns.company.com"。

    3． 接下来的两行我们使用A命令来指定域名与IP地址的对应关系。我们将Web服务器的域名www.company.com与其IP地址202.101.55.1对应起来；将E-Mail服务器的域名mail.company.com与其IP地址202.101.55.2对应起来。

    4． 最后一行，我们使用了CNAME命令为dns.company.com指定了另一个域名以供使用：proxy.company.com。

    2.5 建立反向域名转换数据文件db.127.0.0和db.202.101.55

    反向域名转换数据文件用来提供IP地址查询相应的DNS主机名，每个网段分别有一个数据文件。

    1． 网段127.0.0通常只有一个地址，那就是127.0.0.1 loopback地址。所以我们在db.127.0.0中写入的内容是：

    @ IN SOA dns.company.com. root.dns.company.com.(
    200002011 ；文件版本号
    28800 ；刷新时间（秒）
    7200 ；重试时间（秒）
    3600000 ；终止时间（秒）
    86400） ；TTL生存时间（秒）
    IN NS dns.company.com
    1 IN PTR localhost

    前面两名相信读者已经不会陌生，最后一句我们使用PTR命令让配置文件中的主机可以使用IP地址来知道所对应的域名。

    最前面的1代表127.0.0.1，对应的域名就是localhost。

    2．网段202.101.55就可能会存在更多的记录，前面假定环境下的设置应是：

    @ IN SOA dns.company.com. root.dns.company.com.(
    200002011 ；文件版本号
    28800 ；刷新时间（秒）
    7200 ；重试时间（秒）
    3600000 ；终止时间（秒）
    86400） ；TTL生存时间（秒）
    IN NS dns.company.com
    1 IN PTR www
    2 IN PTR email
    55 IN PTR dns
    55 IN PTR proxy
2.6 获得db.cache文件

    在LINUX系统中通常在提供了一个named.ca的文件，该文件中Internet的顶层域名服务器，但是这个文件通常会发生变化，所以建议最好从Internet上下载最新的版本。该文件可以通过匿名FTP从ftp.rs.internic.net/domain下载，文件名是named.boot。将它拷贝一份为db.cache就可以了。

    3、测试域名服务器

    3.1 使用nslookup测试

    nslookup命令的功能是查询域名服务器中的数据资料。下例就是使用它来测试域名服务器是否架设成功，其中斜体字代表要输入的内容。

    # nslookup
    Default server:dns.company.com

    Address:202.101.55.55 ；能出现这些信息代表成功

    > www
    server:dns.company.com
    Address:202.101.55.1

    3.2 使用ping测试

    还有一种更简单的测试方法，那就是用ping命令，如果成功将显示：

        # ping http://www.company.com/
        Ping http://www.company.com(202.101.55.1);56/ data bytes
        64 bytes from 202.101.55.1:icmp_seq=0 ttl=255 time=1.3ms
        64 bytes from 202.101.55.1:icmp_seq=1 ttl=255 time=0.6ms
        64 bytes from 202.101.55.1:icmp_seq=2 ttl=255 time=0.6ms
        ……

    8.4 小技巧

    安装好域名服务器后，在内部使用域名进行远程连接时，会发现速度非常慢。其实只要/etc/hosts中加上所有内部的机器的域名就可以了。

专业代理神话科技（有个网络）、商务中国、中资源、新网互联等国内多家公司以及香港等公司的虚拟主机、域名服务，欢迎选购！
QQ：46855115 （请注明购买主机或域名，谢谢合作）
2003-7-11 10:56
ejan
落伍者

积分 6873
发贴 6697
注册 2002-5-8
来自 @__________________@
加１００分。

偶爱这里所有可爱的版主同志！
A-Do.net[阿杜]网站出售,BBsex.Net [BBS&Sex]和inBJ.Net[在北京]出售！ 详情点击这里!
2003-7-11 10:56
丁丁
落伍者

积分 7466
发贴 7514
注册 2002-9-26
来自 家网

Quote:
Originally posted by ejan at 2003-7-11 10:56 AM:
加１００分。

捏的，你怎么没实际行动啊

专业代理神话科技（有个网络）、商务中国、中资源、新网互联等国内多家公司以及香港等公司的虚拟主机、域名服务，欢迎选购！
QQ：46855115 （请注明购买主机或域名，谢谢合作）
2003-7-11 10:58
ejan
落伍者

积分 6873
发贴 6697
注册 2002-5-8
来自 @__________________@

Quote:
Originally posted by 丁丁 at 2003-7-11 10:58 AM:

捏的，你怎么没实际行动啊

日，能加就好了。。。。偶没权限啊。

偶爱这里所有可爱的版主同志！
A-Do.net[阿杜]网站出售,BBsex.Net [BBS&Sex]和inBJ.Net[在北京]出售！ 详情点击这里!
2003-7-11 10:58
丁丁
落伍者

积分 7466
发贴 7514
注册 2002-9-26
来自 家网

Quote:
Originally posted by ejan at 2003-7-11 10:58 AM:

日，能加就好了。。。。偶没权限啊。

专业代理神话科技（有个网络）、商务中国、中资源、新网互联等国内多家公司以及香港等公司的虚拟主机、域名服务，欢迎选购！
QQ：46855115 （请注明购买主机或域名，谢谢合作）
2003-7-11 10:59

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.038772 second(s), 5 queries, Gzip enabled


落伍者论坛 - 资源讨论专栏 - [转贴]域名命名的学问 [作者：洋愚君] - powered by Discuz!

落伍者论坛 » 资源讨论专栏 » [转贴]域名命名的学问 [作者：洋愚君]

作者:
标题: [转贴]域名命名的学问 [作者：洋愚君] 上一主题 | 下一主题
zephyr
落伍者

积分 4135
发贴 4069
注册 2001-10-18
来自 --珠峰数据--Www.8848IDC.Com
[转贴]域名命名的学问 [作者：洋愚君]

不要是您想开个商号，比如饭馆(请勿见笑，我们的国情是民以食为天)，什么最重要，美国人会告诉您说：“Location, location, and location”，中国人则说：“地点，地点，地点”(怎么有点像《列宁在一九一八》)。 　　现在是网络时代了，要想把一个网站做“火”，什么最重要？您可能会告诉我：资金，人才，市场推广( =？炒作)，内容，服务……，等等。但是网站的名字就象传统商业的地点一样，好象更重要。因为那叫品牌。

    比如，Yahoo这名字，让人一看可能就记住了而且读起来上口，这名字除了引经据典(Yahoo是《格列佛游记》中的人物)，还幽了自己和用户一默——我是网上一“粗汉”，您要不是网上一“乡愚”，你用我Yahoo干什么？结果风险资本家们用大笔大笔的钱把这个名字炒的更火。现在的字典都在Yahoo这个词条下加了个新的注释。Yahoo的牌子据说估价都快赶上可口可乐这个作了半个世纪的老牌子了。

    所以，建立网络商业品牌的首要步骤，就是给您的网站起个好名字。

    起名字可是学问。您没看见许多香港的小明星火不起来，怎么办？找了个起名专家(实际上就是算命先生)把名字一改，怎么样？火了。起名字的学问实际上源于对文化潮流的理解及对大众心理的把握。起个好名字实属不易。既要容易记，读起来上口，又要有意义。还不能让人联想出歧义。

    互联网起源于美国，网站所用的名字或地址是英文的。中国的网站除了要有个好的英文名，还要起个好的中文名。这中英两个名字还要相互对应，这就需要对中西两种文化都要有所了解。

    本人不敢说对中西文化都有了解，只是从一个上网多年的用户角度对现有的中国网站的名字评说一番，话粗理不俗，哪点讲得不中听，您可别当真。

    要说中国网站最出名的可能要算“新浪网”了。实际上新浪这名字开始用也不过是在1998年底的事。记得当时第一次听说“新浪”这名字，还以为是个黄色网站呢(都怪这个“浪”字)。后来才知道是Sinanet.com和国内的四通利方合并而成。

    Sinanet.com当年由几个斯坦福的学生组成。他们用一个作CAD的软件把台湾大五码汉字文件自动转换为图形文件放在网上。这样为当时计算机上没有中文系统的美国汉语用户提供了方便。当时的Sinanet.com只是一个提供一些中文的台湾新闻的小网站。说它是“北美第一大中文网”有点言过其实。不信你问问有谁还记得它的中文名字“华渊网”。不管如何，新浪这名字听起来要比华渊容易记得多。

    新浪可能是音译自它的英文名Sina.com(音译好象应该是“吸拿”)。拉丁文中SINAE是中国人的意思。英文中没有SINA这词，倒是有Sin，意思是宗教或道德上的罪孽。对一般的中国老百姓来说新浪网的英文名字可能难了点，尽管它只有四个字母。对讲英语的人来说这名字听起来有点古色古香或是说老气了点，不够现代，不够“酷”。

    搜狐当年的英文名字是Sohoo.com。这名字明显是学着Yahoo来的。搜狐为了避“东施”之嫌，同时也是因为他们的域名Sohoo.com不留神让一个南韩公司在1999年底给抢注了(不知是改名在先还是抢注在先？张朝阳怎么连个域名都看不住？)，搜狐只好改名Sohu.com。

    Sohu.com发音听起来象Soho。上次与一美国佬提起搜狐，他困惑地问我：“你是说伦敦的Soho，还是曼哈顿的Soho？”原来在伦敦中区和纽约曼哈顿岛的西南都有一个挺出名的区叫Soho。美国佬还以为这Sohu.com是介绍这两个区的网站呢。

    英文名字容易让人误解，全怨咱在美国是学物理的，可这中文名字也不太好听。狐狸在中国文化中好象名声不太好，本来就有骚和臭的嗅觉效果，如果再加个“馊”字，味道可能更加刺激难闻了。不过咱全当他是幽咱一默。让咱捏着鼻子上他的网。

    可是有一个网站叫ChinaRen.com，这个土洋结合的名字可是让我怎么也幽默不起来。这个网站的中文名字好象叫中国人网，中文名字倒是没什么。问题是它那广告打得到处都是还自以为得意的土洋结合的英文名。

    上次一美国佬问我：“What is China Ren?”，我顺嘴答道：“Ren means man, China Ren is Chinaman?”，说完了我也愣住了！Chinaman是一个极具侮辱性的对中国人的蔑称。好象应翻译成“支那人”(与“东亚病夫”同义)。

    我一个朋友在美国买房子，那个卖主因为嫌出价低，讲了一句侮辱的话，说：“我可不要把房子卖给那个Chinaman”。这句话可把我朋友的房屋经纪人给惹恼了。告了那个卖主种族歧视，后来卖主当庭道了歉，差点没进了班房。

    咱们这几个号称是斯坦福的毕业生好象不知道Chinaman的侮辱性，顺着它，就演绎出了个ChinaRen.com，以为中国人都不知道那是在骂人。它的广告在北京打的到处都是，咱北京怎么没一人出来问问：“你丫骂谁呢？！”

    咱们斯坦福的同学，如果你们真想把网站做大，我劝你们还是换个名字。至少我决不会用一个侮辱中国人的网站。我想其他网民也不愿自己找这个刺激。

    要说名字起的好的也有，China.com的中文名字“中华网”就不错，可是它的英文名字China.com，就有点过了，一香港公司怎么能代表中国。而且这个网实在是盛名之下，其实难符。不过他们就凭着这个名字在华尔街一通狂炒，把“中国概念”彻底玩到家了。不服不行，就这么个名字，玩的好吧。

    相对来说，“中国大全”网站的英文名字ChinaSite.com是个好名字。通俗易懂，恰如其分。你也许注意到许多网站都有一两个网页包含了许多中国网站的链接。这些网页经常被叫作chinasite.html，可见大家都习惯性地把中国网站翻译成英文China Site。

    ChinaSite.com的中文名字叫“中国大全”，听上去有点象当年高考补习资料的名字。不过如果这个网站真的能把内容做到大而全，到是不辜负这个名字。只是随着中国互联网的发展，这大而全的事难点。听说有公司出价300万美元买这个网站，中国大全的那位仁兄不卖。如果您真能找来大笔的投资，把这ChinaSite.com做成是网上大而全的一站，您这名字上了市，美国股民一看这名字就知道这网站是干什么的，追炒一下您这股票，您也让这股票翻它几翻，您到也对得起这么个好名字。否则的话，还不如卖给人家，让人家去作。要不这名字多浪费。

    中国网站的名字难起，好名字难找，也是因为网络域名现在已经开始变成了稀有资源了。好的名字几乎全都有了主儿了。China开头的名字，随着中国网络的热炒，已经找不到了。这就逼得这些网站命名时在土洋结合上做文章。比如，eBay.com出名后，马上出了一连串以e开头再加个中国字的中国特色网络域名。比如亿唐，它的的英文名字叫eTang.com，听起来有点像网上黑社会。看过《教父》的人都明白，那里的“瑭”是黑社会的化身。

    e龙的英文名字eLong.com，让美国人念起来就变成了“一浪”，听起来要不像So long(再见)，或是像elongate。也是有点不对劲。e开头的找不到了，就用my开头。my开头的不好听。那么就在已注册的名字中加一小横。

    再不就全用数字，您看现在到处是“碍特，碍特”的(eight)。什么招都用了。最后干脆全用拼音。这下中国网站的名字更稀奇古怪了。

    那位说了，你老管老美怎么念干吗？中国人听着好就行了。可是，您要到美国去融资，您要到美国去上市，您弄一个lousy name。老美念着不对劲，您上了市，股票也长不起来。您的网除了要在中国出名，您的品牌还要在美国的股民中得到响应，您的股价才不会像网易那样跌破发行价。

    您上市前后，都要作美国股民的工作，要让老美股民人人都记住您这一号，一旦中国加入WTO了，或是中国的网民达到12亿了，美国股民第一个追捧的是您的股，您说您这名字是不是也得照顾点老美？所以起名字的时候，您除了要胸怀12亿中国人民，还要放眼美国乃至全世界的广大股民。您说是不是？

    起名字要有点创造性，别e来e去，这个碍特，那个碍特的。如果您所能想到的好名字都有了主儿了，该买就买，如果让竞争对手买了去，更难办。

    该出手时，就出手。是这么说的吧？

以上文章由域名博士http://www.drname.com提供。/
2002-11-20 14:49
网际浪子
落伍者

积分 2034
发贴 1807
注册 2003-2-14
来自 落伍者
精华。
2003-6-12 14:12
金星
落伍者

积分 280
发贴 308
注册 2003-6-12
来自 湖北宜昌
实用
2003-6-12 14:46
tangliuren
落伍者

积分 1689
发贴 1237
注册 2002-9-6
来自 china
不错

Quote:
和落伍一起成长

2003-6-12 14:47

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.021983 second(s), 5 queries, Gzip enabled


无标题文档

教程部分

1. 鼠标效果系列教程之三——游动的鱼 -- eurostar
2. 第一 次写的LOGO教材~呵呵~大家砸砸 -- 没有人
3. 第一次写教程~~<<象素按钮>>~请大家支持!! -- TV狼乖乖
4. 作加强版的Apple风格按钮（Cool）！！！图文教程 -- xboycn


落伍者论坛 - 资源讨论专栏 - 鼠标效果系列教程之三——游动的鱼 - powered by Discuz!

落伍者论坛 » 资源讨论专栏 » 鼠标效果系列教程之三——游动的鱼

作者:
标题: 鼠标效果系列教程之三——游动的鱼 上一主题 | 下一主题
eurostar
落伍者

积分 5502
发贴 4007
注册 2003-2-14
来自 黑客栈
鼠标效果系列教程之三——游动的鱼

概述
有了上一节的基础，现在我们可以做一个更华丽的效果—追逐鼠标游动的鱼。如下所示。
[Open New Window]

打开Flash MX，建立影片，设置好场景大小、背景颜色和帧频。
鱼的制作
我们把鱼分成三个部分来制作：鱼头、鱼鳍和鱼身。
先来制作鱼头。新建个影片剪辑叫“鱼头”。如果对话框的扩展面板没打开，点击“高级选项”按钮打开它。在“链接”的选项中，勾选“为动作脚本导出”，在“标识符”一栏中，会自动出现“鱼头”这个名称。为了让大家分清楚影片剪辑在库中的名称和它的标识符的区别，我们把它改为“head”。注意，这个head就是影片剪辑“鱼头”的idName。将来我们用attachMovie语句从库中调用“鱼头”时，就要用到它。如图1

图1

进入符号编辑区，使用绘图工具绘制一个鱼头，可以使用椭圆工具先绘制一个椭圆，然后使用箭头工具对其进行调整，最后再用椭圆工具绘制两个眼睛。如图2

提示：使用箭头工具指向打散图形的边缘，当箭头尾部出现一个小圆弧时，按住鼠标左键拖动，就可以编辑图形的形状了。

图2

鱼头做好后，接下来制作鱼身。新建个影片剪辑名为“鱼身”。绘制出如下形状并设定一个渐变色填充。如图3

图3

我们也要给它设定一个idName。在库中右键点击鱼身符号，在弹出菜单中选“链接…”。接着在弹出的链接属性对话框中，在标识符栏里填入“body”。如图4

图4

最后来制作鱼鳍。再新建个影片剪辑叫鱼鳍，idName为“fin”。进入编辑区，在第一帧绘制出鱼鳍的形状。如图5

图5

分别在第15帧和第30帧按F6插入关键帧。我们要做鱼鳍来回扇动的动画。来到第15帧，用箭头工具编辑形状并用混色器面板调节一下颜色。最后如图6

图6

将第1帧和第15帧都设为形状渐变。
好，鱼儿三部分的制作就完成了。下面就是动作脚本的编写了。
在场景的第1帧，加入如下动作：
// 初始化鱼儿
N = 20; //鱼的长度
for (i=1; i<N; i++) {
if (i == 1) { //第1节是鱼头
attachMovie("head", "Pieza"+i, (N+1)-i);
} else if ((i == 4) || (i == 14)) { //第4和14节是2个鱼鳍
attachMovie("fin", "Pieza"+i, (N+1)-i);
} else { //其它的都是鱼身
attachMovie("body", "Pieza"+i, (N+1)-i);
}
//设置大小和透明度
this["Pieza"+i]._xscale = 100-3*i;
this["Pieza"+i]._yscale = 100-3*i;
this["Pieza"+i]._alpha = 100-((100/N)*i);
}

这里介绍一下attachMovie的用法：
myMovieClip.attachMovie( idName, newName, depth [, initObject] )
参数
idName 库中要附加到舞台上某影片剪辑的影片剪辑元件的链接名称。这个我们在前面已经反复强调了，相信大家还没忘吧？要把它和库中显示的元件名区别开，元件名只是个记号，编程时是用不到的。
newname 附加到该影片剪辑的影片剪辑实例的唯一名称。
depth 一个整数，指定影片所放位置的深度级别。
initObject 一个包含属性的对象，这些属性可用于填充新附加的影片剪辑。此参数使动态创建的影片剪辑能够接收剪辑参数。如果 initObject 不是对象，则将被忽略。initObject 的所有属性都会被拷贝到新实例中。构造函数可使用由 initObject 指定的属性。此参数是可选的，我们这里用不到它。
返回
无。
说明
方法；从库中取一个元件并将其附加到舞台上由 MovieClip 指定的影片中。使用 removeMovieClip 或 unloadMovie 动作或方法可删除用 attachMovie 附加的影片。

第2帧的动作脚本：
//此帧控制鱼的移动
R = 12; //调节移动速度的参数
//控制鱼头跟随鼠标移动
Pieza1._x+=(_xmouse-Pieza1._x)/R;
Pieza1._y+=(_ymouse-Pieza1._y)/R;
//控制鱼头转向鼠标的方向
Pieza1._rotation = 57.29578*Math.atan2(_ymouse-Pieza1._y,_xmouse-Pieza1._x);
//控制鱼身跟随鱼头
for (i=2; i<N; i++) {
this["Pieza"+i]._x+=(this["Pieza"+(i-1)]._x-this["Pieza"+i]._x)/2;
this["Pieza"+i]._y+=(this["Pieza"+(i-1)]._y-this["Pieza"+i]._y)/2;
this["Pieza"+i]._rotation=57.29578*Math.atan2(this["Pieza"+(i-1)]._y-this["Pieza"+i]._y,this["Pieza"+(i-1)]._x-this["Pieza"+i]._x);
}

关于跟随的语句，不用多作解释了吧。不过有的朋友可能对“+=”这个操作符不太熟悉。“A+=B”表示什么呢？它其实就等价于“A=A+B”。同理，“A-=B”就相当于“A=A-B”。
控制鱼的转向时，用到了一个数学对象：Math.atan2()。看一下它的用法：
Math.atan2(y, x)
参数
x 一个数字，指定点的 x 坐标。
y 一个数字，指定点的 y 坐标。
返回
一个数字。
说明
方法；以弧度为单位计算并返回 y/x 的反正切值。返回值表示相对直角三角形对角的角，其中 x 是临边边长，而 y 是对边边长。
简单的说，就是根据点的坐标来求角。但它返回的是个弧度值，我们还要把它转变成度数才能用到_rotation属性中。用下面这个公式来计算：
度数=弧度*180/3.14159265=弧度*57.29578

第3帧的action只有一句：
gotoAndPlay(2);

返回第2帧，做成一个循环，使鱼儿不停游动。
好，本例的制作就完成了。通过这一节的学习，我们又掌握了几个知识点：
一、 idName的设置。可以在创建符号时就设好，也可以给做好的符号添加。
二、 attachMovie的用法。
三、 利用两点坐标求角度：Math.atan2(y2-y1,x2-x1) 注意是y在前面哟。

源文件下载

更多教程见 http://bbs.reset.at/

好的论坛只有精华http://bbs.reset.at
2003-7-2 17:44
ajie.net
醒了醒了

积分 7453
发贴 7619
注册 2002-2-13
加分
精华

买地/种玉米 http://www.hyidc.com/
暑假大优惠：国际玉米 60 元 国内玉米 180元
QQ:82409 mail:info@hyidc.com
2003-7-2 17:48
绿云龙
落伍者

积分 4287
发贴 4380
注册 2002-8-14
来自 『新飞网络』
不错，好玩！

恒久科技提供最高性价比高速ASP.NET+ACCESS,PHP+MYSQL+CGI空间
2003-7-2 17:48
missme
落伍者

积分 510
发贴 519
注册 2003-6-19
verygood~~~~
thx

小可论坛：http://missme.7u7.cn/
感谢371it商务频道送国际玉米:http://www.371it.com/
2003-7-2 17:49
鲜每の℃
落伍者

积分 3290
发贴 3326
注册 2002-8-20
来自 华南理工大学
好东西，收了。

中国破解组织联盟CCG
China Cracking Group
看雪学院：http://www.pediy.com/
强烈建议各位朋友去我的论坛。
2003-7-2 17:53
sAsE
落伍者

积分 5206
发贴 4644
注册 2003-2-14
好东西

歓迎するwǒ xīn fēi yáng
最新最齊的免費空間.안정의 고속의 상업의 공간.
2003-7-2 17:53
FENGXINZI
落伍者

积分 18
发贴 18
注册 2003-2-14
Thanks!
2003-7-3 10:45
鬼啸
落伍者

积分 1796
发贴 1825
注册 2002-10-31
来自 广西柳州市
高手~~~~~

欢迎光临我的小站
2003-7-3 10:48
伏地魔
落伍者

积分 1676
发贴 1501
注册 2002-9-20
Very good

够酷BBS Gò Kù Bì Bì Sī
2003-7-3 10:59
kegu
落伍者

积分 1936
发贴 2248
注册 2001-9-30
来自 神啊~救救我吧
好东西

真正的骗子论坛→黄金论坛
希望大家不要再上当了

2003-7-15 19:11
dreamyboy
落伍者

积分 11187
发贴 11684
注册 2002-10-10
来自 飘逸网络
我怎么好象看过？》

代理高速LINUX虚拟主机业务。联系
QQ：691932，演示：http://www.go8go.com/，
买一年送一个月，两年送三个月！MSN：
我的MSN：go8go8go@hotmail.com,ICQ:195225878
2003-7-15 19:17
荒芜沙漠
落伍者

积分 1425
发贴 1448
注册 2002-2-14
要求加精

真正的共产主义→黄金论坛
网络收费账号免费提供
2003-7-15 19:44
angelk7
落伍者

积分 1044
发贴 1092
注册 2002-12-29
不错

碧玉情，情归何处？
水中月，月坠何方？

广告位招租
2003-7-15 19:49

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.028238 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 制作加强版的Apple风格按钮（Cool）！！！图文教程 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 制作加强版的Apple风格按钮（Cool）！！！图文教程

<< [1] [2] >>
作者:
标题: 制作加强版的Apple风格按钮（Cool）！！！图文教程 上一主题 | 下一主题
xboycn
落伍者

积分 4635
发贴 4627
注册 2002-7-5
来自 cn→zj
制作加强版的Apple风格按钮（Cool）！！！图文教程

1.新建一透明层, 画出一个黑色胶囊状的图形.方法是:先画一正圆切换移动工具(Move tool)按住Shift向右拖动鼠标, 将复制的圆形放在合适位置,接着画一长方形将两个原形连接起来并填充黑色.合并图层,这样你就得到了胶囊按钮的图形.

2.新建一层,改变图层混合模式为Screen. 选择合适的前景色和背景色,从按钮的顶部到底部拖一垂直渐变.在这里我用了0x2654A0 和 0xAFCBEE做前景色和背景色. 注意:我所选用的颜色都不是网页安全色(web-safe colors).如果你要把此按钮放在网页上的话,可能需要寻找更好的颜色 ,否则别人看不到不是太可惜了吗. Right?
按住Ctrl+G将渐变层置入按钮图层中.

3.Ctrl+点击黑色按钮图层, 将选择区域保存为通道. 选择你所创建的通道, 保持选择区域浮动, 收缩(contract)它 (具体收缩的数量要看你图像的大小而定) 直到如图所示.
对于其它样式的图形, 例如文字一类有锐角的图形, 你可能需要应用 Select > Modify > Smooth 来平滑图形,具体的数量根据具体情况而定.
反转选择区域 并填充黑色.

4.如果你愿意, 可以发挥到图像编辑窗口在快速蒙版(QuickMask)中进行下一步或继续在通道中编辑.我更愿意选择快速蒙版模式, 因为它能立刻让我看到效果.
保持选择区域浮动按 Q进入快速蒙版.在按钮的底步画一长方形并填充黑色,最终效果如图,其中红色部分代表未选中部分.

5.用高斯模糊(Gaussian Blur) 和亮度/对比度( Brightness / Contrast )进行调整, 如图. 按 Q退出快速蒙版模式再次将选择区域存入通道中.这一步是为按钮的顶部加入高光

6.复制 先前收缩的Alpha channel, 并进行Gaussian Blur. 这一步将给按钮的底部加入高光. 因为它没有硬边,所以我们不需进入快速蒙版模式.

7.回到层面版, 新建一层读取我们为按钮顶部高光建立的Alpha通道选择区域. 选择层>新建图层蒙版>显示选择区域( Layer > Add Layer Mask > Reveal Selection).
点击层图标确保我们是在图层上工作而不是图层蒙版. 选择渐变工具, 在渐变属性面版中选择白色前景色到透明的渐变. 从按钮顶部到中部做一线性渐变填充.调整图层不透明度到80%.

8.新建一层选择混合模式为Color Dodge. Fill it with neutral black. 读取我们为按钮底部高光建立的Alpha通道的选择区域. 再次选择层>新建图层蒙版>显示选择区域(Layer > Add Layer Mask > Reveal Selection).
选择渐变工具设置为白色前景色到透明渐变, 从按钮底部到中部拖动. 调整不透明度为35%.

9.你知道我非常喜欢闪烁的光线.这是苹果按钮所没有的,我想它的效果非常不错. 如果你没有看过我先前的chrome tutorial, 这里将告诉你如何做这些闪光:
新建一层选择一个巨大的soft brush. 点击停留少许时间, 接着, 不要移动画笔的中心点, 按下 [ 键选择一个稍小的soft brush再点击并停留一些时间. 接着再按一次 [键 选择一个较小的soft brush继续绘制.

10.现在为原始的黑色胶囊层添加阴影(dropshadow) 特效. 不要选择太暗的颜色; 因为我们是在做苹果按钮, 不是吗? 它是透明的, 所以光线会穿过按钮. 因此最好选择一个接近按钮的颜色做阴影.
现在给按钮加入一些黑色文字. 苹果在Mac OS X用的是 Lucida Sans 字体. Roman字体 应该也不错.
为文字层加入 阴影(dropshadow)特效. 让阴影稍稍远离文字一些距离,调整阴影的不透明度为80%.

11.Hey,那就是最终的效果. 如果你还想更进一步并在按钮后加入一些灰线,往下看. 适合的背景图案将使你的按钮显得更加透明.
新建一任务,白色背景.新建一层模式为 Multiply.画一水平的黑线 扩展置画部两边.用 移动工具,按下 Alt 和 Shift 将复制线条向下移动一些. 这样将新建一线条复制层,执行Ctrl-E将它与原先的线条层合并.重复此步, 复制,合并, 复制,合并, 直到你有了足够的线条如图.

12.调整不透明度至7%. 干的不错!

13.如果你真想给人们留下深刻印象, 你可以使按钮后的线条看起来有一些折射. 一个小技巧, 例如创建一个用于置换(displacement )的地图,如下图.
我制作这幅图的方法是选择先前收缩的 Alpha 通道, 读取选择区域, 应用 Circular Shapeburst(在KPT3的Gradient Designer工具中), 并进行高斯模糊(Gaussian Blur).
如果你没有KPT3, 那么你或许可以的到相似的结果,方法是:在全黑的通道中用读取先前收缩 Alpha 通道的选择区域,进行收缩调整,用白色填充选择区域, 读取先前收缩的 Alpha 通道选择区域, 应用大数值的 Gaussian Blur.

14.选择从弹出式菜单选择复制通道( Duplicate Channel), 在折叠菜单中选择 New. 单击 OK 保存新文件为PSD. 这个文件将用做置换的地图.
选中黑线层.Alt+点击图层左部的眼睛图标 这将隐藏除了黑线层之外的所有层.调整图层不透明度为100% 这将更易于我们观察. 现在拖动此层到右下角的新建层图标上 ,复制此层. 点击左部的眼睛图标隐藏按钮图层. 现在, 没有选中任何物体, 执行屡镜>变形>玻璃( Filter > Distort > Glass )从下部的菜单中选择读取材质( Load Texture). 在弹出的菜单中选择我们存储的PSD文件点击 OK. 选择较低的变形(Distortion 和平滑 (Smoothness)设置, OK.
最终的结果可能有一些锯齿.你可以用轻微的 高斯模糊(Gaussian Blur)和 亮度/对比度(Brightness / Contrast)进行调整.
现在读取你第一次建立的 Alpha 通道 反转选择区域. 按 Delete 选择混合模式为 Normal.
恢复下部黑线层可视, Ctrl-E对这两层进行合并 返回不透明度为7% . 恢复所有图层可视.

15.完成.
Oh, 顺便说一句, 如果你不喜欢蓝色,可以用色相/饱和度(Hue / Saturation)调整图层轻易的改变按钮的颜色.

这篇教程非常不错，希望能给大家一些启发！

感谢落伍的朋友：丁丁|Delin|Arvan|imsaul|jarod…
云网数字卡直销商,出售各种数字卡

ＮＢＡ中国
2003-7-3 00:57
hotworm
玩的就是心跳

积分 6456
发贴 6437
注册 2001-7-21
来自 旮旯
是ps教程还是fw的？

需要字体 请点祝福吧　　　　　落伍者专用qq：29642474

跟我帖，有好处。但别灌水！
2003-7-3 01:00
xboycn
落伍者

积分 4635
发贴 4627
注册 2002-7-5
来自 cn→zj
是

Adobe Photoshop 的啦

感谢落伍的朋友：丁丁|Delin|Arvan|imsaul|jarod…
云网数字卡直销商,出售各种数字卡

ＮＢＡ中国
2003-7-3 01:01
hotworm
玩的就是心跳

积分 6456
发贴 6437
注册 2001-7-21
来自 旮旯

Quote:
Originally posted by xboycn at 2003-7-3 01:01:
是
Adobe Photoshop 的啦

精——晶
收藏了先

需要字体 请点祝福吧　　　　　落伍者专用qq：29642474

跟我帖，有好处。但别灌水！
2003-7-3 01:03
xboycn
落伍者

积分 4635
发贴 4627
注册 2002-7-5
来自 cn→zj
我很喜欢APPLE风格

感谢落伍的朋友：丁丁|Delin|Arvan|imsaul|jarod…
云网数字卡直销商,出售各种数字卡

ＮＢＡ中国
2003-7-3 01:04
没钱的男孩
落伍者

积分 2771
发贴 2688
注册 2002-5-15
上精华？类似的文章看过N次了

傲群网络 业务联系QQ：48931 技术支持QQ：23721 25954
2003-7-3 01:05
hotworm
玩的就是心跳

积分 6456
发贴 6437
注册 2001-7-21
来自 旮旯

Quote:
Originally posted by 没钱的男孩 at 2003-7-3 01:05:
上精华？类似的文章看过N次了

这些文章不上精华。难道让那些水上精华吗？
现在这里不缺少欢乐和轻松的氛围。
缺少一种虚心好学的态度
大家现在都浮躁的想赚钱，赚钱没错，可是这里是学习与交流的地方

需要字体 请点祝福吧　　　　　落伍者专用qq：29642474

跟我帖，有好处。但别灌水！
2003-7-3 01:08
crocodile
落伍者

积分 3068
发贴 3173
注册 2002-4-29

Quote:
Originally posted by hotworm at 2003-7-2 13:08:

这些文章不上精华。难道让那些水上精华吗？
现在这里不缺少欢乐和轻松的氛围。
缺少一种虚心好学的态度
大家现在都浮躁的想赚钱，赚钱没错，可是这里是学习与交流的地方

严重同意你这个苍蝇

净化 收藏ing

http://www.truez.com/bbs/228zw?styleid=23
睡眠是甜蜜的
成为顽石更是幸福，
只要世界上还有罪恶与耻辱，
不见不闻、无知无觉，是最大的快乐，
——不要惊醒我吧
2003-7-3 01:18
zonel
落伍者

积分 5460
发贴 5500
注册 2002-2-11

Quote:
Originally posted by xboycn at 2003-7-3 12:57 AM:
1.新建一透明层, 画出一个黑色胶囊状的图形.方法是:先画一正圆切换移动工具(Move tool)按住Shift向右拖动鼠标, 将复制的圆形放在合适位置,接着画一长方形将两个原形连接起来并填充黑色.合并图层,这样你就得到了胶 ...

教程很早就看过了

不过以前的教程里没这个。。
http://218.28.49.10/supercow/website/Library/pmsj/ps/aqua15.jpg

这个不知道怎么做的。。。。还有用FW制作冰雪字。。。。

我行我酷--闪酷网络
http://www.3cool.net/
http://www.zonel.net/
落伍会员超级相册
2003-7-3 01:21
活靶子
落伍者

积分 7328
发贴 7552
注册 2001-12-16
来自 AspXboy.Com
最后一副图片怎么做？？？？？？

家穷人丑，一米四九，小学文化，农村户口，薄田一亩，破屋三间，冷锅冷灶，老婆没有，一年四季，药不离口，今日上网，广征女友，革命道路,并肩携手！
● ○
/█∨█\
∏ ∏
签名位广告招租啦，月10元，我将写上购买某商品强烈推荐YouID字样！ 井里有群青蛙，还有一块大石头，一只站在石头上的青蛙对其他青蛙说：“我看到的天比你们看到的大！你们是井底之蛙！！”
2003-7-3 01:41
longfeng
落伍者

积分 962
发贴 1016
注册 2002-11-22
来自 CLASS9飞翔论坛
漂亮！

I‘m Roget. 严重感谢小风子送我S35和zitiger送我1626.NET

Quote:
飞翔论坛
封刀一年，为了美好的将来～～

不再郁闷！我奋力追，追到无法追！准备禁网
2003.7.19
2003-7-6 13:02
轻扬飞舞
落伍者

积分 123
发贴 125
注册 2003-3-19
科比真厉害呀！！

不错。
2003-7-6 13:23
rical
落伍者

积分 4496
发贴 4589
注册 2002-7-8
来自 广东
摆脱！转贴地话说明一下好不好？不要让人对你有误会。

学问要多动手,多提问;少灌水,少装B.程序网上多的是,知识在你脑里又有多少了??不要浪费了你老妈给你的一个脑和两只手.
2003-7-6 13:34
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20
一样的我看过..

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-7-6 13:36
xboycn
落伍者

积分 4635
发贴 4627
注册 2002-7-5
来自 cn→zj

Quote:
Originally posted by rical at 2003-7-6 01:34 PM:
摆脱！转贴地话说明一下好不好？不要让人对你有误会。

OK，我转贴的，你是不是对我有MM夸奖挺不爽啊？？呵呵

感谢落伍的朋友：丁丁|Delin|Arvan|imsaul|jarod…
云网数字卡直销商,出售各种数字卡

ＮＢＡ中国
2003-7-6 13:42
<< [1] [2] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.048662 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 第一 次写的LOGO教材~呵呵~大家砸砸 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 第一 次写的LOGO教材~呵呵~大家砸砸

<< [1] [2] >>
作者:
标题: 第一 次写的LOGO教材~呵呵~大家砸砸 上一主题 | 下一主题
没有人
落伍者

积分 2063
发贴 1964
注册 2002-4-23
来自 福建.莆田
第一 次写的LOGO教材~呵呵~大家砸砸

==========FW齿轮LOGO教材==============

写的乱七八糟的

先请大家看一下最终效果吧~~呵呵！

演示

转换成图形以后用修改----------动画----------选择动画工具

创建一个360度的滚动动画！参数如下~~呵呵

可以试着将第三层中的齿轮变形弄小一点，

然后按照逆时针360度旋转，这样一个简单的齿轮LOGO就完成了~呵呵~

如果还有什么不明白的地方可以下载偶PNG

参考一下~~

这个是我的原来文件
点击下载

Quote:
看什么看，没见过纯情的GG啊！

2003-6-20 22:01
wowo
落伍者

积分 4155
发贴 4155
注册 2002-4-18
嘿嘿~ 不错
上QQ，我找有点事

那天在火车站一位老大爷向我乞讨，我说对不起，wowo家也没有余粮啊，他说：我靠，I 服了 YOU！！！
2003-6-20 22:02
没有人
落伍者

积分 2063
发贴 1964
注册 2002-4-23
来自 福建.莆田

Quote:
Originally posted by wowo at 2003-6-20 22:02:
嘿嘿~ 不错
上QQ，我找有点事

好的~~哈哈

Quote:
看什么看，没见过纯情的GG啊！

2003-6-20 22:02
陆逊
落伍者

积分 2233
发贴 2222
注册 2002-8-8
来自 新西兰+汕头
看了，谢谢。
2003-6-20 22:05
没有人
落伍者

积分 2063
发贴 1964
注册 2002-4-23
来自 福建.莆田

Quote:
Originally posted by 陆逊 at 2003-6-20 22:05:
看了，谢谢。

大家看了要说话的啊~~否则我不是白写了啊~~~5555555555555

记得如果会做了把 作品拿来看看啊~~

Quote:
看什么看，没见过纯情的GG啊！

2003-6-20 22:14
SOFZ
落伍者

积分 757
发贴 787
注册 2002-5-29
我在看!
谢谢
2003-6-20 22:17
随心所欲
我会尽力帮你

积分 5914
发贴 6130
注册 2002-6-30
加精华，记得图片地址别改哦

暑假优惠供应ASP+ACCESS+FSO+CGI虚拟主机，QQ:626318
2003-6-20 22:18
toking
落伍者

积分 1740
发贴 1693
注册 2002-7-25
来自 我妈肚子
有点乱~

珍惜眼前
2003-6-20 22:19
会飞的蛋壳
落伍者

积分 5416
发贴 5196
注册 2002-6-26
来自 www.mxav.com
怎么不用屏幕录像多简单

梦想影视 www.mxav.com
梦想软件 down.mxav.com

2003-6-20 22:28
allenzyk
落伍者

积分 781
发贴 838
注册 2002-1-14
来自 CNMAYA.ORG
不错，

http://expert.csdn.net/expert/forum.asp
2003-6-20 22:32
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20
做得很仔细。赫赫

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-6-26 14:30
crocodile
落伍者

积分 3068
发贴 3173
注册 2002-4-29
不错啊， 很仔细， 赞

http://www.truez.com/bbs/228zw?styleid=23
睡眠是甜蜜的
成为顽石更是幸福，
只要世界上还有罪恶与耻辱，
不见不闻、无知无觉，是最大的快乐，
——不要惊醒我吧
2003-6-26 14:48
赵明亮
落伍者

积分 3603
发贴 3782
注册 2002-11-21
来自 湖州人在杭州5v6.com
FW哪里有下？

最近更新电影列表
老婆被泡，情人被撬，赃款被盗，伟哥失效都碰上的人。。。。
2003-6-26 14:48
v8088
落伍者

积分 3334
发贴 3353
注册 2002-10-1
不错不错呀,得学习学习咯!
2003-6-26 14:49
五线舞
落伍者

积分 1349
发贴 1318
注册 2002-1-13
来自 A Better Zone
挖，到处都是呀，我在ITMAYA看到你发了。

真正的共产主义→黄金论坛
网络收费账号免费提供
2003-6-26 15:00
<< [1] [2] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.030993 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 第一次写教程~~

落伍者论坛 » 网站建设专栏 » 第一次写教程~~<<象素按钮>>~请大家支持!!

<< [1] [2] >>
作者:
标题: 第一次写教程~~<<象素按钮>>~请大家支持!! 上一主题 | 下一主题
TV狼乖乖
落伍者

积分 7419
发贴 7478
注册 2001-9-17
来自 OGame.NeT
第一次写教程~~<<象素按钮>>~请大家支持!!

很简单的东西,别笑话!!

PhotoShop 7.01中文版

添加图层样式,设置如下:

[ Last edited by TV狼乖乖 on 2003-6-10 at 03:48 PM ]

我的BLOG:http://www.cgmax.com/
新种的玉米:Luxixi.com鲁西西...怀念童年ing...
我闭上眼睛就感觉到，此刻她心中也很寂寞···
2003-6-10 15:38
狱火华衣
落伍者

积分 1802
发贴 1657
注册 2002-8-16
来自 领域者
又是PhotoShop -_-!!!

要我八要？爱要就要！
Tom的新闻有兴趣看么？
2003-6-10 15:39
鲜每の℃
落伍者

积分 3290
发贴 3326
注册 2002-8-20
来自 华南理工大学
不错。，

中国破解组织联盟CCG
China Cracking Group
看雪学院：http://www.pediy.com/
强烈建议各位朋友去我的论坛。
2003-6-10 15:40
TV狼乖乖
落伍者

积分 7419
发贴 7478
注册 2001-9-17
来自 OGame.NeT

Quote:
Originally posted by 狱火华衣 at 2003-6-10 03:39 PM:
又是PhotoShop -_-!!!

没玩过FW...-__-b

我的BLOG:http://www.cgmax.com/
新种的玉米:Luxixi.com鲁西西...怀念童年ing...
我闭上眼睛就感觉到，此刻她心中也很寂寞···
2003-6-10 15:40
网迷
落伍者

积分 4263
发贴 4348
注册 2002-6-30
挺好的。我支持

全力打造中國最大的破解軟件站
2003-6-10 15:41
会飞的蛋壳
落伍者

积分 5416
发贴 5196
注册 2002-6-26
来自 www.mxav.com
试试

梦想影视 www.mxav.com
梦想软件 down.mxav.com

2003-6-10 15:41
随心所欲
我会尽力帮你

积分 5914
发贴 6130
注册 2002-6-30
全是大叉叉

暑假优惠供应ASP+ACCESS+FSO+CGI虚拟主机，QQ:626318
2003-6-10 15:44
TV狼乖乖
落伍者

积分 7419
发贴 7478
注册 2001-9-17
来自 OGame.NeT

Quote:
Originally posted by 网迷 at 2003-6-10 03:41 PM:
挺好的。我支持

感谢~

我的BLOG:http://www.cgmax.com/
新种的玉米:Luxixi.com鲁西西...怀念童年ing...
我闭上眼睛就感觉到，此刻她心中也很寂寞···
2003-6-10 15:45
龙柳儿
落伍者

积分 886
发贴 912
注册 2003-2-14
PhotoShop好...不会用FW....~_~

万分感谢sdyclyq帮偶做的FLASH...^^
2003-6-10 15:45
TV狼乖乖
落伍者

积分 7419
发贴 7478
注册 2001-9-17
来自 OGame.NeT

Quote:
Originally posted by 随心所欲 at 2003-6-10 03:44 PM:
全是大叉叉

不是吧...

我的BLOG:http://www.cgmax.com/
新种的玉米:Luxixi.com鲁西西...怀念童年ing...
我闭上眼睛就感觉到，此刻她心中也很寂寞···
2003-6-10 15:45
天灰灰
落伍者

积分 8181
发贴 7719
注册 2002-10-16
来自 囡天小屋
我支持！

不错！

骨灰地带
2003-6-10 15:46
TV狼乖乖
落伍者

积分 7419
发贴 7478
注册 2001-9-17
来自 OGame.NeT

Quote:
Originally posted by 随心所欲 at 2003-6-10 03:44 PM:
全是大叉叉

我换到WWWFOX的空间了,应该没问题吧~~~

原来是长宽的~

我的BLOG:http://www.cgmax.com/
新种的玉米:Luxixi.com鲁西西...怀念童年ing...
我闭上眼睛就感觉到，此刻她心中也很寂寞···
2003-6-10 15:48
随心所欲
我会尽力帮你

积分 5914
发贴 6130
注册 2002-6-30
现在好了，不错，加精

暑假优惠供应ASP+ACCESS+FSO+CGI虚拟主机，QQ:626318
2003-6-10 16:02
网迷
落伍者

积分 4263
发贴 4348
注册 2002-6-30

Quote:
Originally posted by TV狼乖乖 at 2003-6-10 03:45 PM:

感谢~

你能不能做一个有立体感的图片

内容大约是这样的。

这几天我在研究不过我做的图片现在放在家里面上不了网我传不到网上给你看

你试着做一下

内容就是一张材料纸

上面你用写上一些内容

看上去就好像是用手工写的然后用扫描仪扫描的
或者是数码相机拍摄的效果

这样的效果能做出来吗。你？

全力打造中國最大的破解軟件站
2003-6-10 16:04
jarod
落伍者

积分 10801
发贴 11101
注册 2002-4-17
支持小狼

GAMER游戏网 我的破游戏网站,喜欢游戏和想下载游戏的过来看看。恒久空间演示。
笨GOGO 关于英语和留学生的论坛。
2003-6-10 16:07
<< [1] [2] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.031284 second(s), 5 queries, Gzip enabled


无标题文档

操作系统

1. windows server 2003优化设置方法 -- 伏地魔
2. 《Windows 2000 安全设置检查清单》--木耳
3. 系统进程全攻略！！！！|经典| -- 龙慧
4. 安全配置Windows2000服务器 [转帖] -- nbinfo
5. Windows NT/2000 服务器安全设置与效率优化 -- Is.
6. [原创]装系统N次后总结的部分优化经验 -- 苍生一笑
7. Windows server 2003设置使用必备技巧(集) -- 街舞


落伍者论坛 - 网站建设专栏 - Windows server 2003设置使用必备技巧(集) - powered by Discuz!

落伍者论坛 » 网站建设专栏 » Windows server 2003设置使用必备技巧(集)

作者:
标题: Windows server 2003设置使用必备技巧(集) 上一主题 | 下一主题
街舞
淡淡微笑无奈的我

积分 3123
发贴 3017
注册 2001-9-14
来自 YouID.COM
Windows server 2003设置使用必备技巧(集)

Windows server 2003设置使用必备技巧(集)

Windows2003不是为家庭多媒体设计的，它是为大型商业服务的，所以
他自动关闭了许多我们在Windows98、XP上常见的功能，又增加了一些
我们在Windows98、XP上不常见的功能，以此来提升系统效率和增加系统
安全措施。但我们可以让它按照我们自己的意愿运行。下面是我在网上
搜集的一些调试办法，以及我摸索到的一点规律。仅供参考。
美猴王jcc56.163.com

比如，我曾经在调试禁用开机 CTRL+ALT+DEL模式时不小心禁用了管理员
帐户状态，于是进不去系统。经测试，可以先按F8进入安全模式调整：
开始 -->管理工具 --> 本地安全策略 --> 本地策略 --> 安全选项 -->
帐户: 管理员帐户状态-->启用之。慎用！搞不好会进不去系统。

修改被禁止的显卡硬件加速方法： 桌面点右键-->属性-->设置-->高级
-->疑难解答,把滚动条拉到最右 ,然后打开windows\system32\
dxdiag.exe--Display 可以看到DirectDraw Acceleration ,Direct3D
Acceleration,AGP Texture Acceleration,都是禁止的，依次打开它!

修改被禁止的声卡硬件加速方法：打开windows\system32\dxdiag.exe--Display
可以看到DirectDraw Acceleration ,Direct3D Acceleration,AGP
Texture Acceleration,都是禁止的，依次打开它!

启动被关闭了的一些功能：包括显卡，声卡，桌面等等，
开始-->管理工具-->服务 打开。

services-themes -windows audio 是叫你将themes 调整一下：方法：
Q:在 Windows.NET上使用 Theme的办法 A:--->>
1.开始-->管理工具-->服务
2.Themes service 设置为自动 (Automatic)
3.打开 Log on 服务 (enabled)
4.在 General 中, 选择 Start
5.之后就可以在显示属性中设置了

启用声卡：
开始-->控制面板 --> 声音 --> 启用windows音频，并可同时设置它在任务栏显示。

启用 ASP 支持：（先安装 IIS 6）：
控制面板 --> 管理工具 --> Web服务扩展 --> Active Server Pages --> 允许

启用 XP 的主题：运行-->Services.msc回车，找到并双击Themes这个服务，
设置启动类型-->自动，点击Apply后点Start打开。

禁止关机时出现的关机理由选择项：
开始 --> 运行 -->gpedit.msc--> 计算机配置 --> 管理模板 --> 系统 -->
显示关机事件跟踪 --> 禁用。

启用摄像机，摄像头或者扫描仪等设备：
开始 --> 运行 -->Services.msc回车，找到并双击Windows Image Acquisition (WIA) 服务，
设置启动类型为-->自动点击-->应用-->启动-->确定。

在控制面板里显示全部组件：
把 Windows\inf 目录中的 sysoc.inf 文件里的 "hide" 替换掉。

禁用开机 CTRL+ALT+DEL模式：
开始 -->管理工具 --> 本地安全策略 --> 本地策略 --> 安全选项 -->
交互式登录: 不需要按 CTRL+ALT+DEL-->启用。

查有无被激活：开始 -->运行-->oobe/msoobe /a-->回车，稍等一会儿，
就会看到提示。如果没有激活,说明你安装的是未破解的系统，抓紧想想办法吧!
如用Reset5.02激活补丁进入安全模式激活等。

改变开始菜单式样：在"开始"上点右键,打开属性,选择"经典开始菜单"
点"确定",熟悉的开始菜单又回来了!

系统不能自动添加USB硬盘盘符：

控制面板-->系统-->硬件-->设备管理器-->设备管理器-->磁盘驱动器-->用鼠标
指向USB盘-->双击选属性,改“为快速删除而优化”为“为提高性能而优化”-->确定。
再到：开始-->管理工具--计算机管理--磁盘管理--USB-->右键--设定分配驱动器号。

年轻人应该多多学习，努力工作

+[EBD中文论坛]+ +[河北LINXU协会]+ +[YouID.COM]+

2003-6-7 18:24
随心所欲
我会尽力帮你

积分 5914
发贴 6130
注册 2002-6-30
加精，并且收藏！

暑假优惠供应ASP+ACCESS+FSO+CGI虚拟主机，QQ:626318
2003-6-7 18:26
街舞
淡淡微笑无奈的我

积分 3123
发贴 3017
注册 2001-9-14
来自 YouID.COM
但我的问题还是没有找到

年轻人应该多多学习，努力工作

+[EBD中文论坛]+ +[河北LINXU协会]+ +[YouID.COM]+

2003-6-7 18:29
随心所欲
我会尽力帮你

积分 5914
发贴 6130
注册 2002-6-30
慢慢来，目前用2003的应该不是很多了

暑假优惠供应ASP+ACCESS+FSO+CGI虚拟主机，QQ:626318
2003-6-7 18:32
街舞
淡淡微笑无奈的我

积分 3123
发贴 3017
注册 2001-9-14
来自 YouID.COM
ＩＩＳ　６．０　无法安装ＺＥＮＤ

请查看

check this configure file on C:\Windos\php.ini
; cgi.force_redirect is necessary to provide security running PHP as a CGI under
; most web servers. Left undefined, PHP turns this on by default. You can
; turn it off here AT YOUR OWN RISK
; **You CAN safely turn this off for IIS, in fact, you MUST.**
; cgi.force_redirect = 1

年轻人应该多多学习，努力工作

+[EBD中文论坛]+ +[河北LINXU协会]+ +[YouID.COM]+

2003-6-7 18:33
街舞
淡淡微笑无奈的我

积分 3123
发贴 3017
注册 2001-9-14
来自 YouID.COM
变Windows Server 2003 为工作站

翻译文章，点击查看原文

虽然Windows Server 2003是用于服务器的操作系统，不过同样有很多人为了调试程序，开发软件或者学习而需要安装Windows Server 2003，并把该系统作为工作站使用，本文就是为这些人准备的，经过调整，Windows Server 2003才更象个工作站操作系统。

水平有限，翻译的可能不够准确，如有歧异请以原文为准。翻译过程中有些内容是修改过的，请留意。

在安装之前

我想你应该明白怎样安装Windows Server 2003，基本上跟安装Windows XP是一样的。在你安装到设置授权模式的时候按照默认设置就可以。现在我们开始吧！

安装好之后

你首先要做的事情就是禁用Manager Your Server对话框，你一定不希望它每次在你启动系统后来烦你吧。只要点击选中“Don't display this page at logon”复选框就可以了。以后你也可以通过 Control Panel -> Administrative Tools -> Manage Your Server 访问到。图

创建一个新帐户

在Windows Server 2003中是没有欢迎屏幕的，所以第一次启动的时候你不会被要求设置一个新的帐户。但是也不用担心，新建帐户是很容易的，就像这篇文章中的作法一样。

依次点击Start -> Run，然后输入lusrmgr.msc并按回车。会出现Local Users and Groups窗口，之后在左侧面板的Users上点击鼠标右键，并选择New User，并按照图中的示例填写相关的信息（Full Name和Description是可选的），然后选中相关的复选框，并点击Create。

你新建的帐号已经可以使用了，但是在我们用它登录之前，你可能想给你的帐户“Administrator”权限。如果想这样做，在新建的帐户名称上点击鼠标右键，并点击Properties，打开Member of选项卡，点击Add...-> Advanced -> Find Now，然后双击列表顶端的Administrators。点击OK关闭窗口。图

现在你可以注销Administrator然后用新建的帐户登录了。

禁用IE的增强行安全设置

不能浏览网页？那么这一段就是为你写的。

Windows Server 2003的一个新的安全特性就是默认情况下设置了IE的安全性为高，因此你讲不能浏览任何站点（除非你把该站点添加到安全站点中－－译者注）。想修复这个问题吗？继续读下去。

运行IE，你可以看见IE提示说Explorer Enhanced Security设置已经被启用，并且还显示了一个对话框，选中对话框中的“In the future, do not show this message”。图

现在，依次打开Tools -> Internet Options，打开Security选项卡，在“Security Level for this zone”中把Internet区域的安全性调整到Medium。之后你会看到一个对话框询问是否真的要修改安全等级，点击Yes。图

通常工作站中设置为Medium就可以了，因此这个也是适合大部分人的。

安装Sun的JAVA虚拟机

Windows Server 2003中没有包含微软的JAVA虚拟机，而微软也不再提供JAVA虚拟机的下载，虽然还有很多地方可以下载到微软的JAVA虚拟机，不过我还是不建议安装，因为：

1，微软的JAVA虚拟机已经停止升级了，如果以后发现了什么新的安全漏洞也不会有任何的补丁程序
2，很多下载网站提供了不同大小的JAVA虚拟机，你怎么知道哪个才是最好的？

如果你仍然想用微软的JAVA虚拟机，点击这里，下载并安装它，然后继续阅读下一段文章。

决定用Sun的JAVA虚拟机了？
点击这里下载一个

安装过程是很简单的，并且也不需要重启动。

禁用关机原因调查（Shutdown Event Tracker）

因为Windows Server 2003是一个“服务器”，因此知道它为什么要关闭和重启动是很重要的。而既然我们把它当作工作站使用，我们就可以禁用这一特性。同样，这是很简单的。

我们需要配置Group Policy Object Editor，在运行中输入gpedit.msc然后按回车，你应该可以看见图中的组策略编辑器。依次打开Computer Configuration -> Administrative Templates -> System，然后在右侧的面板中双击Display Shutdown Event Tracker这一策略。

接着会出现图中的窗口，选择Disable然后点击OK。现在关闭 Group Policy Object Editor窗口。以后你关机的时候就可以看到传统的窗口。

图形加速

为了保证最佳可用性和最高性能，默认情况下Windows Server 2003中的硬件图形加速和DirectX是被禁用的。如果你需要用到DirectX加速的程序你也可以按照这一段的文章打开它们。

启用硬件图形加速

现在我们准备启用你的硬件图形加速。在桌面的空白处点击鼠标右键，依次点击Properties -> Settings 选项卡 -> Advanced ->Troubleshoot 选项卡，然后把硬件图形加速的滑块拖动到Full。点击OK退出。图

之后屏幕可能会变黑几秒钟。

启用DirectX

接着准备启用DirectX图形加速。在运行中输入dxdiag然后按回车，你会看到一个对话框询问你是否允许dxdiag访问Internet以检查有效的WHQL证书，点击Yes。

打开Display选项卡，然后点击其中的三个按钮启用DirectDraw，Direct3D和 AGP Texture Acceleration。图

音频加速

现在我们已经启用了图形加速和DirectX加速，同样我们还要启用音频加速。

如果你用的是Windows Server 2003 Standard Edition，Windows Audio服务默认已经打开了，你可以跳过这一步。其他版本的用户可以继续看下去。

在运行中输入Services.msc然后按回车，会出现Services 窗口，找到Windows Audio服务，双击打开，把启动类型设置为Automatic，点击Apply，然后点击Start启动该服务。图

最后我们还要使用DirectX诊断工具，在运行中输入dxdiag并回车，打开Sound选项卡，把Hardware Sound Acceleration Level的滑块拖动到Full。图

好了，现在音频也已经全部设置好了。

还有一点需要注意，如果你跟我一样有一个SB Live！声卡，你应该安装2003年3月10日发布的For Win2k/XP的LiveDrvUni-Pack。

UxTheme

主题在哪里？我听见你说了，在本段中我们将设置在Windows Server 2003中使用主题。

首先我们需要回到服务设置对话框启用Themes服务，在运行中输入Services.msc并按回车，找到并双击Themes这个服务，设置启动类型为Automatic，点击Apply后点Start打开这个服务。

现在你已经可以使用Windows XP中的Luna Blue，Silver和Olive Green三种主题。

如果你还想使用更多的主题，首先需要破解你的UXTheme.dll文件。

手动安装

感谢 Vortex.Winbeta.org提供了破解过的UXTheme.dll，因为里面没有附带任何说明文件，因此我制作了一个批处理文件，并连同一个Readme文件一起打包供你下载。不过如果你想自己安装，那么就下载这个文件：

UXThemePatch.zip

（基于某些原因你可能想恢复原始的UXTheme.dll，你可以点击这里下载）

把下载到的Zip文件解压缩并按照下面的说明来做：

阅读ReadMe
复制UXTheme.dll 到 C:\WINDOWS\System32\dllcache
复制uxthemepatch.bat 到你的C盘根目录
重启动系统到Safe Mode Command Prompt (重启动时按F8)
进入命令行模式后，输入cd\ 然后按回车，输入uxthemepatch然后按回车。
这就对了！记得把 C:\WINDOWS 替换成你自己安装Windows Server 2003的实际目录

自动安装

感谢xBetas，为我们提供了自动修改UXTheme.dll的补丁程序。点击下载：

xBetas' PatchXP

根据该补丁的说明，只要点击 Patch按钮，忽略所有警告信息然后点击Reboot!如果一切无误，现在你就可以在Windows Server 2003上使用所有的三方主题了。

启用其他服务

这一段我们将进行如下修改：

启用操作系统内建的IMAPI CD刻录服务
启用Windows Image Acquisition (为使用 摄像头，扫描仪等设备)
如果你不想起用这些服务，就可以跳过这段直接阅读后面的内容了。

如果你想使用操作系统内建的IMAPI CD刻录服务，需要进行如下的操作： (但如果你想加快Nero Burring ROM的启动速度就不要起用这个服务)

在运行中输入Services.msc然后回车，找到并双击IMAPI CD-Burning COM Service服务，设置启动类型为Automatic，点击Apply后点击Start然后点击OK。

重启动系统后就可以在Send-To菜单中看到刻录CD的选项。

如果你有摄像机，摄像头或者扫描仪等设备，进行如下操作：

在运行中输入Services.msc并回车，找到并双击Windows Image Acquisition (WIA) 服务，设置启动类型为Automatic点击Apply后点击Start然后点击OK。

之后就可以给你的摄像机和扫描仪安装驱动程序了。

高级设置

在这一段中我们将深入Windows Server 2003的核心，调整内存和CPU的使用情况。我们将为工作站的使用做进一步的优化。

我们要在 Performance Options中改变内存和CPU的相关设置，这样做：

依次打开Control Panel -> System -> Advanced -> Performance Settings -> Advanced选项卡，把Processor scheduling设置为Programs and lastly，并把Memory usage设置到Programs上，点击OK。图

你还可以禁用错误报告，点击Error Reporting，然后选择Disable Error Reporting，并选中But notify me when critical errors occur。

自动登录

令人欣慰的是Windows XP的TweakUI在Windows Server 2003中工作的很好。虽然TweakUI 的安装程序不能在Windows Server 2003下正确运行，不过我可以提供给你Windows XP中的tweakui.exe。现在我们就能用TweakUI禁用“CTRL-ATL-DEL登录”对话框了，并且还能设置自动登陆。

首先要下载TweakUI

TweakUI.zip

把压缩文件解压到任何一个地方，然后双击运行TweakUI.exe

在左侧的面板中依次打开 Logon -> Autologon，选中 Log on automatically at system startup对话框，输入用户名，并保持Domain设置为默认。

点击Set Password 然后输入密码，点击OK。图

安装DirectX 9.0a

在Windows Server 2003中安装DirectX 9.0a就跟以往在其他Windows中安装任何版本的DirectX一样，如果你还没有启用图形加速和DirectX加速，请在安装前先启用它们。

首先你要下载DirectX 9.0a

DirectX 9.0a 网络安装文件

运行该文件就可以开始安装，在这过程中将会下载大概6.9 MB文件。

安装结束后需要重启动系统。

其他事项

文件夹选项

默认情况下，所有的隐藏文件和文件夹都是显示的，你可以隐藏它们，这样资源管理器中就不会显示太多的隐藏文件。

打开任何一个文件夹，然后在Tools -> Folder Options -> View 选项卡下选中Do not show hidden files and folders，然后点击OK。

Windows Media Player 9

Windows Media Player 9默认已经安装好了。依次打开Start -> Programs -> Accessories -> Entertainment -> Windows Media Player。按照提示选择所有需要的复选框，然后就可以使用了。

你也可以这样把Media Player 9放置到任务栏：在任务栏上点击鼠标右键 ，然后在 Toolbars 菜单下选中Windows Media Player.

怎样在Windows Server 2003上安装Plus！ For Windows XP：

请参考 http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q311410

可用的杀毒软件

Symantec Norton Antivirus Corporate 8.x (请注意，家用版的2002/2003 不能在 Windows Server 2003上安装)

可用的防火墙

Zone Alarm 3.7.159
Norton Personal Firewall 2003

年轻人应该多多学习，努力工作

+[EBD中文论坛]+ +[河北LINXU协会]+ +[YouID.COM]+

2003-6-7 18:35

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.037098 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - [原创]装系统N次后总结的部分优化经验 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » [原创]装系统N次后总结的部分优化经验

作者:
标题: [原创]装系统N次后总结的部分优化经验 上一主题 | 下一主题
苍生一笑
落伍者

积分 6866
发贴 6898
注册 2002-4-10
来自 黑鹰坠落的地方
[原创]装系统N次后总结的部分优化经验

我对98SE系统不熟,大概只用过10天,所以大部分经验都是2000和XP下的,不保证98SE下能用.现在我的系统是比较普遍的XP pro,已经打上了所有的补丁.机器配置是:PIII 1G+256M pc100+40G sega+815E主板,希望我的经验对你有些帮助:)
首先是分区,个人认为C盘是安装操作系统最好的一个分区.因为硬盘其工作原理的关系,C盘的线速度是最大的,这样便使C盘的数据传送量最大,可以得到最快的速度.同理,我们可以把备份,电影之类的放到尽可能后面的分区,因为这些文件运行时对速度要求不高.当然,处于安全性考虑的话,可以把系统装在D盘,不过我想这个对于家用机没什么必要.文件系统应该选择FAT32,经过本人实际测试,NTFS并没能加速多少,而且会引起很多莫名奇妙的错误(重装系统文件夹被锁,不能装部分杀毒软件,在dos下无法识别...)

然后就是安装系统啦,这里就不写了.

OK,完成安装后,我们可以去 驱动之家 [http://www.mydrivers.com/] 下载最新的驱动安装,虽然XP能给现在大部分硬件装上驱动,但是那只是简化版本其作用让你能用这个设备,根本不能挖掘硬件的性能.这里要说一下安装驱动的顺序,建议先安装主板驱动,再安装其他的驱动.部分设备如果最后安装主板驱动会使产生不兼容现象,改变顺序后不兼容却现象排除了.还有人们往往会忽略磁盘驱动,其实磁盘驱动不仅可以帮你打开UDMA模式,而且从1999年开始,硬盘厂商开始使用统一的AMM(Acoustic Management Mode)技术来降低硬盘的噪音.不过这个AMM模式在出厂时均被设置成关闭状态,需要手工激活,所以我在下面提供部分硬盘管理程序:

1.IBM IBM硬盘Feature Tool工具最新1.60版For Win9x/NT4/2000/DOS
虽说是给IBM硬盘提供的驱动,但是AMM已经是统一的标准了,所以只要其他牌子的硬盘支持AMM就完全可以用.这个程序功能十分强大,不过只能运行于dos模式下.

2.Maxtor Maxtor迈拓硬盘Acoustic Management设置工具最新4.0版For Dos
必须是DiamondMax Plus 40、DiamondMax 60、DiamondMax VL 30、DiamondMax Plus 40、D540XD740X这几个系列的Maxtor用户才能使用.

3.Intel Intel英特尔810、810E、810E2、815、815E、820、840、845、850、860芯片组主板最新Intel Application Accelerator应用程序加速器2.3官方正式多语言版For Win9x/ME/NT4/2000/XP
这个是我现在在用的驱动,感觉打开了它的最小声音输出后的确安静不少~~~~

到了这里我们基本上把系统装好了,但是这还是不够的,我们还要继续优化.well,follow me!

开始->运行...->输入 drwtsn32
把除了"转储全部线程上下文"之外的全部去掉,否则一旦程序出错硬盘会响应很久,并且使用很多空间.如果你以前已经遇到过这种情况了,那么请在系统分区下查找user.dmp文件,然后删掉,另外在蓝屏时出现的memory.dmp也删掉,这样可以搞出几十M的空间.

右击 我的电脑 选择 属性->高级->启动和故障恢复 设置
除了自动重启 其他都取消,写入调试信息项 选择 (无)

在Windows中有些程序是自带的而且没有卸载的选项,要修改部分文件财可以卸载.在 工具->文件夹选项->查看 中把 隐藏受保护的操作系统文件 和 显示所有文件和文件夹 打开再找到这个文件 C:\WINDOWS\inf\sysoc.inf [2000下可能是 C:\WINNT\inf\sysoc.inf ]打开它,然后 编辑->替换 查找内容 为"hide"[不包括引号] 替换为 对话框保持空白,然后全部替换

再去打开 控制面板->添加或删除程序->添加/删除windows组件 看看,是不是看见很多原来没有的:)

接下来的优化工作可以全部交给 windows优化大师 了,建议不要使用注册版,用那些未注册的功能就够了,优化注册表之类的事情交给软件做简直就是自灭啊~~~
还有2000默认是打开硬盘共享的,在 windows优化大师 下很容易解决,在 禁止用户向 windows2000 建立空链接 / 禁止系统自动启动服务器共享 / 禁止系统自动启动管理共享 前打勾即可

就这样吧,我要去看电影了,想到什么以后补上.写这个花了我一个半小时啊,5555555555555555

Quote:
到我这里注玉米,免费赠送所注玉米的 Logo(88×31) 一个。联系QQ:42186431
在水边缘那里做主持咯，希望大家能多多捧场
强烈鄙视那些签名鬼大的人！！！

2003-6-10 09:55
Jay
落伍者

积分 4620
发贴 4619
注册 2002-9-28
来自 原產臺北 出口巴西 轉銷大陸
都是大紅X

Quote:

MC FORUM 2003(V2.0製作中。。。)

2003-6-10 09:55
Is.
禁止访问

积分 17342
发贴 17000
注册 2002-1-23
好多XX 怎么精华？赔精神损失费

Quote:
国际玉米 70元/年 国内玉米 200元/年 各类虚拟主机特价出售
至强型论坛空间 ASP+ACCESS 可选SQL 演示：http://bbs.jetdown.com/ 业务联系QQ：365285

2003-6-10 09:56
苍生一笑
落伍者

积分 6866
发贴 6898
注册 2002-4-10
来自 黑鹰坠落的地方

Quote:
Originally posted by Jetdown.com at 2003-6-10 09:56 AM:
好多XX 怎么精华？赔精神损失费

晕,正在改

Quote:
到我这里注玉米,免费赠送所注玉米的 Logo(88×31) 一个。联系QQ:42186431
在水边缘那里做主持咯，希望大家能多多捧场
强烈鄙视那些签名鬼大的人！！！

2003-6-10 09:56
kka
落伍者

积分 854
发贴 852
注册 2001-11-5
tupian where？

偷懒也是一种美德!
沉默着……泪终于渗出了眼眶。只有半滴，轻轻地滑过你美丽的脸颊；另外半滴，却深深地嵌在了我的心里。

2003-6-10 09:57
小林
o○万帖俱乐部老八^_^ ○ o

积分 11270
发贴 11199
注册 2002-10-29
来自 『新都人.COM』

Quote:
Originally posted by Jetdown.com at 2003-6-10 09:56:
好多XX 怎么精华？赔精神损失费

万维主机-Sunking

『统一行动，开始删贴！』
2003-6-10 09:58
苍生一笑
落伍者

积分 6866
发贴 6898
注册 2002-4-10
来自 黑鹰坠落的地方
图片好了~~~~该死的xrea啊,扩展名大小写都算不同的文件

Quote:
到我这里注玉米,免费赠送所注玉米的 Logo(88×31) 一个。联系QQ:42186431
在水边缘那里做主持咯，希望大家能多多捧场
强烈鄙视那些签名鬼大的人！！！

2003-6-10 09:59
SOFZ
落伍者

积分 757
发贴 787
注册 2002-5-29
精华
2003-6-10 10:00
苍生一笑
落伍者

积分 6866
发贴 6898
注册 2002-4-10
来自 黑鹰坠落的地方
好了,好了,都好了

Quote:
到我这里注玉米,免费赠送所注玉米的 Logo(88×31) 一个。联系QQ:42186431
在水边缘那里做主持咯，希望大家能多多捧场
强烈鄙视那些签名鬼大的人！！！

2003-6-10 10:01
Jay
落伍者

积分 4620
发贴 4619
注册 2002-9-28
来自 原產臺北 出口巴西 轉銷大陸
精華

Quote:

MC FORUM 2003(V2.0製作中。。。)

2003-6-10 10:03
Is.
禁止访问

积分 17342
发贴 17000
注册 2002-1-23

Quote:
Originally posted by 苍生一笑 at 2003-6-10 09:59 AM:
图片好了~~~~该死的xrea啊,扩展名大小写都算不同的文件

linux的系统就是这样的！

Quote:
国际玉米 70元/年 国内玉米 200元/年 各类虚拟主机特价出售
至强型论坛空间 ASP+ACCESS 可选SQL 演示：http://bbs.jetdown.com/ 业务联系QQ：365285

2003-6-10 10:03
苍生一笑
落伍者

积分 6866
发贴 6898
注册 2002-4-10
来自 黑鹰坠落的地方
555555555555555555

混了这么久,终于有个精华了,感动

Quote:
到我这里注玉米,免费赠送所注玉米的 Logo(88×31) 一个。联系QQ:42186431
在水边缘那里做主持咯，希望大家能多多捧场
强烈鄙视那些签名鬼大的人！！！

2003-6-10 10:09
输狂了
落伍者

积分 3850
发贴 3440
注册 2002-5-16

Quote:
Originally posted by 苍生一笑 at 2003-6-10 10:01 AM:
好了,好了,都好了

还没有好.

我的笑话网站
http://www.alexa.com/data/details?url=www.sixhc.com
2003-6-10 10:10
天灰灰
落伍者

积分 8187
发贴 7725
注册 2002-10-16
来自 囡天小屋

Quote:
Originally posted by 苍生一笑 at 2003/6/10 10:09 AM:
混了这么久,终于有个精华了,感动

恭喜`

骨灰地带
2003-6-10 10:11

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.029799 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 出去前给大家一个好文章 Windows NT/2000 服务器安全设置与效率优化 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 出去前给大家一个好文章 Windows NT/2000 服务器安全设置与效率优化

作者:
标题: 出去前给大家一个好文章 Windows NT/2000 服务器安全设置与效率优化 上一主题 | 下一主题
Is.
禁止访问

积分 17342
发贴 17000
注册 2002-1-23
出去前给大家一个好文章 Windows NT/2000 服务器安全设置与效率优化

现在有很多人都认为微软的东西漏洞太多，，微软的系统安全性极差，不过通过我在做各种系统的安全配置的过程中我总结出了一些经验，特拿来与各位共享，其实各种系统都有很多漏洞，只不过微软的东西用的人最多，普遍又是水平不是很高，不会作各种安全设置，所以才会让人有现在网上的NT/2000服务性安全性都很差的感觉，其实NT/2000的服务器如果真的做好了各项安全设置之后，其安全性绝对不会比nix系统差。

1.初级篇：NT/2000系统本身的定制安装与相关设置

用NT（2000）建立的WEB站点在所有的网站中占了很大一部分比例，主要因为其易用性与易管理性，使该公司不必再投入大量的金钱在服务器的管理上，这一点优于nix系统，不必请很专业的管理员，不必支付一份可以节省的高薪，呵呵，当然nix的管理员也不会失业，因为其开放源码和windows系统无与伦比的速度，使得现在几乎所有的大型服务器全部采用nix系统。但对于中小型企业来说windows已经足够，但NT的安全问题也一直比较突出，使得一些每个基于NT的网站都有一种如履薄冰的感觉，在此我给出一份安全解决方案，算是为中国的网络安全事业做出一份贡献吧 （说明：本方案主要是针对建立Web站点的NT、2000服务器安全，对于局域网内的服务器并不合适。）

一、 定制自己的NT/2000 SERVER

1． 版本的选择：
WIN2000有各种语言的版本，对于我们来说，可以选择英文版或简体中文版，我强烈建议：在语言不成为障碍的情况下，请一定使用英文版。要知道，微软的产品是以Bug &Patch而著称的，中文版的Bug远远多于英文版，而补丁一般还会迟至少半个月（也就是说一般微软公布了漏洞后你的机子还会有半个月处于无保护状况）

2． 组件的定制：
win2000在默认情况下会安装一些常用的组件，但是正是这个默认安装是极度危险的你应该确切的知道你需要哪些服务，而且仅仅安装你确实需要的服务，根据安全原则，最少的服务+最小的权限=最大的安全。典型的WEB服务器需要的最小组件选择是：只安装IIS的Com Files，IIS Snap-In，WWW Server组件。如果你确实需要安装其他组件，请慎重，特别是：Indexing Service, FrontPage 2000 Server Extensions, Internet Service Manager (HTML)这几个危险服务。

二、 正确安装NT/2000 SERVER

不论是NT还是2000，硬盘分区均为NTFS分区；
说明：
（1） NTFS比FAT分区多了安全控制功能，可以对不同的文件夹设置不同的访问权限，安全性增强。
（2） 建议最好一次性全部安装成NTFS分区，而不要先安装成FAT分区再转化为NTFS分区，这样做在安装了SP5和SP6的情况下会导致转化不成功，甚至系统崩溃。
（3） 安装NTFS分区有一个潜在的危险，就是目前大多数反病毒软件没有提供对软盘启动后NTFS分区病毒的查杀，这样一旦系统中了恶性病毒而导致系统不能正常启动，后果就比较严重，因此及建议平时做好防病毒工作。
（4）分区和逻辑盘的分配
有一些朋友为了省事，将硬盘仅仅分为一个逻辑盘，所有的软件都装在C驱上，这是很不好的，建议最少建立两个分区，一个系统分区，一个应用程序分区，这是因为，微软的IIS经常会有泄漏源码/溢出的漏洞，如果把系统和IIS放在同一个驱动器会导致系统文件的泄漏甚至入侵者远程获取ADMIN。推荐的安全配置是建立三个逻辑驱动器，第一个大于2G，用来装系统和重要的日志文件，第二个放IIS，第三个放FTP，这样无论IIS或FTP出了安全漏洞都不会直接影响到系统目录和系统文件。要知道，IIS和FTP是对外服务的，比较容易出问题。而把IIS和FTP分开主要是为了防止入侵者上传程序并从IIS中运行。
（5）安装顺序的选择：
win2000在安装中有几个顺序是一定要注意的： 首先，何时接入网络：Win2000在安装时有一个漏洞，在你输入Administrator密码后，系统就建立了ADMIN$的共享，但是并没有用你刚刚输入的密码来保护它，这种情况一直持续到你再次启动后，在此期间，任何人都可以通过ADMIN$进入你的机器；同时，只要安装一完成，各种服务就会自动运行，而这时的服务器是满身漏洞，非常容易进入的，因此，在完全安装并配置好win2000 SERVER之前，一定不要把主机接入网络。 其次，补丁的安装：补丁的安装应该在所有应用程序安装完之后，因为补丁程序往往要替换/修改某些系统文件，如果先安装补丁再安装应用程序有可能导致补丁不能起到应有的效果，例如：IIS的HotFix就要求每次更改IIS的配置都需要安装

 三、 安全配置NT/2000 SERVER
即使正确的安装了WIN2000 SERVER，系统还是有很多的漏洞，还需要进一步进行细致地配置。

1．端口：
端口是计算机和外部网络相连的逻辑接口，也是计算机的第一道屏障，端口配置正确与否直接影响到主机的安全，一般来说，仅打开你需要使用的端口会比较安全，配置的方法是在网卡属性-TCP/IP-高级-选项-TCP/IP筛选中启用TCP/IP筛选，不过对于win2000的端口过滤来说，有一个不好的特性：只能规定开哪些端口，不能规定关闭哪些端口，这样对于需要开大量端口的用户就比较痛苦。

2．IIS：
IIS是微软的组件中漏洞最多的一个，平均两三个月就要出一个漏洞，而微软的IIS默认安装又实在不敢恭维，所以IIS的配置是我们的重点，现在大家跟着我一起来：首先，把C盘那个什么Inetpub目录彻底删掉，在D盘建一个Inetpub（要是你不放心用默认目录名也可以改一个名字，但是自己要记得）在IIS管理器中将主目录指向D:\Inetpub；其次，那个IIS安装时默认的什么scripts等虚拟目录一概删除，如果你需要什么权限的目录可以自己慢慢建，需要什么权限开什么。（特别注意写权限和执行程序的权限，没有绝对的必要千万不要给）第三，应用程序配置：在IIS管理器中删除必须之外的任何无用映射，必须指的是ASP,ASA和其他你确实需要用到的文件类型，例如你用到stml等（使用server side include），实际上90%的主机有了上面两个映射就够了，其余的映射几乎每个都有一个凄惨的故事：htw, htr, idq, ida……想知道这些故事？去查以前的漏洞列表吧。在IIS管理器中右击主机->属性->WWW服务 编辑->主目录配置->应用程序映射，然后就开始一个个删吧（里面没有全选的，嘿嘿）。接着在刚刚那个窗口的应用程序调试书签内将脚本错误消息改为发送文本（除非你想ASP出错的时候用户知道你的程序/网络/数据库结构）错误文本写什么？随便你喜欢，自己看着办。点击确定退出时别忘了让虚拟站点继承你设定的属性。安装新的Service Pack后，IIS的应用程序映射应重新设置。（说明：安装新的Service Pack后，某些应用程序映射又会出现，导致出现安全漏洞。这是管理员较易忽视的一点。）

为了对付日益增多的cgi漏洞扫描器，还有一个小技巧可以参考，在IIS中将HTTP404 Object Not Found出错页面通过URL重定向到一个定制HTM文件，可以让目前绝大多数CGI漏洞扫描器失灵。其实原因很简单，大多数CGI扫描器在编写时为了方便，都是通过查看返回页面的HTTP代码来判断漏洞是否存在的，例如，著名的IDQ漏洞一般都是通过取1.idq来检验，如果返回HTTP200，就认为是有这个漏洞，反之如果返回HTTP404就认为没有，如果你通过URL将HTTP404出错信息重定向到HTTP404.htm文件，那么所有的扫描无论存不存在漏洞都会返回HTTP200，90%的CGI扫描器会认为你什么漏洞都有，结果反而掩盖了你真正的漏洞，让入侵者茫然无处下手,不过从个人角度来说，我还是认为扎扎实实做好安全设置比这样的小技巧重要的多。

最后，为了保险起见，你可以使用IIS的备份功能，将刚刚的设定全部备份下来，这样就可以随时恢复IIS的安全配置。还有，如果你怕IIS负荷过高导致服务器满负荷死机，也可以在性能中打开CPU限制，例如将IIS的最大CPU使用率限制在70%。
3.帐号策略：
（1）帐号尽可能少，且尽可能少用来登录；
说明：网站帐号一般只用来做系统维护，多余的帐号一个也不要，因为多一个帐号就会多一份被攻破的危险。
（2）除过Administrator外，有必要再增加一个属于管理员组的帐号；
说明：两个管理员组的帐号，一方面防止管理员一旦忘记一个帐号的口令还
有一个备用帐号；另方面，一旦黑客攻破一个帐号并更改口令，我们还有
有机会重新在短期内取得控制权。
（3）所有帐号权限需严格控制，轻易不要给帐号以特殊权限；
（4）将Administrator重命名，改为一个不易猜的名字。其他一般帐号也应尊循这一原则。
说明：这样可以为黑客攻击增加一层障碍。
（5）将Guest帐号禁用，同时重命名为一个复杂的名字，增加口令，并将它从
Guest组删掉；
说明：有的黑客工具正是利用了guest 的弱点，可以将帐号从一般用户提
升到管理员组。
（6）给所有用户帐号一个复杂的口令（系统帐号出外），长度最少在8位以上， 且必须同时包含字母、数字、特殊字符。同时不要使用大家熟悉的单词（如microsoft）、熟悉的键盘顺序（如qwert）、熟悉的数字（如2000）等。
说明：口令是黑客攻击的重点，口令一旦被突破也就无任何系统安全可言了，而这往往是不少网管所忽视的地方，据我们的测试，仅字母加数字的5位口令在几分钟内就会被攻破，而所推荐的方案则要安全的多。
（7）口令必须定期更改（建议至少两周该一次），且最好记在心里，除此以外不要在任何地方做记录；另外，如果在日志审核中发现某个帐号被连续尝试，则必须立刻更改此帐号（包括用户名和口令）；
（8）在帐号属性中设立锁定次数，比如改帐号失败登录次数超过5次即锁定改帐号。这样可以防止某些大规模的登录尝试，同时也使管理员对该帐号提高警惕。

4．安全日志：

Win2000的默认安装是不开任何安全审核的！
那么请你到本地安全策略->审核策略中打开相应的审核，推荐的审核是：
账户管理 成功 失败
登录事件 成功 失败
对象访问 失败
策略更改 成功 失败
特权使用 失败
系统事件 成功 失败
目录服务访问 失败
账户登录事件 成功 失败
审核项目少的缺点是万一你想看发现没有记录那就一点都没辙；审核项目太多不仅会占用系统资源而且会导致你根本没空去看，这样就失去了审核的意义。 与之相关的是：
在账户策略->密码策略中设定：
密码复杂性要求 启用
密码长度最小值 6位
强制密码历史 5次
最长存留期 30天
在账户策略->账户锁定策略中设定：
账户锁定 3次错误登录
锁定时间 20分钟
复位锁定计数 20分钟
同样，Terminal Service的安全日志默认也是不开的，我们可以在Terminal Service Configration（远程服务配置）-权限-高级中配置安全审核，一般来说只要记录登录、注销事件就可以了。

5.目录和文件权限：

为了控制好服务器上用户的权限，同时也为了预防以后可能的入侵和溢出，我们还必须非常小心地设置目录和文件的访问权限，NT的访问权限分为：读取、写入、读取及执行、修改、列目录、完全控制。在默认的情况下，大多数的文件夹对所有用户（Everyone这个组）是完全敞开的（Full Control），你需要根据应用的需要进行权限重设。
在进行权限控制时，请记住以下几个原则：
1>限是累计的：如果一个用户同时属于两个组，那么他就有了这两个组所允许的所有权限；
2>拒绝的权限要比允许的权限高（拒绝策略会先执行）如果一个用户属于一个被拒绝访问某个资源的组，那么不管其他的权限设置给他开放了多少权限，他也一定不能访问这个资源。所以请非常小心地使用拒绝，任何一个不当的拒绝都有可能造成系统无法正常运行；
3>文件权限比文件夹权限高
4>利用用户组来进行权限控制是一个成熟的系统管理员必须具有的优良习惯之一；
5>仅给用户真正需要的权限，权限的最小化原则是安全的重要保障；
6.只安装一种操作系统；
说明：安装两种以上操作系统，会给黑客以可乘之机，利用攻击使系统重启到另外一个没有安全设置的操作系统（或者他熟悉的操作系统），进而进行破坏。
7.安装成独立的域控制器（Stand Alone）,选择工作组成员，不选择域；
说明：主域控制器（PDC）是局域网中队多台联网机器管理的一种方式，用于网站服务器包含着安全隐患，使黑客有可能利用域方式的漏洞攻击站点服务器。

8.将操作系统文件所在分区与WEB数据包括其他应用程序所在的分区分开，并在安装时最好不要使用系统默认的目录，如将\WINNT改为其他目录；
说明：黑客有可能通过WEB站点的漏洞得到操作系统对操作系统某些程序的执行权限，从而造成更大的破坏。同时如果采用IIS的话你应该在其设置中删除掉所有的无用的映射，同时不要安装索引服务，远程站点管理与服务器扩展最好也不要要，然后删掉默认路径下的www，整个删，不要手软，然后再硬盘的另一个硬盘建立存放你网站的文件夹，同时一定记得打开w3c日志纪录，切记（不过本人建议采用apache 1.3.24）

系统安装过程中一定本着最小服务原则，无用的服务一概不选择，达到系统的最小安装，多一个服务，多一份风险，呵呵，所以无用组件千万不要安装！
9.关于补丁：在NT下，如果安装了补丁程序，以后如果要从NT光盘上安装新的Windows程序,都要重新安装一次补丁程序， 2000下不需要这样做。
说明：

（1） 最新的补丁程序，表示系统以前有重大漏洞，非补不可了，对于局域网内服务器可以不是最新的，但站点必须安装最新补丁，否则黑客可能会利用低版本补丁的漏洞对系统造成威胁。这是一部分管理员较易忽视的一点；
（2） 安装NT的SP5、SP6有一个潜在威胁，就是一旦系统崩溃重装NT时，系统将不会认NTFS分区，原因是微软在这两个补丁中对NTFS做了改进。只能通过Windows 2000安装过程中认NTFS，这样会造成很多麻烦，建议同时做好数据备份工作。
（3） 安装Service Pack前应先在测试机器上安装一次，以防因为例外原因导致机器死机，同时做好数据备份。

尽量不安装与WEB站点服务无关的软件；
说明：其他应用软件有可能存在黑客熟知的安全漏洞。



10.解除NetBios与TCP/IP协议的绑定

说明：NetBois在局域网内是不可缺少的功能，在网站服务器上却成了黑客扫描工具的首选目标。方法：NT：控制面版——网络——绑定——NetBios接口——禁用 2000：控制面版——网络和拨号连接——本地网络——属性——TCP/IP——属性——高级——WINS——禁用TCP/IP上的NETBIOS

11.删除所有的网络共享资源，在网络连接的设置中删除文件和打印共享，只留下TCP/IP协议

说明：NT与2000在默认情况下有不少网络共享资源，在局域网内对网络管理和网络通讯有用，在网站服务器上同样是一个特大的安全隐患。（卸载“Microsoft 网络的文件和打印机共享”。当查看“网络和拨号连接”中的任何连接属性时，将显示该选项。单击“卸载”按钮删除该组件；清除“Microsoft 网络的文件和打印机共享”复选框将不起作用。）
方法：
(1)NT:管理工具——服务器管理器——共享目录——停止共享;
2000:控制面版——管理工具——计算及管理——共享文件夹———停止共享
但上述两种方法太麻烦，服务器每重启一次，管理员就必须停止一次
（2）修改注册表：
运行Regedit，然后修改注册表在HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters下增加一个键
Name: AutoShareServer
Type: REG_DWORD
Value: 0
然后重新启动您的服务器，磁盘分区共享去掉，但IPC共享仍存在，需每次重启后手工删除。

12.改NTFS的安全权限；
说明：NTFS下所有文件默认情况下对所有人（EveryOne）为完全控制权限，这使黑客有可能使用一般用户身份对文件做增加、删除、执行等操作，建议对一般用户只给予读取权限，而只给管理员和System以完全控制权限，但这样做有可能使某些正常的脚本程序不能执行，或者某些需要写的操作不能完成，这时需要对这些文件所在的文件夹权限进行更改，建议在做更改前先在测试机器上作测试，然后慎重更改。

13.加强数据备份；
说明：这一点非常重要，站点的核心是数据，数据一旦遭到破坏后果不堪设想，而这往往是黑客们真正关心的东西；遗憾的是，不少网管在这一点上作的并不好，不是备份不完全，就是备份不及时。数据备份需要仔细计划，制定出一个策略并作了测试以后才实施，而且随着网站的更新，备份计划也需要不断地调整。


14.只保留TCP/IP协议，删除NETBEUI、IPX/SPX协议；
说明：网站需要的通讯协议只有TCP/IP，而NETBEUI是一个只能用于局域网的协议，IPX/SPX是面临淘汰的协议，放在网站上没有任何用处，反而会被某些黑客工具利用。

15.不要起用IP转发功能，控制面板->网络->协议->TCP/IP协议->属性，使这个选框为空。（NT）
说明：缺省情况下，NT的IP转发功能是禁止的，但注意不要启用，否则它会具有路由作用，被黑客利用来对其他服务器进行攻击。

16.安装最新的MDAC（http://www.microsoft.com/data/download.htm）
说明：MDAC为数据访问部件，通常程序对数据库的访问都通过它，但它也是黑客攻击的目标，为防止以前版本的漏洞可能会被带入升级后的版本，建议卸载后安装最新的版本。注意：在安装最新版本前最好先做一下测试，因为有的数据访问方式或许在新版本中不再被支持，这种情况下可以通过修改注册表来档漏洞，祥见漏洞测试文档。

17.设置IP拒绝访问列表
说明：对于WWW服务，可以拒绝一些对站点有攻击嫌疑的地址；尤其对于FTP服务，如果只是自己公司上传文件，就可以只允许本公司的IP访问改FTP服务，这样，安全性大为提高。

18.禁止对FTP服务的匿名访问
说明：如果允许对FTP服务做匿名访问，该匿名帐户就有可能被利用来获取更多的信息，以致对系统造成危害。

19.建议使用W3C扩充日志文件格式，每天记录客户IP地址，用户名，服务器端口，方法，URI字根，HTTP状态，用户代理，而且每天均要审查日志。（最好不要使用缺省的目录，建议更换一个记日志的路径，同时设置日志的访问权限，只允许管理员和system为Full Control）
说明：作为一个重要措施，既可以发现攻击的迹象，采取预防措施，也可以作为受攻击的一个证据。

20.慎重设置WEB站点目录的访问权限，一般情况下，不要给予目录以写入和允许目录浏览权限。只给予.ASP文件目录以脚本的权限，而不要给与执行权限。
说明：目录访问权限必须慎重设置，否则会被黑客利用。

21.ASP编程安全：

安全不仅是网管的事，编程人员也必须在某些安全细节上注意，养成良好的安全习惯，否则，会给黑客造成可乘之机。目前，大多数网站上的ASP程序有这样那样的安全漏洞，但如果写程序的时候注意的话，还是可以避免的。

涉及用户名与口令的程序最好封装在服务器端，尽量少的在ASP文件里出现，涉及到与数据库连接地用户名与口令应给予最小的权限。
说明：用户名与口令，往往是黑客们最感兴趣的东西，如果被通过某种方式看到源代码，后果是严重的。因此要尽量减少它们在ASP文件中的出现次数。出现次数多得用户名与口令可以写在一个位置比较隐蔽的包含文件中。如果涉及到与数据库连接，理想状态下只给它以执行存储过程的权限，千万不要直接给予该用户以修改、插入、删除记录的权限。

需要经过验证的ASP页面，可跟踪上一个页面的文件名，只有从上一页面转进来的会话才能读取这个页面。
说明：现在的需要经过验证的ASP程序多是在页面头部加一个判断语句，但这还不够，有可能被黑客绕过验证直接进入，因此有必要跟踪上一个页面。具体漏洞见所附漏洞文档。

防止ASP主页.inc文件泄露问题
当存在asp 的主页正在制作并没有进行最后调试完成以前，可以被某些搜索引擎机动追加为搜索对象，如果这时候有人利用搜索引擎对这些网页进行查找，会得到有关文件的定位，并能在浏览器中察看到数据库地点和结构的细节揭示完整的源代码。
解决方案：程序员应该在网页发布前对其进行彻底的调试；安全专家需要固定asp 包含文件以便外部的用户不能看他们。 首先对 .inc 文件内容进行加密，其次也可以使用 .asp 文件代替 .inc 文件使用户无法从浏览器直接观看文件的源代码。.inc 文件的文件名不用使用系统默认的或者有特殊含义容易被用户猜测到的，尽量使用无规则的英文字母。


注意某些ASP编辑器会自动备份asp文件，会被下载的漏洞
在有些编辑asp程序的工具，当创建或者修改一个asp文件时，编辑器自动创建一个备份文件，比如：UltraEdit就会备份一个..bak文件，如你创建或者修改了some.asp，编辑器自动生成一个叫some.asp.bak文件，如果你没有删除这个 bak文件，攻击有可以直接下载some.asp.bak文件，这样some.asp的源程序就会给下载。

在处理类似留言板、BBS等输入框的ASP程序中，最好屏蔽掉HTML、JavaScript、VBScript语句，如无特殊要求，可以限定只允许输入字母与数字，屏蔽掉特殊字符。同时对输入字符的长度进行限制。而且不但在客户端进行输入合法性检查，同时要在服务器端程序中进行类似检查。
说明：输入框是黑客利用的一个目标，他们可以通过输入脚本语言等对用户客户端造成损坏； 如果该输入框涉及到数据查询，他们会利用特殊查询输入得到更多的数据库数据，甚至是表的全部。因此必须对输入框进行过滤。但如果为了提高效率仅在客户端进行输入合法性检查，仍有可能被绕过，因此必须在服务器端再做一次检查。


防止ACCESS mdb 数据库有可能被下载的漏洞
在用ACCESS做后台数据库时，如果有人通过各种方法知道或者猜到了服务器的ACCESS数据库的路径和数据库名称，那么他能够下载这个ACCESS数据库文件，这是非常危险的。
解决方法：
(1) 为你的数据库文件名称起个复杂的非常规的名字，并把他放在几目录下。所谓 "非常规"， 打个比方： 比如有个数据库要保存的是有关书籍的信息， 可不要把他起个"book.mdb"的名字，起个怪怪的名称，比如d34ksfslf.mdb， 再把他放在如./kdslf/i44/studi/ 的几层目录下，这样黑客要想通过猜的方式得到你的ACCESS数据库文件就难上加难了。
(2)不要把数据库名写在程序中。有些人喜欢把DSN写在程序中，比如：
DBPath = Server.MapPath("cmddb.mdb"
conn.Open "driver={Microsoft Access Driver (*.mdb)};dbq=" & DBPath
假如万一给人拿到了源程序，你的ACCESS数据库的名字就一览无余。因此建议你在ODBC里设置数据源，再在程序中这样写：
conn.open "shujiyuan"
(3)使用ACCESS来为数据库文件编码及加密。首先在选取 "工具->安全->加密/解密数据库，选取数据库（如：employer.mdb），然后接确定，接着会出现 "数据库加密后另存为"的窗口，存为：employer1.mdb。 接着employer.mdb就会被编码，然后存为employer1.mdb..
要注意的是，以上的动作并不是对数据库设置密码，而只是对数据库文件加以编码，目的是为了防止他人使用别的工具来查看数据库文件的内容。
接下来我们为数据库加密，首先以打开经过编码了的 employer1.mdb， 在打开时，选择"独占"方式。然后选取功能表的"工具->安全->设置数据库密码"， 接着 输入密码即可。这样即使他人得到了employer1.mdb文件，没有密码他是无法看到 employer1.mdb的。

23.SQL SERVER的安全

SQL SERVER是NT平台上用的最多的数据库系统，但是它的安全问题也必须引起重视。数据库中往往存在着最有价值的信息，一旦数据被窃后果不堪设想。

及时更新补丁程序。
说明：与NT一样，SQL SERVER的许多漏洞会由补丁程序来弥补。建议在安装补丁程序之前先在测试机器上做测试，同时提前做好目标服务器的数据备份。

给SA一个复杂的口令。
说明：SA具有对SQL SERVER数据库操作的全部权限。遗憾的是，一部分网管对数据库并不熟悉，建立数据库的工作由编程人员完成，而这部分人员往往只注重编写SQL 语句本身，对SQL SERVER数据库的管理不熟悉，这样很有可能造成SA口令为空。这对数据库安全是一个严重威胁。目前具有这种隐患的站点不在少数。

严格控制数据库用户的权限，轻易不要给让用户对表有直接的查询、更改、插入、删除权限，可以通过给用户以访问视图的权限，以及只具有执行存储过程的权限。
说明：用户如果对表有直接的操作权限，就会存在数据被破坏的危险。

制订完整的数据库备份与恢复策略。

 24. PCANYWHERE的安全：

目前，PCANYWHERE是最流行的基于NT与2000的远程控制工具，同样也需要注意安全问题。

建议采用单独的用户名与口令，最好采用加密手段。千万不要采用与NT管理员一样的用户名与口令，也不要使用与NT集成的口令。同时在服务器端的设置时务必采用security options中的强加密方式，拒绝低加密水平的连接，同时采用口令加密与传输过程中的用户名与口令加密，以防止被嗅探到，还要限制连接次数，另外很重要的一点就是一定在protect item中设置高强度的口令，同时一定限制不能够让别人看到你的host端的任何设置，即便是要察看主机端的相关设置也必须要输入口令！
说明：PCANYWHERE 口令是远程控制的第一个关口，如果与NT的一样， 就失去了安全屏障。被攻破后就毫无安全可言。而如果采用单独的口令，即使攻破了PCANYWHERE，NT还有一个口令屏障。
及时安装较新的版本。

2.中级篇: IIS的安全与性能调整

实际上，安全和应用在很多时候是矛盾的，因此，你需要在其中找到平衡点，毕竟服务器是给用户用而不是做OPEN HACK的，如果安全原则妨碍了系统应用，那么这个安全原则也不是一个好的原则。 网络安全是一项系统工程，它不仅有空间的跨度，还有时间的跨度。很多朋友（包括部分系统管理员）认为进行了安全配置的主机就是安全的，其实这其中有个误区：我们只能说一台主机在一定的情况一定的时间上是安全的随着网络结构的变化、新的漏洞的发现，管理员/用户的操作，主机的安全状况是随时随地变化着的，只有让安全意识和安全制度贯穿整个过程才能做到真正的安全。

提高IIS 5.0网站伺服器的执行效率的八种方法
以下是提高IIS 5.0网站伺服器的执行效率的八种方法：
1. 启用HTTP的持续作用可以改善15~20%的执行效率。
2. 不启用记录可以改善5~8%的执行效率。
3. 使用 [独立] 的处理程序会损失20%的执行效率。
4. 增加快取记忆体的保存档案数量，可提高Active Server Pages之效能。
5. 勿使用CGI程式。
6. 增加IIS 5.0电脑CPU数量。
7. 勿启用ASP侦错功能。
8. 静态网页采用HTTP 压缩，大约可以减少20%的传输量。

简单介绍如下。
1、启用HTTP的持续作用
启用HTTP的持续作用（Keep-Alive）时，IIS与浏览器的连线不会断线，可以改善执行效率，直到浏览器关闭时连线才会断线。因为维持「Keep-Alive」状态时，於每次用户端请求时都不须重新建立一个新的连接，所以将改善伺服器的效率。此功能为HTTP1.1预设的功能，HTTP 1.0加上Keep-Alive header也可以提供HTTP的持续作用功能。

2、启用HTTP的持续作用可以改善15~20%的执行效率。
如何启用HTTP的持续作用呢？步骤如下：在 [Internet服务管理员] 中，选取整个IIS电脑、或Web站台，於 [内容] 之 [主目录] 页，勾选 [HTTP的持续作用] 选项。

3、不启用记录
不启用记录可以改善5~8%的执行效率。如何设定不启用记录呢？步骤如下：
在 [Internet服务管理员] 中，选取整个IIS电脑、或Web站台，於 [内容] 之 [主目录] 页，不勾选 [启用记录] 选项。设定非独立的处理程序使用 [独立] 的处理程序会损失20%的执行效率，此处所谓 独立」系指将 [主目录]、[虚拟目录] 页之应用程式保护选项设定为 [高（独立的）] 时。因此 [应用程式保护] 设定为 [低 (IIS处理程序)] 时执行效率较高如何设定非「独立」的处理程序呢？步骤如下： 在 [Internet服务管理员] 中，选取整个IIS电脑、Web站台、或应用程式的起始目录。於 [内容] 之 [主目录]、[虚拟目录] 页，设定应用程式保护选项为 [低 (IIS处理程序)] 。

4、调整快取（Cache）记忆体
IIS 5.0将静态的网页资料暂存於快取（Cache）记忆体当中；IIS 4.0则将静态的网页资料暂存於档案当中。调整快取（Cache）记忆体的保存档案数量可以改善执行效率。ASP指令档案执行过後，会在暂存於快取（Cache）记忆体中以提高执行效能。增加快取记忆体的保存档案数量，可提高Active Server Pages之效能。可以设定所有在整个IIS电脑、「独立」Web站台、或「独立」应用程式上执行之应用程式的快取记忆体档案数量。如何设定快取（Cache）功能呢？步骤如下：在 [Internet服务管理员] 中选取整个IIS电脑、「独立」Web站台、或「独立」应用程式的起始目录。於 [内容] 之 [主目录]、[虚拟目录] 页，按下 [设定] 按钮时，即可由 [处理程序选项] 页设定[指令档快取记忆体] 。如何设定快取（Cache）记忆体档案数量呢？步骤如下：在[Internet服务管理员] 中，选取整个IIS电脑、或Web站台的起始目录。於 [内容] 之[伺服器扩充程式] 页，按下 [设定] 按钮。即可设定快取（Cache）记忆体档案数量。

5、勿使用CGI程式
使用CGI程式时，因为处理程序（Process）须不断地产生与摧毁，造成执行效率不佳。一般而言，执行效率比较如下： 静态网页（Static）：100 ISAPI：50 ASP：10 CGI：1 　换句话说，ASP比CGI可能快10倍，因此勿使用CGI程式可以改善IIS的执行效率。以弹性（Flexibility）而言：ASP > CGI > ISAPI > 静态网页（Static）。以安全（Security）而言：ASP（独立） = ISAPI（独立）= CGI > ASP（非独立） = ISAPI（非独立）= 静态网页（Static）

6、增加IIS 5.0电脑CPU数量
根据微软的测试报告，增加IIS 4.0电脑CPU数量，执行效率并不会改善多少；但是增加IIS 5.0电脑CPU数量，执行效率会几乎成正比地提供，换句话说，两颗CPU的IIS5.0电脑执行效率几乎是一颗CPU电脑的两倍，四颗CPU的IIS 5.0电脑执行效率几乎是一颗CPU电脑的四倍IIS 5.0将静态的网页资料暂存於快取（Cache）记忆体当中；IIS 4.0 则将静态的网页资料暂存於档案当中。调整快取（Cache）记忆体的保存档案数量可以改善执行效率。

7、启用ASP侦错功能
勿启用ASP侦错功能可以改善执行效率。如何勿启用ASP侦错功能呢？步骤如下：於[Internet服务管理员] 中，选取Web站台、或应用程式的起始目录，按右键选择[内容]，按 [主目录]、[虚拟目录] 或 [目录] 页，按下 [设定] 按钮，选择 [应用程式侦错] 页，不勾选 [启用ASP伺服器端指令侦错]、[启用ASP用户端指令侦错] 选项。

8、静态网页采用HTTP 压缩
静态网页采用HTTP 压缩，大约可以减少20%的传输量。HTTP压缩功能启用或关闭，系针对整台IIS伺服器来设定。用户端使用IE 5.0浏览器连线到已经启用HTTP压缩IIS5.0之Web伺服器，才有HTTP压缩功能。如何启用HTTP压缩功能呢？步骤如下：若要启用HTTP 压缩功能，方法为在 [Internet服务管理员] 中，选取电脑之 [内容]，於 [主要内容] 之下选取 [WWW服务]。然後按一下 [编辑] 按钮，於 [服务] 页上，选取 [压缩静态档案] 可以压缩静态档案，不选取 [压缩应用程式档案] 。 　动态产生的内容档案（压缩应用程式档案）也可以压缩，但是须耗费额外CPU处理时间，若%Processor Time已经百分之八十或更多时，建议不要压缩

以上是对采用IIS作为WEB服务器的一些安全相关的设置与其性能调整的参数设置，可以最大化的优化你的IIS，不过个人认为如果不存在障碍，还是采用apache比较好一些，漏洞少，建议采用apache 1.3.24版本，因为最近经测试，apache 1.3.23之前的版本都存在溢出漏洞，不要怕，这种漏洞很少的，呵呵。另外，个人建议不要采用ASP安全性总不叫人放心，个人认为还是采用JSP好一些，安全性好，功能强大，绝对超值，呵呵，因为PHP也存在不少的洞洞

附：IIS安全工具及其使用说明

一、IIS Lock Tool，快速设置IIS安全属性

    IIS Lock Tool的推出，还要感谢红色代码，因为正是红色代码的大面积传播，致使微软设计发布这款帮助管理员们设置IIS安全性的工具。

（一）、IIS Lock Tool具有以下功能和特点

    １、最基本功能，帮助管理员设置IIS安全性；

    ２、此工具可以在IIS4和IIS5上使用；

    ３、即使系统没有及时安装所有补丁，也能有效防止IIS4和IIS5的已知漏洞；

    ４、帮助管理员去掉对本网站不必要的一些服务，使IIS在满足本网站需求的情况下运行最少的服务；

    ５、具有两种使用模式：快捷模式和高级模式。快捷模式直接帮助管理员设置好IIS安全性，这种模式只适合于只有HTML和HTM静态网页的网站使用，因为设置完成以后，ASP不能运行；高级模式允许管理员自己设置各种属性，设置得当，对IIS系统任何功能均没有影响。

（二）、IIS Lock Tool的使用

    １、软件下载和安装

    IIS Lock Tool在微软网站下载，下载地址：
http://www.microsoft.com/Downloads/...ReleaseID=32362

    安装很简单，需要注意的是，安装以后，程序不会在系统的【程序】菜单出现，也不会在【管理工具】出现，需要安装者在安装目录寻找运行该程序。

    ２、软件的使用

    在以下的介绍中，我们将详细介绍每一步设置的意义和推荐设置，之所以详细介绍，是为了我们明白这些设置到底意味着什么，同时，和我们原来的安全设置相对照，避免出现设置完成以后，系统出现障碍。

  运行该软件，首先出现以下界面（图一）：

图一

    以上界面介绍了IIS Lock Tool的一些基本情况和使用时需要注意的地方：1）使用时应该选择针对本网站最少的服务，去掉不必要的服务；2）设置完成以后，建议对网站进行彻底检查，以确定设置对本网站是否合适；

    在以上界面，点击【下一步】按钮，出现以下界面（图二）：

图二

    以上界面选择快捷模式还是高级模式来运行软件，在这里，软件介绍了两者模式的区别：

  快捷模式：此设置模式关闭了IIS的一些高级服务属性，其中包括动态网页属性（ASP）；所以，我们需要再重复一遍，选择快捷模式只适合提供静态页面的网站，当然，这种模式是相对最安全的。

    高级模式：此模式运行安装者自定义各种属性，同时允许高级属性的运行。

    快捷模式设置我们不必介绍，点击【下一步】按钮就可以设置完成。我们选择【Advanced Lockdown】（高级设置），点击【下一步】按钮，出现以下界面（图三）：

图三

    以上界面帮助管理员设置各种脚本映射，我们来看每一种映射应该怎样设置：

    1）Disable support Active Server Pages(ASP)，选择这种设置将使IIS不支持ASP功能；可以根据网站具体情况选择，一般不选择此项，因为网站一般要求运行ASP程序；

    2）Disable support Index Server Web Interface(.idq,.htw,.ida)，选择这一项将不支持索引服务，具体就是不支持.idq,.htw,.ida这些文件。我们先来看看到底什么是索引服务，然后来决定取舍。索引服务是IIS4中包含的内容索引引擎。你可以对它进行ADO调用并搜索你的站点，它为你提供了一个很好的web 搜索引擎。如果你的网站没有利用索引服务对网站进行全文检索，也就可以取消网站的这个功能，取消的好处是：1）减轻系统负担；2）有效防止利用索引服务漏洞的病毒和黑客，因为索引服务器漏洞可能使攻击者控制网站服务器，同时，暴露网页文件在服务器上的物理位置（利用.ida、.idq）。因此，我们一般建议在这一项前面打勾，也就是取消索引服务；

  3）Disable support for Server Side Includes（.shtml,.shtm,.stm），取消服务器端包含；先来看看什么叫服务器端包含，SSI就是HTML文件中，可以通过注释行调用的命令或指针。SSI 具有强大的功能，只要使用一条简单的SSI 命令就可以实现整个网站的内容更新，动态显示时间和日期，以及执行shell和CGI脚本程序等复杂的功能。一般而言，我们没有用到这个功能，所以，建议取消；取消可以防止一些IIS潜在地漏洞；

    4）Disable for Internet Data Connector(.idc)，取消Internet数据库连接；先看Internet数据库连接的作用，它允许HTML页面和后台数据库建立连接，实现动态页面。需要注意的是，IIS4和IIS5中基本已经不使用idc，所以，建议在此项打勾，取消idc；

    5）Disable support for Internet Printing (.printer)，取消Internet打印；这一功能我们一般没有使用，建议取消；取消的好处是可以避免.printer远程缓存溢出漏洞，这个漏洞使攻击者可以利用这个漏洞远程入侵IIS 服务器，并以系统管理员(system)身份执行任意命令；

    6）Disable support for .HTR Scripting（.htr），取消htr映射；攻击者通过htr构造特殊的URL请求，可能导致网站部分文件源代码暴露（包括ASP），建议在此项前面打勾，取消映射；

    理解以上各项设置以后，我们可以根据本网站情况来决定取舍，一般网站除了ASP要求保留以外，其他均可以取消，也就是全消第一项前面的勾，其他全部打勾，按【下一步】按钮，出现以下界面（图四）

图四

    以上界面设置可以让管理员选择一些IIS默认安装文件的保留与否，我们来看怎样选择：

    1）Remove sample web files，删除web例子文件；建议删除，因为一般我们不需要在服务器上阅读这些文件，而且，这些文件可能让攻击者利用来阅读部分网页源程序代码（包括ASP）；

    2）Remove the Scripts vitual directory，删除脚本虚拟目录；建议删除；

    3）Remove the MSDAC virtual directory，删除MSDAC虚拟目录，建议删除；

    4）Disable Distribauted Authoring and Versioning(WebDAV)，删除WEBDAV，WebDav主要允许管理者远程编写和修改页面，一般我们不会用到，建议删除，删除的好处是可以避免IIS5的一个WebDav漏洞，该漏洞可能导致服务器停止。

    5）Set file permissions to prevent the IIS anouymous user from executing system utilities(such as cmd.exe,tftp.exe)，防止匿名用户运行可执行文件，比如cmd.exe和tftp.exe；建议选择此项，因为红色代码和尼姆达均利用了以上所说的匿名执行可执行文件的功能；

    6）Set file permissions to prevent the IIS anouymous user from writing to content directories，防止匿名用户对目录具有写权限，这个不要解释，建议选择；

    设置以上选项以后，按【下一步】按钮，出现以下界面（图五）：

图五

    要求确认是否接受以上设置，选择【是】，出现以下界面（图六）开始对系统执行设置：

图六

    在以上界面中，我们可以看到对IIS的详细设置情况。设置完成以后，建议重新启动IIS。

二、URLScan Tool――过滤非法URL访问

    仔细观察IIS的漏洞，我们几乎可以得出这样一个结论，所有利用这些漏洞实现对网站攻击的手段均是构造特殊的URL来访问网站，一般有以下几种类型的URL可以利用漏洞：

    １、特别长的URL，比如红色代码攻击网站的URL就是这样：

GET/default.idaXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX%u9090%u6858%ucbd3%u7801%u
9090%u6858%ucbd3%u7801%u9090%u6858%ucbd3%u7801%u9090%u9090%u8190%u
00c3%u0003%u8b00%u531b%u53ff%u0078%u0000%u00=a 200；

  ２、特殊字符或者字符串的URL，比如在URL后面加::$DATA可以看到网页（ASP）源代码；

    ３、URL中含有可执行文件名，最常见的就是有cmd.exe；

    既然这些攻击利用特殊的URL来实现，所以，微软提供了这款专门过滤非法URL的安全工具，可以达到御敌于国门之外的效果，这款工具有以下特点和功能：

    １、基本功能：过滤非法URL请求；

    ２、设定规则，辨别那些URL请求是合法的；这样，就可以针对本网站来制定专门的URL请求规则；同时，当有新的漏洞出现时，可以更改这个规则，达到防御新漏洞的效果；

    ３、程序提供一套URL请求规则，这个规则包含已经发现的漏洞利用特征，帮助管理员设置规则；

（一）、软件的下载与安装

    URLScan可以在微软的网站上下载，地址如下：

http://download.microsoft.com/downl...-US/UrlScan.exe

    和一般软件一样安装，但是，此软件不能选择安装路径，安装完成以后，我们可以在System32/InetSvr/URLScan目录下找到以下文件：

    urlscan.dll：动态连接库文件；
    urlscan.inf：安装信息文件；
    urlscan.txt：软件说明文件；
    urlscan.ini：软件配置文件，这个文件很只要，因为对URLScan的所有配置，均有这个文件来完成。

（二）、软件的配置

    软件的配置由urlscan.ini文件来完成，在配置此文件以前，我们需要了解一些基本知识。

  １、urlscan配置文件的构造形式

    urlscan配置文件必须遵从以下规则：

    （1）此文件名必须为urlscan.ini；

    （2）配置文件必须和urlscan.dll在同一目录；

    （3）配置文件必须是标准ini文件结构，也就是由节，串和值组成；

    （4）配置文件修改以后，必须重新启动IIS，使配置生效；

    （5）配置文件由以下各节组成：

    [Option]节，主要设置节；
    [AllowVerbs]节，配置认定为合法URL规则设定，此设定与Option节有关；
    [DenyVerbs]节，配置认定为非法URL规则设定，此设定与Option节有关；
    [DenyHeaders]节，配置认定为非法的header在设立设置；
    [AllowExtensions]节，配置认定为合法的文件扩展名在这里设置，此设定与Option节有关；
    [DenyExtensions]节，配置认定为非法的文件扩展名在这里设置，此设定与Option节有关；

    ２、具体配置

    （1）Option节的配置，因为Option节的设置直接影响到以后的配置，因此，这一节的设置特别重要。此节主要进行以下属性的设置：

    UseAllowVerbs：使用允许模式检查URL请求，如果设置为1,所有没有在[AllowVerbs]节设置的请求都被拒绝；如果设置为0，所有没有在[DenyVerbs]设置的URL请求都认为合法；默认为1;

    UseAllowExtensions：使用允许模式检测文件扩展名；如果设置为 1,所有没在[AllowExtensions]节设置的文件扩展名均认为是非法请求；如果设置为0,所有没在[DenyExtensions]节设置的扩展名均被认为是合法请求；默认为0;

    EnableLogging：是否允许使用Log文件，如果为1,将在urlscan.dll的相同目录设置名为urlscan.log的文件记录所有过滤；

    AllowLateScanning：允许其他URL过滤在URLScan过滤之前进行，系统默认为不允许0;

    AlternateServerName：使用服务名代替；如果此节存在而且[RemoveServerHeader]节设置为0,IIS将在这里设置的服务器名代替默认的“Server”；

    NormalizeUrlBeforeScan：在检测URL之前规格化URL；如果为1，URLScan将在IIS编码URL之前URL进行检测；需要提醒的是，只有管理员对URL解析非常熟悉的情况下才可以将其设置为0；默认为1；

    VerifyNormalization：如果设置为1，UrlScan将校验URL规则，默认为1；此节设定与NormalizeUrlBeforeScan有关；

    AllowHighBitCharacters：如果设置为1,将允许URL中存在所有字节，如果为0，含有非ASCII字符的URL将拒绝；默认为1；

    AllowDotInPath：如果设置为1，将拒绝所有含有多个“.”的URL请求，由于URL检测在IIS解析URL之前，所以，对这一检测的准确性不能保证，默认为0；

    RemoveServerHeader：如果设置为1，将把所有应答的服务头清除，默认为0;

    （2）[AllowVerbs]节配置

    如果UseAllowVerbs设置为1,此节设置的所有请求将被允许，一般设置以下请求：

    GET、HEAD、POST

    （3）[DenyVerbs]节配置

    如果UseAllowVerbs设置为0，此节设置的所有请求将拒绝，一般设置以下请求：

    PROPFIND、PROPPATCH、MKCOL、DELETE、PUT、COPY、MOVE、LOCK、UNLOCK

    （4）[AllowExtensions]节设置

    在这一节设置的所有扩展名文件将被允许请求，一般设置以下请求：

    .asp、.htm、.html、.txt、.jpg、.jpeg、.gif，如果需要提供文件下载服务，需要增加.rar、.zip

    （5）[DenyExtensions]节设置

    在这一节设置的所有扩展名文件请求将被拒绝，根据已经发现的漏洞，我们可以在这一节增加内容，一般为以下设置：
.asa、可执行文件、批处理文件、日志文件、罕见扩展如：shtml、.printer等。

三、总结

    以上两个工具功能强大，可以真正实现对IIS的保护。IIS Lock Tool简单，相对而言，只是被动的防卫；UrlScan设置比较难，建议对IIS非常熟悉的管理员使用，只要设置得当，UrlScan的功能更加强大。在使用UrlScan的时候，切记不要设置一次万事大吉，需要不停跟踪新出现的漏洞，随时修改URLScan的配置文件。

3。高级篇：NT/2000的高级安全设置

1.禁用空连接，禁止匿名获得用户名列表

Win2000的默认安装允许任何用户通过空用户得到系统所有账号/共享列表，这个本来是为了方便局域网用户共享文件的，但是一个远程用户也可以得到你的用户列表并使用暴力法破解用户密码。很多朋友都知道可以通过更改注册表Local_Machine\System\CurrentControlSet\Control\LSA-RestrictAnonymous = 1来禁止139空连接，实际上win2000的本地安全策略（如果是域服务器就是在域服务器安全和域安全策略中）就有这样的选项RestrictAnonymous（匿名连接的额外限制），这个选项有三个值： 0：None. Rely on default permissions（无，取决于默认的权限 1 ：Do not allow enumeration of SAM accounts and shares（不允许枚举SAM帐号和共享） 2：No access without explicit anonymous permissions（没有显式匿名权限就不允许访问） 0这个值是系统默认的，什么限制都没有，远程用户可以知道你机器上所有的账号、组信息、共享目录、网络传输列表(NetServerTransportEnum等等，对服务器来说这样的设置非常危险。 1这个值是只允许非NULL用户存取SAM账号信息和共享信息。 2这个值是在win2000中才支持的，需要注意的是，如果你一旦使用了这个值，你的共享估计就全部完蛋了，所以我推荐你还是设为1比较好。 好了，入侵者现在没有办法拿到我们的用户列表，我们的账户安全了
2。禁止显示上次登陆的用户名HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\winlogon项中的Don’t Display Last User Name串数据改成1，这样系统不会自动显示上次的登录用户名。将服务器注册表HKEY_LOCAL_ MACHINE\SOFTWARE\Microsoft\
WindowsNT\CurrentVersion\Winlogon项中的Don't Display Last User Name串数据修改为1，隐藏上次登陆控制台的用户名。其实，在2000的本地安全策略中也存在该选项
Winnt4.0修改注册表：
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Current Version\Winlogon 中增加DontDisplayLastUserName，将其值设为1。

2.预防DoS：

在注册表HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters中更改以下值可以帮助你防御一定强度的DoS攻击 SynAttackProtect REG_DWORD 2
EnablePMTUDiscovery REG_DWORD 0 NoNameReleaseOnDemand REG_DWORD 1
EnableDeadGWDetect REG_DWORD 0 KeepAliveTime REG_DWORD 300,000
PerFORMRouterDiscovery REG_DWORD 0 EnableICMPRedirects REG_DWORD 0

在Win2000中如何关闭ICMP(Ping)

    3.针对ICMP攻击
ICMP的全名是Internet Control and Message Protocal即因特网控制消息/错误报文协议，这个协议主要是用来进行错误信息和控制信息的传递，例如著名的Ping和Tracert工具都是利用ICMP协议中的ECHO request报文进行的（请求报文ICMP ECHO类型8代码0，应答报文ICMP ECHOREPLY类型0代码0）。
    ICMP协议有一个特点---它是无连结的，也就是说只要发送端完成ICMP报文的封装并传递给路由器，这个报文将会象邮包一样自己去寻找目的地址，这个特点使得ICMP协议非常灵活快捷，但是同时也带来一个致命的缺陷---易伪造（邮包上的寄信人地址是可以随便写的），任何人都可以伪造一个ICMP报文并发送出去，伪造者可以利用SOCK_RAW编程直接改写报文的ICMP首部和IP首部，这样的报文携带的源地址是伪造的，在目的端根本无法追查，（攻击者不怕被抓那还不有恃无恐？）根据这个原理，外面出现了不少基于ICMP的攻击软件，有通过网络架构缺陷制造ICMP风暴的，有使用非常大的报文堵塞网络的，有利用ICMP碎片攻击消耗服务器CPU的，甚至如果将ICMP协议用来进行通讯，可以制作出不需要任何TCP/UDP端口的木马（参见揭开木马的神秘面纱三）......既然ICMP协议这么危险，我们为什么不关掉它呢？

    我们都知道，Win2000在网络属性中自带了一个TCP/IP过滤器，我们来看看能不能通过这里关掉ICMP协议，桌面上右击网上邻居->属性->右击你要配置的网卡->属性->TCP/IP->高级->选项->TCP/IP过滤，这里有三个过滤器，分别为：TCP端口、UDP端口和IP协议，我们先允许TCP/IP过滤，然后一个一个来配置，先是TCP端口，点击"只允许"，然后在下面加上你需要开的端口，一般来说WEB服务器只需要开80(www)，FTP服务器需要开20(FTP Data)，21(FTP Control)，邮件服务器可能需要打开25(SMTP),110(POP3)，以此类推......接着是UDP，UDP协议和ICMP协议一样是基于无连结的，一样容易伪造，所以如果不是必要（例如要从UDP提供DNS服务之类）应该选择全部不允许，避免受到洪水（Flood）或碎片（Fragment）攻击。最右边的一个编辑框是定义IP协议过滤的，我们选择只允许TCP协议通过，添加一个6（6是TCP在IP协议中的代码，IPPROTO_TCP=6）,从道理上来说，只允许TCP协议通过时无论UDP还是ICMP都不应该能通过，可惜的是这里的IP协议过滤指的是狭义的IP协议，从架构上来说虽然ICMP协议和IGMP协议都是IP协议的附属协议，但是从网络7层结构上ICMP/IGMP协议与IP协议同属一层，所以微软在这里的IP协议过滤是不包括ICMP协议的，也就是说即使你设置了“只允许TCP协议通过”，ICMP报文仍然可以正常通过，所以如果我们要过滤ICMP协议还需要另想办法。

    刚刚在我们进行TCP/IP过滤时，还有另外一个选项：IP安全机制（IP Security)，我们过滤ICMP的想法就要着落在它身上。

打开本地安全策略，选择IP安全策略，在这里我们可以定义自己的IP安全策略。一个IP安全过滤器由两个部分组成：过滤策略和过滤操作，过滤策略决定哪些报文应当引起过滤器的关注，过滤操作决定过滤器是“允许”还是“拒绝”报文的通过。要新建IP安全过滤器，必须新建自己的过滤策略和过滤操作：右击本机的IP安全策略，选择管理IP过滤器，在IP过滤器管理列表中建立一个新的过滤规则：ICMP_ANY_IN，源地址选任意IP，目标地址选本机，协议类型是ICMP，切换到管理过滤器操作，增加一个名为Deny的操作，操作类型为"阻止"（Block）。这样我们就有了一个关注所有进入ICMP报文的过滤策略和丢弃所有报文的过滤操作了。需要注意的是，在地址选项中有一个镜像选择，如果选中镜像，那么将会建立一个对称的过滤策略，也就是说当你关注any IP->my IP的时候，由于镜像的作用，实际上你也同时关注了my IP->any IP，你可以根据自己的需要选择或者放弃镜像。再次右击本机的IP安全策略，选择新建IP过滤策略，建立一个名称为ICMP Filter的过滤器，通过增加过滤规则向导，我们把刚刚定义的ICMP_ANY_IN过滤策略指定给ICMP Filter，然后在操作选框中选择我们刚刚定义的Deny操作，退出向导窗口，右击ICMP Filter并启用它，现在任何地址进入的ICMP报文都会被丢弃了。
    虽然用IP sec能够对ICMP报文进行过滤，不过操作起来太麻烦，而且如果你只需要过滤特定的ICMP报文，还要保留一些常用报文（如主机不可达、网络不可达等），IP sec策略就力不从心了，我们可以利用Win2000的另一个强大工具路由与远程访问控制（Routing & Remote Access）来完成这些复杂的过滤操作。

    路由与远程访问控制是Win2000用来管理路由表、配置VPN、控制远程访问、进行IP报文过滤的工具，默认情况下并没有安装，所以首先你需要启用它，打开"管理工具"->"路由与远程访问"，右击服务器（如果没有则需要添加本机）选择"配置并启用路由及远程访问"，这时配置向导会让你选择是什么样的服务器，一般来说，如果你不需要配置VPN服务器，那么选择"手动配置"就可以了，配置完成后，主机下将出现一个IP路由的选项，在"常规"中选择你想配置的网卡（如果你有多块网卡，你可以选择关闭某一块的ICMP），在网卡属性中点击"输入筛选器"，添加一条过滤策略"from:ANY　to:ANY　协议:ICMP　类型:8 :编码　丢弃"就可以了（类型8编码0就是Ping使用的ICMP_ECHO报文，如果要过滤所有的ICMP报文只需要将类型和编码都设置为255）

    细心的朋友刚才可能已经发现，在输入、输出过滤器的下面，还有一个"碎片检查"功能，这个功能使用来应付IP碎片攻击的，这已经超出了本文所讨论的范围，我会在以后的拒绝服务攻击的文章中继续和大家一起探讨的。Win2000的路由及远程访问是一个功能非常强大的工具集

4.改变windows系统的一些默认值（例如：数据包的生存时间(TTL)值，不同系统有不同的值，有经验的人可以根据TTL的不同的值判断对方使用的是何种操作系统（例如windows 2000默认值128），我改改改，看你怎么看)

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

DefaultTTL REG_DWORD 0-0xff(0-255 十进制,默认值128)

说明:指定传出IP数据包中设置的默认生存时间(TTL)值.TTL决定了IP数据包在到达
目标前在网络中生存的最大时间.它实际上限定了IP数据包在丢弃前允许通过的路由
器数量.有时利用此数值来探测远程主机操作系统.

5.防止ICMP重定向报文的攻击
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

EnableICMPRedirects REG_DWORD 0x0(默认值为0x1)

说明:该参数控制Windows 2000是否会改变其路由表以响应网络设备(如路由器)发送给它的ICMP重定向消息,有时会被利用来干坏事.Win2000中默认值为1,表示响应ICMP重定向报文.

6.禁止响应ICMP路由通告报文
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\interface
PerformRouterDiscovery REG_DWORD 0x0(默认值为0x2)

说明:“ICMP路由公告”功能可造成他人计算机的网络连接异常,数据被窃听,计算机被用于流量攻击等严重后果.此问题曾导致校园网某些局域网大面积,长时间的网络异常.因此建议关闭响应ICMP路由通告报文.Win2000中默认值为2,表示当DHCP发送路由器发现选项时启用

7.防止SYN洪水攻击
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

SynAttackProtect REG_DWORD 0x2(默认值为0x0)

说明:SYN攻击保护包括减少SYN-ACK重新传输次数,以减少分配资源所保留的时
间.路由缓存项资源分配延迟,直到建立连接为止.如果synattackprotect=2,
则AFD的连接指示一直延迟到三路握手完成为止.注意,仅在TcpMaxHalfOpen和
TcpMaxHalfOpenRetried设置超出范围时,保护机制才会采取措施.

8.禁止C$、D$一类的缺省共享
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
AutoShareServer、REG_DWORD、0x0

9.禁止ADMIN$缺省共享
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
AutoShareWks、REG_DWORD、0x0
10.限制IPC$缺省共享
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

restrictanonymous REG_DWORD 0x0 缺省
0x1 匿名用户无法列举本机用户列表
0x2 匿名用户无法连接本机IPC$共享
说明:不建议使用2，否则可能会造成你的一些服务无法启动，如SQL Server

11.不支持IGMP协议
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

IGMPLevel REG_DWORD 0x0(默认值为0x2)

说明:记得Win9x下有个bug,就是用可以用IGMP使别人蓝屏,修改注册表可以修正这个
bug.Win2000虽然没这个bug了,但IGMP并不是必要的,因此照样可以去掉.改成0后用
route print将看不到那个讨厌的224.0.0.0项了.

12.设置arp缓存老化时间设置
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services:\Tcpip\Parameters

ArpCacheLife REG_DWORD 0-0xFFFFFFFF(秒数,默认值为120秒)
ArpCacheMinReferencedLife REG_DWORD 0-0xFFFFFFFF(秒数,默认值为600)

说明:如果ArpCacheLife大于或等于ArpCacheMinReferencedLife,则引用或未引用的ARP缓存项在ArpCacheLife秒后到期.如果ArpCacheLife小于阿ARPCacheMinReferencedLife,未引用项在ArpCacheLife秒后到期,而引用项在ArpCacheMinReferencedLife秒后到期.每次将出站数据包发送到项的IP地址时,就会引用ARP缓存中的项。

13.禁止死网关监测技术
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services:\Tcpip\Parameters

EnableDeadGWDetect REG_DWORD 0x0(默认值为ox1)

说明:如果你设置了多个网关,那么你的机器在处理多个连接有困难时,就会自动改用备份网关.有时候这并不是一项好主意,建议禁止死网关监测.

14.不支持路由功能
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services:\Tcpip\Parameters

IPEnableRouter REG_DWORD 0x0(默认值为0x0)

说明:把值设置为0x1可以使Win2000具备路由功能,由此带来不必要的问题.

15.做NAT时放大转换的对外端口最大值
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services:\Tcpip\Parameters

MaxUserPort REG_DWORD 5000-65534(十进制)(默认值0x1388--十进制为5000)

说明:当应用程序从系统请求可用的用户端口数时,该参数控制所使用的最大端口数.正常情况下,短期端口的分配数量为1024-5000.将该参数设置到有效范围以外时,就会使用最接近的有效数值(5000或65534).使用NAT时建议把值放大点.
16.修改MAC地址
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\

找到右窗口的说明为"网卡"的目录,
比如说是{4D36E972-E325-11CE-BFC1-08002BE10318}

展开之,在其下的0000,0001,0002...的分支中找到"DriverDesc"的键值为你网卡的说明,比如说"DriverDesc"的值为"Intel(R) 82559 Fast Ethernet LAN on Motherboard"然后在右窗口新建一字符串值,名字为"Networkaddress",内容为你想要的MAC值，比如说是"004040404040"然后重启动计算机，ipconfig /all看看.

17.防止密码被DUMP，你只需在服务里面关掉Remote regisitery services

Quote:
国际玉米 70元/年 国内玉米 200元/年 各类虚拟主机特价出售
至强型论坛空间 ASP+ACCESS 可选SQL 演示：http://bbs.jetdown.com/ 业务联系QQ：365285

2003-6-11 12:19
神仙哥哥
落伍者

积分 1652
发贴 1648
注册 2001-8-31
来自 www.e58.net
这么长啊！打包了

1.未满18岁者请在父母指导下与本人聊天
2.我非专业聊天人士.不承担主动招呼业务
3.谢绝一问一答制.
2003-6-11 12:21
ejan
落伍者

积分 6873
发贴 6697
注册 2002-5-8
来自 @__________________@
这么长．

偶爱这里所有可爱的版主同志！
A-Do.net[阿杜]网站出售,BBsex.Net [BBS&Sex]和inBJ.Net[在北京]出售！ 详情点击这里!
2003-6-11 12:21
okwebhelp
落伍者

积分 1595
发贴 1501
注册 2001-8-17
靠呀靠！！！！！！！！！！！！！！无限靠！！！！！！！！！无限日！！！！！！！！！！！
为什么我整理好的全套教材你们不要，单个贴出来还漏图，就加净化？？？日天日地日社会的～～～～～～～～～～｀｀｀

我的教材
http://www.im286.com/viewthread.php?tid=224960

相当全面和专业的配置服务器和安全手册
http://www.im286.com/viewthread.php?tid=224960
2003-6-11 12:23
xrol.net
落伍者

积分 1716
发贴 1711
注册 2001-5-15
来自 萧然在线
出去了？？服务器好像还没搞定呢？？
2003-6-11 12:42
diablo268
落伍者

积分 1829
发贴 1837
注册 2003-2-14
来自 Caribbean
收了

Saude,Sao Paulo,Brasil ICQ:5918387
http://www.365m.com 影音天地,技术交流,销售巴西特色产品
http://www.96315.net
http://www.tz99.com
http://www.sale99.com
2003-6-11 12:43
diablo268
落伍者

积分 1829
发贴 1837
注册 2003-2-14
来自 Caribbean

Quote:
Originally posted by okwebhelp at 2003-6-11 12:23 PM:
靠呀靠！！！！！！！！！！！！！！无限靠！！！！！！！！！无限日！！！！！！！！！！！
为什么我整理好的全套教材你们不要，单个贴出来还漏图，就加净化？？？日天日地日社会的～～～～～～～～～～｀｀｀
...

你的我也收

Saude,Sao Paulo,Brasil ICQ:5918387
http://www.365m.com 影音天地,技术交流,销售巴西特色产品
http://www.96315.net
http://www.tz99.com
http://www.sale99.com
2003-6-11 12:44
红孩儿
落伍者

积分 12900
发贴 13220
注册 2002-4-29
来自 青春专门店　www.4y.cn

Quote:
Originally posted by okwebhelp at 2003-6-11 12:23 PM:
靠呀靠！！！！！！！！！！！！！！无限靠！！！！！！！！！无限日！！！！！！！！！！！
为什么我整理好的全套教材你们不要，单个贴出来还漏图，就加净化？？？日天日地日社会的～～～～～～～～～～｀｀｀
...

哈哈,无限靠,无限日

代理商务中国,新网互联所有产品(http://www.4y.cn/)
国际域名: 85 元.送6无QQ,20M空间,2个邮箱
处理:y2008.com(奥运),98块,送farewell.cn(单词:再见)
2003-6-11 12:46

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.050431 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 安全配置Windows2000服务器 [转帖] - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 安全配置Windows2000服务器 [转帖]

作者:
标题: 安全配置Windows2000服务器 [转帖] 上一主题 | 下一主题
nbinfo
落伍者

积分 6689
发贴 6501
注册 2002-8-7
来自 CHINA 中国 SEX
安全配置Windows2000服务器 [转帖]

安全配置Windows2000服务器

一、 版本的选择

    笔者强烈建议：在语言不成为障碍的情况下，请一定使用英文版。要知道，微软的产品是以“漏洞加补丁（Bug & Patch）”而著称的，中文版的Bug远远多于英文版，而补丁一般还会迟至少半个月（也就是说一般微软公布了漏洞后你的服务器还会有半个月处于无保护状态）。

    二、 组件的定制

    WIN2K在默认情况下会安装一些常用的组件，但是正是这个默认安装是非常危险的，根据安全原则“最少的服务+最小的权限=最大的安全” ，只安装确实需要的服务即可。这里特别提醒注意的是：“Indexing Service”、“FrontPage 2000 Server Extensions”、“ Internet Service Manager”这几个危险服务。

    三、 管理应用程序的选择

    选择一个好的远程管理软件是非常重要的事，这不仅仅是安全方面的要求，也是应用方面的需要。WIN2K的Terminal Service是基于RDP（远程桌面协议）的远程控制软件，它的速度快，操作方便，比较适合用来进行常规操作。但是，Terminal Service也有其不足之处，由于它使用的是虚拟桌面，再加上微软编程的不严谨，当你使用Terminal Service进行安装软件或重启服务器等与真实桌面交互的操作时，往往会出现哭笑不得的现象，例如：使用Terminal Service重启微软的认证服务器（Compaq, IBM等）可能会直接关机。所以，为了安全起见，建议再配备一个远程控制软件作为辅助，和Terminal Service互补，如PcAnyWhere就是一个不错的选择。

    四、 分区和逻辑盘的分配

    至少建立两个分区，一个系统分区，一个应用程序分区。这是因为，微软的IIS（Internet Ihformation Server）经常会有漏洞，如果把系统和IIS放在同一个驱动器会导致系统文件的泄漏，甚至让入侵者远程获取管理权。

    推荐建立三个逻辑驱动器，第一个用来装系统和重要的日志文件；第二个放IIS；第三个放FTP，这样无论IIS或FTP出了安全漏洞都不会直接影响到系统目录和系统文件。

    五、 安装顺序的选择

    不要觉得只要能装上系统，就算完事了，其实WIN2K的安装顺序是非常重要的。

    首先，要注意接入网络的时间。WIN2K在安装时有一个漏洞，就是在输入Administrator的密码后，系统会建立“$ADMIN”的共享，但是并没有用刚输入的密码来保护它，这种情况一直会持续到计算机再次启动。在此期间，任何人都可以通过“$ADMIN”进入系统；同时，只要安装一完成，各种服务就会自动运行，而这时的服务器还到处是漏洞，非常容易从外部侵入。因此，在完全安装并配置好WIN2K Server之前，一定不要把主机接入网络。

    其次，注意补丁的安装。补丁应该在所有应用程序安装完之后再安装，因为补丁程序往往要替换或修改某些系统文件，如果先安装补丁的话可能无法起到应有的效果。

怎么设

    即使正确地安装了WIN2K Server，系统也有很多漏洞，还需要进一步进行细致的配置。

    一、 端口

    端口是计算机和外部网络相连的逻辑接口，也是计算机的第一道屏障，端口配置正确与否直接影响到主机的安全。

    二、 IIS

    IIS是微软的组件中问题最多的一个，平均两三个月就要出一个漏洞，而微软的IIS默认安装又实在不敢恭维，所以IIS的配置是我们的重点。

    首先，删除C盘下的Inetpub目录，在D盘建一个Inetpub，在IIS管理器中将主目录指向D:\Inetpub。

    其次，把IIS安装时默认的scripts等虚拟目录也一概删除，如果你需要什么权限的目录可以以后再建（特别注意写权限和执行程序的权限）。

    然后是应用程序的配置。在IIS管理器中把无用映射都统统删除（当然必须保留如ASP、ASA等）。在IIS管理器中“主机→属性→WWW服务编辑→主目录配置→应用程序映射”，然后开始一个个删吧。接着再在应用程序调试书签内，将“脚本错误消息”改为“发送文本”。点击“确定”退出时别忘了让虚拟站点继承刚才设定好的属性。

    最后，为了保险起见，可以使用IIS的备份功能，将刚刚的设定全部备份下来，这样就可以随时恢复IIS的安全配置。还有，如果怕IIS负荷过高导致服务器死机，也可以在性能中打开CPU限制，如将IIS的最大CPU使用率限制在70%。

    三、 账号安全

    首先，WIN2K的默认安装允许任何用户通过空用户得到系统所有账号和共享列表，这本来是为了方便局域网用户共享资源和文件的，但是，同时任何一个远程用户也可以通过同样的方法得到你的用户列表，并可能使用暴力法破解用户密码给整个网络带来破坏。很多人都只知道更改注册表Local_Machine\System\CurrentControlSet\Control\LSA-RestrictAnonymous = 1来禁止空用户连接，实际上WIN2K的本地安全策略里（如果是域服务器就是在域服务器安全和域安全策略里）就有这样的选项RestrictAnonymous（匿名连接的额外限制），其中有三个值：

    “0”：None， Rely on default permissions（无，取决于默认的权限）

    “1”：Do not allow enumeration of SAM accounts and shares（不允许枚举SAM账号和共享）

    “2”：No access without explicit anonymous permissions（没有显式匿名权限就不允许访问）

    “0”这个值是系统默认的，没有任何限制，远程用户可以知道你机器上所有的账号、组信息、共享目录、网络传输列表(NetServerTransportEnum)等，对服务器来说这样的设置非常危险。“1”这个值是只允许非NULL用户存取SAM账号信息和共享信息。“2”这个值只有WIN2K才支持，需要注意的是，如果使用了这个值，就不能再共享资源了，所以还是推荐把数值设为“1”比较好。

    四、 安全日志

    这里需要注意：WIN2K的默认安装是不开任何安全审核的！那么就应该到“本地安全策略→审核策略”中打开相应的审核，这里需要说明的是，审核项目如果太少的话，你万一想查看的时候发现没有记录那就一点办法都没有，但是审核项目如果太多，不仅会占用大量的系统资源，而且你也可能根本没空去全部看完，这样就失去了审核的意义。推荐的审核如下：

    “账户管理”、“登录事件”、“策略更改”、“系统事件”、“账户登录事件”需要把“成功”和“失败”都打开；“对象访问”、“特权使用”、“目录服务访问”就只打开“失败”。

    与之相关的还有，在“账户策略→密码策略”中设定：“密码复杂性要求启用”，“密码长度最小值6位”，“强制密码历史5次”，“最长存留期 30天”；在“账户策略→账户锁定策略”中设定：“账户锁定3次错误登录”，“锁定时间20分钟”，“复位锁定计数20分钟”等。

    Terminal Service的安全日志默认也是不启用的，可以在“Terminal Service Configration（远程服务配置）→权限→高级”中配置安全审核，一般来说只要记录登录、注销事件就可以了。

    五、 目录和文件权限

    为了控制好服务器上用户的权限，同时也为了预防以后可能的入侵和溢出，还必须非常小心地设置目录和文件的访问权限。NT的访问权限分为：读取、写入、读取及执行、修改、列目录、完全控制。在默认的情况下，大多数的文件夹对所有用户（Everyone这个组）是完全敞开的（Full Control），你需要根据应用的需要进行权限重设。在进行权限控制时，请记住以下几个原则：

    1. 权限是累计的，如果一个用户同时属于两个组，那么他就有了这两个组所允许的所有权限。

    2. 拒绝的权限要比允许的权限高（拒绝策略会先执行）。如果一个用户属于一个被拒绝访问某个资源的组，那么不管其他的权限设置给他开放了多少权限，他也一定不能访问这个资源。

    3. 文件权限比文件夹权限高。

    4. 利用用户组来进行权限控制是一个成熟的系统管理员必须具有的优良习惯。

    5. 只给用户真正需要的权限，权限的最小化原则是安全的重要保障。

    6. 预防ICMP攻击：ICMP的风暴攻击和碎片攻击也是NT主机比较头疼的攻击方法，其实应付的方法也很简单，WIN2K自带一个Routing & Remote Access工具，这个工具初具路由器的雏形。在这个工具中，我们可以轻易地定义输入输出包过滤器。如设定输入ICMP代码255丢弃就表示丢弃所有的外来ICMP报文。

要注意

    实际上，安全和应用在很多时候是矛盾的，因此，你需要在其中找到平衡点，毕竟服务器是给用户用的，如果安全原则妨碍了系统应用，那么这个安全原则也不是一个好的原则。

    网络安全是一项系统工程，它不仅有空间的跨度，还有时间的跨度。很多朋友（包括部分系统管理员）认为进行了安全配置的主机就是安全的，其实这里有个误区，我们只能说一台主机在一定的情况下一定的时间内是安全的，随着网络结构的变化、新的漏洞的发现、管理员和用户的操作，主机的安全状况是随时随地变化着的，只有让安全意识和安全制度贯穿整个过程才能做到真正的安全。

本站出售 音乐程序 分2种ACCESS版本跟MSSQL版本，包括35000首歌曲文件
联系QQ ：19755866 805570
演示地址http://www.nbsky.net/
主机租用托管
2003-6-26 10:56
亚当夏娃
落伍者

积分 5126
发贴 5106
注册 2002-9-22
来自 八闽社区
有了

晶
2003-6-26 10:56
nbinfo
落伍者

积分 6689
发贴 6501
注册 2002-8-7
来自 CHINA 中国 SEX
西瓜 拿到金华去

本站出售 音乐程序 分2种ACCESS版本跟MSSQL版本，包括35000首歌曲文件
联系QQ ：19755866 805570
演示地址http://www.nbsky.net/
主机租用托管
2003-6-26 10:57
夜客在线
落伍者

积分 3042
发贴 3146
注册 2001-5-18
http://www.yearcon.com/showthread.php?s=&threadid=3789

Serv_UPlus FTP 电影下载
http://www.AVfox.com
http://www.yearcon.com

2003-6-26 10:58

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.067814 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网络技术专版 - 找到一个很好的WIN2000设置安全教程！！！ - powered by Discuz!

落伍者论坛 » 网络技术专版 » 找到一个很好的WIN2000设置安全教程！！！

作者:
标题: 找到一个很好的WIN2000设置安全教程！！！ 上一主题 | 下一主题
木耳
搬凳子晒太阳

积分 3727
发贴 3458
注册 2001-9-28
来自 青马企业
找到一个很好的WIN2000设置安全教程！！！

《Windows 2000 安全设置检查清单》

    本文并没有什么高深的东西，所谓的清单，也并不完善，很多东西要等以后慢慢加了，希望能给管理员作一参考。
    具体清单如下：
初级安全篇
1.物理安全
    服务器应该安放在安装了监视器的隔离房间内，并且监视器要保留15天以上的摄像记录。另外，机箱,键盘，电脑桌抽屉要上锁，以确保旁人即使进入房间也无法使用电脑，钥匙要放在另外的安全的地方。
2.停掉Guest 帐号

    在计算机管理的用户里面把guest帐号停用掉，任何时候都不允许guest帐号登陆系统。为了保险起见，最好给guest 加一个复杂的密码，你可以打开记事本，在里面输入一串包含特殊字符,数字，字母的长字符串，然后把它作为guest帐号的密码拷进去。
3．限制不必要的用户数量
    去掉所有的duplicate user 帐户, 测试用帐户, 共享帐号，普通部门帐号等等。用户组策略设置相应权限，并且经常检查系统的帐户，删除已经不在使用的帐户。这些帐户很多时候都是黑客们入侵系统的突破口，系统的帐户越多，黑客们得到合法用户的权限可能性一般也就越大。国内的nt/2000主机，如果系统帐户超过10个，一般都能找出一两个弱口令帐户。我曾经发现一台主机197个帐户中竟然有180个帐号都是弱口令帐户。
4．创建2个管理员用帐号

    虽然这点看上去和上面这点有些矛盾，但事实上是服从上面的规则的。 创建一个一般权限帐号用来收信以及处理一些日常事物，另一个拥有Administrators 权限的帐户只在需要的时候使用。可以让管理员使用 “ RunAS” 命令来执行一些需要特权才能作的一些工作，以方便管理。
5．把系统administrator帐号改名

    大家都知道，windows 2000 的administrator帐号是不能被停用的，这意味着别人可以一遍又一边的尝试这个帐户的密码。把Administrator帐户改名可以有效的防止这一点。当然，请不要使用Admin之类的名字，改了等于没改，尽量把它伪装成普通用户，比如改成：guestone 。
6．创建一个陷阱帐号

    什么是陷阱帐号? Look!>创建一个名为” Administrator”的本地帐户，把它的权限设置成最低，什么事也干不了的那种，并且加上一个超过10位的超级复杂密码。这样可以让那些 Scripts s忙上一段时间了，并且可以借此发现它们的入侵企图。或者在它的login scripts上面做点手脚。嘿嘿，够损！
7.把共享文件的权限从”everyone”组改成“授权用户”
    “everyone” 在win2000中意味着任何有权进入你的网络的用户都能够获得这些共享资料。任何时候都不要把共享文件的用户设置成”everyone”组。包括打印共享，默认的属性就是”everyone”组的，一定不要忘了改。
8.使用安全密码
    一个好的密码对于一个网络是非常重要的，但是它是最容易被忽略的。前面的所说的也许已经可以说明这一点了。一些公司的管理员创建帐号的时候往往用公司名，计算机名，或者一些别的一猜就到的东西做用户名，然后又把这些帐户的密码设置得N简单，比如 “welcome” “iloveyou” “letmein”或者和用户名相同等等。这样的帐户应该要求用户首此登陆的时候更改成复杂的密码，还要注意经常更改密码。前些天在IRC和人讨论这一问题的时候，我们给好密码下了个定义：安全期内无法破解出来的密码就是好密码，也就是说，如果人家得到了你的密码文档，必须花43天或者更长的时间才能破解出来，而你的密码策略是42天必须改密码。
9.设置屏幕保护密码
    很简单也很有必要，设置屏幕保护密码也是防止内部人员破坏服务器的一个屏障。注意不要使用OpenGL和一些复杂的屏幕保护程序，浪费系统资源，让他黑屏就可以了。还有一点，所有系统用户所使用的机器也最好加上屏幕保护密码。
10．使用NTFS格式分区

    把服务器的所有分区都改成NTFS格式。NTFS文件系统要比FAT,FAT32的文件系统安全得多。这点不必多说，想必大家得服务器都已经是NTFS的了。
11．运行防毒软件

    我见过的Win2000/Nt服务器从来没有见到有安装了防毒软件的，其实这一点非常重要。一些好的杀毒软件不仅能杀掉一些著名的病毒，还能查杀大量木马和后门程序。这样的话，“黑客”们使用的那些有名的木马就毫无用武之地了。不要忘了经常升级病毒库
12．保障备份盘的安全
    一旦系统资料被破坏，备份盘将是你恢复资料的唯一途径。备份完资料后，把备份盘防在安全的地方。千万别把资料备份在同一台服务器上，那样的话，还不如不要备份。
中级安全篇

1．利用win2000的安全配置工具来配置策略

    微软提供了一套的基于MMC(管理控制台)安全配置和分析工具，利用他们你可以很方便的配置你的服务器以满足你的要求。具体内容请参考微软主页：
http://www.microsoft.com/windows2000/techinfo/howitworks/security/sctoolset.asp
2．关闭不必要的服务
    windows 2000 的 Terminal Services（终端服务），IIS ,和RAS都可能给你的系统带来安全漏洞。为了能够在远程方便的管理服务器，很多机器的终端服务都是开着的，如果你的也开了，要确认你已经正确的配置了终端服务。有些恶意的程序也能以服务方式悄悄的运行。要留意服务器上面开启的所有服务，中期性(每天)的检查他们。下面是C2级别安装的默认服务：

Computer Browser service TCP/IP NetBIOS Helper
Microsoft DNS server Spooler
NTLM SSP Server
RPC Locator WINS
RPC service Workstation
Netlogon Event log
3．关闭不必要的端口
    关闭端口意味着减少功能，在安全和功能上面需要你作一点决策。如果服务器安装在防火墙的后面，冒的险就会少些，但是，永远不要认为你可以高枕无忧了。用端口扫描器扫描系统所开放的端口，确定开放了哪些服务是黑客入侵你的系统的第一步。\system32\drivers\etc\services 文件中有知名端口和服务的对照表可供参考。具体方法为：
网上邻居>属性>本地连接>属性>internet 协议(tcp/ip)>属性>高级>选项>tcp/ip筛选>属性 打开tcp/ip筛选，添加需要的tcp,udp,协议即可。
4．打开审核策略
    开启安全审核是win2000最基本的入侵检测方法。当有人尝试对你的系统进行某些方式（如尝试用户密码,改变帐户策略，未经许可的文件访问等等）入侵的时候，都会被安全审核记录下来。很多的管理员在系统被入侵了几个月都不知道，直到系统遭到破坏。下面的这些审核是必须开启的，其他的可以根据需要增加：

策略　　　　　　　设置

审核系统登陆事件 成功，失败
审核帐户管理 成功，失败
审核登陆事件 成功，失败
审核对象访问 成功
审核策略更改 成功，失败
审核特权使用 成功，失败
审核系统事件 成功，失败
5.开启密码密码策略

策略　　　　　 设置
密码复杂性要求 启用
密码长度最小值 6位
强制密码历史 5 次
强制密码历史 42 天
6．开启帐户策略
策略　　　　　　　 设置
复位帐户锁定计数器 20分钟
帐户锁定时间 20分钟
帐户锁定阈值 3次
7．设定安全记录的访问权限
    安全记录在默认情况下是没有保护的，把他设置成只有Administrator和系统帐户才有权访问。
8．把敏感文件存放在另外的文件服务器中
    虽然现在服务器的硬盘容量都很大，但是你还是应该考虑是否有必要把一些重要的用户数据(文件，数据表，项目文件等)存放在另外一个安全的服务器中，并且经常备份它们。
9.不让系统显示上次登陆的用户名
    默认情况下，终端服务接入服务器时，登陆对话框中会显示上次登陆的帐户明，本地的登陆对话框也是一样。这使得别人可以很容易的得到系统的一些用户名，进而作密码猜测。修改注册表可以不让对话框里显示上次登陆的用户名，具体是：

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\DontDisplayLastUserName把 REG_SZ 的键值改成 1 .
10．禁止建立空连接
    默认情况下，任何用户通过通过空连接连上服务器，进而枚举出帐号，猜测密码。我们可以通过修改注册表来禁止建立空连接：
Local_Machine\System\CurrentControlSet\Control
\LSA-RestrictAnonymous 的值改成”1”即可。
11.到微软网站下载最新的补丁程序

    很多网络管理员没有访问安全站点的习惯，以至于一些漏洞都出了很久了，还放着服务器的漏洞不补给人家当靶子用。谁也不敢保证数百万行以上代码的2000不出一点安全漏洞，经常访问微软和一些安全站点，下载最新的service pack和漏洞补丁，是保障服务器长久安全的唯一方法。

高级篇
1. 关闭 DirectDraw
    这是C2级安全标准对视频卡和内存的要求。关闭DirectDraw可能对一些需要用到DirectX的程序有影响（比如游戏，在服务器上玩星际争霸？我晕..$%$^%^&??），但是对于绝大多数的商业站点都应该是没有影响的。
    修改注册表 HKLM\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\DCI 的Timeout(REG_DWORD)为 0 即可。
2.关闭默认共享

    win2000安装好以后，系统会创建一些隐藏的共享，你可以在cmd下打 net share 查看他们。网上有很多关于IPC入侵的文章，相信大家一定对它不陌生。要禁止这些共享 ，打开 管理工具>计算机管理>共享文件夹>共享 在相应的共享文件夹上按右键，点停止共享即可，不过机器重新启动后，这些共享又会重新开启的。
    C$ D$ E$ 每个分区的根目录。Win2000 Pro版中，只有Administrator和Backup Operators组成员才可连接，Win2000 Server版本Server Operatros组也可以连接到这些共享目录。
    ADMIN$ %SYSTEMROOT% 远程管理用的共享目录。它的路径永远都指向Win2000的安装路径，比如 c:\winntFAX$ 在Win2000 Server中，FAX$在fax客户端发传真的时候会到。
    IPC$ 空连接。IPC$共享提供了登录到系统的能力。

    NetLogon 这个共享在Windows 2000 服务器的Net Login 服务在处理登陆域请求时用到

    PRINT$ %SYSTEMROOT%\SYSTEM32\SPOOL\DRIVERS 用户远程管理打印机
3.禁止dump file的产生
    dump文件在系统崩溃和蓝屏的时候是一份很有用的查找问题的资料(不然我就照字面意思翻译成垃圾文件了)。然而，它也能够给黑客提供一些敏感信息比如一些应用程序的密码等。要禁止它，打开 控制面板>系统属性>高级>启动和故障恢复 把 写入调试信息 改成无。要用的时候，可以再重新打开它。
4.使用文件加密系统EFS
    Windows2000 强大的加密系统能够给磁盘，文件夹，文件加上一层安全保护。这样可以防止别人把你的硬盘挂到别的机器上以读出里面的数据。记住要给文件夹也使用EFS,而不仅仅是单个的文件。 有关EFS的具体信息可以查看http://www.microsoft.com/windows2000/techinfo/howitworks/security/encrypt.asp

5.加密temp文件夹

    一些应用程序在安装和升级的时候，会把一些东西拷贝到temp文件夹，但是当程序升级完毕或关闭的时候，它们并不会自己清除temp文件夹的内容。所以，给temp文件夹加密可以给你的文件多一层保护。
6.锁住注册表

    在windows2000中，只有administrators和Backup Operators才有从网络上访问注册表的权限。如果你觉得还不够的话，可以进一步设定注册表访问权限，详细信息请参考：
http://support.microsoft.com/support/kb/articles/Q153/1/83.asp
7.关机时清除掉页面文件

    页面文件也就是调度文件，是win2000用来存储没有装入内存的程序和数据文件部分的隐藏文件。一些第三方的程序可以把一些没有的加密的密码存在内存中，页面文件中也可能含有另外一些敏感的资料。 要在关机的时候清楚页面文件，可以编辑注册表HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management把ClearPageFileAtShutdown的值设置成1。
8.禁止从软盘和CD Rom启动系统
    一些第三方的工具能通过引导系统来绕过原有的安全机制。如果你的服务器对安全要求非常高，可以考虑使用可移动软盘和光驱。把机箱锁起来扔不失为一个好方法。
9.考虑使用智能卡来代替密码
    对于密码，总是使安全管理员进退两难，容易受到 10phtcrack 等工具的攻击，如果密码太复杂，用户把为了记住密码，会把密码到处乱写。如果条件允许，用智能卡来代替复杂的密码是一个很好的解决方法。
10.考虑使用IPSec

    正如其名字的含义，IPSec 提供 IP 数据包的安全性。IPSec 提供身份验证、完整性和可选择的机密性。发送方计算机在传输之前加密数据，而接收方计算机在收到数据之后解密数据。利用IPSec可以使得系统的安全性能大大增强。有关IPSes的详细信息可以参考： http://www.microsoft.com/china/technet/security/ipsecloc.asp
2002-11-15 15:32
木耳
搬凳子晒太阳

积分 3727
发贴 3458
注册 2001-9-28
来自 青马企业
还有一篇也比较不错噢！

《Windows 2000漏洞集锦》

    对于Windows 2000的强大的功能和全新的构架我们都不得不叹服微软的实力，可以预见Windows 2000将成为新一代服务器操作系统的主流，同时也成为黑客攻击的对象。但是由于新的Windows2000的全新构架很大程度都依赖于Active Directory(又称之为AD)，这使得许许多多的管理员在忙于适应新的操作系统，和对原来的资料进行系统的迁移，而对Windows 2000的安全性问题还没有引起足够重视。

    本文详细介绍黑客在攻击Windows 2000系统时经常利用的一些漏洞和具体步骤以及应对策略，让网络系统管理员在维护系统时尽量做到有的放矢。有一句话非常有道理：“世界上没有绝对愚蠢的系统，只有绝对愚蠢的管理员。”只要我们的网络管理员能够细心地维护系统，相信黑客们是没有可乘之机的。
登陆输入法漏洞
    这里我们首先介绍一个登录错误，也就是常说的输入法漏洞。当我们启动Windows2000进行到登录验证的提示界面时，任何用户都可以打开各种输入法的帮助栏，并且可以利用其中具有的一些功能访问文件系统，这也就是说我们可以绕过了Windows2000的用户登录验证机制，并且能以最高管理员权限访问整个系统。所以说这个漏洞的危害性是很大的，而且当我们进入系统后，还可以利用Terminal Server远程通信这个漏洞对系统进行攻击。默认的Windows2000系统自带的输入法中有这个漏洞的是：智能ABC,微软拼音,内码,全拼,双拼,郑码。所以就我感觉而言这个漏洞是首要修补的漏洞。
1、把不需要的输入法删除掉，例如郑码等。
2、但是毕竟我们不能把所有的自带输入法都删除，如果我们要使用有漏洞的输入法也可以把那个输入法的帮助文件删除掉。这些帮助文件通常在win2000的安装目录下(如:C:\WINNT)的\help目录下，对应的帮助文件是：
※ WINIME.CHM 输入法操作指南
※ WINSP.CHM 双拼输入法帮助
※ WINZM.CHM 郑码输入法帮助
※ WINPY.CHM 全拼输入法帮助
※ WINGB.CHM 内码输入法帮助
3、微软公司对于此问题发布了MS00-069安全公告，并在互联网上给出了简体中文Windows2000和英文版Windows2000的补丁。所以请尽快打上补丁。
NetBIOS的信息泄漏
     接下来我们谈一下NetBIOS的共享入侵.这个问题从NT刚发行到现在就从来没有解决。而且它一直由来都是NT系统构架最常见的入侵手段。特别值得一提的就是那个IPC$Null session(空会话)在NT系统里都是已知的安全隐患。虽然打了SP3后可以通过修改注册表来对其进行限制。但不知道为什么Windows2000还是原封不动地保留着这个空对话。那么就让我们来看看空会话能给入侵者带来什么样的信息：
net use \\server\IPC$ "" /user:"" //此命令用来建立一个空会话
net view \\server //此命令用来查看远程服务器的共享资源
服务器名称　　　　　　注释
-------------------------------------------------------
\\pc1
\\pc2
命令成功完成。
net time \\server //此命令用来得到一个远程服务器的当前时间。
nbtstat -A server //此命令用来得到远程服务器的NetBIOS用户名字表
NetBIOS Remote Machine Name Table
Name Type Status
---------------------------------------------
NULL <00> UNIQUE Registered
NULL <20> UNIQUE Registered
INTERNET <00> GROUP Registered
XIXI <03> UNIQUE Registered
INet~Services <1C> GROUP Registered
IS~NULL...... <00> UNIQUE Registered
INTERNET <1E> GROUP Registered
ADMINISTATOR <03> UNIQUE Registered
INTERNET <1D> UNIQUE Registered
..__MSBROWSE__.<01> GROUP Registered
MAC Address = 00-54-4F-34-D8-80

    看看，只不过用了几个系统自带的命令就得到了如此多的信息，那么我们有什么办法可以不让别人轻易得到这么多信息哪？
    仅靠单纯的修改注册表是一劳永逸的。

HKEY-LOCAL_MACHINE\SYSTEM\CurrentControSet\Control\LSA
Value Name: RestrictAnonymous
Data Type: REG_DWORD
Value: 1
    但如果一些服务你并不需要开放共享的话。那为什么不禁止它呢？在Windows2000里的方法和NT4的略有不同。它没有限制TCP/IP绑定在NetBISO上，但是我们可以在Internet协议(TCP/IP)属性的设置面板里选取高级(V)选项，然后选择TCP/IP 筛选，接着点选启用TCP/IP筛选，最后在TCP端口点选只允许，然后就可以添加你所想开放的服务的端口了。
奇怪的系统崩溃特性
    此外Windows 2000有一个比较奇怪的特性，使用系统的终端用户可以通过按住右Ctrl，同时Press两次Scrool Lock按键，就轻易可以让整个Windows2000系统完全的崩溃。但同时又在C:\WinNT\下dump完整的当前系统内存记录，内存记录文件名是memory.dmp。当然，这个奇怪的特性默认状态下是关闭的，但是我们可以通过修改注册表的方法把它激活：
1、运行regedt32.exe （Windows2000的32位注册表编辑器）
2、选择主键：
      HKEY_LOCAL_MACHINE\
      然后找到SYSTEM\下的CurrentControlSet\
      选择Services\
      进入i8042prt\中的Parameters
3、新建一个双字节值
4、将键名为CrashOnCtrlScroll
5、然后在设置一个不为零的值。
6、退出重启
    当这一切做完后，你就可以尝试让系统崩溃了，按下按键后的效果为黑屏，将会出现以下信息：
*** STOP: 0x000000E2 (0x00000000,0x00000000,0x00000000,0x00000000)
The end-user manually generated the crashdump.
    值得注意的是，这个奇怪的特性在WindowsNT4中也存在，不知道是不是微软程序员作测试的一个小功能。不过要是有黑客或者病毒利用它，也是很危险的。
Telnet的拒绝服务攻击
    Windows中的Telnet一直以来都是网络管理员们最喜爱的网络实用工具之一，但是一个新的漏洞表明，在Windows2000中Telnet在守护其进程时，在已经被初始化的会话还未被复位的情况下很容易受到一种普通的拒绝服务攻击。而在2000年的2月份，拒绝服务攻击几乎成为了所有大型网站的恶梦。
    Telnet连接后，在初始化的对话还未被复位的情况下，在一定的时间间隔之后，此时如果连接用户还没有提供登录的用户名及密码，Telnet的对话将会超时。直到用户输入一个字符之后连接才会被复位。如果恶意用户连接到Windows2000的Telnet守护进程中，并且对该连接不进行复位的话，他就可以有效地拒绝其他的任何用户连接该Telnet服务器，主要是因为此时Telnet的客户连接数的最大值是1。在此期间任何其他试图连接该Telnet服务器的用户都将会收到如下错误信息：

Microsoft Windows Workstation allows only 1 Telnet Client LicenseServer has closed connection

    察看“列出当前用户”选项时并不会显示超时的会话，因为该会话还没有成功地通过认证。
IIS服务泄漏文件内容
    这是一个NSFOCUS安全小组发现的漏洞。当微软IIS 4.0/5.0(远东地区版本)在处理包含有不完整的双字节编码字符的HTTP命令请求时，会导致WEB目录下的文件内容被泄漏给远程攻击者。
    Microsoft IIS远东地区版本包括中文(简体/繁体),日文，韩文版，由于特定的文字格式使它们都是使用的双字节编码格式。而当IIS接收到用户提交的一个HTTP请求时，如果文件名中包含非ASCII字符，IIS会检查这个字符是否为双字节编码中的前导字符(例如，日文的前导字符包含两段字符：0x81-0x9F, 0xE0-0xFC)。如果是前导字符，它会继续检查下一个字符是否为结尾字符。如果没有下一个字符，IIS会简单地丢弃这个前导字符，因为它并没有构成一个完整的双字节编码。然而，这种处理将导致IIS打开不同的文件而不是用户在请求中指定的文件。
    攻击者通过提交一个特殊格式的URL, 可以使IIS使用某个ISAPI动态链接库打开某种它所不能解释的类型的文件，并获得该文件的内容。依赖于系统安装的ISAPI应用程序的类型，攻击者可能获得WEB根目录或者虚拟目录下的文件内容，这些文件可以是普通文本文件(.asp, .ini, .asa等等)，也可以是二进制文件(.exe等等)。
    黑客们会使用Unicode的方法利用这个漏洞：
    Unicode（统一的字符编码标准, 采用双字节对字符进行编码）可以说是近一段时期以来最为流行的攻击入侵手段，仅国内近期就有江民公司等几个大的网站被这种入侵手段攻击。那我们就来谈一下这个很容易的利用Unicode漏洞配合IIS的漏洞进行入侵吧。
    上面我们提到过由于某些双字节的Windows2000在处理某些特殊字符时与英文版本不同，然而利用这种IIS的漏洞，攻击者就可以通过这些特殊字符绕过IIS的目录审计远程执行任意命令。
http://server/scripts/..Á../winnt/system32/cmd.exe?/c+dir+c:\
    黑客们其实只要下面两句很简单的指令绕过IIS的审计就能够对网站的页面进行改写，所谓的黑了一个网站就是这么的简单。
http://server/scripts/..Á../winnt/system32/cmd.exe?/c+copy+c:\winnt\system32\cmd.exe+d:\inetpub\scripts\123.exe
http://server/scripts/123.exe?/c+echo+黑掉啦?+>+c:\inetpub\wwwroot\default.asp
    这个问题已经在IIS 4.0 + SP6中得到解决，然而微软却让它在IIS 5.0中再度出现。
    但该漏洞不会影响包括英语版在内的其他语言版本的IIS 4.0/5.0。
MS SQL Server的SA空密码攻击
    在Windows2000中，企业级的用户一般都会用到另一个微软的产品，这个产品就是数据库管理软件 MS SQL Server，但是在与MS SQL Server配合使用中，我们发现了很多的问题。最后我们就简单讲一下安装了MS SQL Server的Windows2000的网络操作系统普遍面临的安全问题。
    在安装MS SQL Server后，MS SQL Server会将产生一个默认的SA用户，而且初始密码在管理员没有设置的情况下为空。但是SA是SQL Server中非常重要的安全模块成员，这样一来黑客们就可以通过SQL Server的客户端进行数据库远程连接，然后再通过SQL的远程数据库管理命令xp_cmdshell stored procedure(扩展存储过程)来进行命令操作:
xp_cmdshell "net user id password /add"
Xp_cmdshell "net localgroup Administrators id /add"
    就以上两条简单的命令入侵者就能在MS SQL Server的服务器上马上新建一个管理员级别的Administrators组的用户。所以我们这里提醒各位网管大人，在安装好SQL Server您需要做的第一件事就是把SA的空密码立即进行修改。这个问题就不要我告诉你应该在哪里改了吧?
    而且在一般情况下，一些功能对管理员来说也是没有必要的。如果你不需要MS SQL Server 的xp_cmdshell(use sp_dropextendedproc "xp_cmdshell" [image] 这项功能就不要把xp_cmdshell extended stored proc(扩展存储过程)命令功能留着。

    我们只需要在isql窗口中输入：

use master
sp_dropextendedproc 'xp_cmdshell'

    然后打上Service Pack 3，这里提醒管理员们一下，一定要经常留意微软的补丁包文件，并且注意及时的把系统和软件更新到最新的补丁。
    本文中我们讲述了几个近期来最为流行的漏洞和攻击方法，他们实现入侵是如此的方便，这里可有不少的网友会认为Windows2000是一个不安全的操作系统，但如果你这样的认为那就说明我的文章还没有写明白，所以在最后我要强调一下，只要我们常打补丁包，正确的给系统加设密码，我们的安全率就在85％左右。
2002-11-15 15:34

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.027216 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网络技术专版 - 系统进程全攻略！！！！|经典| - powered by Discuz!

落伍者论坛 » 网络技术专版 » 系统进程全攻略！！！！|经典|

作者:
标题: 系统进程全攻略！！！！|经典| 上一主题 | 下一主题
龙慧
落伍者

积分 4752
发贴 4638
注册 2002-11-20
系统进程全攻略！！！！|经典|

最基本的系统进程（也就是说，这些进程是系统运行的基本条件，有了这些进程，系统就能正常运行）:
smss.exe Session Manager
csrss.exe 子系统服务器进程
winlogon.exe 管理用户登录
services.exe 包含很多系统服务
lsass.exe 管理 IP 安全策略以及启动 ISAKMP/Oakley (IKE) 和 IP 安全驱动程序。(系统服务)
产生会话密钥以及授予用于交互式客户/服务器验证的服务凭据(ticket)。(系统服务)
svchost.exe 包含很多系统服务
svchost.exe
SPOOLSV.EXE 将文件加载到内存中以便迟后打印。(系统服务)
explorer.exe 资源管理器
internat.exe 托盘区的拼音图标
附加的系统进程（这些进程不是必要的，你可以根据需要通过服务管理器来增加或减少）:
mstask.exe 允许程序在指定时间运行。(系统服务)
regsvc.exe 允许远程注册表操作。(系统服务)
winmgmt.exe 提供系统管理信息(系统服务)。
inetinfo.exe 通过 Internet 信息服务的管理单元提供 FTP 连接和管理。(系统服务)
tlntsvr.exe 允许远程用户登录到系统并且使用命令行运行控制台程序。(系统服务)
允许通过 Internet 信息服务的管理单元管理 Web 和 FTP 服务。(系统服务)
tftpd.exe 实现 TFTP Internet 标准。该标准不要求用户名和密码。远程安装服务的一部分。(系统服务)
termsrv.exe 提供多会话环境允许客户端设备访问虚拟的 Windows 2000 Professional 桌面会话以及运行在服务器上的基
于 Windows 的程序。(系统服务)
dns.exe 应答对域名系统(DNS)名称的查询和更新请求。(系统服务)
以下服务很少会用到，上面的服务都对安全有害，如果不是必要的应该关掉
tcpsvcs.exe 提供在 PXE 可远程启动客户计算机上远程安装 Windows 2000 Professional 的能力。(系统服务)
支持以下 TCP/IP 服务：Character Generator, Daytime, Discard, Echo, 以及 Quote of the Day。(系统服务)
ismserv.exe 允许在 Windows Advanced Server 站点间发送和接收消息。(系统服务)
ups.exe 管理连接到计算机的不间断电源(UPS)。(系统服务)
wins.exe 为注册和解析 NetBIOS 型名称的 TCP/IP 客户提供 NetBIOS 名称服务。(系统服务)
llssrv.exe License Logging Service(system service)
ntfrs.exe 在多个服务器间维护文件目录内容的文件同步。(系统服务)
RsSub.exe 控制用来远程储存数据的媒体。(系统服务)
locator.exe 管理 RPC 名称服务数据库。(系统服务)
lserver.exe 注册客户端许可证。(系统服务)
dfssvc.exe 管理分布于局域网或广域网的逻辑卷。(系统服务)
clipsrv.exe 支持“剪贴簿查看器”，以便可以从远程剪贴簿查阅剪贴页面。(系统服务)
msdtc.exe 并列事务，是分布于两个以上的数据库，消息队列，文件系统，或其它事务保护资源管理器。(系统服务)
faxsvc.exe 帮助您发送和接收传真。(系统服务)
cisvc.exe Indexing Service(system service)
dmadmin.exe 磁盘管理请求的系统管理服务。(系统服务)
mnmsrvc.exe 允许有权限的用户使用 NetMeeting 远程访问 Windows 桌面。(系统服务)
netdde.exe 提供动态数据交换 (DDE) 的网络传输和安全特性。(系统服务)
smlogsvc.exe 配置性能日志和警报。(系统服务)
rsvp.exe 为依赖质量服务(QoS)的程序和控制应用程序提供网络信号和本地通信控制安装功能。(系统服务)
RsEng.exe 协调用来储存不常用数据的服务和管理工具。(系统服务)
RsFsa.exe 管理远程储存的文件的操作。(系统服务)
grovel.exe 扫描零备份存储(SIS)卷上的重复文件，并且将重复文件指向一个数据存储点，以节省磁盘空间。(系统服务)
SCardSvr.exe 对插入在计算机智能卡阅读器中的智能卡进行管理和访问控制。(系统服务)
snmp.exe 包含代理程序可以监视网络设备的活动并且向网络控制台工作站汇报。(系统服务)
snmptrap.exe 接收由本地或远程 SNMP 代理程序产生的陷阱消息，然后将消息传递到运行在这台计算机上 SNMP 管理程序
。(系统服务)
UtilMan.exe 从一个窗口中启动和配置辅助工具。(系统服务)
msiexec.exe 依据 .MSI 文件中包含的命令来安装、修复以及删除软件。(系统服务)

详细说明：

win2k运行进程
Svchost.exe
Svchost.exe文件对那些从动态连接库中运行的服务来说是一个普通的主机进程名。Svhost.exe文件定位
在系统的%systemroot%\system32文件夹下。在启动的时候，Svchost.exe检查注册表中的位置来构建需要
加载的服务列表。这就会使多个Svchost.exe在同一时间运行。每个Svchost.exe的回话期间都包含一组服务，
以至于单独的服务必须依靠Svchost.exe怎样和在那里启动。这样就更加容易控制和查找错误。
Svchost.exe 组是用下面的注册表值来识别。

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Svchost
每个在这个键下的值代表一个独立的Svchost组，并且当你正在看活动的进程时，它显示作为一个单独的
例子。每个键值都是REG_MULTI_SZ类型的值而且包括运行在Svchost组内的服务。每个Svchost组都包含一个
或多个从注册表值中选取的服务名，这个服务的参数值包含了一个ServiceDLL值。
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Service

更多的信息
为了能看到正在运行在Svchost列表中的服务。
开始－运行－敲入cmd
然后在敲入 tlist -s （tlist 应该是win2k工具箱里的冬冬）
Tlist 显示一个活动进程的列表。开关 -s 显示在每个进程中的活动服务列表。如果想知道更多的关于
进程的信息，可以敲 tlist pid。

Tlist 显示Svchost.exe运行的两个例子。
0 System Process
8 System
132 smss.exe
160 csrss.exe Title:
180 winlogon.exe Title: NetDDE Agent
208services.exe
Svcs: AppMgmt,Browser,Dhcp,dmserver,Dnscache,Eventlog,lanmanserver,LanmanWorkstation,LmHosts,Messenger,PlugPlay,ProtectedStorage,seclogon,TrkWks,W32Time,Wmi
220 lsass.exe Svcs: Netlogon,PolicyAgent,SamSs
404 svchost.exe Svcs: RpcSs
452 spoolsv.exe Svcs: Spooler
544 cisvc.exe Svcs: cisvc
556 svchost.exe Svcs: EventSystem,Netman,NtmsSvc,RasMan,SENS,TapiSrv
580 regsvc.exe Svcs: RemoteRegistry
596 mstask.exe Svcs: Schedule
660 snmp.exe Svcs: SNMP
728 winmgmt.exe Svcs: WinMgmt
852 cidaemon.exe Title: OleMainThreadWndName
812 explorer.exe Title: Program Manager
1032 OSA.EXE Title: Reminder
1300 cmd.exe Title: D:\WINNT5\System32\cmd.exe - tlist -s
1080 MAPISP32.EXE Title: WMS Idle
1264 rundll32.exe Title:
1000 mmc.exe Title: Device Manager
1144 tlist.exe
在这个例子中注册表设置了两个组。
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Svchost:
netsvcs: Reg_Multi_SZ: EventSystem Ias Iprip Irmon Netman Nwsapagent Rasauto Rasman Remoteaccess SENS Sharedaccess Tapisrv Ntmssvc
rpcss :Reg_Multi_SZ: RpcSs

smss.exe

csrss.exe

这个是用户模式Win32子系统的一部分。csrss代表客户/服务器运行子系统而且是一个基本的子系统
必须一直运行。csrss 负责控制windows，创建或者删除线程和一些16位的虚拟MS-DOS环境。

explorer.exe
这是一个用户的shell（我实在是不知道怎么翻译shell），在我们看起来就像任务条，桌面等等。这个
进程并不是像你想象的那样是作为一个重要的进程运行在windows中，你可以从任务管理器中停掉它，或者重新启动。
通常不会对系统产生什么负面影响。

internat.exe

这个进程是可以从任务管理器中关掉的。
internat.exe在启动的时候开始运行。它加载由用户指定的不同的输入点。输入点是从注册表的这个位置
HKEY_USERS\.DEFAULT\Keyboard Layout\Preload 加载内容的。
internat.exe 加载“EN”图标进入系统的图标区，允许使用者可以很容易的转换不同的输入点。
当进程停掉的时候，图标就会消失，但是输入点仍然可以通过控制面板来改变。

lsass.exe
这个进程是不可以从任务管理器中关掉的。
这是一个本地的安全授权服务，并且它会为使用winlogon服务的授权用户生成一个进程。这个进程是
通过使用授权的包，例如默认的msgina.dll来执行的。如果授权是成功的，lsass就会产生用户的进入
令牌，令牌别使用启动初始的shell。其他的由用户初始化的进程会继承这个令牌的。

mstask.exe
这个进程是不可以从任务管理器中关掉的。
这是一个任务调度服务，负责用户事先决定在某一时间运行的任务的运行。

smss.exe
这个进程是不可以从任务管理器中关掉的。
这是一个会话管理子系统，负责启动用户会话。这个进程是通过系统进程初始化的并且对许多活动的，
包括已经正在运行的Winlogon，Win32（Csrss.exe）线程和设定的系统变量作出反映。在它启动这些
进程后，它等待Winlogon或者Csrss结束。如果这些过程时正常的，系统就关掉了。如果发生了什么
不可预料的事情，smss.exe就会让系统停止响应（就是挂起）。

spoolsv.exe
这个进程是不可以从任务管理器中关掉的。
缓冲（spooler）服务是管理缓冲池中的打印和传真作业。

service.exe
这个进程是不可以从任务管理器中关掉的。
大多数的系统核心模式进程是作为系统进程在运行。

System Idle Process
这个进程是不可以从任务管理器中关掉的。
这个进程是作为单线程运行在每个处理器上，并在系统不处理其他线程的时候分派处理器的时间。

winlogon.exe
这个进程是管理用户登录和推出的。而且winlogon在用户按下CTRL+ALT+DEL时就激活了，显示安全对话框。

winmgmt.exe
winmgmt是win2000客户端管理的核心组件。当客户端应用程序连接或当管理程序需要他本身的服务时这个进程初始化

taskmagr.exe
这个进程呀，哈哈，就是任务管理器了
2002-12-17 00:15

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.041398 second(s), 5 queries, Gzip enabled


落伍者论坛 - 资源讨论专栏 - windows server 2003优化设置方法 - powered by Discuz!

落伍者论坛 » 资源讨论专栏 » windows server 2003优化设置方法

作者:
标题: windows server 2003优化设置方法 上一主题 | 下一主题
伏地魔
落伍者

积分 1679
发贴 1504
注册 2002-9-20
windows server 2003优化设置方法

1，管理工具》服务》Themes 设为auto

2，打开 DirectX 的 D3D 硬件加速：
看桌面属性，设置 -> 高级 -> 疑难问答 -> 硬件加速 -> 完全。运行 dxdiag.exe，打开Display选项卡，可看到 3 项全部启用了。最后，利用Windows updates在Windows Server 2003中安装DirectX 9.0a。

3. 启用声卡：
系统安装后，声卡是禁止状态，所以要在 控制面板 -> 声音 -> 启用，重启之后再设置它在任务栏显示。
现在我们还要启用音频加速。在运行中输入Services.msc然后按回车，会出现Services 窗口，找到Windows Audio服务，双击打开，把启动类型设置为Automatic，点击Apply，然后点击Start启动该服务。
最后我们还要使用DirectX诊断工具，在运行中输入dxdiag并回车，打开Sound选项卡，把Hardware Sound Acceleration Level的滑块拖动到Full。

4. 如何启用 ASP 支持：
Windows Server 2003 默认安装，是不安装 IIS 6 的，需要另外安装。安装完 IIS 6，还需要单独开启对于 ASP 的支持。方法是：
控制面板 -> 管理工具 -> Web服务扩展 -> Active Server Pages -> 允许。

5. 如何启用 XP 的主题：
首先我们需要回到服务设置对话框启用Themes服务，在运行中输入Services.msc并按回车，找到并双击Themes这个服务，设置启动类型为Automatic，点击Apply后点Start打开这个服务。

6. 禁止关机时出现的关机理由选择项：
开始 -> 运行 -> gpedit.msc -> Computer configuration -> Administrative Templates ->
System -> Display shutdown event tracker -> 设置为 Disable。
如果是中文版，则：gpedit.msc，计算机配置 -> 管理模板 -> 系统 -> 显示关机事件跟踪 -> 禁用。

7. 如何启用摄像机，摄像头或者扫描仪等设备：
在运行中输入Services.msc并回车，找到并双击Windows Image Acquisition (WIA) 服务，设置启动类型为Automatic点击Apply后点击Start然后点击OK。

8. 在控制面板里显示全部组件：
把 Windows\inf 目录中的 sysoc.inf 文件里的 "hide" 替换掉。

9. 禁用开机 CTRL+ALT+DEL：
管理工具 -> Local Security Settings（本地安全策略） -> 本地策略 -> 安全选项 -> interactive logon: Do not require CTRL+ALT+DEL，禁用之。慎用！搞不好会进不去系统。
注意：为系统安全起见，一开始设置时管理员的密码就不要留空。

10. 可用的杀毒软件和防火墙：
Symantec Norton Antivirus Corporate 8.01
Zone Alarm 3.7.159
Norton Personal Firewall 2003

够酷BBS Gò Kù Bì Bì Sī
2003-7-1 20:40
dreamyboy
落伍者

积分 11187
发贴 11684
注册 2002-10-10
来自 飘逸网络
ok。

代理高速LINUX虚拟主机业务。联系
QQ：691932，演示：http://www.go8go.com/，
买一年送一个月，两年送三个月！MSN：
我的MSN：go8go8go@hotmail.com,ICQ:195225878
2003-7-1 20:44
網絡蝗蟲
落伍者

积分 1439
发贴 1439
注册 2003-2-14
OLD
2003-7-1 20:47
ajie.net
醒了醒了

积分 7454
发贴 7620
注册 2002-2-13
不错~
精华鼓励一下~

买地/种玉米 http://www.hyidc.com/
暑假大优惠：国际玉米 60 元 国内玉米 180元
QQ:82409 mail:info@hyidc.com
2003-7-1 20:54
longfeng
落伍者

积分 962
发贴 1016
注册 2002-11-22
来自 CLASS9飞翔论坛
看过了

I‘m Roget. 严重感谢小风子送我S35和zitiger送我1626.NET

Quote:
飞翔论坛
封刀一年，为了美好的将来～～

不再郁闷！我奋力追，追到无法追！准备禁网
2003.7.19
2003-7-1 20:58
小志
落伍者

积分 1464
发贴 1461
注册 2002-7-19
书上早就写过了。

Quote:
为了免费空间，我们要一起努力！

2003-7-1 21:20
黑夜鸟
落伍者

积分 645
发贴 708
注册 2003-6-29
t

好好学习~天天向上~30岁前~不谈对象~
2003-7-1 21:24
真爱
落伍者

积分 5101
发贴 4920
注册 2002-8-25
来自 天堂-地狱
不是支持SERVER 2003的驱动还没出来吗？？

我昨天在我机子安装了可它是个哑巴。。

装了声卡驱动也不行。。。

大量出售QQ7位无1.5元/个，8位无0.8元/个，大量买还有优惠。请联系daiya@citiz.netQQ：491854

2003-7-2 08:23
仙鹤
落伍者

积分 1001
发贴 1187
注册 2002-5-22
来自 fiyour.co.sr
tt

http://fiyour.co.sr
http://fiyour.qqvip.com/bbs
http://fiyour.qqvip.com/music
fiyour@vip.sina.com
[img]http://fiyour.1816.net/images/write03.gif[/img]
2003-7-2 13:53
check
落伍者

积分 643
发贴 643
注册 2003-3-19
来自 金光
我在驱动之家装了驱动
现在声音好了
2003-7-2 13:56

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.033334 second(s), 5 queries, Gzip enabled


无标题文档

站长心得

1.个人网站发展之我见(penzi原创) -- penzi
2.漫谈网站开发规范 -- 小林
3.[转载]当前的网络商务营利模式简要分析 -- 木耳


落伍者论坛 - 网站建设专栏 - [转载]当前的网络商务营利模式简要分析 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » [转载]当前的网络商务营利模式简要分析

作者:
标题: [转载]当前的网络商务营利模式简要分析 上一主题 | 下一主题
木耳
搬凳子晒太阳

积分 3727
发贴 3458
注册 2001-9-28
来自 青马企业
[转载]当前的网络商务营利模式简要分析

作者：浪琴派 来自：联讯浩天

这里我也来过二年了，发现这里的朋友大都是网络工作者。而且对程序特别敏感。但有大量的朋友，除了程序外，几年来一点进步也没有。当我与他们交流看法时，大家（包括我）都一样，都是怀着一份热情与梦想，想在互联网上干番事业。但理想与现实的差别常令人失望。但有一点没有变，就是以程序的追求到达了一种痴恋的程度。

于此，我就当前盈利模式提一些个人看法。

1、程序不是万能的，而且在网络商务中，程序只是一个基础。我的从事网络销售的站长朋友，他只会HTML编几个简单的网页，但生存得很好，有盈利，这说明什么呢？所谓网络商务，网络只是一个载体，利润还是要靠商务运作的。即在大家搞网络商务时，别重程序，轻商务。你辛苦建好一个站，却没人来，说明什么呢？那只是一种阿Q的精神胜利法，没有一点实际价值的。故望致力于网络商务的朋友，还是多往营销上考虑，而不是一贯追求程序的完美。毕竟，把自己定位在一个技术专才上的话，那么一个技术员永远只是领工资的，永远也当不了老板的。也永远不会给你带来超额利润的。

2、会学会自己改编程序。光盗版已经失去实际意义了。因为很多功能需要自己开发，而且盗来的程序也大都是东拼西凑的，加上美工，就成了一个漂亮的站了。有时候，看到一个漂亮的站，拼命拉下来，打开一看，尽是一堆垃圾，我想这里各位深有感促吧。

3、紧紧盯住机会，机会永远存在，只怕你抓不住。我的好友，www.51haha.com的站长，天天在QQ上也不支声的，我到上海与他见面时话也不多的，他很务实，一直辛苦地工作时，但带来的利润也是超人的。一个月二万。他是靠短讯起家的，他不太懂技术，他的总结成功经验是：努力务实的工作，还有就是盯住门户的盈利模式。

4、认真定位当前的盈利模式与机会。当前在互联网上最容易见效的是：短讯、媒体流（视频点播）以及商业零售。短讯的机会还有，因为有彩信出现，还有小灵通的短讯，都是一个盈利点。而流媒体呢，象视频与音频下载，利润丰厚到吓死你。但流媒体是有经营风险的，即不能排队目前国家禁止的黑与黄。这点经营者需要认真考虑。第三点，就是商业零售，但你必须抓住你自己熟悉的或者你本地的资源来做，象www.newsungirl.com就是一个成功的例子，认定商品后，大力经营，月进三到四万。

5、需要避免的思维是：急功就利。信息时代的泡沫已经破裂了，一夜暴富也成为过去。我的同乡，当时卖出一个www.169.com的域名就达一百万元的时代也已经过去了。大家再等着天上掉个玉米的想法几乎已经不存在了。有个域名有啥用呢？资源没有被利用起来，一切都是空的。商务的成功，就是把人力资源、物流与其他闲置资源充分地利用，再加以辛勤的劳动才行。梦想兔子撞死在树上的人，怕永远也等不会一只兔子。

6、关于卖盗版。这里有些过客在出售代码。这也未尝不可，但原包装的代码出售，真的有违良心啊。做事要换个角度看看，把自己当成作者你心里会如何想呢？你自己用也算了，还要出卖呢，而且没优化改进直接销售，那种行为是很可耻的。而且究竟能卖出多少呢？我不敢苟同。

以上匆匆写上几点，与众网友共勉。

谈谈人生，谈谈理想，一辈子其实就这么几年。
2003-3-31 02:06
Pvcp.Com
落伍者

积分 2538
发贴 2586
注册 2002-8-19
来自 www.pvcp.com℡
收了～～

网音无限精彩就在点击中...www.pvcp.com
2003-3-31 02:07
91now
看我走的多累

积分 12706
发贴 12629
注册 2002-1-27
不错!很有借鉴意思!

91Ting音乐网!!免费在线听立即进入试听!

OE下载
2003-3-31 02:12
xtyzboy
落伍者

积分 6257
发贴 6299
注册 2002-6-15
来自 www.yzdns.com
vidar速度很快啊

中国源码中心 www.cncode.com全新打造 给你最新的代码下载
主机论坛 www.hostbbs.net,买主机，卖主机，到主机论坛！为您的主机做最好的评测！
欢迎购买主机空间者发布求购信息! 欢迎主机商发布主机新闻及资料
广告位招租 QQ:59519487
2003-3-31 02:15
木耳
搬凳子晒太阳

积分 3727
发贴 3458
注册 2001-9-28
来自 青马企业

Quote:
Originally posted by xtyzboy at 2003-3-31 02:15:
vidar速度很快啊

看到好的就转过来给这边的兄弟看看。

谈谈人生，谈谈理想，一辈子其实就这么几年。
2003-3-31 02:16
xtyzboy
落伍者

积分 6257
发贴 6299
注册 2002-6-15
来自 www.yzdns.com
是啊，的确是好文章

中国源码中心 www.cncode.com全新打造 给你最新的代码下载
主机论坛 www.hostbbs.net,买主机，卖主机，到主机论坛！为您的主机做最好的评测！
欢迎购买主机空间者发布求购信息! 欢迎主机商发布主机新闻及资料
广告位招租 QQ:59519487
2003-3-31 02:20
木耳
搬凳子晒太阳

积分 3727
发贴 3458
注册 2001-9-28
来自 青马企业
睡觉去了，各位晚安！

谈谈人生，谈谈理想，一辈子其实就这么几年。
2003-3-31 02:22
木耳
搬凳子晒太阳

积分 3727
发贴 3458
注册 2001-9-28
来自 青马企业
哈哈，顶一下，让更多的朋友看

谈谈人生，谈谈理想，一辈子其实就这么几年。
2003-6-8 22:15
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20
看起来我也要睡觉了

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-6-8 22:17

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.071073 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 个人网站发展之我见(penzi原创) - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 个人网站发展之我见(penzi原创)

<< [1] [2] [3] [4] >>
作者:
标题: 个人网站发展之我见(penzi原创) 上一主题 | 下一主题
penzi
网站建设专栏--名誉版主

积分 3472
发贴 3548
注册 2002-1-6
个人网站发展之我见(penzi原创)

互联网发展到现在，已经不是一个媒介，而是形成了一个时尚。他以自己巨大的性质特点，掀起了一场

前所未有的浪潮，生活在他的影响下也发生了很大的变化。当宽带飞进千万家，上网已不不存在消费阶

层的问题了。"今天你上网了吗？"似乎成为了一个耳熟能详的口号。再后来，随着网络的需要和人的私

欲心的膨胀，强烈希望在上网有一个属于自己的家圆。于是就诞生了一个新兴的名词：网站!!

(广告之后，马上回来)
******************************************
湖南学生网，精彩每一天……
******************************************
(广告也精彩哦!!)

王晨军说，97年以前的个人网站都不应叫网站，而叫个人主页。我觉得这种说法很不对。因为，一般的

个人站点都不止一页，是一个系统的有顺序和目地性的页面总合。他是一个站点，所有我的看法就是只

要不是一页，都认为是网站。

当商业侵入网站，个人网站就随之变性。

就中国来说，个人网站多得就像，就像，就像身体里的细菌。当然分有益菌和无益菌，还有一种就是综

合合菌。"有益菌"是一种纯公益性的网站，他宣传一钟公益性质的东西，为了帮助弱者，弘扬道义，无

任何其他目地而建立的(代表是http://www.cctf.org.cn/)。"无益菌"是一种纯垃圾的东西，为了特殊商

业目地(简单的说是为了钱)和传播一些无聊思想以及无聊信息而建立的(代表是FLG网站和XXX网站)。我

们应对这类的站点唾之以沫，人人得而诛之。(啊…………呸!!不好意思，失态了)，最后一种网站就是

我们大部分网虫拥有的网站。是一种墙头机构……说不定倒那一边(代表是http://www.hnstu.com/)!

商业网站和个人网站其实是一码事。只不过前者是别人扔钱给他，后者是自己掏私房钱。目前别人扔钱

给他的先不谈了，自己掏腰包的才是重点。现在我们谈论的口号就是在别人扔钱砸我们之前，我们先自

力更生……

(广告之后，马上回来)
******************************************
6U.cn出血价￥1800 21stu.com 跳楼价￥1200
买penzi域名，他好我也好!
帮penzi联系业务，有50%的提成，腰也不酸了，腿也不疼了，真好!!
******************************************
(广告也精彩哦!!)

怎样让个人网站实现赢利，我们的口号就是：不要做大，只要做精……
个人网站生存本身就是一个，很严重的问题。空间域名，都是以MONEY交换的东西。怎样才能让自己的网

站在资金充足的情况下健康发展？

下面的问题就要涉及到你自身了。在你想做好做大自己网站之前，我先问你几个问题：1.你确定你网站

的市场定位了吗？2.你确定你网站的访问群定位了吗？3.你有什么好招数在同行中脱颖而出？4.你写了

好的商业计划了吗？5.你的资金充足吗？如果不，你找到资金来源了吗？6.你找到了资金，怎样确立最

高效益的赢利模矢了吗？7.你有充足的技术来设计和维护了吗？8.当网站需要的是一个有团队，你用什

么方法来团集人心和合作的关系？9.你保存了多少点子来不断激活网站的生命力了吗？10.你今天寄钱给

penzi了吗？寄了多少？(想钱疯了，这个不算 [image])

当你对上面的问题都有个很好的回答，恭喜您：你具备做个标准网站的资历了!!

下面谈谈我自己做网站的经验，仅供参靠(16岁以下不宜)!!

(广告之后，马上回来)
******************************************
penzi 是个大帅哥……
不信请看：http://www.htmcn.com/00.jpg
你健康，我快乐!!
(下面报道娱乐新闻：湖南大学狗仔队惊爆内幕：penzi还没有女朋友，靓女们走过路过不要错过……)
******************************************
(广告也精彩哦!!)

我是99年开始做网站的，想来已经快4年了。一事无成(靠，那你还在这里说教……)。不过这一次我充满

信心。记得99年暑假上了一个电脑陪训班，听课电脑知识。(其实老师教的那些我都会，不过在里面有整

天上机的机会)，我通过自学，慢慢掌握了FP97的用法，第一次给自己做了个人网站，传在163.com上，

可惜现在没有了。第二次是用chinaren的主页大巴。费了6个小时(妈的花了18块)，建了个人主页，把我

的那些滥小说，杂文，散文等传了上去。操，他竟然又取消了(好怀念!)后来一直学，学FW,学Flash。学

html,JS反正有关的都学了。直到感觉自己有成绩了。就开始帮别人设计网站，第一个做的是

qqmusic.com的页面，他送了我51stu.com的域名。此后就如黄河泛滥，一发不可收拾……直到去年我联

合了网迷(现网风私服的站长)，天津校园网的站长等朋友组建了无忧学网(51stu.com)，休学创业，可惜

后来资金没有到位(提醒合作一定要签合同)就不了了之了。网站到闭了，女朋友立刻就没有了。只身去

了广州……直到今年回来。可惜大学上不了!!

下面是今年大事记：
3.17-3.20 湖南学生网构架成功。
3.26 找到了新的投资商。
4.20 组建penzi工作室，不断有高手加入……
5.1 签定合同。
5.12 递交退学申请
……

对于网站的发展，广泛开展合作是一个很好的出路(点到为止)……

举例论证：湖南学生网原创版块和<长沙晚报>AND<当代商报>合作
湖南学生网商城版块和湖南金卷文化书店合作
湖南学生网人才版块和湖南金海人才市场合作
更多合作恰谈中……

湖南学生网原创基地联合湖南各大高校文学社团加入……

现在前景一片大好，下个周去中山融资……
(可以见到剑枫了)

版权所有：penzi
盗版不究……
penzi即日

[ Last edited by penzi on 2003-5-30 at 04:05 AM ]

看我的"王小波"，写我的小说去……
学我的ASP，写我的程序去……
做我的网站，发展我的前途去……
接我的业务，赚我的Money去……
……………

干吧…………
2003-5-30 01:31
情人
落伍者

积分 2552
发贴 2239
注册 2003-2-14
经典，收藏！

2003-5-30 01:32
元神
落伍者

积分 3040
发贴 3130
注册 2002-12-6
来自 深圳的布拉格
今天你DOT COM了吗?

.....{ 在落伍的都是深藏不露, 披着羊皮的"狼" }...
.......{ Jolin:说爱你 }.....{ Jolin:布拉格广场 }.........{ Koyotae:悲伤 }...
...{ 我终于找到在FlashGet中怎样关闭Pasv了,HOHOHO }...

2003-5-30 01:33
cangudu
落伍者

积分 11139
发贴 11206
注册 2002-6-29
来自 中国叛盟.COM
AD

为朋友我愿意两肋插刀,为MM我愿意插朋友两刀!
2003-5-30 01:35
柳叶吹风
落伍者

积分 1123
发贴 1091
注册 2003-5-28
这样休学有点可惜了。。。。（个人见解）

反对隐身！拒绝调戏！
You go your way , I'll go mine.
2003-5-30 01:35
bxch
落伍者

积分 1154
发贴 1089
注册 2002-11-26
来自 山东济南
打击盗版，支持原创！

820娱乐网 九天网络数据中心
2003-5-30 01:36
逸剑
落伍者

积分 1458
发贴 1351
注册 2003-2-25
真的，你該去哈佛讀書了~~~~
2003-5-30 01:51
羽叶芊芊
超级无敌小捣蛋

积分 3236
发贴 2694
注册 2003-2-23
来自 苏州
哈哈，不是吧，，笑死我了。。。

签名：芊芊
我的主页：芊芊的家
我的音乐站: http://www.7t7t.com/
2003-5-30 01:53
ujff
落伍者

积分 3
发贴 3
注册 2002-12-29
哈

高明￣！！！
2003-5-30 01:56
老虎
落伍者

积分 1924
发贴 1597
注册 2002-12-2
王晨军说，97年以前的个人网

王晨军是什么人?

[海纳百川-有容乃大][http://www.softicp.com]
2003-5-30 01:58
sdyclyq
落伍者

积分 2880
发贴 2745
注册 2002-8-12
来自 山东----菏泽
不错
2003-5-30 01:59
penzi
网站建设专栏--名誉版主

积分 3472
发贴 3548
注册 2002-1-6
俺T

看我的"王小波"，写我的小说去……
学我的ASP，写我的程序去……
做我的网站，发展我的前途去……
接我的业务，赚我的Money去……
……………

干吧…………
2003-5-30 02:26
天上人间
落伍者

积分 5008
发贴 4663
注册 2002-2-13
向你学习，，，

“你好宝贝”-以实力打造网络品牌，以时尚造就音乐主流
空间对折 服务器租用7800/年 托管3000
QQ161554 电话057465221155
2003-5-30 02:28
CooCoo
落伍者

积分 1792
发贴 1759
注册 2002-8-10
来自 我不介意你叫我帅哥.
我爱你..

舔晕楼上地,捏昏楼下地.
2003-5-30 02:29
penzi
网站建设专栏--名誉版主

积分 3472
发贴 3548
注册 2002-1-6

Quote:
Originally posted by 老虎 at 2003-5-30 01:58 AM:
王晨军说，97年以前的个人网

王晨军是什么人?

写错了!

是王晨昀

十大个人网站站长……

http://www.itunion.com/book/index.asp
http://www.donews.com/donews/author/5/503/

看我的"王小波"，写我的小说去……
学我的ASP，写我的程序去……
做我的网站，发展我的前途去……
接我的业务，赚我的Money去……
……………

干吧…………
2003-5-30 02:33
<< [1] [2] [3] [4] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.032800 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 漫谈网站开发规范 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 漫谈网站开发规范

<< [1] [2] >>
作者:
标题: 漫谈网站开发规范 上一主题 | 下一主题
小林
o○万帖俱乐部老八^_^ ○ o

积分 11270
发贴 11199
注册 2002-10-29
来自 『新都人.COM』
漫谈网站开发规范

    任何一个项目或者系统开发之前都需要定制一个开发约定和规则，这样有利于项目的整体风格统一、代码维护和扩展。由于Web项目开发的分散性、独立性、整合的交互性等，所以定制一套完整的约定和规则显得尤为重要。本文档将定制一系列约定和规则，他们分别包括组件团队、文件夹命名规则、文件名命名规则、程序代码编程风格、数据库设计约定。这些规则和约定需要与开发人员、设计人员和维护人员共同讨论定制，将来开发都将严格按规则或约定开发。每个团队开发都应有自己的一套规范，一个优良可行的规范可以使我们工作得心应手事半功倍，这些规范都不是唯一的标准不存在对与错，也许有些地方与你当前使用的习惯相驳，很多地方都有争议。比如很多人习惯设计数据库时采用自动增长字段，而有些人（像我这样的人）就坚决反对，各自都有比较充分的理由阐述自己的观点，所以只好根据具体情况来采用相应的策略。

    非常明显在Web项目开发中有前后台开发之分，前台开发主要是指非程序编程部分，主要职责是网站AI设计、界面设计、动画设计等。而后台开发主要是编程和网站运行平台搭建，其主要职责是设计网站数据库和网站功能模板的实现。下面的这些规范主要是从这2个方面来定制的，这些规范是我这几年学习工作中总结的一点小经验，本文档比较适合中小型网站或者Web项目的开发规范。

    1.组建开发团队
    在接手项目后的第一件事是组建团队。根据项目的大小团队可以有几十人，也有可以是只有几个人的小团队，在团队划分中应该含有6个角色，这6个角色是必须的，分别是项目经理，策划，美工，程序员，代码整合员，测试员。也许你的团队还没有6个人，没有关系一个人可以有多个角色，比如项目经理还可以有策划这个角色，如程序员还可以含有代码整合和测试这2个角色，如果你的项目够大人数够多那就分为6个组，每个组分工再来细分。下面简单介绍一下这6个角色的具体职责。

    项目经理，项目总体设计，开发进度的定制和监控，定制相应的开发规范，负责各个环节的评审工作，协调各个成员(小组)之间开发。策划，提供详细的策划方案和需求分析。还包括后期网站推广方面的策划。美工，根据策划和需求设计网站AI，界面，Logo等。程序员，根据项目总体设计来设计数据库和功能模块的实现。代码整合员，负责将程序员的代码和界面融合到一起，代码整合员可以制作网站的相关页面，测试员，负责测试程序。

    2.开发工具
    Web开发工具主要分为3部分，第一部分是网站前台开发工具，第二部分是网站后台开发环境，第三部分是项目管理和辅助软件。下面分别简单介绍这三部分需要使用的软件。

    网站前台开发主要是指Web界面设计。包括网站整体框架建立、常用图片、Flash动画设计等等，主要使用的相关软件是：Adobe Illustrator 、Adodb Photoshop、Dreamweaver MX、Flash MX等。

    网站后台开发主要指网站动态程序开发、数据库建模，主要使用的相关软件是： PowerDesigner（数据库建模），PowerDesigner在数据库设计方面应用非常强大，用它可以快速创建数据库概念和物理模型，我最喜欢的还是它生成数据库Report的功能太方便了，设计数据库强烈推荐用它。Rational Rose（程序建模），如果你的项目功能模块不是特别复杂那就剩了它吧，这样会节省一些时间和开发的复杂度，不过我个人认为不管是大项目还是小项目都应该画画Rose图。

    网站项目管理主要指对开发进度和代码版本的控制。开发进度用Microsoft Project来制定，代码版本控制采用Visual SourceSafe，当然还有其他的选择比如CVS和Rational ClearCase。网站测试采用VS.net的附带工具Microsoft Application Center Test，它可以进行并行、负载测试等。程序文档编写采用Word，如果你非常怀旧用WPS也可以。

    3.网站开发流程
    在项目开始实施之前应该有一个工作步骤也就是工作流程，在项目开发中最需要时间的是总体设计和系统测试，而程序编写代码所占的时间并不多，但有的团队就急于开发写代码，先把程序写出来再说，没有注重评审和测试这2个环节，结果造成返工，我在一家比较大的公司中都遇到多次这种情况。所以项目来了不要急于开工写代码，应该一步一步慢慢来，只有走的慢才能走得稳走得远。图1的开发流程比较好地体现开发的整个环节。

图 1

    从图1可以看到2条主线，这2条主线分别是前台开发和后台开发。前后台开发在项目开发早期互相没有交叉，当然不是绝对没有，Web策划和需求分析都是互相有关系的，一个是网站表现形式和风格的策划另一个是网站功能的策划，它们是衣服和躯干的关系。到了开发后期就需要把界面和功能模块结合起来形成一个统一，也就即将发布的网站。

万维主机-Sunking

『统一行动，开始删贴！』
2003-6-22 20:03
小林
o○万帖俱乐部老八^_^ ○ o

积分 11270
发贴 11199
注册 2002-10-29
来自 『新都人.COM』
    4．数据库开发
    数据文件命名采用系统名+_+文件类型，比如系统名为kupage,则数据库文件命名为kupage_database.mdf，有的数据库文件有多个，比如SQL Server就有2个，一个是数据库文件，另一个是日志文件，那么他们的文件命名分别为kupage_database.mdf，kupage_log.log。文件名全部采用小写。

    数据库表命名规范，表名长度不能超过30个字符，表名中含有单词全部采用单数形式，单词首写字母要大写，多个单词间不用任何连接符号。若库中有多个系统，表名采用系统名称+单词或多个单词，系统名是开发系统的缩写，系统名称全部采用小写英文字符,如bbsTitle,bbsForumType。若库中只含有一个系统，那么表名仅用一个单词或多个单词。单词选择能够概括表内容的一个或多个英文单词，如UserInfo,UserType。关连表命名规则为Re_表A_表B,Re是Relative的缩写，如：Re_User_ArticleType, Re_User_FormType。

    数据库字段命名规范，数据库字段名全部采用小写英文单词，单词之间用”_”隔开，命名规则是表别名+单词，如：user_name,user_pwd。表别名规则，如果表名是一个单词，别名就取单词的前4 个字母；如果表名是两个单词，就各取两个单词的前两个字母组成4 个字母长的别名；如果表的名字由3 个单词组成，你不妨从头两个单词中各取一个然后从最后一个单词中再取出两个字母，结果还是组成4 字母长的别名。

    视图名采用规则View_表A_表B_表C,View表示视图。这个视图由几个表产生就用”_”连接几个表的名，如果表过多可以将表名适当简化，但一定要列出所有表名。

    存储过程命名规则P_表名_存取过程名(缩写)，比如P_User_Del，P_ArticleType_AddData。
    SQL语句编写规则，关键字必须大写，其他书写按上述命名规则，比如：
    SELECT user_id, user_name FROM User WHERE user_id = ‘tom’

    5.文件夹文件名命名规范
    文件夹命名一般采用英文，长度一般不超过20个字符，命名采用小写字母。除特殊情况才使用中文拼音，一些常见的文件夹命名如：images(存放图形文件)，flash（存放Flash文件），style(存放CSS文件)，scripts（存放Javascript脚本），inc(存放include文件)，link（存放友情链接）,media(存放多媒体文件)等。

    文件名称统一用小写的英文字母、数字和下划线的组合。命名原则的指导思想一是使得你自己和工作组的每一个成员能够方便的理解每一个文件的意义，二是当我们在文件夹中使用“按名称排例”的命令时，同一种大类的文件能够排列在一起，以便我们查找、修改、替换、计算负载量等等操作 。

    1、图片的命名原则名称分为头尾两部分，用下划线隔开，头部分表示此图片的大类性质例如广告、标志、菜单、按钮等等。
    放置在页面顶部的广告、装饰图案等长方形的图片取名： banner
    标志性的图片取名为： logo
    在页面上位置不固定并且带有链接的小图片我们取名为 button
    在页面上某一个位置连续出现，性质相同的链接栏目的图片我们取名： menu
    装饰用的照片我们取名： pic
    不带链接表示标题的图片我们取名： title
    下面是几个范例： banner_sohu.gif 、banner_sina.gif、 menu_aboutus.gif 、menu_job.gif、 title_news.gif、 logo_police.gif、 logo_national.gif 、pic_people.jpg 。

    2、动态语言文件命名规则性质_描述，描述可以有多个单词，用”_”隔开，性质一般是该页面得概要。
    范例：register_form.asp，register_post.asp,topic_lock.asp
    6.程序代码编程规范
一个良好的程序编码风格有利于系统的维护，代码也易于阅读查错。在此只讨论ASP的编程风格和约定。在ASP中所有变量是弱变量，无需定义就可以直接使用，而且代码不区分大小写。但其他语言一般这些都要定义的，为了养成良好的编程习惯，编写代码务必按照一下规则。

    1、每个变量名必须定义，在ASP文件的最开始添加语句，强制定制每个变量。

    2、出于易读和一致性的目的，在代码中使用以下变量命名约定：

子类型
前缀
示例

Boolean
bln
blnFound

Byte
byt
bytRasterData

Date (Time)
dtm
dtmStart

Double
dbl
dblTolerance

Error
err
errOrderNum

Integer
int
intQuantity

Long
lng
lngDistance

Object
obj
objCurrent

Single
sng
sngAverage

String
str
strFirstName

    3、程序代码需要有缩进，缩进采用键盘Tab键，不采用空格键。并且”＝”或者链接字符串时需要左右空一格，如下：

    4、函数过程编写的约定。函数或者过程命名采用动作+名词，每个函数需要给出相应的注释，函数功能，传入变量，以及作者和修改相关信息。如下面函数:
    <%
    '[功能] 返回一个参数的值
    '[参数] strParameterName 参数名称
    '[作者] icefire 2002/8/20 am
    Function GetParameterValue(strParameterName)
      Dim objRS, strSQL, strParameterValue
      strSQL = "SELECT ParameterValue FROM damsParameters WHERE ParameterName = '" & 　　　strParameterName & "'"
      .
      .
      .
    GetParameterValue = strParameterValue
    Set objRS = Nothing
    End Function

    5、ASP内置对象区分大小写。如下代码片断
    strUserName = Request.Form(“UserName”)
    Set conn = Server.CreateObject("ADODB.Connection")

    6、数据库连接一个库只能有一个数据库连接文件，创建数据库对象得原则是尽可能晚地打开数据库，尽可能早地关闭数据库。创建数据库对象调用统一地创建函数。如下：
    Sub OpenConn(ByRef conn)
      Dim strDBPath, strDBConnection

      strDBPath = Server.MapPath("database/tax.mdb")
      strDBConnnection = "Driver={Microsoft Access Driver (*.mdb)}; DBQ=" & strDBPath
      Set conn = Server.CreateObject("ADODB.Connection")
      conn.Open strDBConnnection
    End Sub

    7、当一个对象不在使用时要释放对象资源，比如objFSO,objRS对象等。采用统一函数调用。函数如下：
    Sub CloseObj(ByRef obj)
      If IsObject(obj) Then
        obj.Close
        Set obj = nothing
      End If
    End Sub

    8、时间全部以字符串的形式保存到数据库中，这样做能够是日期在不同的数据库中都能良好地保存，也方便数据库地迁移。时间用14位字符串保存，日期用8位字符串保存。

万维主机-Sunking

『统一行动，开始删贴！』
2003-6-22 20:04
谢晓峰
落伍者

积分 3391
发贴 3454
注册 2002-6-29
小喇叭开始广播啦......

感谢 随心所欲,wwwfox,http://8080.org/
要是注册玉米不要钱就好，我天天种玉米.
2003-6-22 20:04
Liguru
落伍者

积分 98
发贴 98
注册 2003-3-19
好文章不顶对不起自己。
2003-6-22 21:20
小林
o○万帖俱乐部老八^_^ ○ o

积分 11270
发贴 11199
注册 2002-10-29
来自 『新都人.COM』

Quote:
Originally posted by Liguru at 2003-6-22 21:20:
好文章不顶对不起自己。

好同志

万维主机-Sunking

『统一行动，开始删贴！』
2003-6-22 21:20
谢晓峰
落伍者

积分 3391
发贴 3454
注册 2002-6-29
干的好,和尚.

感谢 随心所欲,wwwfox,http://8080.org/
要是注册玉米不要钱就好，我天天种玉米.
2003-6-22 21:21
xtyzboy
落伍者

积分 6257
发贴 6299
注册 2002-6-15
来自 www.yzdns.com
不错！加T一下！

中国源码中心 www.cncode.com全新打造 给你最新的代码下载
主机论坛 www.hostbbs.net,买主机，卖主机，到主机论坛！为您的主机做最好的评测！
欢迎购买主机空间者发布求购信息! 欢迎主机商发布主机新闻及资料
广告位招租 QQ:59519487
2003-6-22 21:21
小林
o○万帖俱乐部老八^_^ ○ o

积分 11270
发贴 11199
注册 2002-10-29
来自 『新都人.COM』

Quote:
Originally posted by 谢晓峰 at 2003-6-22 21:21:
干的好,和尚.

终于没叫我喇叭了

万维主机-Sunking

『统一行动，开始删贴！』
2003-6-22 21:22
cee999
落伍者

积分 4276
发贴 4340
注册 2003-3-19
来自 123
不错

51网络之家 : http://www.21cnsky.com/
51论坛
2003-6-22 21:22
梦
杜鹃滴血

积分 2969
发贴 2719
注册 2002-5-6
来自 古墓苍狼
奖励一下

www.wps2000.net重新开放
http://www.wps2000.net/
PHP论坛：http://forum.wps2000.net/Forum.php?ForumID=28
2003-6-22 21:29
小林
o○万帖俱乐部老八^_^ ○ o

积分 11270
发贴 11199
注册 2002-10-29
来自 『新都人.COM』

Quote:
Originally posted by 天行 at 2003-6-22 21:29:
奖励一下

5位QQ奖励吗？

万维主机-Sunking

『统一行动，开始删贴！』
2003-6-22 21:31
梦
杜鹃滴血

积分 2969
发贴 2719
注册 2002-5-6
来自 古墓苍狼

Quote:
Originally posted by 小林 at 2003-6-22 09:31 PM:

5位QQ奖励吗？

当然不了啦

www.wps2000.net重新开放
http://www.wps2000.net/
PHP论坛：http://forum.wps2000.net/Forum.php?ForumID=28
2003-6-22 21:32
小林
o○万帖俱乐部老八^_^ ○ o

积分 11270
发贴 11199
注册 2002-10-29
来自 『新都人.COM』

Quote:
Originally posted by 天行 at 2003-6-22 21:32:

当然不了啦

不是“灌水有奖，送5位QQ”吗？

万维主机-Sunking

『统一行动，开始删贴！』
2003-6-22 21:34
梦
杜鹃滴血

积分 2969
发贴 2719
注册 2002-5-6
来自 古墓苍狼

Quote:
Originally posted by 小林 at 2003-6-22 09:34 PM:

不是“灌水有奖，送5位QQ”吗？

到我论坛灌水方可生效

www.wps2000.net重新开放
http://www.wps2000.net/
PHP论坛：http://forum.wps2000.net/Forum.php?ForumID=28
2003-6-22 21:35
小艾
落伍者

积分 1428
发贴 1426
注册 2002-10-25
来自 南华大学
好
TT
2003-6-22 21:36
<< [1] [2] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.044394 second(s), 5 queries, Gzip enabled


无标题文档

休闲娱乐部分

1. 103首MTV -- 里外都是人
2. 所谓落伍（原创） -- 西瓜
3. 倡议书：从我做起，同心同德，重现落伍者昔日辉煌！ -- ajie.net
4. 简单评论落伍的人（原创） -- 西瓜


落伍者论坛 - 网站建设专栏 - 倡议书：从我做起，同心同德，重现落伍者昔日辉煌！ - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 倡议书：从我做起，同心同德，重现落伍者昔日辉煌！

<< [1] [2] [3] [4] [5] >>
作者:
标题: 倡议书：从我做起，同心同德，重现落伍者昔日辉煌！ 上一主题 | 下一主题
ajie.net
醒了醒了

积分 7456
发贴 7622
注册 2002-2-13
倡议书：从我做起，同心同德，重现落伍者昔日辉煌！

我是2002.2.12号来到落伍者的~
具体怎么知道这里的我已经记不清楚了~
当时我来这里只是为了寻找免费资源~
（其实那时我已经买了新网的经济I型空间并拥有5个国际域名）

我之所以留下来是因为我在这里学了很多东西，得到了很多帮助，也结交了很多朋友！

但是，随着大批免费空间的倒掉，尤其是（l33t.ca、lycos），网络上的免费资源越来越少。于是取而代之的是PZ、JS，尤其是从LINDING事件开始，落伍者慢慢变质了~

再后来，增加了几位新斑竹（我也是其中之一），LINDING的阴影也渐渐散去……

再后来就是随着国内大量同类论坛的倒掉或关闭，许多新人加入了落伍者，其中不乏染上K666（当然K666没倒）等论坛某些恶习的，于是、随意发贴、广告、骂人……

落伍者几乎是彻底的变质了，斑竹管都管不了……

现在落伍者已经停止新用户注册了，我在这里倡议：
各位落伍者，特别是元老、斑竹，从现在起，从自己做起，为重现落伍者昔日辉煌努力！
具体如下：
1、遵守落伍者各项规则
2、每周至少发表（转贴）1-3封技术帖子
3、每天至少回复（帮助）2-5个需要帮助的朋友
4、建议斑竹将原创的技术帖子置顶1-2篇、等有一定的浏览、回复或有新的好技术帖子出现再换
5、对于违反落伍规定的，先警告（毕竟不能新申请ID了）、警告无效，封无赦
希望在农历新年后、在大家的努力下，重现一个和谐的落伍者！也希望那时侯落伍者ID能重新开放申请！

那时也应该是我来到落伍者1年的日子，如果大家的努力奏效了，我会自己掏腰包，买一些商务空间送给确实需要的朋友（虽然我只是穷学生）
2003-1-22 20:35
伊阳
落伍者

积分 2848
发贴 3054
注册 2002-8-5
还好没做元老，否则。。。。
2003-1-22 20:36
cvsg
落伍者

积分 503
发贴 503
注册 2002-11-20
支持,大家一起搞好落伍吧,让落伍更活跃,另外也多出来点好心人!!
2003-1-22 20:37
Xiaolin.Net
落伍者

积分 1181
发贴 522
注册 2002-11-24
1、遵守落伍者各项规则
2、每日至少发表（转贴）1-3封技术帖子
3、每天至少回复（帮助）2-5个需要帮助的朋友
4、建议斑竹将原创的技术帖子置顶1-2篇、等有一定的浏览、回复或有新的好技术帖子出现再换
5、对于违反落伍规定的，先警告（毕竟不能新申请ID了）、警告无效，封无赦

一 三可以做到，二不能
2003-1-22 20:37
丁丁
落伍者

积分 7466
发贴 7514
注册 2002-9-26
来自 家网
支持
2003-1-22 20:38
地狱天使
落伍者

积分 3415
发贴 3619
注册 2001-5-31
bucuo
2003-1-22 20:39
晓寒
落伍者

积分 4216
发贴 4216
注册 2001-7-17
好的.我以后回帖的时候认真些,尽力对楼主有帮助.
2003-1-22 20:39
ZDF
落伍者

积分 1566
发贴 1566
注册 2002-8-2
来自 长沙
尽力而为。
2003-1-22 20:39
ajie.net
醒了醒了

积分 7456
发贴 7622
注册 2002-2-13

Quote:
最初由 Xiaolin.Net 发布
[B]1、遵守落伍者各项规则
2、每日至少发表（转贴）1-3封技术帖子
3、每天至少回复（帮助）2-5个需要帮助的朋友
4、建议斑竹将原创的技术帖子置顶1-2篇、等有一定的浏览、回复或有新的好技术帖子出现再换
5、对于违反落伍规定的，先警告（毕竟不能新申请ID了）、警告无效，封无赦

一 三可以做到，二不能 [image] [/B]

尽量作到把~
只要是大家都用心了~
2003-1-22 20:39
allenzyk
落伍者

积分 781
发贴 838
注册 2002-1-14
来自 CNMAYA.ORG
support
2003-1-22 20:40
boyXP
落伍者

积分 757
发贴 755
注册 2002-1-31
我要按这个做``暑假期间多多帮忙
2003-1-22 20:40
土拨鼠
落伍者

积分 10644
发贴 10779
注册 2001-12-7
来自 美女出阁

1.3应该做到不难
2就难点了
2003-1-22 20:43
踏雪寻妹
别支签字笔揣颗平常心

积分 10062
发贴 10018
注册 2001-7-29
来自 笑看红尘
哈哈
我还记得ajie刚来的时候
2003-1-22 20:43
伊阳
落伍者

积分 2848
发贴 3054
注册 2002-8-5
看我签名
2003-1-22 20:44
游客 218.6.36.x
未注册

积分 N/A
发贴 N/A
注册 N/A
看到了~

同意！
2003-1-22 20:45
<< [1] [2] [3] [4] [5] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.067603 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 所谓落伍（原创） - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 所谓落伍（原创）

<< [1] [2] [3] [4] [5] [6] [7] >>
作者:
标题: 所谓落伍（原创） 上一主题 | 下一主题
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20
所谓落伍（原创）

开篇词(广告)
来落伍
不落伍
国内大事早知道；
国际动态早知道；
各地天气早知道；
小道消息早知道；
幽默笑话早知道；
最新电影早知道；
音乐下载早知道；
最新软件早知道；
病毒木马早知道；
最新价格早知道；
最新代码早知道；
拥有落伍id，您将别无所求。

落 伍

你来落伍你是来干什么的？学习？哦，不，如果你一门心思来学习的，我恐怕这里短期之内不能给你提高些什么。
有很多人说落伍的问题没有人回答，这很难用语言来概括，因为有些问题并不是能回答的，而“高手”往往没有那么多时间来按f5来上论坛。
来落伍能得到什么？我想我能得到很多，自从来了落伍之后，你可以放弃很多以往的习惯，比如电影下载，在别人苦苦搜索，混迹于各大电影论坛，踢着一个一个帖子只为了一本下载速度只有20-30k的“宽带下载影片”，你却可以在他数个月之前用他10倍的速度下载来早早的看过。当别人为了一些"商业代码"苦苦搜索的时候，你却可以在旁边说一句，那是垃圾。当别人到处寻找大型软件下载的时候，落伍却总是源源不断的有人提供，其实只要你天天上落伍，你会拥有市面上最火的软件，最火的影片和几乎最好的代码。
在这里，有人会提供免费的美工，免费的logo免费的banner，或者只要付出一点点代价，诸如几个QQ，一些空间，而这些交换的东西你可能也是是从落伍得来的，对于你来看，似乎还是免费的。请问各位，市面上一秒的flash是多少价格？而在落伍又值多少价格？
不要埋怨落伍没有人免费帮你做logo做banner，他们没有这个义务，这些事情是可遇而不可求的，只要你天天上落伍，我觉得你应该已经有很logo,banner。
网络时代已经进入了理性的时代，收费成了大势所趋，不要埋怨别人不给你免费空间，不要埋怨没有免费的域名，因为没有人有这个义务把自己的钱给你。何况，只要你天天上落伍，你会空间不愁，玉米一把（当然，也许是你被刺激而注册的），记得ajiang同我说过一句话，"咱还会被空间给憋死么。"
在落伍你享受着最便宜的价格但是最好的服务，当然只要你找的对人。你不能说这个人骗子，那个人是骗子，然后说落伍不好，看看外面网上的报价吧，再看看落伍65的玉米都有人说贵，您哪怕留几块钱给兄弟吃口饭吧。
你还想拥有什么？
你希望你的问题都能有人回答，你希望你要的电影都有提供，你希望你的连续剧能够一部接一部看？你想给人给你有价值的东西，空间、代码以及其他，这是落伍？
这好像是天堂的论坛。
这里能得到的东西都不落伍，但人落伍了，那么人不赚钱的在帮助你，那么多人送给你东西，你还希望什么？雷锋也不过如此，看起来落伍人几乎都是活雷锋了。
总有人说，落伍没有以前好了，我记得我刚来的时候也有人说，落伍不如以前好了，一天不如一天了，可是一年多过去了，落伍还是落伍。人总是在怀旧，虽然现在比以前生活水平提高了，但是很多人说起以前的时候还是眼光里面闪烁着激动和兴奋。什么是好？什么是不好？什么是以前，什么是将来？
每一个人心目中都有一个自己的落伍，落伍是不完美的，但是每一个人心里总想让他完美，有人喜欢纯技术的，有人喜欢纯娱乐的，有人喜欢问问题的，有人喜欢有东西下载的，如果参杂了其他东西，或者不允许了其中一样东西，他们也许都会觉得不好，是啊，落伍变了，因为有太多人想把自己的落伍放到这个狭小的地方来。于是可怜的落伍勉强地把所有人的希望都包容了进来。这个时候却突然跳出来一个人，对着落伍大喊，这像什么，大杂烩，垃圾场。于是大家也觉得不好了，大喊把我们把垃圾扔出去。
可是什么是垃圾呢？我们小时都有这样的经历，你会收集一些小玩意儿，也许只是几个香烟壳，打火石，树叶子，你把这些都藏得好好的放在家里，结果都被你妈妈扔掉了，于是你哭，你不吃饭，你要妈妈赔给你。因为在大人眼中，那些就是垃圾，但是在你眼里，那是至宝。我说这个的原因是想说，每一个人眼中衡量的角度都不同，特别是一些很难衡量的东西，什么帖子该删除，什么帖子该去垃圾桶，什么帖子该去休闲栏，不用说会员，就是每一个斑竹尺度都不会同，因为你删了我的而不删除他的，你就不乐意了，因为你转移我的而不转移他的你就不高兴了，于是大呼，其他人都在灌水为什么偏偏针对我。老天，天知道，我和你有深仇大恨么，我和你有过节么，也许是有的，如果有，我会蠢到有这样的办法来对付你么。转移几个帖子算什么，删除几个帖子又怎么样了呢？我真的看不懂。大家学学有些同志吧，有些人，被删除了无数帖子，被删除无数ID，被删除无数分数，被无数人大叫：GET OUT,可他仍然活跃在我们落伍某个角落里面，他的高风亮节，他的英勇无畏、勇往直前的精神不是很值得我们广大群众学习么？
不要在乎这些了，发出去的帖子泼出去的水，你发了帖子，你的目的达到了，只要不是斑竹把你问关键问题的帖子丢掉，其他一些不痛不痒，不尴不尬的东西，丢掉了也就丢掉了。何必太在意呢，请别误会，不是现在，在数月之前，我也是这么说。
落伍不能亡，落伍亡了，就不会有第二个落伍了，哪怕再有人重新建立一个叫落伍的，可那都不会有人承认了，落伍不能重新开始，因为没有机遇给他重新开始的机会，不会再有那样一群可爱的、有能力、有一定水平的朋友聚集在这里了。
珍惜落伍，珍惜我们手上的ID，谢谢大家。

后记：
做了一阵子的所谓超版，遇到了一些问题，首要的就是pm超级多，我终于有感于JET以前为什么老是信箱满了。有些人会说做斑竹不容易，我并不这么觉得，落伍的朋友大部分还是比较能够接受一些管理工作的，因为大部分人自己就是管理者。
可是有些人却不这么看，大致上有这么几类人：第一，我来的比你早，你有什么资格当超版来管我；第二，你斑竹算什么，老子还是站长呢；第三，以前你不是这样的，当了管理员怎么就变了呢？对于第一类人，我想没什么话好对你说，我想大家谁都可以随便组织组织一些话来告诉你你的无知和愚昧；对于第二类人，我觉得更加无聊，这里谁不是站长，哪个不是斑竹？退一步说，站长算什么，说不定你们家楼下卖茶叶蛋老太太的明天也买个chayedan.com弄个空间，她孙子给她装个程序，也网上销售当CEO了。这里的超版的确不算什么，因为没有人怕我们，也不应该怕我们，不会因为得罪了我就没有电影下载，但是你千万不能说你算什么东西，我怕你自己都不能知道你算什么南北；对于第三类，我觉得很失望，因为这类人里面也许很多都是我的朋友，或者把我当作朋友，或者我把他当作朋友，然，不在其位，不谋其政，既然作了，自然要做一些事情，也许某些事情会触犯到你，如果真的给你带来了伤害，我真的十分抱歉，这绝对不是什么客套，但是你千万不要说，你当了“官”了，就变样了，因为我还是我，还有我希望大家不要用你们你们来称呼我，这让我觉得很惶恐。
对于后记，我就说那么多，因为说多了等临时工的角色慢慢褪去，帖子被人重新从底角里面弄出来的时候会是很可笑的一件事情。
最后在后记里面发一句口号：因为我和你的存在，落伍将更加精彩！

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-6-8 17:48
输狂了
落伍者

积分 3850
发贴 3440
注册 2002-5-16
高高高.

我的笑话网站
http://www.alexa.com/data/details?url=www.sixhc.com
2003-6-8 17:50
陆逊
落伍者

积分 2233
发贴 2222
注册 2002-8-8
来自 新西兰+汕头
就是不落伍啦
2003-6-8 17:50
那个那个谁
落伍者

积分 10998
发贴 11020
注册 2002-4-15
强，支持西瓜！

我爱小昭........
2003-6-8 17:50
run
落伍者

积分 2092
发贴 2139
注册 2002-1-27
厉害~

此玉米出售:www.cnkey.net
ＹＹ音乐
2003-6-8 17:50
uneed
落伍者

积分 11898
发贴 12153
注册 2002-1-13
嘿嘿，
西瓜出品
必属精华

不卖美国主机啦，有租美国服务器的找我。。。优QQ：88903066（请注名购空间）
2003-6-8 17:50
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20

Quote:
Originally posted by 输狂了 at 2003-6-8 05:50 PM:
高高高.

我打了半天，你就2分钟不到就三个字？

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-6-8 17:50
jarod
落伍者

积分 10809
发贴 11109
注册 2002-4-17
分析很全面
有一手

GAMER游戏网 我的破游戏网站,喜欢游戏和想下载游戏的过来看看。恒久空间演示。
笨GOGO 关于英语和留学生的论坛。
2003-6-8 17:51
rical
落伍者

积分 4496
发贴 4589
注册 2002-7-8
来自 广东
你打了半天，我也看了半天，晕～～好多字～

学问要多动手,多提问;少灌水,少装B.程序网上多的是,知识在你脑里又有多少了??不要浪费了你老妈给你的一个脑和两只手.
2003-6-8 17:51
boyXP
落伍者

积分 757
发贴 755
注册 2002-1-31
看完了 很有道理``落伍就是这个样子

弄影短信,给你想要的
http://www.dayxp.com/
2003-6-8 17:52
龙慧
落伍者

积分 4752
发贴 4638
注册 2002-11-20
有道理哇 。。。 感觉一样。。。 努力吧西瓜兄弟 复活了的西瓜兄弟 ：）

★★★★★★★★★★★★
商务中国商品零点利销售 主页 www.mylh.com
代理价格+18元 QQ：8292352
★★★★★★★★★★★★
http://www.orderpic.com/ 需要这样的代码 花点钱偶都愿意！ 有的请加我QQ
2003-6-8 17:52
mokeli
落伍者

积分 4039
发贴 4048
注册 2002-6-7
2003-6-8 17:52
小艾
落伍者

积分 1428
发贴 1426
注册 2002-10-25
来自 南华大学
说的太好了
支持啊
因为我和你的存在，落伍将更加精彩！
2003-6-8 17:52
兴隆居士
落伍者

积分 2882
发贴 2889
注册 2001-8-14
来自 金城金县金书斋

Quote:
Originally posted by 西瓜 at 2003-6-8 17:48:

开篇词(广告)
来落伍
不落伍
国内大事早知道；
国际动态早知道；
各地天气早知道；
小道消息早知道；
幽默笑话早知道；
最新电影早知道；
音乐下载早知道；
最新软件早知道；
病毒木马早 ...

就最后一句还可以
因为我和你的存在，落伍将更加精彩！

老道也要赚钱
要学道，找老道----道化万物
2003-6-8 17:54
孤者一狼
落伍者

积分 4370
发贴 4383
注册 2002-6-30

Quote:
Originally posted by uneed at 2003-6-8 05:50 PM:
嘿嘿，
西瓜出品
必属精华

2003-6-8 17:54
<< [1] [2] [3] [4] [5] [6] [7] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.026971 second(s), 5 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 搞点颜色给你瞧瞧 - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 搞点颜色给你瞧瞧

作者:
标题: 搞点颜色给你瞧瞧 上一主题 | 下一主题
里外都是人
DeathKnight

积分 11291
发贴 1412
注册 2003-6-22
搞点颜色给你瞧瞧

王力宏:Last Night mms://wms6.hichannel.hinet.net/HINETMUSIC/Try/SONY/lastnight.wmv|
齊豫:橄欖樹 mms://wms6.hichannel.hinet.net/HINETMUSIC/Try/EMI/oliver.wmv|
蕭亞軒:愛上愛（完整） mms://wms6.hichannel.hinet.net/HINETMUSIC/Try/virgin/elvalove.wmv
吉娃斯．杜嵐:勇闖天涯 mms://wms6.hichannel.hinet.net/H ... g/chivas-brave.wmv|
阿爆＆BRANDY:城堡 mms://wms6.hichannel.hinet.net/H ... 30508_06v_300k.wmv|
黃立成與MACHI/麻吉:麻吉 mms://wms6.hichannel.hinet.net/H ... chi-030331_01v.wmv|
張智成:FOREVER mms://wms6.hichannel.hinet.net/HINETMUSIC/Try/wha/Forever.wmv|
張智成:刺心 mms://wms6.hichannel.hinet.net/HINETMUSIC/Try/wha/heart.wmv|
S.H.E:白色戀歌 mms://wms6.hichannel.hinet.net/H ... 30129_01v_180k.wmv|
陳明真:兩個 mms://wms6.hichannel.hinet.net/HINETMUSIC/Try/yes/2.wmv|
AK 原子少女貓:Tide is high mms://wms6.hichannel.hinet.net/H ... de%20Is%20High.wmv|
梁靜茹：最快樂那一年 mms://wms6.hichannel.hinet.net/HINETMUSIC/Try/rock/happyyear.wmv|
黃立行：我的夢中情人 mms://wms6.hichannel.hinet.net/H ... n/mydreamlover.wmv|
BLUE&Elton John：Sorry Seems To Be The Hardest Word mms://wms6.hichannel.hinet.net/H ... hardest%20word.wmv|
BLUE：One Love
http://music.hinet.net/cgi-bin/play...dummy=blank.asf|
顺子：问自己
mms://wms6.hichannel.hinet.net/HINETMUSIC/Try/EMI/askslef.wmv|

苏永康--幸福离我们很近(MTV)
http://202.103.160.29/entertainment/zuopin3/26575.mpeg
陈绮贞-躺在我的衣柜(MTV)
http://202.103.160.29/entertainment/zuopin3/26574.mpeg
何韵诗-兄弟(MTV)
http://202.103.160.29/entertainment/zuopin3/26573.mpeg
黄品源-小薇(MTV)
http://202.103.160.29/entertainment/zuopin3/26546.mpeg
刘德华-独自去偷欢(MTV)
http://202.103.160.29/entertainment/zuopin3/26544.mpeg
胡彦斌-和尚(MTV)
http://202.103.160.29/entertainment/zuopin3/26544.mpeg
许茹云-永恒的转眼(MTV)
http://202.103.160.29/entertainment/zuopin3/26543.mpeg
郭富城-第四晚心情(MTV)
http://202.103.160.29/entertainment/zuopin3/26542.mpeg
謝霆鋒 容祖兒 3T 新世界傳動網 星 Mobile（广告）
http://202.103.160.29/entertainment/zuopin3/26507.mpeg
E.kids-私人时段(MTV)
http://202.103.160.29/entertainment/zuopin3/26489.mpeg
E.kids-听到留言请回电(MTV)
http://202.103.160.29/entertainment/zuopin3/26488.mpeg
郑伊健 - 一个人恋爱(MTV)
http://202.103.160.29/entertainment/zuopin3/26487.mpeg
范逸臣-I believe(MTV)
http://202.103.160.29/entertainment/zuopin3/26486.mpeg
陈晓东 - 准我爱你(MTV)
http://202.103.160.29/entertainment/zuopin3/26480.mpeg
张柏芝 李克勤-赌爱(MTV)
http://202.103.160.29/entertainment/zuopin3/26454.mpeg
朴正弦之相思病（漫画）
http://202.103.160.29/entertainment/zuopin3/26414.mpeg
张柏芝-留給最愛的說話(MTV)
http://202.103.160.29/entertainment/zuopin3/26294.mpeg
华仔—肉麻情歌
http://202.103.160.29/entertainment/zuopin3/26282.mpeg
張學友-該不該(MTV)
http://202.103.160.29/entertainment/zuopin3/26175.mpeg
黎明-相逢在雨中（MTV）
http://202.103.160.29/entertainment/zuopin3/26173.mpeg
BEYOND-大地(MTV)
http://202.103.160.29/entertainment/zuopin3/26172.mpeg
BEYOND-AMANI(mtv)
http://202.103.160.29/entertainment/zuopin3/26171.mpeg
黃湘怡-你是誰(MTV)
http://202.103.160.29/entertainment/zuopin3/26092.mpeg
刘德华-末世天使(MTV)
http://202.103.160.29/entertainment/zuopin3/26091.mpeg
任賢齊-美麗壞女人(MTV)
http://202.103.160.29/entertainment/zuopin3/26089.mpeg
曹宇-体会(MTV)
http://202.103.160.29/entertainment/zuopin3/26085.mpeg
霍建华-伞下的幸福(MTV)
http://202.103.160.29/entertainment/zuopin3/26084.mpeg
許茹芸-祝福了(MTV)
http://202.103.160.29/entertainment/zuopin3/26071.mpeg
陶喆- My Anata(MTV)
http://202.103.160.29/entertainment/zuopin3/26070.mpeg
郑种基-我代你哭(MTV)
http://202.103.160.29/entertainment/zuopin3/26069.mpeg
林晓培-不知好歹(MTV)
http://202.103.160.29/entertainment/zuopin3/26064.mpeg
张学友--咖啡(MTV)
http://202.103.160.29/entertainment/zuopin3/26061.mpeg
丁文琪-騙子(MTV)
http://202.103.160.29/entertainment/zuopin3/26060.mpeg
许绍洋--胡渣(MTV)
http://202.103.160.29/entertainment/zuopin3/26058.mpeg
潘玮柏--我不怕
http://202.103.160.29/entertainment/zuopin3/26057.mpeg
刘承俊LIVE WOW
http://202.103.160.29/entertainment/zuopin3/26037.mpeg
李娜英-你是谁
http://202.103.160.29/entertainment/zuopin3/26004.mpeg
《下一站…天后》至Hit廣告
http://202.103.160.29/entertainment/zuopin3/25987.mpeg
梁朝伟-朦胧夜雨里(MTV)
http://202.103.160.29/entertainment/zuopin3/25914.mpeg
郑秀文-喜欢憎我(MTV)
http://202.103.160.29/entertainment/zuopin3/25912.mpeg
B.A.D-半个海洋（MTV）
http://202.103.160.29/entertainment/zuopin3/25910.mpeg
容祖兒-我的驕傲(Neway MV)
http://202.103.160.29/entertainment/zuopin3/25908.mpeg
杨千嬅－扬眉(MTV)
http://202.103.160.29/entertainment/zuopin3/25904.mpeg
动力火车-冲动(MTV)
http://202.103.160.29/entertainment/zuopin3/25854.mpeg
谷祖琳--我有权投(MTV)
http://202.103.160.29/entertainment/zuopin3/25852.mpeg
刘德华的动画MTV黑蝙蝠中队
http://202.103.160.29/entertainment/zuopin3/25836.mpeg
赵微—《疯狂接吻》
http://202.103.160.29/entertainment/zuopin3/25673.mpeg
孙燕姿《我不难过》
http://202.103.160.29/entertainment/zuopin3/25582.mpeg
孙燕姿《未完成》
http://202.103.160.29/entertainment/zuopin3/25580.mpeg
容祖儿--麻醉
http://202.103.160.29/entertainment/zuopin3/25548.asf
林熙蕾-羊咩咩
http://202.103.160.29/entertainment/zuopin3/25400.mpg
Twins--爱情当入樽
http://202.103.160.29/entertainment/zuopin3/25345.mpeg
张震岳-----怎么办
http://202.103.160.29/entertainment/zuopin3/25190.asf
1.蕭亞軒-Never look back
mms://wms8.sys.hinet.net/erainfo/muchclub/576982_01_300.wmv
2.蕭亞軒-答應我
mms://wms8.sys.hinet.net/erainfo/muchclub/576983_01_300.wmv
3.蕭亞軒-愛情美
mms://wms8.sys.hinet.net/erainfo/muchclub/577000_01_300.wmv
4.蕭亞軒-下一次戀愛
mms://wms8.sys.hinet.net/erainfo/muchclub/577005_01_300.wmv
5.蕭亞軒-我愛你那麼多
mms://wms8.sys.hinet.net/erainfo/muchclub/576994_01_300.wmv
6.蕭亞軒-Let it go
mms://wms8.sys.hinet.net/erainfo/muchclub/577006_01_300.wmv
7.蕭亞軒-秘密
mms://wms8.sys.hinet.net/erainfo/muchclub/576991_01_300.wmv
8.蕭亞軒-明天
mms://wms8.sys.hinet.net/erainfo/muchclub/576992_01_300.wmv
9.蕭亞軒-給我重新愛你的機會
mms://wms8.sys.hinet.net/erainfo/muchclub/576990_01_300.wmv
10蕭亞軒-薔薇
mms://wms8.sys.hinet.net/erainfo/muchclub/577007_01_300.wmv
11.蕭亞軒-夜
mms://wms8.sys.hinet.net/erainfo/muchclub/577008_01_300.wmv
12.蕭亞軒-上鉤了
mms://wms8.sys.hinet.net/erainfo/muchclub/576995_01_300.wmv
13.蕭亞軒-準備好了沒有
mms://wms8.sys.hinet.net/erainfo/muchclub/576999_01_300.wmv
14.蕭亞軒-窗外的天氣
mms://wms8.sys.hinet.net/erainfo/muchclub/577001_01_300.wmv
15.蕭亞軒-一個人的精彩
mms://wms8.sys.hinet.net/erainfo/muchclub/576996_01_300.wmv
16.蕭亞軒-雨季中
mms://wms8.sys.hinet.net/erainfo/muchclub/577004_01_300.wmv
17.蕭亞軒-多愛自己一下
mms://wms8.sys.hinet.net/erainfo/muchclub/576987_01_300.wmv
18.蕭亞軒-甩啦甩啦
mms://wms8.sys.hinet.net/erainfo/muchclub/576989_01_300.wmv
19.蕭亞軒-最熟悉的陌生人
mms://wms8.sys.hinet.net/erainfo/muchclub/577002_01_300.wmv
20.蕭亞軒-愛是個壞東西
mms://wms8.sys.hinet.net/erainfo/muchclub/576997_01_300.wmv
21.蕭亞軒-突然想起你
mms://wms8.sys.hinet.net/erainfo/muchclub/576985_01_300.wmv
22.蕭亞軒-Cappuccino
mms://wms8.sys.hinet.net/erainfo/muchclub/576998_01_300.wmv
23.蕭亞軒-沒有人
mms://wms8.sys.hinet.net/erainfo/muchclub/576993_01_300.wmv
24.蕭亞軒-我喜歡你快樂
mms://wms8.sys.hinet.net/erainfo/muchclub/576564_01_300.wmv
25.哈林-命中註定
mms://wms8.sys.hinet.net/erainfo/muchclub/574214_01_300.wmv
26.成龍+李秀英-夢想的天際
mms://wms8.sys.hinet.net/erainfo/muchclub/576774_01_300.wmv

[ Last edited by 里外都是人 on 2003-7-3 at 05:55 PM ]

代理商务中国域名 75元/个
送QQ会员月卡一张,内含10个Q币
单独注册68元
联系QQ:121007007

2003-7-3 17:51
里外都是人
DeathKnight

积分 11291
发贴 1412
注册 2003-6-22
小MM热舞
http://202.103.160.29/entertainment/zuopin3/7546.mpeg
JAY-最后的战役
http://202.103.160.29/entertainment/zuopin3/4759.wmv

因为是女子（中文字幕版）
http://202.103.160.29/entertainment/zuopin3/4692.rm

the corrs -joy of life
http://202.103.160.29/entertainment/zuopin3/5602.rm

从开始到现在
http://202.103.160.29/entertainment/zuopin3/5342.rm

刘若英-为爱痴狂
http://202.103.160.29/entertainment/zuopin3/4855.wmv

李贞贤—半
http://202.103.160.29/entertainment/zuopin3/5350.mpeg

恋歌（韩国MTV）
http://202.103.160.29/entertainment/zuopin3/4753.wmv

张柏芝-赌爱
http://202.103.160.29/entertainment/zuopin3/6442.mpeg

最终幻想
http://202.103.160.29/entertainment/zuopin3/4998.mpeg

kuraki mai-feel fine
http://202.103.160.29/entertainment/zuopin3/5605.mpeg

XP形象大使-YOYO陈自瑶
http://202.103.160.29/entertainment/zuopin3/4725.mpeg

魂斗罗 再次出现
http://202.103.160.29/entertainment/zuopin3/4703.mpeg

性感XP广告
http://202.103.160.29/entertainment/zuopin3/5186.mpeg

龙卷风-JAY
http://202.103.160.29/entertainment/zuopin3/4185.mpeg

我的爱人-朴志胤
http://202.103.160.29/entertainment/zuopin3/5959.avi

走开-朴志胤
http://202.103.160.29/entertainment/zuopin3/7573.asx

sterl away-朴志胤
http://202.103.160.29/entertainment/zuopin3/7609.mpeg

kuraki
http://202.103.160.29/entertainment/zuopin3/5594.asf

这个男人不太坏
http://202.103.160.29/entertainment/zuopin3/6404.mpeg

幻想—朴志胤
http://202.103.160.29/entertainment/zuopin3/6908.mpeg

陈惠林-冰室
http://202.103.160.29/entertainment/zuopin3/6441.mpeg

一段幻境历险记
http://202.103.160.29/entertainment/zuopin3/5250.mpeg

日本街舞比赛
http://202.103.160.29/entertainment/zuopin3/6345.wmv

battle rapper CG动画
http://202.103.160.29/entertainment/zuopin3/6062.mpeg

经典动画片头3
http://202.103.160.29/entertainment/zuopin3/7409.mpeg

李贞贤 和平 现场版
http://202.103.160.29/entertainment/zuopin3/7479.mpeg

舒其 雨中的狂野浪漫
http://202.103.160.29/entertainment/zuopin3/9297.avi

宫崎俊MTV
http://202.103.160.29/entertainment/zuopin3/6679.rm

明星走光
http://202.103.160.29/entertainment/zuopin3/6617.mpg

KOF 2002 opening
http://202.103.160.29/entertainment/zuopin3/6987.avi

同一首歌，四个结局（1）
http://202.103.160.29/entertainment/zuopin3/6831.mpeg

同一首歌，四个结局（2）
http://202.103.160.29/entertainment/zuopin3/6923.asf

同一首歌，四个结局（3）
http://202.103.160.29/entertainment/zuopin3/6924.asf

同一首歌，四个结局（4）
http://202.103.160.29/entertainment/zuopin3/6926.mpeg

绝世好爸 主题曲
http://202.103.160.29/entertainment/zuopin3/6810.rm

ZERO-承诺
http://202.103.160.29/entertainment/zuopin3/5012.mpeg

迫不及待的约会
http://202.103.160.29/entertainment/zuopin3/6460.asf

GOODBYE（韩剧美丽的日子）
http://202.103.160.29/entertainment/zuopin3/8087.mpeg

真惨
http://202.103.160.29/entertainment/zuopin3/9704.mpeg

回到过去1
http://202.103.160.29/entertainment/zuopin3/9792.wmv

cs爆笑电影
http://202.103.160.29/entertainment/zuopin3/9432.rm

摇头版CS
http://202.103.160.29/entertainment/zuopin3/9882.mpeg

半兽人
http://202.103.160.29/entertainment/zuopin3/9344.mpeg

CLION DION- I am alive
http://202.103.160.29/entertainment/zuopin3/9486.wmv

朋友首日封-光良
http://202.103.160.29/entertainment/zuopin3/9493.wmv

潜龙碟影2：实体（动画）
http://202.103.160.29/entertainment/zuopin3/7764.mpeg

踢狗
http://202.103.160.29/entertainment/zuopin3/7691.avi

Do you want my love
http://202.103.160.29/entertainment/zuopin3/7334.mpeg

MILK COMETOME
http://202.103.160.29/entertainment/zuopin3/7641.mpeg

梁朝伟和全度妍的MTV
http://202.103.160.29/entertainment/zuopin3/6717.asf

死缠烂打
http://202.103.160.29/entertainment/zuopin3/6646.mpg

助人为乐
http://202.103.160.29/entertainment/zuopin3/6642.mpeg

宫崎俊MTV
http://202.103.160.29/entertainment/zuopin3/6679.rm

当爱擦身而过
http://202.103.160.29/entertainment/zuopin3/6254.mpeg

相对湿度—邓希怡
http://202.103.160.29/entertainment/zuopin3/6349.mpeg

劲舞MTV（虚拟人物版）
http://202.103.160.29/entertainment/zuopin3/6037.rm

我的野蛮女友中文版
http://202.103.160.29/entertainment/zuopin3/5814.mpeg

because of love
http://202.103.160.29/entertainment/zuopin3/5743.mpeg

日月之爱（上）
http://202.103.160.29/entertainment/zuopin3/4733.wmv

日月之爱（下）
http://202.103.160.29/entertainment/zuopin3/4752.wmv

冬季恋歌插曲moment
http://202.103.160.29/entertainment/zuopin3/4655.wmv

苦口良药
http://202.103.160.29/entertainment/zuopin3/4303.mpeg

女校男生
http://202.103.160.29/entertainment/zuopin3/4132.wmv

代理商务中国域名 75元/个
送QQ会员月卡一张,内含10个Q币
单独注册68元
联系QQ:121007007

2003-7-3 17:52
LOOX
落伍者

积分 2565
发贴 2673
注册 2002-6-23
来自 eom.cn
NB阿

虎虎唧唧咕咕嘎！！
本站代理广东华联网络有限公司http://www.163icp.com空间 粤ICP备060138，价格从优。QQ16802757
2003-7-3 17:52
里外都是人
DeathKnight

积分 11291
发贴 1412
注册 2003-6-22
28.張清芳-把自己敲醒
mms://wms8.sys.hinet.net/erainfo/muchclub/576760_01_300.wmv
29.張清芳-蘭花小館
mms://wms8.sys.hinet.net/erainfo/muchclub/576762_01_300.wmv
30.張清芳-深邃與甜蜜
mms://wms8.sys.hinet.net/erainfo/muchclub/575734_01_300.wmv
31 吐司男之吻2
mms://wms8.sys.hinet.net/erainfo/muchclub/576231_01_300.wmv
32 林憶蓮-站在第一排
mms://wms8.sys.hinet.net/erainfo/muchclub/576421_01_300.wmv
33 許慧欣-HAPPY
mms://wms8.sys.hinet.net/erainfo/muchclub/575229_01_300.wmv
34 許慧欣-快樂為主
mms://wms8.sys.hinet.net/erainfo/muchclub/575228_01_300.wmv
35 李玟-So Crazy
mms://wms8.sys.hinet.net/erainfo/muchclub/560165_01_300.wmv
36 李玟-逃脫-經典組曲
mms://wms8.sys.hinet.net/erainfo/muchclub/559752_01_300.wmv
37 李玟-Baby對不起
mms://wms8.sys.hinet.net/erainfo/muchclub/559753_01_300.wmv
38 李玟- I'm Still In Love
mms://wms8.sys.hinet.net/erainfo/muchclub/559751_01_300.wmv
39 李玟-刀馬旦(featuring 周杰倫)
mms://wms8.sys.hinet.net/erainfo/muchclub/559754_01_300.wmv
40 李玟-刀馬旦
mms://wms8.sys.hinet.net/erainfo/muchclub/560490_01_300.wmv
41 王力宏-愛的就是你
mms://wms8.sys.hinet.net/erainfo/muchclub/560164_01_300.wmv
42 王力宏-唯一
mms://wms8.sys.hinet.net/erainfo/muchclub/557839_01_300.wmv
43 周渝民-MAKE A WISH
mms://wms8.sys.hinet.net/erainfo/muchclub/573023_01_300.wmv
44 F4-第一時間
mms://wms8.sys.hinet.net/erainfo/muchclub/557841_01_300.wmv
45 吐司男之吻-聽不到你
http://aspweb.yuntech.edu.tw/u9024005/hear.wmv
46 S.H.E-戀人未滿
mms://wms8.sys.hinet.net/erainfo/muchclub/559365_01_300.wmv
47 S.H.E-冰箱
mms://wms8.sys.hinet.net/erainfo/muchclub/559367_01_300.wmv
48 S.H.E-Beauty Up My Life
mms://wms8.sys.hinet.net/erainfo/muchclub/559366_01_300.wmv
49 S.H.E-他就是他
mms://wms8.sys.hinet.net/erainfo/muchclub/565643_01_300.wmv
50 S.H.E-戀人未滿感謝版
mms://wms8.sys.hinet.net/erainfo/muchclub/565644_01_300.wmv
51 S.H.E-你快樂我隨意
mms://202.3.161.116/mv/she_whatever.wmv
52 S.H.E-Nothing Ever Changes
mms://202.3.161.116/mv/she_nothingeverchange.wmv
53 S.H.E-Yes I love U
mms://202.3.161.116/mv/she_yesiloveu.wmv
54 陳冠希-Angel
mms://wms8.sys.hinet.net/erainfo/muchclub/565950_01_300.wmv ;
55 陳冠希-壞孩子的天空
mms://wms8.sys.hinet.net/erainfo/muchclub/572208_01_300.wmv
56 陳冠希-故意
mms://wms8.sys.hinet.net/erainfo/muchclub/559363_01_300.wmv
57 陳冠希-超速遊戲
mms://wms8.sys.hinet.net/erainfo/muchclub/559362_01_300.wmv
58 陳冠希-夜風
mms://wms8.sys.hinet.net/erainfo/muchclub/559262_01_300.wmv
59 陳奕迅-K歌之王
mms://wms8.sys.hinet.net/erainfo/muchclub/528166_01_300.wmv
60 陳奕迅-不如這樣
mms://wms8.sys.hinet.net/erainfo/muchclub/511253_01_300.wmv
61 陳奕迅-低等動物
mms://wms8.sys.hinet.net/erainfo/muchclub/511254_01_300.wmv
62 陳奕迅-愛是懷疑
mms://wms8.sys.hinet.net/erainfo/muchclub/511252_01_300.wmv
63 張惠妹-記得
mms://wms8.sys.hinet.net/erainfo/muchclub/564631_01_300.wmv
64 張惠妹-感應
mms://wms8.sys.hinet.net/erainfo/muchclub/564630_01_300.wmv
65 陳慧琳-飛吧
mms://wms8.sys.hinet.net/erainfo/muchclub/521376_01_300.wmv
66 蔡依琳-情不自禁
mms://wms8.sys.hinet.net/erainfo/muchclub/441830_01_300.wmv
67 蔡依琳-如果不想要
mms://wms8.sys.hinet.net/erainfo/muchclub/441832_01_300.wmv
68 許茹芸-只說給你聽
mms://wms8.sys.hinet.net/erainfo/muchclub/557838_01_300.wmv
69 許茹芸-遇見另一個人
mms://wms8.sys.hinet.net/erainfo/muchclub/556970_01_300.wmv
70 陶晶瑩-夢見
mms://wms8.sys.hinet.net/erainfo/muchclub/562353_01_300.wmv
71 陶晶瑩-游泳
mms://wms8.sys.hinet.net/erainfo/muchclub/562352_01_300.wmv
72 陳曉淇-Shall We Love
mms://wms8.sys.hinet.net/erainfo/muchclub/563516_01_300.wmv
73 鍾汶-難題
mms://wms8.sys.hinet.net/erainfo/muchclub/563512_01_300.wmv
74 林曉培-無疾而終
mms://wms8.sys.hinet.net/erainfo/muchclub/564628_01_300.wmv
75 容祖兒-說真的
mms://wms8.sys.hinet.net/erainfo/muchclub/566712_01_300.wmv
76 林曉培-Music All Night
mms://wms8.sys.hinet.net/erainfo/muchclub/550666_01_300.wmv
77 林曉培-放手一搏
mms://wms8.sys.hinet.net/erainfo/muchclub/555345_01_300.wmv
78 林曉培-不哭
mms://wms8.sys.hinet.net/erainfo/muchclub/557842_01_300.wmv
79 林曉培-緩慢
mms://wms8.sys.hinet.net/erainfo/muchclub/561947_01_300.wmv
80 五月天-永远的永远
mms://211.216.46.20/video/328.wmv
81 五月天-相信
mms://211.216.46.20/video/317.wmv
82 江美琪-I feel so good
mms://202.109.105.130/vod/VOD/ChinaFun/MTV/Female/8314_3.dat
83 江美琪-双手的温柔
mms://202.109.105.130/vod/VOD/ChinaFun/MTV/Female/1266_3.dat
84 江美琪-在我身边
mms://202.109.105.130/vod/VOD/ChinaFun/MTV/Female/8315_3.dat
85 江美琪-寂寞飞行
mms://202.109.105.130/vod/VOD/ChinaFun/MTV/Female/5867_3.dat
86 江美琪-凝望
mms://202.109.105.130/vod/VOD/ChinaFun/MTV/Female/7222_3.dat
87 江美琪-希望变成你
mms://202.109.105.130/vod/VOD/ChinaFun/MTV/Female/1781_3.dat
88 江美琪-我又想起你
mms://202.109.105.130/vod/VOD/ChinaFun/MTV/Female/1265_3.dat
89 江美琪-上帝的帮助
mms://202.109.105.130/vod/VOD/ChinaFun/MTV/Female/1780_3.dat
90 江美琪-悄悄话
mms://202.109.105.130/vod/VOD/ChinaFun/MTV/Female/1921_3.dat
91 江美琪-如影随形
mms://202.109.105.130/vod/VOD/ChinaFun/MTV/Female/1928_3.dat
92 江美琪-想起
mms://202.109.105.130/vod/VOD/ChinaFun/MTV/Female/7219_3.dat
93 周杰伦-上海1943
mms://61.134.40.133/mtv/zhoujl/sh1943.wmv
94 周杰伦-爸我回來了
mms://61.134.40.133/mtv/zhoujl/bwhll.wmv
95 周杰伦-安静
mms://61.134.40.133/mtv/zhoujl/aj.wmv
96 周杰伦-威廉古堡
mms://61.134.40.133/mtv/zhoujl/wlgb.wmv
97 周杰伦-忍者
mms://61.134.40.133/mtv/zhoujl/rz.wmv
98 周杰伦-世界末日
mms://61.134.40.133/mtv/zhoujl/sjmr.wmv
99 周杰伦-你比从前快乐
mms://61.134.40.133/mtv/zhoujl/nbcqll.wmv
100 周杰伦-蜗牛
mms://61.134.40.133/mtv/zhoujl/wn.wmv
101 周杰伦-双截棍
mms://61.134.40.133/mtv/zhoujl/sjg.wmv
102 周杰伦-龙卷风
mms://61.134.40.133/mtv/zhoujl/ljf.wmv
103 順子-問自己

代理商务中国域名 75元/个
送QQ会员月卡一张,内含10个Q币
单独注册68元
联系QQ:121007007

2003-7-3 17:52
里外都是人
DeathKnight

积分 11291
发贴 1412
注册 2003-6-22
没人看啊

代理商务中国域名 75元/个
送QQ会员月卡一张,内含10个Q币
单独注册68元
联系QQ:121007007

2003-7-3 17:58
uneed
落伍者

积分 11898
发贴 12153
注册 2002-1-13
小芋头那里的？

不卖美国主机啦，有租美国服务器的找我。。。优QQ：88903066（请注名购空间）
2003-7-3 17:59
失落的灵魂
落伍者

积分 2752
发贴 2733
注册 2002-9-22
转贴一把

来~，乖~，点一下
2003-7-3 17:59
里外都是人
DeathKnight

积分 11291
发贴 1412
注册 2003-6-22

Quote:
Originally posted by uneed at 2003-7-3 05:59 PM:
小芋头那里的？

我自己找的

代理商务中国域名 75元/个
送QQ会员月卡一张,内含10个Q币
单独注册68元
联系QQ:121007007

2003-7-3 17:59
uneed
落伍者

积分 11898
发贴 12153
注册 2002-1-13

Quote:
Originally posted by 里外都是人 at 2003-7-3 05:59 PM:

我自己找的

我是说是不是帮他找的？

一个月给你多少米？

不卖美国主机啦，有租美国服务器的找我。。。优QQ：88903066（请注名购空间）
2003-7-3 18:00
里外都是人
DeathKnight

积分 11291
发贴 1412
注册 2003-6-22

Quote:
Originally posted by uneed at 2003-7-3 06:00 PM:

我是说是不是帮他找的？

一个月给你多少米？

100

代理商务中国域名 75元/个
送QQ会员月卡一张,内含10个Q币
单独注册68元
联系QQ:121007007

2003-7-3 18:00
uneed
落伍者

积分 11898
发贴 12153
注册 2002-1-13

Quote:
Originally posted by 里外都是人 at 2003-7-3 06:00 PM:

100

哈哈，别跟我说是美圆啊，HOHO

不卖美国主机啦，有租美国服务器的找我。。。优QQ：88903066（请注名购空间）
2003-7-3 18:01
里外都是人
DeathKnight

积分 11291
发贴 1412
注册 2003-6-22

Quote:
Originally posted by uneed at 2003-7-3 06:01 PM:

哈哈，别跟我说是美圆啊，HOHO

卢布

代理商务中国域名 75元/个
送QQ会员月卡一张,内含10个Q币
单独注册68元
联系QQ:121007007

2003-7-3 18:01
飞儿
落伍者

积分 3486
发贴 3690
注册 2002-4-18
不错

都是一种颜色啊~

我是男的,头象是俺的MM
[url=http://6mb.net/bbs/index.asp][img=88,31]
2003-7-3 18:02
hke
落伍者

积分 1624
发贴 1612
注册 2002-6-14
来自 网E软件园
太好了,转贴哦

Quote:
要下载软件-go→网E软件园

2003-7-3 18:02
GOAO
落伍者

积分 1354
发贴 1292
注册 2001-7-25
不错，有空看看。

.::犯了错.惩罚我.应该的!::.

--==落伍者精华帖整理 [GOAO个人版]==--

先搜索后发帖!少发帖,发精品帖!
2003-7-3 18:16

快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.055021 second(s), 9 queries, Gzip enabled


落伍者论坛 - 网站建设专栏 - 简单评论落伍的人（原创） - powered by Discuz!

落伍者论坛 » 网站建设专栏 » 简单评论落伍的人（原创）

<< [1] [2] [3] [4] [5] [6] [7] [8] [9] [10] ... [13] >>
作者:
标题: 简单评论落伍的人（原创） 上一主题 | 下一主题
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20
简单评论落伍的人（原创）

本来要去睡觉了，既然帖子发到这个地步，说了也就说了，来落伍时间不短了，看的人也多了，其实有不少人，我这里的评论都是说缺点的，熟悉我的人知道我很少骂人，我只是说点意见，希望您能接受，仅此而已。
羽叶小姐，本来您不是我第一个评论的对象，既然今天论坛气氛这么好，我就先说说您吧。
对于您的情况，我可以说只知道朦朦胧胧的东西，隐隐约约的看到。我也知道落伍很多人对您是有看法的，我认为这个事不正常的。如果落伍的某位男性换了一个又一个女朋友，这里是不会有那么多看法的，甚至还有人崇拜，跟帖子说强啊，教教我啊，之类的，因此我深深地感觉到在现实社会中男女仍然是归于不平等的，对于这样的情况我表示深深的同情。
我觉得您最大的疑点问题在于您总是把自己的很私人的东西弄到这里来，今天贴很多心情文章，明天说我想你，过几天突然又换了一个人，虽然可能有许多客观的原因，但是这里会有很多人受不了，因为落伍的很多朋友还是很传统和认真地。我只是觉得，您可以少说一些那样的话题，对于大家的情感上来看是比较容易接受的。
其次，对于您的网络技术，也许比我好，也许您是很多人嘴巴里面说得靠着一个又一个男朋友在做网站，我只是觉得有些东西不要炫耀的好，虽然也许您有很多好东西，但是最好不要炫耀，人言人前不露财，这也是社会给人带来的负面影响，我惊喜地发现最近可能是您比较忙或者其他原因，这样的帖子已经减少了很多。
最后，我希望大家能在这里团结的生活下去。

（第一篇）

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-5-19 23:28
run
落伍者

积分 2092
发贴 2139
注册 2002-1-27
想念一年前的落伍！

此玉米出售:www.cnkey.net
ＹＹ音乐
2003-5-19 23:29
linkhero
落伍者

积分 722
发贴 734
注册 2002-10-6
2003-5-19 23:29
Is.
禁止访问

积分 17342
发贴 17000
注册 2002-1-23
还是灌水有气氛..

Quote:
国际玉米 70元/年 国内玉米 200元/年 各类虚拟主机特价出售
至强型论坛空间 ASP+ACCESS 可选SQL 演示：http://bbs.jetdown.com/ 业务联系QQ：365285

2003-5-19 23:29
情人
落伍者

积分 2552
发贴 2239
注册 2003-2-14
长....

2003-5-19 23:29
天涯·明月·刀
落伍者

积分 2166
发贴 2128
注册 2001-8-15
支持西瓜~

数字卡专卖
2003-5-19 23:29
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20

Quote:
Originally posted by Jetdown.com at 2003-5-19 11:29 PM:
还是灌水有气氛..

还是你不做斑竹的时候有气氛

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-5-19 23:30
service
落伍者

积分 5058
发贴 4914
注册 2003-3-19
不错，顶
2003-5-19 23:30
91now
看我走的多累

积分 12706
发贴 12629
注册 2002-1-27
精辟

91Ting音乐网!!免费在线听立即进入试听!

OE下载
2003-5-19 23:30
让爱做主
又脏又丑农村户口

积分 17166
发贴 17150
注册 2002-7-23
来自 摸摸镇捏捏村
打架好啊

Quote:
国际玉米 70元/年 国内玉米 200元/年 各类虚拟主机特价出售
至强型论坛空间 ASP+ACCESS 可选SQL 演示：http://bbs.jetdown.com/ 业务联系QQ：365285

2003-5-19 23:31
西瓜
落伍拍马国际

积分 23269
发贴 23289
注册 2002-7-20

Quote:
Originally posted by 91now at 2003-5-19 11:30 PM:
精辟

下次有空进一步评论一下你

复活了的西瓜....
看这里今天你为落伍作了多少贡献，
因为我和你的存在，落伍将更加精彩！
因为落伍的精彩，Internet将更加灿烂！
2003-5-19 23:31
天意
落伍者

积分 3571
发贴 3516
注册 2002-12-16
忠言逆耳
2003-5-19 23:31
91now
看我走的多累

积分 12706
发贴 12629
注册 2002-1-27

Quote:
Originally posted by 西瓜 at 2003-5-19 23:31:
下次有空评论一下你

91Ting音乐网!!免费在线听立即进入试听!

OE下载
2003-5-19 23:31
cangudu
落伍者

积分 11139
发贴 11206
注册 2002-6-29
来自 中国叛盟.COM
又咋了？ jet 还在不？ 偶有点问题。。。。。不知道我把程序改了哪里，改不回来了，倒。。。

为朋友我愿意两肋插刀,为MM我愿意插朋友两刀!
2003-5-19 23:31
Is.
禁止访问

积分 17342
发贴 17000
注册 2002-1-23
在~

Quote:
国际玉米 70元/年 国内玉米 200元/年 各类虚拟主机特价出售
至强型论坛空间 ASP+ACCESS 可选SQL 演示：http://bbs.jetdown.com/ 业务联系QQ：365285

2003-5-19 23:32
<< [1] [2] [3] [4] [5] [6] [7] [8] [9] [10] ... [13] >>
快速回复主题
标题: (可选)
选项:
禁用 URL 识别
禁用 Smilies
禁用 Discuz! 代码
使用个人签名
接收新回复邮件通知
[完成后可按 Ctrl+Enter 发布]

可打印版本 | 推荐给朋友 | 订阅主题 | 收藏主题

论坛跳转:

< 联系我们 - 落伍者 >

Powered by Discuz! 3.0 / Licence © 2003, Crossday, Bokavan Co, Ltd
Processed in 0.025830 second(s), 5 queries, Gzip enabled


结束语

来落伍，不落伍
国内大事早知道；国际动态早知道；
各地天气早知道；小道消息早知道
幽默笑话早知道；最新电影早知道；
音乐下载早知道；最新软件早知道；
病毒木马早知道；最新价格早知道；
最新代码早知道；无论如何早知道；
拥有落伍id，您将别无所求。