DHTMLET(TM)

苏昱作品·版权所有
©2002 Rainer Su . All rights reserved .


Rainer's Cascading Style Sheet 2.0 Handbook

End User License Agreement最终用户许可协议
重要须知：
    本《最终用户许可协议》（以下称《协议》）是您（个人或单一实体）与苏昱之间有关苏昱之作品的法律协议。本作品包括计算机软件，并可能包括相关媒体、印刷材料，电子文档，图片。还包括对苏昱提供给您的原作品的任何更新和补充资料。您一旦安装、复制、下载、访问或以其它方式使用本作品，即表示您同意接受本《协议》各项条款的约束。如您不同意本《协议》中的条款，请不要安装或使用本作品。
协议条款：
    本作品受著作权法及国际著作权条约和其它知识产权法和条约的保护。
    本作品（包括但不限于本作品中所含的任何图象、照片、动画、录像、录音、音乐、文字和附加程序）、随附的印刷材料、及本作品的任何副本的产权和著作权，均由苏昱或相关作者拥有。
    本《协议》授予您下列权利：您可以安装、使用、访问、显示、运行本作品。您可以保留多份副本，可以自由传播本作品。
    上述权利不适用于您的任何商业行为或商业用途。否则您务必与苏昱联系。
    苏昱不为本"软件产品"做任何担保。本"软件产品"及任何相关文档以"即此"形式提供，无任何明示的或暗示的担保，包括（但不限于）对可销售性、适用性、或无侵权的暗示担保。使用本"软件产品"所引起的全部风险由您自己承担。
    本协议未明示授予的一切其它权利均为苏昱或相关作者所有。对于此处所指的其他权利，如篡改、反编译、改编、引用、拆解（破坏本作品原始完整性）等，同样请您务必与苏昱先行联系。
    如您未遵守本《协议》的各项条款和条件，在不损害其它权利的情况下，苏昱可终止本《协议》。如此类情况发生，您必须销毁本作品的所有副本及其所有组成部分。苏昱保留对本产品及本协议的最终修改权。

    本《协议》受中华人民共和国法律管辖。

如果您对本《协议》有什么疑问，或您有事想同苏昱联系，请：
    访问：http://www.rainersu.com 　　致信：rainersu@hotmail.com


关于 - Rainer's PicSchema

重要说明：
以下信息截至本文档发布之日止。最新个人信息请在 www.rainersu.com 查阅。
基本情况：
姓名： | 苏昱(Rainer Su)
性别： | 男
生日： | 一九七七年九月十四日
学历： | 小学
形象描述：
长发。麻花辫。为了省事买的都是灰黑色系的衣服。不上相。故照片和本人的观感有较大出入。
如果没被照片吓死或恶心死，建议看看本人。此段信息征女友用。
工作经历：
1996.07-2000.03 | 中国航空油料安徽分工司 (CAOSC) | 油品化验员
2000.03-2000.08 | 北京易得方舟信息技术有限公司 (www.chineseall.com) | 栏目主编 频道经理
2000.09-2001.05 | 上海榕树下计算机有限公司 (www.rongshu.com) | 网页设计 前台工程师
2001.05-2002.04 | 异联信息技术上海有限公司 (Erry) | 软件UI设计师 软件工程师
2002.04-? | 上海贝塔斯曼文化实业有限公司 (Bertelsmann) | 网站负责人
能力自述：
精通网络开发的客户端(前台)技术。专家级的网页技术和丰富的工作经验。
有参与实际大型商业软件产品开发的经历。
多篇小说、散文等发表于《青年作家》、《作家天地》等杂志。
独立开发过多种桌面应用软件产品。
联系方式：

    致信：rainersu@hotmail.com
    访问：www.rainersu.com

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - ©版权所有 苏昱(Rainer Su)，2002 | rainersu@hotmail.com - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


startDownload版本：DHTML Object Model　返回值：无
语法：
Scripting Object .startDownload ( sUrl , fpCallback )
参数：
sUrl | : | 必选项。字符串(String)。指定下载文件的地址。
fpCallback | : | 必选项。指定下载完成后要执行的代码的函数的指针。
返回值：
无
说明：
下载指定的文件。
fpCallback 参数指向的回调函数需要指定一个唯一的参数。当文件下载成功后，文件内容会作为此参数的值传递给函数。
此方法仅仅对于文本文件而言返回的是文档的全部文本内容，假如被下载的文件是其他的格式，则返回的是此格式而非文件内容。
请注意，当 fpCallback 参数指向的回调函数是 Microsoft® Visual Basic® 脚本时，您需要使用 GetRef 函数获取此回调函数的指针。请参看下面的示例代码。
示例：
<script language="VBScript">
function onDownloadDone(s)
MsgBox s
End Function
</script>

<rdl:download id="oDownload" style="behavior:url(#default#download)" />
<div onclick="oDownload.startDownload('download.htm',GetRef('onDownloadDone')"> 下载 </div>


setHomePage版本：DHTML Object Model　返回值：无
语法：
Scripting Object .setHomePage ( sURL )
参数：
sURL : 必选项。字符串(String)。 指定设置为客户端的默认主页的路径和(或)文件名。
返回值：
无
说明：
设置客户端的默认主页。
此方法在设置前会提示用户确认。


setAttribute版本：DHTML Object Model　返回值：无
语法：
Scripting Object .setAttribute ( sAttrName , vAttrValue )
参数：
sAttrName | : | 必选项。字符串(String)。指定持续性属性的名称。
vAttrValue | : | 必选项。指定 sAttrName 的值。可以是任何类型。
返回值：
无
说明：
设定指定的属性的值。
假如 sAttrName 指定的属性尚不存在，则此方法会先添加属性到对象，然后设置其值。
sAttrName 不是大小写敏感的。
对于 userData 行为和 saveSnapshot 行为而言， id 属性是必需的。对于 saveHistory 行为和 saveFavorite 行为而言， id 属性不是必需的，但是提供了可以提高性能，所以推荐使用。
此方法会优先超越( override ) DHTML 的 setAttribute 方法。


save版本：DHTML Object Model　返回值：无
语法：
Scripting Object .save ( sStoreName )
参数：
sStoreName : 必选项。字符串(String)。指向 userData 存储区内的持续性对象的名称。
返回值：
无
说明：
向 userData 存储区内存入指定的存储对象。
此方法向 userData 存储区写入信息。您可以确定到 userData 存储区的访问入口。例如，假如你保存 userData 存储区在 /private/ 目录，则在 /public/ 目录之下的网页不能访问 userData 存储区。


removeDABehavior版本：DHTML Object Model　返回值：无
语法：
Scripting Object .removeDABehavior ( iID )
参数：
iID : 必选项。整数(Integer)。指定要被移除的 DABehavior 的标识。此标识是先前用 addDABehavior 方法添加此 DABehavior 时定义的。
返回值：
无
说明：
移除用addDABehavior 方法添加的 Microsoft® DirectAnimation® behavior (DABehavior) 。


removeAttribute版本：DHTML Object Model　返回值：无
语法：
Scripting Object .removeAttribute ( sAttrName )
参数：
sAttrName : 必选项。字符串(String)。指定持续性属性的名称。
返回值：
无
从对象移除指定的属性。
sAttrName 不是大小写敏感的。
对于 userData 行为和 saveSnapshot 行为而言， id 属性是必需的。对于 saveHistory 行为和 saveFavorite 行为而言， id 属性不是必需的，但是提供了可以提高性能，所以推荐使用。
此方法会优先超越( override ) DHTML 的 removeAttribute 方法。


navigateFrame版本：DHTML Object Model　返回值：有
语法：
Scripting sRetVal ＝ Object .navigateFrame ( sHTTP , sTarget )
参数：
sHTTP : 必选项。字符串(String)。任何正确的 HTTP 地址。
sTarget : 必选项。字符串(String)。
sName | : | 指定目标窗口(框架)的名字。
_self | : | 在当前窗口中打开。
_top | : | 在所有框架之外的最顶层窗口中打开。假如当前窗口无框架结构，此参数值等同于 _self 。
返回值：
sRetVal : 字符串(String)。如果成功返回 OK 。如果不成功返回错误信息。
说明：
导航窗口或框架到指定的地址并用文件夹视图方式显示目录内容。


navigate版本：DHTML Object Model　返回值：有
语法：
Scripting sRetVal ＝ Object .navigate ( sHTTP )
参数：
sHTTP : 必选项。字符串(String)。任何正确的 HTTP 地址。
返回值：
sRetVal : 字符串(String)。如果成功返回 OK 。如果不成功返回错误信息。
说明：
导航窗口到指定的地址并用文件夹视图方式显示目录内容。此方法等同于 sTarget 参数值为 _self 的 navigateFrame 方法。


load版本：DHTML Object Model　返回值：无
语法：
Scripting Object .load ( sStoreName )
参数：
sStoreName : 必选项。字符串(String)。指向 userData 存储区内的持续性对象的名称。
返回值：
无
说明：
从 userData 存储区内载入指定的存储对象。
通过指定的在网站根目录和当前目录之间的目录树内的路径，您可以确定到 userData 存储区的访问入口。例如，假如你保存 userData 存储区在 /private/ 目录，则在 /public/ 目录之下的网页不能访问 userData 存储区。


isHomePage版本：DHTML Object Model　返回值：有
语法：
Scripting bHomePage = Object .isHomePage ( sURL )
参数：
sURL : 必选项。字符串(String)。 指定和客户端的默认主页比较的路径和(或)文件名。
返回值：
bHomePage : 布尔值(Boolean)。false | true
false | : | sURL 是客户端指定的默认主页。
true | : | sURL 不是客户端指定的默认主页。
说明：
探测 sURL 是否客户端指定的默认主页。
假如调用此方法的页面地址和客户端当前的默认主页不在同一个域内则此方法总是返回 false 。例如，如果 http://www.dhtmlet.com 是您的默认主页，而您在 http://www.dhtmlet.com/demo/index.html 页面内调用此方法，则会返回 true 。而您若从其他域名下的页面内调用此方法则会返回 false 。


getAttribute版本：DHTML Object Model　返回值：有
语法：
Scripting vAttrValue = Object .getAttribute ( sAttrName )
参数：
sAttrName : 必选项。字符串(String)。指定持续性属性的名称。
返回值：
vAttrValue : 任何变量类型。假如一个显式属性不存在，则会返回一个空字符串。假如是自定义属性不存在，则会返回 null 。
说明：
获取指定的属性的值。
sAttrName 不是大小写敏感的。
对于 userData 行为和 saveSnapshot 行为而言， id 属性是必需的。对于 saveHistory 行为和 saveFavorite 行为而言， id 属性不是必需的，但是提供了可以提高性能，所以推荐使用。
此方法会优先超越( override ) DHTML 的 getAttribute 方法。


addDABehavior版本：DHTML Object Model　返回值：无
语法：
Scripting Object .addDABehavior ( oBehavior , iID )
参数：
oBehavior | : | 必选项。对象(Element)。指定 DABehavior 要被添加到的对象。
iID | : | 必选项。整数(Integer)。指定要被添加的 DABehavior 的标识。此标识用于以后移除此 DABehavior 的 removeDABehavior 方法调用。
返回值：
无
说明：
添加不在动画制作模型中的 Microsoft® DirectAnimation® behavior (DABehavior) 到运行列表。
当系统开始动画时，附加的 DABehavior 会和源动画中的行为在同一时间开始运行。


availHeight版本：DHTML Object Model　只读
语法：
Scripting iHeight = Object.availHeight
取值：
iHeight : 整数值(Integer)。单位为像素(px)。
说明：
检索系统屏幕工作区的高度。不包括 Microsoft® Windows® taskbar 。
可参阅 screen 对象的 availHeight 特性。


availWidth版本：DHTML Object Model　只读
语法：
Scripting iWidth = Object.availWidth
取值：
iWidth : 整数值(Integer)。单位为像素(px)。
说明：
检索系统屏幕工作区的宽度。不包括 Microsoft® Windows® taskbar 。
可参阅 screen 对象的 availWidth 特性。


bufferDepth版本：DHTML Object Model　只读
语法：
Scripting iBitsPerPixel = Object.bufferDepth
取值：
iBitsPerPixel : 整数值(Integer)。
0 | : | 默认值。无外部缓冲发生。 colorDepth 特性设置为屏幕深度。
-1 | : | 缓冲区深度依据屏幕深度调整。 colorDepth 特性设置为屏幕深度。
1, 4, 8, 15, 16, 24, 32 | : | 离屏缓冲依据指定的位/象素的值发生。 colorDepth 特性也被设为相同的值。 15 等于16位/象素。因为在 5-5-5 的 红-绿-蓝 布局里只使用了 15 位。
说明：
检索离屏位图缓冲区的色彩每个象素所使用的位数。
不被支持的值会导致此特性值返回 -1 。
当此特性值为 -1 并且用户改变了影响显示深度的系统设置时，缓冲区深度会自动更新到新的深度。但是当此特性值为有效值时，前述的情况不会发生。
可参阅 screen 对象的 bufferDepth 特性。


colorDepth版本：DHTML Object Model　只读
语法：
Scripting iBitsPerPixel = Object.colorDepth
取值：
iBitsPerPixel : 整数值(Integer)。1 | 4 | 8 | 15 | 16 | 24 | 32
屏外缓冲的发生基于确定的位/象素的值。 15 等于16位/象素。因为在 5-5-5 的 红-绿-蓝 布局里只使用了 15 位。
说明：
检索目标设备或缓冲区的色彩所使用的位/象素的值。
若 bufferDepth 特性值为 0 或 -1 时，此特性值等于屏幕或打印机的位/象素的值。否则此特性值 等于 bufferDepth 特性的值。
可参阅 screen 对象的 colorDepth 特性。


connectionType版本：DHTML Object Model　只读
语法：
Scripting sConnectionType = Object.connectionType
取值：
sConnectionType : 字符串(String)。lan | modem | offline
lan | : | 通过局域网(本地网)连接。
modem | : | 当前使用调制解调器连接。
offline | : | 用户当前在离线工作。
说明：
检索当前使用的连接类型。


cookieEnabled版本：DHTML Object Model　只读
语法：
Scripting bEnabled = Object.cookieEnabled
取值：
bEnabled : 布尔值(Boolean)。false | true
false | : | 浏览器未提供对 cookies 的支持。
true | : | 浏览器提供对 cookies 的支持。
说明：
检索在浏览器中客户端 cookies 是否被激活。
可参阅 navigator 对象的 cookieEnabled 特性。


cpuClass版本：DHTML Object Model　只读
语法：
Scripting bEnabled = Object.cpuClass
取值：
bEnabled : 字符串(String)。x86 | Alpha
x86 | : | CPU 是 (Intel) x86 处理器。
Alpha | : | CPU 是 (Digital) Alpha 处理器。
说明：
检索系统 CPU 类型。
可参阅 navigator 对象的 cpuClass 特性。


expires版本：DHTML Object Model　读/写
语法：
Scripting Object.expires = sUTCString
取值：
sUTCString : 字符串(String)。全球标准时间 (UTC)格式。全球标准时间指的是由世界时间标准设定的时间。原先也被称为格林威治标准时间或者 GMT 。
说明：
设置或检索随 userData 行为持续的数据的到期时间。
此属性指明保存的数据信息存在的时间长度。当浏览器检查日期发现此属性指明的时间到期时，Microsoft® Internet Explorer 会移除存储的信息。


FOLDER | folder版本：DHTML Object Model　读/写
语法：
XML | < Element FOLDER = sFolder >
Scripting | object.folder = sFolder
取值：
sFolder : 字符串(String)。指定或检索正确的命名空间扩展、地址，或路径。
说明：
指定或检索正确的命名空间扩展、地址，或路径。
Microsoft® Internet Explorer 5+ 会使用此属性替换 a 要素的 href 属性在浏览器窗口中显示网络目录视图。而不支持此属性的浏览器则依旧使用 href 属性进行导航。


height版本：DHTML Object Model　只读
语法：
Scripting iHeight = Object.height
取值：
iHeight : 整数值(Integer)。单位为像素(px)。
说明：
检索系统屏幕的垂直分辨率。
可参阅 screen 对象的 height 特性。


image版本：DHTML Object Model　读/写
语法：
Scripting object.image = oImage
取值：
oImage : 对象(Element)。 DAImage 对象。即 anim:DA 要素显示的图象。
说明：
指定或检索 Microsoft® DirectAnimation® Image(DAImage) 对象。即 anim:DA 要素显示的图象。


javaEnabled版本：DHTML Object Model　只读
语法：
Scripting bEnabled = Object.javaEnabled
取值：
bEnabled : 布尔值(Boolean)。false | true
false | : | 微软虚拟机(Microsoft VM)未被激活。
true | : | 微软虚拟机(Microsoft VM)被激活。
说明：
检索微软虚拟机(Microsoft VM)是否被激活。
可参阅 navigator 对象的 javaEnabled 方法。


platform版本：DHTML Object Model　只读
语法：
Scripting bEnabled = Object.platform
取值：
bEnabled : 字符串(String)。Win32 | Win16 | WinCE
Win32 | : | 浏览器运行于 Windows 32位平台。
Win16 | : | 浏览器运行于 Windows 16位平台。
WinCE | : | 浏览器运行于 Windows CE位平台。
说明：
检索浏览器所运行于的系统平台。
可参阅 navigator 对象的 platform 特性。


sound版本：DHTML Object Model　读/写
语法：
Scripting object.sound = oSound
取值：
oSound : 对象(Element)。 DASound 对象。即 anim:DA 要素播放的声音。
说明：
指定或检索 Microsoft® DirectAnimation® sound(DASound) 对象。即 anim:DA 要素播放的声音。


statics版本：DHTML Object Model　只读
语法：
Scripting oLibrary = object.statics
取值：
oLibrary : 对象(Element)。包含通过 DirectAnimation 可用的函数和特性的对象。
说明：
指定或检索包含和Microsoft® DirectAnimation®一起使用的 DAStatics 类库的对象。


systemLanguage版本：DHTML Object Model　只读
语法：
Scripting sLanguage = Object.systemLanguage
取值：
sLanguage : 字符串(String)。语言代码。请参阅「 语言代码表 」。
说明：
检索当前系统的默认语言。
可参阅 navigator 对象的 systemLanguage 特性。


TARGET | target版本：DHTML Object Model　读/写
语法：
XML | < Element TARGET = sTarget >
Scripting | object.target = sTarget
取值：
sTarget : 字符串(String)。sName | _self | _top
sName | : | 窗口或框架的名字。
_self | : | 导航到当前窗口(框架)。
_top | : | 导航到最高层窗口(框架)。
说明：
指定或检索视图导航的目标窗口或框架的名字。
此特性值是大小写敏感的。


userLanguage版本：DHTML Object Model　只读
语法：
Scripting sLanguage = Object.userLanguage
取值：
sLanguage : 字符串(String)。语言代码。请参阅「 语言代码表 」。
说明：
检索当前的用户语言。
可参阅 navigator 对象的 userLanguage 特性。


width版本：DHTML Object Model　只读
语法：
Scripting iWidth = Object.width
取值：
iWidth : 整数值(Integer)。单位为像素(px)。
说明：
检索系统屏幕的水平分辨率。
可参阅 screen 对象的 width 特性。


XMLDocument版本：DHTML Object Model　只读
语法：
Scripting oXMLObject = Object.XMLDocument
取值：
oXMLObject : 对象(Object)。对对象提供的 XML DOM 的引用。
说明：
获取对由对象所提供的 XML 文档对象模型(DOM)的引用。
当数据持续行为被应用到一个要素时，在它所提供的XML DOM中会自动建立一个根节点。这个节点可以通过 documentElement 特性访问。你可以使用 setAttribute 添加属性到根节点。还可以使用 appendChild 添加子节点到根节点。
当 onload 和 onsave 事件触发时，此特性仅仅对 saveFavorite 和 saveHistory 行为可用。


Appendix　附 录

  1. Color Table 颜色表


DHTMLET(TM)

Introduction手册简介
手册说明：
本手册针对的是已有一定网页设计制作经验的读者。其目的是提供完整清晰的样式表内容的快速索引及进阶帮助。所以对于网页制作和样式表的基础知识，仅简单介绍，恕不赘述。


Language Codes 　语言代码

代码(Code) | 语言(Language) | 代码(Code) | 语言(Language) | 代码(Code) | 语言(Language)
af | Afrikaans | sq | Albanian | zu | Zulu
ar-sa | Arabic (Saudi Arabia) | ar-iq | Arabic (Iraq) | xh | Xhosa
ar-eg | Arabic (Egypt) | ar-ly | Arabic (Libya) | ji | Yiddish
ar-dz | Arabic (Algeria) | ar-ma | Arabic (Morocco) | ve | Venda
ar-tn | Arabic (Tunisia) | ar-om | Arabic (Oman) | vi | Vietnamese
ar-ye | Arabic (Yemen) | ar-sy | Arabic (Syria) | uk | Ukrainian
ar-jo | Arabic (Jordan) | ar-lb | Arabic (Lebanon) | ur | Urdu
ar-kw | Arabic (Kuwait) | ar-ae | Arabic (U.A.E.) | tn | Tswana
ar-bh | Arabic (Bahrain) | ar-qa | Arabic (Qatar) | tr | Turkish
eu | Basque | bg | Bulgarian | th | Thai
be | Belarusian | ca | Catalan | ts | Tsonga
zh-tw | Chinese (Taiwan) | zh-cn | Chinese (PRC) | sv | Swedish
zh-hk | Chinese (Hong Kong, S.A.R. China) | zh-sg | Chinese (Singapore) | sv-fi | Swedish (Finland)
hr | Croatian | cs | Czech | es-pr | Spanish (Puerto Rico)
da | Danish | nl | Dutch (Standard) | sx | Sutu
nl-be | Dutch (Belgium) | en | English | es-hn | Spanish (Honduras)
en-us | English (United States) | en-gb | English (Great Britain) | es-ni | Spanish (Nicaragua)
en-au | English (Australia) | en-ca | English (Canada) | es-bo | Spanish (Bolivia)
en-nz | English (New Zealand) | en-ie | English (Ireland) | es-sv | Spanish (El Salvador)
en | English (Caribbean) | en-bz | English (Belize) | en-za | English (South Africa)
en-tt | English (Trinidad) | et | Estonian | en-jm | English (Jamaica)
fi | Finnish | fr | French (Standard) | fo | Faeroese
fr-be | French (Belgium) | fr-ca | French (Canada) | fa | Farsi
gd | Gaelic (Scotland) | gd-ie | Gaelic (Ireland) | fr-ch | French (Switzerland)
de | German (Standard) | de-ch | German (Switzerland) | fr-lu | French (Luxembourg)
de-li | German (Liechtenstein) | el | Greek | de-at | German (Austria)
he | Hebrew | hi | Hindi | de-lu | German (Luxembourg)
in | Indonesian | it | Italian (Standard) | hu | Hungarian
it-ch | Italian (Switzerland) | ja | Japanese | is | Icelandic
lv | Latvian | lt | Lithuanian | ko | Korean
mk | FYRO Macedonian | ms | Malaysian | ko | Korean (Johab)
no | Norwegian (Nynorsk) | pl | Polish | mt | Maltese
pt-br | Portuguese (Brazil) | pt | Portuguese (Standard) | no | Norwegian (Bokmal)
ro-mo | Romanian (Moldavia) | ru | Russian | rm | Rhaeto-Romanic
ru-mo | Russian (Moldavia) | sz | Sami (Lappish) | ro | Romanian
sk | Slovak | sl | Slovenian | sr | Serbian (Cyrillic)
sb | Sorbian | es | Spanish (Spain – Traditional) | sr | Serbian (Latin)
es-gt | Spanish (Guatemala) | es-cr | Spanish (Costa Rica) | es-mx | Spanish (Mexico)
es-pa | Spanish (Panama) | es-do | Spanish (Dominican Republic) | es | Spanish (Spain – Modern)
es-pe | Spanish (Peru) | es-ar | Spanish (Argentina) | es-ve | Spanish (Venezuela)
es-ec | Spanish (Ecuador) | es-cl | Spanish (Chile) | es-co | Spanish (Colombia)
es-uy | Spanish (Uruguay) | es-py | Spanish (Paraguay) |  |

请参阅属性: userLanguage 、 systemLanguage