eWebEditor - eWebSoft在线编辑器

WEB技术 ｜ WEB交易 ｜ WEB人才 ｜ 免费邮箱 ｜ 交流论坛 ｜ 会员服务
联系我们 [image] 技术支持、BUG报告、产品交流论坛
最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
特 性 介 绍

eWebEditor功能特点：

eWebEditor除了具有前台的调用功能外，还具有很强的后台管理功能，能够对编辑器多种功能进行各种有效的自定义，具体如下：

  • 大量常用功能按钮
    eWebEditor包含了日常所要用到所有的样式功能，如复制、剪切、粘贴、表格、图片、文件、字体、颜色等，并在不断的补充中。
  • 内附文件上传功能
    eWebEditor内涉及的文件相关的功能中，如图片来源，媒体文件来源，附件来源等，都自带有从客户端直接上传到服务器端的功能。
  • 功能界面可自定义
    eWebEditor内的功能按钮及显示样式允许自定义。您可以根据自己实际需要定制各按钮的图片，样式，按钮功能的个数等。
  • 同时多个编辑器支持
    可以在同一个表单Form里有多个eWebEditor，也可以在同一页里有多个eWebEditor，也可以有多个样式不同的eWebEditor。
  • 大文件支持
    一般的输入框有102399字节的限制（100K左右），大文本内容不能使用，而eWebEditor理论上支持无限大文件。
  • 多样式支持
    您只需要在您的整个网站中使用一个eWebEditor，可以定制多个样式，在不同的地方使用不同的样式，而没必要在要用的地方都要拷进去。如：一个样式适合宽度为400的屏幕，共10个工具按钮；一个样式适合宽度为500的屏幕，共15个按钮等。
  • 前台支持
    一般很多使用都把涉及HTML编辑功能的脚本程序都放在管理员的后台管理中进行，而如允许用户在线投稿的前台却不敢使用，怕的是恶意的脚本。eWebEditor自带有一个解释函数，方便前台显示，根据不同的参数样式显示相应的HTML脚本，去除恶意脚本。
  • 调用简单
    在编程开发时，只要写一句代码就可以完成eWebEditor的调用。
  • 自动提交
    现在很多的在线编辑器，在编辑完后，都要点一下保存功能，或者在提交按钮中加入脚本进行处理，然后再提交，而eWebEditor只需加入调用的那一行外，无需上面的操作处理。
  • 自动获取远程文件
    利用远程文件自动获取功能，可以把别人服务器上的图片等文件自动传到自己的服务器，不要当心别人的站点关了，本地链接的文件不存在的问题，也不要再一个个下载下来再传上去了，全过程完全自动。
  • 相对或绝对路径
    对于在线编辑器来说，路径问题一直是一个难点，基本上市面上的在线编辑器所编辑出来的内容链接都用的是带域名的绝对全路径（如：http://www.xxx.com/xxx/xxx.gif）。eWebEditor充分解决了此问题，只要简单设置一下三种路径形式可选（相对路径、绝对根路径、绝对全路径），完全摆脱了站点或系统或目录迁移而带来的路径问题。
  • 图形热点链接
    eWebEditor的此应用绝对是所有在线编辑器软件中的始创，能够在线编辑实现图形的热点链接功能，即一个图片可以按区块链接到多个地址。
  • 状态保持
    现在很多的在线编辑器，在提交后，如果服务器端较验没成功，点击“退回”时，原来编辑器中编辑的内容就会丢失，而eWebEditor会保持编辑后的状态，并且能够与Reset按钮同步Reset。
  • 智能粘贴
    eWebEditor具有三种粘贴方式，常规方式粘贴，纯文本方式粘贴，或者以Word方式粘贴，如果剪贴板中的内容是Word形式的，将有提示是否去除Word格式，因为Word粘进来文档可是非常非常的大，冗余的代码实在的多。
  • 大小自适应
    eWebEditor可以按你调用的宽度和高度自适应编辑器的大小，特别是高度，这是很多编辑器所不具有的，大大方便了调用，使页面能够达到更好的效果。
  • 多种编辑模式
    eWebEditor具有4种编辑模式，有：HTML代码模式、可视设计模式、纯文本模式、预览模式，可以满足所有应用的需要。
  • 完善的接口
    eWebEditor作为一个强大的在线编辑模块，提供了完善的接口，满足更高级用户的需要，您可以通过接口实时控制或者获取编辑器的内容或者状态。

eWebEditor技术特点：

eWebEditor不仅仅是一个产品，更是一个WEB技术的代表，她融入了我们对WEB技术应用的展望。

  • 开放源代码
    eWebEditor源程序完全开放，使得开发人员更能了解其内部的动作，使得程序能够得到更好的调试安装，并做到资源共享。
  • 绿色软件
    eWebEditor不需要在服务器端安装特定的组件，自身也不带组件，使得软件基本可以在所有的Internet虚拟主机上使用。同时，她不需要在客户端安装任何插件，做到真正的绿色。
  • 代码规范
    eWebEditor是一个软件产品，在程序编码中，我们始终强调其编码的规范性。我们不仅仅需要的是一个产品应用，我们更需要的是一个编程规范。我们在产品的不断完善同时，完善我们的编码规范。如适当的注释，很好的组织结构，使其也成为编程人员的学习参考资料。我们也将定时发布我们的编码规范。挑战无处不在，挑战代码极限！
  • 强大错误自检
    eWebEditor在程序编写中对每个变量、参数都进行了严格的错误检测，不管用户如何操作，绝不出现意料之外的信息，防止程序漏洞的产生。
  • 绝无后门
    我们经常发现在网上下载的很多程序都自带有后门，不但可以影响此软件的正常使用，更有的可以破坏整个网站。此例子很多，在此不赘述，不管他们出自什么用心，我们是绝不会这样做的。

eWebEditor使用特点：

eWebEditor是一个所见即所得的在线编辑器。顾名思义，就是能在网络上使用所见即所得的编辑方式进行编辑图文并茂的文章、新闻、讨论贴、通告、记事等多种文字处理应用。其主要特点如果下：

  • 所见即所得
    即通过编辑器编辑的文字、图片等HTML标记输出到页面的效果和编辑时显示的效果一致，让使用者方便地对编辑的内容进行修改、排版等。
  • 自动转换为HTML代码
    在编辑状态编辑的文字、图片等内容都在后台自动转换为可被浏览器识别的HTML标记语言，使用者更能在代码状态在对代码标记进行修改。
  • 简单易用
    编辑器的编辑及使用方法与FrontPage、Dreamweaver等著名主页制作软件类似。无需任何HTML语法知识、儍瓜式的操作让即使没有主页制作经验的使用者也能快速上手。
  • 方便快捷
    使用所见即所得的编辑器能快捷、方便地编辑出效果一流的图文效果，如果使用纯手工编写代码的方法编辑则需要浪费大量时间及精力。

关于我们 - 本站动态 - 本站导航 - 友情链接 - 投稿专栏 - 邮件列表 - 本站留言 - 广告合作 - 版权声明 - 联系我们
Copyright © 2003-2004 webasp.net ewebsoft.com, All Rights Reserved .
webmaster@webasp.net


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
购 买 指 南

购买说明： [TOP] [在线购买]

eWebEditor是个共享软件，完全开放源代码，用户分为免费用户、标准用户、专业用户、VIP用户四种，四种用户在某一版本的功能上基本没有区别，区别在于授权许可、支持服务及部分高级功能上。

授权许可： [TOP] [在线购买]

eWebEditor系eWebSoft.com独立开发软件，eWebSoft.com依法享有该软件之版权。若您准备使用eWebEditor，请仔细阅读以下的授权许可。

  • eWebEditor免费授权许可(eWebEditor Free License)
    此授权许可个人在无任何商业目的下的免费使用，您可用于学习、个人无任何商业目的的站点、个人发布的只有免费版的软件。任何的公司、组织、团体，单位都不在此范围之内，任何有盈利途径的个人站点也不在此范围之内。免费用户版在eWebEditor主界面下会有显著版权标识，用户不能去除此信息。

  • eWebEditor标准授权许可(eWebEditor Standard License)
    此授权许可用户在有盈利途径的个人站点、商业站点（包括公司、组织、团体、单位的介绍交流站点）上使用。授权用户为了界面上的整洁美观，可以去除eWebEditor在主界面下的版权标识。授权用户只能在自己的站点上使用，不能把eWebEditor作为任何产品的一部分进行发布或销售。

  • eWebEditor专业授权许可(eWebEditor Professional License)
    此授权许可用户除了具有标准授权许可中的所有权利，还可将eWebEditor作为其自主开发产品的一部分进行发布或销售，但每个授权许可最多不能超过10个产品。

  • eWebEditor VIP授权许可(eWebEditor VIP License)
    此授权许可用户除了具有专业授权许可中的所有权利，用户自主开发的把eWebEditor作为其一部分的产品个数不受限制。

版本比较： [TOP] [在线购买]

以下图例中： 表示不支持； [image] 表示支持。以下价格单位为人民币。

 | 免费用户版 | 标准用户版 | 专业用户版 | VIP用户版
授权许可类型 | 免费授权许可 | 标准授权许可 | 专业授权许可 | VIP授权许可
完全提供源代码 |  |  |  |
无域名限制 |  |  |  |
无IP限制 |  |  |  |
无服务器数限制 |  |  |  |
无最终用户连接数限制 |  |  |  |
无商业目的使用 |  |  |  |
允许不显示版权标识信息 |  |  |  |
商业目的站点使用 |  |  |  |
加入自主开发产品发布或销售 |  |  |  |
允许加入产品数量 |  |  | <=10 | 无限制
免费技术支持服务 |  | 1年 | 3年 | 终生
免费升级服务范围 |  | 同一主版本 | 同一主版本 | 所有版本
新版本更新通知服务 |  |  |  |
提前7天下载产品最新版本 |  |  |  |
组件相关高级功能 |  |  |  |
SQL SERVER数据库支持 |  |  |  |
ORACLE数据库支持 |  |  |  |
价格 | 免费 | 200元 | 800元 | 1500元
 |  | [购买] | [购买] | [购买]

软件升级服务说明：同一主版本指的是软件的主版本号不变的情况下持续升级，当前软件的版本是v2.00，主版本是2，即在v3.00出来之前都提供免费升级服务。

提示：在购买之前请仔细阅读我们的[授权许可]描述，并确定选择了正确的[授权许可]类型。

产品价格： [TOP] [在线购买]

以下价格单位为人民币。

  • eWebEditor Version 2.XX：
    当前包括 [Version 2.00] [Version 2.16] [Version 2.75] [Version 2.80]
    · 标准用户版：200元
    · 专业用户版：800元
    · VIP 用户版：1500元

  • eWebEditor Verion 2.00以前版本：
    · 不再提供购买，以前购买的用户相应升级为标准用户版。

  • eWebEditor相关定制服务：
    · 价格面议

购买流程： [TOP] [在线购买]

如果您准备购买我们的产品，我们感谢您的大力支持，并请您参看以下步骤。

填写订单　→　确认订单　→　得到订单号　→　付款　→　收到产品及客户编号

  1. 阅读[授权许可]，确保正确选择了您要购买的[授权许可]类型。
  2. 选择支付方式：本站已开通1st-pay™在线支付功能，您可以选择在线支付或者通过银行转账汇款。通过查阅1st-pay™在线支付支持的卡种和银行转账汇款方式，选择最适合您的付款方式。
  3. 点击[在线购买]，填写客户资料表，选择购买的产品类型，并选择支付方式。
  4. 点击“提交”后，将显示确认页，确认您输入的资料信息。
  5. 点击“确认”后，页面将显示您此次购买的临时订单号，请记下此订单号，以做特殊情况下的订单查询使用。
  6. 接下来，跟据您选择的支付方式，进行以下步骤：
    • 如果您选择了在线支付，在刚才的订单号显示页会有一个“进入在线支付”的按钮，点击进入1st-pay™在线支付平台，支付成功后，您的购买订单立即生效，在我们的页面上会显示你的真实客户编号，请记住此客户编号，至此，您的购买操作完成。我们会在第一时间会把软件产品发至您购买时填写的邮箱。
    • 如果您选择了银行转账汇款的方式，请您及时把相应的款项汇入我们的账户，汇入后请通过邮件（webmaster@webasp.net）或QQ（589808）的方式通知我们查收，同时请告之我们您的订单号及汇入时间。当我们确认收到款项后，我们会在第一时间把您的真实客户编号和您购买的软件产品发至您购买时填写的邮箱。
  7. 您收到我们的客户编号及软件产品。购买流程结束。

提示：请妥善保存您的客户编号，客户编号是我们认定授权许可及产品服务的一个重要条件。

1st-pay™在线支付支持的卡种： [TOP] [在线购买]

1st-pay™支持银行卡种列表清单--人民币卡(由于银行卡种不断增加中，请以最新的支持清单为准）:

工商银行
牡丹灵通卡（全国）
牡丹信用卡（全国）
牡丹贷记卡（全国）
建设银行
龙卡信用卡（上海）
龙卡储蓄卡（上海）
龙卡信用卡（黑龙江）
龙卡储蓄卡（黑龙江）
龙卡储蓄卡（广东）
龙卡储蓄卡（广东）
龙卡信用卡（厦门）
龙卡储蓄卡（厦门）
龙卡信用卡（海南）
龙卡储蓄卡（海南）
中国银行
长城信用卡（广州）
长城信用卡（海南）
长城借记卡（厦门）
长城借记卡（广州）
交通银行
万事达信用卡（广州）
维撒信用卡（广州）
万事顺借记卡（广州）
互联借记卡（广州）
太平洋信用卡（海南）
太平洋借记卡（海南）
借记卡用户（郑州）
借记卡用户（厦门）
太平洋借记卡（深圳）
农业银行
信用卡用户(全国）
星座卡用户（广东省）
储蓄提款卡用户（广州）
借记卡用户（厦门）
白玉兰卡（厦门）
金穗信用卡（海南）
招商银行
一卡通（全国）
广东发展
广发信用卡(全国)
广发理财通卡(全国)
民生银行
民生卡网上银行（全国）
深圳发展
借记卡（全国）
借记卡（海南）
华夏银行
华夏卡(全国)
兴业银行
兴业卡（全国）
兴业卡（厦门）
光大银行
阳光卡(全国)
阳光卡（厦门）
阳光卡（海南）
中国邮政
邮政绿卡(广东）
邮政绿卡（厦门）
中信实业
信用卡(全国)
理财宝（全国）
借记卡（全国）
上海浦发
东方卡（全国）
东方卡（深圳）
广东农村信用合作社
储蓄卡（广州）
广州市商业发展银行
储蓄卡（广州）

银行转账汇款方式： [TOP] [在线购买]

转帐或汇款后请与我们联系。转帐时建议多转几角或几分的零头，以方便和其它用户区别。例如标准用户版需200元整，您可以转帐200.10元，这样我们能尽快确认您的到帐信息，也方便您的业务办理。

    手续费1%，最高50元，马上到帐

    存折号(柜台办理使用)：1402 2222 0110 1218 812
    卡　号(网上转帐使用)：9558 8014 0210 4267 825
    开户人：马铃

    汇款方法：到工行柜台填写汇款单，写明帐号和开户人交由营业员办理。

    注意：网上转帐城市区号可不填（到柜台办理要填）。同时，切记在表格下面一行的快速汇款（手续费0.5%）栏后面“打勾”，否则会变成普通汇款（手续费更高要1%），而且到帐时间要2、3天

    开户行：招商银行福州市分行
    开户人：马铃
    开户帐号：20176725
    开户区号：0591

    汇款方法：请使用招行一卡通个人银行专业版进行网上支付，或者到本地招商银行柜台转帐或存入现金。

    手续费1%，办理速汇通2小时到帐

    帐号：4367 4218 2000 0395 021
    开户人：马铃
    开户行：福建省分行城北鼓楼支行专柜

    汇款方法：到建行柜台填写速汇通汇款单，写明帐号、开户人和开户行，交由营业员办理。

    使用存款单，一定不要用汇款单，无须手续费，马上到帐

    卡号：95599 8006 13201 86010
    开户人：马铃

    汇款方法：到农行柜台填写存款单，写明帐号和开户人交由营业员办理。

    ★ 汇款确认 ★

    为了能够以最快的方式处理您的业务，请您在汇款之后立即对您的汇款进行汇款确认。请发email至webmaster@webasp.net或QQ（589808）进行确认，内容包括以下内容：

    姓名：
    订单号：（就是你在线申请得到的订单号）
    汇款金额：
    汇款时间：
    汇款方式：
    汇款地点：
    汇出行：
    汇入行：

售后服务： [TOP] [在线购买]

售后服务主要包括以下几个方面的内容：

  • 产品使用方法，疑难解答。
  • 产品升级技术支持服务。
  • 服务方式：远程维护，电话服务，邮件服务，在线QQ服务。
  • 技术支持相关说明，请参见技术支持栏目。


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
在 线 购 买

第一步：填写订单

非常感谢您选择我们的产品，为了能为您提供更好的服务，请您详细填写以下资料，带*项目为必填项目。

购买信息
*购买产品： 确定已知[各版本的区别]
*付款方式： 在线支付支持的卡种清单|银行转账汇款支持的卡种清单
用户信息
*真实姓名：
*身份证：
*Email： 付款成功后，我们将会把客户编号及产品发至此邮箱
*联系电话：
*联系地址：
客户名称：
如果填写则会在我们的客户列表中以此信息显示，其它资料不会显示给公众！
备注说明：


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
版 权 声 明

eWebEditor版权声明：

“eWebEditor（eWebSoft在线编辑器）”系eWebSoft.com独立开发软件，eWebSoft.com依法享有该软件之版权，此软件为共享软体（shareware）提供免费或付费使用，许可公众无偿学习使用。但该软件使用者（含个人、法人或其它组织）：

  1. 非经eWebSoft.com授权许可，不得将之用于盈利或非盈利性的商业用途。
  2. 为适应实际的计算机应用环境或者改进其功能、性能，可以进行必要的修改，但不得去除eWebSoft.com的版权标示；未经eWebSoft.com书面授权许可，不得向任何第三方提供修改后的软件。
  3. 使用该软件必须保留eWebSoft.com的版权声明，将该软件从原有自然语言文字转换成另一自然语言文字的，仍应注明出处。
  4. 不得有其他侵犯eWebSoft.com软件版权之行为。

凡有上述侵权行为的个人、法人或其它组织，必须立即停止侵权并对其侵权造成的一切不良后果承担全部责任。对此前，尤其是此后侵犯eWebSoft.com版权的行为，eWebSoft.com将依据《著作权法》、《计算机软件保护条例》等相关法律、法规追究其经济责任和法律责任。

eWebEditor版权信息：

  • 产品名称：eWebEditor（eWebSoft在线编辑器）
  • 版权所有：eWebSoft.com
  • 程序制作：eWeb开发团队
  • 主页地址： http://www.eWebSoft.com http://www.webasp.net


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
在 线 演 示

单个编辑器调用：

  • 最新推出 - mini样式
    全菜单，全功能，基于酷蓝界面，工具栏占位小，最佳调用宽度550px
    演示地址：http://eWebEditor.webasp.net/Example/s_mini.asp
  • 自带样式1 - 默认样式
    标准Office风格按钮+灰色调，包括部分主要功能按钮，最佳调用宽度550px
    演示地址：http://eWebEditor.webasp.net/Example/standard.asp
  • 自带样式2 - 全功能，按按钮分类建工具栏
    标准Office风格按钮+灰色调，包括所有功能按钮，最佳调用宽度550px，只适合于演示
    演示地址：http://eWebEditor.webasp.net/Example/s_full.asp
  • 自带样式3 - 淡色调
    标准Office风格按钮+淡色调，包括部分主要功能按钮，最佳调用宽度550px
    演示地址：http://eWebEditor.webasp.net/Example/s_light.asp
  • 自带样式4 - 蓝色调
    标准Office风格按钮+蓝色调，包括部分主要功能按钮，最佳调用宽度550px
    演示地址：http://eWebEditor.webasp.net/Example/s_blue.asp
  • 自带样式5 - 绿色调
    标准Office风格按钮+绿色调，包括部分主要功能按钮，最佳调用宽度550px
    演示地址：http://eWebEditor.webasp.net/Example/s_green.asp
  • 自带样式6 - 红色调
    标准Office风格按钮+红色调，包括部分主要功能按钮，最佳调用宽度550px
    演示地址：http://eWebEditor.webasp.net/Example/s_red.asp
  • 自带样式7 - 黄色调
    标准Office风格按钮+黄色调，包括部分主要功能按钮，最佳调用宽度550px
    演示地址：http://eWebEditor.webasp.net/Example/s_yellow.asp
  • 自带样式8 - 3D灰色调
    标准Office风格按钮+3D灰色调，包括部分主要功能按钮，最佳调用宽度550px
    演示地址：http://eWebEditor.webasp.net/Example/s_3d.asp
  • 自带样式9 - 酷蓝
    COOL界面，蓝色主调，标准风格，部分常用按钮，标准适合界面宽度，最佳调用宽度550px
    演示地址：http://eWebEditor.webasp.net/Example/s_coolblue.asp

多个编辑器调用：

  • 1个表单2个相同样式
    演示地址：http://eWebEditor.webasp.net/Example/multi1.asp
  • 1个表单2个不同样式
    演示地址：http://eWebEditor.webasp.net/Example/multi2.asp
  • 2个表单2个样式
    演示地址：http://eWebEditor.webasp.net/Example/multi3.asp
  • 所有系统自带样式总览
    演示地址：http://eWebEditor.webasp.net/Example/multi4.asp

接口功能调用：

  • 客户端函数调用示例
    演示地址：http://eWebEditor.webasp.net/Example/I_Client.asp
  • 取上传文件示例
    演示地址：http://eWebEditor.webasp.net/Example/I_Upload.asp
  • 弹出窗口调用示例
    演示地址：http://eWebEditor.webasp.net/Example/I_PopUp.asp

高级功能示例：

  • 自动或手动远程文件获取
    利用远程文件自动获取功能，可以把别人服务器上的图片等文件自动传到自己的服务器，不要当心别人的站点关了，本地链接的文件不存在的问题，也不要再一个个下载下来再传上去了，全过程完全自动。
    演示地址：http://eWebEditor.webasp.net/Example/ADV_Remote.asp
  • 相对或绝对路径
    对于在线编辑器来说，路径问题一直是一个难点，基本上市面上的在线编辑器所编辑出来的内容链接都用的是带域名的绝对全路径（如：http://www.xxx.com/xxx/xxx.gif）。eWebEditor充分解决了此问题，只要简单设置一下三种路径形式可选（相对路径、绝对根路径、绝对全路径），完全摆脱了站点或系统或目录迁移而带来的路径问题。
    演示地址：http://eWebEditor.webasp.net/Example/ADV_Path.asp
  • 图形热点链接
    eWebEditor的此应用绝对是所有在线编辑器软件中的始创，能够在线编辑实现图形的热点链接功能，即一个图片可以按区块链接到多个地址。
    演示地址：http://eWebEditor.webasp.net/Example/ADV_Map.asp

实际应用例子：

  • 简单新闻系统示例
    通过一个简单的新闻系统，对eWebEditor的使用进行详尽的实例代码说明。之所以把新闻系统作为eWebEditor功能使用的一个例子，原因在于新闻系统很具有代表性，基本上eWebEditor所具有的功能都能在此系统上给予体现。
    此例一起打包在主程序压缩文档中，例子详细说明请见 [代码实例]
    演示地址：http://eWebEditor.webasp.net/eWebEditor/Example/NewsSystem/List.asp

后台管理：

演示地址：http://eWebEditor.webasp.net/eWebEditor/admin_login.asp

管理用户名：admin 密码：admin


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
产 品 下 载

产品下载：

说明：您可以到最新更新处查看各版本的更新详细内容，what's new

    当前最新：
  • eWebEditor Version 2.8.0 免费用户版 [499K]
    以前提供：
  • eWebEditor Version 2.7.5 免费用户版 [492K]
  • eWebEditor Version 2.1.6 免费用户版 [439K]
  • eWebEditor Version 2.0.0 免费用户版 [436K]
  • eWebEditor酷蓝样式包 [4K]
  • eWebEditor Version 2.0.0 beta sp1 [15K]
  • eWebEditor Version 2.0.0 beta [260K]
  • eWebEditor Version 1.1.3 [312K]
  • eWebEditor Version 1.0.0 [313K]

相关下载：

说明：为了使您能够更好的学习使用了解eWebEditor，此处提供一些相关的工具软件文档下载。

  • eWebEditor介绍文档 Version 2.8.0 （CHM格式）
  • eWebEditor介绍文档 Version 2.7.5 （CHM格式）
  • eWebEditor介绍文档 Version 2.0.0 （CHM格式）
  • eWebEditor介绍文档 Version 1.1.3 （CHM格式）
  • eWebEditor开发文档 Version 1.0.0 （CHM格式）
  • eWebEditor开发工具 EditPlus v2.11 （RAR格式）
  • ASP开发规范 Version 1.0.0 （CHM格式）


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
代码实例

代码实例说明： [顶部]

    在这里我们通过一个简单的新闻系统，对eWebEditor的使用进行详尽的实例代码说明。之所以把新闻系统作为eWebEditor功能使用的一个例子，原因在于新闻系统很具有代表性，基本上eWebEditor所具有的功能都能在此系统上给予体现。

  • 此例子专门使用系统自带样式s_newssystem，此样式使用相对路径保存上传文件，所有上传的文件或远程获取的文件都存在文件夹下的NewsFile文件夹下，所有路径的格式都类似为"NewsFile/XXX.gif"，此样式的远程获取模式为自动打开状态，即说明当提交表单时，编辑内容中的所有远程图片将自动上传到本地服务器。
  • 在例子中文件中都有对每一步骤进行详细的注释，您可以根据实际使用的需要对某些操作步骤或功能进行增删改。
  • 此例子以ACCESS 2000作为数据库保存新闻内容，数据库文件db.mdb中，表的每个字段都有注释，以便于您更好的了解eWebEditor的功能及使用方法。（附：系统数据库ewebeditor.mdb表字段也是有注释的，注释是我们的规定作法，希望您能更了解我们的系统）
  • 此实例打包在 eWebEditor Version 2.7.5 压缩包中

    在线演示地址：http://eWebEditor.webasp.net/eWebEditor/Example/NewsSystem/List.asp

实例安装说明： [顶部]

此实例打包在系统下载压缩包中，在目录Example/NewsSystem/下。要使用此例子，请按如下步骤：

  1. 您必须把下载的压缩包eWebEditor目录设为虚拟目录，且虚拟目录名必须为eWebEditor，之所以有此要求，是因为此新闻例子默认设置的上传文件路径的要求。
  2. 设置完后访问以下地址：
    http://Localhost/eWebEditor/Example/NewsSystem/List.asp

实例文件结构说明： [顶部]

所有文件存放在Example/NewsSystem目录下，各文件的说明如下：

  • DB.mdb：ACCESS数据库文件
  • Startup.asp：每页公用包含文件，包括数据库连接，公用基本函数，头尾部内容
  • Add.asp：增加新闻表单页
  • AddSave.asp：增加新闻保存页
  • Modify.asp：修改新闻表单页
  • ModifySave.asp：修改新闻保存页
  • List.asp：新闻列表页
  • Delete.asp：删除新闻操作页
  • Show.asp：显示新闻内容页

实例数据结构说明： [顶部]

此例子以ACCESS 2000作为数据库，数据库中只有一个表。新闻数据表：用于存入新闻的内容数据，如新闻标题、新闻内容、上传文件名及路径等。具体表结构如下：

新闻数据表：[NewsData]

字段名 | 类型 | 大小 | 主键 | 可空 | 说明
D_ID | 自动编号 | 长整型 | 是 |  | 唯一识别ID
D_Title | 文本 | 200 |  |  | 新闻标题
D_Content | 备注 |  |  |  | 新闻内容
D_Picture | 文本 | 50 |  | 是 | 新闻标题图片
D_OriginalFileName | 备注 |  |  | 是 | 上传或远程获取前原文件名，多个以"|"分隔
D_SaveFileName | 备注 |  |  | 是 | 上传后保存的文件名，多个以"|"分隔
D_SavePathFileName | 备注 |  |  | 是 | 上传后保存的路径文件名(带路径)，多个以"|"分隔

公用文件：Startup.asp [顶部][目录]

<%@ Language=VBScript CODEPAGE=936%>
<% Option Explicit %>

<%

' ============================================
' 常用全局变量
' ============================================
' 数据库对象
Dim oConn, oRs, sSql

' ============================================
' 初始数据处理
' ============================================
' 初始化数据库连接
Call DBConnBegin()

' ********************************************
' 以下为数据库相关函数
' ********************************************
' ============================================
' 初始化数据库连接对象
' 使用原则：最迟调用，最早释放
' ============================================
Sub DBConnBegin()
' 如果数据库对象已打开，不要再打开
If IsObject(oConn) = True Then Exit Sub

' 你可以不需要打开数据库连接对象而直接打开记录集对象，但如果你需要打开多个记录集对象的话，效率是很低的。
' 如果你不创建一个数据库连接对象，ADO会在每个记录集打开时自动创建一个新的数据库连接对象，就算你用的是相同的SQL语句。
Set oConn = Server.CreateObject("ADODB.Connection")

On Error Resume Next
' Access数据库
oConn.Open "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=" & Server.MapPath("db.mdb")

If Err.Number > 0 Then
' 显示错误信息,并且发送邮件通知管理员
'Call DBConnError(Err)

' 完全地退出正在运行的脚本
Response.End
End If

' 创建一个记录集
Set oRs = Server.CreateObject( "ADODB.Recordset" )
End Sub

' ============================================
' 释放数据库连接对象
' ============================================
Sub DBConnEnd()
On Error Resume Next
oRs.Close
Set oRs = Nothing
oConn.Close
Set oConn = Nothing
End Sub

' ********************************************
' 以下为常用函数
' ********************************************
' ============================================
' 错误返回处理
' ============================================
Sub GoError(str)
Call DBConnEnd()
Response.Write "<script language=javascript>alert('" & str & "\n\n系统将自动返回前一页面...');history.back();</script>"
Response.End
End Sub

' ============================================
' 得到安全字符串,在查询中或有必要强行替换的表单中使用
' ============================================
Function GetSafeStr(str)
GetSafeStr = Replace(Replace(Replace(Trim(str), "'", ""), Chr(34), ""), ";", "")
End Function

' ============================================
' 把字符串进行HTML解码,替换server.htmlencode
' 去除Html格式，用于显示输出
' ============================================
Function outHTML(str)
Dim sTemp
sTemp = str
outHTML = ""
If IsNull(sTemp) = True Then
Exit Function
End If
sTemp = Replace(sTemp, "&", "&amp;")
sTemp = Replace(sTemp, "<", "&lt;")
sTemp = Replace(sTemp, ">", "&gt;")
sTemp = Replace(sTemp, Chr(34), "&quot;")
sTemp = Replace(sTemp, Chr(10), "<br>")
outHTML = sTemp
End Function

' ============================================
' 去除Html格式，用于从数据库中取出值填入输入框时
' 注意：value="?"这边一定要用双引号
' ============================================
Function inHTML(str)
Dim sTemp
sTemp = str
inHTML = ""
If IsNull(sTemp) = True Then
Exit Function
End If
sTemp = Replace(sTemp, "&", "&amp;")
sTemp = Replace(sTemp, "<", "&lt;")
sTemp = Replace(sTemp, ">", "&gt;")
sTemp = Replace(sTemp, Chr(34), "&quot;")
inHTML = sTemp
End Function

' ===============================================
' 初始化下拉框
' s_FieldName : 返回的下拉框名
' a_Name : 定值名数组
' a_Value : 定值值数组
' v_InitValue : 初始值
' s_Sql : 从数据库中取值时,select name,value from table
' s_AllName : 空值的名称,如:"全部","所有","默认"
' ===============================================
Function InitSelect(s_FieldName, a_Name, a_Value, v_InitValue, s_Sql, s_AllName)
Dim i
InitSelect = "<select name='" & s_FieldName & "' size=1>"
If s_AllName <> "" Then
InitSelect = InitSelect & "<option value=''>" & s_AllName & "</option>"
End If
If s_Sql <> "" Then
oRs.Open s_Sql, oConn, 0, 1
Do While Not oRs.Eof
InitSelect = InitSelect & "<option value=""" & inHTML(oRs(1)) & """"
If oRs(1) = v_InitValue Then
InitSelect = InitSelect & " selected"
End If
InitSelect = InitSelect & ">" & outHTML(oRs(0)) & "</option>"
oRs.MoveNext
Loop
oRs.Close
Else
For i = 0 To UBound(a_Name)
InitSelect = InitSelect & "<option value=""" & inHTML(a_Value(i)) & """"
If a_Value(i) = v_InitValue Then
InitSelect = InitSelect & " selected"
End If
InitSelect = InitSelect & ">" & outHTML(a_Name(i)) & "</option>"
Next
End If
InitSelect = InitSelect & "</select>"
End Function

' ============================================
' 每页头部内容
' ============================================
Sub Header(str)
Response.Write "<HTML><HEAD><TITLE>eWebEditor在线编辑器 - 例子：新闻系统</TITLE><style>body,p,td,input {font-size:9pt}</style></HEAD><BODY>"
Response.Write "<p align=center><a href='list.asp'>新闻列表</a> | <a href='add.asp'>增加新闻</a></p>"
Response.Write "<p align=center><b>" & str & "</b></p>"
End Sub

' ============================================
' 每页底部内容
' ============================================
Sub Footer()
Call DBConnEnd()
Response.Write "</BODY></HTML>"
End Sub

%>

增加新闻：Add.asp [顶部][目录]

<!--#include file = "Startup.asp"-->

<%

' ======================
' 功能：增加新闻
' 描述：提供一个新增表单，包括新闻标题和新闻内容，新闻内容使用eWebEditor进行编辑；
' 同时接收上传文件，以便删除新闻时，同时删除上传文件；
' 并由编辑区中上传的文件，提供标题新闻的图片选择。
' ======================

Call Header("增加新闻")
Call Content()
Call Footer()

' 本页内容区
Sub Content()
%>

<Script Language=JavaScript>
// 当上传图片等文件时，往下拉框中填入图片路径，可根据实际需要更改此函数
function doChange(objText, objDrop){
if (!objDrop) return;
var str = objText.value;
var arr = str.split("|");
var nIndex = objDrop.selectedIndex;
objDrop.length=1;
for (var i=0; i<arr.length; i++){
objDrop.options[objDrop.length] = new Option(arr[i], arr[i]);
}
objDrop.selectedIndex = nIndex;
}

// 表单提交客户端检测
function doSubmit(){
if (document.myform.d_title.value==""){
alert("新闻标题不能为空！");
return false;
}
// getHTML()为eWebEditor自带的接口函数，功能为取编辑区的内容
if (eWebEditor1.getHTML()==""){
alert("新闻内容不能为空！");
return false;
}
document.myform.submit();
}
</Script>

<form action="addsave.asp" method="post" name="myform">
<% '取源文件名 %>
<input type=hidden name=d_originalfilename>
<% '取保存的方件名，如果不要带路径的填充下拉框，可以在下面的表单项加入onchange事件 %>
<input type=hidden name=d_savefilename>
<% '取保存的文件名（带路径），使用带路径的填充下拉框 %>
<input type=hidden name=d_savepathfilename onchange="doChange(this,document.myform.d_picture)">

<table cellspacing=3 align=center>
<tr>
<td>新闻标题：</td>
<td><input type="text" name="d_title" value="" size="90"></td>
</tr>
<tr>
<td>标题图片：</td>
<td><select name="d_picture" size=1><option value=''>无</option></select> 当编辑区有插入图片时，将自动填充此下拉框</td>
</tr>
<tr>
<td>新闻内容：</td>
<td>
<%
' ewebeditor.asp文件调用的参数：
' id：下面表单项textarea的名称，在此表单中是d_content，注意大小写
' style：编辑器的样式名称，可在eWebEditor的后台设置
' originalfilename：用于获取源文件名的表单项名，在此表单中是d_originalfilename
' savefilename：用于获取保存文件名的表单项名，在此表单中是d_savefilename
' savepathfilename：用于获取保存带路径文件名的表单项名，在此表单中是d_savepathfilename
%>
<textarea name="d_content" style="display:none"></textarea>
<iframe ID="eWebEditor1" src="../../ewebeditor.asp?id=d_content &style=s_newssystem &originalfilename=d_originalfilename &savefilename=d_savefilename &savepathfilename=d_savepathfilename" frameborder="0" scrolling="no" width="550" HEIGHT="350"></iframe>
</td>
</tr>
</table>
<p align=center><input type=button name=btnSubmit value=" 提 交 " onclick="doSubmit()"> <input type=reset name=btnReset value=" 重 填 "></p>
</form>

<%
End Sub

%>

增加新闻保存：AddSave.asp [顶部][目录]

<!--#include file = "Startup.asp"-->
<%

' ======================
' 功能：增加新闻保存页
' 描述：对add.asp文件提交过来的表单数据进行保存操作，有保存新闻标题，新闻内容，新闻标题图片；
' 同时保存所有此篇新闻所有相关的上传或远程获取的文件信息，有源文件名，保存文件名，保存路径文件名。
' ======================

Call Header("增加新闻保存")
Call Content()
Call Footer()

' 本页内容区
Sub Content()
Dim i

' 取提交过来的数据
' 注意取新闻内容的方法，因为对大表单的自动处理，一定要使用循环，否则大于100K的内容将取不到，单个表单项的限制为102399字节（100K左右）
Dim sTitle, sContent, sPicture
sTitle = Request.Form("d_title")
sPicture = Request.Form("d_picture")

' 开始：eWebEditor编辑区取值-----------------
sContent = ""
For i = 1 To Request.Form("d_content").Count
sContent = sContent & Request.Form("d_content")(i)
Next
' 结束：eWebEditor编辑区取值-----------------

' 以下为所有通过编辑器上传的所有文件相关信息，包括编辑区手动上传的和自动远程上传的
' GetSafeStr函数为过滤一些特殊字符，防止有些人恶意的破坏此演示程序
' 上传或远程获取前的原文件名，多个以"|"分隔
Dim sOriginalFileName
' 上传后保存到本地服务器的文件名（不带路径），多个以"|"分隔
Dim sSaveFileName
' 上传后保存到本地服务器的路径文件名，多个以"|"分隔
Dim sSavePathFileName
sOriginalFileName = GetSafeStr(Request.Form("d_originalfilename"))
sSaveFileName = GetSafeStr(Request.Form("d_savefilename"))
sSavePathFileName = GetSafeStr(Request.Form("d_savepathfilename"))

' 保存新闻内容，同时取出自增的新闻ID
Dim sNewsID
sSql = "SELECT * FROM NewsData WHERE D_ID=0"
oRs.Open sSql, oConn, 1, 3
oRs.AddNew
oRs("D_Title") = sTitle
oRs("D_Content") = sContent
oRs("D_Picture") = sPicture
oRs("D_OriginalFileName") = sOriginalFileName
oRs("D_SaveFileName") = sSaveFileName
oRs("D_SavePathFileName") = sSavePathFileName
oRs.Update
sNewsID = oRs("D_ID")
oRs.Close

' 输出成功保存信息
Response.Write "新闻（ID：" & sNewsID & "）增加保存成功！"

End Sub

%>

修改新闻：Modify.asp [顶部][目录]

<!--#include file = "Startup.asp"-->

<%

' ======================
' 功能：修改新闻
' 描述：提供一个修改表单，包括新闻标题和新闻内容，新闻内容使用eWebEditor进行编辑；
' 同时接收上传文件，以便删除新闻时，同时删除上传文件；
' 并由编辑区中上传的文件，提供标题新闻的图片选择；
' 功能与新增相同，不同在于只是修改表单具有初始值。
' ======================

Call Header("修改新闻")
Call Content()
Call Footer()

' 本页内容区
Sub Content()

' 传入参数：新闻ID
Dim sNewsID
sNewsID = Trim(Request("id"))

' 新闻ID有效性验证，防止有些人恶意的破坏此演示程序
If IsNumeric(sNewsID) = False Then
GoError "请通过页面上的链接进行操作，不要试图破坏此演示系统。"
End If

' 从数据库中取初始值
Dim sTitle, sContent, sPicture, sOriginalFileName, sSaveFileName, sSavePathFileName
sSql = "SELECT * FROM NewsData WHERE D_ID=" & sNewsID
oRs.Open sSql, oConn, 0, 1
If Not oRs.Eof Then
sTitle = oRs("D_Title")
sContent = oRs("D_Content")
sPicture = oRs("D_Picture")
sOriginalFileName = oRs("D_OriginalFileName")
sSaveFileName = oRs("D_SaveFileName")
sSavePathFileName = oRs("D_SavePathFileName")
Else
GoError "无效的新闻ID，请点页面上的链接进行操作！"
End If
oRs.Close

' 把带"|"的字符串转为数组，用于初始下拉框表单
Dim aSavePathFileName
aSavePathFileName = Split(sSavePathFileName, "|")

' 根据新闻内容中相关上传文件为数据，初始下拉框表单
' 函数InitSelect，根据数组值及初始值返回下拉框输出字串，具体请见startup.asp文件中函数的说明部分
Dim sOptionSavePath
sOptionSavePath = InitSelect("d_picture", aSavePathFileName, aSavePathFileName, sPicture, "", "无")

%>

<Script Language=JavaScript>
// 当上传图片等文件时，往下拉框中填入图片路径，可根据实际需要更改此函数
function doChange(objText, objDrop){
if (!objDrop) return;
var str = objText.value;
var arr = str.split("|");
var nIndex = objDrop.selectedIndex;
objDrop.length=1;
for (var i=0; i<arr.length; i++){
objDrop.options[objDrop.length] = new Option(arr[i], arr[i]);
}
objDrop.selectedIndex = nIndex;
}

// 表单提交客户端检测
function doSubmit(){
if (document.myform.d_title.value==""){
alert("新闻标题不能为空！");
return false;
}
// getHTML()为eWebEditor自带的接口函数，功能为取编辑区的内容
if (eWebEditor1.getHTML()==""){
alert("新闻内容不能为空！");
return false;
}
document.myform.submit();
}
</Script>

<form action="modifysave.asp?id=<%=sNewsID%>" method="post" name="myform">
<% '取源文件名 %>
<input type=hidden name=d_originalfilename value="<%=sOriginalFileName%>">
<% '取保存的方件名（带路径），如果不要带路径的填充下拉框，可以在下面的表单项加入onchange事件 %>
<input type=hidden name=d_savefilename value="<%=sSaveFileName%>">
<% '取保存的文件名，使用带路径的填充下拉框 %>
<input type=hidden name=d_savepathfilename onchange="doChange(this,document.myform.d_picture)" value="<%=sSavePathFileName%>">

<table cellspacing=3 align=center>
<tr>
<td>新闻标题：</td>
<% ' 函数inHTML：去除Html格式，用于从数据库中取出值填入输入框时，具体请见startup.asp文件中函数的说明 %>
<td><input type="text" name="d_title" value="<%=inHTML(sTitle)%>" size="90"></td>
</tr>
<tr>
<td>标题图片：</td>
<td><%=sOptionSavePath%> 当编辑区有插入图片时，将自动填充此下拉框</td>
</tr>
<tr>
<td>新闻内容：</td>
<td>
<%
' ewebeditor.asp文件调用的参数：
' id：下面表单项textarea的名称，在此表单中是d_content，注意大小写
' style：编辑器的样式名称，可在eWebEditor的后台设置
' originalfilename：用于获取源文件名的表单项名，在此表单中是d_originalfilename
' savefilename：用于获取保存文件名的表单项名，在此表单中是d_savefilename
' savepathfilename：用于获取保存带路径文件名的表单项名，在此表单中是d_savepathfilename

' 请一定要用Server.HtmlEncode()函数对内容进行转换，否则将有可以出现某些内容出了编辑区的情况
%>
<textarea name="d_content" style="display:none"><%=Server.HtmlEncode(sContent)%></textarea>
<iframe ID="eWebEditor1" src="../../ewebeditor.asp?id=d_content &style=s_newssystem &originalfilename=d_originalfilename &savefilename=d_savefilename &savepathfilename=d_savepathfilename" frameborder="0" scrolling="no" width="550" HEIGHT="350"></iframe>
</td>
</tr>
</table>
<p align=center><input type=button name=btnSubmit value=" 提 交 " onclick="doSubmit()"> <input type=reset name=btnReset value=" 重 填 "></p>
</form>

<%
End Sub

%>

修改新闻保存：ModifySave.asp [顶部][目录]

<!--#include file = "Startup.asp"-->
<%

' ======================
' 功能：修改新闻保存页
' 描述：对modify.asp文件提交过来的表单数据进行保存操作，有保存新闻标题，新闻内容，新闻标题图片；
' 同时保存所有此篇新闻所有相关的上传或远程获取的文件信息，有源文件名，保存文件名，保存路径文件名。
' ======================

Call Header("修改新闻保存")
Call Content()
Call Footer()

' 本页内容区
Sub Content()
Dim i

' 传入参数：新闻ID
Dim sNewsID
sNewsID = Trim(Request("id"))

' 新闻ID有效性验证，防止有些人恶意的破坏此演示程序
If IsNumeric(sNewsID) = False Then
GoError "请通过页面上的链接进行操作，不要试图破坏此演示系统。"
End If

' 取提交过来的数据
' 注意取新闻内容的方法，因为对大表单的自动处理，一定要使用循环，否则大于100K的内容将取不到，单个表单项的限制为102399字节（100K左右）
Dim sTitle, sContent, sPicture
sTitle = Request.Form("d_title")
sPicture = Request.Form("d_picture")

' 开始：eWebEditor编辑区取值-----------------
sContent = ""
For i = 1 To Request.Form("d_content").Count
sContent = sContent & Request.Form("d_content")(i)
Next
' 结束：eWebEditor编辑区取值-----------------

' 以下为所有通过编辑器上传的所有文件相关信息，包括编辑区手动上传的和自动远程上传的
' GetSafeStr函数为过滤一些特殊字符，防止有些人恶意的破坏此演示程序
' 上传或远程获取前的原文件名，多个以"|"分隔
Dim sOriginalFileName
' 上传后保存到本地服务器的文件名（不带路径），多个以"|"分隔
Dim sSaveFileName
' 上传后保存到本地服务器的路径文件名，多个以"|"分隔
Dim sSavePathFileName
sOriginalFileName = GetSafeStr(Request.Form("d_originalfilename"))
sSaveFileName = GetSafeStr(Request.Form("d_savefilename"))
sSavePathFileName = GetSafeStr(Request.Form("d_savepathfilename"))

' 修改指定新闻内容
sSql = "SELECT * FROM NewsData WHERE D_ID=" & sNewsID
oRs.Open sSql, oConn, 1, 3
If Not oRs.Eof Then
oRs("D_Title") = sTitle
oRs("D_Content") = sContent
oRs("D_Picture") = sPicture
oRs("D_OriginalFileName") = sOriginalFileName
oRs("D_SaveFileName") = sSaveFileName
oRs("D_SavePathFileName") = sSavePathFileName
oRs.Update
Else
GoError "无效的新闻ID，请点页面上的链接进行操作！"
End If
oRs.Close

' 输出成功保存信息
Response.Write "新闻（ID：" & sNewsID & "）修改保存成功！"

End Sub

%>

新闻列表：List.asp [顶部][目录]

<!--#include file = "Startup.asp"-->

<%

' ======================
' 功能：新闻列表
' 描述：本页代码没有使用到eWebEditor相关的内容，只提供新闻列表，及显示、修改、删除新闻页的链接。
' ======================

Call Header("新闻列表")
Call Content()
Call Footer()

' 本页内容区
Sub Content()

' 从新闻库中取出所有新闻，按ID倒排序
sSql = "SELECT * FROM NewsData ORDER BY D_ID DESC"
oRs.Open sSql, oConn, 0, 1
If Not oRs.Eof Then
Do While Not oRs.Eof
Response.Write "<li>"
' 是否有新闻标题图片，如有则输出显示
If oRs("D_Picture") <> "" Then
Response.Write "<img border=0 src='" & oRs("D_Picture") & "'>"
End If
' 显示标题
' 函数outHTML：去除Html格式，用于显示输出,具体请见startup.asp文件中的说明
Response.Write "<a href='show.asp?id=" & oRs("d_id") & "'>" & outHTML(oRs("d_title")) & "</a>&nbsp;&nbsp;"
' 显示修改链接
Response.Write "[<a href='modify.asp?id=" & oRs("d_id") & "'>修改</a>]"
' 显示删除链接
Response.Write "[<a href='delete.asp?id=" & oRs("d_id") & "'>删除</a>]"
oRs.MoveNext
Loop
Else
Response.Write "现在数据库中还没有新闻！"
End If
oRs.Close

End Sub

%>

删除新闻：Delete.asp [顶部][目录]

<!--#include file = "Startup.asp"-->

<%

' ======================
' 功能：删除新闻
' 描述：新闻删除后，页面转向新闻列表页。
' 删除新闻的同时，删除此新闻相关的上传文件。
' ======================

Call Header("删除新闻")
Call Content()
Call Footer()

' 本页内容区
Sub Content()

' 取参数：新闻ID
Dim sNewsID
sNewsID = Trim(Request("id"))

' 新闻ID有效性验证，防止有些人恶意的破坏此演示程序
If IsNumeric(sNewsID) = False Then
GoError "请通过页面上的链接进行操作，不要试图破坏此演示系统。"
End If

' 从新闻数据表中取出相关的上传文件
' 上传后保存到本地服务器的路径文件名，多个以"|"分隔
' 删除文件，要取带路径的文件名才可以，并且只要这个就可以了，原来存的原文件名或不带路径的保存文件名可用于其它地方使用
Dim sSavePathFileName

sSql = "SELECT D_SavePathFileName FROM NewsData WHERE D_ID=" & sNewsID
oRs.Open sSql, oConn, 0, 1
If Not oRs.Eof Then
sSavePathFileName = oRs("D_SavePathFileName")
Else
GoError "无效的新闻ID，请点页面上的链接进行操作！"
End If
oRs.Close

' 把带"|"的字符串转为数组
Dim aSavePathFileName
aSavePathFileName = Split(sSavePathFileName, "|")

' 删除新闻相关的文件，从文件夹中
Dim i
For i = 0 To UBound(aSavePathFileName)
' 按路径文件名删除文件
Call DoDelFile(aSavePathFileName(i))
Next

' 删除新闻
sSql = "DELETE FROM NewsData WHERE D_ID=" & sNewsID
oConn.Execute sSql

' 3秒转向新闻列表页
response.write "<p align=center>新闻删除成功，3秒后自动返回新闻列表页！<script>window.setTimeout(""location.href='list.asp'"",3000);</script></p>"

End Sub

' 删除指定的文件
Sub DoDelFile(sPathFile)
On Error Resume Next
Dim oFSO
Set oFSO = Server.CreateObject("Scripting.FileSystemObject")
oFSO.DeleteFile(Server.MapPath(sPathFile))
Set oFSO = Nothing
End Sub

%>

显示新闻：Show.asp [顶部][目录]

<!--#include file = "Startup.asp"-->
<!--#include file = "../../Include/DeCode.asp"-->

<%

' ======================
' 功能：显示新闻
' 描述：显示编辑的内容页，此页注意一下DeCode接口函数的调用。
' ======================

Call Header("显示新闻内容")
Call Content()
Call Footer()

' 本页内容区
Sub Content()

' 传入参数：新闻ID
Dim sNewsID
sNewsID = Trim(Request("id"))

' 新闻ID有效性验证，防止有些人恶意的破坏此演示程序
If IsNumeric(sNewsID) = False Then
GoError "请通过页面上的链接进行操作，不要试图破坏此演示系统。"
End If

' 从数据库中取初始值
Dim sTitle, sContent, sPicture, sOriginalFileName, sSaveFileName, sSavePathFileName
sSql = "SELECT * FROM NewsData WHERE D_ID=" & sNewsID
oRs.Open sSql, oConn, 0, 1
If Not oRs.Eof Then
sTitle = oRs("D_Title")
sContent = oRs("D_Content")
sPicture = oRs("D_Picture")
sOriginalFileName = oRs("D_OriginalFileName")
sSaveFileName = oRs("D_SaveFileName")
sSavePathFileName = oRs("D_SavePathFileName")
Else
GoError "无效的新闻ID，请点页面上的链接进行操作！"
End If
oRs.Close

' 禁用某些标签，如出于安全考虑的Script标签，等
' 要使用此功能需要先包含"Include/DeCode.asp"文件。
' 此例只过滤SCRIPT标签，即意味着内容中的客户端脚本不会生效，您可根据实际的需要加入其它标签。
' 当前支持过滤的标签，可以查看DeCode.asp文件中的说明。
sContent = eWebEditor_DeCode(sContent, "SCRIPT")

' 输出新闻
Response.Write "<table border=0 cellpadding=5 width='90%' align=center>" & _
"<tr><td align=center><b>" & sTitle & "</b></td></tr>" & _
"<tr><td>" & sContent & "</td></tr>" & _
"</table>"

' 输出相关文件信息
Response.Write "<p><b>此新闻的相关上传文件信息如下：</b></p>"

' 把带"|"的字符串转为数组，用于列出显示
Dim aOriginalFileName, aSaveFileName, aSavePathFileName
aOriginalFileName = Split(sOriginalFileName, "|")
aSaveFileName = Split(sSaveFileName, "|")
aSavePathFileName = Split(sSavePathFileName, "|")

Response.Write "<table border=1 cellpadding=3 cellspacing=0>" & _
"<tr>" & _
"<td>序号</td>" & _
"<td>原文件名(接口：d_originalfilename)</td>" & _
"<td>保存文件名(接口：d_savefilename)</td>" & _
"<td>保存路径文件名(接口：d_savepathfilename)</td>" & _
"</tr>"
Dim i
For i = 0 To UBound(aOriginalFileName)
Response.Write "<tr>" & _
"<td>" & CStr(i + 1) & "</td>" & _
"<td>" & aOriginalFileName(i) & "</td>" & _
"<td>" & aSaveFileName(i) & "</td>" & _
"<td>" & aSavePathFileName(i) & "</td>" & _
"</tr>"
Next
Response.Write "</table>"

End Sub

%>


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
常 见 问 题

问：我不会任何HTML语法及没有任何主页制作经验，能用好这个编辑器吗？

答：绝对没有任何问题，因为编辑器是完全所见即所得的，所以HTML语法都在后台自动生成。至于使用方面，本编辑器也尽量做到简单易用，相信您能在短时间内学会使用这个功能强大的编辑器的。

问：与普通文本输入框相比，HTML编辑器有什么优势之处？

答：最大的优势就是让使用者更方便快捷地编写出各种不同样式及效果的HTML内容，以往普通文本输入框要实现这些HTML效果的内容就需要使用者具备一定的HTML语法或UBB语法，而且编写内容的时候是手工编写代码方式的，除了不直观以外，还经常出现编写好内容并输出后才发现效果不理想等情况。而使用HTML编辑器则完全杜绝了这些情况的发生。

问：为什么我无法使用编辑器的部分或全部功能？

答：因为编辑器使用了JAVASCRIPT客户端语言，如果浏览器不支持JAVASCRIPT或关闭了这个功能的话，编辑器就不能正常工作了。另外，编辑器还需要使用者的浏览器版本是IE5.5以上，否则编辑器同样不能正常工作。

问：为什么我在修改内容的时候有些内容会跑出编辑区？

答：因为内容都是以HTML格式保存的，如果你在赋值的时候没有对内容进行字符转换，则会以HTML格式进行解释，所以请一定在赋值时加入Server.HTMLEncode()函数。如：
<textarea name=content><%=Server.HTMLEncode(html)%></textarea>

问：我的程序放在一般的虚拟主机上，没有FSO或上传组件支持，能使用上传功能吗？

答：可以。因为eWebEditor上传功能的实现使用的是无组件文件上传，所以无需任何组件的支持。

问：我转原来系统的在线编辑为eWebEditor时，为什么显示出来都是HTML格式源代码？

答：因为很多现有的系统使用的都是UBB之类的编码，都有进行字符转换，有可能在保存或显示页，你把保存或显示页的所有字符转换函数去掉就可以了，因为eWebEditor存的就是HTML格式的代码。

问：为什么我编辑的内容都会多一个逗号？

答：因为内容超过100K时，eWebEditor有自动文件截取功能，使得大的文件内容也能提交，突破microsoft的表单限制。所以请定保证使用下面的形式接收提交来的数据：
<%
For i = 1 To Request.Form("content1").Count
sContent = sContent & Request.Form("content1")(i)
Next
%>


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
功 能 描 述

前台使用功能：

  1. 设置字体样式为粗体
  2. 设置字体样式为斜体
  3. 设置字体样式为带下划线
  4. 设置字体样式为带中划线
  5. 设置字体样式为上标
  6. 设置字体样式为下标
  7. 设置字体变大
  8. 设置字体样变小
  9. 设置内容向左对齐
  10. 设置内容向右对齐
  11. 设置内容向中对齐
  12. 设置内容两端对齐
  13. 设置内容以编号列表形式排列
  14. 设置内容以列表项形式排列
  15. 减少内容的缩进量
  16. 增加内容的缩进量
  17. 设置字体的颜色
  18. 设置字体的背景颜色
  19. 设置对象的背景颜色
  20. 剪切指定内容
  21. 复制指定内容
  22. 粘贴剪贴板中的内容
  23. 以纯文件形式粘贴剪贴板中的内容
  24. 粘贴从Word中复制的内容，并去除冗余格式
  25. 删除指定内容
  26. 删除指定内容的格式
  27. 撒消上次操作
  28. 恢复上次操作
  29. 选定所有内容
  30. 取消选定的内容
  31. 插入文本输入框
  32. 插入文字区
  33. 插入单选按钮
  34. 插入复选框
  35. 插入下拉框
  36. 插入按钮
  37. 插入或修改字幕，即滚动文字
  38. 插入水平尺
  39. 插入换行符
  40. 插入段落
  41. 插入或修改超级链接
  42. 删除超级链接或标签
  43. 图形热点链接
  44. 标签管理
  45. 插入表格...
  46. 表格属性...
  47. 单元格属性...
  48. 拆分单元格...
  49. 表格行属性...
  50. 插入行（在上方）
  51. 插入行（在下方）
  52. 合并行（向下方）
  53. 拆分行
  54. 删除行
  55. 插入列（在左侧）
  56. 插入列（在右侧）
  57. 合并列（向右侧）
  58. 拆分列
  59. 删除列
  60. 在指定位置插入或修改栏目框
  61. 在指定位置插入或修改网页帧
  62. 在指定位置插入或修改图片
  63. 在指定位置插入Flash动画
  64. 在指定位置插入自动播放的媒体文件
  65. 在指定位置插入其它文件
  66. 远程文件自动获取
  67. 在指定位置插入EXCEL表格
  68. 在指定位置插入特殊字符
  69. 指定位置的背景图片管理
  70. 在指定位置插入表情图标
  71. 在指定位置插入当前日期
  72. 在指定位置插入当前时间
  73. 转换指定内容为代码样式
  74. 转换指定内容为引用样式
  75. 转为代码状态
  76. 转为编辑状态
  77. 转为文本状态
  78. 转为预览状态
  79. 右链菜单功能
  80. 粘贴按钮菜单功能
  81. 表单菜单功能
  82. 表格菜单功能
  83. 显示或隐藏指导方针
  84. 查找替换功能
  85. 新建文档功能
  86. 缩放功能
  87. 相对或绝对位置设置功能
  88. 上移一层
  89. 下移一层
  90. 增大编辑区功能
  91. 减小编辑区功能
  92. 打印全页
  93. 打开全屏编辑
  94. 关闭全屏编辑并返回
  95. 弹窗保存并返回
  96. 查看在线使用帮助
  97. 关于编辑器的版权信息
  98. 直接访问eWebEditor站点
  99. 工具菜单
  100. 文件视图菜单
  101. 编辑菜单
  102. 对象效果菜单
  103. 组件菜单
  104. 右键菜单功能
  105. 快捷键功能
  106. 等等...

后台管理功能：

  1. 登录管理功能：登录用户名及密码修改。
  2. 上传文件管理（要FSO支持）：分页查看、选择批量删除、清空。
  3. 样式管理：能够对样式进行增删改、系统自带有几个标准样式，具有快速拷贝新增样式功能，样式一边设置一边具有预览功能，可以取得各样式的最佳调用代码。对于上传文件的扩展名及文件大小，可以按样式进行设置。工具栏的条数，每个工具栏上的按钮数量、排序，按钮图片都可以自定义。等等。
  4. 在线更新：在线更新产品，以获得最新的功能，方便操作。


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
开发人员使用说明

安装：

安装是非常容易的，首先你要做的就是把eWebEditor文件上传到你的网站，请按以下步骤进行：

  1. 从eWebEditor产品网站下载最新的版本。[下载]
  2. 解压下载下来的压缩文件到你本机（确定eWebEditor内的目录文件结构层次保持与压缩文件内一致）。
  3. 在你的站点上建一个新文件夹，如：/eWebEditor/（最好在要目录下，调用更方便）。
  4. 把eWebEditor在的所有文件及目录上传到你站点刚才建立的文件夹中。
  5. 运行例子文件（http://www.yoursite.com/ewebeditor/example/test.asp），看是否运行正常。OK。

设置：

eWebEditor带有后台管理功能，你可以方便对样式，上传文件等进行管理。设置请注意：

  • 后台管理的登录地址：http://www.yoursite.com/ewebeditor/admin_login.asp
  • 第一次安装请用默认用户admin和密码admin登陆后台，并进入管理页面更改管理用户和密码
  • 建议安装好后，更改数据库名字，以免别人恶意下载，默认数据名为db/ewebeditor.mdb，更改名字后请修改include/startup.asp文件中相关连接
  • 系统自带有几个标准样式，不允许修改，在你新增样式时，最好先预览，然后通过“拷贝标准样式”的方式，以达到快速新增样式的目的，且不易出错

调用：

eWebEditor的调用是非常简单，基本上只是在原来的使用中加入一行代码。

标准调用：

<iframe ID="eWebEditor1" src="/ewebeditor.asp?id=content1&style=standard" frameborder="0" scrolling="no" width="500" HEIGHT="350"></iframe>
参数说明：
  • /ewebeditor.asp应改为你实际安装的路径
  • 参数id：相关联的表单项名，也就是提交保存页要引用的表单项名，多个调用时，请保证id不同，可参见后面例子
  • 参数style：使用的样式名，可以是标准的样式名或自定义的样式名，如果使用标准standard可留空
  • width,height：根据实际需要设置，eWebEditor将自动调整与其适应
  • 在后台管理中，可以得到每个样式的最佳调用代码
所有入口参数：(即：eWebEditor.asp?后面的参数)
  • id：相关联的保存编辑内容的表单项名，也就是提交保存页要引用的表单项名
  • style：使用的样式名，可以是标准的样式名或自定义的样式名，如果使用标准standard可留空
  • originalfilename：相关联的保存上传原文件名列表的表单项名，必须是input类型，可以带onchange事件[例子]
  • savefilename：相关联的保存上传保存文件名列表的表单项名，必须是input类型，可以带onchange事件[例子]
  • savepathfilename：相关联的保存上传保存文件名（带路径）列表的表单项名，必须是input类型，可以带onchange事件[例子]

例子：新增表单

你原来可能是：

<textarea name="content1" rows=10 cols=50></textarea>

现在是：

<input type="hidden" name="content1" value="">
<iframe ID="eWebEditor1" src="/ewebeditor.asp?id=content1&style=standard" frameborder="0" scrolling="no" width="500" HEIGHT="350"></iframe>
或者
<textarea name="content1" style="display:none"></textarea>
<iframe ID="eWebEditor1" src="/ewebeditor.asp?id=content1&style=standard" frameborder="0" scrolling="no" width="500" HEIGHT="350"></iframe>

例子：修改表单

你原来可能是：

<textarea name="content1" rows=10 cols=50><%=Server.HTMLEncode(oRs("D_Content"))%></textarea>

现在是：

<input type="hidden" name="content1" value="<%=Server.HTMLEncode(oRs("D_Content"))%>">
<iframe ID="eWebEditor1" src="/ewebeditor.asp?id=content1&style=standard" frameborder="0" scrolling="no" width="500" HEIGHT="350"></iframe>
或者
<textarea name="content1" style="display:none"><%=Server.HTMLEncode(oRs("D_Content"))%></textarea>
<iframe ID="eWebEditor1" src="/ewebeditor.asp?id=content1&style=standard" frameborder="0" scrolling="no" width="500" HEIGHT="350"></iframe>

注意事项：

  • eWebEditor允许在同一表单里有多个，但请保证id在整个网页中是唯一的。即如果已经用了input name=content1第二个调用就要input name=content2之类的。
  • 在使用textarea作为原表单项时，要加入style="display:none"。
  • 在input修改时一定要用value=""，而不是value=''。
  • 一定要在动态加入value值时用Server.HTMLEncode()进行处理，否则有可能内容被截掉。

高级调用：

eWebEditor还提供了一些高级调用的方法，如下，但请保证大小写一致：

  • getHTML()：返回编辑器的内容
  • setHTML( html )：设置编辑器的内容
  • insertHTML( html )：在当前选择处插入内容
  • appendHTML( html )：在文档末尾追加内容
  • setMode( NewMode )：改变当前编辑状态
    参数NewMode:
    • "CODE"：代码状态
    • "EDIT"：编辑状态
    • "TEXT"：文本状态
    • "VIEW"：预览状态

使用例子如下：[在线演示]

<Script Language=JavaScript>
// 取编辑器内容
var sHTML = eWebEditor1.getHTML();
// 设置编辑器内容
eWebEditor1.setHTML('<b>Hello My World!</b>');
// 在当前选择处理插入
eWebEditor1.insertHTML('This is Insert Function!');
// 在尾部追加内容
eWebEditor1.appendHTML('This is Append Function!');
// 改变编辑器状态为代码编辑状态
eWebEditor1.setMode('CODE');
</Script>

取值说明：

由于eWebEditor有对大表单进行自动处理，所以在取值时有些不同，具体如下：

原来是

<%
sContent = Request.Form("content1")
%>

现在是

<%
For i = 1 To Request.Form("content1").Count
sContent = sContent & Request.Form("content1")(i)
Next
%>

接口：弹窗调用说明：

v2.7.5版本后加入了弹窗调用接口的扩充功能，能实现通过一个链接弹窗打开编辑器，并将编辑的内容保存入指定的表单域。

在eWebEditor根目录下文件名为PopUp.asp，提供的接口传入参数如下：
  • style : 样式名
  • form : 要返回或设置值的表单form名
  • field : 要返回或设置值的表单项textarea名

使用例子如下：[在线演示]

<HTML>
<BODY>
<Script Language=JavaScript>
function eWebEditorPopUp(style, form, field) {
var oPopUp = window.open("PopUp.asp?style="+style+"&form="+form+"&field="+field, "PopUp"+form+field, "toolbar=no,location=no,directories=no,status=yes,menubar=no,scrollbars=yes,resizable=yes");
}
</Script>
<FORM ACTION="" METHOD="" NAME="myForm">
<TEXTAREA NAME="myField" COLS="50" ROWS="5"></TEXTAREA>
<INPUT TYPE="BUTTON" VALUE="HTML编辑" ONCLICK="eWebEditorPopUp('s_popup', 'myForm', 'myField')">
</FORM>
</BODY>
</HTML>

接口：前台解释(限制)扩充功能说明：

此功能禁用某些标签，如出于安全考虑的Script标签，等。各版本可能有所不同，请参看实际文件中的说明：

    Function eWebEditor_DeCode(s_Content, sFilters)
  • s_Content : 要转换的数据字符串
  • s_Filters : 要过滤掉的格式集，用逗号分隔多个

使用例子如下：

先包含扩展功能文件，以下路径相应更改
<!--#include file = "Include/DeCode.asp"-->

<%
' 此例只过滤SCRIPT标签，即意味着内容中的客户端脚本不会生效，您可根据实际的需要加入其它标签。
sContent = eWebEditor_DeCode(sContent, "SCRIPT")
%>

更多使用说明请参看[代码实例]，每个程序文件中都有足够详细的注释。
编辑人员使用说明

界面概述：

所见即所得的在线编辑器界面主要分为以下三大部分：

  • 菜单栏
    编辑器顶部为菜单栏，主要放置各种编辑功能的选项及按钮图标，使用者只需点击图标或选择相关选项即可实时对编辑栏编辑的内容进行添加或修改、修饰。
  • 编辑栏
    编辑器中部空白处为编辑栏，主要是供使用者输入及编辑内容所用，同时所编辑的内容全部都是所见即所得，但有部分内容，如活动的图像、文字、电影等在编辑状态下只会呈现静止状态，需使用者转换到预览状态方可真实再现。
  • 状态栏
    编辑器底部为状态栏，主要放置转换编辑器状态的按钮图标，状态共分为：代码状态、编辑状态（默认）、文本状态、预览状态。具体每种状态的作用请详见帮助中心目录的“状态栏使用说明”。

菜单栏使用说明：

编辑器菜单栏图标功能使用说明如下：

  • ：设置字体样式为粗体。
  • ：设置字体样式为斜体。
  • ：设置字体样式为带下划线。
  • ：设置字体样式为带中划线。
  • ：设置字体样式为上标。
  • ：设置字体样式为下标。
  • ：设置字体变大。
  • ：设置字体样变小。
  • ：设置内容向左对齐。
  • ：设置内容向右对齐。
  • ：设置内容向中对齐。
  • ：设置内容两端对齐。
  • ：设置内容以编号列表形式排列。
  • ：设置内容以列表项形式排列。
  • ：减少内容的缩进量。
  • ：增加内容的缩进量。
  • ：设置字体的颜色。
  • ：设置字体背景颜色。
  • ：设置对象背景颜色。
  • ：剪切指定内容。
  • ：复制指定内容。
  • ：粘贴剪贴板中的内容。
  • ：以纯文件形式粘贴剪贴板中的内容。
  • ：粘贴从Word中复制的内容，并去除冗余格式。
  • ：删除指定内容。
  • ：删除指定内容的格式。
  • ：撒消上次操作。
  • ：恢复上次操作。
  • ：选定所有内容。
  • ：取消选定的内容。
  • ：表单菜单。
  • ：插入文本输入框。
  • ：插入文字区。
  • ：插入单选按钮。
  • ：插入复选框。
  • ：插入下拉框。
  • ：插入按钮。
  • ：插入或修改字幕，即滚动文字。
  • ：插入水平尺。
  • ：插入换行符。
  • ：插入段落。
  • ：插入或修改超级链接。
  • ：删除超级链接或标签。
  • ：图形热点链接。
  • ：标签管理。
  • ：表格菜单。
  • ：插入表格...。
  • ：表格属性...。
  • ：单元格属性...。
  • ：拆分单元格...。
  • ：表格行属性...。
  • ：插入行（在上方）。
  • ：插入行（在下方）。
  • ：合并行（向下方）。
  • ：拆分行。
  • 插入列（在左侧）。
  • ：插入列（在右侧）。
  • ：合并列（向右侧）。
  • ：拆分列。
  • ：在指定位置插入或修改栏目框。
  • ：在指定位置插入或修改网页帧。
  • ：在指定位置插入或修改图片。
  • ：在指定位置插入Flash动画。
  • ：在指定位置插入自动播放的媒体文件。
  • ：在指定位置插入其它文件。
  • ：远程自动文件获取。
  • ：在指定位置插入EXCEL表格。
  • ：在指定位置插入特殊字符。
  • ：指定位置的背景图片管理。
  • ：在指定位置插入表情图标。
  • ：在指定位置插入当前日期。
  • ：在指定位置插入当前时间。
  • ：转换指定内容为代码样式。
  • ：转换指定内容为引用样式。
  • ：显示或隐藏指导方针。
  • ：查找替换功能。
  • ：新建文档功能。
  • ：相对或绝对位置设置功能。
  • ：上移一层。
  • ：下移一层。
  • ：缩放菜单。
  • ：增高编辑区。
  • ：减小编辑区。
  • ：转为代码状态。
  • ：转为编辑状态。
  • ：转为文本状态。
  • ：转为预览状态。
  • ：打印全页。
  • ：保存内容到相关联的表单。
  • ：打开全屏编辑。
  • ：关闭全屏编辑并返回。
  • ：弹窗保存并返回。
  • ：查看在线使用帮助。
  • ：关于编辑器的版权信息。
  • ：直接访问eWebEditor站点。
  • ：工具菜单。
  • ：文件视图菜单。
  • ：编辑菜单。
  • ：对象效果菜单。
  • ：组件菜单。

编辑器菜单栏下拉选项功能使用说明如下：

  • 段落格式：设置文字内容的段落格式，使内容更加条理及便于阅读。
  • 特殊字体格式：设置文字内容的特殊格式，包括删除线、飞行文字、移动文字等。
  • 选择字体：设置文字内容的字体格式，可用自定义字体功能设置列表中没出列出的字体格式。注：需浏览者操作系统安装有相应字体文件才可正常显示自定义的字体。
  • 字号：设置文字内容的大小。共分7种尺寸。
  • 缩放：放大或缩小编辑区内的内容。

注意事项：

  • 部分提供修改功能的按键或选项，只需选择原来插入的对象，再按同一按键或选项，即可进行修改。
  • 部分提供设置功能的按键或选项，都可以通过再按一次按键或选项来取消前一次的设置。

编辑栏使用说明：

  • 编辑器编辑栏主要放置供使用者编辑内容的编辑框，若内容超出框架宽度或长度的话，会自动出现滚动条。另外还可通过状态栏的状态转换可转换编辑框的不同编辑状态。

状态栏使用说明：

编辑器状态栏放置有编辑器状态转换栏，共有四种状态可供转换，详细如下：

  • 编辑状态(默认)，在此状态下所有编辑的内容皆为所见即所得的方式。

  • 代码状态，在此状态下所有编辑的内容皆以HTML标记源代码方式显示或编辑。

  • 文本状态，在此状态下所有编辑的内容皆以纯文本方式显示或编辑。

  • 预览状态，在此状态下所有内容皆以不可编辑的页面输出方式显示，可利用此状态预览编辑内容输出后的效果。

使用技巧：

  • 乾坤小挪移
    如果在网络上看到哪篇文章或新闻甚至页面觉得不错的话，可以用鼠标将相应页面内容全部选择起来后，直接拖动或复制到编辑器的编辑框即可，而且原页面上的图片、文字、CSS样式、动态效果等都能原封不动地转移到编辑框，不用修改或添加任何代码。
  • 巧用插入自动播放媒体功能
    插入自动播放媒体功能可以自动识别各种媒体格式并用相应的播放器在页面自动播放，而且这个功能还能识别图像文件，压缩文件等。大家可以充分利用此功能编辑出更多色声俱全的内容。
  • 灵活运用预览状态
    编辑内容中带有动态效果、即时播放媒体、GIF动画等活动内容时，编辑状态中只能显示静态的图像或播放器界面，这时只需要将状态转换为预览状态就可以马上看到这些内容的动态实时效果，如果想继续编辑的话，只需再转换到编辑状态即可。


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
最 新 更 新

[2004-07-06] eWebEditor Version 2.8.0

  • 修复使用相对路径时，从其它站copy图片后粘贴，地址失效的问题
  • 修复一个表单中有多个编辑区时，会多次提交的问题
  • 修复非菜单按钮的撤消和恢复功能不能使用的问题
  • 修复对象上移或下移一层有脚本错误信息的问题
  • 修复删除对象时有脚本错误信息的问题

[2004-05-20] eWebEditor Version 2.7.5

  • 加入锚标签的管理对话页，具有对标签进行增加、删除、修改的功能，同时超级链接对话框中加入锚标签选项，实现同页跳转
  • 使用Application代替每次运行中的读数据库及转换处理操作，大大提高效率，使得页面的调入基本相当于静态网页。
  • 彻底解决路径问题，后台增加路径模式设置，对文件路径允许设置使用“相对路径”、“绝对根路径”、“绝对全路径”
  • 完全整合远程文件自动上传功能：去掉原来提供的接口ReplaceRemoteUrl.asp文件，完全整入编辑功能中，真正实现自动上传，后台加入允许上传远程文件的类型、大小，及是否使用自动上传功能。并加入手动文件上传按钮功能，只要加入此按钮，在编辑页即可看到上传的文件。并与原来的上传文件一样，也提供远程上传文件的接口。
  • 加入常用快捷键功能，现有快捷键汇总如下：
    • 在任何状态模式下有效的快捷键：
      F1：显示帮助信息
      F2：显示或隐藏指导方针
      Ctrl+1：切换到代码编辑模式
      Ctrl+2：切换到可视设计编辑模式
      Ctrl+3：切换到纯文本编辑模式
      Ctrl+4：切换到预览模式
      Ctrl++：增大编辑区
      Ctrl+-：减小编辑区
      Ctrl+Enter：提交
    • 在三种编辑模式有效的快捷键：
      Ctrl+A：全选
      Ctrl+C：复制
      Ctrl+X：剪切
      Ctrl+V：粘贴
      Ctrl+Z：撤消
      Ctrl+Y：恢复
      Ctrl+F：查找
    • 在可视设计编辑模式有效的快捷键：
      Ctrl+B：粗体
      Ctrl+I：斜体
      Ctrl+U：下划线
      Ctrl+D：从Word粘贴
      Ctrl+R：查找与替换
      Shift+Enter：软回车，相当于插入<br>
  • 增加上传组件可选，当前加入ASPUpload、SA-FileUp、LyfUpload组件支持
  • 增加上传文件具有自动建立目录的功能，上传文件是否按日期建目录保存在后台可选，如果使用需要FSO支持，年目录、年月目录、年月日目录可选
  • 增加一个以ACCESS为数据库的简单新闻系统的代码实例，代码中有详细注释，基本涉及eWebEditor的所有功能调用
  • 增加弹窗调用接口，调用popup.asp，可以在弹出的窗口中编辑后，再返回值到原来的编辑框中，可带参数，并相应增加弹窗保存返回的功能按钮
  • 增加弹窗保存返回功能按钮，可与弹窗调用配合使用
  • 增加站点访问按钮功能，更方便的访问在线说明使用方档
  • 增加默认调入时是否显示指导方针的设置，默认为不显示
  • 增加更多的文件类型图片
  • 修复带中划线的域名，不能自动远程图片上传的问题
  • 修复使用自设相对路径时插入文件路径带端口号的问题
  • 修复有可能存在的一些安全上的问题
  • 修复自动远程上传函数中，相同图片可能多次上传的问题
  • 修复表格插入背景图时没有传入接口的问题
  • 修复表格和图片的宽度或高度拖动调整后不能再修改的问题
  • 修复由于IE自带的DHTML接口方法的问题，导致的在菜单中撤消和恢复不能使用的问题
  • 取消载入时编辑区会自动获得焦点
  • 上传文件接口变更：v2.16版中的SourceFileName改为OriginalFileName，同时加入带路径的保存文件名SavePathFileName
  • 系统自带样式名变更，为统一规范命名，系统样式全改为以s_开头的名称，除默认的standard外
  • 在线帮助文件更新，在线演示更新，在线说明文档更新

[2004-04-18] eWebEditor Version 2.1.6

  • 推出小巧实用的mini风格。增加多个菜单按钮：字体菜单、段落菜单、文件视图菜单、组件菜单、工具菜单、编辑菜单、对象效果菜单。所有功能按钮都按菜单进行分类。增加mini系统自带样式，带全部功能，采用全菜单按钮，工具栏占位小，标准界面宽度。系统自带样式达10个。
  • 修复后台样式设为“不使用相对路径”时，设置无效的问题
  • 修复当在代码模式中首行输入样式或注释时，转到设计模式时此代码丢失的问题
  • 修复当不显示工具栏时，不能编辑的问题
  • 修复插入图片时，如果设定有边框颜色，不起作用的问题
  • 修复超链接对话框，当在插入时，target属性不起作用的问题
  • 修复后台管理中的上传文件管理中分页未传id的错误

[2004-04-01] eWebEditor Version 2.0.0

  • 增加纯文件输入功能，并加入客户端IE版本自动检测机制，如版本不足，不会出错，只能使用纯文本输入
  • 增加图形热点链接功能按钮，可以对一个图形分隔链接（在线编辑首创）
  • 增加取上传文件接口，可以在客户端或服务器端取得上传的文件原文件名和实际保存的文件名列表，可用于存入数据库或图片新闻等中
  • 增加超级链接的目标选择，修改原IE自带的链接窗口，并提供公用调用
  • 增加在代码模式或纯文本模式允许粘贴功能，并自动减少行距，以与标准样式匹配
  • 增加一个酷蓝样式（很漂亮的），样式自带样式达9个
  • 修复上传文件大于限定值时的一个JS错误
  • 修复自动远程获取图片的一个小错误，ReplaceRemoteurl.asp文件
  • 修复在编辑状态下显示指导方针后，再切换到代码或者预览状态后，再切换到编辑状态中，那么指导方针就会消失的bug
  • 修复显示为空时，有可能还有<p></p>标志的错误
  • 修复后台管理中使用相对路径设置时出现不能使用特殊字符的错误提示
  • 上传图片后产生冗余代码的清除
  • 修复decode.asp文件中的错误，使得无法过滤的问题
  • 修复后台路径设置中的一些问题，允许使用“/”或“\”或“..”这样的格式
  • 修复使用相对路径时，未考虑端口号的问题
  • 完善后台上传文件管理功能，可管理多个样式目录下的文件
  • 修复有可能乱码的问题
  • 后台上传文件管理中加入目录是否存在的检测，防止页面出错
  • 后台管理加入初始纯文本模式设置
  • 修复预览状态下全屏返回，样式丢失的问题
  • 修复超链接在编辑模式和代码模式间转换时，链接路径变更的问题
  • 修复插入图片时漏掉border属性的问题
  • 使用说明文档更新，增加多个实际操作使用例子

[2004-02-04] eWebEditor Version 2.0.0 beta

  • 增加显示或隐藏指导方针，也就是在表单，链接，表格边框为0时，有一个虚线
  • 样式CSS内容的管理从后台中取消，改为.css文件，放在CSS目录，提高缓存下载速度，及保证样式定义的完整
  • 增加查找替换功能按钮，实现内容的查找及替换
  • 增加直接新建文档功能按钮，即全部清除内容
  • 增加相对或绝对位置设置功能按钮，具有2D功能。使得图片等对象，可以浮于文字上方，重叠等
  • 增加上移一层功能按钮
  • 增加下移一层功能按钮
  • 增加增大编辑区功能按钮
  • 增加减小编辑区功能按钮
  • 增加缩放功能按钮，下拉型或按钮菜单型
  • 后台管理加入是否使用相对路径功能，允许使用相对路径
  • 后台管理加入CSS目录名设置
  • 后台管理加入允许设置调入时的初始模式
  • 后台管理加入允许设置文件上传的目录路径
  • 增加菜单功能，使得功能按钮更加集中及易用
    • 右链菜单功能
    • 粘贴按钮菜单功能
    • 表单菜单功能
    • 表格菜单功能
  • 增加强大的表格处理功能，包括
    • 插入表格...
    • 表格属性...
    • 单元格属性...
    • 拆分单元格...
    • 表格行属性...
    • 插入行（在上方）
    • 插入行（在下方）
    • 合并行（向下方）
    • 拆分行
    • 删除行
    • 插入列（在左侧）
    • 插入列（在右侧）
    • 合并列（向右侧）
    • 拆分列
    • 删除列
  • 修改状态栏样式，更美观
  • 为了更加的规范，图片及部分文件名调整
  • 原来的功能按钮一些属性的扩充，如原有表格对话框加入背景图片，...等
  • 背景图对话框可以做为公用模块进行调用
  • 增加扩充功能，有关图片远程自动获取及上传，在需要使用此功能的接收页面里首先包含ReplaceRemoteUrl.asp，然后执行处理函数就可
  • 说明文档帮助文件相应修改
  • 增加6套样式配色，当前共8套自带样式
  • 按钮图片，全部统一为20px*20px大小
  • 预览再回来时，右键菜单错误
  • 修复为空提交时，检测出还有<p> </p>的问题
  • 修复不使用状态栏时，直接引用状态栏上元素的错误
  • 修复插入表格时漏掉</tr>的错误
  • 其它一些小问题修复...

[2003-12-11] eWebEditor Version 1.1.3

  • 修复“插入自动播放的媒体文件”不能播放出错的问题
  • 修复“预览状态”下“提交”或者“重置”所有格式丢失的问题
  • 增加HTML安全字符转换函数（include/deCode.asp），并在后台增加取得deCode函数代码调用的功能
  • 优化星期生成函数（原来好土）
  • 加入更多的注释便于阅读

[2003-12-01] eWebEditor Version 1.0.0

  • 重点变更：对话框全部由动态改为静态网页，减轻服务器端负担，取消了原来的参数传递方式，转为对象引用。
  • 修复“纯文本粘贴”和“从Word粘贴”功能中焦点丢失的问题。
  • 修复修改图片属性时，提交错误的问题。
  • 修复在xp系统中弹出对话框变形的问题。
  • 修复“插入Flash动画”时不能从url提交的问题。
  • 进一步规范主文件编码结构，同时减小主文件大小，加快调入速度。
  • 说明文档加入“应用场合”说明。
  • 字体背景色和单元格式，表格式背景色的设置分离。
  • 为了使在各操作系统中看到的标准样式是一致的，把标准样式中的与用户自定义有关的颜色，改为绝对颜色。
  • 增加“段落样式”下拉工具按钮，可以对段落的样式进行设置。
  • 增加“对象背景色”功能按钮，可以对表格单格，表格行，表格，网页的背景色进行设置。
  • 增加“设置字体变大”功能按钮。
  • 增加“设置字体变小”功能按钮。
  • 后台管理中加入隐藏“状态栏”设置。
  • 后台管理中加入是否自动检测从Word中粘贴设置。
  • 后台管理中的自带样式允许多个，可以对指定自带样式进行拷贝。
  • 增加1个自带样式，适合较小的编辑区，宽度最佳500，拥有常用功能按钮。
  • 为进一步规范，加入更多更适当的注释，并把改变编辑状态函数ChangeMode()高级调用改为setMode()。
  • 正式开始提供下载。

[2003-11-13] eWebEditor Version 0.9.5 beta

  • 经过两周的内部测试，此版本各方面已经独立完整，现在正式发布外部测试版，为我们1.0正式版的推出做更足的准备。
  • 增加从word粘贴，纯文本粘贴，智能粘贴检测，全屏编辑，返回全屏编辑功能。
  • 正式加入高级功能：setHTML(html)、getHTML()、insertHTML(html)、appendHTML(html)、setMode(NewMode)。
  • 部分代码优化处理、目录结构定架、图片文件名重定。
  • 加入上传扩展名、文件大小按样式设置功能。
  • 介绍说明文档完善。
  • 拟好下一次更新将加入的一些主要功能。
  • 外部测试版，暂不提供下载。

[2003-11-01] eWebEditor Version 0.9.0 beta

  • 经过一段时间的努力，eWebEditor终于出来了，我们将不断的更新升级，并使之成为最好的、基于网页的、开放源码的、无组件式的、代码规范的、绿色的、所见即所得的在线编辑器。
  • 内部测试版，暂不提供下载。


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
应 用 场 合

eWebEditor在WEB相关开发应用中，以可视编辑方式完全可以取代传统的多行文本输入框TextArea！
eWebEditor是一个开发模块，并不能做为一个系统独立使用。

所有WEB开发相关的人员或企业

    随着Internet的发展，很多的个人或企业不但建立起了自己带后台管理的动态网站，还开发了很多基于B/S模式的应用系统。 可以说不管是这些后台程序，还是那些应用系统，她们都大量的使用了多行文本输入框TextArea，以实现多行文本的输入。 这种输入方式通过数据库保存后，取出来时都要经过相应的处理转为HTML格式，以达到按要求显示相应的效果格式。 并且她们最大的缺点就是在输入，或者说编辑时，没法直接看到最终显示出来的效果是什么样的，而要等到提交保存后，经过处理显示出来才能看得到。 而这种方式，也就会使得，为了达到某种更好的效果，要一直编辑、预览、修改、预览、修改、......，直到最终符合要求。 如果有一种输入方式，可以就象Word一样编辑，并且最终显示出来的就是那样的，那该多好！

    eWebEditor就是为了解决问题而产生的。开发人员只需要调用一行简单的代码，就可以为他们的用户提供实现象Word一样具有非富功能和所见即所得的在线编辑输入功能。 并且你不再需要在显示输出时，对内容进行过多的字符转换处理已达到转成HTML格式的目的，eWebEditor已经把内容自动转为HTML格式了。

    用eWebEditor，不再用TextArea！

可以应用的系统

可以使用eWebEditor的地方，真的是太多太多了，基本上所有的应用或系统都可以用上，如：

  • 新闻发布系统的新闻内容区
  • 文章管理系统的文章内容区
  • 留言本的留言内容区
  • 软件下载系统的下载说明区
  • 网络办公系统的文档内容区
  • 网络商店系统的产品说明区
  • 论坛BBS系统的贴子内容区
  • 影视系统的影视媒体说明区
  • ......等等，太多了

用eWebEditor，不再用TextArea！


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
服 务 支 持

服务说明：

如果您在使用中运到问题，请先查看我们的使用说明和常见问题，可能问题可以马上解决。

为了能给您提供更好的服务，请在提交问题时遵守下列规则：

  • 准确：不要提象“你的产品有问题”这样的问题，要尽量的表达准确，请写出发生错误的现象或者程序代码片段等与问题相关的信息。
  • 简练：把您问题的特征描述尽量只要写成几个简单的句子，尽量限制附加很多的代码，如不要把一个完整程序每个页面的代码都附加进来。
  • 耐心：因为我们要回答的问题可能较多，所以您的问题得到回复可能需要几分钟、几小时、甚至几天，请耐心等待。

技术支持：

您在使用我们的产品时，遇到问题寻求技术支持解决，或者您找到程序的bug要报告，都请到我们论坛的产品技术支持专栏发表。

支持论坛：http://www.webasp.net/bbs/
电子邮件：webmaster@webasp.net
ＯＩＣＱ：５８９８０８


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
运 行 环 境

服务器要求：

eWebEditor 是基于ASP开发的一套网络在线编辑系统模块，正常使用该软件您必须保证您的服务器满足如下要求：

  • 硬件环境：
    MS WINDOWS NT PACK 4 OR LATER /WIN2000 WITH IIS 4.0 OR LATER /WIN9X+PWS
  • 数据库：
    Access2000
  • 其他：
    服务器必须安装 微软IE浏览器5.0+

推荐：Windows 2000+IIS5.0+Access2000+IE5.0环境测试（即win2000的默认安装）

客户端要求：

因为编辑器使用了JAVASCRIPT客户端语言，如果浏览器不支持JAVASCRIPT或关闭了这个功能的话，编辑器就不能正常工作了。另外，编辑器还需要使用者的浏览器版本是IE5.5以上，否则编辑器同样不能正常工作。

  • JavaScript支持
  • IE5.5+


最新更新
特性介绍
应用场合
功能描述
运行环境
产品下载
使用说明
代码实例
常见问题
在线演示
成功案例
购买指南
在线购买
服务支持
版权声明
- eWebSoft在线编辑器
    eWebEditor是eWebSoft.com旗下eWeb团队开发的基于网页的在线编辑器。她能够在网页上实现许多桌面编辑软件（如：Word）所具有的强大可视编辑功能；她是一个真正的绿色软件，不需要在计算机上安装任何的客户端软件；并且她是完全开放源代码的，允许无商业目的个人用户免费使用。
当前最新版本：Version 2.8.0 [下载][购买]
成 功 案 例

案例说明：

eWebEditor是个共享软件，完全开放源代码，用户分为免费用户、标准用户、专业用户、VIP用户四种，四种用户在某一版本的功能上基本没有区别，区别在于[授权许可]、支持服务及部分高级功能上。您可以通过这里，查看详细的[用户类型版本对比]。

以下为部分自愿列出的用户，排名按注册先后。

商业付费用户：

  1. 陈劼(上海)
  2. 陈章伟(广东)
  3. 张志成(大连)
  4. 袁军(江阴市)
  5. 张阳(北京)
  6. 张润(北京)
  7. 吴华军
  8. 王海洲(北京)
  9. 李恩佶 / Jimmy(台湾)
  10. 上海马可文化用品有限公司
  11. 安徽农网
  12. 韦亚钧(广东)
  13. 陈忠治(济南)
  14. 松焰資訊股份有限公司
  15. 燃烧的天空
  16. 北京捷瑞电讯设备有限公司
  17. 杨宝罡
  18. 潘述广
  19. 众合软件公司
  20. 福建远力电子有限公司
  21. 曹轩